Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>📝</td>
<td>Example</td>
</tr>
<tr>
<td>📚</td>
<td>Note</td>
</tr>
<tr>
<td>⚠️</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🔧</td>
<td>Syntax</td>
</tr>
<tr>
<td>🧭</td>
<td>Tip</td>
</tr>
</tbody>
</table>
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Center Accounting (CO-OM-CCA)</td>
<td>18</td>
</tr>
<tr>
<td>Master Data in Cost Center Accounting (CO-OM-CCA)</td>
<td>21</td>
</tr>
<tr>
<td><strong>Processing Master Data</strong></td>
<td></td>
</tr>
<tr>
<td>Time-Dependency of Master Data</td>
<td>23</td>
</tr>
<tr>
<td>Selection variant</td>
<td>25</td>
</tr>
<tr>
<td>Creating, Changing, or Displaying Master Data</td>
<td>30</td>
</tr>
<tr>
<td>Deleting Master Data</td>
<td>34</td>
</tr>
<tr>
<td>Master Data Groups</td>
<td>37</td>
</tr>
<tr>
<td>Processing Master Data Groups</td>
<td>38</td>
</tr>
<tr>
<td>Creating or Changing Master Data Groups</td>
<td>40</td>
</tr>
<tr>
<td>Functions for Structural Processing of Master Data Groups</td>
<td>42</td>
</tr>
<tr>
<td>Extra Functions for Processing Master Data Groups</td>
<td>44</td>
</tr>
<tr>
<td>Transport Functions for Master Data Groups</td>
<td>48</td>
</tr>
<tr>
<td>Copying Master Data Groups</td>
<td>49</td>
</tr>
<tr>
<td>Example: Copying the Cost Center Standard Hierarchy</td>
<td>52</td>
</tr>
<tr>
<td><strong>Requesting a Master Data Change in the Intranet/Internet (AC)</strong></td>
<td>53</td>
</tr>
<tr>
<td>Processing Request Forms</td>
<td>56</td>
</tr>
<tr>
<td>Processing a Request in the SAP System</td>
<td>59</td>
</tr>
<tr>
<td>Processing Notifications</td>
<td>60</td>
</tr>
<tr>
<td>Process Notification</td>
<td>61</td>
</tr>
<tr>
<td>Processing Notifications Using Worklist</td>
<td>63</td>
</tr>
<tr>
<td>Task Processing</td>
<td>64</td>
</tr>
<tr>
<td>Processing Tasks Using Worklist</td>
<td>65</td>
</tr>
<tr>
<td>Processing Tasks Using Workflow</td>
<td>66</td>
</tr>
<tr>
<td>Status Query For Request</td>
<td>67</td>
</tr>
<tr>
<td><strong>Enterprise Organization (CO)</strong></td>
<td>68</td>
</tr>
<tr>
<td>Time-Dependency of Enterprise Organizations</td>
<td>71</td>
</tr>
<tr>
<td>Selecting a Date and Preview Period</td>
<td>75</td>
</tr>
<tr>
<td>Terminating/Deleting HR Organizational Units Or Assignments</td>
<td>76</td>
</tr>
<tr>
<td>Activating/Deactivating Query Time Period</td>
<td>77</td>
</tr>
<tr>
<td>The Inheritance Principle</td>
<td>78</td>
</tr>
<tr>
<td>Enterprise Organizations and Standard Hierarchies</td>
<td>79</td>
</tr>
<tr>
<td>Generating an Alternative Profit Center Structure</td>
<td>81</td>
</tr>
<tr>
<td>The Enterprise Organization: Processing Options</td>
<td>83</td>
</tr>
<tr>
<td>The Screen Areas</td>
<td>84</td>
</tr>
<tr>
<td>Searching for Organizational Units</td>
<td>88</td>
</tr>
<tr>
<td>Creating Organizational Units</td>
<td>90</td>
</tr>
<tr>
<td>Displaying or Changing Organizational Units</td>
<td>93</td>
</tr>
<tr>
<td>Assigning, Reassigning, or Moving Organizational Units</td>
<td>94</td>
</tr>
<tr>
<td>Active and Inactive Master Data</td>
<td>96</td>
</tr>
<tr>
<td>Activating Inactive Master Data</td>
<td>98</td>
</tr>
<tr>
<td>Deleting Inactive Master Data</td>
<td>100</td>
</tr>
<tr>
<td><strong>Standard Hierarchy</strong></td>
<td>101</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Editing the Standard Hierarchy</td>
<td>103</td>
</tr>
<tr>
<td>Processing the Standard Hierarchy Using Group Maintenance</td>
<td>106</td>
</tr>
<tr>
<td><strong>Cost Elements</strong></td>
<td></td>
</tr>
<tr>
<td>Specifications from Financial Accounting</td>
<td>110</td>
</tr>
<tr>
<td>Cost Element Categories</td>
<td>112</td>
</tr>
<tr>
<td>Cost Element Master Data</td>
<td>115</td>
</tr>
<tr>
<td>Checklist for Creating Cost Elements</td>
<td>119</td>
</tr>
<tr>
<td>Processing Cost Elements</td>
<td>121</td>
</tr>
<tr>
<td>Displaying Cost Elements with Collective Processing</td>
<td>122</td>
</tr>
<tr>
<td>Cost Element Groups</td>
<td>124</td>
</tr>
<tr>
<td><strong>Cost Centers</strong></td>
<td></td>
</tr>
<tr>
<td>Representative Cost Centers</td>
<td>127</td>
</tr>
<tr>
<td>Assignment Fields in Cost Center Master Data</td>
<td>128</td>
</tr>
<tr>
<td>Cost Center Master Data</td>
<td>131</td>
</tr>
<tr>
<td>Active and Inactive Master Data</td>
<td>133</td>
</tr>
<tr>
<td>Checklist for Creating Cost Centers</td>
<td>137</td>
</tr>
<tr>
<td>Creating Cost Centers Without Active Cost Center Accounting</td>
<td>139</td>
</tr>
<tr>
<td>Processing Cost Centers</td>
<td>140</td>
</tr>
<tr>
<td>Changing and Displaying Cost Centers with Collective Processing</td>
<td>142</td>
</tr>
<tr>
<td>Cost Center Groups</td>
<td>144</td>
</tr>
<tr>
<td><strong>Activity Types</strong></td>
<td></td>
</tr>
<tr>
<td>Activity Type Categories</td>
<td>147</td>
</tr>
<tr>
<td>Price Indicators</td>
<td>148</td>
</tr>
<tr>
<td>Activity Type Master Data</td>
<td>151</td>
</tr>
<tr>
<td>Checklist for Creating Activity Types</td>
<td>153</td>
</tr>
<tr>
<td>Processing Activity Types</td>
<td>156</td>
</tr>
<tr>
<td>Displaying Activity Types with Collective Processing</td>
<td>157</td>
</tr>
<tr>
<td>Activity Type Group</td>
<td>161</td>
</tr>
<tr>
<td><strong>Statistical Key Figures</strong></td>
<td></td>
</tr>
<tr>
<td>Link to LIS</td>
<td>163</td>
</tr>
<tr>
<td>Master Data for Statistical Key Figures</td>
<td>165</td>
</tr>
<tr>
<td>Checklist for Creating Statistical Key Figures</td>
<td>168</td>
</tr>
<tr>
<td>Processing Statistical Key Figures</td>
<td>169</td>
</tr>
<tr>
<td>Processing Statistical Key Figures With Collective Processing</td>
<td>170</td>
</tr>
<tr>
<td>Deleting Statistical Key Figures</td>
<td>171</td>
</tr>
<tr>
<td>Statistical Key Figure Groups</td>
<td>172</td>
</tr>
<tr>
<td><strong>Resources</strong></td>
<td></td>
</tr>
<tr>
<td>Processing Resources</td>
<td>174</td>
</tr>
<tr>
<td><strong>Cost Center Planning (CO-OM-CCA)</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Short-Term Business Planning</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Reconciliation of Cost Center Planning With Other Applications</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Cost Center Planning Scope</strong></td>
<td></td>
</tr>
<tr>
<td>Activity-Independent and Activity-Dependent Cost Planning</td>
<td>178</td>
</tr>
<tr>
<td>Integrated Planning for Internal Orders</td>
<td>181</td>
</tr>
<tr>
<td>Line Items and Integrated Planning</td>
<td>183</td>
</tr>
<tr>
<td>Activating Line Items and Integrated Planning</td>
<td>184</td>
</tr>
<tr>
<td>Planning Flow in Cost Center Planning</td>
<td>185</td>
</tr>
<tr>
<td>Planning Sequence</td>
<td>186</td>
</tr>
</tbody>
</table>
Changing the Planning Sequence 197
Currencies in Planning 198
Checklist for Planning in Cost Center Accounting 201

**Manual Planning** 203
Manager’s Desktop 204
Planning Statistical Key Figures 206
  Planning Statistical Key Figures 207
Activity Type Planning 208
  Executing Activity Type Planning 211
Primary Cost Planning 212
  Activity-Independent Primary Cost Planning 214
    Executing Activity-Independent Primary Cost Planning 215
  Activity-Dependent Primary Cost Planning 216
    Executing Activity-Dependent Primary Cost Planning 218
Resource Planning 219
  Pricing 221
    Maintaining Resource Prices 223
    Copying Resource Prices 224
    Revaluating Resource Prices 226
  Resource Planning 228
    Revaluating Resource Planning 229
Dependency Planning 230
  Dependency Planning 235
    Revaluation in Dependency Planning 236
Planning Order Costs on Cost Centers 238
  Planning Primary Order Costs 239
Revenue Planning 240
  Executing Revenue Planning 241
Secondary Cost Planning 242
  Activity-Independent Activity Input Planning 243
    Executing Activity-Independent Activity Input Planning 244
  Activity-Dependent Activity Input Planning 245
    Executing Activity-Dependent Activity Input Planning 248
Link Between Activity Types and Activity Input Planning 249
Planning Credits From Overhead Costs 250
  Executing Planning of Credits from Overhead 251
Planning Secondary Order Costs 252
Cost Center Budget Planning 253
  Executing Budget Planning 254
Detailed Planning of Cost Elements 255
  Executing Detailed Planning 256
Manual Planning Aid 261
  Executing Manual Planning 263
Periodic Formulas in Cost Center Planning 266
  Executing Planning 271
Planning Functions 273
  Positioning 274
SAP AG Cost Center Accounting (CO-OM-CCA)

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>275</td>
</tr>
<tr>
<td>277</td>
</tr>
<tr>
<td>279</td>
</tr>
<tr>
<td>281</td>
</tr>
<tr>
<td>282</td>
</tr>
<tr>
<td>283</td>
</tr>
<tr>
<td>284</td>
</tr>
<tr>
<td>286</td>
</tr>
<tr>
<td>287</td>
</tr>
<tr>
<td>288</td>
</tr>
<tr>
<td>289</td>
</tr>
<tr>
<td>290</td>
</tr>
<tr>
<td>291</td>
</tr>
<tr>
<td>292</td>
</tr>
<tr>
<td>293</td>
</tr>
<tr>
<td>294</td>
</tr>
<tr>
<td>295</td>
</tr>
<tr>
<td>296</td>
</tr>
<tr>
<td>297</td>
</tr>
<tr>
<td>302</td>
</tr>
<tr>
<td>303</td>
</tr>
<tr>
<td>304</td>
</tr>
<tr>
<td>305</td>
</tr>
<tr>
<td>306</td>
</tr>
<tr>
<td>307</td>
</tr>
<tr>
<td>308</td>
</tr>
<tr>
<td>311</td>
</tr>
<tr>
<td>312</td>
</tr>
<tr>
<td>314</td>
</tr>
<tr>
<td>317</td>
</tr>
<tr>
<td>318</td>
</tr>
<tr>
<td>319</td>
</tr>
<tr>
<td>321</td>
</tr>
<tr>
<td>323</td>
</tr>
<tr>
<td>327</td>
</tr>
<tr>
<td>328</td>
</tr>
<tr>
<td>339</td>
</tr>
<tr>
<td>341</td>
</tr>
<tr>
<td>342</td>
</tr>
<tr>
<td>344</td>
</tr>
<tr>
<td>347</td>
</tr>
<tr>
<td>349</td>
</tr>
<tr>
<td>352</td>
</tr>
<tr>
<td>353</td>
</tr>
<tr>
<td>355</td>
</tr>
</tbody>
</table>

Techniques for Supporting Manual Planning

Planning/Multiple Valuation Approaches in More than One Version

Flexible Selection of Planning Screens

Distribution Keys

Standard Distribution Keys

Examples of Standard Distribution Keys

User-Defined Distribution Keys

Example of a User-Defined Distribution Key

Planning Screen Layout

Planner Profiles

Standard Planner Profiles

Planning Layouts

Standard Planning Layouts

Structuring Planning Layouts

Defining Planning Layouts

Integrated Excel in Planning

Setting Up Integrated Excel

How To Plan Using Integrated Excel

Planning Offline and Uploading into the SAP System
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deleting Planning Data</td>
<td>356</td>
</tr>
<tr>
<td>Copying Planning Values</td>
<td>357</td>
</tr>
<tr>
<td>Copying Planning</td>
<td>360</td>
</tr>
<tr>
<td>Copying Actual Data Into Planning</td>
<td>364</td>
</tr>
<tr>
<td>Copy Actual To Plan</td>
<td>368</td>
</tr>
<tr>
<td>Reevaluating Cost Center Planning</td>
<td>371</td>
</tr>
<tr>
<td>Structuring Revaluations</td>
<td>372</td>
</tr>
<tr>
<td>Creating Revaluations</td>
<td>373</td>
</tr>
<tr>
<td>Carrying Out Revaluations</td>
<td>375</td>
</tr>
<tr>
<td>Revaluation of Plan Data</td>
<td>377</td>
</tr>
<tr>
<td>Revaluating Plan Data</td>
<td>379</td>
</tr>
<tr>
<td>Plan Reconciliation</td>
<td>381</td>
</tr>
<tr>
<td>Example: Plan Reconciliation</td>
<td>383</td>
</tr>
<tr>
<td>Executing Plan Reconciliation</td>
<td>385</td>
</tr>
<tr>
<td>Periodic Reposting</td>
<td>387</td>
</tr>
<tr>
<td>Plan Accrual Calculation</td>
<td>389</td>
</tr>
<tr>
<td>Executing Plan Accrual Calculation</td>
<td>390</td>
</tr>
<tr>
<td>Formula Planning</td>
<td>391</td>
</tr>
<tr>
<td>Template</td>
<td></td>
</tr>
<tr>
<td>Maintaining Templates</td>
<td>395</td>
</tr>
<tr>
<td>Other Methods to Maintain Templates</td>
<td>397</td>
</tr>
<tr>
<td>Evaluating Templates</td>
<td>400</td>
</tr>
<tr>
<td>Environment of Templates</td>
<td></td>
</tr>
<tr>
<td>Functions in Environments</td>
<td>401</td>
</tr>
<tr>
<td>Maintaining Functions</td>
<td>403</td>
</tr>
<tr>
<td>Functions - Basic Data and Language</td>
<td>404</td>
</tr>
<tr>
<td>Realization of the Function</td>
<td>407</td>
</tr>
<tr>
<td>Implementing ABAP Functions</td>
<td>409</td>
</tr>
<tr>
<td>Function Parameters</td>
<td>411</td>
</tr>
<tr>
<td>Function Uses</td>
<td>412</td>
</tr>
<tr>
<td>Function Trees</td>
<td>413</td>
</tr>
<tr>
<td>Editing Function Trees</td>
<td>416</td>
</tr>
<tr>
<td>Additional Function Trees</td>
<td>418</td>
</tr>
<tr>
<td>Activity Quantity Determination</td>
<td></td>
</tr>
<tr>
<td>Quantity Determination: Example</td>
<td>424</td>
</tr>
<tr>
<td>Activation</td>
<td></td>
</tr>
<tr>
<td>Processing Possibilities in the Editor</td>
<td>425</td>
</tr>
<tr>
<td>Methods</td>
<td></td>
</tr>
<tr>
<td>Defining Methods</td>
<td>426</td>
</tr>
<tr>
<td>Changing Logical Conditions Between Columns</td>
<td>427</td>
</tr>
<tr>
<td>Formulas</td>
<td></td>
</tr>
<tr>
<td>Defining Formulas</td>
<td>431</td>
</tr>
<tr>
<td>Calculation Rows</td>
<td></td>
</tr>
<tr>
<td>Defining Calculation Rows</td>
<td>433</td>
</tr>
<tr>
<td>Calling Up Calculation Rows</td>
<td>435</td>
</tr>
<tr>
<td>Locking Planning</td>
<td></td>
</tr>
<tr>
<td></td>
<td>436</td>
</tr>
<tr>
<td></td>
<td>438</td>
</tr>
<tr>
<td></td>
<td>439</td>
</tr>
<tr>
<td></td>
<td>440</td>
</tr>
<tr>
<td></td>
<td>441</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Transferring Plan Values from Other Application Components</td>
<td>442</td>
</tr>
<tr>
<td>The Cost Center Accounting/Personal Cost Planning Interface</td>
<td>443</td>
</tr>
<tr>
<td>Transferring Personnel Costs from HR</td>
<td>445</td>
</tr>
<tr>
<td>The Cost Center Accounting/Asset Accounting Interface</td>
<td>446</td>
</tr>
<tr>
<td>Transferring Depreciation, Interest, and Investments from FIAA</td>
<td>448</td>
</tr>
<tr>
<td>The Interface Between Cost Center Accounting and Production Planning (PP)</td>
<td>450</td>
</tr>
<tr>
<td>Transferring Production Activity Requirements</td>
<td>453</td>
</tr>
<tr>
<td>Transferring Statistical Key Figures From the LIS</td>
<td>455</td>
</tr>
<tr>
<td>Transferring Statistical Key Figures</td>
<td>457</td>
</tr>
<tr>
<td><strong>Periodic Allocations in Plan</strong></td>
<td>459</td>
</tr>
<tr>
<td>Planning Overheads</td>
<td>461</td>
</tr>
<tr>
<td>Distribution</td>
<td>462</td>
</tr>
<tr>
<td>Assessment</td>
<td>464</td>
</tr>
<tr>
<td>Indirect Activity Allocation</td>
<td>466</td>
</tr>
<tr>
<td>Senders and Receivers for Indirect Activity Allocation</td>
<td>470</td>
</tr>
<tr>
<td>Valuating Activity Quantities</td>
<td>472</td>
</tr>
<tr>
<td><strong>Template Allocation in Plan</strong></td>
<td>473</td>
</tr>
<tr>
<td>Template Allocation in Plan: Processes/Cost Centers</td>
<td>475</td>
</tr>
<tr>
<td>Templates for Business Processes/Cost Centers</td>
<td>477</td>
</tr>
<tr>
<td>Executing Template Allocations</td>
<td>480</td>
</tr>
<tr>
<td>Plan Cost Splitting</td>
<td>481</td>
</tr>
<tr>
<td>Plan Price Calculation</td>
<td>485</td>
</tr>
<tr>
<td>Calculating Prices</td>
<td>489</td>
</tr>
<tr>
<td>Manual Actual Postings (CO-OM-CCA)</td>
<td>494</td>
</tr>
<tr>
<td><strong>Editing Manual Actual Postings</strong></td>
<td>496</td>
</tr>
<tr>
<td>Entering Manual Actual Postings</td>
<td>497</td>
</tr>
<tr>
<td>Displaying Manual Actual Postings</td>
<td>500</td>
</tr>
<tr>
<td>Reversing Manual Actual Postings</td>
<td>501</td>
</tr>
<tr>
<td>Reposting Costs and Revenues Manually</td>
<td>502</td>
</tr>
<tr>
<td>Reposting Line Items</td>
<td>504</td>
</tr>
<tr>
<td>Selecting Line Items</td>
<td>506</td>
</tr>
<tr>
<td>Reposting Line Items</td>
<td>508</td>
</tr>
<tr>
<td>Displaying Line Item Repostings</td>
<td>511</td>
</tr>
<tr>
<td>Reversing Line Item Repostings</td>
<td>512</td>
</tr>
<tr>
<td>Time Sheets</td>
<td>513</td>
</tr>
<tr>
<td>Direct Activity Allocation</td>
<td>514</td>
</tr>
<tr>
<td>Internal Activity Allocations in the Intranet (CO-OM-CCA)</td>
<td>517</td>
</tr>
<tr>
<td>Entering Internal Activity Allocations in the Intranet (CO-OM-CCA)</td>
<td>519</td>
</tr>
<tr>
<td>Application Example (CO-OM-CCA)</td>
<td>521</td>
</tr>
<tr>
<td>Internal Price Lists in the Intranet (CO-OM-CCA)</td>
<td>522</td>
</tr>
<tr>
<td>Displaying the Internal Price List (CO-OM-CCA)</td>
<td>524</td>
</tr>
<tr>
<td>Reposting Internal Activity Allocation</td>
<td>525</td>
</tr>
<tr>
<td>Selecting Internal Activity Allocations</td>
<td>527</td>
</tr>
<tr>
<td>Reposting Internal Activity Allocations</td>
<td>529</td>
</tr>
<tr>
<td>Displaying Internal Activity Allocation Repostings</td>
<td>532</td>
</tr>
<tr>
<td>Reversing Repostings for Internal Activity Allocation</td>
<td>533</td>
</tr>
<tr>
<td>Entering Sender Activities</td>
<td>534</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Entering Sender Activities</td>
<td>535</td>
</tr>
<tr>
<td>Displaying Sender Activities</td>
<td>537</td>
</tr>
<tr>
<td>Reversing Sender Activities</td>
<td>538</td>
</tr>
<tr>
<td><strong>Manual Actual Price</strong></td>
<td>539</td>
</tr>
<tr>
<td>Entering Actual Prices Manually</td>
<td>540</td>
</tr>
<tr>
<td>Displaying Actual Prices Manually</td>
<td>541</td>
</tr>
<tr>
<td><strong>Manual Cost Allocation</strong></td>
<td>542</td>
</tr>
<tr>
<td><strong>Entering Statistical Key Figures</strong></td>
<td>543</td>
</tr>
<tr>
<td><strong>Actual Postings to Activity Types</strong></td>
<td>544</td>
</tr>
<tr>
<td>Example of Splitting After Account Assignment to an Activity Type</td>
<td>548</td>
</tr>
<tr>
<td><strong>Receivers of Manual Actual Postings</strong></td>
<td>550</td>
</tr>
<tr>
<td><strong>Funds Commitment (Cost Centers, Internal Orders, Projects)</strong></td>
<td>551</td>
</tr>
<tr>
<td>Creating Funds Commitments</td>
<td>553</td>
</tr>
<tr>
<td>Changing Funds Commitments</td>
<td>555</td>
</tr>
<tr>
<td>Reducing Funds Commitments</td>
<td>556</td>
</tr>
<tr>
<td>Evaluating Funds Commitment Documents in The Information System</td>
<td>558</td>
</tr>
<tr>
<td><strong>Period-End Closing (CO-OM-CCA)</strong></td>
<td>560</td>
</tr>
<tr>
<td><strong>Overview of Period Closing</strong></td>
<td>563</td>
</tr>
<tr>
<td><strong>Schedule Manager (CA)</strong></td>
<td>565</td>
</tr>
<tr>
<td>Variables in Schedule Manager</td>
<td>566</td>
</tr>
<tr>
<td>Defining Global Variables for the Task List and Flow Definition</td>
<td>567</td>
</tr>
<tr>
<td>Defining Selection Variables</td>
<td>568</td>
</tr>
<tr>
<td>Specifying Selection Variables in the Program Variants</td>
<td>569</td>
</tr>
<tr>
<td>Specifying Selection Variables for Flow Definitions With Parallel Branches</td>
<td>571</td>
</tr>
<tr>
<td><strong>Individual Functions of the Schedule Manager</strong></td>
<td>573</td>
</tr>
<tr>
<td><strong>Using the Scheduler</strong></td>
<td>574</td>
</tr>
<tr>
<td>Task List</td>
<td>576</td>
</tr>
<tr>
<td>Task Types</td>
<td>577</td>
</tr>
<tr>
<td>Creating a Task List</td>
<td>578</td>
</tr>
<tr>
<td>Inserting Tasks/Task Groups into the Task List</td>
<td>579</td>
</tr>
<tr>
<td>Inserting Your Own Programs as Tasks</td>
<td>580</td>
</tr>
<tr>
<td>Inserting Your Own Programs as Tasks</td>
<td>581</td>
</tr>
<tr>
<td>Storing Task Documentation</td>
<td>582</td>
</tr>
<tr>
<td>Scheduling Tasks in the Daily Overview</td>
<td>583</td>
</tr>
<tr>
<td>Scheduling a Complete Task List in the Daily Overview</td>
<td>584</td>
</tr>
<tr>
<td>Relative Start Time</td>
<td>585</td>
</tr>
<tr>
<td>Runtime Analysis for Jobs</td>
<td>586</td>
</tr>
<tr>
<td>Controlling Whether Jobs Are Started</td>
<td>587</td>
</tr>
<tr>
<td><strong>Using the Monitor</strong></td>
<td>592</td>
</tr>
<tr>
<td>Monitor - Monitoring Active and Completed Jobs</td>
<td>594</td>
</tr>
<tr>
<td>Monitor - Working with the Object List</td>
<td>596</td>
</tr>
<tr>
<td><strong>Using the Flow Definition</strong></td>
<td>598</td>
</tr>
<tr>
<td>Flow Step Types</td>
<td>600</td>
</tr>
<tr>
<td>Creating a Flow Definition</td>
<td>601</td>
</tr>
<tr>
<td>Specifying Selection Variables for Flow Definitions With Parallel Branches</td>
<td>602</td>
</tr>
<tr>
<td>Choosing Objects for Processing</td>
<td>603</td>
</tr>
<tr>
<td>Defining Processing Options, Output Options and Execution Types</td>
<td>608</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Error Handling</td>
<td>609</td>
</tr>
<tr>
<td>Error: A Job Stops</td>
<td>610</td>
</tr>
<tr>
<td>Error: A Job Becomes</td>
<td>612</td>
</tr>
<tr>
<td>Error: An Executed Report Found an Error</td>
<td>614</td>
</tr>
<tr>
<td>Error: Job Scheduling Was Unsuccessful</td>
<td>616</td>
</tr>
<tr>
<td>Error: The Workflow Stops</td>
<td>617</td>
</tr>
<tr>
<td>Error: The Workflow Becomes</td>
<td>618</td>
</tr>
<tr>
<td>Multilevel Worklist</td>
<td>619</td>
</tr>
<tr>
<td>Multilevel Worklist: Process Flow</td>
<td>632</td>
</tr>
<tr>
<td>Monitor - Working with the Object List</td>
<td>634</td>
</tr>
<tr>
<td>Processing Worklists</td>
<td>637</td>
</tr>
<tr>
<td>Choosing Objects for Processing</td>
<td>647</td>
</tr>
<tr>
<td>Processing Status of Objects</td>
<td>648</td>
</tr>
<tr>
<td>Scenarios for the Schedule Manager</td>
<td>654</td>
</tr>
<tr>
<td>Starting Transactions/Reports Online, Scheduling/ Monitoring Jobs</td>
<td>655</td>
</tr>
<tr>
<td>Starting Transactions/Reports Online, Scheduling Jobs/Job Chains, Monitoring Jobs</td>
<td>656</td>
</tr>
<tr>
<td>Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist</td>
<td>657</td>
</tr>
<tr>
<td>Periodic Reposting</td>
<td>659</td>
</tr>
<tr>
<td>Accrual Calculation</td>
<td>661</td>
</tr>
<tr>
<td>Accrual Calculations Using the Percentage Method</td>
<td>664</td>
</tr>
<tr>
<td>Defining the Percentage Method</td>
<td>666</td>
</tr>
<tr>
<td>Maintaining Overhead Structure Data</td>
<td>669</td>
</tr>
<tr>
<td>Accrual Calculations Using the Target=Actual Method</td>
<td>671</td>
</tr>
<tr>
<td>Maintaining Data for Target=Actual Accrual</td>
<td>673</td>
</tr>
<tr>
<td>Accrual Calculations Using the Plan=Actual Method</td>
<td>675</td>
</tr>
<tr>
<td>Executing Accrual Calculations</td>
<td>677</td>
</tr>
<tr>
<td>Reversing Accrual Calculations</td>
<td>680</td>
</tr>
<tr>
<td>Special Functions for Accrual Calculation</td>
<td>681</td>
</tr>
<tr>
<td>Dependencies</td>
<td>682</td>
</tr>
<tr>
<td>Creating and Maintaining Condition Tables</td>
<td>684</td>
</tr>
<tr>
<td>Defining Custom Dependencies</td>
<td>687</td>
</tr>
<tr>
<td>Where-Used List for Accrual Calculations</td>
<td>690</td>
</tr>
<tr>
<td>Time Dependency of Accrual Calculation</td>
<td>691</td>
</tr>
<tr>
<td>Definition of Multiple Overhead Structures for One Controlling Area</td>
<td>693</td>
</tr>
<tr>
<td>Transfer of Statistical Key Figures from the Logistics Information System (LIS)</td>
<td>694</td>
</tr>
<tr>
<td>Transferring Statistical Key Figures</td>
<td>696</td>
</tr>
<tr>
<td>Overheads</td>
<td>698</td>
</tr>
<tr>
<td>Calculating Overheads</td>
<td>699</td>
</tr>
<tr>
<td>Validity Periods for Master Data</td>
<td>702</td>
</tr>
<tr>
<td>Costing Sheet</td>
<td>704</td>
</tr>
<tr>
<td>Periodic Allocations</td>
<td>707</td>
</tr>
<tr>
<td>Distribution</td>
<td>709</td>
</tr>
<tr>
<td>Assessment</td>
<td>711</td>
</tr>
<tr>
<td>Indirect Activity Allocation</td>
<td>713</td>
</tr>
<tr>
<td>Senders and Receivers for Indirect Activity Allocation</td>
<td>717</td>
</tr>
<tr>
<td>Valuating Activity Quantities</td>
<td>719</td>
</tr>
<tr>
<td>Target=Actual Activity Allocation</td>
<td>720</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Executing Target=Actual Activity Allocation</td>
<td>722</td>
</tr>
<tr>
<td>Template Allocation in Actual</td>
<td>724</td>
</tr>
<tr>
<td>Template Allocation in Actual: Processes/Cost Centers</td>
<td>727</td>
</tr>
<tr>
<td>Templates for Business Processes/Cost Centers</td>
<td>729</td>
</tr>
<tr>
<td>Templates for Bus. Proc. / Cost Center Assignment</td>
<td>732</td>
</tr>
<tr>
<td>Template</td>
<td>733</td>
</tr>
<tr>
<td>Maintaining Templates</td>
<td>736</td>
</tr>
<tr>
<td>Other Methods to Maintain Templates</td>
<td>738</td>
</tr>
<tr>
<td>Executing Template Allocations</td>
<td>741</td>
</tr>
<tr>
<td><strong>Overview of Allocation Methods</strong></td>
<td>742</td>
</tr>
<tr>
<td><strong>Senders and Receivers for Periodic Actual Postings</strong></td>
<td>744</td>
</tr>
<tr>
<td><strong>Defining Periodic Repostings or Periodic Allocations</strong></td>
<td>747</td>
</tr>
<tr>
<td>Defining Sender and Receiver Types for Allocations</td>
<td>749</td>
</tr>
<tr>
<td>Sender and Receiver Rules for Periodic Repostings/Allocations</td>
<td>751</td>
</tr>
<tr>
<td>Combinations of Sender and Receiver Rules</td>
<td>753</td>
</tr>
<tr>
<td>Currencies for Periodic Reposting or Periodic Allocations</td>
<td>758</td>
</tr>
<tr>
<td>Cycle</td>
<td>761</td>
</tr>
<tr>
<td>Processing Cycles</td>
<td>763</td>
</tr>
<tr>
<td>Iterative Processing of Cycles</td>
<td>764</td>
</tr>
<tr>
<td>Cumulative Processing of Cycles</td>
<td>766</td>
</tr>
<tr>
<td>Parallel Processing of Cycles of an Allocation Type</td>
<td>769</td>
</tr>
<tr>
<td>Creating or Changing Cycles</td>
<td>770</td>
</tr>
<tr>
<td>Displaying the Cycle Overview</td>
<td>773</td>
</tr>
<tr>
<td>Functions Within Cycle Maintenance</td>
<td>777</td>
</tr>
<tr>
<td>Processing Cycles</td>
<td>778</td>
</tr>
<tr>
<td>Processing Cycle Run Groups</td>
<td>780</td>
</tr>
<tr>
<td>Displaying Cycle Information</td>
<td>781</td>
</tr>
<tr>
<td>Finding Objects in Cycles</td>
<td>782</td>
</tr>
<tr>
<td>Displaying or Changing Segments of a Cycle</td>
<td>783</td>
</tr>
<tr>
<td>Segment</td>
<td>785</td>
</tr>
<tr>
<td>Creating Segments</td>
<td>788</td>
</tr>
<tr>
<td>Locking Segments in a Cycle</td>
<td>791</td>
</tr>
<tr>
<td>Allocating Plan Values in an Actual Allocation Cycle</td>
<td>792</td>
</tr>
<tr>
<td>Allocating Actual Values in Plan Allocation Cycles</td>
<td>793</td>
</tr>
<tr>
<td>Defining Tracing Factors</td>
<td>794</td>
</tr>
<tr>
<td>Scaling of Negative Tracing Factors</td>
<td>797</td>
</tr>
<tr>
<td>Defining Receiver Weighting Factors</td>
<td>799</td>
</tr>
<tr>
<td>Copying Segments</td>
<td>800</td>
</tr>
<tr>
<td>Executing Periodic Repostings or Periodic Allocations Online</td>
<td>801</td>
</tr>
<tr>
<td>Results of Periodic Repostings or Periodic Allocations</td>
<td>805</td>
</tr>
<tr>
<td>Displaying Standard Settings</td>
<td>808</td>
</tr>
<tr>
<td>Displaying Messages</td>
<td>809</td>
</tr>
<tr>
<td>Displaying Line Items</td>
<td>811</td>
</tr>
<tr>
<td>Displaying Segment Lists</td>
<td>812</td>
</tr>
<tr>
<td>Displaying Sender Lists</td>
<td>813</td>
</tr>
<tr>
<td>Displaying Receiver Lists</td>
<td>814</td>
</tr>
<tr>
<td>SAP AG Cost Center Accounting (CO-OM-CCA)</td>
<td></td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Displaying Journals</td>
<td>816</td>
</tr>
<tr>
<td>Technical Statistics, Expert Trace, and Divergence Analysis</td>
<td>817</td>
</tr>
<tr>
<td>Printing Detail Lists</td>
<td>819</td>
</tr>
<tr>
<td>Executing Periodic Repostings/Allocations in the Background</td>
<td>820</td>
</tr>
<tr>
<td>Reversing Periodic Repostings or Periodic Allocations Online</td>
<td>824</td>
</tr>
<tr>
<td>Segment Adjustments in Closed Periods</td>
<td>825</td>
</tr>
<tr>
<td>Example 1: Segment Reversal Without Segment Rebook</td>
<td>828</td>
</tr>
<tr>
<td>Example 2: Segment Reversal and Segment Rebook</td>
<td>830</td>
</tr>
<tr>
<td>Executing Segment Reversals</td>
<td>832</td>
</tr>
<tr>
<td>Executing Segment Reversal with Segment Rebook</td>
<td>834</td>
</tr>
<tr>
<td>Reversing Segment Adjustments</td>
<td>836</td>
</tr>
<tr>
<td>Displaying Previous Segment Corrections</td>
<td>837</td>
</tr>
<tr>
<td><strong>Example: Periodic Reposting of Telephone Costs</strong></td>
<td>838</td>
</tr>
<tr>
<td>Creating Collection Cost Centers</td>
<td>839</td>
</tr>
<tr>
<td>Creating Statistical Key Figures</td>
<td>840</td>
</tr>
<tr>
<td>Defining Periodic Reposting</td>
<td>841</td>
</tr>
<tr>
<td>Entering Telephone Costs in Financial Accounting</td>
<td>844</td>
</tr>
<tr>
<td>Entering statistical key figures</td>
<td>845</td>
</tr>
<tr>
<td>Executing Periodic Reposting</td>
<td>846</td>
</tr>
<tr>
<td>Executing Reports</td>
<td>847</td>
</tr>
<tr>
<td><strong>Variance Calculation</strong></td>
<td>848</td>
</tr>
<tr>
<td>Variance Categories</td>
<td>853</td>
</tr>
<tr>
<td>Input Side Variances</td>
<td>855</td>
</tr>
<tr>
<td>Output Side Variances</td>
<td>859</td>
</tr>
<tr>
<td>System Settings for Variance Calculations</td>
<td>864</td>
</tr>
<tr>
<td>Target Cost Calculation</td>
<td>866</td>
</tr>
<tr>
<td>Actual Cost Splitting</td>
<td>868</td>
</tr>
<tr>
<td><strong>Predistribution of Fixed Costs</strong></td>
<td>871</td>
</tr>
<tr>
<td>Executing Predistribution of Fixed Costs</td>
<td>875</td>
</tr>
<tr>
<td><strong>Actual Price Calculations</strong></td>
<td>878</td>
</tr>
<tr>
<td>Example of Price Calculation</td>
<td>881</td>
</tr>
<tr>
<td>Calculating Actual Activity at Actual Prices</td>
<td>882</td>
</tr>
<tr>
<td>Price Calculation Methods</td>
<td>883</td>
</tr>
<tr>
<td>Price Calculation With Cost Component Split</td>
<td>887</td>
</tr>
<tr>
<td><strong>Year-End Closing</strong></td>
<td>890</td>
</tr>
<tr>
<td>Carrying Forward Commitments</td>
<td>891</td>
</tr>
<tr>
<td><strong>Information System (CO-OM)</strong></td>
<td>892</td>
</tr>
<tr>
<td>Interactive Information System</td>
<td>893</td>
</tr>
<tr>
<td>Accessing Overhead Cost Reports</td>
<td>895</td>
</tr>
<tr>
<td>Searching for Documentation on Reports</td>
<td>897</td>
</tr>
<tr>
<td>Report Painter Report</td>
<td>899</td>
</tr>
<tr>
<td>Executing Report Painter Reports</td>
<td>901</td>
</tr>
<tr>
<td>Functions for Report Access</td>
<td>906</td>
</tr>
<tr>
<td>User Settings</td>
<td>907</td>
</tr>
<tr>
<td>Managing Extracts</td>
<td>908</td>
</tr>
<tr>
<td>Reading Standard Reports from Archives</td>
<td>911</td>
</tr>
<tr>
<td>Variation</td>
<td>916</td>
</tr>
<tr>
<td>Executing Variations</td>
<td>918</td>
</tr>
<tr>
<td>Function</td>
<td>Page</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Example: Variation</td>
<td>920</td>
</tr>
<tr>
<td>Multiple Selection</td>
<td>921</td>
</tr>
<tr>
<td>Executing Multiple Selections</td>
<td>923</td>
</tr>
<tr>
<td>Example: Multiple selection</td>
<td>925</td>
</tr>
<tr>
<td>Functions for Output of Report Painter Reports</td>
<td>926</td>
</tr>
<tr>
<td>Printing Reports</td>
<td>928</td>
</tr>
<tr>
<td>Exporting Reports</td>
<td>929</td>
</tr>
<tr>
<td>Sending Reports</td>
<td>931</td>
</tr>
<tr>
<td>Selecting/Deselecting Blocks</td>
<td>932</td>
</tr>
<tr>
<td>Entering Threshold Value Conditions</td>
<td>933</td>
</tr>
<tr>
<td>Sorting Report Rows</td>
<td>934</td>
</tr>
<tr>
<td>Hiding/Showing Rows</td>
<td>935</td>
</tr>
<tr>
<td>Selecting Columns and Rows</td>
<td>936</td>
</tr>
<tr>
<td>Navigating Within Reports</td>
<td>937</td>
</tr>
<tr>
<td>Graphics</td>
<td>938</td>
</tr>
<tr>
<td>Calling Up Reports</td>
<td>939</td>
</tr>
<tr>
<td>Variation Functions</td>
<td>940</td>
</tr>
<tr>
<td>Example: Variation Functions</td>
<td>941</td>
</tr>
<tr>
<td>Summarization Level</td>
<td>942</td>
</tr>
<tr>
<td>Hierarchies</td>
<td>943</td>
</tr>
<tr>
<td>Extras</td>
<td>944</td>
</tr>
<tr>
<td>Specifying Column Widths</td>
<td>945</td>
</tr>
<tr>
<td>Setting Number Formats</td>
<td>946</td>
</tr>
<tr>
<td>Settings</td>
<td>947</td>
</tr>
<tr>
<td>Example Process: Report Callup with Extract Management</td>
<td>949</td>
</tr>
<tr>
<td>Creating and Issuing Authorizations for System Administrators and Cost Center Managers</td>
<td>952</td>
</tr>
<tr>
<td>User Settings</td>
<td>953</td>
</tr>
<tr>
<td>Executing Cost Center Reports with Variation</td>
<td>955</td>
</tr>
<tr>
<td>Managing Extracts</td>
<td>957</td>
</tr>
<tr>
<td>Calling Up Cost Center Reports</td>
<td>960</td>
</tr>
<tr>
<td>Period-Based Information System</td>
<td>961</td>
</tr>
<tr>
<td>Executing Report Painter Reports in the Background</td>
<td>962</td>
</tr>
<tr>
<td>Execution of Period-Based Report Painter Reports</td>
<td>963</td>
</tr>
<tr>
<td>Planning Background Jobs</td>
<td>965</td>
</tr>
<tr>
<td>Editing Step Lists and Assigning Variants</td>
<td>967</td>
</tr>
<tr>
<td>Example: Enhance background job</td>
<td>969</td>
</tr>
<tr>
<td>Checking the Processing Status</td>
<td>971</td>
</tr>
<tr>
<td>Maintaining Variants</td>
<td>974</td>
</tr>
<tr>
<td>Executing Period-Based Report Painter Reports with Multiple Selection</td>
<td>975</td>
</tr>
<tr>
<td>Important Standard Reports in Cost Center Accounting</td>
<td>976</td>
</tr>
<tr>
<td>Area: Cost Elements</td>
<td>977</td>
</tr>
<tr>
<td>Cost centers: Act./Plan/Variance and Act./Target/Variance</td>
<td>978</td>
</tr>
<tr>
<td>Cost Centers: Drilldown by Partner</td>
<td>979</td>
</tr>
<tr>
<td>Area: Cost Centers</td>
<td>980</td>
</tr>
<tr>
<td>Cost Centers: Actual/Plan/Commitments</td>
<td>981</td>
</tr>
<tr>
<td>Cost Centers: Drilldown by Transaction</td>
<td>982</td>
</tr>
<tr>
<td>Cost Centers: Internal Business Volume</td>
<td>983</td>
</tr>
</tbody>
</table>
Cost Centers: Rolling Year
Area: Statistical Key Figures
Cost centers: Variances
Cost Centers: Splitting
Template Allocation Structure for Cost Center/Activity Type
Actual/Plan/Commitment Report
Executing the Actual/Plan/Commitment Report
Planning Overview
Executing Planning Overviews Online
Executing Planning Overviews in Background
Price Report
Executing Price Reports Online
Determining Selection Options
Displaying Price Reports
Displaying Period Screens and Overview Screens
Displaying the Master Record
Displaying Cost Components
Executing Price Reports in Background
Line Item Report
Cost Centers: Actual Line Item Report
Cost Centers: Plan Line Item Report
Cost Centers: Commitments Line Item Report
Executing Line Item Reports Online
Deleting Selections
Maintaining Variants
Setting Actual Versions
Selecting Value Types
Specifying Additional Selection Criteria
Displaying Groups
The Line Item Report Display
Displaying Source Documents and Accounting Documents
Displaying the Master Record from the Line Item Report
Displaying Selection Criteria and Selection Logs
Maintaining Header Rows
Executing Line Item Reports in Background
Document Display
Executing Document Display Online
Basic List for Document Display
Executing Document Display in the Background
Master Data Indexes
Calling Up Master Data Indexes
Report Definition
Importing Standard Reports
Standard Layouts
Libraries
Standard Naming Procedure for Information System Objects
Editing Reports
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Groups</td>
<td>1050</td>
</tr>
<tr>
<td>Report Painter</td>
<td>1052</td>
</tr>
<tr>
<td>Report Painter Report</td>
<td>1054</td>
</tr>
<tr>
<td>Creating a Report Painter Report</td>
<td>1056</td>
</tr>
<tr>
<td>Process for Creating Report Painter Reports</td>
<td>1058</td>
</tr>
<tr>
<td>Defining Row and Column Models</td>
<td>1061</td>
</tr>
<tr>
<td>Creating a Model</td>
<td>1062</td>
</tr>
<tr>
<td>Inserting a Model</td>
<td>1063</td>
</tr>
<tr>
<td>Transporting Models</td>
<td>1064</td>
</tr>
<tr>
<td>Defining Columns</td>
<td>1065</td>
</tr>
<tr>
<td>Defining Rows</td>
<td>1068</td>
</tr>
<tr>
<td>Defining Cells</td>
<td>1070</td>
</tr>
<tr>
<td>Defining Sections</td>
<td>1071</td>
</tr>
<tr>
<td>Defining Horizontal Pages</td>
<td>1073</td>
</tr>
<tr>
<td>Exploding Report Rows</td>
<td>1074</td>
</tr>
<tr>
<td>Formatting Rows and Columns</td>
<td>1076</td>
</tr>
<tr>
<td>General Data Selection</td>
<td>1079</td>
</tr>
<tr>
<td>Variation</td>
<td>1082</td>
</tr>
<tr>
<td>Eliminating Internal Business Volume</td>
<td>1084</td>
</tr>
<tr>
<td>Defining Report Headers</td>
<td>1085</td>
</tr>
<tr>
<td>Report Text</td>
<td>1086</td>
</tr>
<tr>
<td>Defining Report Texts</td>
<td>1087</td>
</tr>
<tr>
<td>Report Overview</td>
<td>1088</td>
</tr>
<tr>
<td>Editing Report Painter Reports with Report Writer</td>
<td>1089</td>
</tr>
<tr>
<td>Example Process: Creating a Report Painter Report</td>
<td>1090</td>
</tr>
<tr>
<td>Report Writer</td>
<td>1100</td>
</tr>
<tr>
<td>Sets</td>
<td>1101</td>
</tr>
<tr>
<td>Using Sets</td>
<td>1103</td>
</tr>
<tr>
<td>Predefined Business Key Figures</td>
<td>1105</td>
</tr>
<tr>
<td>Variables in Set Maintenance</td>
<td>1107</td>
</tr>
<tr>
<td>Report Text</td>
<td>1109</td>
</tr>
<tr>
<td>Process Example: Creating a Report Writer Report</td>
<td>1110</td>
</tr>
<tr>
<td>Defining Reports For Overhead Cost Controlling</td>
<td>1115</td>
</tr>
<tr>
<td>Report Painter Or Report Writer?</td>
<td>1117</td>
</tr>
<tr>
<td>Important Basic Key Figures In Overhead Cost Controlling</td>
<td>1118</td>
</tr>
<tr>
<td>Characteristics In Overhead Cost Controlling</td>
<td>1119</td>
</tr>
<tr>
<td>Debit/Credit Indicator (BELKZ &lt;-&gt; BEKNZ)</td>
<td>1125</td>
</tr>
<tr>
<td>Examples of BELKZ and BEKNZ</td>
<td>1126</td>
</tr>
<tr>
<td>Responsible Cost Center (RESP-FLAG)</td>
<td>1128</td>
</tr>
<tr>
<td>Period (PERIO/PERBL/FISCPER)</td>
<td>1130</td>
</tr>
<tr>
<td>Value Type (WRTTP)</td>
<td>1131</td>
</tr>
<tr>
<td>Elimination Of Internal Business Volume (BUEKZ)</td>
<td>1132</td>
</tr>
<tr>
<td>Possible Combinations Of Characteristics/Key Figures</td>
<td>1133</td>
</tr>
<tr>
<td>Special Features In The Definition Of Cost Element Reports For Projects</td>
<td>1134</td>
</tr>
<tr>
<td>Reports With Currency Translation</td>
<td>1135</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Cost Center Summarizations</td>
<td>1137</td>
</tr>
<tr>
<td>Executing Cost Center Summarization</td>
<td>1139</td>
</tr>
<tr>
<td>Cross-Application Topics (CO-OM)</td>
<td>1141</td>
</tr>
<tr>
<td>Validation and Substitution</td>
<td>1142</td>
</tr>
<tr>
<td>Archiving</td>
<td>1143</td>
</tr>
<tr>
<td>Application Link Enabling (ALE)</td>
<td>1144</td>
</tr>
<tr>
<td>Changeover to the Euro</td>
<td>1145</td>
</tr>
</tbody>
</table>
Cost Center Accounting (CO-OM-CCA)

Purpose

You use Cost Center Accounting for controlling purposes within your organization. The costs incurred by your organization should be transparent. This enables you to check the profitability of individual functional areas and provide decision-making data for management. This requires that all costs be assigned according to their source. However, source-related assignment is especially difficult for overhead costs. Cost Center Accounting lets you analyze the overhead costs according to where they were incurred within the organization.

Depending on the level of decision-making powers assigned to the manager of an organizational unit, you can distinguish between various types of responsibility areas within an organization:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Recording costs with reference to plan values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profit centers</td>
<td>Calculating operating results</td>
</tr>
<tr>
<td>Investment centers</td>
<td>Calculating Return On Investment</td>
</tr>
<tr>
<td></td>
<td>In the SAP System you can create an investment center in the Profit Center Accounting component (EC-PCA). You do this by assigning balance sheet items to a profit center.</td>
</tr>
</tbody>
</table>

Dividing an organization into cost centers allows you to follow several goals, depending on the cost accounting method.

- Assigning costs to cost centers lets you determine where costs are incurred within the organization.
- If you plan costs at cost center level, you can check cost efficiency at the point where costs are incurred.
- If you want to assign overhead costs accurately to individual products, services, or market segments, you need to further allocate the costs to those cost centers directly involved in the creation of the products or services. From these cost centers you can then use different methods to assign the activities and costs to the relevant products, services, and market segments.

  This enables you to valuate semi-finished and finished products in Product Cost Controlling (CO-PC), and to calculate contribution margins in Profitability Analysis (CO-PA).

  The “activities” of cost centers represent “internal resources” for business processes in Activity-Based Costing.

Implementation

Cost Center Accounting (CO-OM-CCA) is often used in the first phase of an R/3 implementation, together with the main areas of Financial Accounting (General Ledger (FI-GL), Assets Payable (FI-AP), Assets Receivable (FI-AR)) and Overhead Orders (CO-OM-OPA).

You can also implement Cost Center Accounting without Financial Accounting. Some settings, however, such as chart of accounts, company code, must be made in Financial Accounting.
Integration

The costs of each cost-accounting-relevant business transaction portrayed in the R/3 System through can be assigned through Cost and Revenue Element Accounting (CO-OM-CEL) to an account assignment object in the Controlling component (CO). For overhead costs this can be cost centers, internal orders, business processes, or overhead projects.

Recording and assigning overhead costs allows you to control costs and prepare information for the subsequent areas of Cost Accounting.

You can use the methods of activity allocation, assessment or distribution to further allocate costs, for example, to internal orders (CO-OM-OPA), projects (PS), cost objects (CO-PC) or market segments (CO-PA).

Features

Entering actual costs

Primary costs can be transferred to Cost Accounting from other components, for example, Materials Management (MM), Asset Accounting (AA), Payroll Accounting (PY).

Additional costs and outlay costs are recorded using the accrual method.

Allocating actual costs

You can use various methods to further allocate the actual costs you have recorded, according to their source. The R/3 System distinguishes between transaction-based allocations, which occur within one period, and period-based allocations, which occur at period end.

Planning activities and costs

You can use planning to define organizational targets and carry out regular cost-effectiveness checks. Variances can be calculated by comparing the actual costs and activities with the plan values. These variances serve as a control signal, which helps you to correct business processes, when required.

You can plan costs and activities to determine allocation (activity) prices.

Allocating plan costs

All actual allocations that occur for cost centers can also be planned (for example, distribution, assessment, indirect activity allocation).

Entering plan and actual statistical key figures

Statistical key figures are used as the basis for the indirect allocation methods, as well as for evaluations in the information system (for example, employees, telephones).

Activity Accounting

Activity Accounting uses the activity produced by a cost center as the tracing factor for the costs. You can use activities to measure the operating rate or the rate of capacity utilization for a cost center. The target costs of the cost center refer to the activity output.

Depending on the source of the costs, the activities of a cost center are divided into various activity types (for example, for the Work center cost center: Repair hours or Assembly hours.)
Cost Center Accounting (CO-OM-CCA)

Information system
The information system provides tools with which you can analyze the cost flows that have occurred in your organization. You can carry out standard recurring evaluations; and create special reports for unique tasks or situations.

Constraints
Note that you can only post revenues statistically on cost centers. The true posting must occur on a revenue-carrying object. This could be, for example, a revenue-carrying order (see: Account Assignment for Controlling Objects [Ext.]).
Master Data in Cost Center Accounting (CO-OM-CCA)

Use

Master data determines the structure of the given application component in the SAP System and remains essentially unchanged in a live system, that is, in the current settlement periods.

The cost center structure can reflect the structure of your organization. It generally remains constant over long periods. You can execute cost center planning to reflect your cost center structure and generate periodic cost center and area reports, which can be passed on to the person responsible for analysis. These reports help identify economic weaknesses and planning errors in individual cost centers. To be able to compare results effectively, you should not make changes to this data.

You generally maintain master data once, before the start-up of Cost Center Accounting. It is either entered manually or transferred from legacy or external systems. You can transfer data to the SAP System in two ways:

- External Data Transfer with Function Modules [Ext.]
- External Data Transfer with BAPIs [Ext.]

Master data for Cost Center Accounting is stored in master data tables.

Integration

The SAP System distinguishes between:

- Master data and
- Transaction data

Transaction data can be subdivided into:

- Totals data and
- Line items

Transaction data is business transaction-oriented data that you can continuously create or change in a live system. You store transaction data for Cost Center Accounting in line item tables and totals tables.

The system saves the results of individual postings and business transactions in line item tables. These include postings from external accounting systems, which are found both in Financial Accounting (FI) and in the line item table for primary costs. The following postings are recorded in this way:

- Postings of primary costs in the Financial Accounting (FI)
- Material withdrawals from Materials Management (MM)
- Postings generated during distribution

In these cases, the data is held redundantly in the system. This is necessary, however, as external and internal accounting evaluate the data from different perspectives. External accounting (Financial Accounting) requires the complete document for
evaluations, whereas internal accounting (Controlling) differentiates between primary and secondary costs.

Transaction data also includes postings in Controlling (CO). These postings are made either:

− Using the original cost element (reposting, distribution) or
− Using a secondary cost element (assessment, internal activity allocation).

All postings are stored in the line item table for secondary data.

The sum of the line items for each cost element is updated in the totals tables, which are also split into primary and secondary postings. Totals tables represent a summarization of the line items tables. You can access these tables in the information system during cost center/cost element analysis, as well as in line item reports.
**Processing Master Data**

**Use**
The following functions for creating, changing and displaying master data are available for:

- Cost elements [Ext.]
- Cost centers [Ext.]
- Business processes [Ext.]
- Activity types [Ext.]
- Statistical key figures [Ext.]
- Resources [Ext.]

**Features**
You can use the following functions for **individual objects** (individual processing):

<table>
<thead>
<tr>
<th>Master Data</th>
<th>Processing Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost elements</td>
<td>Create primary or secondary, change, display, delete, display changes</td>
</tr>
<tr>
<td>Cost centers</td>
<td>Create, change, display, delete, display changes</td>
</tr>
<tr>
<td>Business processes</td>
<td>Create, change, display or delete</td>
</tr>
<tr>
<td>Activity types</td>
<td>Create, change, display, delete, display changes</td>
</tr>
<tr>
<td>Statistical key figures</td>
<td>Create, change, display or delete</td>
</tr>
</tbody>
</table>

You can use the following functions for **more than one object** (collective processing):

<table>
<thead>
<tr>
<th>Master data</th>
<th>Processing Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost elements</td>
<td>Display, delete</td>
</tr>
<tr>
<td>Cost centers</td>
<td>Change, display, delete, rough entry</td>
</tr>
<tr>
<td>Business processes</td>
<td>Change, display, delete</td>
</tr>
<tr>
<td>Activity types</td>
<td>Display, delete</td>
</tr>
<tr>
<td>Statistical key figures</td>
<td>Change, display</td>
</tr>
<tr>
<td>Resources</td>
<td>Create, change, display</td>
</tr>
</tbody>
</table>
You can also create, change or display master data groups. For more information, see Processing Master Data Groups [Page 38].

See also

Creating, Changing or Displaying Master Data [Page 30]
Processing Statistical Key Figures [Page 170]
Processing Resources [Page 176]
Time-Dependency of Master Data

Use

You can maintain master data for cost centers [Ext.], cost elements [Ext.], activity types [Ext.] and business processes [Ext.] with time-based dependencies. You can make changes at any time for any time interval. The saving of data is also time-dependent. This can result in multiple database records for a master data record, with different information stored in each database record.

Features

SAP has determined the times when a field may be changed - these cannot be changed. The following time-dependencies are possible:

- Not time-based
  
  The corresponding fields are only valid for the whole period of time in which the object exists, and can only be changed during this period.

  Example: Hierarchy area

- Day-based time dependency

  You can change the corresponding fields as often as you wish, and they are also valid for one or more days.

  Example: Lock indicator

- Period-based time dependency

  The corresponding fields are valid for one period (for example, a month) and are not changeable during this time.

  Example: Profit centers

- Fiscal-year-based time dependency

  The corresponding fields are valid for a whole fiscal year and cannot be changed during that year.

  Example: Cost center currency

For fields that are time-dependent on a daily basis, you can set an indicator to specify whether they are to be saved on a time basis (and so become historically relevant) in customizing for the given master data. See, for example, Specifying Time-Dependent Fields for Cost Centers [Ext.].

Fields with period-based and fiscal year-based time dependencies are always historically relevant.

⚠️

Note that time-dependent storage can lead to large volumes of data. Therefore, define only important fields as historically relevant.
Time-Dependency of Master Data

If the contents of all fields marked as historically relevant are identical in consecutive analysis periods, the SAP System replaces the multiple data records during master data maintenance with a data record for all the single record periods.

Activities

- If you change master data marked as historically relevant, and define a new analysis period for the changed fields, the SAP System creates new data records and shortens the validity period of existing records.

  You create an object (such as a cost center) valid from 01.01.1996 to 31.12.1999, with the manager Brown. You then change the object by defining a different cost center manager for the period from 01.01.1997 to 31.12.1997. You marked the Manager field as historically relevant during Customizing.

  The SAP System saves three data records. To display these in master data maintenance, select the Person responsible field and choose Drilldown:
  
  • One data record for the interval from 01.01.1996 to 31.12.1996, Manager: Brown
  • One data record for the interval from 01.01.1997 to 31.12.1997, Manager: Smith
  • One data record for the interval from 01.01.1998 to 31.12.1999, Manager: Brown

- If you change master data fields marked as historically relevant without defining a new analysis period, the system changes the existing data record for the entire analysis period selected. You can find these changes listed in the change document.

  You proceed as with the previous example, but change the Person responsible field without defining a new analysis period. The SAP System creates only one data record for the Person responsible field from 01.01.1996 to 31.12.1999, Manager: Smith.

  • To change historically-relevant fields in multiple analysis periods, select the appropriate analysis periods during master data maintenance.

  • If you change master data fields that are time-dependent on a daily basis, and not marked as historically relevant, the SAP System changes the existing data record for the entire analysis period selected. You cannot define a new analysis period. You can find these changes listed in the change document.

  You have set the indicator for Person responsible to not historically relevant. Proceed in the same way as the previous example. The SAP System creates only one data record for the Person responsible field from 01.01.1996 to 31.12.1999, Manager: Smith.

  The change document lists the master data field changes. To display the individual changes, choose Environment → Change documents → For field/For cost center in
the master data maintenance, for detailed information on each change. Double click to call up the detail information for each change.

- If you change master data fields that are not time-dependent, the SAP System changes the existing data record for the entire period in which the master data exists. When you change these fields, no new analysis period may be entered.

- Time-based master data storage reduces the maintenance requirements in the SAP System. You can create master data across fiscal year boundaries, and use this data for more than one year without having to recreate the data again each year. You can make changes relevant to a given time-period at any time, without immediately affecting the current data.

You have created a cost center with the following data:

- Cost center 4110
  - Validity period: 01.01.1996 to 31.12.2000

This entry has the advantage that the cost center can be processed in the SAP System until 31.12.2000 inclusively.

On the other hand, you have created a cost center with the following data:

- Cost center 4110
  - Validity period: 01.01.1996 to 31.12.1996

This has the disadvantage that cost center 4110 must be created again if you require it for the following fiscal year.

This rule applies to other objects in Cost Center Accounting, such as cost elements, activity types and business processes.

In the example above, the analysis periods correspond to year boundaries according to the calendar year. You can, however, define periods not based on the calendar year.

This is especially necessary when you have used the fiscal year variant in Financial Accounting to define a postponed fiscal year, an over-long fiscal year or a shortened fiscal year. In these cases, the master data is not based on the fiscal year variants.
Selection variant

Use
You use selection variants to select master data for cost elements [Ext.], cost centers [Ext.], activity types [Ext.], business processes [Ext.], orders [Ext.] or WBS elements [Ext.] using one or more master data attributes.

You define a selection variant, with which you can select all cost elements of a cost element category [Ext.], or all primary costs [Ext.].

You only need to enter the selection criteria for the object once and then save them in a selection variant. The system uses the criteria stored in the selection variant during runtime to determine the corresponding objects.

Note that the selection of objects can require a lot of runtime.

Features
During collective processing of master data you can use selection variants to select objects according to master data attributes.

When creating or changing groups (see: Creating or Changing Master Data Groups [Page 40]) you can insert existing selection variants in the end node of a hierarchy by choosing <Name of selection variant> or making a selection from the F4 help.

You can execute reports using selection variants in the Information System. To do this, enter the name of the selection variant instead of a group in the selection screen. You can also define reports using selection variants. Enter the name of the selection variant as the characteristic value under Group. This allows you, for example, to display in the report all the cost centers of a company code [Ext.]

Activities
You can create, change or display selection variants.

- You create selection variants in the Implementation Guide (IMG) of the given component under Master data under the information system [Ext.]

  For more detailed information on the procedure, see the IMG for each set of master data (for example, under Define Selection Variants and Cost Centers [Ext.]).

- During collective processing of the given master data

  To create new selection variants in collective processing, select Selection variant and choose Create selection variant.

  - In the list of activity type fields for each object, enter the criteria to be used for activity type selection.
  - Save your entries.
  - Enter a variant name and a description for your variant.
Selection variant

- **Save** your entries.
  
  To change an existing selection variant, select **Selection variant** and then choose **Change selection variant**.
  
  To display existing selection variants, select **Selection variant** and then choose **Display selection variant**.

  When you are creating or changing groups you can double click on the selection variant you have entered to change it. You **cannot**, however, create any new selection variants.
Creating, Changing, or Displaying Master Data

Purpose
The following functions for individual creating, changing and displaying master data are available for the following objects:

- Cost elements [Ext.]
- Cost centers [Ext.]
- Business processes [Ext.]
- Activity types [Ext.]

Process Flow
Call up each function for the corresponding master data from the SAP Easy Access menu.

Initial screen
- Enter the numeric key in the initial screen, for the object that you want to process.
- If you want to create new master data for an object, enter a validity period as well. You can use an existing object as a template.
- Choose Master data The system displays the basic screen for master data processing.
  - If the object was defined with field characteristics for an analysis period, you can access the basic screen directly.
  - If different field characteristics exist for the object in different analysis periods, the system displays a dialog box for the selection of the desired analysis period first.
    - To select a single analysis period, double-click on it, or select this period of time. Choose Choose to leave the dialog box.
    - To select more than one analysis period, select each interval using Select block. Choose Choose to leave the dialog box.

You have defined different field characteristics for your object for the following periods:
- From 01.01.1996 to 30.06.1996:
- From 01.07.96 to 31.10.96:
- From 01.11.96 to 31.12.96:
- From 01.01.97 to 31.12.99:
To select a single analysis period, for example from 01.01.1997 to 31.12.1999, double click on it in the dialog box.
To select an interval block, for example, from 01.01.1996 to 31.10.1996, choose *Select block* to select the individual periods (from 01.01.1996 to 30.06.1996 and 07.01.1996 to 31.10.1996), then choose *Choose*.

**Basic Screen**

The following graphic shows how the basic screen is set up, using the example of cost center master data:

![Diagram showing basic screen setup for cost center master data](image)

The master data fields, and their tab pages vary according to the object.

**Drilldown**

- Cost center _____
- Controlling area _____
- Valid from _____ Valid to _____

<table>
<thead>
<tr>
<th>Basic data</th>
<th>Control</th>
<th>Templates</th>
<th>Address</th>
<th>Communication</th>
<th>History</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name/Description</td>
<td>Record qty</td>
<td>Formula planning</td>
<td>Name</td>
<td>Language key</td>
<td>Created by</td>
</tr>
<tr>
<td>Manager</td>
<td>Set locks</td>
<td>Acty and process allocation</td>
<td>Street name</td>
<td>Telephone</td>
<td>Created on</td>
</tr>
<tr>
<td>Dept.</td>
<td></td>
<td>Overheads</td>
<td>PO box</td>
<td>Telebox no.</td>
<td>Display change document</td>
</tr>
<tr>
<td>Cost center category</td>
<td></td>
<td></td>
<td>City</td>
<td>Telex no.</td>
<td></td>
</tr>
<tr>
<td>Hierarchy area</td>
<td></td>
<td></td>
<td>Postal code</td>
<td>Telex no.</td>
<td></td>
</tr>
<tr>
<td>Company code</td>
<td></td>
<td></td>
<td>District</td>
<td>Telefax no.</td>
<td></td>
</tr>
<tr>
<td>Business area</td>
<td></td>
<td></td>
<td>Country</td>
<td>Teletext no.</td>
<td></td>
</tr>
<tr>
<td>Functional area</td>
<td></td>
<td></td>
<td>Region</td>
<td>Printer destination</td>
<td></td>
</tr>
<tr>
<td>Currency</td>
<td></td>
<td></td>
<td>Jurisdiction</td>
<td>Data line</td>
<td></td>
</tr>
<tr>
<td>Profit Center</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- The system displays the master data fields on different tab pages on the **basic screen**. After initial entry, the system displays the basic data tab page, which is ready for input. On this tab page, the system generally displays all fields that need to be edited.
- You can edit more fields by selecting the appropriate tab page. You can use pushbuttons on the tab pages to go from one maintenance transaction or display transaction to another.
Creating, Changing, or Displaying Master Data

- When you **change** or **display** master data fields, note the following two different situations:
  - If **field contents** exist for the analysis period, the system displays them on the corresponding tab page.
  - If **different field contents** exist for the analysis period, the system does **not** display the contents. A "+" in the corresponding field refers to the different field contents. To display the different field contents, double-click on the field, or choose **drilldown**.

- If the field can be changed for individual days, you can edit the field contents in the **Drilldown** dialog box.

- If you **cannot** change the field for individual days, choose **Edit -> Analysis period** to edit the field. Select one of the analysis periods in the dialog box. Then change the field contents. If you also want to make changes to other analysis periods, repeat the worksteps for the other analysis periods.

You have defined the **cost center type [Ext.]** for a cost center as follows:
- From 01.11.1996 to 31.12.1996: "P"
- From 01.07.1996 to 31.10.1996: "F"
- From 01.01.1996 to 30.06.1996: "H"

If you select the analysis period 01.01.1996 to 30.06.1996, the system displays "H" in the **Cost center category** field.

If you select the analysis period 01.01.1996 to 30.06.1996, the system displays "H" in the **Cost center category** field. Choose **Drilldown** to display the different field contents by period.

- You can change the analysis period in the **basic screen** for **changing** or **displaying** master data. Choose **Edit -> Analysis period**.
  
The system displays the **Analysis Period: Display** dialog box. You can:
  - Select another analysis period for editing or display.
  - Specify an analysis period that is not yet in the system, by choosing **Other analysis period**.

  The new analysis period must lie in the validity period of the object that you specified when you created the object. When you **save** the data, the system creates several data records using the changed field characteristics.

See also:

- [Processing Statistical Key Figures](#)
- [Processing Resources](#)
Deleting Master Data

Use

You can use the functions (that follow) for deleting master data for the following objects:

- Cost elements [Ext.]
- Cost centers [Ext.]
- Business processes [Ext.]
- Activity types [Ext.]

You can either delete cost centers individually or in collective processing.

Prerequisites

You can only delete each object in the current controlling area [Ext.] once the following has been done:

<table>
<thead>
<tr>
<th>Object</th>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost element</td>
<td>There is no transaction data for the cost elements in the planning or</td>
</tr>
<tr>
<td></td>
<td>commitments data in the affected fiscal years.</td>
</tr>
<tr>
<td></td>
<td>No statistical key figures [Ext.] have been planned.</td>
</tr>
<tr>
<td>Cost center</td>
<td>There is no transaction data for the cost elements in the planning or</td>
</tr>
<tr>
<td></td>
<td>commitments data in the affected fiscal years.</td>
</tr>
<tr>
<td></td>
<td>No statistical key figures have been planned.</td>
</tr>
<tr>
<td>Activity type</td>
<td>There is no transaction data for the activity types in the planning or</td>
</tr>
<tr>
<td></td>
<td>commitments data in the affected fiscal years.</td>
</tr>
<tr>
<td></td>
<td>No statistical key figures have been planned.</td>
</tr>
<tr>
<td>Business processes</td>
<td>There is no transaction data for the business processes in the planning or</td>
</tr>
<tr>
<td></td>
<td>actual data in the affected fiscal years.</td>
</tr>
<tr>
<td></td>
<td>No statistical key figures have been planned.</td>
</tr>
</tbody>
</table>

The corresponding checks are executed by the system.

Procedure

1. To delete individual objects, choose the Master data for relevant application from the SAP Easy Access Menu, and then <Object> → Individual processing → Delete.
   
   To delete individual objects, choose the Master data for relevant application from the SAP Easy Access Menu, and then <Object> → Individual processing → Delete.

2. To delete one object, enter it in the initial screen.
Deleting Master Data

To delete more than one object, enter the selection criteria for the objects in the initial screen. The following selection criteria are available for activity types:

a. <Object> or <Object>-interval
b. <Object> group
c. All <objects> in a controlling area
d. Selection variant [Page 28]

You save selection criteria for the object selection in the selection variant. You can use the selection variant to select all objects with the same entries in one or more master data fields.

You can create, change or display the selection variant at this point.

Select one of the criteria and enter the appropriate selection parameters.

3. Enter a time period in which the selected object(s) are valid.

Objects that you want to delete, must be in the selected time period. However, it is sufficient for the validity period for the object to overlap with the selected time period.

Deleting Objects Online

4. Before you delete one or more cost objects, you should check in a test run which of the selected objects may be deleted. To do so, accept the default values for the Test run and choose Execute.

a. The system carries out comprehensive checks on dependent data.

   The system displays a list of all the objects that you can delete.

   The system then displays a list of all the selected objects that you cannot delete. For each object, the system displays the dependent data that prevents deletion.

   The list display uses the ABAP list viewer [Ext.].

b. Return to the initial screen and correct the entries for the selection, if required.

5. To delete one or more objects, deselect Test run and choose Execute. Answer the confirmation prompt with Yes.

   The system lists all the selected objects that it deleted.

   It also lists all the objects it did not delete. For each object, the system displays the dependent data that prevents deletion.

   The list display uses the ABAP list viewer [Ext.].

Deleting Objects in The Background

6. If you want to delete a large number of objects, the checks for dependent data require quite some time. You should therefore carry out the deletion in the background at times of minimal system usage. Choose Background processing and choose Execute. Answer the confirmation prompt with Yes.

7. Enter a job name in the dialog box.

8. Enter a date and time for the planned start, or select Immediate start.
Deleting Master Data

You can also define from which date and from which time no more starts should occur.

9. Leave the dialog box by choosing Confirm. In the next dialog box, choose Save.

The system deletes the objects at the time specified.

10. To check the current status of the job, choose System → Own jobs → Job overview → Execute.
Master Data Groups

Definition

Master data can be grouped together, for example:

- Cost center groups
- Cost element groups
- Activity type groups
- Statistical key figure groups
- Business process groups
- Order groups

In addition to those groups that are subnodes of the standard hierarchy, for analysis or planning purposes, you can also create alternative groups that do not belong to the standard hierarchy.

All cost centers and business processes must be incorporated in the relevant standard hierarchy. Note that you can assign a cost center or business process to only one hierarchy group, but to any number of alternative groups.

Use

You can use master data groups in different areas (analysis, planning, allocation).

You can divide complex groups into manageable sections by separating them into sub-groups. You can create and maintain sub-groups separately and then combine them in larger groups.

Remember that groups have no time dependencies. In contrast, most master data is time-dependent.

If, for example, the cost center structure changes for the new fiscal year, the standard hierarchy changes with it. As the standard hierarchy is not time-dependent, the system ensures that reports covering multiple fiscal years always use the same standard hierarchy, thus providing comparable results.

To save older standard hierarchies for documentation purposes, copy the hierarchy before making changes and use this copy for evaluating reports for previous fiscal years (see: Copying Master Data Groups [Page 49]).
Processing Master Data Groups

Use
You can use the following functions to create and change groups for the following objects:

- Cost elements [Ext.]
- Cost centers [Ext.]
- Business processes [Ext.]
- Activity types [Ext.]
- Statistical key figures [Ext.]
- Orders [Ext.]
- WBS elements [Ext.]

Features
The following graphic shows the functions for processing master data groups:
Activities

To process master data groups, choose Master Data -> <Object> group from the SAP Easy Access menu in the relevant component.

See also

Creating or Changing Master Data Groups [Page 40],
Functions for Structural Processing of Master Data Groups [Page 42],
Additional Functions for Processing Master Data Groups [Page 44],
Transport Functions for Master Data Groups [Page 48],
Copying Master Data Groups [Page 49].
Creating or Changing Master Data Groups

Prerequisites

You want to create new master data groups or change existing ones.

Procedure

1. In the master data menu of the given application component, choose Master data → <object> group → Create or Change.
2. Enter the group you wish to change or create.
   - If you are creating a new group, you can use an existing group as a template. The template group can belong to the same controlling area [Ext.], or chart of accounts [Ext.], or different ones.
   a. If you are using reference groups from the same controlling area, assign a new name to the new group. The highest node contains the group names entered. The existing structure is appended to the highest node. This means that every change to the original automatically affects the copy.
   b. If you are using a reference group from a different controlling area, you may use the same name for the new group. The entire structure is copied into the current controlling area. It retains the same name. The copy and the original are two separate structures.
   c. If a subgroup (node) already exists with the same name you have selected for the new group, the system asks whether you want the existing group to be overwritten by the new group or whether the copying should be aborted (see: Copying Master Data Groups [Page 49]).
3. Choose Hierarchy.
4. You can create your groups successively in the group structure display.
   - To do so, select the node from which you want to extend the group, and choose Insert at same level or Insert at lower level.
5. At the required location in the tree structure, the system displays fields in which you can enter a name and description for the new subgroup (node).
   - You can use the F4 help to make your entries.
6. Then choose Enter or Accept change.
7. To assign individual values to an end node, select the node and choose Insert <object> (for example, Insert cost center).
   - So long as the structure is not the standard hierarchy for Cost Center Accounting or Activity-Based Costing, the system displays fields in which you can enter the From-value and the To-value.
   - You can use the F4 help to make your entries.
8. Choose Accept change.
   - The system either displays the individual values assigned and their descriptions, or issues a message that the individual values do not exist.
9. To create or change groups belonging to an object (such as a cost element or cost center), you can assign a selection variant to an end node (see: Selection Variants [Page 28]). Proceed as follows:
   a. Position your cursor on an end node.
   b. Choose *Insert <object> group at lower level* and enter the name of the selection variant, or choose this variant using input help.
   c. Choose *Enter*.
   d. To change the selection variant, simply double-click on it. You can reassign selection variants just as you reassigned groups.
   e. To display a list of the master data for a selection variant, position your cursor on the selection variant and choose *Extras → Break down selection variant*. In a dialog box the system displays a list of the corresponding master data.

When you are creating or changing groups you can not create any new selection variants.

10. Save your structure.

If you are processing the standard hierarchy [Ext.] or a hierarchy group of cost centers or business processes, you can also create or change the master data of cost centers or business processes.

See

Processing the Standard Hierarchy Using Group Maintenance [Page 106] (Cost Center Accounting)
Processing the Standard Hierarchy Using Group Maintenance [Ext.] (Activity-Based Costing)
Functions for Structural Processing of Master Data Groups

Use

The following functions for processing the structure are available to help you process master data groups:

Features

<table>
<thead>
<tr>
<th>Function</th>
<th>Description/Execution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand all/Collapse all</td>
<td>Expands or hides subgroups (nodes). You can also do this by clicking the “+” or “−” in the tree structure. To expand or collapse the entire tree, position your cursor on the top node and choose Expand/Collapse. You can display and print different summarizations of the hierarchy.</td>
</tr>
<tr>
<td>Find values</td>
<td>Searches for values within the given group. Choose Edit → &lt;Object&gt; → Search. The group is expanded to the value selected. The system marks the value. You can also search for a value by choosing System → List → Find.</td>
</tr>
<tr>
<td>Reassigning nodes</td>
<td>Assigns a node to a different group within the structure. Proceed as follows: 1. Select the subgroup or the node to be moved. 2. Select the target group (this can be on the same level or on a lower level). 3. To insert the subgroup, choose Lower level or Same level.</td>
</tr>
<tr>
<td>Remove nodes/values from the</td>
<td>Removes a subgroup or a value from the whole group. However, the given subgroup or value remains on the database. Proceed as follows: 1. Select the highest node containing the subgroup, value, or value interval. 2. Choose Edit → Selected entry → Remove 3. Save your change.</td>
</tr>
<tr>
<td>structure</td>
<td></td>
</tr>
</tbody>
</table>
### Functions for Structural Processing of Master Data Groups

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete node</td>
<td>Deletes the node of a group from the database.</td>
</tr>
<tr>
<td></td>
<td>Proceed as follows:</td>
</tr>
<tr>
<td></td>
<td>1. Select the highest node in the tree structure.</td>
</tr>
<tr>
<td></td>
<td>2. Choose <em>Edit → Selected entry → Delete</em></td>
</tr>
<tr>
<td></td>
<td>3. Answer the confirmation prompt with <em>Yes</em>.</td>
</tr>
<tr>
<td></td>
<td>You may only delete the given node if it is not used in any other place in the system.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the tree structure.</td>
</tr>
<tr>
<td></td>
<td>Choose <em>Group → Print or System → List → Print</em>.</td>
</tr>
<tr>
<td>Maintain values</td>
<td>Creates or changes values for a node of the group.</td>
</tr>
<tr>
<td></td>
<td>Choose <em>Insert &lt;Object&gt;</em>.</td>
</tr>
<tr>
<td></td>
<td>If the group belongs to the standard hierarchy for the cost centers or the business processes, you cannot insert the cost center or business process, but you <strong>can create it</strong>.</td>
</tr>
<tr>
<td>Sort individual values</td>
<td>Sorts the values of the given subgroups.</td>
</tr>
<tr>
<td></td>
<td>Place your cursor on a node and choose <em>Edit → &lt;Object&gt; → Sort asc./Sort desc.</em></td>
</tr>
<tr>
<td>Display or change master data</td>
<td>Branches to the <strong>display</strong> mode for the given master data.</td>
</tr>
<tr>
<td></td>
<td>Select a value and choose <em>Goto → Display “cost center” (and so on)</em>.</td>
</tr>
<tr>
<td></td>
<td>In the change mode of the group maintenance of cost centers and business processes you can also <strong>change</strong> the given master record.</td>
</tr>
<tr>
<td></td>
<td>If you have specified an interval of individual values, master data display is not possible.</td>
</tr>
</tbody>
</table>
Extra Functions for Processing Master Data Groups

Use
The following additional functions are available to help you process master data groups. Choose Extras or Goto from the menu:

Features

Functions in the Extras Menu
The Extras menu on the initial screen, or the group display, allow you to carry out the following functions for a controlling area [Ext.] and a key date (only possible when using time-based fields):

Entering Report Settings
- You make group settings for the display of Report Writer reports. You can also select the following indicators:
  - Row information in lower-level nodes:
    - Format class: Used to define columns and rows of a report for specific formatting.
    - Symbolic name to coordinate the addressing of cells in a report
    - Suppress the expansion of Report Writer Reports

- You can also set the following indicators for nodes (groups):
  - Header information:
    - Description
    - Symbolic name to coordinate the addressing of cells in a report
    - Representative cost centers

  The representative cost center represents a group of values that can be used in the following ways for processing a (cost center ) group in the information system:
  - Replaces text variables when displaying master data
  - Select a printer for printing a group, for which the responsibility area changes with each level.
  - Authorization checks:
    - The representative value determines the extracts in the variation that are to be protected from unauthorized access (See: Representative Cost Centers [Page 128]).
    - Authorization group for additional authorization protection

Expand Selection Variants [Ext.]
If you have inserted a selection variant as the end node of a group (see: Creating or Changing Master Data Groups [Page 40]), you can display a list of the master data for this selection variant. Position your cursor on the selection variant and choose Extras → Expand selection variant.
**Where-Used Lists for Subgroups**

To display the where-used list for groups (nodes), position your cursor on the group and choose *Extras → Where-used list for group*. Make the necessary settings.

**Checks and Help Functions**

- **Check uniqueness**
  
The system checks whether a node exists more than once in the same group, or a value exists more than once in the same node.

  
  If the individual value “5” appears in both subgroup A (interval 1 – 10) and subgroup B (Individual value 5), the R/3 System displays the overlap area (0000000005 – 0000000005) and both subgroups A and B.

- **Check completeness**
  
The system checks whether all the master data defined in the controlling area is included in the group you entered on the initial screen.

- **Group value search**
  
  You can search for individual values (for example, cost centers, cost elements, orders) within a group.

- **Delete non-used groups**
  
  You can delete the groups that have no where-used lists in the system (for example, groups for which allocations and reports are not used). The system selects all the corresponding groups. Select the groups that you want to delete, and choose *Delete group*.

- **Delete groups that have no organizational units**
  
  You can delete the groups that have not been assigned to any organizational unit. The system selects all the corresponding groups.

  
  To check whether all of these groups are to be deleted, start the function as a test run first.

- **Compare two groups**
  
  You can check two groups for common attributes. The system displays the common attributes and the differences in both hierarchies, with regards to assigned organizational units and values.

**Standard Hierarchy Master Data: Test / Comparison**

The SAP System checks the following for the standard hierarchy [Ext.] and the corresponding master data:

- Checks the uniqueness of the standard hierarchy:
  
  Each detail may only appear once

- Completion of the standard hierarchy:
  
  All master data records in the controlling area must be in the hierarchy
Extra Functions for Processing Master Data Groups

The Test function lists any errors found, while Adjust removes the errors.

**Entering Default Settings**

You can make the following default settings for the master data and the structure of groups: Choose Extras → Default settings → Structure.

- **Default settings for master data of groups:**
  - Master data check
    The SAP System checks whether a corresponding master record (such as a cost center for cost center groups) exists for individual values or representative values that you enter. For time-based master data this check occurs on the defaulted key date. You can display the corresponding master data record.
  - Breakdown intervals
    If value intervals exist for the end nodes, the system breaks these down in the group display. All the individual values existing in the interval are listed under the interval.
  - Display texts
    The system reads and displays the texts from the master data for the individual values.

- **Default settings for structures of groups:**
  - Display texts
    You can define whether subgroups (nodes) are displayed with or without text.
  - Display representative value
  - Display header information
  - Compress end nodes
    You can define whether end nodes should or should not be expanded when you expand a group.
  - Expand to level
    You can define to which level the expansion is carried out. The highest level is represented by the lowest level of a group.

You can make the following default settings for the use of groups: Choose Extras → Default settings → Where-used list.

You can select the following uses:

- Groups
- Allocations
- Reports
- Planning
- Rollup
- Variables
Extra Functions for Processing Master Data Groups

- Predefined columns
- Validation [Ext.]/Substitution [Ext.]
- Authorization objects
- Currency translation
- Customizing
- DART views

You can activate these indicators in the *Extras* menu. For system performance reasons, however, do not activate them for very large groups.

**Functions in the Goto Menu**

You can ensure that the system writes *change documents* for given master data groups in Controlling. These change documents log all the changes to the group structure and group name. You make these settings in Customizing, under *Controlling -> General Controlling -> Prepare Productive Start -> Activate Change Documents for Groups [Ext.]*.

To display change documents when you are processing groups, position your cursor on the subgroup (node) and choose *Goto → Change documents*.

⚠️

Note that writing change documents affects the performance of group maintenance functions. In particular, change documents should not be created for changes to order groups.
Transport Functions for Master Data Groups

Use
The transport functions below are provided for you for processing master data groups.

Features
Master data groups can be:

- **Exported**
  The system exports the selected group from a client [Ext.] with all dependent nodes (for example, a test client) to transfer it to a different (such as the production client). Enter the name of the export file. Select whether to export the data to the presentation server or the application server.

- **Imported**
  The system imports the exported groups with all subordinate nodes to the target client and saves them. Enter the name of the export file. Select whether to import the data to the presentation server or the application server.

- **Copying from a client**
  The SAP system copies the specified group from the source client to the target client.

⚠️ When importing and exporting data from a client, existing groups are overwritten. This could lead to inconsistencies in the master data.

💡 You have created the cost center standard hierarchy and all the cost centers in a Customizing client. You then created a new production client from the Customizing client using Copy from client. Afterwards, you deleted cost centers in the production client, created new cost centers, and restructured the standard hierarchy. If you now re-import the standard hierarchy from the Customizing client, this overwrites the standard hierarchy in the production client.

Proceed as follows:
- In the current client, export the groups to be overwritten to an export file.
- Then execute the import or copy from a client.
- Check the result of the import or the copy.
- If necessary, you can re-import the group to reset the previous group structure.
Copying Master Data Groups

Use
You can copy the following groups within a controlling area [Ext.] or within a chart of accounts [Ext.]:

- Cost center groups [Ext.]
- Cost element groups [Ext.]
- Activity type groups [Ext.]
- Statistical key figure groups [Ext.]
- Order groups [Ext.]
- Business process groups
- WBS element groups

Copying groups is especially useful for fixing characteristic values at a given time for a group with time-dependent objects: This lets you make changes that will affect the next fiscal year.

Copying within a chart of accounts or into a different chart of accounts always refers to cost element groups.

Features

Copying the entire group structure in the same controlling area or chart of accounts

1. In the relevant application component, choose Master data \(<object>\) group \(\rightarrow\) Create or Change or Display.

2. On the initial screen for group maintenance, choose Group \(\rightarrow\) Copy.

3. Enter the group to be copied and enter a suffix.

   The suffix can be any given string of alphanumeric or special characters. For example, you can use a numerical fiscal year that characterizes the group.

4. Choose Copy \(<object>\) group.

   The system copies the group. If a subgroup (node) in the target controlling area has the same name, the system asks whether you want the existing group to be overwritten by the new group.

5. Save the copy.

   The system creates a copy of the existing group in the same controlling area or chart of accounts. The system creates a new name for the copy by adding the suffix to the original name of the node. If a suffix already existed in the previous name, this is replaced by the new suffix.

   The copy and the original are two separate, independent structures.
The number of groups doubles with each copy transaction. For very large hierarchies, you should therefore regularly delete any copies you no longer require. Alternatively, you can keep the number of groups low if you copy only the parts in which changes have taken place and manually create the security copy.

Within controlling area 0001, you want to copy the current HIER group. Enter the suffix 1998.

The system generates the HIER 1998 group in controlling area 0001.
You copy order groups and WBS element groups independent of controlling area and chart of accounts.

### Copying the entire group structure in a different controlling area or chart of accounts

1. In the relevant application component, choose Master data → <object>-group → Create.
2. Choose a group from a different controlling area or chart of accounts (see: Creating or Changing Master Data Groups [Page 40] )
3. Enter a name for the new group and choose Hierarchy.

   You can adopt the name of the group used as the reference. The entire structure is then copied into the current controlling area or chart of accounts. It retains the same name.
4. Save the copy.

   The copy and the original are two separate, independent structures.

   This option does not exist for order groups, because they are not assigned to either a controlling area or a chart of accounts.

In controlling area 9999, you want to create a copy of the HIER group of controlling area 0001. To do this, create the HIER group in controlling area 9999 with reference to the HIER group of controlling area 0001.

### Copying the top group node in the same controlling area or chart of accounts and appending the existing structure.

1. In the relevant application component, choose Master data → <object>-group → Create.
2. Choose a group from the same controlling area or chart of accounts as a reference (see: Creating or Changing Master Data Groups [Page 40] )
3. Enter a new name for the new group and choose Hierarchy.

   The highest node contains the group names entered. The existing structure is appended to the highest node. This means that every change to the original automatically affects the copy.
4. Save the copy.
In controlling area 0001, you want to create the HIER_NEW group as a copy of the HIER group. To do this, create the HIER_NEW with reference to the HIER group. The system creates the HIER_NEW node. The remaining nodes are appended to this node.

When you copy groups, the system checks whether nodes of the same name as the copy already exist in the system. If the system finds at least one node with an existing name, a message asks you whether the system should overwrite the existing nodes or if the copying should not be executed. It is not possible to overwrite existing nodes in the standard hierarchy.
Example: Copying the Cost Center Standard Hierarchy

Problem:
You are processing the standard hierarchy using group maintenance.

In the current fiscal year, you want to carry out cost center planning for the following fiscal year, based on the standard hierarchy [Ext.]. However, in the new fiscal year, changes are made to the standard hierarchy structure. This could be, for example, because cost centers are removed or added, or because the hierarchy assignment of the cost centers has changed. To carry out planning using the standard hierarchy structure that is valid for the next fiscal year, you must make the appropriate changes to the standard hierarchy.

However, the existing standard hierarchy is required for reporting in the current fiscal year, because only this hierarchy portrays the structure in the current fiscal year.

Solution:
Copy the current standard hierarchy, and then make the changes to the structure.

You now have two hierarchies available in the system:

- The standard hierarchy for the current fiscal year, which you use for reporting
- The modified standard hierarchy, with which you carry out planning for the next fiscal year
Requesting a Master Data Change in the Intranet/Internet (AC)

Purpose

You can request the change to the following master data from the Intranet/Internet:

<table>
<thead>
<tr>
<th>Object</th>
<th>Type of change</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost centers [Ext.]</td>
<td>create, change, lock</td>
</tr>
<tr>
<td>Internal orders [Ext.]</td>
<td>date</td>
</tr>
<tr>
<td>G/L accounts [Ext.]</td>
<td>create, change</td>
</tr>
<tr>
<td>Vendors [Ext.]</td>
<td>Address change</td>
</tr>
<tr>
<td></td>
<td>Enter, delete, change bank details</td>
</tr>
<tr>
<td>Customers [Ext.]</td>
<td>Address change</td>
</tr>
<tr>
<td></td>
<td>Enter, delete, change bank details</td>
</tr>
</tbody>
</table>

You can only request changes to master data for customers and vendors via the Internet.

You do not have to know the name of the processor, since the system automatically determines it. The request is transferred to the SAP System and can be processed there with the functions of the message processing.

You can call up the individual request forms from the various SAP application (depending on the object) and from the workplace.

<table>
<thead>
<tr>
<th>Start change request</th>
<th>for &lt;Object&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>From the Employee Workplace [Ext.] launchpad</td>
<td>Cost centers, internal orders, G/L accounts, customers, vendors</td>
</tr>
<tr>
<td>from the Enterprise Organization [Page 66]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From Editing the standard hierarchy [Page 103]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From the cost center master data report [Page 1036]</td>
<td>Cost centers</td>
</tr>
<tr>
<td>From the web transaction Create internal order [Ext.]</td>
<td>Internal orders</td>
</tr>
<tr>
<td>From the web transaction Display internal order [Ext.]</td>
<td>Internal orders</td>
</tr>
<tr>
<td>From Editing G/L account master data individually [Ext.]</td>
<td>G/L accounts</td>
</tr>
</tbody>
</table>

Prerequisites

- In a scenario, you have defined the process for request a master data change.
  To do so, in Customizing choose Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific
Requesting a Master Data Change in the Intranet/Internet (AC)

Customizing → Request For Change to Master Data → Define Own Scenarios For Request For Change To Master Data [Ext.].

- For cost centers and G/L accounts, you have determined which requests can be started from the aforementioned SAP applications.

To do so, in Customizing choose (for example) Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request For Change to Master Data → Assign Own Scenarios For the Request For Change To Master Data [Ext.].

Process Flow

1. You call up the request form for a master data change.
   a. To call up the form from the Employee Workplace launchpad, choose Create internal service request.
   b. To call up the form from the SAP System, for the application choose Extras Change request for <object>.

   In the master data directory, specify that a cost center has to be changed.

   From the directory, you can go to the request form for master data changes by choosing Extras → Change request for cost centers.

2. You request a change to or a new master record using the form in the Intranet/Internet (see Processing Request Forms [Page 56]).

   When you send the request, the information is transferred to the SAP R/3 System. The system determines the responsible processor based on entries made in Customizing (see Define Own Scenarios For The Request For Change to Master Data [Ext.]).

3. The processor receives the request for a master data change in his/her worklist or workflow inbox (see Task Processing [Page 54]).

4. The following options are available to the processor:
   a. They may require additional information, should the request be incomplete. They attach a note to the requests and enter the person making the request as the processor.
   b. The processor rejects the request for a master data change.
   c. They approve the request and makes the necessary adjustments in the SAP R/3 System.
   d. They forward the request.

   In the second decision level, the options a to d are available again.

   In the last three cases, the processor can enter a text to explain the reason for his/her decision.

   You can check the current state of the request at any time (see Status Query of a Request [Page 57]).
Request for Master Data Change

**Intranet/Internet**
- Request form for:
  - Creating master data
  - Changing master data
  - Deleting master data
  - Locking master data

**SAP R/3 System**
- Request in the R/3 SAP System
  - Find processor
  - Request being processed
  - Execute
  - Request executed

**Decision**
- Query
- Forward
- Reject
- Execute

**Master data Database**
- Post

**Result**
The master data change is either completed or the request is rejected.

For more information, see the SAP Library under Cross-Application Components → Internal Service Request [Ext.].
Processing Request Forms

Use
With a request form, you can request a master data change from the Intranet/Internet.
The standard system comes with predefined formulas with which you can request changes to various objects. This form is divided into various areas, but you can adjust the layout and the individual fields individually.

Prerequisites
- You defined in Customizing which fields are to be available on the form.
  For more information, see Cross-Application Components → Internet/Intranet Services → Definition of Scenarios With Specific Customizing → Request For Master Data Change → Define Own Scenarios For The Request For Master Data Change [Ext.]
- You have defined the layout of the form
  a. Using the SAP@Web Studios [Ext.]
  b. Using the Web Application Builder [Ext.] in the ABAP Development Workbench
- If you access the form via Create an Internal Service Request from the launchpad of the Employee Workplace, you first have to select the right request from, such as a request for a new cost center or a change to customer bank details (see Creating an Internal Service Request [Ext.]).
Procedure

1. Enter the data for the object.

   For the request **Create a new cost center**, you are required to make the following entries:
   - Controlling area
   - Cost center key
   - Valid from ... to
   - Name
   - Responsible person

   For the request **Change an existing cost center**, you are required to make the following entries:
   - Controlling area
   - Cost center key
   - Valid from ... to

2. Enter a text to describe the problem.

   This is an optional entry.

3. If you know the name of the processor for this problem, enter it in the **processor** field.

   If a **processor** or a **standard role** was entered in Customizing, these fields contain the corresponding entries. The partner role setting in Customizing controls whether an individual employee or a department is entered as the problem processor. You can find additional information about roles in [Defining Roles based on Responsibilities](#) [Ext.].

   If an entire department was entered in Customizing as the processor, you **cannot overwrite** the Processor field. The system displays a list of the processors.

4. The fields for **Created by** contain your data.

5. If you make the request on behalf of someone else (for example, for a colleague or boss), you can also list the initiator.

   The processor of the request can then contact the initiator directly should any questions arise.

6. **Check** your entries.

7. **Send** the request.

   Confirm the message, that your request has been saved.

Result

The request is transferred to the SAP R/3 System and assigned to a processor.
Processing a Request in the SAP System

Use

You have made one of the following requests using an Intranet/Internal request form:

- Request Change to Master Data [Page 53]
- Request an Adjustment Posting [Ext.]

The request is automatically transferred to the SAP System and assigned to a processor.

Integration

The system creates a message [Ext.] when the request form is sent. The following functions are available for processing messages [Page 60] in the SAP System.

- Task processing [Page 64]
  The following jumps to the following activities are available in task processing:
  - Access to the request form
  - Access to the processing transactions in the SAP R/3 System
    that were set up in Customizing for the related requests.
    See Cross-Application Components → Internet/Intranet Services → Internal Service Request → Definition of Scenarios with Specific Customizing → Request for a Master Data Change (Request for an Adjustment Posting) → Define Own Scenarios For The Request For Master Data Change [Ext.] (Define Own Scenarios For The Request For Adjustment Postings [Ext.]).

- Status query [Page 67]
- Document Flow Display [Ext.]
  The document flow display is only relevant for the request for an adjustment posting.

Activities

To call up the functions for message processing, in the SAP Easy Access Menu choose Office → Message.

You can find additional information about messages in the SAP Library under Cross-Application Components (CA-NO) → Messages [Ext].
Processing Notifications

To process the internal service request [Ext.], you can do the following:

- Processing notifications [Page 61]
- Processing notifications using the worklist [Page 63]

You call up processing via:

- Office → Notification → Worklist → Notifications or
- Office → Notification → Change
Process Notification

Use

Put notification in process

Once you have created a notification and entered all relevant information, you can put the notification in process. When you put a notification in process, you release the notification for processing.

A notification can be put in process in the following ways:

- You can put a notification in process manually.
- The system puts a notification in process automatically if an order was created for the notification.

When a notification is put in process, the system changes the status of the notification from “outstanding” (OSNO) to “notification in process” (NOPR).

Postpone notification

In some cases, it may be necessary to delay the processing of a notification (for example, if the assigned tasks cannot be carried out yet).

Using this function, you can postpone the processing of a notification. When you postpone a notification, it receives the status NOPO (notification postponed).

You cannot postpone a notification that has already been put in process.

Complete notification

You complete a notification when the problem has been solved and no further processing is necessary. Once you complete a notification, you can no longer change any data in the notification. You can then only display the notification.

When a notification is completed, it receives the status NOCO (notification completed).

You cannot complete a notification if outstanding tasks still exist in the notification.

Categorizing a notification problem

When you complete a notification, the system displays a dialog box with the current date and time. You can accept the displayed date and time as the completion time or you can change it. In this dialog box, you must specify whether the problem arose because of an internal or external cause. For example, if a vendor delivers a defective product, you are dealing with an externally caused problem.

Put notification in process again

You can put a completed notification in process again, if you determine that additional processing is necessary.

Archive completed notification
Process Notification

Completed notifications are automatically archived and are deleted from the database after a specific, predefined time interval. This time interval is defined in Customizing. Therefore, make sure you have finished processing the notification before you complete it.

Delete notification

In some cases, you may want to delete a notification. You cannot, however, delete a notification directly. You must set a deletion flag in the notification which identifies it as one that can be deleted.

A company typically runs an archiving program at regular intervals. This program searches for the notifications with deletion flags, converts the deletion flags to deletion indicators, and copies the notifications to an archive. The system then deletes the notifications from the database.

Before you delete a notification, make sure that it is no longer needed.

Once you set a deletion flag for a notification, you can no longer change the data in the notification. It then receives the status Deletion flag and Completed. You can now only display the notification. For more information about notification statuses, see Status Management [Ext.].

If you set a deletion flag in the notification header, the system also sets deletion flags for the individual notification tasks.

You can cancel the deletion flag as long as it has not been converted to a deletion indicator. You can then put the notification back in process and change or display it in the usual manner.

Procedure

<table>
<thead>
<tr>
<th>Desired processing type</th>
<th>What you should know</th>
</tr>
</thead>
<tbody>
<tr>
<td>Put notification in process</td>
<td>Call up the notification in the create or change mode and then choose Notification → Functions → Put in process.</td>
</tr>
<tr>
<td>Postpone notification</td>
<td>Call up the notification in the change mode, choose Notification → Functions → Postpone, and then save the notification.</td>
</tr>
<tr>
<td>Complete notification</td>
<td>Call up a notification in the change mode and choose Notification → Functions → Complete. Specify the completion date/time and the cause of the problem; then close the dialog box and save the notification.</td>
</tr>
<tr>
<td>Delete notification</td>
<td>To set a deletion flag, call up the notification in change mode and then choose Notification → Functions → Deletion flag → Set.</td>
</tr>
<tr>
<td></td>
<td>To reset the deletion flag, choose Notification → Functions → Deletion flag → Deselect.</td>
</tr>
</tbody>
</table>
Processing Notifications Using Worklist

Use

Using the worklist for notifications, you can select notifications on the basis of different criteria and process them. You can select the notifications as follows:

- You select the notifications using the My worklist function. The system then displays the following notifications for further selection and processing:
  - All notifications to be processed by you as the "person responsible" or that fall within your department's area of responsibility
  - All notifications to be processed by you as a <Partner function>
  - All notifications you created
  - All notifications that were last processed by you

- You select the notifications using the General selection function. The system then displays all notifications for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, notification status, selection period).

Prerequisites

If you use the General selection function and you want to process notifications for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities

You choose Logistics → Central Functions → Notification → Worklist → Notifications to call up the worklist for notifications.

You enter the required data and choose Execute.

See also:

Select and Process Notifications Using Worklist [Ext.]
Task Processing

Purpose
Using the functions for task processing, you can change or display the tasks in a notification independently of the notification itself. In this way, you can:

• Process tasks quickly and easily
• Execute tasks using the functions of the action box
• Access the information in the associated notification at any time

Process Flow
1. You process the tasks using one of the following options, depending on your job duties or method of working:
   - **Worklist [Page 65]**
     You call up the worklist for tasks to determine whether tasks exist that you must process.
   - **Workflow [Page 66]**
     You check your workflow inbox determine whether tasks exist that you must process.
   - **Functions for Task Processing [Ext.]**
     If you want to process a specific task in a specific notification, use the transactions for processing or displaying a task.

2. After you have selected and executed one of the above options, you process a task by either:
   - Forwarding the task to another person, if you cannot process the task yourself
   - Carrying out the instructions specified in the task
   - Documenting the information for a task that has just been executed; for example, as a task long text or via a follow-up function in the action box (internal remark)
   - Setting the status of the task to "completed," once you have carried out the instructions specified in the task
   - Executing additional follow-up functions in the action box, if additional tasks need to be implemented

Result
Once you have processed and completed a task, you can complete the notification (provided there are no other tasks in the notification that need to be processed).
Processing Tasks Using Worklist

Use
Using the worklist for tasks, you can select notification tasks on the basis of different criteria and process them. You can select the tasks as follows:

- You select the tasks using the *My worklist* function. The system then displays the following tasks for further selection and processing:
  - All outstanding tasks to be processed by you as the "person responsible"
  - All tasks to be processed by you as a *<Partner function>*
  - All tasks you created
  - All tasks you completed
- You select the tasks using the *General selection* function. The system then displays all tasks for further selection and processing. Make sure the preset selection criteria contain the values you want (for example, selection period, outstanding tasks only).

Prerequisites
If you use the *General selection* function and you want to process tasks for which you are not responsible or which you did not create, you must have the corresponding authorization.

Activities
You choose *Logistics* → *Central functions* → *Notification* → *Worklist* → *Tasks* to call up the worklist for tasks.

You enter the required data and choose *Execute*.

See also:
*Select and Process Tasks Using the Worklist [Ext.]*
Processing Tasks Using Workflow

Use
If a task is created in a notification or if the person responsible for a task is changed, the system can automatically notify the person or department responsible via the SAP Business Workflow that a task needs to be processed.

You receive the information about the task that needs to be processed as a work item in your inbox (Business Workplace). Your inbox provides an overview of all tasks that you are responsible for processing. You can begin processing the work item directly from your business workplace.

Integration
You can access your business workplace by choosing Office → Workplace from the SAP menu. Then choose Inbox → Workflow to display any work items that may be present.

Prerequisites
The required system settings to activate the SAP Business Workflow have been made.

Activities
If there is a work item in your inbox, proceed as follows to begin processing the work item:

• You double click the work item to display a description of the task to be executed.
• You choose Execute to process the work item. The system calls up the transaction to process the task.
Status Query For Request

Use
You can call up the status of the request at any time during its runtime.

See also:
- Status Management For Notifications [Ext.]
- Display Status Information [Ext.]
- System Status Assignment [Ext.]
- Assigning And Changing User Statuses [Ext.]
- Status Management For Tasks [Ext.]
Enterprise Organization (CO)

Purpose

The enterprise organization [Ext.] is a uniform, integrated user interface [Ext.] for the different organizational units in the SAP system.

The structure of your enterprise is represented in the SAP system by means of different organizational units (controlling area, company code, cost center and so on). In the Human Resources (HR) organizational structure [Ext.] for example, a company is broken down into departments, each of which is responsible for performing particular tasks. By way of contrast, in the standard hierarchy [Ext.] for cost center accounting, companies are broken down with regard to responsibilities for costs.

The enterprise organization helps you process your organizational structures so that:

- These structures can be changed to reflect organizational changes within the enterprise.
- A company's organizational structure is more transparent since the links between the organizational units are visible and can be evaluated.
- The different business processes can be integrated optimally, and thus are more economical with resources.
- The data is for internal and external reporting

Implementation Considerations

You need to activate the enterprise organization to be able to use it. You do this in Customizing for the application component in question by choosing Enterprise Organization → Enter Settings for the Enterprise Organization [Ext.].

Integration

Enterprise organization is based on the organizational plan in HR, and contains additional functions and organizational units specific to accounting.

The following areas are currently integrated in enterprise organization:

- HR organizational plan
- Cost center standard hierarchy
- Profit center standard hierarchy

If the enterprise organization is active for a controlling area, you can no longer assign the organizational units (controlling area, company code, and cost center) in the HR organizational structure. Instead, use the functions in the enterprise organization.

Enterprise organization therefore provides an overview of the enterprise in terms of responsibilities for:

- Personnel
- Costs
Features

Representing the structure of an enterprise

- The structure of an enterprise is displayed in a simple tree structure.
- You can change the enterprise organization per specific date.

  This facility enables you to create past, present, and future organizational structures for your enterprise (see also Time-Dependency of Enterprise Organizations [Page 71]).
- The single maintenance screen for several organizational units or structures enables you to display and evaluate the links between the organizational units.
- Using the search function, you select the organizational units and then assign these to the organizational structure using drag-and-drop (see Searching for Organizational Units [Page 88]).

Processing organizational structures

- In the enterprise organization, you can create new organizational units (see Creating Organizational Units [Page 90]).

  In so doing, the system transfers the data in accordance with the inheritance principle (see the Inheritance Principle [Page 78]).
- Using drag-and-drop, you can copy organizational units from the selection area into the tree structure (see Assigning, Reassigning, or Moving Organizational Units [Page 94]).
- Using drag-and-drop, you can copy organizational units from the selection area into the tree structure (see Assigning, Reassigning, or Moving Organizational Units [Page 94]).
- You can maintain the master data for the individual objects directly from the tree structure (see Displaying or Changing Organizational Units [Page 93]).
- You can activate or delete inactive master record versions from cost centers and profit centers (see: Activating Inactive Master Data [Page 98] or Deleting Inactive Master Data [Page 100]).
- Enterprise organization is a logical development of the HR organizational plan.

  An enterprise structure is more detailed in HR than in CO. Therefore all CO objects (such as controlling area, cost center) are assigned to the HR-Organizational Unit [Ext].

  Note, however, that you can only assign one object type to a single HR organizational unit each time you are processing.
- When processing the enterprise organization, the system carries out a number of checks on consistency.

  For example, you can enter a cost center in the enterprise organization only if you have already assigned a controlling area to this enterprise organization.
Enterprise Organization (CO)

You can make checks on a particular key date. To do so, choose Enterprise organization → Check. You can make the following checks online or in a background job.

- Check that the enterprise organization is complete (see Time-Dependency of Enterprise Organizations [Page 71]).
- Consistency checks

- From the enterprise organization you go to the web form to request a cost center change by choosing Extras -> Change request for cost centers (see Requesting a Change to Master Data in the Intranet/Internet [Page 53]).

  Data from the detail area is also transferred to the form.

Constraints

From the enterprise organization you can only currently display master data for controlling areas and company codes.

Making mass changes to master data simultaneously as under Change Management [Ext.] is currently not possible.

For more information, see the SAP Library under Human Resources → PA - Personnel Management → Organizational Management [Ext].
Time-Dependency of Enterprise Organizations

Use
You can change the enterprise organization [Ext.] per specific date. This enables you to display past, present, and future organizational structures of an enterprise.

Note however that this time-based facility is not used in all SAP application components that are connected to the enterprise organization. In accounting for example, organizational units such as the company code [Ext.] or controlling area [Ext.] are not time-dependent. In the case of cost centers [Ext.], the period is the only time factor of relevance. For each application, you can enter the time at which the changes to the organizational structure in question are to take effect.

Features

Validity of Organizational Units and Assignments

• A key date and preview period [Page 75] is set for processing the enterprise organization.
  When you call this up for the first time, the following are standard settings:
  − Today's date is set as the key date which you can change as required.
  − A preview period of one year is set, which you can change as required.
    The next time that you call this function up, the entries you selected for the key date and the preview period are set.

• If you create a new organizational unit in the overview area then:
  − The validity of the organizational unit starts with the set key date.
    You can bring this forward in the detail area.
  − The assignment in the organizational unit starts with the set key date.
    You can end [Page 78] the assignment if it should only have a limited validity.

• If you are looking for organizational units in the search area, the system selects all those that are possible, for which the set key date and preview period apply, and displays them in the selection area.

• In the structure tree in the overview area objects are indicated with ◦ if their validity or assignment does not begin until the preview period. Objects are indicated with ◻ if their validity or assignment ends in the preview period.

Assignments usually become valid on the selected key date. Alternatively you can use a dialog box to enter any validity dates required when you assign organizational units (see Activating/Deactivating Timeframe Query [Page 77]).

Transferring Changes in The Enterprise Organization in Organizational Structures

• The changes you make to the enterprise organization are immediately transferred to the organizational plan in Human Resources (HR).
Time-Dependency of Enterprise Organizations

- For the cost centers or profit center standard hierarchy, you can specify when and how changes in the enterprise organization are to be transferred to the appropriate standard hierarchy. You can also generate additional alternative hierarchies (for planning purposes for example).

  For more information, see Customizing for the corresponding application and choose Enterprise Organization → Generate Standard Hierarchy or Alternative Hierarchy [Ext.].

- In Customizing for Cost Center Accounting or Profit Center Accounting, you can specify a range of fiscal years within which the system ensures that the standard hierarchy is complete. Complete means here that all cost centers or profit centers that are valid for all or part of this period (according to the start or end date) are contained in the standard hierarchy.

  For more information, see Customizing for the corresponding application by choosing Enterprise Organization → Enter Settings for Enterprise Organization [Ext.].

  You can also generate the standard or alternative hierarchy from the application, by choosing Enterprise organization → Generate.
You make changes to your enterprise organization on 12/20/1998.

In the **first instance** you generated your standard hierarchy on 09/14/1998. It follows that the standard hierarchy contains the previous status of the enterprise organization. To enable these changes to be incorporated in planning, you can generate an alternative hierarchy that contains the latest version of the enterprise organization as of 12/20/1998. At the start of the new fiscal year, you can then replace the standard hierarchy with the more up-to-date alternative hierarchy.

In the **second instance** you generated your standard hierarchy on 01/01/1999. It follows that the standard hierarchy contains the new status of the enterprise organization. If you need to be able to access the previous version of the standard hierarchy, you can generate an alternative hierarchy containing the old status of the enterprise organization prior to 12/20/1998.

**See also:**
Time-Dependency of Enterprise Organizations

Linking Enterprise Organizations and Standard Hierarchies [Page 79]
Selecting a Date and Preview Period

Use
To display and edit data according to key dates and time periods, select a key date and preview period.

Procedure
1. Choose Settings → Date and Preview period (or ).
   The Define Date and Preview Period dialog box appears.
2. Enter the key date in the Start Date field.
3. In the Preview period field, enter the preview period.
   When you confirm your entries with Return, the preview period you selected is displayed.
   Correct your entries as required.
4. Confirm your entries by choosing .

Result
You have set a date and a preview period. You can change these settings at any time.
Terminating/Deleting HR Organizational Units Or Assignments

Use

- You can terminate the validity of an HR organizational unit, so reduce the timeframe, or you can delete it altogether, including its entire history.
- You can terminate the following assignments:
  - HR organizational unit <-> HR organizational unit
  - HR organizational unit <-> Cost center
  - HR organizational unit <-> Profit center
- You can delete the following assignments:
  - HR organizational unit <-> HR organizational unit
  - HR organizational unit <-> Cost center
  - HR organizational unit <-> Profit center
  - HR organizational unit <-> Company code

Procedure

**Terminate HR Organizational Unit Or Assignment**

1. In the **Overview area**, select the organizational unit or its assignment that you want to terminate.
2. Choose **Terminate** and choose the organizational unit or the corresponding assignment.
3. Enter the new **End date** for the organizational unit or the assignment.
4. Choose **Save**.

**Delete HR Organizational Unit Or Assignment**

1. In the **Overview area**, select the organizational unit or its assignment that you want to delete.
2. Choose **Delete** and choose the organizational unit or the corresponding assignment.
3. Choose **Save**.
Activating/Deactivating Query Time Period

Use
The validity of assignments normally begins on the key date you have specified. Alternatively, you can activate a dialog box, in which you can enter any validity date when assigning objects (this does not apply when you are assigning persons (employees) or users to positions).

Procedure
1. Choose Settings → Query time for organizational changes
   The Query time for organizational changes dialog box appears.
2. Select the Query time for organizational changes field, if you want to enter a validity date when you are assigning objects. Otherwise, you can deselect this field.
3. Confirm your entries by choosing ✓.

Result
If you have activated the time period query, a dialog box will appear when you move or assign objects, you can enter the validity of the assignment in this dialog box.

If you have deactivated the time period query, the validity of the assignment is determined according to the key date.
The Inheritance Principle

The organizational units in the enterprise organization [Ext.] are subject to the principle of inheritance.

Company code [Ext.] B is assigned to the higher level node. It follows that you must have assigned all those objects that lie below this node (in this case cost centers [Ext.] 4210 and 4220) to company code B.

If cost center 4220 is new, the master data for this cost center is displayed for processing in the detail area. In so doing, the system fixes the assignment to company code B (and therefore also to controlling area [Ext.] 0001). It is not possible for you to change this assignment.

The system checks if cost centers have been assigned to a profit center. The corresponding profit center is transferred to the master data.

For profit centers, the system transfers the assigned company code to the master data.
Enterprise Organizations and Standard Hierarchies

Use
For the cost centers or profit centers standard hierarchy, you can specify on what date changes in the enterprise organization [Ext.] the system is to transfer to the appropriate standard hierarchy [Ext.]. You can also generate additional alternative hierarchies (for planning purposes for example).

Before you generate a hierarchy, first run the consistency checks on the enterprise organization. To do so, choose Enterprise organization → Check.

Features
Generating a standard hierarchy from the enterprise organization
You can generate your standard hierarchy for a controlling area at any given key date.

The system determines the current fiscal year from this key date. In Customizing you define the number of fiscal years (starting from the current fiscal year) to be taken into consideration in the past and in the future (for more information on this, see Customizing for the application component in question under Enterprise Organization → Enter Settings For Enterprise Organization [Ext.]).

The entries you make here are used by the system to determine a validity period that in turn controls which objects the standard hierarchy contains.

The system then determines all the organizational units and links from the enterprise organization that apply to the standard hierarchy and which lie within this validity period.

If the master records for the objects are different from the corresponding data in the enterprise organization, the system changes them to match the enterprise organization. This adaptation is a standard setting for when you generate the standard hierarchy from the enterprise organization (see The Inheritance Principle [Page 78]).

Generating an alternative hierarchy from the enterprise organization
In addition to the standard hierarchy, you can also generate alternative hierarchies to represent past or future organizational structures.

You can then for example make changes now for the coming fiscal year, but not incorporate these changes in the standard hierarchy until the start of the new fiscal year. Likewise, for reporting purposes you can compare the current organizational structure with that of the previous year.

Generating a standard hierarchy from an alternative hierarchy
During a fiscal year, you made changes to the enterprise organization that have not yet been incorporated into the standard hierarchy. However, for planning purposes, you generated an alternative hierarchy, which corresponds to the current status of the enterprise organization.
Enterprise Organizations and Standard Hierarchies

For the new fiscal year, you now want to incorporate these changes into the standard hierarchy. You can do so by generating the new standard hierarchy from the current alternative hierarchy.

Generating an enterprise organization from a standard hierarchy

To generate the enterprise organization for the first time, you can generate it for a controlling area from an existing standard hierarchy.

Using the functions in the enterprise organization, you can then edit this standard hierarchy.

Activities

- To generate a standard or alternative hierarchy from the enterprise organization, in Customizing for Cost Center Accounting or Profit Center Accounting choose Enterprise Organization → Generate Standard or Alternative Hierarchy From The Enterprise Organization [Ext.].

- To generate the enterprise organization from an existing standard hierarchy, in Customizing for Cost Center Accounting or Profit Center Accounting choose Enterprise Organization → Generate the Enterprise Organization from the Standard Hierarchy [Ext.].

- To generate the standard hierarchy from an alternative hierarchy, go to Customizing for Cost Center Accounting or Profit Center Accounting and choose Enterprise Organization → Generate Standard or Alternative Hierarchy From The Enterprise Organization [Ext.].

You can also generate the standard or alternative hierarchy from the application, by choosing Enterprise organization → Generate.
Generating an Alternative Profit Center Structure

Use

It is necessary to generate an alternative profit center structure view if the organizational structure of your Profit Center Accounting is not identical to that of the organizational structure. If you generate this alternative profit center structure view, profit center and profit center groups can appear more than once in the organizational structure.

A controlling area contains a number of company codes. Each company code contains a "sales" cost center.

You have structured your Profit Center Accounting according to functions and want to assign all "sales" cost centers to the cross-company code "sales" profit center.

This means that the "sales" profit center must be inserted at various points in the organizational structure.

In the standard hierarchy, each profit center can be assigned to one node only. If a profit center is not explicitly assigned to just one other organizational unit of the same type in the organizational structure, an additional step is required in order to generate the standard hierarchy from the enterprise organization.

This additional step is the generation of an alternative profit center structure. In each structure view, you can assign all profit centers and profit center groups explicitly and generate the standard hierarchy from them.

Activities

- If you want to organize your Profit Center Accounting in such a way that profit centers / profit center groups appear more than once in the organizational structure, define this in Customizing for Profit Center Accounting, under Enterprise Organization → Enter Settings for Enterprise Organization [Ext.].

To generate the alternative profit center structure view, choose 🗓.

⚠️ Once you have generated the alternative profit center structure view, you cannot reverse it. Once you have activated the alternative profit center structure view, the system always calls it up when generating the profit center standard hierarchy.

The system automatically carries over changes in the enterprise organization to the alternative profit center structure view. If these changes affect the standard hierarchy, it must be regenerated.

- You display and maintain the alternative profit center structure view from the enterprise organization, by choosing Goto → Change View...

When you generate the alternative profit center structure view from the enterprise organization, the only profit centers to be hierarchically structured are those which belong explicitly to just one other organizational unit of the same type in the assignment monitor. Profit centers and profit center groups which do not meet this criterion are
Generating an Alternative Profit Center Structure

offered in a list in the detail area (*Multiply assigned objects*). Enter these in the alternative profit center structure view using drag-and-drop. Once all profit centers are explicitly assigned, choose to generate the profit center standard hierarchy,
The Enterprise Organization: Processing Options

Use

The functions provided under enterprise organization [Ext.] enable you to display and maintain different objects (cost centers, profit centers) and different organizational structure belonging to an enterprise (cost center standard hierarchy [Ext.], HR organizational plan [Ext.]).

Features

Using the functions under enterprise organization, you can

- Generate an organizational structure by creating organizational units and assigning them to one another (see Creating Organizational Units [Page 90]).
- Display the organizational structure or individual organizational units (see Displaying or Changing Organizational Units [Page 93]).
- Change the organizational structure by assigning organizational units to it for the first time, or by moving or deleting these units (see Displaying or Changing Organizational Units [Page 93], Assigning or Moving Organizational Units [Page 94]).
The Screen Areas

Use

You use the enterprise organization [Ext.] maintenance screen to create, display or change organizational structures.

The maintenance screen is divided into different areas, each of which covers particular functions:

- **Search Area**
- **Overview Area**
- **Selection Area**
- **Detail Area**

The combination of **search area** and **selection area** is called the **Object Manager**.

To display individual areas more clearly, you can hide other areas of the screen.

- To make the remaining areas of the screen larger, you can display/hide the **Object Manager**.
- If you display large lists in the **selection area**, you can hide the **search area**. To do so, choose **Result list large/small**.
- If you are processing large structures in the **overview area**, you can hide the **detail area**. To do so, click the pushbutton above the **detail area**.

Each time you start the functions belonging to enterprise organization, the system automatically calls up the data that you last processed and uses the size settings from your last session for the screen areas.
Features

Search area

In the search area you select one or more organizational units that you want to display or change, for example:

- HR organizational units [Ext.]
- Cost centers [Ext.]
- Inactive cost centers
- Cost center groups [Ext.]
- Profit centers [Ext.]
- Inactive profit centers
- Profit center groups
- Company codes [Ext.]
- Controlling areas [Ext.]

See also:
Searching for Organizational Units [Page 88]

Selection area

In the selection area, the organizational units you selected are displayed in a list.

- You can add extra columns by choosing Column configuration. These additional columns can be for any of the data available as master data.
- You can restrict the list using certain criteria by setting the filter. You can, for example, select all objects of an owner.
- You can display or change an organizational unit in its assignment to the organizational structure, and the corresponding detailed information, by using the following options:
  - Choose the organizational units by double-clicking on them.
    The system transfers the organizational unit to the central overview area and displays the master data in the detail area.
  - Use drag-and-drop to move the organizational unit to the overview area.
- You can activate and delete inactive master data versions of cost centers or profit centers. You have the following options:
  - Select the objects in the selection list.
    You can also select the objects in the structure tree of the overview area by selecting all of the corresponding rows.
  - Choose Activate.
    A dialog box appears that contains a list of all inactive objects. The objects that you selected in the selection list or structure tree are already marked in this list.
The Screen Areas

If you have not yet selected any objects, you can select in this dialog box all the inactive objects that you want to activate.

− Choose Activate in the dialog box.

• You can call up the assignment overview for a cost center or profit center. Do this by selecting the right mouse button on the corresponding object.

In the overview area the system displays the time frame in which each object is and to which HR organizational unit it is/was assigned to.

Overview area
The overview area displays the selected organizational unit (with all the objects assigned to it) as a tree structure, in the time frame set [Page 75]. The processing functions are provided in a clear manner in a function box.

You can also access the most important functions using the right mouse button.

You can:
• Display/hide additional columns using the Column configuration
• Print the structure
• Set the time interval in which the structure (including the CO objects it contains) is to be processed.
• Create new objects and assign them to existing objects.
• Move the objects within the tree structure using drag-and-drop.
• Select a new object.
• Copy an HR organizational unit more than once
• Reduce the length of time that a link between an object and the HR organizational unit exists.
• Delete a link between an object and the HR organizational unit.
• Go up a level in the overall hierarchy by using One level up.

You do not have to select the corresponding higher-level node to do so. The system automatically supplements it in the tree structure.

See also:
Creating Organizational Units [Page 80]
Assigning, Reassigning, or Moving Organizational Units [Page 94]
Terminating or Deleting HR Organizational Units or Assignments [Page 76]
Selecting Key Date and Preview Period [Page 75]

Detail area
In the detail area, you can display or process the master data for each object.
The Screen Areas

To display or process the master data for a particular object, choose the object by double-clicking on it in the tree structure.

In the **detail area**, you can do the following for the selected object:

- Change the validity period
- Change the processing period, which corresponds to the preview period

See also:
The **Displaying or Changing Organizational Units** [Page 93]
Searching for Organizational Units

Use
In the search area you select one or more organizational units that you want to include in your organizational structure.

You can search for the following organizational units:

- HR organizational units [Ext.]
- Cost centers [Ext.]
- Inactive cost centers
- Cost center groups [Ext.]
- Profit centers [Ext.]
- Inactive profit centers
- Profit center groups
- Company codes [Ext.]
- Controlling areas [Ext.]

Prerequisites

- The HR organizational units that you are looking for must exist in the current plan version.
  
  See Customizing for the relevant application component, under Enterprise Organization → Setting Active Plan Variant [Ext.].

- You have activated the enterprise organization for your application component.
  
  See Customizing for the relevant application component, under Enterprise Organization → Enter Settings for Enterprise Organization [Ext.].

Procedure

Searching for Objects
1. Select the required organizational units.
   
   The Search for <Organizational Unit> dialog box appears.

2. Enter a numeric key or a name.
   
   To restrict the search further, choose an additional field.
   
   You can also search by entering a *.

3. To transfer the hit list into the selection area, choose Search.

4. To supplement the list, choose the required organizational unit again, and then choose Add.
   
   The organizational units that are found, are added to the list in the selection area.
Searching for Organizational Units

You can display more information in the hit list. You can do this to show the following columns for example:

- Assignment to enterprise organization
  The system displays whether the object in question is already assigned to the enterprise organization.
- Link period
  The system displays the period for which the object is assigned to the enterprise organization.
- Activation status
  The system displays whether the object is active (green) or inactive (red).
  If there is an active and an inactive version of the object, the system always displays the inactive version here. You can switch between versions in the detailed information for the object.

To display the additional columns, choose Column configuration and select the appropriate column. Choose Continue.

Creating/Displaying/Deleting Search Variants

1. Select the required organizational units.
   The Search for <Organizational Unit> dialog box appears.
2. Enter the desired selection criteria for the search.
3. Choose Create search variant and enter a suitable name.
4. Choose Enter.
   The system saves the selection criteria you enter as a search variant and assigns these to the appropriate organizational unit in the search area.
5. To check your entries, select the search variant and choose Display search variant.
6. To delete a search variant, select the variant and choose Delete search variant.

You can display the result of a search for a search variant directly in the selection area. To do so, choose the appropriate search variant by double-clicking on it.

You can scroll down/up the results of the search. Choose Previous search result, or Next search result.
Creating Organizational Units

Use
You create organizational units to create or change the organizational structure of your enterprise.

Prerequisites
You need to activate enterprise organization [Ext.] for your application component.

For more information, see Customizing for the relevant application component by choosing Enterprise Organization → Enter Settings for Enterprise Organization [Ext.].

Check the key date and the preview period [Page 75] and change the information if required. This time interval specifies the processing time frame for the enterprise organization, and is also set as the processing period for the contained CO objects.

Procedure

Creating a Root Organizational Unit
1. If you did not generate the enterprise organization from the standard hierarchy, you need to recreate the enterprise organization.
   
   You do this in Customizing for the relevant application component by choosing Enterprise Organization → Create Enterprise Organization [Ext.]
   
   The standard system contains a new HR organizational unit [Ext.] with the provisional title New Organizational Unit, which you can use as a root organizational unit.

2. In the detail area, overwrite the provisional entries.

3. Save your entries.

Creating Additional HR Organizational Units
1. To create further HR organizational units within an organizational structure, in the overview area select the organizational unit under which the new object is to be assigned.

2. Choose Create → Organizational unit

   You can also copy organizational units [Ext.] that already exist. All of the characteristics of this organizational unit are copied also. You can adjust the data in the detail area.

3. To maintain the data for an HR organizational unit, double-click on the unit in the organizational structure.

Creating Cost Centers/Profit Centers
1. You can create more cost centers/profit centers:
   
   a. In Customizing for the relevant application component by choosing Enterprise Organization → Create Enterprise Organization [Ext.]
Creating Organizational Units

b. In the relevant application component by choosing Master data → Enterprise organization → Change.

2. To create cost centers/profit centers within an organizational structure, go to the overview area and select the HR organizational unit to which the cost center/profit center is to be assigned.

3. Choose Create → Cost center/Profit center.

   The system displays the relevant master data in the detail area. Thus the system transfers the data using the inheritance principle (see the Inheritance Principle [Page 78]).

   If a CO object is already assigned to an HR organizational unit, you cannot assign any additional CO objects.

4. Maintain the master data for the cost center or profit center.

5. Choose Enter.

   The system saves the master data as inactive [Page 137].

   The system displays the assignment of the cost center/profit center to the HR organizational unit of the structure in the overview area.

You can currently maintain only cost center and profit center master data in the enterprise organization. You can display the master data for controlling area and company code only from the organizational structure.

For more information about cost center master data, see Cost Center Master Data [Page 133].

For more information about profit center master data, see Profit Centers [Ext.].

Creating Cost Center Groups/Profit Center Groups

To generate a standard or alternative hierarchy from the enterprise organization, you must create the cost center groups or profit center groups first.

For more information, see Customizing for the relevant application under Enterprise Organization → Generate Standard Hierarchy or Alternative Hierarchy [Ext.].

1. You can create groups:

   a. In Customizing for the relevant application component by choosing Enterprise Organization → Create Enterprise Organization [Ext.]

   b. In the relevant application component by choosing Master data → Enterprise organization → Change.

2. To create groups within an organizational structure, in the overview area, select the HR organizational unit to which the group is to be assigned.

   The detail area contains the data on the HR organizational unit for processing.

3. In the detail area on the tab strip CO assignment, choose either Cost center group → Create, or Profit center group → Create.
Creating Organizational Units

4. Enter the name of the group and a description.

   The system transfers the group to HR organizational unit assignment to the structure in the overview area.

   If you have **not** yet generated a **group** in the standard hierarchy from the enterprise organization, you can subsequently change the group name and the description.

   If a group or an object is already assigned to an HR organizational unit, you **cannot** assign an additional group.
Displaying or Changing Organizational Units

Use

You can display or change the master data on the individual organizational units.

⚠️

You can currently change only **cost center and profit center master data** in the enterprise organization. You can display the master data for controlling area and company code **only** from the organizational structure.

Procedure

1. In the **selection area** or the **overview area** choose an organizational unit by double-clicking on it.

   The **detail area** contains the master data on this object which you can display or edit.

   a. To select an organizational unit from the **selection area** you must already have searched for one or more organizational units (see **Searching for Organizational Units [Page 88]**).

   b. To select an organizational unit in the **overview area**, you must already have transferred objects to this area or have created them there (see **Creating Organizational Units [Page 90]**, **Assigning or Moving Objects [Page 94]**).

2. To display or change the master data, select the required tab strip in the **detail area**.

3. Enter data as required.

   In the **detail area**, you can do the following for the selected object:

   - Change the validity period
   - Change the processing period, which corresponds to the **preview period [Page 75]**

4. **Save** your entries.

   The system saves the master data as **inactive [Page 137]**.
Assigning, Reassigning, or Moving Organizational Units

Use
To reflect changes to your organizational structure you can:

- **Assign** organizational units to the organizational structure.
- **Reassign** organizational units, by transferring them to a new position in the organizational structure.
  
  This enables a time differentiation from the old assignment.
- **Move** organizational units, meaning they are moved to a new position on the same branch of the hierarchy.

Assignments normally become valid on the selected key date. Alternatively you can use a dialog box to enter any validity dates required when you assign organizational units (see Activating/Deactivating Timeframe Query [Page 77]).

Prerequisites
You have created an organizational structure; other organizational units may exist that have not yet been assigned to this structure.

From the structure, choose an organizational unit that you want to process. The organizational structure is displayed in the overview area. For more information, see Searching for Organizational Units [Page 88], and Creating Organizational Units [Page 90].

Procedure

Assigning organizational units
1. Search for an organizational unit (see Searching for Organizational Units [Page 88]).

   The organizational unit is displayed in the selection area.
2. In the selection area, select the organizational unit.
3. In the overview area, assign the organizational unit to the superordinate organizational unit using drag-and-drop.

   When you assign a cost center or profit center to an HR organizational unit using drag-and-drop the system makes the following comparisons:
   - The profit center entered in the cost center master data with the one derived from the enterprise organization, and if required, changes the entry in the cost center master data.
   - The controlling area entered in the profit center master data with the one derived from the enterprise organization, and if required, changes the entry in the profit center master data.
If the organizational unit was already assigned to the structure, the system differentiates the old assignment chronologically. This means that the organizational unit is assigned to the new item from the set key date.

4. Choose Save.

Reassigning or moving organizational units

1. In the **overview area**, select the organizational unit from the structure that you want to reassign or move.

2. To move the organizational unit within a hierarchy branch, choose *Move up* or *Move down*.

3. To reassign the organizational unit within the organizational structure, use *drag-and-drop* to assign it to the desired superordinate organizational unit.

   This enables a time differentiation from the old assignment.

   To navigate between activities, choose *Scroll forward* or *Scroll back*. 
Active and Inactive Master Data

Use
A master record can be in an active and/or an inactive version. There are active/inactive master record versions for cost centers [Ext.], business processes [Ext.] and profit centers [Ext.].

Prerequisites
You are in the maintenance screen for the Enterprise Organization [Page 68].

Features
Active Master Data
The system works only with the active version of the master record. Therefore, only active master data is used for postings for example.

Inactive Master Data
If you change one or more of the values in a master record, the system initially saves these changes in a new inactive version without making the required consistency checks. This version is not used productively, for example, for postings.

When you create a new master record, the system initially creates an inactive version of the master record. To be able to use the master data productively, you need to activate the master record.

When you activate the master data, the system checks the data and if no inconsistencies, transfers it to the active version of the master record. The inactive version is deleted.

If there is an older active version of the corresponding master record, the system overwrites it.

Inactive master data is not transported, nor is it distributed via ALE. You cannot maintain inactive master data with either single processing [Page 142] or collective processing [Page 144].

Activities
You can activate or delete the corresponding inactive master data:

- In the Enterprise Organization [Page 68]
- In standard hierarchy processing for cost centers [Page 103]
- In the standard hierarchy for profit centers [Ext.]
- In standard hierarchy processing for business processes [Ext.]
- In Customizing for the relevant application, choose Master Data → <Object> → Delete/activate inactive <objects>.
See also

Activating Inactive Master Data [Page 98]
Deleting Inactive Master Data [Page 100]
Activating Inactive Master Data

Prerequisites
You are on the maintenance screen for the enterprise organization, and have already selected cost centers, business processes, or profit centers.

In the search area you can look for inactive cost centers, business processes, or profit centers.

Procedure
1. Select the inactive object that you want to activate,
   a. In the list in the selection area, or
   b. In the structure tree in the overview area.

   ![Tip]

   You can select more than one object in the selection area and/or the overview area.

2. Choose Activate.

   A dialog box appears that contains a list of all inactive objects. The objects that you selected in the selection list or structure tree are already marked in this list.

   ![Tip]

   If you have not yet selected any objects, you can mark in this dialog box all the inactive objects that you want to activate.

3. In the dialog box choose Activate.

   The system saves the objects as active [Page 137].

   ![Tip]

   You can activate inactive master data in Customizing also. In Customizing for the relevant application component, choose Master Data → <Object> → Activate inactive <object>.

Result
The system changes the activation status in the selection area and in the overview area from inactive (red) to active (green).

In the detail area you see whether a master data was created, changed or deleted by looking at the status text.
If there is an active and an inactive master record version, you can switch between versions in the **detail area**. You can also trigger the checks for the inactive master record version.

💡

You trigger activation and checking only after you have made all your changes. You can also select more than one object in the **selection area** and/or the **overview area** for this.
Deleting Inactive Master Data

Prerequisites
You are on the maintenance screen for the enterprise organization, and have already selected cost centers, business processes, or profit centers.

In the search area you can look for inactive cost centers, business processes, or profit centers.

Procedure
1. Select the inactive object that you want to delete,
   a. In the list in the selection area, or
   b. In the tree structure in the overview area.

   You can select more than one object in the selection area and/or the overview area.

2. Choose Delete inactive version.
   A dialog box appears that contains a list of all inactive objects. The objects that you selected in the selection list or structure tree are already marked in this list.

   If you have not yet selected any objects, you can mark in this dialog box all the inactive objects that you want to delete.

3. In the dialog box, choose Delete inactive version.
   The system deletes the marked inactive objects.

You can delete inactive master data in Customizing also. In Customizing for the relevant application component, choose Master Data → <Object> → Delete inactive <objects>.
Standard Hierarchy

Definition
Tree structure representing all cost centers belonging to a controlling area from a Controlling perspective.

Structure
You can combine cost centers into cost center groups. You can then create cost center hierarchies from these groups by combining the groups according to decision-making area, area of responsibility, or management area.

A cost center hierarchy comprises all cost centers for a given period and therefore represents the whole enterprise. This hierarchy is known as the standard hierarchy.

Integration
You can make changes to the standard hierarchy:

- In the maintenance interface of the Enterprise Organization [Ext.] (see Editing the Standard Hierarchy [Page 103])
- In group maintenance (see Editing the Standard Hierarchy Using Group Maintenance [Page 106])

⚠️ If you have activated the enterprise organization (see Enter Settings for the Enterprise Organization [Ext.]) you cannot edit the standard hierarchy directly; it is shown in display mode only. You should therefore change the enterprise organization and then generate the current standard hierarchy from here (see Enterprise Organization [Page 68], Generating a Standard or Alternative Hierarchy from the Enterprise Organization [Ext.]).

The only exception here is master data for cost center groups that are needed for reporting. If you process the standard hierarchy using the maintenance interface for the enterprise organization, you can change the data shown in the detail area on the Report information tab strip.

⚠️ If you process the standard hierarchy from the enterprise organization, you can also generate alternative hierarchies in addition to the standard hierarchy. You may need these alternative hierarchies for reporting processes for example (see Time-Dependency of Enterprise Organizations [Page 71]).

The alternative hierarchies display the status of the standard hierarchy at a given moment.
Standard Hierarchy
Editing the Standard Hierarchy

Use
You use the enterprise organization [Ext.] maintenance screen to display or edit your standard hierarchy.

The maintenance screen is divided into different areas, each of which covers particular functions:

- **Search area**
- **Overview area**
- **Selection area**
- **Detail area**

The combination of search area and selection area is called the Object Manager.

To display individual areas more clearly, you can hide other areas of the screen.

- To make the remaining areas of the screen larger, you can display/hide the Object Manager.
- If you display large lists in the selection area, you can hide the search area. To do so, choose Result list large/small.
- If you are processing large structures in the overview area, you can hide the detail area. To do so, click the pushbutton above the detail area.

Each time you start the functions belonging to enterprise organization, the system automatically calls up the data that you last processed and uses the size settings from your last session for the screen areas.
Editing the Standard Hierarchy

Features

Search area
In the search area, you select one or more organizational units that you want to display or edit, or that you want to assign to the standard hierarchy, for example:

- For the cost center standard hierarchy
  - Cost centers
  - Inactive cost centers
  - Cost center groups
- Profit center standard hierarchy
  - Profit center
  - Inactive profit center
  - Profit center groups
- Business process standard hierarchy
  - Business processes
  - Inactive business processes
  - Business process groups

See also:
Searching for Organizational Units [Page 88]

Selection area
In the selection area, the organizational units you selected are displayed in a list.

- You can restrict the list using certain criteria by setting the filter. You can, for example, select all objects of an owner.
- You can display and edit organizational units in your standard hierarchy assignment and the related master data. To do so, the following options are available:
  - Choose the organizational units by double-clicking on them. The system transfers the organizational unit to the central overview area.
  - Use drag-and-drop to move the organizational unit to the overview area.
- You can activate and delete inactive master data versions of cost centers, business processes, and profit centers. To do so, you have to select the objects in the selection list.

  You can also select the objects in the structure tree of the overview area.

See also:
Active and Inactive Master Data [Page 137]
Overview area
The overview area displays the selected organizational unit in a tree structure in terms of its assignment to the standard hierarchy.

You can:
- Display/hide additional columns using the Column configuration
- Print the structure
- Set the time interval in which the standard hierarchy, including the CO objects contained in it, is to be processed.
- Create new objects and assign them to existing objects.
- Move the objects within the tree structure using drag-and-drop.
- Select a different object for display or editing

See also:
Creating Organizational Units [Page 90]
Assigning, Reassigning, or Moving Organizational Units [Page 94]

Detail area
In the detail area, you can display or edit the master data of the individual objects.

To display or edit the master data for a particular object, choose the object in question by double-clicking on it in the tree structure.

See also:
Displaying or Changing Organizational Units [Page 93]

In the case of faulty or missing cost center master data, you can request a master data change by choosing Extras -> Change request for cost centers (see Requesting a Change to Master Data in the Intranet/Internet [Page 53]).
Processing the Standard Hierarchy Using Group Maintenance

Use
To create cost centers, you need to define a hierarchical cost center structure (cost center group). In Cost Center Accounting, this structure is known as the standard hierarchy [Ext.].

Integration
When you create a controlling area [Ext.], you specify the name for the highest node of the standard hierarchy for this controlling area.

You must assign each cost center you create to a group in the standard hierarchy. This ensures that the standard hierarchy contains all the cost centers in the controlling group. When analyzing the standard hierarchy, the R/3 System then automatically includes all cost centers.

In addition, you can assign each cost center to any number of alternative groups. Note however that you cannot create any alternative groups when maintaining the standard hierarchy.

Prerequisites
In controlling area maintenance, you assigned the highest node of the standard hierarchy to the controlling area.

Note that this cost center group cannot contain any individual values (cost centers).
You can subdivide the individual groups again, depending on the level of detail required or the cost center structure. A group can include more groups and more cost centers.

If you require representative cost centers for summarizations or reporting, allow for these when you define the standard hierarchy (see: Representative Cost Centers [Page 128]).

**Changing and Displaying Standard Hierarchies**

To change or display the standard hierarchy of the current controlling area, choose *Master data* → *Cost center group* → *Change or Display*.

You can also change the standard hierarchy when entering under the Customizing settings for Cost Center Accounting.

You create and edit the standard hierarchy in the same way as for all other master data groups (see: Creating or Changing Master Data Groups [Page 40] and Processing Master Data Groups [Page 38]).

**Creating, Changing and Displaying Master Data from the Standard Hierarchy**

When you create or change the standard hierarchy, you can also create or change master data at the same time. Note that when you display the standard hierarchy, you can display (but not change) the cost center master data.
Creating a cost center for an end node

1. To create a new cost center and assign it to an end node, position your cursor on the node and choose Insert cost center.

2. On the dialog box, enter the name of the cost center and a validity period.
   - If you are creating a cost center for the first time and you have not stored a default value for a validity period, you must enter a date from which the cost center is valid. When you create additional cost centers, the system offers this date as a default value.
   - If the cost center already exists for one or more validity periods, the new validity period must not overlap with the existing one. If it does, the system issues an error message. You can determine existing validity periods in group maintenance by double-clicking on an existing cost center.

3. You can use an existing cost center as a reference.

4. Choose Enter and create the master data for the cost center.

5. To return to group maintenance, choose Back or End.
   - If you choose Cancel, the system does not save the master data you have entered.

   The cost centers are only created or changed temporarily and are only saved by the system when you save the standard hierarchy (together with the new or changed groups). To avoid losing data, you should save frequently, especially when you are creating a standard hierarchy with master data.

Changing or displaying existing cost center master data

- When you create or change the standard hierarchy, you can double-click on an existing cost center to maintain its master data.
- When you display the standard hierarchy, you can double-click on an existing cost center to display its master data.
  - If the cost center exists for multiple validity periods, select the desired validity period from the dialog box.

  When you process alternative cost center groups, you cannot process any cost center master data.

Changing the assignment of a cost center to a node in the standard hierarchy

To move a cost center within the standard hierarchy, select the cost center and either:

- Place your cursor on the target node and choose Lower level, or
- Place your cursor on the target cost center and choose Same level.

Deleting Nodes From the Standard Hierarchy

For performance reasons, you can not delete cost centers when you are processing the standard hierarchy. If in the standard hierarchy you want to delete end nodes or subgroups (nodes) to
which cost centers are assigned, you must first delete the cost centers assigned to them (see: Deleting Cost Centers [Ext.]).

The "Warehouse" node represents the end node in the "Logistics" group. You have already assigned the cost centers “Goods in control”, “Inbound warehouse” and “Outbound warehouse” to this node. You **cannot** delete the “Warehouse” node, if it is in the standard hierarchy. First, you must assign the three cost centers to a new group. You do this by changing the hierarchy area in the master data. Only then can you delete the “Warehouse” group. However, if this is an alternative group, you can delete the node immediately.
Cost Elements

Definition
Cost elements classify an organization’s valued consumption of production factors within a controlling area [Ext.]. A cost element corresponds to a cost-relevant item in the chart of accounts [Ext.].

Structure
We distinguish between primary cost [Ext.] and revenue elements [Ext.] and secondary cost elements [Ext.].

Primary Cost/Revenue Elements
A primary cost or revenue element is a cost or revenue-relevant item in the chart of accounts, for which a corresponding general ledger (G/L) account exists in Financial Accounting (FI). You can only create the cost or revenue element if you have first defined it as a G/L account in the chart of accounts and created it as an account in Financial Accounting. The SAP System checks whether a corresponding account exists in Financial Accounting.

Examples of primary cost elements include:
- Material costs
- Personnel costs
- Energy costs

Secondary Cost Elements
Secondary cost elements can only be created and administrated in cost accounting (CO). They portray internal value flows, such as those found in internal activity allocation, overhead calculations and settlement transactions.

When you create a secondary cost element, the SAP System checks whether a corresponding account already exists in Financial Accounting. If one exists, you can not create the secondary cost element in cost accounting.

Examples of secondary cost elements include:
- Assessment [Ext.] cost elements
- Cost elements for Internal Activity Allocation [Ext.]
- Cost elements for Order Settlement [Ext.]

Integration
Cost elements in Controlling (CO) are closely related to the general ledger accounts used in Financial Accounting (FI). This is because the SAP System is structured as an Integrated Accounting System [Ext.]:

110 April 2001
Cost elements document which costs (differentiated by category) are incurred within a settlement period, and in which amount. They provide information concerning the value flow and the value consumption within the organization. Cost Element Accounting and Cost Center Accounting/Internal Orders are closely linked in the SAP System. Each posting to an account that is also a cost element, is assigned either to a cost center or order. This ensures that at period-end the data is subdivided by cost elements and cost centers/internal orders for analysis purposes. The following section describes how you can subdivide and characterize cost elements in the SAP System.

Cost element characteristics depend on the controlling area and the allocation methods used in your organization.
Specifications from Financial Accounting

Use

Some cost elements [Ext.], the primary cost [Ext.] and revenue elements [Ext.], are transferred directly from Financial Accounting. Therefore, you must consider the FI organizational structures when you create cost elements. This section includes a brief description of these specifications.

For more information, see the SAP Library → FI Financial Accounting → Accounts Payable or Accounts Receivable → FI Cross Application Topics → Organizational Structure of Financial Accounting (see: Organizational Structure of Financial Accounting [Ext.]).

Integration

The operational chart of accounts [Ext.] is used by the Financial Accounting component (FI) and the Cost and Revenue Element Accounting component (CO-OM-CEL). The items in a chart of accounts can be simultaneously expense or revenue accounts in FI and cost or revenue elements in CO-OM-CEL.

A chart of accounts can be valid for one or more company codes [Ext.], depending on the structure of your business organization.

Each company code uses only one chart of accounts. To take country-specific accounting requirements into account, you must assign the company codes from external accounting to country charts of accounts.

The controlling area [Ext.] and its company code(s) must use the same chart of accounts.

You should consider the following when assigning company codes to controlling areas:

- One company code is assigned to a controlling area. Both organizational units must use the same chart of accounts.
- Several company codes are assigned to one controlling area. All company codes must use the same chart of accounts.

The following graphic shows how you can group accounts in Financial Accounting.
You can transfer primary cost and revenue elements to cost accounting from the expense and revenue accounts in FI.

The following graphic shows the links between accounts in Financial Accounting and cost elements in Controlling using the international chart of accounts (INT).
Cost Element Categories

Definition

The cost element category [Ext.] has a technical control function. It determines whether you can post to a cost element directly or indirectly.

**Direct posting** means: You post a fixed amount to an account by specifying the account number. You can post directly to all primary cost elements [Ext.].

**Indirect posting** means: The R/3 System determines the account automatically at the time of posting. You can only post indirectly to secondary cost elements [Ext.].

Use

The following cost element categories can be used for primary cost elements:

- **01: Primary cost element**
  This category of cost element can be debited with all primary postings, for example, in Financial Accounting (FI) or Materials Management (MM).

- **03: Accrual cost element / percentage method**
  This cost element category may only be used in Cost Center Accounting (CO-OM-CCA) with the percentage method of accrual calculation [Ext.]. You can post directly in Financial Accounting to register when actual costs are incurred. The R/3 System uses this cost element category to post accrued costs in Cost Center Accounting.
  
  If you do not want to consider actual costs (for example, additional costs), you can create this category of cost elements exclusively in Controlling. You define the account in the chart of accounts, but you do not need to create the account as a G/L account in Financial Accounting.

- **04: Accrual cost element / target=actual method**
  This cost element category may be used only in the target=actual method of accrual calculation with Cost Center Accounting. You can post the cost directly from Financial Accounting to register when actual costs are incurred. The R/3 System uses this cost element category to post accrued costs in Cost Center Accounting.
  
  If you do not want to consider actual costs (for example, additional costs), you can create this category of cost elements exclusively in Controlling. You define the account in the chart of accounts, but you do not need to create the account as a G/L account in Financial Accounting.

- **11: Revenue elements**
  The cost element category is used to post revenues.
  
  Revenues are displayed in Controlling with a negative sign (-). An exception to this is Profitability Analysis (CO-PA). In CO-PA revenues are displayed with a positive sign (+).

⚠️

If you post revenues to cost centers, the values appear as statistical information only. This means that you can repost revenues for posting adjustments to other cost
Cost Center Accounting (CO-OM-CCA)

Cost Element Categories

centers, but another allocation is not possible. Revenues are ignored in iterative activity price calculation and are therefore not included in the allocation price of an activity type.

Before you define a revenue element, check whether the posting is in the form of a credit memo whose costs you want to take into account. If this is the case, use cost element category 01 (primary cost elements), not category 11 (revenue elements). These credit memos appear as negative costs and are processed in the same way as all other cost elements of category 01.

Example: Cost centers

<table>
<thead>
<tr>
<th>Cost center with revenue posting</th>
<th>Cost center with credit entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Costs</td>
<td>10,000</td>
</tr>
<tr>
<td>Revenues</td>
<td>-5,000</td>
</tr>
<tr>
<td>Cost effective</td>
<td>10,000</td>
</tr>
</tbody>
</table>

- **12: Sales deduction**
  Cost elements of this category are used to post sales deductions. Sales deductions (reductions, adjustments, corrections) are adjustment or deduction postings of revenues, such as discounts and rebates. Certain revenues, such as freight charged separately in the invoice, surcharges for small quantities or special orders, are not classified as sales deductions. Such value items are defined as revenue elements.

  The account assignment options for cost elements of this category are the same as for cost element category 11 (revenue elements). Values on cost centers are displayed statistically only (as for revenues).

- **22: External settlement**
  Cost elements of this category are used to settle [Ext.] order, project, or cost object costs to objects outside of Controlling. CO external objects can be, for example, assets (AM), materials (MM) or G/L accounts (FI). The R/3 System always creates an accounting document when you settle to external objects.

  You cannot use this cost element category for settlement to objects within Controlling (such as cost centers, orders, or projects). Use secondary cost element category 21 for internal settlement. In contrast to settlement to CO-external objects, no accounting documents are generated by the R/3 System for settlement to CO internal objects as the value flow occurs exclusively within CO.

- **90: Cost element for balance sheet accounts in Financial Accounting**
  Cost elements of this category are generated automatically when you create cost elements in Controlling that have asset reconciliation accounts, that is, special balance sheet accounts, as corresponding general ledger accounts in Financial Accounting.

  You cannot change this cost element category in CO master data maintenance.

  FI does not require CO account assignments of category 90. However, if you do enter a CO account assignment, this is only updated statistically even for true CO objects.
Cost elements of category 90 enable you to control the costs of an order or project budget during the acquisition of fixed assets that can be directly capitalized. To achieve this you enter a capital investment order or work breakdown structure (WBS) element in the appropriate field in the asset master data. The Asset Management (AM) component ensures that when the asset is acquired, the order or WBS element is automatically entered in the document.

In Controlling, orders and WBS elements are debited statistically. This statistical debit is checked with the budget during availability control.

The R/3 System does not support other uses of category 90 cost elements at present. You cannot plan using these cost elements.

The following cost element categories can be used for **secondary cost elements**:

- **21: Internal settlement**
  This cost element category is used to settle (further allocate) order or project costs to Controlling (CO) internal objects. CO-internal objects are, for example, orders, profitability segments, cost centers and projects.
  
  You cannot use this cost element category for settlement to CO-external objects (such as fixed assets, materials, or G/L accounts). Use primary cost element category 22 for external settlement.

- **31: Order/project results analysis**
  This cost element category is used to save the order/project results analysis data on the relevant order/project.

- **41: Overhead rates**
  This cost element category is used to further allocate overhead costs using overhead rates [Ext.] from cost centers to orders.

- **42: Assessment**
  This cost element category is used to allocate costs using the assessment method.

- **43: Allocation of activities/processes**
  This cost element category is used during internal activity allocation [Ext.] and in Activity-Based Costing.

- **50: Incoming orders: sales revenues**
  This cost element category is used for sales revenues from sales orders with incoming orders in the current period of the project-related incoming order.

- **51: Incoming orders: other revenues**
  This cost element category is used for other revenues, such as imputed interest, from sales orders with incoming orders in the current period of the project-related incoming order.

- **52: Incoming orders: costs**
  This cost element category is used for costs from sales orders with incoming orders in the current period of the project-related incoming order.

- **61: Earned values**
Cost Element Categories

This cost element category is used for the earned values from the earned value analysis in Project System.
Cost Element Master Data

You can maintain cost element master records using time-based dependencies (see: Time-Based Dependencies of Master Data [Page 25]). The following time-based dependencies are possible in the SAP System:

- Time independent (I)
- Fiscal-year-based time dependency (Y)
- Period-based time dependency (P)
- Day-based time dependency (D)

The following table shows the cost element master data according to time dependency.

Time-Independent and Time-Based Master Data for Cost Elements

<table>
<thead>
<tr>
<th>Time-independent fields (I)</th>
<th>Fiscal-year based fields (Y)</th>
<th>Period-based fields (P)</th>
<th>Day-based fields (D)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Cost element characteristics</td>
<td>None</td>
<td>Default account assignment</td>
</tr>
<tr>
<td>Name</td>
<td>Cost element category</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Record quantity indicator</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unit of measure</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following table shows:

- Field usage
- Time base of these fields

Cost Element Master Data

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic data</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Description of the cost element (default transferred from general ledger account)</td>
<td>I</td>
</tr>
<tr>
<td>Cost element category</td>
<td>Classification of primary and secondary cost elements (see: Cost Element Category [Page 115])</td>
<td>Y</td>
</tr>
<tr>
<td>Attribute mix</td>
<td>Additional classification option/evaluation in reporting</td>
<td>Y</td>
</tr>
<tr>
<td><strong>Indicator</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Record quantity</td>
<td>Recording of consumption quantities; warning for actual postings without consumption quantities; no effect on quantity updates</td>
<td>Y</td>
</tr>
<tr>
<td>Internal unit of measure</td>
<td>Determines which unit of measure is recorded</td>
<td>Y</td>
</tr>
<tr>
<td><strong>Default account assignment</strong></td>
<td>Assignment to cost center/order</td>
<td>D</td>
</tr>
</tbody>
</table>

April 2001 119
You can add user-defined additional fields to cost element master data. To do this, use the enhancement COOMKA01 *Cost elements: User-defined fields in the master data record*. You can maintain the additional fields on a tab page in the relevant individual processing of the master data. You can use these additional fields to select master data in selection variants for deletion or for list display.

To create additional fields, go to Customizing for Cost Element Accounting and choose *Master Data → Cost Elements → Develop Enhancements for Cost Element Master Data [Ext.]*.

For more information on enhancement COOMKA01 see the documentation for the enhancement. You can display the documentation if you assign the enhancement to a project in the enhancement transaction CMOD.

For more information on how to use enhancements, see [BC - Changes to the SAP Standard [Ext.]](#).
Checklist for Creating Cost Elements

You must fulfill the following prerequisites before you start creating cost elements:

- You have created a controlling area [Ext.], and assigned one or more company codes to it (see: Maintain Controlling Areas [Ext.] in Customizing for General Controlling).
- The company code(s) [Ext.] assigned to the controlling area all use the same chart of accounts [Ext.].
- If you want to use a user-defined cost element attribute mix, you have defined this in Customizing (IMG) for Cost Element Accounting (see: Create cost element [Ext.]).
- You have created G/L accounts in Financial Accounting for the primary cost elements (see: Create G/L accounts [Ext.], in Customizing for G/L accounts).
- Check the existing search helps, if necessary, (see: Define Search Helps for Cost Elements [Ext.] in Customizing for Cost Element Accounting).
Processing Cost Elements

Use
You can use the following functions to create, change and display cost elements:

Integration
When you create primary cost elements [Ext.], the SAP System checks whether a corresponding general ledger (G/L) account exists in Financial Accounting (FI).

If no account exists, you can go directly from the cost element initial screen to the master data maintenance screen in Financial Accounting by choosing Environment → Create G/L account.
You can create a G/L account in the chart of accounts or in the company code.

In the basic screen, choose Environment → Display G/L account to display the G/L account for the cost element.

If you use the reconciliation ledger (see: Reconciliation Ledger [Ext.]) and you want to use reconciliation reports to compare the data in Financial Accounting with that from Controlling, note that the primary cost elements in question must be valid on January 1 of the corresponding fiscal year.

Features
The following graphic depicts the functions for the processing of cost elements:
In Customizing, you can also specify that the system create cost elements automatically. For more information, see the Implementation Guide (IMG), under Controlling → Overhead Cost Controlling → Cost and Revenue Element Accounting → Master Data → Cost Elements → Automatic Creation of Primary and Secondary Cost Elements [Ext.].

See also:
- Creating, Changing and Displaying Master Data [Page 30]
- Deleting Master Data [Page 34].
Displaying Cost Elements with Collective Processing

Prerequisites

Collective processing allows you to display several cost elements in one workstep. Deletion with collective processing is described under Deleting Cost Elements [Ext.].

Procedure

1. To change cost elements in collective processing, choose Accounting → Controlling → Cost Element Accounting (or Cost Center Accounting) → Master data → Cost element → Collective processing → Display.

2. You can select cost elements by the following criteria:
   a. Cost element or cost element interval
   b. Cost element groups
   c. All cost elements in a controlling area
   d. Selection variant [Page 28]

      You save selection criteria for the cost element selection in the selection variant. You can use the selection variant to select all cost elements with the same entries in one or more master data fields.

      You can create, change or display the selection variants at this point.

3. Select one of the criteria and enter the appropriate selection parameters.

4. Enter a time period in which the selected cost elements are valid.

   Cost elements for display must exist in the selected time period. However, you can make a selection even if the validity period for the cost element overlaps with the selected time period.

5. Choose Execute.

   The system displays a list of all the selected cost elements.

   The detail list display takes place with the ABAP List Viewer (see: ABAP List Viewer [Ext.]). You can display, sort and filter the data offered by the ABAP List Viewer.

6. To simplify future selections you can build groups from the cost elements contained in the list. To do this, choose Create group and enter a key and a description for the new cost element group.

   -- End of Content --
Cost Element Groups

Definition
You can collect cost elements with similar characteristics in cost element groups.

Use
The following graphic shows an example of a cost element group.

You can use cost element groups in the information system, for example. You can use the cost element group structure to define the row structure of your reports. Totals are calculated in the report for each node.

You can also use cost element groups whenever you want to process several cost elements in one transaction. For example, in cost center planning, distribution or assessment.

You want to plan Personnel costs. To do this, you want to plan and display all personnel costs in one business transaction. To do this, select the Personnel costs group.

You want to further allocate operating supply costs using assessment. You want to process these cost elements in one business transaction. To do this, select the Operating supplies group.
Cost Center Accounting (CO-OM-CCA)  

Cost Element Groups

Processing Cost Element Groups

- To create, change, or display cost element groups [Ext.], choose Accounting → Controlling → Cost Element Accounting (or Cost Center Accounting) → Master data → Cost element groups → Create/Change/Display.

- To copy cost element groups, choose Accounting → Controlling → Cost Element Accounting (or Cost Center Accounting) → Master data → Cost element groups → Create/Change/Display → Group → Copy.

Groups or subgroups (nodes) (such as, personnel costs, material costs, and so on) do not represent cost elements.

See:

Creating or Changing Master Data Groups [Page 40].
Copying Master Data Groups [Page 49] Processing Cost Element Groups, [Ext.]
Cost Centers

Definition
Organizational unit within a controlling area that represents a clearly delimited location where costs occur. You can make organizational divisions on the basis of functional, settlement-related, activity-related, spatial, and/or responsibility-related standpoints.

Use
Cost centers are grouped together into decision, control, and responsibility units.
You use cost centers for differentiated assignment of overhead costs to organizational activities, based on utilization of the relevant areas (cost determination function) and for differentiated controlling of costs arising in an organization (cost controlling function).
You can assign activity types to a cost center. These activity types divide the specific activities that can be produced in a cost center.

Structure
Before you create cost centers, you define a hierarchical cost center structure (see: Standard Hierarchies [Page 101]).

Cost center structures and characteristics depend on the accounting objective you are following and the cost accounting system you decide to employ.
Representative Cost Centers

Purpose

You cannot post to or plan on representative cost centers. You assign representative cost centers to standard hierarchy nodes or to an alternative hierarchy.

You need representative cost centers for:

- **Summarizations** (see also: Cost Center Summarization [Page 1137]).
  
  In summarization, the R/3 System collects data from cost centers in the assigned cost center group as an independent dataset in the representative cost center.

- **Reporting**
  
  The representative cost center supplies totals records for Report Writer reports, using the data created with the summarization. To evaluate the summarization data, you must create user-defined reports. Example reports can be found in report library 1RU.

SAP recommends gathering together all representative cost centers existing in the standard hierarchy, [Ext.] or in the alternative hierarchies, into a single node. You should then assign this node below the top node in the hierarchy.
Process Flow

1. Create a cost center, as described in Processing Master Data [Page 23].
2. To lock the representative cost center against manual postings, choose Indicators in the Cost Centers basic screen and set the lock indicators.
3. In cost center group maintenance or in the standard hierarchy, enter the representative cost center in the report information. Choose Extras → Report information in the Change Cost Center Group screen, and enter the representative cost center in the Report Information dialog box.

SAP recommends that you give the same name to the representative cost center as the node of the cost center group to which it is assigned.
Representative Cost Centers

If, during report information maintenance, you enter a representative cost center that has not yet been created as a cost center in the controlling area, the system issues an appropriate message. If you still enter the representative cost center, the system issues an error message following the subsequent summarization run.
Assignment Fields in Cost Center Master Data

You make assignments to organizational units in the cost center master data.

Company code

In Customizing (IMG) for Cost Center Accounting (CO-OM-CCA), you assign one or more company codes to your controlling area (see: Assigning Company Codes And Controlling Areas [Ext.]).

A cost center can be assigned to only one company code. If you define a one-to-one assignment between controlling area and company code, you cannot enter the company code in the cost center master data. The company code is set by the SAP System. If the assignment is not one-to-one (cross-company-code cost accounting), you can enter the company code when you edit the master data.

Business area

When defining a company code, you can specify whether the SAP System should create a balance sheet or a profit and loss (P/L) statement for each business area. If you assign a cost center to this company code, you must also specify the assignment to a business area in the cost center master data.

Profit centers

In Customizing (IMG) for Cost Center Accounting, you must specify whether Profit Center Accounting (EC-PCA) is active in the controlling area (see: Processing Controlling Areas [Ext.]). If Profit Center Accounting is active, the R/3 System issues a warning message if you have not entered a profit center in the cost center master data.

Currency

The object currency is always valid only for the fiscal year in which you create it. You cannot change it during the fiscal year.

To do so would mean that the values stored in the totals records are no longer correct due to exchange rate fluctuations. The system does not permit such changes.

If the Different company code currency indicator is active (the company code currency varies from the controlling area currency in at least one of the company codes) the system automatically adopts the company code currency as the object currency. The Currency field is not ready-for-input.

You can only change the object currency if you have not posted plan or actual data to the cost center.

Joint Venture

In the SAP System, a joint venture is a collection of cost objects, whose costs are broken down on partners. Normally a joint venture is managed by an operator that carries the incurred costs. At period-end, the costs incurred are broken down and allocated to the appropriate partners.
Assignment Fields in Cost Center Master Data


If at least one company code with active joint venture is assigned to the controlling area, the Joint venture function is available in the Cost Center Maintenance Basic Screen. You can make the necessary entries for the joint venture in a dialog box.

Logical System

If you are using distributed Cost Center Accounting (Application Link Enabling (ALE)) and you have selected distribution method 2 (decentralized Cost Center Accounting) in the controlling area, you should enter the master system of the cost center in the Logical system field.

Cost Center Master Data

Cost center master data can either be in an active or inactive version (see Active and Inactive Master Data [Page 137]).

You can maintain cost center master data using time-based dependencies (see Time-Dependency of Master Data [Page 25]). The following time dependencies are possible in the SAP System:

- Time independent (I)
- Fiscal-year-based time dependency (Y)
- Period-based time dependency (P)
- Day-based time dependency (D)

The following table shows the cost center master data according to time dependency:

<table>
<thead>
<tr>
<th>Time-independent fields (I)</th>
<th>Fiscal-year based fields (Y)</th>
<th>Period-based fields (P)</th>
<th>Day-based fields (D)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hierarchy area</td>
<td>Currency</td>
<td>Profit centers [Ext.]</td>
<td>Lock indicator</td>
</tr>
<tr>
<td>Logical system</td>
<td>Company codes [Ext.]</td>
<td>Allocation methods</td>
<td>Name</td>
</tr>
<tr>
<td></td>
<td>Business area [Ext.]</td>
<td>Costing sheet [Ext.]</td>
<td>Description</td>
</tr>
<tr>
<td></td>
<td>Formula planning template, activity-independent.</td>
<td></td>
<td>Responsible person</td>
</tr>
<tr>
<td></td>
<td>Formula planning template, activity-dependent.</td>
<td></td>
<td>Department</td>
</tr>
<tr>
<td></td>
<td>Allocation template, activity-independent.</td>
<td></td>
<td>Address</td>
</tr>
<tr>
<td></td>
<td>Allocation template, activity-dependent.</td>
<td></td>
<td>Communication data</td>
</tr>
<tr>
<td></td>
<td>Costing sheet</td>
<td></td>
<td>Cost center category</td>
</tr>
<tr>
<td></td>
<td>Record quantity indicator</td>
<td></td>
<td>Joint Venture Data</td>
</tr>
</tbody>
</table>

The following tables show:

- Field usage
- Time base of these fields

Basic data
Cost Center Master Data

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of cost center</td>
<td>T</td>
</tr>
<tr>
<td>Description</td>
<td>Description of cost center</td>
<td>T</td>
</tr>
<tr>
<td>Responsible person</td>
<td>Cost center manager</td>
<td>T</td>
</tr>
<tr>
<td>Department</td>
<td>Department to which cost center belongs</td>
<td>T</td>
</tr>
<tr>
<td>Cost center category</td>
<td>Classification of cost centers, planning information, posting information (primary and secondary postings, etc.)</td>
<td>T</td>
</tr>
<tr>
<td>Hierarchy area</td>
<td>Classification of cost center in standard hierarchy</td>
<td>I</td>
</tr>
<tr>
<td>Company code</td>
<td>Assignment to a company code</td>
<td>Y</td>
</tr>
<tr>
<td>Business area</td>
<td>Assignment to a business area</td>
<td>Y</td>
</tr>
<tr>
<td>Profit Center</td>
<td>Assignment to a profit center</td>
<td>P</td>
</tr>
<tr>
<td>Currency</td>
<td>Cost center currency</td>
<td>Y</td>
</tr>
<tr>
<td></td>
<td>Default value: Controlling area currency</td>
<td></td>
</tr>
<tr>
<td>Logical system</td>
<td>Cost center logical system (ALE); field displayed only if distribution method 02 (decentralized Cost Center Accounting) is active in the controlling area</td>
<td>I</td>
</tr>
</tbody>
</table>

You can change basic data, such as name, description, person responsible, department, or cost center category, as often as required.

There are restrictions to the changes you can make to a hierarchy area or cost center currency.

You can change assignments of the organizational units company code, business area, or profit center, to a cost center at a later date within a fiscal year. The following conditions must be met:

- The currency of the new company code corresponds to the currency of the old company code.

No currency translations are currently being executed.

- Only plan data is posted in the given fiscal year.

- The cost center is not assigned to a fixed asset, a work center or a HR master record.

At this time, there is no check whether the cost center is assigned to a HR master record.

**Control**

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
</table>

April 2001
### Cost Center Master Data

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record quantity indicator</td>
<td>Recording of consumption quantities; warning for actual postings without consumption quantities; no effect on quantity updates</td>
<td>T</td>
</tr>
<tr>
<td>Lock indicator</td>
<td>For plan and actual postings (primary, secondary, revenues, commitments)</td>
<td>T</td>
</tr>
</tbody>
</table>

#### Templates

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acty-independent form.planning temp.</td>
<td>Template for activity-independent formula planning (see: [Formula Planning](Page 391))</td>
<td>Y</td>
</tr>
<tr>
<td>Acty-dependent form.planning temp.</td>
<td>Template for activity-dependent formula planning (see: [Formula Planning](Page 391))</td>
<td>Y</td>
</tr>
<tr>
<td>Acty-independent allocation template</td>
<td>Assigned template for activity-independent allocations (cost centers). See also [Assign Template for Processes/Cost Centers](Page 732)</td>
<td>Y</td>
</tr>
<tr>
<td>Acty-dependent allocation template</td>
<td>Assigned template for activity-dependent allocations (cost centers/activity types). See also [Assign Template for Processes/Cost Centers](Page 732)</td>
<td>Y</td>
</tr>
<tr>
<td>Costing sheet</td>
<td>Controls the calculation of overhead costs (see: [Costing Sheet](Page 704))</td>
<td>P</td>
</tr>
</tbody>
</table>

#### Address

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td>Address of cost center</td>
<td>T</td>
</tr>
</tbody>
</table>

#### Assessment

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>assessment</td>
<td>Methods of communication such as telephone, fax, printer, data lines, etc.</td>
<td>T</td>
</tr>
</tbody>
</table>

#### Joint Venture

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joint Venture</td>
<td>Data for joint venture; fields are only displayed when joint ventures is active in at least one company code.</td>
<td>P</td>
</tr>
</tbody>
</table>

#### History

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created by .. on…</td>
<td>Last changed by...and date of last change (entered automatically by the system)</td>
<td></td>
</tr>
</tbody>
</table>
You can add additional fields to cost center master data. To do this, use enhancement COOMKS01 *Cost centers: User-defined additional fields in master data record*. You can maintain the additional fields on a tab page in the relevant individual processing of the master data. You can use these additional fields to select master data in selection variants for deletion or for list display.

You create additional fields in Customizing (IMG) for Cost Center Accounting. Choose *Master Data → Cost Centers → Program Enhancements for Cost Center Master Data [Ext.]*.

For more information on enhancement COOMKS01 see the documentation for the enhancement. You can display this documentation when using the enhancement transaction CMOD by choosing *Display SAP doc*.

For more information on how to use enhancements, see *BC - Changes to the SAP Standard [Ext.]*.
Active and Inactive Master Data

Use
A master record can be in an active and/or an inactive version. There are active/inactive master record versions for cost centers [Ext.], business processes [Ext.] and profit centers [Ext.].

Prerequisites
You are in the maintenance screen for the Enterprise Organization [Page 68].

Features
Active Master Data
The system works only with the active version of the master record. Therefore, only active master data is used for postings for example.

Inactive Master Data
If you change one or more of the values in a master record, the system initially saves these changes in a new inactive version without making the required consistency checks. This version is not used productively, for example, for postings.

When you create a new master record, the system initially creates an inactive version of the master record. To be able to use the master data productively, you need to activate the master record.

> When you activate the master data, the system checks the data and if no inconsistencies, transfers it to the active version of the master record. The inactive version is deleted.

If there is an older active version of the corresponding master record, the system overwrites it.

⚠️ Inactive master data is not transported, nor is it distributed via ALE. You cannot maintain inactive master data with either single processing [Page 142] or collective processing [Page 144].

Activities
You can activate or delete the corresponding inactive master data:

- In the Enterprise Organization [Page 68]
- In standard hierarchy processing for cost centers [Page 103]
- In the standard hierarchy for profit centers [Ext.]
- In standard hierarchy processing for business processes [Ext.]
- In Customizing for the relevant application, choose Master Data → <Object> → Delete/activate inactive <objects>. 
Active and Inactive Master Data

See also

Activating Inactive Master Data [Page 98]
Deleting Inactive Master Data [Page 100]
Checklist for Creating Cost Centers

- You have created the controlling area and assigned one or more company codes to it.
  You have assigned the highest node of the standard hierarchy to your controlling area
  (see: Maintain Controlling Areas [Ext.] in Customizing for General Controlling).

- If you want to use user-defined cost center categories, you have defined them in Customizing
  for Cost Center Accounting (CO-OM-CCA) (see: Maintain Cost Center Categories [Ext.]).
  Depending on the cost center categories, you have entered default values for planning
  and posting primary and secondary costs or commitments data. Check these default
  values.

- You have defined a standard hierarchy (see: Maintain Standard Hierarchy [Ext.] in
  Customizing for Cost Center Accounting).

- Check the existing search helps, if necessary, (see: Define Search Helps for Cost Centers
  [Ext.] in Customizing for Cost Center Accounting).
Creating Cost Centers Without Active Cost Center Accounting

Use
Even if Cost Center Accounting (CO-OM-CCA) is inactive, you can create cost centers as rough entries for use in validation. This can make sense when:

- Financial Accounting has been imported from SAP, but cost accounting is not yet active.
- Financial Accounting is executed in a non-SAP system.

Features
This method lets you specify a cost center when posting costs to primary cost elements [Ext.]. The R/3 System checks whether the cost center exists when you create the posting document. You can generate data from the posting documents created by the R/3 System for use in non-SAP systems. The cost center specified in the posting document can be used as a target account assignment. This guarantees that you can only make postings to cost centers that actually exist.

In this procedure, the master data stored in the database contains only the cost center number, controlling area [Ext.], and period of validity. There is no assignment to the standard hierarchy [Ext.]. You cannot maintain basic data, indicators, address or communication data using this method.

⚠️ You cannot plan or post actual costs to cost centers created in this way.

Actions
To enter rough entries for these cost centers proceed as follows:

1. In the control indicators of your controlling area, set the Cost centers indicator to 3 (active for existence checks). For more information, see the Implementation Guide Controlling → Overhead Cost Controlling → Cost Center Accounting → Maintain Controlling Area [Ext.].

2. In the Cost Center Accounting menu, choose Master data → Cost center → Collective processing → Rough entry and create the cost centers you require.

To post plan or actual costs to these cost centers, you must enter the appropriate information in the change function for master data. You must supplement the basic data and, if necessary, the additional data, such as indicators.

You can also transfer postings created in Financial Accounting to Cost Center Accounting. For more information, see the Implementation Guide for Controlling → General Controlling → Production Start-Up Preparation → Follow-Up Posting → Post Follow-Up from Financial Accounting Documents [Ext.].
Processing Cost Centers

Use

You can use the following functions to create, change and display cost centers:

Features

The following graphic explains these functions:
Changing Cost Center Master Data

You can change basic data, such as name, description, cost center category, department, person responsible, indicator or address, as often as required.

You can only assign a cost center to a node in the standard hierarchy [Ext.] or change the currency of a cost center in certain cases (see: Assignment Fields in the Cost Center Master [Page 131]).

Changing Group Assignments

You define the group assignment of a cost center for the entire lifetime of the cost center. You can also only change the group assignment for the entire lifetime. This means that unless you select the entire lifetime of the cost center, the SAP System does not accept the change. If you have divided the analysis period into different periods, you can select the complete analysis period by selecting the complete object interval list in the Analysis Period: Choose dialog box (see: Processing Master Data [Page 23]).

If you change the group assignment, the system creates a change document. To display the change documents, choose Environment → Change documents → For field/For cost center.

Evaluations Using Older Group Assignments

For evaluations in the information system, you can only use the current assignment in the standard hierarchy. If you require older group assignments for evaluation, you can do the following:

- If you use group maintenance to process the standard hierarchy, create a copy of the hierarchy first. Next, make the necessary changes.
  
  see Example: Copying The Standard Hierarchy of Cost Centers [Page 32]

- If you process the standard hierarchy on the maintenance screen for the enterprise organization, create an alternative hierarchy at the required time.
  
  See Time-Dependency of The Enterprise Organization [Page 71]

See also

Creating, Changing and Displaying Master Data [Page 30]
Deleting Master Data [Page 34].
Changing and Displaying Cost Centers with Collective Processing

Use

Collective processing allows you to change or display several cost centers in one workstep. Deletion with collective processing is described under Deleting Cost Centers [Ext.].

Procedure

1. To change cost elements in collective processing, choose Accounting → Controlling → Cost Center Accounting → Master data → Cost center → Collective processing → Change.
   
   To display cost centers in collective processing, choose Accounting → Controlling → Cost Center Accounting → Master data → Cost center → Collective processing → Display.

2. You can select cost centers by the following criteria:
   a. Cost center or cost center interval
   b. Cost center group
   c. All cost centers in a controlling area [Ext.]
   d. Selection variant [Page 28]
      You save selection criteria for the cost center selection in the selection variant. You can use the selection variant to select all cost centers with the same entries in one or more master data fields.
      You can create, change or display the selection variants at this point.

3. Select one of the criteria and enter the appropriate selection parameters.

4. Enter a time period in which the selected cost centers are valid.
   a. Cost centers that you want to change must exist in the selected time period. The validity period for the cost centers must lie completely within the time period you have selected.
   b. Cost centers that you want to display must also exist in the selected time period. However, you can select these cost centers even if the validity period for the cost centers overlaps with the selected time period.

5. If you want to change cost centers, enter a list variant or use the F4 help to select one of the existing list variants.
   The list variants allow you to control the list display for the selected cost centers.
   SAP offers you standard list variants, which differ in the number of master data fields that can be maintained. You can also define your own list variants, for which you can select all standard master data fields for maintenance. To create your own list variants, choose:
   a. Environment → Maintain list variants or
   b. In the Implementation Guide (IMG) for Cost Center Accounting, choose Master Data → Cost Centers → Define List Variants for Collective Processing [Ext.]
      If you want to display cost centers, you do not need any list variants.
6. Choose **Execute**.
   
   The system displays a list of all the selected cost centers.

7. To maintain fields in collective processing that have not yet been displayed, choose **Format → Other list variant** or **Previous list variant** or **Next list variant**

8. To maintain the master data for a single cost center from list processing for cost centers, select the appropriate row and choose **Goto → Master data**.
   
   You can make further changes in the cost center master data and save these changes.

9. From list processing for cost centers, choose **Goto → Cost center list** to access the cost center list display.
   
   The system executes the cost center list using the selection criteria you entered in the initial screen for cost center collective processing.

10. If you want to **change** cost centers, you overwrite the entries in the ready-for-input fields and save your entries.

   You can only change master data fields that have the same value for the whole of the selected period. Otherwise, these fields are not ready-for-input (see: **Processing Master Data** [Page 23]).

   Choose **Extras → Change org. units** to change assignments of the organizational units company code, business area, or profit center at a later date within a fiscal year. The following conditions must be met:

   - The currency of the new company code corresponds to the currency of the old company code.
     
     No currency translations are currently being executed.

   - Only plan data is posted in the given fiscal year.

   - The cost center is not assigned to a fixed asset, a work center or a HR master record.
     
     The system does not check as to whether the cost center is assigned to an HR master record.
     
     The new values are valid for the complete fiscal year.

11. When you **display** cost centers, the system displays the list using the ABAP List Viewer (see: **ABAP List Viewer [Ext.]**).
   
   You can display, sort and filter the data offered by the ABAP List Viewer.
   
   To simplify future selections you can build groups from the cost centers contained in the list. To do this, choose **Create group** and enter a key and a description for the new cost center group.
Cost Center Group

Definition
You can collect cost centers according to various criteria into groups. This enables you to use cost centers to depict the structure of the organization in the SAP System.

Use
You can use the groups to build cost center hierarchies, which summarize the decision-making, responsibility, and control areas according to the particular requirements of the organization. The individual cost centers form the lowest hierarchical level.

There must be at least one group that contains all cost centers and represents the entire business organization. This cost center group is described as the standard hierarchy. You can assign more cost center groups to the standard hierarchy.

You can also create any number of alternative groups. You can structure these, for example, according to organizational and/or functional viewpoints. Cost center groups enable you to perform evaluations for each decision-making, responsibility, or control area. They also support the processes during planning and internal allocations.

You can assign each cost center to only one group in the standard hierarchy, but to as many alternative groups as you require.

Processing Cost Center Groups

- To create, change, or display cost center groups, choose Accounting → Controlling → Cost Center Accounting → Master data → Cost center groups → Create/Change/Display.

  The alternative cost center groups can contain parts of the standard hierarchy (see: Standard Hierarchies [Page 101]).

- To copy cost center groups, choose Accounting → Controlling → Cost Center Accounting → Master data → Cost element groups → Create/Change/Display → Group → Copy.

  For more information, see Creating or Changing Master Data Groups [Page 40] and Copying Master Data Groups [Page 49].

See:
Creating or Changing Master Data Groups [Page 40].
Copying Master Data Groups [Page 49].
Activity Types

Definition

Activity types classify the activities produced in the cost centers within a controlling area [Ext.].

Use

To plan and allocate the activities, the system records quantities that are measured in activity units. Activity quantities are valuated using a price (allocation price).

In Overhead Cost Controlling, costs based on the activity quantity of an activity type are posted separately in fixed and variable portions. When you divide the activities of a cost center into activity types, you should consider whether the costs can be allocated effectively to the activity types.

The prices of the activity types of a cost center can be either entered manually, or calculated by the system based on the costs allocated to the activities. Prices can be calculated either using plan costs or actual costs.

You can plan, allocate, and control costs either at the activity type level of a cost center, or at the cost center level. You can enter actual costs at the cost center level. Costs entered at the cost center level are assigned using splitting [Ext.].

You can also assign the activity type of a cost center directly. This use was designed for certain application areas (such as personnel costs and depreciation postings).

For more information, see Actual Postings to Activity Types [Page 546].

Integration

You can assign one activity type, multiple activity types, or no activity types to a cost center.

Typical examples of activity types for cost centers are machine hours, administrator hours, CPU minutes or units produced.
Activity Type Categories

Definition

The activity type category [Ext.] lets you determine whether, and how, an activity type is allocated.

Use

The following table gives you an overview of the possible activity type categories and their use in Cost Center Accounting (CO-OM-CCA).

Activity Type Categories for Plan and Actual Allocation

<table>
<thead>
<tr>
<th>Activity Type Categories</th>
<th>Description</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Actual activity is entered and allocated directly</td>
<td>Allocation of measurable activities; actual quantity × plan price</td>
</tr>
<tr>
<td>2</td>
<td>Actual quantities result from the total of the activity inputs, calculated using tracing factors on the individual receivers</td>
<td>Indirect calculation of activity quantities using receiver tracing factors</td>
</tr>
<tr>
<td>3</td>
<td>Actual activities are allocated using indirect activity allocation</td>
<td>Automatic allocation of activity quantities using receiver tracing factors</td>
</tr>
<tr>
<td>4</td>
<td>Activity types are not allocated</td>
<td>This activity type can be used only to record quantities (no values) on the sender cost centers</td>
</tr>
</tbody>
</table>

Activity Type Category for Actual Allocations

<table>
<thead>
<tr>
<th>Activity Type Categories</th>
<th>Description</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>Target=actual activity allocation</td>
<td>Actual allocation of the activities using target=actual activity allocation This activity type category can only be used for actual allocations. Planning can be executed using activity type categories 1, 2, or 3. Category 1 is most commonly used.</td>
</tr>
</tbody>
</table>

- Activity type category 1: Manual entry, manual allocation
  
  You plan activity quantities manually for activity types in this category.
  
  You enter actual activity quantities in internal activity allocation, based on business transactions.
  
  Plan activities are allocated using activity input planning on the receivers. It may be necessary to reconcile the plan sender quantities and the plan scheduled activities.
• Activity type category 2: Indirect calculation, indirect allocation
  
  For activity types of this category, you plan activity types on the sender cost center.
  
  You can calculate the plan and actual activity quantities for activity types of this category as follows:
  
  − Automatically, using receiver tracing factors, which you can value with weighting factors and are defined for each sender, or
  
  − Using a fixed quantity, which you define in the segment definition of the indirect activity allocation (see: Indirect Activity Allocation [Page 713]).
  
  The R/3 System automatically reconciles the plan and scheduled activity quantities.

• Activity type category 3: Manual entry, indirect allocation
  
  You plan activity quantities manually for activity types in this category.
  
  To enter the actual activity quantities by business transaction, access the Cost Center Accounting menu, and choose Actual postings → Sender activities (see: Entering Sender Activities [Page 534]). You cannot enter receiver objects here.
  
  Plan and actual activity quantities are allocated automatically using defined sender/receiver relationships. The R/3 System calculates the activity quantity to be allocated to each receiver, based on the relationship of the tracing factors to all receivers. Manually planned or posted activity quantities are further allocated in full to the receivers. This means that the activity types in the plan are always reconciled following the activity allocation.

• Activity type category 4: Manual entry, no allocation
  
  You plan activity quantities manually for activity types in this category.
  
  To enter the actual activity quantities by business transaction, access the Cost Center Accounting menu, and choose Actual postings → Sender activities (see: Entering Sender Activities [Page 534]). You cannot enter receiver objects here.
  
  You cannot allocate to other objects.

• Activity type category 5: Calculation and allocation through target=actual activity allocation
  
  You require activities of this activity type category when you carry out target=actual activity allocation. Target=actual activity allocation is a special from of indirect activity allocation, where the planned input of an activity is transferred as an actual value, in accordance with the operating rate (see: Target=Actual Activity Allocation [Page 720]).
  
  Target=actual activity allocation is used only to allocate actual values. Therefore, activities participating in target=actual allocation must be assigned different activity type categories for planning and actual allocation.
  
  Actual allocation requires activity type category 5. Planning requires activity type categories 1, 2, or 3. Category 1 is most commonly used.
  
  In activity type maintenance, you have the option of entering separate plan and actual activity type categories. An actual activity type category is required only if actual allocation varies from plan allocation. Otherwise, the SAP System automatically adopts the plan activity type category in the actual.
Activity Type Categories

You may use the following combinations of plan and actual activity type categories:

- You can generally combine all categories allowing allocation (1, 2, 3, and 5). However, you must apply the same allocation method (manual or indirect) in both plan and actual.

- You can combine the plan activity type categories 1, 2, and 3 (with manual and indirect allocation), together with the actual activity type category 5 (with target=actual activity allocation).

- You can not combine activity type category 4 (manual entry, no allocation) with categories allowing allocation. Moreover, you can only select activity type category 4 if you have activated the No allocation indicator.
Price Indicators

Definition
The Price indicator determines how the price [Ext.] of a business process or an activity type is calculated for a cost center.

Use
There are two fields: The Price indicator determines the way the system calculates prices for actual values. For actual allocations, you can enter a price indicator different from that in the plan.

You can enter the following values for the (plan) price indicator:

- 001:
  The R/3 System calculates the price of the activity type automatically, based on the plan activity and the plan costs required by the cost center.
  - Fixed price: Fixed plan costs ÷ plan activity
  - Variable price: Variable plan costs ÷ plan activity
  - Total price: Fixed price + variable price

- 002:
  The R/3 System calculates the variable portion of the price, based on the plan activity. The fixed portion, however, is based on capacity.
  This method usually results in an underabsorption for the cost center. This is because the cost center is not credited in full for the costs of providing the capacity.
  - Fixed price: Fixed plan costs ÷ capacity
  - Variable price: Variable plan costs ÷ plan activity
  - Total price: Fixed price + variable price

  If you have set values 001 or 002, the system calculates new prices when you execute Plan Price Calculation [Ext.].

- 003:
  You set the price of the activity type manually.

- 004:
  Activation from version maintenance

You cannot enter price indicator 004 (the plan price of the activity is calculated purely iteratively). If you activate Purely iterative price in the version, the SAP System calculates a purely iterative price, in addition to the price resulting from planning.

You can enter the following values for the (actual) price indicator:
Price Indicators

- 005:
  The SAP System calculates the actual price based on the actual activity if you execute Actual Price Calculation [Ext].

- 006:
  The R/3 System calculates the variable portion of the price, based on actual activity. The fixed portion, however, is based on the capacity.
  
  If you have set values 005 or 006, the system calculates new prices when you execute actual price calculation. Recalculation of actual activity at actual prices can only be executed if you have selected recalculation during version maintenance.

- 007:
  Manual actual price: You set the price of the activity type or business process manually. Using this price indicator, you can set a price manually that is independent of and varies from the plan.

- 008:
  Actual price, activation from version maintenance: The system calculates the actual price of the activity type or business process iteratively only. If you activate the indicator Iter., the system calculates a purely iterative price in addition to the price resulting from planning.
  
  You cannot enter price indicator 008 (the actual price is calculated purely iteratively). If you activate Purely iterative price in the version, the SAP System calculates a purely iterative price, in addition to the price resulting from planning.
Activity Type Master Data

You can maintain the master data of activity types using time-based dependencies (see: Time-Based Dependencies of Master Data [Page 25]). The following time-based dependencies are possible in the SAP-R/3-System:

- Time independent (I)
- Fiscal-year-based (Y)
- Period-based time dependency (P)
- Day-based time dependency (D)

The following table shows the activity type master data according to time dependency:

<table>
<thead>
<tr>
<th>Time-independent fields (I)</th>
<th>Fiscal-year based fields (Y)</th>
<th>Period-based fields (P)</th>
<th>Day-based fields (D)</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Basic data</td>
<td>None</td>
<td>Basic data</td>
</tr>
<tr>
<td>Activity unit</td>
<td>Activity type category [Ext.]</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>Actual activity type category</td>
<td></td>
<td>Cost center categories [Ext.]</td>
<td></td>
</tr>
<tr>
<td>Allocation cost element</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Output</td>
<td>Output unit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Output factor</td>
<td>Indicator</td>
<td></td>
<td>Indicator</td>
</tr>
<tr>
<td>Price Indicators</td>
<td>Actual price indicator</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Average prices</td>
<td>Predistribution of fixed costs [Ext.]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Plan quantity set</td>
<td>Actual quantity set</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The following table shows:

- Field usage
- Time base of these fields
### Activity Type Master Data

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Basic data</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Name of activity type</td>
<td>D</td>
</tr>
<tr>
<td>Description</td>
<td>Description of activity type</td>
<td>D</td>
</tr>
<tr>
<td>Activity unit</td>
<td>Unit of measure in which the activity is allocated</td>
<td>Y</td>
</tr>
<tr>
<td>Cost center categories</td>
<td>Cost center categories for which the activity types is valid for planning and allocation</td>
<td>D</td>
</tr>
<tr>
<td>Activity type category, Actual activity type category</td>
<td>Defines whether, and how, the activity type is to be entered and allocated (default value) (see: activity type categories [Page 148])</td>
<td>Y</td>
</tr>
<tr>
<td><strong>Allocation cost element [Ext.]</strong></td>
<td>Secondary cost element, under which the activity type is allocated (default value, can be overwritten in activity type planning)</td>
<td>Y</td>
</tr>
<tr>
<td>Price indicator, Actual price indicator</td>
<td>Defines how the price of the activity type is to be calculated on a cost center (default value) (see: price indicators [Page 151])</td>
<td>Y</td>
</tr>
<tr>
<td>Average prices</td>
<td>Defines whether the prices of cost centers/activity types remain constant for the complete fiscal year (default value) (see: procedure for price calculation [Page 883])</td>
<td>Y</td>
</tr>
<tr>
<td>Predistribution of fixed costs</td>
<td>Determines whether or not fixed costs are to be distributed in advance to the cost centers receiving the activity (default value) (see: predistribution of fixed costs [Page 871])</td>
<td>Y</td>
</tr>
<tr>
<td>Plan quantity set</td>
<td>If you set this indicator, the planned activity quantity is not changed by plan reconciliation - even where planning for the object is not to be reconciled.</td>
<td>Y</td>
</tr>
<tr>
<td>Actual quantity set</td>
<td>Determines whether, in addition to the allocated activity type quantity credited to the cost center, you can also post a manual quantity (default value)</td>
<td>Y</td>
</tr>
<tr>
<td><strong>Indicator</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock indicator</td>
<td>Locks the activity type against the planning of activity inputs</td>
<td>D</td>
</tr>
<tr>
<td><strong>Output</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Output unit</td>
<td>Alternative output unit</td>
<td>Y</td>
</tr>
<tr>
<td>Output factor</td>
<td>Alternative output factor</td>
<td>Y</td>
</tr>
</tbody>
</table>
You can specify an alternative output unit if the output of the activity type is measured in a different unit from that used by the activity type itself.

One hour of the activity "Lathing" produces 10 drills. The activity unit is "Hour", the alternative output unit is "Piece". You can also specify an output factor, in this case "10".

The system is able to automatically derives the output from the scheduled activity, using the alternative output unit and the alternative output factor.

You can add user-defined additional fields to activity type master data. To do this, use the enhancement COOMLA01 Activity type: User-defined additional fields in the master data record. You can maintain the additional fields on a tab page in the relevant individual processing of the master data. You can use these additional fields to select master data in selection variants for deletion or for list display.

You create additional fields in Customizing (IMG) for Cost Center Accounting. Choose Master Data → Activity Types → Program Enhancements for Activity Type Master Data [Ext.].

For more information on enhancement COOMLA01 see the documentation for the enhancement. You can display the documentation if you assign the enhancement to a project in the enhancement transaction CMOD.

For more information on procedure for enhancements, see BC - Changes to the SAP Standard [Ext.].
Checklist for Creating Activity Types

- You have created the controlling area, and assigned one or more company codes to it (see: Maintain Controlling Areas [Ext.] in Customizing for General Controlling).

- You have created cost elements for the activity allocation (cost element category 43) (see: Maintain Cost Elements for Activity Allocation [Ext.] in Customizing for Cost Center Accounting).

- Check the existing search helps, if necessary, (see: Define Search Helps for Activity Types [Ext.] in Customizing for Cost Center Accounting).
Processing Activity Types

Use

You can use the following functions to create, change and display activity types [Ext.]:

Features

The following graphic depicts the functions available for processing activity types:

Changing Master Data of Activity Types

You generally make changes to the master data of activity types either at the beginning or at the end of the fiscal year. This is to ensure that the data remains consist.
Processing Activity Types

Cost center category
If you change the cost center category [Ext.], be careful to avoid inconsistencies with information stored in the cost center master data.

The activity type *Repair hours* is only allowed on service cost centers. The cost center category for this is “H”. The system stores this cost center category in the master data of the activity type. You then plan your cost centers.

The cost center category in the activity type master data is then changed to “W” for administration. You may no longer plan on, or allocate internal costs to, service cost centers using activity type *Repair hours*. This is because this activity type is now valid only for administration cost centers.

Default values for allocations
You can store the following indicators as default values within the master data of the activity types:

- Activity type category
- Actual activity type category
- Price indicator
- Actual price indicator
- Cost element for the activity allocation
- Average price
- Predistribution of fixed costs
- Plan quantity set
- Actual quantity set

If you are planning for the first time, you can overwrite the default value.

You can also store a default value for allocable activity type categories (activity type categories 1, 2 or 3). Within planning, you can change this default value to a different allocable activity type category or allocation category.

You may only change non-allocable activity type category 4 to an allocable activity type category (or the other way round), if no dependent data exists.

Activity type category
You can only change the activity type category in the master data of the activity type at fiscal-year level.

Changes between activity type categories 1, 2, 3, and 5 are possible even if you have already planned using the given activity type. This is because they are only default values.

You can only make changes in activity category 4, or from activity type category 4 to a different category, if you have not yet posted in the plan or actual of the fiscal year using the given activity type.
For actual allocations, you can enter an activity type category different from the category in the plan. If you do not enter an activity type category for actual allocation, the SAP System uses the same activity type category for both actual and plan (see: Activity Type Category [Page 148]).

**Cost element for the activity allocation**

The allocation cost element can only be changed in the master data of the activity type at fiscal-year level.

You should only change the allocation cost element if you no longer require it. If you must debit an activity type using a different allocation cost element, you can change the allocation cost element when you plan the activity type on the cost center.

The activity type is always allocated using the allocation cost element entered during planning.

**Price indicator**

You can only change the price indicator in the master data of the activity type at fiscal-year level.

For actual allocations, you can enter a price indicator different from that in the plan. If you do not enter a price indicator for the actual allocation, the SAP System uses the same price indicator in the actual and planning data (see: Price Indicator [Page 151]).

**Average Price**

The *Average price* indicator specifies whether prices of cost centers/activity types remain constant for the whole fiscal year. You can only change the indicator in the activity type master data at fiscal year level.

**Predistributed Fixed Costs**

The *Predistributed fixed costs* indicator determines whether the fixed costs (incurred for providing an activity) are to be predistributed to the cost centers that received the activity. You can only change the indicator in the activity type master data at fiscal year level (see: Activity Type Planning [Page 208], and Predistribution of Fixed Costs [Page 871]).

**Set Actual Quantity**

The *Manual actual quantity* indicator determines whether a manual quantity can be posted as well as the allocated activity quantity that credits the cost center. The manual posting is particularly useful if the allocated activity quantity is determined inversely, but the actual quantity on the sender is known.

**Set Plan Quantity**

If this indicator has been set, then the planned activity quantity **not** changed by the plan reconciliation - even if planning for the object is not to be reconciled.

**See also:**

Creating, Changing and Displaying Master Data [Page 30]
Deleting Master data [Page 34]
Processing Activity Types
Displaying Activity Types with Collective Processing

Prerequisites

Collective processing allows you to display several activity types [Ext.] in one workstep. Deletion with collective processing is described under Deleting Activity Types [Ext.].

Procedure

1. To display cost elements in collective processing, choose Accounting → Controlling → Cost Center Accounting → Master data → Activity type → Collective processing → Display.

2. You can select activity types by the following criteria:
   a. Activity type or activity type interval
   b. Activity type group
   c. All activity types in a controlling area [Ext.]
   d. Selection variant [Page 28]

   You save selection criteria for the activity type selection in the selection variant. You can use the selection variant to select all activity types with the same entries in one or more master data fields.

   You can create, change or display the selection variants at this point.

3. Select one of the criteria and enter the appropriate selection parameters.

4. Enter a time period in which the selected activity types are valid.

   Activity types that you want to display must exist in the selected time period. However, you can make a selection even if the validity period for the activity types overlaps with the selected time period.

5. Choose Execute.

   The system displays a list of all the selected activity types. The following functions are available:
   - Master data records
     Select a row, then choose Goto -> Master data to display the corresponding master data.
   - Create group
     With the Create group function, you can create a new master data group. You select the master data that is to be combined in a group and assign a name to the group.

     You can select the rows as desired (see also Selecting rows [Ext.]). If you do not select a row and choose Create group, a group is created for all master data displayed.

For more information on display and navigation options, see SAP List Viewer (ALV): Grid Control [Ext.]
Activity Type Group

Definition
You can gather activity types with similar characteristics into activity type groups.

Use
You can use activity type groups to process multiple activity types in one business transaction within Cost Center Accounting. This is true for planning or assessment. During planning, for example, you can display and plan multiple activity types in one transaction. You can also use activity type groups during assessment [Ext.] (for example, assessment to specified activity type groups).

As with cost elements and cost centers, the SAP System enables you to create and administrate activity type groups in parallel. For example, you can create separate activity type groups for planning and allocation purposes. You can also define additional activity type groups, for purposes such as price analysis.

Processing Activity Type Groups

• To create, change, or display activity type groups, choose Accounting → Controlling → Cost Center Accounting → Master data → Activity type groups → Create/Change/Display.

• To copy activity type groups, choose Accounting → Controlling → Cost Center Accounting → Master data → Activity type groups → Create/Change/Display → Group → Copy.

See:
Creating or Changing Master Data Groups [Page 40].
Copying Master Data Groups [Page 49].
Statistical Key Figures

Definition

Figure representing
- Cost Centers [Ext.]
- Activity Types [Ext.]
- Orders [Ext.]
- Business Processes [Ext.]
- Profit Centers [Ext.]
- Real Estate Objects [Ext.]

You can use them as the basis for internal allocations, such as Distribution [Ext.] and Assessment [Ext.].

You assess the costs for the cafeteria to the individual cost centers, based on the number of employees in each cost center. To do this, you need to enter the number of employees in each cost center as a statistical key figure.

Structure

You can define statistical key figures as either:
- Fixed values
- Totals values

Key figures defined as fixed values are valid as of the posting period, and in all subsequent posting periods of the fiscal year.

The statistical key figure Employees is defined as a fixed value. In period 1 of the fiscal year, you post 10 Employees on cost center 4100. The system then automatically posts 10 employees in periods 2 through 12.

In period 6, the number of employees is increased to 15. This means that in period 6, you post 15 Employees on the cost center. The system automatically posts 15 employees in periods 6 through 12.

Key figures defined as Totals values are valid only in the posting period in which they are entered.

You define the statistical key figure Telephone units as a totals value. In period 1 of the fiscal year, you post 1000 Telephone units on cost center 4100. The system posts 1000 telephone units in period 01 only.
Statistical Key Figures

Integration

As well as entering statistical key figures manually, you can also transfer them automatically from the information systems of other SAP System application components. To do this, statistical key figure maintenance includes an interface that enables you to link the statistical key figures in Controlling with those in the Logistics Information System (LIS). You transfer plan and actual key figures from the LIS separately.
**Link to LIS**

**Use**

During the individual processing of statistical key figures [Ext.] you can use an interface to the Logistics Information System (LIS). This enables you to link the key figures in Controlling with the key figures in the LIS. This link lets you create the prerequisites for a later transfer of key figures from the LIS to the key figures defined in Controlling and with the key figures connected with the LIS.

**Features**

The following graphic depicts the functions for the link to the LIS:

---

**Creating an LIS Link**

If you want to transfer key figures, choose *Link to LIS* in the basic screen for statistical key figures. The system automatically creates the link to the LIS.

The system offers you two methods with which you can search for key figures in the LIS.

- Search by info structure
- Search by info set

Info structures are the database tables in which period-based data of the operative application is updated. They are comprised of characteristics suitable for summarization (such as, Purchasing Organizations), and key figures (for example, Sales).
Link to LIS

Info sets are collections of key figures that have a logical relationship to each other. They contain either key figures or sets. This allows you to generate different levels of detail.

Differences Between the Two Search Strategies

<table>
<thead>
<tr>
<th></th>
<th>Search by info structure</th>
<th>Search by info set</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Scope</strong></td>
<td>Key figures from LIS standard analyses</td>
<td>Key figures from:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- LIS standard analyses</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Reports</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Transactions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Tables</td>
</tr>
<tr>
<td><strong>Level of detail</strong></td>
<td>Three levels:</td>
<td>Any number of levels:</td>
</tr>
<tr>
<td></td>
<td>1. Application</td>
<td>1. Info set</td>
</tr>
<tr>
<td></td>
<td>2. Info structure</td>
<td>2. Additional info sets</td>
</tr>
<tr>
<td></td>
<td>3. Key figure</td>
<td>3. Key figure</td>
</tr>
</tbody>
</table>

To search effectively using the info structure, you need to know about the technical relationships of the database tables. When you search by info set, it is helpful if you know about the logical relationships.

The following examples demonstrate the search procedure for LIS key figures:

**Search by info structure**

When you created the statistical key figure *Incoming orders* in Controlling, you activated the link to the LIS. In the dialog box, you choose *Search by info structures*. The system displays a list of applications:

- Sales and Distribution
- Purchasing
- Production
- Logistics General, and so on.

Select *Sales and Distribution*. Another list appears with the info structures for the selected application. Select *S001* for *Customer*. Another list appears with the key figures for the *Customer* info structure. Select the key figure *Incoming orders qty* (AEMENGE).

When you transfer this key figure, the system uses the LIS value for the key figure *Incoming orders* in CO.

**Search by info set**

Select the following info sets, successively, from the lists offered to you by the system:
1. Info set: Logistics info sets
2. Info set: Sales and Distribution
3. Info set: Customer
4. Info set: Incoming sales order (customer view)
5. Key figure: Incoming orders in base unit from customer analysis

You cannot transfer any currency key figures.

If you have selected a key figure from the LIS using one of the above methods, the system displays the information for the LIS statistical key figure in the initial screen for key figure maintenance.

**Additional Functions**

If you want to display the assignments of a CO statistical key figure to LIS key figures, choose *Edit → Display assignments*.

If you want to display all uses of the CO key figure, including manually set figures, choose *Edit → Display all references*.

**Breaking the Link to LIS**

If you want to break the link to LIS, choose *Separate from LIS* in the basic screen for statistical key figures.
Master Data for Statistical Key Figures

Use

The following table shows:

- The use of master data for statistical key figures [Ext.]
- The time dependency of master data

Features

<table>
<thead>
<tr>
<th>Field</th>
<th>Use</th>
<th>Time base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name</td>
<td>D</td>
</tr>
<tr>
<td>Unit of measure of StKF</td>
<td>Creation of key figures</td>
<td>D</td>
</tr>
<tr>
<td>Key figure categories [Ext.]</td>
<td>Creation of key figures</td>
<td>Y</td>
</tr>
<tr>
<td></td>
<td>Tracing factors for Distribution [Ext.]/Assessment [Ext.]</td>
<td></td>
</tr>
</tbody>
</table>
Checklist for Creating Statistical Key Figures

- You have created the controlling area, and assigned one or more company codes to it (see: Maintain Controlling Areas [Ext.] in Customizing for General Controlling).

- You have defined units for the statistical key figures. You define units of measure in Customizing under Global Settings → Check units of measure [Ext.].
Processing Statistical Key Figures

Use

You can create, change and display statistical key figures individually or collectively. Individual processing lets you process only one statistical key figure. Collective processing lets you process multiple statistical key figures simultaneously.

You can use the following functions in individual processing: The functions for collective processing are in: Processing Statistical Key Figures Using Collective Processing [Page 171].

Creating Statistical Key Figures

You enter statistical key figures with individual processing in a similar way to master data maintenance for cost centers [Ext.], cost elements [Ext.], activity types [Ext.] and business processes [Ext.].

Individual processing has the following advantages compared to collective processing:

- You can use a reference when you create statistical key figures.
- The entry screen is more clearly structured than the list screen.
- If you are using the Logistics Information System (LIS), you can create a link to the LIS (see: Link to The LIS [Page 165]).

Changing Statistical Key Figures

When you make changes to statistical key figures, be careful to avoid generating any inconsistencies.

For example, do not change the key figure category and the statistical key figure unit during the fiscal year. Otherwise you cannot reliably compare values with earlier periods. It is best to change the key figure categories or create new statistical key figures at the end of the fiscal year.

The key figure category affects changes made to statistical key figures in the following ways:

- When you make changes to key figures of the category Fixed values, you must enter a new fixed value. This new value is valid for all subsequent periods, until you enter another new value.
- When you make changes to statistical key figures of the category Totals values, you can first reset the values using reversed +/- signs, and then enter the new values.

Activities

To process statistical key figures individually, access the Cost Center Accounting menu, the Activity-Based Costing menu, or the Profit Center Accounting menu and choose:

Master data -> Statistical key figures → Individual processing → Create/Change/Display.
Processing Statistical Key Figures With Collective Processing

Use
You can use the following functions to change and display statistical figures with collective processing:

Features
The following graphic depicts the functions available for the collective processing of statistical key figures:
Deleting Statistical Key Figures

1. To delete individual statistical key figures, go to the menu for cost center or business process cost calculation and choose *Master data → Statistical key figures → Individual processing → Delete*.

2. In screen *Delete Statistical Key Figures: Initial Screen*, enter the key figure to be deleted.

3. Choose *Delete*.

4. Answer *Yes* when the system asks if the statistical key figure should be deleted?

   The system rejects attempts to delete statistical key figures that are already used in total records.
Statistical Key Figure Groups

Definition
You can gather statistical key figures into statistical key figure groups.

Use
You can use statistical key figures, or parts of them, when you need to process multiple statistical key figures in one business transaction. For example, in cost center planning, distribution or assessment.

Statistical key figures used as tracing factors for distribution or assessment can be collected in groups.

As with other master data groups, you can create and maintain statistical key figure groups in parallel in the system.

Processing Statistical Key Figure Groups

• To create, change, or display statistical key figures, choose Accounting → Controlling → Cost Center Accounting or Activity-Based Costing, or Profit Center Accounting → Master data → Statistical key figure groups → Create/Change/Display.

• To copy statistical key figure groups, choose Accounting → Controlling → Cost Center Accounting or Activity-Based Costing, or Profit Center Accounting → Master data → Statistical key figure groups → Create/Change/Display → Group → Copy.

See:
Creating or Changing Master Data Groups [Page 40].
Copying Master Data Groups [Page 49].
Resources

Definition
A resource comprises goods and services, which are supplied internally and externally, to produce business activities.

Use
You can use resources to carry out a detailed, quantity-based primary costs planning below the cost element level for cost centers, orders and WBS elements. Resource planning will replace detailed planning at a later date. The SAP R/3 System valuates the given resource consumption with a price, which you can store separately and period-dependent in a price file in the system.

You can not use resources in the actual.

Structure
You can choose from three resource types, which the system derives internally from the available data.

- The resource is only known within Overhead Cost Controlling (type R)
  You can store the price directly in the price tables.
- The resource refers to a material (type M).
  The system takes only the material price for valuation of the resource consumption.
- The resource refers to a base planning object (see: Reference and Simulation Costing) (type B).
  The system valuates the resource consumption using the price of the costed base planning object.

The resource master record is structured as follows:

- Resource key
- Validity period of the resource
- Resource units
- Cost element
- Resource name
- Plant
- Material
- Base object costing
- Purchasing organization
- Resource type (derived internally)
- Entered by (derived internally)
- Entry date (derived internally)
You can only enter individual values, not resource hierarchies.

**Integration**

Resources can have their own prices or they can take the price of a material or a base planning object.

If you specify a cost element in the master record, you can only plan under this cost element.
Processing Resources

Creating Resources

1. To create master data for resources [Ext.], choose Accounting → Controlling → Cost Center Accounting → Master data → Resources → Create/Change.

   You can also create resource master data in the Implementation Guide (IMG) for Cost Center Accounting, under Master data → Resources → Define Resources → Create/Change Resources.

2. Choose New entries.

3. Specify a key for the resource.

   The key may contain a maximum of 10 characters and must be valid for one fiscal year.

4. Enter the validity period for the resource.

   The From-date must be the beginning of the fiscal year, and the To-date must be the end of the fiscal year.

5. Enter a resource unit (RU). The SAP System uses this resource unit during planning.

   You can overwrite the resource unit during planning. Note that the units in the resource master data, in planning, and in the material master record must be convertible with one another.

6. If you are planning the resource consumption exclusively under one particular primary cost element or revenue element, you should enter this cost element or revenue element.

   If you do not specify a cost element, you can use any primary cost element or revenue element during planning.

7. Enter a name for the resource.

8. If the resource price is to be derived from the price of a material [Ext.] you should enter a plant [Ext.] and a material number.

   If the resource price is to be derived from the price of a base planning object (see: Reference and Simulation Costing [Ext.]) you should enter a base planning object.

   If you want to create a resource without reference to another organization unit, you should leave empty the fields Plant, Material, Base planning object and PurOrg.

9. Save your entries.

   The SAP System derives the resource type from your entries (see: Resources [Page [174]]. The system also enters the user name of the person entering the data and the entry date.

Changing Resources

1. To change master data for resources, choose Accounting → Controlling → Cost Center Accounting → Master data → Resources → Display/Change.

   You can also change resource master data in the Implementation Guide (IMG) for Cost Center Accounting, under Master data → Resources → Define Resources → Create/Change Resources.
2. You change the resource master data by overwriting the appropriate entries.

**Displaying Resources**

1. To display resource master data, choose Accounting → Controlling → Cost Center Accounting → Master data → Resources → Display.

2. You can also display resource master data in the Implementation Guide (IMG) for Cost Center Accounting, under Master data → Resources → Define Resources → Display Resources.
Cost Center Planning (CO-OM-CCA)

Purpose

Cost center planning involves entering plan figures for costs [Ext.], activities [Ext.], prices [Ext.] or statistical key figures for a particular cost center and a particular planning period. You can then determine the variances from these figures when you come to compare these plan values with the costs actually incurred. These variances (see: Variance Calculation [Page 848]) serve as a signal to make the necessary changes to your business processes.

Cost center planning forms part of the overall business planning process, and is a prerequisite for standard costing. The main characteristic of standard costing is that values and quantities are planned for specified timeframes, independently of the actual values from previous periods.

You can take plan costs and plan activity quantities to determine the (activity) prices. These prices can be used to valuate internal activities during the ongoing period, that is, before the actual costs are known.

Cost center planning has the following objectives:

- To plan the structure of the organization’s future operations for a clearly defined time period.
  
  You should define performance targets and target achievement grades. You must consider the internal and external (market) factors affecting your organization.

- To control business methods within the current settlement period.
  
  This ensures that you keep as closely as possible to the plan. Iterative planning lets you adapt the target performance to reflect any changes in the organizational environment.

- To monitor efficiency after completion of the settlement period using plan/actual or target/actual comparisons.

- To provide a basis for the valuation of organizational activities, independent of random fluctuations.

For more information, see:

Short-Term Organizational Planning [Page 179]

Reconciliation of Cost Center Planning With Other Applications [Page 181]
Short-Term Business Planning

Use

Cost center planning is a component of short-term business planning. Short-term refers to a planning horizon for the duration of a fiscal year. In short-term business planning, you create the following sub-plans:

- One or more sales plans
- One or more master production schedules
- One or more cost plans
- One or more operating profit plans

The planning process combines the individual planning areas into an integrated planning network.

The following figure shows how the individual planning areas are linked to one another.
Sales Plan

The starting point for short-term planning is the sales plan. It establishes the quantities to be sold in the planning period. Generally, the sales plan is created by Sales and Distribution (SD) and Controlling (CO). The plan sales volumes are forwarded to Production Planning (PP) because this module reconciles plan capacities and activities.

Master Production Schedule

The master production schedule is worked out in close coordination with the sales plan. The master production schedule determines both the capacities and the quantity requirements for raw materials and operating supplies. The plan activities established here are forwarded to the cost centers which must supply these capacities in the form of units of activity. Moreover, the cost center managers must plan the costs to be incurred and the activity quantities to be taken from other cost centers based on the plan capacities and activities.

Cost Center Plan

Cost center planning consists of the following areas:

- Planning of activity quantities and/or prices
- Planning of costs expected to be incurred
- Planning statistical key figures, which are used as the basis for the allocation of costs

Together with sales planning, cost planning is the starting point for sales and profit planning.

Sales and Profit Plan

You can calculate revenues based on the planned sales volume and prices, from which the plan contribution margins can be derived. To do this, the revenues are compared with the plan costs.

Financial Budget

Interdependencies exist between cost, sales, and financial planning. The financial planning can trigger a restrictive effect on production planning and cost center planning.
Reconciliation of Cost Center Planning With Other Applications

Use
Cost center planning is a sub-area of the overall business planning. For this reason, the integration and reconciliation of cost center planning are of particular importance.

During planning you must manually reconcile the data in the various application components.

The following areas must be reconciled:
- Planned activities and capacities with the activities and capacities of Production Planning (PP)
- Material costs with Materials Management (MM)
- Maintenance costs with Plant Maintenance (PM)
- Accrual costs with Financial Accounting (FI)

The following costs can be transferred:
- Personnel costs from Human Resources (HR)
- Cost accounting depreciation from Assets Management (AM)
- Key figures from the Logistics Information System (LIS)
Reconciliation of Cost Center Planning With Other Applications

- Activity requirement from Production Planning (PP)

See also:

- Transferring Plan Values from Other Application Components [Page 442]
- Short-Term Organizational Planning [Page 179]
- Reconciliation of Cost Center Planning With Other Applications [Page 181]
Cost Center Planning Scope

Cost center planning is divided into the following planning areas:

• Cost elements/activity input
  – Primary costs
  – Secondary costs
  – Revenues

• Activity type planning/price planning

• Statistical key figure planning

The following graphic provides an overview of the different planning areas:
Statistical key figures can be planned for different purposes, for example, as a basis for distribution, assessment, or creating key figures in the information system. You can plan statistical key figures on cost centers or on the activity types of the cost centers. In addition to manually planning statistical figures you can also transfer statistical key figures from the Logistics Information System (LIS). For more information, see Processing Statistical Key Figures [Page 170] and Logistics Information System [Page 594].

In activity type planning, you plan the activity produced by a cost center. This represents the quantity-based output of a cost center. During planning you can manually set the price with which the SAP system valuates the activity during allocations. You can choose to retain this price or have the system overwrite it during plan price calculation. You can also plan the capacity required for providing the activity type.

The input side of the cost center is affected when the primary and secondary cost values are planned. The primary and secondary plan costs refer to the costs incurred in producing the plan output on the cost center.
Value-based cost planning can be executed manually or automatically. For the automatic planning of primary costs you can use plan distribution (see Distribution [Page 709]).

For automatic planning of secondary costs, you can use assessment. The SAP system determines the planning values on the basis of user-defined rules. For planning purposes, you can transfer primary costs to cost center planning from Human Resources and Asset Accounting (see: Transferring Planning Values From Other Components [Page 442]).

The quantity-based planning of secondary costs is based on the consumption of activity, which the SAP system valuates using the corresponding activity type price. The planning of secondary costs by quantity (that is, activity input planning) can be done manually or automatically using indirect activity allocation (see Indirect Activity Allocation [Page 713]). The SAP system determines the activity quantities according to the receiver tracing factors.

Activity input enables extra planning detail: You can plan primary and secondary costs both independently and dependently of activity.

For manual cost planning the SAP system provides a variety of special planner profiles for the various planning areas. These profiles are tailored to specific planning projects and contain suitable planning layouts (input screens for planning).

In one planner profile you can collect planning layouts grouped according to various criteria.

For more information, see also the Implementation Guide (IMG), under Controlling → Controlling → Cost Center Accounting → Planning → Manual Planning → User-Defined Planning Layouts [Ext.]. Cost center planning in the standard SAP system contains a planning layout designed for a specific planning area for each planner profile.

Planner profile SAP101 contains a planning layout that can be used both for activity-independent and activity-dependent primary cost planning.

For more information about using planner profiles and planning layouts, see the IMG under Controlling → Cost Center Accounting → Planning → Manual Planning → Create User-Defined Planner Profiles [Ext.] as well as in Structuring the Planning Screen [Page 319].
Activity-Independent and Activity-Dependent Cost Planning

Use

Activity-independent cost planning covers both primary and secondary costs, but does not refer to a specific activity type. The opposite to this is activity-dependent planning.

Activity-dependent planning of primary and secondary costs enables you to plan both fixed and variable costs. You may require this functionality if your costing system uses flexible standard costing based on marginal costs. It is also possible to carry out flexible standard costing based on full costs or marginal costs.

Standard costing based on full costs means that the fixed costs are distributed in proportion to the operating level. This could mean that portions of fixed costs are included in the prices. You can assign plan activity-independent costs to activity types using various rules, for example, using equivalence numbers or your own splitting rules (see: Plan Cost Splitting [Page 481]).

Standard costing based on marginal costs means that the fixed costs included in the prices are not proportional to the operating level. If you want to use prices based on full costs for your marginal costing, as well as purely proportional prices, you must assign to the cost objects the fixed costs of the sender cost centers in addition to allocating the variable costs of internal activity allocation. Because the fixed preparation costs are not proportional to the operating level, you should not allocate them in a marginal costing system based on the activity output of the sender cost centers.

Predistribution of Fixed Costs [Page 371] enables you to distribute the fixed costs in full to the cost centers that have planned activity input. The following prerequisites apply:

- Within an agreed activity plan, the sender cost centers provide activity quantities because other cost centers have planned to consume them.
- The sender cost center has not caused the fixed costs for the provision of these activities.
Integrated Planning for Internal Orders

Features

Integrated planning for Internal Orders with Cost Centers or Business Processes

In integrated planning for internal orders, cost centers or business processes, you can integrate cost element and activity input planning for an internal order with cost center or business process planning. You can do this in a plan version. All the planned business allocations on the internal order (also repostings, assessments and so on) are then automatically updated on the sender/receiver cost center, or on the sender/receiver business process.

You can only use integrated planning for Internal Orders with Cost Center Accounting or Activity Based Costing, if the internal order already exists at the time of cost center or business process planning. You cannot lock the plan version. You can only plan locally for internal orders that are not plan-integrated. The same applies to internal orders that did not exist when you planned the cost centers or business process. You can also manually plan costs and activities on receiver cost centers or business processes, when required.

For more information, see:

- Planning Order Costs on Cost Centers [Page 238]
- Cost Center Planning [Page 178] for planning on cost centers.
Cost Center two plans to take 2000 production hours from cost center one, using an internal order. The planning of activities on the cost center and internal order can be integrated, because the internal order already exists in the system, and the same time horizon is planned. If integrated planning is active, the scheduled activity for the order is updated on cost center one. The settlement of the internal order in the plan is updated on cost center two (the receiving cost center).

Cost center three plans to take 700 production hours from cost center one. No internal order exists at the time of cost center planning. The internal order is created later and so cannot be integrated into planning. You need to execute cost center planning manually, and independently from order planning.

**Integrated Planning of Internal Orders with Profit centers, and the Extended General Ledger**

If you activate integrated planning with Profit Center Accounting and the Extended General Ledger, the system transfers planning data for internal orders and Cost Center Accounting to Profit Center Accounting and the Extended General Ledger.
You need to activate the *Integrated Planning* indicator in the version. This ensures that the system makes the planning data for internal orders available to other applications in the SAP system.

**Activities**

For more information on activating integrated planning for internal orders, see [Integrated Planning Indicator in Versions [Ext.]](Ext).
Line Items and Integrated Planning

If you distribute plan data from CO-OM-CCA to other applications (such as Special Purpose Ledger or Profit Center Accounting), and you want to record line item documents for each change in plan data, activate the plan integration indicator, which automatically activates line items.

⚠️

The plan integration indicator is found in various components, including Cost Center Accounting, Activity-Based Costing, and Overhead Orders. Changes to the indicator in one component applies to all other components.

See also:

Activating Line Items and Integrated Planning [Page 191]
Activating Line Items and Integrated Planning

Procedure

You can set *Integrated planning* either:

- In version maintenance as part of fiscal-year-based parameters
  
  a) To do this, call up the Implementation Guide (IMG) for Controlling, under *Overhead Cost Controlling* → *Cost Center Accounting* → *Planning* → *Basic Settings* → *Maintain Versions [Ext.]* or *Controlling* → *Activity-Based Costing* → *Planning* → *Maintain Versions [Ext.]*
  
  b) Select *Integrated planning* under *Settings for fiscal year*.

  You can select or deselect *Integrated planning* in version maintenance only if no plan data exists in the R/3 System.

- In cost center planning
  
  If plan data exists, you can select *Integrated planning* in the Cost Center Accounting initial screen as follows:

  Choose *Accounting* → *Controlling* → *Cost centers* → *Planning* → *Planning aids* → *Activate integration*.

  This function ensures that.

  - All existing plan data records for controlling area/version/fiscal year are updated as line items. The R/3 System transfers these line items to the FI/CO interface.
  
  - The R/3 System transfers any existing line items from plan allocation (assessment, distribution, or accrual cost calculation) to the FI/CO interface.

  You can only deactivate *Integrated planning* if no plan data exists.

- To avoid system performance problems, select *Background processing*.

- If the integrated planning run is terminated by the R/3 System, you can continue the integration in a second run. Note, however, that the corresponding plan version remains locked until integration has been completed.

- Select *Test run* if you do not want to update the results immediately.
Planning Flow in Cost Center Planning

Cost center planning is handled differently in almost every business organization. The type of industry, organizational structures, and responsibilities are factors affecting planning.

In the Cost Center Accounting (CO-OM-CCA) application component, the entire planning process can be performed online. The advantage of online planning is that it provides immediate results, which you can analyze using the information system. Interactive cost center planning is supported by the following planning tools in the SAP system:

- Planning is based on predefined planning layouts in the standard system, which are saved in planner profiles (see: Planner Profiles [Page 321], and the Implementation Guide (IMG) under Controlling → Cost Center Accounting → Planning → Manual Planning → Maintain User-Defined Profiles [Ext.]). Planning layouts are entry screens for planning. They are subdivided into planning areas, such as cost elements or activity type planning. You can create your own planning layouts using Report Painter (see: Report Painter [Ext.]) if the standard planning layouts do not meet your requirements. For more information, see also the Implementation Guide (IMG), under Controlling → Cost Center Accounting → Planning → Manual Planning → User-Defined Planning Layouts [Ext.].

- The planning process is not a one-time event, but an iterative process which usually goes through several cycles. This is reflected in plan data storage: The SAP system allows you to save different versions at the same time (see also Planning and Multiple Valuations in More Than One Version [Page 307]).
Planning Sequence

Purpose
There is no fixed sequence for cost center planning. However, SAP recommends certain guidelines. The following sequence is just one possible alternative.

Process Flow

Activity type planning
SAP recommends you begin with activity type planning or allocation base planning since the plan activity quantities and capacities determine the plan volume of costs. The system refers all cost center costs to the activity types, and then calculates the prices for each activity type. You can also plan prices during activity type planning. The prices are not determined by the system in this case. As well as activity quantities and prices, you can also plan equivalence numbers during activity type planning.

When the activity types are further allocated, the system credits the cost centers according to the activity they provide. This requires the determination and setting of plan prices after cost center planning is complete. Only then can the cost centers be completely cleared of costs. Price calculation therefore represents the final stage of cost center planning (see: Plan Price Calculation [Page 485]).

Planning statistical key figures
Following activity type planning, you can start planning statistical key figures. These are figures that the system uses as the basis for plan distribution and plan assessment.

You can also execute actual distribution, actual assessment or indirect activity allocations based on the planned statistical key figures.

Primary cost planning
You generally plan primary costs after planning activity units or capacities so as to reflect the activity volumes. For more information, see: Planning Scope: Overview [Page 183].

Manual Primary Cost Planning
Costs for activity quantities/capacities incurred due to external procurement or material issues must also be planned. You enter these costs online by cost center/cost element. For more detailed cost center planning below the cost element level, you can use base object costing (see: Detailed Planning of Cost Elements [Page 255]).

You can plan primary costs as:

- Activity-independent
- Activity-dependent

You can split the activity-dependent primary costs into fixed and variable costs. The SAP R/3 System updates the activity-independent costs entirely as fixed costs.
Planning Sequence

Resource Planning
Resource planning is a planning aid that allows you to plan activity-dependent and activity-independent primary costs or revenues based on quantities. You use resource planning if only the quantities of the consumed resources are known.

Dependency Planning
Dependency planning is a planning method that enables you to represent simple proportional relationships with a view to calculating both activity-independent and activity-dependent costs.

Planning Primary Order Settlement Costs on Cost Centers
You can manually plan the order costs on receiver objects for non-planning integrated orders (see: Planning Order Costs on Cost Centers [Page 238]).

Revenue Planning
As well as costs, you can also plan anticipated revenues under special cost elements (see: Revenue Planning [Page 240]).

Planning Statistical Cost Elements for Balance Sheet Accounts
You plan statistical costs for balance sheet accounts to control order or project budgets when you acquire fixed assets that are directly capitalized.

Automatic Primary Cost Planning
In addition to manual planning of primary cost you can also plan primary costs based on predefined rules. In this case, the SAP R/3 System calculates the plan values based on your specifications.

Plan Accrual Calculation
After you have manually planned the primary costs, the next step is to plan accrual costs. You plan the accrual costs on the relevant costs centers using percentage rates.

Before planning the accrual costs, you must first define delimiting parameters. In most cases these are identical to the actual accrual parameters. For more information, see Accrual Calculation [Page 561].

Plan Distribution
Plan distribution is the final activity of primary cost planning. You plan the primary costs for the entire fiscal year on allocation cost centers. The system periodically distributes these costs, for example, telephone costs, heating costs or rent, to the individual cost centers according to predefined keys.

Before distributing plan costs, you must define distribution rules. In most cases these are identical to actual distribution rules. For more information, see: Distribution [Page 709].

Periodic Reposting in Planning
Periodic reposting represents a posting aid for the adjustment of any incorrect postings. You can execute these postings at different times than the other business transactions (see: Periodic Reposting [Page 359]).
Secondary cost planning

When you have completed primary cost planning, you carry out secondary cost planning. This can be executed value- or quantity-based, manually or automatic.

Manual Secondary Cost Planning

With manual secondary cost planning you can plan secondary costs by value as activity inputs. You can plan the following: Planning Secondary Costs [Page 242].

- Activity-independent activity inputs
- Activity-dependent activity inputs

If you plan activity types manually, the system automatically generates a preliminary credit record for the sender cost centers. The system posts this credit record using a secondary cost element stored in the activity type master record. You can overwrite this secondary cost element during activity type planning. If the system is to calculate the prices iteratively, the system valuates the activity type after calculating the price and generates a credit record. As activity is consumed, the system reduces the credit record by the activity quantity received, valuated using the price of the activity type.

You plan 10,000 hours of the activity type Lathing on cost center 4210. One activity unit has a total price of $45 and is allocated using cost element 620000, Internal activity allocation to production. The system generates a credit record of $450,000 on cost center 4210 under cost element 620000. An activity input of 100 hours of the activity type Lathing reduces the preliminary credit record by 100 hrs X $45/hr = $4,500.

Planning Secondary Order Settlement Costs

You can manually plan the order costs on receiver objects for non-planning integrated orders (see: Planning Order Costs on Cost Centers [Page 238]).

Planning Credits From Overhead Costs

To enable a plan/actual comparison for non-planning integrated orders, you can manually plan the credits on the cost centers that exist in the actual as credit objects for overhead costs on orders (see: Planning Credits from Overhead Costs [Page 250]).

Automatic Secondary Cost Planning

Automatic secondary cost planning lets you plan value-based secondary costs using plan assessment, or quantity-based using indirect activity allocation.

Plan Assessment

Plan assessment is used to plan value-based secondary costs. You can assess the primary and/or secondary cost elements cumulatively, or in groups, according to user-defined rules. You must define assessment rules before executing plan assessment. In most cases they are identical to actual assessment rules. Plan assessment cannot start until these rules are defined (see: Assessment [Page 711]).
Planning Sequence

Indirect Activity Allocation

Indirect activity allocation is used for the automatic allocation of actual and plan activities. You can specify keys to allocate activities, which is not possible when you use manual activity input in the plan or actual activity allocation (see: Indirect Activity Allocation [Page 713]).

Plan Reconciliation

Plan reconciliation enables you to check and reconcile the exchanges of internal activity. The system adjusts the activity quantity planned for a cost center to the scheduled activity of the receiver cost centers (see: Plan Reconciliation [Page 381]).

Price Calculation

Iterative price calculation is the final stage of the planning process. All the previous planning transactions are taken into account. The SAP System calculates the prices of your activity types for each cost center in multiple iteration steps. The system then uses these prices to valuate the activity relationships (see: Plan Price Calculation [Page 485]).

Budget Planning

You can carry out cost center budgeting at any time, independent of the other planning steps. Budget planning does not use the data of the other planning steps, which means that you execute it at any time within your planning process. Budget planning provides you with an additional tool for cost control. You can analyze budget variances in a budget report (see: Cost Center Budget Planning [Page 253]).

Transferring Planning Data from Other Components

Integrated planning enables you to copy data stored in Cost Center Accounting into your cost center planning from any of the following application components:

- Depreciation and interest from FI-AA
- Personnel costs from HR
- Planned activity from PP
- Key figures from LIS
Changing the Planning Sequence

Use

The sequence described here represents an ideal planning situation. You can change this sequence at any time.

Activity type planning, for example, may be unnecessary if either there is no direct internal activity allocation using activity types or your planning is activity-independent only.

You can switch the sequence of plan accrual calculation and plan distribution.

- If you start plan accrual calculation first, the (plan) accrued amounts can be distributed during plan distribution.
- If you start plan distribution first, the (plan) distributed amounts can be processed during plan accrual calculation.

If you change the (planned) primary costs after executing plan assessment, you may have to repeat plan accrual calculation, plan distribution, and plan assessment.

Price calculation should always be the final task in your planning process. If you run price calculation before all planning transactions have been executed, the prices will be incomplete. You must repeat price calculation if you make any subsequent changes to your planning.

⚠️

Price calculation and assessment are iterative processes. This means that a cost center can be debited with costs after assessment if there are cyclical activity relationships between cost centers. If price calculation is already completed, the costs from assessment may not be taken into account. To ensure that price calculation covers all costs, you should repeat the assessment and price calculation manually until all cost centers have been fully credited.
Currencies in Planning

Use

Currencies can be updated for both plan and actual values. The use of more than one currency must be allowed in the controlling area.

You can plan in the following currencies:

- Controlling area currency [Ext.]
- Object currency [Ext.]
- Transaction currency [Ext.]
- Currency of the user’s choice

The controlling area is always used, regardless of whether you have selected All currencies in the control indicators for your controlling area.

You specify the object currency in the master data of the given planning object, for example, a cost center. The object and transaction currencies are only active if you have selected All currencies in the controlling area for the relevant fiscal year.

You can select any permitted currency as the transaction currency. The system always derives the value date and the exchange rate type from the fiscal-year dependent data of the version.

User-Definable Currency

In addition to planning in controlling area, object or transaction currencies, you can also plan in a currency of your choice. You can also translate your plan values, for example, into euro. You can include the user-definable currency in additional columns or rows of the planning layout for cost element planning. You can then display or maintain this currency.

If you have made a change to the exchange rates between two planning meetings for activity input (for example, due to the EURO changeover), this may cause large differences between the values in the object currency for the receiver, and for the sender, even though both have the same currency.

This is due to the fact that the system does not revaluate when the exchange rates change.

To avoid data inconsistencies, you can create a new version as a buffer, and copy your prices into it.

Then copy the prices back to your original version.

You need to copy the objects as well as the prices for orders and projects that are not plan integrated.

The following key figures are available for plan values in user-definable currency:

- Planned fixed costs
- Planned variable costs
Currencies in Planning

- Planned total costs
- Actual total costs

If the appropriate rows or columns exist in the planning layout, you can set your user-definable currency in the initial screen for manual planning. Choose Settings → User-definable currency.

If you use the user-definable currency, you can enter the following attributes:

- Currency
- Exchange rate type
- Value date for the translation

If you do not specify a currency, the system uses the controlling area currency. If you do not enter an exchange rate type, the SAP R/3 System derives the exchange rate type and the value date from the fiscal-year dependent version parameters.

You can make default settings for your user-definable currency in Customizing for Cost Center Accounting or Activity-Based Costing. Choose Planning → Manual Planning → Create User-Defined Planner Profiles.

You can also define the relevant Set/Get parameters as user parameters in your user master data.

The SAP R/3 System translates into the user-definable currency, or from the user-definable currency into controlling area currency, regardless of whether you have selected All currencies in the control indicators for the controlling area.

The SAP R/3 System does not write the user-definable currency to the database when postings occur.

Currencies in Planning Layouts

If you do not use the transaction currency as a characteristic in your planning layout:

- The SAP R/3 System automatically uses the object currency for newly created planning records
- As of Release 4.0, the system updates the accumulated plan and actual costs in controlling area and object currencies across all data records, even if the costs were updated under different transaction currencies.

If you change these accumulated costs, the system updates under the transaction currency corresponding to the object currency, if such a record already existed. Otherwise, the update is executed using the first transaction currency that the system finds in the database.

You can only include the key figure “Actual costs in transaction currency” in those planning layouts that use the characteristic “Transaction currency”.

If you plan in the transaction currency, the system automatically translates the plan data to cost center and controlling area currency during the planning process.

When planning in different currencies, the planning results are always stored in transaction currency, object currency, and controlling area currency.
You plan raw materials on cost center 4210 in Japanese Yen JPY (the raw materials come from Japan, and are invoiced in Yen). However, you plan personnel costs in US dollars USD.

The following situations might exist:

1. You want to plan in USD only
   Enter USD as the transaction currency.

2. You want to plan in JPY only.
   Enter JPY as transaction currency.

3. You want to plan in both currencies.
   Enter an asterisk (*).
Checklist for Planning in Cost Center Accounting

Use
Before you start to plan, you should clarify the following:

Distribution keys
Do you require your own distribution keys?
- Create your own distribution keys if necessary (see also: Distribution Keys [Page 311]).

Planner Profiles and Planning Layouts
Do the planner profiles and planning layouts meet your planning requirements?
- Check the planner profiles and planning layouts in the standard R/3 System and define new ones if necessary (see also: The Implementation Guide (IMG) for Controlling, under Overhead Cost Controlling → Cost Center Accounting → Planning → Manual Planning → User-Defined Planning Layouts [Ext.] or Maintain User-Defined Planner Profiles [Ext.]).

Currencies in Cost Center Planning
Do you need to plan in different currencies?
- Specify the use of different currencies for the controlling area.
- Set the currencies in which you wish to plan or display costs in the planning layouts (see also: Currencies [Ext.], Currencies in Planning [Page 198]).
- Maintain the translation rates (see also: R/3 Customizing → Global Settings [Ext.]).

Versions
Do you want to create your own versions for alternative plans?
- Create new versions if necessary.
  (See also: Customizing for Cost Center Accounting under Planning → Basic Settings → Maintain Versions [Ext.])

Do you need to copy existing versions?
- You must authorize copying in the source versions to be copied.

Do you want to document changes in planning?
- You need to select Integrated planning in the relevant versions. If plan values do not yet exist, you can select Integrated planning to ensure that the R/3 System writes plan line items and transfers them to the FI/CO interface. If plan values already exist, you can arrange for the system to write the plan line items at a later date (see also: Line Items and Integrated Planning [Page 190]).

Detailed planning
For which cost centers/cost elements do you require Detailed Planning [Page 255]
Once you have planned an area using detail planning, you must always use detail planning for this area.
Manual Planning

Use

Manual planning covers the following planning areas:

- Planning statistical key figures
- Activity type planning
- Primary cost planning
- Secondary cost planning
- Budget planning
- Detailed planning

You plan activity types, statistical key figures and costs using the appropriate planning methods (see also: Techniques for Supporting Manual Planning [Page 306]). In the standard system, SAP provides planner profiles and planning layouts for the relevant planning area (see also: Structuring the Planning Screen [Page 319]). You can either use these profiles and layouts as they stand, or adapt them to meet your own requirements.

Unlike Periodic Allocations [Page 459] where the system determines the plan values once at period-end with user-defined rules, in manual planning you plan each value yourself.

Integration

Manual planning is implemented in other application components belonging to the SAP R/3 System.

<table>
<thead>
<tr>
<th>Application component</th>
<th>Information:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internal orders</td>
<td>Primary Cost and Revenue Planning [Ext.]</td>
</tr>
<tr>
<td>Activity-Based Costing</td>
<td>Manual Process Planning [Ext.]</td>
</tr>
<tr>
<td>Real Estate Management</td>
<td>Cost and Revenue Planning on Real Estate Objects [Ext.]</td>
</tr>
<tr>
<td>Project System</td>
<td>Manual Cost Planning in the Work Breakdown Structure [Ext.]</td>
</tr>
</tbody>
</table>
Manager's Desktop

Use

Manager's Desktop assists in the performance of administrative and organizational management tasks. In addition to functions in Personnel Management, Manager's Desktop also covers other application components like Controlling, where it supports manual planning or the information system for cost centers.

Prerequisites

- You use the HR system to manage your organizational structure.
- You created one or more positions. You can also enter the position directly in the organizational unit.
- You have assigned a position (that is also a chief position) to the user in question.
  - You have assigned a cost center to every position.
  For more information, see:
    - Organizational Plan Mode [Ext.] (new interface)
    - Expert Mode [Ext.] (old interface)
    - Organizational Management [Ext.]
- In Customizing for Cost Center Accounting, you assigned function codes [Ext.] to individual planner profiles and planning layouts.

Features

For the planner profiles and planning layouts selected, you can access manual planning from Manager's Desktop by branching to the HR system.

Activities

To plan using Manager's Desktop, proceed as follows:

1. Choose Human resources → Manager's Desktop → Costs + Budget.
2. On the right screen area, select the Cost center assignment tab strip, and choose an assigned cost center.
   
   Cost centers are indicated by a "K", positions by an "S", and organizational units with an "O".

3. In the structure tree, choose Controlling → Cost Center Accounting → Planning.
4. Select the type of planning you require, for example cost element planning, activity planning and so on.
   
   The system branches to manual cost center planning, whereby you can only choose (using function codes) from the planner profiles and planning layouts that you selected in Customizing.
For more information on Manager's Desktop, see the SAP Library under Human Resources → PA Personnel Management → Manager's Desktop [Ext].
Planning Statistical Key Figures

Use

Statistical key figures can be used:

- to determine business key figures on cost centers
  
  Costs per employee

- as a receiver base (key) for assessments and distributions

  You assess the cafeteria costs to individual cost centers within your organization, according to the number of employees.
  
  The telephone costs are distributed to the individual cost centers according to the number of telephones in each cost center.
  
  In this case, you plan the number of employees and the number of telephones on each cost center as a statistical key figures and enter them as actual values.

There are two different types of statistical key figures.

- Fixed values
- Total values

  In the overview screens for the planning of statistical key figures, the R/3 System displays the average values (not totals) for statistical key figures of category Fixed values.

You can plan statistical key figures as activity-independent or activity-dependent. Use planning layout 1 - 301 for activity-independent planning, and planning layout 1 - 302 for activity-dependent planning (see: Structuring the Planning Screen [Page 319]).

For more information on the automatic transfer of statistical key figures from the LIS, see: Processing Statistical Key Figures [Page 170] and Transferring Statistical Key Figures from the Logistics Information System [Page 694].

Actions

- Executing Statistical Key Figure Planning [Page 207]
- Executing Manual Planning [Page 263]
Planning Statistical Key Figures

1. Select a **standard planner profile** [Page 823]

   To set a standard planner profile, choose:

   - for applications belonging to Controlling (cost centers, internal orders, processes)
     `Planning → Set planner profile`
   - For Real Estate Management: `Controlling → Planning → Set planner profile`
   - For the Project System: `Financials → Planning → Costs in WBS → Set planner profile`

<table>
<thead>
<tr>
<th>Planning type</th>
<th>Standard profiles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity-independent planning of statistical key figures</td>
<td>SAP101, etc.</td>
</tr>
<tr>
<td>Activity-dependent planning of statistical key figures</td>
<td>SAP104</td>
</tr>
</tbody>
</table>

• To create a new plan, or to change an existing one, choose `Planning → Statistical Key Figures → Change`.

For more information about planning and changing planning screens, see [Executing Manual Planning][Page 263] and [Techniques for Supporting Manual Planning][Page 306]
Activity Type Planning

Use
Normally, each cost center provides a portion of the services in the activity process of the whole enterprise. This does not apply to cost centers that were created for allocation purposes only.

This portion of the activity process can be quantified into one or more activity types, depending on the cost center category. Activity types are used as a synonym of “Allocation base” as used in business publications.

Activity types are used to determine the quantity-based output of a cost center. The plan activity quantities of production and service cost centers must be reconciled with the master production schedule in logistics. This determines the required plan activity quantity, as well as the plan capacity.

Activity types are used primarily to control the activity quantities on the cost centers. This enables you to measure the operating rate or the rate of capacity utilization of a cost center.

The following examples describe how to plan measurable activity quantities. You can enter or confirm these activity quantities in the actual data. Valuating the activity quantities with either iterative or manual prices leads to secondary costs on the receivers (for example, cost centers or orders).

Production cost centers can usually measure their portion of the activity process exactly. The production cost center SF1 4210 manufactures semi-finished parts to produce machines that are sold to the external market. To do this, it uses the Lathing and Welding activities. These activities can be quantified and measured exactly so that each semi-finished part is to be lathed for 30 minutes and welded for 5 minutes. This means that the activity of this production cost center can be measured using the activity types Lathing minutes and Welding minutes.

Administrative cost centers cannot usually measure their portion of the activity process in the same way as the production cost centers. For example, the personnel cost center hires new employees for production, carries out payroll accounting, and conducts appraisals. Many administrative activities are performed on this cost center that cannot be quantified directly in terms of end products (= cost objects) sold to the external market.

In addition to manual planning of activity quantities, you can also use indirect activity allocation to plan activity quantities automatically. See: (Indirect Activity Allocation [Page 713])

Integration
In Cost Center Accounting, activity types can be defined uniquely using the bases "Plan activity", "Capacity", "Output quantity", "Price" and "Equivalence number".

The price can be either:
- Set manually,
Calculated iteratively (In this case, the SAP R/3 System considers all the activity relationships between the relevant cost centers).

You can also overwrite the default value of the activity type category from the activity type master data record (see: Activity Type Category [Page 148]). The SAP R/3 System saves the new activity type category in the fiscal year and version in which you are currently planning.

**Activity Type Planning and Plan Price Planning**

To calculate the prices iteratively, you need to set the price indicator for the activity type during planning. You need to select a planning layout for activity type planning that has the attribute Price indicator as a ready-for input field. You can, for example, do so in the standard planning layout 1-102, in standard planner profile SAP101 (see: Standard Planning Layouts [Page 328]). The default value for the price indicator, which is taken from the activity type master data, is set in the standard system so that iterative price calculation executed, based on the plan activity quantity (see: Price Indicator [Page 151]).

You can still set manual prices for each cost center/activity type combination. This can be necessary, for example, if the prices you require for price calculation are fixed within your company and are to be unaffected by any internal activity relationships. However, if you have set the price indicator to 1 (price calculation based on plan activity) the system allocates activity quantities using the iterative price. For more information on price calculation, see: Plan Price Calculation [Page 485].

**Activity Type Planning and Predistribution of Fixed Costs**

If you are using standard costing based on marginal costs, you do not allocate the fixed costs proportionally to the operating level. Instead, you use predistribution of fixed costs [Page 371] to ensure that the fixed costs are debited to the cost centers consuming the activity. In activity type planning you can overwrite the default value for the indicator Predistribute fixed costs in the activity type master data, if you have included this attribute in your planning layout. This indicator determines whether or not the fixed costs incurred (due to producing a given activity) are to be distributed in advance to the cost centers receiving the activity.

**Features**

During activity type planning, the SAP R/3 System creates a credit record (unspecified credit) that is posted using a secondary cost element. This credit record is always based on the planned activity quantity of an activity type and its price on the corresponding cost center. You can store this default value for the cost element in the master record of the activity type, and overwrite it for each cost center. This credit posting ensures that the sender cost center can be credited in full, irrespective of the planned activity inputs.

In the cost center report, the system displays a credit of the corresponding cost center, even if activity input was not yet posted.

With each activity input, the R/3 System reduces the credit on the sender by the activity quantity consumed.

During reconciled planning (planned activity quantity = total of the activity inputs), the unspecified credit record is equal to zero (quantity-based and value-based).
Activity Type Planning

The Plan activity and Capacity values are used in iterative price calculation and can be analyzed in the information system. In addition to these, you can plan an equivalence number. Equivalence numbers are weighting factors used to apportion activity-independent plan costs to the activity types. The activity-independent plan costs apportioned in this way are also used in iterative price calculation. For more information on equivalence numbers see Plan Price Calculation [Page 485].

You can define equivalence numbers for each period. The overview screen for activity type planning displays the average values of the equivalence numbers.

When you initially plan for part of the fiscal year, the system sets the equivalence figures to zero for the non-planned period. Therefore, you need to always check the values for the equivalence figures in the period screen.

You can select the following types of equivalence number:

1. The same equivalence number for all periods
   In the overview screen, enter distribution key 1 (equal distribution) for the equivalence number. If you want to change this value later, simply change the equivalence number in the overview screen.

2. Differing equivalence numbers in the individual periods
   Go to the period screen and enter separate equivalence numbers for each period.

See also:
Planning Activity Types [Page 211]
Executing Manual Planning [Page 263]
Executing Activity Type Planning

Procedure
To plan activity types:

- Select a standard profile, such as SAP101.
- Choose Accounting → Controlling → Cost centers → Planning → Activities/prices → Change.


Activities which cannot be planned, or only at great expense, do not have to be planned manually (activity type category 3). The activity quantities are calculated automatically through indirect activity allocation (see: Indirect Activity Allocation [Page 713]).

Result
The planning of quantifiable activities, which are valued using iteratively determined or manually set prices, leads to secondary costs on the receivers of the activity. The R/3 System updates these secondary costs under an allocation cost element defined in the activity type master data.
Primary Cost Planning

Use
Planning primary costs involves entering those costs that arise from the consumption of goods and services supplied to the organization from external (as opposed to internal) sources.

Primary costs include:
- Labor costs
- External services
- Material costs
- Operating supplies
- Accrual costs

These accrual costs either have different values in CO than in FI (imputed interest or depreciation), or are incurred at different times in CO than FI (special payments such as vacation bonuses, or irregular costs, for example, repairs).

Features
In primary cost planning, you can enter costs and consumption quantities for each cost center/cost element. This means that primary costs can be planned by quantity, as well as by value.

In primary cost planning, which is based on value, the system records only the plan costs for each cost element. To do this, use, for example, planner profile SAP101 and standard planning layout 1 - 101.

During primary cost planning that is based on quantity, you plan the consumption of goods and services that the organization procures from external sources. No valuation occurs. For example, you can use planner profile SAP101 and standard planning layout 1 - 101, which includes the characteristics Fixed consumption and Variable consumption for planning.

The unit of measure that you are using for planning is converted by the SAP System to the unit of measure that you specified for the corresponding cost element in the master record.

If you only know the quantities of the resources consumed, you also use resource planning [Page 219] to carry out a quantity-based primary cost planning using planner profile SAPR&R and standard planning layout 1 - 1R1. The SAP System executes the valuation using the prices you have stored.

Primary costs can be planned using different methods: The following methods are available:
- Manual primary cost planning
  - Activity-independent primary cost planning
  - Activity-Dependent Primary Cost Planning
- Automatic primary cost planning
- Plan distribution
- Planned results analysis

See also:
Manual Planning [Page 203]
Periodic Allocations [Page 459]
Activity-Independent Primary Cost Planning

Use

You plan activity-independent primary costs, subdivided by cost element, on the cost centers to which you later also assign the actual costs. Most cost elements are planned in this way (for example, material costs, raw material and operating supply costs, etc.).

If you want to further subdivide the plan total of each cost element, see Detailed Planning [Page 255] or Resource Planning [Page 219].

Detailed planning below the cost element level is useful, for example, if several items are summarized under one cost element.

See also:

Executing Activity-Independent Primary Cost Planning [Page 215]
Executing Activity-Independent Primary Cost Planning

Procedure

To plan activity-independent primary costs:

- Select a standard profile [Page 323], such as SAP101 or SAPALL.
- Choose Planning → Cost element/activity input → Change.

Choose Change to enter new primary costs or change existing ones. You can enter the plan total per cost element and if required, switch to the period screen to distribute the costs to periods in the fiscal year according to a standard distribution key or one created by yourself. In the period screen you can also distribute the period values manually.

Activity-Dependent Primary Cost Planning

Use

You plan activity-dependent primary costs as follows on a cost center(s)/cost center group:

- By cost element(s)/cost element group
- Based on the activity type(s)/activity type group

This means that you can plan a fixed amount and a variable amount for your primary costs. Variable costs are the costs incurred in producing a given activity, proportional to the quantity of activity produced. You can calculate target costs based on the costs split and the operating rate (actual activity quantity related to the plan activity quantity). Target costs for costs planned by value are comprised of:

- Plan fixed costs
- Plan variable costs adapted to the actual operating level (= target costs of the actual operating level)

See also: Variance Calculation [Page 848]
You plan salaries on a production cost center based on the manufacture of the finished product X. The planned activity type is *Production hours* FST. Your activity-dependent primary cost planning, for example, using planner profile SAP101 and standard planning layout 1 - 101) contains the following values:

Activity Type FST: 1000 hrs

<table>
<thead>
<tr>
<th>Cost element</th>
<th>Total costs</th>
<th>Fixed costs</th>
</tr>
</thead>
<tbody>
<tr>
<td>430000</td>
<td>$600,000</td>
<td>$200,000</td>
</tr>
</tbody>
</table>

To produce 1000 hours of activity type FST, costs of $400,000 are required. This amount represents the variable costs. The portion of fixed costs, $200,000, is incurred irrespective of the activity quantity.

For activity-dependent costs, which are planned based on quantity, the following formulas apply:

Variable target quantity = Variable plan quantity \* Operating rate

Fixed target costs = Fixed target quantity \* Fixed price

+ Variable target quantity \* Fixed price

+ Fixed target quantity \* Variable price

Variable target costs = Variable target quantity \* Variable price

See also [Target Cost Calculation](Page 866).

See also:

[Executing Activity-Dependent Primary Cost Planning](Page 218)
Executing Activity-Dependent Primary Cost Planning

Procedure

To plan activity-dependent primary costs:

- Select a standard profile [Page 323], such as SAP101 or SAPALL.
- Choose Planning → Cost element/activity input → Change.

Choose Change to change existing plans or to create new ones. In the overview screen you can enter the fixed and variable portion for each cost element. You use a distribution key to distribute the plan values on the individual fiscal year periods. You can select either a standard distribution key or a user-defined key. You can also distribute your period values manually on the individual periods using the period screen.

Resource Planning

Use

Resource planning is a planning aid. If you only know the quantities of consumed resources (see also: Resources [Page 174]), you can use resource planning to plan activity-dependent or activity-independent primary costs [Ext.] or revenues [Ext.] by quantity. You can carry out detailed planning of a cost element by subdividing the cost element on the basis of the resources. The SAP R/3 System valuates the given resource consumption with a price, which you can store separately in the system.

You can also link resources to a material [Ext.] or to a base planning object [Ext.]. This means that a resource or a base planning object has been entered in the resource master record. For the valuation of resource consumption during planning, the SAP R/3 System uses the price of the material, regardless of whether you have defined a price for the resource during pricing (see also: Pricing [Page 221]).

- During primary cost planning, you can plan resources on cost centers, cost center/activity type, orders and WBS elements.
- You cannot plan resources during overall planning of orders and WBS elements.

Resource planning differs in the following ways from activity input planning, which also provides a quantity-based planning approach:

- From where is the activity/resource input/taken from?
- Cost element, under which the consumption is posted

<table>
<thead>
<tr>
<th>Distinguishing characteristic</th>
<th>Activity input planning</th>
<th>Resource planning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin of the activity/resource</td>
<td>Internal</td>
<td>External</td>
</tr>
<tr>
<td>Cost element, under which the consumption is posted</td>
<td>Secondary</td>
<td>Primary</td>
</tr>
</tbody>
</table>

You can also copy resources together with the planning (see also: Copying Planning Values [Page 357]). The system copies only the consumption quantities. The system valuates the resource prices during the copying transaction. If the price of a resource in the target fiscal year is 2% higher than the price of the same resource in the source fiscal year, the costs in the target fiscal year will also be 2% higher than the costs in the source fiscal year.

You can also transfer resource consumption from an SAP external system into resource planning via the external data interface. For more information about the external data interface, see External Data Transfer [Ext.].
Resource Planning

Features
Resource planning contains the following functions:

- Price determination (see: Price Determination [Page 221])
- Manual planning of resources (see: Executing Resource Planning [Page 228])
- Revaluation (see: Revaluating Resource Planning [Page 229])

Price determination
You can specify the prices for the resource consumption valuation individually. You can also use pricing to specify criteria, combinations of criteria or define rules for determining prices.

Manual planning
SAP provides you with the standard planner profile SAPR&R. This planner profile contains standard planning layouts for resource planning on cost centers [Ext.], orders [Ext.] and WBS elements [Ext.].

For more information on planner profiles and planning layouts, see Planner Profiles [Page 321] and Standard Planning Layouts [Page 328].

Revaluation
When you change a resource price in price maintenance, the SAP R/3 System automatically recalculates your planning.

If, however, a resource refers, for example, to a base planning object, and the price of this base planning object changes, the system does not automatically execute a recalculation. In this case, you must recalculate the costs already planned using this resource. Only then can you ensure that your planning is up-to-date. (See also: Revaluating Resource Planning [Page 229])
Pricing

Use

You can specify the prices [Ext.] for the resource consumption valuation individually. You can also use price determination to specify criteria, combinations of criteria or define rules for determining prices.

The SAP R/3 System executes price determination using the condition technique. It enables you to adjust the access to the resource prices to meet your individual requirements. The system controls price determination using the following settings:

- Condition types
- Price tables [Ext.]
- Access sequences [Ext.]
- Costing sheets

In the standard system, SAP supplies price tables, access sequences, condition types and costing sheets. You can also define new, individual settings for price determination. For more information about Pricing, see the Implementation Guide (IMG) under Controlling → Overhead Cost Controlling → Cost Center Accounting → Planning → Resource Planning → Pricing Strategy [Ext.].

The following access sequences are stored in the standard access sequence K001:

- Price per cost center
- Price per controlling area
- Price per country/region

You must enter fiscal year and version as selection criteria. Other criteria, such as company code, controlling area, plant, cost center, region, and so on, you can define yourself.

Price table for the combination resource/region

<table>
<thead>
<tr>
<th>Resource</th>
<th>Region</th>
<th>Price in USD</th>
<th>Price unit</th>
<th>From per.</th>
<th>FYear</th>
<th>Vers.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power kWh</td>
<td>Chicago</td>
<td>0,22</td>
<td>100</td>
<td>01</td>
<td>1998</td>
<td>000</td>
</tr>
<tr>
<td>Power kWh</td>
<td>New York</td>
<td>0,20</td>
<td>100</td>
<td>01</td>
<td>1998</td>
<td>000</td>
</tr>
</tbody>
</table>

You specify the criteria resource and region in an access sequence. The R/3 System uses this to ensure that you can maintain one price per region for a resource. During price maintenance, the above-mentioned prerequisites apply for one price, regarding version, currency key and validity period.
Pricing

For example, for the resource “Power” in the Chicago region, price determination calculates a price of 0.22 USD in the entire fiscal year 1998 in version 000 for 100 kWh.

You can store prices in any currency and for any integral price units.

- Within one fiscal year and one version, the currency key for a resource must be the same.
- You can store prices for a version from a specified period of a fiscal year. The prices are then valid till the end of the fiscal year.
- You can maintain resource prices in resource planning. To do so, choose Planning → Cost and activity input → Change → Extras → Resource planning → Maintain prices.
Maintaining Resource Prices

Use
You use resource prices [Ext.] to valuate resource consumption in planning.

- You cannot edit scale prices in resource planning.
- If a resource in the master record (see also: Processing Resources [Page 176]) is linked to a material or a base planning object, you do not need to and cannot maintain prices.

Prerequisites
In the Customizing for your application, you specified a pricing strategy by choosing Planning → Manual Planning → Resource Planning → Pricing Strategy [Ext.] (see also Pricing [Page 221]).

Procedure
Once you have defined your pricing strategy, you then maintain resource prices as follows:

2. Select a condition type [Ext.] and choose Condition records from the tree structure.
3. Choose an access sequence [Ext.].
4. Enter the controlling area, version, and fiscal year.
5. Choose New entries.
6. Maintain resource prices by entering data in the following fields:
   a. Resources
   b. From period
   c. Amount
   d. Currency
   e. Price unit
   f. Unit of measure
7. Save your entries.
Copying Resource Prices

Use
If your resource prices are subject to only minor fluctuations, and you want to transfer values from previous years (or from another version) to your current planning, you can do this by copying either all or some individual resource prices.

Prerequisites
You have created resource prices.

Procedure
To copy resource prices, proceed as follows:
2. Define a template by maintaining the following fields:
   a. Version
   b. Fiscal year
   c. Resource from
   d. Resource to
3. If you want to copy resource prices (belonging to one or more resources) that are valid in particular periods only, choose Selection list.
   The system displays a list of the resources for the version and fiscal year selected.
   From this list, you can select the resources (with the corresponding validity periods and prices) for copying.
4. Maintain the processing option parameters:
   a. To copy large amounts of data, you should activate Background processing. This enables you to process data at times when system usage is at a minimum.
   Do not activate Background processing and Selection list at the same time.
   b. If you do not want data to be updated, select Test run.
   c. To check the results, activate Detail list.
5. Define a target by entering data in the following fields:
   a. Version
   b. Fiscal year
6. If you activated Selection list, you can select individual entries and copy them using the Copy prices key.
7. If you activated Selection list, you can select individual entries and copy them using the Copy prices key.

Result
The system displays a results list of the records copied.
Reevaluating Resource Prices

Use
If you expect changes to resource prices that apply to most if not all resource prices, you can reevaluate individual prices or all resource prices from a previous fiscal year.

Prerequisites
You have created resource prices.

Procedure
To reevaluate resource prices, proceed as follows:


4. If you want to reevaluate resource prices (belonging to one or more resources) that are valid in particular time periods only, choose Selection list.
   The system displays a list of the resources for the version and fiscal year selected.
   From the selection list, you can select the resources (with the corresponding validity periods and prices) that you want to revaluate on either a percentage basis or an absolute basis.

5. Maintain the processing option parameters:
   d. To copy large amounts of data, choose Background processing - this allows you to carry out processing at times of low system usage.

   Do not activate Background processing and Selection list at the same time.
   e. If you do not want data to be updated, select Test run.
   f. To check the results, activate Detail list.

5. If you have not activated Selection list, you can revaluate in one of the following ways:
   a. Percentage
      Choose the Percentage pushbutton and enter a revaluation percentage.
   b. Absolute
      Choose the Absolute pushbutton and enter an absolute value. Enter an absolute value - this will be either positive or negative, depending on whether you want to increase or reduce your prices.

6. If you activated Selection list, you can select individual entries and revaluate them as follows:
   a. Revaluate prices on percentage basis
      Enter a percentage rate for revaluation.
   b. Revaluate prices on absolute basis
      Enter an absolute value. Enter an absolute value - this will be either positive or negative, depending on whether you want to increase or reduce your prices.
Result

The system:

- Revaluates the selected resource prices according to your revaluation criteria.
- Displays a result list containing the reevaluated records.
Resource Planning

Prerequisites

If you want to carry out resource planning without adopting the standard planner profile SAPR&R, you must define your own planner profile and planning layout [Ext.].

Procedure

To plan primary costs at resource level, proceed as follows:

1. Select a planner profile for resource planning such as the standard planner profile [Page 323] SAPR&R.
   
   To do so, in your application choose Planning → Set planner profile.

2. Choose Planning → Cost element/activity input → Change.

3. Select a planning layout for resource planning.

To change existing plans or create new ones, choose Change. In the overview screen you can enter the fixed and variable plan consumption for a resource. You use a distribution key [Ext.] to distribute the plan values to the fiscal year periods. You can either select a standard distribution key or define your own. On the period screen, you can also distribute your period values manually to the individual periods.

If you have stored a price for the resource (see: Pricing [Page 221]) the system reevaluates the consumption using this resource price (see also Revaluating Resource Planning [Page 229]).

Reevaluating Resource Planning

Use
If a resource refers to a specimen [Ext.] or material [Ext.], and its price is changed, you must reevaluate resource planning manually.

Procedure
To reevaluate resources:
1. In the planning menu for your application, choose Cost/activity input → Change → Extras → Resource planning → Revaluate.
2. Specify which data is to be reevaluated.
3. To do this, maintain the following fields:
   a) Controlling area
   b) Version
   c) From period
   d) To period
   e) Fiscal year
   f) From resource
   g) To resource
4. Choose Execute.

Result
The SAP R/3 System posts the resource consumption using the updated price. You can check the results on the overview screen and on the period screen for planning.
Dependency Planning

Use

Dependency planning [Ext.] enables you to plan both activity-independent and activity-dependent primary costs based either on quantity or value, by using proportional dependencies between the object that causes costs and the required components. The system can calculate primary costs for a statistical key figure (activity-independent and dependent) and an activity type (activity-dependent only).

In the case of value-based or cost-based dependency planning, you plan activity-dependent or activity-independent primary costs per unit of a statistical key figure or activity type. Dependency planning that is value-based is typically used in administration. This is often time-consuming for determining proportional contexts. In this area, it is more usual to combine the different parts causing costs under a general term (office supplies for example) and to plan them per unit causing costs (employee for example).

In the case of quantity-based dependency planning, you plan the consumption of a resource per unit of a statistical key figure or activity type, for example Consumption of screws per car, or Consumption of lubricant per production hour. Total plan costs are equal to the consumption per activity unit or unit of a statistical key figure multiplied by the quantity of the object causing the cost (number of cars for example) and the valuation using the resource price. Quantity-based dependency planning is most commonly used in production, where simple proportional dependencies usually exist between finished products and the additional substances required.

You want to plan costs for manufacturing a car body. In addition to the many parts that go to form the body, you also require lubricant, screws and rivets, all three of which are defined as resources. In dependency planning, the system calculates the costs for the car bodies from the planned quantities of the individual car body components (metal parts, screws, rivets), the corresponding prices, and the quantity required in each case per car body (= dependency quantity).

You can determine the different types of planning such as cost or quantity-based planning, and activity-dependent or independent planning using the dependency type [Ext.] It specifies what the dependency price or dependency quantity relates to.

It can be one of the following values:

- 1

The dependency price [Ext.] or dependency quantity [Ext.] relates to the planned quantity of a statistical key figure that you planned on either an activity-dependent or activity-independent basis.

During activity-independent dependency planning, the system calculates planned costs using the (activity-independent) planned quantity of the statistical key figure. If no activity-dependent statistical key figure is planned, the system sets the statistical key figure value in planning to zero.

Under activity-independent dependency planning, the SAP System calculates planned costs using the activity-independent planned statistical key figure quantity.

The system updates the costs entirely as fixed costs.
The dependency price or dependency quantity relates to the planned quantity of a statistical key figure that you planned on an activity-independent basis.

Even if you plan activity-dependent costs using dependency type 2, the system always uses the activity-independent planned quantity of the statistical key figure to calculate planned costs.

Dependency planning using dependency type 2 is the equivalent of activity-independent dependency planning using dependency type 1.

The system updates the costs entirely as fixed costs.

The dependency price or dependency quantity is based on the planned quantity of an activity type. Dependency type 3 can be used only for objects that are to be planned on an activity-dependent basis.

The system updates the costs entirely as variable costs.

The dependency type is directly correlated to the dependency source type [Ext.]. It determines whether the system calculates planned costs and planned consumption using (a) activity-independent/activity-dependent planned quantities of statistical key figures or (b) planned quantities of activity types. The system enters the planned quantity for the dependency source type in the dependency source quantity [Ext.]

The system calculates planned costs per period.

If, per period, you defined different dependency prices, dependency quantities, or resource prices, note that these values are not displayed in the planning overview. The value displayed here is an average value. The values per period can only be viewed on the period screen for planning.

If you change the prices or quantities, the system revalues planning.

Additional, fixed costs that are not dependency-based can only be planned under the same cost element if you define additional resources, for example Additional fixed costs. You must enter a 1 for the resource price.

The following tables provide an overview of the planning options available to you in dependency planning:

| Cost-based dependency planning | Activity-independent | Activity-dependent |
### Dependency Planning

<table>
<thead>
<tr>
<th>Dependency type</th>
<th>1</th>
<th>2</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>Activity Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dependency source type</strong></td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Activity Types</td>
<td></td>
</tr>
<tr>
<td><strong>Fixed dependency price</strong></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
<td>Activity Types</td>
</tr>
<tr>
<td><strong>Variable dependency price</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>X</td>
<td>Activity Types</td>
</tr>
<tr>
<td><strong>Dependency source quantity</strong></td>
<td>Stat. key figure, activity-ind. or activity-dep.</td>
<td>Stat. key figure, activity-ind. or activity-dep.</td>
<td>Stat. key figure, activity-ind. or activity-dep.</td>
<td>Statistical key figure, activity-ind.</td>
<td>Activity Types</td>
<td></td>
</tr>
<tr>
<td><strong>Fixed planned costs</strong></td>
<td>Fixed dep.price X dep.source quantity</td>
<td>Fixed dep.price X dep.source quantity</td>
<td>Fixed dep.price X dep.source quantity</td>
<td>Fixed dep.price X dep.source quantity</td>
<td>Activity Types</td>
<td></td>
</tr>
<tr>
<td><strong>Variable planned costs</strong></td>
<td>0</td>
<td>0</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>Variable dep.price X dep. source quantity.</td>
</tr>
</tbody>
</table>

X = can be manually planned

### Quantity-based dependency planning

<table>
<thead>
<tr>
<th>Dependency type</th>
<th>1</th>
<th>2</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>Activity Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dependency source type</strong></td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Statistical key figure</td>
<td>Activity Types</td>
<td></td>
</tr>
<tr>
<td><strong>Fixed dependency quantity</strong></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>0</td>
<td>Activity Types</td>
</tr>
<tr>
<td><strong>Variable dependency quantity</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>X</td>
<td>Activity Types</td>
</tr>
<tr>
<td><strong>Fixed dependency price</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Activity Types</td>
</tr>
<tr>
<td><strong>Variable dependency price</strong></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>Activity Types</td>
</tr>
</tbody>
</table>
### Dependency Planning

<table>
<thead>
<tr>
<th>Dependency source quantity</th>
<th>Stat. key figure, activity-ind. or activity-dep.</th>
<th>Statistical key figure, activity-ind.</th>
<th>Stat. key figure, activity-ind. or activity-dep.</th>
<th>Statistical key figure, activity-ind.</th>
<th>Activity Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fixed plan consumption</strong></td>
<td>Fixed dep.quantity X dep.source quantity</td>
<td>Fixed dep.quantity X dep.source quantity</td>
<td>Fixed dep.quantity X dep.source quantity</td>
<td>Fixed dep.quantity X dep.source quantity</td>
<td>X</td>
</tr>
<tr>
<td><strong>Variable planned consumption</strong></td>
<td>0</td>
<td>0</td>
<td>X</td>
<td>X</td>
<td>Variable dep.quantity x dep. source quantity</td>
</tr>
<tr>
<td><strong>Resource price</strong></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td><strong>Variable planned costs</strong></td>
<td>0</td>
<td>0</td>
<td>Variable planned consumption x resource price</td>
<td>Variable planned consumption x resource price</td>
<td>Variable planned consumption x resource price</td>
</tr>
</tbody>
</table>

X = can be manually planned

**Dependency Planning: Examples [Ext.]**

### Prerequisites

Before you carry out dependency planning, you should have carried out the following functions:

- For cost-based dependency planning:
  - Statistical key figure planning or key figure transfer from the LIS (Logistics Information System) or key figure calculation using formula planning.
  - Activity type planning or activity transfer from PP, or indirect activity allocation

- For quantity-based dependency planning:
  - Statistical key figure planning or key figure transfer from the LIS (Logistics Information System) or key figure calculation using formula planning.
  - Activity type planning or activity transfer from PP, or indirect activity allocation
  - Resource definition, price maintenance, planning of resource consumption
Dependency Planning

You can also carry out dependency planning using data from non-SAP systems.

Features

Dependency planning involves the following:

- Manual planning of primary costs (see also: Dependency Planning [Page 235])
- Revaluation (see also: Revaluation in Dependency Planning [Page 236])

Manual planning

SAP provides you with the standard planner profile SAPR&R. This planner profile contains standard planning layouts for value-based and quantity-based dependency planning for cost centers.

For more information on planner profiles and planning layouts, see Planner Profiles [Page 521] and Standard Planning Layouts [Page 528].

If you carry out dependency planning and then call up cost planning with a planning layout that does not contain dependency price and dependency quantity, you cannot enter planned costs.

Revaluation

If you change the quantity of a statistical key figure or an activity quantity, the SAP System automatically reevaluates your planning.

Note however, that if you carry out dependency planning with values (statistical key figures, activity types) that you did not plan manually, the SAP System does not automatically revalue planning. In this case, you need to reevaluate costs already planned. Only then can you ensure that your planning is up-to-date.
Dependency Planning

Prerequisites
If you want to carry out dependency planning without using the standard planner profile SAPR&R and the standard planning layouts that this contains, you must define your own planner profile and planning layouts for value-based and quantity-based dependency planning.

Procedure
To plan primary costs at dependency level, proceed as follows:
1. Select a planner profile for dependency planning, for example the standard planner profile SAPR&R.
   To do so, choose Accounting → Controlling → Cost centers → Planning → Set planner profile.
2. Choose Planning → Cost element/activity input → Change.
3. Choose a planning layout for value-based or quantity-based dependency planning.
   To change existing plans or create new ones, choose Change.
You use a distribution key [Ext.] to distribute the plan values to the fiscal year periods. You can either select a standard distribution key or define your own. On the period screen, you can also distribute your period values manually to the individual periods.
If you change the dependency quantity or the dependency source quantity (quantity of a statistical key figure or an activity quantity) the system reevaluates costs and consumption (see also Reevaluating Dependency Planning [Page 236]).
Revaluation in Dependency Planning

Use

If you use statistical key figures, activity quantities, cost elements or prices in dependency planning that you did not plan manually or that you copied, the system does not automatically revalue your dependency planning.

You should revalue your planning manually if you:

- Imported statistical key figures or activity quantities into the system using the external data interface.
- Calculated statistical key figure quantities using formula planning
- Transferred statistical key figure quantities from the LIS (Logistics Information System) to cost center planning.
- Transferred activity quantities from PP to cost center planning.
- Calculated activity quantities using indirect activity allocation
- Calculates prices for activity types using price calculation

If you make the following changes to planning, the system automatically revaluates dependency planning after each change:

- Changes to manually-planned values
- Changes to planned values due to plan reconciliation
- Changes to copied plan values for cost elements

The system does not automatically revalue copied activity quantities and key figure quantities.

Procedure

To revaluate resources:

5. Choose Accounting → Controlling → Cost Center Accounting → Planning → Cost element/activity input → Change → Extras → Dependency planning → Revaluate.

6. Specify for which cost centers your dependency planning is to be reevaluated as follows:
   a) Single cost centers
   b) A cost center group
   c) All cost centers
   d) A selection variant [Ext.] that you define yourself
      – Enter a name for a selection variant.
Revaluation in Dependency Planning

− Choose Create or Change (depending on whether you want to create a new selection variant or change an existing one).
− Specify which data is to be revalued.
− Save your selection variant [Ext.].

7. Maintain the following fields:
   a) Version
   b) From period
   c) To period
   d) Fiscal year

8. Choose Execute.

Result

The system updates the revalued planned costs and the revalued planned consumption. You can check the results on the overview screen and on the period screen for planning.
Planning Order Costs on Cost Centers

Use

Using integrated planning of internal orders [Page 187] between internal orders and cost centers, you can manually plan order costs for non-planning integrated orders on the receiver cost centers. You have the following options:

- **Primary order costs, profile SAP101 or SAPALL**
  - Activity-independent
  - Activity-dependent

- **Secondary order costs, profile SAP104 or SAPALL**
  - Activity-independent
  - Activity-dependent

With secondary order cost planning, you can create planning records for each sender/receiver for one or for several settlement cost elements.

See also:

- Executing Primary Order Cost Planning [Page 239]
- Executing Secondary Order Cost Planning [Page 252]
Planning Primary Order Costs

Procedure

To plan primary order costs on cost centers, proceed as follows:

1. In Master Data Maintenance [Page 110], create a cost element for the internal settlement of order costs (that is, settlement to a cost center).

2. Enter these settlement cost elements in the selection criteria for the Cost element characteristic.

   This ensures that you can plan the settlement cost elements.

Select a standard planner profile [Page 223].

To set a standard planner profile, choose:

- For applications belonging to Controlling (cost centers, internal orders, processes) Planning → Set planner profile.

- For the Projects System, Planning → Controlling → Costs in WBS → Set planner profile.

2. In your application, choose Planning → Cost element/activity input → Change.

Revenue Planning

Use

In addition to costs, the production planner needs to account for anticipated revenues. The procedure for this planning is the same as for activity-independent primary cost planning. You plan revenues on cost centers using special cost elements. If you post revenues on cost centers, the values appear as statistical information only (see: Account Assignment of Controlling Objects [Ext.])

⚠️

Remember to use negative signs for values entered in revenue planning.

See also:

Executing Revenue Planning [Page 241]
Executing Revenue Planning

Procedure

To plan revenues, proceed as follows:

- Select the standard profile [Page 323] SAP 104 or SAPALL.

- Choose Accounting → Controlling → Cost centers → Planning → Cost element/activity input → Change.

You can plan cost elements of category 11 (revenue element) or 12 (sales deduction).

Secondary Cost Planning

Use

In addition to primary costs, secondary costs are often incurred during the production of cost center activity. This is because a cost center must often take activity from other cost centers to produce its own activity. Secondary costs on the cost center result from internal allocations, such as activity allocations or assessments.

To get meaningful periodic comparisons of plan and actual data, you must plan secondary costs as well as primary costs. You can plan secondary costs as value-based (assessment or order settlement) or quantity-based (activity input).

See also:
- Periodic Allocations [Page 459]
Activity-Independent Activity Input Planning

Use

In activity-independent activity input planning you plan the quantity of activity input to a receiver cost center independent of an activity type on this receiver center.

Features

The plan activity quantity consumed by a receiver cost center is multiplied by the sum of the fixed and variable prices of the sender cost center and the sender activity type. The R/3 System posts the resulting value as fixed costs under a secondary cost element for internal activity allocation.

The SAP R/3 System

- Credits the sender cost center with the amount resulting from the plan activity quantity multiplied by the price.
- Debits the receiver cost center with the total of the activity quantity received multiplied by the price.

If you did not set manual prices for all cost centers, and you are carrying out an iterative price calculation, the SAP R/3 System values the activity relationships between your cost centers during price calculation [Page 485] using the iteratively calculated prices.

Integration

The plan activity input can be compared with the actual activity quantities on the receiver cost centers, which you posted during internal activity allocation.

By valuating the planned activity input quantity with the plan price of the activity type, manually or iteratively, the R/3 System calculates the planned secondary costs on the receiver cost centers. These plan secondary costs can be compared with the actual secondary costs already posted (actual activity quantity multiplied by plan activity price). You can then determine any variances (see: Variance Calculation [Page 848]).

See also:

Executing Activity-Dependent Primary Cost Planning [Page 244]
Executing Activity-Independent Activity Input Planning

Procedure

To manually plan activity-independent activity inputs:

2. Select a standard planner profile [Page 323]
   To set a standard planner profile, choose:
   - For applications belonging to Overhead Cost Controlling (cost centers, internal orders, processes) Planning → Set planner profile
   - For Real Estate Management: Controlling → Planning → Set planner profile
   - For the Project System: Financials → Planning → Costs in WBS → Set planner profile

2. In your application component, choose Planning → Cost and activity inputs → Change
   On a receiver object or receiver group (for example a receiver cost center or receiver group) you plan the input of one or more activity type(s) or an activity group. In so doing, you specify the sending object (the sending cost center(s) or cost center group) and the sender activity type(s) or activity group.

Activity-Dependent Activity Input Planning

Use

With activity-dependent activity input planning you can plan secondary costs dependent on an activity type in the receiver. You plan the input of activity type Y of sender cost center A for activity type X of receiver cost center 1. Activity type Y of sender cost center A is required to produce activity type X on receiver cost center 1.

Features

The SAP System posts the planned debit of the receiver cost center under a secondary cost element for internal activity allocation. If you have not manually planned the prices during activity type planning, the SAP System calculates the debit for the receiver cost center using the iteratively calculated price.

The system:

- Credits the sender cost center by the amount of the plan activity quantity multiplied by the price (manual or iterative). This amount is split into a total amount and a fixed amount.
- Debits the receiver cost center with the product of the activity quantity received multiplied by the price. The example below illustrates how costs are split into fixed and total portions.

Receiver cost center 1 takes 300 hours of repair activity (REP) from sender cost center A. The following plan data results:

<table>
<thead>
<tr>
<th>Sender cost center A</th>
<th>Activity Type Planning</th>
</tr>
</thead>
<tbody>
<tr>
<td>AT</td>
<td>Total qty</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>REP</td>
<td>1,000 h</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Receiver cost center 1</th>
<th>Activity Input Planning</th>
</tr>
</thead>
<tbody>
<tr>
<td>AT</td>
<td>Quantity</td>
</tr>
<tr>
<td></td>
<td>fixed</td>
</tr>
<tr>
<td></td>
<td>var.</td>
</tr>
<tr>
<td>REP</td>
<td>100 h</td>
</tr>
<tr>
<td></td>
<td>200 h</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The debit to the receiver is calculated as follows:

- **Total debit**
  The total debit to the receiver for an activity type equals the credit to the sender for this activity type, that is, the total activity quantity input $\times$ overall price.

- **Fixed debits**
  The fixed debit to the receiver for an activity type is derived from the fixed activity input. The fixed activity input is incurred irrespective of the activity to be produced on the receiver cost center. The fixed debit is composed of two elements.
  
  a) The total activity quantity input multiplied by the fixed price.
     All costs that were fixed on the sender cost center remain fixed on the receiver cost center.
  
  b) The fixed activity quantity input multiplied by the variable portion of the price.
     The fixed debit is comprised of the total costs of the activity input **without** the variable costs (variable quantity of activity input multiplied by the variable price).

The credit to the sender is calculated as follows:

- Fixed credit
  Total quantity $\times$ fixed price

- Variable credit
  Total quantity $\times$ variable price

**See also:**
Planning Activity-Dependent Activity Input [Page 248]
Executing Activity-Dependent Activity Input Planning

Procedure

To plan activity-dependent activity inputs:

- Select a standard profile [Page 323], such as SAP102 or SAPALL.
- Choose Accounting → Controlling → Cost centers → Planning → Cost element/activity input → Change.

For a receiver cost center or cost center group you plan the input of one or more activity types (or an activity type group). Specify the sender activity type (group) and the receiver activity type (group). Before you can plan activity-dependent activity inputs you must select a suitable standard planner profile or define your own profile for activity input planning.

Link Between Activity Types and Activity Input Planning

Use

A direct link exists between activity type planning and activity input planning. This can have the following effects:

- If you change the price of an activity type, or if you change your activity type planning so that a new iterative price results, the SAP System recalculates all activity inputs on cost centers that have received this activity type.

- The SAP System updates the scheduled activity on the sender cost centers. The scheduled activity comprises the plan activity quantity of an activity type for all receiver cost centers and orders. When you plan the activity input of an activity type, the system identifies the total activity quantity used by the receivers as “scheduled activity”.

If the scheduled activity is not the same as the plan activity after activity input has been planned, then your planning may contain inconsistencies: The plan credit of the sender cost center that was posted by the SAP System as a preliminary credit to this cost center does not equal the total of debits on the receivers. This means that either more or less activity was used than was planned on the sender cost center. You should therefore carry out plan reconciliation [Page 381] after completing your planning.
Planning Credits From Overhead Costs

Use

You plan credits from overhead for orders that are not integrated into planning. To enable a plan/actual comparison you can plan the credits manually on the cost centers that appear under actual costs as credit objects for overhead costs on orders.

⚠️

You must enter the plan values a negative sign (-).

See also:

Executing Planning Credits from Overhead Costs [Page 251]
Executing Planning of Credits from Overhead

Procedure

To plan credits from overheads:

- Select the standard profile SAP 101 or SAPALL.
- Choose Accounting → Controlling → Cost Center Accounting → Planning → Costs/Activity input → Change.

Plan using cost elements of category 41.

Planning Secondary Order Costs

Procedure

To plan secondary order costs on cost centers, proceed as follows:

1. In master data maintenance, create a cost element for the internal settlement of order costs (that is, settlement to a cost center).

2. Enter these settlement cost elements in the selection criteria for the Cost element characteristic.
   This ensures that you can plan the settlement cost elements.

3. Select a standard planner profile, for example, SAPALL [Page 323]
   To set a standard planner profile, choose:
   - for applications belonging to Controlling (cost centers, internal orders) Planning → Set planner profile
   - For the Project System: Financials → Planning → Costs in WBS → Set planner profile

4. In your application, choose Planning → Cost and activity inputs → Change

Result

The system:

- Credits the sender cost center by the product of the plan activity input quantity multiplied by the price of the activity type.
- Debits the receiver cost center by this amount under a secondary cost element for the order cost settlement (category 21)
  If activity input from a cost center has been planned for an order, the system updates the scheduled activity and the resulting credit
- on the sender cost center for plan-integrated orders
- Does not update scheduled activity and resulting credits on the sender cost center for non-plan-integrated orders

⚠️ If you have planned activity input from cost centers for plan-integrated orders, you may not plan any secondary order costs on the receiver cost centers using secondary order cost planning. Otherwise, this would result in credits on sender cost centers being posted twice.
Cost Center Budget Planning

Use

Cost center budgeting provides a further method of planning in addition to primary cost and secondary cost planning. This tool enables you to carry out a comparison between actual postings and plan budgets. You can thus determine when the budget is exceeded and carry out timely availability checks. You can create budgets

- for a single cost center or
- for cost centers of a cost center group

You can see the budget data in a budget report [Page 189]. The budget report compares plan data, commitment data, and actual data (resulting from actual postings) as well as the allotted and available amounts.

Prerequisites

Before you can plan your budget, you must create a budget profile [Ext.] during Customizing for Cost Center Accounting. Alternatively, you may use an existing profile. You can change the following budget profile settings when you are planning your budget:

- Budgeting time frame
- Decimal places
- Scaling factor
- Distribution Keys
- Fiscal year or period values

See also:

Planning Budgets [Page 254]
Executing Budget Planning

Procedure

To execute budget planning, proceed as follows:


2. Enter a budget profile.

   - The budget profile parameters specification of:
     - The budgeting time period, in the past, or in the future
     - The starting year in which budget planning is to begin
     - The scaling and decimal places for the display of values in budget planning
     - Period planning or fiscal year planning
     - Default values for the distribution key.

3. Choose Overview screen to access the overview screen of the annual values. You can then change the budget of your cost center.
   - If you entered a cost center group in the initial screen of budget planning, you can choose Group structure y/n function to display or hide the group structure.
     If you choose Y, the system displays the top node of the group with the sum of all the planned budgets of the lower-level cost centers.
   - If you have selected period values in the budget profile, you can choose Period overview to switch from the list of annual values to the list of period values for a cost center.
     The R/3 System distributes the plan annual value to the individual periods according to the distribution key defined in the budget profile. You can change this distribution key in the period screen if required.

   You can only select true distribution keys. True distribution keys break down an annual value into monthly values, so that the sum of the monthly values equals the original annual value.

   - Choose Period values in the Annual values overview screen to display the individual period values for each cost center. You can select a given period, or view all the period values of a cost center or cost center group. Choose → Goto → Period → Select period/Next/Previous Period
Detailed Planning of Cost Elements

Use

Detailed planning enables you to perform detailed planning below the cost element level. This can be useful (during actual postings) where multiple actions and business transactions are totaled under one cost element. The following section contains an example of detailed planning:

Labor costs are recorded under cost element 420000. According to the plan, $368,700 are required. However, the labor costs are split according to employee category and period:

- $1000 are planned per period for employees in category A. This amounts to $12,000 per category A employee. Category B employees, however, are external, seasonal workers, for whom costs of $1,000 are planned for periods 1 to 3, and periods 10 to 12. This amounts to $6,000 per employee. Category C employees are temporary vacation workers, for whom you plan costs of $900 in periods 6 to 8. This amounts to $2700 per category C employee.

Integration

In detailed planning, you can also access base planning objects. Base object costing is an application in Product Cost Planning (CO-PC-PCP) that can in part also be used in Cost Center Accounting. Base object costing enables you to record the costs of a cost object that is comprised of various raw materials, internal services and semi-finished products. This means that you can combine frequently recurring activity types or cost elements, and include them in your primary cost planning.

The external service "Maintenance" is made up of several cost components. These consist of “Grinding”, “Oiling”, “Polishing” and “Quality assurance”. You can generate base object costing for the external service “Maintenance”, based on the above criteria.

For more information about base object costing, see the SAP Library under Controlling → Product Cost Controlling → Product Cost Planning → Reference and Simulation Costing [Ext.] or Working with Reference and Simulation Costing → Reference and Simulation Costing: Process → Creating Base Planning Objects [Ext.]
Executing Detailed Planning

Prerequisites

You access detailed planning by choosing Cost Center Accounting → Planning → Cost and activity inputs → Change/Display. Select a row for which you wish to apply detailed planning and choose Edit → Detailed planning → Change/display.

Features

Note the following when you use detailed planning in Cost Center Accounting:

- You can only execute detailed planning in the controlling area currency. Cost planning in a foreign currency is possible in detailed planning but only to a limited extent, since plan values in the transaction currency or object currency can only be determined from the controlling area currency. The planning results can be displayed in cost element planning in the transaction currency or in the object currency.

- The results of detailed planning can only be evaluated during cost center planning, not in the information system.

- If you plan costs and consumption once using detailed planning, they can not be changed again in cost center planning. They must always be changed using detailed planning. You can make changes only on the list screen and in the periodic distribution of detailed planning.

- If one period is planned using periodic allocation in detailed planning, you must plan the entire fiscal year using detailed planning.

- You can plan up to 16 periods in a periodic distribution using detailed planning.

On the detailed planning list screen you can enter an unlimited number of costing items in list form. Choose Edit to use the editing functions (such as, select, delete, cut, copy, insert, insert item, delete item).

You can make the following entries on here:

- Item categories
- Resources
- Plant
- Quantity
- Unit of measure
- Lot-size independent
- Total price (= price per unit of measure)
- Description
- Formulas

Choose Goto → Previous/next view to call up the different list screen views. The views have different column sequences on the list screen.
Item Category
The item category marks the items within costing according to their origins. It determines which type of costs can be planned for the costing item. You can control which entries are allowed for each costing row, and how the row is to be edited.

The system ignores entries in columns not supported by the item category.

The following item categories are available in Cost Center Accounting.

- **Item category “V”**
  Used to enter variable costs. You usually select this category when using detailed planning during primary cost planning.

- **Item category “B”**
  Used to refer to existing base object cost estimates.

- **Item category “M”**
  Used to perform costing for an existing material.

- **Item category “S”**
  Used to total all the costing items entered so far.

- **Item category “T”**
  Used to enter a single line of text

### Table of Item Categories in Cost Center Accounting

<table>
<thead>
<tr>
<th>Item category</th>
<th>Entries</th>
<th>SAP System result</th>
</tr>
</thead>
<tbody>
<tr>
<td>V (variable item)</td>
<td>Quantity, unit of measure, price</td>
<td>Total value</td>
</tr>
<tr>
<td>B (base object costing)</td>
<td>Name, quantity</td>
<td>Price, unit of measure, cost element, description, total value</td>
</tr>
<tr>
<td>M (material)</td>
<td>Material number, plant, quantity</td>
<td>Price, unit of measure, cost element, description, total value</td>
</tr>
<tr>
<td>S (sum)</td>
<td></td>
<td>Total of item values above this item, or the item values specified in a formula</td>
</tr>
<tr>
<td>T (text)</td>
<td></td>
<td>Description</td>
</tr>
</tbody>
</table>

Resources
The resource controls the origin of a costing item. Depending on the item category, you can enter different data:

- **Item category “B”** Enter a base planning object.
Executing Detailed Planning

**Item category “M”** Enter a material number

**Plant**

For item category “M” (material), enter the plant to which the material is assigned.

**Planned quantities**

If you make no other entries in periodic distribution for detailed planning (*Functions → Distribution*), the system distributes the quantities entered on the list screen equally among the plan periods. If rounding differences occur, the quantities are rounded down in the first periods and rounded up in the last periods (see also: Unit of measure)

**Unit of measure**

When quantities are distributed evenly across the plan periods, the unit of measure determines how the values are to be rounded up or down, as required. You define units of measure in Customizing (*Global Settings → Check Units of Measurement*). You also set the number of decimal places to which the quantities are to be displayed. Rounding is based on the defined number of decimal places. If rounding differences occur, the values are rounded down in the first periods, and rounded up in the last periods.

You plan 40 pieces at a price of $5 per piece. During definition of the unit of measure *PC*, you defined that values for this unit of measure are to be displayed without decimal places. The quantity is distributed evenly to the individual plan periods. Three pieces at $5 each are distributed in each of the periods 1 to 8, and four pieces at $5 each are distributed in each of the periods 9 to 12.

**Lot Fix**

If the quantity is to remain unchanged during lot size changes, enter “F” as the item indicator. This indicates the item as a fixed lot.

**Total price (= price per unit of measure)**

Used to enter the plan (anticipated) price per unit of measure. The system automatically multiplies this price by the plan quantity to get the total value of the costing item.

If you make no other entries in periodic distribution for detailed planning (*Functions → Distribution*), the list screen of detailed planning distributes the prices entered evenly among the plan periods, except for rounding due to the decimal places defined in the unit of measure.

**Formulas**

If you choose item category "S" (sum), you can enter a formula. For information about entering formulas, see the *SAP Library* under *Controlling → Product Cost Controlling → Product Cost Planning → Reference and Simulation Costing → Working with Reference and Simulation Costing → Creating Base Object Cost Elements → Entering Formulas for Costing Items [Ext.]*.

**Periodic Distribution for Detailed Planning**

The quantities and corresponding prices you entered on the detailed planning list screen are first distributed evenly to the relevant periods (except for rounding due to the decimal places defined in the unit of measure).
You can change this distribution using the periodic distribution of detailed planning. To do so, on the detailed planning list screen, choose Functions → Distribute. You can change the distribution by saving a different distribution key for the quantity and/or price in the field DK (distribution key) see Distribution Key [Page 311]. However, you can also plan quantities and prices manually for each individual period. The distribution key is then automatically set to 0.

The system calculates the average price and the total quantity based on the quantities and prices of the individual periods. The system also calculates the average price, weighted with the quantity.

If you change periodic distribution, the system transfers to the detailed planning list screen the total quantity and the average price, weighted with the quantity, of the costing item. The system uses the changed values for Quantity and Price to recalculate the Total Quantity. These changes take effect immediately on the overview screen and the period screen in primary cost planning.

You enter three costing items. Two are to be distributed evenly, and the third to be set in the last period. On the detailed planning list screen, you enter quantities and prices for the evenly-distributed costing items. You plan the quantities and prices of the other costing items in periodic distribution.

As soon as you make new entries on the detailed planning list screen, the system changes the periodic distribution. The entry made on the detailed planning list screen is redistributed evenly on the periods. The following section contains an example of periodic distribution of plan values using detailed planning:

Enter the following on the detailed planning list screen:
- Item category: V
- Quantity: 6
- Unit of measure: PC
- Price - total: 10,00 USD

The system calculates the total value to be $60.00.

Then choose Functions → Distribute and make the following manual distribution:

<table>
<thead>
<tr>
<th>Period</th>
<th>Price</th>
<th>Quantity</th>
<th>Quantity X Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>35</td>
<td>1</td>
<td>35</td>
</tr>
<tr>
<td>2</td>
<td>5</td>
<td>1</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>5</td>
<td>3</td>
<td>15</td>
</tr>
<tr>
<td>4</td>
<td>5</td>
<td>1</td>
<td>5</td>
</tr>
</tbody>
</table>

The system calculates a total quantity of 6 PC and an average price of $12.50 (= $50/4).

The average price weighted with the quantity is calculated as follows:

\[
\frac{($35.00 + $5.00 + $15.00 + $5.00)\text{PC}}{6\text{PC}} = $10.00.
\]
Executing Detailed Planning

On the detailed planning list screen, the weighted average price is displayed as *Total Price* and the total quantity as *Quantity*. These are used to calculate the *Total Value*. In this example, the values on the list screen do not change.

For more information, see [Reference and Simulation Costing [Ext.]].
Manual Planning Aid

Use
If you trigger an error message in cost center planning, or want to check your entries, you can get help from the following (under Extras) for the error analysis.

- **Error log**
  Detailed documentation of how you can remove errors relating to:
  - Master data
  - Combinations
  - Locked characteristic combinations
  - Integrated planning
    The system displays a list of objects that have errors. You should only use this function when you have saved your planning.
  - Undeleted planning records
    The system describes why a planning record was not deleted.

- **Group display**
  List of selected groups (see also: Processing Master Data Groups [Page 38]):
  - Cost Center Groups [Page 146]
  - Cost Element Groups [Page 125]
  - Activity Type Groups [Page 162]
  - Statistical Key Figure Groups [Page 173]
  - Sender Process Group [Ext.]
  - Sender Cost Center Groups [Page 146]
  - Sender Activity Type Groups [Page 162]

- **Displaying Line Items**
  The system displays the line items for a selected data cell

- **Display planner profiles**
  The system displays the current planner profile [Page 321] and planning layouts assigned to it.

- **Display layouts**
  Displays the current planning layout [Page 327] in layout maintenance in Customizing.

- **Controlling areas, displaying**
  Displays the current controlling area
Executing Manual Planning

Purpose
This process describes how to execute cost center planning and lists the aids provided by the SAP R/3 System. This process applies to all applications in the SAP R/3 System, which use the planning layouts and planner profile methods. These are as follows:

- Cost Center Accounting
- Internal orders
- Activity-Based Costing
- Real Estate Controlling
- Project System

Process Flow
The graphic shows the screen sequence used in planning.

Planning
- Set planner profile
- Costs/activity inputs
- Activity output/prices
- Statistical key figures:
  - Change/create
Initial Screen

Depending on the planner profile selected (see also: Planner Profiles [Page 321]), the initial screen contains the first planning layout that this planner profile contains (see also: Planning Layouts [Page 327]). You can scroll between the planning layouts of a planner profile.

As well as displaying the groups you have used, you can also display the planner profile and the planning layout(s) contained in it (see also: Manual Planning Aids [Page 261]).

You can use various indicators to control how much data is to be prepared for the following overview screen.
If you have locked a planning transaction for some of the periods in the fiscal year in the period lock [Ext.], and you are using a period interval for manual planning that contains at least one of the locked periods, then the system does not allow you to plan. This also applies to the periods that are not locked.

Therefore, you should use only period intervals that do not contain locked periods.

Overview Screen

The overview screen layout depends on the planner profile and related planning layouts. You can manually change individual settings, such as scaling or the layout of rows and columns, during planning.

The first plan or actual record that you post to an object in a fiscal year using a certain cost element is the record that determines the unit of measure for the consumption. If there is no unit of measure, then you cannot plan consumption. You need to differentiate between the following:

– There is still at least one plan record (in another version)
  You can only change the unit of measure and the consumption in the version that was planned first. Once you have defined a unit of measure in that version, which is valid for the whole fiscal year, the consumption (in this unit of measure) is ready for input for all versions. The unit of measure in the first version can only be changed until planning data is posted in another version. After this, you can only make the unit of measure ready for input by deleting the plan records in all versions, and re-creating the required unit of measure.

– At least one actual record already exists
  You need to reverse the actual records that exist, and re-create the required unit of measure. After this, the consumption in planning (under this unit of measure) is ready for input.

– Orders have at least one database record for actual or plan values. This database comes from an order settlement (by cost element).
  Even after an order settlement is reversed, a database record still exists, and prevents the unit of measure from being changed.

Period Screen

In the period screen you can display or change the period-based distribution of your plan value. You can select the period screen either for each row from the planning overview screen or from the initial screen.
Periodic Formulas in Cost Center Planning

Use
In cost center planning, various data cells are linked together using periodic formulas, such as:

Fixed costs + variable costs = overall costs.

are linked together. In the SAP R/3 System, the variables of these formulas correspond to the key figures (or attributes) to be planned, or to the key figure values determined by the system. If you enter one or more key figure values, the system uses heuristic rules to determine which values are to be calculated. If you manually enter all of the values linked by a periodic formula, the system overwrites one of the manually entered values according to a priority list.

The periodic formulas are not calculated among the cumulated values of the overview screen, but always by period.

The system applies the periodic formulas in the following ways:

- Individually
- Building on one another

Enter the values in the object currency for the key figures Variable costs and Fixed costs in the activity-dependent primary cost planning. The system calculates the value for the overall costs according to the formula:

Fixed costs + variable costs = overall costs.

This value is given in the object currency.

Independently of the structure of the planning layout, the costs from the example mentioned above are also translated through further process steps into the controlling area currency and the transaction currency.

Features
Here is a selection of the periodic formulas offered by the system for the planning of CO objects:

- Fixed + variable = Overall (only activity-dependent)
- Fixed Cost Center Accounting = Overall (activity-independent in
- Costs = price/price unit * plan activity quantity
Periodic Formulas in Cost Center Planning

- **Fixed costs/variable costs** = Fixed consumption/variable consumption
- **Currency translations**
  - Fixed controlling area currency <-> Fixed object currency
  - Variable controlling area currency <-> Variable object currency
  - Fixed controlling area currency <-> Fixed transaction currency
  - Variable controlling area currency <-> Variable transaction currency
  - Fixed controlling area currency <-> Fixed user-definable currency
  - Variable controlling area currency <-> Variable user-definable currency
  - Overall controlling area currency <-> Overall user-definable currency

Depending on the values you entered during planning, the system calculates the missing values by solving the formulas according to the given variables.

**Fixed + Variable = Overall (Primary Costs and Quantities)**

This formula is valid for cost element planning and price planning. During the calculations, the system keeps to the following priorities:

1. **Fixed + variable = overall**
   
   If you have entered a fixed value, as well as a variable and overall value, the system overwrites your overall value.

   ![Image]

   You plan the following primary costs:

   - **Fixed** $20
   - **Variable** $40
   - **Overall** $80

   The system calculates an overall value of $60 and overwrites the value of $80 in line with the first priority.

2. **Overall - variable = fixed**

3. **Overall - fixed = variable**


**Fixed Costs = Overall Costs/ Fixed Quantities = Overall Quantities**  
*(Activity-Independent in Cost Center Accounting)*

The system uses this formula if you are not planning any activity-dependent costs. If only overall costs exist, the system updates this value as fixed costs.

Overall costs = overall price/price unit * overall quantity  
Variable costs = variable price/price unit * variable quantity

If you have not planned any prices, you cannot carry out a valuation during secondary planning. Only after price calculation or manual price planning does the system execute a recalculation of the received activity quantities using the prices.

**Enter the following values in the activity type planning:**

- **Activity quantity of the fixed activity type** Drills. 100 hrs
- **Activity quantity of the variable activity type** Drills. 200 hrs
- **Fixed price** $10/hr
- **Variable price:** $20/hr
- **Price unit** 1, that is, the price is valid for 1 hour of activity type Drills.

From this, the system calculates the following costs for the receiver of the activity.

**Overall plan costs**

\[
\text{Overall plan costs} = \text{Overall price} \times \text{Total quantity} = (\text{Fixed price} + \text{variable price}) \times (\text{Fixed qty} + \text{Variable qty}) = (101 + 20/1) \times (100 + 200) = 9000
\]

**Plan variable costs**

\[
\text{Plan variable costs} = \text{Variable price:} \times \text{Variable qty} = 20/1 \times 200 = 4000
\]

**Fixed plan costs**

\[
\text{Fixed plan costs} = \text{Overall plan costs} - \text{Plan variable costs}
\]
Fixed Costs/Variable Costs = Fixed Consumption/Variable Consumption

The system uses this formula when you manually plan primary costs. If you have manually planned all four values, and the system determines a breach of this formula due to your entry values, it overwrites the entry value according to the following priorities:

1. **Fixed consumption = fixed costs * variable consumption/variable costs**
   
   From your entry values, the system first determines the fixed consumption and then overwrites the manually entered value.

2. **Variable consumption = variable costs * fixed consumption/fixed costs**

You plan the following:

**Primary cost planning:**
- Fixed costs: $2000
- Variable costs: $3000

**Activity type planning:**
- Fixed quantity: 100 hrs
- Variable qty: 300 hrs

The system carries out the following calculations:

\[
\frac{2000}{3000} = \frac{100}{300}
\]

As you have planned all the values manually and the relationships in the formula are not identical, the system overwrites the *Fixed consumption* value with

\[
\text{Fixed consumption} = \frac{2000 \times 300}{3000} = 200 \text{ hrs}
\]

With the value 200 hrs for the fixed consumption, the formula is once again correct.
Currency Translations

During manual planning, the system executes any necessary currency translations if these have been activated in the controlling area. Generally, the system carries out manual planning in the controlling area currency. Additionally, however, you can also use plan values in transaction, object or a freely-definable currency (see also: Currencies in Planning [Page 198]). To do this, you need to add another column to the corresponding planning layout for each additional leading amount in a different currency. The following translations are possible:

- Controlling area currency to transaction currency
- Controlling area currency to object currency
- Controlling area currency to user-definable currency

- Transaction currency to controlling area currency
- Object currency to controlling area currency
- User-definable currency to controlling area currency
Executing Planning

Prerequisites
To access the initial screen for planning, you need to select a planner profile (see also: Planer Profiles [Page 321]), or ensure that a planner profile is entered in the PPP user parameters. You can also overwrite this planner profile before you enter planning and save it in your user parameters.

Procedure
1. Set a planner profile in the planning menu for your component. Choose:
   Planning → Set planner profile
2. Enter a planner profile.
3. Choose Save user master record.
   In the subsequent planning sessions, the SAP system selects the last planner profile saved in the user master record.

Initial screen
1. Enter the characteristics of the characteristic groups for which you want to execute planning, for example, cost center, cost element, activity type or the given group.
2. Activate Free or Form-based.
   If you select Free, the SAP system lists in the overview screen the planned records to be changed. The SAP system displays the header characteristics completely, even if no planning values exist. You can also enter new characteristic values and add them to the rows.
   If you select Form-based, the SAP system lists in the overview screen all planning objects with valid master records selected in the initial screen, even if no planning values exist. The SAP system displays the same characteristic value structure in each planning session. You cannot enter any new characteristic values. The following section contains an example of the free and form-based selection:

   • You plan activity-independent primary costs for all cost centers of cost center group “Production”, S04100, using, for example, cost element 400000. Enter cost center group S04100 in the initial screen. The group contains cost centers 4110, 4120, 4130 and 4140. You have not yet planned any costs for cost center 4110.
   • If you select Free, the SAP system displays cost centers 4120, 4130, and 4140. The system does not offer you cost center 4110 for changes. You can include the cost center still to be planned in the rows.
   • If you select Form-based, the SAP system displays all cost centers of the group for changes and entries. However, it is not possible in this case to add further cost centers in the rows.
Executing Planning

To check the entry data, the system provides you with error analysis help under Extras (see also: Manual Planning Aids [Page 261]).

3. Choose Execute.

Overview screen

In the overview screen, proceed as follows:

1. Enter planning values for the characteristic combinations you have selected.

2. To do this, use the planning aids provided by the SAP system (see: Planning Functions [Page 273]).

3. Save your entries.

Period screens

To branch to the period screen, proceed as follows:

1. In the Planning: Overview Screen, position your cursor on an entry and choose Period screen.

2. Adopt the default values offered by the SAP system or enter your own period values.

   You can also use a distribution key [Ext.] in the overview screen other than that offered by the SAP system. This enables you to carry out a different distribution of the planning values across the periods.

Result

You can now view your planning values in the information system and compare them with plan or actual values from other areas or periods (see Important Standard Reports in Cost Center Accounting [Page 976]).
Planning Functions

Use
Planning contains functions that you can use in the following areas:

- Entering and processing plan data
- Navigating within planning (between planning layout and combinations)
- Settings for planning
- Error analysis
Positioning

Use
The Position function allows you to position your cursor on a targeted row in a long list. This saves you from having to scroll up and down the screen.

Procedure
Choose Position and enter the characteristic value you require in the lead column.
Cut

Use

This function lets you move all the data in the selected range to the clipboard. When you do that, the system clears the selected cells.

You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row

You can select an entire column by clicking on the column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Prerequisites

The selected area may not contain any attribute cells (such as distribution keys), since these cannot be cleared.

Features

When you choose Cut, all the selected cells are cleared (set to “0”) and the values contained there are moved to the clipboard. The contents are the clipboard are

- Overwritten, the next time you use the Cut or Copy function or
- Deleted as soon as you switch from the overview screen to the period screen or back.

The function Paste [Page 279] lets you insert the values from the clipboard to another position on the entry screen.

If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Copy

Use
This function lets you copy all the data in the selected range to the clipboard.
You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row
- An entire row

You can only paste a row into another row if the target row is ready for input. Consequently, the screen must contain rows that are ready for input before you can copy entire rows to the clipboard.

You can select an entire row or column by clicking on the row or column header. To select a block, use the Select block function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Features
When you choose Copy, the values contained in the selected cells are copied to the clipboard. The contents are the clipboard are

- Overwritten, the next time you use the Cut or Copy function or
- Deleted as soon as you switch from the overview screen to the period screen or back.

The function Paste [Page 279] lets you insert the values from the clipboard to another position on the entry screen.
Paste

Prerequisites
You can only use this function if you have already cut or copied data to the clipboard. For details, see Cut [Page 275] and Copy [Page 277].

Use
The function Paste lets you insert the values from the clipboard to the selected area on the entry screen.

Where the data is inserted depends on what is in the clipboard and what you have selected (either explicitly or by positioning the cursor) on the entry screen.

<table>
<thead>
<tr>
<th>What is in the clipboard?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>an entire column</td>
<td>You can select either the entire target column or the first cell in that column.</td>
</tr>
<tr>
<td>an entire row</td>
<td>You can either select the entire target row (blank row) or position the cursor on the target row in the lead column.</td>
</tr>
<tr>
<td>a block within a column</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
<tr>
<td>a block within a row</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Tips
When using the Paste function, note the following:

- You can copy entire rows to the clipboard. If you do, you can only insert the row in a blank row that allows data entry.
  The system inserts the characteristic values in the lead columns along with the values in the value columns. However, if you only copied the row, note that the combination of characteristics already exists. You therefore need to change the new row.

- If some cells in the target range are in display mode, the values in those cells are not overwritten. However, if you change values that are used to calculate other values, this could also change those calculated values, even if they are in cells that are not ready for input.

- The Paste function does not change or delete the content of the clipboard.
If you want to reverse the *Cut* function, choose *Undo entries* or the corresponding icon.
Insert

This function lets you insert new lines between existing ones.
Delete

Use
The *Delete* function lets you delete planning records that have already been posted.

If you choose *Delete* in *activity type planning*, plan records are deleted from the database only if no dependent data records exist. For example, you cannot delete an activity type on a cost center if activity input has already been posted to the cost center using this activity type. The R/3 System informs you if dependent records exist.

Procedure
1. Select the necessary rows.
2. Choose *Edit → Delete*.

Note that the system only deletes the planning records when they are posted from the database.
Change Values

Use

To use the function Change values, you first need to select a range of data cells that does not contain any attributes (such as distribution keys). You can then change the values in the selected range using the functions Revaluate and Add.

Features

- Revaluate
  
  This function increases the values in the selected cells by a percentage that you enter. You can also enter a negative sign, in which case the values in the selected cells are decreased by that percentage.

- Add

  The Add button lets you add the value you specify in the Value field to the values in the selected cells. Again, you can enter a negative sign, in which case the value you entered is subtracted from the previous values.

  If you want to reverse the Change values function, choose Undo entries or the pushbutton 🔄 (see Clear Row, Undo, Redo [Page 290]).
Goal Seek Function

Use

The goal seek function is used in manual planning to find the content of a cell automatically by referencing another cell that shares the first cell's function. The cell whose content is to be sought is referred to as the source cell. The target cell must be linked to the source cell by a formula and must represent the result of this formula.

You can enter a value - the target value - for the target cell in the goal seek function. After the function has been carried out, the value necessary for reaching the target value is written to the source cell. In this way, the system simulates manual entry.

Your planning layout contains, among others, the following columns: planned revenue, planned quantity and planned price. The planned revenue is the product of planned quantity and planned price.

When entering planning figures, you can use the goal seek function to produce in the planned price cell the value required in order to attain a certain target revenue, such as 120,000 USD. Select the planned price as the source cell and the revenue as the target cell. Ensure that there is a value in the planned quantity cell.

Since the source cell must always be the cell unlocked for manual entry, the system automatically designates as source cell that cell of the selected pair that is unlocked. If both of the selected cells are unlocked for entry, you can switch the cells round after having selected the goal seek function and then specify the source cell.

Prerequisites

- Your current planning layout should always contain formulas or ratios.
• You need to select two cells and ensure that at least one of those selected - the **source cell** - is unlocked for manual entry.

• All cells used to calculate between the source and target cells must have entries.

• Neither of the selected cells should be the totals row.

**Activities**

1. Select just two cells.
2. Choose *Edit → Goal seek*.
3. If necessary, change around the source and target cells.
4. Enter a target value.
5. If you want to cancel the result produced by the goal seek function, choose *Edit → Undo → Undo entry.*
Long Text

Use
In manual planning, this function enables you to enter an explanatory text for each planning row.

Activities
1. Select a row for which you wish to enter a text.
2. Choose Edit → Long text.
3. Save your entries.
Displaying/Changing/Deactivating Detailed Planning

**Use**

You can use detailed planning to enter detailed planning data for a given cost element.

For more information on detailed planning, see the SAP Library under Financials → CO Controlling → Cost Center Accounting → Cost Center Planning → Manual Planning → Detailed Planning of Cost Elements [Page 255], Executing Detailed Planning [Page 256].

**Activities**

To enter detailed planning data on a cost element, proceed as follows:

1. Select a planning row.
2. Choose Edit → Display/Change detailed planning.
3. To cancel detailed planning data, choose Edit → Deactivate detailed planning.
Calculating Output

Use
Within activity type planning, the R/3 System can calculate the output from the planned level of activity. The SAP R/3 System calculates the output of a cost center using the formula:

\[
\text{Output} = \text{Plan activity} \times \text{Output factor}
\]

\[
\text{Plan activity} \times \text{Output factor} = \text{Output}
\]

The R/3 System takes the default value for the output factor from the master record of the given activity type.

Prerequisites
You have defined the Output characteristic in your planning layout.

Procedure
Choose Edit → Activity → Output.
Distribution Key 11

Use

You can only use this distribution key in Cost Center Accounting for activity-dependent cost planning or activity-dependent statistical key figure planning. The system distributes the entry value in line with the activity quantity planned on the cost center at the time of using the distribution key. If you change activity quantities later or copy plan values to another version, the system does not automatically execute new distributions.

Procedure

On the overview screen, in the DK column of the desired characteristic, select distribution key 11.
Clear Row, Undo, Redo

**Clear Row**

This function is only active when you make an entry that is not allowed.

It allows you to reverse the entries made in the row where the error occurred, thus returning the row to its last valid state in the planning session. The system then continues checking the entries with the next row.

**Undo**

This function (pushbutton 🔄) reverses all the entries in the last dialog step. The system always stores the five last states so that you can restore these. However, these states are lost each time you switch from the overview screen to the period screen or back. After that you can no longer undo the previous step.

If you choose this function by mistake, you can “undo” the “undo” using the **Redo** function.

**Redo**

The **Redo** function (pushbutton 🔄) is only active after you have used the **Undo** function.
Formatting and Printing Forms

Use
This function lets you output the entry screen data in a list, which you can then:

• Print
• Mail as an attachment
• Export to a word processing or spreadsheet program
• Store as a file in a directory

As you cannot print from the entry screen, the system branches to a list of all the data for the current selection. This list corresponds exactly to the entry screen. This means, for example, that any changes made to the column width are reflected in the column width of the list. You cannot make changes to the list itself.

By choosing Format to print → Form you can generate a blank form, the layout of which conforms to that of your planning screen.

Procedure
Choose Plan data → Format to print.
You can print the list generated in this way (the system uses the ABAP List Viewer [Ext.]).
or Format to print → Form
Overview Screen

This function takes you to the overview planning screen. What is displayed depends on where you are when you choose this function:

- **Initial screen**
  
  The system displays the rows and columns of the overview screen for the first valid combination of header characteristic values.

- **Period screen**
  
  The system displays the overview screen for the current combination of characteristic values.
Period Screen

This function takes you to the period planning screen. What is displayed depends on where you are when you choose this function:

- **Initial screen**
  The system internally determines the structure of the overview screen and then displays the period screen that corresponds to the first row of the overview screen.

- **Overview screen**
  The system displays the period screen for the selected row or the row where the cursor is positioned. The characteristic values in that row appear in the header of the period screen.

  The rows of the period screen contain the individual periods for the current combination of characteristic values.
Next Combination, Previous Combination, Other Combination

Use
If you enter an interval of characteristic values on the variables screen, you can plan multiple combinations of characteristic values. These functions let you navigate between these combinations.

Next Combination
- Overview screen
  This function takes you to the next valid combination of characteristic values from the general data selection.
- Period screen
  This function takes you to the combination of characteristic values that represents the next row of the overview screen.

Previous Combination
- Overview screen
  This function takes you to the previous valid combination of characteristic values from the general data selection.
- Period screen
  This function takes you to the combination of characteristic values that corresponds to the previous row of the overview screen.

Other Combination
This function lets you navigate to any valid combination of characteristic values in the general data selection. This function is only available on the overview screen.
Next Layout, Previous Layout

These two functions are only active when you work with a planner profile. They let you jump to the next or previous layout in your planner profile.

You must post your data before you can leave a layout.
Number Format

Use
You use number formats to specify whether your plan value should be entered or displayed in the original value or scaled, for instance, as a power of ten.

You plan labor costs of $100,000 on the Production cost center.
If you select number format 1000, the system displays the amount in thousands of dollars, in this example 100. To increase plan costs to $150,000, enter 150.

You can select any number formats and change the plan value display. You can also specify the number of decimal places. The number of decimal places is dependent on the number format. If you select an invalid combination, the system displays an error message.

Procedure
Select a row, then choose Settings → Number format.
Lead Columns

Use

When you enter planning data, and are using multiple lead columns, the R/3 System displays the overall total for all entries in the planning layout. You can also select the following:

- **Total**
  The system displays a *subtotal* for each characteristic of the lead column.
  
  If, for example, there are two lead columns and you choose *Total*, the system adds up all value fields across the characteristic of the other lead column.
  
  An exception to this are planning layouts with only one lead column. As standard, the R/3 System does not display an overall total. To display the overall total, choose *Total*.

- **Hierarchies**
  The R/3 System displays a subtotal for the hierarchy nodes to which the selected lead column characteristic belongs. The system also displays an overall total for the top node of the hierarchy. This overall total is comprised of the subtotals of the lower-level nodes.
  
  If the planning layout only contains one lead column, you can choose either *No total, Total* or *Hierarchy*.
  
  If the planning layout contains more than one lead column, that is, there are multiple characteristic combinations possible for the lead columns, and you have selected *Total* for a characteristic, the system displays the subtotals for this characteristic by totaling the other lead column characteristics. The system displays these subtotals in addition to the characteristic combinations.
  
  If you have selected *Hierarchy* for a characteristic, the system creates subtotals for the selected characteristic. It also adds up these subtotals along the hierarchy to which the characteristic belongs.

You can set the display of subtotals as a default setting when you define a planner profile during Customizing. You can change this settings for the length of the planning session when you enter the planning data in the application.

You are using a planning layout with two lead columns. Cost center and cost element. The characteristic values of the cost center are: 4711, 4712, 4713. The characteristic values of the cost element are: 400000, 410000, 420000. In the standard settings, the overview screen appears as follows:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Planning costs in CO area currency</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td>4712</td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td>4713</td>
<td>420000</td>
<td>30</td>
</tr>
</tbody>
</table>
The dialog box for setting the lead column display appears as follows:

<table>
<thead>
<tr>
<th>Lead column</th>
<th>Hierarchy</th>
<th>Total</th>
<th>No total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Cost element</td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

If you have already entered values for all characteristics combinations, the planning overview screen appears as follows:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field 1</th>
<th>Value fields 2 etc.</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>20</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td>*Cost center</td>
<td>*Cost element</td>
<td>450</td>
<td></td>
</tr>
</tbody>
</table>

If you choose Total for the cost center characteristic, the system displays the following:
If you choose *No total* for the cost center characteristic, and *Total* for the cost element characteristic, the system displays the following:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Plan costs CAC</th>
<th>Plan costs TC</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>20</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>120</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>150</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>180</td>
<td></td>
</tr>
</tbody>
</table>

*Cost center*  "Cost element"  450
A group exists for the cost center characteristic, in which the characteristic values (cost centers) are assigned. The cost center group is structured as follows:

**KOSTL**
- **KOSTL1**
  - 4711
  - 4712
- **KOSTL2**
  - 4713
  - 4713

If you choose *Hierarchy* for the cost center characteristic, and *No total* for the cost element characteristic, the system displays the following on the overview screen:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field 1</th>
<th>Value fields 2 etc.</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>20</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>50</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>60</td>
<td></td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>150</td>
<td></td>
</tr>
<tr>
<td><strong>KOSTL1</strong></td>
<td>*Cost element</td>
<td>210</td>
<td></td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
<td></td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>80</td>
<td></td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>240</td>
<td></td>
</tr>
<tr>
<td><strong>KOSTL2</strong></td>
<td>*Cost element</td>
<td>240</td>
<td></td>
</tr>
<tr>
<td><strong>KOSTL</strong></td>
<td>*Cost element</td>
<td>450</td>
<td></td>
</tr>
</tbody>
</table>

The overall total is the total of all the subtotals generated by the system for the characteristic for which you have selected *Hierarchy* or *Total*. 
The R/3 System always displays hierarchies bottom-up on the overview screen. The hierarchy levels are indicated in an additional column by a corresponding number of asterisks "*" (zero being the lowest hierarchy level).

**Actions**

To display subtotals and hierarchies in Customizing, as well as in the application component, choose *Settings → Lead columns.*
All Key Values On/Off

Use

In planning layouts containing with several lead columns, it can occur that several characteristic values relate to the same value in another column. In such cases, the system default is to display the repeated characteristic only once in the overview screen.

By choosing *Settings → All key values on/off*, you can set the repeated characteristic values to be displayed or hidden. The selected setting, however, is only valid for the planning session you are working in.

---

**Standard Setting: All Key Values Off.**

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td></td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

**All Key Values On**

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

---

In order that you can distinguish the initial value of a characteristic from a hidden value, the initial value is displayed with the special character "#".
Header Display On/Off

Use
The function *Header display on/off* allows you to display or hide information at the top of the overview screen and of the period screen. The setting is only valid during that particular planning session.

Activities
Choose *Settings → Header display on/off*. 
User-Defined Currencies

Use

In addition to planning in controlling area, object or transaction currencies, you can also plan in a currency of your choice.

See also: Currencies in Planning [Page 198]

Activities

Choose Settings → User-defined currency
User Settings

Use

Under user settings, you enter which values the selection screens are to contain when you call up the reports. These user settings include:

- Selection criteria
- Planning period
- Reporting timeframe
- Reporting currency
- Other details (actual valuation for example)

In Customizing for the relevant Controlling application component or in the relevant area menu, you can define these settings per user or enter standard settings. The standard settings apply to all users for whom no user-specific settings apply.

For more information, see Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.].
Techniques for Supporting Manual Planning

You can use various planning techniques to perform manual cost center planning. The techniques you use depend on your organization’s requirements. They may vary between organizations. This section deals with the following questions:

• Should the cost center planning be executed in multiple versions? (for example, to depict alternative or continuous planning)
  In the SAP R/3 System you can create as many **versions** as you require.
  See also: Planning and Parallel Valuation in Multiple Versions [Page 307].

• Which cost structures can be expected in the planning period?
  If seasonal fluctuations are expected, you must be able to plan these using flexible distribution keys.

• Is planning to be executed centrally or locally? (possibly using predefined planning models)
  The answer to this question determines which planning view you select. The planning view determines the selection of objects and combinations of objects to be planned during cost center planning. For example, you can specify whether you want to plan a cost element on a cost center, or a cost element group on a cost center, or a cost element group on a cost center group.
  See also: Flexible Selection of Planning Views [Page 308]

• Do you need to plan in different currencies?
  You can select the currencies to be use in the planning process.
  See also:
  Currencies in Planning [Page 198]

• How are the planning screens to be structured?
  The planning screens (planning layouts) must meet your planning requirements. If the standard planning layouts in the system do not meet your specific requirements, you can create your own planning layouts. This allows you to define your own entry screens.
  See also:
  – Structuring the Planning Screen [Page 319]
Planning/Multiple Valuation Approaches in More than One Version

Use

Planning in More Than One Version

You can plan your cost centers in more than one version. This corresponds to the planning procedure used in industry, whereby an initial version is created by using existing plan or actual values (such as values from the previous or current fiscal year). These are mainly percentage-based revaluations (See also Revaluating Cost Center Planning [Page 371]) and the plan values are adjusted to the new targets. These plan values are then revised and reworked in a second version, following discussions with the cost center managers. You can use these version as the basis for new revaluations to generate any number of new versions, for example, to calculate best-case and worst-case scenarios.

These versions are stored separately in the system and can be compared with each other in the information system (plan/plan comparisons, or comparisons of the actual costs with different versions).

When you create a controlling area, the system automatically creates version 000 (plan/actual). The actual values created when entering primary costs and allocating costs internally are posted in this version. You also use this version to store the prices required for internal activity allocation in the actual. You must use version 000 for plan/actual comparisons. You can also edit version 000 during cost center planning, without having to create it previously. Version 000 therefore contains plan and actual data for analysis purposes. You can also use any number of additional plan versions. However, no actual data is saved in these alternative versions. For more information on versions, see the IMG under Controlling → Cost Center Accounting → Planning → Basic Settings → Define Versions [Ext.].

Multiple Valuation Approaches in More than One Version

If you have activated multiple valuation approaches in your controlling area, you can use more than one actual version. Each actual version can have the following valuations:

- Legal valuations
- Group valuations
- Profit center valuations

One of the valuations becomes the operational valuation (in the actual version 000).

You can only plan data using the operational valuation.

For more information see Multiple Valuation Approaches/Transfer Prices [Ext.].
Flexible Selection of Planning Screens

Purpose

You can select the planning view according to your requirements. This supports the varied business planning needs. You have the following options for the selection of the planning level:

Selecting Planning Views

<table>
<thead>
<tr>
<th>Planning view</th>
<th>Where used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center/cost element, activity type, or statistical key figure</td>
<td>Local planning by cost center manager</td>
</tr>
<tr>
<td>Cost center group/cost elem. group, activity type group, or statistical key figure group</td>
<td>Local planning by cost center manager; group can be specified as &quot;planning model&quot;</td>
</tr>
<tr>
<td>Cost center group/cost elem. group, activity type group, or statistical key figure group</td>
<td>Central planning by cost center planner in consultation with the cost center manager</td>
</tr>
</tbody>
</table>

Process Flow

You can create groups of cost centers, cost elements, activity types, and statistical key figures during master data maintenance especially for planning purposes. For more information, see:

- Cost elements [Page 110]
- Cost centers [Page 127]
- Activity types [Page 147]
- Statistical Key Figures [Page 163]

You can, of course, access existing groups, such as from the standard hierarchy or the cost element structure of the overhead allocation sheet, if these fit your planning requirements.

Central and Local Planning

You can switch at any time between central and local, cost-center or cost-element-based planning.

- Plan multiple cost elements on one cost center (local)
- Plan multiple cost centers under one cost element/cost element group (central)

The type of planning you select depends on the organizational structures of your business enterprise.

The two methods can also be combined. For example, certain cost elements (such as insurance and taxes) can be planned centrally, and other cost elements (such as operating supply items) can be planned locally by the respective cost center managers.

You need first to define the planning structures for both procedures. You can either access the original structures which you defined during master data maintenance (the cost center hierarchy of the company or the overhead allocation sheet structure), or you can define alternative
structures (hierarchies) for planning purposes. The following graphic shows an example of a cost center structure:

Example

In the planning process, you first plan the production cost center SFI 4210 with the cost elements "Wages" (420000), "Shift premium" (421000), "Salaries" (430000) and "Salary bonus" (431000).

Then you plan the production cost center SF2 4220 with the cost elements "Wages" (420000), "Shift premium" (421000) and "Salaries" (430000). The cost element (431000) "Salary bonus" is not planned. Therefore, no record is stored in the data base for this cost element on cost center 4220.

You then plan cost center 4230 using all four cost elements.

This procedure is the same as the one used for planning multiple activity types or statistical key figures.
Flexible Selection of Planning Screens
Distribution Keys

Use

During planning, the SAP R/3 System interprets the values you enter as overall values. Planning transactions use distribution keys, based on different criteria, to distribute the values to the individual plan periods. You can enter the distribution key in manual planning.

The SAP R/3 System uses your planning data during runtime, regardless of whether you have already saved a distribution key or not. The entered plan value is distributed according to each distribution key to the periods. The system saves the period values that are determined in this way.

The standard system includes predefined fixed distribution keys which cannot be changed (see: Standard Distribution Keys [Page 312]).

In addition, you can create any distribution keys you require, for example, to allow for seasonal fluctuations, or to create shift schedules (see: User-Defined Distribution Keys [Page 317]).

Any changes made to the definition of a distribution key do not have an effect on the data that you planned previously using this distribution key.

For more information on creating your own distribution keys, see the Implementation Guide for Cost Center Accounting, under Planning → Manual Planning → Define Own Distribution Keys [Ext.]
Standard Distribution Keys

Use

SAP provides the following standard distribution keys:

- **Distribution key 0**
  Used to enter values manually for each period.

- **Distribution key 1**
  Used to distribute the input value (annual plan value) equally across all plan periods.

- **Distribution key 2**
  Used to distribute the input value (annual plan value) according to the last distribution key used.

- **Distribution key 3**
  Interprets the input value as a percentage rate and multiplies it each period by the previous value.

- **Distribution key 4**
  Used to distribute period values not equal to zero to the subsequent empty periods.

- **Distribution key 5**
  Copies period values not equal to zero to the subsequent empty periods.

The SAP R/3 System differentiates between true distribution keys and input help.

- If a plan value is distributed on periods using a true distribution key, the sum of all period values always equals the sum of the original plan values entered.

- If you use an input help, the original value entered may change.

  The standard distribution keys 0, 3, 4, and 5 are input helps only. You change the entered parameters. The system does not save these distribution keys. This is so that new changes to the plan values can be avoided. Instead, it resets them to zero after use.

- **Distribution key 6**
  Copies a given period value to subsequent periods.

  This distribution key has no effect on the manually planned values, as it is used on the period level. The distribution keys are, however, available on the annual level.

- **Distribution key 7**
  Used to distribute the input value (annual plan value) among the individual periods in line with the number of calendar days per period.

- **Distribution key 11**
Can only be used in Cost Center Accounting for planning activity-dependent costs or activity-dependent statistical key figures.

The input value (annual plan value) is distributed in line with the activity quantity planned on the cost center.

⚠️

The R/3 System uses only those activity quantities planned at the time of the distribution key’s use. If you change activity quantities later or copy plan values to another version, the R/3 System does **not** automatically carry out new distributions.
Examples of Standard Distribution Keys

The following graphics illustrate distribution, based on the various distribution keys. The examples use monthly planning. Distribution keys can also be used in the same manner for other period cycles (for example, quarterly planning).

<table>
<thead>
<tr>
<th>Distribution Key 0</th>
<th>Distribution Key 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Individual values entered manually for each period</td>
<td>Equal distribution across the individual periods</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>1,500</td>
</tr>
<tr>
<td>4</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>1,500</td>
</tr>
<tr>
<td>Total</td>
<td>24,000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Input value: 24,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Distribution Key 2</th>
<th>Distribution Key 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution according to an existing distribution</td>
<td>Input value is interpreted as a percentage and refers to previous values</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Input value: 36,000</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>Total</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Input value: 50(%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>Total</td>
</tr>
</tbody>
</table>
### Examples of Standard Distribution Keys

<table>
<thead>
<tr>
<th>Distribution Key</th>
<th>Distribution Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>Period values are distributed to subsequent empty periods</td>
<td>Period values are copied to subsequent empty periods</td>
</tr>
<tr>
<td><strong>Period</strong></td>
<td><strong>Input</strong></td>
</tr>
<tr>
<td>1</td>
<td>8,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
</tr>
<tr>
<td>5</td>
<td>10,000</td>
</tr>
<tr>
<td>6</td>
<td>2,500</td>
</tr>
<tr>
<td>7</td>
<td>2,500</td>
</tr>
<tr>
<td>8</td>
<td>2,500</td>
</tr>
<tr>
<td>9</td>
<td>6,000</td>
</tr>
<tr>
<td>10</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td>1,500</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>24,000</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Distribution Key</th>
<th>Distribution Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>7</td>
</tr>
<tr>
<td>Period value is copied to subsequent periods</td>
<td>Input value is apportioned to the periods based on the number of calendar days in each period</td>
</tr>
<tr>
<td><strong>Period</strong></td>
<td><strong>Prev. value</strong></td>
</tr>
<tr>
<td>1</td>
<td>2,000</td>
</tr>
<tr>
<td>2</td>
<td>2,000</td>
</tr>
<tr>
<td>3</td>
<td>2,000</td>
</tr>
<tr>
<td>4</td>
<td>2,000</td>
</tr>
<tr>
<td>5</td>
<td>2,000</td>
</tr>
<tr>
<td>6</td>
<td>2,000</td>
</tr>
<tr>
<td>7</td>
<td>2,000</td>
</tr>
<tr>
<td>8</td>
<td>2,000</td>
</tr>
<tr>
<td>9</td>
<td>2,000</td>
</tr>
<tr>
<td>10</td>
<td>2,000</td>
</tr>
<tr>
<td>11</td>
<td>2,000</td>
</tr>
<tr>
<td>12</td>
<td>2,000</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>24,000</strong></td>
</tr>
</tbody>
</table>
### Examples of Standard Distribution Keys

**Distribution Key 11**

Input value is apportioned to the costs centers corresponding to the activity quantity (only applies to Cost Center Accounting)

**Input value: 24,000**

<table>
<thead>
<tr>
<th>Period</th>
<th>Planned activity</th>
<th>Subs. value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>2</td>
<td>60h</td>
<td>4,000</td>
</tr>
<tr>
<td>3</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>4</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>5</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>6</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>7</td>
<td>30h</td>
<td>3,000</td>
</tr>
<tr>
<td>8</td>
<td>60h</td>
<td>6,000</td>
</tr>
<tr>
<td>9</td>
<td>45h</td>
<td>4,500</td>
</tr>
<tr>
<td>10</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>11</td>
<td>15h</td>
<td>1,500</td>
</tr>
<tr>
<td>12</td>
<td>15h</td>
<td>1,500</td>
</tr>
</tbody>
</table>
User-Defined Distribution Keys

Use

If your planning must allow for regular periodic fluctuations, you can define custom distribution keys. The R/3 System distributes the total value you entered in planning to the individual periods, based on the distribution defined in the key.

You can create distribution keys before or during planning. SAP recommends creating them before planning begins if you know that organization-specific distribution keys are required.

Examples for distribution keys are seasonal fluctuations or shift schedules.

Activities

To define individual distribution keys, see the Implementation Guide (IMG) for the relevant Controlling component, under Planning → Manual Planning, for example under Maintain User-Defined Distribution Keys [Ext.] for cost centers.
Example of a User-Defined Distribution Key

In your distribution key, you define the number of the shifts that are worked per period, in this case per month. In cost center planning you enter the annual plan activity and combine this entry with your distribution key.

Five employees each work 7 hours per shift. Multiplying the work time of 35 hours per shift by the total number of shifts in one year, 680, results in an annual plan activity of 23,800 hours. The following table displays the distribution of the annual plan activity of 23,800 hours in line with the distribution key you have stored.

<table>
<thead>
<tr>
<th>Entry value: 23,800 hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
<tr>
<td>680</td>
</tr>
</tbody>
</table>
Planning Screen Layout

Use
You enter plan data in Controlling via entry screens. You structure these entry screens during Customizing for planning using the Report Painter [Ext.] functions (see also: User-Defined Planning Layouts [Ext.]). In the following, entry screens for plan data are referred to as planning layouts [Page 327].

Planning layouts are used in different application components within the SAP System. Information on defining planning layouts other information over and above cost center planning can be found as follows:

<table>
<thead>
<tr>
<th>Internal orders</th>
<th>User-Defined Planning Layouts [Ext.]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity-Based Costing</td>
<td>Defining Planning Layouts [Ext.]</td>
</tr>
<tr>
<td>Real Estate Controlling</td>
<td>User-Defined Planning Layouts [Ext.]</td>
</tr>
</tbody>
</table>

The standard system includes several common planning layouts [Page 328] designed for cost center planning and other related activities. These planning layouts are structured according to planning areas and assigned to a particular planner profile (for cost center planning for example). See also: Planner Profile [Page 321].

One planner profile can contain multiple planning areas. One planner area can contain multiple planning layouts. You can group planning layouts efficiently by assigning them to planner profiles. During planning you can switch between planning layouts belonging to a given planning area of a given planner profile.

⚠️ Before switching planning layouts within a planning area, you must first save the data of the planning layout you are leaving.

The graphic below shows the possible uses of planner profiles and planning layouts:
It is advisable to create a separate planner profile, with appropriate planning layouts, for each enterprise area for which planning is to be performed.

Planning with user-definable entry screens has the following advantages:

You can:

- Define multiple lead columns
- Flexibly structure value columns, for example:
  - Version planning
  - Quarterly, half-year, and annual planning
  - Centralized or decentralized planning
  - Activity outputs (sender perspective)
  - Cost planning in different currencies
  - Planning with varying actual price indicators, and a switching structure for cost component splitting
Planner Profiles

Use

You use planner profiles to control the process flow for planning. They are hierarchically structured. In a planner profile, you specify the planning layout to be used for each planning area, such as cost elements/activity inputs, activity types/prices, or statistical key figure planning. You can store any number of planning layouts for each planning area in a planner profile.

The planning layouts are assigned to a planner profile as profile items. Each planning area may contain any number of profile items. The profile item determines the sequence of the planning layouts in a planner profile. Using different profile items you can assign the same planning layout (with different default parameters) to one planner profile.

You have assigned the planning area Cost elements/activity inputs to the planner profile PROFIL 1. In profile items 1 and 2 you have assigned planning layout 1-101 to this planning area.

For the planning layout in profile item 1 you set the parameters Version 0 and cost center group PRODUCTION. For the planning layout in profile item 2 you set the parameters Version 1 and cost center group ADMINISTRATION.

During planning you can choose Next/previous planning layout to switch between the planning layouts of the selected planner profile. This allows you to plan in different versions.

In a planner profile, you can set the following planning conditions.

- You can control planning authorizations by assigning an authorization group to a planner profile. This is particularly important for decentralized planning. By using specialized planner profiles for planners, and by assigning authorization groups, you ensure that planning is restricted to the relevant area of responsibility.

- By setting default parameters for the planning layout in the planner profiles, you can enter default settings for the variables of a planning layout. You enter values for these variables in the planner profile. You can overwrite these values, and you can also prevent overwriting by selecting the appropriate indicator in the planner profile definition. In a planning session, the system checks all variables defined in a planning layout and handles them as parameters.

The system includes the following standard planner profiles:

For more information on creating planner profiles, see Customizing for

- the Controlling applications under:

  Controlling → Cost Center Accounting/Activity-Based Costing/Internal Orders → Planning → Manual Planning → Maintain User-Defined Planner Profiles [Ext.]

- R/3 Real Estate management under:

  Real Estate → Real Estate Controlling → Planning → Create User-Defined Planner Profiles [Ext.]

- the Project System under:
Planner Profiles

Standard Planner Profiles

Use
The R/3 System includes the following standard planner profiles:

<table>
<thead>
<tr>
<th>Planner profile</th>
<th>Use</th>
</tr>
</thead>
</table>
| SAP101          | Overhead Cost Controlling  
|                 | Primary costs/activity types/statistical key figure planning |
| SAP102          | Overhead Cost Controlling  
|                 | Activity inputs/activity types/statistical key figure planning |
| SAP103          | Overhead Cost Controlling/Production Planning  
|                 | Costs, revenues/activity types/prices PP planning/statistical key figures |
| SAP104          | Overhead Cost Controlling  
|                 | Secondary order costs/activity types for cost component splitting/activity-dependent statistical key figures |
| SAPEASY         | Overhead Cost Controlling  
|                 | Simplified planning of cost elements, revenue elements, activity types and statistical key figures |
| SAPABC          | Overhead Cost Controlling  
|                 | Planning with business processes |
| SAPALL          | Overhead Cost Controlling/Production Planning  
|                 | Contains all important planning layouts, which are also contained in SAP101 to SAP104 |
| SAPR&R          | Overhead Cost Controlling  
|                 | Resource planning, dependency planning |

Planner profiles SAP101, SAP102, SAP103 and SAP104 are not maintained as of Release 4.0A.

Standard profile SAP101 includes the following standard planning layouts:
- Activity-independent and activity-dependent primary cost planning
- Activity type planning/price planning
- Activity-independent statistical key figure planning
Standard Planner Profiles

Standard profile SAP102 includes the following standard planning layouts:
- Activity-independent and activity-dependent secondary cost planning
- Activity type planning/price planning
- Activity-independent statistical key figure planning

Standard profile SAP103 includes the following standard planning layouts:
- Activity-independent primary cost planning/revenue planning
- Activity type planning from a production planning (PP) perspective
- Activity-independent statistical key figure planning

Standard profile SAP104 includes the following standard planning layouts:
- Activity-independent secondary order cost planning
- Activity type planning with actual price indicators and a switching structure for cost component splitting
- Activity-dependent statistical key figure planning

The standard profile SAPEASY contains standard planning layouts for simplified planning of costs, revenues, activity types and statistical key figures.

The standard profile SAPABC contains standard planning layouts for activity inputs of business processes.

The standard profile SAPALL contains standard planning layouts for all planning areas, including Activity-Based Costing. SAPALL contains a summarization of planner profiles SAP101 to SAP104.

Planner profiles SAP101, SAP102, SAP103 and SAP104 are not maintained as of Release 4.0.

The standard planner profile SAPR&R contains planning layouts for the resources and dependency planning on cost centers, orders, and WBS elements.

(See also: Resource Planning [Page 219], Dependency Planning [Page 230])

Profiles SAP101 and SAP102 cover most planning scenarios, i.e. activity-independent and activity-dependent primary/secondary cost planning, activity type planning, and statistical key figure planning. Profiles SAP103 and SAP104 are designed to meet special requirements.
SAP103 especially enables simplified planning from a production planning perspective. Profile SAP104 meets the special requirements of a cost center planner for activity type planning with cost component splitting and activity-dependent statistical key figure planning. The planner profile SAPEASY simplifies your planning tasks. You can make centralized or decentralized basic planning of overall costs or prices without additional attributes, except for Distribution key and Long text.

From a business perspective, the following tables are available for the planning area "Cost centers: Cost elements/activity inputs":

**Cost elements/activity inputs/process inputs**

<table>
<thead>
<tr>
<th>Business transaction</th>
<th>Planning Layout</th>
<th>Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity-independent primary cost planning</td>
<td>1 - 101, 1 - 103, 1 - 161, 1 - 162</td>
<td>SAP101, SAPALL, SAP103, SAPEASY</td>
</tr>
<tr>
<td>Activity-Dependent Primary Cost Planning</td>
<td>1 - 101</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>Activity-independent activity input planning</td>
<td>1 - 102</td>
<td>SAP102, SAPALL</td>
</tr>
<tr>
<td>Activity-independent process input planning</td>
<td>1-102P</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Activity-dependent process input planning</td>
<td>1-102P</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Activity-dependent activity input planning</td>
<td>1 - 102</td>
<td>SAP102, SAPALL</td>
</tr>
<tr>
<td>Revenue planning</td>
<td>1 - 101, 1 - 103</td>
<td>SAP101, SAPALL, SAP103</td>
</tr>
<tr>
<td>Planning for credits from overhead</td>
<td>1 - 101, 1 - 103</td>
<td>SAP101, SAPALL, SAP103</td>
</tr>
<tr>
<td>Planning of activity-independent settlement costs</td>
<td>1 - 101, 1 - 103</td>
<td>SAP101, SAPALL, SAP103</td>
</tr>
<tr>
<td>Planning activity-dependent settlement costs</td>
<td>1 - 101</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>Primary order cost planning for cost centers</td>
<td>1 - 104</td>
<td>SAP104, SAPALL</td>
</tr>
<tr>
<td>Secondary order cost planning for cost centers</td>
<td>1 - 104</td>
<td>SAP104, SAPALL</td>
</tr>
<tr>
<td>Primary order cost planning for business processes</td>
<td>1-104P</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Secondary order cost planning for business processes</td>
<td>1-104P</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Resource Planning</td>
<td>1 - 1R1</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>Value-based dependency planning</td>
<td>1 - 1R1</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>Quantity-based dependency planning</td>
<td>1 - 1R3</td>
<td>SAPR&amp;R</td>
</tr>
</tbody>
</table>
From a business perspective, the following tables are available for the planning area "Cost centers: activity types/prices:

**Activity type planning/price planning**

<table>
<thead>
<tr>
<th>Business transaction</th>
<th>Planning Layout</th>
<th>Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard activity type/price planning</td>
<td>1 - 201</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Activity type/price planning with control indicator</td>
<td>1 - 204</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Centralized planning of activity types/prices</td>
<td>1 - 201C</td>
<td>SAPALL</td>
</tr>
</tbody>
</table>

From a business perspective, the following tables are available for the planning area "Cost centers: statistical key figures:

**Statistical key figure planning**

<table>
<thead>
<tr>
<th>Business transaction</th>
<th>Planning Layout</th>
<th>Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard statistical key figure planning</td>
<td>1 - 301</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Activity-dependent statistical key figure planning</td>
<td>1 - 302</td>
<td>SAPALL</td>
</tr>
<tr>
<td>Centralized statistical key figure planning</td>
<td>1 - 303C</td>
<td>SAPALL</td>
</tr>
</tbody>
</table>
Planning Layouts

Use

You use planning layouts to specify your cost planning structure. You define the headings, lead columns, and value columns, based on your specific business requirements. You do this for each planning area. The planning areas are:

- Cost elements/activity input
- Activity types/prices
- Statistical key figures

You can create different planning layouts for each planning area which may have different key columns, characteristics, and so on. This allows you to set up flexible planning schemes which meet specific business requirements such as versions, semi-annual or quarterly planning. The SAP standard system contains default versions of the most commonly used planning layouts for each planning area. You can easily create additional planning layouts, if required. The planning layouts supplied by SAP are described below:

See also: Standard Planning Layouts [Page 328] for cost center planning.
Standard Planning Layouts

Use

The standard system includes planning layouts for all planning areas. You can use these standard planning layouts, copy and adapt them to your requirements, or create completely new planning layouts. The standard planning layouts are divided into two categories: Planning layouts permanently assigned to a planner profile and planning layouts not yet assigned to a planner profile. The unassigned planning layouts are required only for special situations. Before using these unassigned planning layouts, you must first assign them to the corresponding planner profile.

Standard planning layouts are supplied only in client 000. To use the planning layouts in other clients, you must import them into the given client. You should execute this import after each release upgrade. For more information, see Customizing for Controlling under Controlling → General Controlling → Preparation for Production Start → Transporting System Settings → Transport Settings for Planning → Import Standard Planning Layouts [Ext.].

The standard planning layouts are protected. They cannot be changed. To create your own planning layouts with a similar structure to a standard planning layout, first copy the standard planning layout under a different name and then change the copy.

Integration

A list of standard planning layouts with brief descriptions is provided below.

SAP supplies the following planning layouts:

Cost Element/Activity Input Planning

<table>
<thead>
<tr>
<th>Planning layouts</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 101</td>
<td>Activity-independent and activity-dependent primary cost element planning</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>1 - 102</td>
<td>Activity-independent and activity-dependent activity input planning</td>
<td>SAP102, SAPALL</td>
</tr>
<tr>
<td>1 - 102P</td>
<td>Activity-independent and activity-dependent process input planning</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 103</td>
<td>Activity-independent cost and revenue element planning</td>
<td>SAP103</td>
</tr>
<tr>
<td>1 - 104</td>
<td>Activity-independent and activity-dependent secondary order cost planning</td>
<td>SAP104, SAPALL</td>
</tr>
<tr>
<td>1 - 104P</td>
<td>Primary and secondary order cost planning for business processes</td>
<td>SAPALL</td>
</tr>
</tbody>
</table>
### Standard Planning Layouts

<table>
<thead>
<tr>
<th>Planning Layout</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 161</td>
<td>Decentralized simplified planning of costs and revenues</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 162</td>
<td>Centralized simplified planning of costs and revenues</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 1R1</td>
<td>Resource planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>1 - 1R1</td>
<td>Value-based dependency planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td>1 - 1R3</td>
<td>Quantity-based dependency planning</td>
<td>SAPR&amp;R</td>
</tr>
<tr>
<td><strong>Not assigned</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1 - 151</td>
<td>Activity-independent cost planning in transaction currency</td>
<td></td>
</tr>
<tr>
<td>1 - 152</td>
<td>Activity-independent cost planning for four quarters</td>
<td></td>
</tr>
<tr>
<td>1 - 153</td>
<td>Cost element planning for two versions</td>
<td></td>
</tr>
<tr>
<td>1 - 154</td>
<td>Cost element planning with previous year figures displayed</td>
<td></td>
</tr>
<tr>
<td>1 - 155</td>
<td>Activity output (sender perspective) with receiver valuation</td>
<td></td>
</tr>
<tr>
<td>1 - 156</td>
<td>Central planning of a cost element</td>
<td></td>
</tr>
<tr>
<td>1 - 157</td>
<td>Cost element plan/actual comparison</td>
<td></td>
</tr>
</tbody>
</table>

Planning layouts 1 - 151 to 1 - 157 are provided in addition to the planning layouts already included in the planner profiles.

### Activity Type Planning

<table>
<thead>
<tr>
<th>Planning Layouts</th>
<th>Description</th>
<th>Assigned to Planner Profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 201</td>
<td>Standard activity type planning</td>
<td>SAP101, SAP102, SAPALL</td>
</tr>
<tr>
<td>1 - 201C</td>
<td>Centralized planning of activity types/prices</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 202</td>
<td>Simplified PP planning</td>
<td>SAP103</td>
</tr>
<tr>
<td>1 - 203</td>
<td>Activity type planning with actual price indicator, switching structure for cost component splitting</td>
<td>SAP104</td>
</tr>
<tr>
<td>1 - 204</td>
<td>Activity type planning with prices and additional attributes, such as predistribution of fixed costs</td>
<td>SAP101, SAPALL</td>
</tr>
<tr>
<td>1 - 261</td>
<td>Simplified price planning</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 262</td>
<td>Centralized simplified price planning</td>
<td>SAPEASY</td>
</tr>
</tbody>
</table>
Statistical Key Figure Planning

<table>
<thead>
<tr>
<th>Planning layouts</th>
<th>Description</th>
<th>Assigned to planner profile</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 301</td>
<td>Activity-independent statistical key figure planning</td>
<td>SAP101, SAP102, SAP103</td>
</tr>
<tr>
<td>1 - 302</td>
<td>Activity-dependent statistical key figure planning</td>
<td>SAP104</td>
</tr>
<tr>
<td>1 - 303C</td>
<td>Centralized statistical key figure planning</td>
<td>SAPALL</td>
</tr>
<tr>
<td>1 - 361</td>
<td>Simplified statistical key figure planning</td>
<td>SAPEASY</td>
</tr>
<tr>
<td>1 - 362</td>
<td>Centralized simplified statistical key figure planning</td>
<td>SAPEASY</td>
</tr>
</tbody>
</table>

Planning Layouts for Cost Element/Activity Input Planning

- Activity-independent and activity-dependent cost element planning (1 - 101)

With this planning layout you can plan:

- Activity-independent and activity-dependent primary costs (cost element category 01, 04)
- Revenues (cost element category 11, 12)
- Activity-independent and activity-dependent settlement costs (cost element category 21)
- Credits from overhead (cost element category 41)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Cost element</th>
<th>Cost element categories</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>400.000</td>
<td>1</td>
<td>Activity-independent primary cost planning</td>
</tr>
<tr>
<td>-</td>
<td>800.000</td>
<td>11/12</td>
<td>Revenue planning</td>
</tr>
<tr>
<td>Production hour</td>
<td>400.000</td>
<td>1</td>
<td>Activity-dependent primary cost planning</td>
</tr>
<tr>
<td>-</td>
<td>655.000</td>
<td>21</td>
<td>Activity-independent planning of settlement costs</td>
</tr>
</tbody>
</table>
To use activity-dependent and activity-independent planning in one planning layout, proceed as follows:

1. Select *Entry optional* in the planning layout for the variable of the activity type group. This is the case for standard planning layouts.

2. In the initial planning screen, you must have:
   - Specified an activity type group including the initial value, or
   - Entered "*" for the activity type. This entry allows you to plan all activity types, including the initial value.

- Activity-independent and activity-dependent activity input planning (1 - 102)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

**Header**
- Period
- Fiscal year
- Version
- Cost centers

<table>
<thead>
<tr>
<th>Receiver act. type</th>
<th>Sender cost center</th>
<th>Sender activity type</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>4210</td>
<td>REP</td>
<td>Activity-independent activity input planning</td>
</tr>
<tr>
<td>Production hour</td>
<td>4210</td>
<td>REP</td>
<td>Activity-dependent activity input planning</td>
</tr>
</tbody>
</table>

- Activity-independent cost and revenue element planning (1 - 103)

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

**Header**
- Version
- Fiscal year
- Period
- Cost centers
Standard Planning Layouts

<table>
<thead>
<tr>
<th>Cost/revenue element</th>
<th>Cost element categories</th>
<th>Business transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>400.000</td>
<td>1</td>
<td>Activity-independent primary cost planning</td>
</tr>
<tr>
<td>800.000</td>
<td>11/12</td>
<td>Revenue planning</td>
</tr>
</tbody>
</table>

- Activity-independent and activity-dependent secondary order cost planning (1 - 104)
  
  Planning layout 1 - 104 was originally intended for secondary order cost planning. With this planning layout you can plan:
  
  - Activity-independent and activity-dependent primary costs
  - Revenues
  - Activity-independent and activity-dependent settlement costs
  - Credits from overhead rates
  - Activity-independent and activity-dependent secondary order costs
  - Activity-independent and activity-dependent secondary costs

The following table provides examples of planning records in this planning layout that can be used individually or collectively.

**Header**

- Version
- Fiscal year
- Period
- Cost centers

<table>
<thead>
<tr>
<th>Cost element</th>
<th>Receiver acty type</th>
<th>Sender cost center acty type</th>
<th>Sender cost center</th>
<th>Cost element type</th>
<th>Transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>400.000</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>1</td>
<td>Activity-independent primary cost planning</td>
</tr>
<tr>
<td>800.000</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>11/12</td>
<td>Revenue planning</td>
</tr>
<tr>
<td>400.000</td>
<td>Production hour</td>
<td>-</td>
<td>-</td>
<td>1</td>
<td>Activity-dependent primary cost planning</td>
</tr>
</tbody>
</table>
Standard Planning Layouts

<table>
<thead>
<tr>
<th>Activity-independent secondary order costs</th>
<th>Activity-dependent secondary order costs</th>
<th>Planning for credits from overhead</th>
</tr>
</thead>
<tbody>
<tr>
<td>655.000</td>
<td>Production hour</td>
<td>634.000</td>
</tr>
<tr>
<td>655000</td>
<td>4210 FST</td>
<td>21</td>
</tr>
</tbody>
</table>

- Local planning of total costs (1 - 161)
  This planning layout allows you to plan locally (for each cost element) the total plan costs, without having to enter additional attribute values.

- Centralized planning of total costs (1 - 162)
  This planning layout allows you to plan centrally (for each cost center) the total plan costs, without having to enter additional attribute values.

- Resource planning (1 - 1R1)
  This planning layout lets you plan quantity-based primary costs.
  The characteristics activity type, cost element, resource, consumption and costs are displayed together. The resource is a new characteristic that can be positioned anywhere in the layout: For example, in the header, in a lead column or in a value column. You can also include three new key figures in the planning layout for resource planning:
  - Price in the planned currency
  - Price in controlling area currency
  - Price unit
  The system calculates as follows:
  - Fixed consumption quantity * Price = Fixed costs
  - Variable consumption quantity * Price = Variable costs
  - Total consumption quantity * Price = Total costs
  Only the consumption quantities are displayed as ready for input in the planning layout.
  It is possible to plan resources and cost elements in one planning layout. If the cost element and the resource are in the same lead column, and you enter only a resource, the system derives the cost element from the resource master data.
Standard Planning Layouts

If you have executed detailed planning (by resource) for one or more cost elements, the system accumulates the costs below the cost element at resource level. These costs can then be used, for example, for distribution, assessment or plan cost splitting.

- **Value-based dependency planning**
  You use this planning layout for value-based planning of primary costs. You can add the following new key figures to the planning layout for value-based dependency planning:
  - Dependency type
  - Dependency source type
  - Fixed dependency price
  - Variable dependency price
  - Dependency source quantity

  The system calculates as follows:
  - Fixed dependency price * Dependency source quantity = Fixed costs
  - Variable dependency price * Dependency source quantity = Variable costs

  Depending on the dependency type, the fields Fixed dependency price, Variable dependency price, Plan fixed costs, and Plan variable costs in the planning layout are ready for input.

- **Quantity-based dependency planning**
  This planning layout lets you plan quantity-based primary costs. The characteristics activity type, cost element, resource, consumption and costs are displayed together. You can also include three new key figures in the planning layout for value-based dependency planning:
  - Dependency type
  - Dependency source type
  - Fixed dependency quantity
  - Variable dependency quantity
  - Fixed dependency price
  - Variable dependency price
  - Dependency source quantity
  - Fixed plan consumption
  - Variable planned consumption

  The system calculates as follows:
Standard Planning Layouts

- Fixed dependency price * Dependency source quantity = Fixed costs
- Variable dependency price * Dependency source quantity = Variable costs

Depending on the dependency type, the fields Fixed dependency qty, Variable dependency qty, Plan fixed consumption, Plan variable consumption, Plan fixed costs, and Plan variable costs in the planning layout are ready for input.

- Activity-independent cost planning in transaction currency (1 - 151)
  You can use this planning layout to plan costs in transaction currency.

- Activity-independent cost planning for four quarters (1 - 152)
  This planning layout allows you to plan by fiscal quarter.

- Cost element planning in two versions (1 - 153)
  You use this planning layout to enter plan values for two different versions. The SAP R/3 System calculates the difference between the two values.

- Cost element planning with display of previous year figures (1 - 154)
  This planning layout lets you display the previous year plan values for costs and consumption, in addition to the current plan values. The SAP R/3 System calculates the difference between the two values.

- Planning activity output from a sender perspective (1 - 155)
  This planning layout allows you to plan sender outputs. From a sender perspective, you plan: How high is the activity output of the sender?

- Central planning of a cost element (1 - 156)
  You can use this planning layout to plan centrally the costs and consumption of a cost element for all cost center/activity type combinations. The “Cost element” characteristic is in the planning layout header, the “Cost center/activity type” characteristic is in the rows.

- Plan/actual comparison for cost elements (1 - 157)
  With this planning layout, you can plan activity-independent costs while displaying the actual values of a comparison year.

Planning Layouts for Activity Types/Price Planning

- Activity type planning (1 - 201)
  Planning layout 1 - 201 lets you plan activity types on cost centers or cost center groups. The planning layout value columns contain the following key figures:
  - Plan activity
  - Capacity
  - Cost element for the activity allocation
  - Fixed price
  - Variable price
  - Price unit
Standard Planning Layouts

- Equivalence number
- Scheduled activity

*Distribution key, Activity unit, Plan price indicator, Long text exists, and Average price are added to the value columns as attributes.*

- Activity type planning for the PP planner (1 - 202)

This planning layout contains only key figures and attributes relevant to production planning. This includes the following characteristics and attributes:
  - Plan activity
  - Fixed price
  - Variable price
  - Price unit
  - Plan price indicator

  - Distribution keys
  - Activity unit
  - Cost element for the activity allocation
  - Average prices
  - Long text exists

- Activity type planning with actual price indicator and switching structure for cost component splitting (1 - 203)

In addition to key figures for activity type planning (see also 1 - 201) this planning layout has key figures and attributes which give you the following activity type planning options:
  - Plan output
  - Set an actual price indicator varying from the plan.
  - Specify a switching structure for cost component splitting

- Activity type planning with different attributes (1 - 204)

In this planning layout you can plan activity types with the following attributes:
  - Predistribution of fixed costs
  - Plan price indicator
  - Actual price indicator
  - Price calculation with the periodic averages
  - Plan activity type category
  - Actual activity type category
  - Exchange rate type
  - Value date
Switching structure
- Output factor
- Long text exists
- Allocation cost element

- Simplified price planning (1 - 261)
  This planning layout lets you plan total prices for each activity type. Available attributes are Price unit, Distribution key, and Long text exists.

- Simplified centralized price planning (1 - 262)
  This planning layout lets you plan total prices centrally. Available attributes are Price unit, Distribution key, and Long text exists.

Planning Layouts for Statistical Key Figure Planning

- Activity-independent statistical key figure planning (1 - 301)
  You can use planning layout 1 - 301 to plan a current and a maximum value. Available attributes are Distribution key, Unit, Key figure type and Long text exists.

- Activity-dependent statistical key figure planning (1 - 302)
  Planning layout 1 - 302 contains the same value columns as the planning layout for activity-independent key figure planning. It differs only in the lead columns. While planning layout 1 - 301 has only one lead column (statistical key figure), planning layout 1 - 302 has two: Activity type and Statistical key figure. With this planning layout you can plan activity-independent and activity-dependent statistical key figures.

⚠️

To use activity-dependent and activity-independent planning in one planning layout, proceed as follows:

1. Enter Entry optional in the planning layout as the variable for the statistical key figure group. This is defaulted for standard planning layouts.
2. In the initial planning screen, you must have:
   - Specified a statistical key figure group that includes the initial value, or
   - Entered “*” for the statistical key figure. This entry allows you to plan all statistical key figure, including the initial value.

- Simplified statistical key figure planning (1 - 361)
  You can use this planning layout to plan a current value. Available attributes are Distribution key, Unit, Key figure type and Long text exists.

- Simplified centralized statistical key figure planning (1 - 362)
  This planning layout allows you to plan centrally (for each cost center) a current value. Available attributes are Distribution key, Unit, and Long text exists.
Standard Planning Layouts
Structuring Planning Layouts

Use

If the standard planning layouts supplied by SAP do not meet your requirements, you can define your own layouts. The following section describes the structure of a planning layout and the procedure for defining your own layouts (see also Defining Planning Layouts [Page 341]).

All planning layouts are based on the following structure:

```
<table>
<thead>
<tr>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headers</td>
</tr>
<tr>
<td>Key Columns</td>
</tr>
</tbody>
</table>
```

The **header** of the planning layout contains the characteristics that apply to the whole planning table. You make these entries in the planning layout, under *Edit → Gen. data selections*.

To plan activity-independent costs, you define header characteristics, such as version, period, fiscal year, cost center and cost element. These characteristics are always displayed in the planning initial screen and the planning overview screen.

The **lead columns** contain the objects to be planned. You can define multiple lead columns. You create lead columns using predefined characteristics provided by SAP.

If you want to plan activity-independent costs, you define the cost element as a lead column. When you plan activity-dependent costs, you add the activity type as the second column. You enter the cost element and the activity type in the initial screen. However, in contrast to the other characteristics on this screen, you must also define them in the lead columns. This is so that you can plan them.

The **value columns** are used for the planning itself. This is where you enter the plan values.

You create value columns from the following:

- Characteristics
- Attributes
Structuring Planning Layouts

- Formulas

For activity-independent or activity-dependent cost planning, you set the characteristics Fixed plan costs or Variable plan costs in the value columns. You can add further characteristics, such as a distribution key.

You define these three areas during Customizing for Controlling, under Overhead Cost Controlling → Cost Center Accounting or Activity-Based Costing under Planning → Manual Planning → User-Defined Planning Layouts. Once you define a planning layout, you can only change it in Customizing, not during planning.
Defining Planning Layouts

Use

If the standard planning layouts supplied by SAP do not meet your requirements, you can define your own layouts. The IMG contains more detailed information on defining planning layouts:

- For Overhead Cost Controlling applications, see:
  
  Controlling → Cost Center Accounting / Activity-Based Costing / Internal Orders → Planning → Manual Planning → User-Defined Planning Layouts [Ext.]

- For SAP Real Estate Management, see:
  
  Real Estate → Real Estate Controlling → Planning → User-Defined Planning Layouts [Ext.]

- For the Project System, see:
  
Integrated Excel in Planning

Use

For planning with integrated Excel, Microsoft Excel is used as a planning screen for your planning data in the SAP System. This allows you to combine the comfort of Excel's formatting and data processing functions with the powerful planning functions of your SAP application. You are therefore able to use the Office input interface with online planning in the SAP System.

There are two ways of using Excel to plan your data:

- Planning with Excel integrated into the user interface of the SAP System
  Excel replaces the standard SAP planning screen. This enables you to plan using the functions of both the SAP System and Excel.
- Offline planning in Excel and uploading data into the SAP System
  From one or more PCs that are not connected to the SAP System, you can enter your planning data into several Excel spreadsheets. This data can then be uploaded into the SAP System, where you can process it further using the SAP planning functions.

Prerequisites

Software

To be able to plan using integrated Excel, the following should be installed on your PC:

- The Windows NT 4.0 or Windows 95 operating system
- Microsoft Excel 97
- A current SAP GUI (32 Bit) matching your System Release

Hardware

To ensure good response times, your PC should have a Pentium II processor and 64 MB RAM.

Features

In Customizing, you can define Excel spreadsheets for use as templates in planning. In those templates, you can move data around, insert graphics, define macros, and format text and cells. You can use this template to plan with integrated Excel or to plan with the upload function.

Link between Excel and the SAP System

From the technical point of view, Excel is called up by the SAP System using OLE (Object Linking and Embedding), an interface in the Office programs. Integrated Excel into the SAP System allows you to use the same Excel functions that are available with the integration of Excel in Word, for example.

On a more detailed level, the link between the Excel spreadsheet and the SAP planning layout is created above the position of the data in the Excel spreadsheet:

The SAP System uses Customizing to determine which SAP data is in Excel and where it can be found. The position of the data cannot be changed in the planning screen to ensure that the data is imported correctly. The fields of the planning layout are mapped to the Excel spreadsheet using File Description [Ext.].
Constraint
You cannot use integrated Excel to enter any planning data in the period screen.

Activities

Initial Steps
To be able to use Microsoft Excel as your planning screen, you need to activate the indicator integrated Excel in Customizing for your application when Setting Up The Planning Framework [Ext.] (only CO-PA), or when you assign your planning layouts to a planner profile.

In Customizing, you can also design an Excel spreadsheet to be used as a template for planning in Excel.

For more information about setting up integrated Excel, see Setting Up Integrated Excel [Page 344].

Planning in Excel

- Excel integrated in the SAP interface
  
  To plan directly in the SAP System using integrated Excel, you can choose between executing a corresponding parameter set (only CO-PA) or using a planner profile in which Excel was activated as the planning screen for one or more layouts. You enter your planning data in Excel and can use Excel functions such as macros or diagrams as well as all the usual SAP planning functions. For more information on planning with integrated Excel, see How To Plan Using Integrated Excel [Page 347].

- Planning in Excel and uploading data into the SAP System
  
  The Excel template created in Customizing can be copied as often as required and used to create planning data in Excel. By using the uploading function for Excel, you can transfer the individual files into the SAP system. This means that planning data can be entered into different PCs, local planning thereby being possible. For more information on the required procedure, see Planning Offline and Uploading into the SAP System [Page 349].
Setting Up Integrated Excel

**Prerequisites**

Your Planning Layouts [Ext.] must be defined.

⚠️ If you want to change a planning layout for which you have already created an Excel template, you must create a new Excel template.

For technical reasons, it is necessary that the system already contain planning data that corresponds to the planning layout (at least one row) before an Excel spreadsheet can be formatted as a template. If no such data is present in the system, you need to create some. One way of doing this is by entering data into the appropriate layout without integrated Excel.

**Procedure**

**Activating Excel**

Depending on the application you are working in, you should proceed as follows:

- **In Profitability Analysis (CO-PA)**, you set the integrated Excel indicator to "active" when you define a parameter set for the planning method *Enter planning data or Display planning data* (for more information, see the section *Set Up Manual Entry of Planning Data [Ext.*]). When you first select this parameter set in the planning framework, the structure that you specified in the planning layout is represented in the upper left-hand corner of an Excel sheet.

- **In the other applications**, select *Integrated Excel* in Customizing on the *Define Planner Profiles* screen when you assign planning layouts to the planner profile. This activates Excel as the planning tool for that layout in that planner profile. When you enter planning, the system displays the planning layout you defined in the upper left-hand corner of an Excel spreadsheet.

  When moving the planning layout, you can enter a specific name for the file description. This makes sense, for example, in cases where you intend to use the file description several times. If you do not enter anything here, the system automatically creates a file description when you save your planner profiles. This file description will reflect the position in the profile.

  ⬤ If you want to customize a particular spreadsheet to be used uniquely with that layout in planning, you need to define an appropriate template (see "Defining an Excel Template").

  If you want to **upload** an Excel spreadsheet, you need to edit an Excel sheet template in order that the system can generate a file description. This file description is required for the upload. Furthermore, you need to make several additional settings (see *Planning Offline and Uploading into the SAP System [Page 349]*).
Defining an Excel Template

1. **CO-PA**: Execute the planning method *Enter planning data*, using the related parameter set. Doing so takes you to an unformatted Excel sheet. There you choose *Settings → Formatting*.

   **Other applications**: In the IMG for defining the planner profile, choose *Default Parameters* and enter values for the variables defined in the planning layout. You must do this so that you can open the spreadsheet in the next step. If desired, you can delete these entries again after you have customized your Excel template.

   To open Excel in the SAP window, choose 📐.

2. In the *Maintain File Description* screen, you can now customize an Excel spreadsheet as a template for your planning screen.

   Note the following:
   - To **move** planning data within the spreadsheet, only use the appropriate SAP function. To do this, select the data you want to move using 📐, and then position the cursor on the target location and choose 📐. You save the link between the old position and the new position of the data by choosing 📐 *Save file description [Ext.]*.
   - The first Excel spreadsheet is protected. Cells that were not locked against entries in the SAP entry screen, such as those that can be defined in the planning layout, are excluded from this protection in Excel. If you want to use functions in Excel that extend beyond editing those cells where entries can be made, you first need to remove the general spreadsheet protection in Excel.
   - After editing, you should then reactivate the spreadsheet protection in Excel to ensure that, for subsequent planning, the only data that can be entered corresponds to that specified in the SAP System.
   - You can use the Excel formatting functions (such as different fonts or colors) to format the Excel template.
   - You can use Excel to create diagrams, macros and formulas and then use these for additional calculations, for example. It is recommended that you insert these into a second spreadsheet to avoid the data conflicting with the actual R/3 planning data later. The SAP planning data is imported from the first spreadsheet only.
   - When you enter formulas in the SAP data area in Excel, they are overwritten by the formula result during posting, and the formulas themselves are then discarded.
   - You can save the Excel formatting in the SAP System by choosing 📐 *Save Excel layout*.

3. If you later want to upload files from your PC to the SAP System, you must enter a **generic file name [Ext.]** (see the section Planning Offline and Uploading into the SAP System [Page 349]).

4. Choose 📐 in the toolbar. This function will also save the file description and the Excel template.

   Data saved with this function is permanent from then on.
Setting Up Integrated Excel

5. Choose \( \text{CO-PA} \): You then return to the planning framework.

Other applications: You return to the Default Parameters screen. Delete any values you entered for the variables if you do not want to have them displayed as the template in planning. Choose \( \text{Save} \).

The default parameters are only saved temporarily at this point.

For this reason, you should then finish by saving the planner profile. Only then does the system assign a definitive file description to the planning layout and save the values for the variables are saved permanently.
How To Plan Using Integrated Excel

Prerequisites

To be able to use Microsoft Excel as your planning screen in the SAP System, you need to make the appropriate settings either in Customizing under Define Planner Profile or when defining the parameter set for the Enter planning data planning method (CO-PA only). For more information, see Setting Up Integrated Excel [Page 344].

Procedure

1. **CO-PA**: Execute the planning method Enter planning data using a parameter set for which Excel has been activated as the planning tool. This automatically calls up Excel within the SAP window.
   - **Other applications**: Enter planning using a planner profile and choose a planning layout for which integrated Excel has been activated. To open Microsoft Excel in the SAP System window, choose . (It is not possible to use Excel to create planning data in the period screen.)
   - If you have used Customizing just to set the indicator for integrated Excel and no special formatting has been made in the Excel template for this planning layout, the system displays the planning data unformatted in the upper left-hand corner of the spreadsheet.
   - If you have formatted an Excel template in Customizing, the system opens this template in Excel.

2. Enter your planning data.

   Note the following:
   - You must avoid any use of the following Excel functions:
     - Delete
     - Paste
     - Sort
     Use of the above functions prevents data from being imported correctly into the SAP System.
   - If you want to delete data, choose in the SAP System.
   - Enter new objects for planning directly beneath the existing SAP data (where appropriate, beneath the totals row). To paste, use the SAP possible entries function (available via ). Note that the system does not recognize data that is separated from the existing SAP planning data by an empty row.
   - You can sort additional data into existing data by choosing Edit → Sort in the SAP menu.
   - If the Excel spreadsheet is protected, then the entries that can be made in the individual cells correspond to those specified in the SAP System.
   - You can access SAP possible entries by choosing .
   - The SAP System only imports data from the first spreadsheet in an Excel folder. You can perform additional calculations or add diagrams on a second spreadsheet. These
How To Plan Using Integrated Excel

- Calculations and diagrams are only kept during your planning session if they have not already been created in Customizing.
- When you enter formulas in the SAP data area in Excel, they are overwritten by the formula result during posting, and the formulas themselves are then discarded.
- If you want to save, use an SAP planning function or run a validity check, you need to make sure that no cell is currently being edited in Excel. You can control this by displaying the "Formula Bar" in Excel (choose View → Formula bar).
- To run a validity check for the data you have entered, choose ✓ in the SAP System.

3. Post the data by choosing ✅.

You then return to the initial screen.
Planning Offline and Uploading into the SAP System

Use
You can create your planning data in multiple files on your PC and upload those files later into the SAP System.

Prerequisites
To be able to upload the files, you must specify the characteristic values in the lead column of the corresponding planning layout. It is not enough to simply specify the characteristic text.

Procedure

Setup
The data you enter in Excel is uploaded into the SAP System using a suitable file description. You are therefore required to use an Excel template defined in Customizing for your offline planning. You need to proceed as follows:

1. Follow the procedure outlined in the section Setting Up Integrated Excel [Page 344] and structure you Excel sheet template according to your needs.
2. Enter a generic file name [Ext.] under Generic file. This name must consist of a string of characters (upper case), an asterisk (*), and the file suffix ".TXT" (example: PLANNING*.TXT).

When you later upload Excel files into the SAP System, this generic file name links the file on your local PC to the file description.

The name ranges of the various generic file names cannot overlap, because this would mean that the assignment of file name to file description would not be unique. For example, if you assigned the generic file name PLAN*.TXT to one file description and PLANS*.TXT to another, file PLANS03.TXT would not be uniquely assigned.

For an overview of all file descriptions together with the generic file names, you can call up the program RKCDPREO with the ABAP Editor for the ABAP Workbench. From the list drawn up by the program, you can delete any file descriptions and generic file names that are no longer used.

3. In Excel, save a copy of the file on your PC and assign it a name that matches the generic file name [Ext.]. For example, if the generic file name is SALES*.TXT, you can name the downloaded file SALES1, SALES2, or SALES_NW.

You have to save your copy of the Excel template as an Excel file (suffix ".XLS") for the template to be opened correctly. The text format (suffix ".TXT") becomes necessary when the file is uploaded back into the SAP System. For this reason, you must save the file with file type "TXT" before uploading it into the SAP System.
Planning Offline and Uploading into the SAP System

Once you have downloaded the Excel template, you can make copies of it or give it to other users for the purpose of offline planning. The name of each new file you create must still adhere to the generic file name so that they can be uploaded later.

Local Planning

1. Enter your planning data offline using the downloaded Excel file (or copies of this file). Whenever you want to save your planning data but are not yet ready to upload it, save in .XLS-format.

   Note the following for local planning:
   - You must avoid any use of the following Excel functions:
     - Delete
     - Paste
     - Sort
     Use of the above functions prevents data from being imported correctly into the SAP System.
   - You can perform additional calculations or add diagrams on a second spreadsheet since only the first spreadsheet is saved when the Excel folder is saved as a TXT file before uploading. The additional spreadsheets are therefore not relevant for uploading.
   - During the upload, the SAP System interprets each row as an object. This means that, before you upload the file, you must delete any totals or subtotals rows. Otherwise the system will try to interpret these as separate planning objects and import them into the database as well.
   - If you want to delete a characteristic value (such as a product or cost element) in the SAP System, enter a zero in that row. This is necessary because the system uploads exactly those objects that are contained in the Excel file. If you remove the individual object completely, its values will not be reset to zero in the SAP System.

2. When you are ready to upload your data, save the file in text format (suffix ".TXT").
3. Make sure that the file name adheres to the generic file name, so that it can be assigned to the file description correctly.

Uploading Files

1. To import planning data into the SAP System, call up the uploading function:
   - By choosing Extras → Excel Planning → Upload in the planning menu for Cost Center Accounting
   - By choosing Planning → Integrated Planning → Upload from Excel → Execute in the Profitability Analysis menu.
   - By choosing Planning → Plan values → Upload from Excel in the Special Ledger menu.

2. Specify the file or directory that you want to import.
3. In the file description field, you can specify the file description with which the file(s) are to be imported. If you leave this field blank, the system will automatically create a file description using the generic file name.
4. Upload your files.
Utilities

Use

This section describes the utilities in cost center planning with which you can generate plan values from already planned or posted data from the SAP R/3 System. You can also have these plan values calculated by the R/3 System or transfer plan values to cost center planning. You have the following options:

- **Copying Plan Values** [Page 360]
- **Copy Actual Values to Planning** [Page 368]
- **Revaluate Planning** [Page 371]
- **Revaluate Plan Data** [Page 377]
- **Maintain Resource Prices** [Page 223]
- **Copy Resource Prices** [Page 224]
- **Revaluate Resource Prices** [Page 226]
- **Periodic Repostings** [Page 659]
- **Plan Accrual Calculation** [Page 389]
- **Plan Costs, Statistical Key Figures, or Activity Inputs Using Formulas** [Page 391]
- **Locking Planning** [Page 441]
- **Transfer Plan Data From Other Applications** [Page 442]
Deleting Planning Data

Use
Plan data that you no longer require (perhaps because you want to regenerate your planning according to other criteria) can be deleted. In so doing, you can either delete:

- Planned costs.
- All planning data, including activity quantities and key figures and prices.

Every user authorized to plan is also authorized to delete planning data, unless you specify otherwise in authorization management. For reasons of security, you should revise your authorization concept relating to planning data, entering authorizations for deleting planning data where necessary.

Features
When deleting planned costs, the R/3 System takes the following business transactions into account:

<table>
<thead>
<tr>
<th>RKP1</th>
<th>Planning Primary Costs</th>
</tr>
</thead>
<tbody>
<tr>
<td>RKP5</td>
<td>Planning Revenue Elements</td>
</tr>
<tr>
<td>RKP6</td>
<td>Activity-dependent planning Primary costs</td>
</tr>
<tr>
<td>RKP8</td>
<td>Planning Settlement Costs</td>
</tr>
<tr>
<td>RKP9</td>
<td>Activity-dependent planning order costs</td>
</tr>
<tr>
<td>RKPZ</td>
<td>Planning overhead credits</td>
</tr>
</tbody>
</table>

When deleting all planning data, the system also takes the following business transactions into account:

<table>
<thead>
<tr>
<th>CPPP</th>
<th>ABC process assessment: Plan</th>
</tr>
</thead>
<tbody>
<tr>
<td>KAZP</td>
<td>Plan Cost Center Accrual</td>
</tr>
<tr>
<td>KOAM</td>
<td>Plan internal activity allocation settlement</td>
</tr>
<tr>
<td>KOAP</td>
<td>Plan Settlement</td>
</tr>
<tr>
<td>RKP2</td>
<td>Planning Activities</td>
</tr>
<tr>
<td>RKP3</td>
<td>Plan Secondary Costs</td>
</tr>
<tr>
<td>RKP4</td>
<td>Planning statistical key figures</td>
</tr>
<tr>
<td>RKP7</td>
<td>Activity-dependent planning secondary costs</td>
</tr>
<tr>
<td>RKPB</td>
<td>Planned periodic reposting</td>
</tr>
</tbody>
</table>
## Deleting Planning Data

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RKPD</td>
<td>Transfer materials planning from PP</td>
</tr>
<tr>
<td>RKPK</td>
<td>Plan key figures with template</td>
</tr>
<tr>
<td>RKPL</td>
<td>Plan Indirect Activity Allocation</td>
</tr>
<tr>
<td>RKPP</td>
<td>Primary planning with template</td>
</tr>
<tr>
<td>RKPS</td>
<td>Plan secondary costs with template</td>
</tr>
<tr>
<td>RKPU</td>
<td>Plan Overhead Cost Assessment</td>
</tr>
<tr>
<td>RKPV</td>
<td>Plan Overhead Cost Distribution</td>
</tr>
<tr>
<td>RKPW</td>
<td>Secondary order cost planning</td>
</tr>
<tr>
<td>RKPX</td>
<td>Activity-dependent secondary order cost planning</td>
</tr>
<tr>
<td>KSP0</td>
<td>Plan splitting</td>
</tr>
<tr>
<td>KSP1</td>
<td>Primary plan splitting</td>
</tr>
<tr>
<td>KSP2</td>
<td>Secondary plan splitting</td>
</tr>
<tr>
<td>KSP3</td>
<td>ILV plan splitting</td>
</tr>
<tr>
<td>KZPP</td>
<td>Periodic plan overhead rates</td>
</tr>
</tbody>
</table>

See also:

- [Deleting Planned Costs](#) [Page 355]
- [Deleting Planning Data](#) [Page 356]
Deleting Planned Costs

Use
If you want to replan your primary and secondary costs, you can delete either selected primary cost elements and revenue elements or all primary cost element and revenue elements from your version.

Procedure
To delete planned costs:
1. Choose *Accounting* → *Controlling* → *Cost Center Accounting* → *Planning* → *Planning Aids* → *Delete* → *Planned costs*.
2. Enter a version, a fiscal year, and the cost elements to be deleted.
3. Maintain the following processing options:
   a. If you initially do not want to update the values, but only want to check the dataset to be deleted, select *Test run*.
   b. To delete large amounts of data, choose *Background processing*. This enables you to process data at times when system usage is at a minimum.
4. Choose *Execute*. 
Deleting Planning Data

Use
If you want to regenerate your entire planning, you can delete all planning data such as costs, activity quantities, resource quantities, key figure quantities, and prices in your version for a given fiscal year.

Procedure
To delete planning data, proceed as follows:

1. Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning aids → Delete → Planning data.

2. Select the version and the fiscal year in which you want to delete planning data.

3. Maintain the following processing options:
   a. If you want to delete large amounts of data, choose Background processing. This enables you to process data at times where system usage is at a minimum.
   b. If you do not want to update the results immediately, select Test run.
   c. To go ahead with deleting your planning data, deactivate Test run and choose Execute.
Copying Planning Values

Use

The Planning function is a planning aid that enables you to copy planning values automatically from business transactions that can also be planned manually. You can:

- Reuse large parts of your manual planning from the previous year for your current fiscal year
- Transfer plan values within a fiscal year across different periods
- Generate alternative versions
- Use SAP enhancements to extend the standard functions for copying plan data

If you want the plan allocation data (such as assessment or distribution) to also be available in the target version, you need to make the corresponding allocations in the target version.

You need to create the cycles in the target version. You can reference the cycles in the source version for this.

Features

You can copy the following planning data:

1. Primary costs/revenues
   a. Primary costs (not dependent on activity)
   b. Primary costs (dependent on activity)
   c. Revenues
2. Secondary costs
   a. Activity input (not dependent on activity)
   b. Activity input (dependent on activity)
   c. Other secondary costs (not dependent on activity)
      i. Secondary order costs
      ii. Settlement costs
      iii. Credits from overhead rates
   d. Other secondary costs (dependent on activity)
      i. Secondary order costs
      ii. Settlement costs
3. Other planning data
   a. Statistical key figures:
   b. Activity quantities
   c. Prices
Copying Planning Values

Currencies for Copying

The usage of different currencies when you copy planning data depends on the All currencies indicator in your controlling area, for the template and target fiscal year. The system determines the currencies from the value date and the exchange rate type if these currencies are not transferred 1:1 from the template to the target fiscal year.

You need to differentiate between the following:

• **All** currencies are active in the template and target fiscal year.
  
  The system determines the object currency from the transaction currency, using the exchange rate type and the value date.

• **Not all** currencies are active in the template and target fiscal year.
  
  In this case, the controlling area currency is the leading currency, and is transferred when you copy 1:1 from the template to the target fiscal year.

  All other currencies:
  
  - If all currencies are active in the target fiscal year only, then the SAP R/3 System determines the object currency from the controlling area currency. The transaction currency is the same as the controlling area currency.
  
  - If all currencies are active in the template fiscal year only, then the system updates only the controlling area currency in the target fiscal year as the only currency.

  When you are copying, currency is translated using the exchange rate for the target version. As the system copies on a period basis, and as rounding differences cannot be avoided during copying, this may cause minor variances in the period values. The total value of the target version is the sum of the period values. As a result, the period level variance is transferred to the total value level. This can cause significantly greater variances in the total value, than on the period level.

Leading Currency

When copying planning values, you can specify a leading currency for costs and prices. The standard settings is such that the system uses the transaction currency for the costs, and the controlling area for the prices.

You can select the following currencies for costs:

• Controlling area currency
• Transaction currency

  You can only select the transaction currency if you have already selected All currencies in the source and target fiscal year of your controlling area. If, however, this indicator is not selected in a given fiscal year, the R/3 System automatically selects the controlling area currency as the leading currency.

  If you have planned using the transaction currency, you must also copy using the transaction currency.

• Object currency
You can only select the object currency if you have already selected All currencies in the source and target version of your controlling area. If, however, this indicator is not selected in a given version, the R/3 System automatically selects the controlling area currency as the leading currency.

The transaction currency is set as a default.

**You can select the following currencies for prices:**

- Controlling area currency
  
  The controlling area currency is set as a default.

- Object currency

**SAP Enhancements**

You can enhance the standard functions for copying planning data. You can process the data imported for copying before you transfer it to the planning interface for validation and updating. The enhancement COOMKPT4 offers the following:

For a detailed description, see the [online help](#) for enhancement COOMKPT4, and the Implementation Guide (IMG) for Controlling, under Cost Center Accounting → Planning → Planning Aids → Develop Enhancements for Copying Actual and Plan Data [Ext.].

**1:1 copies or 1:n copies**

You can copy planning data as follows:

1. 1:1
   
   You copy planning data belonging to one or more reference cost center(s) to the same cost center(s) in the target version.

1. 1:n
   
   You copy planning data belonging to one or more reference cost center(s) to one or more differently named cost center(s) in the target version.

For information about this procedure, see [Copying Planning](#) [Page 360].
Copy planning

Procedure

To copy planning, proceed as follows:

1. In the planning menu of your application, choose Planning aids → Copy → Copy Plan to plan

2. Enter the leading currency.
   Before using the copying transaction, you can specify the currency in which the costs and prices are to be recorded. Choose Plan currencies and select a currency for costs, and for prices.

   - If you have posted multiple planning records for a cost element with different transaction currencies, do not select the object currency and the controlling area currency. Instead, select the transaction currency as the leading currency.
   - You can only select the transaction currency for costs and prices if you have already selected All currencies in the source and target fiscal year of your controlling area.
   - You only copy planned records in transaction currency if the transaction currency is the leading currency.

3. Select the target to be copied to. To do so, choose one of the following options:
   - A single cost center or business process
   - A cost center interval or business process interval
   - A cost center group or business process group
   - All cost centers or business processes

   You can also define a selection variant in which you specify selection criteria that meet your particular requirements.
   To do so, choose Selection variant and the Create icon.

4. Choose a template.
   Enter a Version, From period, To period, and a Fiscal year.

5. Choose a target.
   Enter a Version, From period, To period, and a Fiscal year.

   You can copy:
   - Within fiscal years, periods, and versions

   At least one of the above selection criteria must be different in the target version.
   Planning values cannot be copied to themselves.
   - Between different fiscal years, periods, and versions
When copying, either all of the template selection criteria can differ from the target selection criteria or at least one of the selection criterion.

You can copy the following data:

<table>
<thead>
<tr>
<th>Copy from</th>
<th>Targets</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version</td>
<td>From period</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
</tr>
</tbody>
</table>

6. Specify whether you want to make a 1:1 copy or a 1:n copy.
   a. To make a 1:1 copy, activate Template = target.
      The system copies planning data belonging to one or more template cost center(s) to the same cost center(s) in the target version.
   b. To create a 1:n copy:
      Activate Choose template
      Choose Select
      Enter the template cost center you require.
      You can only copy 1:n (multiple copies) if you are not using detailed planning.

7. Select the plan data to be copied.
   This data may be data belonging to:
   - All planning transactions
   - Individual planning transactions
   You can either copy planning values for all planning transactions or just for individual business transactions, such as activity-independent primary costs or activity-independent activity inputs.
   - Planning structures with or without data
   You can copy only the planning structures, that is planning records without planning values, or you can copy the structures and the corresponding planning values.

8. Choose the following settings:
   - Long texts
     These are texts that you entered during the planning process
   - Detailed planning
Copy Planning

You can copy detailed planning, provided:

- The template and target fiscal year are identical
- You copy the data for all periods, not for individual periods
- The exchange rate type and the value date in the template and target versions are identical
- You create a 1:1 copy (in other words, you must copy from the template).
- You can only copy detailed planning within a cost center, but you can copy between different versions.

9. Maintain the following processing options:

- Do not change
  
  If you do not want the system to change the data in the target, activate the *Do not change* indicator.

  If you want to copy data for a certain object that already has data in the target version, the system does not copy the actual data if the indicator *Do not change* is active.

- Reset and overwrite

  When you set this indicator, the SAP system deletes any existing data in the target version. You therefore should check to make sure that you want to overwrite the existing data.

- Background

  If you want to copy large volumes of planning data, you should schedule a background job for a time when system workload is low and activate the *Background processing* indicator.

- Test run

  If you do not want the system to update the results, select *Test run*. The system then generates a log, but does not change any data.

- Detail list

  The SAP system creates a list with all copied data records and the planning processes selected for copying.

To speed up copying and avoid unnecessary system use, note the following:

- Select only the business transactions you have actually planned. If, for example, you have not planned any secondary order costs, you should deactivate the corresponding planning transaction.
- If copying large quantities of data, ensure that you select background processing. This means you can process data at times of minimal system usage.
- If copying large quantities of data online, ensure that you start the copying program per business transaction. Ensure that you copy the activity types before you copy the other...
planning areas, since the system requires the activity types to update activity-dependent records.

- Avoid copying existing data with the indicator *Reset and overwrite*. This minimizes the amount of data which has to be read during reset.

- Do not use the detailed list if the list of copied records is not absolutely necessary. The basic list (without copied records) is always displayed.

- If possible, do not copy long texts, as this considerably increases program runtime.

- Copy only parts of the cost center hierarchy.

Copying multiple periods or an entire fiscal year has only a minimal effect on runtime when compared with copying a single period.
Copy Actual Data Into Planning

Use

The function *Copy actual to plan* is a planning aid that lets you copy actual values automatically from business transactions that can also be planned manually. You cannot copy any periodic allocations in the actual like periodic reposting, distribution, accrual calculation. You must also execute them in the plan. You can:

- Reuse large parts of your actual data from the previous year for your current fiscal year
- Transfer actual values to planning within a fiscal year, independently of period
- Use SAP enhancements to extend the standard functionality for copying actual data

Features

You can copy the following actual data:

1. Activity types
   a) Activity quantities that are created on the sender side using manual activity allocation
   b) Activity quantities determined through indirect activity types
   c) Activity quantities recorded for nonallocable activity types
   d) Actual prices

   The R/3 System updates the actual prices as plan prices in the target version. In the plan, the system valuates the activity quantities consumed by the receivers.

2. Primary costs

   You can copy only the following business transactions that can be planned manually:
   a) Primary postings from Financial Accounting, and postings of cost element category 90 (statistical)
   b) Repostings in CO

   Actual values from automatic business transactions, such as periodic repostings or distribution cannot be copied. These enhancements enable you either to remove these cost elements, or to replace them with cost elements that can be planned manually.

   Primary costs are updated by activity type if you have carried out actual cost splitting. Cost portions that have not been split, or only partially, are posted independent of activity types.

<table>
<thead>
<tr>
<th>Cost centers</th>
<th>Cost element</th>
<th>Activity type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>400000</td>
<td></td>
<td>35 USD primary posting 20 USD + 15 USD</td>
</tr>
</tbody>
</table>
20 USD of primary costs were posted to cost center C1. The split distributed the 20 USD on activity types AT1 and AT2 and credited the cost center with 20 USD. Then 15 USD was posted.

When you copy this data to your plan, the R/3 System updates the following planning records:

<table>
<thead>
<tr>
<th>Cost centers</th>
<th>Cost element</th>
<th>Activity type</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>400000</td>
<td>AT1</td>
<td>10 USD, activity-independent planning</td>
</tr>
<tr>
<td>C1</td>
<td>400000</td>
<td>AT2</td>
<td>10 USD</td>
</tr>
<tr>
<td>C1</td>
<td>400000</td>
<td></td>
<td>-20 USD credit from splitting</td>
</tr>
</tbody>
</table>

3. Revenues
   You can also copy statistical revenues to the cost center. The planning is also statistical.

4. Activity allocation
   You can copy manually posted activity allocations, but not automatic business transactions.
   The plan data is updated the same way as in manual planning. The system only updates the planned quantities. The costs are calculated using plan quantity X plan price. If you have carried out actual cost splitting [Page 368], the system updates the activity input by activity type in the same way as the primary costs.

5. Order Settlement
   You can copy debits to cost centers from order settlement. The plan data is updated by the R/3 System as primary or secondary order costs, depending on the source of the costs.
   If you have carried out actual cost splitting, the system updates the order settlement costs by activity type in the same way as the primary costs.
   There are two possibilities:
   a) The target version does not use plan-integrated orders.
      The system copies all the order settlement costs.
   b) The target version uses plan-integrated orders.
      The system only copies the settlement costs for orders that are not plan-integrated. For plan-integrated orders, you need to use plan settlement in the target version.

If an order has been settled by cost element, the system does not copy the corresponding debit records of the cost center. The records are listed in the error log.
Cost Center Accounting (CO-OM-CCA)

Copying Actual Data Into Planning

with a message saying that primary cost elements or assessment cost elements are not allowed in secondary cost planning. In order cost planning, only cost elements of category 21 (Internal settlement) are allowed. You can avoid this error by replacing the original cost element with a settlement cost element in the SAP enhancement.

6. Overhead

You can copy the credits posted to cost centers as overhead. Planning of overhead cost elements must be activity-independent. As with order settlement costs, only records on orders that are not plan-integrated are copied if the target version uses plan-integrated orders.

7. Statistical key figures

Plan statistical key figures are updated the same way as the actual statistical key figures (activity-dependent or activity-independent).

Activity-independent and activity-dependent planning

As of Release 4.5A, the R/3 System splits the planned activity-independent costs during the copying transaction. This means that you no longer have to split actual costs in the reference version if you want to retain planned activity-dependent costs in the target version.

When you copy data into planning, the R/3 System automatically splits primary and secondary costs from activity allocation and order settlement onto the activity types. The splitting is executed according to the target costs of the reference fiscal year (first splitting step) in the target version, the system updates the plan data as activity-dependent (fixed/variable) or activity-independent. This depends on how you planned in the reference in plan version 0.

As only the first splitting step is made, the costs in the target version have the same structure after the copying as the planned values in the reference version. The plan data in the target version exist as if they had been planned manually.

The actual costs of 900 USD posted to cost center C1 in 1998 are copied into the planning for 1999. During the copying, the system uses the target costs (or plan costs) of 1998 to split the actual costs on the activity types AT1 and AT2. It also splits the costs into an activity-independent portion.

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Activity type</th>
<th>Cost element</th>
<th>Target costs/plan costs</th>
<th>Actual costs</th>
<th>Plan costs after copying</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td></td>
<td>400000</td>
<td>300 USD</td>
<td>900 USD</td>
<td>450 USD</td>
</tr>
<tr>
<td>C1</td>
<td>AT1</td>
<td>400000</td>
<td>200 USD</td>
<td>300 USD</td>
<td></td>
</tr>
<tr>
<td>C1</td>
<td>AT2</td>
<td>400000</td>
<td>100 USD</td>
<td></td>
<td>150 USD</td>
</tr>
</tbody>
</table>

Note that, following copying, plan values and actual values can vary due to different currency conversion. For actual data, the system converts the values for every posting using the average rate as per the posting date. For planning data, the system converts the total per period based on the assumed exchange rate and the value date of the plan version.
SAP Enhancement

You can enhance the standard functionality for copying actual data into planning. The enhancement COOMKPT4 offers the following:

For a detailed description, see the online documentation for enhancement COOMKPT4 as well as in the Implementation Guide (IMG) for Controlling, under Overhead Cost Controlling → Cost Center Accounting → Planning → Planning Aids → Program Enhancements for Copying Actual and Plan Data [Ext.].

For information about how to copy actual data, see also Copying Actual to the Plan [Page 368].
Copy Actual To Plan

Procedure

To copy actual values to a new plan, proceed as follows:

1. Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning aids → Actual to plan.

2. Select the target to be copied to. To do so, choose one of the following options:
   • A single cost center or business process
   • A cost center interval or business process interval
   • A cost center group or business process group
   • All cost centers or business processes

   You can also define a selection variant in which you specify selection criteria that meet your particular requirements.

   To do so, choose Selection variant and the Create icon.

3. Choose a template.

   Enter a From period, To period, and a Fiscal year.

4. Choose a target.

   Enter a Version, From period, To period, and a Fiscal year.

   You can copy:
   – Copying data within fiscal years and periods
   – Copying data between different fiscal years and periods

   When copying, either all of the template selection criteria can differ from the target selection criteria or at least one of the selection criterion.

   You can copy the following data:

<table>
<thead>
<tr>
<th>Actual reference</th>
<th>Target plan</th>
</tr>
</thead>
<tbody>
<tr>
<td>From period</td>
<td>To period</td>
</tr>
<tr>
<td>1</td>
<td>6</td>
</tr>
<tr>
<td>1</td>
<td>6</td>
</tr>
<tr>
<td>1</td>
<td>12</td>
</tr>
</tbody>
</table>

5. Select the actual data to be copied.

   This data may be data belonging to:
   – All actual data
Data belonging to particular business transactions

You can either copy plan values for all planning transactions or just for individual business transactions, such as primary costs, revenues, activity quantities.

Structures with or without data

You can either copy the structures only (planning records without planning values) or you can copy both the structures and the corresponding planning values.

6. Maintain the following processing options:

- Do not change

  If you do not want the system to change the data in the target, activate the Do not change indicator.

  If you want to copy data for a certain object that already has data in the target version, the system does not copy the actual data if the indicator Do not change is active.

- Reset and overwrite

  When you set this indicator, the SAP system deletes any existing data in the target version. You therefore should check to make sure that you want to overwrite the existing data.

- Background

  If you want to copy large volumes of data, you should schedule a background job for a time when system workload is low and activate the Background processing indicator.

- Test run

  If you do not want the system to update the results, select Test run. The system then generates a log, but does not change any data.

- Detail list

  The system creates a list containing all the data records copied and the actual business transactions that you selected for copying.

If you activated the Reset and overwrite indicator, and have already carried out a plan cost split in the target version, the system does not overwrite the data that was split. You need to carry out the split again after copying the data.

To speed up copying and avoid unnecessary system use, note the following:

- Select only the business transactions you have actually planned.

- If copying large quantities of data, ensure that you select background processing. This means you can process data at times of minimal system usage.

- If copying large quantities of data online, ensure that you start the copying program per business transaction. Ensure that you copy the activity types before you copy the other
Copy Actual To Plan

planning areas, since the system requires the activity types to update activity-dependent records.

- Avoid copying existing data with the indicator *Reset and overwrite*. This minimizes the amount of data which has to be read during reset.

- Do not use the detailed list if the list of copied records is not absolutely necessary. The basic list (without copied records) is always displayed.

- Copy only parts of the cost center hierarchy.
Reevaluating Cost Center Planning

Use

You can reevaluate existing versions using various criteria: You can reevaluate primary costs that can be planned manually (activity-independent and dependent) and revenues as a percentage consumption also. This allows you to reevaluate complete plans or parts of them.

- You cannot revaluate cost elements for assessment, accrual or indirect activity allocation.
- The system does not include data records from resource and dependency planning during revaluation.

The revaluation amount (determined from the revaluation percentage) is added to or subtracted from the existing amount. The system documents the revaluation using line items. You can execute a revaluation for the entire fiscal year, as well as for individual periods.

All currency fields are involved in the revaluation (provided they were filled during planning).

Revaluation Organization

To revaluate a cost center plan, proceed as follows.

- Creating/Changing an (Existing) Revaluation
  
  Specify the rules with which the relevant cost centers and cost elements of the controlling area are to be reevaluated. Each rule is stored as a revaluation. You can define multiple revaluations in one controlling area.

- Executing the Revaluation
  
  The revaluation is executed, reversed or repeated.

For more information, see Structuring Revaluations [Page 372] and Creating Revaluations [Page 373].
Structuring Revaluations

Use

The diagram below shows the criteria according to which you can structure a revaluation. It is possible to revaluate multiple areas of the controlling area according to different aspects.

Defining a Revaluation

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
</tr>
</thead>
<tbody>
<tr>
<td>All cost elements</td>
<td>m Cost element groups</td>
</tr>
<tr>
<td>All cost centers</td>
<td>1 revaluation</td>
</tr>
<tr>
<td>n sub-hierarchies</td>
<td>n revaluations</td>
</tr>
<tr>
<td></td>
<td>n x m revaluations</td>
</tr>
</tbody>
</table>

If you want to revaluate the entire controlling area based on the same criteria, you require only one revaluation. The following section contains an example of a revaluation:

The total primary costs are to be increased by 10% for the shop floor area, and by 5% for the logistics area. You define a separate revaluation for each area.

Use selection criteria to specify the cost center(s) and cost element(s) you want to revalue. Then set the percentage rates. You can choose between:

- Revaluation of costs
- Revaluation of consumption
Creating Revaluations

Procedure

To create revaluations:


2. Enter the following data on the initial screen:
   - Name of the revaluation
   - Fiscal year
   - From period, To period
   - Version

3. Enter the cost center(s) and cost element(s) you want to revaluate. You specify individual values, intervals or a group.

   If you have defined and stored a revaluation with a cost element group and then make a change to this group under group maintenance, then although the system displays the up-to-date cost element group when you call up the revaluation function once again, the original values remain on the database. It follows that before revaluation using the changed cost element group, you should branch to the definition of the revaluation, choose the Definition pushbutton and then choose Save again since only then does the system carry out the revaluation using the up-to-date cost element group.

4. Specify the revaluation percentage rates for costs and/or consumption.

4. For more information on creating revaluations, see the Cost Center Accounting Implementation Guide under Planning → Planning Aids → Define Revaluation.

Deleting revaluations

Revaluations can be deleted at any time. To do so, choose Planning → Planning aids → Revaluate → Costs → Extras → Revaluation → Delete.

⚠️ Before you delete existing revaluation definitions, you should ensure that all revaluations performed with these revaluation definitions are reversed. This is because you can no longer reverse a revaluation once the definition has been deleted.
Carrying Out Revaluations

Procedure

To execute a revaluation:

1. Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning aids → Revaluate → Costs.
2. Enter the following selection parameters for your revaluation:
   a) Fiscal year
   b) From period, To period
   c) Version
3. Maintain the following processing parameters:
   a) Background processing
   b) Test run
   c) Basic lists

   If you do not select Background processing, the system executes the revaluation online. If you have large amounts of data to process, you should execute the revaluation in the background. This means you can process data at times of minimal system usage.

   Detailed list and Test run are defaulted to active. This ensures that you can check the results of the test run. If Detailed list is active, the system displays a results list for the revaluation. Otherwise, the system displays a message describing whether and, if applicable, how the revaluation was closed.

   If you select Test run, the system executes the revaluation, but it does not update any results. If you deselect Test run, the system does update the results. If Test run is selected, you can only remove any errors by reversing the entire revaluation.

4. Enter a name for your revaluation and choose Execute.
5. You can also choose to save variants when you execute the revaluation. This enables you to save different combinations of revaluations and call them up when required.

   Choose Save variant, then enter a variant name and a description.

   If you want to execute the same revaluation again, you can call up the saved variant.

   Choose Get variant and enter a name.

Reversing revaluations

You can reverse revaluations at any time by choosing Reverse in the revaluation initial screen. The system reverses the line items of the revaluation.

Repeating revaluations

Revaluations can be repeated as often as desired. The table below shows which combinations are supported, and which system precautions are to be taken.

Repeating revaluations
## Carrying Out Revaluations

<table>
<thead>
<tr>
<th>Combination</th>
<th>Repeat with changed percentage rate</th>
<th>Repeat with new structures (cost centers/cost elements)</th>
<th>Repeat with old revaluation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Steps in the SAP System</strong></td>
<td>Change the revaluation percentage rate in the revaluation</td>
<td>Reverse the (old) revaluation with the reversal function. Changing structures in the revaluation</td>
<td>Define a new revaluation</td>
</tr>
<tr>
<td><strong>Effects in the SAP System</strong></td>
<td>The (plan) line items of the previous revaluation are reversed. The changed revaluation is executed with the initial values.</td>
<td>The (plan) line items of the previous revaluation are reversed. The changed revaluation is executed with the initial values.</td>
<td>The (plan) line items are written for each revaluation.</td>
</tr>
</tbody>
</table>
Revaluation of Plan Data

Use

The SAP R/3 System does not automatically revaluate your manually planned data when exchange rates change. If you have set up exchange rate changes in your system, you have to revaluate your manually planned data to achieve an up-to-date version in planning. The SAP R/3 System provides a function with which you can revaluate plan costs as well as plan prices for cost centers with varying exchange rates.

- In order for the system to revaluate your plan data, a leading currency has to be entered. The system uses the leading currency as the basis for recalculation when exchange rates change. Plan data in the leading currency remains unchanged, and the system revaluates the remaining plan values.

- If you created plan records using resource planning and revaluate the values, the system ignores the leading currency for the exchange rate differences of the resource price currency.

  The SAP R/3 System calculates the value directly in all three possible database currencies from the selected currency in which the price of the resource is maintained. This ensures that the following is valid for all currencies: Value = Amount * Price / Price Unit.

  For resource R, a price of 100 BRL per unit has been set up. Cost center KS (object currency DEM) in a controlling area using the currency USD receives 5 units of resource R. The transaction currency is CHF. The database currencies are DEM, CHF, and USD.

See also: Example: Reevaluating Plan Data [Ext.]

Features

When recalculating plan costs, the R/3 System takes the following into account:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RKP1</td>
<td>Planning primary costs</td>
</tr>
<tr>
<td>RKP5</td>
<td>Planning revenue elements</td>
</tr>
<tr>
<td>RKP6</td>
<td>Activity-dependent planning Primary costs</td>
</tr>
<tr>
<td>RKP8</td>
<td>Planning settlement costs</td>
</tr>
<tr>
<td>RKP9</td>
<td>Activity-dependent planning order costs</td>
</tr>
<tr>
<td>RKPZ</td>
<td>Planning overhead credits</td>
</tr>
<tr>
<td>RKP2</td>
<td>Planning activities</td>
</tr>
<tr>
<td>RKP3</td>
<td>Plan secondary costs</td>
</tr>
<tr>
<td>RKP4</td>
<td>Planning statistical key figures</td>
</tr>
<tr>
<td>RKPW</td>
<td>Secondary order cost planning</td>
</tr>
<tr>
<td>RKPX</td>
<td>Activity-dependent secondary order cost planning</td>
</tr>
</tbody>
</table>
Revaluation of Plan Data

For more information on how to proceed, see:

Reevaluating Plan Data [Page 379]
Reevaluating Plan Data

Procedure

To revaluate plan data, proceed as follows:


2. Enter a version, a period interval, and a fiscal year.

3. Select the objects to be reevaluated. You have the following options:
   a. A single cost center
   b. A range of cost centers
   c. A selection variant
   d. All cost centers

4. Enter the leading currency.

Before executing the revaluation transaction, you can specify the currency in which the costs and prices are to be recorded.

- If you have posted multiple planning records for a cost element with different transaction currencies, do not select the object currency and the controlling area currency. Instead, select the transaction currency as the leading currency.

- You can only select the transaction currency for costs and prices if you have already selected All currencies in the source and target fiscal year of your controlling area.

- You only copy planned records in transaction currency if the transaction currency is the leading currency.

5. Maintain the following processing options:
   c. If you do not want to update the results immediately, select Test run.
   d. To check the results, select both Test run and Test run detail list.
   e. To value large amounts of data, choose Background processing. This enables you to process data at times when system usage is at a minimum.

6. Choose Execute.

Result

The system reevaluates all manually planned costs and prices that are affected by the exchange rate differences.
Reevaluating Plan Data
Plan Reconciliation

Use

Plan reconciliation is used to check and reconcile the exchange of internal activity.

It can be used in the following situations:

1. The first time you create a plan

   Each cost center plans its activity output and the necessary activity inputs. This can result in differences between the plan quantities for the sender and receiver cost center/business process. For this reason you should carry out plan reconciliation.

   Plan reconciliation is also active for business processes. The following description refers only to cost centers, but applies equally to business processes or business process groups.

2. Planning adjustments:

   If the planned activity output of a final cost center changes, the entire planning network needs to be reconciled again. Plan reconciliation lets you examine how the change affects the planning network.

   The planned activity output of a final cost center changes, for example, if:

   a) A plan-integrated order plans to use more activity from the final cost center.

   b) An additional cost center plans to consume activity from the previously final cost center

Features

In plan reconciliation, the planned activity output for a cost center is adjusted to the planned activity input for the receiver cost centers. In this way, the SAP System is able to correct the variable activity consumption, as well as the variable costs required to provide the activity. The fixed portions of the activities and costs consumed are not changed by plan reconciliation.

If no activity input is planned for an activity type, the activity quantity is not changed during plan reconciliation. It is therefore unnecessary to plan activity inputs for the activity provided by end cost centers.

The difference between the planned activity production of a cost center and the planned activity consumption by other cost centers is displayed in a list.

Example of Plan Reconciliation [Page 383]

Plan reconciliation is executed iteratively. This means that mutual activity relationships between cost centers are taken into account. Mutual activity relationships occur, for example, when a cost center plans to consume activity from a cost center, to which it also provides activity.
Plan Reconciliation

Note the following when using plan indirect activity allocation: (see: Indirect Activity Allocation [Page 713])

After plan reconciliation is completed, indirect activity allocation must be repeated because the tracing factors may have changed. This means that the indirectly allocated activity must be redistributed to the receivers.

If the activity to be indirectly allocated was **manually planned**, the activity and the activity-dependent plan costs are adjusted to the correct activity production by plan reconciliation.

If the activity was itself **indirectly calculated**, the activity is no more than a numerical figure. Plan costs of this activity are independent of the size of this figure, even if they were planned activity-dependent. Plan reconciliation neither changes the figure nor adjusts the activity-dependent costs. If indirect activity allocation is repeated, the number is recalculated on the basis of the changed tracing factors and posted, without changes in the activity-dependent costs.

See also:

Executing Plan Reconciliation [Page 385]
Example: Plan Reconciliation

Administrative cost center 920 plans the output of 200 administrative hours. Administrative cost center 921 plans the input of 240 administrative hours from cost center 920 and the output of 400 administrative hours. Motor pool cost center 110 plans input of 400 hours from cost center 921 and activity production of 5000 kilometers. Garage cost center 122 plans the input of 100 hours from cost center 921 and output of 200 repair hours.

In the plan reconciliation list, cost center 921 and cost center 900 display a difference of 100 administrative hours between plan activity and plan activity input of the receiver cost centers.
Example: Plan Reconciliation

After posting plan reconciliation, the plan activity quantity of cost center 921 is raised 25% from 400 to 500 hours. Plan activity input for cost center 921 is also raised 25% to 300 hours. The plan activity quantity for cost center 920 is adjusted to the plan activity input of cost center 921 and raised to 300 hours.

See also:
Executing Plan Reconciliation [Page 385]
Executing Plan Reconciliation

Procedure

To execute plan reconciliation, proceed as follows:

1. Choose Accounting → Controlling → Cost center Accounting or Activity-Based Costing → Planning → Planning aids → Plan reconciliation.

2. Choose either
   - Cost center group/business process group
   - All cost centers/all business processes
   - No cost center/business process

3. On the initial screen, enter the following:
   - Version
   - Periods
   - Fiscal year

4. Choose Test run, Background processing, and Detailed list to control the type of processing as well as the formatting of the results. Select one or several options and choose Plan reconciliation → Execute.
   - Select Test run so that the system carries out plan reconciliation but does not post the results.
   - Select Test run, and Detailed list. In this way, you can check the test run results.
   - If the values are correct, you can post the results in the plan reconciliation list screen. Choose Execute.
   - Alternatively, you can answer “Yes” to the posting prompt when leaving the list screen, or deselect Test run on the initial screen and choose Execute.
   - If you are working with large amounts of data, execute reconciliation in a background job during periods of low system usage.

Choose Settings. You can then limit the number of iterations and the scope of the plan reconciliation.

Detailed List

The plan reconciliation list in the defaulted display variant identifies all plan activity quantities for cost centers for each activity type or business process.

The planned activity quantities are compared with the reconciled plan activity. These were calculated during plan reconciliation from the planned activity inputs of the receiver objects.

A further column displays the calculated difference between the planned activity quantities and the reconciled plan activity.
Executing Plan Reconciliation

When plan reconciliation is posted, the variable portion of the activity quantity is adjusted to the planned activity quantity of the receiver objects and is updated as a variable plan activity quantity.

You can structure the list screen for plan reconciliation using the following functions:

- Choose or Settings → Display variant → Current to change the position and length of the list display fields within a dialog box.

  You can find additional information on dialog box use under Functions of the ABAP List Viewer [Ext.].

- Choose Edit → Sort to arrange the rows of the list in ascending or descending order after entering individual columns.

- Choose Edit → Find to search for terms.

- Choose Edit → Set filter to limit the plan reconciliation results list with a user-defined condition.

  Enter the field name that is to act as the delimiting criterion. Save an amount for this field.

  In the new condition, select the field “Total plan activity”.

  Enter 500 in the Amount field.

  The SAP System displays only those entries in the results list where plan activity exceeds 500 units.

- Choose List → Print to print the screen list.

Period values

After call up, the sum of all period values is displayed in the plan reconciliation list screen.

Choose or Goto → Period values to display the individual period values for the plan reconciliation. You can then choose Previous period or Next period to scroll through the individual periods. The same functions are available as those found in totals display across periods.

Activity analysis

In the period display, you can call up the activity analysis for any displayed object. To do so, position the cursor on the row and choose Goto → Activity analysis or Activ.Analysis. From the selected activity type of a cost center of business process, you can follow the activity flow. Select the symbols in the “Activity network” column to summarize the activity relationships or to expand them again. The system displays closed relationships in the activity network using lines in the Activity network column. Members of closed relationships are marked in red.

You can obtain additional information in the activity analysis display by choosing Goto → Activity analysis help.
Periodic Reposting

Use

Periodic reposting [Ext.] is posting aid that enables you to adjust postings made to your cost centers or business processes, internal orders, or WBS elements. It has the same result as transaction-based reposting. The results of transaction-based repostings have a direct effect on the actual costs of the sender and the receiver, whereas periodic repostings have a one-time effect on actual costs at period-end closing.

Postings relevant to Controlling (CO) such as telephone costs, postal charges, insurance, and so on are entered in Financial Accounting (FI) and posted to an allocation cost center or a business process. These are used exclusively for cost collection. This minimizes the number of different account assignments you have to make when entering data in FI. At the end of the period, the collected costs are reposted to the cost centers or business processes which incurred the costs by means user-defined keys (fixed values or dynamic tracing factors). The following information is passed on to the receivers:

- The original cost element (the primary cost element [Ext.]) is retained.

  During periodic repostings, you can allocate activity-dependent plan costs to receiver objects of the category “Cost center” (sender activity type is retained) or "business process”.

  You can allocate activity-independent costs to all receiver object categories, for example, cost centers, business processes, or orders.

- The allocation cost center is not important for the receiver cost centers (neither is the sender business process for the receiver processes). The SAP System therefore stores data records for periodic reposting in a way that uses less memory than, for example, distribution [Ext.].

  For this reason, the sender cost center or sender process is not updated using this method. You can only analyze from which cost center or from which business process the costs originate from the line items, and not from the totals records.
If you are working with transfer prices [Ext.] (multiple valuation approaches) the periodic reposting is executed in parallel in all valuations. The costs to be allocated are taken from the corresponding valuation. The tracing factor is always taken from the values of the operational valuation. The values allocated may differ in each of the valuation methods.

Senders and receivers are displayed in the results list, differentiated according to the parallel actual versions of the various valuations.

For more information on transfer prices, see the SAP Library under:

- Financials → Enterprise Controlling (EC) → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
- Financials → Controlling (CO) → Controlling → Overhead Cost-Controlling → Multiple Valuation Approaches in Overhead Cost Controlling [Ext.]

See also:

Defining Periodic Repostings or Periodic Allocations [Page 747]
Creating or Changing Cycles [Page 770]
Executing Periodic Repostings or Periodic Allocations Online [Page 801]
Displaying the Cycle Overview [Page 773]
Plan Accrual Calculation

Use
Plan accrual calculation lets you plan accrual costs: Accrual costs are subdivided as follows:

- **Additional costs**
  Costs that have no equivalent in Financial Accounting (for example, managerial income or imputed rents)

- **Valuation differences**
  Costs that have a different equivalent in FI (for example, vacation bonuses or insurance)

Payroll fringe costs such as bonuses, which can generally be calculated as a percentage rate of the wage or salary costs, are not usually calculated and planned on every individual cost center. You can calculate these using the plan accrual methods.

The vacation bonus is accrued on the basis of the plan labor costs using an an overhead rate of 10%. The system debits all cost centers on which labor costs are planned.

The SAP R/3 System takes into account the activity-dependent plan costs during the calculation of accrual amounts using the percentage method, which assigns a percentage rate to the fixed and variable portions of the overall costs.

You have planned a total of $200,000 salary costs on cost center 4310. This includes fixed costs of $60,000. The overhead rate for the vacation bonus is 30%. The R/3 System calculates the following accrual amounts:

<table>
<thead>
<tr>
<th>Total</th>
<th>Fixed</th>
</tr>
</thead>
<tbody>
<tr>
<td>200,000</td>
<td>60,000 * 0.3 = 18,000</td>
</tr>
</tbody>
</table>

See also:
[Executing Plan Accrual Calculation](Page 390)
Executing Plan Accrual Calculation

Prerequisites
Before you can execute accrual calculation, you must already have maintained the accrual definition (see: Accrual Calculation [Page 661]).

Procedure
To calculate plan accrual, proceed as follows:

Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning aids → Accrual calculation.

For more information on maintaining the accrual parameters, see the IMG for Controlling, under Overhead Cost Controlling → Cost Center Accounting → Planning → Accrual Calculation [Ext.].
For information on accruals, see also Accrual Calculation [Page 661].
Formula Planning

Use

Formula planning lets you use calculation dependencies to plan your cost center costs. You can define these dependencies as formulas in templates (see: Templates [Page 393]) that are independent of the cost center. In this way, cost centers with similar templates can use the same formulas.

Formula planning supports manual planning. It is particularly suitable for the planning of cost elements and activity inputs whose values are determined on many cost centers using similar logic. For example, Personnel Cost Planning, in which various cost elements (planned as statistical key figures) are derived from the number of employees.

For each cost center, you can create one planning template for activity-independent costs and key figures, and one planning template for activity-dependent costs and key figures. You can then store them in the cost center master record. You can also define subtemplates, to which reference can be made from the higher-level planning template.

In planning template maintenance, which you can find in Customizing, the following values can be used in the formula calculation:
For activity-independent planning templates: Total costs and total quantities
For activity-dependent planning templates: Fixed costs, fixed quantities and variable costs per activity unit, as well as variable quantities per activity unit.

You can use the following data from the SAP R/3 System in formula planning:

- All master data information for the cost center, for example, to define constraints.
- All master data information for the activity type, for example, to define constraints.
- Any primary planned costs
- Plan activity, scheduled activity and capacity for any cost center/activity type
- Any statistical key figures

You can also retain the cost centers, version, activity type and fiscal year as variable, so that the R/3 System can use the up-to-date evaluated cost center, etc. for the calculation.

- The R/3 System calculates the costs in the planning template in the controlling area currency only.
- You cannot plan activities, revenues or order costs.

Prerequisites

During system configuration, you have created a planning template. (See also: The Implementation Guide (IMG) for Controlling, under Overhead Cost Controlling → Cost Center Accounting → Planning → Formula Planning → Maintain Planning Structures [Ext].)
Formula Planning

Features

Formula planning contains the following functions:

• **Template maintenance**
  
  In planning template maintenance you define, per row, one or more formulas for an object (cost element, statistical key figure or calculation row) to calculate costs or quantities (see: Formulas [Page 435]). The R/3 System evaluates these formulas, during which it calculates one object for each row (cost element, statistical key figure). You can take Functions [Page 403] that permit the reading of plan and actual values, for example ACTIVITY_TYPE_ACTUAL_QTY or ACTIVITY_TYPE_PLAN_QTY and link these functions to basic formulas.

  Using the interim results, which you can display in the Calculation Rows [Page 438] the R/3 System can calculate complicated formulas. You can use activations (see: Activation [Page 427]) to represent conditions for which a formula is to be calculated.

  You maintain planning templates in Customizing.

• **Evaluation of the planning template** (see: Evaluating Templates [Page 400])

  When you evaluate a planning template for a cost center or a cost center group, the system uses the formulas defined in the template to calculate the costs or key figure values. To do this, the system calculates each individual planning template for the given cost centers. If the object is a cost element or a statistical key figure, the system creates a plan record on the cost center for the cost element or statistical key figure. This plan record overwrites any manually planned record that may exist. It can be overwritten again in manual planning.

  For the evaluation of planning templates, you can enter any cost centers cost center groups, or all cost centers. For these cost centers, the R/3 System selects the corresponding planning template and evaluates it. You can start the evaluation as often as you wish for one cost center.

Example for Formula Planning [Ext.]
Template

Definition

A template for the Formula-Controlled Calculation [Page 391] of primary costs and statistical key figures on cost centers and activity inputs on cost centers/activity.

Use

In a planning template, you can store Formulas [Page 435], which the system evaluates. They are then used to calculate primary costs, statistical key figures, or activity inputs on the cost centers. Each planning template is assigned to an Environment [Page 401]. Among the factors you specify in the environment is whether a planning template is to be used for the planning of activity-independent or activity-dependent costs, statistical key figures, or activity inputs.

Structure

A planning template consists of rows and columns. You can identify the rows through a specified object type. These can be, for example, Calculation Rows [Page 438], comment rows or rows for the reading of a cost element.

You can use the column parameters to specify the exact characteristic values of the row to be calculated. The following columns exist:

- **Object types:**
  - Specifies the characteristic value of the given row, for example, comment rows, calculation rows, resources, cost elements, statistical key figures, sub-templates.

  If you choose the “Cost element” type, you can store a formula for a cost element in this row. To calculate the value for the given cost element, the system takes planned values that you have used in the formula.

  If you choose the “Calculation row” type, you can use another formula in this row to link previously defined rows.

- **Name:**
  - The name contains a description of the following rows:

- **Object:**
  - You can enter an object or branch to a sub-template. The system calculates a value for the object in a formula that is yet to be defined.

- **Cost formulas:**
  - Fixed costs
To calculate fixed costs, you can enter a formula in the CPI environment for the planning of activity-independent costs. (See also: Formulas [Page 435])

− Variable costs per activity unit

In the CPD environment for the planning of activity-dependent costs, you can enter a formula for the calculation of fixed, and variable, costs per activity unit.

- Quantity formula
  
  − Fixed quantity

  In the CPI environment for the planning of activity-independent costs and key figures, you can enter a formula for the calculation of fixed quantities of a cost element, statistical key figure, resource or the value of a calculation row. (See also: Formulas [Page 435])

  See also: Quantity Determination [Page 425]

  − Variable costs per activity unit

  In the CPD environment for the planning of activity-dependent costs and key figures, you can enter a formula for the calculation of fixed and variable quantities per activity unit of a cost element, statistical key figure or resource.

- Activation [Page 427]

You enter a condition that controls the evaluation of the formula or sets the previously defined rows to active or inactive.

For more information, see the SAP Library under Activity-Based Costing under Template [Page 733] and Processing Templates. [Page 736]
Maintaining Templates

Initial screen
1. In the Implementation Guide (IMG) of the application follow path Templates → Maintain Template [Ext.] → Create template, or Change template.
2. In the Template field, enter the name of the template you wish to create or maintain.
3. Choose Template environment [Page 401].
4. Choose Overview.

When creating templates, you can choose the one with the settings you want to transfer from group box Copy from. You can change this data in the overview screen.

Overview Screen
1. If you are creating a new template, enter a descriptive text.
2. Select the item category in column Category/Obj.
3. Enter a name for the item.
4. Edit the remainder of the columns. You come to the individual columns with a mouse click or by using the keyboard. With a mouse click you arrive at:
   i. Object columns in the selection editor (for procedure, see: Object Determination [Ext.])
   ii. Quantity columns in the quantity editor (for procedures, see: Quantity Determination [Page 425])
   iii. Activation column in the activation editor (for information see: Activation [Ext.]).
5. After creating or changing all the rows, choose Enter.
6. Choose Save data.

To see what column types are available, see information on the corresponding template:

   Templates for Cost Objects and Calculations [Ext.]
   Template for Profitability Segments [Ext.]
   Template for Business Processes/Cost Centers [Page 729]
   Template for Processes Formula Planning [Ext.]
   Template for Cost Center Formula Planning [Page 393]
   Template for Profit Center Formula Planning [Ext.]
   Template for Easy Cost Planning [Ext.]

See also:
Maintaining Templates

Other Methods to Maintain Templates [Page 738]
Other Methods to Maintain Templates

Use

The following functions allow you to maintain the template.

Features

Initial screen

<table>
<thead>
<tr>
<th>In order to</th>
<th>... Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>reach the change mode</td>
<td>Template → Change</td>
</tr>
<tr>
<td>reach the display mode</td>
<td>Template → Display</td>
</tr>
<tr>
<td>reach the create mode</td>
<td>Template → Create</td>
</tr>
<tr>
<td>reach the maintenance of the function tree [Page 416]</td>
<td>Environment → Function tree</td>
</tr>
<tr>
<td>reach the maintenance of the environment [Page 401]</td>
<td>Environment → Maintain environment</td>
</tr>
<tr>
<td>see the Where-used list (an overview of where templates are used as sub-templates, or where business processes or cost centers are assigned to)</td>
<td><a href="#">Template → Where-used list</a></td>
</tr>
<tr>
<td>display the template hierarchy (an overview of all existing templates), delete templates directly in this tree structure If you delete a template from the hierarchy, the template is permanently deleted from the R/3 System. The hierarchy tree structure consists of the levels Controlling area, Environment, Template, and Sub-template.</td>
<td><a href="#">Environment → Hierarchy</a></td>
</tr>
<tr>
<td>Generate templates (this occurs after the transport; see Transport Settings for Activity-Based Costing [Ext.])</td>
<td>You are in the hierarchy display. 1. Place the cursor on a controlling area, an environment or a template. 2. Processing → Generate Template. All templates belonging to the chosen level are generated.</td>
</tr>
<tr>
<td>see an overview of the individual rows of templates which were created, viewed or changed</td>
<td><a href="#">Goto → Overview</a></td>
</tr>
</tbody>
</table>

Overview Screen

<table>
<thead>
<tr>
<th>In order to</th>
<th>... Choose</th>
</tr>
</thead>
</table>
Other Methods to Maintain Templates

<table>
<thead>
<tr>
<th>Action</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch from the display to the change mode (or reverse)</td>
<td><code>Template</code> → <code>Display/Change</code></td>
</tr>
<tr>
<td>Save your entries</td>
<td><code>Template</code> → <code>Save</code></td>
</tr>
<tr>
<td>Check your entries (the system performs a syntax check of formulas and methods, and also ensures that all objects exist; it returns a message after the checking is done)</td>
<td><code>Template</code> → <code>Check</code></td>
</tr>
<tr>
<td>Display the Where-used list</td>
<td><code>Template</code> → <code>Where-used list</code></td>
</tr>
<tr>
<td>Display only the Actual column</td>
<td><code>Actual column</code> or <code>Template</code> → <code>Column selection</code> → <code>Actual column</code></td>
</tr>
<tr>
<td>Display only the Plan column</td>
<td><code>Plan column</code> or <code>Template</code> → <code>Column selection</code> → <code>Plan column</code></td>
</tr>
<tr>
<td>Display all columns</td>
<td><code>All columns</code> or <code>Template</code> → <code>Column selection</code> → <code>All columns</code></td>
</tr>
<tr>
<td>Insert an existing template into one that you will create (all rows of the existing template will be inserted in the current template, and can be changed thereafter)</td>
<td><code>Edit</code> → <code>Insert template</code></td>
</tr>
<tr>
<td>Assign a receiver object to a template - to reach the respective assignment transaction</td>
<td>Environment → Assignment</td>
</tr>
<tr>
<td>- Assigning Templates for Cost Objects and Calculations [Ext.]</td>
<td></td>
</tr>
<tr>
<td>- Templates for Bus. Proc./Cost Center Assignment [Page 732]</td>
<td></td>
</tr>
<tr>
<td>- Assigning Templates for Processes (Formula Planning) [Ext.].</td>
<td></td>
</tr>
<tr>
<td>- Template-Allocation for Profitability Segment Template Allocation for Profitability Segment [Ext.]</td>
<td></td>
</tr>
<tr>
<td>Display the template hierarchy</td>
<td><code>Environment</code> → <code>Hierarchy</code></td>
</tr>
<tr>
<td>Generate templates (see above)</td>
<td><code>Processing</code> → <code>Generate Template</code></td>
</tr>
<tr>
<td>Test the template</td>
<td></td>
</tr>
<tr>
<td>!</td>
<td></td>
</tr>
<tr>
<td>You can test only the templates of environment 001!</td>
<td></td>
</tr>
<tr>
<td>1. Choose <code>edi</code>.</td>
<td></td>
</tr>
<tr>
<td>2. In screen <code>Parameters for testing</code>, enter your test data</td>
<td></td>
</tr>
<tr>
<td>3. Choose <code>edi</code>.</td>
<td></td>
</tr>
<tr>
<td>4. You reach <code>Template Trace: Basic screen [Ext.]</code> and can continue to <code>Template Trace: Detail [Ext.]</code>.</td>
<td></td>
</tr>
</tbody>
</table>
## Editing in Overview screen

<table>
<thead>
<tr>
<th>In order to</th>
<th>... follow these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>select a cell for editing</td>
<td>1. position the cursor on the cell that you want to edit</td>
</tr>
<tr>
<td></td>
<td>2. double click on the row or choose <img src="edit.png" alt="Edit" /></td>
</tr>
<tr>
<td></td>
<td>In the description column you arrive at the long text editor; in the object and activation column, at the selection or activation editor (see, Defining methods [Ext.]); in the quantity column, at the quantity editor (see, Defining formulas [Page 436]).</td>
</tr>
<tr>
<td>create long text for the row</td>
<td>1. mark the row</td>
</tr>
<tr>
<td></td>
<td>2. choose <em>Edit → Item long text</em></td>
</tr>
<tr>
<td></td>
<td>3. in screen <em>Text processing</em> enter an abbreviation for the corresponding language</td>
</tr>
<tr>
<td></td>
<td>4. Choose <img src="abbreviation.png" alt="Abbreviation" />.</td>
</tr>
<tr>
<td></td>
<td>5. enter the text (for more information, see screen <em>Long text for items</em> through Help → Application help)</td>
</tr>
<tr>
<td>copy a row or cell</td>
<td>1. place the cursor on the row or cell</td>
</tr>
<tr>
<td></td>
<td>2. choose <img src="copy.png" alt="Copy" /> or <em>Edit → Copy line/cell</em>.</td>
</tr>
<tr>
<td></td>
<td>3. Place the cursor on the target point</td>
</tr>
<tr>
<td></td>
<td>4. choose <img src="paste.png" alt="Paste" /> or <em>Edit → Insert line/cell</em></td>
</tr>
<tr>
<td>Move a row/line or cell</td>
<td>1. place the cursor on the row or cell</td>
</tr>
<tr>
<td></td>
<td>2. choose <img src="cut.png" alt="Cut" /> or <em>Edit → Cut line/cell</em></td>
</tr>
<tr>
<td></td>
<td>3. Place the cursor on the target point</td>
</tr>
<tr>
<td></td>
<td>4. choose <img src="paste.png" alt="Paste" /> or <em>Edit → Insert line/cell</em></td>
</tr>
<tr>
<td>Insert a line/row</td>
<td>1. place the cursor on the line, over which another line is to be inserted</td>
</tr>
<tr>
<td></td>
<td>2. choose <img src="paste.png" alt="Paste" /> or <em>Edit → Insert line</em></td>
</tr>
</tbody>
</table>
Evaluating Templates

Prerequisites
You have defined a planning template/activity type and assigned it to at least one cost center.

Procedure

1. Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning Aids → Formula planning → Costs and Statistical key figures or Activity Inputs.

2. Select whether you want to specify one cost center, one cost center interval, one cost center group, all the cost centers in your controlling area or a selection variant for which plan values are to be calculated according to the corresponding planning template.

3. Enter the version, period and fiscal year.

4. To avoid system bottlenecks when you process large quantities of data, choose Background processing.

5. Choose Test run if you do not want to update the results immediately.
   The system writes the plan data in a Detailed list. For this reason, you should always select Detailed list together with Test run.

6. Choose Detailed list to check the evaluation results.

Result
The system displays the calculated plan values in the detailed list.

For more information on form planning, see Formula Planning [Page 391].
Environment of Templates

Use

Maintenance of Template Environments

The maintenance of template environments administers all environments, sub environments, and functions [Ext.], that you have available to you when working with the template.

In this function you can complete the following tasks:

- Maintenance of functions (for example creating, editing and copying functions). For more information see Functions in Environments [Page 403] and Maintaining Functions [Page 404].
- Maintenance of function trees (structuring of functions through function trees, grouping nodes and function references). For more information see Functions Trees [Page 416] and Maintaining Function Trees [Page 418].
- Display of environments, sub environments and functions

Environments and sub environments are standard, and cannot be changed, this means that they can not be deleted and you are not able to create new environments or sub environments.

Environments and Associated Sub-environments

An Environment is a group of functions. A template is always created for one particular environment and can then access all functions that belong to that environment and its sub-environments (for more information see Template [Page 733]). For the most part, the environment provides only those functions and information necessary for the template in its corresponding context.

The SAP System includes environments for the following areas:

- Template Allocation to cost objects or use of cost objects and materials in the plan calculation (environment 001-012)
- Template allocation to business process, cost center or cost center/activity type (environments SDP, SCI, SCD)
- Template-Allocation for Profitability Segment (environment PAC)
- Formula planning (environment CPD, CPI, BPP, PCA)
- Determining output quantities (environment SOP)
- Easy Cost Planning/ Internal service orders (environments 200 – 299)

Sub-Environments are groups of function that are assigned to the environment. They are organised on the basis on content. A sub-environment can be assigned to many different environments. If you create a function in a sub environment, it is automatically available in all environments which contain the sub environment (see note) A template, however can only be created in an environment.
Environment of Templates

Functions permit it that, with the use of Templates, cost-driver-relevant data of the SAP System and possible external systems can be accessed. Functions are evaluation procedures with which you can call up the value of a field or the results of a function module.

Functions in Sub-Environments

<table>
<thead>
<tr>
<th>Possible receiver Objects</th>
<th>Environment</th>
<th>Sub-Environment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Object: Production order</td>
<td>Environment 001: Materialcalc./ Production orders</td>
<td>Sub-environment 101: Sender processes</td>
</tr>
<tr>
<td>Cost Object: Sales Orders</td>
<td>Environment 008: Sales orders</td>
<td>Sub-environment 105: Routing</td>
</tr>
<tr>
<td>Profitability Segment</td>
<td>Environment PAC: Profitability Analysis</td>
<td></td>
</tr>
</tbody>
</table>

Functions, that were created in sub-environment 101 are then available in Environments 001, 008 and PAC. Functions that were created in sub-environment 105 are then available in Environments 001 and 008.
Functions in Environments

Definition

Functions are evaluation procedures with which you can call up the value of a field or the results of a function module within a Template [Ext.]. A function is clearly identifiable through the environment [Ext.], name space [Ext.] and logical function names.

Use

Objects, quantities, activation requirements and assignment times are dynamically determined through the definitions of Methods [Ext.] and Formulas [Page 435] for Templates [Page 433]. They are always assigned to environments [Ext.] or sub-environments [Ext.] (see Environment of the Template [Page 401]), and can be structured or organized into function trees (see Function Trees [Page 416]).

You can use standard functions or define new ones (see Maintaining Functions [Page 404]), this means that you can access exactly the right driver information that the respective enterprise needs. In addition to access to table fields and standard function modules, you can also create ABAP-function modules, whose results are accessible by the function (see Implementing ABAP-functions [Page 411]).

Structure

While creating functions, you determine, among other things, the following:

- The external (language dependent) function names
- To which environment or sub-environment they belong (see Maintaining Functions [Page 404])
- The logical (internal to program) function names and name space (see Functions - Basic Data and Language [Page 407])
- Which values and data will be determined with the function; that is, which field or function module will contain these (see Activating the Function [Page 409])
- Whether and which parameter and function will be assigned (see Parameter of Functions [Page 412])
- In which columns of the template the function can be used (see Function Use [Page 413])
- Which function hierarchy the function belongs to (see Additional Function Trees [Page 424])

See Also: Example: Creating Functions [Ext.]
Maintaining Functions

Maintaining Functions

Maintain functions [Ext.] in the Implementation Guide (IMG) of the Activity-Based Function under Templates → Maintaining environments and function trees [Ext.]. It is the same transaction in which you Maintain function trees [Page 318].

If you want to edit or create functions, it is useful to create a special function tree for this purpose. By doing this you retain an overview of your work.

Display functions

1. Position the cursor on a function reference.
2. Choose Edit → Function → Display.
3. The tab index of the function-transaction appear on the right screen area.
4. To see in which templates the function is used, choose (screen area to the right).
5. To switch to the change mode, choose .
6. To close and leave the screen area, choose .

Displaying using the right mouse button option: position the cursor on the function symbol; right mouse click and choose Display function.

You can also display the function by double clicking on the function reference.

Creating functions

Create a function, and generate the corresponding function reference at the same time.

1. Choose .
2. In the selection window Maintaining Environments and function trees, enter the Template application, for the function you want to create.
3. All environments and sub-environments that exist within the chosen template application are listed in the screen area to the left.
4. Position the cursor on a Function tree, Structure node or Function reference. From the function tree, you can create the function reference only at a subordinate level. From the structure nodes, you can create a function at the same level or lower. From the function reference, you can create a function only at the same level.
5. Choose Edit → Function → Create
6. In dialog box Creating functions, enter a description for the new function.
7. Choose Same level or Lower level.
8. The tab index of the function transaction appear on the right screen area.
9. Make your entries using the tab index.
10. To save the entries, choose .
Maintaining Functions

For more information on the entries necessary for tab indexes, see:
Functions - Basic Data and Language [Page 407]
Realization of the Function [Page 409]
Function Parameters [Page 412]
Function Use [Page 413]
Additional Function Trees [Page 424]
Example: Creating Functions [Ext.]

Copying functions

1. Position the cursor on a function reference.
2. Choose Edit → Function → Copy.
3. In dialog box Copying functions, enter a description for the new function in row Function.
4. Choose Same level.
5. The tab index of the function transaction appear on the right screen area.
6. Make your entries using the tab index.
7. To save the entries, choose .

Copying using the right mouse button option: position the cursor on the function symbol ; right mouse click and choose Copy function.

Changing functions

1. Position the cursor on a function reference.
2. Choose Edit → Function → Change
3. The tab index of the function transaction appear on the right screen area.
4. Make your entries using the tab index.
5. To save the entries, choose .

You can make changes by using the right mouse button option.

Deleting functions

1. Position the cursor on a function reference.
2. Choose Edit → Function → Delete
3. Answer the following system query with Yes.
4. To save the entries, choose .
Maintaining Functions

The function is then completely deleted, along with the SAP1 function trees for the environments containing this function.

You can also delete by using the right mouse button option.

Displaying function documentation

1. Position the cursor on a function reference.
2. Choose Goto → Function docu.
3. You can leave the document display by using Back.

You can also display the function documentation by using the right mouse button option.
Functions - Basic Data and Language

Use
In view Basic Data enter the function [Ext.] a description and a logical (internal program) function name, and determine a name space. In the view Language, you can enter external function names in other languages.

See Also: Example: Creating Functions [Ext.]

Basic Data of Function

Description
Here, enter a short description of the function. Through option Documentation, you can enter a detailed description.

Logical Function Names
The logical function name is the clear function description (part of the internal programming). This name is the same for all languages.

Environment
Choose the environment [Ext.] or sub-environment [Ext.] to which the function should be assigned.

Name Space
You can use the Name space field to distinguish your own functions from those functions provided in the standard SAP System. You can buy name spaces from SAP or use a default name space. The SAP name space is SAP.

For more information about working with name spaces, see Name Spaces and Naming Conventions (BC-CTS-NAM) [Ext.].

Language of Function
In the view Language, you can assign the external function names and descriptions in other languages to the function.

Enter the external function names in the field with the same name. This name is language-dependent.

Functions - Basic Data / Naming
Realization of the Function

Use

In the Implementation view

- Assign an ABAP program function to the logical function [Ext.] (with reference field)
- As an option, use a data element to determine the Possible entries for functions (in cases with reference fields)
- Fill the Result field for the function (in cases with function references)
- For a function in the hierarchy derived from an existing function, include the associated sub-function (in cases with reference functions)

Features

Assigning Realizations (Field or Function references)

You can base a logical function on function modules or table fields, meaning that the function result comes from a module or from field contents. Make entries either in the ABAP function name field for a function module, or in the fields Table name and Field name for the table field.

Function Result Types

Functions based on function modules can have the following result types:

- **Number Value/String**: Useful for functions in activity quantities and activation.
- **Boolean values (true/false)**: this result type is useful for functions in the activation editor that have true/false results.

Functions with reference to a function module must either use Type of Parameter or Type of Function.

- **Type of parameter**: Useful for functions in object determination. Choose (F4) a function parameter in the field that determines the type at the time of processing. A parameter of this result type can refer to different table fields. It is therefore more flexible than a type for a given, fixed table field.

For the function COMPONENTS_OF_GROUP, you enter ABAP parameter GROUP_FIELD in the Results field. In template maintenance, you enter the function SEND_PROCESS as a parameter.

- **Type of Function**: This result type (or Type of Parameter) must be used for functions in object determination. Through F4 choose from the valid functions.

Using Data Elements for Determining/Selecting Possible Entries

Comparison

During comparisons in the framework of defining Methods [Ext.], the Possible entries function for comparison operand 2 offers only those functions with data elements agreeing with those for
Realization of the Function

comparison operand 1. Each function that is realized as a table field is assigned a data element via the ABAP Dictionary. Functions realized as function modules have no data element assignments.

You can use the *F4 data element* field to change the existing assignment, or create an assignment (for functions with reference to function modules) that makes additional comparisons possible.

If the function you selected as comparison operand 1 is assigned data element KOKRS, the R/3 System will not offer functions for comparison operand 2 using the assigned data element BUKRS. In order to allow compares with both these functions, you must assign both functions the same data element, such as ORG_UNIT.

If you enter an asterisk (*) in the *F4 data element* field, this function appears for all instances of comparison operand 2, as long as it is generally available in this context.

Selecting Parameters

By using *F4* for parameters, you call up a selection list of only those functions whose data elements match those of the parameters. If you enter a data element, in addition to the above, you will also call up all functions that contain the given data elements.

For more information, see Function parameters [Page 412] and Function Uses [Page 413].

See Also: Example: Creating Functions [Ext.]

Table for Flexible Functions

Define a flexible function by entering in this field. Here you determine which table (for example: routing, BOM) is used for the posting run of the flexible function, in case this is created in the template maintenance. For more information see Defining Flexible Functions [Ext.].

Including the Reference Function

You can define a function by copying an existing function (such as one in the standard R/3 System) and then modifying it for your own requirements. In this case, enter the logical function name of the reference in the *Reference function* field.
Implementing ABAP Functions

Use

Enter the name of the appropriate function module in field ABAP Function name if the result of the function [Ext.] should also be the result of the function module.

A multitude of function modules are standard in this SAP release. If these modules do not meet your needs, you can create your own by following these steps.

Procedure

1. Create a function group for your ABAP functions
2. In the Top-Include of the function group enter the line TYPE-POOLS: TPLIC. The group TPLIC contains important types for the Template Analysis.
3. Create function modules in the function group:
   a. First define the interface Choose the tab page Import In the rows of column Import Parameter enter:
      i.  PERIOD_FROM (starting period)
      ii. PERIOD_CNT (number of periods)
      iii. CALL_PROG (calling program); in this line enter SY-REPID in column Reference field/structure.
      iv.  In the column Transfer values set the respective flag
   b. Then choose the tab page Tables Enter RTABLE_VAL in the column Table Parameter, and TPLIC_RVAL_TAB in the column Associated type (this is contained in group TPLIC ). RTABLE_VAL is the results table; it contains the period with the resulting value of the function for each entry
4. Fill in fields Period, with the corresponding periods, and Value, with the results of the period (PERIOD_CNT) at the end of the coding for the ABAP-Function in the results table for each period to be evaluated.
5. Save your entries.

Result

The ABAP-Function you have created is now available for when you define functions. It can be called up in field ABAP Function name (tab page Implementation).
Function Parameters

Use

Use the Parameters view to assign parameters to functions [Ext.] (with function reference).

See Also: Example: Creating Functions [Ext.]

Features

ABAP Parameters and External Parameters

A function module can have parameters. If this is the case, you must assign the corresponding ABAP parameters to the associated functions. Parameters that have already been applied are shown. If external names or descriptions of such parameters are changed, then these are valid for all applications of this parameter. You can choose any parameter here except PERIOD_FROM, PERIOD_CNT and CALL_PROG. You then assign each of these to a language-dependent external parameter; use the Explanation column to enter a commentary on the parameters.

Parameter Type and Default Value

The parameter types include:

- **Normal**: The parameter appears without an entry; you must fill the field during template maintenance. Do not enter any values in the Default column.

- **Hidden**: the parameter does not appear on the screen. You need to enter a value in the Default column. This can be a function with field reference or a character string bracketed in quotation marks (").

- **Literal field**: the entry value of the parameter contains the function name field as a character string; that is, a literal entry. The parameter does not take hold of these contents, but rather the program transfers internally the combination of table fields in quotation as character string. With this parameter type you can enter a field name in column Default.

- **Optional**: A free space (" ") is shown as parameter in the template maintenance. You can fill the field during template maintenance. Do not enter any values in the Default column. However, you must enter a default value in the associated function module if you do not make any entries during template maintenance.

Using Data Elements for Determining Possible Entries

By using F4 for parameters gives only those functions whose data elements match those of the parameters. You can enter the data element in the F4 data element column, or allow the R/3 System to take the data element from the corresponding function module.

If you enter an asterisk (*) in the F4 data element column, all functions appear for all instances of the parameter, as long as they are generally available in this context.

For more information, see Function Uses [Page 413].
Function Uses

Use

In the Function Use view, determine in which template cells (line/column intersection) a Funktion [Ext.] can be used.

When arranging functions in sub-environments [Ext.], the item categories, columns and column types available for you to process depends on the template application you chose. You can choose the template application through your filter entry before creating the function (see the example below and also Editing Functions [Page 404], section "Creating functions").

See Also: Example: Creating Functions [Ext.]

Features

Overview/All Columns Tabs

Overview / All Columns: you can use the tab page Overview or All Columns for your entries. In Overview only the types of template columns are shown; for example, Object, Quantity, Activation, and Assignment Time. A marking applies to all columns of a particular type. All existing columns are shown in All Columns; for example, Object, Quantity Plan, Activation Plan, Assignment Time Plan, Actual Quantity, Actual Activation, Actual Assignment Time.

In editing mode: The selection in the Overview is valid for the column type (for example, Quantity). In the All Columns tab you can, therefore edit all available columns with that type (for example if you deselect Plan Qty, the selection of Actual Qty remains).

The selection on the Overview tab shows you whether selections on the All Columns tab have been made uniformly or not:

<table>
<thead>
<tr>
<th>Selection on Overview tab (in editing mode)</th>
<th>Settings in All Columns</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick in white field (changes possible)</td>
<td>All columns are selected</td>
</tr>
<tr>
<td>Tick in grayed out field (changes only possible in All Columns tab)</td>
<td>At least one, but not all columns are selected</td>
</tr>
<tr>
<td>No tick (changes possible)</td>
<td>No Columns are selected</td>
</tr>
</tbody>
</table>

Column Type

The column type shows you which item categories can be chosen (for example, Process, Sub-Template, Calculation Row, and so on). Which column types are available depends on the template application chosen (see example below).

Other Columns

Additional columns (object, quantity, and others): by marking the checkbox, you decide that the functions in these column-line combinations can be chosen.

Filter

By using the icon (Filter) while in a cell you can activate or deactivate further requirements, and thereby constrain the use requirements:
Cost Center Accounting (CO-OM-CCA)

Function Uses

- In the columns for quantities and allocation events you can determine whether a function can be used as a formula component and/or as a parameter.
- In the columns for Object and Activation you can decide whether the function can be used as a Column Header (comparison operand 1), Column Entry (comparison operand 2), and/or Parameter.

In editing mode: If you call the filter in the overview tab, you see through the selection of the usage criteria, whether they are uniformly set or not (in the individual columns of the All columns tab).

<table>
<thead>
<tr>
<th>Selection on Overview tab (in editing mode)</th>
<th>Settings in All Columns</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tick in white field (changes possible)</td>
<td>The usage criteria are set in all columns</td>
</tr>
<tr>
<td>Tick in grayed out field (changes only possible in All Columns tab)</td>
<td>Usage criteria set for at least one, but not all columns</td>
</tr>
<tr>
<td>No tick (changes possible)</td>
<td>No usage criteria set</td>
</tr>
</tbody>
</table>

Switching between Applications

While displaying functions, you can switch between the template applications by using Environment Other template applications and see the various line/column combinations.

Create a function in the sub-environment 101. Various column types and item categories are made available depending on what template application you chose.

<table>
<thead>
<tr>
<th>Chosen template application</th>
<th>Column types available</th>
<th>Item categories available (lines)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost object/Calculation COB</td>
<td>Object, quantity, activation, allocation event</td>
<td>Process Calculation row (Process) Flexible function (process) Cost center / activity type Calculation rows (cost centers/activity types)</td>
</tr>
<tr>
<td>Cost center/business process activity allocation SBP</td>
<td>Object, quantity/costs, activation</td>
<td>Process Cost center / activity type Calculation row (Process) Calculation rows (cost centers/activity types)</td>
</tr>
</tbody>
</table>
| Profitability segment PAC | Object, quantity, activation | Process  
Calculation row (Process)  
Flexible function (process)  
Cost center / activity type  
Calculation rows (cost centers/activity types) |
Function Trees

Definition

A function tree is a directly definable structure used to organize functions. It is always assigned to an environment or sub-environment and can contain structure nodes and function references.

Use

The function tree organizes the available functions in the applicable process template environment according to their uses or other characteristics. Afterwards, the function is the main focus of further editing. For more information on editing function trees, structure nodes and function references, see Editing Function Trees. Go to Editing Functions for more on working with functions.

Structure

<table>
<thead>
<tr>
<th>Function Tree Structure Levels</th>
<th>Contains:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment</td>
<td>Standard environments or sub-environments with their associated function trees.</td>
</tr>
<tr>
<td>Function Tree</td>
<td>Structure for the hierarchical structure of functions with the associated structure nodes and function references. The standard SAP System includes function tree SAP1 for all environments.</td>
</tr>
<tr>
<td>Structure Nodes</td>
<td>Further structuring possibilities</td>
</tr>
<tr>
<td>Function reference</td>
<td>Link to Function</td>
</tr>
</tbody>
</table>

Delivered as part of the software, function tree SAP1 is standard to all environments (for example, for Environment 001 - Function Tree SAP-001, for Environment PAC - Function Tree SAP1-PAC). Furthermore, this includes all standard-delivery structure nodes (sub-environments) and function references (with links to the respective functions).

Example

Function Trees

The example illustrated shows functions of environments 001 and the groups they correspond to. Structure node “BOM” contains function references relevant to bill of materials, while structure node “Routing” provides those referring to the routing.
Function Tree SAP1-001 für Environment 001

Structure node: BOM
- Function reference AME_...
- Function reference ANZAHL_...

Structure node: Routing
- Function reference APLAN_...
- Function reference ANZAHL_...
- ...
Editing Function Trees

Use
In the function Environments and Function trees you can process:

- Function Trees [Page 416]
- Structure Nodes [Page 416]
- Function References [Page 416]

How you do this will be explained in this document. The processing of functions [Ext.], that are used in the same transaction, is explained in Maintaining Functions [Page 404].

The selected environment always serves as the basis for maintaining these objects.

You have the left and right screen area available. The left side shows the existing environments. You can expand the hierarchies and display the structure of the function trees, structure nodes and function references in these hierarchies. Position the cursor on the object you want to edit.

The right side lists the details of the object chosen most recently (function tree, structure nodes or function reference) or all tab pages of the currently chosen function. Otherwise, use the right side to edit functions.

If you want to maintain Function trees structure nodes and function references (for example change, delete and so on) – you must first copy the standard function tree SAP1: maintenance is only possible in copied function trees.

Procedure

General Requirements

Display filter

1. In the Implementation Guide (IMG) of the Activity-Based Costing follow path Templates → Maintaining Environments and Function Trees [Ext.]. Displayed on the left side are all the existing environments.

2. Choose.

3. If you want to further focus the display, choose Template application, Environment and/or Tree.

If you enter SBP as the environment, the system displays only the function trees assigned to environment SBP. If you enter CPI in field Template-Application, the system displays only those trees of the environment that belong to the Template-Application Formula Planning Business Processes/Cost Center.

Displaying higher and lower level environments

1. Position the cursor on an environment line.
2. To display all higher level environments, choose.
3. To display all lower level environments, choose.

**Enlarging and reducing the screen area**
1. To change the size of the screen area, click on its respective vertical border.
2. Hold the left mouse button down and drag to the left or the right.

**Display object**
To view objects that are subordinate to other objects, double click on its name: the system displays the contents of the objects in both screen areas.

To display the structure nodes belonging to a function tree, double click on the function tree.
To display the function references belonging to a structure node, double click on the structure node.

**Copying with drag and drop**
You can copy objects from the right to the left screen areas, or within the left screen area.

1. Position the cursor on an object (Function tree, Structure node or Function reference).
2. Hold down the left mouse button.
3. Drag the cursor to the insert position.
4. Release the mouse button.
5. To save the function tree, choose.

**Editing Function Trees**

**Creating function trees**
1. Position the cursor on the environment where you want to create a new function tree.
2. Choose Function tree → Create.
3. In the dialog box Create function tree enter the name and description of the new function tree in row Tree. The chosen environment is displayed.
4. In the dialog box, choose.
5. To save the function tree, choose.

The new function tree is then displayed in both screen areas.

**Building new function trees**
While building new function tree, the system reconstructs its contents based on the environment with all subordinate environments and their functions.
1. Position the cursor on a function tree.
Editing Function Trees

2. Choose *Function tree → Newly reconstruct*.
3. Enter the name and description of the new function tree or accept the default values in the dialog box *Generate function tree*. The chosen environment is displayed.
4. In the dialog box, choose 📝.
5. To save the function tree, choose 📝.

The function tree is now newly reconstructed. The original contents are also reconstructed; that is, it contains all subordinate environments (as structure nodes) and their functions (as function references) of the chosen environment as delivered in SAP1.

**Newly reconstructing using the right mouse button option:** position the cursor on the function tree symbol; press the right mouse button and choose *Build new function tree*. Here, you cannot change the name or description.

**Copying function trees**

Copy function trees to work with the contents of its SAP1. The SAP1 is standard, but cannot be changed. However, you can change the copied version. You can also copy your own function trees.

1. Position the cursor on a function tree.
2. Choose *Function tree → Copy*.
3. In the dialog box *Copy function tree* enter the name and description of the new function tree in row *Tree*. The chosen environment is displayed.
4. In the dialog box, choose 📝.
5. To save the function tree, choose 📝.

The copy of the function tree contains all structure nodes and function references of the original tree, and it can be changed as you wish.

**Copying using the right mouse button option:** position the cursor on the function tree symbol; press the right mouse button and choose *Copy function tree*.

You can also copy with drag and drop.

**Importing function trees**

Use the import function to import a function tree from another client (for example, from an upgrade).

1. Position the cursor on a function tree.
2. Choose *Function tree → Import*.
3. In dialog box *Import function tree*, determine the tree to be imported.
4. Enter the source client from which the tree is to be imported.
5. In the dialog box, choose 📝.
6. To save the function tree, choose 📝.
Activating/deactivating function trees

These settings are made by the user. The environment function tree SAP1 is always active, even when no flag is set.

1. Position the cursor on a function tree. Note the small box in column **Active**: if the small box is marked, then the function tree is active; that is, it will be displayed in the template-maintenance. If it is not marked, the function tree is inactive.

2. Choose *Function tree → (de)activate*: an inactive tree has an unmarked box, and an active one has a marked box.

3. To save the function tree, choose ☐.

You can also activate or inactivate the tree by using the right mouse button options.

Delete function tree

1. Position the cursor on a function tree.

2. Choose *Function tree → Delete*.

3. To save the deletion, choose ☐.

Editing Structure Nodes

Creating structure nodes

1. Position the cursor on a structure node of a function tree.

2. Choose *Edit → Structure nodes → Create*

3. In dialog box *Create structure nodes*, enter the names of the new structure nodes.

4. Determine if the structure nodes should be inserted at the same level or at a lower level.
   
   i. If you choose *Same level*, the new structure node appears before the structure node you placed the cursor on.

   ii. If you choose *Lower level*, the new structure node appears below the node you placed the cursor on.

5. To save the entries, choose ☐.

Copy structure nodes

1. Position the cursor on a structure node of a function tree.

2. Choose *Maintain → Structure nodes → Copy*

3. In the dialog box *Copying structure nodes*, determine if the structure nodes should be inserted at the same level or at a lower level.

   i. If you choose *Same level*, the new structure node appears before the structure node you placed the cursor on.

   ii. If you choose *Lower level*, the new structure node appears below the structure node you placed the cursor on.

4. To save the entries, choose ☐.
Cost Center Accounting (CO-OM-CCA)

Editing Function Trees

You can also copy using the right mouse button options, or drag and drop.

Changing structure nodes

Here you can give a structure node another name.
1. Position the cursor on a structure node of a function tree.
2. Choose Maintain → Structure nodes → Change
3. In dialog box Change structure node enter a new text for the structure node.
4. In the dialog box, choose ✓.
5. To save the entries, choose ✓.

You can make changes by using the right mouse button options.

Deleting structure nodes

Here you delete structure nodes including the text.
1. Position the cursor on a structure node of a function tree.
2. Choose Maintain → Structure nodes → Delete
3. To save the deletion, choose ✓.

You can also delete by using the right mouse button options.

Maintaining Function References

The function reference is the structure object that refers to a function. Use the function reference if you want to load a function and edit or display it on the right side of the screen (see Editing Functions [Page 404]).

Entering function references
1. Position the cursor on a function tree or a structure node.
2. Choose Edit → Function reference → Insert.
3. In the List of available functions you can choose the function that the function reference should refer to.
4. In the dialog box Create function reference, determine whether the reference should be inserted at the same level or at a lower level.
   i. If you choose Same level, (only affecting structure nodes) the new function reference appears before the structure node you placed the cursor on.
   ii. If you choose Lower level, the new function reference appears below the structure node or function tree you placed the cursor on.
5. To save the entries, choose ✓.
Copying function references
1. Position the cursor on a function reference.
2. Choose Edit → Function reference → Copy.
3. In dialog box Copy function reference, choose Same level, and the copy will be inserted before the function reference.
4. To save the entries, choose .
   You can also copy using the right mouse button options, or drag and drop.

Changing function references
Here you change the reference to a function with another function.
1. Position the cursor on a function reference.
2. Choose Edit → Function reference → Change.
3. In selection window List of available functions choose another function.
4. To save the entries, choose .
The function reference is replaced and carries the description of the new function.
   You can make changes by using the right mouse button options.

Deleting function references
Deleting a function reference does not affect the function it refers to. They remain in function tree SAP1 of the respective environment.
1. Position the cursor on the function reference to be deleted.
2. Choose Maintain → Function reference → Delete
3. To save the deletion, choose .
   You can also delete by using the right mouse button options.
Additional Function Trees

Use

Functions [Ext.] are assigned to specific function trees which are selected by asset environment [Ext.]. These are always the trees which are directly assigned to this environment, or which belong to a sub-environment [Ext.] of the latter.

In view Function tree you can determine in which additional function trees the function can be found.

Features

The mark in column One indicates that the function is assigned to a function tree. The subsequent columns indicate which function tree that is and to which environment it belongs.

A field with gray background and marks documents the function trees containing functions.

In order to assign functions to further trees, mark the white field. Provided here are the individual trees, belonging to the environments, and containing the sub-environment of the function.

For more information, see Function Trees [Page 416].
Activity Quantity Determination

Use

Activity quantity determination uses Formulas [Page 435] to calculate the amounts used in the evaluation of a template. For example, you can allow the R/3 System to calculate the quantity of a sender object (for example, a business process) utilized by a cost object.

In order to define the formulas, you use a formula editor function.

See also:

Example: Quantity Determination [Ext.] (Template for cost object/calculation)
Example: Quantity Determination [Page 426] (Template for formula planning/cost centers)
Defining Formulas [Page 436]
Workflow-Integration Business Process [Ext.]
Quantity Determination: Example

In the planning template, you have defined a row of object type “Stat. key fig.” with the object “Employee”. For the quantity, you branch to the quantity editor and define a formula. You use the function OWN_STAT_KEY_FIG in the quantity editor and select, for example, the statistical key figure “Salaried employees”. In this case, the SAP R/3 System writes the planned quantity of the statistical key figure “Salaried employees” in the statistical key figure “Employees”.
Activation

Use

During activation, you use Methods [Page 431] to activate all items of the planning template for which the methods have the values True. For the evaluation of the planning template, the R/3 System considers only active items with their objects and quantities.

If, therefore, the method uses the value “True” (active) during planning template evaluation, the SAP R/3 System transfers the objects of the rows with the corresponding quantities to planning.

If, during planning template evaluation, the method has the value “False” (inactive), the system ignores these items.

The system evaluates the activation condition before the object selection or quantity determination. This means that you cannot evaluate any attributes of the object (e.g. cost element category).

To enter a more complex method, branch to the activation editor.

You can use the following condition to specify that your planning template may only be used on cost center 1100 in the periods 7 to 12 of the current fiscal year “1998”.

```
CURRENT_PERIOD >= '7'
AND
CURRENT_FISCAL_YEAR = '1998' AND
COST_CENTER_NAME = '1100'
```

See also:
Defining Methods [Page 433]
Processing Possibilities in the Editor

Use
To reach the Selection or Activation Editors, double click on the Object or Activation column (see, Defining methods [Ext.]); to reach the Quantity Editor, click on the Quantity or Cost columns (see Defining formulas [Page 436]). The following processing possibilities are available:

You can activate most processing possibilities by using the mouse or the right mouse button.

Processing Possibilities in all Editors

<table>
<thead>
<tr>
<th>In order to:</th>
<th>... follow these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>call up the Editor</td>
<td>1. Position the cursor on an Object, Activation or Quantity column.</td>
</tr>
<tr>
<td></td>
<td>2. Double click on the column.</td>
</tr>
<tr>
<td>leave the editor (the entries remain until saved)</td>
<td>Choose either ( ) or F3.</td>
</tr>
<tr>
<td>stop the processing and leave the editor (entries are rejected)</td>
<td>Choose either ( \times ) or F12.</td>
</tr>
<tr>
<td>mark a line</td>
<td>Click on the furthest left end of the line.</td>
</tr>
<tr>
<td>mark a column</td>
<td>Double click on the column header.</td>
</tr>
<tr>
<td>insert a line/row</td>
<td>1. Mark the line.</td>
</tr>
<tr>
<td></td>
<td>2. Choose either ( ) or CTRL+F2.</td>
</tr>
<tr>
<td>delete a line</td>
<td>1. Mark the line.</td>
</tr>
<tr>
<td></td>
<td>2. Choose either ( ) or CTRL + F1.</td>
</tr>
<tr>
<td>reverse your entry</td>
<td>Choose ( ) or CTRL + F12 (you remain in Editor).</td>
</tr>
<tr>
<td>reach the previous position</td>
<td>Choose either ( ) or SHFT+F1.</td>
</tr>
<tr>
<td>reach the next position</td>
<td>Choose either ( ) or SHFT+F6.</td>
</tr>
</tbody>
</table>

Processing possibilities in the Selection and Activation Editor (Object and Activation columns)

<table>
<thead>
<tr>
<th>In order to:</th>
<th>... follow these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>check your entries</td>
<td>Choose either ( ) or F6.</td>
</tr>
</tbody>
</table>
Cells positioned underneath one another are linked through the operator OR by default. Changes are not possible.

Comparisons between cells positioned next to one another are linked through AND through default; a change to OR is possible.

### Processing possibilities in the Quantity Editor (Quantity and Cost Columns)

<table>
<thead>
<tr>
<th>In order to</th>
<th>... follow these steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>check the formula</td>
<td>Choose F6.</td>
</tr>
<tr>
<td>format the formula</td>
<td>Choose CONTROL + SHIFT F4.</td>
</tr>
</tbody>
</table>
### Processing Possibilities in the Editor

<table>
<thead>
<tr>
<th>Function</th>
<th>Instructions</th>
</tr>
</thead>
</table>
| display the documentation for an applied function [Ext.] | 1. Place the cursor on letters of the function.  
2. Choose either F1 or SHFT+F2. |
| end the processing                          | Choose SHIFT F3.                    |
| select a function                           | Choose SHIFT + F7.                   |
| change a flexible function                  | Choose SHIFT + CONTROL +F2 (see Maintaining Flexible Functions [Ext.]). |
| delete a flexible function                  | Choose SHIFT + CONTROL +F3 (see Maintaining Flexible Functions [Ext.]). |
Methods

Use

You use methods during activation.

A method lets you define a condition for the activation.

You can use methods to show logical conditions, which consist of individual comparisons. These comparisons are linked by a logical AND or a logical OR. Each comparison consists of two comparison operands and one comparison operator, for example "A>B". The operands are either functions of the currently valid environment or constant values. At activation the result of a method is either True or False.

For more information, see Activation [Page 427].

To define a method you can create various columns that each consist of one header and at least one cell. The header corresponds to the first comparison operand and each cell corresponds to a second comparison operand. For example, a column with three cells corresponds to three comparisons, where the first comparison operand is always the same.

When you evaluate a method, the entries in the cells of each column are linked to a logical OR. The resulting quantity of a column is linked by a logical AND to the resulting quantity of the other columns as a default value.

You can change the default value if required.

For more information, see Changing the Logical Links of Columns [Page 434].

You want to depict the following condition:

\[(x > 10 \text{ OR } x \in M) \text{ AND } x < 100\]

with \(M = \{ 2 ; 20 ; 200 \}\)

Then you must create the following columns:

1. Column:
   Comparison operand 1:   \(x\)
   1. Row:
   Comparison operator:   >
   Comparison operand 2:   10

2. Column:
   Comparison operand 1:   \(x\)
   1. Row:
Methods

Comparison operator: \(<\>
Comparison operand 2: 100

x and M are functions from the environment.

See also:
Defining Methods [Page 433]
Functions in Environments [Page 403]
Defining Methods

Procedure

1. Select a cell from the activation column of the planning template for which you want to define a method. You access the activation editor.

2. Choose Column on.

   The system displays a dialog box for the definition of comparisons.

3. Select a function for comparison operand 1 and enter the required parameters.

4. Select a comparison operator.

5. Maintain comparison operand 2 by choosing F4 (input help). You can then execute one of the following steps, if required.
   - Select a fixed value.
   - Select a function and enter the required parameters where necessary.
   - Choose True or False.

   The system displays the values or functions applicable to the current situation.

   For more information, see Function Usage [Page 413].

6. To maintain additional column cells, select the corresponding cell to display once again the dialog box for the definition of comparisons.

7. To maintain additional columns, start again at step 2.

8. Save your entries.

You can change or display the parameters you have entered in the dialog box for the Definition of comparisons.
Changing Logical Conditions Between Columns

Procedure

To change the logical condition definitions between the individual columns:

- Mark the affected column and allocate it a comparison operator, or a parenthesis, through which you mark one of the switches: AND, OR, (, or ).

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND</td>
<td>The column will be bound with the following one through the logical AND.</td>
</tr>
<tr>
<td>OR</td>
<td>The column will be bound with the following one through the logical OR.</td>
</tr>
<tr>
<td>( = open parenthesis</td>
<td>The contents of the column will get an open parenthesis (sensible with more than two columns).</td>
</tr>
<tr>
<td>) = close parenthesis</td>
<td>The contents of the column will get a close parenthesis (sensible with more than two columns).</td>
</tr>
</tbody>
</table>
Formulas

Use

A formula is a logical or mathematical expression used to calculate numerical values, such as $a + b$. You can use basic expressions to construct formulas of any degree of complexity required. In addition, you can use functions from the currently valid environment, or you can use constant values.

See also:

Activity Quantity Determination [Page 328] and Defining Formulas [Page 436].
Defining Formulas

Procedure

1. Double click on the cell in the quantity column of the template in which you want to define a formula. This action takes you to the activity quantity formula editor.

2. Enter a formula. Enter values directly or activate button Function [Ext.] and choose a function from the function tree.

3. The type of function you chose will determine how you should proceed (the function type is not clear at the time you choose the function).

<table>
<thead>
<tr>
<th>Chosen Function or Entry</th>
<th>Further Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter the value directly or you have chosen a Function [Ext.] without parameters.</td>
<td>Proceed with step 4.</td>
</tr>
<tr>
<td>You chose a function that is assigned to a table. You can tell that this is the case if screen Definition of a flexible function appears.</td>
<td>Define a flexible function (see Defining Flexible Functions [Ext.] and Implementing the Function [Page 409]. After the definition, continue with step 4.</td>
</tr>
<tr>
<td>You chose a Function [Ext.] with parameters. An additional screen will appear.</td>
<td>Enter a value for each row for which you choose F4, and then choose Fixed value or Functions/Variables. The values or functions available for selection are determined during the function definition in tab Function Use [Page 413].</td>
</tr>
</tbody>
</table>
| The lines indicate the parameter type “normal” or “optional” (see the note in the right column and Function Parameters [Page 412], section “Parameter Type and Default Value”). | • If you select Fixed value, you can enter the value directly or you get a selection window where you can select specific master data.  
• If you choose Functions/Variables, choose a function from the function tree. |

4. To check if your entries can be properly processed, choose button Check or Formula → Check.

5. To format an entered formula, choose Formula → Format.

6. To get information for a chosen function, position the cursor on the function name and use the button Information about Function or choose Formula → Information about function.

7. To leave the editor, choose Back (your entries remain until you save the template).

For more information on the Editor, see Processing Possibilities in the Editor [Page 428].
Calculation Rows

Use
You use calculation rows to generate interim results in the planning template. You can then use these results in other places. You can define formulas and methods in calculation row. You can access formulas in the quantity column and in the activation column. You can only access methods in the activation column.

See also:
Example for Formula Planning [Ext.]
Defining Calculation Rows [Page 439]
Calling Up Calculation Rows [Page 440]
Defining Calculation Rows

Procedure

1. Choose the item category “Calculation row”.
2. Enter a name.
3. Enter a name in the “Object” column.
4. Define a formula.
   For more information, see Defining Formulas [Page 436].
5. Define a method.
   For more information, see Defining Methods [Page 433].
6. Save your entries.

You can define calculation rows anywhere in the planning template. However, to improve usability, it is best to keep all calculation rows at the beginning.

See also:

Example for Formula Planning [Ext.]
Calling Up Calculation Rows [Page 440]
Calling Up Calculation Rows

Procedure
You can call up calculation rows during quantity determination or during activation.

- **Quantity Determination** [Page 425]
  1. In the quantity editor, choose the function CALCULATION\_ROW\_VALUE and enter the name of the calculation row you want to call up as the parameter (enter in the object column of the overview screen).
  2. Otherwise, define your formula as usual.

- **Activation** [Page 427]
  3. In the activation editor, choose the function CALCULATION\_ROW\_VALUE as comparison operand 1, and enter the name of the calculation row you want to call up as the parameter.
  4. Choose the operator “=” or “not equal to”.
  5. As comparison operand 2, choose the value “True” or “False”.

    For the operator “=” the item is “Active” at the time of evaluation if the values of comparison operand 2 and the calculation row agree. If they do not agree, it is “Inactive”. For the operator “Not equal to” the item is “Active” at the time of evaluation if the values of comparison operand 2 and the calculation row do not agree. If they do agree, it is “Active”.

<table>
<thead>
<tr>
<th>If comparison operand 2 is:</th>
<th>And calc. row is:</th>
<th>Then item is:</th>
</tr>
</thead>
<tbody>
<tr>
<td>True</td>
<td>True</td>
<td>Active</td>
</tr>
<tr>
<td>True</td>
<td>False</td>
<td>Inactive</td>
</tr>
<tr>
<td>False</td>
<td>True</td>
<td>Inactive</td>
</tr>
<tr>
<td>False</td>
<td>False</td>
<td>Active</td>
</tr>
</tbody>
</table>

You have entered the value “False” as comparison operand 2. If the value of the calculation row is “False” at the time of evaluation, this method produces the result “Active”. If the value of the calculation row is “True”, the result of the method is “Inactive”.

See also:
- **Defining Formulas** [Page 436]
- **Defining Methods** [Page 433]
Locking Planning

Usually, after cost center plans have been reconciled and closed, no more planning changes are made. If this is the case, planning is locked against changes by activating the version indicator. See **Planning → Basic Settings → Versions → Maintain Versions** in the implementation guide (IMG) for Cost Center Accounting, or **Planning → Maintain Versions [Ext.]** in the IMG for Activity-Based Costing.
Transferring Plan Values from Other Application Components

Purpose

This section describes the enhancements made to integrated planning within cost center planning.

Integrated planning allows you to transfer data planned in another, upstream SAP R/3 System application component into cost center planning. To do this, certain prerequisites must be met in both Cost Center Accounting and in the upstream application components.

Integration

You can transfer data from the following application components.

- Human Resources (see: The Cost Center Accounting/Personnel Cost Planning Interface [Page 443])
- Asset Accounting (FI-AA) (see: The Cost Center Accounting/Asset Accounting Interface [Page 446])
- Logistics Information System (LIS) (see Transferring Statistical Key Figures from the LIS [Page 694])
- Production Planning and Control (PP) (see Transferring Activity Requirements [Page 450])

If you have planned or entered costs, key figures or activities in a feeder system for Cost Center Accounting and then transfer the costs to CO-OM-CCA, you do not need to plan accruals/interest, personnel costs, statistical key figures and activity requirements in Cost Center Accounting.
The Cost Center Accounting/Personal Cost Planning Interface

Use

During integrated planning between Cost Center Accounting (CO-OM-CCA) and Personnel Planning (PD), you can transfer planned personnel costs to primary cost planning in Cost Center Accounting. The following topics cover which conditions must be met in both application components and how the data is transferred.

Prerequisites

You created valid personnel records and plan personnel costs in PD before transferring the data to CO-OM-CCA. For more information on maintaining HR master records, see the SAP Library under HR Human Resources → PA - Personnel Management → PA - Personnel Administration → Procedures in Personnel Administration → Processing Human Resource Data [Ext.] or Personnel Cost Planning → Compensation Management PA-CM → PA Human Resources Cost Planning.

You can plan personnel costs for target wages, payroll results, or basic pay, and transfer these costs to Cost Center Accounting. Note the following:

1. Selection of a valid cost center as account assignment object
   You must specify a cost center to which the personnel costs are posted in the Organizational Assignment screen of the personnel master record. This cost center must already exist in Cost Center Accounting and must meet the following requirements.
   - The cost center must be valid throughout the entire planning period in HR cost planning.
   - You must not have entered any planning locks.
   - The cost center currency must be the same as the currency used in planning personnel costs.
     (See: Cost Centers [Page 127])
   Other fields in which you must enter data include the:
   - Validity period of the personnel master record
   - Company code
   - Plant

2. Selecting a valid cost element
   In Personnel Cost Planning you define a primary cost element with which you post personnel costs to Cost Center Accounting.
   You must have already created this cost element in Cost Center Accounting (see: Cost Elements [Page 110]).

3. Currencies
   The data transferred from the Personnel Cost Planning application component is always recorded in transaction currency.
The Cost Center Accounting/Personal Cost Planning Interface

If the *All currencies* indicator is active for the controlling area, the value in transaction currency is also translated to object and controlling area currency and transferred to the transaction currency field.

If you have not selected this indicator, the system transfers only the value in controlling area currency into the corresponding field during primary cost planning. The other currency fields are not filled.

If the currencies used in HR and CO-OM-CCA differ, check that the exchange rates for the currencies are maintained.

4. Planning period

The planning period in the HR system must be the same as the planning period in CO-OM-CCA to which you are transferring the personnel costs.

5. Saving and Releasing Plan Data

After entering the plan data in the Personnel Cost Planning application component, you must save and release your planning. You must specify a name for the HR plan scenario containing the data. The data is transferred with the plan scenario to CO-OM-CCA.

6. HR plan scenario/version

An HR plan scenario is assigned to one specific version. You can only transfer values from one HR plan scenario to a version. If you want to transfer data from another HR plan scenario, you must first reverse the data already transferred. To do this, choose *Reverse transferred data* in the data transfer program.

For more information, see *Transferring Personnel Costs from HR (as of Release 4.6A)* [Page 445]
Transferring Personnel Costs from HR

Use

The personnel costs that you planned in Human Resources (HR) can be processed in Overhead Cost Controlling. To enable this, the system transfers the data to the relevant cost centers.

If Personnel Cost Planning and Overhead Cost Controlling are in systems at Release 4.6A or later, the system automatically transfers the personnel costs to Controlling.

In prior Releases, the user initiates the data transfer.

Prerequisites

- In Customizing for Cost Center Accounting, you activated Transfer personnel costs from HR [Ext.] (as of Release 4.6A).
- In Personnel Cost Planning, you have entered one or more cost centers.

For more information on the HR system and on data transfer, see the SAP Library under HR Human Resources → PA Personnel Management → Compensation Management (PA-CM) → Personnel Cost Planning → Integration with Controlling (CO) [Ext.], Releasing Scenarios [Ext.], Transferring Data to CO [Ext.].
The Cost Center Accounting/Asset Accounting Interface

Use

In integrated planning between the Cost Center Accounting and Asset Accounting, you can transfer depreciation and interest for an asset (calculated periodically) to primary cost planning for Cost Center Accounting.

If you want to transfer depreciation and interest from planned investments for asset acquisitions in the fiscal year to cost center planning, you need to note the following:

• You can plan costs that cannot be activated or receive interest (as well as those that can) on the objects in investment planning.

• The SAP R/3 System calculates depreciation and interest using the overall plan value.

• To restrict depreciation and interest planning for planned investments on the true portion of investments that can be activated, enter a flat-rate percentage for each valuation area. Enter this percentage for the expected portion of the planned overall costs that can be activated.

Integration

If you record assets in different company codes for the same cost center, then the system transfers only the value of one company code when it transfers the planned depreciations to cost center planning. To ensure a complete transfer, you can do the following:

• You can set up your own G/L accounts and cost elements for the assets whose depreciation is to be transferred to cost centers in other company codes.

• For each cost center and company code, you can create a plan-integrated order that is settled to each cost center. You assign the affected assets to each order, so that the depreciation on this order can be planned and posted.

• If only a few cost centers are affected, you can also plan the depreciation manually.

• You should also take into account the structure of your cost accounting, as well as the assignment of the assets to cost centers. A cost center must be uniquely assigned to a company code, also in cost accounting which is cross-company code.

Prerequisites

To transfer data from Asset Accounting to Cost Center Accounting, proceed as follows:

1. Define an asset class
   In the asset class you define the assignment for all assets that are assigned to this class by specifying an existing cost center and an activity type for activity-dependent planning. The assets class is linked to a chart of depreciation which you have created. It contains a number of different depreciation areas designed to handle depreciation for a particular purpose (such as book or tax depreciation).

2. Create valid asset master records
The SAP R/3 System posts the depreciation and interest based on the chart of depreciation defined in the asset class. You can transfer these values to activity-independent primary cost planning in Cost Center Accounting.

3. Store the cost center/activity type in the asset master data record

For more information about primary cost planning in Asset Accounting, see Basic Functions for Organizational Structures [Ext.].

The following conditions must apply in Cost Center Accounting:

1. You have created valid cost centers
2. Valid cost elements
3. If you want to transfer activity-independent values, you need to define valid activity types and carry out activity type planning.
   - You have defined valid planner profiles and planning layouts.
4. You have created a version (if you are not planning with version 000).
5. You have defined distribution keys (if you are not using standard distribution keys)

In controlling area 0001 you have created fixed asset 15010, assigned to asset class 1000/chart of depreciation 1DE. On 15 April 1994 you post an external acquisition of $20,000 to this asset. The SAP R/3 System calculates the depreciation and interest for the asset according to the depreciation areas defined in the chart of depreciation. In this example this value is $2000/year (straight-line depreciation over ten years).

You can transfer this value to primary cost planning in cost center accounting. If you entered distribution key 01, the SAP R/3 System distributes the $2000 equally to all the periods in the current fiscal year.

<table>
<thead>
<tr>
<th>Period</th>
<th>Depreciation Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>2000/12</td>
</tr>
<tr>
<td>02</td>
<td>2000/12</td>
</tr>
<tr>
<td>...</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>2000/12</td>
</tr>
<tr>
<td>Total</td>
<td>2000</td>
</tr>
</tbody>
</table>
Transferring Depreciation, Interest, and Investments from FI-AA

Use
You can transfer depreciation, interest and investments in Asset Accounting, and in Cost Center Accounting.

Procedure
Execute the data transfer as follows:

1. Choose:
   a) In Asset Accounting Periodic processing → Primary cost planning or
   b) In Cost Center Accounting Planning → Planning aids → Transfers → Depreciation/interest FI-AA

2. To transfer primary costs (depreciation and interest) from one or more fixed assets, use the following selection criteria.
   a) Company Code
      You can transfer data from one or multiple company codes. The company code used in the FI-AA application component is set as a default.
   b) Asset numbers
      You can transfer the depreciation and interest of one or multiple fixed assets. The SAP R/3 System calculates depreciation and interest for acquisition postings to the fixed asset(s) entered here.
   c) Valuation areas
      The Costing depreciation area (straight-line depreciation over a remaining life of ten years), is defaulted and can be transferred.
   d) Periods
      You can limit planning to a given period interval of the fiscal year. If you do not enter a period interval, planning is performed for all periods.
   e) Activity-independent/Activity-dependent
      You can transfer activity-dependent values and activity-independent values to primary cost planning in Cost Center Accounting. There are three available options:
      • Activity-independent planning (activity types defined in the asset master record are ignored)
      • Activity-dependent planning (asset master records without activity types are ignored)
      • Activity-dependent and activity-independent planning (costs from assets with an activity type are activity-dependent, costs from assets without an activity type are activity-independent).
   f) Version/Planner profile/Planning layout/Distribution key
Transferring Depreciation, Interest, and Investments from FI-AA

As in manual planning, you must enter a version defined in Cost Center Accounting, and specify a planning layout. Enter the version into which you want to transfer the data to Cost Center Accounting.

You can specify a distribution key that you have previously defined in Cost Center Accounting. The SAP R/3 System uses this distribution key to determine the values for the time period you have defined. If you do not specify a distribution key, the system determines a value for each of the periods.

g) Transfer plan values

You must select this indicator to transfer plan values to Cost Center Accounting. If the indicator is not selected, the SAP R/3 System executes only a test run, in which the data is read. The data is not transferred to Cost Center Accounting.

If values have been determined for Asset Accounting and transferred to Cost Center Accounting, the SAP R/3 System overwrites any existing planning data. The new values are not added to the old values. If an error occurs during data transfer, the system issues an error log.
The Interface Between Cost Center Accounting and Production Planning (PP)

Use
This interface enables you to transfer the following data from Production Planning by plant, as plan figures to Cost Center Accounting and Activity-Based Costing:

- Activity quantities from plan orders in requirements planning
- Activity quantities from simulated plan orders from a planning scenario in long-term planning
- Activity quantities from Sales & Operations Planning (SOP) orders in an SOP version

Prerequisites

- You need to define the activity types in the work centers.
- For the activity types, you need to maintain formulas for cost calculation in the work center.
- You need to maintain the transfer control. (See also: Transferring Production Activity Requirements [Page 453].)

Features
The SAP R/3 System calculates these activity quantities using the routing or master recipe, which is structured by cost center / activity type. When activity quantities are transferred, each plan or SOP order is scheduled, and the activity quantities are assigned to one or more CO periods depending on the order dates.
Activity quantities are determined in the work centers using activity types and related formulas. The activity quantity requirements determined in long-term planning are taken into account by the system when it reconciles the activity requirement with the activity provided by the cost centers/business processes. The SAP R/3 System uses the planned activity quantities and the planned costs to calculate the prices of the activity types. These prices are then used for product costing.

If you transfer the activity requirement from the SOP, then the system schedules and evaluates the production quantities created in the SOP using the routings or rough-cut planning profiles. It does this for the activity requirement calculation of each cost center.

Using SOP for transferring activity requirements is recommended only under certain conditions for the following reasons:

- It is not possible to assign resources to cost centers or activity types in the rough-cut planning profile. You cannot transfer data from rough-cut planning profiles.
- The scheduling is set up so that the system ignores any additional work centers that the rough-cut planning profile may have. In this case, no activity quantities can be transferred.
- The system does not determine any secondary requirements from BOMs in the SOP.

If you transfer the activity requirement from the SOP, then the system uses the routings to schedule and evaluate the plan orders for make-to-order production in long-term or requirement planning. It does this for the calculation of the activity requirement.
The Interface Between Cost Center Accounting and Production Planning (PP)

As there is not yet any operative data in materials planning for annual planning in the planned year, it is normally not possible to transfer activity quantities from a requirements plan.

If you transfer the activity requirement from long-term planning then the system controls the transfer using a planning scenario. The planning scenario contains the planning timeframe and the plant in which planning was executed.

The activity requirements of long-term planning are not automatically updated in Cost Center Accounting and Activity-Based Costing. After the planning results have been reconciled, you can transfer the data to Cost Center Accounting and Activity-Based Costing using a special planning function.

You should prioritize long-term planning when collecting activity quantities for Cost Center Accounting. If you want to use SOP, you should transfer the data from the corresponding SOP version to long-term planning, and then from there to Cost Center Accounting.

The SAP R/3 System determines the secondary requirements of activity quantities based on simulated planned orders. These orders create the long-term plan during a planning run or during multilevel planning for meeting these requirements.

Therefore, you need to execute a planning run or a multilevel single-item planning every time the primary requirements are changed. This ensures that the secondary requirements are updated.

See also:

Transferring Production Activity Requirements [Page 453]
Transferring Production Activity Requirements

Prerequisites
Scheduled activity is transferred in two steps:

- Transfer control
- Transfer

Before starting the data transfer, you must define the transfer control data.

1. Choose Accounting → Controlling → Cost Center Accounting → Planning → Planning aids → Transfers → Scheduled activity PP→Transfer control.

2. Specify the target for the data you want to transfer.
   To transfer data, specify the following for each controlling area.
   a) Version
   b) Period from / Period to.
   c) Fiscal year

3. Specify the source of the data you want to transfer.
   Make the following entries in the detailed screen.
   a) Indicate whether the data should be transferred from preliminary planning, requirements planning, or long-term planning.
   b) Enter a version for rough planning or a plan scenario for long-term planning.
   c) Enter a termination type.
      The termination type specifies which end results are to be read for the data transfer.

4. Save your entries.

Procedure
To transfer the data, proceed as follows:

1. Enter the Plant, Version, From period, To period, and Fiscal year.

2. To transfer large amounts of data, Choose Background processing. This allows you to carry out processing at times of low system usage.

3. Select a detail level for the output. You have the following options:
   a) Cost Center/Activity Type
      The system outputs a detailed list, sorted by cost center/activity type.
   b) Material/plant
      The system outputs a detailed list, sorted by material/plant.
   c) Plan-/SOP-order
      The system outputs a detailed list, sorted by plan-/SOP order.

4. Choose Execute.
Transferring Production Activity Requirements

If you repeatedly transfer activity requirements, the system deletes the existing activity requirements in the corresponding version and fiscal year for the plants that you want to transfer to.

Therefore, it is never possible to transfer activity quantities from SOP, requirements planning or long-term planning additively, but only as an alternative to Cost Center Accounting.
Transferring Statistical Key Figures From the LIS

Use

You can transfer key figures that exist in the Logistics Information System (LIS) to cost accounting, where they are referred to as statistical key figures. The transfer can be executed as follows:

- Activity-independent to a cost center/cost center group, business process/business process group, or to all cost centers/business processes of a controlling area
- Activity-dependent to a cost center/cost center group or to all cost centers of a controlling area based on one activity type/activity type group or all activity types

Prerequisites

Before you transfer statistical key figures from LIS, you must establish a connection between LIS and the key figures and cost centers in the controlling area. You do this by assigning one or more statistical key figures to the cost center by specifying, among other things, the version and fiscal year.

To do so, choose Assignment -> Maintain or the following activities in Cost Center Accounting Customizing under Planning -> Plan Data Transfer -> Statistical Key Figure Transfer from LIS:

- Define Statistical Key Figure Link with LIS [Ext.]
- Define Cost Center - Key Figure Assignment [Ext.]
- Define Cost Center/Activity Type - Key Figure Assignment [Ext.]

Procedure

Execute the data transfer as follows:

1. Choose Accounting -> Controlling -> Cost Center Accounting -> Planning aids -> Transfers -> Activity-independent statistical key figures, LIS or Activity-dependent statistical key figures, LIS

2. Specify the objects for which you want to transfer statistical key figures from LIS:
   - A single cost center
   - A range of cost centers
   - A cost center group
   - A user-defined selection variant
   - All cost centers

3. Enter the version, period and fiscal year.

4. Specify whether the system should overwrite existing key figures or not change them. To do so, activate either Reset, Overwrite, or, Do not change.

5. Maintain the processing option parameters:
   - If you want to transfer large data sets, you should set up a background job to be run when the system is not heavily in use. Select Background processing.
Transferring Statistical Key Figures From the LIS

b. If you do not want the system to update the results, select *Test run.*

c. You should also select *Detail lists* along with *Test run,* so you can check the results of the test run.

For performance reasons, you should only activate the *detail list* when absolutely necessary. In either case, the system outputs a results list.

6. Enter a LIS template.

   a. Enter the fiscal year.

   b. Enter a template version from which the key figures in LIS are found.

**See also:**

Statistical Key Figure Transfer from the LIS [Page 594]
Transferring Statistical Key Figures

Prerequisites
You have created the necessary statistical key figures [Ext.] and linked them to the Logistics Information System (LIS). You have assigned the cost center and key figure(s), along with the variant, in Customizing or by choosing Assignments → Maintain.

Procedure
1. Choose Planning → Planning aids → Transfers → Activity-dependent (or independent) statistical key figures, LIS, or
   Period-end closing → Single functions → Transfers → Activity-dependent (or independent) statistical key figures, LIS
2. To transfer actual data from a previous fiscal year and use it as your current plan data, choose LIS reference.
   Enter a reference version and a fiscal year.
3. You must specify the following parameters:
   - Version
   - Period
   - Fiscal year
4. Select or deselect:
   - Reset and overwrite
   - Do not change
5. If required, select the processing parameters:
   - Background processing
   - Test run
   - Detail lists
6. Start the transfer by choosing Execute.

Result
After posting the data, you can display the data as statistical key figures on the objects.
You can enter or transfer statistical key figures on the following objects:
- Cost centers [Ext.]
- Cost center/Activity type [Ext.]
- Business process [Ext.] (only if you are using Activity-Based Costing)
- Cost object [Ext.]
Transferring Statistical Key Figures
Periodic Allocations in Plan

Use

In distribution and assessment, you further allocate costs (or quantities for indirect activity allocations) collected on a cost center during the accounting period to receivers, according to user-defined keys. These are therefore indirect allocation methods, because the exchange of activity is not the basis for allocating costs/quantities. Instead, user-defined keys such as percentage rates, amounts, statistical key figures, or posted amounts provide the cost/quantity assignment basis.

The advantage of these methods is that they are easy to use. You usually define the keys and the sender/receiver relationships only once.

Distribution and assessment are used primarily for cost centers. This is because direct cost allocation is not possible here due to the variety of transactions, the lack of clearly defined individual activity types and the fact that the entry of the activity is too time-consuming. For example, the costs of the company cafeteria may be assigned based on the number of employees in each cost center. Telephone costs are seldom allocated directly to the individual cost centers, but are collected on a clearing cost center for each period. They are then repotted or distributed at the end of the period according to the number of telephone units or telephone installations in each cost center.

Prerequisites

You carry out allocations at period end (during period-end closing) using predefined parameters (keys, sender-receiver relationships).

You can use different currencies for the periodic allocations. To do this, you must have selected All currencies during controlling area maintenance.

The currencies are converted using the translation rates you entered in Customizing when configuring the system (see also: Currencies [Ext.]).

The value date determines which currency translation rate is used for the currency conversion. If you do not enter a value date, the system estimates the most accurate translation rate for the period.

If you are working with transfer prices (parallel value flows) distribution and assessment are executed in parallel in all valuations. The costs to be allocated are taken from the corresponding valuation. The tracing factor is always taken from the operational valuation. The values allocated may differ in the different valuation methods.

Senders and receivers are displayed in the results list, differentiated according to the parallel actual versions of the various valuations.

For more information about transfer prices, see the SAP Library under Financials → Enterprise Controlling → Profit Center Accounting → Transfer Prices (see: Transfer Prices [Ext.]) and multiple valuations [Ext.].
Periodic Allocations in Plan
Planning Overheads

Use

Once you have executed cost element planning [Ext.], the system can determine the overhead rates for the plan values.

For further information, see the SAP Library under Financials → Controlling → Cost Element Accounting.

Integration

- The system **debits** internal orders and cost centers with overheads, regardless of whether integrated planning with Cost Center Accounting is active.

- **Cost centers, business processes** and **internal orders** are only **credited** if integrated planning is active for the order to which overhead is applied and all credit objects. You also need to activate integrated planning for internal orders with Cost Center Accounting/Activity-Based Accounting in the version. For more information, see Integrated Planning Indicator in Versions [Ext.].

- You can use overhead rate planning on **cost centers** to execute **plan accrual**. This is useful if you are dealing with true overhead costs. If the object is plan integrated, and integrated planning with Cost Center Accounting is activated in the version, you can write credit records for any credit object, as well as debit records (in contrast to accrual for accrued overhead). For more information on plan accrual calculation, see the SAP Library under Financials → Controlling (CO) → Cost Center Accounting → Cost center planning → Utilities → Plan accrual calculation [Page 389].

Features

Whether plan costs incur overhead or not, depends on which costing sheet and, where appropriate, which overhead key you defined in your object.

The overhead rates are allocated using a secondary cost element for overhead rates.

Activities

To plan overhead rates, choose Planning → Allocations → Overhead in the corresponding application.

For more information on overhead rate calculation, see Calculating Overheads [Page 698].
Distribution

Use

Distribution [Ext.] is used to allocate the primary costs of a cost center. The following information is passed on to the receivers:

- The original cost element (that is, the primary cost element [Ext.]) is retained.
- Sender and receiver information (for example, the identities of the sender and receiver cost center/business process) is documented using line items in the CO document.

You can use the information system to analyze the distribution results according to sender and receiver relationships.

See also:

- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Assessment

Use

Assessment [Ext.] is a method of allocating primary and secondary costs in Cost Center Accounting and Activity-Based Costing. The following information is passed on to the receivers:

- The original cost elements are assigned cumulatively, or in groups, to assessment (secondary) cost elements. The original cost elements are not recorded on the receivers.
- Sender and receiver information (sender cost center, receiver cost center, or business process) appears in the Controlling (CO) document.

Allocation through assessment is useful when the composition of the costs is unimportant for the receiver. For example, the assessment of cafeteria costs to a cost center need not be broken down further.

You can use the information system to analyze the assessment results by assessment cost element according to sender and receiver relationships.

In periodic reposting [Ext.], distribution [Ext.], and assessment, the system writes line items for each sender and receiver. You cannot restrict this process. You can reverse the line items if you repeat the periodic allocation within a given period. The posting date of the actual allocation is always the last day of a calendar month. The posting date of the plan allocation is always the first day of a calendar month.

You cannot allocate consumption quantities using assessment. To allocate activity quantities, you must use indirect activity allocation.

Features

For allocations using assessment, you can summarize all the cost elements into one assessment cost element [Ext.]. When you carry out the assessment, the system allocates all the costs to be allocated from the sender using this cost element. However, this method does not store any information on the receiver, regarding the composition of the costs.

Alternatively, you can use an allocation structure [Ext.] to define which cost elements are to be allocated under which assessment cost elements. You can assign individual cost elements, cost element groups or intervals to an assessment cost element. The allocation structure can be stored during segment maintenance.

Until now, if you wanted information regarding the composition of costs at a summarized level, you needed to create a large number of segments. These segments only differed in the assignment of the allocation cost elements to the assessment cost elements. Allocation structures enable you to reduce maintenance and the runtime of the cycle.
Company A has 10 subsidiaries in Germany. The primary costs of each subsidiary are to be allocated at period end using its own assessment cost element. Cost centers are summarized across all the subsidiaries (for example, all cafeterias of the subsidiaries). However, although the sender and receiver remain the same, an individual assessment cost element is to be used for each subsidiary.

Until now, you needed to create a corresponding segment for each cost element that was assigned to an individual assessment cost element.

<table>
<thead>
<tr>
<th>Segment</th>
<th>Sender</th>
<th>Receiver</th>
<th>Cost element</th>
<th>Assessment cost element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment 1</td>
<td>Cost center 3500</td>
<td>Cost center 3600</td>
<td>Cost element 415000</td>
<td>Assessment cost element 510000</td>
</tr>
<tr>
<td></td>
<td>Purchasing</td>
<td>Cafeteria</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Segment 2</td>
<td>Cost center 3500</td>
<td>Cost center 3600</td>
<td>Cost element 430000</td>
<td>Assessment cost element 520000</td>
</tr>
<tr>
<td></td>
<td>Purchasing</td>
<td>Cafeteria</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can now summarize the primary cost elements 415000, 430000 in an allocation structure, as well as their assignments to assessment cost elements. This reduces the number of segments required.

<table>
<thead>
<tr>
<th>Segment</th>
<th>Sender</th>
<th>Receiver</th>
<th>Allocation structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment 1</td>
<td>Cost center 3500</td>
<td>Cost center 3600</td>
<td>Allocation structure A1 (415000 → 510000 430000 → 520000 ... →... )</td>
</tr>
<tr>
<td></td>
<td>Purchasing</td>
<td>Cafeteria</td>
<td></td>
</tr>
</tbody>
</table>

For more information, see the Implementation Guide (IMG) for Cost Center Accounting or Activity-Based Costing, under Actual Postings → Period End Closing → Assessment → Create Assessment Cost Elements [Ext.] or Maintain Allocation Templates [Ext.] or under Planning → Allocations → Assessment → Create Assessment Cost Elements [Ext.] or Maintain Allocation Structures [Ext.].

See also:
- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Processing Cycles [Page 763]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Indirect Activity Allocation

Use

You can use indirect activity allocations [Ext.] to automatically allocate planned and actual activities.

You can specify keys to allocate activity, which is not possible when you use manual activity input in the plan or actual activity allocation. In addition, if calculating the sender activity quantities involves too much time or expense, the R/3 System can determine the activity quantity inversely based on the activity of the receivers.

If you execute indirect activity allocation without completing planning for the combination cost center/activity type, you must activate the actual price indicator in the activity type master data.

A special type of indirect activity allocation for actual allocation is the plan=actual activity allocation [Page 720]. Differenct than other types of indirect activity allocation, the plan=actual activity allocation allows for a multiple level activity network to be determined iteritavely with the operating rate as the tracing factor.

Features

You can choose between two methods of indirect activity allocation, depending on the activity types [Ext.] category. These methods are determined for each segment and can be combined in one cycle.

Activity quantities can be determined on the sender object

For certain activity types you can determine the total activity quantity for each sender. These are category 3 activity types, Manual entry, indirect allocation.

Using indirect activity allocation, these posted activity quantities are distributed by the senders among the receivers defined in the segment according to their allocation bases [Ext.]. The corresponding segment must use the sender rule Posted quantities. Any receiver rule can be used, with the exception of Fixed quantities (see: Sender and Receiver Rules for Periodic Repostings/Allocations [Page 751]).
Cost Center Accounting (CO-OM-CCA)

Indirect Activity Allocation

The Quality control cost center uses 1000 hours of the Testing activity type. This cost center provides activity for the cost centers Goods receipt and Finished products. Allocations are made on the basis of the tracing factor Number of test items (TI). These are 4000 items for the Goods receipt cost center and 6000 items for Finished products. This corresponds to an activity input of 400 hours for Goods receipt and 600 hours for Finished products.

The price per activity unit for the Quality control cost center is 50 USD/hr. This results in activity output costs of 50,000 USD. The receiver cost centers are debited with the following costs based on the tracing factor TI.

Goods receipt: (50,000 USD X 4000 TI) / 10,000 TI = 20,000 USD
Finished products: (50,000 USD X 6,000 TI) / 10,000 TI = 30,000 USD

Activity quantities can be determined for each sender, but only with great difficulty

In this case, the R/3 System determines the activity quantity based:

- Either on receiver tracing factors with weighting factors, which can be defined for each sender
  
  If you use the sender rule Inversely determined quantities, you define the weighting factors described above by choosing Sender values.

- Or through Fixed quantity values, which you define in segment definition.
  
  If you use the sender rule Fixed quantities, you define the fixed activity quantity by choosing Sender values.

These activity types belong to category 2 (Indirect entry, indirect allocation).
Indirect Activity Allocation

The corresponding segment can use the following combinations of sender and receiver rules:

<table>
<thead>
<tr>
<th>Sender rule</th>
<th>Receiver rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inversely determined quantity</td>
<td>Any</td>
</tr>
<tr>
<td>Fixed quantity</td>
<td>Any</td>
</tr>
</tbody>
</table>

(see: Sender and Receiver Rules for Periodic Repostings or Periodic Allocations [Page 751]).

In the example, you calculate activities for the sender using the receiver tracing factors with weighting factors, which are to be defined for the sender. The sender rules here are inversely determined quantities. You can use any receiver rule.

The receiver tracing factors are:
- Goods receipt: 4000 test items
- Finished products: 6000 test items

You need 0.4 hour to check one item using the Quality control cost center. The sender rule defines a weighting factor of 0.4 for the Test activity type.

This results in an activity input of 1600 hours on the Goods receipt cost center and 2400 hours on Finished products.

The Test activity is valuated with a price of 5 USD/hr. This results in a credit to the sender of 20,000 USD and debits of 8,000 USD to Goods receipt and 12,000 USD to the Finished products cost center.
If you are working with transfer prices (parallel value flows), the indirect activity allocations are carried out in the leading valuation. The plan price used for allocation thus applies to all the valuations.

For more information on transfer prices, see the SAP Library

- **Financial** → **EC Enterprise Controlling** → **Profit Center Accounting** → **Multiple Valuation Approaches/Transfer Prices [Ext.]**
- **Financials** → **CO - Controlling** → **Overhead Controlling** → **Overhead Controlling** → **Multiple Valuations [Ext.]**.

See also:

- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Senders and Receivers for Indirect Activity Allocation

Use

Sender
Senders of indirect activity allocation in the actual and plan are always cost objects of the category Cost center [Ext.]/Activity type [Ext.]. In a segment you can also activity types of category 2 (indirect entry, indirect allocation) or category 3 (manual entry, indirect allocation).

You do not always have to adopt the value of the activity type category from the activity type master. This value is only a default value, which you can overwrite in the activity type planning for each version and each fiscal year (see: Activity Type Category [Page 148]).

Receiver
As with manual activity allocation, Receivers in actual indirect activity allocation can be any cost object (cost centers, orders, projects, business processes, or Real Estate Objects [Ext.]). You can use any true CO objects, with the exception of profitability segments, as receivers for indirect activity allocation in the plan (see Account Assignment for Controlling Objects [Ext.]). Cost center/activity type categories, however, can not be grouped with other receiver object types in the same segment.

Cost center/activity type combinations are created by the system during activity type planning.

If the receiver of the activity allocation is a cost object (such as a production order or a product cost collector), the price used for the valuation is based on the valuation variant that is connected to the cost object via the calculation variant for the current calculation. If the receiving cost object is not connected to a calculation variant for the current calculation, the plan price for the period is used for the valuation.

Prerequisites
You have carried out activity type planning [Page 208] for all category 3 activity types for all senders of the category cost center/activity type, if you are using the Posted quantities rule.

You can only plan activity quantities using activity type planning for category 3 activity types. For activity types of category 2, this field is not ready-for-input in activity type planning. This is because the system determines the activity quantities inversely from the receiver tracing factors or using fixed quantities. In this case, the system automatically determines the corresponding planning record of cost center/activity type.
Activities

If you have already carried out activity type planning or internal activity allocation [Ext.], the SAP system checks whether the activity type category matches the segment definition.

If you have not carried out activity type planning or internal activity allocation, you specify the sender activity type (activity type category 2 or 3) through the sender rule. This specification is not dependent on the default value stored in the activity type master record.

- Activity type category is 1 (manual entry, manual allocation):
  In this case, no indirect activity allocation is possible.

- Activity type category is 2 (indirect determination, indirect allocation):
  In this case, the segment definition can include the following combinations of sender and receiver rules:

<table>
<thead>
<tr>
<th>Sender rule</th>
<th>Receiver rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inversely determined quantity</td>
<td>Any</td>
</tr>
<tr>
<td>Fixed quantity</td>
<td>Any</td>
</tr>
</tbody>
</table>

- Activity type category is 3 (manual entry, indirect allocation):
  The segment definition must include the sender rule Posted quantities and any receiver rule except Fixed quantities.
Valuating Activity Quantities

Use

Indirect Activity Allocation in the Actual

For actual indirect activity allocation [Ext.], all quantities are posted as total quantities. The quantity is split into fixed and variable portions using actual cost splitting (see: Actual Cost Splitting [Page 868]).

You are using indirect activity allocation in the actual together with predistribution of fixed costs [Ext.], and both sender and receiver are participating in the predistribution. The system reduces the valuation on the sender and receiver side by the amount of the sender fixed costs.

• On the sender side, the portion of the fixed costs is zero. The overall costs therefore contain only variable portions.

• On the receiver side, the overall costs also contain only variable costs. The fixed costs are zero, due to the fully variable activity input. This is because the sender fixed costs are allocated using the predistribution of fixed costs.

Indirect Activity Allocation in the Plan

For indirect activity allocation in the plan, the system determines the fixed and variable quantity portions according to the receiver type and its tracing factor in the given segment.

• The system posts all quantities as variable if the receiver type is a cost center/activity type combination or a business process and if the receiver tracing factor is determined on the portions of the plan or actual activity quantities of the receiver.

• The system posts all quantities as variable if the receiver type is an order, cost object or WBS element.

• In all other cases, that is, for other receiver types or other receiver tracing factors, the system posts the quantities as fully fixed.

If a price exists for a sender object, the R/3 system uses this to valuate the activity quantity for the sender and corresponding receivers. This amount is split into fixed and variable debits and credits in the same way as the valuation of activity-dependent activity input planning (see: Planning Secondary Costs [Page 242]).
Template Allocation in Plan

Use

The use of template [Ext.] allocations is one method to assign overhead costs. This method is unique for several reasons:

- Costs are not only allocated, but the system also determines the quantities that the respective receiver objects consume or utilize; costs are calculated based on the quantities and prices and are, therefore, more accurately determined
- You work with templates: the sender, quantities and activation time do not already exist, but are dynamically determined through the template at the time of the calculation
- The template uses functions defined by the user or already provided in the system to determine the needed data; these functions pull information already in fields or carry out complex algorithms from the operative data in the SAP system; they are created and maintained in the environment maintenance
- Sender objects can be business processes or cost centers/activity types
- Possible receiver objects of the template allocation in plan can be:
  - Internal Orders
  - WBS Elements
  - Profitability segments of profit and market segment analysis
  - Business Processes
  - Cost centers or cost centers/activity types

In order to describe the allocation quantities in plan, you create modeled assumptions allowing best estimates of expected quantities based on the given (static) master data.

For example, the number of purchase orders per sales orders serves as the process driver of the procurement process for a sales order processor. In order to estimate the plan quantities of expected procurements for this order, the SAP System uses the relevant template function to dynamically determine the number of different components not in stock based on the bill of materials for the product to be produced.

Prerequisites

These include:

- Creating the necessary sender objects; for example Business Processes [Ext.] or cost centers/activity types
- Maintaining the environment [Page 401] or Functions necessary for your receiver object
- Providing the process drivers (for example, statistical key figures) used by the functions
- Creating an appropriate template [Page 733]
Template Allocation in Plan

- Assigning the template to the receiver object (Cost Driver [Ext.] or Profitability Segment [Ext.]).

Features

Enter the receiver object(s) in the entry screen for template allocation to determine the overhead costs. When you carry out the allocation, the system does the following:

- Through the search rule you defined, the correct template is assigned to the receiver object
- The template finds the correct business process(es) or cost centers/activity types
- It calculates the quantities demanded/required
- It sets the time period of the allocation and checks, if necessary, the activation requirements

The result is a list of receiver and sender objects of the activity quantities and relevant costs (quantity*price).

Activities

You have completed all prerequisites.

To carry out a template-allocation:

- Enter the template-allocation transaction for which receiver object(s) determine overhead costs
- Execute the template-allocation
- After the results are displayed (Display run results: Template Allocation [Ext.], you can use the Template Trace [Ext.] to display a more detailed view.
- In Display Detail [Ext.] it is also possible to view the results of individual template cells.

See also:

Template Allocation in Actual [Page 724]
Template Allocation in Plan: Processes/Cost Centers

Use

Along with profitability segments and cost objects, business processes, cost centers/activity types, and cost center receiver objects can also be used in template allocations. A template allocation can be run on such business processes, cost centers or cost centers/activity types only when these are assigned fixed allocation templates in the master data. Only one template can be referenced to each business process for allocations; to each cost center one for activity dependent and another for activity independent allocations. You can assign additional templates for the formula planning. Each business processes or cost center can appear several times as a sender in various templates.

In the allocation templates for business processes or cost centers/activity types, the system sets the fixed plan quantities and the plan quantity factor (here, only with activity dependent planning) as absolute values or calculates them through the formulas or functions.

Cost centers and sender business processes allocate plan quantities to receiver. By evaluating the process flow with the plan activity price, the R/3 System can assign costs to the receivers during the allocation itself.

The allocation is dependent on the period and fiscal year.

You can use business processes or cost center/activity types as senders with template-allocation for business processes/cost centers. You can use the following objects as receivers (SBP = name of the environment):

- SBP: Business process
- SCD: Cost centers/Activity types (activity dependent allocation)
- SCI: Cost centers (activity independent allocation)

Prerequisites

Master data and templates

These include:

- Creating the necessary sender objects; for example Business Processes [Ext.] or Cost Center [Ext.]/Activity Types [Ext.]
- Maintaining the Environment [Page 401] or functions necessary for your receiver object
- Providing the Process Drivers [Ext.] (for example, statistical key figures) used by the functions
- Creating appropriate Templates [Page 733]
- Assigning the template to the receiver object (business process, cost center or cost center/activity type)

The allocation uses only activity types of category 1 (manual entry, manual allocation) and category 2 (indirect entry, indirect allocation) and sender business processes of category 1 and category 2 (equivalent to the activity type categories). You do not need to accept the category from the activity type or business process
Template Allocation in Plan: Processes/Cost Centers

master data. These are default values which you can overwrite in quantity and price planning for activity types and business process for each version and fiscal year.

Planning, Quantities and Prices

- First, the quantities must be summed and the prices planned for all the receiver objects of the intended allocation and for all sender objects of type cost center/activity type.

For more information, see Process Output (Quantities and Prices) Planning [Ext.] (ABC) and Activity Type Planning [Page 208] (CCA).

- SOP/LTP: you can determine and transfer plan quantities for receiver objects (business processes) of the highest hierarchy level (see Exploding Structured Processes [Ext.]) in the following manner: you can transfer the requirements of production from the intended, rough production planning (SOP), or of the long term planning (LTP) from the receiver object, and execute the allocation with this data.

For more information, see Transferring Activity Schedules [Ext.] (ABC) and Transferring Activity Schedules [Page 450] (CCA).

Note the following regarding receiver business processes: if a sub-process does not include a plan process quantity, the SAP System uses the allocated process quantity for process cost calculations. The system uses this process quantity for further calculations.

This happens only if the sub-process is simultaneously a receiver process in the structure hierarchy. Therefore, activity quantities of cost center/activity types are treated only as scheduled activities.

Activities

In Activity-Based Costing or Cost Center Accounting, choose Planning → Allocation → Template allocation.

For more information on template assignments and allocations, see:

Templates for Business Processes/Cost Centers [Page 729]
Templates for Bus. Proc./Cost Center Assignment [Page 732]
Executing Template-Allocations [Page 741]
Example Template Allocation Process (Plan) [Ext.]

Reversing allocations in plan

It is possible for you to reverse an allocation in plan. In the screen for template allocations, choose Extras → Reverse (normally not necessary, as corrections are made in the delta postings).

Additional business posting transactions while executing allocations in plan

You can also make a manual posting in the template allocation. This allows you to make additional postings for extraordinary cases manually; namely for business processes, cost centers or cost center/activity types.
Templates for Business Processes/Cost Centers

Definition

The template is a dynamic tool, which uses functions [Ext.], formulas [Page 435], and Boolean logic (true/false) to calculate values. It consists of a grid of columns and rows.

- Create a template in environment SBP for allocations in business processes.
- Create a template in environment SCI for allocations in cost centers.
- Create a template in environment SCD for allocations in cost centers/activity types.

Structure

You can choose between six item categories. Depending on the item category you choose, you will have the following columns available for data entry.

<table>
<thead>
<tr>
<th>Item Type</th>
<th>Columns that can be edited</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commentary row</td>
<td>Description</td>
</tr>
<tr>
<td>Process</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Sub-Template</td>
<td>Name, Object, Activation condition</td>
</tr>
<tr>
<td>Cost center / activity type</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Calculation row (Process)</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Calculation rows (cost centers/activity types)</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
</tbody>
</table>

You have the following entry and maintenance possibility per column type.

<table>
<thead>
<tr>
<th>Column type</th>
<th>Possible Entries/Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Type</td>
<td>Commentary row, Process, Sub-template, Cost center/activity type, Calculation row (Process), Cost center/activity types, Calculation row (Cost center/activity type)</td>
</tr>
<tr>
<td>Description</td>
<td>Explanations</td>
</tr>
<tr>
<td>Object</td>
<td>Based on the item type, enter the sender object (such as business process). You can enter a fixed object with type process or cost center/activity type, or you can let the system determine this dynamically within an analysis period for one or more processes or cost center/activity types. For more information, see Object Determination [Ext.].</td>
</tr>
</tbody>
</table>
Activation Requirements

Under Activation, determine the conditions, which activate the item. You can enter Active or Inactive as fixed values, or you can define a method, which allows the R/3 System to activate or deactivate the item when the valuation occurs.

For more information, see Activation [Ext.].

Plan/Actual quantity factor (only environment SCD and SBP!)

Factor for variable output quantity. Enter a factor in items process or cost center/activity types. The planned output quantity of the receiver object is multiplied with the factor. The result is the sender output quantity. You can enter a constant value, or you can allow the R/3 System to determine the appropriate value when the valuation occurs.

For more information, see Quantity Determination [Page 425].

Plan quantity fixed/Actual quantity fixed

Enter the consumption quantities in items process or cost center/activity types. You can enter a constant value, or you can allow the R/3 System to determine the appropriate value when the valuation event occurs.

For more information, see Quantity Determination [Page 425].

If you choose item category calculation row, the editor cannot be called up in the object columns.

Example

Template for allocation in business processes (environment SBP).

In the above illustration, the resource consumption chain appears with the main process at the very end, Process 3.
Whenever process HP is consumed, processes 1, 2 and 3 are also used, as well as the cost center/activity type 1.

The following table clarifies the allocation names:

<table>
<thead>
<tr>
<th>This process is used...</th>
<th>...then this object is used...</th>
<th>...with a fixed quantity that is calculated with...</th>
<th>...with a variable quantity that is calculated with...</th>
<th>...all of which is set in template.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process HP (through receiver object)</td>
<td>process 1</td>
<td>formula 1</td>
<td>factor 0.5</td>
<td>HP</td>
</tr>
<tr>
<td></td>
<td>process 2</td>
<td>20 units (fixed entry, no calculation)</td>
<td>formula 2</td>
<td>HP</td>
</tr>
<tr>
<td>Process 2 (through process HP)</td>
<td>CCtr 1/Activity type 1</td>
<td>_</td>
<td>factor 10</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>process 3</td>
<td>formula 3</td>
<td>factor 2</td>
<td>2</td>
</tr>
</tbody>
</table>

See also:

- Templates [Page 733]
- Executing Template-Allocations [Page 741]
Executing Template Allocations

1. Choose the transaction for the template allocation in your application.
2. Enter the receiver object(s) (see Selection variant [Page 28]).
3. Enter the version [Ext.] (if more than one exists) and the periods and fiscal year for the allocation.
4. You can determine the type of processing and the preparation of results with the Test run, Background processing, and Detail list indicators.
   i. If you activate the Test run indicator, the SAP system runs the template allocations without posting the results. We recommend using the Detail list indicator together with the Test run indicator so that you may then analyze the test run results.
   ii. If you need to process large volumes of data, use the Background processing indicator for executing the allocation during periods of low system use.
5. To execute the template allocation, choose or Allocation → Execute.
6. After the results are displayed (Display run results: Template Allocation [Ext.]), you can use the Template Trace: Basic Screen [Ext.] for a more detailed/broken down view.
7. In Display Detail [Ext.] it is also possible to view the results of individual template cells.
Plan Cost Splitting

Use

During plan cost splitting, the system splits the activity-independent plan costs of a cost center among the activity types of this cost center. You must split plan costs before executing:

- **Price calculation:**
  Plan costs are split automatically during price calculation. The SAP System determines the plan prices from the ratio of plan costs and plan activity. Splitting activity-independent plan costs on the cost center activity types helps to calculate the fixed price portion of the overall price. Plan cost splitting therefore ensures that all planned costs are considered during price calculation.

- **Plan/Target/Actual Comparison**
  To view all costs at the cost center/activity type level and make plan/target/actual comparisons, you must split activity-independent actual and plan costs among the activity types. You use the same methods for actual and plan costs.

  In the actual there is an additional splitting step in which the actual data is adjusted to the plan data. Actual data is distributed to the activity types on the basis of target costs or target quantities and by cost element.

Prerequisites

To split plan costs, you must first plan the corresponding values in activity type planning.

For additional information on splitting rules see Customizing for Controlling, under *Cost Center Accounting → Planning → Allocations → Activity Allocation → Splitting → Maintain splitting structure [Ext.]*. If you not made any settings for splitting in the IMG, the splitting is based on equivalence numbers.

Note the following requirements:

- If you split costs based on equivalence numbers, but you have not planned these during activity type planning, the SAP System uses equivalence number 1 as a standard value.

- If you have transferred planning data but no equivalence numbers to the CO application component via the planning data interface (see: External Data Transfer [Ext.]) the system sets the equivalence number to 0. You must therefore repeat the planning of the equivalence numbers.

Features

The activity-independent costs planned on a cost center are split on the activity types according to the splitting structure that you defined during Customizing and assigned to this cost center. A splitting structure contains one or more assignments in which you store splitting rules for the corresponding cost element(s) or cost element groups. You can restrict the selection of cost elements or cost element groups, as well the activity types on which the costs are split.
Plan Cost Splitting

Splitting methods are assigned to the splitting rules. These methods specify how the costs are split. Based on the splitting methods, which are fixed in the R/3 System, you can split plan costs according to the following criteria:

- Activity quantity
- Equivalence number
- Capacity
- Output
- Scheduled activity
- Statistical key figure (quantity)
- Statistical key figure (maximum quantity)
- No splitting is executed

You can also use weighting indicators to control whether tracing factors are to be weighted for the cost splitting. Set the indicator if the individual tracing factor values use different units of measure. If the Conversion indicator is active, the values are multiplied with the equivalence numbers of the activity types. This enables you to compare the different units of measure of the tracing factor values.

Activities

To execute plan cost splitting, access the Cost Center Accounting menu and choose **Cost Centers → Planning → Allocations → Splitting**

See also:

[Actual Cost Splitting](Page 368)
Example for Plan Cost Splitting

You have planned the following activity-independent values on cost center A:

### Activity-Independent Primary Cost Planning

<table>
<thead>
<tr>
<th>Cost element</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>420.000</td>
<td>$1,000</td>
</tr>
<tr>
<td>430.000</td>
<td>$1,500</td>
</tr>
<tr>
<td>404.000</td>
<td>$2,400</td>
</tr>
<tr>
<td>400.000</td>
<td>$1,200</td>
</tr>
</tbody>
</table>

You can carry out splitting into production hours and machine hours, for example, based on equivalence numbers or quantities. The following values result:

### Activity type planning

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Activity quantity</th>
<th>Equivalence number</th>
</tr>
</thead>
<tbody>
<tr>
<td>FST</td>
<td>100</td>
<td>3</td>
</tr>
<tr>
<td>MST</td>
<td>20</td>
<td>2</td>
</tr>
</tbody>
</table>

For cost elements 420000 to 430000 splitting occurs based on equivalence numbers. For cost elements 400000 to 404000 splitting is based on quantities. Store the following splitting rules in splitting structure XY.

### Splitting Structure XY:

<table>
<thead>
<tr>
<th>Assignments</th>
<th>Cost element interval</th>
<th>Rule</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>420.000 - 430.000</td>
<td>PERS</td>
<td>21: Equivalence numbers, plan</td>
</tr>
<tr>
<td>2</td>
<td>400.000 - 404.000</td>
<td>ROH</td>
<td>12: Activity quantity</td>
</tr>
</tbody>
</table>

The splitting methods (splitting by equivalence numbers or by activity quantity) are set in the SAP R/3 System as defaults.

The SAP R/3 System determines the following values, based on the splitting rules:

### Splitting Based on the PERS Rule:

<table>
<thead>
<tr>
<th>Cost-Element</th>
<th>Portion MST</th>
<th>Split plan costs MST</th>
<th>Portion FST</th>
<th>Split plan costs FST</th>
</tr>
</thead>
<tbody>
<tr>
<td>420.000</td>
<td>2/5</td>
<td>$1,000 * 2/5 = $400</td>
<td>3/5</td>
<td>$1,000 * 3/5 = $600</td>
</tr>
</tbody>
</table>
### Example for Plan Cost Splitting

<table>
<thead>
<tr>
<th>Amount</th>
<th>Portion</th>
<th>Split plan costs MST</th>
<th>Portion</th>
<th>Split plan costs FST</th>
</tr>
</thead>
<tbody>
<tr>
<td>430.000</td>
<td>2/5</td>
<td>$1,500 * 2/5 = $600</td>
<td>3/5</td>
<td>$1,500 * 3/5 = $900</td>
</tr>
</tbody>
</table>

### Splitting Based on the ROH Rule:

<table>
<thead>
<tr>
<th>Cost element</th>
<th>Portion MST</th>
<th>Split plan costs MST</th>
<th>Portion FST</th>
<th>Split plan costs FST</th>
</tr>
</thead>
<tbody>
<tr>
<td>400.000</td>
<td>20/120</td>
<td>$1,200 * 1/6 = $200</td>
<td>100/120</td>
<td>$1,200 * 5/6 = $1,000</td>
</tr>
<tr>
<td>404.000</td>
<td>20/120</td>
<td>$2,400 * 1/6 = $400</td>
<td>100/120</td>
<td>$2,400 * 5/6 = $2,000</td>
</tr>
</tbody>
</table>
Plan Price Calculation

Use

Plan price calculation determines prices for the plan activity types of each cost center and activity type or business process (see also: Actual Price Calculation [Page 378]).

In the plan, the SAP System considers all the planned activity relationships between cost centers and between business processes. It calculates the prices iteratively by dividing the plan costs by the plan activity quantity.

Alternatively, you can also determine the fixed portion of the price as the quotient (ratio) of plan costs and capacity. This is useful when the costing of a given product is not to be influenced by the costs of providing the maximum activity quantity. For example, an energy-supplying cost center must always be capable of supplying the maximum level of activity, even if this activity quantity is not always used. In this case, the fixed provision costs should remain on the supplying cost center, since the full amount cannot be assigned directly to the product costs.

You can only execute price calculation if, during the activity type planning for the given cost centers or business processes, you have set the price indicator [Page 151] to 1 or 2. Price calculation is based on the plan activity quantity if you select “1”, or based on the capacity if you select “2”. It is not advisable to carry out price calculation if you have specified all prices manually (price indicator “3”).

Prerequisites

For iterative price calculation all necessary data (cost of all business transactions, primary and secondary costs, activity-dependent and activity-independent costs) must be available. This requires that the following conditions have been met:

1. Planning is complete.
2. If orders or logistics are part of planning you must settle the orders or projects to the cost centers.

Features

The SAP System calculates different prices, depending on the Methods indicator, which you set in the corresponding version. To set this indicator, call up the Implementation Guide (IMG) for Cost Center Accounting or Activity-Based Costing, then choose Planning → Basic Settings → Maintain Versions. Select the version you require and choose Settings for fiscal year. Select the corresponding fiscal year and choose Detail. You can set the Method you require under Plan.

The following values are possible:

- 1 Periodic prices
- 2 Average prices
- 3 Cumulative prices

For more information, see Methods for Price Calculation [Page 883].

The SAP System calculates the price of an activity type on a cost center or on a business process by dividing the sum of all the costs of this cost center or business process by the plan
Plan Price Calculation

activity or capacity. As a result, different periodic prices can occur when you use the Periodic price method, which means that either the total plan costs of a cost center or business process, or the plan activity, or both of these factors, can display different values. The following factors produce these periodic differences.

- **Distribution keys**
  
  If you do not distribute the plan costs and activity equally between the periods, this results in differing values for plan activity and plan costs (primary and secondary), and therefore differing tracing factors in price calculation.

- **Equivalence numbers**
  
  You can plan equivalence numbers by period. Different equivalence numbers in individual periods result in higher portions of activity-independent costs being distributed to the activity types in these periods. This results in differing total costs in the individual periods, which means that the fixed portion of the price changes periodically. Equivalence numbers have the value 1 unless another value is entered. This means that all activity types are weighted equally.

In Cost Center Accounting, you include activity-independent plan costs in your activity prices by using splitting rules which you specify as part of plan cost splitting (for more information, see: plan cost splitting [Page 481]). The SAP System distributes the activity-independent plan costs of a cost center to the activity types of the cost center. The simplest way to do this is to distribute on the basis of equivalence numbers. The SAP System calculates the ratio of the equivalence number of one activity type to the total of all equivalence numbers for activity types on the cost center. The activity-independent plan costs are multiplied by this weighting factor and added to the activity-dependent plan costs.

Activity-independent plan costs are always fixed. Therefore, the plan fixed quotient of the activity-dependent plan costs is increased by the amount which results from the distribution of the activity-independent plan costs based on equivalence numbers.

You have planned $30,000 activity-independent costs on cost center A. You have also planned the activity types as follows.

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Quantity</th>
<th>Equivalence number</th>
</tr>
</thead>
<tbody>
<tr>
<td>FST</td>
<td>400 hrs</td>
<td>2</td>
</tr>
<tr>
<td>REP</td>
<td>100 hrs</td>
<td>1</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td>3</td>
</tr>
</tbody>
</table>

The activity-independent plan costs are then incorporated in the price calculation:

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Fixed costs by activity type</th>
<th>Fixed activity portion</th>
</tr>
</thead>
<tbody>
<tr>
<td>FST</td>
<td>$30,000 \times \frac{2}{3} = $20,000</td>
<td>$20,000 /400 hrs = $50 /hr</td>
</tr>
<tr>
<td>REP</td>
<td>$30,000 \times \frac{1}{3} = $10,000</td>
<td>$10,000 /100 hrs = $10 /hr</td>
</tr>
</tbody>
</table>

The activity-independent portion of the price for cost center A is $50/hr for activity type FST and $10/hr for activity type REP.
Plan cost splitting is automatically performed in plan price calculation. Separate plan cost splitting is necessary only if you want to review the splitting process using the explanation feature.

Price Calculation

You have planned your data as follows.

<table>
<thead>
<tr>
<th>Activity type</th>
<th>Cost Center 1</th>
<th>Cost Center 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan activity</td>
<td>1,000 hrs</td>
<td>100 hrs</td>
</tr>
<tr>
<td>Primary costs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>$10,000</td>
<td>$5,000</td>
</tr>
<tr>
<td>Salaries</td>
<td>$5,000</td>
<td>$5,000</td>
</tr>
<tr>
<td>Energy</td>
<td>$1,000</td>
<td>$1,000</td>
</tr>
<tr>
<td>Total primary costs</td>
<td>$16,000</td>
<td>$11,000</td>
</tr>
<tr>
<td>Secondary costs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Activity from:</td>
<td>Cost Center 2</td>
<td>Cost Center 1</td>
</tr>
<tr>
<td></td>
<td>10 hrs</td>
<td>50 hrs</td>
</tr>
</tbody>
</table>

The SAP System calculates the prices for these cost centers step by step.

1. The primary costs are divided by the plan activity. The resulting price is used to valuate the activity input.

2. In the following steps, the calculated prices are used to valuate other activity relationships. The exact price of an activity type of a cost center is determined through iteration.

Instead of using the plan activity, you can also use the capacity (maximum activity quantity) as the basis for calculating the fixed portion of the iterative prices. You make these settings during activity type planning (see: Activity Type Planning [Page 208]). Note that the capacity of a cost center for a given activity type can only be used for fixed costs as the basis for price calculation. The plan activity is used as the basis for the variable costs, even if the price indicator is set to “2” (price calculation based on capacity).

A cost center supplying energy must always be ready to supply the maximum amount of activity. The costs for this activity remain constant since they are based on the capacity.

Once all prices have been calculated, the SAP System reevaluates the activity relationships between the cost centers.
Plan Price Calculation

See also:
Executing Price Calculation [Page 489]
Calculating Prices

Procedure

You can use price calculation (see also Plan Price Calculation [Page 485]) for Cost Center Accounting and Activity-Based Costing.

To calculate prices:

1. Choose:
   a. Accounting → Controlling → Cost Center Accounting or Activity-Based Costing and
   b. Planning → Allocations → Price calculation

2. Choose either
   a. Cost center group/business process group (To ensure correct results, the group must consist of a closed activity network)
   b. All cost centers/all business processes
   c. No cost center/business process

3. Enter the following parameters:
   a. Version
   b. Periods
   c. Fiscal year

Iterative prices cannot be calculated for special periods, since no plan values exist for these periods.

4. Maintain the following processing parameters:
   a. Background

You can carry out price calculation either online or in the background.

Online calculation should be used only when you do not expect excessively long run times, such as due to large activity networks.

If you set up complex activity networks you should always use background processing. By starting a background job during times of low system use, you avoid processing bottlenecks during peak times.

To plan background processing, check off the appropriate indicator in the Price Calculation initial screen and enter a job name in the subsequent dialog box.

b. Test run

If you do not want to update immediately, you should select Test run. The SAP System does calculate the price, but it does not post any data. It only generates the detail list.

c. Detail lists
Calculating Prices

If you want to check your results, you should select Test run together with Detail lists. The detail lists shows the prices calculated by the system for each cost center / activity type combination. You can make the posting later from the list.

To post the price calculation from the list display, choose Price calculation → Post. Alternatively, in the Price Calculation initial screen, choose Price calculation → Execute. Deselect Test run to allow updating of the results.

d. With predistribution of fixed costs

If you are using marginal costing, yet still wish to work with allocation rates based on full costs, you should select With predistribution of fixed costs. The SAP system predistributes the fixed costs during the plan price calculation (see also: Predistributing Fixed Costs [Page 875]).

Ensure that your planning is reconciled by checking that the scheduled activity quantity is not greater than the planned activity quantity for the sender cost center. If this is the case, the SAP System displays the error and does not update the values (see Plan Reconciliation [Page 881]).

Result

The detail list contains the following information:

- The calculated prices (total and fixed) for each cost center and activity type or for each business process, per period
- The number of warnings and errors

Choose Edit → Format in the list display to change the display format of the prices to suit your own requirements.

- Currency

  The Currency function enables you to determine in which currency (object currency or controlling area currency) your prices should be displayed.

  If you want to display and post your prices in both controlling area currency and object currency, you must select All currencies when you maintain the control data for your controlling area.

- Values

  You can select from the following display options by choosing Values for your prices:
  - Overall/Fixed
  - Overall/Variable
  - Fixed/Variable

- Activity price

  If you use manually set prices as well as iteratively calculated prices, choose Price to display the following prices:
Calculating Prices

- Iteratively calculated prices, for which the manually set prices were considered by the system.
  This is the allocation price, whereas the fully iterative price can only be determined for control purposes.

- Prices calculated iteratively only (manually set prices are ignored in this calculation).
  To calculate fully iterative activity prices, you must activate the appropriate checkbox in your version. Activate activity price By calculating fully iterative activity prices as well as those which also consider manually-set prices, you can see the effect of the manual-set prices on your complete price calculation. Purely iterative prices can be calculated and displayed, but they cannot be used for allocations.

- Price unit
  You can select from the following values when displaying the *Price unit*:
  - 1
  - Optimized
    The price unit indicates how many units of measure the price for the activity type refers to. The SAP System optimizes the price unit to minimize rounding differences. The optimized value of the prices with the price units are then posted.
    The system displays the prices by period in the detail lists. Choose *Previous period* and *Next period* to scroll between periods. Choose *Select* to display the period values of the selected list rows.

The following additional functions are available in the detail list:

- Period screen/basic list
  This function enables you to switch between a display of individual period values for all activity types and cost centers and a complete display of all periods for one specified activity type and cost center.

- Messages
  You get a list of all errors and warnings with corresponding explanations, as well as notes on how to correct the errors.

- Technical statistics
  This provides you with an overview of the amount of master data processed, as well as links, table entries and iteration steps.

- Sender analysis
  This function identifies and displays the part of the activity network from which the selected cost center is receiving an activity. When you select a list line, the system displays the corresponding activity types, the activity input quantity for the cost center, the overall price, the fixed price, and the price unit.

- Settings
  You can maintain control parameters defaulted by SAP for the process flow for price calculation. You can set the following parameters:
  - Generation
Calculating Prices

This controls the generation of the program for iterative price calculation.

Before you can calculate prices, the SAP System generates the report required for running the program. The system generates the number of entries in the relevant internal tables, as well as in the parallel-processed field groups.

This improves system storage requirements and run times.

As the generation itself also takes time, this indicator should be activated only for large-scale processing.

- Number of senders/receivers

The system sets the appropriate number of entries in the internal tables when you select Generation.

- Number of relationships between senders and receivers

The system sets the appropriate number of entries in the internal tables when you select Generation.

- Number of cost centers in the controlling area

The system sets the appropriate number of entries in the internal tables when you select Generation.

- Number of significant digits of the price unit

To increase the accuracy of the results, the SAP System optimizes the price unit during price calculation. The price refers not to unit 1, but to the units 10, 100, 1000 or 10000. If the price per unit is already relatively high, but you still want to use the price unit to increase the accuracy of your prices, this leads to still higher values for your prices. You can limit this by specifying the significant digits. Places will be shifted only until this number of significant digits has been reached.

If the price per unit is exactly 1033.33333333, with six significant digits the price unit remains 1 and the price would be %1033.33. With 12 significant digits and a price unit of 10,000 the price is $10,333,33.3333.

- Indicator for deactivating price unit optimization

Deactivates the optimization of price units as explained above. If this indicator is selected, the price unit always has the value 1.

- The tolerance percentage rate for reconciliation of actual and scheduled activity

When you call up price calculation, the activity type planning should be reconciled. This means that the planned activity of the activity type should correspond to the scheduled activity quantity of the receiver. Only then can you determine meaningful prices. Therefore, price calculation checks all activity types for matching values and generates warnings or error messages if necessary.

However, minor deviations can occur due to rounding differences in planning, in particular when distributing plan values to individual periods.

Enter the allowable percentage difference (+ and -) between plan and scheduled activity.
Post anyway

Activate this indicator if the results of price calculation should be posted even if they contain errors.

Exceptions are serious system errors resulting in a software crash and errors occurring during posting preparation (problems with integration or document number assignment).

Usually, results are not posted when there is an error in price calculation. You can carry out the update online at a later time using the result list. This does not apply to background processing. For background processing, activate Post anyway so that prices will be posted automatically even if errors occur.

You can display the results of price calculation in the price report (see Price Report [Page 996]).
Manual Actual Postings (CO-OM-CCA)

Purpose

You post actual values manually to enable you to monitor costs on an ongoing basis. These postings enable you to recognize variances at an early stage, and to take the necessary counter measures.

You are assisted in entering manual actual postings by a user-definable reporting, which covers periodic actual cost statements, plan/actual comparisons, and comparison reports based on periodic actual/actual comparisons. You can use this reporting for example to compare the actual costs of the previous period with the actual costs of the current period.

Features

Actual cost entry involves transferring primary costs from upstream components to the Controlling (CO) application component. In the CO component, this transfer occurs real-time from the components Financial Accounting (FI), Asset Accounting (FI-AA), Materials Management (MM), Production Planning (PP) and Payroll Accounting (PA-PA). This is achieved by entering a cost accounting object (such as a cost center or an internal order) during account assignment.

For more information on entering primary costs, see Entering Primary Costs.

Primary costs entered in other systems are allocated further using internal allocations and as true to source as is possible. To enable this, costs are determined for each business transaction, based on the valued internal activity. They are then posted real-time to the sender and receiver object(s) (debit and credit postings).

In the case of internal repostings, costs are reposted from one object to another in order to make the necessary adjustments. This enables you to produce up-to-date statements during the current fiscal period, showing the costs incurred on the cost centers and the cost behavior pattern.

The following business-transaction based repostings or allocations are available in Cost Center Accounting:

- Reposting Costs Manually [Page 502]
- Reposting Revenues Manually [Page 502]
- Reposting Line Items [Page 504]
- Direct Activity Allocation [Page 514]
- Reposting Internal Activity Allocation [Page 525]
- Entering Sender Activity [Page 534]
- Entering Actual Prices [Page 539]
- Entering Statistical Key Figures [Page 545]

Periodic allocations are described under Period-End Closing [Page 560].
Editing Manual Actual Postings

Use

In Controlling, all manual actual postings are structured according to the same principle. You can enter data using either individual entry (for complex allocations) or list entry, where large quantities of data are involved.

The R/3 System assists you in making manual actual postings, through the provision of Entry [Page 497], Display [Page 500], and Reversal [Page 501] functions.

You can use these functions for the following postings:

- Reposting Costs Manually [Page 502]
- Reposting Revenues Manually [Page 502]
- Direct Activity Allocation [Page 514]
- Entering Statistical Key Figures [Page 545]
Entering Manual Actual Postings

1. On the upper screen area, enter the document date and the posting date.
   The system defaults the current date, which you can however overwrite.

2. Choose Extras → Number ranges to display the external or internal number ranges set for
   the given transaction-based allocation.
   a. If you have defined a number range with internal number assignment for the sender and
      you do not enter a document number, the system assigns a number automatically (see:
      Number Ranges [Ext.]).
   b. If a number range with external number assignment is defined for the sender, enter a
      (free) document number from the number range interval.
      This allows you to use the external number assignment universally. This also
      ensures that the Controlling documents can be adapted to the numbering
      conventions of the feeder systems (for example, entry of operations in the production
      department).

3. To avoid needing to reenter the same business transaction repeatedly, you can use existing
   documents as a template for further postings.
   To do so, enter the number of the reference document.
   a. You can get the document number of this document by choosing F4 help for the
      document date or by searching per document date, period or fiscal year.
   b. To display the data for the reference document, choose Display reference document.
   c. To use (and later change) this data, choose Confirm.

4. If you wish, you can display further information on the posting such as the user or the
   exchange rate type.
   To do so, choose the tab strip Additional information.

   If you wish, you can display or hide particular screen areas. To do so, use the icon
   Compress data areas on the left edge of the relevant screen area.

5. Choose a screen variant.
   If you do not enter a screen variant, the system uses the standard variant intended for
   the given allocation.
   You define your own screen variants for manual actual posting in Customizing (per
   business transaction). This screen variant is effectively a collection of settings that
   determines which fields appear on the entry screen.
   For more information, see the Implementation Guide (IMG) for Cost Center Accounting,
   under Actual Postings → Manual Actual Postings → Define Own Screen Variants for
   Postings in Controlling [Ext.]

6. Specify whether you want to enter data using List entry or Individual entry.
   a. If you choose List entry, you can enter more than one posting row for the selected
      document and business transaction.
Entering Manual Actual Postings

b. If you choose Individual entry you can only enter one posting row at a time for the document and business transaction selected.

Below the individual entry screen, the system displays a list to which you can transfer every posting row.

To navigate between these posting rows, select the posting row that you want to move up to/down to. The system displays the data on the selected posting row on the individual entry screen.

7. Enter the data for your posting.

The list entry columns and the ready-for-input fields on the individual entry screen are set in line with the selected screen variant.

You can execute repostings between the individual Controlling objects, such as cost centers or orders, in any currency stored in the system. Repostings are made automatically at the average rate set in Customizing (see: Currencies [Ext.]).

In the Currency field, enter the currency in which the given documents are to be posted.

When entering quantities, you do not need to specify units of measure. The R/3 System automatically adopts the units of measure from the totals transaction data.

8. On the list screen, you can take advantage of the following functions:

Copy posting row
- Select the row you wish to copy.
- Choose Copy.
- Mark the row before which you want to insert the copied row.
- Choose Insert.

Cut out one or more posting rows and insert them elsewhere
- Select the affected row(s).
- Choose Cut.
- Mark the row before which you want to insert the copied row.
- Choose Insert.

Delete one or more posting rows
- Select the affected row(s).
- Choose Delete row.

Use an existing value for the posting rows that follow
- To do so, position your cursor on the value you want to transfer to the empty column fields.
- Choose Fill column.
The value now appears in all the previously empty rows in the relevant column. If, for example, you enter several postings for the same receiver, you then do not need to repeat entry of the receiver.

To reset the fields, position your cursor on the column and choose Reset column.

**Total of all posted positive and negative items per currency or unit of measure**
- To display this figure, use the Show/hide totals line icon.

9. On the individual entry screen, you can take advantage of the following functions:

- **Transfer posting record to navigation list**
  Enter the data and choose Confirm.

- **Delete posting record**
  Choose Delete.

- **Copy posting record**
  Choose Copy.

- **Copy an existing value to empty fields of a column**
  - To do so, position your cursor on the value you want to use in further postings.
  - Choose Hold data.

  The value appears in the relevant field in all other posting records that you enter. If, for example, you enter several postings for the same receiver, you then do not need to repeat entry of the receiver.

  To reset the fields, position your cursor on the appropriate value and choose Reset data.

You can branch to the overview list from both the list entry and individual entry screens by choosing Goto → Overview list.

The overview list contain all posting records created for a document.
Displaying Manual Actual Postings

1. On the upper screen area, enter the number of the document that you want to display.
   You can locate the document number by choosing input help for the document date or by
   searching per document date, period or fiscal year.

2. If you wish, you can display further information on the posting such as the user or the
   exchange rate type.
   To do so, choose the tab strip *Additional information* in the upper screen area.

3. Specify whether you want to display data using *List entry* or *Individual entry*.
   a. If you choose *List entry*, the system displays all posting rows for the selected document
      and business transaction.
   b. If you choose *List entry*, the system displays all posting rows for the selected document
      and business transaction on the *List entry* screen.
      Below the individual entry screen, the system displays a list to which you can transfer
      every line item.
      To navigate between these line items, select the line item that you want to move up
      to/down to. The system displays the data on the selected line item on the individual
      entry screen.

4. To branch to the corresponding document in Financial Accounting, choose *Goto → FI/CO
   documents*.
   You can branch to the following documents:
   - Profitability Analysis documents
   - Profit Center Accounting documents
   - Special Purpose ledger documents
Reversing Manual Actual Postings

1. On the upper screen area, enter the number of the document that you want to reverse.
   You can locate the document number by choosing input help for the document date or by
   searching per document date, period or fiscal year.

2. Choose Enter.
   The system automatically adds the document date and the posting date of the original
   document.

3. If you wish, you can display further information relating to the original document such as the
   user or the exchange rate type.
   To do so, choose the tab strip Additional information in the upper screen area.

4. To display the reversal document, choose List entry or Individual entry.
   a. If you choose List entry, the system displays all posting rows for the selected reversal
      document in a list.
   b. If you choose List entry, the system displays all posting rows for the reversal document
      on the Individual entry screen.
      Below the individual entry screen, the system displays a list to which you can transfer
      every line item.
      To navigate between these line items, select the line item that you want to move up
      to/down to. The system displays the data on the selected line item on the individual
      entry screen.

5. To reverse the document, choose Post.
Reposting Costs and Revenues Manually

Use

You can repost primary costs [Ext.] manually using transaction-based repostings, whereby the original cost element is always retained. This function is designed mainly to adjust posting errors.

You should always adjust posting errors in the application component where they occurred. This ensures that external and internal accounting are always reconciled. You can only adjust posting errors involving one cost accounting object (a cost center or internal order for example) using a transaction-based reposting in Controlling (CO).

To repost collective postings from one cost center to other cost centers at period end, you can use periodic repostings (see: Periodic Repostings [Page 659]).

In Activity-Based Costing, you can only repost costs.

You can only post revenues as statistical items to cost centers - these revenues cannot be included in periodic allocations.

You mistakenly assigned the amount of 10,000 USD for the cost element External services to cost center 4210. The costs should have been posted to cost center 4220. In transaction-based reposting, you can repost the full amount to the correct cost center under the same cost element. This transaction affects only CO, since the costs are debited (to cost center 4220) and credited (to cost center 4210) using the same cost element.
If you are working with transfer prices [Ext.] (parallel value flows), you cannot repost costs or revenues for parallel valuations. You need to use the function for reposting line items (see: Reposting Line Items [Page 504]).

For more information on transfer prices, see Multiple Valuation Approaches [Ext.] in Overhead Cost Controlling, and the SAP Library under Financials → EC Enterprise Controlling → EC Profit Center Accounting → Transfer Prices → Multiple Valuation Approaches/Transfer Prices [Ext.].

**Activities**

- To repost costs, from the area menu of the relevant application component, choose Actual postings → Manual reposting of costs → Enter.
- To display repostings of costs, from the relevant application component menu, choose Actual postings → Manual reposting of costs → Display.
- To reverse repostings of costs, from the relevant application component menu, choose Actual postings → Manual reposting of costs → Reverse.
- To repost revenues, from the area menu of the relevant application component, choose Actual postings → Manual reposting of revenues → Enter.
- To display revenues that have been reposted, from the relevant application component menu, choose Actual postings → Manual reposting of revenues → Display.
- To reverse repostings of revenues, from the relevant application component menu, choose Actual postings → Manual reposting of revenues → Reverse.

See also:

- Entering Manual Actual Postings [Page 497]
- Displaying Manual Actual Postings [Page 500]
- Reversing Manual Actual Postings [Page 501]
- Receivers of Manual Actual Postings [Page 550]
Reposting Line Items

Use

Reposting line items enables you to adjust posting errors of costs and revenues. You can repost specific line items from CO documents. This enables you to track the primary postings, for example, from Financial Accounting (FI) through to the account assignment object in Cost Center Accounting (for example, a cost center [Ext.], an order [Ext.], or a real estate object [Ext.]).

Prerequisites

The CO documents contain a reference to the primary posting document.

Features

Reposting line items corresponds to a reversal posting on the sender object. This is because the system takes the debit/credit indicator from the line item and updates it immediately for the sender and receiver account assignment objects.

You select the line items that are to be reposted on a selection screen and then process them. This makes it possible, for example, to:

- Select the line items to be reposted from the CO document corresponding to the FI document. The system then reposts the selected line items as follows:
  The given amount is reassigned from the account assignment object (for example, a cost center) of the selected line item to one or more new CO objects.

  If you specify multiple CO objects, you must ensure that the total amount to be reposted does not exceed the overall value of the line items for the sender object.

- Select all corresponding documents, for example, using account assignment objects. The system then offers these documents for collective processing.

- Repost a primary cost posting, previously allocated to one CO object, to two CO objects.

- Repost a portion of the posted line item.
  To do this, you post the portion of the line item to a new account assignment object, and the remainder to the source object.

- Post a line item to a different account assignment object.
  The changed document rows are checked by the system, and the data, provided it contains no errors, is updated in one go.

The system uses a reference document number to create a link between the document of the original line item and the adjustment document.

Activities

You repost line items in two steps:

1. Select the line item that you want to repost (see: Selecting Line Items [Page 506]).
2. Enter the repostings and execute them (see: Reposting Line Items [Page 508]).

See also
Receivers of Manual Actual Postings [Page 550]
Selecting Line Items

Procedure

1. To select the line items you want to repost, from the relevant application component area menu, choose Actual postings → Repost line items → Enter.

2. If the fields offered by the R/3 System on the initial screen for selecting line items for reposting are not sufficient, you can show more fields.
   a. Choose Change selection parameters
   b. Choose New field selection
   c. In the Field choice for dynamic selections dialog box, mark the field you need for selecting account assignment objects, data or accounting documents.
   d. Choose Copy selected items.
      The fields are transferred to Dynamic selections on the right-hand side of the screen.
   e. To undo your selections, select the fields in question and choose Delete selected objects.
   f. You can make entries in the Dynamic selections selection screen. These selections are adopted by the system when you return to the initial screen.
   g. Save your entries.
      The initial screen is now displayed. This screen now includes the fields that you selected.

3. To save the selected fields to your use master record, choose Save field selection. The system then always displays these fields.
   
   If you want to display a standard field selection for all users, choose Edit → General standard and confirm the security prompt with Yes. Your selection is offered to all users who have not entered their own selections.

4. Enter the following data on the initial screen:
   a. The criteria for the Account assignment objects
   b. The general criteria, by which the data is to be selected for the reposting.
   c. A document number
      You can enter one or more individual values, intervals or groups for each of the fields offered by the system. The only exceptions are accounting documents, cost centers, activity types and orders.

5. The following functions are also available on the initial screen:
   a. Selection options offers you more options for entering selection criteria (see: Specifying Selection Options [Page 399]).
   b. You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
c. By choosing *Goto → Variants*, you can save your entries on the initial screen as a variant, enabling you to use these values again when you next call up the initial screen (see: *Processing Variants [Page 1014]*).

6. Choose *Execute*.

**Result**

The system displays a list of all the line items that meet your selection criteria.

**See also:**

*Reposting Line Items [Page 508]*
Reposting Line Items

Prerequisites
You have selected the line items that you want to repost (see: Selecting Line Items [Page 506]).

Procedure

1. To execute repostings, you can overwrite the values in the ready-for-input fields within the document list.

   The following options exist:

   **Post values previously allocated to one account assignment object (such as a cost center) to two account assignment objects**
   
i. Reduce the value allocated to the previous cost center.
   
   ii. Choose **Enter**. The R/3 System displays the difference for the posted value quantity in a new row, using the current account assignment object.
   
   iii. Enter the new account assignment object to which you want to repost the difference.

   You cannot increase the value posted previously. The sum of the amounts for all the document items entered for one line item must correspond to the amount from the original line item.

   **Posting Line Items to a Different Account Assignment Object**

   i. Change the CO account assignment object of the prior primary cost posting.
   
   ii. If required, overwrite the **Object Type [Ext.]**.

   **Using Auxiliary Account Assignments During Line Item Reposting.**

   i. Enter the **object types** and the **account assignment objects** for the auxiliary account assignments (statistical postings) in the list.

      You can select from four account assignment objects. The system always makes a true posting for one of these objects, enabling you to make additional statistical postings for up to three objects.

2. To repost more than one document to the same account assignment object:
   
   a. Select the affected row(s).

      To make your selections, you can use the functions **Select all**, **Select block** and **Delete all selections**.

   b. Choose **Change acct assignment**

      Enter the new account assignment object in the dialog box.

   c. Choose **Continue** to leave the dialog box.

3. To undo the entries in one row or for several rows,
   
   a. Select the necessary rows
Reposting Line Items

To make your selections, you can use the functions Select all, Select block and Delete all selections.

b. Choose Reset row

4. To sort the documents listed by column,
   a. Select a column by clicking on the column header
   b. Choose Sort or Sort descending or, from the menu, choose Edit → Sort or Edit → Sort descending

5. To switch to single processing of a document,
   a. Position your cursor on the relevant line item.
   b. Choose either Edit row, Goto → Edit row, or double-click on the item.

   You can get more information for your document row in Individual processing and make changes, if required.

   From the individual processing, you can go to the document list, the document header and the display for the old document rows.

6. To return to the list of documents, choose List.

7. To reach the document header,
   a. Position your cursor on the relevant line item.
   b. Choose Header

   In the document header you enter the posting date and the document date, plus a description for the reposting.

   The posting date must be in the same fiscal year as the document you want to repost.

   If, for line item postings, you have set external number assignment in the IMG, you can enter the document number in the document header. Choose Number ranges to display the available document numbers.

   If you selected internal number assignment, the system assigns the document numbers automatically.

   To return to the list of documents, choose List.

8. Choose Old document rows to branch to the source document.

9. To check the total quantities reposted per quantity unit,
   a. Enter your repostings
   b. Choose Check total

10. To execute the reposting, choose Post.

Result

The system executes the repostings and outputs the generated document number.
Reposting Line Items
Displaying Line Item Repostings

Prerequisites
The CO documents contain a direct or indirect reference to the document of a primary posting.

Procedure
1. From the application component area menu, choose Actual postings → Repost line items → Display.
2. In the initial screen, enter the criteria for the account assignment object and, if required, for the general criteria for which the system selects data for the reposting; or enter a document number (see: Selecting Line Items [Page 506]).
3. Choose Execute.
   The system displays a list of repostings, which meet the criteria you entered.
4. If you want to sort the documents in a list by a column,
   a. Mark the column header
   b. Choose Sort or Sort descending.
5. To display the individual processing of a document,
   a. Position your cursor on the appropriate row
   b. Choose Edit row, or Goto → Edit row or double-click on the row.
      The system gives you additional information for the document row.
6. To display the document header for a document
   a. Position your cursor on the given row
   b. Choose Header
Reversing Line Item Repostings

Prerequisites

The CO documents contain a direct or indirect reference to the document of a primary posting.

Procedure

1. From the application component area menu, choose Actual postings → Repost line items → Reverse.
2. In the initial screen, enter the criteria for the account assignment object and, if required, for the general criteria for which the system selects data for the reposting; or enter a document number (see: Selecting Line Items [Page 506]).
3. Choose Execute.
   The system displays a list of repostings meeting the criteria you entered.
4. To sort the documents in a list by column,
   a. Mark the column by clicking on the column header
   b. Choose Sort or Sort descending.
5. To reverse a document,
   a. Mark the appropriate document row
   b. Choose Reversal indicator.
6. Post the reversal.

If you have reposted line items and then want to reverse the source document, the system displays an error message informing you that you must first reverse the reposting. In Customizing, you can change this error message to a warning by choosing General Controlling → Change Message Control [Ext.].
Time Sheets

Use

The time sheet lets you create uniform, cross-component personal time records. It unifies the existing personal time keeping functionalities from the individual components. The time sheet can provide you with information about the working time used for internal activity allocation in Controlling (CO).

For more information, see the SAP Library under CA Cross-Application Components → Time Sheets [Ext.] and the Implementation Guide (IMG) under Cross-Application Components → Time Sheets [Ext.].
Direct Activity Allocation

Use

Direct activity allocation involves the measuring, recording, and allocating of business services performed. To do this, you must create the relevant (measurable) tracing factors (allocation bases which can be used as cost drivers). In Cost Center Accounting these are known as activity types [Ext.]. Activity allocation occurs, for example, when business transactions are confirmed or when posting activity quantities to accounts. The system multiplies the activity produced by the price [Ext.] of the activity type.

To do so, for the cost centers [Ext.] or business processes [Ext.] involved, you must plan activity types either using prices set manually or using subsequent iterative price calculation (see also: Plan Price Calculation [Page 485]).

If the receiver of the activity allocation is not a cost object (such as, cost center, business process, or internal order), then the following applies: If no price was set manually, then the plan price is used. If you have not executed an iterative price calculation, then the manually set price for the activity type is used for direct activity allocation (the price in the plan/actual (000) version).

If the receiver of the activity allocation is a cost object (such as, a production order or a product cost collector), then the price used for valuation is determined according to the valuation variant (which is linked to the cost object for the simultaneous costing via the costing variant). If the receiving cost object is not linked to a costing variant for the simultaneous costing, then the plan price for the valuation period is used.

The service cost center "Plumbers" (4110) performs 1 hour of the activity type "Repairs" for production cost center HFI (4210). The plan price for the repairs activity type is 35 USD per hour. In direct activity allocation, this price is valuated as follows:

1 hr X 35 USD/hr = 35 USD

The “Plumbers” cost center is credited with this amount and the HFI production cost center is debited correspondingly.
Direct activity allocation is most often used with the following cost controlling methods:

- Standard costing
  - Static standard costing
  - Flexible standard costing
- Activity-Based Costing
- Direct costing

If you implement internal activity allocation with predistribution of fixed costs (see *Predistribution of Fixed Costs* [Page 371]) and the sender is involved in predistribution of fixed costs, it depends on the receiver as to whether, under internal activity allocation, the system allocates total costs or only the variable costs.

- If the senders and receivers participate in the predistribution of fixed costs and you post true costs to the receiver, the system only allocates variable costs during the internal activity allocation. The fixed portion is ignored.
- If the sender participates in the predistribution of fixed costs, but the receiver (to which you are to post true costs) does not, the system allocates fixed and variable costs.
- If additional receivers, which are participating in the predistribution of fixed costs, are statistically posted to, the system allocates only variable costs to these receivers.
- If additional receivers, which are not participating in the predistribution of fixed costs, are statistically posted to, the system allocates both fixed and variable costs to these receivers.

The system always displays the true value flow on the user interface for internal activity allocation.
Direct Activity Allocation

If you are working with transfer prices (multiple value flows), the internal activity allocations are carried out in the leading valuation. The plan price used for allocation thus applies to all the valuations.

For more information on transfer prices, see the SAP Library under EC Enterprise Controlling → Profit Center Accounting → Transfer Prices (see: Multiple Valuation Approaches/Transfer Prices [Ext.] and Multiple Valuation Approaches in Overhead Cost Controlling [Ext.]).

You can use the internet component Internal Activity Allocations in the Intranet to enter direct activity allocations in the internet. For more information, see:

- R/3 Internet Application Components [Ext.]
- Internal Activity Allocations in the Intranet (CO-OM-CCA) [Page 517]
- Internal Price Lists in the Intranet (CO-OM-CCA) [Page 522]

Activities

- To enter direct activity allocations, from the application component area menu, choose Actual postings → Statistical key figures → Enter.

- To enter direct activity allocations, from the application component area menu, choose Actual postings → Statistical key figures → Enter.

- To enter direct activity allocations, from the application component area menu, choose Actual postings → Activity allocation → Reverse.

See also:

- Entering Manual Actual Postings [Page 497]
- Displaying Manual Actual Postings [Page 500]
- Reversing Manual Actual Postings [Page 501]
- Receivers of Manual Actual Postings [Page 550]
Internal Activity Allocations in the Intranet (CO-OM-CCA)

Use

You can use the internet applications for internal activity allocations \[Ext.\] to record activities that are created and consumed internally. Examples of such internal activities are:

- Repair activities
- Assets produced in-house
- Tools
- Consulting activities

The activity quantities are measured, recorded and allocated during the internal activity allocation. Activity entry and activity allocation occur, for example, when you record the activity.

The internet applications for internal activity allocation enable you to record worldwide the internally produced activities with a minimum of effort. They make a significant contribution to speeding up the entry and allocation of these activities. As soon as you have recorded the activity, you can get a statement of the costs incurred on the debited cost center.

The processing of activities confirmed back to the internet occurs just as for the processing of activities that are entered directly into the SAP System.

As an enhancement to this component, the internet application component Internal Price Lists offers you the option of displaying the prices for the internal activity allocation (Internal Price Lists in the Intranet (CO-OM-CCA) \[Page 522\]).

As an SAP user, the internet application component for internal activity allocation provides you with the following advantages compared to activity entry and allocation without an internet connection:

- You can enter internal activities worldwide.
- You make the entries in a simply structured interface on the Webserver.
- You can enter the activity as soon as it has been produced You do not need to call or fax the confirmation.
- The cost center for which the activity was produced, is debited as soon as the activity is produced. You have an up-to-date overview at all times of the debits or credits of individual cost centers.

For more information on internet application components (IAC), see IAC Programming \[Ext.\].

Type of Internet Application Component

Intranet
Internal Activity Allocations in the Intranet (CO-OM-CCA)

Prerequisites

Authorizations/Security:

To be able to carry out an internal activity allocation in the internet, you require the following:

- A user master in the SAP System
- The authorization to enter activities in the SAP System

List of Authorization Objects

<table>
<thead>
<tr>
<th>Authorization objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>K_VRGNG</td>
<td>CO: Business transactions, actual postings</td>
</tr>
<tr>
<td></td>
<td>Plan and actual allocations</td>
</tr>
</tbody>
</table>

Features

Differences to the R/3 Transaction

The internet application component has the following limitations compared with the R/3 standard transaction KB21:

- Allocation can only take place in version 0 (= Plan/Actual Version).
- Document numbers cannot be entered manually (external number assignment). The document number is always generated automatically by the system (internal number assignment).
- You cannot enter senders and receivers together in one list screen. For a fixed sender, you must enter each time all receivers to which you want to allocate, before you enter the next sender.
- The system offers input screens only for internal activity allocation to cost centers, orders and WBS elements.
- Cost objects, sales orders, run schedule headers, profitability segments and business processes are not receivers of internal activity allocation in the internet.

Adaptation Possibilities

SAP does not foresee any adaptation possibilities for these internet application components.

R/3 Development Objects

There are no development objects for which an adaptation can be carried out.

Service Name

The service name of this internet application component is ILV1. You can find all the corresponding files under this service name in the SAP@Web Studio.
Entering Internal Activity Allocations in the Intranet (CO-OM-CCA)

Prerequisites

To carry out internal activity allocations [Ext.] using the Internet, you must have a user in the SAP System and the authorization for internal activity allocations.

You can only enter internal activities using the Internet if you have already created the corresponding activity type [Ext.] in the SAP System.

Additionally, the SAP System must have a plan price for the activity type on the cost center. During planning, you can either set this price manually or calculate it iteratively.

Once the plan price is known, the cost center providing the activity can debit the receiving object with the product of the activity quantity multiplied by the plan price of the activity.

Logons

Because internal activity allocation is an Intranet process, you must first log on to the SAP System from the internet. The logon procedure requires your user name and password for the SAP System.

Screen Structure

In the Internet Application Component Internal Activity Allocation screen, enter the document header, sender cost center, and activity type in the left half of the screen. You process the document items in the right half of the screen.

Document Header, Sender Cost Center, Activity Type

Enter your sender cost center and the activity type to be allocated.

You can accept or overwrite the default settings in the document header for the posting date and the controlling area [Ext.].

In the document header, you also determine to which object you want to allocate the activity. The Internet Application Component allows allocations to the following objects:

- Cost centers
- Orders
- WBS elements

Document Items

If you choose the document item entry function, you can enter up to five document items for internal activity allocation in the right half of the screen.

In each case, enter the activity consumption and the receiver object for the activity. The R/3 System automatically takes the activity unit from the entries in the activity type master data.

Before saving your entries, you can check your totals. The system displays the controlling area currency, the positive or negative overall total of the posting, and the fixed portion of the allocated costs.
Entering Internal Activity Allocations in the Intranet (CO-OM-CCA)

When you save your entries, the system displays the document number under which the activity allocation was posted.

To enter additional activity allocations, return to the document header entry in the left half of the screen.

From there, you may also exit the Internet Application Component *Internal Activity Allocation.*
Application Example (CO-OM-CCA)

A project leader is responsible for coordinating a project involving a number of subsidiaries in various countries around the world. The project leader visits the subsidiaries regularly to stay informed about progress and to give advice.

The services of the project leader are to be charged to the cost centers for which he provided consulting. He records the activity quantities via the internet so that they can be allocated immediately to the relevant cost centers.
Internal Price Lists in the Intranet (CO-OM-CCA)

Use

In the internal activity allocation [Ext.], the activities from a cost center producing the activities are posted to the receiver of the activity (such as, an order). You can list the activity prices [Ext.] of the activity types using the internal price list. The system determines the valid allocation activity prices for the date entered.

For example, the person responsible for a CO object that receives an activity can use the internal price list to check the activity prices of an activity type. Before the activity input, you could, for example, be interested in the activity prices at different times and from different cost centers. After the activity input, you might want to check the activity prices already allocated.

The internet application component Internal price lists is comparable with the Activity price report available in the R/3 system.

Internal activity allocation is performed using the internet application component Internal Activity Allocation in the Intranet (CO-OM-CCA) [Page 517].

If you are using Internal price lists, as opposed to the Activity price report, you have the option of selecting activity types using a search term. The system searches according to a character chain, which you can define, in the following activity type fields:

- LSTAR Key
- KTEXT Name
- LTEXT Description

For more information on internet application components (IAC), see the IAC Programming [Ext.].

Type of Internet Application Component
Intranet

Prerequisites

Authorizations/Security:

To display the price list in the intranet, you require the following authorizations:

- Display authorization for all controlling areas
- Display authorization for the activity type master in the appropriate controlling area

List of Authorization Objects

<table>
<thead>
<tr>
<th>Authorization object</th>
<th>Description</th>
<th>Required authorization</th>
</tr>
</thead>
<tbody>
<tr>
<td>S_TABU_DIS</td>
<td>Controlling area display authorization</td>
<td>ACTVT = 03</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DICBERCLS = KC</td>
</tr>
<tr>
<td>K_CSLA</td>
<td>Activity types master record in the controlling area</td>
<td>ACTVT = 03</td>
</tr>
<tr>
<td></td>
<td></td>
<td>KOKRS</td>
</tr>
<tr>
<td>S_TCODE</td>
<td>Transaction authorization</td>
<td>KW3P</td>
</tr>
</tbody>
</table>
Standard Settings and Preset Data
When you call up the internal price list, the system displays the local system date (SY-DATLO) as the selection date.
The standard default settings selects all activity types and all cost centers, so long as you do not carry out any limitations.
Controlling area 1000 is the default setting for the HTML template SAPLKW3P_1010.HTML.
The standard R/3 System does not display the controlling area. You have the following options:
- CO_AREA_MODE = "HIDE": Do not display controlling area
- CO_AREA_MODE = "SHOW": Display controlling area
- CO_AREA_MODE = "INPUT": Display entry-ready field for controlling area

Features
Service Name
The service name of this intranet application component is IPL1. You can find all the corresponding files under this service name in the SAP@Web Studio.
Displaying the Internal Price List (CO-OM-CCA)

In the standard system, you use the internal price list as follows:

In the initial screen, you can change the selection for the displayed activity type prices [Ext.] in the left half of the screen. You have the following selection options:

- To select all activity types existing on a given date, enter only the date for which the internal price list is to apply. The SAP System calculates the prices for the corresponding period (month, or year, of the given date). The current date is defaulted.

  You must enter a date.

  The prices in the Internet application component Internal Price List may differ from the prices listed in the price report in the system. This can occur if you generate the price report across more than one period.

- To display the prices for one activity type, specify the key for this activity type.

  You must enter the key exactly. You cannot search generically.

- To select particular activity types, you can specify a character string, which the system searches for in the keys, names, and descriptions of all activity types.

  Do not fill the Activity type field in this case. This is because the system processes both fields using an AND link.

When you start the selection, the system displays a listing of all selected activity types in the upper-right part of the screen. If an activity type has only one price (for one cost center), this is indicated in the list.

When you select an activity type, the system displays an overview of the corresponding cost centers and prices in the lower part of the screen.

In the upper window, you can select another activity type at any time, or start a new selection in the left part of the screen.
Reposting Internal Activity Allocation

Use
You repost internal activity allocations [Ext.] to adjust any incorrect postings arising during the internal activity allocation.

Repostings enable you to adjust an internal activity allocation without the need to reverse the document first and then make an adjustment posting.

Prerequisites
You can only repost an internal activity allocation if you have already allocated activities that you now want to adjust.

Features
You select the internal activity allocations that are to be reposted on a selection screen, and then process them. This makes it possible, for example, to:

- Process together all the activity allocations of a receiver
- Repost to two receivers an activity quantity that was previously allocated to only one receiver
- Repost a portion of the posted activity quantity
- Post an activity allocation to a different receiver

The changed document rows are checked by the system, and the data, provided it contains no errors, is updated in one workstep.

Through a reference document number, the system creates a reference between the document from the source activity allocation and the adjustment document.

You can only post direct internal activity allocations that have been posted in Controlling. You cannot repost activity allocations that were not posted in Controlling.

- Project confirmation
  You can only repost those project confirmation documents in CO, which are related to activity allocation.

- Time recording using cross-application time sheets
  You can only repost the documents from time recording using cross-application time sheets (CATS) in CO, which relate to activity allocation. You can use background processing to post the time records to CO (see: Time Sheets [Page 513]).

You have the option of reposting the internal activity allocation in a different period. Due to the negative activity flow between the old receiver and the sender, the old receiver may contain a negative quantity.

For non-period-related internal activity allocations, you should therefore use a cumulative price, as other price calculations would lead to incorrect results (see: Actual Price Calculation [Page 878]).
Reposting Internal Activity Allocation

If you are using reposting of internal activity allocations together with predetermination of fixed costs (see: Predetermination of Fixed Costs [Page 871]) and the sender is participating in the predistribution, it depends on the receiver whether the overall costs or only the variable costs should be allocated (see: Direct Activity Allocation [Page 514]).

Activities

You repost internal activity allocation in two steps:

1. Select the internal activity allocations that you want to repost (see: Selecting Internal Activity Allocations [Page 527]).
2. Enter the repostings and execute them (see: Reposting Internal Activity Allocations [Page 529]).

See also

Receivers of Manual Actual Postings [Page 550]
Selecting Internal Activity Allocations

Procedure

1. To select internal activity allocations [Ext.] for reposting, from the relevant application component area menu, choose Actual postings → Repost activity allocation. → Enter.

2. If the fields offered by the system on the initial screen for entering IAA reposting are not sufficient, you can show more fields required for your selection.
   a. Choose Change selection parameters.
   b. Choose New field selection
   c. In the Field choice for dynamic selections dialog box, mark the field you need for the selection of sender, data, or receiver.
   d. Choose Copy selected items.
      The fields are transferred to Dynamic Selections on the right-hand side of the screen.
   e. To undo your selections, select the fields in question and choose Delete selected objects.
   f. You can make entries in the Dynamic selections selection screen. These selections are adopted by the system when you return to the initial screen.
   g. Save your entries.
      The initial screen is now displayed. This screen now includes the fields that you selected.

3. To save the selected fields to your use master record, choose Save field selection. The system then always displays these fields.
   If you choose Selection: Reposting IAA (without receivers) the system saves all fields except for the receivers. If you choose Selection: Reposting IAA (only receivers) the system saves the fields for the receivers. Select both if you want to save all fields.

   If you want to display a standard field selection for all users, choose Edit → General standard and confirm the security prompt with Yes. Your selection is offered to all users who have not entered their own field selection.

4. Enter the following data on the initial screen:
   a. Sender
   b. Receiver
   c. General criteria, by which the data for the reposting is to be selected.
      You can enter one or more individual values, intervals or groups for each of the fields offered by the system.

5. The following functions are also available on the initial screen:
   a. Selection options offers you more options for entering selection criteria (see: Specifying Selection Options [Page 399]).
   b. You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
Selecting Internal Activity Allocations

c. By choosing Goto → Variants, you can save your entries on the initial screen as a variant, enabling you to use these values again when you next call up the initial screen (see: Processing Variants [Page 1014]).

6. Choose Execute.

Result

The system displays a list of the internal activity allocations that meet your selection criteria.

See also:

Reposting Internal Activity Allocation [Page 529]
Reposting Internal Activity Allocations

Prerequisites
You have selected the internal activity allocations that you want to repost (see: Select Internal Activity Allocations [Page 527]).

Procedure
1. To execute repostings, you can overwrite the values in the ready-for-input fields within the list of documents.

   The following options exist:

   **Post an activity quantity to two receivers that was previously allocated to only one receiver**
   
i. Reduce the quantity to be allocated to the previous cost center.
   
   ii. Choose Enter.

   The system displays the difference for the posted quantity in a new row, together with the receiver.

   iii. Enter the receiver to which you want to repost the difference.

   ![Diagram]

   The number of working hours allocated from cost center 4200 to cost center 4205 should be reduced from 200 hours to 150 hours. You post the difference of 50 hours to cost center 4210.

   ![Diagram]

   It is not possible to increase the activity quantity compared to the previously posted activity quantity. The sum of the amounts for all the document items entered for one line item must correspond to the amount from the original line item.

   **Post an activity allocation to a different receiver**
   
i. Change the receiver of the previous activity allocation.

   ![Diagram]

   20 working hours produced by cost center 4200 were posted incorrectly to cost center 4205 instead of cost center 4210.

   **Post an activity allocation to a different receiver category**
   
i. Position your cursor on the relevant line item.
   
   ii. Choose Change receivers.
   
   iii. Enter the new receiver under the corresponding receiver type.

   ![Diagram]

   The 20 working hours produced by cost center 4200 should be posted to an order and not to cost center 4205.
Reposting Internal Activity Allocations

Using Auxiliary Account Assignments for Activity Allocations

i. In the list, enter the receiver categories and the receivers for the auxiliary account assignments.

Up to three auxiliary account assignments are possible (receiver 2 to receiver 4) depending on the activity allocation method.

2. To repost more than one document to the same receiver,
   a. Select the affected row(s).
      To make your selections, you can use the functions Select all, Select block and Delete all selections.
   b. Choose Change receivers
      Enter the new receivers in the dialog box. Choose Continue to leave the dialog box.

3. To undo the entries in one row or for several rows,
   a. Select the necessary rows
      To make your selections, you can use the functions Select all, Select block and Delete all selections.
   b. Choose Reset row

4. To sort the documents listed by column,
   a. Select a column by clicking on the column header
   b. Choose Sort or Sort descending

5. To switch to single processing of a document,
   a. Position your cursor on the relevant line item.
   b. Choose either Edit row, Goto → Edit row, or double-click on the item.

You can get more information for your document row in Individual processing and make changes, if required.

From the individual processing, you can go to the document list, the document header and the display for the old document rows.

6. To return to the list of documents, choose List.

7. To reach the document header,
   a. Position your cursor on the relevant line item.
   b. Choose Header or Goto → Header

In the document header you save a description for the reposting, the posting date and the document date.

The posting date must be in the same fiscal year as the document you want to repost.
Reposting Internal Activity Allocations

If, for internal activity allocation (transaction RKL) you have set external number assignment in the IMG, you can enter the document number in the document header. Choose Number ranges to display the available document numbers.

If you selected internal number assignment, the system assigns the document numbers automatically.

To return to the list of documents, choose List.

8. Choose Old document rows to branch to the source document.
   a. If the document was created using internal activity allocation in CO, the system displays the old document just as for Actual postings → Activity allocation → Display.
   b. If the document was created using project confirmations the system displays the confirmation document.
   c. If the document was created using a time recording with Cross Application Time Sheets (CATS), the system displays the CATS document.

If the document was created by the reposting of a different document for internal activity allocation, the system cannot display the old document rows. The system issues an appropriate note.

9. To check the total quantities reposted per quantity unit:
   a. Enter your repostings
   b. Choose Check

10. To execute the reposting, choose Post.

**Result**

The system executes the repostings and outputs the generated document number.
Displaying Internal Activity Allocation Repostings

Prerequisites
You have reposted internal activity allocations (see: Reposting Internal Activity Allocations [Page 529]).

Procedure
1. From the application component area menu, choose Actual postings → Repost activity allocation → Display.
2. On the initial screen, enter the criteria for the senders, receivers and general criteria for which the system selects data for the reposting (see: Selecting Internal Activity Allocations [Page 527]).
3. Choose Execute.
The system displays a list of repostings that meet the criteria you entered.
4. If you want to sort the documents in a list by a column,
   a. Mark the column header
   b. Choose Sort or Sort descending
5. To display the individual processing of a document,
   a. Position your cursor on the appropriate row
   b. Choose Edit row, or Goto → Edit row or double-click on the given row.
The system gives you additional information for the document row.
6. To display the document header for a document,
   a. Position your cursor on the given row
   b. Choose Header
Reversing Repostings for Internal Activity Allocation

Prerequisites
You have reposted internal activity allocations and you now want to reverse them (see: Reposting Internal Activity Allocations [Page 529]).

Procedure
1. From the application component area menu, choose Actual postings → Repost activity allocation → Reverse.
2. On the initial screen, enter the criteria for the senders, receivers and general criteria for which the system selects data for the reposting. (see: Selecting Internal Activity Allocations [Page 527].)
3. Choose Execute.
   The system displays a list of repostings, which meet the criteria you entered.
4. If you want to sort the documents in a list by a column,
   a. Mark the column header
   b. Choose Sort or Sort descending.
5. To reverse a document,
   a. mark the appropriate document row
   b. choose Reversal indicator.
6. Post the reversal.

If you have reposted an activity allocation and then want to reverse the source document for the activity allocation using Actual postings → Activity allocation → Reverse, the system issues an error message informing you that you must first reverse the reposting. In the Implementation Guide (IMG) for General Controlling (section Change Message Control [Ext.]) you can change this error message to a warning.
Entering Sender Activities

Use

You can enter activities that have been marked for **indirect** allocation (activity type category 3: manual entry, indirect allocation) or as **non-allocable** (activity type category 4: manual entry, no allocation).

- You enter **indirect** allocable activity to determine the quantity flow for indirect activity allocation. You enter the activity quantity on the sender cost center or on the sender business process.

  Under indirect activity allocation, the activity quantity is distributed to the receiver cost centers according to their allocation bases (see also: Indirect Activity Allocation [Page 713]).

- You enter **non-allocable** activity on cost centers or business processes that cannot be credited using activity allocation. The activity quantity produced by the cost center is used as the basis for cost control. The SAP System uses the plan activity and the non-allocable activity to calculate an operating rate. It can then determine target costs and variances for the cost center.

  When entering sender activities, you can enter activities for the following **sender objects**:

  - Business processes
  - Cost Center/Activity Type

In a business organization, variable costs are incurred on a sales cost center for each product unit sold. These costs cannot be credited to a profitability segment using direct internal activity allocation. The costs remain on the cost center, unless you are using the Internal Orders component (CO-OM-OPA) or Profitability Analysis (CO-PA) which allow a credit to take place.

See also

- Entering Sender Activities [Page 535]
- Displaying Sender Activities [Page 537]
- Reversing Sender Activities [Page 538]
Entering Sender Activities

1. To enter sender activities, from the relevant application area menu, choose Actual postings → Sender activities → Enter.

2. On the initial screen, enter the document date and the posting date.
   The system defaults the current date, which you can however overwrite.

3. Choose Number intervals to display the external or internal number ranges set for the given transaction-based allocation.
   a. If you have defined a number range with internal number assignment for the sender and you do not enter a document number, the system assigns a number automatically (see: Number Ranges [Ext.]).
   b. If a number range with external number assignment is defined for the sender, enter a (free) document number from the number range interval.
      This allows you to use the external number assignment universally. This also ensures that the Controlling documents can be adapted to the numbering conventions of the feeder systems (for example, entry of operations in the production department).

4. To avoid continually reentering similar allocations, you can use existing documents as a template.
   This helps minimize errors when entering documents. Enter the template document under Template.

5. To enter one posting, choose Detail screen.
   To enter more than one posting, choose List screen.

6. Enter the data for your posting.

7. On the list screen, you can copy as many document rows as you require, minimizing the number of entries you need to make.
   a. To do so, select the line that you want to copy.
   b. Choose Copy.
   c. Mark the row before which you want to insert the copied row.
   d. Choose Insert.

8. On the list screen, you can cut out one or more rows and insert them in other positions.
   a. Mark the given row(s).
   b. Choose Cut.
   c. Mark the row before which you want to insert the copied row.
   d. Choose Insert.

9. To delete one or more rows on the list screen, mark the given rows and choose Delete item(s).

10. Also on the list screen, you can transfer an existing value into column fields that are still empty.
Entering Sender Activities

a. To do so, position your cursor on the value you want to transfer to the empty column fields.

b. Choose *Set/reset*.

The value now appears in all the previously empty rows in the relevant column. You do not need to repeat the entries.

To reset the fields, position your cursor on the column and choose *Set/reset* once more.

11. On the **list screen**, you can copy the last value entered in a column into a new row.

   To do so, enter “*” in the given column of the new row. When you *post*, the system enters the appropriate amount.

12. Enter the activity quantity.

   You do not need to enter the activity unit, since the system automatically adopts the relevant units from the totals transaction data.

13. To display the document header, choose **Document header**.

   You can enter a text for the document header.

14. On the **Detail screen** you can switch between different posting rows.

   To do so, choose *Previous item* or *Next item* or alternatively, *First item* or *Last item*.
Displaying Sender Activities

1. To display sender activities, from the menu of the relevant application area, choose Actual postings → Sender activities → Display.
2. On the initial screen, enter the document number. You can find this number by using F4 help to search according to document date, posting date, period, and fiscal year.
3. To display the document, choose List screen or Detail screen.
Reversing Sender Activities

1. To reverse sender activities, from the menu of the relevant application area, choose *Actual postings → Sender activities → Reverse.*

2. On the initial screen, enter the *document date* and *document number.*

   You can find the document number by using F4 help to search according to *document date, posting date, period,* and *fiscal year.*

3. To display the reverse document, choose *List screen* or *Detail screen.*

4. To post the reversal document, choose *Post.*
Manual Actual Price

Use
You can manually set an actual price for an activity price of a cost center or a business transaction, independent of the actual activity price calculation. This price is drawn for the valuation of activity relationships between cost centers or business processes. You can overwrite the price retroactively if the price is dependent on the price indicator or on the actual price calculation.

Prerequisites
To produce an actual price manually, first choose a suitable planner profile.
The standard planner profile contains planning layout 1-N01, which produces a manual actual price for activity types in cost centers, and 1-Q01, which produces a manual actual price for a business process.

Features
You can set the fixed or variable part of the actual price in cost centers for an activity type. Moreover, you can determine actual price units and actual price indicators (see Price Indicators [Page 151]).
Similarly, planning layout 1-N01 shows the data booked to the plan price.
You can define the fixed and variable parts of the actual price, actual price unit, and actual price indicator (see Price Indicators [Page 151]) for business processes.
Similarly, planning layout 1-Q01 shows the data booked to the plan price.

Activities
For more information, see:
Entering Actual Prices Manually [Page 540]
Displaying Actual Prices Manually [Page 541]
Entering Actual Prices Manually

Procedure

Initial screen

1. In the menu for Cost centers or for Processes, choose Actual postings → Actual price → Enter.
2. Then enter the relevant periods and fiscal year.
3. Also enter:
   i. for which business process or business process groups you want to define the price, or
   ii. for which cost center(s) and activity type(s) you want to define the price
4. Activate either free- or form-based.
   If you choose free, the SAP System offers an overview screen containing previously planned records available for change. The system shows the header completely, even when no values already exist. Moreover, you can enter new characteristic values in the rows.
   If you choose form-based, the SAP System produces all objects selected in the initial screen, independent of whether values exist or not. In each price setting, the same characteristic value structure appears. You cannot produce new characteristic values.
5. Choose Overview Screen or Period Screen.

Overview Screen

Follow these steps in the Overview screen:

1. Enter the price for the object you selected.
2. Check or set the price indicator.
3. Choose Book.

Period screen

To branch to the Period screen, follow these steps:

1. In the Overview screen, position the cursor on an entry and choose Period screen.
2. Accept the value suggested by the system, or enter your own period value.

You will find more information on navigating through the Overview or Period Screens under Planning Functions [Page 273].
Displaying Actual Prices Manually

Procedure

6. In the menu for Cost centers or for Processes, choose Actual postings → Actual price → Display.

7. Then enter the periods and fiscal year for the price you want displayed.

8. Also enter:
   i. for which business process or business process group you want to display the price, or
   ii. for which cost center(s) and activity type(s) you want to define the price

9. Activate either free- or form-based.
   If you choose free, the SAP System offers an overview screen containing previously planned records.
   If you choose form-based, the SAP System produces all objects selected in the initial screen, independent of whether values exist or not.

10. Choose Overview Screen or Period Screen.

You will find more information on navigating through the Overview or Period Screens under Planning Functions [Page 273].
Manual Cost Allocation

Use
Manual cost allocation involves posting secondary costs [Ext.] manually. The system credits a sender object (for example, a cost center) and debits a receiver object (for example, an order). Until now, you could only use automatic methods for cost allocation (such as assessment or distribution (see: Assessment [Page 711], Distribution [Page 709]).

You can use manual allocation to:

- Avoid the need for complicated Customizing settings for simple allocations
- Manually transfer external data
- Make simple adjustments to incorrect secondary postings.

Note, however, that you then lost the information regarding the value flow, as the system starts a new process chain with manual allocation (see example).

You should not, however, confuse manual cost allocation with a reversal in the conventional sense. If you reverse automatic allocations that were subsequently manually adjusted, the system ignores the manual allocations during the reversal. You must manually reverse these manual allocations one at a time.

Features
You can use manual cost allocation to allocate primary and secondary cost element categories [Ext.]. You can use all cost element categories that may be used for allocations within Controlling. An exception to this is category 43 (allocation of activities/processes) which may only be used for activity allocation.

If you manually report an accrual cost element, the system will ignore the corresponding values during a subsequent accrual calculation.

Restrictions
You can only use manual cost allocation for actual postings. It is not possible to copy data records that were generated using manual cost allocation into plan data.

The system does not currently support the transfer of mass data.

During an assessment, the “Energy” cost center incorrectly allocated automatically heating costs of 1,000 USD to the trade fair order. These costs should have been allocated to the “General Administration” cost center. In this case you can use manual allocation to make the necessary adjustments. You should proceed as follows:

1. Manually allocate the heating costs of 1,000 USD again, this time, however, negative, from the “Energy” cost center to the trade fair order.
2. Then allocate the 1,000 USD manually to the “General Administration” cost center. This ensures that the receiver cost center recognizes the “Energy” cost center as the sender.

If you execute an automatic assessment or allocation after executing a manual allocation, note that the cost elements used for the manual allocation must be stored in the corresponding allocation structure for assessment or accrual calculation.

If in the above example you manually allocate the heating costs of 1,000 USD directly from the trade fair order to the “General administration” cost center, the system does not recognize the “Energy” as the original sender.
Manual Cost Allocation

The manual allocation from the trade fair order to the “General administration” cost center occurs without reference to previous postings. This means that the system cannot display internal business volume, even if the “Energy” cost center and the “General administration” cost center belong to the same cost center group.

Activities

• To enter a manual allocation, from the relevant application menu, choose Actual postings → Manual cost allocation → Enter

• To display a manual allocation, from the relevant application menu, choose Actual postings → Manual cost allocation → Display

• To reverse a manual allocation, from the relevant application menu, choose Actual postings → Manual cost allocation → Reverse

See also:

Entering Manual Actual Postings [Page 497]
Displaying Manual Actual Postings [Page 500]
Reversing Manual Actual Postings [Page 501]
Receivers of Manual Actual Postings [Page 550]
Entering Statistical Key Figures

Use

You can enter statistical key figures [Ext.] for use in reporting or as tracing factors for period-based allocations. This also occurs within a transaction-based allocation in Controlling.

The cafeteria costs are apportioned monthly to all the cost centers in the company based on the number of employees in each cost center. The statistical key figure “Employees” is used as the tracing factor for assessing (apportioning) the costs.

Features

Note the key figure category when you enter the statistical key figures:

- **Fixed values** are carried forward from the posting period to all the subsequent posting periods of the fiscal year. Changes are valid for the subsequent periods until a new value is entered (for example, number of employees).

- Key figures defined as **Totals values** are valid only in the posting period in which they are entered. When changing values, you first have to undo the existing value with a reversed +/- sign and then enter a new value (for example, number of telephone units).

Activities

- To enter statistical key figures, from the relevant application area menu, choose *Actual postings* → *Statistical key figures* → *Enter*.

- To display statistical key figures, from the relevant application area menu, choose *Actual postings* → *Statistical key figures* → *Display*.

- To reverse statistical key figures, from the relevant application area menu, choose *Actual postings* → *Statistical key figures* → *Reverse*.

See also:

- Entering Manual Actual Postings [Page 497]
- Displaying Manual Actual Postings [Page 500]
- Reversing Manual Actual Postings [Page 501]
- Receivers of Manual Actual Postings [Page 550]
Actual Postings to Activity Types

Use

When you execute actual postings you can assign directly to the activity type [Ext.] of a cost center [Ext.]. You can use an activity type as an account assignment object in the following application areas:

- Personnel costs for Payroll Accounting
  You can use the sender activity type specified in the time sheet [Page 513], or in Time Management to further assign personnel costs to Payroll Accounting
- Depreciation postings on the activity type in Asset Accounting (see: Depreciations [Ext.]).
  For periodic postings of depreciation costs in the general ledger you can, in addition to cost centers and orders, also assign costs to the activity type stored in the asset master data.

In the same way, you can also assign costs directly to activity types for G/L account postings in Financial Accounting (see: Posting Documents [Ext.]).

In Controlling you can execute repostings of line items for activity types (see: Reposting Line Items [Page 504]).

Note that the R/3 System ignores the costs assigned to activity types during a later Distribution [Ext.].

To allocate activity, you can use either direct activity allocation [Page 514] or indirect activity allocation [Page 713].

To ensure an exact assignment of the costs to the activity types, you assign costs in the actual just as in the plan. You should therefore post either in the actual and in the plan to the cost center, or in the actual and in the plan to the activity types of the cost center.

Direct account assignment of activity types has an effect on actual cost splitting (see: Actual Cost Splitting [Page 568]). The R/3 System requires that the costs assigned directly to the activity types are assigned correctly, and in full, to the activity types. Directly assigned activity types do not therefore take part in the first splitting step. The R/3 System simply splits the cost into fixed and variable. In the second splitting step, the R/3 System also splits the activity-independent costs on the directly assigned activity types (see: Example of Splitting After Account Assignment to an Activity Type [Page 548]).

Prerequisites

To assign costs to an activity type, go to Customizing for General Controlling and choose the IMG activity for creating a controlling area, under Organization → Maintain Controlling Area [Ext.]. Select AA: Activity Type under Activate components (see: Control Indicators).
If you want to assign costs to activity types for G/L postings in Financial Accounting you should select Activity Type as an entry field in the field selection lists for the corresponding General Ledgers and posting keys. To do this, see Customizing for Financial Accounting, under Financial Accounting Global Settings → Basic Settings → Document → Line item → Controls → Define Posting Keys [Ext.] and Maintain Field Status Variants [Ext.]).
Example of Splitting After Account Assignment to an Activity Type

Splitting without account assignment to an activity type

<table>
<thead>
<tr>
<th></th>
<th>Target</th>
<th>Actual</th>
<th>1. Splitting step</th>
<th>2. Splitting step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center 4200</td>
<td>$100</td>
<td>$500</td>
<td>$100</td>
<td></td>
</tr>
<tr>
<td>Activity type 1420</td>
<td>$200</td>
<td>$200</td>
<td></td>
<td>$250</td>
</tr>
<tr>
<td>Activity type 1422</td>
<td>$200</td>
<td>$200</td>
<td></td>
<td>$250</td>
</tr>
<tr>
<td>Total</td>
<td>$500</td>
<td>$500</td>
<td>$500</td>
<td>$500</td>
</tr>
</tbody>
</table>

From the target costs of $500, the R/3 System posted $100 to cost center 4200 and $200 to each of the activity types 1420 and 1422. $500 of activity-independent costs are posted to cost center 4200 in the actual.

In the first splitting step, the R/3 System uses the target costs to split the activity-independent costs on activity types 1420 and 1422. $100 of activity-independent costs remain on cost center 4200.

In the second splitting step, the R/3 System uses equivalence rules to split this $100 on the activity types. In the example, the splitting occurs in equal portions on activity types 1420 and 1422.

Splitting using account assignment to an activity type

<table>
<thead>
<tr>
<th></th>
<th>Target</th>
<th>Actual</th>
<th>1. Splitting step</th>
<th>2. Splitting step</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center 4200</td>
<td>$100</td>
<td>$300</td>
<td>$100</td>
<td></td>
</tr>
<tr>
<td>Activity type 1420</td>
<td>$200</td>
<td>$200</td>
<td>$200</td>
<td>$250</td>
</tr>
<tr>
<td>Activity type 1422</td>
<td>$200</td>
<td>$200</td>
<td>$200</td>
<td>$250</td>
</tr>
<tr>
<td>Total</td>
<td>$500</td>
<td>$500</td>
<td>$500</td>
<td>$500</td>
</tr>
</tbody>
</table>

The target costs are posted as described in the first section. In the actual, the R/3 System posted $300 to cost center 4200 and $200 directly to its activity type 1420.

In the first splitting step, the R/3 System ignores activity type 1420 of cost center 4200. This assumes that all costs on activity type 1420 of cost center 4200 were assigned directly. The R/3 System uses the target costs to split the $300 on activity type 1422. $100 of activity-independent costs remain on cost center 4200.

In the second splitting step, the R/3 System uses equivalence rules to split this $100 on the activity types. The R/3 System now considers also the directly assigned activity types. In the example, the splitting occurs in equal portions on activity types 1420 and 1422.
Example of Splitting After Account Assignment to an Activity Type
## Receivers of Manual Actual Postings

<table>
<thead>
<tr>
<th>Receiver objects</th>
<th>Costs reposting</th>
<th>Revenue reposting</th>
<th>Line item reposting</th>
<th>Direct acty allocation</th>
<th>Acty alloc. reposting</th>
<th>Entry of actual prices</th>
<th>Manual cost allocation</th>
<th>Entry of statistical key figure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Order</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Business process</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>WBS element</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Cost object</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Real Estate object</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Cost center/activity type</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Profitability segment</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer order</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Network/ activity</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Production process</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

When entering sender activities, you can enter activities for the following sender objects:

- Business processes
- Cost center/activity type
Funds Commitment (Cost Centers, Internal Orders, Projects)

Use
You use this function to enter anticipated costs or revenues where you do not yet know which business transaction will later cause them (purchase order, material reservation and so on). In this way, you can reserve parts of the budget in advance.
You can assign funds commitment to internal orders, cost centers, or projects.

Integration
A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.
For more information, see Availability Control [Ext.].
The system displays the funds commitment as a commitment in the information system for the account assignment objects. For more information, see Commitments Management [Ext.].
You can archive the documents for funds commitment. For more information on archiving, see: CA - Archiving Application Data [Ext.].

Prerequisites
To process the funds commitment, you need the corresponding authorizations for each document type from the K_KMOB_DCT authorization object.

Features
Funds commitment includes the following single activities:

• **Creating Funds Commitments** [Page 553]
  You create a funds commitment as a marked document, which contains:
  – Data in the document header, that is valid for the entire document
  – At least one funds commitment item that contains the actual data on the funds commitment.

• **Changing Funds Commitments** [Page 555]
  You can change the funds commitment as well as enter more items for funds commitment.

• **Reducing Funds Commitments** [Page 556]
  When you manually reduce a funds commitment, you enter the reduction amount for the funds commitment item. You use the open amount to determine the reduction amount. The reduction amount is always the difference between the funds commitment amount, and the total of the partial amounts already reduced. The reduction amount must not be greater than the open amount.
  You can:
Funds Commitment (Cost Centers, Internal Orders, Projects)

- **Reduce one funds commitment**
  You can reduce the items for one marked document by specifying the document number for a funds commitment.

- **Reduce more than one funds commitment**
  You can reduce the items in marked documents for more than one funds commitment when you are in a list.

- **Calling Up Reduction History [Ext.]**
  
  **Reduction reference**
  For information purposes, you can make reference to a follow-up document (such as, order, purchase order, FI document) through which the actual costs will be or have been incurred.

  - To enter a reduction reference for **reduction documents already entered**, choose *Edit → Reduction references* in the reduction history.
  - To enter reduction references for the **current reduction document**, choose *Extras → Reduction references* from the list screen or detail screen.

  **Reversing reduction references**
  You can reverse individual reduction postings. Place the cursor on a reduction document in the reduction history, and choose *Reverse*. The system indicates the reduction document in the *STO* column as reversed.

- **Evaluations Of Funds Commitment Documents In The Information System [Ext.]**
Creating Funds Commitments

Procedure

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Create.
   - Accounting → Controlling → Project System → Actual postings → Funds commitment → Create.

   The Create Funds Commitments screen appears.

2. Enter data as required.
   - Document type
     The document type categorizes your documents, and controls whether you can enter negative values for funds commitment (to display credits for example). See also: Document Type / Number Assignment [Ext.]
   - Document date (issue date of the original document)
     The system defaults today's date, but you can overwrite this if required.
   - Document number
     If you specified an external number assignment for the funds commitment, enter the required document number here. You can define the number interval for the internal or external number assignment in the implementation guide for each application.

3. You have the following options:
   a. If you want to enter more than one funds commitment item, then choose Fast entry.
      You can specify a reference to another funds commitment, as well as account assignments and an amount for each funds commitment item.
   b. If you want to enter a funds commitment item, then choose Detail screen.
      You can use all functions that are available for processing a funds commitment item.

4. Enter data as required.
   - Order, WBS element or cost center.
     The account assignment objects (order and WBS element) must have a status that allows the funds commitment business transaction.
     For more information on status management, see General SAP Status Management [Ext.]

     You need to specify another true account assignment object (such as a cost center) for statistical internal orders or WBS elements. The system does not debit these with costs, but records the values for information purposes only.
Creating Funds Commitments

- On the *Detail screen* enter the following information if required:
  - **Cost center**
    
    The *cost center* account assignment object does **not** have status management.
  - **Material or vendor.**
    
    If you know which material or which vendor is going to require the funds commitment, you can specify this. The system checks whether material or the vendor exist in the system.
  - **Quantity and price**
    
    As an alternative to a funds commitment amount, you can enter a quantity and a unit price.

5. Save your entries with \[\].

**Results**

For internal number assignment, the system determines the document number when you save. The document number is used for posting the funds commitment.

During funds commitment, the system updates a cost commitment on the account assignment object. This update is independent of commitments management activation in Customizing for

- Your controlling area
- Your order type
- Your cost center

A funds commitment that is assigned to a WBS element, a network, or an internal order is part of the active budget availability control. The funds commitment checks whether the available budget is still sufficient. The system includes defined tolerance limits below and above the budget.

If a specified tolerance limit is exceeded by a funds commitment, the system can trigger different actions when you save:

- **Warning**
- **Mail to the order or project manager**
- **Error message**

For more information on availability control, see: [Availability Control [Ext.]](availabilitycontrol).
Changing Funds Commitments

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Change.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Change.
   - Logistics or Accounting → Project System → Controlling → Actual postings → Funds commitment → Change.

   The Change Funds Commitment screen appears.

2. Enter the necessary data and choose Fast entry or Detail screen.

   You can switch between the fast entry and the detail screen at any time.
   In the detail screen, you can switch between the document items using and .

3. Change the document item, or create a new one.

   Once a funds commitment item is completed with the reduction of this document, select Completed in the detail screen. The system displays the completed funds commitment item and then reduces the funds commitment completely. If the system is to reconstruct the funds commitment, undo the selection.
Reducing Funds Commitments

Reducing Funds Commitments Manually

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Actual postings → Funds commitment → Reduce.
   - Accounting → Controlling → Internal orders → Actual postings → Funds commitment → Reduce.
   - Logistics or Accounting → Project System → Controlling → Actual postings → Funds commitment → Reduce.

   The Reduce Funds Commitments Manually screen appears.

2. Enter the necessary data and choose \(\mathbb{Q}\).

3. If the system is to reduce the funds commitment completely, select the completion indicator for this funds commitment item in the detail screen. You can also enter a reduction reference.

4. To reduce the funds commitment by amount, enter the reduction amount and if required, a descriptive short text in the detail screen, under Reduction information.

5. If you want to complete a funds commitment item with a reduction posting, select the Item completed indicator.

6. If you want to reduce commitments for more funds commitment items, choose \(\mathbb{Q}\).

7. Save the funds commitment reduction with \(\mathbb{Q}\).

Reduce Funds Commitments with Invoices

Prerequisites

In Customizing under Financial Accounting → Basic Settings for Financial Accounting → Document → Line Item → Control → Maintain Field Status Variants [Ext.] the Earmarked funds field is selected as a mandatory or an optional entry.

Procedure

1. When you post a vendor invoice in the account assignment block, enter the document number of a funds commitment in the Earmarked funds field.

Results

To obtain an overview of reduced funds commitments, choose Environment → Usage history. The system displays a list of the reduction amounts with the following information:

- Document amount
- Number, amounts and data from the reduction postings
- Open amount
Evaluating Funds Commitment Documents in The Information System

1. Choose one of the following:
   - Accounting → Controlling → Cost Center Accounting → Information system → Reports for Cost Center Accounting → Line items → Cost centers: Commitment line items
   - Accounting → Controlling → Internal orders → Information system → Reports for internal orders → Line items → Orders: Commitment line items
   - Logistics or Accounting → Controlling → Project System → Information System → Controlling → Actual postings → Commitments.

   The Display Line Item Commitments for Projects screen appears.

2. Enter the necessary data and choose More selection criteria. The Define More Selection Criteria screen appears.


4. From the overview tree, choose Documents/Objects → Reference document category. In the right-hand screen area, the system displays the Dynamic selections group box.

5. Enter the reference document category MIVO and save your entry with .

6. The Display Commitment Line Items for Projects screen appears.

7. Use to run the report.

For more information, see Commitments Management [Ext.].

Results

You receive a list of all fund commitment documents that fulfill the specified selection conditions.
Period-End Closing (CO-OM-CCA)

Purpose
Period-end closing in Overhead Cost Controlling is part of the work carried out at period-end throughout the entire organization.

The tasks required at period-end, and the sequence in which they must be carried out, depend on what system functions you use and which cost accounting method. This topic describes the basic elements of period-end closing. The explanations assume that you are using all the features available.

Implementation Considerations
Before you can close a period in Overhead Cost Controlling, the data transferred to this component from other application SAP System components must be complete. In particular, all postings in Financial Accounting (FI) that are relevant to Cost Accounting must have been carried out.

This means, for example, that:
- Payroll accounting must have taken place in Personnel Management (PA).
- In Sales and Distribution (SD), all the invoices have been created and passed on to Financial Accounting.
- The vendor and customer accounts have been locked against postings in the period to be closed.

You are not allowed to lock all accounts, as period-end closing in Overhead Cost Controlling sometimes requires postings to be made Financial Accounting.

Features

Transferring of Statistical Key Figures from the LIS
To ensure that all primary costs and revenues from other components have been posted to Overhead Cost Controlling, it is advisable to start by updating the statistical key figures. Statistical key figures are used as the basis for allocations. This update can occur, for example, through a transfer of the key figures from the Logistics Information System (LIS).

Periodic Repostings/Accrual Calculation
After this, you use repostings [Ext.] to adjust any values that are incorrect or had been posted to allocation cost centers for reasons of simplification. Then the primary costs are distributed according to their source. The primary costs can now be used as the basis for the accrual calculation [Ext.] of valuation differences and additional costs.
Periodic Allocations
Secondary allocations then occur. Using the appropriate allocation or settlement method, the costs are allocated between the business objects of Overhead Cost Accounting and to the cost objects of Product Cost Controlling (CO-PC).

Splitting
When all the costs have finally been assigned to the cost centers, you use splitting [Ext.] to assign the activity types to the cost centers. This is the basis for calculating the prices of the activity types based on actual costs. Using the actual prices, you can perform an actual price valuation of the activity produced by the cost centers.

Variances
After splitting you can analyze the variances [Ext.] of the actual costs from the target costs. These variances lead to cost center under- or over-absorption. The variances of the production cost centers and the costs of the sales and distribution and the administration cost centers are transferred to Profitability Analysis (CO-PA). In CO-PA, the overhead costs can be assigned to any level of the contribution margin scheme. This is the final step in actual cost accounting. You should now lock the period against all postings.

Reconciliation with Financial Accounting
If there is a need for reconciliation between Controlling and Financial Accounting, the relevant allocations are made in FI using the reconciliation posting [Ext.].

The system then lists the period-end closing tasks in a logical sequence:
1. Transfer of statistical key figures from the Logistics Information System (LIS)
2. Periodic reposting of costs from allocation cost centers
3. Distribution [Ext.] of primary costs
4. Accrual calculation of accrued costs
5. Indirect internal activity allocation [Ext.]
6. Allocation of process costs.
7. Overhead Calculation [Ext.]
8. Settlement of overhead orders and projects
9. Assessment [Ext.] of primary and secondary costs
10. Balance-effective settlement of orders to fixed assets, material stock or the balance sheet account
11. Assignment of actual costs to the activity types by means of splitting
12. Calculating prices of cost centers activities or business processes, based on the actual costs
13. Calculation and analysis of the variances between target and actual costs
14. Assessment to Profitability Analysis of the under or over-absorption for the cost centers or business processes
15. Locking the period for all cost accounting business transactions
16. Generating reconciliation postings in Financial Accounting
Follow-up costs can be dealt with by repeating the processing for the given period.
Overview of Period Closing

Use
Within period-end closing for Cost Center Accounting, period-related business transactions are executed after the period end. This includes:

- Periodic reposting
- Accrual cost calculation
- Transfer of statistical key figures from the LIS (Logistics Information System)
- Overhead calculation
- Periodic allocations
- Variance calculation
- Predistribution of fixed costs
- Actual price calculation in Cost Center Accounting

Features

Schedule Manager
Schedule Manager assists you in carrying out and checking period-end closing (see: Schedule Manager [Page 565]).

Periodic Repostings
Periodic reposting is a posting adjustment method. It offers you the same results as several transaction-based repostings made during the fiscal year.

Accrual Calculation
Making accrual calculations involves determining accrued costs using percentage overhead rates. These are then apportioned to credit objects (cost centers or internal orders).

Transferring of Statistical Key Figures from the LIS
You can transfer statistical key figures in the Logistics Information System (LIS) to the Cost Center Accounting component (CO-OM-CCA).

Periodic Allocations
With periodic allocations, the costs incurred are allocated by means of user-defined keys (for example, fixed amounts or percentages). With this method, the actual costs incurred for each period can only be identified after the given period is closed.

Periodic allocations include

- Distribution [Page 709]
- Assessment [Page 711]
Overview of Period Closing

- **Indirect Activity Allocation** [Page 713]
- **Target=Actual Activity Allocation** [Page 720]
- **Template Allocation** [Page 724]

During **distributions** and **assessments** the system allocates costs incurred (or quantities incurred, for **indirect activity allocations**) according to user-defined keys. In **Target=actual activity allocation** the R/3 system determines the actual activity quantities to be allocated, based on the plan activity inputs of the receiver, and taking into account the operating rate of the receiver.

After allocating your costs and activities, you can calculate variances and actual activity prices.

**Variance Calculation**

Variance calculation lets you categorize and display variances incurred on cost centers by cost element. Variance calculation is based on the results of actual cost entry and the allocation methods as well as planning.

**Predistribution of Fixed Costs**

**Predistribution of fixed costs** lets you apportion the fixed costs, which were planned for the activity production, in full as actual costs to the cost centers that planned the activity input.

**Actual Price Calculations**

Actual price calculation lets you determine prices using exclusively actual data. You can use the actual activity price to revaluate all the activity in the actual. In this way, cost centers can be credited in full.
Schedule Manager (CA)

The extensive automation features of the Schedule Manager facilitate the definition, scheduling, execution, and review of tasks that are executed on a regular basis, such as period-end closing. The Schedule Manager consists of four independent components:

- Flow Definition [Page 599]
- Scheduler [Page 574]
- Monitor [Page 592]
- Worklist [Page 619]
Variables in Schedule Manager

By defining variables in Schedule Manager, you can minimize the amount of work that is required to make the necessary value changes (for example, Period) for tasks in the task list.

For more information, see:

- Defining Global Variables for the Task List and Flow Definition
  [Page 567]
- Defining Selection Variables [Page 568]
- Specifying Selection Variables in the Program Variants [Page 569]
- Specifying Selection Variables for Flow Definitions With Parallel Branches [Page 605]
Defining Global Variables for the Task List and Flow Definition

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

Features

You can define selection variables for single programs that are included as tasks in the task plan, as well as for flow definitions.

You can specify global parameters for the task list, such as the company code or profit center.

In Schedule Manager, the same flow definitions (= workflows) can be run in parallel, such as for different plants. The definition of the global variables defined for the main workflow can also be used for the parallel branches.

Activities

You can display the currently defined selection variables. To do so, choose Extras → Settings → Selection variables. You can also define new selection variables. You can then choose these as selection variables in the variable attributes when creating variants for single programs.

For more information, see:

Defining Selection Variables [Page 568]
Specifying Selection Variables in the Program Variants [Page 569]
Specifying Selection Variables for Flow Definitions With Parallel Branches [Page 605]
Defining Selection Variables

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables.

Prerequisites

You must assign a TVARV variable for the plant to each program that is to be run once for all plants.

Procedure

1. Call up the transaction STVARV (Display table TVARV: Selection variables).
2. Choose Change.
   You can create, change and delete new variables.
3. Define a parameter name for your variant.
4. Call up the transaction SM34.
5. Go to view cluster VSMANTVARV.
6. Specify the same parameter name for the variable as you did in transaction STVARV.

   Changes to the global selection variables specified for the task list are transferred to all variables specified in tasks in the task list.

Result

You defined a global selection variable for Schedule Manager.

For more information, see:

Defining Selection Variables in the Program Variants [Page 569]
Specifying Selection Variables for Flow Definitions With Parallel Branches [Page 605]
Specifying Selection Variables in the Program Variants

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Page 568].

You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

1. Choose a processing step in the navigation area. On the right of the screen, you see Flow definition: Task details.

2. Enter a new variant for this processing step and define a name for this new variant in the Variant field.

3. Choose Change variant. The Variant Maintenance screen appears. Program <program name>, variant <variant name>.

Procedure

4. Choose Attributes.

5. Make an entry in the Description field.

6. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.

7. Choose Selection variables.

8. To choose selection criteria for the variables P_FROM (period) and P_GJAHR (fiscal year), use the input help.

You previously entered these variables in table TVARV.

9. Save your entries. The Variant Maintenance screen appears. Program <program name>, variant <variant name>.

Result

You can no longer make entries in the Period and Fiscal year fields. These fields are now always filled through the current entries in table TVARV.
Specifying Selection Variables for Flow Definitions With Parallel Branches

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

You have five programs that must run with the same valuation for nine plants. That means that every program must run with a plant-specific variant for each plant. These variants differ only in their Plant specification.

As described below, you define global variables for fiscal year, period and plant. Create variants for the five programs and define the global variants that you created previously. Finally define a flow definition (A) for the five programs. Define a flow definition (B) with nine parallel branches (for the plants). Include the flow definition A in each of these branches. A dialog box appears that displays the three global variables (fiscal year, period, plant). Enter a value for the variable Plant and flag the entry as to be saved. The dialog box reappears when you plan flow definition B in the day view. Enter values for each fiscal year and period. Do not make an entry for the variable Plant. If you make an entry here, the system does not accept it. You defined the plant when creating the flow definition.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Page 568].

You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

4. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.
5. Enter a new variant for this processing step and define a name for this new variant in the Variant field.
6. Choose Change variant.
   The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Procedure

9. Choose Attributes.
10. Make an entry in the Description field.
11. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.
Specifying Selection Variables for Flow Definitions With Parallel Branches

12. Choose Selection variables.

13. To choose selection criteria for the variables P_FROM (period) and P_GJAHR (fiscal year), use the input help.

You previously entered these variables in table TVARV.

10. Save your entries.

The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Result

The system uses these entries for the following purposes:

- To feed these variables to a program created directly as a task in the workflow.
- To feed these variables to the parallel branches.

The system mixes the variables of the parallel branches with those of the main workflow.

If the parameter values of the main workflow are different from those of the subworkflows, the system uses the parameter values that were specified when the subworkflows were created.
Individual Functions of the Schedule Manager

Use
A number of periodic tasks are executed on a regular basis (daily, weekly, or monthly) in the SAP System. An example of such a task is period-end closing. This requires the processing of a large number of individual objects at certain times. This process is supported by the individual components of the Schedule Manager.

Features

Flow definition
In a flow definition, you can link tasks to each other if they are related or if you wish to use a worklist in them. You can therefore schedule a flow definition as a task in the scheduler.
See also Using the Flow Definition [Page 599] in the SAP Library.

Scheduler
In the scheduler, you can schedule tasks in a structure tree. You can use drag-and-drop in a daily overview to enable the system to execute the tasks at a certain time.
See also Using the Scheduler [Page 574] in the SAP Library.

Monitor
The monitor gives you an overview of the scheduled tasks during and after processing. You can correct faulty objects in a worklist.
See also Using the Monitor [Page 592] in the SAP Library.

Worklist
Objects that are to be processed in a processing step sequence are managed in the worklist.
The worklist monitor presents information such as which objects were processed without errors and which objects could not be processed. You can display information on the cause of errors, and thus control the way in which the object is processed further.
The worklist ensures that when a processing step sequence is processed again, the system only processes the objects which had errors or which you manually instructed the system to reprocess. Define the processing step sequence in the flow definition.
See also Multilevel Worklist [Page 519] in the SAP Library.
Using the Scheduler

Use
In the scheduler, you can execute and monitor complex business flows, for example, period-end closing. You can define task lists if you have the corresponding authorization.

Integration
- You can group tasks that are to be executed in the background in a particular order, (and which are controlled by the workflow) into a flow definition [Page 599].
- You monitor flows and jobs during and after processing in the monitor [Page 692].
- Use the multilevel worklist [Page 619] to improve performance and reduce error processing.

Prerequisites
Before using the scheduler, you need to create a task list in which you can later insert the tasks to be scheduled.

Features

The scheduler is divided up into three areas:
- **Task list**
  Tasks structured into task groups in chronological order, which are executed periodically, possibly by more than one user to complete a certain process.
Individual Functions of the Schedule Manager

- **Monthly overview**
  - An overview of the current and previous month.
  - You can select a day from the monthly overview, which the system then displays in the daily overview in detail.

- **Daily overview**
  - Overview of the tasks to be done during the day.
  - Tasks created in the task list are scheduled in the daily overview. The system displays executed tasks in the daily overview with the time that they started.

**Activities**

Create a task list.

Schedule tasks in the daily overview and if required, have the system execute them.
**Task List**

**Definition**
A structured group of tasks, which are executed periodically, and possibly by more than one user to complete a certain process, such as, period-end closing.

**Use**
The task list enables you to schedule your process (split into tasks) in the daily overview (**Scheduling in the Daily Overview [Page 587]**).

**Structure**
The task list is displayed as a structure tree, into which you can insert different **task types [Page 577]**.

**Integration**
The **Schedule Manager [Page 565]** consists of the daily overview and the monthly overview.
**Task Types**

You can use the following types of task in the task plan:

- Job chains executed in the background (= flow definition)
- Individual jobs executed in the background (= program with variant)
- Programs or transactions executed online.
- Notes as placeholder to describe a task that you do not process in the SAP System (such as “inform Mr. X”)

It is only programs with variants that can be scheduled in the daily view and the system executes them automatically. The system cannot start programs and transactions. You can start these manually from the task list. To do so, use the right mouse button to choose Execute.

**See also:**

[Inserting Your Own Programs into the Task List][Page 584]
Creating a Task List

Use

The task list [Page 576] forms the basis of the scheduler [Page 574]. This is where you arrange tasks or task groups into a chronological structure that represents an entire process (such as period-end closing).

Prerequisites

You have divided the process to be displayed into its components (programs, transactions, and jobs).

Procedure

1. Choose Task list → Create.
2. Enter a name for the new task list.
3. Choose Insert.
   A detail screen appears.
4. Enter a description for the new task list.
5. Specify the display format for the daily and monthly overviews.
6. Save your entries.

Result

You have created a task list in which you can now insert tasks.

See also:

Creating New Tasks/Task Groups in the Task List [Page 579]

To create and process a copy of the SAP task list in your own namespace, choose Task list → Save.
Inserting Tasks/Task Groups into the Task List

Use
To complete a process in Schedule Manager, you need to split the process into its parts (programs, transactions, jobs). You can then insert, delete and reorganize the tasks or task groups (tasks grouped according to content or time-based criteria) chronologically in the task list.

Prerequisites
You create a task list [Page 578].

Procedure

Inserting Tasks/Task Groups in the Task List
1. Choose Change task list.
2. Select the highest node under which the new task/task group should appear.
3. Use a right mouse click to choose Insert task.
   You can enter a different description for the task/task group and also choose the task type. You can specify the person responsible for the task.
4. Choose Insert.
5. Save the changes.
The task types are displayed by various symbols in the structure tree of the task list.

Using Existing Tasks as Templates for New Tasks
1. Use a right mouse click to select the task that you want to use as the template for the new task.
2. Choose Copy.
3. Position your cursor on the node under which the new task is to be assigned.
4. Use a right mouse click to choose Insert.
5. Save your changes to the task list.

Changing or Deleting Tasks
1. Choose Change task list.
2. Use a right mouse click to select the task to be checked/deleted.
3. Choose Change or Delete.
4. Save the changes.

Reorganizing Tasks in the Task List
1. You can use drag-and-drop to move a task to another position in the task list.
2. Save the changes.
Inserting Tasks/Task Groups into the Task List

**Result**

You can now process the task plan by scheduling the tasks in the daily overview.

Note that you can enter a relative start time [Page 589] when creating a task. You require this start time, if you want to schedule a complete task list [Page 588]. To prevent tasks from being started at weekends or public holidays, you can restrict start dates to calendar days and weekdays.
Inserting Your Own Programs as Tasks

Use
You can include your own transaction directly in the task plan without having to make changes to the transaction.

If you run your own program periodically, you can extend the program so that it can be used in flow definitions (Workflows) and you can see the processing status in the monitor.

For the program to use the worklist, the programming guidelines for the job monitor and the flow definition must be met. You must carry out further program extensions.

Procedure

Connecting Your Own Program to the Monitor
The program CUSTOMER_REPORT is available in the system as standard. This shows you how to call two function modules that enable the easiest connection to the monitor (without a workflow connection).

Incorporate the two Includes SCHEDMAN_INIT and SCHEDMAN_CLOSE in your program. The program is connected to the Job Monitor.

Utilizing Your Program for Flow Definition
If you also want to utilize your program in flow definitions, you must incorporate the Include RKASMAWF in the selection screen.

At the beginning of processing, install the following coding instead of the Include SCHEDMAN_INIT mentioned above:

```plaintext
data: gs_key like schedman_key.
data: ls_detail like schedman_detail_user.
data: ls_appl like schedman_customer.
data: ld_dummy(20) value 'ABCDEFGHIJKL'.
constants: customer_appl like smmain-application value 'CUSTOMER'
  ls_detail-application = customer_appl.
  ls_detail-repid = sy-repid.
  * ls_detail-testflag = true. "Decide if testrun or not
  ls_appl-customer_field = ld_dummy.

CALL FUNCTION 'KPEP_MONI_INIT_RECORD'
  EXPORTING
      LS_DETAIL = ls_detail
      *
      LS_WITEM =
```
Inserting Your Own Programs as Tasks

```plaintext
LS_APPL = ls_appl
* LD_WORKLIST_FLAG = ' '
IMPORTING
   LS_KEY = gs_key.
* TABLES
* LT_SELKRIT =
* LT_PARAM =
```

In the structure **SCHEDMAN_CUSTOMER**, you can define your own fields, which you fill with values at runtime.

At the end of program processing, install the following coding **instead of** the Include **SCHEDMAN_CLOSE**:

```plaintext
data: ld_aplstat like smmain-aplstat.
data: LS_SCMA_EVENT LIKE SCMA_EVENT.
constants: c_status_ok value '0'.
constants: c_status_undefined value '2'.
constants: c_status_error value '4'.
constants: c_status_aborted value 'A'.
include schedman_events.

* decide the status you want to send
  ld_aplstat = c_status_ok.
* ld_aplstat = c_status_undefined.
* ld_aplstat = c_status_error.
* ld_aplstat = c_status_aborted.

* If the report ended with error --> stop whole workflow. Otherwise
  * start the next job
    if ld_aplstat = '4' or ld_aplstat = 'A'.
      ls_scma_event-wf_event = cs_wf_events-error.
    else.
      ls_scma_event-wf_event = cs_wf_events-finished.
    endif.
```
The variables `wf_witem` and `wf_okey` are from include RKASMAWF and are filled AUTOMATICALLY. Fill them into structure `ls_scma_event`:

\[
\begin{align*}
ls\_scma\_event\_WF\_WITEM &= wf\_witem, \\
ls\_scma\_event\_WF\_OKEY &= wf\_okey.
\end{align*}
\]

CALL FUNCTION 'KPEP_MONI_CLOSE_RECORD'

EXPORTING

\[
\begin{align*}
LS\_KEY &= gs\_key, \\
LS\_MESSAGE &= , \\
LD\_OBJECTS &= , \\
LS\_EXT &= , \\
LS\_RL &= , \\
LS\_SCMA\_EVENT &= ls\_scma\_event
\end{align*}
\]

* TABLES

* LT_SPOOL =

CHANGING

\[
LD\_APLSTAT = ld\_aplstat
\]

EXCEPTIONS

\[
\begin{align*}
NO\_ID\_GIVEN &= 1, \\
OTHERS &= 2.
\end{align*}
\]

For programs that you want to include in flow definitions, note the following:

- If it is a cross-application program, you need to copy the program that was already stored with an application, and then store the new program in the SCMAPROG table with the new application.

Enter the name of your program as a customer program in Schedule Manager. For more information, see Inserting Your Own Programs as Tasks [Page 584].

You can include your own program in a flow definition using these settings, and see the results in the monitor.
Inserting Your Own Programs as Tasks

Prerequisites

To add your own programs to the task list and schedule them, you must store them in the system and make sure the Schedule Manager knows how to access them.

Procedure

1. To do so, choose Extras → Settings → Customer Programs.
   This brings you to the table Registration of Customer Schedule Manager Programs.
2. Choose New entries.
3. Enter the ABAP program name or search for it using the input help.
4. Use the input help to select an application.
   You can enter either a CUSTOMER application or a standard application. If you use a standard application, you must replace the constant value CUSTOMER_APPL in the coding for SCHEDMAN_INIT with your chosen value.
   
   constants: customer_appl like smmain-application value '*********'.
5. You can set the following indicators:
   
   AVo (worklist)
   Determines that the program
   
   - Receives the objects to be processed in the worklist of the Schedule Manager. This means that no scope of selection must be defined for the report itself. The scope of selection only has to be defined once in the flow definition.
   
   - Processes these objects within the worklist, and that a processing status is set for each processing step and object during processing.
   
   - Issues messages on the object within the worklist.

   To ensure that these requirements are met, certain programming guidelines must be followed when the customer program is written.

   Sel (Selection)

   A program for which this indicator is set is a selection program for the worklist (or for a flow definition with worklist) for a customer application. Programming guidelines must be followed for such programs as well.

   Rep (Reports)

   This indicator is set for programs that generate reports that are based on worklists. Programming guidelines must be followed for such programs as well.
6. Save your entries.
Essentially any program can be scheduled in Schedule Manager.

However, to enable information on the program to be output in the job monitor, the program must meet certain programming guidelines.

Additional programming guidelines must be met to enable the program to be scheduled with the workflow (flow definition).

For the program to use the worklist, the programming guidelines for the job monitor and the flow definition must be met. Further programming guidelines must also be noted.

For more information, see Inserting Your Own Programs as Tasks. [Page 581].
Storing Task Documentation

Use
You can attach Microsoft Office documents to the tasks where they are required for processing. You can also store straightforward long texts to document a task.

Procedure
Creating Microsoft Office Documentation
1. Choose Change task list.
2. Use the right mouse button to select the task to be documented.
3. Choose Office document.
   The required Microsoft Office document type appears. You can now enter your text.
4. Save the document and return to the scheduler by choosing File → Close → Back to the Schedule Manager.

Creating a Long Text
1. Choose Change task list.
2. Use the right mouse button to select the task to be documented.
3. Choose Long text.
   A window appears in which you can enter a note.
4. Choose Continue.
   The system returns to the scheduler.

You can only store one long text and one Microsoft Office document at the same time for a given task.

All users assigned to this task list have access to these documents.

Sending Long Texts
1. Use the right mouse button to select the task for which you have entered a note.
2. Choose Send note.
3. Enter the recipient and a recipient type.
   You can select the priority of the transmission and other attributes.
   You can view the note again and create attachments.

Result
You have stored a document for a task, which is now permanently available to you for reference.
Scheduling Tasks in the Daily Overview

Use

To enable the system to start tasks at certain times, you need to schedule the tasks from the task list in the daily overview.

Prerequisites

You have inserted tasks into a task list.

Procedure

1. Choose Insert task.
2. Use drag-and-drop to schedule a task from the task list in the daily overview, by dropping the task onto an appropriate time.

   Transactions and programs can only be started directly by you. You cannot schedule these task types [Page 577] in the daily overview.

3. To start a transaction or program from the task list, select this task.
4. Use the right mouse button to choose Execute.

Result

The system executes the tasks at the times you specified.
Scheduling a Complete Task List in the Daily Overview

Use
You can schedule a complete task list. The advantage of doing so is that you can use the same task list each month for scheduling purposes simply by changing the start date and time.

Prerequisites
Before you can schedule the complete task list, you must specify a relative start time for each task in the task list. This schedules the sequence of tasks independently of the concrete start date of the task list.

Scheduling a Complete Task List in the Daily Overview
1. Select the highest node of the task list with the right mouse button.
2. Choose Schedule.
3. Specify when the task list should be run.
   You can choose between:
   • Starting on the current day
   • Starting on any other day

Scheduling the Complete Task List
Before actually scheduling the task list, you can run a simulation.
1. Select the highest node of the task list with the right mouse button.
2. Choose Simulation of scheduling.
3. Specify when the task list should be run.
   The system outputs a list showing the starting dates of the tasks in the task list.

Deleting the Scheduling of a Complete Task List
1. Select the scheduled task list in the daily overview.
2. Choose Delete.
   The system outputs a table showing the statuses of the tasks in the task list.

You can decide when the jobs in the task list should be started. For more information, refer to Controlling Whether Jobs Are Started [Page 591].
Relative Start Time

Use

You can schedule complete task lists.

To do this, it is necessary to specify a relative start time for each task.

Features

The relative start time contains two time parameters:

- The number of calendar days or workdays (called the offset), such as 2 calendar days or 1 workday.
- The actual starting time, such as 12:15 pm.

Using these parameters, you can schedule and reschedule the individual tasks independently of the actual run date of the task list itself.

Example 1

You have created the task foreign currency valuation with the parameters offset in working days: 1 and start time: 12:15 pm. If the task list is scheduled to start on a Friday and a factory calendar is being used, the task will be started the following Monday at 12:15 pm (weekends are not working days). If a Gregorian calendar is being used (in this case all days are working days), the task would be started on Saturday at 12:15 pm. If the same task list were scheduled to start on a Monday, in both cases the task would be started on the following Tuesday at 12:15 pm.

If the task list contains several tasks with relative start times, the actual start times are always calculated on the basis of the scheduled date and the specified calendar.

Example 2

The task assessment has an offset of 1 calendar day, and the task settlement has an offset of 2 calendar days. The schedule date of the task list is March 11. The task assessment is started on March 12 (March 11 + 1 day), and the task settlement is started on March 13 (March 11 + 2 days).

The offset for the start time is always based on the concrete schedule date. The system then calculates the concrete start date from this offset using the schedule date and the specified calendar.
Runtime Analysis for Jobs

Use
Runtime analysis shows you the average runtime of jobs or flow definitions. It also estimates the runtime of the next job to be executed.

Activities
1. Select a job with the right mouse button.
2. Choose runtime analysis.
   The system shows you the following information:
   • The average runtime
   • The number of runs executed
   • The runtime of the last and next-to-last runs
   • The estimated runtime of the next run
3. You can also enter your own estimation of the runtime.

If any runtime information is available for tasks in the task list, it is displayed in the last three columns of the task list.
Controlling Whether Jobs Are Started

Use
If you schedule a job in the daily overview but do not release it, it is not automatically started by the system when the start time is reached. This function is particularly useful for scheduling a complete task list [Page 588].

Features
You can release a job:

- When inserting it into the task list
- After scheduling the job in the daily overview

Activities
You are in the mode task list - scheduling.

1. You select a job with the right mouse button.
2. You choose Schedule.
   On the subsequent screen, you specify under Release task whether the job is executed automatically when the start time is reached.
Using the Monitor

Use

The monitor shows the information on an active or completed job that was scheduled in the scheduler.

To improve performance and facilitate error rectification, use the multilevel worklist [Page 519].

Integration

The monitor is part of the Schedule Manager [Page 565].

Other components are:

- Flow definition
  
  You can group tasks that are to be executed in the background in a particular order (and which are controlled by the workflow) into a flow definition [Page 599].

- Scheduler
  
  You can create individual tasks for business transactions (which for example, make up period-end closing) in the scheduler [Page 574] task list. By scheduling them in the daily overview, you enable the system to execute them.

Structure

For detailed information on the functions of the monitor, refer to:

- Monitor - Monitoring Active and Completed Jobs [Page 594]
• Monitor - Working with the Object List [Page 334]
Monitor - Monitoring Active and Completed Jobs

Definition
The monitor shows the information on an active or completed job that was scheduled in the scheduler.

Prerequisites
To enable the system to start jobs or job chains, you need to schedule them in the daily overview of the scheduler.

Features
To determine the current status of jobs that are still running, you can repeat the database selection.
If you only wish to see jobs with a certain status, you can hide the other statuses.
The monitor is divided into three areas:

Structure

• Structure tree
The structure tree displays the workflows (expanded into substeps) and jobs which ran at particular times, in chronological order.
You receive information on:
Monitor - Monitoring Active and Completed Jobs

• The job status
• The job runtime
• The update status

Use the right mouse button to see the different functions available for this job, such as:
• Start transaction
• Restart report
• Goto object monitor in the generalized worklist, and so on.

For more detailed information on a job, double-click on the required entry in the structure tree. The detail view appears.

• **Detail view of a job**

  By switching the tab titles you can select different detailed information (details, parameters, additional information) on a job.

  There are four pushbuttons underneath the tab page. These are only active if corresponding data for the selected job is available:
  
  • Spool list
  Display of batch spool list(s)
  
  • Job log
  Display of the job log belonging to the batch job
  
  • Extract
  Online display of results lists that were saved
  
  • Basic list
  Online display of a short list that was saved. This list contains the most important information on a job.

• **Message list**

  If messages occurred for a job and these were saved, then the system displays them in the message area.

  To go to a message long text, double-click on the corresponding message.

**Activities**

From a scheduled job, you call up the monitor from the daily overview of the scheduler.

You call up the required details for a selected job.

**See also:**

Monitor - Working with the Object List [Page 634]
Monitor - Working with the Object List

Definition

The monitor of the Schedule Manager is a tool for processing multilevel worklists. It contains information on active or completed jobs that were planned in the scheduler.

Use

This section provides information on using the object list in the monitor of the Schedule Manager. For more information on jobs in the monitor, see Using the Monitor [Page 592].

The monitor performs the following functions:

- Displays the available worklists and their processing steps
- Keeps track of the processing status of each object (such as product cost collectors, WBS elements, internal orders, and production orders) and each processing step
- Assists you in analyzing the causes of errors for the objects and processing steps
- Displays the processing status of objects (particularly for the objects with errors)
- Shows the hierarchical relationships between the objects
- Compares object hierarchies with each other
- Controls whether objects enter the next processing step
- Sends objects to the responsible person for further processing

You can set the processing status so that objects of negligible value, for example, are not reprocessed in a processing step even if errors are issued for the objects in that step. In this case, it is not necessary to remove the cause of the error.
The monitor is divided into the following screen areas:

**Structure Tree with Worklists/Processing Steps/Jobs**

The structure tree containing the worklists, processing steps and jobs is displayed on the left side of the monitor.

In the system, the worklists are updated separately for each scope of selection and processing step sequence. The processing step sequence is specified in the flow definition. You can view the worklists of the application component in which you are working, including their functions and objects.

The system displays the following information on each worklist:

- Number of objects in the worklist
- Processing steps
- Number of objects processed in each processing step
- Number of objects with errors in each processing step

**Object List**

The object list is located in the top right area of the screen. The object list can display one or more processing steps of a worklist. You select the processing steps in a worklist in the structure tree `worklists/processing steps/jobs`.

The object list includes the following information:
Monitor - Working with the Object List

- The objects for the selected processing steps. You can control which objects are displayed for each processing step by means of a filter that takes the individual processing statuses into account. In application toolbar icons for object list, choose the icon Objects: Set status filter.
  
  The system uses the last user-specific default setting of the dialog box. Note the default settings of this dialog window in the SAP standard system. The last user-specific setting of the dialog box is the default.

- The processing step performed for the object
- The processing status of the object for each processing step
- A check box you can select to indicate that you have processed the object in the worklist monitor
- The person responsible for the object (if any)

**Message List**

The message list is located in the lower right-hand portion of the screen. The message list displays messages for certain objects. You can use these messages to analyze the causes of error for each object and processing step.

**See also:**

- Schedule Manager: Multilevel Worklist [Page 619]
- Multilevel Worklist: Process Flow [Page 632]

For detailed information on using the monitor of the Schedule Manager, see the following section:

- Processing Status of Objects and Processing Steps [Page 648]
- Processing Worklists [Page 637]
Using the Flow Definition

Use
A flow definition consists of individual flow steps. These steps include scheduling programs with variants in the job control of the SAP System, and interaction with users by email.

The flow definition ia a graphical summary of several steps. A step in the flow definition corresponds to a task in the task plan, except that the individual step does not appear directly in the task plan, rather it is displayed in the flow definition, which is included in the task plan.

Integration
The Schedule Manager provides a multilevel worklist [Page 319]. The multilevel worklist improves performance and facilitates error finding. To use the Schedule Manager worklist, create a flow definition and schedule it in the scheduler. For further information about this worklist, see Choosing Objects for Processing [Page 347].

Prerequisites
Workflow profiles enable you to adapt the user interface of the flow definition according to your requirements. If required, the project team can create and provide this type of profile. To make individual processing available as flow steps, you need a program which provides all the processing parameters and displays an ergonomic user interface.

⚠️
If you are using the workflow builder function for the first time in the SAP System, go into Customizing and choose Basis → Business Management → SAP Business Workflow → Maintain Standard Settings for the SAP Business Workflow and then Automatic Customizing.

For more information, see Creating a Flow Definition [Page 301].
For more information on error handling in flow definitions, see: Error Handling [Page 309].

Features
You can define individual flow definitions with as many flow steps as you like, or you can link flow definitions together within an "upper" flow definition. You must assign the "upper" flow definition to an application (or application component) that is on a higher level than the applications assigned to the lower-level flow definitions.
Flow Step Types

In the workflow builder, you can schedule four types of flow step:

**Program with Variants**

Enter a program and a variant.

**User Decision**

For a user decision, the system sends a message to a user. The system generates a text that creates a message header in the user’s inbox. The system stops processing the individual tasks in the flow definition until the user confirms the message. The text should therefore contain the information required to make the decision, such as which task the system just executed and which data needs checking.

**Fork**

You can define as many tasks as you wish in each of the parallel branches. All of the parallel branches join at the end, although the task that follows the join is only processed when all of the tasks in each branch are completed.

You cannot subsequently change the number of parallel branches. However, you can delete a branch by deleting all of the tasks in the branch. You **cannot** add another branch.

**Flow Definition**

The flow definition consists of several tasks that the system executes in the specified order, once you schedule the flow definition in the daily overview of the scheduler. You can create further "sub-" flow definitions within a flow definition.
Creating a Flow Definition

Use

You use a flow definition [Page 599] in the Schedule Manager [Page 565]. You can insert a flow definition in the task list of the scheduler, then schedule it into the daily overview and run it.

Procedure

1. Choose Extras → Process flow definition in the Scheduler
   Enter a description for the flow definition
2. Choose Create.

   ! Warning
   When creating without a template, the system generates a flow definition example (with flow steps) for the specified application. Do not delete the steps Check objects in worklist and Renew worklist processing, because these steps enable the recursive call of worklist processing. If the step Renew worklist processing is deleted, you cannot include it in the flow definition.

3. In the screen that follows, enter a description for your flow definition and then assign it to an application component.

   ➡ Note that all flow steps in a flow definition (which is also assigned to an application) must also be assigned to this application or to the application on the next level up or down.
Creating a Flow Definition

If you have chosen the application Controlling for the flow definition, you can only create flow steps in this flow definition if the application that you define for the steps is above or below Controlling (SAP) in the hierarchy (for example, Internal Orders, Cost Center Accounting…). In this flow definition for example, you cannot insert a report in which the application Financial Accounting is defined.

4. If required, indicate that you are working with a worklist [Page 619]. To work with a multi-level worklist, you must have chosen an application with a worklist and the function With worklist during creation.

5. Enter a development class in the dialog box Create object catalog entry, then save your entry. The workflow builder appears. Each node (step, event or operator) in the workflow builder has a menu that you can call up using the right mouse button. This immediately shows you the operations that are possible for a node, and cancels out the need for long menu structure or pushbutton paths.
6. In the navigation area, select the node Steps.

7. Choose Create step.

8. Choose the flow step type [Page 500].

9. Specify the required information for the flow step.

You can choose programs only using the input help. Programs are displayed in the input help only if you have registered them in the tables SCMAPROGRAMS (for SAP programs) or SCMAPROG_CUST (for your own programs). For more information about working with your own programs, see Inserting Own Programs as Tasks [Page 501].

10. Choose Cancel to return to the Workflow Builder.

11. You see the task in the structure tree of the task area. The task is integrated in the graphic of the flow definition. Move the task to the desired position in the flow definition.

12. Save your entries.

For more information on the Workflow Builder, see the SAP Library under BC-Basis Components → Business Management (BC-BMT) → SAP Business Workflow Navigation (BC-BMT-WFM) → Workflow Builder [Ext.].
Creating a Flow Definition

If you are using the workflow builder function for the first time in the SAP System, go to the Implementation Guide (IMG) and choose Basis → Business Management → SAP Business Workflow → Maintain Standard Settings for the SAP Business Workflow and then Automatic Customizing.

You can also use the SAP standard flow definitions. Variant names for these flow definitions begin with SAP&. These variants only contain selection variables named SAP-SCMA. Use the STVARV transaction or Schedule Manager, Extras → Settings → Selection variables to adapt the variable values according to your requirements. For further information on selection variables, see Defining Global Variables for Task Lists/Flow Definitions [Page 567] and Defining Selection Variables for Flow Definitions With Parallel Branches.
Specifying Selection Variables for Flow Definitions With Parallel Branches

Use

Normally the selection criteria for period-end closing do not change very often. Criteria that do change regularly are the closing period and the fiscal year. The period and fiscal year must be changed for each program or flow definition specified as a task in the task list.

To avoid having to change these values for every single program or every flow definition, you can define selection variables in the program variants.

You have five programs that must run with the same valuation for nine plants. That means that every program must run with a plant-specific variant for each plant. These variants differ only in their Plant specification.

As described below, you define global variables for fiscal year, period and plant. Create variants for the five programs and define the global variants that you created previously. Finally define a flow definition (A) for the five programs. Define a flow definition (B) with nine parallel branches (for the plants). Include the flow definition A in each of these branches. A dialog box appears that displays the three global variables (fiscal year, period, plant). Enter a value for the variable Plant and flag the entry as to be saved. The dialog box reappears when you plan flow definition B in the day view. Enter values for each fiscal year and period. Do not make an entry for the variable Plant. If you make an entry here, the system does not accept it. You defined the plant when creating the flow definition.

Prerequisites

You have defined the variables already. For more information, see Defining Selection Variables [Page 568].

You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

7. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.

8. Enter a new variant for this processing step and define a name for this new variant in the Variant field.

9. Choose Change variant.
   The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

Procedure

14. Choose Attributes.

15. Make an entry in the Description field.

16. Now you want to specify variables for the period and fiscal year that you can then change once centrally for all programs and flow definitions that use those variables. To do this, under the heading Selection screen objects, select the column S in the lines Period and Fiscal year.
Specifying Selection Variables for Flow Definitions With Parallel Branches

17. Choose Selection variables.

18. To choose selection criteria for the variables P_FROM (period) and P_GJAHR (fiscal year),
   use the input help.

   You previously entered these variables in table TVARV.

11. Save your entries.
   The Maintain Variant: Program <program name>, Variant <variant name> screen appears.

**Result**

The system uses these entries for the following purposes:

- To feed these variables to a program created directly as a task in the workflow.
- To feed these variables to the parallel branches.

   The system mixes the variables of the parallel branches with those of the main workflow.
   If the parameter values of the main workflow are different from those of the subworkflows, the system uses the parameter values that were specified when the subworkflows were created.
Choosing Objects for Processing

Use
An advantage of this worklist [Ext.] is that the objects for processing only have to be selected once per flow definition.

Prerequisites
You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

Procedure
1. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.
2. Enter a new variant for this processing step and define a name for this new variant in the Variant field.
3. Choose Create variant.
   The Variant Maintenance screen appears. Program <program name>, variant <variant name>.
   Here you can determine the scope of selection of the program variants for the flow definition.
4. To be able to choose more extensive selection criteria, first complete the required entry fields, for example Period <006>, Fiscal year <2000>.
5. You can now define further selection parameters using the various pushbuttons that are offered in dialog boxes.
6. Choose Attributes.
   The ABAP: Save Attributes of Variant <Variant name> screen appears.
Defining Processing Options, Output Options and Execution Types

You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

16. Choose a processing step in the navigation area.
   On the right of the screen, you see Flow definition: Task details.

17. Choose Change variant.
   The screen Variant Maintenance appears. Program <program name>, variant <variant name>.

18. In the corresponding group frames, select the desired processing option, output option and execution type. For example, you can define whether parallel processing is allowed.

19. Perform variant maintenance for all programs that are linked to the flow definition.

For further information see Defining Selection Variables in the Program Variants [Page 569] and Selection Variables for Flow Definitions with Parallel Branches [Page 605].
Error Handling

Job error handling involves the following:
1. For checking purposes:
   • Periodically reading the job status
   • Checking the maximum runtime
2. When errors occur:
   • User decision "Continue the flow with the next task"
   • User decision "Reschedule the job"

⚠️

The user decision "Reschedule job" is **not** available for worklists.
Error: A Job Stops

Cause
The job stops, if for example, the system is turned off.

Error Handling
The dialog for an error in the job administration is handled in its own sub-workflow, which consists of a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Page 601]). That person receives the mail that an error has occurred in job XY in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

You can use this option without any problems, for jobs that have worklists. However, you need the worklist ID to be able to execute the job outside of the workflow.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Ext.] to control the rescheduling of the job.
Graphical Representation of the Flow

Workflow started

An error occurred in job &1

Reschedule job

Schedule Manager: Schedule job

Set the FINISHED event

Event sent

Workflow finished

Schedule Manager: Schedule job

Continue flow
Error: A Job Becomes "Stuck"

Symptom
The program has a runtime that is far longer than expected.

Error Handling
The dialog for a processing error in the program is handled in its own sub-workflow, which consists of a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Page 601]). That person receives the mail that an error has occurred in program X, variant Y in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:
- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

You can use this option for jobs that have worklists. However, you need the worklist ID to be able to execute the job outside of the workflow.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Ext.] to control the rescheduling of the job.

Graphical Representation of the Flow
Workflow started

Program &1, variant &2 contains errors

Reschedule job

Schedule Manager: Schedule job

Continue flow

Workflow finished
Error: An Executed Report Found an Error

Symptom
Due to an error in the content, the REPORTERROR workflow event was triggered.

Error Handling
The workflow executes an error dialog. This contains a user decision. The user decision is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, send to section (See also: Creating a Flow Definition [Page 601]). That person receives the mail that an error has occurred in program X, variant Y in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:
- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Ext.] to control the rescheduling of the job.

⚠️
No user decision is called up for jobs that have worklists. This is because the error handling for worklists is triggered by rerunning the task steps in the workflow. Therefore, programs written for worklists always trigger the FINISHED event.

Graphical Representation of the Flow
Error: An Executed Report Found an Error

Workflow started

Job started

Schedule Manager: Start job

Fork

Schedule Manager: Job error handling

Wait for REPORTERROR event

Wait for FINISHED event

Schedule Manager: Dialog for program errors

1 from 3

Workflow finished
Error: Job Scheduling Was Unsuccessful

Cause
Scheduling a job can be unsuccessful if the technical name of the report or variant was changed after the flow definition was created. This means that the technical names in the flow definition no longer exist.

Error Handling
The workflow recognizes the error and issues an error message displaying the faulty technical name of the report or variant.

The message is linked to a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Page 601]). That person receives the message in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Ext.] to control the rescheduling of the job.
Error: The Workflow Stops

Cause
The workflow stops due to an error in the workflow runtime system.

Symptom
The job just scheduled is completed since the job control functions separately from the workflow. However, the following steps in the flow definition are no longer executed.

Error Handling
It is not possible to restart at the point where the workflow stopped. Therefore, you need to reschedule the whole flow definition.
Error: The Workflow Becomes "Stuck"

Cause
During job scheduling using the workflow, if an error occurs in the program section of the report and the report is being run at the AT SELECTION-SCREEN OUTPUT event, then the job is not scheduled.

Error Handling
The system issues an error message to notify you that scheduling is not complete.

The message is linked to a user decision. This message is sent as a top priority mail to the person whose name is entered in the detail screen for maintenance of jobs in the flow definition, in the When error, mail to section (see also: Creating a Flow Definition [Page 601]). That person receives the message in their mail inbox.

There are two options in the user decision.

Continue the flow with the next task
You choose this option if:

- You corrected the error and rescheduled the job manually in a separate session, and are waiting for the job to be executed.
- You executed the transaction online.
- You decided that the error is not relevant.

Reschedule the job
You choose this option if you corrected the error and would like to use the Schedule Manager [Ext.] to control the rescheduling of the job.
Multilevel Worklist

Use

The worklist of the Schedule Manager is a multilevel worklist. This worklist is particularly useful for the period-end closing activities.

Why Is the Worklist Multilevel?

In previous releases, the period-end closing process in the R/3 system consisted of a series of batch jobs. The sequence of the processing steps was established by the order in which the jobs were called. The objects were selected separately for each job. Through the selection criteria entered, it was possible to specify a unified scope of selection. This scope of selection had to be respecified for each processing step (that is, for each individual function of period-end closing).

When an object was processed, errors that occurred in previous processing steps were not taken into account. For this reason, it was necessary to check the objects that had errors once a job was completed. Any errors had to be corrected and then the job restarted for the entire scope of selection. In some areas (such as the period-end close in Product Cost by Period), it was already possible to create a single-level worklist for individual processing steps. With this single-level worklist, the objects with errors could be called up for each processing step, and the causes of the errors determined. The processing step could then be performed again for the object after the error was corrected. This worklist did not prevent objects with errors from being processed in the subsequent processing step (that is, in the subsequent job).

Advantages of the Multilevel Worklist

The worklist of the Schedule Manager is a multilevel worklist. This means that the worklist is generated for a sequence of processing steps rather than for just one processing step. The worklist therefore enables efficient execution of processing step sequences. Processes such as period-end closing can be performed much more efficiently with a multilevel worklist.

The multilevel worklist has the following advantages:

- The processing step sequences (such as in period-end closing) can be performed faster than before.

  Manual processing after completion of each job is no longer necessary. Manual processing is only necessary after executing a sequence of processing steps that consists of multiple jobs (for example, complete closing of an application component).

  Furthermore, if errors were issued for objects in the single-level worklist, it was often necessary to repeat the processing steps for the entire scope of selection (and not just for the objects with errors). With the multilevel worklist, the processing steps are repeated only for the objects that have errors.

- CPU time is reduced because objects are selected only once for each processing step sequence, instead of for each individual processing step. Objects are selected before the first processing step is executed. The multilevel worklist provides performance benefits particularly with complex structures in which dependencies between objects must be taken into account (such as complex project structures).

As a rule, jobs are planned and monitored by members of the EDP team. In many cases, these employees are not responsible for the correcting the errors shown in the error logs. With the multilevel worklist, you can directly inform the employees responsible for correcting the errors.
Multilevel Worklist

This notification takes place by means of a mail message that is sent automatically through the workflow [Ext.].

Integration

The multilevel worklist is part of the Schedule Manager and is always used with the other functions of the Schedule Manager (see Prerequisites).

The following applications, functions, and objects are currently supported by the multilevel worklist:

Cost Object Controlling: Manufacturing Orders and Product Cost Collectors

<table>
<thead>
<tr>
<th>Process Flow</th>
<th>Period-end closing for manufacturing orders and product cost collectors [Ext.]</th>
</tr>
</thead>
</table>
| Scope of Selection for Processing Objects | Closing encompasses production orders, CO production orders (production orders without a quantity structure), process orders; product cost collectors and QM orders. With co-products, some of the period-end closing work is performed at the level of the items of the manufacturing orders.
A prerequisite is that the following requirements are met for these objects:
- The objects are not assigned to a cost object hierarchy, or it is specified in the cost object category that the individual orders of a material are processed outside the cost object hierarchy (see Product Cost by Period).
- Account assignment can be made directly on the objects. This means that with regard to the selection of manufacturing orders, account assignment is made on the manufacturing orders themselves and not on a product cost collector.
- The objects do not have status DLFL (deletion flag).
Product cost collectors are objects of the Product Cost by Period subcomponent.
Manufacturing orders (including manufacturing orders without a quantity structure) are objects of the Product Cost by Order subcomponent. |
<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template allocation</td>
<td>Order header (including product cost collectors)</td>
</tr>
<tr>
<td>Revaluation at actual prices [Ext.]</td>
<td>Order header (including product cost collectors)</td>
</tr>
<tr>
<td>Actual overhead [Ext.]</td>
<td>Order header (including product cost collectors)</td>
</tr>
</tbody>
</table>
### Preliminary Settlement for Co-Products, Rework

- Preliminary settlement for co-products: Order header of manufacturing orders as processing objects; order items as receivers.
- Preliminary settlement of rework:
  - Order header of manufacturing orders as processing objects, order header of manufacturing orders or product cost collectors as receivers; but not: Settlement of rework on product cost collectors or manufacturing orders assigned to a cost object hierarchy (see below).
- Preliminary settlement of collective orders (old processing method without automatic goods movement):
  - Header of manufacturing orders as processing objects, header of manufacturing orders as receivers.

### WIP calculation [Ext.]

Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors.

### Variance calculation

Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors.

### Settlement [Ext.]

Production and process orders or, in joint production, their items, as well as CO production orders and product cost collectors.
Multilevel Worklist

**Cost Object Controlling: Cost Object ID (Cost Object Nodes in a Cost Object Hierarchy and General Cost Objects)**

<table>
<thead>
<tr>
<th>Process Flow</th>
<th>Period-end closing for cost object ID</th>
</tr>
</thead>
</table>

April 2001
### Scope of Selection for Processing Objects

Period-end closing includes:

- Cost object nodes of cost object hierarchies and the single objects assigned to the cost object hierarchy. These can be the following: Product cost collectors, manufacturing orders, production orders without quantity structure, and (if applicable) order items of manufacturing orders (with joint production) for which the following conditions apply:
  - Account assignment can be made directly on the objects. This means that account assignment for manufacturing orders is made on the manufacturing order itself and not on a product cost collector.
  - The objects do **not** have the status DLFL (deletion flag).

Cost object hierarchies are part of the *Product Cost by Period* component.

- General cost objects

  General cost objects are objects of the *Costs for Intangible Goods and Services* component.

### Processing Step Objects

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template allocation</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to the cost object hierarchy (product cost collectors, manufacturing orders or production orders without quantity structure); <strong>general cost objects</strong></td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to the cost object hierarchy; <strong>general cost objects</strong></td>
</tr>
<tr>
<td>Actual cost distribution</td>
<td>Cost object nodes of <strong>cost object hierarchies</strong>; the single objects assigned to the lowest cost object nodes are the final receivers</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Depending on the Customizing settings, cost object nodes of <strong>cost object hierarchies</strong> or the single objects assigned to a cost object hierarchy; <strong>general cost objects</strong></td>
</tr>
</tbody>
</table>
| Preliminary Settlement for Co-Products, Rework | Only for orders assigned to the **cost object hierarchy**:  
- Preliminary settlement for co-products: Order header of manufacturing orders as processing objects, order items as receivers  
- Preliminary settlement of rework: Order header of manufacturing orders as processing objects, order header of manufacturing orders or product cost collectors that are assigned to the cost object hierarchy as receivers |
<p>| WIP calculation | The single objects assigned to a <strong>cost object hierarchy</strong>; but not: Order items in joint production (manufacture of co-products), CO production orders |</p>
<table>
<thead>
<tr>
<th>Multilevel Worklist</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Variance calculation</strong></td>
</tr>
<tr>
<td><strong>Settlement</strong></td>
</tr>
</tbody>
</table>
## Project System

<table>
<thead>
<tr>
<th>Process Flow</th>
<th>Period-end closing for Project System</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Scope of Selection for Processing Objects</strong></td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td><strong>Processing Step</strong></td>
<td><strong>Objects</strong></td>
</tr>
<tr>
<td>Generation of settlement rule</td>
<td>WBS elements</td>
</tr>
<tr>
<td>Template allocation</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Cost forecast</td>
<td>Networks</td>
</tr>
<tr>
<td>Interest calculation</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Project earned value</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Results analysis</td>
<td>WBS elements and orders</td>
</tr>
<tr>
<td>Incoming orders</td>
<td>WBS elements</td>
</tr>
<tr>
<td>Settlement</td>
<td>WBS elements, networks, and orders</td>
</tr>
<tr>
<td>Reporting</td>
<td>WBS elements, networks, and orders</td>
</tr>
</tbody>
</table>
Multilevel Worklist

Internal Orders

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Scope of Selection for Processing Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period-end closing for internal orders</td>
<td>Internal orders, maintenance orders</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template allocation</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Interest calculation</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Results analysis</td>
<td>Internal orders, maintenance orders</td>
</tr>
<tr>
<td>Settlement</td>
<td>Internal orders, maintenance orders</td>
</tr>
</tbody>
</table>

Sales Orders

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Scope of Selection for Processing Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period-end closing for sales orders</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Processing Step</th>
<th>Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template allocation</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Revaluation at actual prices</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Actual overhead</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Results analysis</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
<tr>
<td>Settlement</td>
<td>Sales order items that carry costs and revenues</td>
</tr>
</tbody>
</table>

Prerequisites

You are working with the Schedule Manager and are using all of its functions.

A prerequisite for the use of the multilevel worklist is that a constant quantity of objects (or, in subsequent executions, their subset) is processed in a predefined sequence of processing steps.

The selection set of the objects is determined through the application you select (for example, Cost Object Controlling: Manufacturing orders and product cost collectors) (see above), as well as through any additional entries that you may make when creating report variants (see below).

The sequence of processing steps is specified in the flow definition.

This means that you proceed as follows:

2. From the scheduler, create a flow definition [Page 599]. In the flow definition, specify the processing step sequence (for example, a sequence of all single functions of period-end closing for product cost collectors). The creation of the flow definition is realized through the Workflow Builder.

   You access the flow definition with the menu options Extras → Process the flow definition. When you create the flow definition, you should:
Multilevel Worklist

Specify which application the flow definition is intended for (such as Cost Object Controlling: Manufacturing Orders and Product Cost Collectors)

Make sure you create a flow definition with a worklist

The Workflow Builder appears. Depending on the application you selected, you receive a SAP template that you can modify to meet your requirements.

3. Create a task for each processing step in the flow definition. Such tasks can be, for example, reports for the single functions of period-end closing or user decisions.

To facilitate maintenance of the flow definition, the system offers you a default template. This consists of a task placeholder at the beginning of the flow as well as a task placeholder in the feedback loop. You define the placeholder at the beginning of the flow before the feedback loop as a report task for selecting the worklist. You define the single functions of period-end closing as tasks in the feedback loop.

To define the selection or a single function (such as overhead calculation) as a task, select the Program indicator when you create the task. Then, select the report from a proposal list that you want to include in the processing sequence (such as Overhead: Worklist of Manufacturing Orders)

Then create a report variant for the execution of the report. Maintain the parameters for the variant. Here you can specify various parameters such as whether a detail list is output and whether processing takes place simultaneously on multiple servers.

You can further filter the scope of selection of the object to be processed by using a selection profile.

In addition, enter the period and fiscal year.

You can use the same flow definition each time if you enter selection variables instead of fixed values for the period and fiscal year when you maintain the report variants. In this case, the system calculates the period and fiscal year of the single functions dynamically from the current values for these variables when it executes the flow definition. This is only possible if you use selection variables (called TVARV variables) for the period and fiscal year parameters. When you create the report variant, you specify that you are working with selection variables. You maintain the selection variables by entering the transaction STVARV, or by starting the transaction through Extras → Settings → Selection Variables in the menu of the Schedule Manager and changing the variables there to the period and fiscal year to be processed. This enables you to use the same job variant every month. You only need to update the TVARV variable before executing the job variant.

You specify a user decision if you want the previous processing results to be checked after one or more processing steps. After executing the previous processing steps, the system automatically sends a mail message to the person responsible for checking the results (usually the cost accountant). When you create the flow definition, you specify which user receives this mail.

When you use the multilevel worklist, the system always specifies a user decision and a feedback loop for the reentry into postprocessing as the last step of the flow definition.

You can also insert user interactions at other points in the process definition if you want to check the objects processed up to a particular step before continuing with processing.
Multilevel Worklist

If you approve (release) the check of the objects with errors, you make it possible for the objects with errors to automatically be reprocessed later.

4. Enter the flow definition as a task in the task list of the Scheduler.

5. Start the task (the flow definition) in the Scheduler.

6. You monitor the flows and jobs during and after processing in the monitor [Page 592] of the Schedule Manager.

Features

Basic Functions of the Multilevel Worklist

The multilevel worklist is generated for an entire sequence of processing steps.

The scope of selection is determined once and is valid for all processing steps. The worklist encompasses the objects of the scope of selection for which processing in the present processing step sequence is both possible and necessary. The scope of selection, therefore, equals the maximum scope of the worklist. Certain restrictions can be specified for individual processing steps in the scope of selection. These restrictions are usually determined through selection profiles that are specified when report variants are created.

The processing steps are performed in an order strictly defined in the flow control of the scheduler. A processing status is maintained for each object and processing step. The processing status indicates whether further processing of the object is allowed.

Each processing step only contains the objects for which (based on the processing status of the previous processing step) processing in this step is allowed.

In each processing step, dependencies between objects are interpreted according to the application. For this reason, it can be necessary to include other objects when processing an object in a step. The system accounts for such object dependencies automatically. You do not have to make any additional settings.

You want to perform results analysis for a WBS element (nonvaluated project stock). Production orders whose actual costs should be included in results analysis are assigned to the WBS element.

There are individual worklists for each processing step sequence (that is, each flow definition). Typical processing step sequences are the period-end closing sequences for the individual application components. Individual worklists are created for each application (for example, for internal orders and projects).

The multilevel worklist fulfills the following basic requirements:

- The selected objects are processed as far as possible.
- The selected objects are only processed when processing is both necessary and possible.
- Object dependencies are taken into account.

Object dependencies can be encountered, for example:

- In engineer-to-order environments
- When you are using cost object hierarchies
Suppose you are performing results analysis for WBS elements in an engineer-to-order environment. The system first determines which WBS elements are relevant on the basis of the selection criteria. These WBS elements are called primary objects because they are the original objects to be processed.

Results analysis also includes values that are posted to the production orders assigned to the WBS elements. These production orders are selected on the basis of their dependency on the WBS element. They are called secondary objects.

The determination of secondary objects depends not only on the type of worklist (for example, cost object hierarchies, projects), but also on the present business function and on the processed objects.

Suppose you are performing period-end closing for a cost object hierarchy.

You calculate the actual overhead at the level of the cost object nodes. In this case, there are no dependent objects because every cost object node is included in overhead calculation. Relationships to other cost object nodes do not play a role.

You also want to distribute the actual costs assigned to the cost object nodes to the lowest cost object nodes of the assigned product cost collector. The following situation arises during distribution:

As soon as a cost object node in a cost object hierarchy is a primary object, all other nodes are secondary objects (as long as they are not also primary objects).

During the execution of the flow definition, the individual processing steps receive a list of the objects to be processed. Each processing step sends the processing status of each object and a list of the displayed messages back to the worklist.

The scope of selection can contain all objects to be processed in a particular flow. However, in some situations you may want to perform the same flow more than once in parallel with different scopes of selection. This manual parallel processing can serve to reduce the overall run time.

Suppose you want to perform period-end closing for the application component Product Cost by Order in Cost Object Controlling. You can process all production orders and process orders in a plant, or all plants in a controlling area.

You create multiple scopes of selection in which you select by plant and order type. This means that, for example, one scope of selection includes all production orders in a plant, while another scope of selection includes all process orders in that same plant.

The previous processing step in the sequence must be fully completed before the next step can be started.

After the entire processing step sequence has been executed, the user forces a manual check.
Multilevel Worklist

The user-defined flow of individual processing steps (specified in the flow definition), the check of the objects with errors, as well as the release of this check (for renewed processing of objects) should be repeated until all objects in all processing steps have the status OK. Once this is achieved, processing is completed.

Processing of Objects in the Worklist

You process the worklist in the monitor. The monitor shows a list of the faulty objects and the messages issued for the objects. This information is needed for analyzing and correcting the errors.

In the monitor, you can specify how objects are to be processed the next time the processing step sequence is executed. For example, you can specify the following:

- That objects marked as faulty in a given processing step are excluded the next time that processing step is executed, and instead enter the subsequent processing step.
- That objects processed without errors are nevertheless reprocessed if they are faulty in a business sense (for example, as a result of incorrect Customizing settings).

If an object was processed without error in an update run for project interest calculation, new interest calculation can only be triggered if the previous interest calculation is first reversed. If no reversal is carried out, the object is not included in the recalculation of interest even though its processing status would normally allow this.

You control this through the processing status for the object and processing step.

Note the following:

If an object has been changed since it was processed in the processing step sequence defined by the flow definition (for example, additional costs have been assigned to the object), this change is not taken into account if the object has already been processed without error. In this case, you should change the processing status for the first processing step of the processing step sequence to force reprocessing.

See also:

See the following sections for additional information on the monitor and how to use it:

Schedule Manager: Monitor - Working with the Object List [Page 534]
Processing Worklists [Page 537]
Processing Status [Page 548]

Triggering Reprocessing of Objects

Automatic Reprocessing

Once all objects have been processed and you have corrected the errors or specified that the processing step for which errors were issued should be skipped, the processing step sequence can be repeated in order to reprocess the objects that had been faulty in the previous run. You initiate reprocessing from the mail.
The system then processes the objects in the selection scope that had been processed with errors in the first run of the processing sequence and those that you instructed the system to reprocess (processing forced manually). For each object, processing starts with the processing step that had errors or for which processing was forced manually. The only processing steps repeated for an object are those for which errors occurred in the previous run, those that have not yet been performed, and those for which reprocessing was forced.

Both in the first run and in the repeated run, the only objects that are processed in each processing step are those that were successfully processed in the previous step and that have not yet been successfully processed in the current step. This limits the number of objects to be reprocessed in each step to those for which errors appeared in that step or in the preceding steps of the first run. Dependencies between objects are also taken into account. That is, depending on the object to be processed and the processing step, it may be necessary to reprocess additional objects even though they were already processed successfully.

**Administrative Data Reorganization of the Multilevel Worklist**

The administrative data of multilevel worklists encompasses the scope of selection, the step information (flow step), the processing status for the object, and the error messages for the object. This administrative data is deleted together with the workflow data of the Schedule Manager. It is not possible to archive the worklists.

**Activities**

Once all processing steps have been executed, the system informs you by mail that the results of the processing steps are ready for review. After you have checked the results and corrected any errors, the system asks you whether you would like to repeat reprocessing.

To make the relevant checks, access the monitor of the Schedule Manager.

You can access the monitor in the following ways:

- From the mail
- Directly from the menu of the application component

**See also:**

[Multilevel Worklist: Process Flow](Page 632)
Multilevel Worklist: Process Flow

Prerequisites

You have created a flow definition [Page 599]. In the flow definition, you define the sequence of processing steps that you want to perform. A processing step corresponds to a single function. Examples of individual processing steps are WIP calculation, variance calculation, and settlement. A processing step sequence is defined by linking these single functions to each other in a flow definition.

You have established the flow definition in the scheduler [Page 574].

Process Flow

1. The system starts the sequence of processing steps in accordance with the planning specified in the scheduler. The objects to be processed are selected on the basis of the following logic:
   - Objects that were processed successfully in the previous flow step but have not yet been processed successfully in the current flow step are transferred from the selection to be processed. These objects are called primary objects.
   - The system also reads the dependent objects for the current flow step for all selected objects. These dependent objects are called secondary objects. If a primary object has one or more secondary objects that were not successfully processed in the previous flow step, neither the primary object nor its associated secondary objects can be processed in the current flow step.

2. The system executes the processing steps.

3. When the system has executed all processing steps, you receive a mail to inform you that the planned sequence of processing steps has been completed. This mail is generated using the workflow link.

4. You can reprocess the faulty objects directly from the mail.

5. The user can view the processed objects with their processing status in the monitor of the Schedule Manager.

6. The user processes the objects with errors.

7. The user retriggers the processing step sequence from the mail in his office inbox.

8. The system now processes the objects in the selection that were processed with errors in the first run of the processing sequence, or whose processing was forced manually.

   For each object, processing starts with the step that was not processed correctly.

   The subsequent processing steps are then started automatically in the defined sequence.

   If an object that was processed without errors in the first run of the processing step sequence is changed before the second run of the processing step sequence, these changes do not result in an automatic reprocessing of the object. If you want the object to be reprocessed, manually set the corresponding processing status.
The production order 1000000 is included with all other production orders of plant 1000 in period-end closing of *Product Cost by Order*. Work in process for the order is calculated as EUR 1,000 and settled to *Financial Accounting* (FI). All processing steps (for example, *WIP calculation* and *settlement*) of the processing step sequence were also performed without out errors.

However, not all production orders were processed without errors. In this way, for example, the production order 1000005 receives the processing status *error* for the processing step *WIP calculation* and the production order 1000010 receives the processing status *error* for the processing step *Settlement*.

After work in process has been settled for all production orders, including production order 1000000, additional costs amounting to EUR 200 are posted to production order 1000000.

Remove the errors for the production orders 1000005 and 1000010 and reinitiate the processing step sequence. The production orders 1000005 and 1000010 are reprocessed. Production order 1000000 is not processed as it was processed without errors in the first run.

If you want to force a reprocessing of production order 1000000, you can manually set the corresponding processing status.

See also:

- Schedule Manager: Worklist [Page 519]
- Schedule Manager: Monitor - Working with the Object List [Page 634]
- Processing Status of Objects and Processing Steps [Page 648]
- Processing Worklists [Page 537]
Monitor - Working with the Object List

Definition
The monitor of the Schedule Manager is a tool for processing multilevel worklists. It contains information on active or completed jobs that were planned in the scheduler.

Use
This section provides information on using the object list in the monitor of the Schedule Manager. For more information on jobs in the monitor, see Using the Monitor [Page 592].

The monitor performs the following functions:
- Displays the available worklists and their processing steps
- Keeps track of the processing status of each object (such as product cost collectors, WBS elements, internal orders, and production orders) and each processing step
- Assists you in analyzing the causes of errors for the objects and processing steps
- Displays the processing status of objects (particularly for the objects with errors)
- Shows the hierarchical relationships between the objects
- Compares object hierarchies with each other
- Controls whether objects enter the next processing step
- Sends objects to the responsible person for further processing

You can set the processing status so that objects of negligible value, for example, are not reprocessed in a processing step even if errors are issued for the objects in that step. In this case, it is not necessary to remove the cause of the error.
The monitor is divided into the following screen areas:

**Structure Tree with Worklists/Processing Steps/Jobs**

The structure tree containing the worklists, processing steps and jobs is displayed on the left side of the monitor.

In the system, the worklists are updated separately for each scope of selection and processing step sequence. The processing step sequence is specified in the flow definition. You can view the worklists of the application component in which you are working, including their functions and objects.

The system displays the following information on each worklist:

- Number of objects in the worklist
- Processing steps
- Number of objects processed in each processing step
- Number of objects with errors in each processing step

**Object List**

The object list is located in the top right area of the screen. The object list can display one or more processing steps of a worklist. You select the processing steps in a worklist in the structure tree `worklists/processing steps/jobs`.

The object list includes the following information:
Monitor - Working with the Object List

- The objects for the selected processing steps. You can control which objects are displayed for each processing step by means of a filter that takes the individual processing statuses into account. In application toolbar icons for object list, choose the icon Objects: Set status filter.
  The system uses the last user-specific default setting of the dialog box. Note the default settings of this dialog window in the SAP standard system. The last user-specific setting of the dialog box is the default.
- The processing step performed for the object
- The processing status of the object for each processing step
- A check box you can select to indicate that you have processed the object in the worklist monitor
- The person responsible for the object (if any)

Message List
The message list is located in the lower right-hand portion of the screen. The message list displays messages for certain objects. You can use these messages to analyze the causes of error for each object and processing step.

See also:
Schedule Manager: Multilevel Worklist [Page 619]
Multilevel Worklist: Process Flow [Page 532]

For detailed information on using the monitor of the Schedule Manager, see the following section:
Processing Status of Objects and Processing Steps [Page 648]
Processing Worklists [Page 537]
Processing Worklists

Use
You process worklists in the monitor of the Schedule Manager.

Navigating to the Monitor

Procedure
1. You can access the monitor in the following ways:
   a. In the Schedule Manager, there are three ways of accessing the monitor from the screen Schedule Tasks for Task List: By selecting a calendar day, selecting the desired tasks in the daily overview, and then choosing Monitor daily overview in the application toolbar; by choosing the Monitor icon above the daily overview; or by double-clicking on a task in the daily overview.
   b. From the menu of the application component. For example, to access the worklists of the Product Cost by Period component, go to the menu of Product Cost by Period and choose Period-End Closing → Schedule Manager → Worklist Monitor. Choose the following: Product Cost Collector or Cost Object Hierarchy. The screen Select Worklist appears.
      In the selection screen, use the possible entries function for the Application field to select the application component for which you want to call up the worklist (such as Cost Object Controlling: Manufacturing Orders and Product Cost Collectors). Usually the appropriate application will already be shown as a default. Enter the additional selection criteria such as the period and fiscal year, and choose Enter. You can further restrict the selection with the icon Further selection criteria.

Result
The screen Schedule Manager: Monitor appears.

Working with the Monitor of the Schedule Manager

Using the Monitor
The monitor enables you to analyze the objects processed in a worklist and control how the objects are processed further. The focus is on the objects for which errors were issued.

Objects for which errors were issued in a processing step do not enter the next processing step.

You can analyze and correct the error, or you can instruct the system to skip processing (that is, not to process the objects in the corresponding step). Skipping processing can be appropriate for objects that have errors but whose value is negligible.

You instruct the system to skip processing by setting the processing status to skip processing. The system then processes the object in the next processing step as if it had been processed without errors in the previous step.

If the object is part of a hierarchy, this can also prevent the object from stopping the entire hierarchy from being processed.

The functions hierarchy display and hierarchy comparison provide support when you search for errors.
When actual overhead rates were calculated in the period-end closing process, one production order was not processed due to faulty Customizing settings. The production order is assigned to a WBS element. When the cost accountant reviewed the objects in the monitor, he decided that the missing overhead is insignificant and can be disregarded, since the effort involved in finding and correcting the error would be out of proportion to the amount in question. The faulty production order should therefore be included in results analysis for the WBS element. To prevent the entire project to which the production order is assigned from being excluded from processing, the accountant sets the processing status of the production order for the step overhead to *Skip processing*.

On the other hand, it may sometimes be necessary to process an object again even though it has been processed without error. You do this by setting the status *Repeat processing*. This can be appropriate in cases where incorrect Customizing settings have resulted in improper values. The processing steps only recognize errors that are indicated as errors in the monitor. However, an object can be faulty in a business sense without necessarily generating an error message. Such errors can only be found by checking the results by hand.

In the flow definition, you can specify that a manual check (usually by the cost accountant) should take place after certain processing steps.

To force renewed processing of the object after correcting the error (in our example, this would involve selecting another results analysis method in Customizing), you change the processing status to *Repeat processing*.

Suppose you want to calculate results analysis data for a WBS element. In Customizing, you selected a results analysis method that causes unrealized profits to flow into inventory valuation. However, you don't want unrealized profits to be inventoried.

It may also be necessary to force an object to be processed due to the fact that postings which debited an object after period-end closing made the period-end closing data obsolete.

Suppose you have performed period-end closing for a production order. All processing steps of the production order were performed without error. The production order is then debited with additional costs that must be accounted for in period-end closing. You must therefore force the system to repeat the processing steps for the production order. In this case, you only need to force a repeat of the first processing step of the sequence. The production order is automatically included in all subsequent processing steps.

The monitor of the Schedule Manager is divided into three screen areas:

- Structure tree with worklists/processing steps/jobs
- Object list
- Message list (you have the choice between object messages, step messages, and messages of the originating objects)
Structure of the Monitor

Different functions are available in each screen area. These functions are described in the Procedure section below.

**Procedure**

**Displaying Objects for One or More Processing Steps**

You want to view the processed objects for one or more processing steps.

In the object list, you can choose to view all processed objects or only the objects with errors, for example, for one or more processing steps. Since the worklist’s primary function is to assist you in analyzing the objects with errors, you should limit yourself to viewing only the objects that have errors. If you choose to view all processed objects, this will reduce system performance.

With the default settings of the standard system, objects with the following processing statuses are displayed:

- Flagged for postprocessing
- Processing forced manually
- Error
- Followup error
Processing Worklists

- Hierarchy error
- Minor error

For detailed information on the processing statuses updated for the objects, see the following section: Processing Status for Objects [Page 348].

To view the objects, proceed as follows in the structure tree worklists/processing steps/jobs:

Double-click on a processing step in the structure tree worklists/processing steps/jobs to generate the object list for that processing step. If there are any messages that refer to the processing step as a whole (rather than to specific objects), they are displayed in the message list.

Double-click on a worklist in the structure tree worklists/processing steps/jobs to generate the object list for all processing steps. If there are any messages for the worklist, they are shown in the message list.

You can also select the processing steps with the context menu. Proceed as follows:

a) To display all processing steps for the objects in a worklist:
Select a worklist with the right mouse button and choose Object list - All steps in the context menu. The object list for the worklist is generated.

The object list can display up to ten processing steps. If there are more than ten steps, the dialog box Select Processing Steps appears, in which you can select a maximum of ten steps.

a) To display individual processing steps for the objects in a worklist:
If you don't want to see all processing steps for a worklist, select a worklist with the right mouse button and choose Object list - Select steps in the context menu. The dialog box Select Processing Steps appears, in which you can select a maximum of ten steps.

When you process worklists for manufacturing orders, the object list has a column for the material number. The material shown in this column is usually the material that is manufactured with the order shown in that row.

In joint production, the column shows the following:
- For the order header (i.e., for the object "ORD order"):
  - If a process material is being used, the process material is shown.
  - Otherwise the leading co-product is shown. The leading co-product is the co-product shown in the first order item.
- For the order item (i.e., for the object "OIT order item"), the material produced with that order item is shown.

Displaying the Processing Status for Each Object and Processing Step
The object list shows the processing status for each object and processing step. A column is displayed in the object list for each processing step selected in the structure tree.
worklists/processing steps/jobs. This column shows the processing status of each object. The processing statuses are represented as icons. If you want to know which processing status is assigned to which icon, then click on the corresponding Legend icon above the object list. The screen Processing Status: Icon Legend appears. The icon in the dialog box provides explanations of the processing statuses.

For detailed information on processing statuses, including examples, see the following section: Processing Status for Objects [Page 648]

Filtering Objects

You can also display objects of other processing statuses through a status filter. To do so, click on the filter icon (Objects: Set status filter) above the object list. Select the relevant processing status and press Enter. All objects that have the corresponding processing status are displayed in the object list.

You can also filter objects according to criteria other than the processing status (function of the ABAP List Viewer).

Deciding Whether to Process Objects Further

You now have a list of objects. These are normally the objects with errors. You must decide whether to continue processing these objects. You have the following options:

- You correct the errors.
- You instruct the system to continue processing the objects even though you have not corrected the errors. This is appropriate for objects whose value is insignificant.

Reports on the objects are available to help you reach a decision.

Executing Reports

Reports can help you determine the following:

- Whether the value of the object is negligible

  In this case, you instruct the system not to process the object. Otherwise, you correct the error.

- Whether the values calculated for an object are acceptable in a business sense. You may also want to do this for objects that were processed without error (processing status OK).

  If this is not the case, then once you have corrected the problem (the error may have been caused by faulty Customizing settings), you can force further processing. You can also assign further reports with the function report assignment (if supported).

To view a report on an object, position the cursor on the object in the object list and click on the Execute report icon above the object list. Then enter the required parameters and select the report you want to see (only for projects; production orders do not allow reports to be selected). On the basis of the data in the report, you can now decide how the object is to be handled.

To analyze the error for the objects with the processing status Error, look at the messages for the object and processing step.

Messages for One or More Objects

To see the messages that were issued for one or more objects:

1. Select the objects.
Processing Worklists

In the **object list**, select an object by positioning the cursor on the object, holding down the left mouse button, and pressing the Ctrl key on the keyboard. Continue to select further objects in the same way.

2. View the messages.

To see the messages for the selected objects, click the **Display object messages** icon above the **object list**. You can also display the messages for one line of the object list by double-clicking on the line.

In the pull-down menu of the **Display object messages** icon above the object list, you can choose between the following types of messages:

- **Object messages**
- **Step messages**
- **Messages of originating objects**

The object messages appear in the **message list**.

3. View the long text of the messages.

To analyze the error, you will normally need to look at the long text of the message. To see the long text, double-click on the message in the **message list**.

**Step-Specific Messages (Messages Without Reference to a Specific Object)**

To see the messages for a particular processing step, go to the object list and choose the drop-down menu of the **Display object messages** icon, and then choose **Display step messages**. The step-specific messages are displayed in the message list.

**Messages of Originating Objects**

You should look at the **messages of the originating objects** particularly when you want to analyze objects with the processing status **Followup error**.

**Skipping Processing Manually**

You have decided to have the system skip a processing step for one or more objects.

- In the **object list**, select the step statuses that you want to change. Click the icon **Set processing status**.

If you select the status **Skip processing**, the system changes the processing status to **Skipped manually**. The object is not included in this processing step during the next execution of the processing step sequence. The object enters the subsequent processing step as if it had been processed without errors.

**Forcing Processing Manually**

There are two ways to force the system to reprocess objects:

Position your cursor in the **object list** and press the right mouse button. In the context menu, choose **Repeat processing**. The system changes the processing status to **Postprocessing forced manually**. The next time the processing step sequence is performed, the object is included in that processing step and in all subsequent processing steps.

You can also force the system to process objects by selecting the objects and clicking the icon **Set processing status (icon in the object list)** and choosing **Repeat processing**. You can select multiple objects at the same time with the following methods:
To select an entire column, click on the column header.
To select individual columns, lines, or cells, hold down the Ctrl key and click.

The system changes the processing status to Postprocessing forced manually. The next time the processing step sequence is performed, the object is included in that processing step and in all subsequent processing steps.

Editing Master Data
From the object list, you can access master data maintenance for the object. To do so, position your cursor on the relevant object and click on the Edit master data icon above the object list. The system starts a new session. You are now in the change mode of the relevant object. You can close the session by going back (green arrow).

The error message Maintain the settlement rule of the sender is issued for a production order for the processing step Settlement. To maintain the settlement rule, call up the production order.

Display as Hierarchy
In the hierarchy view, the objects are displayed according to their hierarchical relationship to each other.

Select one or more objects in the object list and choose Display as hierarchy. The screen Object list - hierarchy view appears. In the hierarchy view, the object or objects you branched from are selected.

Expand the object hierarchy. This provides a quick overview of the relationships between the faulty objects. You can process objects to which a particularly large number of faulty objects are assigned.

To go back to the object list from the hierarchy, choose Back to object list.

In the object list hierarchy view screen, you can only change the processing status of individual objects. Mass changes to the processing status of the objects is only possible in the object list.

In addition, a requirement for the display hierarchy function is that the objects have hierarchy information in the worklist. This is the case in the Project System and for cost object hierarchies.

Hierarchy Comparison
Objects that have hierarchy information (such as projects and cost object hierarchies) can be compared with each other using the hierarchy comparison function. This allows you to more efficiently find errors that are due to differences in the values of two periods. Comparing the data of two periods is particularly useful because the items and values of the objects in the hierarchy can change between periods.
Processing Worklists

In the project system, it is also possible to compare two versions of an original structure. The changes that were made to the version are shown in a separate window.

Before you start the comparison, you specify which two data structures you want to compare. You define one of the two structures as the original structure and the other as the version. During the comparison, the two structures are represented in the form of a hierarchical structure tree in a separate screen area. You can compare individual objects, subhierarchies, or the two complete structures. The results of the comparison are grouped into different categories:

- New objects (which objects were added to the version?)
- Changed objects (which object attributes were changed, and how?)
- Nonexistent objects (which objects do not exist or were deleted?)
- Hierarchy position of changed objects (which objects changed their position in the hierarchy?)

For detailed information on the hierarchy comparison, see the documentation under:

Logistics → Project System → Collaborative Engineering and Project Management → Monitoring → Comparing Two Folders

The Schedule Manager only supports the comparison function; synchronization is not possible.

Sending Objects

Select one or more objects in the object list and choose the Send icon above the object list. To receive a log of the transmission, choose Send log. If you choose Send to agent, the person responsible for the object receives a mail in his or her inbox (Office → Workplace → Inbox) with information on the required change. From this mail, you can access the screen Schedule Manager: Monitor which displays only the sent objects. Note that the filter function in the icons of the object list (Objects: Set Status Filter) is not available when you access the monitor through your office inbox.

To be able to use the function for sending objects, the following settings must be made in each client:

2. Select task type Workflow template and enter task 20001060 (SCMA_WL_DISP). The screen Workflow Template: Change appears.
3. Select the tab Triggering events. Activate the event linkage by clicking the icon Event linkage active in the first column. The light symbol changes to green.
4. Save the data.

If no agent can be determined for the object, the dialog box Entry of Responsible Agent appears, in which you can specify the user responsible for further processing.

The object list contains the field Agent ID next to the existing column headers. This field shows the agent responsible for the object. The agent can be an R/3 user or a node in the organization plan.
On the basis of the organizational data of the objects (such as the plant, company code, and so on), you can specify criteria for each object type that are used to determine the agent.

You specify the agents responsible for the objects under:

Schedule Manager → Extras → Settings for worklist → Maintain responsibilities for objects.

For detailed information on maintaining responsibilities, refer to the SAP Library under:

Human Resources → Personnel Management → Organizational Management → Integration with SAP Business Workflow → Role Resolution → Role Definition → Define Roles Using Responsibilities

Define Roles Using Responsibilities [Ext.]

Flagging Checked Objects

You can flag objects to indicate that you have checked them.

To do this, either select the check box **Object checked** directly, or select one or more objects and click the icon Change “checked” indicators and then in the pull-down menu:

- **Select indicators**: selects the check boxes for the selected objects
- **Deselect indicators**: deselects the check boxes for the selected objects
- **Toggle checked <-> not checked**: Toggles the status for the selected objects

The indicators are only visual and have no effect on processing.

Displaying Other Worklists

To display other worklists, click the **Other worklist** icon at the top of the screen. The enter the required data and choose **Enter**. This function is only available when you access the Schedule Manager through the application components. When you access the Schedule Manager through a mail in your Office inbox, this function is not available.

Triggering Reprocessing of the Worklist

**Prerequisites**

Before you trigger reprocessing of the worklist, you must have done the following:

- Corrected the errors of the faulty objects, or instructed the system to skip processing for those objects
- Forced reprocessing of objects that are faulty in a business sense

**Procedure**

To trigger reprocessing, access the mail that was sent to you through the workflow. Start reprocessing from this mail.

**Result**

The following objects are processed:

- Objects that had errors in the previous execution of the processing step sequence and whose errors have been corrected
  These objects are processed starting with the processing step in which the error occurred.
Processing Worklists

- Objects that had errors in the previous execution of the processing step sequence and for which the processing status *Skip processing* was set
  
  These objects are processed starting with the processing step following the processing step for which the status *Skip processing* was set.

- Objects that received the status *Postprocessing forced manually*
  
  These objects are processed starting with the processing step for which the status *Postprocessing forced manually* was set.

**See also:**

Many of the icons displayed above the individual screen areas support the standard functions of the ABAP List Viewer (ALV). These icons are not explicitly explained here. The same applies to the standard ALV functions in the context menu (right mouse button). For information on the ALV, refer to the SAP Library under *Cross-Application Components (CA) -> General Application Functions -> ABAP List Viewer*, or under: [Functions of the ABAP List Viewer [Ext.]](http://help.sap.com)
Choosing Objects for Processing

Use
An advantage of this worklist [Ext.] is that the objects for processing only have to be selected once per flow definition.

Prerequisites
You are in flow definition [Ext.] in Schedule Manager (Extras → Flow definition → Edit flow definition).

Procedure
20. Choose a processing step in the navigation area. On the right of the screen, you see Flow definition: Task details.
21. Enter a new variant for this processing step and define a name for this new variant in the Variant field.
22. Choose Create variant.
   The Variant Maintenance screen appears. Program <program name>, variant <variant name>.
   Here you can determine the scope of selection of the program variants for the flow definition.
23. To be able to choose more extensive selection criteria, first complete the required entry fields, for example Period <006>, Fiscal year <2000>.
24. You can now define further selection parameters using the various pushbuttons that are offered in dialog boxes.
25. Choose Attributes.
   The ABAP: Save Attributes of Variant <Variant name> screen appears.
Processing Status of Objects

Use

The processing status of an object tells you whether processing was successful in a specific processing step.

For every object listed in the worklist of the Schedule Manager [Page 619], a processing status is indicated for each processing step. The system sets the processing status during processing. This status can be changed manually in the monitor.

In addition to information on the success of processing, the processing status shows whether further processing of an object is allowed. This ensures that an object which was not processed in a processing step due to errors is not passed on to the next step.

Integration

The processing status is displayed in the monitor. The status is not updated to the processed object. For more information on the monitor, see the following section: Schedule Manager: Monitor - Working with the Object List [Page 634]

The examples described below are based on the use of the multilevel worklist in Cost Object Controlling and the Project System.

Features

Through the processing status, the worklist of the Schedule Manager controls whether an object is processed in the following processing step. The system automatically sets the following processing statuses:

Automatic Processing Statuses

- Not processed
  The object has not been processed yet.
- OK
  The object was processed without errors.
- Minor error
  A warning or error occurred while the object was being processed. However, this error does not prevent further processing in a following step.
- Flagged for postprocessing
  This status is set in the following case:
  The object must be processed in a processing step because, for example, processing was forced. In the subsequent processing step, the object has one of the following processing statuses:
  - OK
  - Not relevant
- **Minor error**
- **Filtered**

Since the object normally would not be processed when it has this processing status, the system sets the processing status of the subsequent processing step to *Flagged for postprocessing*. This ensures that an object processed in one step is always included in the subsequent processing steps. The processing status is reset to *Flagged for postprocessing* regardless of whether the object was changed in the previous processing step.

- **Error**

An error occurred while the object was being processed that prevents further processing. You can either correct the error or instruct the system to include the object in the subsequent processing step despite the error (processing status *Processing skipped manually*).

- **Followup error**

An object receives the processing status *Followup error* for a processing step if it belongs to a group of objects that are processed together and this group contains one or more objects that were processed with errors (processing status *Error*), or were not processed, in the previous processing step.

The object with the processing status *Followup error* is not processed in the processing step for which it received that error. This ensures that the entire group of objects can only be processed when none of the objects contains an error that hinders the processing of an object in the group.

See the end of this text for an example of the processing statuses *Followup error* and *Hierarchy error*.

- **Hierarchy error**

An object receives the processing status *Hierarchy error* for a processing step if it belongs to a group of objects that are to be processed together and this group contains one or more objects that were processed with errors in the current processing step (processing status *Error*).

The object with the processing status *Hierarchy error* is not processed in the processing step for which it received that error. This ensures that the entire group of objects can only be processed when none of the objects contains an error that affects processing.

See the end of this text for an example of the processing statuses *Followup error* and *Hierarchy error*.

- **Filtered**

The user has excluded the object from processing by defining an application-specific filter.

- **Not relevant**
  - The object is not relevant for processing in this processing step due to its attributes derived from Customizing or master data.
  - The object is not relevant due to a status that has been set for it.
Processing Status of Objects

Example 1:

According to the selection parameters, all production orders of a plant are selected for variance calculation in period-end closing of Product Cost by Order. No variance key has been specified for some of the production orders. These production orders are not included in variance calculation. The production orders receive the processing status *Not relevant*.

Example 2:

According to the selection parameters, all production orders of a plant are selected for overhead calculation in period-end closing of Product Cost by Order. A system status or user status is set for some production orders, which does not allow processing. Examples of this are the system statuses *open, closed, deletion flag* and *locked*.

In some cases, a given status may make an object relevant or irrelevant only in certain processing steps.

Example:

A production order has a settlement rule with the settlement type FUL (full settlement). If neither the status DLV (delivered) nor the status TECO (technically completed) is set for the object, it is *not relevant for variance calculation* and receives the corresponding processing status. The order is relevant for the other processing steps of period-end closing such as template allocation, overhead calculation, calculation of work in process and settlement, regardless of whether one or none of the two statuses is set.

As a rule, with the processing status *not relevant*, no messages are issued for the object and processing step. To see the messages that caused the processing status to be set to *not relevant*, you can have the system process the object individually. Possibly, you can also force the issuance of messages through user-defined error management by putting the message type at the top.

For WIP calculation and results analysis, you can force the system to issue messages despite the status *not relevant*. You can guarantee the issuance of messages by setting the indicator *Log information messages*. If the indicator is set, all information messages are issued including those from processing within and outside of the multilevel worklist, even if the status *not relevant* is set for an object and processing step.

**Manual Processing Statuses**

You can set the following processing steps manually:

- Processing skipped manually
In the object list, the user manually sets the processing status of an object and processing step to *Skip processing*. The system changes the processing status to *Processing skipped manually*.

The object with this processing status is not included in the relevant processing step, and enters the next processing step.

- **Processing forced manually**

In the object monitor, the user manually sets the processing status of an object and processing step to *Repeat processing*. The system changes the processing status to *Processing forced manually*. The object is processed in the relevant processing step again even if the processing step had been executed without error.

If an object was processed without error in an update run for project interest calculation, new interest calculation can only be triggered if the previous interest calculation is first reversed. If no reversal is carried out, the object is not included in the recalculation of interest, despite its processing status.

**Example**

Example of the processing statuses *Follow-up error* and *Hierarchy error*:

During the calculation of actual overhead rates in period-end closing, a production order assigned to a WBS element was not processed due to deficient Customizing settings. The production order receives the processing status *Error* for the processing step *Actual overhead*.

In addition to this production order, other production orders are also assigned to the WBS element. All other production orders assigned to the WBS element receive the processing status *Hierarchy error* for the processing step *Actual overhead*. This status indicates that an object of an object group (all production orders assigned to a WBS element) contained errors in the processing step.

The processing step following the processing step *Actual overhead* is *Results analysis*. During results analysis for the WBS element, the data is included that was updated to the production orders assigned to the WBS element. Because one of the production orders assigned to the WBS element was marked as faulty and all other production orders received the corresponding processing status *Hierarchy error* in the processing step *Actual overhead*, the processing step *Results analysis* can not be carried out successfully for the WBS element.

The WBS element receives the processing status *Followup error* for the processing step *Results analysis*.

If you decide that the deficit resulting from the missing overhead is so low that it can be ignored, you can avoid time-consuming error analysis by specifying a processing status that prevents the production order from being included in the calculation of overhead. All production orders, including the one for which no overhead was calculated, are included in results analysis.

If the value of the production order is significant, you must remove the cause of error.

**Additional Information**

Note the following:

- There is no one-to-one assignment of message types to processing statuses in the worklist of the Schedule Manager. For example, not every message of message type "E" (error)
Processing Status of Objects

results in the processing status Error for an object in the Schedule Manager in that processing step.

The system issues the message CK 214 as an error message.

If this message is based on target cost version 0 in variance calculation, the processing status Error is set in the worklist of the Schedule Manager.

If this message is based on a target cost version in variance calculation that is not 0, the processing status Minor error is set in the worklist of the Schedule Manager.

- Some messages are issued with different message types based on the object to be processed. Different processing statuses are set in the Schedule Manager.

In variance calculation, if message KV 158 is based on a single production order, the system issues this message as an error message. The processing status Error is set in the worklist of the Schedule Manager.

In variance calculation, if this message is based on a product cost collector to which multiple production orders are assigned, the system issues a warning message. The processing status OK is set in the worklist of the Schedule Manager.

Note the following:

If you are using the multilevel worklist of the Schedule Manager, the objects with the processing status Error for a processing step are not processed in the subsequent step. In many cases, the processing status Error is set because a message was issued with the message type “E” (error). When calculating variances and scrap variances, you can use user-defined error management to influence the message type for a large number of messages In the worklist of the Schedule Manager, this can result in a different processing status being updated to the processing step. This enables you to ensure that objects are processed in the subsequent processing step, for example.

A message was issued as an error message in variance calculation. The processing status Error is issued in the monitor.

The error is not serious, so you decide that the object should be processed in the next processing step. You therefore use user-defined error management to specify a message type of lower severity (such as “W” for a warning message). This ensures that the object does not receive the processing status Error for the processing step in the worklist due to this message. The object then enters the subsequent processing step.

No Processing Status Output

It may occasionally happen that no processing statuses are issued. See the following for an example of this: Separation of Value Calculation from Goods Movements: Effects on Cost Object Controlling [Ext.].

See also:

For information on the following topics and many others, see the section Processing Worklists [Page 637].
• When processing should be skipped or forced manually
• How to decide whether to do so
• How you can change the processing status

For detailed information on user-defined error management, see the following section:

User-Defined Error Management in Cost Object Controlling [Ext.]
Scenarios for the Schedule Manager

Purpose
You can use the elements of the Schedule Manager in different scenarios in various combinations.

Prerequisites
You are working on a complex process, which consists of many different business transactions (tasks).

Process Flow
You decide which functions (scheduler [Page 574], monitor [Page 592], flow definition [Page 599], multilevel worklist [Page 619]) you require to execute and monitor your process.

You can choose between three scenarios:

• Starting Transactions/Reports Online, Scheduling Jobs [Page 655]
• Starting Transactions/Report Online, Scheduling Jobs and Job Chains [Page 656]
• Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist [Page 657]
Starting Transactions/Reports Online, Scheduling/ Monitoring Jobs

Use
Not only can you start transactions and reports online, and schedule jobs in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Page 592] while they are being executed.

Integration
You need the scheduler [Page 574] and monitor from the Schedule Manager for this scenario.

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.

Features
This scenario contains the following work steps:

- Creating a Task List [Page 578]
- Inserting a Task/Task Group in the Task List [Page 579]
- Scheduling Tasks in the Daily Overview [Page 587]
- Monitoring Jobs in The Monitor [Page 592]

Activities
In this scenario, you choose a task list in the scheduler or create a new task list.
You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.
Starting Transactions/Reports Online, Scheduling Jobs/Job Chains, Monitoring Jobs

Use
Not only can you start transactions and reports online, and schedule jobs/job chains from the flow definition in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Page 592] while they are being executed.

Integration
For this scenario, you need the following elements: the scheduler [Page 574], the monitor of the Schedule Manager [Page 592], and the flow definition [Page 599].

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.

Features
This scenario contains the following work steps:

- Creating a Task List [Page 578]
- Inserting a Task/Task Group in the Task List [Page 579]
- Scheduling Tasks in the Daily Overview [Page 587]
- Monitoring Jobs in The Monitor [Page 592]
- Creating a Flow Definition [Page 599]

Activities
In this scenario, you choose a task list in the scheduler or create a new task list.

You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.

You can also insert job chains (that you specified in a flow definition) into the task list and schedule them in the daily overview. You can also use the monitor to check processing of the job chains.
Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist

Use
Not only can you start transactions and reports online, and schedule jobs in the task list with this scenario, but you can also monitor the scheduled jobs in the monitor [Page 592] while they are being executed. You can also use worklists and check them in the object monitor [Page 634] in the generalized worklist.

Integration
For this scenario, you need the scheduler [Page 574], the monitor of the Schedule Manager, the flow definition [Page 599] and the multilevel worklist [Page 619].

Prerequisites
The application contains reports for your processing, which you can schedule as jobs.
You are using worklists.

Features
This scenario contains the following work steps:

- Creating a Task List [Page 578]
- Inserting a Task/Task Group in the Task List [Page 579]
- Scheduling Tasks in the Daily Overview [Page 587]
- Monitoring Jobs in The Monitor [Page 592]
- Creating a Flow Definition [Page 599]
- Working with the Worklist Monitor [Page 634]

Activities
In this scenario, choose a task list from the scheduler, or create a new one. Only use task lists that have the task type flow definition.

You insert tasks in the daily overview. You can monitor the jobs in the monitor by selecting a task with the right mouse button and choosing Monitor.

In addition to the scheduler, monitor and flow definition, you can also work with a generalized worklist. Objects that are to be processed in a processing step sequence are managed in the worklist. Define the processing step sequence in the flow definition.

The worklist monitor shows you, for example, which objects were processed without errors, and which objects could not be processed. You can display information on the cause of errors, and thus control the way in which the object is processed further.

The generalized worklist ensures that when processing step sequences are repeated, the system only reprocesses the objects that previously contained errors and those for which you manually forced reprocessing.
Starting Transactions/Reports Online, Scheduling Jobs and Job Chains, Worklist
Periodic Reposting

Use

Periodic reposting [Ext.] is posting aid that enables you to adjust postings made to your cost centers or business processes, internal orders, or WBS elements. It has the same result as transaction-based reposting. The results of transaction-based repostings have a direct effect on the actual costs of the sender and the receiver, whereas periodic repostings have a one-time effect on actual costs at period-end closing.

Postings relevant to Controlling (CO) such as telephone costs, postal charges, insurance, and so on are entered in Financial Accounting (FI) and posted to an allocation cost center or a business process. These are used exclusively for cost collection. This minimizes the number of different account assignments you have to make when entering data in FI. At the end of the period, the collected costs are reposted to the cost centers or business processes which incurred the costs by of means user-defined keys (fixed values or dynamic tracing factors). The following information is passed on to the receivers:

- The original cost element (the primary cost element [Ext.]) is retained.
  
  During periodic repostings, you can allocate activity-dependent plan costs to receiver objects of the category “Cost center” (sender activity type is retained) or "business process".

  You can allocate activity-independent costs to all receiver object categories, for example, cost centers, business processes, or orders.

- The allocation cost center is not important for the receiver cost centers (neither is the sender business process for the receiver processes). The SAP System therefore stores data records for periodic reposting in a way that uses less memory than, for example, distribution [Ext.]. For this reason, the sender cost center or sender process is not updated using this method. You can only analyze from which cost center or from which business process the costs originate from the line items, and not from the totals records.
If you are working with transfer prices [Ext.] (multiple valuation approaches) the periodic reposting is executed in parallel in all valuations. The costs to be allocated are taken from the corresponding valuation. The tracing factor is always taken from the values of the operational valuation. The values allocated may differ in each of the valuation methods.

Senders and receivers are displayed in the results list, differentiated according to the parallel actual versions of the various valuations.

For more information on transfer prices, see the SAP Library under:

- Financials → Enterprise Controlling (EC) → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
- Financials → Controlling (CO) → Controlling → Overhead Cost-Controlling → Multiple Valuation Approaches in Overhead Cost Controlling [Ext.]

See also:

Defining Periodic Repostings or Periodic Allocations [Page 747]
Creating or Changing Cycles [Page 770]
Executing Periodic Repostings or Periodic Allocations Online [Page 801]
Displaying the Cycle Overview [Page 773]
Accrual Calculation

Use
Operating expenses are often allocated differently in financial accounting than in cost accounting. If, for example, an expense incurred in external accounting covers a whole year, you must assign a proportion of the whole to each individual cost accounting period. You distribute irregularly-occurring expenses, according to cost-origin, on the months in which they are incurred. This allows you to avoid irregularities within cost accounting. Costs allocated in this manner are termed accrued costs [Ext.].

The even distribution of a one-off expense is referred to as time-based accrual calculation [Ext.]. With the aid of the accrual calculation functions, you can take these costs into account in the Controlling component.

Features
You can calculate accruals in two ways.

- You can post accruals in the Financial Accounting component (FI) using recurring entries and pass the accruals along to the Controlling component using a special cost element for accrual allocation. Here, the accruals (or imputed costs) are calculated in financial accounting, not internal accounting.

- You can calculate accruals in the Controlling component based on the costs posted there. To do so you can use the following approaches:
  - Accrual calculations using the percentage method
  - Accrual calculations using the target=actual method

If you use either of these procedures, you must ensure that subsequent postings are made in the Financial Accounting component if you want to display the accruals postings there as well.
Accrual Calculation

**Accrual Methods**

- Accruals in FI
  - Accrual costs for deferrals
  - Breakdown Accruals
  - Subs. posting in FI
- Accruals in CO
  - Accrual costs per cost center/period
  - Accrual calc. in CO
  - Accrual calc. in FI
- Postings in FI
  - Recurring entries

**Actions**

To execute **accrual calculation [Ext.]**, you must define the necessary data and carry out the following steps, according to the accrual calculation method you are using:

- For accrual cost calculation using the percentage method, you must first create an overhead structure (see: **Defining the Percentage Method [Page 666]**).

- For accrual calculation using the target=actual or the plan=actual methods, you must create the corresponding accrual cost elements. You must also carry out cost element and activity type planning (see: **Maintain Data for Target=Actual Accrual Calculation [Page 673]**).

You can maintain data for an overhead structure, as well as for target=actual credits, during system configuration and for the application component itself. You must enter this data as **controlling area dependent [Ext.]**.

This controlling area dependent data includes:

- For the percentage method
  - Calculation bases
  - Overhead percentage rates
  - Credit objects
- For the target=actual method
  - Target=actual credits
Accrual Calculations Using the Percentage Method

Use

With the percentage method, the costs to be accrued are determined in cost accounting using a percentage rate on a reference cost element. The advantage of this method over using a recurring entry in the Financial Accounting component (FI) is that accrual is based on the actual costs posted. This method is useful for calculating accrual [Ext.] for non-wage labor costs such as vacation bonuses.

You plan labor costs of $10,000 per month on cost center 4210. You define a 10% rate on labor costs to cover the vacation bonus. This results in additional plan costs of $1,000 per month. You also define a 10% rate on the actual costs of $2,000 per month. This results in additional actual debits of $1,200 per month.

<table>
<thead>
<tr>
<th>Period</th>
<th>Jan</th>
<th>Feb</th>
<th>Mar</th>
<th>Apr</th>
<th>May</th>
<th>Jun</th>
<th>Jul</th>
<th>Aug</th>
<th>Sep</th>
<th>Oct</th>
<th>Nov</th>
<th>Dec</th>
</tr>
</thead>
<tbody>
<tr>
<td>Labor costs</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
<td>12,000</td>
</tr>
<tr>
<td>Accrued vacation bonus (10% of labor costs)</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
<td>1,200</td>
</tr>
</tbody>
</table>

\[ \sum \text{Vacation bonus paid} = 15,000 \]

Accrual rules for periodic accrual calculation

Cost center 4210

<table>
<thead>
<tr>
<th>Period</th>
<th>Accrued amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>+ 1,200</td>
</tr>
<tr>
<td>02</td>
<td>+ 1,200</td>
</tr>
<tr>
<td>03</td>
<td>+ 1,200</td>
</tr>
<tr>
<td>04</td>
<td>+ 1,200</td>
</tr>
<tr>
<td>05</td>
<td>+ 1,200</td>
</tr>
<tr>
<td>06</td>
<td>+ 1,200</td>
</tr>
</tbody>
</table>

Accrual object

<table>
<thead>
<tr>
<th>Period</th>
<th>Accrual object and effective act. costs</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>- 1,200</td>
</tr>
<tr>
<td>02</td>
<td>- 1,200</td>
</tr>
<tr>
<td>03</td>
<td>- 1,200</td>
</tr>
<tr>
<td>04</td>
<td>- 1,200</td>
</tr>
<tr>
<td>05</td>
<td>- 1,200</td>
</tr>
<tr>
<td>06</td>
<td>- 1,200 +15,000</td>
</tr>
</tbody>
</table>

The accrued amount in cost accounting equals $1,200 USD per month, totaling $14,400 for the entire year. The credits are posted to a credit object, an order, each month. In external accounting, the expenses of $15,000 are posted in the month of June to the order. You can display the balance between external and internal...
accounting at any time on the order. You can also transfer the balance to the operating profit.

**Actions**

[Executing Accrual Calculation](Page 677)
[Reversing Accrual Calculation](Page 680)
Defining the Percentage Method

Use

The percentage method of accrual calculation distinguishes between cross-controlling area data, which you maintain in an overhead structure, and controlling-area related data, such as base cost elements, overhead rates and credit objects.

The following section summarizes the most important steps for defining the percentage method. For detailed information on defining an overhead structure, see the Implementation Guide (IMG) for Controlling under Cost Center Accounting and the sections:

- Planning → Planning Aids → Accrual Calculation → Percentage Method [Ext.]
- Actual Postings → Period-End Closing → Accrual Calculation → Percentage Method [Ext.]

The following rules apply when you define the percentage method:

- To which base cost elements does the overhead apply?
  This information is stored in the base rows.

- Under which cost element is the overhead posted?
  This information is stored in overhead rows.

- How high is the overhead rate?
  This information is stored in overhead rows.

- Which credit object (cost center or internal order) is to be credited?
  This information is stored in overhead rows.

The structure, and the rules entered to calculate accrual, are very similar to those used in the Product Cost Controlling component (CO-PC). Therefore, you can also use this structure in accrual of costing-based costs.

The following example illustrates an overhead structure for accruals of vacation bonuses.

<table>
<thead>
<tr>
<th>Row no.</th>
<th>Costs</th>
<th>Overhead</th>
<th>Amount</th>
<th>Row Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>010</td>
<td>Labor costs</td>
<td></td>
<td>200,000</td>
<td>Base row</td>
</tr>
<tr>
<td>020</td>
<td>Vacation bonus</td>
<td>10% on top of labor costs</td>
<td>20,000</td>
<td>Overhead row</td>
</tr>
<tr>
<td>030</td>
<td>Holiday bonus</td>
<td>10% on top of labor costs</td>
<td>20,000</td>
<td>Overhead row</td>
</tr>
<tr>
<td>040</td>
<td>Annual bonus</td>
<td>5% on top of labor costs</td>
<td>10,000</td>
<td>Overhead row</td>
</tr>
</tbody>
</table>

Activities

To define accrual cost calculation with the percentage method:
1. Defining overhead structures
   The overhead structure links all parts of the percentage method. It contains calculation bases, overhead rates, assignments, the accrual cost element, and the credit object.

   You create the overhead structure during Customizing. Per controlling area, you can maintain the data required to do this both within the application component and from Customizing.

2. Determine assignments
   You set the controlling area [Ext.] and the processing methods for which the overhead structure is valid.

   When you maintain controlling area dependent data, the R/3 System offers only those overhead structures in which assignments exist for the corresponding controlling area.

   You can define only one overhead structure per controlling area. If you require more structures in order to create different versions of accrual calculations, you can work with substructures.

3. Specify calculation base
   The calculation base includes all the cost elements receiving overhead postings.

4. Specifying overhead rates
   You must determine the validity period of the percentages serving as overhead rates. You must also assign a dependency to each overhead rate (see: Defining Custom Dependencies [Page 587]).

   If the business area financial statement active, you need to specify the overhead rates per business area.

5. Determine credit/allocation
   You use the credit key to define:
   a) The accrual cost element used to apply the accrual amount allocated
   b) the credit object (cost center [Ext.]/internal order [Ext.])

Steps 1 and 2 refer to the overhead structure definition, meaning the framework. As a rule you define an overhead structure during Customizing of the R/3 System. Steps 3 through 5, however, belong to data maintenance for the structure, which is usually carried out in the application component.

See also:
Maintaining Overhead Structure Data [Page 387]
Defining the Percentage Method
Maintaining Overhead Structure Data

1. To define the overhead method, choose:

   Period-end closing → Single functions → Accrual calculation → Extras → Settings → Percentage method, or

   Planning → Planning aids → Accrual calculation → Extras → Settings → Percentage method

2. Using the overhead structure [Ext.] display for the given controlling area [Ext.], you can maintain, create, or call up information on accrual calculations for selected objects.

   To do so, choose one of the following objects either by double-clicking on it or by choosing Goto from the menu:

   a. **Base** (basis for calculation)
      
      You specify the base cost elements that are to be assigned overhead per controlling area. Choose Where-used list → Overhead structure or Controlling area to display whether and where the base cost element assignments exist.

   b. **O/H rate** (overhead rates)
      
      Determines plan and actual overhead rate percentages for each controlling area applying to a particular validity period. On the overhead list screen, the Assignments indicator shows whether individual overhead rates exist.

   c. **Credit** (credit objects)
      
      Determines credit objects (cost centers [Ext.] or internal orders [Ext.]) for each controlling area in a particular validity period and the relevant accrual cost element. The overview screen displays the credit objects that exist in the system, along with their credit keys.

      The system displays the credit records as follows:

      - The company code [Ext.] is only displayed if it cannot be derived from the controlling area.
      - If, in Financial Accounting, you specified that financial statements are also to be created for business areas, you must also specify a business area for the credit object. In addition to the credit records, the system also displays the business area.

      Note that the credit object must be assigned to the company code and business area in question.

      - If the business area requirement is a partial one, or if no requirement exists, the screen display does not display the business area. You can maintain the credit records differentiated by business area in a further entry screen.

3. To check the assignment of the current object (calculation base, overhead rate, or credit) and to display the assignments per controlling area, per overhead structure and the structures not used, when maintaining the above-mentioned accrual data, choose Where-used list → Overhead structures or Controlling area (see: Where-Used List for Accrual Calculations [Page 690]).
Maintaining Overhead Structure Data

⚠️

You can change assignments only in Customizing. For more information, see the Implementation Guide (IMG) under Controlling → Cost Center Accounting and the sections:

- Planning → Planning Aids → Accrual Calculation → Percentage Method → Maintain Overhead Structure [Ext.].

- Actual Postings → Period-End Closing → Accrual Calculation → Percentage Method → Maintain Overhead Structure [Ext.].

4. Save your entries.
**Accrual Calculations Using the Target=Actual Method**

**Use**

The target=actual method is used to calculate accrual [Ext.] for activity-dependent costs. You plan the activity-dependent primary costs using an accrual cost element:

- On the cost centers for which you want to calculate accrual
- In the timeframes during which you want to execute accrual calculations

When calculating accrual in actual, the R/3 System determines the target costs of the relevant cost center based on an activity type and inserts the target values in the fields for actual values. This method is particularly useful where you can plan accrual on a period basis and where the costs are activity-dependent.

You expect energy costs of $24,000 in period 11 on production cost center 4310, dependent on the number of production hours. A quarter of these costs, $6,000, are not activity-dependent. On cost center 4310, you plan activity-dependent accruals (cost element type 4) which the R/3 System can then distribute equally on the posting periods using standard distribution key 1. The actual activity quantity for activity type PHR (production hours) is 1200 hours, whereas the plan activity quantity was 1000 hours. This results in an operating rate of 1200 / 1000 = 120%.

The R/3 System calculates the following values for the accrual:

<table>
<thead>
<tr>
<th>Period</th>
<th>1</th>
<th>2</th>
<th>...</th>
<th>11</th>
<th>12</th>
<th>∑</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td>total fix</td>
<td>2000 500</td>
<td>total fix</td>
<td>2000 500</td>
<td>...</td>
<td>total fix</td>
</tr>
<tr>
<td>Target</td>
<td>500 * 1.2 = 2300</td>
<td>2300</td>
<td>...</td>
<td>2300</td>
<td>2300</td>
<td>27600</td>
</tr>
<tr>
<td>Actual</td>
<td>2300</td>
<td>2300</td>
<td>2300</td>
<td>2300</td>
<td>2300</td>
<td>27600</td>
</tr>
</tbody>
</table>

Act. operating level = 1200 hrs
Plan operating level = 1000 hrs

Cost accounting accruals total $27,600. The corresponding amount posted in Financial Accounting is $24,000. The expense in the Financial Accounting
Accrual Calculations Using the Target=Actual Method

component (FI) is posted on the credit object in period 11, as are the period-based credits in the Controlling component (CO). The difference of -$3,600 is transferred by the system to the operating profit.

**Actions**

[Executing Accrual Calculation](Page 677)
[Reversing Accrual Calculation](Page 680)
Maintaining Data for Target=Actual Accrual

Use

In target=actual accrual calculation, you must determine which credit object (cost center or order) is credited for each target=actual cost element.

In a credit record, you enter a credit object (cost center or order) for a certain validity period and a target=actual cost element (category 4).

If you want to make postings to different credit objects in a fiscal year, enter more than one credit record with different credit objects.

The credit record display is controlled by the SAP R/3 System as follows:

- The company code appears only if it is not clearly assigned to the controlling area.
- If this company code requires a business area assignment (meaning you selected the indicator Business area balances under the company code data), the business area also appears in the credit record display.
- If the business area requirement is a partial one, or if no requirement exists, the screen display does not display the business area. You can maintain the credit records differentiated by business area in a further entry screen.

Prerequisites

Before you define the accrual calculation:

- Create target=actual cost elements (category 4).
- Carry out activity type planning for the relevant cost centers and activity types.
- Plan activity-dependent costs for the accrual cost element.

The activity-dependent plan costs are used in target cost calculations to determine the accrual amounts for the target=actual method. The target costs of a cost center/activity type are based on the total plan costs (fixed and variable) multiplied by the operating rate of the cost center.

Procedure

1. To define target=actual accrual, access the Cost Center Accounting menu and choose Period-end closing → Single functions → Accrual calculation → Extras → Settings → Target=actual method.

   On the overview screen for target=actual accrual calculation, the system displays all category 4 cost elements created for the current controlling area.

2. You can call up the cost element from the overview screen for target=actual credit postings by selecting the object or by choosing Goto → Detail screen.
The Existing credit record indicator shows whether detailed information exists for the following:

a. Business area  
b. Validity period  
c. Credit object (cost center or order)

3. Branch to the detail screen for a target=actual cost element and enter the credit records.

4. To branch to the credit records for another target=actual cost element, on the detail screen, choose Target=actual credit → Other T=A credit...

5. To display the other controlling areas in which the target=actual cost element in question is used, choose CO area.

6. Save your entries.
Accrual Calculations Using the Plan=Actual Method

Use

The plan=actual method is used to accrue activity-independent amounts. Target costs cannot be determined because no activity-dependent costs occur. All the plan costs are used as the actual costs. As is the case with target=actual accrual calculation, you must be able to plan the costs for plan=actual accrual by period, meaning you assume a predefined amount, such as an annual insurance premium, and use this amount to plan the costs which would be incurred each month. During primary cost planning, the R/3 System spreads the total amount across the posting periods based on the distribution key you select.

Cost center 4110 anticipates paying an insurance premium of $12,000 in period 11. You plan accrual amounts for this cost center, which the standard R/3 System distribution key 1 (equal distribution) spreads evenly across periods 1 through 12. When you calculate accrual, the R/3 System automatically enters the plan monthly value of $1,000 in the actual value fields.

As with the percentage method, you can specify either an internal order or a cost center as the accrual object. The system then creates period-based credit postings on this object. You can settle this object on a general ledger account, allowing you to identify any imbalances between the balances and the accruals.

Actions

Executing Accrual Calculation [Page 677]
Reversing Accrual Calculation [Page 680]
Accrual Calculations Using the Plan=Actual Method
Executing Accrual Calculations

Prerequisites

You can execute accrual calculations [Ext.] after you have defined an overhead structure [Ext.] and maintained the relevant data for this structure, or after you have maintained your target=actual credit postings.

You can simulate the accrual calculation for testing or forecasting purposes. To do so, select Test run on the initial screen.

This function lets you check the results of the accrual calculation without making any changes in the database.

Procedure

1. To carry out accrual calculation in plan or actual, from the Cost Center Accounting menu, choose:
   a. Planning → Planning aids → Accrual calculation or
   b. Period-end closing → Single functions → Accrual calculation

2. On the initial screen, enter the fiscal year and the posting period.

   You can calculate accruals for an individual cost center [Ext.], a cost center group [Ext.], or the entire controlling area [Ext.]. A cost center group can be any group stored in the system. You may also use the standard hierarchy [Ext.] or selected parts thereof.

   When calculating plan accrual, also specify the version.

3. Select or deselect:
   a. Background processing
   b. Test run
   c. Detailed lists

   If you do not select Background processing, the system carries out accrual calculation online. The display shows the values calculated for the accrual cost elements. If you have large amounts of data to process, we advise running accrual calculation in the background. This means you can process data at times of minimal system usage.

   If the Detailed list indicator is active, the R/3 System displays a list of accrual calculation results. The Detailed list and Test run indicators are defaulted to active. This ensures that you can check the results of the test run.

4. You can enter further data on the initial screen as follows:
Executing Accrual Calculations

a. To set the value date for the actual accrual calculation manually, choose Extras → Value date.…
   If you do not enter a value date, the system converts the currencies using the last day of the posting period.

b. To change the controlling area, choose Extras → Set controlling area.
   • This controlling area is then stored for all following activities (see: Selecting and Displaying the Current Controlling Area [Ext.])

c. To maintain the user parameters, choose Environment → User parameters.
   i. To store the values that you specified on the initial screen as user parameters, activate the corresponding parameters and choose Save.
      This saves the current user parameter setup as a default.
   ii. To change your entries on the initial screen and to have these new values stored in your user parameters, you must re-save the parameters.

d. To display the controlling area → overhead structure assignments, choose Goto → Assignments…

e. Once you have executed the accrual calculation, you can display any errors that occurred and the processing statistics by choosing Goto → Statistics.

5. Choose Execute.

Result

• You can access the most important information about the accrual calculation [Ext.] when you have finished processing.
   In the results list screen, choose Goto → Messages or Statistics.

• Choose Starting values to check which data was used to begin the calculation.

• Choose Goto → Statistics to call up a log of the postings made by the system.

• You can use the information system to display the controlling area, cost center, or line item reports.

• You can also call up these functions from the detailed lists.
   The detail lists display the values calculated by cost center/activity type/allocation cost element.

• You can branch to the detail screen for the percentage method and analyze the values (such as base cost elements and overhead rates) in more detail.

The R/3 System records sender and receiver line items and totals records for accrual postings. The posting date of actual accrual is always the last day of a calendar month. The posting date of plan accrual is always the first day of a calendar month.

If you repeat the calculation, the system records one line item each detailing the difference between the previous and the current run.
Reversing Accrual Calculations

Use

If you want to reverse an accrual calculation [Ext.], the system resets the target=actual credit postings and the accrual overhead rates.

Procedure

1. To reverse accrual calculation in plan or actual, from the Cost Center Accounting menu, choose:
   - Planning → Planning aids → Accrual calculation, or
   - Period-end closing → Single functions → Accrual calculation
   You can reverse accrual calculations for:
   a) A given cost center
   b) A cost center group
   c) All cost centers in a controlling area
   d) A given version (in plan accrual calculation)
   e) A given period in a fiscal year
2. Select or deselect the indicators under Processing.
   For more information on these indicators, see Executing Accrual Calculations [Page 377].
3. Choose Accrual calculation → Reverse.
4. Once the reversal is over, the system displays an overview of the reversal process, including the number of objects processed, error log, and so on).
Special Functions for Accrual Calculation

Use

You can use the following special functions during accrual calculation [Ext.]:

Assigning Overhead/Dependencies [Page 682]
Defining Condition Tables [Page 684]
Defining Custom Dependencies [Page 687]
Where-Used List for Accrual Calculations [Page 690]
Defining Time-Based Overhead Structures and Accrual Calculation Data [Page 691]
Defining Multiple Overhead Structures in One Controlling Area [Page 693]
Cost Center Accounting (CO-OM-CCA)  SAP AG

Dependencies

Dependencies

Use

When you create an overhead rate (during overhead structure [Ext.] definition), you must assign a dependency to the overhead rate. You use dependencies to determine the overhead percentages used for the cost centers participating in accrual calculation [Ext.]. The overhead rates are stored according to various criteria (for example, cost center category [Ext.], business area [Ext.] or company code [Ext.]).

Note that changing the assignment between overhead rate and dependency can lead to inconsistent data.

Features

You can define single-level and double-level dependencies. Single-level means that only one criterion determines how to calculate the overhead rate.

Double-level means that two criteria in combination determine the rate. The R/3 System checks first whether overhead rates already exist that satisfy the first criterion. Depending on the results of the first step, the R/3 System searches for overhead rates that match the second criterion.

You want to calculate accrual for non-wage labor costs on all the firm’s cost centers; however, the costs for special insurance payments apply only to the production cost centers. To accrue the non-wage labor costs, you define an overhead rate with the dependency Controlling area; to accrue the insurance costs, you define a rate with the dependency Cost center/controlling area. This allows you to use special overhead rates for the production cost centers.

Standard Dependencies

The standard R/3 System includes the following dependencies:

<table>
<thead>
<tr>
<th>Dependency</th>
<th>Assignment of Overhead Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>BKR1</td>
<td>By company code</td>
</tr>
<tr>
<td>BKR2</td>
<td>For an entire controlling area [Ext.], including special overhead rates for given company codes</td>
</tr>
<tr>
<td>BKS1</td>
<td>By cost center in a company code</td>
</tr>
<tr>
<td>BKS2</td>
<td>For an entire company code, including special overhead rates for given cost centers in a controlling area</td>
</tr>
<tr>
<td>GBR1</td>
<td>By business area</td>
</tr>
<tr>
<td>GBR2</td>
<td>For an entire controlling area, including special overhead rates for given business areas</td>
</tr>
<tr>
<td>GKS1</td>
<td>By cost center in a business area</td>
</tr>
</tbody>
</table>
The dependency names in the standard R/3 System are based on their structures. The single-level dependency names use the field abbreviation and the numeral 1; the names of the double-level dependencies use the field abbreviation and the numeral 2.

**Activities**

To display the standard dependencies in the SAP R/3 System, choose Environment → Extras → Dependencies in overhead rate maintenance.

When you create an overhead rate, select one of the dependencies listed above. If the standard R/3 System dependencies do not meet your particular requirements, you can create your own. To do so, you must create:

- Your own condition table definitions
- Your own dependency definitions

**See also:**

- Creating and Maintaining Condition Tables [Page 684]
- Defining Custom Dependencies [Page 687]
Creating and Maintaining Condition Tables

Use

Condition tables contain the master data fields on which the overhead rates depend. In the condition tables for cost center accrual calculation, you can use the following fields from the cost center master data record:

- Controlling Area [Ext.]
- Cost center [Ext.]
- Cost center category [Ext.]
- Company code [Ext.]
- Business area [Ext.]
- Overhead type (plan/actual)

You **must** use the controlling area and the overhead type.

The R/3 System includes the following standard tables:

<table>
<thead>
<tr>
<th>Short Text</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area/overhead type</td>
<td>027</td>
</tr>
<tr>
<td>Controlling area/overhead type/cost center</td>
<td>026</td>
</tr>
<tr>
<td>Controlling area/cost center category</td>
<td>058</td>
</tr>
<tr>
<td>Controlling area/cost center category/cost center</td>
<td>061</td>
</tr>
<tr>
<td>Controlling area/company code</td>
<td>059</td>
</tr>
<tr>
<td>Controlling area/company code/cost center</td>
<td>062</td>
</tr>
<tr>
<td>Controlling area/business area</td>
<td>060</td>
</tr>
<tr>
<td>Controlling area/business area/cost center</td>
<td>063</td>
</tr>
<tr>
<td>Controlling area/company code/business area</td>
<td>105</td>
</tr>
</tbody>
</table>

You can only use table numbers 500 to 999 for your custom condition tables. The numbers up to 499 are reserved for standard condition tables.

Procedure

Creating condition tables

1. To create new (custom) condition tables, in Cost Center Accounting, choose
   
   *Planning → Planning aids → Accrual calculation* or
   
   *Period-end closing → Single functions → Accrual calculation*
   
   The system displays the *Plan or Actual Accrual Calculation for Cost Centers* screen.
2. Choose Extras → Settings → Percentage method.
   The system displays the initial screen for maintaining cost center accrual calculation.

3. Choose Environment → Settings → Percentage method.
   The system displays the Maintain CO-OM Accrual Calculation: Overhead Structure - Overview screen.

4. Choose Environment → Extras → Condition tables
   The system displays the Create Condition Table for Cost Centers screen.

5. Enter a number for your condition table and choose Enter.
   Ensure that you adhere to the naming convention described above. You can also enter a standard condition table as a reference.
   The system displays the Create Condition Table for Cost Centers: Field Overview.

6. In the Field catalog group box, the system displays all available fields from the cost center master data.
   Select the fields you require (double-click). You can scroll down/up the list.
   The fields you select appear in the Selected fields group box.

7. To close the process, choose Condition → Generate.

Maintaining condition tables

1. To store values in your own condition tables, on the CO-OM Accrual Calculation: Assignments by Controlling Area screen, place your cursor on an overhead structure and choose Choose overhead structure.
   The system displays the CO-OM Accrual Calculation: Overhead Structure Detail screen.

2. Select the appropriate structure (double-click).
   The system displays Maintain CO-OM Accrual Calculation: Overhead Controlling Area/Overhead screen.
   You can select the overhead structures according to cost center category, overhead type (actual, plan) or the validity period. Choose Execute.

   In the following cases, the system displays an SD for maintenance of condition records in:

   • The dependency of the overhead contains customer-specific condition tables.
   • The dependency of the overhead contains combinations of condition tables that are not contained in the R/3 standard system.

3. In addition to the values selected by you, the system may also display other SD-specific fields in the table.
   Ignore the SD fields that you do not want to use.
Defining Custom Dependencies

Use

In dependencies, you define the sequence in which the R/3 System accesses condition tables.

You want to access the field sequence “Cost center/cost center category/controlling area”. This means, in the dependency, that the R/3 System first accesses table 26 (cost center), then table 58 (cost center category), and finally table 27 (controlling area).

You can use the Exclusive field to specify whether the system should access other tables once one table has been successfully processed.

Procedure

1. In Cost Center Accounting, choose:
   
   Planning → Planning aids → Accrual calculation or
   
   Period-end closing → Single functions → Accrual calculation
   
   The system displays the Plan or Actual Accrual Calculation for Cost Centers screen.

2. Choose Extras → Settings → Percentage method.
   
   The system displays the initial screen for maintaining cost center accrual calculation.
Defining Custom Dependencies

3. Choose Extras → Settings → Percentage method.
   The system displays the Maintain CO-OM Accrual Calculation: Overhead Structure - Overview screen.

4. To define your own dependencies, choose Environment → Extras → Dependencies.
   The system displays the Change Access Sequences screen.

5. In the navigation area, double-click on Access Sequences (= dependencies).
   i. Choose New entries.
   ii. Enter a key and a name for the access sequence.

6. Select a dependency and, in the navigation tree, double-click on Accesses (= condition tables).
   i. Choose New entries.
   ii. Specify a consecutive number.
      This number controls the sequence with which the system accesses the individual tables.
   iii. Enter the table to be accessed.
      Do not make an entry in the Conditions field.
   iv. To prevent the system from accessing further tables following successful processing, select the Exclusive indicator for the corresponding table.
      In the standard system, this indicator is always set for the first table.

7. Select a condition table and, in the navigation tree, double-click on Fields.
   i. The system enters data in the appropriate fields of the selected condition table.
   ii. For each table field, enter a document field.
      To do so, select Field catalog and double-click on the document field(s) you require.
      The name of the table field is the same as that of the document field. The system proposes this name for the document field.

8. Save your entries.

See also

Dependencies: Examples [Ext.]
Where-Used List for Accrual Calculations

Use
Within accrual maintenance, you can display and change the use of all objects defined for accrual calculation [Ext.] (overhead structures, calculation bases, overhead rates, credit objects, and accrual cost elements).

Features
The use is differentiated according to the following criteria:

- **Overhead Structure [Ext.]**
  - In which overhead structure does the calculation base, overhead rate, or credit posting appear?

- **Controlling Area [Ext.]**
  - To which controlling areas are overhead structures assigned?
  - What controlling area dependent data is maintained for the calculation bases, overhead structures, or credit postings?

To view the information for individual objects, choose *Used in.*
Time Dependency of Accrual Calculation

Use

You can define the overhead structures [Ext.] and the accrual data [Ext.] for given validity periods.

- The assignment of an overhead structure to a controlling area [Ext.] is valid for the defined posting periods.

Until now you have used only the target=actual method for accrual calculation. As of fiscal year 1996 you wish to calculate additional accruals with the percentage method. You define the corresponding overhead structure and the actual/plan assignments for the periods 001/1996 to 012/1999. If you wish to assign still another overhead structure as of 1998, you must limit the first assignment to periods 001/1996 to 012/1997 and assign the new structure to take effect as of period 001/1998.

- The overhead rates are valid for the given time periods. If system maintenance reveals overlaps with existing intervals, the system automatically subdivides these intervals. You can define different validity periods for plan and for actual rates. The system display compares these with one another. During posting, the system also combines rows that have the same contents.

You have set a plan rate of 10% for all of 1996. You set the following percentage rates in the actual:

<table>
<thead>
<tr>
<th>Period</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>001/1996 to 003/1996</td>
<td>10 %</td>
</tr>
<tr>
<td>004/1996 to 004/1996</td>
<td>12 %</td>
</tr>
<tr>
<td>005/1996 to 005/1996</td>
<td>10 %</td>
</tr>
<tr>
<td>006/1996 to 006/1996</td>
<td></td>
</tr>
<tr>
<td>007/1996 to 012/1996</td>
<td>15 %</td>
</tr>
</tbody>
</table>

If you enter 12% in actual for May and June, nothing will change for the plan rate (10% for all of 1996).

In June, the system merges the rates for April and May and extends them into June. This results in the following in actual.

<table>
<thead>
<tr>
<th>Period</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>001/1996 to 003/1996</td>
<td>10 %</td>
</tr>
<tr>
<td>004/1996 to 006/1996</td>
<td>12 %</td>
</tr>
<tr>
<td>007/1996 to 012/1996</td>
<td>15 %</td>
</tr>
</tbody>
</table>

The system stores overhead rates internally with the date. When you execute accrual calculation, planning transactions use the first day of the period and actual transactions the last day when referring to the data. For the “valid as of” date, the
First day of the accrual calculation period or the last day of the “to” period is updated and displayed in the where-used record.

- **Credit objects** are valid to a specified date.

Up to the end of 1995, secondary wage costs are calculated for accrual on the cost center “Accrual Calculation, Non-Wage Labor Costs”. As of 1996, you want to use an order instead of a cost center.

<table>
<thead>
<tr>
<th>Time period</th>
<th>Cost element</th>
<th>Cost center</th>
<th>Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>012/1995</td>
<td>434.000</td>
<td>ABG-LNK</td>
<td></td>
</tr>
<tr>
<td>012/1999</td>
<td>434.000</td>
<td>9A00-LNK</td>
<td></td>
</tr>
</tbody>
</table>

Credit objects differentiated according to business area have priority over undifferentiated ones.

<table>
<thead>
<tr>
<th>CCode</th>
<th>BArea</th>
<th>To period</th>
<th>CElm</th>
<th>CCtr</th>
<th>Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>0001</td>
<td>0100</td>
<td>012/1995</td>
<td>434.000</td>
<td>ABG-LNK</td>
<td></td>
</tr>
<tr>
<td>0001</td>
<td>0100</td>
<td>012/1996</td>
<td>434.000</td>
<td>9A00-LNK</td>
<td></td>
</tr>
<tr>
<td>0001</td>
<td>0100</td>
<td>012/1996</td>
<td>434.000</td>
<td>ABG-LNK</td>
<td></td>
</tr>
</tbody>
</table>

Cost center ABG-LNK is used for business area 0100 until the end of 1996, and order 9A00-LNK as of the beginning of 1997. The same order was also used for other business areas in 1996.
Definition of Multiple Overhead Structures for One Controlling Area

Use

As a rule, you can assign only one Overhead Structure \([\text{Ext.}]\) to each Controlling Area \([\text{Ext.}]\). In practice, Accrual Calculations \([\text{Ext.}]\) are required for different areas, and these must be supported by different overhead structures. In the Cost Center Accounting component (CO-OM-CCA), you can set up multiple substructures within a main overhead structure.

Subordinate Overhead Structures

<table>
<thead>
<tr>
<th>From Level</th>
<th>To Level</th>
<th>Allocations</th>
</tr>
</thead>
<tbody>
<tr>
<td>010</td>
<td></td>
<td>Labor costs 200.000</td>
</tr>
<tr>
<td>020</td>
<td>010</td>
<td>Vacation bonus 20.000</td>
</tr>
<tr>
<td></td>
<td>010</td>
<td>10% on top of labor costs</td>
</tr>
<tr>
<td>030</td>
<td>010</td>
<td>Holiday bonus 20.000</td>
</tr>
<tr>
<td></td>
<td>010</td>
<td>10% on top of labor costs</td>
</tr>
<tr>
<td>040</td>
<td>010</td>
<td>Annual bonus 10.000</td>
</tr>
<tr>
<td></td>
<td>010</td>
<td>5% on top of labor costs</td>
</tr>
<tr>
<td>110</td>
<td></td>
<td>Motor pool costs 100.000</td>
</tr>
<tr>
<td>120</td>
<td>110</td>
<td>Motor pool insurance 60.000</td>
</tr>
<tr>
<td></td>
<td>110</td>
<td>(60% on top of motor pool costs)</td>
</tr>
<tr>
<td>130</td>
<td>110</td>
<td>Motor pool repair costs 40.000</td>
</tr>
<tr>
<td></td>
<td>110</td>
<td>(40% on top of motor pool costs)</td>
</tr>
</tbody>
</table>

Accrual of non-wage labor costs is calculated in rows 010 to 040; The vacation and holiday bonuses are assigned to a common accrual object, and the annual bonus to a different object.

Accrual of insurance and repair costs are calculated for the company's motor pool in rows 110 to 130, and the accrual is also posted to a separate credit object.
Transfer of Statistical Key Figures from the Logistics Information System (LIS)

Use
You can transfer key figures from the Logistics Information System (LIS) to Cost Center Accounting as statistical key figures [Ext.].

Prerequisites
The requirements include:

- The LIS is active and the Logistics components (LO) feed data to the LIS database.
- You must create statistical key figures in the Controlling component, such as number of invoice verifications, and created the corresponding key figure link to the LIS [Page 165]. In the master data, specify the LIS statistical key figure to be transferred, such as Number of invoices (S012 - ALFPP).
- You have maintained the assignment of one or more statistical key figures to the relevant objects in Customizing or by choosing Assignment → Maintain, for example, by specifying the version and the fiscal year.
- You have entered a variant that uses an assortment of parameters to delimit the values to be taken from the LIS.

For more information about these Customizing settings, see the Implementation Guide (IMG) for Cost Center Accounting, under:

- Planning → R/3 Internal Plan Data Transfer → Statistical Key Figure Transfer from LIS → Maintain Cost Center / Key Figure Assignment [Ext.] or Maintain Activity Type / Key Figure Assignment [Ext.]
- Actual Postings → R/3 Internal Actual Data Transfer → Statistical Key Figures from LIS → Maintain Cost Center / Key Figure Assignment [Ext.] or Maintain Activity Type / Key Figure Assignment [Ext.]

Features
You can transfer statistical key figures as follows:

- **Activity-independent** on a cost center [Ext.], cost center group [Ext.] or on all cost centers of a controlling area [Ext.]
- **Activity-dependent** on a cost center, cost center group or on all costs centers of a controlling area, dependent on an activity type [Ext.], activity type group [Ext.] or on all activity types of a controlling area.

To transfer the number of invoice receipts for the cost centers of Accounts Payable.

- Cost center 1 processes customers "A" through "K" and cost center 2 processes customers "L" through "Z".
Transfer of Statistical Key Figures from the Logistics Information System (LIS)

- The R/3 System transfers only the invoice receipts for customers "A" through "K" to cost center 1. (The same applies to cost center 2.)
- A transfer transaction brings the key figures from the LIS. They are posted as statistical key figures on the cost centers.
- You can use this data as a tracing factor for periodic allocations. The R/3 System can then allocate data processing costs to cost centers 1 and 2 based on the statistical key figures.
  You can display the statistical key figures in the information system.
Transferring Statistical Key Figures

Prerequisites
You have created the necessary statistical key figures [Ext.] and linked them to the Logistics Information System (LIS). You have assigned the cost center and key figure(s), along with the variant, in Customizing or by choosing Assignments → Maintain.

Procedure
1. Choose Planning → Planning aids → Transfers → Activity-dependent (or independent) statistical key figures, LIS, or
   
   Period-end closing → Single functions → Transfers → Activity-dependent (or independent) statistical key figures, LIS

2. To transfer actual data from a previous fiscal year and use it as your current plan data, choose LIS reference.
   
   Enter a reference version and a fiscal year.

3. You must specify the following parameters:
   - Version
   - Period
   - Fiscal year

4. Select or deselect:
   - Reset and overwrite
   - Do not change

5. If required, select the processing parameters:
   - Background processing
   - Test run
   - Detail lists

6. Start the transfer by choosing Execute.

Result
After posting the data, you can display the data as statistical key figures on the objects.

You can enter or transfer statistical key figures on the following objects:

- Cost centers [Ext.]
- Cost center/Activity type [Ext.]
- Business process [Ext.] (only if you are using Activity-Based Costing)
- Cost object [Ext.]
Overheads

Purpose
You use overhead costing to allocate overhead through percentage-based or quantity-based overhead rates. The basis for the allocation are the primary cost elements that you post as overhead costs. In the manufacturing industry, for example, these are usually the labor and material costs.

Integration
To make an overhead costing, you need to define control data in customizing for the corresponding application, and include this in a Costing sheet [Page 704].

Features
You can apply overhead to both plan and actual costs, or on the basis of commitment data.

Business processes do not use commitments.
If you debit a cost center with overhead rates, then they also apply to all the activity types in this cost center.

You can make an overhead costing:

- For one or several objects
- Without updating the calculated overheads, for test and forecasting purposes

Constraints
You start Overhead Calculation [Page 699] using its own transaction. This means that you cannot carry out transaction-based overhead calculation.
Calculating Overheads

Use

You can allocate overheads using percentage-based or quantity-based overhead rates for plan or actual data, alternatively you can use commitments data.

Prerequisites

To make an overhead costing [Ext.], you need to define control data during customizing and include this in a costing sheet [Page 704].

Features

You can calculate overhead for single or multiple objects. Collective processing is based on selection variants that are individually definable.

You can start overhead costing for test and forecast purposes without updating the overhead calculation. The system then calculates the overhead, without you having to update the object (such as, internal order, cost center, business process). This enables you to identify and correct any errors before the actual calculation (such as, an invalid overhead costing sheet in the master data, or missing percentage rates).

You can run overhead costing online or in the background without a display.

The following reports are also available for overhead calculation:

- RKAZCO43: Overhead: Manufacturing orders and Product cost collectors
- RKAZKJPJ: Cost object hierarchy, general cost objects
- RKAZVA44: Actual overhead: Sales orders
- RKAZKSI4: Actual overhead: Cost centers incl. activity types
- RKAZCPZI: Actual overhead: Business processes
- RKAZKGI4: Actual overhead: Internal and maintenance orders
- RKAZCJ45: Actual overhead: Projects/WBS elements/Networks
- RKAZKSP4: Planned overhead: Cost centers including activity types
- RKAZCPZP: Planned overhead: Business processes
- RKAZKGP4: Planned overhead: Internal and maintenance orders
- RKAZCJ47: Planned overhead: Projects/WBS elements/Networks
- RKAZKSO9: Commitment overhead: Cost centers including activity types
- RKAZKGO4: Commitment overhead: Internal and maintenance orders
- RKAZCJO9: Commitment overhead: Projects/WBS elements/Networks

You can use the dialog display to check the overheads that the system calculates based on the costing sheet.
Calculating Overheads

You can create an overhead costing as often as required for each period. If any of the object values (for example, internal order, cost center, business process), or overhead costing values change themselves, the system updates the difference (can be a positive or a negative value).

Date Determination

The system determines the date during overhead costing as follows:

- **Posting date:**
  - *Plan processing of line items:* First day of the period
  - *Actual processing:* Last day of the period
    You can enter a posting date for overhead calculation. However, the posting date must be within the period for which you are calculating the overhead.
    To enter the posting date, choose *Accounting → Controlling → Internal orders → Period-End Closing → Single functions → Overhead rates → Actuals - individual processing → Extras → Posting date.*
    
  - *Commitments:* The system does not write any line items

- **Document date:**
  Today’s date

- **Overhead calculation:**
  With posting date

- **Currency translation:**
  - *Actual:* With the entered value date, otherwise posting date
  - *Planning data:* With the entered value date, otherwise with the value entered in the version for planning data in Customizing under *Controlling → Internal Orders → Planning → Basic Settings → Maintain Versions → Maintain Settings of Version in Controlling Area → Settings by Fiscal Year → Details → Tab Page: Planning → Currency translation.*

Results List and Error Log

The system displays the results of the overhead calculation in a list for all objects, for which it has determined values. This list contains the following information:

- **Basic list** with information on current processing and number of objects processed.
- **Detailed list** with the amounts for each sender and receiver when you enter the credit cost element. If you already performed the overhead costing for the given period, the system only displays variances from the overhead already costed.
- **Period drilldown** in the planning data, should the overhead costing or simulation occur over several periods.

If errors occur during processing, the system refers you to an error log that contains an error listing.

You can print both the results list and the error log.
Activities

Enter the costing sheet required for overhead costing in your object (such as a cost center, business process, internal order, project or costing reference object).

To calculate the overhead rates, choose Accounting → Controlling → Internal orders → Period-End Closing → Single Functions → Overhead Rates → Actuals - Individual Processing.

- To run the overhead calculation in the background without a display, select Background processing.
- To simulate the overhead calculation, choose Test run.
- To check overhead calculations using the costing sheet, select Dialog display.

⚠️ The dialog display always shows the current data from the database, even if the system updated them already. The Detail list shows whether the data were updated already.

The Detail list only displays differences to the overheads already updated. If the overhead is already updated, the Dialog display shows the results of the overhead calculation, and the Detail list is empty. No dialog display is issued for a reversal.

- To create a worklist for objects that do not have overhead applied to them, select Worklist (in Collective processing).

✅ If the credit object is an internal order, you need to deactivate the partner update and avoid settling the credit orders, as this enables you to avoid performance problems.

The system will only contain plan overheads for projects and WBS elements in individual or collective processing for one more fiscal year only. If the overhead is to be applied for more than one fiscal year, you need to calculate overhead separately for each fiscal year. This is the only way that you can guarantee an update to the profit center and the special purpose ledger. You do not need to enter a To-fiscal year.
Validity Periods for Master Data

Overhead costs are only applied to cost centers and business processes if valid master data exists in the processing period for the overhead calculation.

The processing period consists of:

- In the **actual**: One period of a fiscal year
- In the **plan**: One period or period interval of a fiscal year
- In **commitments**: All periods

Note the following during overhead calculation:

- If you want to apply overhead to a cost center or a business process in the **actual**, the cost center or the business process must be defined at least on the **last day** of the period for which you are executing the overhead calculation.

- If you want to apply overhead to a cost center or a business process in the **plan**, the cost center or the business process must be defined at least on the **first day** of the period for which you are executing the overhead calculation.

- If you apply overhead to a cost center as a **commitment**, the R/3 System executes the overhead calculation in all periods in which the cost center is defined on at least one day.

If no valid master data exists for the cost center or the business process in the entire processing period, the R/3 System issues an error message.

If, however, the above-mentioned conditions are met for at least one period of the processing period, the system does not issue an error message.

You want to carry out overhead calculation in the plan for periods 1 to 6 (= January to June).

If the cost center is defined as of 1 July, the R/3 System does not apply overhead to it. The system issues an error message.

If the cost center is defined from 1 Jan to 31 March, the R/3 System applies overhead to this cost center in the plan for periods 1 to 3. The system does not issue an error message.

If the cost center is defined from 1 Jan to 2 June, the R/3 System applies overhead to this cost center in the plan for periods 2 to 6. The system does not issue an error message.

- A cost center is defined on 15 Jan. The R/3 System should apply overhead to the cost center in period 1 of the plan, actual and commitments.

  In the plan you get an error message, because the cost center is not defined on 1 Jan.

  In the actual you get an error message, because the cost center is not defined on 31 Jan.

  In the commitments, the R/3 System executes the overhead calculation.
• A cost center is defined on 15 Jan. and on 1 Feb. The R/3 System should apply overhead to the cost center in period 1 and 2 of the plan and commitments. In the plan, the overhead calculation is only executed in period 2, because the cost center is defined on 1 Feb., but not on 1 Jan. No error message is issued by the R/3 System. In the commitments, the overhead calculation is executed in periods 1 and 2.
Costing Sheet

Definition

The costing sheet combines all parts of the overhead costing, and determines the rules for calculating the values to be posted.

Structure

The costing sheet links the control data for the overhead costing.
• **Calculation Base**

This defines the primary cost elements to which a particular overhead is to be applied.

This represents a group of cost elements to which you want to apply overhead. For each controlling area, you can assign individual cost elements or cost element intervals and individual origins as well as origin intervals to the calculation bases.

• **Overhead**

The overhead rate determines to what extent the percentage-based or quantity-based overhead rate should be applied to the direct costs. It also specifies under which conditions (dependencies) the overhead rate is to be applied. For example, you can calculate a defined overhead rate for each plant by specifying a plant dependency.

• **Credit**

A credit specifies the credit object and the credit cost element.

If an object in actual data is debited with overhead, then another object (such as, a cost center, or order) is credited at the same time. You allocate the overhead using a special overhead cost element (category 41).

Only debits are posted in commitments (no credits).

A costing sheet comprises multiple rows that are processed from top to bottom during the overhead calculation.

• **Base Rows**

You define these by assigning a calculation base, so that they contain the direct costs that are to have overhead applied to them during the overhead costing.

• **Overhead Rows**

These are defined by the assignment of an overhead rate.

An overhead row consists of a base row or a totals row. The overhead amount is calculated by multiplying the amount contained in these rows by the overhead percentage rate or quantity-based overhead rate determined through the overhead rates.
Costing Sheet

As well as overheads, the overhead rows contain credit keys. These credit keys determine which object (such as a cost center or order) is to be credited under which cost element during overhead rate determination.

- **Totals Rows**
  
  Totals rows are used to generate subtotals or final totals.

**See also:**

[Calculating Overhead](Page 699)
Periodic Allocations

Use

In Distribution [Ext.] and Assessment [Ext.], you further allocate costs (or quantities for Indirect Activity Allocations [Ext.]) collected on a cost center during the accounting period to receivers, according to user-defined keys. These are therefore indirect allocation methods, because the exchange of activity is not the basis for allocating costs/quantities. Instead, user-defined keys such as percentage rates, amounts, statistical key figures, or posted amounts provide the cost/quantity assignment basis.

The advantage of these methods is that they are easy to use. You usually define the keys and the sender/receiver relationships only once.

Distribution and assessment are used primarily for cost centers. This is because direct cost allocation is not possible here due to the variety of transactions, the lack of clearly defined individual activity types and the fact that the entry of the activity is too time-consuming. For example, the costs of the company cafeteria may be assigned based on the number of employees in each cost center. Telephone costs are seldom allocated directly to the individual cost centers, but are collected on a clearing cost center for each period. They are then reposted or distributed at the end of the period according to the number of telephone units or telephone installations in each cost center.

In Target=actual activity allocation the system determines the actual activity quantities to be allocated, based on the plan activity inputs of the receiver, and taking into account the operating rate of the receiver.

Prerequisites

Allocations are carried out at the period end (during period-end closing) and draw upon predefined parameters (keys, sender-receiver relationships).

You can use different currencies for the periodic allocations. To do this, you must have selected All currencies during controlling area maintenance.

The currencies are converted using the translation rates you entered in Customizing when configuring the system (see also: Currency Definition [Ext.]).

The value date determines which currency translation rate is used for the currency conversion. If you do not enter a value date, the system estimates the most accurate translation rate for the period.

If you are working with Transfer Prices [Ext.] (parallel value flows) distribution and assessment are executed in parallel in all valuations. The costs to be allocated are taken from the corresponding valuation. The tracing factor is always taken from the operational valuation. The values allocated may differ in the different valuation methods.

Senders and receivers are displayed in the results list, differentiated according to the parallel actual versions of the various valuations.

For more information about transfer prices, see the SAP Library under Financials → Enterprise Controlling → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
Periodic Allocations

- Financials → CO - Controlling → Overhead Cost Controlling → Overhead Cost Controlling → Multiple Valuations [Ext.].
Distribution

Use

Distribution [Ext.] is used to allocate the primary costs of a cost center. The following information is passed on to the receivers:

- The original cost element (that is, the primary cost element [Ext.]) is retained.
- Sender and receiver information (for example, the identities of the sender and receiver cost center/business process) is documented using line items in the CO document.

You can use the information system to analyze the distribution results according to sender and receiver relationships.

See also:
- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Assessment

Use

**Assessment [Ext.]** is a method of allocating primary and secondary costs in Cost Center Accounting and Activity-Based Costing. The following information is passed on to the receivers:

- The original cost elements are assigned cumulatively, or in groups, to assessment (secondary) cost elements. The original cost elements are not recorded on the receivers.

- Sender and receiver information (sender cost center, receiver cost center, or business process) appears in the Controlling (CO) document.

Allocation through assessment is useful when the composition of the costs is unimportant for the receiver. For example, the assessment of cafeteria costs to a cost center need not be broken down further.

You can use the information system to analyze the assessment results by assessment cost element according to sender and receiver relationships.

In **periodic reposting [Ext.], distribution [Ext.],** and assessment, the system writes line items for each sender and receiver. You cannot restrict this process. You can reverse the line items if you repeat the periodic allocation within a given period. The posting date of the actual allocation is always the last day of a calendar month. The posting date of the plan allocation is always the first day of a calendar month.

You cannot allocate consumption quantities using assessment. To allocate activity quantities, you must use indirect activity allocation.

Features

For allocations using assessment, you can summarize all the cost elements into one **assessment cost element [Ext.]**. When you carry out the assessment, the system allocates all the costs to be allocated from the sender using this cost element. However, this method does not store any information on the receiver, regarding the composition of the costs.

Alternatively, you can use an **allocation structure [Ext.]** to define which cost elements are to be allocated under which assessment cost elements. You can assign individual cost elements, cost element groups or intervals to an assessment cost element. The allocation structure can be stored during segment maintenance.

Until now, if you wanted information regarding the composition of costs at a summarized level, you needed to create a large number of segments. These segments only differed in the assignment of the allocation cost elements to the assessment cost elements. Allocation structures enable you to reduce maintenance and the runtime of the cycle.
Company A has 10 subsidiaries in Germany. The primary costs of each subsidiary are to be allocated at period end using its own assessment cost element. Cost centers are summarized across all the subsidiaries (for example, all cafeterias of the subsidiaries). However, although the sender and receiver remain the same, an individual assessment cost element is to be used for each subsidiary.

Until now, you needed to create a corresponding segment for each cost element that was assigned to an individual assessment cost element.

<table>
<thead>
<tr>
<th>Segment</th>
<th>Sender</th>
<th>Receiver</th>
<th>Cost element</th>
<th>Assessment cost element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment 1</td>
<td>Cost center 3500 Purchasing</td>
<td>Cost center 3600 Cafeteria</td>
<td>Cost element 415000</td>
<td>Assessment cost element 510000</td>
</tr>
<tr>
<td>Segment 2</td>
<td>Cost center 3500 Purchasing</td>
<td>Cost center 3600 Cafeteria</td>
<td>Cost element 430000</td>
<td>Assessment cost element 520000</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

You can now summarize the primary cost elements 415000, 430000 in an allocation structure, as well as their assignments to assessment cost elements. This reduces the number of segments required.

<table>
<thead>
<tr>
<th>Segment</th>
<th>Sender</th>
<th>Receiver</th>
<th>Allocation structure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment 1</td>
<td>Cost center 3500 Purchasing</td>
<td>Cost center 3600 Cafeteria</td>
<td>Allocation structure A1 (415000 → 510000 430000 → 520000 ... →... )</td>
</tr>
</tbody>
</table>

For more information, see the Implementation Guide (IMG) for Cost Center Accounting or Activity-Based Costing, under Actual Postings → Period End Closing → Assessment → Create Assessment Cost Elements [Ext.] or Maintain Allocation Templates [Ext.] or under Planning → Allocations → Assessment → Create Assessment Cost Elements [Ext.] or. Maintain Allocation Structures [Ext.].

See also:

- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Processing Cycles [Page 763]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Indirect Activity Allocation

Use

You can use indirect activity allocations [Ext.] to automatically allocate planned and actual activities.

You can specify keys to allocate activity, which is not possible when you use manual activity input in the plan or actual activity allocation. In addition, if calculating the sender activity quantities involves too much time or expense, the R/3 System can determine the activity quantity inversely based on the activity of the receivers.

If you execute indirect activity allocation without completing planning for the combination cost center/activity type, you must activate the actual price indicator in the activity type master data.

A special type of indirect activity allocation for actual allocation is the plan=actual activity allocation [Page 720]. Differenct than other types of indirect activity allocation, the plan=actual activity allocation allows for a multiple level activity network to be determined iteritavely with the operating rate as the tracing factor.

Features

You can choose between two methods of indirect activity allocation, depending on the activity types [Ext.] category. These methods are determined for each segment and can be combined in one cycle.

Activity quantities can be determined on the sender object

For certain activity types you can determine the total activity quantity for each sender. These are category 3 activity types, Manual entry, indirect allocation.

Using indirect activity allocation, these posted activity quantities are distributed by the senders among the receivers defined in the segment according to their allocation bases [Ext.]. The corresponding segment must use the sender rule Posted quantities. Any receiver rule can be used, with the exception of Fixed quantities (see: Sender and Receiver Rules for Periodic Repostings/Allocations [Page 751]).
The Quality control cost center uses 1000 hours of the Testing activity type. This cost center provides activity for the cost centers Goods receipt and Finished products. Allocations are made on the basis of the tracing factor Number of test items (TI). These are 4000 items for the Goods receipt cost center and 6000 items for Finished products. This corresponds to an activity input of 400 hours for Goods receipt and 600 hours for Finished products.

The price per activity unit for the Quality control cost center is 50 USD/hr. This results in activity output costs of 50,000 USD. The receiver cost centers are debited with the following costs based on the tracing factor TI.

Goods receipt: \( \frac{50,000 \text{ USD} \times 4000 \text{ TI}}{10,000 \text{ TI}} = 20,000 \text{ USD} \)

Finished products: \( \frac{50,000 \text{ USD} \times 6000 \text{ TI}}{10,000 \text{ TI}} = 30,000 \text{ USD} \)

**Activity quantities can be determined for each sender, but only with great difficulty**

In this case, the R/3 System determines the activity quantity based:

- Either on receiver tracing factors with weighting factors, which can be defined for each sender
  
  If you use the sender rule *Inversely determined quantities*, you define the weighting factors described above by choosing *Sender values*.

- Or through Fixed quantity values, which you define in segment definition.
  
  If you use the sender rule *Fixed quantities*, you define the fixed activity quantity by choosing *Sender values*.

These activity types belong to category 2 (Indirect entry, indirect allocation).
Indirect Activity Allocation

The corresponding segment can use the following combinations of sender and receiver rules:

<table>
<thead>
<tr>
<th>Sender rule</th>
<th>Receiver rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inversely determined quantity</td>
<td>Any</td>
</tr>
<tr>
<td>Fixed quantity</td>
<td>Any</td>
</tr>
</tbody>
</table>

(see: Sender and Receiver Rules for Periodic Repostings or Periodic Allocations [Page 751]).

Cost Center
Quality Control

**Tester hours**
- Weighting factor: 0.4 hrs/piece
- Inversely determined activity quantity
  \[(4000 + 6000) \times 0.4 \text{ h/piece} = 4000 \text{hrs}\]
- Price: 5 USD/hr
- Credit: 4000 hrs x 5 USD/hr
  \[= 20,000 \text{ USD}\]

In the example, you calculate activities for the sender using the receiver tracing factors with weighting factors, which are to be defined for the sender. The sender rules here are **inversely determined quantities**. You can use any receiver rule.

The receiver tracing factors are:
- Goods receipt: 4000 test items
- Finished products: 6000 test items

You need 0.4 hour to check one item using the *Quality control* cost center. The sender rule defines a weighting factor of 0.4 for the *Test* activity type.

This results in an activity input of 1600 hours on the *Goods receipt* cost center and 2400 hours on *Finished products*.

The *Test* activity is valuated with a price of 5 USD/hr. This results in a credit to the sender of 20,000 USD and debits of 8,000 USD to *Goods receipt* and 12,000 USD to the *Finished products* cost center.
Indirect Activity Allocation

If you are working with transfer prices (parallel value flows), the indirect activity allocations are carried out in the leading valuation. The plan price used for allocation thus applies to all the valuations.

For more information on transfer prices, see the SAP Library

- Financial → EC Enterprice Controlling → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
- Financials → CO - Controlling → Overhead Controlling → Overhead Controlling → Multiple Valuations [Ext.]

See also:

- Defining Periodic Repostings or Periodic Allocations [Page 747]
- Creating or Changing Cycles [Page 770]
- Executing Periodic Repostings or Periodic Allocations Online [Page 801]
- Displaying the Cycle Overview [Page 773]
Senders and Receivers for Indirect Activity Allocation

Use

Sender

Senders of indirect activity allocation in the actual and plan are always cost objects of the category Cost center [Ext.]/Activity type [Ext.]. In a segment you can also activity types of category 2 (indirect entry, indirect allocation) or category 3 (manual entry, indirect allocation).

You do not always have to adopt the value of the activity type category from the activity type master. This value is only a default value, which you can overwrite in the activity type planning for each version and each fiscal year (see: Activity Type Category [Page 148]).

Receiver

As with manual activity allocation, Receivers in actual indirect activity allocation can be any cost object (cost centers, orders, projects, business processes, or Real Estate Objects [Ext.]).

You can use any true CO objects, with the exception of profitability segments, as receivers for indirect activity allocation in the plan (see Account Assignment for Controlling Objects [Ext.]). Cost center/activity type categories, however, can not be grouped with other receiver object types in the same segment.

Cost center/activity type combinations are created by the system during activity type planning.

If the receiver of the activity allocation is a cost object (such as a production order or a product cost collector), the price used for the valuation is based on the valuation variant that is connected to the cost object via the calculation variant for the current calculation. If the receiving cost object is not connected to a calculation variant for the current calculation, the plan price for the period is used for the valuation.

Prerequisites

You have carried out activity type planning [Page 208] for all category 3 activity types for all senders of the category cost center/activity type, if you are using the Posted quantities rule.

You can only plan activity quantities using activity type planning for category 3 activity types. For activity types of category 2, this field is not ready-for-input in activity type planning. This is because the system determines the activity quantities inversely from the receiver tracing factors or using fixed quantities. In this case, the system automatically determines the corresponding planning record of cost center/activity type.
Senders and Receivers for Indirect Activity Allocation

Activities

If you have already carried out activity type planning or internal activity allocation [Ext.], the SAP system checks whether the activity type category matches the segment definition.

If you have not carried out activity type planning or internal activity allocation, you specify the sender activity type (activity type category 2 or 3) through the sender rule. This specification is not dependent on the default value stored in the activity type master record.

- Activity type category is 1 (manual entry, manual allocation):
  In this case, no indirect activity allocation is possible.

- Activity type category is 2 (indirect determination, indirect allocation):
  In this case, the segment definition can include the following combinations of sender and receiver rules:

<table>
<thead>
<tr>
<th>Sender rule</th>
<th>Receiver rule</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Inversely determined quantity</em></td>
<td>Any</td>
</tr>
<tr>
<td><em>Fixed quantity</em></td>
<td>Any</td>
</tr>
</tbody>
</table>

- Activity type category is 3 (manual entry, indirect allocation):
  The segment definition must include the sender rule *Posted quantities* and any receiver rule except *Fixed quantities*. 
Valuating Activity Quantities

Use

Indirect Activity Allocation in the Actual

For actual indirect activity allocation [Ext.], all quantities are posted as total quantities. The quantity is split into fixed and variable portions using actual cost splitting (see: Actual Cost Splitting [Page 868]).

You are using indirect activity allocation in the actual together with predistribution of fixed costs [Ext.], and both sender and receiver are participating in the predistribution. The system reduces the valuation on the sender and receiver side by the amount of the sender fixed costs.

- On the sender side, the portion of the fixed costs is zero. The overall costs therefore contain only variable portions.

- On the receiver side, the overall costs also contain only variable costs. The fixed costs are zero, due to the fully variable activity input. This is because the sender fixed costs are allocated using the predistribution of fixed costs.

Indirect Activity Allocation in the Plan

For indirect activity allocation in the plan, the system determines the fixed and variable quantity portions according to the receiver type and its tracing factor in the given segment.

- The system posts all quantities as variable if the receiver type is a cost center/activity type combination or a business process and if the receiver tracing factor is determined on the portions of the plan or actual activity quantities of the receiver.

- The system posts all quantities as variable if the receiver type is an order, cost object or WBS element.

- In all other cases, that is, for other receiver types or other receiver tracing factors, the system posts the quantities as fully fixed.

If a price exists for a sender object, the R/3 system uses this to valuate the activity quantity for the sender and corresponding receivers. This amount is split into fixed and variable debits and credits in the same way as the valuation of activity-dependent activity input planning (see: Planning Secondary Costs [Page 242]).
Target=Actual Activity Allocation

Use

Target=actual activity allocation is a special form of indirect activity allocation [Ext.] for actual allocations. It enables you to determine an activity network on multiple levels and iteratively with the operating rate [Ext.] as the tracing factor.

You can use target=actual activity allocation for cost centers and for business processes. The following example is applicable to cost centers and business processes.

In target=actual activity allocation, the actual activity quantities to be allocated are not entered directly. Instead, they are calculated by the SAP R/3 System using the plan activity inputs of the receivers, based on the operating rates of the cost centers receiving the activity type.

Because target=actual allocation is intended only for allocating actual values, activity to be allocated with this method must be assigned different activity type categories for planning and actual postings.

You determine activity type categories for planning and actual allocation in the activity type master data (see: Activity Type Categories [Page 148]).

- You must use activity type category 5 (target=actual activity allocation) for actual allocations.
- You can use activity type categories 1, 2, or 3 for planning. Category 1 is most commonly used.

Features

Target=actual activity allocation is executed as follows.

- The operating rate of the receiving cost center is determined using its own actual and plan activity.
- From the operating rate and the plan activity input, the system calculates the target activity input for the receiving cost centers. This results in the target activity of the sender cost center, that is, the activity quantity which must actually be produced based on the operating rate adjustments.
- The variable portion of the plan activity quantity is adjusted to the operating rate of the receiving costs center/activity type using target=actual activity allocation. It is then updated as a variable actual activity quantity. The fixed portion of the activity quantity is transferred from the plan to the actual during target=actual activity allocation.

Planning must be fully reconciled at the planning level as a requirement for using this allocation method. Non-reconciled planning leads to incorrect operating rates, which, in turn, result in an incorrect allocation. For more information on reconciliation of planning, see: Plan Reconciliation [Page 381].
Example of Target=Actual Activity Allocation [Ext.]

Target=actual activity allocation is executed iteratively. This means that recursive activity relationships between cost centers are taken into account. Recursive activity relationships occur, for example, when a cost center takes activity from another cost center, to which it also provides activity.

The system generally terminates target=actual allocation if extremely high operating rates are determined for a receiving cost center. For example, if the activity quantity was planned unrealistically for the cost center, or if an activity price was set manually, and an activity quantity of 1 was entered.

If you are working with transfer prices (parallel value flows), the target=actual activity allocation is executed in the leading valuation. The plan price used for allocation thus applies to all the valuations.

For more information on transfer prices, see the SAP Library under

- Financials → EC - Enterprise Controlling → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
- Financials → CO - Controlling → Overhead Controlling → Overhead Controlling → Multiple Valuations [Ext.]
Executing Target=Actual Activity Allocation

1. To execute target=actual activity allocation, go to the Cost Center Accounting menu or the Activity-Based Costing menu, and choose:
   
   Actual postings → Period-end closing → Allocations → Target=actual activity allocation.

2. You can limit the target=actual activity allocation to a given cost center group.
   
   To do so, choose Cost center group and enter the desired group.
   
   The default setting is All cost centers.

3. On the initial screen, enter the version, the periods, and the fiscal year for the target=actual activity allocation.

4. You can control the type of processing as well as the formatting of the results.
   
   Choose
   
   a. Test run
      
      If you select Test run, the system carries out the target=actual activity allocation, but does not post the results.
      
      To check the results of the test run, select the indicators Detailed list and Test run.
   
   b. Background processing
      
      If you are working with large amounts of data, execute the reconciliation in the background during periods of low system usage.
   
   c. Detail lists
      
      The default display variant settings for the detail list identify all planned activity quantities on the cost centers for each activity type. The system specifies the actual activity of the activity-receiving cost centers.
      
      The system calculates and displays the operating rate [Ext.] during the target=actual activity allocation using the variable actual and plan activity.
      
      During the update of the target=actual activity allocation, the system adjusts the variable portion of the plan activity quantity on the sender to the operating rate of the receiver cost centers/activity types. The result is updated as a variable actual activity.

5. To post the results (with update), proceed as follows:
   
   a. On the list screen, choose Save.
   
   b. When exiting this screen, choose Yes in response to the update question.
   
   c. On the initial screen, choose Execute (deselect the Test run indicator first).

6. To tailor the list to your own requirements, choose Current display variant.
   
   You can do the following:
   
   a. Change position and length of display fields.
   
   b. Include or remove fields from the list.
   
   c. Remove fields from the field pool and insert them in a given position in the list.
   
   d. Change the order of the fields already included in the list.
7. To arrange the list according to the entries in individual columns, choose Sort ascending or Sort descending.

8. Choose Edit → Find to search the list for desired terms.

9. Choose Edit → Set filter to delimit the plan reconciliation results lists according to your defined conditions.

   Enter the field name that is to act as the delimiting criterion and enter an amount for this field.

   Choose Total plan activity as a criterion.

   You enter 500 to 1000 as the value for this field.

   The system displays only those entries in the results list where plan activity lies between 500 and 1000 units.

10. Choose List → Print to print the list.

11. When you call up the list screen for target=actual allocation, the system displays the sum of all the period values.

    Choose Period values to display the individual period values for the target=actual activity allocation.

    Choose Previous period or Next period to scroll through the individual periods.

    The same functions are available here as in the totals display for periods.

12. To display the activity flows in the system, in the period display, choose Activity analysis.

    Based on the selected cost center activity type, you can follow the activity flow though multiple cost centers. By clicking on the symbols in the Activity network column, you can summarize the activity relationships or expand them again. The system displays closed relationships in the activity network using lines in the activity network column. Members of closed relationships are marked in red.
Template Allocation in Actual

Use

The use of template [Ext.] allocations is one method to assign overhead costs. This method is unique for several reasons:

- Costs are not just allocated, but the system also determines the quantities that the respective receiver objects consume or utilize; costs are calculated based on the quantities and prices, and therefore more accurately determined

- Working with templates: the sender, quantities and activation time do not already exist, but can be dynamically determined through the template at the time of the calculation

- The template uses functions [Ext.] defined by the user or already provided in the system to determine the needed data; these functions pull information already in fields or carry out complex algorithms from the operative data in the SAP system; they are created and maintained in the environment maintenance

- Sender objects can be business processes or cost centers/activity types

possible receiver objects of the template allocation in actual can be:

- Product Cost Collector
- PP-Production Orders
- CO-Production Orders
- PP-Process Orders
- Sales Orders
- Service Orders
- Internal Orders
- General cost objects
- WBS Elements
- header and activity assigned network
- Profitability segment of profit and market segment analysis
- Cost centers or cost centers/activity types
- Business Processes

In order to describe the allocation quantities in actual, you can draw upon actual quantities updated in the SAP System (such as the Logistic Information System or the confirmed quantities entered in the system).

For example, the number of purchase orders per sales orders serves as the process driver of the procurement process for a sales order processor. You can configure the Logistics Information System so that it updates the appropriate key figure for this sales order for each procurement transaction related to the order. Thus, at the time of template allocation, the relevant template function uses the most recent
Template Allocation in Actual

Information on procurement occurrences for the sales order from the Logistics Information System

Template-Allocation for Cost Objects (example, production order)

Prerequisites

These include:

- Creating the necessary sender objects; for example Business Processes [Ext.] or Cost Center [Ext.]/Activity Types [Ext.]
- Maintaining the environment [Page 401] or functions [Ext.] necessary for your receiver object
- Providing the process drivers (for example, statistical key figures) used by the functions
- Creating appropriate templates [Page 733]
- Assigning the template to the receiver object (Cost Driver [Ext.] or Profitability Segment [Ext.]).

Price determination, planning and plan reconciliation should be carried out.

Features

Enter the receiver object(s) in the entry screen for template allocation to determine the overhead costs. When you carry out the allocation, the system does the following:

- Through the search rule you defined, the correct template is assigned to the receiver object
- The template finds the correct business process(es) or cost centers/activity types
- It calculates the quantities demanded/required
- It sets the time period of the allocation and checks, if necessary, the activation requirements
Template Allocation in Actual

The result is a list of receiver and sender objects of the activity quantities and relevant costs (quantity*price). The price is calculated based on the valuation variant, which is tied to the receiver cost object for the simultaneous costing using the costing variant. If the receiving cost object is not tied with a costing variant for the simultaneous costing, then the planned price for the period is used for the valuation.

Activities

You have defined your assumptions.

To carry out a template-allocation:

- Enter the template-allocation transaction for which receiver object(s) determine overhead costs
- Execute the template-allocation
- After the results are displayed (Display run results: Template Allocation [Ext.], you can use the Template Trace [Ext.] to display a more detailed view.
- In Display Detail [Ext.] it is also possible to view the results of individual template cells.

See also:

Template Allocation in Plan [Page 473]
Template Allocation in Actual: Processes/Cost Centers

Use

Along with profitability segments and cost objects, business processes, cost centers, cost centers/activity types receiver objects can also be used in template allocations. A template allocation can be run on such business processes, cost centers or cost centers/activity types only when these are assigned fixed allocation templates in the master data. Only one template can be referenced to each business process; to each cost center one for activity dependent and another for activity independent allocations. You can assign additional templates for the formula planning. Each business processes or cost center can appear several times as a sender in various templates.

The system calculates the actual quantity retroactively from receiver to sender objects with template allocations for business processes, cost centers or cost centers/activity types in actual. By evaluating the process flow with the plan activity price, the SAP System can assign costs to the receivers during the allocation itself.

The allocation is dependent on the period and fiscal year.

You can use business processes or cost center/activity types as senders with template-allocation for business processes/cost centers. You can use the following objects as receivers (SBP = name of the environment):

- SBP: Business process
- SCD: Cost centers/Activity types (activity dependent allocation)
- SCI: Cost centers (activity independent allocation)

Prerequisites

These include:

- Creating the necessary sender objects; for example Business Processes [Ext.] or Cost Center [Ext.]/Activity Types [Ext.]
- Maintaining the Environment [Page 401] or functions necessary for your receiver object
- Providing the Process Drivers [Ext.] (for example, statistical key figures) used by the functions
- Creating appropriate Templates [Page 733]
- Assigning the template to the receiver object (business process, cost center or cost center/activity type)
- Actual quantities of the receiver objects must already exist.
- Allocation relationships that are defined through templates must be structured hierarchically.

The allocation uses only activity types of category 1 (manual entry, manual allocation) and category 2 (indirect entry, indirect allocation) and sender business processes of category 1 and category 2 (equivalent to the activity type categories). You do not need to accept the category from the activity type or business process
Template Allocation in Actual: Processes/Cost Centers

Master data. These are default values which you can overwrite in quantity and price planning for activity types and business process for each version and fiscal year.

Activities

In Activity-Based Costing or Cost Center Accounting, choose Period-end closing → Individual functions → Allocations → Template allocations.

For more information on template assignments and allocations, see:
- Templates for Business Processes/Cost Centers [Page 729]
- Templates for Bus. Proc./Cost Center Assignment [Page 732]
- Executing Template-Allocations [Page 741]
- Example Template Allocation Process (Actual) [Ext.]

Reversing allocations in actual

You can reverse an allocation in actual. In the screen for template allocations, choose Extras → Reverse (normally not necessary, as corrections are made in the delta postings).

Additional business posting transactions while executing allocations in actual

You can also make a manual posting in the template allocation. This allows you to make additional postings for extraordinary cases manually; namely for business processes, cost centers or cost center/activity types.
Templates for Business Processes/Cost Centers

Definition

The template is a dynamic tool, which uses functions [Ext.] and formulas [Page 435] and Boolean logic (true/false) to calculate values. It consists of a grid of columns and rows.

- Create a template in environment SBP for allocations in business processes.
- Create a template in environment SCI for allocations in cost centers.
- Create a template in environment SCD for allocations in cost centers/activity types.

Structure

You can choose between six item categories. Depending on the item category you choose, you will have the following columns available for data entry.

<table>
<thead>
<tr>
<th>Item Type</th>
<th>Columns that can be edited</th>
</tr>
</thead>
<tbody>
<tr>
<td>Commentary row</td>
<td>Description</td>
</tr>
<tr>
<td>Process</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Sub-Template</td>
<td>Name, Object, Activation condition</td>
</tr>
<tr>
<td>Cost center / activity type</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Calculation row (Process)</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
<tr>
<td>Calculation rows (cost centers/activity types)</td>
<td>Name, Object, Activation condition, Plan quantity factor variable (only SBP and SCD), Plan quantity fixed, Actual quantity factor variable (only SBP and SCD), Actual quantity fixed</td>
</tr>
</tbody>
</table>

You have the following entry and maintenance possibility per column type.

<table>
<thead>
<tr>
<th>Column type</th>
<th>Possible Entries/Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Type</td>
<td>Commentary row, Process, Sub-template, Cost center/activity type, Calculation row (Process), Cost center/activity types, Calculation row (Cost center/activity type)</td>
</tr>
<tr>
<td>Description</td>
<td>Explanations</td>
</tr>
<tr>
<td>Object</td>
<td>Based on the item type, enter the sender object (such as business process). You can enter a fixed object with type process or cost center/activity type, or you can let the system determine this dynamically within an analysis period for one or more processes or cost center/activity types. For more information, see Object Determination [Ext.]</td>
</tr>
</tbody>
</table>
Activation Requirements

Under Activation, determine the conditions, which activate the item. You can enter Active or Inactive as fixed values, or you can define a method, which allows the R/3 System to activate or deactivate the item when the valuation occurs. For more information, see Activation [Ext.].

Plan/Actual quantity factor (only environment SCD and SBP!)

Factor for variable output quantity. Enter a factor in items process or cost center/activity types. The planned output quantity of the receiver object is multiplied with the factor. The result is the sender output quantity. You can enter a constant value, or you can allow the R/3 System to determine the appropriate value when the valuation occurs. For more information, see Quantity Determination [Page 425].

Plan quantity fixed/Actual quantity fixed

Enter the consumption quantities in items process or cost center/activity types. You can enter a constant value, or you can allow the R/3 System to determine the appropriate value when the valuation event occurs. For more information, see Quantity Determination [Page 425].

If you choose item category calculation row, the editor cannot be called up in the object columns.

**Example**

Template for allocation in business processes (environment SBP).

In the above illustration, the resource consumption chain appears with the main process at the very end, Process 3.
Whenever process HP is consumed, processes 1, 2 and 3 are also used, as well as the cost center/activity type 1.

The following table clarifies the allocation names:

<table>
<thead>
<tr>
<th>This process is used...</th>
<th>...then this object is used....</th>
<th>...with a fixed quantity that is calculated with...</th>
<th>...with a variable quantity that is calculated with...</th>
<th>...all of which is set in template.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process HP (through receiver object)</td>
<td>process 1</td>
<td>formula 1</td>
<td>factor 0.5</td>
<td>HP</td>
</tr>
<tr>
<td>process 2</td>
<td>20 units (fixed entry, no calculation)</td>
<td>formula 2</td>
<td>HP</td>
<td></td>
</tr>
<tr>
<td>Process 2 (through process HP)</td>
<td>CCtr 1/Activity type 1</td>
<td>_</td>
<td>factor 10</td>
<td>2</td>
</tr>
<tr>
<td>process 3</td>
<td>formula 3</td>
<td>factor 2</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

See also:

- Templates [Page 733]
- Executing Template-Allocations [Page 741]
Templates for Bus. Proc. / Cost Center Assignment

Use

The assignment allows the template-allocation to use the respective business process or cost center as receiver objects.

Each business process or cost center can be tied to only one template. However, each business processes, cost center and cost center/activity type can appear as a sender object in various templates.

The assignment is year-dependent. It cannot be changed within the fiscal year time frame. However, you can take shorter periods within a fiscal year into account by activating or deactivating time-based entries within the template itself.

Prerequisites

You must create one or more templates in the template environments SBP (business processes), SCD (cost center/activity types) or SCI (cost centers).

Procedure

1. In the menu for Activity-Based Costing choose Master data → Business process → Individual processing → Change; in the menu for Cost Center Accounting you can also choose Master data → Cost Center → Individual processing → Change.

2. In the initial screen for Change business process or for Change cost center, choose the business process or cost center to which you want to assign a template.

3. Choose tab Templates.

4. Choose a template in the Template field.

   i. For business processes, use field Allocation template; here you will find all templates created for environment BPP.

   ii. Cost center / activity type: choose a template in field Alloc.templ. actl. depen. Here you will find all templates for environment SCI.

   iii. Cost center: choose a template in field Alloc.templ. actl. indep. Here you will find all templates for environment SCD.

5. Choose

   From the template fields you can also:

   • Display allocation structure
   • Display templates
   • Change templates, or
   • Create templates
Template

Definition

The template is a dynamic tool, which uses functions [Ext.], formulas [Page 435] and Boolean logic (true/false) to calculate values. It consists of a grid of columns and rows.

It is used in overhead allocations, and planning of business processes or cost center/activity types.

Special environments exist for each template application. Select an environment before you create a template. The environment determines which row and column types you will have available.

Use

Applications and receiver objects

Template-Allocation

Quantities are determined with the template, and then evaluated with a (unit) price. Costs calculated this way can be allocated to the receiver objects with the template:

- For example, cost objects (environments 001-002) in the area of cost object controlling for production, customers process order, and in product cost planning. The system assigns the template to a cost object (see: Template-Allocation to Cost Objects [Ext.], or Template Application in the Standard Cost Estimate [Ext.]).

- Business process, cost center, cost center/activity type (environment SBP, SCI, SCD): It allows you to record the cost and quantity flow under business processes and cost centers. The template is assigned to the process or to the cost center in the master data (see: Template Allocation in Plan: Processes/Cost Centers [Page 475] and Template Allocation in Actual: Processes/Cost Centers [Page 727]).

- Profitability segment (environment PAC), which can be used for administration, operation and other service activity processes, since with these many evaluations can be carried out. Here, the templates are assigned in the results and market segment calculations (CO-PA) to a profitability segment (see: Template Allocation to Profitability Segments [Ext.]).

Plan calculation (environment 001 - 003)

Controlled here are the overhead cost allocations from business processes or cost center/activity types to the calculation object over the template. The template ascertains which overhead costs are used and to which extent. It also determines how these costs are assigned to the product. (see: Template-Allocation in Plan Calculation [Ext.]).

Easy Cost Planning/ External Services (Environments 200 -299)

This costing method enables a simple, SAP System integrated cost planning. You work with derivation rules, which are used to define the template. This method can be used for, among other things, the planning objects Internal service requests (see also: Easy Cost Planning and Execution Services [Ext.]).

Formula planning (environment CPD, CPI, BPP, PCA)

Formula planning is an aid to planning. You can plan cost elements, statistical key figures, activity types and other elements in cost center and business process planning with the template.
Template

(see: Formula Planning Cost Centers [Page 397], Formula Planning Business Processes [Ext.], Formula Planning Profit Centers [Ext.]). Use environments CPI and CPD for cost center planning, BPP for business process planning, and PCA for profit center planning.

Process quantity determination (environment SOP)

With the template you can set process output quantities through the transfer of scheduled activities from PP (see: Transferring Activity Schedules). The environment is SOP.

Flexible Inputs

Templates are set flexibly:

- Templates are independent of receiver object types. You can use a given template for multiple receiver objects. At the time the valuation event occurs, a search strategy actively looks for the appropriate template to be used. For more information, see Assigning Templates for Cost Objects and Calculations [Ext.].

- You can define the objects to be evaluated in various ways. You can define methods that determine the object dynamically for the analysis period. For more information, see Object Determination [Ext.].

- The quantity can be a function of variables. You can use formulas to determine the quantity of an object (for example, of a business process), which is allowed by a receiver object. For more information, see Quantity Determination [Page 425].

- You can set individual template rows (items) to active or inactive. Using the methods allows you to determine when the position is active and when not; this is helpful when certain processes are necessary but only for specific receiver objects, and not for others. The template uses active items only during valuations. For more information, see Activation [Ext.].

- You can use sub-templates. You can define allocation data once in a template, and then use this template later as a sub-template.

Environments and functions

In order to dynamically determine objects and quantities as well as activation requirements with the template use the Formulas [Page 435] and Methods [Ext.]. These use Functions [Page 403].

You are provided many functions. The ones that can be used is determined by the application of the template; that is, the chosen environment. You can also create your own functions.

For more information, see Template Environments [Page 401].

Structure

A template consists of rows (which hold items) and columns. The environment chosen also determines the rows and columns available to you.

The columns displayed include the following:

- Type of item, such as business process, cost element, statistical key figure, sub-template, or Calculation row [Ext.].

- Name of the item

- Object column, such as the name of the process, sub-template, or formula row

- quantity columns (actual/plan): for example, process quantity, statistical key figure quantity, resource quantity
• **Activation column** (actual/plan)

See also:

Maintaining Templates [Page 736]

Other Methods to Maintain Templates [Page 738]
Maintaining Templates

Initial screen
5. In the Implementation Guide (IMG) of the application follow path Templates → Maintain Template [Ext.] → Create template, or Change template.
6. In the Template field, enter the name of the template you wish to create or maintain.
7. Choose Template environment [Page 401].
8. Choose Overview.

When creating templates, you can choose the one with the settings you want to transfer from group box Copy from. You can change this data in the overview screen.

Overview Screen
7. If you are creating a new template, enter a descriptive text.
8. Select the item category in column Category/Obj.
9. Enter a name for the item.
10. Edit the remainder of the columns. You come to the individual columns with a mouse click or by using the keyboard. With a mouse click you arrive at:
   i. Object columns in the selection editor (for procedure, see: Object Determination [Ext.])
   ii. Quantity columns in the quantity editor (for procedures, see: Quantity Determination [Page 425])
   iii. Activation column in the activation editor (for information see: Activation [Ext.]).
11. After creating or changing all the rows, choose Enter.
12. Choose Save data.

To see what column types are available, see information on the corresponding template:
   Templates for Cost Objects and Calculations [Ext.]
   Template for Profitability Segments [Ext.]
   Template for Business Processes/Cost Centers [Page 729]
   Template for Processes Formula Planning [Ext.]
   Template for Cost Center Formula Planning [Page 393]
   Template for Profit Center Formula Planning [Ext.]
   Template for Easy Cost Planning [Ext.]

See also:
Other Methods to Maintain Templates

Use

The following functions allow you to maintain the template.

Features

Initial screen

<table>
<thead>
<tr>
<th>In order to</th>
<th>... Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>reach the change mode</td>
<td>Template → Change</td>
</tr>
<tr>
<td>reach the display mode</td>
<td>Template → Display</td>
</tr>
<tr>
<td>reach the create mode</td>
<td>Template → Create</td>
</tr>
<tr>
<td>reach the maintenance of the function tree [Page 416]</td>
<td>Environment → Function tree</td>
</tr>
<tr>
<td>reach the maintenance of the environment [Page 401]</td>
<td>Environment → Maintain environment</td>
</tr>
<tr>
<td>see the Where-used list (an overview of where templates are used as sub-templates, or where business processes or cost centers are assigned to)</td>
<td>or Template → Where-used list</td>
</tr>
<tr>
<td>display the template hierarchy (an overview of all existing templates), delete templates directly in this tree structure If you delete a template from the hierarchy, the template is permanently deleted from the R/3 System. The hierarchy tree structure consists of the levels Controlling area, Environment, Template, and Sub-template.</td>
<td>or Environment → Hierarchy</td>
</tr>
<tr>
<td>Generate templates (this occurs after the transport; see Transport Settings for Activity-Based Costing [Ext.])</td>
<td>You are in the hierarchy display. 3. Place the cursor on a controlling area, an environment or a template. 4. or Processing → Generate Template. All templates belonging to the chosen level are generated.</td>
</tr>
<tr>
<td>see an overview of the individual rows of templates which were created, viewed or changed</td>
<td>or Goto → Overview:</td>
</tr>
</tbody>
</table>

Overview Screen

<table>
<thead>
<tr>
<th>In order to</th>
<th>... Choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate templates (this occurs after the transport; see Transport Settings for Activity-Based Costing [Ext.])</td>
<td>You are in the hierarchy display. 3. Place the cursor on a controlling area, an environment or a template. 4. or Processing → Generate Template. All templates belonging to the chosen level are generated.</td>
</tr>
</tbody>
</table>
### Other Methods to Maintain Templates

<table>
<thead>
<tr>
<th>Instruction</th>
<th>Key Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>switch from the display to the change mode (or reverse)</td>
<td>or Template → Display/Change</td>
</tr>
<tr>
<td>save your entries</td>
<td>or Template → Save</td>
</tr>
<tr>
<td>Check your entries (the system performs a syntax check of formulas and methods, and also ensures that all objects exist; it returns a message after the checking is done)</td>
<td>or Template → Check</td>
</tr>
<tr>
<td>display the Where-used list</td>
<td>or Template → Where-used list</td>
</tr>
<tr>
<td>display only the Actual column</td>
<td>Actual column or Template → Column selection → Actual column</td>
</tr>
<tr>
<td>display only the Plan column</td>
<td>Plan column or Template → Column selection → Plan column</td>
</tr>
<tr>
<td>display all columns</td>
<td>all columns or Template → Column selection → All columns</td>
</tr>
<tr>
<td>insert an existing template into one that you will create (all rows of the existing template will be inserted in the current template, and can be changed thereafter)</td>
<td>or Edit → Insert template</td>
</tr>
<tr>
<td>assign a receiver object to a template - to reach the respective assignment transaction</td>
<td>Environment → Assignment</td>
</tr>
<tr>
<td>Environment → Assignment</td>
<td></td>
</tr>
<tr>
<td>Assigning Templates for Cost Objects and Calculations [Ext.]</td>
<td></td>
</tr>
<tr>
<td>Templates for Bus. Proc./Cost Center Assignment [Page 732]</td>
<td></td>
</tr>
<tr>
<td>Assigning Templates for Processes (Formula Planning) [Ext.].</td>
<td></td>
</tr>
<tr>
<td>Template-Allocation for Profitability Segment Template Allocation for Profitability Segment [Ext.]</td>
<td></td>
</tr>
<tr>
<td>display the template hierarchy</td>
<td>or Environment → Hierarchy</td>
</tr>
<tr>
<td>Generate templates (see above)</td>
<td>or Processing → Generate Template.</td>
</tr>
<tr>
<td>test the template</td>
<td></td>
</tr>
<tr>
<td>You can test only the templates of environment 001!</td>
<td></td>
</tr>
<tr>
<td>5. Choose ✎.</td>
<td></td>
</tr>
<tr>
<td>6. in screen Parameters for testing, enter your test data</td>
<td></td>
</tr>
<tr>
<td>7. Choose ✎.</td>
<td></td>
</tr>
<tr>
<td>8. you reach Template Trace: Basic screen [Ext.] and can continue to Template Trace: Detail [Ext.] .</td>
<td></td>
</tr>
</tbody>
</table>
## Other Methods to Maintain Templates

### Editing in Overview screen

<table>
<thead>
<tr>
<th>In order to:</th>
<th>... follow these steps</th>
</tr>
</thead>
</table>
| select a cell for editing    | 3. position the cursor on the cell that you want to edit  
4. double click on the row or choose 🖱.  
   In the description column you arrive at the long text editor; in the object and activation column, at the selection or activation editor (see, Defining methods [Ext.]); in the quantity column, at the quantity editor (see, Defining formulas [Page 436]). |
| create long text for the row | 6. mark the row  
7. choose Edit → Item long text  
8. in screen Text processing enter an abbreviation for the corresponding language  
9. Choose 🖱.  
10. enter the text (for more information, see screen Long text for items through Help → Application help) |
| copy a row or cell           | 5. place the cursor on the row or cell  
6. choose 🖱 or Edit → Copy line/cell.  
7. Place the cursor on the target point  
8. choose 🖱 or Edit → Insert line/cell |
| Move a row/line or cell      | 5. place the cursor on the row or cell  
6. choose 🖱 or Edit → Cut line/cell  
7. Place the cursor on the target point  
8. choose 🖱 or Edit → Insert line/cell |
| Insert a line/row            | 3. place the cursor on the line, over which another line is to be inserted  
4. choose 🖱 or Edit → Insert line |
Executing Template Allocations

8. Choose the transaction for the template allocation in your application.

9. Enter the receiver object(s) (see Selection variant [Page 28]).

10. Enter the version [Ext.] (if more than one exists) and the periods and fiscal year for the allocation.

11. You can determine the type of processing and the preparation of results with the Test run, Background processing, and Detail list indicators.
   
   i. If you activate the Test run indicator, the SAP system runs the template allocations without posting the results. We recommend using the Detail list indicator together with the Test run indicator so that you may then analyze the test run results.
   
   ii. If you need to process large volumes of data, use the Background processing indicator for executing the allocation during periods of low system use.

12. To execute the template allocation, choose or Allocation → Execute.

13. After the results are displayed (Display run results: Template Allocation [Ext.]), you can use the Template Trace: Basic Screen [Ext.] for a more detailed/broken down view.

14. In Display Detail [Ext.] it is also possible to view the results of individual template cells.
Overview of Allocation Methods

The table illustrates the main differences between the allocation methods.

<table>
<thead>
<tr>
<th>Allocation methods</th>
<th>Template allocation</th>
<th>Periodic reposting</th>
<th>Distribution</th>
<th>Assessment</th>
<th>Indirect activity allocation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocation of</td>
<td>Actual and plan</td>
<td>Primary costs</td>
<td>Primary costs</td>
<td>Primary and secondary cost elements</td>
<td>Actual and plan activities</td>
</tr>
<tr>
<td></td>
<td>quantities of cost center/activity type and business processes</td>
<td>Periodic reposting</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allocation with</td>
<td>Allocation cost</td>
<td>Original cost</td>
<td>Original cost element</td>
<td>Assessment cost element (= secondary cost element)</td>
<td>Allocation cost element (= secondary cost element)</td>
</tr>
<tr>
<td></td>
<td>element (= secondary cost element)</td>
<td>element</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Information in</td>
<td>Item text for</td>
<td>Receiver objects</td>
<td>Sender cost center and receiver objects</td>
<td>Sender cost center and receiver objects</td>
<td>Sender cost center and receiver objects</td>
</tr>
<tr>
<td>report</td>
<td>template, sender</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>and receiver objects</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sender objects</td>
<td>Cost center/</td>
<td>Order, cost center, cost center/</td>
<td>Cost center</td>
<td>Cost center, cost center/</td>
<td>Cost center and cost center/</td>
</tr>
<tr>
<td></td>
<td>activity type,</td>
<td>cost center/</td>
<td></td>
<td>activity type</td>
<td>activity type</td>
</tr>
<tr>
<td></td>
<td>business process</td>
<td>activity type, cost</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>object, WBS element</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use</td>
<td>Allocation method</td>
<td>Posting aid for</td>
<td>Settlement of primary and secondary costs</td>
<td>Settlement of quantities, retrograde calculation of sender values</td>
<td>Settlement of quantities, retrograde calculation of sender values</td>
</tr>
<tr>
<td></td>
<td>for cost centers/</td>
<td>collecting and</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>activity types and</td>
<td>allocating primary</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>processes</td>
<td>costs</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

April 2001
Senders and Receivers for Periodic Actual Postings
## Senders and Receivers for Periodic Actual Postings

<table>
<thead>
<tr>
<th>Sender objects</th>
<th>Periodic reposting</th>
<th>Accrual rate</th>
<th>Overhead rate</th>
<th>Distribution</th>
<th>Assessment</th>
<th>Indirect activity allocation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost center</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Order</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Business process</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>WBS element</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Cost object</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
### Senders and Receivers for Periodic Actual Postings

<table>
<thead>
<tr>
<th>Receiver objects</th>
<th>Posting</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Periodic reposting</td>
</tr>
<tr>
<td>Cost center</td>
<td>X</td>
</tr>
<tr>
<td>Order</td>
<td>X</td>
</tr>
<tr>
<td>Business process</td>
<td>X</td>
</tr>
<tr>
<td>WBS element</td>
<td>X</td>
</tr>
<tr>
<td>Cost object</td>
<td>X</td>
</tr>
<tr>
<td>Real Estate object</td>
<td></td>
</tr>
<tr>
<td>Cost center/activity type</td>
<td></td>
</tr>
<tr>
<td>QM order</td>
<td></td>
</tr>
<tr>
<td>Customer order</td>
<td></td>
</tr>
<tr>
<td>Process order</td>
<td></td>
</tr>
<tr>
<td>Project</td>
<td></td>
</tr>
<tr>
<td>Production order</td>
<td></td>
</tr>
<tr>
<td>Product cost collector</td>
<td></td>
</tr>
</tbody>
</table>
Defining Periodic Repostings or Periodic Allocations

Purpose
At period-end, when all costs have been incurred, you can use various allocation methods. You can use periodic reposting [Ext.], distribution [Ext.], assessment [Ext.] or indirect activity allocation [Ext.] to assign primary costs from other components, as well internally allocated secondary costs, to the cost-originating cost centers.

To execute periodic reposting or periodic allocations, you must define allocation cycles [Ext.]. You create a separate cycle for the plan and for the actual allocation of the same allocation type.

⚠️ Consumption quantities cannot be allocated in assessment.

Note that distribution the system does not consider any primary costs that are planned activity-dependent.

During assessment, and periodic reposting in the actual, the system automatically allocates activity-dependent costs to the receivers.

For periodic reposting in the plan, you can also specify that given activity types are allocated to the receiver cost center/ receiver activity type.

Prerequisites
Before you define periodic repostings or periodic allocations, you should specify the following:

- Which object reposts or allocates the costs?
- To which object are the costs to be reposted or allocated?

This means that you must define sender-receiver relationships for these allocation types.

You can make these settings in either the Cost Center Accounting menu or in the Implementation Guide for Cost Center Accounting.

💡 The cost center Cafeteria allocates its costs to all cost centers in the organization. Cafeteria is the sender and all cost centers in the organization (including the cafeteria itself) are receivers.

You can also define multiple cost centers as senders.

Cost centers, orders, WBS elements, and cost objects can all be used as receivers.

- Which costs or activity quantities are to be reposted or allocated?
  For each sender, you define which costs or activity quantity are to be further allocated.
Cost Center Accounting (CO-OM-CCA)

Defining Periodic Repostings or Periodic Allocations

(see: Sender and Receiver Rules for Periodic Repostings or Periodic Allocations [Page 751]).

• According to which criteria (receiver tracing factors) are costs or activities allocated?

  At this point, you need to specify how the costs to be allocated should be subdivided. In Cost Center Accounting, the allocation keys are referred to as **tracing factors** for the allocation.

  (see: Sender and Receiver Rules for Periodic Repostings or Periodic Allocations [Page 751]).

  The costs of the *Cafeteria* cost center are to be allocated to all cost centers, in line with the number of employees in each cost center. You enter the number of employees as a statistical key figures on each cost center.

Process Flow

To define a periodic reposting or a periodic allocation, carry out the following steps:

1. In the Implementation Guide (IMG), create the sender and receiver types you require for the given periodic reposting or periodic allocation.

   (see: Defining Sender and Receiver Types for Allocations [Page 49])

2. Define a cycle.

   (see: Creating or Changing Cycles [Page 770])

3. Define segments for a cycle.

   (see: Creating Segments [Page 788])

4. If required, define tracing factors for the cycle.

   (see: Define Tracing Factors [Page 794])

5. If required, define the receiver weighting factors.

   (see: Define Receiver Weighting Factors [Page 799])

Result

Once you have created a cycle, you can execute it.

(see: Executing Periodic Repostings or Periodic Allocations Online [Page 801], Executing Periodic Repostings or Periodic Allocations in the Background [Page 820])

See also:

Process Example: Periodic Reposting of Telephone Costs [Page 338]
Defining Sender and Receiver Types for Allocations

Use

For each allocation method, you can determine in the cycle definition which sender and receiver types are ready for entry. You define this selection during Customizing for the given allocation. Data control is controlling-area dependent and distinguishes between plan and actual.

You change field attributes by specifying:

- Which tables fields should be active for the given allocation
- Whether you can enter individual values, intervals, or groups in the fields

Actions

To define sender or receiver types for the given allocation in the plan, see the Implementation Guide under Controlling → Cost Center Accounting → Planning in the following sections:

Define Sender/Receiver Types for Periodic Reposting [Ext.]
Define Receiver Types for Distribution [Ext.]
Define Receiver Types for Assessment [Ext.]
Define Sender/Receiver Types for Indirect Activity Allocation [Ext.]

To define sender or receiver types for the given allocation in the actual, see the Implementation Guide under Controlling → Cost Center Accounting → Actual Postings → Period Closing in the following sections:

Define Sender/Receiver Types for Periodic Reposting [Ext.]
Define Receiver Types for Distribution [Ext.]
Define Receiver Types for Assessment [Ext.]
Define Sender/Receiver Types for Indirect Activity Allocation [Ext.]

⚠️

If you change the field attributes for a field that is already used in cycles:

- The system deletes the corresponding data records from the table when you change individual values, groups and intervals with To-values.
- The system deletes the To value when you change intervals with From values.

💡

You are using assessment to cost centers [Ext.] and want to use only cost center groups [Ext.] as the receivers.

Select Cost center from the table field and deselect Individual value and Interval. The R/3 System displays only Cost center group as ready for entry during assessment cycle definition for the receivers.
Sender and Receiver Rules for Periodic Repostings/Allocations

The rules for the allocation types are comprised of sender and receiver rules. These are illustrated in the graphic:

**Sender Rules**

Sender values for **distribution [Ext.], assessment [Ext.]** and **periodic reposting [Ext.]** can be determined according to the following rules:

1. Posted amounts
2. Fixed amount
3. Fixed price

Sender values for **indirect activity allocation [Ext.]** can be determined according to the following rules:

1. Posted amount
2. Fixed amounts
3. Inversely determined quantities

**Receiver Rules**

You can use the following receiver rules for **distribution, assessment, and periodic reposting**:

1. Variable portions
2. Fixed amounts
Sender and Receiver Rules for Periodic Repostings/Allocations

3. Fixed percentages
4. Fixed portions

If, when defining the segment, you selected the receiver rule *Variable portions*, then those fields in which you must make entries in the following are marked as required entry fields. This helps prevent incorrect entries.

You can use the following receiver tracing factors for **indirect activity allocation**:

1. Variable portions
2. Fixed amounts
3. Fixed percentages
4. Fixed portions

**Receiver Tracing Factors**

If you are using the receiver rule *Variable portions*, you can use the following receiver tracing factors:

1. Act. costs
2. Planned costs
3. Actual consumption
4. Plan consumption
5. Actual statistical key figures
6. Plan statistical key figures
7. Actual activity
8. Plan activity
9. Statistical actual costs
10. Statistical plan costs

If you are using variable portions as the receiver rule, together with, for example, the receiver tracing factors actual- or plan costs, this is described as **flexible tracing factor determination**. The tracing factor is determined by the system dynamically during the allocation, based on the posted amounts.

For more information, see *Combinations of Sender and Receiver Rules* [Page 753]
Combinations of Sender and Receiver Rules

The following sender and receiver relationships are possible for distribution, assessment and periodic reposting:

<table>
<thead>
<tr>
<th>Receiver</th>
<th>Fixed amounts</th>
<th>Fixed percentage rate</th>
<th>Fixed portions</th>
<th>Variable portions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posted amounts</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed amounts</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed prices</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

The following sender and receiver relationships are possible for indirect activity allocation:

<table>
<thead>
<tr>
<th>Receiver</th>
<th>Fixed quantities</th>
<th>Fixed percentage rates</th>
<th>Fixed portions</th>
<th>Variable portions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Posted quantities</td>
<td>Activity type category 3</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fixed quantities</td>
<td>Activity type category 2</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Inversely determined quantities</td>
<td>Activity type category 2</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Examples
1. Allocation by fixed amounts (on the receiver side)
Combinations of Sender and Receiver Rules

1. Allocation by **fixed values** (on the receiver side)

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: 200 T$</td>
<td>B: 50 T$</td>
</tr>
<tr>
<td>200 T$</td>
<td>C: 50 T$</td>
</tr>
<tr>
<td>△ 30 T$</td>
<td>D: 70 T$</td>
</tr>
</tbody>
</table>

⚠️

The combination of fixed amounts on the receiver side with fixed amounts on the sender side is not advisable. In this case, the system always uses the fixed receiver amounts for the allocation.

2. Allocation by **fixed percentages** (on the receiver side)

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>A: 100 T$</td>
<td>B: 20%</td>
</tr>
<tr>
<td>100 T$</td>
<td>C: 20%</td>
</tr>
<tr>
<td>△ 20 T$</td>
<td>D: 40%</td>
</tr>
</tbody>
</table>

⚠️

The total of the percentage rates may not be greater than 100%. If the total percentage is less than 100%, a remainder amount remains on the sender.

3. Allocation by **fixed portions** (on the receiver side)
Sender cost center A allocates an overall amount of $100,000. Of this amount, 50 portions are allocated to receiver cost centers B and C, as well as 100 portions to cost center D. A total of 200 portions are allocated.

The amount to be allocated for each cost center is calculated by dividing the overall amount to be allocated ($100,000) by the overall sum of the portions (200) and then multiplying this total by the shares for each receiver.

As a rule, the sender cost centers are automatically credited in full using this method, except when a percentage residual value is to remain on the senders.

4. Allocation by variable portions (on the receiver side)

The receiver tracing factors are determined from the values on the totals databases. You specify the selection criteria for the receiver tracing factors on the Tracing factors screen.

The following selection criteria can be used, depending on the receiver rule you have selected:
- Version
- Cost element
- Activity type
- Statistical key figure

5. Allocation by fixed prices (on the sender side)

This applies only to assessment, distribution and periodic reposting.

The sender values are calculated according to fixed prices. Enter a price in the Sender values screen per sender for each receiver tracing factor. This is the same method as for the fixed sender amounts. However, in this case the sender is not credited by the specified amount as with the Fixed amounts rule. The R/3 System calculates the sender amount by multiplying the total and the price of the given receiver tracing factors. This
Combination of Sender and Receiver Rules

amount is allocated to the appropriate receivers in line with the receiver tracing factors. The receivers are debited accordingly.

The Cafeteria cost center allocates a fixed amount for each employee to the cost centers Personnel 1 and Personnel 2. The tracing factor is statistical key figure Employees. The following values result:

<table>
<thead>
<tr>
<th>Receivers</th>
<th>Number of employees</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personnel 1</td>
<td>50</td>
</tr>
<tr>
<td>Personnel 2</td>
<td>100</td>
</tr>
<tr>
<td>Total</td>
<td>150</td>
</tr>
</tbody>
</table>

The fixed sender price is set at $5.00/employee. The SAP R/3 System calculates the following values:

Personnel 1: $5.00/employee * 50 emp. = $250
Personnel 2: $5.00/employee * 100 emp. = $500
Cafeteria: $5.00/employee * 150 emp. = $750

6. Allocation by fixed quantities (on the receiver side)

This applies only to indirect activity allocation.

You can only allocate by fixed quantities with indirect activity allocation. The sender values are calculated according to fixed quantities. Enter a quantity for each sender in the Sender values screen. The senders are credited by the product of these quantities and the corresponding price. The receivers are debited with the product from the quantities, which the R/3 system calculates on the basis of the receiver rules, and the corresponding price.

7. Allocation by inversely calculated quantities (on the sender side)

This applies only to indirect activity allocation.

The sender values are calculated based on the receiver tracing factors. You can valuate the sender values with a weighting factor, which you define in the Sender values screen.

Receiver rule: Variable portions
Receiver tracing factor: statistical key figure (NE = number of employees)
Sender rule: Inversely determined quantities

The “Cafeteria” cost center provides 500 cooked meals (activity type CKM) to three receiving cost centers.

The following receiver tracing factors are defined.
The SAP R/3 System credits the sender with 200 units of activity type CKM. The sender cost center determines the unit of measure.

<table>
<thead>
<tr>
<th>Receivers</th>
<th>Tracing factors</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>100 employees</td>
</tr>
<tr>
<td>C</td>
<td>50 employees</td>
</tr>
<tr>
<td>E</td>
<td>50 employees</td>
</tr>
<tr>
<td>Total</td>
<td>200 employees</td>
</tr>
</tbody>
</table>
Currencies for Periodic Reposting or Periodic Allocations

Use
Provided you select All currencies in the system settings for the controlling area, you can select the currencies to be allocated for all types of allocations. The following possibilities exist:

- Allocation in controlling area currency [Ext.]
- Allocation in object currency [Ext.] (= cost center currency)
- Allocation in transaction currency [Ext.]

You select the currencies to be used in the header data of the allocation cycle.

Features

Allocation in Controlling Area Currency
This is the most important currency for the allocation. The controlling area currency is the base currency in which the allocation is carried out; the system then converts amounts to object currency (cost center currency) if this is different from the controlling area currency.

Allocation in Object Currency
You can also allocate costs in the object currency. You have two options:

1. Object currency is stored independently
   
   The system calculates sender values in object currency and processes these values parallel to controlling area currency values during iteration.

2. The system uses translation rates to determine the object currency during the update from the controlling area currency.

   You maintain the currency translation rates in the Implementation Guide (IMG) for Cost Center Accounting (CO-OM-CCA) under Planning → Basic Settings → Define translation rates.
You can only allocate costs in the object currency, if both sender and receiver cost centers are using the same currency.

### Controlling Area Currency

<table>
<thead>
<tr>
<th>Cost Center A</th>
<th>Cost Center Currency: DEM</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Total 1:</td>
<td>1,000 DEM</td>
</tr>
<tr>
<td>Total 2:</td>
<td>2,000 CHF</td>
</tr>
<tr>
<td>Line Items:</td>
<td>- 3,280 USD</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost Center B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area currency: DEM</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost Center C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area currency: DEM</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
</tbody>
</table>

### Allocation in the Transaction Currency

You can also allocate costs in the **transaction currency**. The system determines the posted sender values separately in the transaction currency and posts them under the transaction currency to the receiver.

<table>
<thead>
<tr>
<th>Cost center A</th>
<th>Cost center currency: DEM</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Total 1:</td>
<td>1,000 DEM</td>
</tr>
<tr>
<td>Total 2:</td>
<td>2,000 CHF</td>
</tr>
<tr>
<td>Line Items:</td>
<td>- 1,000 DEM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost center B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area currency: DEM</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost center C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area currency: DEM</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
<tr>
<td>Line Items:</td>
</tr>
</tbody>
</table>

If you set the **Transaction currency** indicator, the system creates considerably more totals records and line items than with the other two options mentioned.
Currencies for Periodic Reposting or Periodic Allocations

If you do not set the indicator, the system converts all postings on the sender side to controlling area currency and then distributes them. In this case, the crediting and debiting of the senders and receivers always occurs in the controlling area currency.
Cycle

Definition

A cycle [Ext.] can comprise one or more segments

You can create up to 999 segments in a cycle.

Use

Theoretically, you can define a cycle for an entire controlling area. For performance and allocation reasons, however, you can create several cycles, which you can process sequentially. This ensures that one cycle is processed before the next cycle is executed.

This division into cycles is advisable for many reasons:

• You can allocate the costs of organizational sub-areas separately by dividing them into cycles, including time-based divisions. You do not need to repeat all the cycles if errors occur or changes are required.

You have divided your allocations into four cycles. An error occurs in the third cycle. You can correct this error and repeat the allocation for this cycle. You only have to repeat the fourth cycle if it is dependent on the results of the third cycle.

This method is attractive to organizations with a large number of cost centers or business processes, where it is too time-consuming to process allocations in a single cycle. Dividing allocations into multiple cycles also allows you to allocate costs at different times.

• You can create modular allocation cycles. For example, you can process service cost centers or business processes in the first cycle and the individual cost centers or business processes in a later cycle.

Dependent Cycles

Cycles are said to be dependent, if a cycle uses the results from a previous cycle’s allocation. Therefore, you must execute dependent cycles in the correct order to ensure correct results.

Note the following requirements:

• If you have specified several cycles in the initial screens (collective start), the system executes the cycles sequentially. The allocation results for a cycle are transferred internally to the next cycle. The database update time is insignificant. Iterative relationships between cycles are not included.

• If you start dependent cycles separately, data exchange takes place in the database, but the end results correspond to those for the collective start.

Dependent Segments

The sequence of the segments in a cycle has no effect on the cycle results.
Cycle

The R/3 System uses two forms of segment execution:

- Executing without the iteration indicator: Each segment is processed separately. Dependent or cyclical segment relationships are ignored.
- Execution with iteration indicator: Allocation takes place iteratively between segments until all senders are credited or the agreed residual percentage is reached. Dependent or cyclical segment relationships are processed.

(see Iterative Processing of Cycles [Page 764])

Validity Periods for Cycles

Cycles are saved time-based. You must define a validity period for each cycle.

You create the cycle VER10 for the period from 01/01/1997 until 31/05/1997 and from 01/06/1997 until 31/12/1997. The cycle exists in two validity periods.

- From 01/01/1997 to 31/05/1997 and
- From 01/06/1997 to 31/12/1997

When allocating costs, you can select a given validity period for the cycle. If you select the cycle starting on 01/01/1997, the R/3 System selects the first of the two cycles for processing.

⚠️

The cycle you select must be valid for the posting period.

For example, you cannot allocate costs in the second half of a fiscal year for a cycle defined exclusively for the first half of the fiscal year. In the example above, this means that for the cycle VER10 of 01.01.1997 you could not allocate costs in period 08.1997.
Processing Cycles

Use
You can use the following functions to process your cycles:

- Iterative Processing of Cycles [Page 764]
- Cumulative Processing of Cycles [Page 766]
- Parallel Processing of Cycles of an Allocation Type [Page 769]
Iterative Processing of Cycles

Use
You can process a cycle [Ext.] iteratively or non-iteratively.

Non-Iterative Processing
If no cyclical links exist between your cost centers, you can deselect Iterative in the cycle definition header. In this case, the SAP System processes the segments in the cycle in succession without iteration. This makes processing much faster. However, this does not correspond to hierarchy processing, because the second segment does not take the results of the first segment into account.

If you want to process the cycle segments in a hierarchy, you need to create more than one cycle, and start these cycles one after the other. You can also start them all together.

You can also use the non-iterative method if the costs for internal consumption of services are to remain on the sender cost center, for example, the costs of internal energy consumption on the Energy cost center.

Iterative Processing
If you want to execute the processing iteratively, you must select "Iterative" for the cycle. The SAP System also includes cyclical relationships in the cost center network (a receiver can also be a sender of costs).

Cost center A allocates (according to fixed percentage rates) to cost centers B and C. Cost center C allocates (also according to fixed percentage rates) to cost centers A and B. The allocations from cost centers A are marked with the figure 1, allocations from cost center C with the figure 2. Firstly, you carry out an allocation for cost center A, then an allocation for cost center C. This ensures that when you allocate for cost center C, the system considers the amount received from cost center A. The costs in cost center A are then allocated, where the interim amount received from C is taken into account. In this way, the iteration is carried out until all participating sender cost centers are completely credited (unless a percentage is allocated to remain with the senders). Processing occurs hierarchically between the cycles (that is, building on one another).
Iterative Processing of Cycles

<table>
<thead>
<tr>
<th>Segment 1</th>
<th>Sender: A</th>
<th>Receiver: B</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1,000</td>
<td>50 %</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Receiver: C</td>
</tr>
<tr>
<td></td>
<td></td>
<td>50 %</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Segment 2</th>
<th>Sender: C</th>
<th>Receiver: B</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amount from 1</td>
<td>50 %</td>
<td>Receiver: A</td>
</tr>
<tr>
<td></td>
<td></td>
<td>50 %</td>
</tr>
</tbody>
</table>

Calculation method/sequence

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>1,000</td>
<td>-</td>
</tr>
<tr>
<td>2</td>
<td>C</td>
<td>500</td>
<td>250</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>250</td>
<td>-</td>
</tr>
<tr>
<td>4</td>
<td>C</td>
<td>125</td>
<td>62.5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-</td>
<td>1,000</td>
</tr>
</tbody>
</table>
Cumulative Processing of Cycles

Use

Assessments [Ext.], distributions [Ext.] or periodic repostings [Ext.] are usually executed by period. This means that values posted to a sender in a given period are allocated by the system on the basis of the tracing factors [Ext.] that were entered in this period.

If the tracing factors or the sender amounts to be allocated experience strong fluctuations, you cannot assign the allocated costs according to their source if you are using period-based processing. Cumulative processing of the tracing factors or sender values lets you smooth out these fluctuations. It does this by spreading the allocations across periods.

A publishing company produces magazines that appear once or twice each month, as well as magazines that appear less frequently. The administration costs are assessed to the cost centers, using monthly sales as the tracing factor.

Without cumulative assessment, overhead costs are not applied to magazines in the months in which they do not appear. Yet their production still leads to administration costs in such months. These administration costs would additionally debit the magazines that appear at least once each month. Over a longer period of time, the magazines that appear at least once each month would carry too great a portion of the administration costs, and the remainder would carry too small a portion.

With cumulative assessment, the allocation of the administration costs is spread across the months. The system debits magazines that do not appear in a given month for administration costs according to their portion of the cumulative sales.

In some countries, the smoothing of allocations is a legal stipulation. Cumulative allocation offers a way of meeting these legal requirements.

There are also ordering parties (for example, in the public sector) who demand a smoothing of allocations to exclude manipulation of expenses.

Prerequisites

To execute cumulative processing effectively,

- The sender-receiver relationships must be stable within the fiscal year.
  
  You are not allowed to delete any senders or receivers within the fiscal year. The system checks this condition when you execute cumulative processing.

  If you delete senders or receivers that existed in prior periods, but are now no longer valid or no longer exist due to master data checks or cycle changes, this will lead to incorrect allocations.

  It is not a problem, however, if you enlarge the allocation network.

- You should use the sender rule Posted amounts and the receiver rule Variable portions.
  
  It is only this rule combination that allows you to execute cumulative processing on the sender and on the receiver side.
You can not carry out a collective start of cumulative and non-cumulative cycles.

Features

Executing Cumulative Processing

If a cycle is executed cumulatively, the sender amounts posted up to the current period are allocated on the basis of tracing factors to the receivers. Cumulative processing always cumulates values starting from period 1.

The system also cumulates the calculated allocation amounts per receiver. It then posts them in the current period, minus the amounts already allocated to each receiver in the previous periods. This ensures that the postings in the prior periods remain unchanged.

The system only includes the amounts on the receivers that were posted in the previous periods also using the corresponding cumulative processing.

If you use cumulative processing for a period interval and have already posted cycles from the to period, then the SAP System reverses all periods from the to period up to and including the last posted period. The system issues an online message to confirm this. A message is also logged in the background.

You should not change the Cumulative indicator in the current fiscal year.

Scaling negative tracing factors is based only on the cumulative overall tracing factor for a receiver, and not on the values of the tracing factors in individual periods (see: Scaling Negative Tracing Factors [Page 797]).

The system provides a limited form of cumulative allocation for assessment to the Profitability Analysis component (CO-PA). The posted sender values are allocated by period to Profitability Analysis. The tracing factors, however, are accumulated across periods. This means that no smoothing of the allocated sender amounts occurs across periods. However, there is a smoothing of the tracing factors for the allocation from the senders to the receivers.

Reversing Cumulative Processing

If you want to reverse a cumulative processing, the reversal must be executed to the last updated period (inclusive).

For online execution, you carry out the reversal of the subsequent, already updated periods, using a dialog box. However, the reversal is not executed in the background if subsequent periods have already been updated.
Cumulative Processing of Cycles

You want to reverse an accumulated cycle in period 3. However, periods 1 to 5 have already been updated. You can only execute the reversal of period 3 if you also reverse periods 4 and 5.

See also: Example of Cumulative Processing [Ext.]
Parallel Processing of Cycles of an Allocation Type

Use

Parallel processing of cycles [Ext.] results in considerable time savings. To process cycles of one allocation type in parallel, they must be assigned to different cycle run groups.

You define the cycle run groups in the cycle header data. You also assign cycles to the cycle run groups in the header data.

(see: Processing Cycle Run Groups [Page 780])

To process the cycles of a cycle run group in parallel, start the cycles one after the other, if required, in different sessions.

You are carrying out a cross-company code cost accounting and want to perform the actual assessment in the individual company codes in parallel. Create a cycle run group for each company code and assign the appropriate cycles to these groups. You can then carry out the actual assessment in the individual company codes in parallel.

When you execute a cycle, you can start a consistency check. The system checks whether you are allowed to execute the selected cycles in parallel.

See

Executing Periodic Repostings or Periodic Allocations Online [Page 801]
Executing Periodic Repostings or Periodic Allocations in the Background [Page 820]
Creating or Changing Cycles

Use
You can create or change cycles for periodic allocations in the plan and in the actual, as well as during the system settings for the given allocation definition, or in the application itself when you execute the allocation or from the cycle overview display (Page 773).

The following periodic allocations are defined through cycles:
- Periodic Repostings
- Distribution
- Assessment
- Indirect Activity Allocation

Procedure
1. To create or change cycles within an application, access the initial screen of the given periodic allocation in the plan or in the actual, and choose Extras → Cycle → Create/Change (see Executing Periodic Repostings or Periodic Allocations Online [Page 801]).

   To create or change cycles for periodic allocations in the actual when you make system settings, see the Implementation Guide under Controlling → Cost Center Accounting → Actual Postings → Period-End Closing in the following sections:
   - Defining Periodic Repostings [Ext.]
   - Defining Distribution [Ext.]
   - Defining Assessment [Ext.]
   - Defining Indirect Activity Allocation [Ext.]

   To create or change cycles for periodic allocations in the plan when you make system settings, see the Implementation Guide under Controlling → Cost Center Accounting → Planning in the following sections:
   - Defining Periodic Repostings [Ext.]
   - Defining Distribution [Ext.]
   - Defining Assessment [Ext.]
   - Defining Indirect Activity Allocation [Ext.]

2. Enter a name for the allocation cycle and a starting date in the selection screen.

   The cycle Vert10 is defined from 01/01/1992 to 12/31/1992. Subsequently, Vert10 is defined from 06/01/1992 to 12/31/1992. You must enter the start date when you execute the allocation cycle. The system uses the start date to uniquely identify the selected allocation cycle (see: Cycles [Page 761]).

   When you create a cycle, you can use an existing cycle as a reference and then change it to fit your requirements.
Creating or Changing Cycles

You can also use a reference cycle from a different controlling area [Ext.]. Plan cycles can be used as a reference for actual cycles, or actual cycles as a reference for plan cycles. In these cases, you enter the reference cycle together with the creation date and the controlling area.

3. Choose Execute to enter the header data for the cycle.

4. The system uses the fiscal year end as the default end date for the cycle. If you want a different end date, simply overwrite the default value.

5. Enter a description for your cycle.

6. The system sets a status for the cycle in line with your processing. The following statuses are possible:
   - New
   - Revised
   - Saved

7. Deselect Iterative if you want the system to ignore any iterative sender/receiver relationships when you execute a cycle for periodic reposting [Ext.], assessment [Ext.] or distribution [Ext.].
   (see Iterative Processing of Cycles [Page 764].)
   If you want to execute a cumulative cycle, select Cumulative.
   (see: Cumulative Processing of Cycles [Page 766])

8. Select the Field groups you want to use in the processing of the cycle.
   - You can also include the object currency or transaction currency in the cycle processing for periodic repostings, assessments and distributions.
     (see Currencies for Periodic Reposting or Periodic Allocations [Page 758])

   The object or transaction currencies are valid only if you specify during Customizing that all currencies are valid in the controlling area.

   If the company code currency differs from the controlling area currency, the system automatically activates the Object currency. You can change this setting.
   - You can also use Consumption for periodic reposting and distribution.
   - However, only the output quantity can be included for indirect activity allocation.

9. Choose a Version for the plan cycles. The system offers you the Version as standard in the plan.

   When you enter the version, you can execute a cycle in multiple versions in the plan, without having to reverse the cycle that had previously been executed in a different version.

10. Save your entries for the cycle header.
If you access the cycle display from the cycle overview display on page 773, the system updates the structure tree in cycle overview display as well as the cycle information.

11. If you have already created segments for the cycle you are currently processing, you can go to the first segment from the header data. Choose 1st segment or Goto → 1st segment.

12. To create more segments for the cycle, choose Append segment or Edit → Append segment.

(see: Creating Segments on page 788)

See also
Functions Within Cycle Maintenance on page 777
Displaying the Cycle Overview

Use

The cycle overview provides a profile of all cycles of a given type, including the segments belonging to this type. You can display cycles for:

- Periodic repostings
- Plan/actual assessments
- Plan/actual distribution
- Indirect activity allocation

Prerequisites

You have created cycles.

You are on the execute screen for the allocation or reposting to be carried out. To call up the cycle overview, choose Extras → Cycle → Display overview.

Features

Cycle Tree Structure

- The cycles on the allocation or reposting selected are displayed in a tree structure. The segments are assigned to one level lower down in the hierarchy in each case.
Displaying the Cycle Overview

You have accessed the cycle overview on the execute screen for an actual assessment. The tree structure now displays all the cycles, including the segments for the actual assessment.

- Under Selection criteria in the selection and information area, you can specify which cycles are displayed in the tree structure.
- You can expand either the whole structure or a part of it using the mouse.
  - To do so, select the highest node of the area that you want to expand.
  - Choose Expand subtree.
  - To close the area, choose Collapse subtree.
- In the structure tree, you can search for cycles or segments.
  - Choose Search.
    - The system highlights the selected object in the tree structure and displays the data belonging to the object in the selection/information area.
    - If more than one object exists with the same name, you can move to the next object in the structure by choosing Enter again.
- You can print the structure.
  - In the current display, that is, only the nodes you have expanded
    - To do so, choose Print view.
  - As a complete hierarchy with all segments and additional information, that is, the structure is completely expanded
    - To do so, choose Print entire hierarchy.
- You can display additional columns containing additional information in the structure tree.
  - To do so, choose Change layout.
  - If you have already defined your own layouts, you can access them by choosing Select layout.
  - You can save the current display of the structure tree by choosing Save layout and entering a name for the layout.
  - If you have selected many additional columns, you can display the screen areas horizontally. You can display all the columns in a structure tree. To do so, choose Settings → Up in structure tree.
You can sort the information in the structure tree based on your point of view. To do so, choose Change drilldown.

You want to search for all cycles created by a certain user. You can do this by sorting the structure tree alphabetically using the created by field.

**Selection/Information Area**

**Selection criteria**

- On the Selection criteria tab strip, you specify which cycles and what additional information is to be displayed in the structure tree. You can:
  - Select one or more cycle types to be displayed in the structure tree.
  - Narrow down the cycles selected further, for example by entering particular cycle numbers.
  - Search explicitly for an object such as cost center 4210 or order 100144.
- To include your entries in the structure tree, choose Execute selection.
- To delete your entries from the selection area, choose Delete entries.

**Cycle Information**

- On the Cycle information tab, you can display data on a particular cycle or segment. To do so, Double click on the corresponding object in the tree structure.
  - The system displays the following data:
    - **For cycles**
      - General data on the cycle
Displaying the Cycle Overview

- Number of segments in the cycle
- Cycle run group [Ext.]
- Last date on which the cycle was executed or cancelled

For segments

- Data on segment definition
- Sender of the first segment
- Receiver of the first segment

  To display the receiver, choose Display receiver.

- You can branch to executing a cycle.
  To do so, choose Execute cycle.

- You can call up the cycle display or cycle maintenance directly from the cycle overview screen.
  To do so, choose Display cycle, Change cycle, Create cycle, or Delete cycle.

(see Creating or Changing Cycles [Page 770], Processing Cycles [Page 778], Creating Segments [Page 788], Displaying or Changing Segments of a Cycle [Page 783])

The system transfers the corresponding data on the cycle.

When you save changes to a cycle or segment in the cycle maintenance, the system updates the structure tree and the cycle information in the cycle overview.

- You can update the information on the cycle and the structure tree.
  To do so, choose Refresh.

Processed to date

- From the Processed to date tab, you can drilldown from the overview to all cycles displayed in the structure tree, if the cycles were already executed.

  The overview is sorted by cycle types [Ext.]. With a double click, you can drilldown to the document number and then to the CO document.

  You have selected all cycles for the actual distribution and displayed them in the structure tree. If you now choose the Processed to date tab, the system displays all the cycles already executed for the actual distribution.

  Choose Back or F3 to return to the cycle overview.
Functions Within Cycle Maintenance

Use
The following functions are available for processing cycles during cycle maintenance: You can also call up these functions from all of the cycle maintenance screens. From

- The header data of the cycle
- Segment maintenance
- Tracing factor maintenance
- Weighting factor maintenance

Features

- Formal cycle checks
- Saving cycles
- Printing complete or compressed cycles
- Deleting cycles
- Processing other cycles
  (see: Processing Cycles [Page 778])

- Creating Segments [Page 788]
- Copying Segments [Page 800]
- Displaying or Changing Segments of a Cycle [Page 783]
- Processing Cycle Run Groups [Page 780]
- Displaying Information for Cycles [Page 781]
- Finding Objects in Cycles [Page 782]
Processing Cycles

Prerequisites

You have created a cycle [Ext.] or changed an existing one. There are now additional functions available within cycle maintenance for the processing of cycles.

Procedure

Formal Cycle Checks

You can carry out a formal check of the cycle at any time. This lets you identify errors in the cycle definition at an early stage.

1. To check the entire cycle, choose Formal check or Cycle → Formal check.
   
   The system checks:
   
   a. The cycle entered against the master data.
   
   b. Whether the sender has been credited fully (100%). To do this, the system adds up the values in all segments. If the sender has not been credited fully (100%), the system issues a warning message.
   
   c. Whether the sender/receiver amounts or quantities agree if, under segment values and the tracing factor [Ext.], you selected rule 2 (fixed amounts or fixed quantities). The system warns you if the amounts or quantities for the senders and receivers do not agree. The system then overwrites the fixed sender values with the sum of the fixed receiver values.

   The formal check is not a complete check. It does not guarantee that you can carry out the cycle without errors. You can only check this if you start the cycle on the Cycle Processing initial screen in the Test run.

2. The system issues a message after the check to inform you whether the check was closed successfully or not. To view the error log, choose Extras → Error log.
   
   The system displays any error messages in a dialog box, separated according to segments. Double click on an error message to go to the long text.

Saving Cycles

You can save a cycle with or without executing a check.

1. To save a cycle without a check, choose Cycle → Save cycle → Without check.
   
   You can also save a cycle, even if it is incomplete or if errors occurred during the formal check, which you want to remove at a later date.

2. To save cycle with a check, choose Cycle → Save cycle → With check.
   
   Before you save the cycle, the system executes the same checks as for Formal check. If errors occur during the check, the system issues an error log and does not save the cycle.
Printing Cycles
1. Choose Cycle → Print to print the entries for a cycle.
2. Specify a printer and the number of copies, then choose Print.
   The system prints the entries for each cycle and the individual segments on individual sheets.
3. You also have the option of printing the entries for a cycle in compressed format. Choose Cycle → Print compressed.
4. Specify a printer and the number of copies, then choose Print.
   The system prints the entries for the cycle and the corresponding segments on one sheet.

Deleting Cycles
1. To delete the entire cycle you are currently processing, choose Cycle → Delete.
2. Answer the confirmation prompt with Yes.
   The system deletes the cycle and you return to the Cycle Maintenance initial screen.
   You can access the Delete cycle function from the cycle overview display [Page 773].

Processing Other Cycles
1. To process another cycle of the same allocation type, choose Cycle → Other cycle.
   You access the Cycle Maintenance initial screen of the same allocation type.
2. To create a new cycle of this allocation type, choose Cycle → Create.
Processing Cycle Run Groups

Prerequisites
If you want to execute multiple cycles [Ext.] of the same allocation type in parallel, you must first assign these cycles to different cycle run groups.

Creating Cycle Run Groups and Assigning Cycles
1. To define a cycle run group, choose Goto → Cycle run group in the cycle header data.
2. Choose Create group.
3. Enter a name and a description for the new cycle run group.
4. Choose Enter to leave the dialog box.
5. To assign the cycle to the new cycle run group, exit the Define cycle run group dialog box by choosing Confirm.

Assigning a Cycle to an Existing Cycle Run Group
1. To assign a cycle to an existing cycle run group, choose Goto → Cycle run group in the cycle header data.
2. Enter the cycle run group to which you want to assign the cycle.
3. Choose Confirm to exit the dialog box.

Displaying Cycle Run Groups
1. Choose Goto → Cycle run group in the cycle header data if you want an overview of all existing cycle run groups as well as the cycles assigned to them.
2. Choose Overview: Run group.
   The system displays a tree structure for the cycle run groups and the cycles assigned to them

Deleting Cycle Run Groups
1. You can only delete a cycle run group if it has no cycles assigned to it.
   You should first assign the cycles from the cycle run group to be deleted to other cycle run groups.
2. Choose Goto → Cycle run group in the cycle header data if you want to delete the cycle run group.
3. Enter the cycle run group you want to delete.
4. Choose Delete group and choose Yes in response to the security prompt.
Displaying Cycle Information

Display change documents

To display an overview of the change documents, choose Extras → Change documents.

For the header data and for the individual segments, the overview of the change documents displays:

- Which user originally created the segments and at what date
- Which user carried out a change, and at what date
- The type of change involved

Display History

To get information on the history of a cycle [Ext], choose Extras → History.

The system displays the following data in a dialog box:

- User and date cycle was created
- User and date cycle was last changed
- User and date cycle was last run
Finding Objects in Cycles

Prerequisites

If segments already exist in the cycle [Ext.] to be processed, you can search within the entire cycle for given input values.

Procedure

1. Choose Object search.
   The system offers all the fields used in the cycle (such as, cost center, activity type, order, cost object, WBS element).
2. Enter a search term and select a field.
   If you enter search terms for more than one object, the system searches using the AND link.
   
   For example, if you are searching for cost center 4120 and activity type 400000, the system provides a list of all segments in which both search terms exist.
3. Choose Continue to leave the dialog box.
   The system displays a list of segments in a dialog box containing the search term/s.
4. To spring from the dialog box to a segment definition, position your cursor on a given segment in the list and choose Select selected segment. Alternatively, select the segment by double-clicking on it.
Displaying or Changing Segments of a Cycle

Prerequisites

If segments already exist in the selected cycle [Ext.], you can display a list of all segments of this cycle in a dialog box. You can call up the segment overview from all screens within the cycle definition.

If you go to the cycle maintenance from the cycle overview display [Page 773] and have changed segments, the system updates the tree structure and the related cycle information in the cycle overview display when saving.

Procedure

1. To call up the segment overview, choose Segment overview or Goto → Segment overview.
   - The system displays the following data for each segment in a dialog box:
     - Segment name
     - Segment text
     - Sort field
     - Sender rule
     - Receiver rule
     - Type of scaling for negative tracing factors
     - Indicates whether the segment is locked
     - Percentage amount of sender
     - Current segment number
   - All the fields are ready for input, except for the sender rules, receiver rules and the current segment number.
     - This allows you to quickly execute changes to the cycle definitions using this list.
   2. If you want to sort the segment according to given criteria, you should save the contents that characterize the segment in the sort field.
     - The system can sort the segments in the cycle according to these contents.
     - To sort existing segments in a given sequence, you should use the sort field and do not change the segment names.
   3. To ensure that your entries in the dialog box are correct, choose Continue or Enter.
     - If you have selected invalid values for the scaling of negative tracing factors, you receive an error message.
     - If you have changed the name of an existing segment, you receive a message.
   4. To go from the list to a specific segment,
Displaying or Changing Segments of a Cycle

a. Position your cursor on the segment in the segment list.

b. Choose Select or double-click on the segment.

6. To saved changes within the list, choose Transfer values.
   The system returns to the context from which the list was requested.

7. To search for individual segments in the list,
   a. Choose Search
   b. Select the search criteria in the dialog box and enter the related data.
   c. Specify whether you want to search in the entire dialog box or only from the current cursor position.
   d. Choose Continue to leave the dialog box.
      The cursor springs to the selected segment in the list.
      If you have already searched for a term, you can continue the search by choosing More searches.

8. You can sort the list as follows:

   Sorting a list by column
   a. Select the column by double-clicking the column header.
   b. Choose Sort ascending or Sort descending.

   Resorting segments in a list
   a. Position the cursor on the segment and choose Cut segment.
   b. Position your cursor on the segment before which the segment is to be inserted and choose Insert segment.
   c. Assign a new name for the inserted segment.

The sort function does not change the physical file for the segments on the database and therefore does not change the sequence when execute the cycle.

9. You can copy one of the segments from the list and thereby physically change the cycle on the database.
   a. Position the cursor on the segment and choose Copy segment.
   b. Position your cursor on the segment before which the copy is to be inserted and choose Insert segment.
   c. Assign a new name for the inserted segment.

10. Choose Print to print the list.
    Specify the printer and the number of copies in the dialog box.
**Segment**

**Definition**

Summarization of Allocation Rules

**Use**

You can define more than one segment within a cycle [Ext.]. The following information is collected in a segment:

- **Sender objects** (such as, cost centers) for which the values to be allocated are calculated using the same rules
- **Receiver objects**, for which tracing factors [Ext.] are determined using the same rules.

**Sender values or receiver tracing factors for each allocation / reposting**

<table>
<thead>
<tr>
<th>Allocation or reposting</th>
<th>Sender values</th>
<th>Tracing factors for the receiving objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic reposting</td>
<td>Fixed amounts</td>
<td>Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>posted amounts</td>
<td>fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>fixed portions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>variable portions</td>
</tr>
<tr>
<td>Distribution</td>
<td>Fixed amounts</td>
<td>Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>posted amounts</td>
<td>fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>fixed portions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>variable portions</td>
</tr>
<tr>
<td>Assessment</td>
<td>Fixed amounts</td>
<td>Fixed amounts</td>
</tr>
<tr>
<td></td>
<td>posted amounts</td>
<td>fixed percentages</td>
</tr>
<tr>
<td></td>
<td></td>
<td>fixed portions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>variable portions</td>
</tr>
<tr>
<td>Indirect Activity</td>
<td>Posted quantities</td>
<td>Fixed quantities</td>
</tr>
<tr>
<td>Allocations</td>
<td>inversely determined</td>
<td>fixed percentages</td>
</tr>
<tr>
<td></td>
<td>quantities</td>
<td>fixed portions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>variable portions</td>
</tr>
</tbody>
</table>

If you specify a delta version when defining the sender values, the SAP R/3 System automatically takes you to distribution or assessment in Activity-Based Costing (CO-OM-ABC).

In this case, you can use the following attributes to make more specifications for the *Business process or business process group* receiver object:

- External value-added
- Internal value-added
- Category
- Cost behavior
**Examples**

At period-end closing, the cost center *Administration buildings* allocates actual costs incurred to all administration cost centers based on the square meters of floor area used by each cost center. You enter this tracing factor as a statistical key figure on the receivers. The sender and receiver cost centers are combined with the distribution rule in one segment.

At period-end closing, the cost center *Energy* allocates actual costs incurred to the other cost centers. Costs are allocated to production based on gas meter readings (statistical key figure) and to administrative cost centers based on heated floor space in square meters (statistical key figure). You must define two segments because the tracing factors for the two receiver groups are different. In each segment, you specify the portion of costs charged to production and the portion of costs charged to the administration. The graphic below illustrates this.

<table>
<thead>
<tr>
<th>Segment</th>
<th>Sender</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“Admin.buildings” cost center</td>
<td>“Administration” cost center</td>
</tr>
<tr>
<td></td>
<td>Allocation: 100% of actual costs</td>
<td>Tracing factor: m² of space</td>
</tr>
<tr>
<td>2</td>
<td>“Energy” cost center</td>
<td>“Administration” cost center</td>
</tr>
<tr>
<td></td>
<td>Allocation: 30% of actual costs</td>
<td>Tracing factor: m² heated space</td>
</tr>
<tr>
<td>3</td>
<td>“Energy” cost center</td>
<td>“Production” cost center</td>
</tr>
<tr>
<td></td>
<td>Allocation: 70% of actual costs</td>
<td>Tracing factor: Gas consumption (meter reading)</td>
</tr>
</tbody>
</table>

| Unitary / identical value calculation for the senders | Same allocation base calculation for the receivers |

Within a given segment, the value determination for the senders must match the allocation base calculation for the receivers.

The SAP R/3 System processes the segments sequentially during allocation.

If the total percentage of both segments exceeds 100%, the SAP System issues an error message. If the total percentage is less than 100%, the remaining costs stay with the sender object.
Creating Segments

Creating Segments
To append a segment to an existing Cycle [Ext.], choose Append segment or Edit → Append segment from the cycle header data.

Enter a segment name and a segment description.

If more than one segment exists in a cycle, choose Previous segment or Next segment to scroll through the existing segments. The system informs you if no other segment exists.

You can create up to 999 segments in a cycle.

Creating Segment Headers
To define an assessment, enter an assessment cost element [Ext.] (= secondary cost element), or select an allocation structure [Ext.] (see: Assessment [Page 711]).

Choose Display allocation structure to display the individual assignments of your selected allocation structure.

Choose Change allocation structure to change existing structures or to create new ones.

Specify the sender rules for the allocation in the segment under Sender values.

(see Rules for Periodic Repostings or Periodic Allocations [Page 751]).

Enter the percentage by which the sender value is to be credited.

Specify whether you want to allocate plan values in an actual allocation cycle, or actual values in a plan allocation cycle.

(see Allocating Plan Values in an Actual Allocation Cycle [Page 792] or Allocating Actual Values in a Plan Allocation Cycle [Page 793]).

Specify the receiver rules for the allocation in the segment under Tracing factors.

(see Rules for Periodic Repostings or Periodic Allocations [Page 751]).

If required, enter the desired scaling for the negative tracing factors.

If you have not specified tracing factors as fixed amounts, fixed portions or fixed percentages, negative tracing factors may arise. This would lead to receivers being credited with negative tracing factors or iterations being canceled. There are various methods for scaling any negative tracing factors.

(see Scaling Negative Tracing Factors [Page 797]).

If you are using the Variable portions receiver rule, you specify the receiver tracing factor.

(see Rules for Periodic Repostings or Periodic Allocations [Page 751]).

Sender/Receiver Relationships
Depending on the settings you made for the sender and receiver types for each allocation type during Customizing, the system offers you different fields for the senders and receivers.
For business processes, for example, the system may offer you the *External value added*, *Internal value added*, *Type* or *Allocation* type fields.

If you want to use the corresponding allocation characteristics from the master data record of a business process, select the *ST* indicator for the appropriate field.

To do this, you need to save the appropriate allocation characteristics in the master record.

If you want to enter a group in the segment definition for a sender or a receiver, you can only create or change this group from the sender definition.

- To do so, position your cursor on the group.
- Choose *Extras → Create or change group*.

This takes you to the group maintenance for the master data. Choose *Back* to return to segment definition.

To display information on the senders or receivers for the segment, choose *Extras → Display senders* or *Display receivers*.

The system displays an overview of the header data for your cycle, as well as the senders or receivers.

Receivers of allocations can be:

- **True** Controlling objects
- **Statistical** Controlling objects assigned to a true Controlling object, such as statistical orders that have a cost center specified in their master record. In this case, the posting is true for the true Controlling object and statistical for the statistical Controlling object.

(see *Account Assignment of Controlling Objects [Ext.]*)

To check the cycle you have defined, choose *Formal check* or *Cycle → Formal check*.

The system checks the cycle with the master data.

The formal check is not a complete check. It does not guarantee that you can carry out the cycle without errors. You can only check this if you start the cycle on the *Cycle Processing* initial screen in the *Test run*.

The system issues a message after the formal check to inform you whether the check was completed successfully. To view any errors, choose *Extras → Error log*.

Within a cycle you can lock a segment for processing by selecting the *Lock indicator* in the segment's header data.

The system ignores this segment during the processing of the cycle.

(see *Locking Segment Cycles [Page 791]*)

Save your entries for the segment.
Creating Segments

If you go to the cycle maintenance from the cycle overview display [Page 773], the system updates the tree structure and the related cycle information in the cycle overview display.

Maintaining Sender Values

Specify the sender values.

The fields offered by the R/3 System for the sender values are based on the sender rules that you entered in the segment header.

Maintaining Receiver Tracing Factors

Specify the receiver tracing factors.

The fields offered by the R/3 System for the tracing factors are based on the receiver rules that you entered in the segment header.

Maintaining Receiver Tracing Factors

Choose Receiver weighting factors to specify receiver-specific weighting factors that the system should include in the allocation.

See also

Functions Within Cycle Definition [Page 777]
Specifying Tracing Factors [Page 794]
Specifying Receiver Weighting Factors [Page 799]
Locking Segments in a Cycle

Use
You can lock individual segments in a cycle [Ext.]. These segments do not participate in the processing of the cycle.

This is useful if data in your segment has changed and you wish to repeat a periodic allocation for this segment only. By locking the other segments in the cycle, processing time is reduced.

Actions
You can lock the individual segments of a cycle when you create or change a cycle or a tracing factor. Select Lock indicator.
Allocating Plan Values in an Actual Allocation Cycle

Use

You create separate cycles [Ext.] for plan and actual allocations.

In segment definition, however, you can define that the plan costs are allocated in the actual instead of the posted actual costs. To do this, choose Plan values during segment definition.

This ensures that the actual costs are allocated just as the plan costs. The system ignores any plan allocations that have already been executed.

In actual assessment or actual distribution using plan values, the system does not consider any costs arising through plan assessment or plan distribution. Instead, the system uses amounts from actual assessment or actual distribution.
Allocating Actual Values in Plan Allocation Cycles

Use

You create separate cycles [Ext.] for plan and actual allocations.

In segment definition, however, you can define that the actual costs are allocated in the plan, instead of the posted plan costs. To do this, choose Actual values during segment definition.

This ensures that the plan costs are allocated just as the actual costs. The system ignores any actual allocations that have already been executed.

In plan assessment or plan distribution using actual values, the system does not consider any costs arising through the actual assessment or actual distribution. Instead, the system uses amounts from the plan assessment or the plan distribution.
Defining Tracing Factors

1. To define receiver tracing factors [Ext.] during segment definition, choose Receiver tracing factor or Goto → Receiver tracing factor.

   !
   Tracing factors must be defined before you carry out periodic allocations. You cannot calculate tracing factors while you are executing periodic allocation within a cycle. For example, the data for segment 1 cannot be the tracing factors for segment 2.

2. You can overwrite the following entries in the tracing factor definition:
   - Segment name
   - Segment text
   - Lock indicator
   - Receiver tracing factors
   - Scaling of negative tracing factors

3. Define the tracing factors you selected in the segment.

   The ready-for-entry fields on the Receiver tracing Factor screen are based on the receiver rules you selected in the segment definition.
   a. If you have entered the receiver rule Fixed amounts, enter the amount.
   b. Specify the percentage rate if you selected receiver rule Fixed percentages.
   c. If you selected the receiver rule Fixed portions, specify the portion.

   You can display the text on the relevant receiver objects for the tracing factors. To do so, double-click on the object, or choose Detail.
   d. If you entered the receiver rule Variable portions (flexible tracing factor determination), enter the selection criteria the system is to use as the tracing factor.

   **Selection criteria fields, reflecting the variable portion types for the selected receiver tracing factor**
<table>
<thead>
<tr>
<th>Variable portion type</th>
<th>Selection criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual costs</td>
<td>Cost element</td>
</tr>
<tr>
<td>Plan costs</td>
<td>Version, cost element</td>
</tr>
<tr>
<td>Actual consumption</td>
<td>Cost element</td>
</tr>
<tr>
<td>Plan consumption</td>
<td>Version, cost element</td>
</tr>
<tr>
<td>Actual statistical key figures</td>
<td>Activity type statistical key figure</td>
</tr>
<tr>
<td>Plan statistical key figures</td>
<td>Version activity type statistical key figure</td>
</tr>
<tr>
<td>Actual activity</td>
<td>Activity type</td>
</tr>
<tr>
<td>Plan activity</td>
<td>Version activity type</td>
</tr>
<tr>
<td>Statistical actual costs</td>
<td>Cost element</td>
</tr>
<tr>
<td>Statistical plan costs</td>
<td>Version Cost element</td>
</tr>
</tbody>
</table>

The possible entries as selection criteria depend on the field groups you selected in the cycle header.

⚠️

Note the following when you execute periodic repostings [Ext.] or distribution [Ext.]:

If you selected the field group Consumption and the sender rule Variable portions in the Segment header screen, you must enter the tracing factor as the secondary cost element used to post the consumption during activity allocation (in plan or actual).

This cost element is stored in the master data of the allocated activity type, but you can overwrite it during planning.

4. You can create or change a group for the selection criteria when defining the tracing factors.
   a. To do so, position your cursor on the group.
   b. Choose Extras → Create or change group.
      This takes you to the group maintenance for the master data. Choose Back to return to segment definition.

5. To display information on the senders or receivers for the segment, choose Extras → Display senders or Display receivers.
Defining Tracing Factors

The system displays an overview of the header data for your cycle, as well as on the senders or receivers.

6. **Save** your entries for the tracing factor.

7. To access the corresponding segment definitions, choose *Back* or *Segment header*.

8. If more than one segment exists in a cycle, choose *Previous segment* or *Next segment* to scroll through the existing segments.

   You always scroll to the corresponding segment definition. The system informs you if no other segment exists.

9. Choose **Goto** → **First segment** to access the first segment of the cycle.

10. Choose **Header data** or **Goto** → **Header data** to access the cycle header data.

11. Choose **Edit** → **Delete segment** to delete the segment for the tracing factor.

**See also**

*Functions Within Cycle Maintenance [Page 777]*
Scaling of Negative Tracing Factors

Use

Negative tracing factors can occur if you did not define the tracing factors [Ext.] as quantities or percentage rates, but take them from the database. For example, a distribution [Ext.] by activity types [Ext.] or statistical key figures [Ext.].

The scaling of negative tracing factors is only of importance when the receiver tracing factors have different +/- signs.

If part of the receiver has positive and part negative tracing factors, we distinguish between two cases:

- If the total of all the receiver tracing factors is greater than zero, then the system credits (without scaling) the receiver as well as the sender with negative tracing factors. In the process, the receivers with positive tracing factors are debited more heavily.

- If the total of all the receiver tracing factors is less than zero, the system credits (without scaling) the receiver as well as the sender with positive tracing factors. The receivers with negative tracing factors are thus debited more heavily.

In iterative processing, this can mean that the iteration does not converge, leading to cancellations or incorrect results.

Features

You have the following options for scaling negative tracing factors:

- No scaling (1)
  Negative tracing factors are allowed for.

- Standard scaling (2)
  The scaling depends on the total of the receiver tracing factors:
  - If the total of the receiver tracing factors is positive or zero, then the largest negative tracing factor is set to zero. The other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive.
  - If the total of the receiver tracing factors is negative, the largest positive tracing factor is set to zero. The other tracing factors are reduced correspondingly. This ensures that all the receiver tracing factors are negative.

- Absolute value (negative value becomes positive) (3)
  For negative tracing factors, the +/- sign is reversed. This ensures that all the receiver tracing factors are positive.

- Negative tracing factors become zero (4)
  Negative tracing factors are set to zero. Therefore, you do not allocate costs to these receivers.

- Smallest negative tracing factor becomes zero (5)
  The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. This ensures that all the receiver tracing factors are positive.
Scaling of Negative Tracing Factors

Receivers, which before the scaling had the tracing factor 0, are given a positive tracing factor.

- Smallest negative tracing factor becomes zero, but zero remains zero (6)
  The largest negative tracing factor is set to zero. All other tracing factors are increased correspondingly. Receivers, which before the scaling had the tracing factor 0, are given tracing factor 0.

Example of Scaling Negative Tracing Factors

<table>
<thead>
<tr>
<th>Scal.neg. Tra.fa.</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tra.factor Rec. 1</td>
<td>-100</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Tra.factor Rec. 2</td>
<td>200</td>
<td>300</td>
<td>200</td>
<td>200</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>Tra.factor Rec. 3</td>
<td>-50</td>
<td>50</td>
<td>50</td>
<td>0</td>
<td>50</td>
<td>50</td>
</tr>
<tr>
<td>Tra.factor Rec. 4</td>
<td>0</td>
<td>100</td>
<td>0</td>
<td>0</td>
<td>100</td>
<td>0</td>
</tr>
<tr>
<td>Total Tra.factors</td>
<td>+50</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The scaling of negative tracing factors can be set only for single segments and not for the entire cycle.

The following graphic illustrates a distribution with and without the scaling of negative tracing factors for option 5: **The smallest negative tracing factor becomes zero**

<table>
<thead>
<tr>
<th></th>
<th>Without scaling</th>
<th></th>
<th>With scaling</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sender</strong></td>
<td><strong>Receiver</strong></td>
<td><strong>Tracing factors</strong></td>
<td><strong>Distributed amt</strong></td>
</tr>
<tr>
<td>Cost ctr A 5,000</td>
<td>KST B 1,000</td>
<td>+ 10,000</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>KST C 300</td>
<td>- 3,000</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>KST D 200</td>
<td>- 2,000</td>
<td>0</td>
</tr>
<tr>
<td><strong>Σ Tracing factor</strong></td>
<td><strong>500</strong></td>
<td><strong>Σ Distrib.: 5,000</strong></td>
<td><strong>2,500</strong></td>
</tr>
</tbody>
</table>
Defining Receiver Weighting Factors

1. To define receiver-specific weighting factors, choose *Receiver weighting factors* or *Goto* → *Receiver weighting factors*.

2. If you want to use a different receiver weighting factor other than 1, simply overwrite the default setting under *Factor*.

   When you make the entry, note that you must take into account the factor of the decimal places of the receiver weighting factor.

   The [tracing factors](ext) selected for the given receiver are multiplied by this weighting factor. The allocation is made using a tracing factor determined by the system on the basis of the weighting factor.

3. You can overwrite the following entries in the definition of the receiver weighting factor:
   - Segment name
   - Segment text
   - Lock indicator

4. Save your entries for the receiver weighting factors.

5. To access the corresponding segment definitions, choose *Back* or *Segment header*.

6. If more than one segment exists in a [cycle](ext), choose *Previous segment* or *Next segment* to scroll through the existing segments.

   You always scroll to the corresponding segment definition. The system informs you if no other segment exists.

7. To access the first segment of the cycle, choose *Goto* → *First segment*.

8. Choose *Header data* or *Goto* → *Header data* to access the cycle header data.

9. Choose *Edit* → *Delete segment* to delete the segment for the receiver weighting factor.

See also:

*Functions Within Cycle Definition* [Page 777]
Copying Segments

Prerequisites
You can copy existing segments and then change these copied segment.
You can copy segments:
- Within a cycle [Ext.]
- From a different cycle in the same controlling area
- From a different cycle in a different controlling area

Procedure
1. Choose Edit → Copy segment.
2. Enter the following in the dialog box:
   - Controlling area
   - Cycle
   - Start date
   - Segment name of the segment to be copied
3. Assign a new name for the segment in the current cycle.
4. Choose Continue to leave the dialog box.
Executing Periodic Repostings or Periodic Allocations Online

Prerequisites

Creating Cycles

Before you can execute a periodic reposting [Ext.] or a periodic allocation [Ext.] for one or more cycles [Ext.], you must already have created the corresponding cycle(s) (see: Defining Periodic Repostings or Periodic Allocations [Page 747]).

Periodic Reposting or Allocation: Access

<table>
<thead>
<tr>
<th>Periodic repostings</th>
<th>Periodic allocations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td></td>
</tr>
<tr>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting</strong> -&gt; Planning -&gt; Planning aids -&gt; Periodic reposting</td>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Planning -&gt; Allocations -&gt; Relevant allocation</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
</tr>
<tr>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Period-end closing -&gt; Single functions -&gt; Periodic reposting</td>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Period-end closing -&gt; Single functions -&gt; Relevant allocation</td>
</tr>
</tbody>
</table>

If you have large amounts of data to process, SAP recommends executing periodic repostings or periodic allocations in the background. This enables you to run these postings at times when system usage is at its lowest (see Executing Periodic Repostings or Periodic Allocations in the Background [Page 820]).

Procedure

1. Enter the period or the period interval, and the fiscal year, for which you want to execute the periodic reposting or periodic allocation.

2. If you first want to execute periodic reposting or periodic allocation without carrying out an update and checking the results in the lists, you should adopt the default settings for Test run.
   
   If you select Test run, the system executes the periodic reposting or the periodic allocation, but does not update the database.
   
   If you want to execute periodic reposting or periodic allocation with update, deselect Test run.

3. The standard settings if for the system to display the Basic list for the cycle processing, which list displays all executed cycles. If errors occurred during processing, you can analyze these using the basic list. You can also use the Segment list to display the segments for each cycle (see: Displaying Segment Lists [Page 812]).
Executing Periodic Repostings or Periodic Allocations Online

From the basic list and the segment list, you can branch to the line item display (containing the plan and actual line items created on the sender and receiver side) (see: Results of Periodic Repostings or Periodic Allocations [Page 305]).

To display other lists, choose List selection. You can display (and print) sender and receiver lists (see Displaying Sender Lists [Page 313]) or journal lists (see Displaying Journals [Page 815]).

4. Enter the cycle(s) for which the periodic reposting or periodic allocation is to be executed.

5. Under Settings, make the following entries:

a. To vary the display of the different lists (basic list, sender list, receiver list, segment list, and journal list) use input help to select one of the three default display variants.

The expanded period display 1RKS_DEF is set as the standard.

You can change this setting on the list screen:

i. To do so, choose Settings → Display variant → Select and select one of the existing display variants.

ii. Choose Current display variant and adjust the list display accordingly. Now choose Copy and save the list display under a new name. To do so, choose Settings → Display variant → Save.

You can then use a display variant with this name for all lists (basic list, sender list, receiver list, segment list and journal list). In this way, you can save all five lists according to your individual needs.

Note that if you select the summarized period display 1RKS_DEF_PER as a display variant, the system evaluates totals records only.

You can create the display variants for specific components.

b. To determine the way in which the database is accessed, enter the database in the dialog box.

Database selection in the standard is by cycle. If this setting would lead to too many objects being selected (leading to poor system performance) you should select a different setting.

c. To store an extract when executing a cycle, select Store extract under in the dialog box and enter an extract.

This facility enables you to display a results list that generated a batch job.

To display the data belonging to the extract choose Goto → Extract Management. The same navigation functions are available as those when carrying out the cycle online. For example, you can display the senders of a segment separately.

d. If the processing of a cycle has already been terminated with an error message or it has supplied incorrect results, you can generate a flow trace log when executing the cycle. This logs all data relevant to the error search.

To do so, select Flow trace on in the dialog box.
Executing Periodic Repostings or Periodic Allocations Online

If you activated the flow trace log, you can display it after processing by choosing Technical statistics (see: Displaying Technical Statistics, Expert Trace, Divergence Analysis [Page 817]).

e. To check processing of cycles, you can (per allocation type) log the runtimes of the sub-areas of a cycle execution. To do so, select Runtime analysis on in the dialog box.

f. If you want to execute several cycles in a collective start, you can specify whether the system should end the periodic reposting or periodic allocation, or whether it should continue executing the follow-on cycles.

i. If the cycles in the collective start are linked and follow-on errors can be expected, choose End program.

ii. If the cycles in the collective start are not linked, and you want to output all errors in one run, choose Change to simulation mode.

g. To execute several cycles of the same allocation type in parallel, you must first assign these cycles to different cycle run groups (see: Processing Cycle Run Groups [Page 780]).

To execute a consistency check, choose Test obligatory. The test run checks whether you are allowed to execute the selected cycles in parallel.

Choose Extras → Cycle run groups to access the Cycle run group: Overview screen. To start the check report, choose Check cycle run groups.

In this report, the system controls whether cycles that are using the same organizational units (company code, business area, and so on) are assigned to different cycle run groups. The system checks, for example, whether the objects of a company code exist in different cycle run groups. If this were the case, it could lead to inconsistencies when you execute the cycles in parallel.

6. To enable you to easily repeat the periodic reposting or periodic allocation at a future date with the same entries, the R/3 system lets you save your entries as variants.

   a. Choose Extras → Variant → Save and enter a name and, if necessary, a short text for the variant.

   b. To transfer variants to the initial screen, choose Extras → Variant → Get. Use the input help (F4), to display a list of saved variants, from which you can select the variant you require.

   c. To delete a variant, choose Goto → Variant → Delete. You can specify whether you want to delete the variant(s) in all clients or only in the current client.

You can only call up and use variants within the same component, the same allocation type (e.g. assessment), as well as divided according to actual and plan.

7. To display the basic list, choose Execute (see: Results of Periodic Repostings or Periodic Allocations [Page 805]).

8. To post (with update) the periodic reposting or periodic allocation:
Executing Periodic Repostings or Periodic Allocations Online

a. Return to the initial screen.
b. Deactivate Test run.
c. Choose Execute.

See also
Displaying the Cycle Overview [Page 773]
Results of Periodic Repostings or Periodic Allocations

Use

At the end of the periodic reposting [Ext.] or the periodic allocation [Ext.], the system displays a basic list, which enables you to control and monitor the processing.

The basic list shows the number of senders and receivers for each cycle [Ext.] for which the periodic reposting or periodic allocation was executed.

Additionally, it shows whether, and how many, errors occurred during the cycle processing. You can analyze these errors within the basic list.

From the basic list, you can branch to the line item display with the plan and actual line items created on the sender and receiver side. You can also display a Segment list for each segment.

If you have specified in the initial screen, under Detail lists, that the system should generate sender, receiver or journal lists, you can display or print these from the basic list.

If you specified in the initial screen, under Settings, that the system should generate a runtime log, you can display and print Technical statistics, an Expert trace or a Divergence analysis (for iterative cycles) from the basic list.

If you are working with transfer prices [Ext.] (parallel value flows), the system always displays the actual version 000, although value records can be posted and allocated independently from one another.

For more information about transfer prices, see the SAP Library under:

- Financials → EC - Enterprise Controlling → Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]
- Financials → CO - Controlling → Overhead Controlling → Overhead Controlling → Multiple Valuations [Ext.]

Features

Within the basic list, you can use the following ABAP List Viewer functions (see: ABAP List Viewer [Ext.]):

- Navigation
  - Navigating in Lists [Ext.]
- Sorting
  - Sorting Ascending or Descending Lists [Ext.]
- Filter
  - Setting and Deleting Filters [Ext.]
- Totaling
  - Totaling Values and Deleting Totals [Ext.]
Results of Periodic Repostings or Periodic Allocations

Building Subtotals [Ext.]
Displaying Totals Rows Only and Breaking Down Totals [Ext.]
Displaying and Hiding Non-Totals Rows for Subtotals [Ext.]
Selecting Totals Levels [Ext.]
Determining Drilldown for Totals Levels [Ext.]

Status Display
Displaying List Statuses [Ext.]

Columns
Optimizing Column Widths [Ext.]
Freezing to Columns and Unfreezing Columns [Ext.]
Selecting Layouts [Ext.]
Changing Layouts [Ext.]
Saving Layouts [Ext.]
Managing Layouts [Ext.]

You must use the basic list to specify a variant other than the initial variant.

Search
Searching for Terms [Ext.]

Save
Sending Lists as Documents [Ext.]
Saving Lists as Files [Ext.]

The following functions are also available in the basic list of the cycle report:

Default Settings
Displaying Default Settings [Page 308]

Messages
Displaying Messages [Page 309]

Additional Lists
Displaying Line Items [Page 311]
Displaying Segment Lists [Page 312]
Displaying Sender Lists [Page 313]
Displaying Receiver Lists [Page 314]
Displaying Journals [Page 316]
Displaying Standard Settings

Prerequisites
You have executed one or more cycles and are on one of the result lists screens (basic list, segment list, sender list, or receiver list).

You can return to the standard list settings if you have:

- Entered your own display variant
- Additionally created totals or subtotals
- Hidden totals or subtotals

Procedure
To return to the standard list settings, choose Settings → Standard settings
Displaying Messages

Prerequisites

If errors have occurred during processing, the system displays the total number of errors in the Number of messages column of the Basic list, as well as in the basic list header. The system also displays an error message in the basic list header data.

The system displays the number of messages for the errors that occurred in a cycle [Ext.] in the corresponding segment list header data.

The number of messages for errors that occurred in a segment are displayed in the corresponding sender or receiver list header data.

Procedure

Display All Messages

1. To analyze all errors that occurred during processing of the given cycles,
   a. Click on the number of errors in the Disp messages row of the basic list header data.
   b. In the segment list, choose Goto → Messages → Selection.
   c. In the basic list, position your cursor on the corresponding cycle and choose Goto → Messages → Selection.
      The system displays the errors in a dialog box.
2. To get more information on the error,
   a. Double-click on a message
   b. Position the cursor on the message and choose Message long text.
3. Choose Continue to leave the dialog box.

Displaying Messages for a Cycle

1. To analyze the errors that occurred during processing of the given cycles,
   a. Select the number of errors in the Disp messages row of the segment list header data.
   b. In the segment list, choose Goto → Messages → Selection.
   c. Position your cursor in the basic list on the cycle and choose Goto → Messages → Select.
      The system displays the errors in a dialog box.
2. To get more information on the error,
   c. Double-click on a message
   d. Place your cursor on the message and choose Message long text.
3. Choose Continue to leave the dialog box.

Displaying Messages for a Segment

1. To analyze the errors that occurred during processing of a segment,
Displaying Messages

1. Click on the number of errors in the *Disp messages* row of the sender or receiver list header data.
   
   b. Choose *Goto → Messages → Select* in the sender or receiver list.
      
      The system displays the errors in a dialog box.

2. To receive more information on the error,
   
   a. Double-click on a message
   
   b. Position your cursor on the message and choose *Message long text*.

3. Choose *Continue* to leave the dialog box.

**Result**

If the analysis of the messages is sufficient, change the cycle definition in line with the message and repeat the allocation.

If the message analysis is **not** sufficient, repeat the allocation and create a runtime log (see: *Executing Periodic Repostings or Periodic Allocations Online [Page 801]*).
Displaying Line Items

Prerequisites
You can call up the line item [Ext.] display from the basic list, the segment list, the sender list or the receiver list.

Procedure
1. To branch to the line item display with sender- and receiver-side generated plan or actual line items, position your cursor:
   - In the basic list on a cycle [Ext.]
   - In the segment list on a segment
   - In the sender list on a sender
   - In the receiver list on a receiver
2. Choose Select or double-click on the segment.

See also:
Line Item Report [Page 1006]
Displaying Segment Lists

Prerequisites
You can call up the segment list from the basic list, the sender list or the receiver list.

Procedure
1. To display the segment list, position your cursor:
   a. On a cycle [Ext.] in the basic list
   b. On a sender in the sender list
   c. In the receiver list on a receiver
2. Choose Segment list or Goto → Segments.
   The segment list displays the segments for the selected cycle, sender or receiver.
   The system displays the following information on a segment:
   a. The lock indicator (segment not included in processing)
   b. The invalid indicator (an error arose during processing)
   c. The sender rules and receiver rules
   d. The number of senders
   e. The number of receivers
   f. The number of messages
3. To hide fields, choose Current display variant.
4. The segment list provides the same functions as the basic list (see: Results of Periodic Repostings or Periodic Allocations [Page 805]).
5. From the segment list, you can (per segment) branch to the:
   a. Basic list
   b. Sender list
   c. Receiver list
   d. Line item report
Displaying Sender Lists

Prerequisites

To display the sender list, you must first select Senders and receivers under List selection on the initial screen.

You can call up the sender list from the basic list or the segment list.

Procedure

1. To display the sender list, position your cursor:
   a. In the basic list on a cycle [Ext.]
   b. In the segment list on a segment
2. Choose Sender list or Goto → Senders.
   The sender list displays the senders for the selected cycle or segment.
   For each sender, the system displays
   a. The Invalid indicator (errors occurred during processing)
   b. The posted amounts in the controlling area currency.
3. Choose Current display variant to display the amounts also in the object currency or the sender base.
4. In the sender list you have the same functions available as in the basic list (see: Results of Periodic Repostings or Periodic Allocations [Page 805]).
6. From the sender list, you can, for each sender, branch to the:
   a. Basic list,
   b. Segment list,
   c. Receiver list and
   d. Line item report.
Displaying Receiver Lists

Prerequisites

To display the receiver list, on the initial screen select Senders and receivers (under List selection).

You can call up the sender list from the basic list, the segment list or the receiver list.

Procedure

To display the receiver list position your cursor:

On a cycle [Ext.] in the basic list
On a segment in the segment list
On a sender in the sender list

Choose Receiver list or Goto → Receivers.

The receiver list displays the receivers for the selected cycle, segment or sender.

The system displays the following information on a receiver:

- The invalid indicator (an error arose during processing)
- The posted amounts in the currency of the controlling area

If you call up the receiver list from the sender list, the system displays the tracing factor in place of the allocated amounts and the currency. The amounts allocated to the receiver do not have to originate from the same sender for which the sender list is generated.

To display the amounts in object currency, or the receiver tracing factor and the receiver weighting factor, choose Current display variant.

You cannot display any values when you call up the receiver list from the sender list. The only extra field available is the Factor.

In the receiver list you have the same functions available as in the basic list (see: Results of Periodic Repostings or Periodic Allocations [Page 805]).

From the receiver list, you can (per sender) branch to the:

- Basic list
- Segment list
- Sender list
- Line item report
Displaying Journals

Use

The journal provides you with an overview of the receivers, senders and corresponding values in a segment. It is therefore especially suitable for analyzing allocated values for iterative cycles [Ext.].

Prerequisites

To display the journal, you must first select Journal on the initial screen (under List selection). You can call up the journal from the basic list only.

Procedure

To display the journal, choose either Journal in the basic list or Goto → Journal.

For all segments in the cycle, the journal displays:

- The determined sender values
- The allocated sender values
- The allocated receiver values in the controlling area currency

To display the amounts in object currency, the sender or receiver tracing factor, choose Current display variant.

The journal provides the same functions as in the basic list (see: Results of Periodic Repostings or Periodic Allocations [Page 805]).

To return to the list of documents, choose Basic list.
Technical Statistics, Expert Trace, and Divergence Analysis

Use
If errors have occurred during cycle [Ext.] processing, the technical statistics, expert trace and divergence analysis let you analyze those errors which you cannot solve using the system messages.

The technical statistics and the divergence analysis enable user analysis. The expert trace requires analysis by experts.

Prerequisites
To use technical statistics, expert trace and divergence analysis choose Settings in the initial screen and select Runtime log on in the dialog box. You need to make this setting before you execute the cycle.

In addition, divergence analysis requires that:
- You use a cycle with iterative sender/receiver relationships
- These relationships are taken into account when you execute the cycle
- An error arose that led to a divergence (see: Iterative Allocation [Page 764])

Procedure
Displaying Technical Statistics
To execute an error analysis using technical statistics, in the periodic allocation basic list choose Technical statistics or Tools → Technical statistics.

This system displays a tree structure with the following information:
- Runtime of all cycles (insofar as more than one exists)
- Runtime log
- Selection criteria
- Database access
- Sender values on the database
- Receiver values on the database
- Sender values to be allocated, broken down into periods
- Receiver values to be allocated, broken down into periods
- Line item table

The following functions let you change the tree structure display:
- To expand the tree structure or a subtree, position your cursor on the appropriate node and choose Expand.
Technical Statistics, Expert Trace, and Divergence Analysis

To collapse the tree structure or a subtree, position your cursor on the appropriate node and choose Collapse.

To display only a subtree, position your cursor on the appropriate node and choose Set focus.

The system displays the subtree.

To display the higher subtrees once again, click on the cycle named in the first row.

Displaying the Expert Trace

To display the expert trace, choose Tools → Expert trace.

Select the required information and double click on the cycle for which you require the information.

The system gives you information on the contents of the individual database fields.

To return to the basic list, choose Basic list.

Displaying Divergence Analysis

To analyze divergences occurring for cycles with iterative sender/receiver relationships, choose Tools → Divergence analysis.
Printing Detail Lists

Prerequisites

From all the lists you display, you can print the corresponding individual list (basic list, segment list, sender list, receiver list or journal list).

You can also print the results lists from the basic list. The results lists contain:

- The basic list
- All segment lists
- All sender lists for all periods
- All receiver lists for all periods

If you selected Journal under List selection on the initial screen, you can also print the journal from the basic list.

The journal offers you an overview of the receivers, senders and corresponding values existing in a segment. The journal is especially suited for the analysis of allocated values for iterative cycles.

If you selected Flow trace on under Settings on the initial screen, you can also print the expert trace from the basic list.

The expert trace provides you with information on the contents of the individual database fields.

Procedure

To print the relevant list, choose:

- List → Print trace
- List → Print journal
- List → Print results list
- List → Print individual list

Enter the following data in the Print Parameters screen:

- Printer
- The number of copies
  - and, if required:
- Spool control data
- Print format
- Choose Print.
Executing Periodic Repostings/Allocations in the Background

Prerequisites

Creating Cycles

Before you can execute a periodic reposting [Ext.] or a periodic allocation [Ext.] for one or more cycles [Ext.], you must already have created the corresponding cycle(s) (see: Defining Periodic Repostings or Periodic Allocations [Page 747]).

Periodic Reposting or Allocation: Access

<table>
<thead>
<tr>
<th>Periodic repostings</th>
<th>Periodic allocations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td>Periodic allocations</td>
</tr>
<tr>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting</strong> -&gt; Planning -&gt; Periodic reposting</td>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Planning -&gt; Allocations -&gt; Relevant allocation</td>
</tr>
<tr>
<td>Actual</td>
<td>Periodic allocations</td>
</tr>
<tr>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Period-end closing -&gt; Single functions -&gt; Periodic reposting</td>
<td>Accounting -&gt; Controlling -&gt; <strong>Cost Center Accounting or Activity-Based Costing</strong> -&gt; Period-end closing -&gt; Single functions -&gt; Relevant allocation</td>
</tr>
</tbody>
</table>

Procedure

1. Enter the period or the period interval, and the fiscal year, for which you want to execute the periodic reposting or periodic allocation.
2. Select Background processing.
3. To execute periodic reposting or periodic allocation without carrying out an update, and to check the results in printed lists, do not change the Test run setting.
   - If you select Test run, the system executes the periodic reposting or the periodic allocation, but does not update the database.
   - If you want to execute periodic reposting or periodic allocation with update, deselect Test run.
4. The standard setting is for the system to print the Basic list for the cycle processing, which list contains all executed cycles. You can also use the Segment list to display the segments for each cycle (see: Displaying Segment Lists [Page 512]).
   - To print other lists, choose List selection. You can print sender and receiver lists (see Displaying Sender Lists [Page 513]) or journal lists (see Displaying Journals [Page 516]).
   - The system outputs basic lists, segment lists (and receiver lists and sender lists, if required) in a spool file. An additional spool file is generated for the journal lists.
5. Enter the cycle(s) for which the periodic reposting or periodic allocation is to be executed.
6. Under **Settings**, make the following entries:
   
   a. To vary the display of the different lists (basic list, sender list, receiver list, segment list, and journal list) use input help to select one of the three default display variants.
      
      The expanded period display **1RKS_DEF** is set as the standard default.
      
      You can change this setting on the list screen:
      
      i. To do so, choose **Settings → Display variant → Select** and select one of the existing display variants.
      
      ii. Choose **Current display variant** and adjust the list display accordingly. Now choose **Copy** and save the list display under a new name. To do so, choose **Settings → Display variant → Save**.
         
         You can then use a display variant with this name for all lists (basic list, sender list, receiver list, segment list and journal list). In this way, you can save all five lists according to your individual needs.
      
      Note that if you select the summarized period display **1RKS_DEF_PER** as a display variant, the system only evaluates totals records.
      
      You can create the display variants for specific components.
   
   b. To determine the way in which the database is accessed, enter the database in the dialog box.
      
      Database selection in the standard is **by cycle**. If this setting would lead to too many objects being selected (leading to poor system performance) you should select a different setting.
   
   c. To store an extract when executing a cycle, select **Store extract under** in the dialog box and enter an extract.
      
      Using this facility, you can for example display a results list that generated a batch job.
      
      To display the data belonging to the extract choose **Goto → Extract Management**. The same navigation functions are available as those when carrying out the cycle online. For example, you can display the senders of a segment separately.
   
   d. If the processing of a cycle has already been terminated with an error message or it has supplied incorrect results, you can generate and print a flow trace log (expert trace) when executing the cycle. This logs all data relevant to locating the error.
      
      To do so, select **Flow trace on** in the dialog box.
      
      If you selected the flow trace log, the system generates an additional spool request for the expert trace.
   
   e. To check processing of cycles, you can (per allocation type) log the runtimes of the sub-areas of a cycle execution.
      
      To do so, select **Runtime analysis on** in the dialog box. To display the logs, choose **Goto → Runtime analysis**.
Executing Periodic Repostings/Allocations in the Background

f. If you want to execute several cycles in a collective start, you can specify whether the system should end the periodic reposting or periodic allocation, or whether it should continue executing the follow-on cycles.

i. If the cycles in the collective start are linked and follow-on errors can be expected, choose End program.

ii. If the cycles in the collective start are not linked to one another, and you want to output all errors in one run, choose Change to simulation mode.

g. To execute several cycles of the same allocation type in parallel, you must first assign these cycles to different cycle run groups (see: Processing Cycle Run Groups [Page 780]).

To execute a consistency check, choose Test obligatory. The test run checks whether you are allowed to execute the selected cycles in parallel.

Choose Extras → Cycle run groups to access the Cycle run group: Overview screen. To start the check report, choose Check cycle run groups.

In this report, the system controls whether cycles that are using the same organizational units (company code, business area, and so on) are assigned to different cycle run groups. The system checks, for example, whether the objects of a company code exist in different cycle run groups. If this is the case, it could lead to inconsistencies when you execute the cycles in parallel.

7. To enable you to easily repeat the periodic reposting or periodic allocation at a future date with the same entries, the R/3 system lets you save your entries as variants.

b. Choose Extras → Variant → Save and enter a name and, if necessary, a short text for the variant.

c. To transfer variants to the initial screen, choose Extras → Variant → Get. Use the input help (F4), to display a list of saved variants, from which you can select the variant you require.

d. To delete a variant, choose Goto → Variant → Delete. You can specify whether you want to delete the variant(s) in all clients or only in the current client.

You can only call up and use variants within the same component, the same allocation type (e.g. assessment), as well as divided according to actual and plan.

8. Choose Execute.

9. In the dialog box, enter the print parameters (printer, number of copies) for your background job, and choose Print.

10. Assign a name to your background job.

b. Enter the Date and a Time if you want to execute the background job at a specific time.

c. Choose Immediate start if you want to start the background job immediately.

The system executes the periodic reposting or the periodic allocation in the background. If you have deselected Test run, the system updates the periodic reposting or the periodic allocation.
11. You can check the status of your background jobs in the job overview.
   a. To do so, choose System → Own Jobs → Job overview.
   b. Choose Execute.
   c. After some time, choose Update again.

See also
Displaying the Cycle Overview [Page 773]
Reversing Periodic Repostings or Periodic Allocations Online

1. Access the periodic reposting or periodic allocation you require.

<table>
<thead>
<tr>
<th>Periodic reposting</th>
<th>Periodic allocations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td></td>
</tr>
<tr>
<td>Accounting → Controlling → <strong>Cost Center Accounting</strong> → Planning → Planning aids → Periodic reposting.</td>
<td>Accounting → Controlling → <strong>Cost Center Accounting</strong> or <strong>Activity-Based Costing</strong> → Planning → Allocations → Relevant allocation.</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
</tr>
<tr>
<td>Accounting → Controlling → <strong>Cost Center Accounting</strong> or <strong>Activity-Based Costing</strong> → Period-end closing → Single functions → Periodic reposting.</td>
<td>Accounting → Controlling → <strong>Cost Center Accounting</strong> or <strong>Activity-Based Costing</strong> → Period-end closing → Single functions → Relevant allocation.</td>
</tr>
</tbody>
</table>

2. On the initial screen, you make the same entries as for executing periodic repostings or allocations (see: Executing Periodic Allocations Online [Page 801]).

3. From the menu for the periodic reposting or the selected periodic allocation method, choose Reverse (for example, Assessment → Reverse).

You can reverse periodic repostings [Ext.] or periodic allocations [Ext.] as often as you want within a cycle [Ext.].
Segment Adjustments in Closed Periods

Use

Segment adjustment enables you to adjust postings made in periods already closed, without having to repeat the period-end closing.

For example, data such as the values of the tracing factors might only be available after period-end closing. You therefore need to adjust the previously accepted values. You can execute this adjustment without having to carry out a time-consuming repeat of the period-end closing.

Segment adjustment in the actual can be used for the following allocations:

- Periodic reposting [Ext.]
- Assessment [Ext.]
- Distribution [Ext.]

Features

Segment Adjustment

Segment adjustments [Ext.] are carried out for periods for which period-end closing has taken place. These are known as periods to be adjusted.

The posting occurs in a period for which period-end closing has not yet taken place. These are known as posting periods.

Periods to be adjusted and posting periods can be in different fiscal years.

Requirement for a segment adjustment is that the relevant cycle in the period to be adjusted has already been executed.

There are two types of segment adjustment:

Segment Reversal Without Segment Rebook

The segment reversal [Ext.] reverses postings in the period to be adjusted for one or more cycle segments. The posting occurs in the posting period. The posting is made for identification purposes in reporting under its own business transaction (see: Business Transactions in Controlling [Ext.]).

Neither the cycle itself, nor the tracing factors are adjusted during the segment reversal. There is no explicit segment rebook. The values generated by the segment reversal are dealt with during the regular period-end closing for the posting period.

You normally carry out the segment reversal when adjusting segments with fixed tracing factors.

Segment Reversal with Segment Rebook

First, you carry out a segment reversal as described in part 1. Then, the segment rebook [Ext.] performs the postings again for the period to be adjusted. This can be for one or more segments in a cycle. The posting occurs in the posting period. The posting is made under the given original transaction, that is the transaction for the actual periodic
Segment Adjustments in Closed Periods

reposting, actual assessment, or the actual distribution (see: Business Transactions in Controlling [Ext.])

In the segment rebook, the cycle is executed for segments in the period to be adjusted. Note the following:

The system does **not** redetermine the sender amounts to be allocated, rather it takes the credit amounts of the previous segment reversal.

- Note that the sender amounts in the following case **are** redetermined. If you entered fixed amounts for the sender or receiver, these amounts are included in the segment rebook.
- To do this, choose the sender or receiver rule *Posted amounts*.

The system uses the segment definition valid for the current posting period.

The posting occurs in the posting period.

You carry out segment rebook, if **true** errors have occurred in the period to be adjusted, for example, if incorrect receivers or tracing factors have been specified. These errors are adjusted in the cycle or in the period to be adjusted. You then execute a segment rebook.

You normally carry out the segment rebook when adjusting segments with **variable portions**.

Reversing the segment adjustment

You can reverse segment reversals and segment rebooks. The system determines segment reversal and segment rebook documents for the given segments and posts them in the posting period with reversed +/- signs.

Within the segment adjustment you can:

- Carry out a segment reversal
- Carry out a segment reversal with subsequent segment rebook
- Reverse the adjustment postings

At period-end closing for the posting period, according to the cycle definition, the system uses the values from the segment adjustment postings.

- It is generally not advisable to use the segment adjustment for iterative cycles, as the function is only executed for the specified segments. The effects upon other segments in the cycle are not considered in the period to be adjusted.

- If you rename segments after executing the cycle, this will lead to errors during segment adjustment. You should only rename segments if you are sure that the cycle has not yet been executed. To group segments, you can use the sort field in the *Cycle Maintenance* overview screen.
Segment adjustments are updated under their own transactions, which you must assign in the Implementation Guide Assign number ranges (see: Business Transactions in Controlling [Ext.]).
Example 1: Segment Reversal Without Segment Rebook

The costs on cost center A are distributed to cost centers B and C. The tracing factors for the *distribution [Ext.]* are meter readings, which are read each month and recorded as statistical key figures.

- In January, the costs on cost center A ($100) are distributed equally to cost centers B and C ($50 each).
- In February, you realize that the meter readings have been read incorrectly. The distribution should have been 40% to cost center B and 60% to cost center C. The statistical key figures are changed appropriately.

  This means that in February you carry out a *segment reversal [Ext.]* for January. Cost centers B and C are each credited with $50 and cost center A is debited with $100.

  Additionally, you post a further $100 to cost center A in February. Due to this posting and the segment reversal there are now $200 on cost center A. In period-end closing, the system distributes $200 at 40% to cost center B and 60% to cost center C due to the changed statistical key figures. Cost center A is therefore credited with $200, cost center B with $80 and cost center C with $120.

- In March, you realize that the meter readings have also been read incorrectly in February. The distribution should have already occurred in January and February at 10% to cost center B and 90% to cost center C. The statistical key figures are changed appropriately.

  This means that in March you carry out a segment reversal for January and February.

  When you carry out the segment reversal for January and February, the system recognizes that a segment reversal already took place in February. The segment reversal in February means that the postings in January have already been considered by the system. The system therefore considers only the postings made in February for the segment reversal in March, otherwise this would lead to data inconsistencies.

  Multiple segment reversals are recognized automatically by the SAP System and are not considered. The system issues an appropriate note.

  Following the segment reversal for January and February, cost center B is credited with $80, cost center C is credited with $120 and cost center A is debited with $200.

  Additionally, you post a further $100 to cost center A in March. Due to this posting and the segment reversal there is now $300 on cost center A. In period-end closing, the system distributes $300 at 10% to cost center B and 90% to cost center C due to the changed statistical key figures. Cost center A is therefore credited with $300, cost center B is debited with $30 and cost center C is debited with $270.

  For the periods January through March, cost center A has now been fully credited. Cost center B is debited with $30 and cost center C with $270.
### Example 1: Segment Reversal Without Segment Rebook

**January**

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Posting</th>
<th>Distribution</th>
<th>DB values January</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stat. key figure</td>
<td>B</td>
<td>500</td>
<td></td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>500</td>
<td></td>
</tr>
<tr>
<td>Posted values</td>
<td>A</td>
<td>+ 100</td>
<td>- 100</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>+ 50</td>
<td>+ 50</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>+ 50</td>
<td>+ 50</td>
</tr>
</tbody>
</table>

**February**

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Segment reversal</th>
<th>Posting</th>
<th>Distribution</th>
<th>DB values February</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stat. key figure</td>
<td>B</td>
<td>400</td>
<td>0</td>
<td>+ 50</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>600</td>
<td>+ 30</td>
<td>+ 70</td>
</tr>
<tr>
<td>Posted values</td>
<td>A</td>
<td>+ 100</td>
<td>+ 100</td>
<td>- 200</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>- 50</td>
<td>+ 80</td>
<td>- 50</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>- 50</td>
<td>+ 120</td>
<td>+ 70</td>
</tr>
</tbody>
</table>

**March**

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Segment reversal</th>
<th>Posting</th>
<th>Distribution</th>
<th>DB values February</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stat. key figure</td>
<td>B</td>
<td>100</td>
<td>- 300</td>
<td>- 0</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>900</td>
<td>+ 30</td>
<td>- 50</td>
</tr>
<tr>
<td>Posted values</td>
<td>A</td>
<td>+ 200</td>
<td>+ 100</td>
<td>- 300</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>- 80</td>
<td>+ 30</td>
<td>- 50</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>- 120</td>
<td>+ 270</td>
<td>+ 150</td>
</tr>
</tbody>
</table>
Example 2: Segment Reversal and Segment Rebook

The costs on cost center A are distributed to cost centers B and C. The tracing factors for the distribution [Ext.] are meter readings, which are read each month and recorded as statistical key figures.

In the months January through March, the costs of cost center A were distributed equally on cost centers B and C. In April, you realize that the meter readings have been read incorrectly. The distribution should have been 3/4 to cost center B and 1/4 to cost center C.

The change to the distribution should be retrospectively valid for the periods already closed.

In the months January through March, $100 was distributed on each of the cost centers A, B and C.

Results of the Segment Adjustment [Ext.]

<table>
<thead>
<tr>
<th>Stat. key fig.</th>
<th>Cost Center</th>
<th>Period to be Adjusted</th>
<th>Posting Period</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Jan.</td>
<td>Feb.</td>
<td>March</td>
</tr>
<tr>
<td>B</td>
<td></td>
<td>500</td>
<td>500</td>
<td>500</td>
</tr>
<tr>
<td>C</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Posted values</td>
<td>A</td>
<td>-$100</td>
<td>-$100</td>
<td>-$100</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>+$50</td>
<td>+$50</td>
<td>+$50</td>
</tr>
<tr>
<td></td>
<td>C</td>
<td>+$50</td>
<td>+$50</td>
<td>+$50</td>
</tr>
</tbody>
</table>

Segment reversal [Ext.]:

In April, the R/3 system reversed in the segment the distributions from cost center A to cost centers B and C, which were carried out in the months January through March.

Cost center A is debited with 3x$100 = $300.

Cost centers B and C are each credited with 3x$50 = $150.

Segment rebook [Ext.]:

In April, the R/3 system executes again the distributions in the segment from cost center A to cost centers B and C, based on the modified statistical key figures for the months January through March.

Cost center A is credited with $300.

Cost center B is debited with 750/1000x$300 = $225.

Cost center C is debited with 250/1000x$300 = $75.
Example 2: Segment Reversal and Segment Rebook
Executing Segment Reversals

Prerequisites
You want to reverse [Ext.] postings in individual segments of a cycle.
The cycle has already been executed in the periods you want to reverse.

Procedure
1. Choose Accounting → Controlling → Cost Center Accounting → Period-end closing
   Single functions → Periodic reposting or
   → Single functions → Allocations → <allocation in question>
2. Choose Periodic reposting or <allocation in question> → Segment adjustment.
3. Under Processing parameters, enter the Periods to be adjusted and the Fiscal year.
4. Under Posting parameters, enter the posting period and the fiscal year in which the posting was made.
   The posting period has not yet been closed. Therefore you may not include it in the interval for the periods to be adjusted.
5. Enter the cycle for which you want to execute the segment reversal.
6. Under Segment selection, enter one or more segments or one or more segment intervals from the selected cycle for which you want to reverse the segment adjustment.
   You must enter the exact name of the segment. To assist, use input help.
7. If you want to carry out the segment reversal at first without an update and check the result in a list, you should adopt the default settings for the indicators Test run and Detail lists.
   If you select Test run, the system executes the segment reversal, but does not update the results.
   If you have selected Detail lists, you can branch from the basic list to the line item report and verify the results of the segment reversal.
8. To display the result list, choose Execute.
9. To post the segment reversal:
   a. Return to the initial screen.
   b. Deactivate the indicator Test run.
   c. Choose Execute.
If you have large amounts of data to process, execute the segment reversal using background processing. This means you can process data at times of minimal system usage. Select *Background processing*.

10. Once you have executed the segment reversal, you have the option of executing a segment rebook. Choose *Yes* in the dialog box if you wish to do this.

**Result**

If you have selected the *Detail lists* indicator, you can double-click to go to the actual line item report (after you have carried out the segment rebook) (see: *Periodic Allocation Results* [Page 805], *Line Item Report* [Page 1006]).
Executing Segment Reversal with Segment Rebook

Prerequisites
You want to reverse [Ext.] postings in individual cycle segments and then carry out new postings due to changed tracing factors or receivers. The cycle [Ext.] has already been executed in the periods you want to adjust.

Procedure
1. Choose Accounting → Controlling → Cost Center Accounting → Period-end closing
   Single functions → Periodic reposting or
   → Single functions → Allocations → <allocation in question>
2. Choose Periodic reposting or <allocation in question> → Segment adjustment.
3. Under Processing parameters, enter the Periods to be adjusted and the Fiscal year.
4. Under Posting parameters, enter the posting period and the fiscal year in which the posting was made.

   The posting period has not yet been closed. Therefore you may not include it in the interval for the periods to be adjusted.
5. Enter the cycle for which you want to carry out the segment adjustment.
6. Under Segment selection, enter one or more segments or one or more segment intervals from the selected cycle for which you want to execute the segment adjustment.

   You must enter the exact name of the segment. To assist, use input help.
7. Under Processing options, select With segment rebook.
8. If you want to carry out the segment adjustment at first without an update and check the result in a list, you should transfer the default settings for the indicators Test run and Detail list.

   If you have selected Test run, the system executes the segment reversal without an update and starts the segment rebook [Ext.] without updating the results.

   If you have selected Detail list, the system displays a detailed results list for the segment reversal or for the segment rebook.
9. To display the result list, choose Execute.
10. To post the segment reversal:
    a. Return to the initial screen.
    b. Deactivate the indicator Test run.
    c. Choose Execute.
If you have large amounts of data to process, it is advisable to execute the segment adjustment with background processing. This means you can process data at times of minimal system usage. To do so, under Processing options select Background processing.

Result
If you have selected the Detail list indicator, you can double-click to go to the actual line item report (after you have carried out the segment rebook) (see: Periodic Allocation Results [Page 805], Line Item Report [Page 1006]).
Reversing Segment Adjustments

Prerequisites
You have carried out a segment reversal [Ext.] or a segment reversal with segment rebook [Ext.] and you now want to reverse these postings again.

Procedure
1. Choose Accounting → Controlling → Cost Center Accounting → Period-end closing
   Single functions → Periodic reposting or
   → Single functions → Allocations → <allocation in question>
2. Choose Periodic reposting or <allocation in question> → Segment adjustment.
3. Under Posting parameters, enter the posting period and the fiscal year in which the posting was made.
4. Enter the cycle for which you want to reverse the segment adjustment.
5. Under Segment selection, enter one or more segments or one or more segment intervals from the selected cycle for which you want to reverse the segment adjustment.
6. Choose Segment adjustment → Reverse.

Result
The system reverses the postings of the segment reversal and segment rebook for the given segments and given posting period in the given fiscal year.
Displaying Previous Segment Corrections

Prerequisites
You have carried out a segment reversal [Ext.] or a segment reversal and segment rebook [Ext.] and you now want to see an overview of the adjustments for a single period of a fiscal year.

Procedure
Choose Accounting → Controlling → Cost Center Accounting → Period-end closing

  Single functions →
  Periodic reposting or

  Allocations → <Allocation in question>

Choose Periodic reposting or <Allocation in question> → Segment adjustment.

Choose Segment adjustment → Processed to date.

Enter the relevant fiscal year and periods.

Choose Execute.

Result
The system displays an overview of the periods and cycles in which segment reversals, segment rebooks or segment reverse and rebooks were carried out, together with the document entries.

To branch to the document display, double-click on a document number.
Example: Periodic Reposting of Telephone Costs

As the appearance of the SAP System interfaces can change, the screens used for the example may differ from the screens you are using. They are used in the example only as an aid to understanding.

Purpose

The charges for the telephone costs occurring in a given period arrive in a lump sum for the entire organization. However, you must charge the individual cost centers responsible for the telephone costs within the framework of the Cost Center Accounting component (CO-OM-CCA).

Prerequisites

You must be able to count the number of telephone calls, the number of charge units, the rates for long-distance calls, or some other meaningful measurement for each cost center in order to be able to assign costs.

Process Flow

One-Time Actions

2. Create a statistical key figure [Page 840] for use in telephone cost allocation.
3. Define periodic reposting [Page 841] for allocating the telephone costs.

Periodic Actions

1. Enter telephone costs in the Financial Accounting component [Page 844].
2. Enter statistical key figures [Page 845] for telephone calls made from each cost center.
3. Execute periodic reposting [Page 846].
4. Check the debits and credits by running a report [Page 847].

The process flow uses the following example:

You post the telephone costs for October, 15,000 USD, initially on the collection cost center 4712. In October, cost center 4713 made 50 calls and cost center 4714 made 100 calls. Periodic reposting allows you to allocate the telephone costs on cost centers 4713 and 4714 based on the number of calls made. Cost center 4713 is debited with 5000 USD and cost center 4714 with 10,000 USD; cost center 4712 is credited with 15,000 USD.
Creating Collection Cost Centers

In order to reduce the posting effort, when entering the telephone costs in the Financial Accounting component (FI), you can post them on an allocation cost center used exclusively for cost collection. First, you must create the collection cost center.

Procedure

You create the collection cost center in the Cost Center Accounting menu:

1. Choose Master data → Cost center → Individual processing → Create.
2. Enter a name for the cost center (for example, 4712).
3. Enter the timeframe in which you need the collection cost center.
4. Choose Master data.
5. Enter a name and a short description for the cost center (for example, Telephone in each field).
6. Enter the responsible manager for the cost center.
7. Enter a cost center category (such as A for administration).
8. Assign the cost center to a hierarchy area in the standard hierarchy.
   
   Do not assign collection cost centers to any cost center group belonging to the main line of the organization. Assign them instead to their own group node and assign it to the highest node of the standard hierarchy.

9. If you carry out cross-company-code cost accounting, assign your cost center to a company code. If necessary, assign a business area. If the Profit Center Accounting component (EC-PCA) is active in the controlling area, assign a profit center as well.

10. Save your entries.
Creating Statistical Key Figures

As tracing factor [Ext.] for the portion of telephone costs for the individual receiver cost centers, you use a statistical key figure [Ext.] (such as number of calls).

You create the statistical key figure in the Cost Center Accounting menu.

**Procedure**

1. Choose *Master data* → *Statistical key figure* → *Individual processing* → *Create*.
2. Enter a name for the statistical key figure (such as tel.).
3. Choose *Master data*.
4. Enter a description for the statistical key figure (such as Telephone Calls).
5. Enter a unit of measure for the statistical key figure (such as ST).
6. Select the statistical key figure category *Totals values*. The system posts the number of calls on the cost center for the current period only, and does not carry them over into the following periods.

   If you want to distribute telephone costs based on the number of telephone sets, choose the key figure category *Fixed values*. The system retains the number of sets as of the current period and carries it over into the following periods for the remainder of the fiscal year. If you increase the number of sets in a later period, this number will then apply to the following periods.
Defining Periodic Reposting

Use

To allocate telephone costs, you should use the periodic reposting [Ext.] allocation method. Periodic reposting has the advantage of requiring very little runtime to operate.

Periodic reposting uses the original cost element, meaning the primary cost element remains intact. When you allocate telephone costs, the allocating cost center is unimportant for the receiving cost centers. The R/3 System therefore stores data records for periodic reposting in a way that uses less memory than for, say, distribution. The sender cost center is not updated with this method.

To allocate telephone costs in Controlling (CO), you can use the following allocation methods:

- Periodic reposting
- Distribution [Ext.]
- Assessment [Ext.]

The allocation methods differ in the manner they transfer information from external accounting to internal accounting.

Procedure

To define a periodic reposting [Ext.], carry out the following steps:

1. Create a cycle [Ext.].
2. Create segments for the cycle.
3. Specify the tracing factors [Ext.].

Creating Cycles

In the initial screen for Cost Center Accounting, choose Period-end closing → Single functions → Periodic reposting. Reposting

In the Periodic Reposting initial screen, choose Extras → Create cycle.

You can also create the cycles you require in the Implementation Guide (IMG) for Cost Center Accounting. Under Actual Postings → Period-End Closing → Periodic Repostings, choose the IMG activity Define Periodic Repostings [Ext.]. In the dialog box, choose Create Actual Periodic Reposting.

Enter a name for the cycle (such as tel01).

Enter a starting date for the cycle.

Choose Execute to go to the entry screen for cycle header data.

Enter the date marking the end of the validity period for the cycle.

Enter a descriptive text for the cycle (such as Per.Reposting Telephone Costs).

Deactivate the Iterative indicator because no sender/receiver relationships appear during allocation of telephone costs.
Creating Segments

To create a segment, choose Attach segment.

Enter a name for the segment (such as 0001).

Enter a descriptive text for the segment (such as Credit CCtr 4712).

Accept the default settings for sender values and tracing factors.

The posted actual values that were posted on the sender are to be allocated in full to the receivers. Therefore, you choose rule 1, Posted amounts and a Portion of 100%. In addition, you accept the default setting Actual values.

The tracing factor for periodic reposting is the number of telephone calls carried out by the receiver cost centers. These are variable portions. Therefore, under Tracing factors, you accept rule 1, Variable portions.

Since you are using a variable receiver tracing factor that is based on statistical key figures, enter a 5 under Type of variable portions (actual statistical key figure). You save the statistical key figure representing the number of telephone calls in the next step, “Determining Tracing Factors”.

Under Scaling negative tracing factors, accept the default setting of 1 (no scaling).

In the group Allocation characteristics, enter the sender cost center and its cost element (such as your collection cost center 4712 and cost element 473120 (telephone call units)).

Enter the cost centers acting as receivers (such as 4713, 4714).

Defining Tracing Factors

Choose Tracing factors to go to the Tracing Factors initial screen.

The default settings in the Segment name, Type of variable portions, and Scaling negative tracing factors are taken from the segment entries.

Under Selection criteria, enter the statistical key figures serving as the basis of the periodic reposting. Enter your statistical key figure tel. This represents the number of telephone calls made from the receiver cost centers.

Save your entries.

You can specify the fields for sender and receiver data that are to be in the segment, and in the tracing factors in the Implementation Guide (IMG) for Cost Center Accounting. Choose Actual Postings → Period-End Closing → Periodic Repostings → Define Sender/Receiver Types for Periodic Reposting [Ext.].

For more information on creating cycles, see the IMG for Cost Center Accounting under Actual Postings → Period-End Closing → Periodic Repostings → Define
Defining Periodic Reposting

Periodic Repostings [Ext.] and under Definition of Periodic Repostings or Period-Based Allocations [Page 747].
Entering Telephone Costs in Financial Accounting

1. To enter the postings in the Financial Accounting component (FI) from the SAP R/3 initial screen, choose Accounting → Financial accounting → General ledger, then Document entry → G/L account posting.

2. To simplify account posting, you can enter the telephone costs in the Financial Accounting component with the posting from the collection cost center you created.

If you have more detailed information from the documents, you can also post directly to the responsible cost centers from the Financial Accounting component when the invoice arrives. If this is the case, you do not need to allocate the telephone costs to the Controlling component (CO).
Entering statistical key figures

You enter the number of telephone calls made by the individual cost centers [Ext.]. You enter statistical key figures [Ext.] in the Cost Center Accounting menu.

Procedure

1. In the Cost Center Accounting initial screen, choose Actual postings → Statistical key figures → Enter.
2. Accept the defaulted current document date and the posting date.
3. In the Version field, enter 0 (plan/actual version).
5. For each receiver cost center, enter the number of telephone calls made by using the statistical key figure tel.
Executing Periodic Reposting

To allocate telephone costs to the responsible cost centers, you can carry out the periodic reposting that you have defined. You carry out periodic reposting in the Cost Center Accounting menu.

**Procedure**

1. In the initial screen for Cost Center Accounting, choose *Period-end closing → Single functions → Periodic reposting*.
2. In the initial screen, enter the period and the fiscal year for your reposting. If, for example, you want to carry out reposting for the month of October, enter period 10.
3. Choose the desired processing type:
   a) Background processing
   b) Test run
   c) Detail lists
   Before you carry out the posting, you should execute a test run. The resulting values will not be posted at first.
   If you decide to use detailed lists, you can display the results of the periodic reposting in the screen. You have the option of branching to the line item display.
   For system performance reasons, choose *Background processing* for large periodic repostings.
4. Enter a name for the cycle (such as tel01).
5. Choose *Enter* to insert the additional entries for your cycle.
6. Choose *Execute* to carry out periodic reposting.
7. If you selected *Detailed list*, the system displays the *Basic list*.
8. The *Messages* column and the detailed list header display the number of error messages. To display the error messages, select the number of errors in the basic list header.
   You can also choose *Goto → Messages → All* to see all the messages.

**Note**

For more information, see *Periodic Repostings* [Page 359].
Executing Reports

After carrying out **periodic reposting [Ext.]**, you should check that the collection cost center was fully credited, and that the costs were debited to the originating cost centers. To do so, call up the **actual line item report [Ext.]**.

**Procedure**

1. To call up the actual line item report after executing periodic reposting, double-click on a row of the basic list.
2. To change the display of allocated telephone costs, choose **Current display variant** in the report.
   - Select the fields you wish to hide and choose **Hide selected fields**, or select the fields you wish to display and choose **Show selected fields**.
   - Choose **Confirm** to leave the dialog box.
   The credits on the collection cost center and the debits on the receiver cost centers always appear with the partner object.
3. Select the header for the **Value/CO area crcy** column and choose **Total**. The R/3 System displays the total for the selected column.
4. Select the header for the **Object** column and choose **Subtotal**.
   - In the next dialog box, you can decide whether to create subtotals for each cost center, and whether to sort them in ascending or descending order.
   - Choose **Confirm** to leave the dialog box.

The R/3 System creates subtotals for the line item values from each cost center.
**Variance Calculation**

**Use**
Variances in the Controlling component (CO) at period-end closing can be due to several causes:

- Planning was overshot/undershot
- The actual costs [Ext.] on the cost center or business process differ from the target costs [Ext.]
- Over-/under-absorption occurs on the cost center or the business process

Variance calculation [Ext.] lets you analyze the causes of these variations.

Variance calculation is based on the reconciled planning of internal activity between cost centers and business processes and the costs thereby incurred. Variances are the differences between actual costs and plan costs [Ext.] or target costs. They are displayed separately for a cost center, for an activity type of a cost center or business process, divided into fixed and variable portions. Where possible, they are classified by cost element.

Variance calculation distinguishes between cost centers with activity types (such as production cost centers) and those without (such as administrative cost centers). Actual costs are always posted as activity-independent. To determine the activity input, you therefore need to split the actual costs and the activity-independent plan or target costs of cost centers with activity types on the activity types (see: Actual Cost Splitting [Page 868]). In this way, you can analyze the reasons for the variances [Ext.] for a given cost center activity. Variance calculations compare detailed planning on the activity type level with the corresponding actual costs.

In order to compare plan with actual costs, you must determine the actual activity produced by the cost center or business process in contrast with planning. Variance calculation is therefore carried out on the basis of target costs.

Variance calculation allows you to analyze the actual balance. The system determines the variances of the target costs from the actual costs split on the activity types, as well as from the allocated actual costs in the different variance categories by cost element for each cost center/activity type or business process.

Cost center or business process variances can result from the following situations:

- Too few or too many costs were debited (see: Input-Side Variances [Page 855])
- Too few/too many costs were allocated (see: Output-Side Variances [Page 859])

**Input and Output Side**

These causes can occur separately or together, meaning that variances can originate on both the input and output side of a cost center or business process (see: Variance Categories [Page 853]).
Variance Calculation

Variance Causes

Input Side Variances

What caused the under-/overabsorption?

Cost variances?

- Have the prices changed?
  - 40 cents
  - Input price variance
  - 50 cents
  - +20%

- Have the consumption quantities changed?
  - 40 cents
  - Input quantity variance
  - 80 cents
  - +100%

- Have we used different materials?
  - 40 cents
  - Resource-usage variance
  - 60 cents
  - +50%

Output side variance

Input side variance

Actual costs: Input side

Target costs

Actual credit postings through activity allocation

Total variance

April 2001
Variance calculation is one of the functions performed at period-end closing. Variance calculation uses all the values resulting from all transactions in the Cost Center Accounting (CO-OM-CCA) and Activity-Based Costing components (CO-OM-ABC).

The SAP R/3 System
- Calculates the target costs first
- Splits the actual costs on the activity types [Ext.]
- Calculates variances by cost center, activity type, or business process based on the data

In special periods, variances are calculated on the basis of the target or plan costs of the prior periods. This means that in special periods variance calculation can only be carried out cumulatively. To do this, the system imports, the plan and targets costs of the special period in addition to the actual costs, as well as the actual costs of the prior periods. These costs are used to recalculate the overall variances of the analysis period.

You cannot allocate variances further within the Cost Center Accounting or Activity-Based Costing components. You can only credit a cost center or business process completely by using actual price calculation or through settlement to Profitability Analysis (CO-PA).

You can use reporting tools to further analyze the variance calculation results. These means that you can display relevant data divided into fixed and variable portions, or as totals:
- Operating rate [Ext.]
- Target costs and quantities
- Actual costs and quantities
- Variance categories [Ext.]

In addition, the R/3 System also displays:

- The calculation basis for the individual values (for instance, the distribution base for actual cost splitting)
- How the individual values are made up (for example, individual variance categories)

You can also use the functions Splitting explained, Target costs explained and Variance explained to call up the results in different formats.

As well as changing the list formats, you can also use the totaling and sorting functions. There is also a detail display by cost element for individual objects.

The individual processing steps can be followed successively and you can choose F1 to call up information for the given values.

You can display an overview of the different variance categories in a hierarchical structure. To do so, choose Variance explanation and then Variance categories. You can branch move from this tree structure to the individual variance categories or to the online help. The list for a variance category displays the variances and the relevant formula used for calculating the variance.

**Actions**

To start variance calculation:

1. Choose Actual postings → Period-end closing → Variances
2. Select Cost center, Cost center group, or All cost centers (in Cost Center Accounting) or Business process, Business process group, or All business processes (in Activity-Based Costing), and enter the appropriate object.
3. Enter the period and fiscal year.
4. Select one or more of the following processing indicators.
   - Background processing
   - Test run
   - Detail list

For more information about variance calculation and the functions of the explanation tool, see: Calculating Variances [Ext.].
Variance Calculation
**Variance Categories**

**Use**

The SAP System assigns variances to variance categories, according to the cause of the variance. The system distinguishes between the input and output sides of the cost center or business process.

**Features**

The table lists the different variance categories and their causes.

<table>
<thead>
<tr>
<th>Input Side Variance Categories</th>
<th>Cause of Variances</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input price variances</td>
<td>Change in price of the material component</td>
</tr>
<tr>
<td>Input quantity variance</td>
<td>The plan quantity differs from the actual quantity consumed</td>
</tr>
<tr>
<td>Resource-usage variance</td>
<td>No actual or target costs exist for a cost element</td>
</tr>
<tr>
<td>Remaining input variance</td>
<td>You chose not to calculate input quantity, input price, or resource-usage variances</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Output Side Variance Categories</th>
<th>Cause of Variances</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output price variance</td>
<td>You entered a price manually (such as for an activity type)</td>
</tr>
<tr>
<td>Output quantity variance</td>
<td>You manually posted a quantity that differs from the quantity leading to the credit posting on the cost center or business process</td>
</tr>
<tr>
<td>Volume Variance</td>
<td>The operating rate for a cost center or business process has changed</td>
</tr>
<tr>
<td>Secondary fixed cost variance</td>
<td>A portion of the target fixed costs are dependent on the operating rate</td>
</tr>
<tr>
<td>Remaining Variance</td>
<td>You chose not to calculate volume-, fixed cost- or output price variances</td>
</tr>
</tbody>
</table>
Idle capacity cost variance is not a variance category. You can, however, determine idle capacity cost variance in certain cases, based on the volume variance and the output price variance (see: Output Side Variances [Page 859]).
Input Side Variances

Use

The input side [Ext.] consists of all debits and credits on the cost center or business process, other than credits due to activity allocations.

The input side compares actual costs [Ext.] with target costs [Ext.]. Input side variances [Ext.] include additional costs, reduced costs, and changed consumption of the individual cost elements, divided into fixed and variable portions. The input side variance categories include:

- Input price variances [Ext.]
- Input quantity variances [Ext.]
- Resource-usage variance [Ext.]
- Remaining input variances [Ext.]

The variance categories of the input side are determined periodically for each cost element.

Features

Input price variances

Input price variance indicates changes in costs due to prices.

Variances caused by price and quantity differences are also assigned to input price variances.

If you planned 10 labor hours worth 1000 USD for a cost element, and posted 10 hours worth 2000 USD in the actual, the price variance for the 2000 USD equals 1000 USD. Based on the plan data, 10 hours should cost 1000 USD. The difference between actual and plan data is due to higher prices (wages in this case) because there is no difference in activity quantity consumed.

The R/3 System calculates and posts the input price variances for primary postings by business transaction, as described in the Implementation Guide (IMG) under “Determining Primary Data Price Variances”. You can display input price variances in the information system.

The R/3 System calculates the input price variances again if you specify quantities long with costs in the postings.

If the quantities are incomplete or missing, the R/3 System takes the input price variances from the posting rates of actual costs as calculated on a percentage basis during postings by business transaction. If no percentage rates exist, the R/3 System cannot calculate input price variances.

In target/actual comparisons, the input price variances are defined by the following formulas:

Input price variance = (Actual price – Plan price) X Actual input quantity

Fixed input price variance = (Fixed actual price – Fixed plan price) X Actual input quantity
Input Side Variances

For activity relationships using predistribution of fixed costs [Ext.], the system uses the posted input price variances of the totals records (see: Predistribution of Fixed Costs [Page 871]).

Input quantity variance

Input quantity variance indicates under- and over-consumption for cost elements. Variances arising from both price and quantity differences appear as input price variances.

To support the activity type Machine Hours, you plan the consumption of 10 liters of lubricant in proportion to the activity quantity produced. For an operating rate of 110%, the actual lubricant consumption is 12 liters. The input quantity variance amounts to one liter. To produce the cost center activity, there was an over-consumption of one liter of lubricant when compared to the plan. Consumption based on the operating rate should be only 11 liters.

For target/actual comparisons, the quantity variances are defined by the following formulas:

Input quantity variance = (Actual input quantity – Target input quantity) X Plan price
Fixed input quantity variance = (Actual input quantity – Target input quantity) X Fixed plan price

Calculation of input quantity variances is possible only if complete consumption quantities exist in both target and in actual.

For activity relationships using predistribution of fixed costs, the system uses the difference between target costs and actual costs, minus the input price variance, as the input quantity variance (see: Predistribution of Fixed Costs [Page 871]).

Hints for Cost Center Accounting:

- To determine input price or input quantity variances, the SAP System requires consumption quantities as well as plan and actual costs. In this way variance calculation can determine cost and consumption influences and display them. It is often sufficient, however, to plan consumption quantities only for those cost elements that are subject to price fluctuations and also represent important costs. Enter a unit of measure in the master data for the given cost element. You can also use units of measure for which a conversion is possible. Additionally, if you select Record quantities in the cost element and cost center master data, the R/3 System issues a warning if you do not post quantities. The deciding factor for the separate calculation of quantity and price variances is the unit of measure.

- If recording consumption quantities is difficult or impossible, you can still determine input price variances. To do so, you must store percentage input price variances for individual cost elements during Customizing. The R/3 System uses these input price variances based on transaction for primary postings and for period-end closing during variance calculation. The system displays the resulting input quantity variance in the remaining input variance (see: For more information, see the IMG for Cost Center Accounting, under Actual Postings → Variances → Specify Primary Data for Input Price Variances [Ext.]).
Resource-usage variance

Resource-usage variance indicates changes in the plan consumption of cost elements. It occurs if you post an unplanned cost element in actual, or if no actual data exists for a plan cost element.

The resulting difference between plan and actual postings cannot be assigned to either input price or input quantity variance. The R/3 System has no basis for comparing plan and actual data postings. They are thus identified as variances in resource usage.

You post plan costs of 100 USD on a cost center under cost element 400.000. You make the corresponding actual posting under cost element 410.000. Variance calculation identifies both entries as resource-usage variances equal to the amount of the posted costs.

The system determines resource-usage variances if either no controllable costs, or no target costs exist for a cost element.

In target/actual comparisons, the resource-usage variances are defined by the following formulas:

Resource-usage variance = Actual costs – Target costs – Input price variance

Fixed resource-usage variance = Fixed actual costs – Fixed target costs – Fixed input price variance

Remaining input variance

Remaining input variance includes all the variances occurring on the input side which cannot be assigned to any of the following categories:

- Input price variances
- Input quantity variance
- Resource-usage variance

This can be due to several causes:

- You planned cost elements and made actual postings, but did not record consumption quantities. The SAP R/3 System therefore cannot determine input price or input quantity variances.
- A user deactivated variance calculation for one of the listed categories. The resulting variance amount is assigned by the system to the remaining input variance.

For many organizations, remaining input variance is often the classic consumption variance (input quantity variance). Cost elements that react quickly to price changes are recorded by quantity, which ensures an exact calculation of input price and input quantity variances for these cost elements. For cost elements with little or no price sensitivity, the difference between actual and target costs is usually caused by greater consumption. This procedure reduces the requirements for entering plan and actual data, but lets you display results for individual cost elements.

If you specified in the variance variant that the system does not calculate input price, input quantity, or resource-usage variances, the system displays only the remaining input variance on the input side.
Input Side Variances

Input Side Variance Categories
Output Side Variances

Use

The output side [Ext.] consists of all the credits for a cost center or business process that are due to activity allocations. On the output side, the system compares the allocated actual costs [Ext.] with the target costs [Ext.] or plan costs [Ext.]. The output side variance categories include:

- Output Price Variance [Ext.]
- Output Quantity Variance [Ext.]
- Fixed Cost Variance [Ext.]
- Volume Variance [Ext.]
- Secondary Fixed Cost Variance [Ext.]
- Remaining Variance [Ext.]
- Idle-Capacity Cost Variance [Ext.]

Features

Output Price Variance

An output price variance occurs if you use a price that differs from the plan price, which is calculated iteratively each month, based on plan activity. The target credit posting (= plan price x actual activity) varies from the actual credit posting (= allocation price x actual activity) on the affected cost center or business process. Output price variance can be due to several causes:

- If you use average prices instead of period-based prices
- If the capacity of the activity type is used as the basis of the price calculation.
- If you set a price manually

Output price variances are determined by the following formula:

Output price variance = actual activity x (plan price - actual price)

You plan 100 hours of an activity on a cost center/activity type with plan costs of 1000 USD. The plan price is 10 USD/hr. In the actual, you use a manually-set price of 12 USD/hr. Actual activity of 110 hours produces an actual credit posting of 1320 USD (= 110 hours x 12 USD/hour) on the cost center. The target credit, however, equals 1100 USD (110 hours x 10 USD/hour). The output price variance is therefore 220 USD.

If the given activity type of a cost center or a business process participates in the predistribution of fixed costs [Ext.], the fixed target credit is not dependent on the operating rate, but corresponds to the plan fixed costs (see: Fixed Cost Distribution [Page 871]).
Output Side Variances

If you have manually entered the actual quantity for the given activity type of the cost center or business process, the system calculates the output price variance corresponding to the input price variance.

Output price variance =
Target credit x (manual actual qty/output qty) - allocated Act. costs

Fixed output price variance =
Fixed target credit x (manual actual qty/output qty) - allocated Act. costs

Output Quantity Variance

The output quantity variance is the difference between the actual credits and the target credits, which is the difference between the manually-entered actual costs and the allocated actual quantities.

Variance calculation determines output quantity variance by cost element on a period basis.

Output quantity variance is based on the formula
Output quantity variance = (actual qty - manual actual qty) x plan price
Fixed output quantity variance = (actual qty – manual actual qty) x fixed plan price

Variances arising from both price and quantity differences appear as output price variances.

If the corresponding activity is part of predistribution of fixed costs, the fixed target credit is not proportional to the operating rate (see: Predistribution of Fixed Costs [Page 871]).

Fixed Cost Variance

Fixed cost variances occur when the actual operating rate varies from the plan operating rate and some of the planned fixed costs are either underabsorbed or overabsorbed due to the credit postings.

The fixed cost variance is displayed by cost element and calculated periodically.

The fixed cost variance comprises:

The volume variance
The secondary fixed cost variance

The fixed cost variance is based on the following formula:

Fixed cost variance =
Plan fixed costs X (1 - operating rate) + fixed target costs - plan fixed costs
The system only determines the fixed cost variance if the operating rate varies from 100%.

**Volume Variance**

Volume variance shows for each cost element the over/underabsorption of fixed plan costs for each activity type or business process. It shows whether the fixed costs are covered by the actual activity. The cause of this variance category is always an actual activity varying from the plan activity – not, for example, a manually-set fixed allocation price. The results for the covering fixed costs are also affected by a manually-set allocation price. However, the cause of the variance is not the activity, but rather the structuring of the allocation price.

Volume variance is based on the formula

\[
\text{Volume variance} = \text{fixed plan costs} \times (1 - \text{operating rate})
\]

The following data is given:

<table>
<thead>
<tr>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed planned costs</td>
<td>1,000 USD</td>
</tr>
<tr>
<td>Plan activity</td>
<td>100 hours</td>
</tr>
<tr>
<td>Calculated plan price</td>
<td>10/hr</td>
</tr>
<tr>
<td>Actual activity</td>
<td>200 hours</td>
</tr>
</tbody>
</table>

Based on actual activity of 200 hours, you allocate fixed costs of $2,000 (= $10/hour \(\times\) 200 hours).

Because the fixed plan costs equal only $1,000, the volume variance equals – $1000 (= $1,000 – $2,000), being the overestimated portion of fixed costs due to actual activity.

If an activity type or a business process take part in the predistribution of fixed costs, the volume variance is **not** calculated (see: Predistribution of Fixed Costs [Page B71]).

**Secondary Fixed Cost Variance**

Secondary fixed cost variance is the difference between fixed plan costs and fixed target costs. It occurs only if a cost center or a business process carries out an activity-dependent activity input. Part of the fixed target costs (= fixed price \(\times\) variable target quantity) is dependent on the operating rate. The result is a difference between the planned fixed costs and the target fixed costs.

If an activity type or a business process take part in the predistribution of fixed costs, the secondary fixed cost variance is **not** calculated. In this case, the target...
Output Side Variances

Fixed costs correspond to the plan fixed costs (see: Predistribution of Fixed Costs [Page 871]).

Remaining Variance

Remaining variance indicates a difference between target costs and allocated actual costs that cannot be assigned to any of the following variance categories:

- Output price variance
- Output quantity variance
- Fixed cost variance

This can be due to the following causes:

- You deactivated calculation of variance categories on the output side.
- You deactivated all variance categories. If this is the case, the sum of all variances determined is displayed in the remaining variance.

The system does not calculate and display the remaining variance by cost element, but does so for the entire Controlling object.

The following special cases are also possible:

- Minor differences appear as remaining variance if you wish.
- If no target costs exist for the Controlling object, this also results in all variances appearing under remaining variance.

Idle Capacity Cost Variance

The system cannot determine idle capacity cost variance directly. However, you can also calculate it from the volume variance and the fixed portion of the output price variance if the following prerequisites are fulfilled:

- The system calculated period-based prices for the activity on the basis of capacity.
- No subsequent adjustment occurs in the actual.

In this case, the idle capacity cost variance is calculated as follows:

Idle capacity cost variance = volume variance + fixed output price variance

To display the idle capacity cost variance, you have two options:

- Variance calculation determines the volume variance and the output price variance
- You can then use a report to display the two variance categories together and identify them as idle capacity cost variance.

Idle capacity cost variance appears as the sole variance category on the output side

- If this is the case, you must deactivate all variance categories on the output side with the exception of remaining variance. The idle capacity cost variance then appears to the remaining variance.
- However, you must define the variance variant for the entire controlling area.
Output Side Variance Categories

- Output price variance
- Target costs or target credit
- Volume variance
- Output quantity variance

Price

Allocated actual costs

Activity

Plan activity
Manually posted actual activity
Scheduled actual activity
System Settings for Variance Calculations

Use

Variance calculation [Ext.] is carried out in several steps. You must differentiate between system configuration in Customizing, which is a prerequisite for variance calculation, and the further steps executed within variance calculation itself. These include:

- Target cost calculation
- Cost splitting

Once you complete these steps, the system can calculate the variances.

You can perform cost splitting and target cost calculation without calculating variances. However, if you calculate variances, the system performs these steps automatically.

Features

For more information on Customizing, see the Implementation Guide (IMG) for the Activity-Based Costing component (CO-OM-ABC) under:

- Actual postings → Variances → Maintain target versions [Ext.]
- Actual postings → Variances → Maintain variance variants [Ext.]

See also the IMG for Cost Center Accounting, under:

- Actual postings → Period-end closing → Activity allocations → Splitting [Ext.]

Creating Target Versions

Before you can calculate variances, you must set up a target version for the relevant controlling area. The target version determines the following.

- The versions the system uses for plan and actual data
- The version to which the system posts split actual costs and the variances

Moreover, you must specify the cost element group for which the first stage of actual cost splitting is performed, and the variance variant for which the variances are calculated.

Version 000 is the only version permitted for all plan, actual, and target versions. The system automatically sets any plan or actual versions to version 000. The target version is necessary nevertheless for standardization of variance calculation in the Cost Center Accounting and Product Cost Controlling components.

Assigning Variance Variants to Target Versions

The variance variant controls which variance categories are to be calculated.
Determining Splitting Rules in Splitting Structures

You assign splitting rules to a splitting structure. You save the splitting structure in the cost center master data (see: Cost Center Master Data [Page 133]). The splitting rules you define determine the criteria for actual cost splitting on the activity types of a cost center.

See also:

Target Cost Calculations [Page 866]
Actual Cost Splitting [Page 868]
Target Cost Calculation

Use

To achieve useful comparisons of the plan [Ext.] and actual costs [Ext.] of a period, you need a consistent basis. Plan and actual costs are compared on the basis of actual activity.

The system uses the operating rate [Ext.] to adjust the plan costs of a period to the actual activity.

The operating rate is based on the following formula:

\[
\text{Operating rate} = \left( \frac{\text{Actual activity}}{\text{Plan activity}} \right) \times 100
\]

The plan costs adapted to actual costs in this manner are called target costs. In variance calculation, the system calculates target costs for each cost center and business process in each period. The values are calculated according to the following formulas:

- **For activity-dependent costs that were not incurred through internal activity allocations [Ext.]**: The value-based viewpoint is in the foreground here, even if you enter additional quantities during planning.
  
  \[
  \begin{align*}
  \text{Fixed target quantity} &= \text{Fixed plan quantity} \\
  \text{Variable target quantity} &= \text{Variable plan quantity} \times \text{Operating rate}
  \end{align*}
  \]
  
  Fixed target costs = Fixed plan costs
  Variable target costs = Variable plan costs \times \text{Operating rate}
  Total target costs = \text{Fixed plan costs} + \text{Variable plan costs} \times \text{Operating rate}

  For these costs, the emphasis is on value-based calculation, even if additional quantities are entered when planning.

- **For credit records from internal activity allocations**: Fixed target costs = Fixed plan costs \times \text{Operating rate}
Variable target costs = Variable plan costs \times \text{Operating rate}

  If an activity type or a business process participate as senders in predistribution of fixed costs [Ext.], the fixed costs are not corrected with the operating rate (see: [Predistribution of Fixed Costs [Page 371]]). In this case:

  Fixed target costs = Fixed plan costs

- **For all activity-independent costs**: Fixed target costs = Fixed plan costs
  Variable target costs = Variable plan costs

- **For activity-dependent costs from internal activity allocation.**
Fixed target quantity = Fixed plan quantity
Variable target quantity = Variable plan quantity \times Operating rate

Fixed target costs = Fixed target quantity \times Fixed price
+ Fixed target quantity \times Variable price
+ Variable target quantity \times Fixed price

Variable target costs = Variable target quantity \times Variable price.

Here, the emphasis is on quantity-based calculation because allocation takes place via activity quantities. The target costs can vary with the operating rate because the variable target quantity is included in the fixed target costs.

If during activity allocation you assigned the fixed costs using predistribution of fixed costs, (see: Predistribution of Fixed Costs [Page 871]), the target costs are calculated as follows:

Fixed target costs = Fixed plan costs
Variable target costs = Variable plan costs \times Operating rate

In this case, the fixed costs are not dependent on the operating rate.
Actual Cost Splitting

Use

Actual cost splitting [Ext.] makes it possible to divide costs into fixed and variable portions. You can also use it to carry out target/actual comparisons and to calculate actual prices.

If you have posted actual costs [Ext.] exclusively to cost centers, these costs must be apportioned (split) on the activity types [Ext.]. It is only in this way that you can compare the actual costs with the target costs [Ext.] of the activity types and display the variances by activity type.

The actual costs are split in two stages:

In the first splitting step, the system distributes actual costs by cost element to the activity types based on the target costs or target quantities.

If no target costs exist for a cost element, the R/3 System uses the target costs of the assigned cost element group to determine a tracing factor for the first splitting step.

This entails:

- The distribution of primary costs [Ext.], based on the target costs.
- The distribution of secondary costs [Ext.] (indirect activity allocation [Ext.]) based on the target quantities, if these exist. If this is not the case, the distribution is based on the target costs.

By splitting costs you can compare actual costs directly with target costs.

A second splitting step is necessary if:

- No target costs or quantities exist for the cost element or cost element group. In this case, the basis for actual cost splitting is missing.
- Activity-independent target costs or quantities exist. In this case, the portion of actual costs corresponding to the activity-independent target costs (or quantities) remains on the cost center.

In the second splitting step, the actual costs are distributed on the activity types according to splitting rules. If you have not defined any splitting rules for a cost center, the R/3 System splits actual costs based on the equivalence numbers for the activity types.

The system treats actual costs as fixed costs after the second splitting step.

To further compare actual costs with target costs, the system also distributes the plan and target costs based on the same tracing factors.

Plan cost splitting uses only the second splitting step.

Direct account assignment of activity types has an effect on actual cost splitting (see: Actual Postings to Activity Types [Page 546]). The R/3 System requires that the costs assigned directly to the activity types are assigned correctly, and in full, to the activity types. Directly assigned activity types do not therefore take part in the first splitting step. The R/3 System simply splits the cost into fixed and variable. In the second splitting step, the R/3 System also splits the activity-independent costs on the
directly assigned activity types (see: Example of Splitting After Account Assignment to an Activity Type [Page 548]).

Prerequisites
To define splitting rules, go to the Implementation Guide (IMG) under Controlling → Overhead Cost Controlling → Cost Center Accounting → Actual Postings → Period-End Closing → Activity Allocation → Splitting [Ext.].

If you not made any settings for splitting in the IMG, the splitting is based on equivalence numbers.

Features
To define splitting rules you first create a splitting structure. A splitting structure contains one or more assignments in which you store splitting rules for the corresponding cost element(s) or cost element groups. You can restrict the selection of cost elements or cost element groups, as well the activity types on which the costs are split.

Splitting methods are assigned to the splitting rules. These methods specify how the costs are split. Based on the splitting methods, which are set as fixed in the SAP System, you can split actual costs according to the following criteria:

- Activity quantity
- Equivalence number
- Capacity
- Output
- Scheduled activity
- Statistical key figure (quantity)
- Statistical key figure (maximum quantity)
- No splitting is executed

You can also use weighting indicators to control whether tracing factors are to be weighted for the cost splitting. Set the indicator if the individual tracing factor values use different units of measure. If the Conversion indicator is active, the values are multiplied with the equivalence numbers of the activity types. In this way the different units of measure remain comparable to one another.

Actions
To run the actual cost splitting function without calculating variances in the Cost Center Accounting initial screen, choose

Cost centers → Actual postings → Period-End Closing → Allocations → Splitting.

See also:
Plan Cost Splitting [Page 481]
Predistribution of Fixed Costs

Use

You use Predistribution of Fixed Costs [Ext.] as part of marginal costing. You can use predistribution of fixed costs for Cost Centers [Ext.] and Business Processes [Ext.].

It is also useful in marginal costing, as part of overall costing, to determine cost of goods manufactured [Ext.] based on full costs. As a result, along with allocation of variable (marginal) costs via internal activity allocation, you must also allocate fixed costs from sender cost centers or sender business processes on the cost objects [Ext.]. Because the fixed preparation costs are not proportional to the operating rate, you should not allocate them based on the activity output of the sender cost centers/sender business processes.

Predistribution of fixed costs solves this problem by distributing the fixed costs in their entirety on the cost centers or business processes that plan the activity inputs. This enables you to prepare the activities of sender cost centers or sender business processes within the framework of a reconciled activity plan. Remember: the sender cost center or sender business process did not cause the fixed costs for the provision of these activities because the activity input was planned by other cost centers or business processes.

Features

For each activity type of a sender cost center or for each business process, the system distributes the fixed plan costs of version 0 as actual costs on the cost centers or business processes that planned the activity inputs.

Senders of fixed cost predistribution can be cost centers/activity types or business processes, if, for the given activity type or business process you set the indicator Predistributed fixed costs in the master data or under planning. See also: Predistribution of Fixed Costs [Page 375].

Receivers of predistribution of fixed costs can only be CO objects of the type cost center, cost center/activity type, or business process. No other CO objects can function as receivers.

If, however, you settle plan-integrated orders or projects on a cost center in plan, fixed cost predistribution takes place on the receiver cost center (see under “Order Settlement” below).

The distribution of the fixed costs on the receiver cost centers or business processes is proportional to the fixed portion of the plan activity input quantities. The amount of the fixed cost predistribution equals the plan activity input on the receiver cost center or receiver business process multiplied by the fixed plan price of the sender cost center or sender business process. This amount is posted in the actual.

This ensures the absorption of activity-independent costs by the cost centers or business processes planning the given activity input, regardless of the operating rate.

The following graphic illustrates the predistribution of fixed costs:
Predistribution of Fixed Costs

Integration

If you use fixed cost predistribution for activity types belonging to a cost center or for business processes, this affects actual allocations and period-end closing.

Actual Activity Allocation

For activity types or business processes used in predistribution, the receiver category determines whether the actual activity allocation assigns the total costs or only the variable costs to the receivers (cost center or business processes).

The system thereby prevents activity receivers from being debited twice with fixed costs.

- If, for the sender, the indicator Predistributed fixed costs is set and the receiver is of category cost center, cost center/activity type, or business process, only variable costs are allocated under internal activity allocation. The fixed portion is ignored.

- If the sender participates in the predistribution of fixed costs, but the receiver does not (because it is not a CO object of the category cost center, cost center/activity type, or business process) the system allocates the fixed and the variable costs.

- If the indicator Predistributed fixed costs is not set for the sender, the system allocates both fixed and variable costs, regardless of the receiver.

This applies to all actual activity allocations, whether or not fixed cost predistribution actually posts fixed costs on the receivers.

order settlement

You cannot use plan-integrated Orders [Ext.] or projects as receivers. The system always debits these with fixed and variable costs.

If orders and projects settle on cost centers or business processes participating in predistribution of fixed costs, the system prevents these cost centers or business processes from being debited twice with the fixed costs. The fixed costs from activity allocation are in this case reallocated from
the order back to the sender cost center (assuming this cost center predistributed its fixed costs). This occurs whether or not fixed cost predistribution actually posts fixed costs on the receivers.

⚠️

The reversed posting of fixed costs occurs only during period-based order settlement, not during full settlement. Therefore, you may not settled orders in the actual using full settlement, if they have used activities whose fixed costs have been predistributed.

The following graphic illustrates the predistribution of fixed costs with planning integrated orders:

---

**Target Cost Calculations**

When you use predistribution of fixed costs, the system uses other target cost formulas to determine **Target Costs [Ext.]** (for more information, see **Target Cost Calculation [Page 866]**).

**Actual Price Calculations**

⚠️

In the SAP System, revaluation during actual price determination should not carried out in conjunction with predistribution of fixed costs, because the former overwrites the latter's data.
Predistribution of Fixed Costs

Variance Calculation

**Input Side [Ext.]:**
If the sender activity type or sender business process predistributes fixed costs, you cannot calculate prices in target nor in actual. The total quantities in the relevant data records then refer solely to the variable portion of costs.

⚠️
Because you cannot calculate prices based on the actual cost rates with predistributed fixed costs, any earlier calculations of *input price* [Ext.] or *input quantity variance* [Ext.] will produce false results.

*Input quantity variances* [Ext.] exist for activity inputs only if you implement actual price calculation without revaluation, meaning you use the same price in both plan and in actual. If you reevaluate activity inputs in actual, you must update the *input price variances* [Ext.] for variance calculation in the actual data records.

**Output Side [Ext.]:**
If the cost center or business process in question predistributes its fixed costs, this will not result in *volume variances* [Ext.], but it will produce over- or under-absorption of the fixed costs. This variance arises if the cost center or business process allocates activities in actual (and, thus, fixed costs) to objects outside of Cost Center Accounting or Activity-Based Costing. The variance is thus displayed as *remaining variance* [Ext.].

The system multiplies the plan costs of the input side by the *operating rate* [Ext.] in order to calculate the target credit for *variance calculation* [Ext.]. This is equivalent to multiplying the plan price by the actual activity. As the result thereby includes the operating rate variance, the difference between target and actual credit equals the *output price variance* [Ext.].

In the case of fixed cost predistribution, the system corrects the fixed portion of the target credit so that the operating rate variance is no longer included. The difference between target and actual credit then includes the allocation price variance and the over-absorption of fixed costs described above. The over-absorption of fixed costs then becomes part of the fixed allocation price variance (see *Variance Calculation* [Page 348]).

**Activities**
For more information on carrying out predistribution of fixed costs, see *Executing Predistribution of Fixed Costs* [Page 875].
Executing Predistribution of Fixed Costs

Prerequisites

- You can define fixed cost predistribution for each activity type of a sender cost center or sender business process. It does not matter whether the relevant indicator is set for the receiving cost centers or business processes.
  
  You can store a default value for this purpose in the activity type master data (see: Processing Activity Types [Page 157]). For business processes, you can store a default value in the business process master data or define a value for the business process category (see: Fields in the Business Process Master Record [Ext.]).

- The final determination of the predistribution of fixed costs [Ext.] occurs in activity type planning or process output planning.
  
  You can overwrite the default value there (see Activity Type Planning [Page 208] or Planning Process Outputs (Quantities and Prices) [Ext.]) In planning itself, you can change the fixed cost predistribution indicator only if no actual cost postings exist.

- You carry out predistribution after finishing planning.
  
  You can carry out fixed cost predistribution either as part of plan price calculations [Page 485] or in a separate allocation for selected cost centers or business processes, for cost center groups or business process groups, or for the entire controlling area [Ext.].

Procedure

Executing Predistribution of Fixed Costs as Part of Plan Price Calculation

You can execute the actual postings for fixed cost predistribution as part of your plan price calculations.

1. Choose Accounting → Controlling → Cost Center Accounting (or Activity-Based Costing) → Planning → Allocations → Price calculation.

2. Select the indicator With fixed cost predistribution (see Plan Price Calculations [Page 485]).

Executing predistribution with price calculation results in better system performance because the corresponding plan allocations already exist. Activity types with manually-set prices also take part in fixed cost predistribution when executed with plan price calculations.

Executing Predistribution of Fixed Costs as a Separate Allocation

1. To carry out predistribution of fixed costs in a separate allocation run, choose Accounting → Controlling → Cost Center Accounting (or Activity-Based Costing) → Period-end closing → Single functions → Predistribution of fixed costs.

2. You can limit predistribution of fixed costs to the following objects:
   a. Cost center or business process
   b. A certain number of cost centers or business processes
   c. Cost center group or business process group
Executing Predistribution of Fixed Costs

d. All cost centers or business processes in a controlling area

e. All cost centers or business processes belonging to a given selection variant

You save selection criteria for cost centers in a selection variant [Ext.]. You can use the variant to select all cost centers with the same entries in one or more master data fields.

To create new selection variants, choose Goto → Selection variant → Create.

i. In the list of fields, enter the criteria to be used for selection. For example, you can select all cost centers belonging to a given company code.

ii. Save your entries.

iii. Enter a name and a description for your variant.

iv. Save your entries.

To change an existing selection variant, choose Change selection variant.

To display an existing selection variant, choose Display selection variant.

3. Choose one of the objects.

4. Enter the version, periods and fiscal year for which you want to carry out predistribution of fixed costs.

5. If you wish, you can run predistribution of fixed costs as a test run only. To do so:

a. Use the default settings for test run and detail list

b. Choose Execute.

The detail list display uses the ABAP list viewer [Ext.].

6. To execute predistribution of fixed costs as an update run (as opposed to a test run):

a. Return to the initial screen.

b. Deactivate Test run.

c. Choose Execute.

Reversing Predistribution of Fixed Costs

⚠️ Reversing fixed cost predistribution is useful only if an error occurred during the posting. Carry out the reversal only if you really want to reverse all postings.

To reverse predistribution for the period entered, on the Predistribution of Fixed Costs: Cost Centers screen, choose Extras → Reset.

Result

The system allocates the plan fixed costs in version 000 as actual costs on the plan receivers (cost center or business process) for the activity types of a cost center or for the sender business processes participating in predistribution of fixed costs.

You can repeat predistribution of fixed costs as often as you wish. If you do so, the system updates only the difference between the old and new allocation. If the values do not vary from the previous allocations, the system does not update any values.
Actual Price Calculations

Use

During actual price calculation, the system calculates iterative prices for activity types [Ext.] or business processes [Ext.] based on actual costs and actual activities. The calculation takes into account all activity exchanges between cost centers [Ext.] or business processes.

Price calculation [Ext.], which you can carry out during planning, is based on planned costs and activity. The resulting prices are used to valuate actual activity.

After running actual price calculation, you can choose to revalue actual activity at actual prices. This revalues the activity using the difference between plan and actual prices. By revaluing the actual activity with actual prices, you can fully balance sender cost centers and sender business processes.

A reposting of internal activity allocation can also be carried out in a different period (see: Reposting Internal Activity Allocation [Page 525]). Due to the negative activity flow between the old receiver and the sender, the old receiver may contain a negative quantity.

During reposting of internal activity allocations in other periods, then, use cumulated price calculation because other types of price calculations will produce inconsistent results (see Price Calculation Methods [Page 833]).

If you are working with transfer prices (parallel value flows) actual price calculation and recalculation are possible in all valuations. In the output list of the price calculation, you can choose to display the prices in all valuations.

For more information on transfer prices, see Multiple Valuation Approaches in Overhead Cost Controlling [Ext.] and also the SAP Library under Financials → EC Enterprise Controlling → EC Profit Center Accounting → Multiple Valuation Approaches/Transfer Prices [Ext.]

Prerequisites

You must meet the following requirements before you can recalculate actual activity at actual prices:

- Activate the relevant indicator in the version

In the fiscal year parameters for the version [Ext.], you can specify the method of price calculation (see Price Calculation Methods [Page 833]), or whether to allow recalculation of actual activities with actual prices, and how the recalculation is to be executed. The Recalculation field controls the recalculation of actual activity at actual prices. See Planning → Basic Settings → Versions → Maintain Versions [Ext.] in Customizing for Cost Center Accounting or Planning → Maintain Versions [Ext.] in Customizing for Activity Based Costing.

You have the following options:

- Recalculation in a special business transaction [Ext.]
The system posts the difference between the plan and actual allocation valuations using a separate business transaction (actual price calculation). This makes it easier to track variances between valuations using actual and plan prices.

- Recalculation in the original transaction
  
The system posts the recalculation in the original transaction. The variances between calculations at actual and plan prices can then no longer be tracked. Use this option if you do not have plan prices, meaning the original allocation was not valuated.

- Maintain the price indicator in activity type planning or process output planning
  
The system takes default values from activity type master data for the plan and actual price indicators (see Activity Type Category [Page 148] and Processing Activity Types [Page 157]) or the business process master record (see Price Indicators [Page 151]).
  
  You can change both indicators when planning, providing no plan values exist. However, you must use a planning layout with the characteristics Actual price indicator and Plan price indicator (see Standard Planning Layout [Page 828]).

  If you do not fill the Actual price indicator field, the system automatically valuates activity using the plan price.

- If you need to split the costs on activity types or business processes and divide them into fixed and variable portions (say, for reporting), you should carry out actual splitting with update before you carry out the actual price calculation (see Actual Cost Splitting [Page 868]).

  You can also carry out splitting during actual price calculation. To do so, select Execute actual splitting internally in the Settings for Price Calculation. Note, however, that this procedure does not post the splitting data.

- If the activity receivers are orders, you must recalculate the orders before you carry out the price calculation with recalculation using actual prices. To do so, go to the Internal Orders initial screen and choose Period-end closing → Single functions → Recalculation at actual prices → Individual processing.

Activities

To carry out actual price calculation, from the Cost Center Accounting menu or Activity Based Costing menu, choose:

Period-end closing → Single functions → Price calculation

See also:

Executing Price Calculation [Page 489]

For more information on how to calculate actual prices and interpret the results, see also:

Example of Price Calculation [Page 881]
Actual Price Calculations

- Calculating Actual Activity at Actual Prices [Page 882]
- Price Calculation Methods [Page 883]
- Price Calculation With Cost Component Split [Page 887]
- Plan Price Calculation [Page 485]
Example of Price Calculation

Sender A has the following plan and actual values:

<table>
<thead>
<tr>
<th>Costs</th>
<th>Activity</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td>$100</td>
<td>10 hrs</td>
</tr>
<tr>
<td>Actual</td>
<td>$110</td>
<td>9 hrs</td>
</tr>
</tbody>
</table>

The following activity input is performed:

<table>
<thead>
<tr>
<th>Senders</th>
<th>Primary costs</th>
<th>Receivers</th>
<th>Activity input</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td>A</td>
<td>B</td>
<td>10 hrs</td>
<td>$10/hr</td>
</tr>
<tr>
<td>Actual</td>
<td>A</td>
<td>B</td>
<td>9 hrs</td>
<td>$10/hr</td>
</tr>
</tbody>
</table>

The actual activities are valuated with plan activity prices: 9 hrs X $10 /hr, resulting in allocated actual costs of $90.

If actual price calculation is performed, the following values result:

<table>
<thead>
<tr>
<th>Sender credit</th>
<th>Sender balance</th>
<th>Sender revaluation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>10 hrs * $10/hr = $100</td>
<td>0</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>9 hrs * $10/hr = $90</td>
<td>$110 - $90 = $20</td>
</tr>
</tbody>
</table>

If the actual sender activity of 9 hours is revalued with the difference between plan and actual prices, sender A receives a further $20 and is fully cleared. Without actual price calculation and revaluation, the residual amount of $20 (110 - (9 * 10)) remains on the sender.
Calculating Actual Activity at Actual Prices

Use

Because you carry out actual price calculation at period-end closing, no actual prices exist at the time of the actual activity posting. For this reason, the initial valuation of actual activity uses plan prices. If no plan price exists (as is the case with pure actual cost calculation), you can post the activity without a valuation. During period-end closing, the R/3 System calculates the actual prices iteratively and, provided you have made the required settings recalculates the difference between the plan and actual prices (see the example in Actual Price Calculations [Page 878]).

The procedure for the actual price calculation does not differ from plan price calculation (see: Plan Price Calculation [Page 485]). You can calculate a purely iterative price in the actual, just as for plan price calculation. To do so, select Purely iterative price in the fiscal year parameters of the version.

To calculate the purely iterative actual price, the R/3 System uses the actual costs and actual activity for all cost centers/activity types or business processes. The plan prices (whether calculated iteratively or entered manually) are treated by the system like manual settings and are ignored during the calculation of the purely iterative price in the actual. Actual activity inputs are initially valuated with the relevant plan price. This may result in large variances between the purely iterative actual price and the calculated actual price; activity inputs are valuated with plan prices, whereas the credits on cost centers and business processes are based on activity valuated with iterative actual prices.

In the price report (see: Price Report [Page 996]) you can compare the purely iterative prices with the prices calculated through the manual settings. In this way, you can analyze the effects of price changes (in actual, the manually-set prices and the iteratively calculated plan prices) on the complete pricing framework.
Price Calculation Methods

Use

You can use the following price calculation [Ext.] methods in the plan and in the actual:

Price calculation can be based on:

- Period-based price
- Average prices
- Cumulative price

Features

Period-Based Prices

The system divides the costs arising in each period by the activity. This can result in different prices in each period. If your fixed costs remain constant throughout the fiscal year but the activity quantities fluctuate, the activity input valuation uses a relatively high price in those periods with lower activity quantities (see period 2 in the example). An activity input in a period with a higher activity quantity is valued with a relatively low price, because the fixed costs draw on the higher activity quantity (see period 1 in the example).

<table>
<thead>
<tr>
<th>Fixed costs</th>
<th>Variable Costs</th>
<th>Activity</th>
<th>Period-Based Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period 1</td>
<td>$1,000</td>
<td>1,000 hrs</td>
<td>$2.00/hr</td>
</tr>
<tr>
<td>Period 2</td>
<td>$1,000</td>
<td>100 hrs</td>
<td>$11.00/hr</td>
</tr>
</tbody>
</table>

The activity receivers in period 2 are disadvantaged compared with the activity receivers of period 1. The period-based price is higher in period 2 than in period 1, due to the lower activity quantity. The price in period 2 contains a higher proportion of fixed costs than the price in period 1. This is because the fixed costs in period 2 are related to a lower activity quantity. The variable unit cost, that is, the variable portion of the period-based price, is the same in both periods ($1/hour).

Average Prices

The average price is based on the total costs from all periods divided by the total activity quantity of an activity type from those periods. This ensures that the activity inputs of all receivers are valued with the same price, regardless of the period in which the activity input occurs.

<table>
<thead>
<tr>
<th>Fixed costs</th>
<th>Variable Costs</th>
<th>Activity</th>
<th>Prices</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period 1, period</td>
<td>$1,200</td>
<td>$1,000</td>
<td>1,000 hrs</td>
</tr>
<tr>
<td>Period 2, period</td>
<td>$1,000</td>
<td>$100</td>
<td>100 hrs</td>
</tr>
<tr>
<td>Average</td>
<td>$2,200</td>
<td>$1,100</td>
<td>1,100 hrs</td>
</tr>
</tbody>
</table>
Price Calculation Methods

This method does not result in a complete crediting (clearing) of costs in the individual periods. This means:

- Too much is credited (Period 1: Credited with $3,000 compared with $2,200)
- Too little is credited (Period 2: Credited with $300 compared with $1,100)

You can clear a cost center or business process completely only by totaling across all periods.

Cumulative Prices

In cumulative price calculation the price for a period is based on the accumulated total costs and activity of all previous periods (the period entered in the To period field). In this way, price calculation allows for cost fluctuations in the periods.

When revaluation is carried out under the cumulative procedure, all the sender objects are fully credited in those periods that you specified for actual price calculation. In this process, the activity inputs are valuated with the new price in each selected period. Clearing entries are made in these periods to ensure that this equal valuation.

The cumulative price calculation method requires that all activity receivers can be posted to in all periods in the interval specified, i.e. the period cutoff indicator must not be active for these objects. This is to ensure that receivers in the first period can still receive clearing entries in the last period.

Example 1: Differences between cumulative price and price per period

Periodically differentiated prices: The costs per period are divided by the activities; prices can vary widely.

<table>
<thead>
<tr>
<th>Period</th>
<th>Cost per period</th>
<th>Activity per period</th>
<th>Price per period</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1,000 USD</td>
<td>100 hours</td>
<td>10 USD/hour</td>
</tr>
<tr>
<td>2</td>
<td>2,000 USD</td>
<td>50 hours</td>
<td>40 USD/hour</td>
</tr>
<tr>
<td>3</td>
<td>1,000 USD</td>
<td>250 hours</td>
<td>4 USD/hour</td>
</tr>
</tbody>
</table>

Cumulative price: The price is calculated from the total of the current and previous periods. For example, the price for period 2 is calculated from the costs of periods 1 and 2 (1,000 USD + 2,000 USD) divided by the activities for these periods (100 + 50). The price variances are not so marked.

<table>
<thead>
<tr>
<th>Period</th>
<th>Cumulative costs</th>
<th>Cumulative activity</th>
<th>Cumulative price</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1,000 USD</td>
<td>100 hours</td>
<td>10 USD/hour</td>
</tr>
<tr>
<td>2</td>
<td>3,000 USD</td>
<td>150 hours</td>
<td>20 USD/hour</td>
</tr>
<tr>
<td>3</td>
<td>4,000 USD</td>
<td>400 hours</td>
<td>10 USD/hour</td>
</tr>
</tbody>
</table>

Example 2: Revaluation at actual prices

Under revaluation, activity allocations are valuated at actual prices and the difference as against the values already posted is then subsequently allocated.
If, for actual price calculation, you enter a number of periods, the system revaluates for each period; the sender objects are fully credited in each period.

If you enter one period only, subsequent allocation is carried out for this period only and this is then the only period that is fully credited.

**Entry: Periods 1 to 3**

<table>
<thead>
<tr>
<th>Per</th>
<th>Actual costs</th>
<th>Activity</th>
<th>Cum.actual price</th>
<th>Plan costs</th>
<th>Plan price</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1,000 USD</td>
<td>100 hours</td>
<td>10 USD/hour</td>
<td>500 USD</td>
<td>5 USD/hour</td>
</tr>
<tr>
<td>2</td>
<td>3,000 USD</td>
<td>150 hours</td>
<td>20 USD/hour</td>
<td>750 USD</td>
<td>5 USD/hour</td>
</tr>
<tr>
<td>3</td>
<td>4,000 USD</td>
<td>400 hours</td>
<td>10 USD/hour</td>
<td>2,000 USD</td>
<td>5 USD/hour</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Period</th>
<th>Difference between plan/actual costs</th>
<th>Revaluation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>500 USD</td>
<td>+ 500 USD</td>
</tr>
<tr>
<td>2</td>
<td>2,250 USD</td>
<td>+ 1,250 USD</td>
</tr>
<tr>
<td>3</td>
<td>2,000 USD</td>
<td>- 1,000 USD</td>
</tr>
</tbody>
</table>

- **Period 1:**
  
The difference between actual and plan costs is 500 USD; the amount by which the receivers are debited. The sender objects are fully credited in period 1.

- **Period 2:**
  
The difference between plan and actual costs is 2,250 USD. As calculation takes place using cumulative values here, the receiver objects are only debited with 1,250 USD. The sender objects are still credited in full, because 1,000 USD were already allocated to the receivers from the first period.

- **Period 3:**
  
Revaluation results in the receivers being debited by 1,000 USD too much. This amount is credited to the receivers, so that the sender objects are credited in full (and correctly). Where does this figure come from? The difference between plan costs and actual costs is 2,000 USD. In periods 1 and 2 the receivers were debited with 1,250 USD plan costs and 1,750 USD revaluation, a total of 3,000 USD. The difference between plan and actual is however only 2,000 USD, meaning that the receivers were debited by 1,000 USD too much.

**Entry: Periods 3 to 3**

If, for actual price calculation you enter period 3 only, allocation is correct, but the senders are fully credited in this period only. This is because the price calculation program posts only in the period(s) that were entered under From period/To period. Here, 750 USD is revaluated because although the plan costs for periods 1 to 3 are included in the calculation (3,250 USD) no revaluation took place in periods 1 and 2.
Price Calculation Methods

<table>
<thead>
<tr>
<th>Period</th>
<th>Difference between plan and actual costs</th>
<th>Revaluation</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>2,000 USD</td>
<td>+ 750 USD</td>
</tr>
</tbody>
</table>

Unlike the average price, which you can also define for individual cost centers/activity types or business processes, cumulative calculation can be selected for all sender objects. You can make this setting in the version settings (see Maintaining Versions [Ext.]).

The cumulative method is only useful if the costs and/or the activity quantities are subject to wide-ranging fluctuations. In particular, this would apply if the time of activity output is not identical to the time of the cost occurrence. Compared to average price calculation (which also ensure a proportionate debiting of receivers) the advantage of cumulative prices is that the cost center or business process is fully credited at any given time. For average prices, this is true only for the entire period.
Price Calculation With Cost Component Split

Use

Price calculation [Ext.] with cost component split provides a breakdown of the price of an activity type [Ext.] or a business process [Ext.] that has been determined iteratively on the basis of all costs and activity relationships. You can determine, for example, the proportions of material costs and wage costs in the price.

During activity allocation the cost component split for the sender is retained on the receiver, provided you did not define different cost components [Ext.] for the target object in the switching structure. This applies only to price calculation. Internal activity allocation [Ext.] in the actual is not affected by this.

Prerequisites

Before you can display the cost component split for the prices (the splitting into cost components [Ext.]) you must fulfill several requirements on the system side.

- Create a cost component structure [Ext.]
  You save the cost component structure used for price calculation in the version [Ext.]. Cost component splitting is not carried out if a cost component structure does not exist in the version.

- Assign cost components to the cost component structure
  The cost component encompasses all costs of the assigned cost element range. You assign cost components to the cost component structure based on your organizational requirements.

  You assign the following cost components to cost component structure 01:
Price Calculation With Cost Component Split

- 1 Raw materials
- 2 Personnel
- 3 Production
- 4 Energy

- Assign cost elements [Ext.] to the cost components

  By assigning cost elements, you specify which costs (primary or secondary) flow to which cost component and how the costs are updated during price calculation. The cost component calculations occur in separate iterative calculations. This retains the cost component split for activity allocation.

  You assign cost elements 400.000 through 410.000 to the cost component Raw Materials in cost component structure 01.

- Switching structure

  If you want to use a different component split for the sender than that used for the receivers, create a switching structure for your cost component structure. The switching structure determines which sender cost component flows to which receiver cost components. You assign switching structures to cost center/activity type combinations within activity type planning.

  The Energy cost center allocates activity to several production cost centers. All costs from the energy cost center (labor and materials) flow into the receiver cost component Energy.

  You assign switching structure 2 to cost component structure 01. The switching structure contains the following information:

  Labor costs assigned to cost component 2 Personnel flow to the target cost component 4 Energy during activity allocation.

  Materials assigned to sender cost component 1 Raw Materials also flow to cost component 4 Energy during activity allocation.

  The target cost component Energy contains costs from the cost components Personnel and Raw Materials.

For more information about price calculation or cost component splitting for Cost Center Accounting, see the Implementation Guide (IMG), under Controlling →

- Cost Center Accounting → Planning → Allocations → Activity Allocation → Price Calculation [Ext.] or
- Actual Postings → Period-End Closing → Activity Allocation → Price Calculation [Ext.] or

For more information about price calculation or cost component splitting for Activity-Based Costing, see the Implementation Guide (IMG), under Controlling → Overhead Cost Controlling →

- Planning → Allocations → Price Calculation [Ext.] or
• **Actual Postings → Period-End Closing → Price Calculation [Ext.]** or
  
  • **Planning → Maintain Versions [Ext.]**.

See also:

[Actual Price Calculation [Page 878]](page878)
Year-End Closing

Use

During the year-end closing, you can transfer carry forward open commitment values from purchase requisitions, purchase orders and funds commitments to the first period of the next fiscal year. You can select by account assignment object (cost centers, orders, or projects). Alternatively, you can process individual documents. The carry-forward of the commitment values occurs for each controlling area.

Only the assigned values are updated by the system. Warnings or error messages from availability control are ignored.

A purchase order exists with the delivery date 10/11/1996. The corresponding commitment is displayed in period 11/1996. After transferring the commitments for the fiscal year 1996, the commitment appears in the period 01/1997.

For more information on commitments management, see the SAP Library under Financials → CO Controlling → CO Internal Orders → CO Commitments Management (see: Commitments Management).
Carrying Forward Commitments

To carry forward a commitment [Ext.] to the first period of the following fiscal year, proceed as follows:

1. Choose Accounting → Controlling → Cost Center Accounting → Year-end closing → Commitment carried forward.
2. Enter the relevant cost center(s).
3. Select or deselect the following indicators:
   a. Test run
      If you select Test run, the system carried forward the commitment, but does not update the results.
   b. Detail lists
      If you activate Detail list, the system displays the results of the commitment carried forward. The results list shows which values were carried forward.
      You should activate the Detail list together with the Test run. This ensures that you can check the results of the test run.
   c. Reversal
      The Reversal indicator controls whether data that has already been carried forward should be reversed again or not.
4. If you have large amounts of data to process, it is advisable to execute the commitment carry-forward using background processing. This means you can process data at times of minimal system usage.
   Choose Program → Execute in background.
The system offers a comprehensive, flexible information system to analyze cost flows in an organization. With the information system functions, you can carry out standard recurring evaluations; you can also construct special reports for unique situations. Following their entry into the SAP System, you can analyze all costs online and trace them right back to the original document. You can execute all reports available online in background runs as well. This is especially helpful for large amounts of data.

For hierarchically grouped objects, such as cost centers, you can create separate reports for all hierarchy nodes and individual objects, or you can create all the relevant reports in a single selection run through the database. The second option allows you to navigate within a hierarchy. This enables particularly flexible monitoring of cost center areas. You can also create Cross-Controlling Area Reports [Ext.].

The information system includes functions:

- For report callup
- For report processing

See also:
Report Callup with Extract Management [Page 949]
Creating a Report Painter Report [Page 1090]
Interactive Information System

Use

With the interactive information system you can evaluate data from business transaction postings directly on the screen. You can use a wide array of predefined standard reports with numerous analysis functions. The advantages of the interactive information system are the ability to review recently posted entries and to analyze this data with the aid of totals, Summarizations [Ext.], and key figures.

Features

The line item report analyzes Line Items [Ext.] using criteria entered by the user.

The Report Painter tool also allows you to analyze summarized line items in the form of Totals Records [Ext.] based on your criteria.

Each business transaction is documented using a line item and saved in a Controlling (CO) line item file. The R/3 System manages data separately in these files by plan and actual transactions.

Actual and Commitment [Ext.] postings are always documented as individual line items. Each posting transaction (for example, an Internal Activity Allocation [Ext.]) creates one or more line item entries.

In planning, you can use the version to determine whether or not the system creates line items for planning transactions (see: Cost Center Planning [Page 178]).

The plan and actual line items are differentiated further into primary and secondary postings. Primary postings are transferred from external accounting to internal accounting, while secondary postings are exclusively entries in internal accounting. You can analyze the individual transaction movements in actuals and commitments with the aid of the line item report.

The R/3 System summarizes each individual transaction automatically in a totals record. This summarization by the system is based on the criteria “cost center/cost element” or “cost center/cost element/activity type”. The R/3 System saves the summarized numbers in CO totals record files. The totals record structure is similar to that of the line item data. You can then analyze the summarized data with Report Painter reports. You can call up a line item report from the totals record report, and from the line item report you can access the original document, such as the posting in the Financial Accounting component (FI).

To simplify Report Painter report callup, you can use Extracts [Ext.] and user-specific defaults for selection parameters. If extracts exist for the report callup, the R/3 System does not need to read the data from the database, which can be greatly time-consuming. By using custom selection criteria, you can execute a given report without having to repeatedly enter selection criteria.

Report Writer and Report Painter reports are available initially only in the standard client of the R/3 System. You must transport the standard reports to the target client and generate them there. To do so, see the Implementation Guide (IMG) for Cost Center Accounting under Information System → Standard Reports → Importing Standard Reports [Ext.] or Generating Standard Reports [Ext.]

You only need to define your own reports if you cannot address selected user-specific report structures with the standard reports.
Accessing Overhead Cost Reports

Use

Cost Controlling contains certain functions for calling up the following reports:

- Report Painter Reports [Ext.]
- Line Item Reports [Ext.]
- Planning overviews

Note that as of Release 4.6A, the report tree is now part of the area menu. For more information on area menus and how to maintain them, see:

  - Overview of New Area Menu Maintenance [Ext.]
  - Processing Area Menus [Ext.]

Features

- Executing Reports

  Executing Reports on the Basis of Extract Management Settings

  If you saved selection criteria for the report, and the Extracts [Ext.] exist, the system calls up the current extract automatically. Otherwise, the selection screen for report callup appears (see Report Painter Reports [Page 899]).

  Executing Reports with the Selection Screen

  To execute the report from the selection screen (and independently of the extract management settings) position your cursor on the report node and choose Execute with selection screen or Nodes → Execute with selection screen (see Report Painter Reports [Page 899] and Defining Extract Management Settings [Ext.]). The selection screen accepts any default settings saved for this report (see: Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.]).

- User Settings

  To save user-specific selection criteria for calling up reports, choose Information System → User Settings → Specify User Settings. You use the selection criteria to determine the default values for the selection screens when you call up reports. If you default all the selection criteria for the report, you can call up a report without going to the selection screen (see Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.]).

- Documentation

  For documentation on individual reports in the report tree, select the relevant end node and choose Goto → Documentation. You can access documentation on the report in question. Choose Goto → Documentation → Report.
Searching for Documentation on Reports

Use

The retrieval system assists you in searching for particular reports (see Searching for Documents Using the Retrieval System [Ext.]).

Prerequisites

You have prepared the Group of Texts [Ext.], the subject of the search. To do so, generate a lexicon in Customizing under Basis Components → Frontend Services → Generate a lexicon for report search [Ext.].

You are on the Area Menu Maintenance screen (transaction se43n).

Procedure

1. Enter the key for your area menu.
2. Choose Display area menu.
   The system displays the <title> area menu.
3. Select the highest node, for example Cost Center Accounting.
4. Choose Goto → Find reports.
   The Search in report documentation dialog box appears.
5. Enter a text in the editor area.
6. Choose Start search.
   The retrieval system searches through the prepared group of texts for the corresponding report documentation. The reports that belong to these texts are displayed in a results list.
7. Select a report from the result list.
8. To obtain the documentation on the report, choose Display documentation.
9. To execute the report, choose Execute.

Result

The system displays a list consisting of four columns. The information is listed in descending order according to the relevance of the report documentation found with regard to the search term.

- Column 1: Description of report contents
- Column 2: Technical name of report
Searching for Documentation on Reports

- **Column 3**: Selection variant,
  if the same report was defined for different selection variants.

- **Column 4**: Report type

  The following report types are possible:
  - ABAP reports (_)
  - Report writer reports (RW)
  - Transactions [Ext.] (TR)

You search for reports belonging to Cost Center Accounting.

**Search request:**

I am searching for a report that displays differences between actual values and plan values.

**Search results:**

<table>
<thead>
<tr>
<th>Description</th>
<th>Report name</th>
<th>Variant</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost centers: Drilldown by transaction</td>
<td>1SVG</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>Area: Cost Elements</td>
<td>1AIP</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>Area: Cost centers</td>
<td>1SKL</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>Activity types: Receiver, plan</td>
<td>1LLV</td>
<td></td>
<td>RW</td>
</tr>
<tr>
<td>Area: Internal business volume</td>
<td>1SBU</td>
<td></td>
<td>RW</td>
</tr>
</tbody>
</table>
**Report Painter Report**

**Use**

You can use a Report Painter [Ext.] to create a report for analyzing all quantities and values posted during planning and actual data allocation. You can create the reports using either original data from the database or data from extracted files.

If you create reports using original data, it must be sorted and retrieved first on the basis of your desired criteria. Depending on the volume of data, this can be very time-consuming. This is the case, for example, with cost center area reports involving numerous cost elements [Ext.] and activity types [Ext.]. A data selection from the original database is only recommended when a near-time and current review of data is absolutely necessary in Controlling (CO).

For most other purposes, you should create temporary or period-based extracts [Ext.] for analyses, especially for those involving larger data volumes such as area reports. For example, you can create daily or weekly area reports based on the data stored in a given extract.

**Features**

If extracts exist that match your selection criteria when you call up the report, the system offers the extracts for your selection.

When you leave reports based on selections from the database, the system indicates that you have the option of saving the report data as an extract.

You can analyze the reports saved in extracts at any time without undue strain on the system performance.

⚠️ The system deletes the extracts if the release status is changed (for example from Release 4.0 to 4.5). Once a maintenance level has been changed (for example from Release 4.5A to 4.5B), the extracts that you saved previously are available once again.

You can use the Implementation Guide (IMG) to make user settings [Ext.] for selected or all users that ensure the display of the most current extract during report callup. In addition, you can determine the selection parameters for report callup for individual users or for all users per component. If extracts exist that match the selection parameters given during report callup, and if you arranged to have the most current extract automatically displayed each time, you do not need to use the selection screen before report callup.

👉 You should run extensive reports in the background or during off-peak periods (see Period-Based Information System [Page 961]).

The system includes a variety of standard reports. You can find an overview of all standard reports in the standard report tree of the relevant Controlling component (CO). The most important reports are described in Important Standard Reports in Cost Center Accounting [Page 976].
Do not change the structure of the predefined standard reports. If you wish to change reports, create new reports by copying the standard reports and make the appropriate changes to the new reports. For more information on creating your own reports, see the SAP Library under AC - Financials → FI - Financial Accounting → FI Special Purpose Ledger → FI-SL-Sets [Ext.] and Report Writer [Ext.].

If you use transfer prices (multiple value flows), the information system for the Overhead Cost Controlling component (CO-OM) can access all valuations. The selection field for valuation appears after you activate the multiple valuations. In reporting, you can make target/actual comparisons between plan values in the operational valuation and the actual values in other valuations.

You can enter a default in the user settings under report currency (see the Cost Center Accounting IMG under Information system → User Settings → Specify User Settings [Ext.]).

If you do not use transfer prices, the valuation field does not appear in the selection screen.

For more information on multiple valuation approaches/transfer prices, see Multiple Valuation Approaches [Ext.] and also the SAP Library under EC Enterprise Controlling → EC Profit Center Accounting → Transfer Prices [Ext.].
Executing Report Painter Reports

Most of the standard reports that you can call up in Cost Center Accounting are Report Painter [Ext.] reports. To access a Report Painter report, choose Cost Center Accounting → Information system → Reports for Cost Center Accounting.

Select the report group and the report required, and start it using a double-click.

If the following prerequisites are fulfilled, the system does not display the selection screen, but either the selection screen for extracts [Ext.] or the most current extract matching the selection criteria (see step 10):

– User-specific selection criteria is stored in all the components within Overhead Cost Controlling for all the selection screen fields (see Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.]).

– Extracts exist that match these selection criteria or a variation that encompasses the selection criteria.

– In the implementation guide (IMG) in the settings for extract management, the settings for your user or the standard settings require that existing extracts are used when you call up reports (see: IMG for Cost Center Accounting, under Information System → Specify Settings for Extract Management [Ext.]).

You can also store settings in the IMG which automatically call up the most current extract. In this case, the system does not display the extract list.

In the Report Painter report selection screen, enter the report parameters under Value selection. Report parameters are:

– Controlling areas [Ext.]

– Fiscal year [Ext.]

– From period

– To period

– Version [Ext.]

Under Set selection, enter the report objects for which you want to call up a report. You can enter individual values, value intervals, or groups. To enter multiple individual values or intervals, choose Multiple selection.

The order of the report parameters and report objects on the selection screen is specified in the library (that uses the report painter report) by entering the position for each characteristic (see: Library [Page 1044]).

If you created a selection variant [Ext.] for the report objects (see: Selection Variant [Page 28] and the Cost Center Accounting IMG under Define Selection Criteria [Ext.]) call up the report for this selection variant. To do so, enter the <name of the selection variant> under Group +.

The selection screen is dependent on the corresponding report. Some reports require more parameters than others.
Executing Report Painter Reports

You can save default selection criteria for calling up Report Painter reports. You can define these either as user-specific or as standard settings (see the Cost Center Accounting IMG under Information System → Specify User Settings [Ext.]).

Create extract

If no extracts exist that match your selection criteria, you should save the report in an extract. You can evaluate the dataset again at a later time by choosing the corresponding extract (see: Managing Extracts [Page 357]).

To do so, choose Extract parameters.

Enter the following in the dialog box that appears:

– Activate the Create extract indicator.

– Description:

Enter a descriptive text for the extracts. At a later time, you can display the report without having to repeat your entries in the selection screen. To do so, select the corresponding extract.

You cannot use the description to find the extract in the system. The system uses the selection criteria you enter and the report group to find the extract.

– Password

One password, which you must enter twice, protects your saved selection data from unwanted access by other users. If, later on you wish to display an extract for which you created a password, you need to enter the password.

– Expiration date

If you want to delete the extract automatically after a given time, enter the number of days in the Expires in field, or the date in the Expires on field.

If you do not want the extract to be deleted, choose No expiration date. This is useful, for example, if you are require report at an unspecified later date, or if the report run takes an extremely long time.

The system deletes the extracts if the release status is changed (for example from Release 4.0 to 4.5). Once a maintenance level has been changed (for example from Release 4.5A to 4.5B), the extracts that you saved previously are available once again.

– Choose Continue to close the dialog box and save your entries.

If you wish to execute a report that does not have an extract matching the selection criteria, the system inquires (when you leave the report) whether you want to save the report in an extract. If you choose Yes, the Create Extract dialog box appears.
If you change a report without it changing the selection screen, then the system is still able to locate previously saved extracts for the report. If by changing the report, you change the selection screen, then the system can no longer locate the saved extracts using the selection criteria. However, these are still available in Extract Management (see: Managing Extracts [Page 957]).

Output parameters

Choose Output parameters to make further settings for data output.

– Dates for reading master data

You can assign time-based dependencies to the master data texts as well as the Controlling objects. You therefore decide whether the system reads the master data on the current date or on a fixed date that you entered. The system checks whether the Controlling objects have valid master data records.

– Output medium

Under Output medium you enter the medium in which the report should be output. The following methods are available:

You can display the report on the screen or print it.

You can display the report on the screen or print it using the departmental printer. If a departmental printer is defined in the master data and can be located by the system for the current report, the printer will be used by default.

You can release the report as a text file. Enter a file name in the dialog box that appears. This is the name of the text file to which the Report Painter output is downloaded, on either the application server or the presentation server. Decide whether to save the report in a Local PC file or as a file on a Network server. If you save the report on a server, enter the export format (spreadsheet or word processing). If you save the report on your PC, enter the format, and the relevant program to be started with the report, or enter other parameters for the application.

You can release your report in Microsoft ® Excel format.

You can release your report to the Executive Information System (EIS).

You can send your report to a selected user. Enter the name of the SAPOffice user and set the indicator to specify the recipient type (such as P for Personal distribution list).

You can decide not to release the report at all. In this case, the system only saves the selection data. If you choose Execute after you leave the dialog box, the system gives you an overview of the number of selected, processed, and summarized records in a selection log. You have the option of selecting your report at a later time from the list of existing extracts (see step 10).

Data source

You can choose the following options under Data source:

– Display extract

If you choose Display extract, the callup of the Report Painter report offers a list of existing extracts that match the selection criteria.

The standard system default is Display extract. You can save standard and custom extract management settings in the Implementation Guide (IMG) under Information.
Executing Report Painter Reports

System → User Settings → Determining Extract Management Settings [Ext.]. In the IMG, you also specify whether the system displays a list of all matching extracts or whether it displays the most current extract automatically.

– New selection

Choose New selection if you want the report to call up the current data from the database, as long as the user has the authorization. This is useful if you need the most current, second-by-second data available.

– Read data from archives

This option applies only to those reports allowing you to read standard reports from archived data [Page 911].

If you saved the option for variations in the report definition, variation maintenance appears when you execute the report. To make entries, choose Variation.

In the dialog box, determine for which group nodes (such as Cost Center Groups [Ext.]) and/or individual values (such as Cost Centers [Ext.]) of a selected group a report is to be issued.

The default is based on the given report definition.

– The indicator Do not expand causes only one report to be issued for the highest node of the selected group.

– The indicator Expand causes reports to be issued for all nodes and individual values in the selected group.

– The indicator Individual values causes reports to be issued only for individual values in the selected group.

Choose Detail for further variation settings (see Variations [Page 1082]).

If you enter an object group in the selection screen (such as cost center group or cost element group [Ext.]), and you activated the variation in the report definition, the system automatically carries out variation by choosing Breakdown. If you do not want to use variation, change the setting under Variation.

The following functions are also available on the selection screen:

– You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).

– You can save your entries in a variant in the initial screen fields and get them again when you next call up the initial screen (see: Processing Variants [Page 1014]).

To run the report, select either Execute or Program → Execute.

If there are already extracts in the system for your selection criteria, and if you chose Display extract under Data source (but did not set the indicator Display current extract in the IMG), then the system displays a list of the existing extracts in the Choose Extracts in the dialog box, before executing the report.

Select the extract that you wish to access.
The dialog box list also appears if an extract exists for a variation that encompasses a report matching your selection criteria. The system directly calls up the report in the variation matching the selection data.

If you do not want to display any of the existing extracts, leave the dialog box by choosing *Cancel* and change the *Data source* setting to *New selection* (see step 6).

The following ABAP list viewer functions are available in the extract list: (see: ABAP List Viewer [Ext.])

- Sorting Ascending or Descending Lists [Ext.]
- Setting and Deleting Filters [Ext.]
- Defining Current Layouts [Ext.]
- Finding Terms [Ext.]
- Printing Lists [Ext.]

If, in the IMG activity Determining Extract Management Settings [Ext.], you selected the *Display current extract* indicator, the system displays the current extract without displaying the list.

**Result**

When you select the report based on your entries in the selection screen for the first time, the system searches for the data in the database using your selection criteria and prepares and presents the data based on the report definition.

When you leave the report, the system inquires whether you want to save an extract for this report. If you choose *Yes*, the *Create Extract* dialog box appears (see step 4: “Create extract”).

When you call up the report via an extract, the system uses the data from the extract during report execution.

For more information on the functions available in your report, see Functions for Output of Report Painter Reports [Page 926].
Functions for Report Access

Use

The graphic lists the steps required for executing a report.

![Diagram of report access process]

Selection requirement

**Values selection**
- Controlling Area
- Fiscal Year

**Sets selection**
- Cost center group
  - Values
- Cost element group
  - Values

Execution:
- Execute
- Fetch variants
- Variation
- Output parameters
- Data source
- Extract parameters

Additional entries:
- Date master data read
- Output medium

Session:
- Password
  - Description
  - Expiration date
    - Expires in ___ days
    - Expires on ___
    - No expiration date
User Settings

Use

Under user settings, you enter which values the selection screens are to contain when you call up the reports. These user settings include:

- Selection criteria
- Planning period
- Reporting timeframe
- Reporting currency
- Other details (actual valuation for example)

In Customizing for the relevant Controlling application component or in the relevant area menu, you can define these settings per user or enter standard settings. The standard settings apply to all users for whom no user-specific settings apply.

For more information, see Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.].
Managing Extracts

Use

If you save reports in extracts, you can access this data at any time without an additional selection run in the database.

You can create extracts:

- Before you execute the report, by choosing *Extract parameters* in the selection screen and selecting *Create extract* in the dialog box
- When you leave a report, by choosing *Yes* when the system inquires if you want to create an extract for the report

With extract management you can:

- Display extracts
- Delete extracts
- Print extracts
- Change the expiration dates of extracts

If you make changes to a report definition that affects the selection screen, then the system cannot use the corresponding selection criteria to locate extracts already saved. However, these are still available in Extract Management

Prerequisites

*Extracts [Ext.]* exist for *Report Painter [Ext.]* reports.

Procedure

1. From the menu of the relevant Overhead Cost Controlling component (such as Cost Center Accounting) or in Cost and Revenue Element Accounting, choose *Information system → Tools → Extract directory.*
2. On the selection screen for extract maintenance, enter the criteria according to which you want to select extracts.
   - If you are searching for a given extract, enter the extract name.
   - Decide whether to display only those extracts created by you or another user, or whether you want to display extracts regardless of creator.
   - Decide whether to display extracts from past time frame, or whether you want to display all extracts regardless of creation date.
   - You can select extracts from a particular *Report Group [Ext.]* or from a report group interval.
   - If you want to limit the extract selection further (such as by characteristic, value, or group), choose *Further selection criteria.* You can extend the number of selection criteria as you desire, or delete criteria you already entered.
3. Choose **Execute**. The system displays a list of all extracts that meet your selection criteria.

4. **Display extract**
   
   To display an extract, select the extract and choose **Display**. The system displays the relevant extract.

5. **Delete extracts**
   
   To delete the extract, select it and choose **Delete**. If you choose yes when the system inquires if the selected extracts are to be deleted, the system then deletes those extracts.
   
   The system deletes the extracts if the release status is changed (for example from Release 4.0 to 4.5). Once a maintenance level has been changed (for example from Release 4.5A to 4.5B), the extracts that you saved previously are available once again.

6. **Print extracts**
   
   - To print the extract, select it and choose **Print**.
   
   - Enter the printer from which you want to print the extract.
   
   - Under **Spool control data**, decide whether to print immediately or whether to create a spool order.
   
   - If you chose **Background printing** then you need to enter the start time for the print request. To do this, either choose **Start request immediately** or enter the start date and the start time for the print request.
   
   The system prints the selected extracts.

7. **Change expiration dates of extracts**
   
   - To change the expiration dates of extracts, select the extracts from the extract tree that you wish to set to the same date.
   
   - Choose **Change expiration date**.
   
   - If you want to delete the extract automatically after a given time, enter the number of days in the **Expires in** field, or the date in the **Expires on** field.

   If you do not want the extract to be deleted, choose **No expiration date**. This is useful when, for example, you are going to run the report at an unspecified later date, or if the report run takes an extremely long time.

   - Choose **Confirm** to close the dialog box and save your entries.
   
   Before you execute a report, you can call up extract management from the corresponding selection screen by choosing **Environment → Extracts**. This enables you to have all the functions available:
   
   - Display
   
   - Print
   
   - Print in the background
Managing Extracts

- Change the expiration date
- Delete
- Select/Deselect

For information on extract management, see Customizing for Cost Center Accounting under *Information System → User Settings → Specify Settings for Extract Management [Ext.]*.
Reading Standard Reports from Archives

Use

You can use Report Painter [Ext.] reports and line item [Ext.] reports from the Cost Center Accounting (CO-OM-CCA) and Internal Orders components (CO-OM-OPA) to evaluate archives. Generally, the following reports can read the relevant data from any archive:

- All Report Painter reports for table CCSS
- The actual line item report for internal orders [Ext.]
- The actual line item report for cost centers [Ext.]
- Document display

The R/3 System includes a variety of report and archiving object [Ext.] combinations. The standard system thus provides only a limited number of reports for given archiving objects. However, it is also possible to execute other reports for an archiving object.

Actions

Reading Report Painter Reports from the Archive via the Component

1. To execute a Report Painter report, choose Information system → Report selection in the given component and select the desired report.
2. On the report selection screen, choose Data source.
3. On the following dialog box, select Read from archive and choose Continue.
4. On the following dialog box, enter the object from which you want to read the archived data. Choose F4 Help to obtain a list of the archiving objects to which the report applies.
5. Choose Archive selection to determine the archive files for the report.
6. As in the standard transaction, you can start the report online or in a background job.

Reading Line Item Reports and Documents from the Archive via the Component

1. To execute a line item report or document display, choose Information system → Report selection in the given component and select the desired line item report or document display.
2. On the report selection screen, choose Extras → Data source.
3. On the following dialog box, select Archive as the data source.
4. On the following dialog box, enter the object from which you want to read the archived data. Choose F4 Help to obtain a list of the archiving objects to which the report applies.
5. Choose Archive selection to determine the archive files for the report.
6. As in the standard transaction, you can start the report online or in a background job.
Reading Standard Reports from Archives

As it is often unnecessary to enter further selection criteria when reading data from an archive, you can enter an asterisk (*) under Cost center and Order where required.

Reading Reports from Archive Administration from the Archive (SARA Transaction)

1. Under Object name, enter the archiving object (such as CO_COSTCTR) and choose Evaluate.

   Choose F4 Help for the Read program field to list all the reports for the archiving object.

2. Choose and execute the required report.

3. Branch from the selection screen to the data source selection:
   a) For Report Painter reports, choose Data source.
   b) For line item reports or for document display, choose Extras → Data source.

4. The archiving object is already defaulted. Choose Archive selection to determine the archive files for the report.

5. As in the standard transaction, you can start the report online or in a background job.

Assigning Reports to Archiving Objects

The R/3 System stores the report assignments to the archiving objects. The assignment controls which objects appear in the F4 Help for the data sources and which reports appear for the read programs in archive administration.

A warning message appears if you choose an archiving object that is not assigned the relevant report or a report that is not assigned the relevant archiving object. You can ignore this warning message. You can execute the report if you wish, but you must bear in mind that incomplete data will be the result.

To view the assignments in the standard R/3 System, see the ARCH_REPOW table.

Importing Standard Assignments

The ARCH_REPOW table is a Customizing table that also allows user-defined assignments. Standard assignments are provided therefore in client 000 only. You cannot use reports in other clients for reading data from the archive.

1. To import standard assignments to other clients, go to the SAP R/3 initial screen, choose Tools → ABAP Workbench → ABAP Editor, and enter and execute program ARCH_REPOW_IMPORT.

2. Enter CO_* as the archiving object.

3. Accept the default settings in the other fields (source client 000, report type RW).

4. Choose Execute.

Creating Custom Assignments

In principle, you can read data from given archiving objects even if the standard R/3 System does not have the relevant combination of report and archiving object.
For Report Painter reports, the prerequisites are:
- The report applies to table CCSS
- The archiving object includes table COSP or COSS
  Tables COSP and COSS may also appear in the archiving object definitions as COSPA and COSSA.

Of course, you may also use custom reports to read archiving object data.

For line item reports, table COEP must be part of the archiving object. Table COEP may also appear in the archiving object definition as view COVP or COVPxy (where “x” and “y” stand for numerals).

If you want to work with previously unsupported assignments, enter these in table ARCH_REPOW in order to avoid confusion among end-users. In addition, you can include documentation justifying the use of the corresponding report for your own archive reading runs.

To enter a new assignment:
1. Start system transaction SM30.
2. Enter table ARCH_REPOW.
3. Choose Maintain.
4. Choose New entries to enter the new assignments.

Make the following entries:
- Under Object name, enter the name of the archiving object.
- Under Report type, enter:
  RW for Report Painter reports
  TR for line item reports
- Under Program name, enter:
  The name of the report group for Report Painter reports
  KSB1 for the actual line item report for cost centers
  KOB1 for the actual line item report for internal orders
  KSB5 for document display
- Leave the Activate archive selection field empty.

Standard Contents of Table ARCH_REPOW

<table>
<thead>
<tr>
<th>Report</th>
<th>Program Name</th>
<th>Report Type</th>
<th>Object Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Center Actual Line Items</td>
<td>KSB1</td>
<td>TR</td>
<td>CO_ALLO_ST</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_ALLO_ST</td>
</tr>
<tr>
<td>Cost Center Actual Line Items</td>
<td>KSB1</td>
<td>TR</td>
<td>CO_CCTR_EP</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_CCTR_EP</td>
</tr>
</tbody>
</table>
## Reading Standard Reports from Archives

<table>
<thead>
<tr>
<th>Area</th>
<th>Code</th>
<th>Access</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost elements</td>
<td>1AIP</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Area: Statistical key figures</td>
<td>1SKL</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Cost centers: Drilldown by Partner</td>
<td>1SHK</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Cost centers: Actual/plan variance</td>
<td>1SIP</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Area: Cost Centers</td>
<td>1KSL</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Area: Activity types</td>
<td>1SLB</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Cost Centers: Period Breakdown Actual/Plan</td>
<td>1SMA</td>
<td>RW</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Cost Center Actual Line Items</td>
<td>KSB1</td>
<td>TR</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_CCTR_ID</td>
</tr>
<tr>
<td>Area: Cost elements</td>
<td>1AIP</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Area: Statistical key figures</td>
<td>1KSL</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Cost centers: Drilldown by Partner</td>
<td>1SHK</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Cost centers: Actual/plan variance</td>
<td>1SIP</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Area: Cost Centers</td>
<td>1KSL</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Area: Activity types</td>
<td>1SLB</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Cost Centers: Period Breakdown Actual/Plan</td>
<td>1SMA</td>
<td>RW</td>
<td>CO_CCTR_PL</td>
</tr>
<tr>
<td>Area: Cost elements</td>
<td>1AIP</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Area: Statistical key figures</td>
<td>1KSL</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Cost centers: Drilldown by Partner</td>
<td>1SHK</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Cost centers: Actual/plan variance</td>
<td>1SIP</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Area: Cost Centers</td>
<td>1KSL</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Area: Activity types</td>
<td>1SLB</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Cost Centers: Period Breakdown Actual/Plan</td>
<td>1SMA</td>
<td>RW</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Cost Center Actual Line Items</td>
<td>KSB1</td>
<td>TR</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_COSTCTR</td>
</tr>
<tr>
<td>Order Actual Line Items</td>
<td>KOB1</td>
<td>TR</td>
<td>CO_ITEM</td>
</tr>
<tr>
<td>Cost Center Actual Line Items</td>
<td>KSB1</td>
<td>TR</td>
<td>CO_ITEM</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_ITEM</td>
</tr>
</tbody>
</table>
# SAP AG Cost Center Accounting (CO-OM-CCA)

## Reading Standard Reports from Archives

<table>
<thead>
<tr>
<th>Description</th>
<th>Code</th>
<th>Rights</th>
<th>KSTRG</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_KSTRG</td>
</tr>
<tr>
<td>List: Orders</td>
<td>6L00</td>
<td>RW</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>List: Cost elements</td>
<td>6M00</td>
<td>RW</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>Order: Actual/plan variance</td>
<td>6O00</td>
<td>RW</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>Order: Drilldown by Partner</td>
<td>6O08</td>
<td>RW</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>Order: Drilldown by Period</td>
<td>6Z02</td>
<td>RW</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>Order Actual Line Items</td>
<td>KOB1</td>
<td>TR</td>
<td>CO_ORDER</td>
</tr>
<tr>
<td>CO Documents, Actual Costs</td>
<td>KSB5</td>
<td>TR</td>
<td>CO_ORDER</td>
</tr>
</tbody>
</table>
Variation

Use

Variation makes it possible to create an individual report for each element of a group, which you defined in the general data selection. When you call up the report, the variation makes the selection for the entire group. You can then navigate interactively during the report output within the hierarchical structure of the group to display a report for every element in the group.

You can decide whether individual characteristics in the general selection are to be displayed only with a totals report, only individual reports for the characteristic values, or both total reports and individual reports.

Variation is only possible in reports for which at least one general selection characteristic is a group or a variable for a group.

The advantage of variations is that you only need to carry out the selection once.

For example, you can create an individual report for each group node and end node in a cost center hierarchy.

The cost center hierarchy is used here as an example for variation. However, you can carry out variation for any group for which you select a report.

Variation is useful especially for executing reports for an entire cost center group in a background run, so that you can move quickly between the various cost center reports.

In addition, you can use variation at period-end closing to create and print a complete report for the cost center group or the organization itself, without having to create reports one-by-one for each cost center.

Variation is possible only if you activate it in the report definition. The procedure is described in General Selections. For activation in the Report Writer report, see the SAP Library under AC - Financials → FI - Financial Accounting → FI Special Purpose Ledger → Report Writer.

If you enter an object group in the selection screen (such as cost center group), and you have activated a variation in the report definition, the SAP System automatically executes variation. If you do not want to use variation, change the setting under Variation.

If you decided to generate extracts before calling up the variation, the system generates an extract for each report in the variation (see Executing Report Painter Reports).

We recommend you execute variation for the entire organization or for large areas only in an off-peak period in a background job.
Activities

To set up a variation using general selections for a report, choose Edit → General selections → Variation.

If you decide on several characteristics, determine the sequence they should appear on selection screen using the characteristic name indicator.

In the dialog box Variation/Eliminate Internal Business Volume, the system displays the general selection characteristics that have an interval, group, or variable as characteristic value. You can define a variation for each of these characteristics.

The default setting is Do not break down. No variation is carried out for the characteristic. The system displays a report in which the intervals and groups of the characteristic are totaled.

If you choose Individual value for a characteristic, the system performs a variation for the characteristic down to individual values. The system displays a report for all the individual values of the interval or of the group.

If you choose Expand, the system displays a report for all nodes and individual values in the interval or group.

If you wish to select a particular variation area for report generation, or decide on the release of reports for individual values, choose the selection screen for report call-up.

In the report you can then display individual reports for the groups or individual values in the variation area. (See Variation [Page 940]).
Executing Variations

Procedure

1. On the Cost Center Accounting initial screen, choose Information system → Reports for Cost Center Accounting.

2. Select the desired report and start it.

3. Make entries in the selection screen as described in Executing Report Painter Reports [Page 901].

4. If you activated variation in the report definition, the Variation screen appears for variation maintenance.

5. In the dialog box Additional Entries: Variation you decide which nodes and/or Cost Centers [Ext.] from the selected Cost Center Group [Ext.] are released. The default settings from the dialog box are based on the entries from report definition:

   - If you choose the indicator *Do not breakdown*, only one report for the highest node of the selected group is released.
   - If you choose the indicator *Breakdown*, reports are released for all nodes and cost centers.
   - If you choose the indicator *Individual values*, reports are released exclusively for the individual cost centers in the group.

6. If you wish to make additional special settings for variation, choose Detail.

7. Enter the variation area in the following dialog box.

   The variation area contains the hierarchy levels in the report. A hierarchy level represents a level in the cost center group which you have selected for the report. The top node in the cost center group is located on hierarchy level 1. Cost centers represent the lowest level. They are always on a hierarchy level that has a value greater than 1. By setting an interval of 1-3, you establish a variation executed for the highest three hierarchy levels in the cost center group.

   The numbering of the variation levels goes from highest to lowest (top-down). The summarization levels in a report, on the other hand, are numbered from lowest to highest (bottom up). The number of asterisks (*) before a report row identifies the summarization level. The manner of viewing a variation is thus different from that for the summarization levels. Summarization Level [Page 942]

8. Activate or deactivate the Individual value indicator.

   The Individual value indicator determines whether the variation should be carried out to the cost center level.

   - If the indicator is activated, a report will be generated for each cost center.
   - If the indicator is inactive, only cost center group data will be reported and a summarized report comprising the cost centers will be generated.

   The following relationship exists for variation indicators and variation area/individual value.
If the entry from report definition or the last entry for the variation is identical to one of the indicators, the dialog box is displayed with the corresponding indicator when variation maintenance is called up.

<table>
<thead>
<tr>
<th>Indicator</th>
<th>Variation Area</th>
<th>Individual value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Breakdown</td>
<td>1 to 99</td>
<td>Active</td>
</tr>
<tr>
<td>Individual values</td>
<td>1-</td>
<td>Active</td>
</tr>
<tr>
<td>Do not breakdown</td>
<td>1 to 1</td>
<td>Inactive</td>
</tr>
</tbody>
</table>

If Individual values was chosen, this setting is displayed in the variation maintenance dialog box and in the corresponding detailed screen, but this cannot be changed. The reports will always be executed only for the cost centers in the selected cost center group.

If the entry from report definition or the last entry for the variation is identical to one of the indicators, the dialog box will be displayed with the corresponding indicator when variation maintenance is called up.
Example: Variation

The following graphic shows a section of a Cost Center Hierarchy [Ext.] as an example.

Step

1

ACME INC.

Admin

Production

Warehouse

Buildings

Motor Pool

Production: Unfinished

Production: Finished Products

2

3

4

200 210

400 410

500 510

Selection Object: Acme Inc.

<table>
<thead>
<tr>
<th>Indicators</th>
<th>Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>Breakdown</td>
<td>All group nodes and individual values</td>
</tr>
<tr>
<td>Individual values</td>
<td>200 to 510</td>
</tr>
<tr>
<td>Do not breakdown</td>
<td>Acme Inc. only</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Variation Area</th>
<th>Individual Value</th>
<th>Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>3 to 4</td>
<td>Inactive</td>
<td>As above, but excluding cost centers 200 to 510</td>
</tr>
</tbody>
</table>
## Multiple Selection

### Use

Multiple selection allows you to process multiple combinations of data entry fields (that is, characteristics from the initial screen) in a single run. Multiple selection lets you combine several selections and create specific summarized reports for individual group nodes for your Cost Centers [Ext.], Cost Center Group [Ext.], or for other parameters such as Fiscal Year [Ext.] or Controlling Area [Ext.].

Multiple selection and variations simplify the creation of multiple reports of the same type using numerous different data entries. The following table lists the differences between multiple selection and variation:

<table>
<thead>
<tr>
<th>Multiple Selection/Variation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Multiple selection</strong></td>
</tr>
<tr>
<td>No direct report output</td>
</tr>
<tr>
<td>No individual value detail</td>
</tr>
<tr>
<td>Poor runtimes because a selection is required for each group node</td>
</tr>
<tr>
<td>All characteristics, value, or set variables can be varied</td>
</tr>
<tr>
<td>No changes to report definition required</td>
</tr>
<tr>
<td><strong>Variation</strong></td>
</tr>
<tr>
<td>Direct report output following variation</td>
</tr>
<tr>
<td>Individual value detail</td>
</tr>
<tr>
<td>Better performance because only one selection is required</td>
</tr>
<tr>
<td>Only characteristics in general selections can be varied</td>
</tr>
<tr>
<td>Must be activated in report definition</td>
</tr>
</tbody>
</table>

With multiple selection you can control the degree of detail for a group and the subordinate subgroups by means of a fixed indicator and a hierarchy indicator.

### Fields in the Initial Screen for Multiple Selection

<table>
<thead>
<tr>
<th>Controlling area</th>
<th>From 0001 To 0003</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fiscal year</td>
<td>From 1991 To 1992</td>
</tr>
<tr>
<td>Version</td>
<td>......</td>
</tr>
<tr>
<td>Cost center</td>
<td>......</td>
</tr>
<tr>
<td>Cost element</td>
<td>......</td>
</tr>
</tbody>
</table>

As a result of a multiple selection with these input values, the system saves the following combinations of controlling area and fiscal year:

<table>
<thead>
<tr>
<th>Combination</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area</td>
<td>0001</td>
<td>0002</td>
<td>0003</td>
<td>0001</td>
<td>0002</td>
<td>0003</td>
</tr>
</tbody>
</table>
Multiple Selection

All other criteria remain unchanged. With multiple selection you create six different selections for six different reports of the same report type. These reports are not immediately visible on the screen. You receive a listing of the data entry values (such as cost element groups) for which reports were generated. You can view the report data in the spool file. For further information, see the SAP Library Financials → FI Financial Accounting → FI - Special Purpose Ledger → Report Writer [Ext].
Executing Multiple Selections

1. To carry out multiple selection from the Cost Center Accounting initial screen, choose Information system → Tools → Report Painter.


3. Enter the required Report Group [Ext.] in the initial screen. User F4 help to choose from the list of available report groups.

4. Choose Multiple selection or Utilities → Multiple selection.

5. In the initial screen of multiple selection you vary the data selection criteria by entering value intervals and by activating or deactivating indicators.

   **Fixed Values:**
   If you enter fixed values such as From period and To period, you cannot carry out multiple selection.

   **Vary Values:**
   Interval values in the Controlling Area [Ext.], Fiscal Year [Ext.], and Version [Ext.] fields enable you to create multiple reports involving all possible combinations of fiscal year, version and controlling area.

   **Vary Sets:**
   For cost center and cost element groups you activate/deactivate the fixed and hierarchy indicators.

      a) If the fixed indicator is activated, a report is generated only for the entered cost center or cost element group. When the fixed indicator is deactivated, the group detail is expanded. The degree of detail is determined by the hierarchy indicator.

      b) If the hierarchy indicator is active, the system generates reports for all subordinate groups in addition to the selected cost center group or cost element group. If the hierarchy indicator is inactive, the system generates reports only for the lowest cost center or cost element groups in the hierarchy.

6. Choose Output parameters to select further parameters. Choose Create extracts to make the necessary settings for Extracts [Ext.]. See the options under Executing Report Painter Reports [Page 901] and steps 4 and 5 above.

7. Test run:
   If the indicator Test run is active, variations executed online will only generate a log of the variations in values posted for the report output.

   If you do not activate the indicator, the system releases reports based on the entries you made. Depending on the output medium, the output lists are written to the spool file or exported to a sequential file.

Because multiple selection is very time-consuming, you should check before report output whether the reports were given the correct entry values. This is especially important if value intervals are among the entry values to be canceled. To do so, activate the Test run indicator.
Executing Multiple Selections

8. Menu Entries and Functions Menu entries and functions in the initial screen for multiple selection have the same functional capabilities as those in the initial selection screen. See: Executing Report-Painter Report [Page 301].

9. Display and Print Reports

   You can review and print files which have been created in multiple selection in the spool file.

   To do so, choose:

   * System → Services → Print request

   • In the Spool initial screen, choose Joto → Overview.

   You receive a list of the print jobs contained in the spool file.

   • Highlight a report and choose Spool request → Display, to display the corresponding report on your screen.

   • Select a report and choose Spool request → Print to go to the initial screen for printing entries. Enter an output device as well as the number of copies and choose Print.

   !

   If you wish to print one or more reports for which you have multiple selected data entry values, you must activate the Output reports indicator in the initial screen of multiple selection and deactivate the Test run indicator.
**Example: Multiple selection**

The following cost center groups are available:

```
Step
1
2
3
4
```

The table shows the various possible combinations of fixed and hierarchy indicators. The value entered is Acme Inc.

**Fixed/Hierarchy Indicator**

<table>
<thead>
<tr>
<th>Fixed</th>
<th>Hierarchy</th>
<th>Selected Groups/Values</th>
<th>No. of Reports</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>&quot; &quot;</td>
<td>Acme Inc.</td>
<td>1</td>
</tr>
<tr>
<td>&quot; &quot;</td>
<td>x</td>
<td>All groups</td>
<td>8</td>
</tr>
<tr>
<td>&quot; &quot;</td>
<td>&quot; &quot;</td>
<td>&quot;Warehouse&quot;, &quot;Building&quot;, &quot;Motor pool&quot;, &quot;Production: Unfinished&quot;, &quot;Production: Finished Products&quot;</td>
<td>5</td>
</tr>
</tbody>
</table>
Functions for Output of Report Painter Reports

Use
You have various options for navigation during Report Painter [Ext.] report output, in addition to functions for changing the report layout.

Features
The following graphic shows how to use the various functions for report output.
Printing Reports

1. To print a report, choose Report → Print.

2. If you executed a variation, decide whether to print all variation reports or only the current report.

3. Decide whether to print all the pages of the report or only the current page.
   
   Depending on the size of the report and the page size given in the layout parameters, the report will be divided horizontally and vertically among different pages.
   
   You can print the page displayed on the screen, or print all pages.

4. To print selected pages, choose Further options. You can enter the vertical and horizontal page area of the report that you wish to print. You can also enter the page length of the report. If the given paper size is too small, the report is continued on the following page.

5. Choose Continue.

6. In the screen Print Parameters you enter the following information.
   
   – Printer
   – The number of copies
   – Spool control data
   – Print format

You can also print directly from the initial selection screen. From this screen, use Program → Execute + print (see: Executing Report-Painter Report [Page 501]).
Exporting Reports

Prerequisites

You can download a report to a file and thus enable it to be made available to either the presentation server or the application server.

Procedure

2. For export to the presentation server (the computer workstation with which you are working) enter the following parameters in the window Export to Presentation Server.
   - Export format
   - File name of the output file
   - Parameters to start the PC application
3. To output to the application server (the network server where the R/3 System is running) enter a File name in the field and choose Application server. In the Export to Application Server dialog box, enter the Export format.
   
   The following table provides an explanatory overview of the export parameters:

Export Parameters

<table>
<thead>
<tr>
<th>Export Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export format</td>
<td>For output to the presentation server, you can use the following Export formats:</td>
</tr>
<tr>
<td></td>
<td>1. Spreadsheet</td>
</tr>
<tr>
<td></td>
<td>In spreadsheet formats, all formatting codes are removed.</td>
</tr>
<tr>
<td></td>
<td>2. Word processing</td>
</tr>
<tr>
<td></td>
<td>3. DBAS format</td>
</tr>
<tr>
<td></td>
<td>4. Microsoft ® Excel</td>
</tr>
<tr>
<td></td>
<td>The file is exported in Excel format.</td>
</tr>
<tr>
<td></td>
<td>4. HTML format</td>
</tr>
<tr>
<td></td>
<td>The file is exported in HTML format.</td>
</tr>
<tr>
<td></td>
<td>WK1 format</td>
</tr>
<tr>
<td></td>
<td>Spreadsheet format</td>
</tr>
<tr>
<td></td>
<td>For export to the application server, you can use the Spreadsheet and Word processing export formats.</td>
</tr>
<tr>
<td>File name</td>
<td>The File name describes the file in which you write the report data.</td>
</tr>
</tbody>
</table>
### Exporting Reports

| Program                      | In the *Program* field you can enter the name of a program which should be executed on the presentation server upon completion of the data export.  
|                             | **Example:** `C:\EXCEL\EXCEL` |
| Parameters for application   | In the *Parameters for application* field you enter the parameters required for program execution on the presentation server.  
|                             | **Example:** When you enter the program parameter `&`, this parameter will automatically be replaced by the current file name upon program execution. |
Sending Reports

Prerequisites

You have the option of sending reports via electronic mail.

To be able to do this, the selected report data must already exist as an Extract [Ext.] . If this is not the case, you can save the data here as an extract. Enter a name, a password if necessary, and an expiration date for the extract.

Procedure

1. Choose Send or Send report.
2. The document name and send date are defaulted in the Create and Send Document screen. You can overwrite the send date.
3. Under Note you can enter the changed data for the report.
4. Enter a recipient and specify the recipient with the Recipient type indicator. Under Recipient you enter the name, distribution list, or the address of the recipient or the organizational unit.

   The table lists the valid recipient types.

Recipient Types

<table>
<thead>
<tr>
<th>Indicators</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>P</td>
<td>Personal distribution list</td>
</tr>
<tr>
<td>O</td>
<td>SAPOffice user name</td>
</tr>
<tr>
<td>C</td>
<td>General distribution list</td>
</tr>
<tr>
<td>B</td>
<td>SAP user name</td>
</tr>
<tr>
<td>U</td>
<td>Internet address</td>
</tr>
<tr>
<td>X</td>
<td>X.400 address</td>
</tr>
<tr>
<td>R</td>
<td>SAP user in other SAP System</td>
</tr>
<tr>
<td>A</td>
<td>External address</td>
</tr>
<tr>
<td>F</td>
<td>Fax number</td>
</tr>
<tr>
<td>H</td>
<td>Organizational unit</td>
</tr>
<tr>
<td>J</td>
<td>SAP object</td>
</tr>
</tbody>
</table>
Selecting/Deselecting Blocks

Selecting Blocks
1. To highlight a block, select the row at the beginning of the block and choose Select block.
2. Then select the row at the end of the block and choose Select block again.

Deselecting Block
Choose Edit → Deselect block to undo the highlighted markings.
Entering Threshold Value Conditions

Prerequisites
You can enter a threshold value condition in the executed report in order to emphasize or print report rows with color highlights, depending on numerical values or specific report columns (reference columns).

Procedure
1. Choose Edit → Threshold value and enter the condition in the dialog box.

   Your report has columns for actual costs [Ext.], plan costs [Ext.], and variance [Ext.] between actual and plan costs. You want to emphasize all rows with variances greater than or equal to 10,000. To do so, you enter a threshold value. In this example, the condition is >=, the threshold value is 10000, and the reference column is 3. You also need to set the Threshold Value Condition Active indicator.

2. Choose Additional options to determine whether to highlight the selected rows, or whether to print only those report rows that fulfill the threshold value condition. In addition, you determine whether to ignore the plus/minus sign during value selection for those values fulfilling the condition.

3. Choose Further condition to enter a second threshold value condition.

   If you use a standard layout in report definition with the Changes allowed during execution indicator activated under Page/Control, you can save changed threshold values for future report callups.

For more information, see the SAP Library under FI-Financial Accounting → FI-Special Purpose Ledger → Report Writer → Report Writer Reports → Defining The Report Header [Ext.]
Sorting Report Rows

Sorting Report Rows in Ascending/Descending Order

To sort selected report rows in a particular report column, select the corresponding column and choose *Sort in ascending order / descending order.*

The R/3 System sorts only consecutive report rows on the same summarization level; the order set in the summarization hierarchy remains unchanged.

After a report column is sorted, a symbol appears in the report column header.

Undoing Sorts

To restore the original report row order, choose *Edit → Undo sorting.*

The function sorts only the report rows in the current report.
Hiding/Showing Rows

Hiding Rows
To hide a row, place the cursor on that row or select a block (see: Selecting or Deselecting a Block [Page 332]) and choose Edit → Hide row. The system hides the row(s) selected.

You do not want to print certain rows in a report. Therefore, you hide these rows and print the displayed section of the report.

Showing Rows
To show a row, choose Edit → Show row. All hidden rows appear again.
Selecting Columns and Rows

1. In large reports with more than one column or row, choose Goto → Position → Page/Section/Row/Column to find specific pages, sections, columns, or rows.

2. Choose Position → Row to find specific report rows.

3. In the Choose Row Block dialog window, choose one of the listed blocks.

   For more detailed selection, in other words of a particular Cost Element [Ext.], Activity Type [Ext.] or Statistical Key Figure [Ext.] in the row block, the system displays the Cost Element Group [Ext.], Activity Type Group [Ext.] or Statistical Key Figure Group [Ext.].

   You can choose the cost element, activity type or statistical key figure from these groups.

For more information about column and rows, see the R/3 library under AC - Financials → FI Financial Accounting → FI-Special Purpose Ledger → Report Writer → Report Writer Reports → Define Rows [Ext.] or Define Columns [Ext.].
Navigating Within Reports

In extensive reports consisting of multiple column blocks, you can go directly to the first or last column block, or page forwards or backwards within the columns.

To do so, choose First/Previous/Next/Last column or Goto → First/Previous/Next/Last column.
Graphics

Use
You have the option of displaying report data in a graphic.

Features
Choose Graphics or Goto → Graphics to display the graphic you specified in the menu Settings → Layout → Page/Control as the first graphic. You can reconfigure this graphic as required by using the functions and menu options in the SAP Presentation Graphics tool.

Choose Edit → Select block to highlight a report block you wish to include in the graphic.

You can choose Settings to change the basic settings of your graphic in a variety of ways.

For further information on graphic functions, see the R/3 library under FI - Financials → Special Purpose Ledger → Report Writer → Report Groups → Executing Report Groups (see: Executing Report Groups [Ext.]).
Calling Up Reports

1. To call up another report, select the report row and choose Call up report. The Select Report dialog window displays a list of reports for selection.

2. Select the desired report.

A list only appears if you make the necessary settings in the report definition.

For more information, see the R/3 library under FI Financials → FI Special Purpose Ledger → Report Writer (see: Report Writer [Ext.]).
Variation Functions

Use

Choose Variation to create separate reports for groups and individual values online, using those reports for which you define a variation and for which you have maintained a variation area.

To see the variation functions, choose View → Variation.

When you access the cost center report: Actual/Plan/Variance by its Cost Center Group [Ext.], and you have maintained the variation area for the Cost Center [Ext.], you can navigate within this cost center group. In other words, you can select a subordinate group or an individual cost center.

Features

Choose Graphic selection to display the structure of the cost center group from which you can select the desired target group.

Other functions in variation include:

- **Left/Right**
  You can use Left and Right to navigate within a hierarchy step.

- **Previous Step/Next Step**
  You can use Previous/next step to navigate to a higher or lower group node in the hierarchy.

- **First/Previous/Next/Last Setting**
  These functions allow you to access the given selection, or to work through the cost center group from a particular starting point.

See also:

Example: Functions Within Variation [Page 941]

For further information on variation, see: Variation [Page 1082] and the SAP Library under AC - Financials → FI - Financial Accounting → FI Special Purpose Ledger → Report Groups → Report Group Execution [Ext.]
Example: Variation Functions

You created the following cost center group:

```
Step
1
ACME INC.

2
Admin

3
Production

4
Warehouse

5
Buildings

6
Motor Pool

7
Production: Unfinished

8
Production: Finished Products

9
200

10
210

11
400

12
410

13
500

14
510
```

In the cost center group, the R/3 System interprets your choice of Left from “Buildings” to be a move to “Warehouse”. You can not move Right from “Motor pool” because no groups exist on to the right of “Motor pool”.

The R/3 System interprets Previous level from the “Warehouse”, “Buildings”, or “Motor pool” as a jump to “Administration”. Next level is not possible from “Motor pool” or “Warehouse” because no groups exist beneath them. Next level from “Buildings” creates separate reports for cost centers 200 and 210. This requires you activate the Single value indicator in the previous definition of the variation area.
Summarization Level

Use

You can specify from within a report which summarization levels should be displayed. To do so, choose View → Summarization level.

A summarization level corresponds to a level in a group, such as in the Cost Element Group [Ext.]. The summarization level 0 indicates the individual values.

The maximum possible number of summarization levels in your report is equal to the number of levels in the cost element group. The maximum level value is a defaulted upper limit.
Hierarchies

Use

You can expand the report hierarchy [Ext.] completely (display the report down to its lowest level), or collapse it completely (only display the report rows from the highest hierarchy level). To do so, choose View → Hierarchy.

If you selected a totals row, you can expand the hierarchy by one additional level by displaying the level beneath the row. Alternatively, you can collapse the hierarchy by one additional level by collapsing the level beneath the totals row.

You can also expand and collapse the hierarchy by selecting the totals rows. If the levels beneath a totals row were displayed before, your selection collapses all the levels beneath. If the levels were collapsed before, the selection displays a level beneath the totals row.

In the executed report, one or more asterisks (*) indicate the totals rows. The number of asterisks is based on the number of hierarchy steps. Therefore, the totals rows on the lowest levels always have a single asterisk.
Extras

Use
Choose Extras for supplementary information on the report.

Features
You can find the following functions in under Extras:

• Selection Log
  You can display and print the selection log for your report.
  The selection log provides information on:
  – The number of records read from which tables
  – What percentage of records read were used in the report
  – How many records were not used due to failed authorization checks

• Messages
  The system collects all warning messages that arise during report execution, for example if cells cannot be valuated. You can display the warning messages.

• Technical Information
  You can view information on the table, library, report group, report, and programs.

• Comments
  You can attach an explanatory text to the current report. This text appears at the end of the report after the last page. You can generate the comments using the SAP Script Editor.

⚠️
If you recreate or delete a report group, the comments appended to the report group are deleted.

• Documentation
  Choose Extras → Documentation to display and print the documentation for the corresponding report.

• List/Display/Change Definition
  The functions call up the corresponding features of report definition and allow you to display or change the current definitions.
Specifying Column Widths

To specify column widths, and the position of the key columns and data columns, choose Settings → Column width.

You can also specify the column width and unit width individually for different format classes. Choose Settings → Layout → Column totals (Settings [Page 947]).
Setting Number Formats

Choose Settings → Number format to make the following settings for each format class:

- Number of decimal places
- Scaling (for example, 3 represents 10^3)
- Column width
- Reverse ± sign
- Unit width in the report (that is, the number of columns to be reserved in the report for currency or units of measure)

You can also specify the column width and unit width individually for different format classes. Choose Settings → Layout → Column totals (see Settings [Page 547]).
Settings

Use
Choose Settings to determine the parameters for structuring your report and the texts within it.

Features

- Layout
  Choose Settings → Layout to set page format and display parameters.
  Layout parameters which you can edit online are ready for data entry; those that cannot be edited online are not ready for entry. You can only set the latter during report definition.

- Texts
  Choose Settings → Texts to configure title pages, end pages, headers, and footers, to create text for exports, and to access word processing functions (see: Report Texts [Page 1109]).

You can change report texts in an executed report only if you use a standard layout in report definition with the Changes allowed during execution indicator activated under Page/Control. You cannot change report texts in standard reports.

- Graphic Column Text
  If your report contains several levels of header text in the columns, you can define the way the text appears in graphic displays by choosing Graphic column text.

- Displaying Format Classes
  You can display the format classes for report column assignments in the first report row. Format classes combine columns with the same decimal place, scale, and column width characteristics. You can define up to six different classes per report.

  The Actual Costs [Ext.], Plan Costs [Ext.] and absolute Variance [Ext.] report columns are grouped into one format class. The following parameters are specified for the first format class, which you can also change by choosing Settings → Layout:

  - Decimal Places: 3
  - Scale: 3
  - Column Width: 15

  The column Percentage variance is differentiated by a second, separate format class:

  - Decimal Places: 2
  - Scale: 0
  - Column Width: 4

Report/Report Interface
If you use a standard layout in report definition with the *Changes allowed during execution* indicator activated under *Page/Control*, you can determine which receiver reports can be called up from the released report.

Example Process: Report Callup with Extract Management

Purpose
At the end of each month, the reports (important to cost center managers in the entire organization) are executed, and the data is stored in extracts [Ext.]. Reports that contain data for individual cost centers [Ext.] or cost center groups [Ext.] are executed using variation, so that a separate report can be created for each cost center and cost center group.

You can set the user parameters for your cost center managers so that they can automatically access the most current extracts.

When calling up a report from the report tree, each manager receives the relevant individual data. The manager does not need to select the data from the database again, which reduces the workload of the system.

The cost center manager cannot navigate to areas within the extracts that do not belong to the authorized CO-OM responsibility area.

The system administrator who sets up these reports needs to have authorization to select the data from the database. However, this does not authorize the administrator to display the data in those reports.

The cost center managers need authorization to display the reports for their CO-OM responsibility area. However, this does not entitle them to select the data from the database or to create extracts.

The following graphic displays the way in which a report is executed in extracts, in the background with the variation. It also shows how you can save it in extracts.
Example Process: Report Callup with Extract Management

Process Flow

1. Initial setups include creating the authorizations for system administrators and cost center managers [Page 952].

2. The system administrator arranges for all the reports to be accessible to all users in EUROs. The system administrators execute the report (such as the Cost Centers: Actual/Plan Variance report) in the background and with the variation, and save the report in extracts (see: Executing a Cost Center Report with Variation and Saving it in Extracts [Page 955]).

3. The system administrator makes the settings for extract management for the cost center managers in Customizing (see: Specifying Settings for Extract Management [Ext.]). In their user-specific settings, the cost center managers save their selection criteria for the reports they want to display (see Customizing for Controlling under Cost Center Accounting → Information System → User Settings → Specify User Settings [Ext.]).

4. The cost center manager accesses the report (see: Calling Up Cost Center Reports [Page 960]).

This procedure is shown in more detail in the following sections using the Cost Centers: Actual/Plan/Variance report.

Result

Each cost center manager can quickly and easily display the relevant reports required.
Creating and Issuing Authorizations for System Administrators and Cost Center Managers

Prerequisites
A controlling area [Ext.] and the corresponding standard hierarchy [Ext.] exist in your SAP System.

Creating Authorizations for System Administrators

In the Implementation Guide (IMG) for Cost Center Accounting, choose Authorization Management → Define Authorizations and Profiles [Ext.].

Create a role.

Choose the Menu tab page.

Assign the PF CG transaction on this page.

Choose the Authorizations tab page and the Change authorization data icon.

Enter CO as the organizational level.

Use Manual to insert the CO: General authorization object for Cost Center Accounting (K_CCA) authorization object.

Place the cursor on your authorization object.

Choose Edit → Copy authorization.

Maintain the field values for the Actions for CO-OM authorization check.

Actions: Enter the 3027 action (select totals records) in the From column.

Cost element: Enter the necessary cost elements.

Area of responsibility: Choose Cost center, standard hierarchy node or Cost center group.

Choose New entries and maintain the corresponding values.

Choose Confirm to leave the dialog box.

Save the authorization.

Choose Generate.

Creating Authorizations for Cost Center Managers

In the Implementation Guide (IMG) for Cost Center Accounting, choose Authorization Management → Define Authorizations and Profiles [Ext.].

Create a role.

Choose the Menu tab page.

Assign the PF CG transaction on this page.

Choose the Authorizations tab page and the Change authorization data icon.

Enter CO as the organizational level.
Creating and Issuing Authorizations for System Administrators and Cost Center Managers

Use Manual to insert the CO: General authorization object for Cost Center Accounting (K_CCA) authorization object.

Place the cursor on your authorization object.

Choose Edit → Copy authorization.

Maintain the field values for the Actions for CO-OM authorization check.

Actions: Enter the 3027 action (select totals records) in the From column.

Cost element: Enter the necessary cost elements.

Area of responsibility: Choose Cost center, standard hierarchy node or Cost center group.

Choose New entries and maintain the corresponding values.

Choose Confirm to leave the dialog box.

Save the authorization.

Choose Generate.

Assigning Authorizations to Users

On the initial screen for role maintenance, choose Users.

Enter the users to whom you wish to assign the role.

Save your entries.

Result

The system administrators are authorized to select data from the database. This authorization applies for the entire organization.

Each cost center manager has the authorization to display reports from his or her CO-OM responsibility area.
User Settings

Use

Under user settings, you enter which values the selection screens are to contain when you call up the reports. These user settings include:

- Selection criteria
- Planning period
- Reporting timeframe
- Reporting currency
- Other details (actual valuation for example)

In Customizing for the relevant Controlling application component or in the relevant area menu, you can define these settings per user or enter standard settings. The standard settings apply to all users for whom no user-specific settings apply.

For more information, see Customizing for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext.].
Executing Cost Center Reports with Variation

Procedure

1. In the Cost Center Accounting menu, choose Information system → Reports for Cost Center Accounting → Plan/Actual Comparisons → Cost Centers: Actual/Plan/Variance

2. Enter a controlling area [Ext.], fiscal year [Ext.], periods, and a version [Ext.] on the selection screen under Selection values (for example, controlling area 0001, fiscal year 1998, from period 1, to period 1, version 0).

3. Enter the top node of the standard hierarchy [Ext.] as the cost center group.

   If variation was activated in the report definition, and if you enter a cost center group, the system automatically executes the variation. This means that a report is create for each cost center and each node in the cost center group you specified. You can check this by choosing Variation. If the variation is active the field Explode is selected in the dialog box.

4. Enter a cost element group (for example, INT).

5. To save your report in extracts [Ext.], choose Extract parameters.
   a) Activate the Create extract indicator in the dialog box.
   b) Enter a descriptive text for the extracts (such as Actual/Plan/Variance Jan. 98).
   c) Select Expires on and enter an expiration date for the extracts (such as 28/2/1998). The extracts will be deleted when this date is reached.

   Even if you select No expiration date, the extracts will be deleted whenever you regenerate the report or when you upgrade your system to a new release or upgrade level.

   d) Choose Continue to close the dialog box and save your entries.

6. Choose Output parameters and select No output in the dialog box because the system administrator should not be authorized to display the reports.

7. To execute the report in the background for performance reasons, save your entries on the selection screen in a variant for the time being.
   a) Choose Goto → Variants → Save as variant.
   b) Enter a variant name (for example, CLOSINGO198) and the description of the variant (for example Closing period 01 1998).
   c) Save your variant.

8. Schedule a background job and assign the variant to it.
   a) Choose Program → Schedule background job.
   b) Choose the Start date and then Date/Time
Executing Cost Center Reports with Variation

c) Enter the date and time of the start date.
d) Save the start date.
e) Choose Steps.
f) Place the cursor on the background job and choose Change.
g) In the Edit step dialog box, enter the variants defined previously (for example, CLOSING0198).
h) Save the step.
i) Return to the Define job screen.
j) Save your background job.

9. To check the processing status of your background job, choose System → Own jobs → Job overview, and then Execute.

The system displays an overview with the processing status of the jobs that you scheduled. To update the processing status display, choose Update every now and again.

Result

The system carries out data selection on the database. It saves the data for the created reports in extracts.
Managing Extracts

Use

If you save reports in extracts, you can access this data at any time without an additional selection run in the database.

You can create extracts:

• Before you execute the report, by choosing Extract parameters in the selection screen and selecting Create extract in the dialog box
• When you leave a report, by choosing Yes when the system inquires if you want to create an extract for the report

With extract management you can:

• Display extracts
• Delete extracts
• Print extracts
• Change the expiration dates of extracts

If you make changes to a report definition that affects the selection screen, then the system cannot use the corresponding selection criteria to locate extracts already saved. However, these are still available in Extract Management

Prerequisites


Procedure

3. From the menu of the relevant Overhead Cost Controlling component (such as Cost Center Accounting) or in Cost and Revenue Element Accounting, choose Information system → Tools → Extract directory.

4. On the selection screen for extract maintenance, enter the criteria according to which you want to select extracts.

   – If you are searching for a given extract, enter the extract name.
   – Decide whether to display only those extracts created by you or another user, or whether you want to display extracts regardless of creator.
   – Decide whether to display extracts from past time frame, or whether you want to display all extracts regardless of creation date.
   – You can select extracts from a particular Report Group [Ext.] or from a report group interval.
   – If you want to limit the extract selection further (such as by characteristic, value, or group), choose Further selection criteria. You can extend the number of selection criteria as you desire, or delete criteria you already entered.
Managing Extracts

5. Choose Execute. The system displays a list of all extracts that meet your selection criteria.

6. Display extract

To display an extract, select the extract and choose Display. The system displays the relevant extract.

6. Delete extracts

To delete the extract, select it and choose Delete. If you choose yes when the system inquires if the selected extracts are to be deleted, the system then deletes those extracts.

The system deletes the extracts if the release status is changed (for example from Release 4.0 to 4.5). Once a maintenance level has been changed (for example from Release 4.5A to 4.5B), the extracts that you saved previously are available once again.

7. Print extracts

– To print the extract, select it and choose Print.
– Enter the printer from which you want to print the extract.
– Under Spool control data, decide whether to print immediately or whether to create a spool order.
– If you chose Background printing then you need to enter the start time for the print request.
  To do this, either choose Start request immediately or enter the start date and the start time for the print request.

The system prints the selected extracts.

8. Change expiration dates of extracts

– To change the expiration dates of extracts, select the extracts from the extract tree that you wish to set to the same date.
– Choose Change expiration date.
– If you want to delete the extract automatically after a given time, enter the number of days in the Expires in field, or the date in the Expires on field.

If you do not want the extract to be deleted, choose No expiration date. This is useful when, for example, you are going to run the report at an unspecified later date, or if the report run takes an extremely long time.

– Choose Confirm to close the dialog box and save your entries.

Before you execute a report, you can call up extract management from the corresponding selection screen by choosing Environment → Extracts. This enables you to have all the functions available:

– Display
– Print
– Print in the background
Managing Extracts

- Change the expiration date
- Delete
- Select/Deselect

For information on extract management, see Customizing for Cost Center Accounting under Information System → User Settings → Specify Settings for Extract Management [Ext].
Calling Up Cost Center Reports

Procedure

1. In the Cost Center Accounting initial screen, choose Information system → Report selection.

2. In the report tree under Plan/Actual comparisons, choose the Cctr: Actual/Plan/Variance report.

3. If the default settings for the selection criteria are complete, in other words, you have stored your selection criteria on the selection screen for all parameters, then the system displays the most current extract [Ext.] for these parameters.

   Because your system administration carried out variation, the transaction calls up a report within variation which matches the selection parameters and for which you have the appropriate display authorization.

4. If you did not make custom default settings, or if these do not match the selection criteria for an existing extract, the R/3 System displays the selection screen.

   Enter the desired selection parameters. If an extract exists for these selection parameters, the R/3 System displays the current extract automatically. Otherwise, the system makes a new data selection from the database.

Result

The R/3 System accesses one of the extracts created with the variation by system administration (such as Actual/Plan Variance, Jan 1998).
Period-Based Information System

Use
In order to avoid runtime performance problems during periods of high use, the period-based information system allows you to start reports during periods of lower use at predefined times. In this way, you can avoid the use of further resources when the system reaches a bottleneck.

Features
In contrast to the interactive information system, the period-based information system combines several processing steps and performs them without user intervention. To do so, you must define a background job. The background job carries out all processing steps necessary to produce reports at a set time or periodically at set intervals. As the user, you initiate report processing by indicating a starting time. The system then performs all further steps without further instructions.

This is particularly useful if you know you need extensive, current detests at predefined times for evaluation.
Executing Report Painter Reports in the Background

To call up Report Painter [Ext.] reports in the relevant component of Controlling, choose:

1. Information System → Reports for Cost Center Accounting or Activity-Based Costing etc. and then the desired report.

   The selection screen described in Executing Report Painter Reports [Page 901] appears.
   The report parameters activated during report execution will be incorporated in the background processing.

2. Enter the report parameters in the selection screen.

3. To execute the report immediately in a background job, choose Program → Execute in background.

4. Enter the following information in the Print Parameters screen:
   a) The name of the output device
   b) The number of copies
   c) If necessary, the spool information and output format

5. Choose Save.

**Result**

The system executes the report in the background.
Execution of Period-Based Report Painter Reports

Purpose
To schedule background jobs for Report Painter [Ext.] reports for fixed times, or to release them at regular intervals in the background, you must save the report in a variant and then schedule a background job.

A variant contains the selection criteria for a particular report.

You create a variant for every report that you would like to generate at regular intervals. The R/3 System uses these variants to generate the reports using the current data at the established intervals.

In the period-based information system, you must enter a preset start and repeat frequency for each online variant. The R/3 System then calls up and releases the report on a periodic basis at predetermined times.

When you plan a background job, enter the name of the variant you chose for the selected report.

Process Flow
1. To call up report painter reports in the relevant component of Overhead Cost Controlling, choose Information System → Report selection.
2. Select the desired report from the report tree of the relevant component. The selection screen described in Executing Report Painter Reports [Page 901] appears. The report parameters activated during report execution will be incorporated in the background processing.
3. To schedule the report as a background job, enter the report parameters in the selection screen.
4. Save your entries in a variant. Choose Goto → Variants → Save as variant.
   a) Enter a name and a description for your variant.
   b) Save your variant.
5. Schedule the background job. Choose Program → Plan job.
   a) Choose Start date.
   b) Enter a start date and time and, if necessary, activate the Execute job periodically indicator.
   c) Save your entries.
   See Planning Background Jobs [Page 965]
6. Choose Steps to access the step list for the background job, to edit the desired steps, or to assign variants to them.
   See Editing Step Lists and Assigning Variants [Page 967]
7. Monitor the processing status of the background job with the job overview functions.
   See Checking the Processing Status [Page 971]
Result

The R/3 System executes the background job for report at the given time and periodically at the given intervals thereafter.

For more information on batch input folders, see the R/3-library, under BC - Basis Components → Kernel Components → BC - System Service → Batch Input Folder (see: Batch Input Folders [Ext.]).
Planning Background Jobs

Enter the following information when planning background jobs:

- Start date
- Frequency interval
- Print specifications
- Target host, if necessary

Enter the following information for the job definition:

- Job name
  Job names are defaulted on the basis of the selected report and selected options (such as *Multiple selection*).

- Job class
  You can determine the priority of your job in the *Job class* field. "C" is the default class. Job class "A" is reserved for jobs with high priority, "B" for regular job runs.

- Target host
  In cases where background processes are active on several hosts, you must specify the server where your background job should be processed. To do so, enter the name of the desired host on the initial screen.
  - If you leave the target host field blank, your background job will be processed by the current server.
  - Enter another host, for example, when you wish to use a printer that is only accessible through that server.

- Start date
  Choose *Start time* on the initial screen to display the *Start Time Values* dialog window, where you can enter the start time for the background job.
  You have the following options:
  - Immediate
    Frees the report background job and begins execution immediately.
  - Date/Time
    Indicate a date and time for the scheduled start. Choose *No start after* to prevent the background job from being started after a particular time.
  - After job
    Enter a preliminary job in the *Name* field. Activate the *Start status dependent* indicator so that the R/3 System starts the job only after the preliminary job runs successfully.
  - After event
Planning Background Jobs

You can enter an event that must occur in order for the job to start. This ensures that
the condition is met before the job starts. If the event requires a parameter, choose
Parameter.

− At operation mode

You can enter a name for the operational mode in which the job should be started
(such as normal mode or night mode).

− Periodic job execution indicator

With the exception of the After job option, all options allow you to execute the starts
on a periodic basis. When you activate the Periodic job indicator, you will have to
select period values. Choose Period values to set repeat runs for the reports on an
hourly, daily, weekly, or monthly basis, or for any other interval of your choosing.

⚠️

Remember to save the data you specified for your job. Saving this information
releases the job for processing.
Editing Step Lists and Assigning Variants

1. Choose Steps to access the step list for the background job, to edit the desired steps, or to assign variants to them.

   A job can consist of multiple steps to be processed sequentially. A step consists of a single program (ABAP program or an external program), and possibly a variant and user name as well. Several reports can be started within a given background job. If you plan a background job, this defines a minimum of one step when you enter the program. You can assign a variant to this step.

   Choose Goto → Maintain variants to leave the step list and display the ABAP Variant Maintenance initial screen. Here you can edit the standard variants that come with the program or create new variants for the program.

2. To edit a job and assign the desired variants to it, select the desired job and use the following functions:

   – Change

     In the Steps editing screen, you can determine which of the previously defined, online variants should be used for the report. In the Variants field, enter the variant you wish to use when processing the report.

     Choose Variant list to display a directory of all saved variants. Variants can be incorporated into the step’s Change screen from this overview.

     The User and Program name fields are defaulted, but you can overwrite them.

     Choose Print specifications to display the print parameters screen for background processing. Enter the output device, the number of printouts, and, if necessary, the spool control data and the output format.

     Remember to save the print specifications and the step variants. Afterwards, save the job definition. Saving this information releases the job for processing.

   – Create

     Choose Create if you have already entered a background job and would like to add more steps.

     If you choose ABAP program, you can vary the program, the variants, the user, or any combination of these three fields. The step defined in this manner will be added to the selected job.

     Choose External program to enter the name, parameter, and target host.

   – Select/Move

     Choose Select and Move to change the order of the steps in the step list. To do so, choose Select to mark a step, select the location where you want the step to be moved to, and choose Move.

   – Display
Editing Step Lists and Assigning Variants

The data for the selected step appears.

– Delete
  This deletes the selected step.

– Spool list
  Provides information about created spool requests.

For more information, see the Process Example: Enhancing a Background Job [Page 969].
Example: Enhance background job

1. Initial creation of the background job:
   a) Initial screen Define Job:
      (Tools → Background job → Multiple selection)
         Job name: J1CS100X
         Job class: C
         Status: Planned
   b) Set and save the start time and repeat interval: Choose Start time
   c) Display and edit the step list: Choose Steps
   d) Select the step and assign variants: Choose Change
      User: MILLER
      ABAP program
      Name: J1CS100X
      Variant: SEL1
      Language: E
   e) Set and save the print parameters: Choose Print specifications
   f) Save the step parameters
   g) Save the background job in the Define Job screen
   h) If you wish, view the job by choosing:
      Goto → Job overview
   i) Return to background job planning

2. Enhance background job
   a) Enter the name of the job to be enhanced:
      Job name: J1CS100X
      Job class: C
      Status: Planned
   b) Edit steps: Choose Steps
   c) Add a new variant to the step: Choose Create
      User name: MILLER
      Choose ABAP
      ABAP program
      Name: J1CS100X
      Variant: SEL2
   d) Save the step
Example: Enhance background job

e) Save the job

Result: The same job (J1CS100X) holds two separate reports. The "enhanced" report uses the new variant in the second step.
Checking the Processing Status

1. Choose System → Own jobs → Job overview to see the job selection screen.

2. Enter the relevant selection criteria in order to find your job. The following selection criteria are available:
   - Job name
     The default setting is an asterisk (*) which you can overwrite.
   - User name
     The default setting is your name, which you can overwrite.
   - Start date
     You can select the job by entering a time interval with date and time, or by selecting a given event.
   - Other selection criteria
     - Job status (planned, released, ready, active, finished, terminated)
     - Jobs without a start date
     - Jobs with preliminary jobs

3. Choose Execute to see the alphabetical job overview.

   The list displays all jobs started, along with the corresponding processing status.

   The table explains the processing statuses.

**Background Job Processing Status**

<table>
<thead>
<tr>
<th>Processing Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planned</td>
<td>The job has a variant assignment but no start date.</td>
</tr>
<tr>
<td>Released</td>
<td>All preconditions for starting are fulfilled. The start date and the repeat period were determined and a variant exists.</td>
</tr>
<tr>
<td>Ready</td>
<td>The job is released but not yet processed; it is waiting in the job queue.</td>
</tr>
<tr>
<td>Active</td>
<td>The job is being processed.</td>
</tr>
<tr>
<td>Finished</td>
<td>Processing is completed.</td>
</tr>
<tr>
<td>Terminated</td>
<td>Processing ended due to an error.</td>
</tr>
</tbody>
</table>

4. Select the desired job in order to carry out the following functions:
   - Job log
     Choose Job log to display a log of the start time and messages.
   - Display
     Choose Display for general information on the background job, such as the dates and times it was planned, last changed, released, or the planned start. In addition, you can display the repeat period, a follow-up job, and a preliminary job.
Checking the Processing Status

The following functions are available:

- Start date
- Steps
  - Job details (time of planning/change/release/start/execution)
  - Preliminary job
  - Follow-up job(s)

- Refresh
  Choose Refresh to renew the displayed job processing status.

- Spool list
  Choose Spool list to view the spool order for your job and the report data. The spool order includes the spool number, the generation date and time, the output status, the size of the file, and the title. Choose Output order to see the date of the print order with the corresponding processing status. Choose Attribute to display the spool order data, such as spool number, user, and output device, and so on.

- Steps
  A job can consist of multiple steps to be processed sequentially. This means that the background job can start multiple reports within itself. A step consists of a program and a user name. If you plan a background job, this defines a minimum of one step when you enter the program. Choose Steps to view a list of steps for the selected job. This includes the program name, the list key, the parameter and variant for the program, and the user name. The list key indicates whether the associated step created a list in the spool file.

  For more information on steps, see Planning Background Jobs [Page 965].

5. Choose Job for the following functions:

- Scheduling: Reset/Release/Repeat
- Copy
- Delete
- Change
- Display
- Move
- Capture
- Cancel job
- Print list

For more information on processing batch input sessions, see the SAP Library under BC Basis → Kernel Components BC-KRN → BC System Services → Managing Batch Input Sessions (see: Batch Input Sessions [Ext.]).
Maintaining Variants

Prerequisites

Menu items are available in background processing for the overview and maintenance of variants, allowing you to display the respective processing status of your background job. You can reach these functions from the Edit Step List initial screen.

Procedure

1. To go to the Delimit Variants screen, choose Goto → Variants. You will see the entries in the selection criteria for the variants and the parameters. The following functions are available.
   - Directory
     
     The function gives an overview of the program variants, allowing you to see which variants are write protected and the last person to make changes to them.
     
     Select a variant in order to display the related selection criteria and parameters.
     
     You can also display or delete individual variants or print the variant directory, particular variants, or all variants.
   - Print the selection criteria and parameters
   - Values, changing
   - Display attributes
   - Change attributes

2. To go to the Variants initial screen, choose Goto → Variant maintenance.
   
   You can do the following in the variants program:
   - Create
   - Display
   - Change
   - Copy
   - Rename
   - Delete
   - Adjust

   If you make changes, save them.
Executing Period-Based Report Painter Reports with Multiple Selection

Prerequisites

In order to execute multiple selection in background jobs, you must first save a variant. A variant contains the selection criteria for a particular report. Execution of Period-Based Report Painter Reports [Page 963].

To produce periodic reports at defined intervals, you must perform the following steps.

Procedure

1. To carry out multiple selection from the Cost Center Accounting initial screen, choose Information system → Tools → Report Painter [Ext.].

   From the Report Painter initial screen, choose Report Writer → Execute report group.

2. To create a variant for multiple selection, choose Utilities → Variant maintenance → Multiple selection.

   - Enter a name for the variant and choose Create.
   - Choose Continue.
   - Enter the selection parameters for the variant.
   - Choose Continue.
   - Enter a description for your variant.
   - Save your variant.
   - Return to the Execute Report Group initial screen.

3. To schedule a background job for multiple selection, choose Utilities → Background job → Multiple selection (see: Scheduling Background Jobs [Page 965] as well as Editing Step Lists and Assigning Variants [Page 967]).

4. Monitor the processing status of the background job with the job overview functions (see: Checking the Processing Status [Page 971]).
Important Standard Reports in Cost Center Accounting

Use

You will find a description below of some important reports for Cost Center Accounting (CO-OM-CCA) supplied in the SAP R/3 System. Additional information for other reports not described here can be found in the documentation for those reports. Choose Extras → Documentation from the report in question.

Standard reports are organized into four different libraries.

- The 1VK Library contains reports for cost accounting systems based on full costs [Ext.].
- The 1GK Library contains reports for cost accounting systems based on marginal costs [Ext.]. These can be used alongside those in the 1VK Library.
- The 1AB Library contains reports for variance [Ext.] analyses.
- The 1RU Library contains summarization [Ext.] reports.

The following reports occupy a special position, since they are not Report Painter reports.

- Planning Overview [Page 991]
- Price Report [Page 996]
- Line Item Report [Page 1006]
- Document Display [Page 1029]
- Calling Up the Master Data Index [Page 1037]
Area: Cost Elements

Use

The Cost Elements: Area reports analyze postings made on a cost element [Ext.], structured by cost centers [Ext.].

The cost accounting report based on full costs [Ext.] can be called up under Information System → Reports for Cost Center Accounting → Plan/Actual comparisons → Area: Cost elements.

The report for cost accounting based on marginal costs [Ext.] is in Target/Actual Comparison → Additional Characteristics → Cost Centers:

For the designated cost center or cost center group you receive an overview according to cost element of actual and plan or actual and target values with the absolute and percentage variance [Ext.] The marginal costs report additionally presents the fixed and variable components of the actual, target and plan costs. Further, both reports show the actual and the plan quantities.
Cost centers: Act./Plan/Variance and Act./Target/Variance

Use

You call up the report Cost Centers: Actual/Plan/Variance in the standard Cost center Accounting report tree with the node Plan/Actual Comparison. You call up the report Cost Centers: Actual/Target/Variance in the standard report tree under Target/Actual Comparison.

The report Cost Centers: Actual/Plan/Variance is used for a cost accounting based on full costs [Ext.]. The report Cost Centers: Actual/Target/Variance is available for cost accounting based on marginal costs [Ext.]. These reports generate a company settlement document.

The reports aid in the evaluation of actual and plan or actual and target values. The totaling within a report takes place for each cost element [Ext.] or cost element group [Ext.].
Cost Centers: Drilldown by Partner

Use

The reports *Cost Centers: Drilldown by Partner* is used to analyze allocated values in the actual and in the plan. This shows the corresponding plan [Ext.] and target costs [Ext.] for each cost center [Ext.] or cost center group [Ext.]. In addition, you list the partners involved in the allocation.

You call up the report for cost accounting based on full costs [Ext.] from *Cost Center Accounting* under Plan/Actual Comparison → Additional Characteristics → Cost Centers: Drilldown by Partner.

You can call up the report based on marginal costs [Ext.] in Target/Actual Comparison → Additional Characteristics → Cost Center: Drilldown by Partner.
Area: Cost Centers

Use

To call up the Area: Cost Centers report, choose Information System → Reports for Cost Center Accounting → Plan/Actual comparisons → Area: Cost centers.

This report is used in Absorption Costing [Ext.] for the evaluation of actual [Ext.] and plan costs [Ext.] for cost centers [Ext.] or cost center groups [Ext.].

There is a differentiated comparison of plan and actual costs in the area list that is arranged by cost centers / cost center groups (for the selected cost centers and cost center groups). There is also a comparison of the absolute and percentage Variances [Ext.]. This report contains one row for each cost center and cost center group.
Cost Centers: Actual/Plan/Commitments

Use

To access the Cost Centers: Actual/Plan/Commitments report, choose Information system → Reports for Cost Center Accounting → Plan/Actual Comparisons → Additional Key Figures → Cost Centers: Actual/Plan/Commitments.

In absorption costing [Ext.], this report enables you to analyze cost centers [Ext.] or cost center groups [Ext.] taking into account those purchase orders that were assigned to cost centers.

This report contains a comparison for the selected cost center or cost center group of actual, commitment, assigned, and plan values for each cost element [Ext.], as well as the values still available.
Cost Centers: Drilldown by Transaction

Use

The reports *Cost Centers: Drilldown by Transaction* is used to analyze postings according to transaction types. In these reports the system provides an overview of plan/actual or plan/target values differentiated by transaction (for example assessment [Ext.], distribution [Ext.], accrual calculation [Ext.], reposting [Ext.]) for the selected cost center or cost center group. Each transaction is differentiated by cost element.

You call up the report for cost accounting based on full costs [Ext.] from *Cost Center Accounting* under Plan/Actual Comparison → Additional Characteristics → Cost Centers: Drilldown by Transaction.

You can call up the report based on marginal costs [Ext.] in Target/Actual Comparison → Additional Characteristics → Cost Centers: Drilldown by Partner.
Cost Centers: Internal Business Volume

Use

Internal business volume means all allocations occurring exclusively within a cost center group [Ext.].

In the other cost center reports you can only eliminate internal volume when you use the cost center [Ext.] characteristic in the general selections of the report. However, using the report for the elimination of internal business volume, the system displays internal business volume as a row or column in the report.

The reports on elimination of internal business volume are found in the 1VK library and are summarized in the report group Cost Centers: Example, Internal Business Volume (1SBU).

In Cost Center Accounting, call up the report by choosing Other Reports → Area: Internal Business Volume.

From there, choose Goto → Other report to access the other internal business volume reports.

Features

The following reports are available.

- Cost Centers: actual/plan net
  
  For the selected cost center or cost center group, the system displays the actual [Ext.] and plan costs [Ext.], as well as the absolute and percentage variances [Ext.] by cost element [Ext.]. Internal business volume within the selected cost center area is not displayed.

- Area list net
  
  For the selected cost centers, the system displays actual and plan costs without showing internal business volume within the cost center area.

- Cost Centers: gross/net
  
  For the selected cost centers or cost center groups, the system displays the posted costs, inclusive of and exclusive of the internal business volume.

- Cost Centers: internal business volume in rows
  
  For the selected cost center or cost center group, the system displays the actual and plan costs for a selected cost element group [Ext.], where debit and credit are displayed separately. The internal business volume within the cost center group is displayed in a separate row block by cost element.
Cost Centers: Rolling Year

Use

This report serves to compare actual and plan figures in CO-OM-CCA within full cost controlling. The report displays actual and plan costs as well as the statistically posted costs and posted statistical key figures in the last 12 periods.
Area: Statistical Key Figures

Use

You call up the report Area: Statistical Key Figures in the standard CO-OM-CCA report tree under Plan/Actual Comparison → Additional Characteristics → Area: Statistical Key Figures.

In marginal or absorption costing, this report analyzes posted statistical key figures [Ext.] in actual and plan, as well as their absolute and percentage variances [Ext.] for a cost center area.
Cost centers: Variances

Use
You can call up the Cost Centers: Variances report in the standard reporting tree in Cost Center Accounting by choosing Target/actual comparisons → Variance analysis.

This report is used within Marginal Costing [Ext.] as an entry point into variance calculation [Ext.]. It shows the actual and target costs for individual cost centers or a cost center area, and explains the variances between actual and target costs. The report divides the variances occurring on the input [Ext.] and output [Ext.] sides according to individual variance categories [Ext.].
**Cost Centers: Splitting**

**Use**

This report is used within Marginal Costing [Ext.] as an entry point into cost splitting analysis. You can use this report to analyze the splitting of costs for one or more cost centers [Ext.] to the corresponding activity types [Ext.].
Template Allocation Structure for Cost Center/Activity Type

Use
This report displays
- For selected cost centers, cost center groups, selection variants, or for all cost centers
- For a key date
- Which actual or plan allocation structures you have defined for template allocation [Page 473]
- Which activity quantities were posted to the given object as fixed quantities and which as variable.

Features
Per cost center/activity type you can:
- Display the cost center [Page 127] or activity type [Page 147] master record.
- Go to the relevant template [Page 393]
- Display the allocation structure [Ext.]
- Create groups [Page 40]
Actual/Plan/Commitment Report

Use

In this report, the system provides you with a comparison (related to the controlling area [Ext.1]) of posted actual values, planned budget values, and commitments by cost center [Ext.1]. This comparison is made for the time frame that you specified. Additionally, separate columns display Assigned funds as well as Available funds, which allow you to carry out availability controls.

(See also: Actual/Plan/Commitment Report [Page 390])
Executing the Actual/Plan/Commitment Report

1. To call up the actual/plan/commitment report budget reports on cost centers, from the Cost Center Accounting menu, choose Information system → Reports for Cost Center Accounting → More Reports → Other Reports → Area: Actual/Budget/Commitments.

2. On the initial screen for the report, enter:
   - Cost center [Ext.] or a cost center group [Ext.]
   - Fiscal Year [Ext.]

3. Choose Execute to see the report.
Planning Overview

Use

Planning overviews give you an overview of planning of individual objects in Overhead Cost Controlling (CO-OM), such as Cost Centers [Ext.], Business Processes [Ext.], and Orders [Ext.].

In the planning overview, you can drill down planning by line items and periods. Planning is also structured by planning transactions, with the partner relationships displayed for secondary cost planning.

You can execute planning overviews online or in background jobs.

For more information, see:

Executing Planning Overviews Online [Page 993]

Executing Planning Overviews in Background [Page 994]

Features

The planning overviews offer the following functions:

| Displaying the Master Record | Position the cursor on the object and choose . |
| Display periods               | The initial callup of the planning overview displays the plan value totals for the selected periods in the fiscal year. To display the planning of one line for the individual periods, position the cursor on the line of the planning overview and choose . Choose . to return to the basic list. |
| Displaying Line Items         | The initial callup of the planning overview displays the plan value totals. To display the planning line items [Ext.] of one line, position the cursor on the line of the planning overview and choose . |
| Call for partner             | You can display the planning overview of a partner object if the object is a cost center, order, or business process. You must use a variant in the planning overview that displays the partner object in a column. Select the partner object and choose . |
| Display price                | You can call up the relevant price reports from the planning overview for a cost center or business process. To display the prices for individual activity types for a cost center in the planning overview, select an activity type in the list and choose . To display the prices of a business process in the planning overview of a business process, select a business process in the activity amounts section of the screen and choose . |
| Print                        | To print the entire planning overview, choose List→Print or . To print a section of the report, choose from the toolbar section of the screen. |
Planning Overview

For more information of the functions available, see ABAP List Viewer (ALV): Grid Control [Ext.]

Report currency

You can display a report currency in the planning overviews in Overhead Cost Controlling. You can make user-specific settings determining whether the overviews display amounts in the controlling area [Ext.], object [Ext.], or transaction [Ext.] currencies, or in a freely-defined currency (such as euros). For more information on defining report currencies, see User Settings [Page 954].
Executing Planning Overviews Online

1. To execute a planning overview, from the Controlling menu (Cost Center Accounting, Internal Orders, Activity Based Costing, and so on) choose Information system → Reports on cost center accounting or Activity based costing.

2. Choose Planning reports → Planning overview.

3. In the initial screen of the planning overview, enter the object for the report. Depending on the planning overview, this is either a cost center [Ext.], an order [Ext.], or a business process [Ext.].

4. Enter the report parameters in the selection screen.
   i. Fiscal year [Ext.]
   ii. From/to period
   iii. Version [Ext.]

5. Choose Execute to close the dialog box and execute the planning overview.

You can find information on the functions available in the planning overview display in the documentation Planning Overview [Page 991].
Executing Planning Overviews in Background

1. To execute a planning overview, from the Controlling menu (Cost Center Accounting, Internal Orders, Activity Based Costing, and so on) choose Information system → Reports on cost center accounting or Activity-based costing.
   The planning overview is found under Planning overview

2. From the initial screen, choose Planning overview → Background job or Multiple execution.

3. In the initial screen of the planning overview, enter the object for the report.
   Depending on the planning overview, this is:
   – A cost center [Ext.] or a cost center group [Ext.]
     In addition, enter an activity type [Ext.] if you want to limit the report to a single activity type.
   – A business process [Ext.] or a business process group.

4. Enter the report parameters in the selection screen.
   – Fiscal Year [Ext.]
   – From/to period
   – Version [Ext.]

5. Depending on the planning overview, you can select various lists to be displayed in the overview.
   The standard default for all planning overviews include the lists of cost elements and statistical key figures.
   Additionally, the planning overview for cost centers includes the lists of activity types, and the planning overview for business processes includes the list of process quantities.

6. Determine the row structure of your report. You can display the rows in the planning overview by period (Period breakdown) or by line item (Line item breakdown).

7. Decide whether to display cost elements planned with value 0 (Display rows with zeros).

8. Choose one of the existing variants for the column structure of your lists.

9. Assign a name to your background job.

10. Choose Execute or Planning overview → Execute.

11. In the dialog box, enter the print parameters (printer, number of copies) for your background job, and choose Print. Your background job is now scheduled.

12. Release your background job.
   – Choose System → Own Jobs → Job overview.
   – Under Further selection criteria, choose Jobs without start dates.
   – Choose Execute.
   – Select your job in the job overview and choose Release.
Executing Planning Overviews in Background

- Enter the time you want the job to run (immediately, at a given date and time, after another job, after an event, in a particular mode, based on the factory calendar, or on a periodic basis).

- Choose Save.

The R/3 System executes the job at the selected time. Choose Refresh to check the status in the job overview.
Price Report

Use

The price report gives you an overview of the prices calculated by the system and manually entered prices [Ext.].

Price reports are available for the following components:

- **Cost Center Accounting**
  
  In Cost Center Accounting, the price report for activity types provides an overview of the activity prices for each cost center [Ext.] and activity type [Ext.]

- **Activity-Based Costing**
  
  In Activity-Based Costing, the price report provides an overview of the process prices for each business process [Ext.]

For more information on

- The entries on the initial screen and the selection options, see Executing Price Reports Online [Page 997] and Specifying Selection Options [Page 999]

- The functions for displaying the price report, see Displaying the Price Report [Page 1001]

The price report in the SAP System corresponds to the internet application component Internal Price Lists. For more information, see Internal Price Lists in the Intranet (CO-OM-CCA) [Page 522].
Executing Price Reports Online

1. To call up the price report in the relevant component of Overhead Cost Controlling (Cost Center Accounting or Activity-Based Costing), choose
   
   Information system ➔ Reports for Cost Center Accounting or Activity-Based Costing and so on.

   The price report is under Prices.

2. In the initial screen, enter the criteria according to which the price report selects data.
   
   Enter the report object.
   
   – In the initial screen of the price report for activity types in the Cost Center Accounting component (CO-OM-CCA), enter a cost center [Ext.], a cost center interval, or a cost center group [Ext.].
     Additionally, enter an activity type [Ext.], an activity type interval, or an activity type group [Ext.].
   
   – In the initial screen of the price report for business processes in the Activity-Based Costing component (CO-OM-ABC), enter a business process [Ext.], a business process interval, or a business process group.

3. Enter the following selection parameters:
   
   – Version [Ext.]
   
   – Fiscal Year [Ext.]
   
   – Period from...to....

4. In addition, you can limit the price report to selected price indicators.

   The price indicator provides the basis of calculation for the price. The following values are allowed:
   
   1: The price is calculated iteratively on the basis of plan activity on the cost center or business process.
   
   2: The price is calculated iteratively on the basis of the capacity of the cost center or business process.
   
   3: The price is entered manually.
   
   4: The plan price is calculated purely iteratively.
   
   5: The actual price is calculated on the basis of actual activity.
   
   6: The actual price is calculated on the basis of capacity.
   
   7: The actual price is calculated purely iteratively.

   Enter the price unit.

   Decide whether you want to display all the selected prices or only those prices used in allocation.

7. The following functions are also available on the initial screen:

   – Selection options offers you more options for entering objects and object intervals (see: Defining Selection Options [Page 999]).
Executing Price Reports Online

- You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
- You can save your entries in a variant in the initial screen and retrieve them again when you next call up the initial screen (see: Processing Variants [Page 1014]).

8. To display the document display online, choose Execute or Execute program.

To display the document display online and print it immediately, choose Program → Execute and print. If you execute the report, you can also print it later from the display screen.

For more information on

Working in the selection screen, choose Help selection screen

Displaying the price report, see Displaying Price Reports [Page 1001].
Determining Selection Options

You can define specific selection options for the relevant report objects or for report object intervals in the selection screen.

Determining Selection Options for Individual Values

1. If you entered an individual value for a report object in the selection screen, select the value and choose Selection options or Edit → Selection options.

   The dialog box has the following selection options:
   - Individual value
   - Greater than or equal to
   - Less than or equal to
   - Greater than
   - Less than
   - Not equal to

2. Choose Select or Exclude from selection.

   Choose the desired selection options.

   You enter cost center 4120 as report object. You choose Greater than or equal to in the selection options. The SAP system displays a report for all cost centers numbered 4120 and higher.

   If you choose Exclude from selection, you receive a report for all cost centers up to, but not including, cost center 4120.

3. Leave the dialog box by choosing Confirm.

Determining Selection Options for Intervals

1. If you entered an interval for a report object in the selection screen, select the interval and choose Selection options or Edit → Selection options.

   The dialog box has the following selection options:
   - Range of values
   - Outside the interval

2. Choose Select or Exclude from selection.

   Choose the desired selection options.

   You enter cost center interval 4100 to 4200 as report object. You choose Outside the interval in the selection options. You receive a report for all cost centers except for those in the interval 4100 and 4200 inclusive.
Determining Selection Options

3. Leave the dialog box by choosing Confirm.
Displaying Price Reports

Use

On the overview screen for the price report, the system displays the data as follows:

- The system displays the prices (total/fixed/variable) for each cost center [Ext.] and activity type [Ext.] or for each business process [Ext.].
- The Price unit (PUnit) gives the number of activity units for which the price applies. For example, if “Drilling” displays “10” for the activity unit “Hours”, the price applies to ten hours of drilling.
- Each price displays the Price indicator (PrIn).
- The Allocation price indicator (A) shows whether the price:
  - Cannot be used for allocation
  - Can be used for valuation of actual and plan allocations
  - Can be used for valuation of plan allocations
  - Can be used for valuation of actual allocations
- You can display the prices in controlling area [Ext.] or object currency [Ext.]. You can display the total price, the variable portion, and the fixed portion. You can change the display using display variants [Ext.].

If you use the price report for multiple periods, the system initially displays the average of the prices in all periods. The average is weighted with the quantities from the individual periods. To view individual period prices, choose Period screen.

If the price unit varies throughout the individual periods, the price appears using the smallest unit found in the periods.

Features

Within the price report, you can use the functions provided by the ALV Grid Control to change the presentation of the data in reports:

For more information, see ABAP List Viewer (ALV): Grid Control [Ext.]

The following additional functions are available:

Displaying Period Screens and Overview Screens [Page 1002]
Displaying Master Records [Page 1003]
Displaying Cost Components [Page 1004]
Displaying Period Screens and Overview Screens

The initial calliope of the price report displays the data for the selected objects in the overview screen for the entire fiscal year.

Displaying Period Screens

To display data for an activity type [Ext.], a cost center [Ext.], or a business process [Ext.] for each period, select the corresponding row in the overview screen. Next, choose or Goto → Period screen.

The data for this object is organized according to the individual periods in the fiscal year. The columns in the period screen are identical with those in the overview screen. You can use all the overview screen functions in the period screen except Display master record, Cost components, Set filter, and Delete filter (see: Displaying Price Reports [Page 1001]).

Displaying Overview Screens

To switch to the overview screen from the period screen, choose Back or Joto → Back.
Displaying the Master Record

To display the master data record for a cost center [Ext.], activity type [Ext.], or business process [Ext.], select the lead column and choose Master record or Goto → Master record.
Displaying Cost Components

Procedure

Select a row in the list and choose Goto → Cost components. This starts the report.

Result

The report displays the cost components for the relevant object, based on the cost component structure you defined in the Implementation Guide (IMG) (see also: Price Calculation With Cost Component Split [Page 887]).
 Executing Price Reports in Background

Complete the first seven steps as explained in Executing Price Reports Online [Page 997].

Choose Program → Execute in background.

In the dialog box, enter the print parameters (printer, number of copies) for your background job, and choose Print.

You can check the status of your background jobs in the job overview.

Choose System → Own Jobs

Choose Job overview.

Choose Execute.

After some time, choose Update again.
Line Item Report

Use
Line item [Ext.] reports enable you to select individual posting documents. Controlling contains line item reports for the following components:
Cost Center Accounting
Internal Orders
Activity-Based Costing

Features
You can use the following line items reports for the analysis:
Actual line item report
You can display line item reports for archived actual costs (see: Reading Standard Reports from the Archive [Page 811]).
Plan line item report
You use these reports to update plan line items. To do so, in Customizing under Controlling General → Controlling, choose Organization → Maintain Versions [Ext.] and activate the Integrated planning indicator in the settings for each fiscal year.
Commitment line item report
You can use this report in both Cost Center Accounting and in Overhead Orders.
CO line item report for reconciliation ledger
To call up the selection screen, go to the Cost Element Accounting menu and choose Information system → Reports for Cost Element Accounting → Document Display → Reconciliation Ledger: CO Line Items.

For more information on cost center line item reports, see Cost Centers: Actual Line Item Report [Page 1008], Cost Centers: Commitments Line Item Report [Page 1010] and Cost Centers: Plan Line Item Report [Page 1009].

For more information on business process line item reports, see Business Processes: Plan Line Items [Ext.] and Business Processes: Actual Line Items [Ext.]

If there are any incorrect line items, you can trigger an adjustment posting directly from the report by choosing Extras → Correction request (see Request for Adjustment Postings in the Intranet [Ext.]).

Selection
You can select line item reports according to the following parameters:
Object (cost center [Ext.], business process [Ext.], order [Ext.])
Range of objects (a given number)
Object group
Cost element
Cost element interval
Cost element groups
Posting period
Debit date for commitment [Ext.]

The selection screen enables application-wide use of the line item report. In the selection screen you can limit the selection according to object type, partner object type, and other selection criteria. You can access the line item report from the selection screen.

You can use the enhancement COOMEP01 to add to additional fields in the line item report. To do so, in Customizing for the relevant application component, choose Information System → Standard Reports → Enhancements for Line Item Reports [Ext.].

**Standard Variants**

You can format the list using display variants contained in the standard system. You can also define your own display variants.

For more information on displaying the line item report, see Displaying the Line Item Report [Page 1019].

If you are working with transfer prices (multiple valuation approaches) you can select the required valuation approach (with which the line item report is displayed) in the initial screen for the line item report. You do this on the line item report initial screen by choosing Extras → Data source.

For more information on transfer prices, see Multiple Valuation Approaches [Ext.].

In the SAP standard display variants, the value fields in the controlling area currency were replaced with the value fields in the report currency. This enables you to display/print line item reports in any currency. For more information on report currency, see the IMG for Cost Center Accounting under Information System → User Settings → Specify User Settings [Ext].
Cost Centers: Actual Line Item Report

Use

This report displays the cost center line items for actual costs. These line items correspond to the document rows, which are generated by the R/3 System for all postings of costs to cost centers and for allocations.

For more information, see Line Item Report [Page 1006].
Cost Centers: Plan Line Item Report

Use

This report displays the cost center line items for planned costs. These line items correspond to the document rows, which are generated by the R/3 System for all postings of costs to cost centers and for allocations. The system only writes plan line items if you have activated the settings for plan line items in your version.

For more information, see Line Item Report [Page 1006].
Cost Centers: Commitments Line Item Report

Use

This report displays the commitments line items posted to the cost centers. A commitment shows that actual costs are to be incurred at a future date, for example, due to the entry of a purchase order with account assignment to a cost center. When the actual costs are incurred, the commitments are reduced, that is to say, the corresponding line items can no longer be displayed after this time.

For more information, see Line Item Report [Page 1006].
Executing Line Item Reports Online

1. To execute a line item [Ext.] report, go to the menu in the relevant component of the SAP R/3 System (Cost Center Accounting, Overhead Cost Orders and Activity-Based Accounting) and choose

   Information system → Report selection, then Line Items → Actual or Commitment.

   You call up the plan line item report via the report/report interface or from the basic list for period-based allocations (see Executing Periodic Repostings or Periodic Allocations Online [Page 801]).

   You can display line item reports by controlling area [Ext.]. To change the controlling area when necessary, choose Extras → Set controlling area.

2. In the initial screen, enter the criteria according to which the line item report selects data.
   – Enter an object (cost center [Ext.], order [Ext.], business process [Ext.]), an object interval or an object group (cost center group [Ext.], business process group, order group [Ext.]).
   – If you wish to restrict the selection to particular cost elements [Ext.] enter a cost element, a cost element interval or a cost element group [Ext.].
   – For actual and plan line item reports, enter under Posting date the date or timeframe for which you want to select data.
     For commitment line items reports, enter under Expected debiting date the date or timeframe for which you want to select data. To limit the selection to open line items, choose Open items only.
   – Enter the version for the plan line item report.

3. To determine the data presentation in the line item report, choose a standard display variant under Display variant or define your own variant (see Choosing Display Variants [Ext.]).

4. If you require fast performance when calling up line item reports, choose Further settings and activate the Variant fields only indicator in the dialog box. This means that you can make only limited changes to the selected display variant in the line item report. The number of fields offered for selection in display variant definition is thereby reduced.
   If you require the full range of variant definition, leave the Variant fields only indicator deactivated.

5. You can set the number of selected entries to a maximum limit. To do so, choose Further settings and enter under Maximum number of hits the maximum number of rows to be read from the database. In this way, you can greatly reduce the waiting times for processing.

6. The following functions are also available on the initial screen:
   – You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
Executing Line Item Reports Online

- You can restrict the selection even further, by value type and other selection criteria (see: Selecting Value Types [Page 1016], Setting Actual Versions [Page 1015], Specifying Additional Selection Criteria [Page 1017]).

- You can save your entries in the initial screen of a variant and call them back up again when you next open the initial screen (see: Maintaining Variants [Page 1014]).

- If you entered an object group in the initial screen, you can display it (see: Displaying Groups [Page 1018]).

- You can read line items from the archive (see: Reading Standard Reports from Archives [Page 911]). To do so, choose Extras → Data source.

7. To display the line item report online, choose Execute or Execute program.

   To display the line item report online and print it immediately, choose Program → Execute and print. If you execute the report, you can also print it later from the display screen.

For more information on displaying the line item report, see The Line Item Report Display [Page 1019].
Deleting Selections

Prerequisites
You entered one or more individual values or intervals for a report object in the selection screen.
You can delete either the first selection row for this report object (meaning the first value or interval) or all selection rows.

Deleting Selection Rows
To delete the first selection row for a report object, select the object and choose Delete selection or Edit → Delete selection row.
The SAP system deletes the first row appearing in the selection screen. If you defined further selection rows with multiple selection, the screen displays the next selection row.

Deleting All Selections
To delete the all selection rows for a report object, select the row and choose Edit → Delete all selections.
The SAP system deletes not only all the visible rows for the report object in the selection screen; it deletes all rows for this report object created with multiple selection.
Maintaining Variants

You can save your selection screen entries in a variant. When you return to the initial screen you can call up the corresponding variants. If necessary, you can also change them. By doing this, you can avoid repeating criteria for the same reports in the initial screens.

You can also delete existing variants.

Saving Entries as Variants

1. Choose Goto → Variant → Save as variant to save your entries as a newly created variant.
2. Choose Continue.
3. Enter a Variant name and a short description under Description for your variant.
4. Save your variant.

Getting Variants

1. Choose Goto → Variant → Get to call up an existing variant.
   A dialog box displays existing variants with their names and descriptions, in addition to their relevant selection screens.
2. Select the desired variant to leave the dialog box.

Displaying Variants

1. Choose Goto → Variant → Display for an overview of existing variants for initial screens.
   A dialog box displays existing variants with their names and descriptions, in addition to their relevant selection screens.
2. Select the variant to view the selection screen objects and the hidden selection criteria for the variant.

Deleting Variants

1. Choose Goto → Variant → Delete to eliminate an existing variant.
2. Select the variant to be deleted and choose Select.
3. Specify in the dialog box whether you want to delete the variant in all clients or only in the current client.
4. Choose Continue to leave the dialog box.
Setting Actual Versions

Prerequisites

Setting actual versions is useful only for actual and commitment line item reports.

Procedure

1. To limit the selection screen to given actual versions, choose Extras → Actual version.
2. Enter the version in the dialog box.
3. Leave the dialog box by choosing Execute.
Selecting Value Types

1. To limit the selection screen to given value types, choose Extras → Select value types.

   The table lists the standard value types in the system.

### Standard Settings for Value Types

<table>
<thead>
<tr>
<th>Line Item Report</th>
<th>Standard Value Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan line item report</td>
<td>01 Plan</td>
</tr>
<tr>
<td>Actual line item report</td>
<td>04 Actual</td>
</tr>
<tr>
<td>Commitment line item report</td>
<td>11 Statistical actual</td>
</tr>
<tr>
<td></td>
<td>21 Commitment from procurement</td>
</tr>
<tr>
<td></td>
<td>22 Commitment from purchase order</td>
</tr>
<tr>
<td></td>
<td>23 Commitment from reservation</td>
</tr>
<tr>
<td></td>
<td>24 Manual commitment</td>
</tr>
<tr>
<td></td>
<td>26 Commitment from fixed price agreement</td>
</tr>
</tbody>
</table>

   Until Release 3.1, the line item report for actual costs defaulted all value types. In Release 4.0, the defaults were changed according to the table above.

2. The following ABAP List Viewer functions are available in the value type list:
   - Select detail (see: Select Detail [Ext.])
   - Search by (see: Searching for Terms [Ext.])
   - Mark all and Delete all markings (see: Marking Rows and Deleting Markings [Ext.])
   - Sort in ascending order and Sort in descending order (see: Sorting List in Ascending or Descending Order [Ext.])
   - Set filter (see: Setting and Deleting Filter [Ext.])
   - Define current display variants (see: Defining Current Display Variants [Ext.])

3. In the Select Value Types dialog box, select the desired value types.

4. Choose Confirm to leave the dialog box.
Specifying Additional Selection Criteria

Prerequisites

You can only use the additional selection criteria for online execution of the line item report, not for execution in the background.

The additional selection criteria provides you with more fields to enhance your selection possibilities.

Procedure

1. Choose Further selection criteria or Extras → Further selection criteria
2. Select the criteria by which you want to further limit your selection in the Field selection dialog box.
3. Choose Confirm to leave the dialog box.
4. Enter the values for the selection criteria in the subsequent screen Further selection criteria.
5. Save your values and return to the selection screen.
Displaying Groups

If you have entered a group of report objects in the selection screen, choose Display group or Goto → Display group to display the structure of the given group.
The Line Item Report Display

Use

The line item [Ext.] report display lists all the data records you selected in the initial screen. You can change the layout of this list using the following functions:

Features

You can analyze your dataset in the line item report using the following ABAP List Viewer functions (see: ABAP List Viewer [Ext.]):

Navigation
Navigating in Lists [Ext.]

Detail
Selecting Details [Ext.]

Sorting
Sorting Ascending or Descending Lists [Ext.]

Filter
Setting and Deleting Filters [Ext.]

Totaling
Totaling Values and Deleting Totals [Ext.]
Building Subtotals [Ext.]
Displaying Totals Rows Only and Breaking Down Totals [Ext.]
Displaying and Hiding Non-Totals Rows for Subtotals [Ext.]
Selecting Totals Levels [Ext.]
Determining Drilldown for Totals Levels [Ext.]

Status Display
Displaying List Statuses [Ext.]

Columns
Optimizing Column Widths [Ext.]
Fixing to Columns and Revoking Fixings [Ext.]

Layouts [Ext.]
Selecting Layouts [Ext.]
Changing Layouts [Ext.]
Saving Layouts [Ext.]
Managing Layouts [Ext.]

Basic List
The Line Item Report Display

Displaying Basic Lists [Ext.]

Search

Searching for Terms [Ext.]

Print

Printing Lists [Ext.]

Save

Sending Lists as Documents [Ext.]

Saving Lists in the Report Tree

Saving Lists as Files [Ext.]

The following additional functions are available:

Source documents and accounting documents

Displaying Source Documents and Accounting Documents [Page 1021]

Master Data Records

Displaying Master Records [Page 1023]

Selection criteria and selection logs

Displaying Selection Criteria and Selection Logs [Page 1024]

Header rows

Maintaining Header Rows [Page 1025]
Displaying Source Documents and Accounting Documents

Prerequisites

In the line item [Ext.] report or in the document display you see the Controlling (CO) documents created by internal repostings, allocations, and postings.

You can display the source document, as well as other documents generated from the source document, from:

- An actual line item report
- A commitment line item report
- The document display

Displaying Source Documents

To display the original document for an actual line item, a commitment line item, or a document itself proceed as follows:

1. Place your cursor on the line item or document in question
2. Choose Source document or Environment → Source document.

If a line item or document was generated by a posting process in the Financial Accounting component (FI), you will see the original FI document. You can also see additional information of cost controlling significance, such as posting date, document type [Ext.], posting key [Ext.] and author, and so on, providing the document was not deleted in FI and you have display authorization for that document.

If an actual-line item, commitment line item or the document was generated by a posting process in the Controlling component (CO), the system displays the original CO document [Ext.].

The Controlling and Financial Accounting components create separate documents. When primary postings from FI are transferred to CO, corresponding documents with unique document numbers are generated in CO. Additional CO documents are generated through internal transactions, such as internal activity allocation, assessment, and accrual calculations.

Displaying Accounting Documents

To display other documents arising from the original document for an actual line item, a commitment line item, or a document itself proceed as follows:

1. Position your cursor on the line item or document
2. Choose Environment → Accounting documents.

If the Profit Center Accounting (EC-PCA) and Profitability Analysis (CO-PA) components are active and relevant documents exist, you can display these documents as well.
Displaying Source Documents and Accounting Documents
Displaying the Master Record from the Line Item Report

To branch from the line item report or the document display into the master record of an object (such as, a cost center [Ext.], cost element [Ext.] or an activity type [Ext.]) position your cursor on the appropriate object in the list and choose Master record or Environment → Display master record.
Displaying Selection Criteria and Selection Logs

Displaying Selection Criteria
To display the report selection criteria from the line item report or the report display, choose Extras → Selection → Criteria.

Displaying Selection Logs
To display the report selection log from the line item report or the report display, choose Extras → Selection → Log.

The selection log lists the number of records found on the database and the runtime for each individual object.

Result
You can change the selection criteria and selection log display with the following ABAP list viewer functions:

- First/Last column and Left/right column (see Navigating Within Lists [Ext.])
- Sort in ascending order/descending order (see Sorting Lists in Ascending or Descending Order [Ext.])
- Current display variant (see Defining Current Display Variants [Ext.])
- Search by (see: Searching for Terms [Ext.])
- Printing (see: Printing Lists [Ext.])
Maintaining Header Rows

Prerequisites

In the line item report and the document display you can change existing header rows and insert new ones.

You define a header row for line item reports and document displays by display variant. The header rows are imported, transported, and copied together with the display variant for line item reports and document displays.

Procedure

1. To maintain header rows, choose Settings → Current display variant → Current header rows.

2. Change the header rows based on your requirements.
   - To insert new rows, select the area beneath the last row or the row beneath the insertion point for the new row and choose Insert row.
   - To delete entries, select the row and choose Cut.

You can enter texts or select variables. The R/3 System fills the variables with the current values when you call up the line item report.

   - To insert general text variables, choose General variables.

   General variables include current page number, display variant name, local time, filter characteristics, and text constants displayed in the relevant logon language.

   - To insert text variables for characteristics, choose Characteristics. The characteristics appear based on the type of line item report or document display.

     A characteristic variable represents data for the characteristics used in the report definition. Characteristics include posting date, fiscal year, and controlling area. You must always enter characteristics with a text type and a value. Text type selections include the name, value, short text, or long text for a given selection parameter. Values include individual values, value/group, value "from", and value "to" for a given characteristic.

     - To define a corresponding frame, choose Frame.

3. Save your header row changes.

Maintaining Header Rows
Executing Line Item Reports in Background

1. To execute a line item [Ext.] report, go to the menu in the relevant component of the SAP R/3 System (Cost Center Accounting, Overhead Cost Orders and Activity-Based Accounting) and choose

   *Information system → Report selection*, then *Line Items → Actual or Commitment.*

   ![Image]

   You can display line item reports by controlling area [Ext.]. To change the controlling area when necessary, choose *Extras → Set controlling area.*

2. In the initial screen, enter the criteria according to which the line item report selects data.
   - Enter an object (cost center [Ext.], order [Ext.], business process [Ext.]), an object interval or an object group (cost center group [Ext.], business process group, order group [Ext.]).
   - If you wish to restrict the selection to particular cost elements [Ext.] enter a cost element, a cost element interval or a cost element group [Ext.].
   - For actual and plan line item reports, enter under *Posting date* the date or timeframe for which you want to select data.
     For commitment line items reports, enter under *Expected debiting date* the date or timeframe for which you want to select data. To limit the selection to open line items, choose *Open items only.*
   - Enter the version for the plan line item report.

3. In order to determine the data presentation in the line item report, choose a standard display variant under *Display variant* or define your own variant (see: Selecting Display Variants [Ext.]).

   ![Image]

   You can use the display variant to determine the page breaks used when printing the report. The sorting and subtotals use the *GW* field for this purpose.

4. The following functions are also available on the initial screen:
   - You can delete entries for individual selection rows or all entries for the selection (see: *Deleting Selections [Page 1013]*)
   - You can narrow down the selection further still, by value type and selection criteria (see: *Select Value Type [Page 1016], Set Actual Version [Page 1015]*)
   - You can save your entries in a variant in the initial screen and get them again when you next call up the initial screen (see: *Processing Variants [Page 1014]*)
   - If you entered an object group in the initial screen, you can display it (see: *Display Group [Page 1018]*)
   - You can read line items from the archive (see: *Reading Standard Reports From the Archive [Page 1011]*) To do so, choose *Extras → Data source.*

5. Choose *Program → Execute in background.*
 Executing Line Item Reports in Background

6. In the dialog box, enter the print parameters (printer, number of copies) for your background job, and choose Print.

7. You can check the status of your background jobs in the job overview.
   – Choose System → Own Jobs → Job overview.
   – Choose Execute.
   – After some time, choose Update again.
Document Display

Use

Document display enables you to display the documents of CO actual cost postings and plan postings. You can only display documents for plan postings if plan line items are updated. To do this, you need to activate the *Integrated planning* indicator for each fiscal year in the default settings in the Implementation Guide (IMG) for General Controlling → Maintain Versions [Ext.].

The system always displays a complete document, regardless of which Controlling objects (cost centers [Ext.] for example) are affected.

For cost allocation, this means that you can also see the credit posting on the partner object. In the line item report you see which partner object is involved, but you do not see the posted values unless you have also selected the partner object.

For actual primary postings you can branch into the original documents in Financial Accounting. You can also view purely CO documents arising from repostings of costs and revenues, as well as activity allocation documents.

For more information on the functions in the basic list for displaying documents, see Basic List for Document Display [Page 1032].

For incorrect line items, you can directly trigger an adjustment posting from the report of the document display by choosing Extras → Correction request (see Request for Adjustment Postings in the Intranet [Ext.]).
Executing Document Display Online

1. To call up the document display for plan and actual postings in the Cost Center Accounting or Activity-Based Costing initial screen, choose Information System → Report selection, then Line Items → Controlling Documents, Actual Costs.

   You can display CO documents by controlling area [Ext.]. To change the controlling area when necessary, choose Extras → Set controlling area.

2. Enter the document number in the initial screen for document display, or choose Possible entries to find a number.

   If you use the entry help, you can search for a document number in the Document Number dialog box according to the following criteria:
   - By document date
   - By posting date
   - By posting periods in fiscal year
   - By original document number

   If you know the reference company code, you can enter this as an additional search aid.

3. In order to determine the data presentation in the document display, choose a standard display variant under Display variant or define your own variant (see: Selecting Display Variants [Ext.]).

4. If you require fast performance when calling up document displays, choose Further settings and activate the Variant fields only indicator in the dialog box. This means that you can make only limited changes to the selected display variant in the document display. The number of fields offered for selection in display variant definition is thereby reduced.

   If you require the full range of variant definition, leave the Variant fields only indicator deactivated.

5. You can set the number of selected entries to a maximum limit. To do so, choose Further settings and enter under Maximum number of hits the maximum number of rows to be read from the database. In this way, you can greatly reduce the waiting times for processing.

6. The following functions are also available on the initial screen:
   - Selection options offers you more options for entering objects and object intervals (see: Determining Selection Options [Page 399]).
   - You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
   - You can limit the selection further by value types, actual versions, and other selection criteria (see: Selecting Value Types [Page 1016], Setting Actual Versions [Page 1015], Specifying Additional Selection Criteria [Page 1017]).
   - You can save your entries in a variant in the initial screen and get them again when you next call up the initial screen (see: Maintaining Variants [Page 1014]).
   - You can read line items from the archive (see: Reading Standard Reports From Archives [Page 911]). To do so, choose Extras → Data source.
7. To display the document display online, choose *Execute* or *Execute program*.

To display the document display online and print it immediately, choose *Program → Execute and print*. If you execute the report, you can also print it later from the display screen.

For more information on the functions in the basic list for displaying documents, see *Basic List for Document Display [Page 1032]*.
Basic List for Document Display

Use
The basic list contains all the documents that meet your selection criteria.
The basic list is a sequential list. You can format the data for the document display using display variants.

If there are any incorrect line items, you can trigger an adjustment posting directly from the report by choosing Extras → Correction request (see Requesting an Adjustment Posting in the Intranet [Ext.]).

Features
You can analyze your dataset in the basic list for document display using the following ABAP List Viewer functions (see: ABAP List Viewer [Ext.]):

Navigation
Navigating in Lists [Ext.]
Detail
Choosing Details [Ext.]
Sorting
Sorting Ascending or Descending Lists [Ext.]
Filter
Setting and Deleting Filters [Ext.]
Totaling
Displaying and Deleting Sums [Ext.]
Creating Subtotals [Ext.]
Displaying Totals Rows Only and Breaking Down Totals [Ext.]
Displaying and Collapsing Non-Totals Rows for Subtotals [Ext.]
Choosing Totals Levels [Ext.]
Determining Drilldown for Totals Levels [Ext.]
Status Display
Displaying List Statuses [Ext.]
Columns
Optimizing Column Widths [Ext.]
Freezing to Columns and Unfreezing Columns [Ext.]
Layouts [Ext.]
Choosing Details [Ext.]
Changing Layouts [Ext.]
Saving Layouts [Ext.]
Layout Management [Ext.]
Basic List
Displaying Basic Lists [Ext.]

Search
Searching for Terms [Ext.]

Print
Printing Lists [Ext.]

Save
Sending Lists as Documents [Ext.]
Transferring a List to a Local File [Ext.]

The following additional functions are available:

Source documents and accounting documents
Displaying Source Documents and Accounting Documents [Page 1021]

Master data records
Displaying Master Records [Page 1023]

Selection criteria and selection logs
Displaying Selection Criteria and Selection Logs [Page 1024]

Header rows
Maintaining Header Rows [Page 1025]
Executing Document Display in the Background

1. To call up the document display for plan and actual postings, choose Information System → Report selection, then Line Items → Controlling Documents, Actual Costs in the Cost Center Accounting initial screen.

   You can display CO documents by controlling area [Ext.]. To change the controlling area when necessary, choose Extras → Set controlling area.

2. Enter the document number in the initial screen for document display, or choose Possible entries to find a number.

   If you use the entry help, you can search for a document number in the Document Number dialog box according to the following criteria:
   - By document date
   - By posting date
   - By posting periods in fiscal year
   - By original document number

   If you know the reference company code, you can enter this as an additional search aid.

3. In order to determine the data presentation in the document display, choose a standard display variant under Display variant or define your own variant (see: Choosing Display Variants [Ext.]).

4. If you require fast performance when calling up document displays, choose Further settings and activate the Variant fields only indicator in the dialog box. This means that you can make only limited changes to the selected display variant in the document display. The number of fields offered for selection in display variant definition is thereby reduced.

   If you require the full range of variant definition, leave the Variant fields only indicator deactivated.

5. You can set the number of selected entries to a maximum limit. To do so, choose Further settings and enter under Maximum number of hits the maximum number of rows to be read from the database. In this way, you can greatly reduce the waiting times for processing.

6. The following functions are also available on the initial screen:
   - Selection options offers you more options for entering objects and object intervals (see: Determining Selection Options [Page 999]).
     You can delete entries for individual selection rows or all entries for the selection (see: Deleting Selections [Page 1013]).
   - You can limit the selection further by value types, actual versions, and other selection criteria (see: Selecting Value Types [Page 1016], Setting Actual Versions [Page 1015]).
   - You can save your entries in a variant in the initial screen and get them again when you next call up the initial screen (see: Maintaining Variants [Page 1014]).
Executing Document Display in the Background

7. Choose *Program* → *Execute in background*.

8. In the dialog box, enter the print parameters (printer, number of copies) for your background job, and choose *Print*.

9. You can check the status of your background jobs in the job overview.
   - Choose *System* → *Own Jobs* → *Job overview*.
   - Choose *Execute*.
   - After some time, choose *Update* again.

– You can read line items from the archive (see: Reading Standard Reports From Archives [Page 311]). To do so, choose *Extras* → *Data source*. 
Master Data Indexes

Use

The information system for Controlling provides you with master data indexes for business processes [Ext.], cost objects [Ext.], cost centers [Ext.], cost elements [Ext.], activity types [Ext.], and internal orders [Ext.], as well as for statistical key figures [Ext.]. This enables you to check at any time, which master data has been maintained within the system. From the master data index, you can branch to the master data records of the displayed objects. Therefore, from the information system you have access to all information relating to the Controlling (CO) master data.

See also: Calling Up the Master Data Index [Page 1037]

If cost center master data is faulty or missing, you can request a master data change from the master data index by choosing Extras -> Change request for cost centers (see Requesting a Change to Master Data in the Intranet/Internet [Page 53]).
Calling Up Master Data Indexes

You access the reports for the master data indexes in the relevant Controlling component under Information system → Reports for Cost Center Accounting or Cost Element Accounting → Master Data Indexes.

Select the required master data report.

The following master data reports are available:

- Cost centers [Ext.]
- Cost Elements [Ext.]
- Activity Types [Ext.]
- Statistical Key Figures [Ext.]
- Internal Orders [Ext.]
- Business processes [Ext.]

On the initial screen, select the data that you want to display in the report.

In all master data reports you can select by:

- Individual value
- Range of values
- Group
- All values
- Selection variant (see below)

Under Parameter, enter the time period for which you want to display the master data.

Having entered the selection criteria, you access the master data report by choosing Execute.

The system displays a list of the selected master data.

Functions of master data list

The following functions are available in the list:

Master data records

Select a row, then choose Goto -> Master data to display the corresponding master data.

Create group

With the Create group function, you can create a new master data group. You select the master data that is to be combined in a group and assign a name to the group.

You can select the rows as desired (see also Selecting rows [Ext.]). If you do not select a row and choose Create group, a group is created for all master data displayed.

For more information on the functions in the master data indexes, see ABAP List Viewer (ALV): Grid Control [Ext.].

Selection variants

To create new selection variants, choose (Create selection variant).
**Calling Up Master Data Indexes**

In the list of fields, enter the criteria to be used for selecting master data.

Save your entries.

Enter a variant name and a description for your variant.

Save your entries.

To change an existing selection variant, choose (Change selection variant).

To display existing selection variants, choose (Display selection variant).
Report Definition

Use
The CO information system has the task of formatting the postings created in the application component according to various criteria. However, it is not possible to cover all user requirements through the information system. Minor adjustments to the reports are often required or new reports have to be created.

Features

Report Painter
The central tool for defining reports within the information system is the Report Painter [Ext.]. With Report Painter you can define reports quickly and easily across rows and columns. During the definition process, the system displays the report as it will appear when it is displayed on the screen.

For minor modifications to the standard report delivered by SAP you can use this as a model. The R/3 System also provides a variety of row and column models as modules for your own report definition. These models enable you to create reports simply and flexibly.

You do not need to create sets [Ext.] when working with Report Painter. You can enter characteristic values directly. Reports can be divided into sections and column blocks during definition.

To access the Report Painter menu from Cost Center Accounting, choose Information system → Tools → Report Painter.

For more information about Report Painter, see the R/3 Library, under FI Financial Accounting → FI Special Purpose Ledger → Report Writer Reports. (see: Report Painter Reports [Page 1052]).

Report Writer
If you want to define a report that differs from the standard, you can use the Report Writer [Ext.] report definition.

Report Writer lets you define reports that are structures on the basis of sets. A set is an arranged quantity of similar elements, such as cost centers, cost elements and posting periods. The modules available for use in the reports are summarized by the R/3 System in a report table. This allows you to use the sets in any reports of a report table.

Working with Report Writer involves a longer learning process than Report Painter. Since Report Painter covers the majority of the functions of Report Writer, but is easier to use, you should generate as many of your reports as possible through Report Painter.

To access the Report Writer menu from Cost Center Accounting, choose Information system → Tools → Report Painter → Report Writer.

For more information about Report Painter, see the R/3 Library, under FI Financial Accounting → FI Special Purpose Ledger → Report Writer Reports. (see: Report Writer Reports [Ext.]).
Importing Standard Reports

Use

To call up a report tree containing all the reports for a given component, choose *Information system* in the relevant Controlling component.

In the Cost Center Accounting menu, choose *Information system* → *Reports for cost center accounting* to call up the Standard Report Tree for Cost Center Accounting. You can use these reports without making any adjustments.

For the various Controlling master data, SAP provides a variety of reports, which can display report data in the actual, plan, or target for different time periods. The standard report tree gives you an overview of all standard reports delivered by SAP. For information about the most commonly used reports, see *Important Standard Reports* [Page 976].

Standard reports are delivered with client 000. They must be transported to your target client before you can use them.

Activities

To import standard reports, call up the Implementation Guide (IMG) for the relevant CO component and choose *Information System* → *Standard Report* → *Import Standard Reports* [Ext.].

The following importing options exist:

- **Import some reports**
  
  The system displays a list of all report groups. Select the report groups necessary for your reporting needs.

- **Import all reports**
  
  If you want to import all reports, you should create a background job at a time of low system usage.

In the *Processing mode* dialog box, you specify whether you want to import the reports online or in the background.

⚠️

It is best not to change the standard reports at the target client level after transport. Instead, you can use these reports as models for customized reports or save a copy of these reports under another name.

Any changes made to the standard reports are overwritten the next time the report is transported to your client.

In the event of a new release or upgrade, you must repeat the transport of standard reports from client 000.
Standard Layouts

Use

Use the report's layout function to define the appearance and the control parameters for the report output. This includes, for example, page length or report width. In order to avoid maintaining parameters for each report, the parameters are incorporated into the standard layouts and assigned to the reports. If needed, these values can be overwritten for a given report.

The following standard layouts are provided in the Cost center Accounting information system. They vary from one another in the number of rows per logical page.

1-BTC1 through 1-BTC7 are ideal for displaying reports on large PC monitors or for printing.

1-ONL1 through 1-ONL4 are ideal for displaying reports on small PC monitors.


For more information on layout parameters, see the SAP Library under Financials → FI Financial Accounting → FI Special Purpose Ledger → Report Writer → Standard Layout [Ext.].
Libraries

Use

As a transfer structure to Report Painter [Ext.] or Report Writer [Ext.] you use a reporting table, which is defaulted by SAP and cannot be maintained. The reporting table is a logical view of different database tables and includes all characteristics, basic key figures, and (predefined) key figures (= these were predefined columns).

In Cost Center Accounting, reporting table CCSS is used as the transfer structure.

Reporting table RWCOOM is also available for special totals record reports in overhead controlling (see also: Defining Reports for Overhead Cost Controlling [Page 1115]).

Features

In a library, you collect the characteristics, basic key figures, and predefined columns from the report table, which you need for your Report Painter or Report Writer reports. The table name is stored in the header of each library.

Characteristics are non-numerical fields. They represent criteria with which you can select data records. Examples of characteristics are the controlling area and fiscal year.

Basic key figures are numeric fields, which can be evaluated in a report. Examples include overall costs and activity quantities.

Key figures consist of a basic key figure and one or more characteristics. They are used for the fast definition of frequently-used columns. Examples include total actual costs for the current fiscal year or plan fixed costs for the previous fiscal year.

A report can only be generated using characteristics, basic key figures, and key figures from the library assigned to the report.

The following graphic illustrates how libraries work in the SAP System.
In library maintenance, you can assign a newly defined library to a table. You also define the allowed characteristics, basic key figures and key figures. The SAP System provides an overview of each of the three categories in which you can select the objects allowed for a given library.

By entering the item in the Item column, you can determine:

- which order characteristics, basic key figures and key figures are displayed in the selection lists of the report painter.

  This allows you to place any entries commonly used in reports at the beginning of the selection list.

- In which order report parameters (Values selection) and the report objects (Sets selection) (for example, cost centers, cost elements) are displayed on the selection screen in report painter reports.

If you select objects without positioning or with position “0”, the system does not offered the objects with the report definition using Report Painter. However, you can use these characteristics in Report Writer reports.

The standard reports delivered with Cost Center Accounting are summarized in the following libraries.

All reports for cost accounting methods based exclusively on the full costs [Ext.] method are located in the 1VK library.

For methods that also take marginal costs [Ext.] into account, there are special reports located in the 1GK library in addition to the reports found in the 1VK library.
Libraries

Use the 1AB library for variance [Ext.] analyses.
For summarization [Ext.] reports, use the 1RU library.

Standard libraries 1C1 and 101 have not been supported since Release 2.1. The standard reports for these libraries have been deleted. The SAP System still includes libraries 1C1 and 101 so that user-defined reports based on these libraries can continue to be used.

See also:
Important Basic Key Figures: [Page 1118]
Characteristics [Page 1119]

Activities

To create, display or maintain a library, call up the relevant Controlling (CO) component and choose:


Choose Utilities → Catalog to display an overview of all libraries for a table.

Choose Extras → Use to generate a list of the reports assigned to the selected library.

Choose Goto Header, Characteristics, Basic key figures or Key figures to edit these library functions.

In maintenance or in the display of basic key figures or characteristics, choose Documentation to call up description of previously selected basic key figures and characteristics.

For further information, see the SAP Library AC - Financials → FI - Financial Accounting → FI - Special Purpose Ledger → Report Writer → Libraries [Ext].
Standard Naming Procedure for Information System Objects

Generally speaking, information system objects are assigned a name beginning with a number. The SAP R/3 System reserves the following numbers for the individual CO application components.

### Standard Naming Procedure

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>For SAP internal use only</td>
</tr>
<tr>
<td>1</td>
<td>Cost Center Accounting</td>
</tr>
<tr>
<td>2</td>
<td>LIS</td>
</tr>
<tr>
<td>3</td>
<td>LIS</td>
</tr>
<tr>
<td>4</td>
<td>FI-LC</td>
</tr>
<tr>
<td>5</td>
<td>Reconciliation Ledger</td>
</tr>
<tr>
<td>6</td>
<td>Overhead Orders and Project Management</td>
</tr>
<tr>
<td>7</td>
<td>Product Cost Controlling</td>
</tr>
<tr>
<td>8</td>
<td>Profit Center Accounting</td>
</tr>
<tr>
<td>9</td>
<td>Activity-Based Costing</td>
</tr>
</tbody>
</table>

You can establish your own naming conventions for object names that do not begin with a numeral.
Editing Reports

Creating or Copying a Report

1. To create a report with Report Painter or Report Writer, go to the relevant CO application component and choose:
   

2. You should observe Sap’s standard naming conventions when creating new objects (see: Standard Naming Procedure for Information System Objects [Page 1047]). Use a non-numerical entry as the first character of the object name.

3. To generate a report by changing a standard report, enter a standard report as a model. You can also produce a copy of the standard report with Report Painter as follows:
   
   Choose Report → Display/Change.

   On the initial screen, choose Group → Copy.

   In the Copy dialog box, enter the library, the name of the standard report and the copy. You can assign the new report to the same library or a different library. The copy can then be modified to suit your requirements.

   Then modify the copy to meet your requirements.

Creating Report Groups

Assign your report to a report group and generate the report group (see: Report Groups [Page 1050]). Only then can you execute the report.

If you attempt to start a report without having generated a report group first, a dialog box appears to ask whether you would like to insert the report in a report group. The given report group is created as new, if required, and then generated automatically.

Transporting Reports

1. If you have implemented a SAP R/3 System with more than one client [Ext.], you should transport the reports in all relevant clients. To do so, choose:

   Information system → Tools → Report Painter → Utilities → Transport → Reports/Report Groups → Copy from client

2. Enter the new report groups that you wish to copy from a given client to your target client.
**Report Groups**

**Use**

Report groups incorporate all the reports within a library [Ext.] that access similar data but format these data differently. The report group lists the databases selected for all reports within the report groups, thus avoiding multiple selections.

All reports within a report group are executed at the same time, thus giving you the opportunity to jump between individual reports within the report display screen.

The report group name consists of four characters. Standard report group names start with the number reserved for that particular application component area (see: Standard Naming Procedure for Information System Objects [Page 1047]). Generally, the report group name is identical to the first four characters of the assigned reports.

**Actions**

To display, create, or maintain a report group, access the Cost Center Menu and choose:

*Information system* → *Tools* → *Report Painter* → *Report Writer* → *Report group* → *Display/Change/Create/Delete*

- Choose *Utilities* → *Directory* to display an overview of all existing report groups.
- You can generate a list of reports assigned to the selected report group by choosing *Goto* → *Reports*.

Before you can execute standard reports from the application component menu, you must import the reports or report groups to your client and generate the reports there. For more information on importing report groups, see Importing Standard Reports [Page 1041].

The SAP R/3 System lets you generate report groups in the following ways.

**Executing a report group.**

- Choose *Report Painter* → *Report Writer* → *Report group* → *Execute*.
- In the initial screen enter a report group and choose *Execute*.

  If the report group has not yet been generated or has been changed since it was last generated, the system displays a dialog box to ask whether you want to generate the report group as new.

  The system does not delete extracts that you saved for a report (defined using the report writer or report painter) if you regenerate the report.

**Generating Some of the Reports**

- In the Implementation Guide (IMG) for the relevant Controlling component, choose *Information System* → *Standard Reports* → Generate Standard Reports [Ext.].
- In the *Select Processing Mode* dialog box, choose *Online*. 
The system displays a selection list of all standard report groups delivered by SAP.

- Select the groups you wish to use and generate them.

**Generate all Reports**

If you want to generate all report groups for your client [Ext.] (for instance, following an SAP release change or as a client copy), then it is recommended for performance reasons that you generate these report groups simultaneously in the background. To do this, proceed as described previously. In the Select Processing Mode dialog box, choose Background.

For more information on report groups, see the R/3 library under AC - Financials → FI - Financial Accounting → FI - Special Purpose Ledger → Report Groups (see: Report Groups [Ext.]).
Report Painter

Purpose
You use the Report Painter to create reports from data in the Special Purpose Ledger (FI-SL) application component and other R/3 application components to meet your specific reporting requirements.

Many reporting requirements can be met using the standard reports provided by various R/3 application components. However, if your reporting requirements are not fulfilled by SAP’s standard reports, you can use the Report Painter to quickly and easily define your own reports.

The Special Purpose Ledger (FI-SL) application component does not provide any standard Report Painter reports because you must first install your FI-SL system setup (database tables and so on) to meet your specific business requirements.

Advantages of the Report Painter include:
- Easy and flexible report definition
- Report definition without using sets
- Direct layout control

Integration
The Report Painter is similar to the Report Writer [Ext.], but is easier to use. Many of the Report Writer functions are available in the Report Painter, but you do not need to be familiar with Report Writer concepts (such as sets) to be able to use the Report Painter.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries, row/column models, and standard layouts) in your own specific reports. When you create a Report Painter report, you can use groups (sets), but you can also enter characteristic values directly.

Features
You define Report Painter reports using a graphical report structure, which forms the basis for the report definition. This graphical structure displays the report rows and columns as they will appear in the final report when the report data is output. When you execute a Report Painter report, the system automatically converts the Report Painter report into Report Writer format.


You can add multiple reports to a report group. You can switch back and forth between the reports in a report group.
If the system takes a long time to select the data for the report, SAP recommends that you store the selected data in an extract. Once data is stored in an extract, it can be output later without having to be selected again.

**Converting a Report Painter Report into a Report Writer Report**

Since the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report so that you can use the complete range of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a basis. The Report Painter report is copied and becomes available as a Report Writer report. The system generates the required sets automatically.

You cannot, however, edit the sets generated in this way using the set maintenance function. Nor can you use these sets in other reports or functions.

**Example**

You will find a detailed example for creating a Report Painter report under Create Actual/Plan Comparison Report [Ext].
Report Painter Report

Use

Using the graphical interface of the Report Painter [Page 1052], you can create planning layouts, drilldown reports, and Report Painter reports that meet your specific reporting requirements.

The Report Painter reports can be accessed either from the original databases or as an extract [Ext.] from an extract file.

If you call the reports from the original databases, the data records stored there must first be selected according to the specified criteria and then prepared. This selection can, depending on the volume of data, be very time-consuming.

For your reports, particularly when analyzing large amounts of data, such as area reports, create temporary or periodic extracts that can be accessed when the report is called. You can, for example, create area reports on a daily or weekly basis, which you can save as an extract under a name that you choose.

If, when you call the report, extracts already exist that match your selection criteria, the existing extracts are displayed for selection. When you exit the report generated by the database using your selections, a query appears asking you whether you want to save the report as an extract.

You can analyze the reports saved as extracts at any time without having an undue effect on system performance.

When you upgrade your system release (for example, from Release 4.0 to 4.6), the existing extracts are deleted. However, after a change in the correction release (for example, from Release 4.6A to 4.6B) the extracts saved are still available.

In Customizing for the Special Purpose Ledger, you can define user settings for individual users or for all users, so that only the most current extract for reports is displayed when a report is called. In addition, for each component you can define for individual users for all users, which selection parameters are to be used when calling reports. If, when calling the report, extracts exist that match the selection parameters stored and it has been defined that the most current extract is always automatically displayed, you no longer need to fill the selection screen before you call a report.

For performance reasons or if there is little system capacity, large reports should be generated in the background.

Features

In the Report Painter report definition you have to define the rows, columns and the general selection criteria that apply to the whole report.

For more information, see:

Defining Rows [Page 1068]
Defining Columns [Page 1065]

A detailed example for creating a Report Painter report: Creating an Actual/Plan Comparison Report with the Report Painter [Ext.]

Converting a Report Painter report to a Report Writer report

Although the Report Painter does not currently support all the functions of the Report Writer, you can convert a Report Painter report into a Report Writer report in order to use the complete spectrum of functions provided by the Report Writer. To do this, follow the procedure for creating a new Report Writer report using the Report Painter report as a reference. The Report Painter report is copied and now available as a Report Writer report. The system automatically generates the necessary sets, so that you do not have to enter the prefixes for the set names.

You can not, however, edit the sets generated in this way using the set maintenance function. You cannot use these sets in other reports or functions.
Creating a Report Painter Report

Procedure

From the relevant application, choose Tools → Report Painter → Report → Create.


Enter the name of the library the report is to use, and a name and description for the report. The report name can be a maximum of eight characters long.

If you want to create your report using an existing Report Painter report as a basis, enter the name of the report that you want to copy under Copy from. Both reports must use the same library.

Choose Create.

The next screen displays an empty report containing four rows and four columns (this is the basic structure for a report). You define your report on this screen.

Enter or change the description for the report by double-clicking the report description field.

A dialog box appears in which you can enter a short, medium, and long text for the report description.

Define the rows of your report (see Defining Rows [Page 1068]).

Rows contain a combination of characteristic values or formulas. Note the lead column at the first position of the rows. The Report Painter uses the lead column to access the rows. You can replace the description Lead column with a different term.

Define the columns of your report (see Defining Columns [Page 1065]).

Columns contain a combination of a basic key figure and optional restricting characteristic values. You can also use predefined key figures to present key figures and characteristics that make business sense. For example, a number of predefined key figures are delivered for the libraries in Overhead Cost Controlling that can be copied directly into the reports, where they can be modified as required.

Define general data selection criteria (see General Data Selection [Page 1079]).

The general data selection criteria restrict data selection for the report.

Choose Save and then Execute to create the report.

Assign the report to a report group [Ext.].

You have to display the report before you execute it, so that you can later change the report layout directly from the report list.
Once you have defined a report, you can display and print out a table of contents with Extras → Overview.

The overview contains the characteristics and characteristic values used in the individual sections, column blocks, and general data selection criteria. It also provides general information such as the user who last changed the report, the report name, and the standard layout assigned to the report, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.

For more information, see:

Defining Report Headers [Ext.]
Defining Report Text [Page 1087]
Defining Report Layouts [Ext.]
Defining Cells [Ext.]
Defining Global Cells [Ext.]
Defining Report Documentation [Ext.]
Process for Creating Report Painter Reports

Use

This section explains the main steps required to create a Report-Painter report.

The steps required to create a report painter report may differ somewhat from those described here. This depends on the complexity of your reports and whether you are using the standard objects from the information system.

Process Flow

Selecting and maintaining a library for your report.

As the transfer structure to Report Painter you use a report table, which is defaulted by SAP and can not be maintained. This table contains characteristics, key figures and predefined columns. In a library, you collect the characteristics, key figures, and predefined columns from the report table, which you need for your Report Painter reports.

When you define a Report Painter report, you assign it to a library. Reports assigned to one library can only use the characteristics, key figures, and predefined columns selected for that library.

When you create or maintain a library, the Position field determines the sequence in which the characteristics, key figures or (predefined) key figures appear in the Report Painter selection lists when you define a report. This allows you to position the objects that you use regularly in your reports at the beginning of the selection lists. If you do not make an entry in the Position field, you will not be able to use this object in Report Painter reports.

You can use either the standard SAP libraries for your reports or define your own. For more information, see Libraries [Page 1044].

Selecting or maintaining a standard layout for your report.

Standard layouts determine report layout features and the format of your report data.

If the SAP standard layouts do not meet your reporting requirements, you can create a new standard layout or change an existing one.

Defining row and column models.

A model is a one-dimensional, predefined reporting structure that you can insert in either the rows or columns of your report.

If you often use the same or similar row or column definitions in your reports, it is recommended that you create row or column models.

You must define the row and/or column models that you want to include in your report definition before you define the report.

You can also use the standard column models supplied by SAP.

For more information on defining row and column models, see Defining Models for Rows and Columns [Page 1061].
Defining the report.

Defining a Report Painter report involves the following steps.

Define the report columns

You define the report columns using the characteristics, key figures, and predefined columns selected for the library that the report uses. Alternatively, you can use a **column model** for column definition. Column models are predefined column structures which you insert into your entire column definition, instead of defining each individual column.

For more information on the definition of report columns, see [Creating Report Painter Reports](Page 1056).

Define the report rows.

You define the report rows using the characteristics selected for the library selected for the report.

Alternatively, you can use a **row model** for your row definition. Row models serve the same purpose as column models, but are used to define a report row.

For more information on the definition of report rows, see [Creating Report Painter Reports](Page 1056).

Edit and format the report rows and columns in line with your requirements. (For example, you can hide rows or columns, define the column width or define colors for your report rows).

Define general data selection criteria for the selection of your report data.

Selection criteria are the characteristics used to select data for the entire report. You cannot enter characteristics as data selection criteria if they are already being used in the report rows or columns.

For more information, see [General Data Selection Criteria](Page 1079).

Assigning the report to a report group.

Once you have defined a report, you must assign it to a report group. A report group can contain one or more reports from the same library. However, reports that share the same data will select data more quickly and improve processing time.


For more information on the definition, see [Report Groups](Page 1050).

Generating the report group.

During this step, the system generates the programs necessary for processing the reports.

When you generate a report group, Report Painter reports are converted to Report Writer format. However, you can only change or display Report Painter reports using the Report Painter tool.

For more information on generating reports, see [Report Groups](Page 1050).
Process for Creating Report Painter Reports

Executing the report group.

Report execution involves the selection and output of all the database records used in the report.

Once the system selects records according to the online selection criteria, it outputs the report data in the format defined for the report in question.

For more information on characteristics and basis key figures and their use, see Defining Reports for Overhead Cost Controlling [Page 1115].
Defining Row and Column Models

Purpose

If you often use the same or similar row or column definitions in your reports, it is recommended that you create row or column models.

A model is a one-dimensional, predefined reporting structure which you can insert in either the rows or columns of your report.

The following graphic shows how you can use row and column models in a report definition.

Process Flow

To be able to use models in a report, you need to carry out the following steps:

Creating a Model [Page 1062]
Applying a Model [Page 1063]
Transporting Models [Page 1064]
Creating a Model

To create a row or column model, choose Model → Create from the Report Painter [Ext.] menu.

In the initial screen, you enter whether you want to define a column or a row model. This is where you determine the functions available for editing purposes.

Before you create the model, you must first assign it to a library [Ext.]. The library contains the characteristics, key figures, and predefined columns which you can use in your model. All models and reports that use these models must be assigned to the same library.

Enter a name and short description for each model.

If you want to create a model using an existing model as a reference, enter the name of the existing model you wish to copy, or choose Model Copy, then enter the model and library.

You create row and column models with Report Painter in the same way as you create rows and columns in a report (see Creating Report Painter Reports [Page 1056]). In contrast to a report, however, models are only one-dimensional and do not contain any report texts.

When defining a column model, you can only use the functions available for defining columns. You cannot use the Explode, Expand or Collapse functions for column models.

You can define several column blocks within column models. However, you cannot define different report sections within models.

Once you have defined your model, you should check for any errors using Model → Check.

After you have defined your row and column models, you can go directly to the report definition with Environment → Create report.

Simplified definition of reports is made possible by a number of predefined row and column models.

Row model 1-LM-BEL-ENT identifies all cost elements separately according to debit and credit postings and calculates any over- or under-absorption in a totals row.

Column model 1-CM-QUARTAL displays the actual costs for all four quarters as well as for the complete fiscal year.
Inserting a Model

To insert row or column models in your report, put your cursor in the corresponding place and choose:

*Edit → Rows → Get row model*

*or Edit → Columns → Get column model*

When you insert the model, it overwrites all previously defined row and column definitions for that report section. For this reason, you should define additional report rows/columns only after you insert the model.

*Edit → Rows → Insert row model*

*or Edit → Columns → Insert column model*

The model is added to the defined report as the last row or column. No other row or column is overwritten.

You can only use a characteristic in the report rows, columns or in the *general selection* criteria.

Ensure that when you define a row, the characteristics used for it are not already being used in a column or in the *general selection*.

Ensure that when you define a column, the characteristics used for it are not already being used in a row or in the *general selection*.
Transporting Models

Choose Utilities → Transport → Models in the Report-Painter [Ext.] menu to export models to external files, import models from external files or to copy models from a source client.

The procedure is the same as for transporting Report-Writer [Ext.] objects.

For more information on transport functions, see the SAP Library under AC - Accounting → FI - Financials → Special Purpose Ledger → Report-Writer Utilities → Transporting Report-Writer-Objects [Ext.].
Defining Columns

Position the cursor on the column you want to define, and choose Edit ➔ Elements ➔ Insert element, or double-click the element.

In the subsequent dialog box, specify what type the element should be:

Key figure with characteristics

You combine a basic key figure with the characteristics you require.

Predefined key figure

An appropriate combination of a basic key figure and one or more characteristics is offered by the system. You can accept the predefined key figure or change it.

Formula

This option is only available if other elements are already defined.

You can use the formula builder to calculate the values of the column. You can use other columns or previously defined cells for the calculation.

For information on the terminology of the elements, see Terminology [Ext.].

Choose Confirm.

If you chose key figure with characteristics,

a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the column being defined.

In the upper area of the dialog box, select the basic key figure that you want to use in the report.

From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Move these to the left-hand side of the screen with the arrow. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.

On the left-hand side of the dialog box, enter the values for the selected characteristic(s):

You can enter individual values, intervals of values, or groups for the chosen characteristic(s).

If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).

If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).

If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Ext.].

If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already exist in the system. For more information, see Sets in Report Columns [Ext.].

If you chose predefined key figure,

a list of predefined key figures is displayed, from which you can choose the key figure you want to use.
Defining Columns

In the subsequent dialog box, you only need to enter the values for the characteristics. You can also change the key figure at this point, as described under key figure with characteristics.

If you chose formula,

a formula builder is displayed with which you can define a formula using other report columns and the previously defined cells. The column is calculated using the formula.

You can define formulas that refer to elements in different column blocks. However, you can only define formulas within one report section.

Choose and enter short, medium, and long texts for the column.

Choose Check and then Confirm.

To define additional columns, carry out steps 1 to 5 again.

You can copy report columns. Select a column and position the cursor where you want to insert the column. Choose Edit → Selected area → Copy. You can then change the copied column as desired.

You may find it useful to use sets to define entire blocks of columns. For more information, see the SAP Library under Creating Sets [Ext.] and Using Sets in Report Columns [Ext.].

Column Texts

If you want to change the text you entered for the report column, you can simply overtype the column text or position the cursor on the column element and choose Edit → Elements → Change text.

Under Formatting → Row/column texts you can specify which of the three text formats (short, medium, long) you want to use in the column header.

You can also use variables in your column headings. When you execute the report, the variables will be replaced with their default values if the column text type Key is selected in the report’s standard layout. To use a variable for the column text, enter the variable in the dialog box for the three column texts. First enter & and then the name of the variable.

Suppose your report uses the value variable &PERIOD for the period, and you want to display the current value for the period in a column heading. Enter <&PERIOD> in the column heading of the report. If the column text type Key is selected in your report’s standard layout, the variable is replaced with the period value (for example, 5) when you execute the report. The description is printed for all other column text types (for example, May).

Editing Columns

The options under Edit → Columns allow you to select a variety of functions for editing report columns.
The option Edit → Get column model or Insert column model inserts a predefined column structure into your report columns. For more information, see Defining Row and Column Models [Page 1061].

The Edit → Columns → Hide function hides the report row on which the cursor is positioned. You can process hidden columns in the same manner as the hidden rows.

**Using Formula Variables in Report Columns**

A formula variable represents a user-defined formula that establishes a value for the variable. Numerical value variables and formula variables can be used as operands in column formulas. Using formula variables in report columns enables you to create new types of reports.

For more information, see Formula Variables in Reports [Ext.].
Defining Rows

Rows in a report are defined in a similar way to columns. However, you cannot enter predefined key figures in rows. You define row elements using basic key figures in combination with the characteristics selected for the library that the report uses. You can also use formulas.

Procedure

Position the cursor on the row you want to define, and choose Edit → Elements → Insert element, or double-click the element. For information on the terminology of elements, see Terminology [Ext.].

Define the row.

If no other rows exist in the section, a dialog box appears on which you can select the combination of basic key figure and associated characteristics to be displayed in the row being defined.

In the upper area of the dialog box, select the basic key figure that you want to use in the report.

From the list of available characteristics on the right-hand side of the dialog box, choose the characteristics you want to use. Use the arrow to move these to the left-hand side of the screen. The characteristics displayed are those of the library assigned to your report. The order in which the characteristics appear in the selection list is determined by the Position field in the library definition.

On the left-hand side of the dialog box, enter the values for the selected characteristic(s):

You can enter individual values, intervals of values, or groups for the chosen characteristic(s).

If you want to define all possible values for the chosen characteristic(s), enter an asterisk (*).

If you want to specify an initial value for the chosen characteristic(s), enter a pound sign (#).

If you want to enter a variable instead of a characteristic value, select . Enter the name of the variable and choose Confirm. You can only enter variables that already exist in your system. For more information, see Variables [Ext.].

If you want to enter a characteristic value in the form of a set, select . Enter the name of the set and choose Confirm. You can only enter sets that already exist in the system. For more information, see Sets in Report Rows [Ext.].

For performance reasons, you should use sets whenever possible.

If rows have been defined in the section, you can also insert a formula. From the dialog box, choose Formula. A formula builder is displayed with which you can define a formula using other report rows and the previously defined cells. The row is calculated using the formula.

You can define formulas that refer to elements in different row blocks. However, you can only define formulas within one report section.

Choose and enter short, medium, and long texts for the row.
Choose Check and then Confirm.

To define additional rows, carry out steps 1 to 5 again.

You can copy report rows. Select a row and position the cursor where you want to insert it. Choose Edit → Selected area → Copy. You can then modify the copied row as desired.

You may find it useful to use sets to define entire blocks of rows. For more information, see the SAP Library under Creating Sets [Ext.] and Sets in Report Rows [Ext.].

**Editing Rows**

Under Edit → Rows there are a number of special functions for editing report rows. Get row model inserts a predefined row structure in your report rows. For more information, see Defining Row and Column Models [Page 1061]. Insert blank line inserts a blank line in the current row (where the cursor is positioned).

Edit → Rows → Hide hides the row on which the cursor is positioned. The hidden row retains its contents and can still be used in formulas. You can edit hidden rows with Hidden rows → Change. You can also delete and display the hidden rows (Delete and Show functions).

Edit → Rows → Explode expands the hierarchical levels of the group/value interval defined for the row characteristic. For more information, see Exploding Report Rows [Page 1074].
Defining Cells

Use

Cells enable you to use values that the report displays for particular row/column combinations as operands in formulas. A cell pinpoints a particular location or range within the column-row matrix of a report. In the Report Painter, you can work with rows, columns, and individual cells. If you want to work with cells, you must select the relevant cells.

Procedure

You edit cells in the same way you edit row and column elements.

Position the cursor on the cell and choose Edit → Elements → Change/display, or simply double-click the cell.

The cell is selected. All cells you select in this way can then be used in the formula builder in the entire report (all sections and horizontal pages) as operands for the definition of formulas.

If you don't enter a text for the selected cell, the system automatically assigns a description to it. This description is the lead column/column header.

To enter your own cell text, position the cursor on the cell and choose Edit → Element → Change text. You can then enter a short, medium, and long text for the cell.

If you use cells as operands in formulas, but do not want to display or print these cells in your report, you can hide the rows and columns used to create the cell by choosing Edit → Rows/Columns → Hide. If you have selected the affected cells, you can still use them in the formula builder.

If you want to select cells in exploded rows of a group (set), the selected cell always refers to the highest summation level in the group. If you want to select cells for a subgroup, you must define an additional report row for the subgroup, select the cell you want to use, and then hide the report row.
Defining Sections

Use

A section consists of one or more physical rows and columns forming a logical unit. In the vertical direction, a report consists of one or more sections. Each section is displayed on a new screen. You can define sections with key figures and characteristics, as well as sections with derived basic key figures.

In a section that contains calculated key figures, you can create an overview of the most important values used in your report. A section with calculated key figures is a new report section and is displayed on a new screen. You normally define a section with basic key figures at the end of your report.

Sections with Calculated Key Figures

To define a section with calculated key figures, first select the cells you want to use in the section. For information on selecting cells, see Defining Cells [Page 1070]. You can also enter your own text for these cells.

Choose Edit → Sections → New section. In the New Report Section dialog box, select Section with calculated key figures.

Position the cursor on the row or column and choose Edit → Elements → Define element or double-click on the row or column.

The section with calculated key figures is made up of a row/column structure in which you enter short, medium, and long texts.

Define the cells you want to use in the section at the point of intersection of the row/column combination. Position the cursor on the appropriate cell and choose Edit → Elements → Define element, or double-click on the cell.

You enter cell calculations for the section with key figures in the Formula Builder. All selected cells of the report are displayed in the Formula Builder as buttons. You can then define your key figure formula as required.

The Formula Builder enables you to use the selected cells in the section with calculated key figures. You can also use cells that were calculated using the selected cells.

Another feature is that you can reselect cells used in the section with calculated key figures to calculate values for other cells within the section (recursive cell definition).

If you don’t want to display or print the cells you use in your section with calculated key figures in the other sections of your report, you can hide the corresponding rows and columns by choosing Edit → Rows/Columns → Hide.

Sections with Characteristics and Key Figures

To define a new section in your report, choose Edit → Sections → New section.

In the following dialog box, select Section with characteristics and key fig.
Defining Sections

A new row and column structure appears for you to define your new report section. You define rows and columns as described under Defining Columns [Page 1065] and Defining Rows [Page 1068].

You can switch between the different sections by choosing Goto → Section → and then First section, Previous section, Next section, or Last section.

You can only perform calculations using columns within the same section. For calculations between sections that use columns, you must select cells. For more information, see Defining Cells [Page 1070].

Once you have defined a report, you can display and print out a table of contents of the report with Formatting → Section overview.

The overview contains the characteristics and characteristic values used in the individual sections, horizontal pages, and general data selection criteria. It also provides general information such as the user who last changed the report and the report name, as well as details on the report formats.

If you double-click an individual characteristic, you can see where this characteristic is used in the report definition.
Defining Horizontal Pages

Use

A horizontal page consists of one or more physical report columns that form a logical unit. Each horizontal page is defined and displayed on a new report page and on a separate screen. When you define a new horizontal page, the report row definitions remain the same.

Procedure

To define a new horizontal page, choose Edit → Horizontal page → New column block.

A row/column structure appears in which the rows are already defined. For information on defining columns, see Defining Columns [Page 1065].

The icons and move the display back and forth between the horizontal pages.

You can perform calculations involving more than one horizontal page. You can therefore define formulas that refer to columns in different horizontal pages.
Exploding Report Rows

Use

You use the *Explode* function to specify whether individual values only, a sum only, or individual values with totals and subtotals are to be displayed for the characteristics used in the report rows.

If you have defined more than one characteristic in a report row, you can define the order in which the characteristics are displayed in the report.

Procedure

To explode a report row, position the cursor on the report row and choose *Edit → Rows → Explode*.

The *Explode characteristics* dialog box lists the row characteristics for which you have entered an interval of values, a group, or a variable. You can use the *Explode* function for each of these characteristics.

In the standard system, the *No explode* indicator is set as the default. A row total only is displayed in the report for the characteristic.

If you select *Single values*, only individual values are displayed in the report for the characteristic. Sums are not displayed in the report.

It is advisable to select *Single values* for characteristics for which you do not usually calculate sums, such as statistical key figures or activity types.

If you select *Explode*, the report displays single values, subtotals, and a grand total. Subtotals are calculated based on the hierarchical structure of the characteristic.

You can specify the hierarchical sequence in which the characteristics are output in the report rows. The characteristic assigned number 1 appears at the highest level of the hierarchy. For each value defined for this characteristic, data is summarized for all of the characteristics below it in the hierarchy.

You entered the characteristics *cost center* and *account* in a report row for cost centers 100, 200, and 300 and accounts 4000010 and 4000020. If you assign number 1 to *cost center* and number 2 to *account*, the report breaks down cost centers by accounts. If you switch the order, the report breaks down accounts by cost centers.

You can use the function *Display sort order* to display the characteristics in the order you have defined.

Exploded report rows are displayed with one or more asterisks in the report definition, depending on the row summation level.

If you enter a group as the characteristic value for a report row, the hierarchical structure of this group is depicted in the report definition. If you set the *Explode* indicator for this row, all subtotals and the sum total are displayed for this group in the report definition.
Exploding Report Rows

together with the corresponding number of asterisks. The lowest level in the group (usually the individual values) are not displayed in the report definition.

Suppose you define a report row for the characteristic account and enter the group (the set) ACCOUNTS as the characteristic value. (The group ACCOUNTS is a single-dimension set containing income and expense accounts.) If you select Explode for the ACCOUNTS group, the report definition displays a totals row for all accounts, and subtotals rows for the income and expense accounts. The individual account values, however, are not displayed in the report definition.

If you enter a set variable as the characteristic value, the row structure is only determined when you output the report. The default set assigned to the set variable displays in the report definition. When you execute the report, you can overtype this default set on the selection screen if you want.

Suppose you define a report row for the characteristic account and enter the set variable ACCT as the group characteristic value. The default set of the variable only has one summation level. In the report definition, the exploded row is displayed with only one asterisk.
Formatting Rows and Columns

Column Formats

Assigning a Standard Layout and Format Groups

You define the format of your report columns using format groups. These format groups tell the Report Painter which format to use in each report column. You can define up to five format groups, allowing you to use five different column formats in your report.

A format group is used to determine the following layout parameters:

- Column width
- Right column margin
- Display unit
- Decimal places
- Scaling factor
- Reverse +/- sign

You define the layout parameters for the different format groups in the report layout assigned to the report. The report layout also contains information on the report page layout and text formats. For more information on standard layouts, see Standard Layouts and Creating a Standard Layout.

You can display the standard layout assigned to your report with Formatting → Report layout. In the dialog box displayed, you can make changes to the report layout. The function Use standard layout assigns the new layout to the report as the standard layout.

The Format group row in the report definition displays the format group currently assigned to each report column. Format group 0 is automatically set as the default for all columns. To change the format group assigned to a column, double-click the format group field and select the desired format group. The column is then formatted according to the layout parameters for the specified format group.

Changing the Default Settings of Format Groups

You can overwrite the default layout parameters for individual format groups in your report. These changes are only valid for the report that you are currently editing. To do so, position the cursor on the column to which the format group is assigned, and choose Formatting → Column.

You can overwrite the default parameters of the standard layout using the Column width, Numerical format, and Reverse sign functions. The numerical format controls how values are displayed in your report (scaling factor and number of decimal places).

If you specify one decimal place and a scaling factor of 1000 for the value 1000000, this value will be displayed as 1000.0 in the report.
The formatting functions under Formatting → Column change the format of all columns that use the same format group. If you want to change the format of a single column, you must assign a different format group to this column.

### Aligning Column Headings and Selecting the Text Length

You establish the alignment of the column headings for all report columns. To change the horizontal alignment of text (left-justified, centered, or right-justified), choose Formatting → All columns → Text alignment.

You can also specify which type of text you want to use in all column headings (short, medium, or long text). To do so, choose Formatting → Row/column texts and select the text type you want to display.

### Row Formats

#### Overscore/Underscore

You can use the Over-/Underscore functions to highlight individual report rows. For example, you can have the system display lines above and/or below totals rows. To do so, position the cursor on the row and choose Formatting → Row. In the subsequent dialog box, activate Underscore and/or Overscore.

#### Row Colors

You can add color highlighting to individual report rows. To do so, position the cursor on the row and choose Formatting → Row. In the following dialog box, select a color (for totals, subtotals, inserted rows, or for emphasis). The system assigns a color based on the selection you make here.

You can format more than one row at a time by selecting the rows and then formatting them, as desired. The rows remain selected once you have completed the format changes. You must remove the selections manually using the Deselect all function. Formatting commands that affect all rows or columns are independent of any selections you have made.

#### Text Type

You can specify which type of text you want to use in the report lead column (short, medium, or long text). To do so, choose Formatting → Row/column texts. In the dialog box, select the text type you want to display.

#### Expand to/Collapse to

You can only use the Expand to/Collapse functions for report rows that are exploded in the report definition and contain totals rows. You must therefore select a group as the characteristic value for the row and explode that row. The lowest level in a group hierarchy (usually the individual values) are not displayed in the report definition.

If you position the cursor on an exploded row in the report definition and choose Collapse to or Formatting → Collapse to, you can specify the summation level up to which you want to collapse exploded report rows.
Formatting Rows and Columns

By choosing Formatting → Expand to, you can specify the summation level up to which you want to expand exploded report rows.

The summation levels you define in the report definition are used when you output the report. You can, however, expand or collapse these rows again in the report output.

The Report Painter does not process exploded report rows as individual row elements. You cannot therefore use all functions on exploded rows, which can be used on other report rows.

For example, if you use the Delete function on an exploded row, the system deletes the entire row element and not just the exploded row.

If you use the Underscore/Overscore and Color settings functions on exploded report rows, any changes you make are valid for all rows at the same characteristic level.

For more information, see Layout [Ext.] and Section Layout [Ext.]
General Data Selection

Use

To define a report, you define the rows and column structure and the general selection criteria that apply to the report as a whole. The general selection criteria are the characteristics used to select data for your report. Your general data selection criteria can only contain those characteristics that are not already being used in the report rows and columns.

Features

To define the general data selection criteria for your report, choose Edit → General data selection.

⚠️

If you define data selection in a report with more than one account assignment object (such as cost centers and internal orders), you must make sure that all account assignment objects are completely defined in all sections.

In the orders section [Ext.], you must add the characteristic cost center, while in the cost centers section you must add the characteristic order. The value for the cost centers in the order section, and for orders in the cost centers section, is always a pound sign (#).

Definition of 1st section:

Cost center: &1KOSET
Order: #

Definition of 2nd section:

Cost center: #
Order: &6-AUFGR

In the dialog box Element definition: General data selection, select from among the available characteristics those characteristics you want to use in general data selection. To select the characteristics, choose 🔄.

Enter values for the selected characteristics under Selected characteristics. You can enter individual values, intervals of values, groups, or variables.

✅

The following characteristics must be defined in your report, either as data selection criteria, report rows, or report columns:

- Company
- Ledger
- Version
General Data Selection

Record type
Period

To improve processing time, you should specify all characteristics in general data selection that are not needed in the report rows or columns.

In the reports assigned to table CCSS, the controlling area characteristic must always be used in general data selection. The controlling area characteristic can only be used as a single value or variable.

The company code characteristic depends on the time-dependent characteristic cost center. If the cost center is not valid during the current time period, the system cannot determine a valid company code for the data records of the selected cost center, and therefore no data can be displayed. If the cost center was valid in a different company code in the previous year, the system assigns the values posted on the cost center to the company code that is valid for the master data date of the report.

Since the relevant date for time-dependent master data in the Report Painter and Report Writer reports is the master data date, you should set this date explicitly such that all cost centers used in the report are valid on that date. To do this, choose Output parameters → Master data date in the selection screen of the report.

If you enter specific values, intervals of values, or groups for a characteristic, your report is always executed using these values. The More indicator displays a list in which you can enter several intervals or individual values for the characteristic on which the cursor is positioned.

You define the characteristic Year as data selection criteria for your report and enter 2000 as the year. When the report is executed, the system only selects data records for the year 2000.

If you enter a variable [Ext.] for a characteristic, the system prompts you to enter a value for the variable on the Selection screen when you execute the report’s report group. The single value/set assigned to the variable appears as the default value on the selection screen. You can overwrite this default value if you want.

If you enter a variable as data selection criteria, the values you enter on the selection screen when executing the report’s report group are only valid for one report run. Each time you run the report, you can enter a different value for the variable.

To define a variable for a selection characteristic, turn on the Variable indicator in the relevant entry field in the column. Then choose Check to check the entry and refresh the screen. The input help function (F4) displays a list of available variables for the characteristic.

You create a set variable called CSTCTR for the characteristic Cost Center and enter a set name as the default value for the set variable. If you use this variable as data selection criteria in your report, the system asks you to enter a set name when
you select the report data records. You can use the default set name assigned to the variable or another set.

The input help function always displays all variables for the relevant characteristic. Variables are displayed even if they are already being used in rows or columns.

You create variables within set maintenance. For more information, see Creating Variables [Ext.]. Choose Confirm to conclude the definition of general data selection.

**Variation**

The variation [Page 1082] function allows you to create a separate report for each element in a group (set) that is used as general data selection criteria in your report.

When you execute a report for which variation has been defined, you can enter a variation range for report execution on the selection screen or specify the output of reports for single values.

For more information, see Executing a Report Group [Ext.]. Within the report, you can then output individual reports online for the groups or individual values in the variation range.

**Elimination of Internal Business Volume**

For each characteristic, you can use the Elimination of internal business indicator to eliminate or display internal business volume in the report. Internal business volume represents the allocations that take place within one characteristic group.

For more information, see Elimination of Internal Business Volume [Page 132] and Activating Elimination of Internal Business Volume [Page 1084].

If both the variation of the selection and the internal business volume elimination are activated, the internal business volume is eliminated dynamically. When you navigate between the reports for the elements of the group in the report output, the internal business volume is redetermined for each element and then eliminated in the report.
Variation

Use

Variation makes it possible to create an individual report for each element of a group, which you defined in the general data selection. When you call up the report, the variation makes the selection for the entire group. You can then navigate interactively during the report output within the hierarchical structure of the group to display a report for every element in the group.

You can decide whether individual characteristics in the general selection are to be displayed only with a totals report, only individual reports for the characteristic values, or both total reports and individual reports.

Variation is only possible in reports for which at least one general selection characteristic is a group or a variable for a group.

The advantage of variations is that you only need to carry out the selection once.

For example, you can create an individual report for each group node and end node in a cost center hierarchy [Ext.]

The cost center hierarchy is used here as an example for variation. However, you can carry out variation for any group for which you select a report.

Variation is useful especially for executing reports for an entire cost center group [Ext.] in a background run, so that you can move quickly between the various cost center [Ext.] reports.

In addition, you can use variation at period-end closing to create and print a complete report for the cost center group or the organization itself, without having to create reports one-by-one for each cost center.

Variation is possible only if you activate it in the report definition. The procedure is described in General Selections [Page 1079]. For activation in the Report Writer [Ext.] report, see the SAP Library under AC - Financials → FI - Financial Accounting → FI Special Purpose Ledger → Report Writer [Ext.].

If you enter an object group in the selection screen (such as cost center group), and you have activated a variation in the report definition, the SAP System automatically executes variation. If you do not want to use variation, change the setting under Variation.

If you decided to generate extracts [Ext.] before calling up the variation, the system generates an extract for each report in the variation (see Executing Report Painter Reports [Page 901]).

We recommend you execute variation for the entire organization or for large areas only in an off-peak period in a background job.
**Activities**

To set up a variation using general selections for a report, choose *Edit* → *General selections* → *Variation*.

If you decide on several characteristics, determine the sequence they should appear on selection screen using the characteristic name indicator.

In the dialog box *Variation/Eliminate Internal Business Volume*, the system displays the general selection characteristics that have an interval, group, or variable as characteristic value. You can define a variation for each of these characteristics.

The default setting is *Do not break down*. No variation is carried out for the characteristic. The system displays a report in which the intervals and groups of the characteristic are totaled.

If you choose *Individual value* for a characteristic, the system performs a variation for the characteristic down to individual values. The system displays a report for all the individual values of the interval or of the group.

If you choose *Expand*, the system displays a report for all nodes and individual values in the interval or group.

If you wish to select a particular variation area for report generation, or decide on the release of reports for individual values, choose the selection screen for report call-up.

In the report you can then display individual reports for the groups or individual values in the variation area. (See *Variation [Page 940]*).
Eliminating Internal Business Volume

Use

In the dialog box Variation/Eliminate Internal Business Volume, the system displays the general selection characteristics that have an interval, group, or variable as characteristic value. For each characteristic you can choose Eliminate internal business volume [Page 1132] to decide whether internal business volume is to be displayed in, or eliminated from, the report. Internal business volumes consist of all allocations that occur exclusively within a characteristic group.

When you activate the Internal business volume elimination indicator, the system only displays internal business volume for the given characteristic in the general selection.

If you leave the default value active (space), the system does not display any internal business volume for the given characteristic in the general selection.

If you decide on both variation and internal business volume elimination (internal business volume elimination = Space), the internal volume is eliminated dynamically. When you navigate between the group element reports in the report output, the system determines the internal business volume again for each element and eliminates it from the report.
Defining Report Headers

In the menu of the Report Painter [Page 1052], choose Edit → Report header.

The dialog box Report Painter: Maintain Report Header appears.

If you want authorization protection for the report, enter an authorization group.

Enter the name of the standard layout assigned to the report.

When you first create a report, the default standard layout is SAP. This standard layout [Ext.] is shipped with all SAP R/3 Systems. For more information, see Layout [Ext.].

To make default settings for exporting the report to an application or presentation server, choose Export parameters.

In the subsequent dialog box, enter the required data. You can see the default values you entered in the report output under Report → Export. You can change these default settings as required.

For more information on exporting reports, see Exporting Reports to an External File [Ext.].

To save the report header, choose Continue.
Report Text

Use
In a Report Painter or Report Writer report, you can enter texts for the following:
- Title page
- Headers
- Footers
- End page
These texts are used for list output and exports in text format.

Text for export
The text for export is used for Office integration and for exports into HTML or spreadsheet format.

The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites
You can only change texts in the report output if the report uses a standard layout in which the `Change allwd dur exctn` indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features
You can enter the following types of texts for report texts:
- Normal text
- Standard text variables such as the date, user name, and page number
- Special text variables
- Text variables for selection parameters
- Text variables for characteristics used in the text
For more information, see Variables in Report Text Definition [Ext.].
Defining Report Texts

To enter report texts from any Create Report screen:

Report Writer

From the screen Create Report or Change Report or Display Report: Initial Screen, choose Goto → Texts.


Report Painter


To enter text, choose one of the processing functions in the following table.

<table>
<thead>
<tr>
<th>Processing Functions for Text Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
</tr>
<tr>
<td>Enter text for title page</td>
</tr>
<tr>
<td>Enter text for headers</td>
</tr>
<tr>
<td>Enter text for footers</td>
</tr>
<tr>
<td>Enter text for last page</td>
</tr>
<tr>
<td>Enter text for export of report to HTML and Office Integration</td>
</tr>
</tbody>
</table>

The screen Change <text position> <report name> in Language <language code> appears.

If these functions are not available, choose Formatting → Report layout and check whether Change allowed during execution is selected on the tab Page/control.

Choose Text → Save.

Choose Text → Exit.

The text appears on the Create Report: Texts screen.

To save the report, choose Report → Save.

Entering Variables in Report Text

In the report output, you can insert text variables, frames, and rows with Insert. For more information about the different types of text variables you can define in your report text, and how to enter variables in report text, see Using Variables in Report Text Definition [Ext.].
Report Overview

Use

Once you have defined your report, you can display and print the entire report contents by choosing Extras → Overview.

The overview contains the characteristics and characteristic values used in the individual report sections, column blocks and general data selection criteria. It also provides general information, such as the report name, date of the last change, and information on formatting.

If you double click on an individual characteristic, the system provides an overview of where this characteristic is used in the report.
**Editing Report Painter Reports with Report Writer**

**Use**
If you have created a Report Painter [Ext.] report, you can edit this report afterwards by using Report Writer [Ext.] if you want to use some of the more complex Report Writer functions.

**Actions**


Enter a name for the Report Writer report and the Report Painter report and the library to which it is assigned under Copy from.

To converting the Report Painter report into a Report Writer report, the SAP R/3 System automatically generates the necessary sets. From Release 4.0 you do not need to enter a prefix for set names.

You cannot edit the automatically generated sets using maintenance transactions or use them in other reports.

Once you have saved the report, you now have a Report Writer report identical to the Report Painter report. You can edit this new report using Report Writer functions.
Example Process: Creating a Report Painter Report

Purpose
The 1SIP-001 cost center report (Cost Centers: Actual/Plan/Variance) is used to show how to create a report using the Report Painter [Ext.]. To see how to create a report with Report Writer [Ext.] see Example Process: Creating a Report Writer Report [Page 1110].

To create a report with the Report Painter, choose:
*Information system* → *Tools* → *Report Painter* → *Report* → *Create.*

Your report must be assigned to an existing library. Choose 1VK, as this is a report that is used in absorption costing.

When you name the report, you should keep to the usual naming conventions (see: Report Groups [Page 1050]).

Prerequisites
Define the requirements of your report first.

Graphical display:

<table>
<thead>
<tr>
<th>Section 1</th>
<th>Cost elements</th>
<th>Block 1/2</th>
<th>Section 1</th>
<th>Cost elements</th>
<th>Block 2/2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost</td>
<td>Actual Debit</td>
<td>Vari. (Abs.)</td>
<td>Cost</td>
<td>Actual Debit</td>
<td>Vari. (Abs.)</td>
</tr>
<tr>
<td>elements</td>
<td>costs Credit</td>
<td>Vari. (%)</td>
<td>elements</td>
<td>costs Over/</td>
<td>Vari. (%)</td>
</tr>
<tr>
<td>Debit</td>
<td>Plan costs</td>
<td></td>
<td>Debit</td>
<td>under-</td>
<td></td>
</tr>
<tr>
<td>Credit</td>
<td></td>
<td></td>
<td>Credit</td>
<td>absorption</td>
<td></td>
</tr>
<tr>
<td>Over/</td>
<td></td>
<td></td>
<td>Over/</td>
<td></td>
<td></td>
</tr>
<tr>
<td>under-</td>
<td></td>
<td></td>
<td>under-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>absorption</td>
<td></td>
<td></td>
<td>absorption</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 2</th>
<th>Stat. postings</th>
<th>Block 1/1</th>
</tr>
</thead>
<tbody>
<tr>
<td>postings</td>
<td>Stat. plan</td>
<td>Vari. (%)</td>
</tr>
<tr>
<td>Over/</td>
<td></td>
<td></td>
</tr>
<tr>
<td>under-</td>
<td></td>
<td></td>
</tr>
<tr>
<td>absorption</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 3</th>
<th>Activity types</th>
<th>Block 1/1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Act. activity</td>
<td>Vari. (Abs.)</td>
</tr>
<tr>
<td>types</td>
<td>Plan activity</td>
<td>Vari. (%)</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Section 4</th>
<th>Stat. key figures</th>
<th>Block 1/1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stat.</td>
<td>Actual</td>
<td>Vari. (Abs.)</td>
</tr>
<tr>
<td>key</td>
<td>Plan</td>
<td>Vari. (%)</td>
</tr>
<tr>
<td>figures</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The cost center report should contain the following information:
Example Process: Creating a Report Painter Report

The costs of a cost center [Ext.] / cost center group [Ext.] in actual and planning data should be structured by cost elements [Ext.] and displayed with the absolute and relative variances [Ext.].

Debits and credits should be displayed in different rows.

The reporting time frame should contain as many periods of a fiscal year as you require.

You should be able to call the report up for any cost center or cost center group.

The corresponding quantities should also be structured by cost elements and displayed separately in the actual and planning data with the absolute and relative variances.

For the same reporting time frame and the same cost center/cost center group, the statistical postings (postings updated with a different value type) should be displayed in the actual and planning data with the absolute and relative variances in their own report section.

For the same reporting time frame and the same cost center/cost center group, the activity types [Ext.] should be displayed in the actual and planning data with the absolute and relative variances in their own report section.

For the same reporting time frame and the same cost center/cost center group, the statistical key figures [Ext.] should be displayed in the actual and planning data with the absolute and relative variances in their own report section.

Process Flow

Section 1: Creating the "Cost Elements" Section Description

Create "cost elements" section one first. You can enter the description for the report and the section in the report header. Double-click on the entry row for the report description and store the text as a middle and long text for the Actual/Plan/Variance report. You can enter the cost element text directly for the section.

Section 1: Defining Report Rows (Debit and Credit, Under and Over-Absorption)

There are different templates that you can use to define the cost element rows in the report.

Choose Edit -> Rows -> Get row template and choose 1-LM-BEL-ENT from the dialog box. The system inserts the template rows in the report section.

⚠️ The template overwrites all of the rows that you defined in the report section. You should define any additional report rows that you want after the template has been inserted.

Defining your own report rows

The following describes how you define report rows for cost elements.

To define a report row, place the cursor on the row and choose Define element or Edit -> Element -> Define element. You can also double-click on the corresponding report row.

The system should display the debits and credits, and the over and under-absorption for the selected cost centers in the report rows of the cost center report.

To do this, you define two rows, which display the characteristics "Cost element" and "CO debit/credit indicator". Choose the characteristics from the list in the dialog box. The list contains all the characteristics provided by the selected library.
Example Process: Creating a Report Painter Report

CO Debit/credit indicator

The debit/credit indicator in the Debit row has the characteristic value "D" (= debit).

When you use the “CO debit/credit indicator” characteristic (BEKNZ), the system displays the debit and credit postings in separate rows, even for reposting.

As an alternative, the “CO debit/credit” indicator (BELKZ) is available to total the debit and credit postings per cost element for both manual or periodic repostings and display them as total costs. Moreover, when you reverse an FI document with a cost center account assignment, credit posting records are balanced with the original cost center debit.

Cost element

As the cost element characteristic value, you can enter any individual value, one or more intervals (Choose More), or a cost element group that has been defined in the Cost Center Accounting menu. If you do so, the report is only created for the cost elements you have specified.

However, you want to specify cost elements and cost element groups only when the report starts. Therefore, you enter the 1KSTAR variable (cost elements) under Groups. You can then enter variables with the Variable on/off function after selecting an entry field. By using variables, you can enter the cost element group or cost element interval on screen.

You can also define your own variables in the Set Maintenance screen (see also: Sets [Ext.]).

Row Texts

When you define a report row, you enter the appropriate short, medium, and long text descriptions. Choose Copy short text to copy the short text to the other rows. Choose Format → All rows/All columns → Text length to define which text to display in the report rows.

As a text, enter “Debit”.

Breakdown

By entering a cost element interval or cost element group when calling up the report, you can display the costs in the report for each cost element and generate group totals at various hierarchical levels. The structure of the cost element groups is set in their definitions in the Master Data Maintenance screen.

To expand the cost elements in the report, choose Edit → Rows → Expand. The default setting is Do not expand (detail). Cost element intervals and groups are displayed as totals in a row. The Ind. value setting displays individual values, but does not display subtotals or final totals. If you choose Expand, the system displays individual values, subtotals and final totals. The select this setting for the cost elements in the cost center report.

Breakdowns of report rows are displayed with one or more asterisks (*) in the report definition, depending on the summation level. If you are using variables, the summation level in turn is determined by the default value for the set variable. In the case of variable 1KSTAR, the default value 1-S-KSTAR-AL only expands to one level. Consequently, the expanded cost element row is marked with a single asterisk.
Other report rows

To define a credit row at the same time as defining a debit row, position your cursor on a debit row and choose Select/Deselect. Then position your cursor on the new row and choose Copy.

You can also change the selected characteristics and/or characteristic values by either double clicking on the desired row or by choosing Define element. Change the characteristic value for the “CO debit/credit indicator” to “C” (= credit).

You may use a characteristic value within the report rows more than once. The same applies to report columns. However, you cannot use a characteristic in a row and a column.

In the last row in the cost center report you calculate the over- or under absorption for the cost center. To do so, define a formula row using the formula editor, based on existing rows. You can also enter the formula directly. Then, choose Check to determine whether the formula is correct.

Section 1, Block 1 - Defining Report Columns (Plan and Actual Costs and Their Variances)

Now create the plan and actual columns for section 1. The report columns should display the actual and plan values for the selected posting periods, together with absolute and percentage variance figures.

The SAP System includes various column models for defining columns in the report.

Choose Edit → Columns → Get column model and select 1-CM-IPA from the dialog box. The column models then appear in your report.

The model overwrites all columns previously defined for the report section. You should therefore define individual report columns after inserting the model.

Defining Custom Report Columns

The following section describes how to define your own report columns for actual and plan costs as well as for absolute and relative variances.

To define a report column, place your cursor on the column and choose either Define element or Edit → Element → Define element. You can also select the desired report column by double clicking on it.

Use the relevant predefined columns when defining “Actual costs” and “Plan costs” columns.

Predefined columns

The selection list displayed by the system contains all predefined columns available in the selected library. You can define additional predefined columns in set maintenance. For more information, see Further reading → FI-SL Sets → Variables.

The key figure Costs with the characteristics value type and version has been preset for the predefined columns Actual Costs and Plan Costs:
Example Process: Creating a Report Painter Report

Characteristic values for actual costs:
Version 0 (plan/actual version)
Value type 04 (= actual)

Characteristic values for plan costs:
Version: 1VERP (= plan version)
Value type: 01 (= plan)

For the plan costs column, the version has been defined as a variable.
Use the default setting and enter “Actual costs” or “Plan costs” as the column text.

Formulas
Use the formula editor to define the "absolute variance" and "percentage variance" columns using existing columns. Check to see that the formula has been entered correctly before adopting the formula.

If row and column formulas conflict, column calculations always take precedence.

Section 1, Block 2 - Define Report Columns (Plan and Actual Quantities and Their Variances)

The SAP System allows you to define additional columns for previously defined rows in the cost center report; these columns are defined in a new column block. The columns found in a given column block form a logical unit.

To create a new column block, choose Goto → New column block and define the columns as described above.

An additional column block is defined for the cost center report, containing the predefined columns Actual Amount and Plan Amount as well as absolute and percentage variances calculated on the basis of these numbers.

You can perform calculations across more than one column block. This lets you to refer to column formulas contained in other blocks.

Section 2 Defining Statistical Postings

You can also define other logically associated row/column combinations on a new page of the report. These are known as sections.

To define a section with new row and column combinations, choose Goto → New section. In the dialog box, adopt the default setting Section with characteristics and key figures.

For the cost center report, you can define another section for statistical postings (postings that can be updated using various cost element categories).

For the statistical postings, you display the cost elements in the rows. Choose the Cost element characteristic and enter the variable 1KSTAR as the characteristic value.

Proceed as described under 2.
Example Process: Creating a Report Painter Report

The breakdown the cost element rows by line items and totals rows. To do this, choose \textit{Edit} \rightarrow \textit{Rows} \rightarrow \textit{Breakdown} and activate \textit{Breakdown}.

To define columns, proceed as described under 3.

Defining Section 3 (Activity Types)

In this section, you display the activity types in the actual and the plan together with the absolute and percentage variances.

To define the rows in the activity type section, choose the Activity type characteristic and enter an asterisk (*) as the characteristic value so that all activity types can be displayed in the report rows.

Creating totals using activity types is often inadvisable, as different activity types use different units of measure. Therefore, when you expand the rows (\textit{Edit} \rightarrow \textit{Rows} \rightarrow \textit{Breakdown}), choose the \textit{Single values} indicator so that single values are broken down, but nothing is totaled.

To define columns, proceed as described under 3.

Defining Section 4 (Statistical Key Figures)

In this section you display the statistical key figures in the actual and the plan, together with their absolute and percentage variances.

Define the rows using the characteristic \textit{Statistical Key Figures} and enter an asterisk (*) as characteristic value in order to display all activity types in the report rows. During breakdown of the rows, use the \textit{Individual values} indicator with \textit{Edit} \rightarrow \textit{Rows} \rightarrow \textit{Breakdown} in order to breakdown individual values without performing totaling operations.

To define columns, proceed as described under 3.

Defining General Data Selection Criteria

Use this function to establish selection criteria applicable to the entire report.

You can only define characteristics in general data selection that have not been used in the row or column definitions.

Define the general data selection for your report by choosing: \textit{Edit} \rightarrow \textit{Gen. selection} \rightarrow \textit{Change selection}.

Define the following characteristics and characteristic values for the example cost center report.

Controlling area: 1KOKRE
Fiscal year: 1FISCYR
From period: 1PERFR
To period: 1PERTO
Cost center group: 1CCTRGR.

Select the \textit{Controlling area}, \textit{Cost center}, \textit{Fiscal year}, and \textit{Period} characteristics.
Cost Center Accounting (CO-OM-CCA)

Example Process: Creating a Report Painter Report

As characteristic values, you can select individual values, intervals, or variables. If variables are entered, the corresponding entry fields appear in the report selection screen together with the variables decided upon for the rows and columns.

Position your cursor on the controlling area field. Choose Variable on/off to activate the option of entering variants. Choose F4 help to display available variables. Select the variable 1KOKRE.

For the cost center, position the cursor on the entry field for the group. Select the variable 1KOSET. The variable 1KOSET enables you to enter a cost center, an interval or a cost center group in the selection screen when you call up the report. Report Painter creates a report that totals all postings for the selected cost centers sorted by cost element.

For fiscal year, position the cursor on the entry field for fiscal year. Select the variable 1GJAHR.

For period, position the cursor first on the entry field for “From” fiscal year and select the variable 1PERIV. Then place the cursor on the entry field for “To” fiscal year and select the variable 1PERIB.

You must use the characteristic “Controlling area” for reports assigned to table CCSS. This characteristic can only be used as an individual value, and then only as a general data selection criterion.

Defining Report Texts

Choose Extras → Report texts to add headers, footers, title pages, and closing pages to your report.

The report must be saved at least once before you can begin text maintenance.

Formats and Standard Layouts

Assigning Standard Layouts

The display of values in the report is determined using formats. Each report has five format groups available to structure columns. All columns assigned to the same format group are displayed in the same way. You maintain format groups when you define standard layouts [Ext.].

Use Format → Standard layout to display previously defined standard layouts. To assign a particular standard layout to your report, choose Format → Standard layout and enter the one you require. For the example cost center report, select standard layout 1-BTC2.

Maintaining Format Groups

Maintain the format groups. The Formats rows in your report definition are used to establish the format applicable to the individual report columns. The default value for all columns is set by the system as format group “0”. For the columns to display the percentage variance, use format group 2 from the standard layout (narrower column width). For the columns that are to display units (activities and quantities), use format group 1 from the standard layout (unit width of column: 5).

Overwriting Standard Layout Defaults
You can overwrite standard layout settings in the report itself. When doing so, be careful to change all columns of the format group at the same time. You can also choose Formatting → Column to change the column width, numerical format (factor and decimal places) and the reverse sign for individual format groups if necessary.

Set the column width for the leading column at 30.

**Defining Column Text and Text Type**

You should then establish report column justification.

Choose Format → All columns → Justify column text and activate the indicator Text centered.

For all columns you determine whether or not to include the use of the short, medium, or long text as the row/column text. Choose Format → All columns → Text type. Activate the Short text indicator. Choose Format → All rows → Text type. Activate the Medium text indicator.

**Over/Underscoring, Colors**

You can also select over- and/or underscoring and colors for the particular rows you want to emphasize.

Position your cursor on the row and choose Format → Row → Under/Overscore. Use underscoring for the “Debit” and “Credit” rows, and under- and overscoring for the “Over/Under-absorption” row.

Position your cursor on “Over/Under-absorption”, then choose Format → Row → Color setting and activate the Color for totals indicator.

**Inserting Blank Rows**

To insert blank rows in the report, choose Edit → Rows → Insert blank rows.

**Checking, Generating and Executing Reports. Assigning reports to Report Group**

After creating your report, choose Check to test for formal errors in the report. The SAP System generates an error log listing any errors found. Remove the errors using the error log and save your report.

Then, execute your report in a test run. Choose Report → Execute. If the report has not been assigned to a report group, a system prompt inquires whether to insert the report and to which group. Answer Yes to the prompt and enter an existing or a new report group name.

Alternatively, you can assign the report to a report group by choosing Environment → Assign to report group. Enter an existing group or a new report group. If the group does not yet exist, a system prompt inquires whether you want to create one at this time.

The report group is then generated and the report executed. On the report selection screen you can then execute the report with the desired selections.

**Enhancements**

Below are several enhancements to the cost center report that explain other important Report Painter functions. These enhancements are not included in the standard report 1SIP-001.

**Section 1: Report Columns: Defining Plan and Actual Costs per Employee (Example for Working with Cells)**
Example Process: Creating a Report Painter Report

Assume you want the Cost Element section of the cost center report to include two additional columns displaying actual and plan costs per employee for each cost element. To do so you use cell calculation.

However, you did not define a cell in the statistical key figure section (section 4) that explicitly displays employee numbers, since the characteristic value is "*", or all statistical key figures.

To display the statistical key figure "Employee," you must define an additional row in the statistical key figure section using the characteristic "Statistical key figure" and a characteristic value of "EMP" (Employee).

In this case, you will only be able to edit those cells that are an intersection of the "Employee" rows and "Statistical key figures: actual" columns. Position your cursor on the appropriate cell and choose Edit element or double-click on the cell. In the Cell processing dialog box, set the selection option. Then choose Edit → Element → Change text and chose short, medium, and long texts for the "Employee" cells.

The same procedure is used at the crossover point where the row “Employee” and column “Plan statistical key figure” overlap.

With the formula editor you can use all selected cells in the entire report when defining columns. All previously defined columns are also available.

You can now use the new cell to make calculations for an additional column in the “Cost Elements” section of the report. Position your cursor after the columns for actual and plan costs. Double-click and choose the element type Formula from the first dialog box. In the Enter Calculation Formula dialog box, choose Actual costs from the list of Existing Formulas, the division symbol, and the indicator EMP. Choose Transfer. The formula column is now defined.

In the same way, create a column Plan costs/employee.

To prevent output of the new row inserted in the key figures section when calling up the report, you need to hide the row. Place your cursor on the required row and choose Edit → Rows → Hide.

Defining Sections 5 and 6 (Activity Quantities, Activity/Plan Capacity) - Example for Processing a Section With Key Figures

As a further enhancement to cost center report 1SIP-001 create another section. You want to display the actual and plan activity quantities and the absolute and percentage variances. In a further column, capacity is displayed. The rows display the activity types.

To create this section, proceed as described in II.6.

Then, define a new section 6, “Activity/Plan Capacity” as a section with key figures. In this section, the relationships “Actual activity quantity/Plan Capacity” and “Plan activity/Plan capacity” are displayed.

Schematic illustration of the enhancements:
Example Process: Creating a Report Painter Report

Select the appropriate cells in section 5, “Activity Quantities”, by placing the cursor on them and choosing Edit element or by double-clicking on the cells. In the Cell processing dialog box, set the selection option. To add short, medium, or long texts to the cells, choose Edit → Element → Change Text.

Then choose Goto → New section and define a new report section 6, “Activity/Plan Capacity”. Choose Section with derived key figures from the dialog box.

In the row and column combinations in the section with key figures, edit first the short, medium, and long texts for rows and columns.

For your section with key figures, define an Actual activity/Plan capacity column, a further column Plan activity/Plan capacity column, and an Activity type row.

The report is to display the relationship of actual activity to plan activity for the corresponding activity type at the cell intersection of the Actual activity/Plan capacity column and the Activity type row. Position your cursor on the corresponding cell and choose Edit element or double-click on the cell. The SAP System offers the formula editor for cell processing. You are then able to use all selected cells and accompanying descriptions in the formula editor. If no text has been created for these cells, the functions carry a description of the row/column intersection that defines the cell. Choose Activity type/Actual activity/Plan capacity.

In the same way, use the appropriate formula editor function for the cell representing the intersection of the Plan activity/Plan capacity column and the Activity type row.

You can use all previously selected cells in the formula editor to define new cells for the section with key figures.
Report Writer

Use

In addition to the Report Painter, you can also use the Report Writer [Ext.] to define reports. As the latter offers a large number of features, it takes longer to learn how to use it to maximum advantage.

The following topics describe the additional features required to create reports using Report Writer.

Since Report Painter has most of the features offered by Report Writer, but is easier to use, it is generally recommended that you use Report Painter where possible.

For more information about the Report Writer, see the SAP Library, under FI Financial Accounting → FI Special Purpose Ledger → Report Writer Reports [Ext.].
Sets

Use
The definition of reports using report writer [Ext.] is based on the set [Ext.] concept. You can build set hierarchies by linking sets. On the basis of these set hierarchies, Report Writer can build totals. The row/column structure and the general data selection criteria in a Report Writer report are all defined with sets.

Integration
In various places, the CO information system uses the master data groups created in the application component menus, such as cost center [Ext.] groups or cost element [Ext.] groups. These groups can be entered at the time the report is started. Basic or single dimension sets are generated for the master data characteristics in the group maintenance records for the master data. You can also use selection variants [Page 28] for these groups. As a general rule, however, other sets are needed for report definition purposes that cannot be created in the master data group maintenance records. This requires you to edit these sets in Report Writer using the set maintenance function.

Master data group maintenance only creates sets that refer to a single characteristic. By contrast, the multi-dimensional set 1-L-IP-SH-01 contains the characteristics "CO debit/credit indicator" and "Cost element".

Features
The following set types [Ext.] are available:

• Basic sets
  A basic set contains individual values or value intervals for a given characteristic. Basic sets can also contain value and formula variables as well as formulas.

• Single dimension sets
  These contain single values, value intervals, basic sets or single dimension sets that use the same characteristic. You can therefore use single dimension sets to define hierarchies consisting of basic sets or of other single dimension sets for the same characteristic.

• Predefined column
  A predefined column contains enhanced predefined columns and formulas. You can use enhanced predefined columns to access the value and quantity fields in the Controlling application component databases.

• Multi-dimensional sets
  These can contain basic sets, single dimension sets, and predefined columns with different characteristics. Each characteristic, however, may appear only once in a multi-dimensional set. You can also use set variables with these sets to change the construction of the report.
Sets

For more information on sets, see the SAP Library, under FI - Financials → FI Special Ledger → Sets [Ext.]
Using Sets

Use

The information system classifies the created sets [Ext.] according to their purpose in the report definition.

The following classes have been created:

<table>
<thead>
<tr>
<th>Class</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row sets</td>
<td>1-L-Name</td>
</tr>
<tr>
<td>Column sets</td>
<td>1-C-Name</td>
</tr>
<tr>
<td>Selection sets</td>
<td>1-S-Name</td>
</tr>
<tr>
<td>Additional sets</td>
<td>1-Z-Name</td>
</tr>
</tbody>
</table>

Features

Analyzing Sets

Set Maintenance provides a number of ways to analyze sets and their use, with the Utilities menu.

- Set directory
- Values in sets
- Set usage
- Graphics
- Unused sets

Set directory

Requesting the set directory display from the Utilities menu calls up a selection screen to limit your search by set ID, table field name, author name or name of the last person to change the set, and set type. The R/3 System offers you a list of sets including a description, indication of the set type and field, and the creation and modification date.

You can also call up the Set Name dialog box from any initial screen with the Set ID entry field by choosing F4 help.

To select standard sets defined as row sets, enter:

Set name: 1-L*

Activities

To process sets, choose:
Using Sets

Predefined Business Key Figures

Use

Report columns contain values and quantities derived from the Controlling databases, such as actual and plan figures. These figures can in turn come from different versions or may have been entered in different periods and fiscal years. When you define reports, this characteristics must be available for the Report Writer. In a multi-dimensional set, enter all characteristics needed to describe the value columns (such as period, fiscal year, actual value type, version 0). To include these criteria in the key figures (predefined business key figures), enter an additional set containing these characteristics.

You need key figures to create a set structure for the report columns. These sets contain additional key figures, and possibly formulas, and are created as a dataset.

Each row in a data set generates a column in your report.

The 1-C-IP key figure (actual/plan cost comparison) in the CCSS table contains the following entries:

<table>
<thead>
<tr>
<th>ISWKG</th>
<th>Key figure for actual costs [Ext.]</th>
</tr>
</thead>
<tbody>
<tr>
<td>PSWKG</td>
<td>Key figure for plan costs [Ext.]</td>
</tr>
<tr>
<td>Calculation row</td>
<td>Absolute variance [Ext.]</td>
</tr>
<tr>
<td>Calculation row</td>
<td>Percentage variance</td>
</tr>
</tbody>
</table>

Activities

Editing (Predefined) Key Figures

To edit key figures, choose:

Information system → Tools → Report Painter → Report Writer → Predefined column → Maintain

Specify the table to which the respective application component reports are assigned (see also: Libraries [Page 1044]).

In the standard system, at least one predefined key figure has been created for all key figures in Cost Center Accounting. It is therefore useful to search for existing predefined key figures when you define your own reports.

To display a list of predefined key figures, choose:

Information system → Tools → Report Painter → Report Writer → Create/Change Report Edit → Element → Insert Element → Predefined Key Figure.

The system distinguishes between the following value types.

<table>
<thead>
<tr>
<th></th>
<th>Act. costs</th>
</tr>
</thead>
<tbody>
<tr>
<td>P</td>
<td>Planned costs</td>
</tr>
</tbody>
</table>
Predefined Business Key Figures

<table>
<thead>
<tr>
<th>A</th>
<th>Target costs [Ext.]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Y</td>
<td>Statistical actual costs</td>
</tr>
<tr>
<td>Q</td>
<td>Statistical plan costs</td>
</tr>
<tr>
<td>S</td>
<td>Variances</td>
</tr>
<tr>
<td>O</td>
<td>Commitments [Ext.]</td>
</tr>
</tbody>
</table>

The key figures are preset by SAP and derived from the field groups of the CO databases. The field group for amount fields displayed in the controlling area currency is WGK001-WKG016. To access the field groups from within Report Writer, use key figure SWKG.

The suffixes found at the end of the key figures often identify a period or other descriptive characteristics.

Predefined key figures:

| ISWKG | Overall actual costs displayed in controlling area currency [Ext.] |
| PSWKF | Fixed plan costs displayed in controlling area currency |
| ISWKG-LJ | Overall actual costs for the current year displayed in controlling area currency |
Variables in Set Maintenance

Use

When using sets [Ext.] to define reports, you do not need to enter characteristic values each time you call up the report. It can be useful, nevertheless, to determine the characteristic values you want to analyze at the time the report is executed. You can accomplish this by using variables supplied when the report is executed. You do not need to change the report definition.

Features

Set Maintenance distinguishes between three variable types.

Value variable

Each value variable represents an individual value. You can enter value variables directly until the time the report is processed.

1PERIV (= From period) has a default value of "1," that is, valid from period 1.

Set variable

Each set variable represents a set. You can enter set variables directly into a multi-dimensional set until the time the report is processed.

1KOSET (= cost center) contains the default set 1-S-KSTDUMMY (cost center group).

Formula variable

Each formula variable represents a formula or a user exit found in a basic set.

Formula variable 1GJAHR contains the current fiscal year, determined from the system date.

You can display standard variables by choosing F4 help on the Variable field. You can select an entry through the Selection conditions for variables dialog box.

Activities

To process sets, choose:


For more information on variables in set maintenance, see the SAP Library, under AC - Financials → FI - Financial Accounting → FI Special Ledger → Variables [Ext.]
Variables in Set Maintenance
Report Text

Use
In a Report Painter or Report Writer report, you can enter texts for the following:
Title page
Headers
Footers
End page
These texts are used for list output and exports in text format.
Text for export
The text for export is used for Office integration and for exports into HTML or spreadsheet format.
The definition of report texts in the Report Painter is similar to that in the Report Writer.

You can also define report texts in the report output. SAP recommends that you enter report texts only after the report has been executed and output. This allows you to see which values the report text variables will use.

Prerequisites
You can only change texts in the report output if the report uses a standard layout in which the Change allwd dur exctn indicator is selected on the Page/Control screen. You cannot change texts in standard reports included with your SAP R/3 System.

Features
You can enter the following types of texts for report texts:
Normal text
Standard text variables such as the date, user name, and page number
Special text variables
Text variables for selection parameters
Text variables for characteristics used in the text
For more information, see Variables in Report Text Definition [Ext].
Process Example: Creating a Report Writer Report

Purpose
The following example shows you how to construct the cost center report 1 SIP-001 (described in the Example process: Creating a Report Painter Report [Page 1090] section) using the Report Writers [Ext.].

You will learn how to create new reports using existing Report Writer sets and variables. To create a cost center report, access Cost Center Accounting and choose:


Prerequisites
You first define your report requirements.

The cost center report should provide the following information:

The actual and plan costs of a cost center [Ext.] or cost center group [Ext.], should be structured by cost elements [Ext.] and displayed with the absolute and relative variances [Ext.].

Debit and credits are to be displayed in different rows.

The reporting period may include as many periods per fiscal year as required.

You should be able to call up the report for specific cost centers or cost center groups.

The appropriate actual and plan figures should be displayed on a separate page, sorted by cost element, together with absolute and relative variances.

Actual and plan statistical postings (postings that are updated with a different cost element type) together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.

Actual and plan activity types [Ext.] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.

Actual and plan statistical key figures [Ext.] together with absolute and relative variances should be displayed in a separate report section for the same reporting period and cost center/cost center group.

Before you define the report, you must decide:

Which characteristics should appear in the report?

Where are these characteristics to be entered?

Which report characteristics should be variable and which should be fixed?

Can variables already defined for report requirements be used with the new report?

A characteristic can only be used once in a report, in report rows, report columns, or data selection criteria. You decide the most appropriate location for the characteristic.

The following characteristics are required for the example cost center report.
Process Example: Creating a Report Writer Report

General data selection characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KOKRS</td>
<td>Controlling Area [Ext.]</td>
</tr>
<tr>
<td>KOSTL</td>
<td>Cost center group</td>
</tr>
<tr>
<td>GJAHR</td>
<td>Fiscal Year [Ext.]</td>
</tr>
<tr>
<td>PERBL</td>
<td>Periods</td>
</tr>
</tbody>
</table>

The characteristics “Fiscal year” and “Period” can remain general data selection criteria, since every column of the report will contain values from the same time period. If you want the report columns to represent different reporting periods, however, you must place these characteristics in the appropriate columns.

Report row characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KSTAR</td>
<td>Cost element</td>
</tr>
<tr>
<td>BELKZ</td>
<td>CO debit/credit indicator</td>
</tr>
</tbody>
</table>

Report column characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WRTTP</td>
<td>Value type (actual, plan)</td>
</tr>
<tr>
<td>VERSN</td>
<td>Version [Ext.] (actual version is always 0)</td>
</tr>
</tbody>
</table>

Key figures in the report columns

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWKG</td>
<td>Costs</td>
</tr>
</tbody>
</table>

The next step when defining the report is to check whether you can use existing sets for rows, columns, and general data selection criteria.

Process Flow

1. **Defining Report Rows**

   To access row maintenance, choose *Rows* in the *Report Definition* screen.

   You can use row sets to display the hierarchical structure of the cost elements and to calculate group totals at various levels. In the Cost Center Accounting menu you have created at least one cost element group. The SAP R/3 System created cost element sets, which you can now use as row sets. By entering such a set in the row definition, the report is always be generated using the cost elements entered for those rows.
If instead you wish to enter the cost element group when the report is started, you must enter a multi-dimensional set in a report row containing a set variable. This set variable acts as a placeholder for the cost element group. When such a variable is defined in the report, the SAP R/3 System allows you to enter the cost element group or interval in the report selection screen.

Set variable &1KSTAR

The example cost center report should also distinguish between debit and credit postings. This is done by including characteristic BELKZ in the multi-dimensional set in addition to the cost element. The value of characteristic BELKZ can either be D (for debit) or C (for credit).

Use multi-dimensional set 1-L-IP-SH for the example cost center report. Note that the single dimension set 1-S-BELKZ is located in the first set row, followed by the set variable &1KSTAR in the second set row. As a result, the report first displays all debit postings for the cost center, followed by all credit postings. The cost elements are be sorted and totaled in these logical rows according to the set structure for the indicated cost element groups. Report Writer generates a subtotal at every set level.

In addition to the group totals derived from the cost element structure, the report also generates a total for each BELKZ characteristic value and a grand total for the multi-dimensional set.

The SAP R/3 System automatically identifies a logical report row within a given report, based on the row set description (such as 1-L-IP-SH "Cost elements"). The system derives the ID for the highest order group total from the first set in the multi-dimensional set found in the report row (such as 1-S-BELKZ "Over-/underabsorption"). All other lower order group total IDs are likewise derived from the respective set description (such as 1-S-BELKZ-S "Total costs").

You can create other report texts that differ from the set descriptions defined in Set Maintenance. Choose Extras → Additional texts from the row or column definition dialog box and enter the specific report text for the lead column and a grand total in either Texts for Column Block or Texts for Row Block.

You can use characteristic BEKNZ in addition to characteristic BELKZ. If you use characteristic BELKZ, the report totals the debit and credit postings per cost element for both manual or periodic repostings. These postings are displayed as total costs. Moreover, reversing FI documents with the cost center account assignment feature balances out any credit posting entries by using the original debit entry for the account. Alternatively, using characteristic BEKNZ results in the debit and credit postings being displayed in separate rows, even in the case of repostings.

2. Defining Additional Report Rows

Just as with report 1SIP-001, you can also define additional logical report rows for the example cost center report that represent activity types, statistical key figures, and
statistical postings. The latter postings are those made to the cost element records, but which are updated later using a different cost element category.

You may use a characteristic value within the report rows more than once. The same applies to report columns. However, you cannot use a characteristic in a row and a column.

3. Defining Report Columns

Assume you now want to display the actual and plan figures for particular posting periods in the columns of the example cost center report, including absolute and percentage variances. You need to enter the predefined column 1-C-IP in the report, containing the predefined columns ISWKG (actual costs) and PSWKG (plan costs). The characteristics VERSN (=version) and WRTTP (=value type) are stored in additional sets for the predefined columns ISWKG and PSWKG.

Use the Layout variation function to establish how the values are displayed in the report. Each report has five variations available for this purpose. A single variation establishes column width, the column number for the value's unit, and the number of decimal places and exponents for the report output. You can change these values for a particular report with the report layout function or save them in a standard layout. You can assign a display variant to each column in the report. You define this in the “P” column in the basic entries for the predefined columns.

The first three columns have been assigned display variant "0" in data set 1-C-IP, and the fourth column has been assigned variant "2." The fourth column will thus be 10 characters wide, not 20.

You can only perform arithmetic calculations within a column block. This means that the formulas may not refer to other predefined columns.

In the event your report uses more than one logical row or column, you must be sure only to activate logically permitted combinations so that your report generates useful results.

Assume that the cost center report should now display statistical key figures. In this case, it only makes sense to use a column set that also displays the statistical key figure values. All other columns for these report rows should be deactivated. In this instance, the appropriate column set is 1-C-SSK.

To deactivate individual columns in the row definition dialog, place the cursor on the desired row and choose Inactive columns. In the Inactive Columns dialog box, select the columns you wish to deactivate.

4. Defining General Data Selection Criteria

Use general data selection to define the characteristics you wish to use to select the data for the entire report. You can only use characteristics as general data selection criteria that you have not yet used in the individual rows or columns of the report.
Process Example: Creating a Report Writer Report

With the exception of multi-dimensional sets, you can use all set types as general data selection criteria. You can also use set variables. However, you can only use those characteristics that have not been entered in the row or column definitions.

In the case of the example cost center report, the reporting objects are the cost centers themselves. Set variable &1KOSET was used for this characteristic. As a result, you are able to enter a cost center set or individual cost center values when you call up the report. Report Writer creates a report that sums up all postings for the selected cost centers and displays the same by cost element.

On the other hand, you should use a variation if you want to generate a report for each individual cost center for the set and for all levels of the cost center set. Use the Vary function to enter the group level for characteristic KOSTL to which Report Writer should expand the cost center set. The default value is 1 to 99, with level 1 being the highest hierarchical node and level 99 the lowest. If you also want to create a report for each individual cost center, you must additionally set the “I” indicator (individual value).

If you do not want to vary your cost center set on all levels, use other values. Level 1 indicates the highest hierarchical node and level 99 the lowest.

You can only activate the variation when you start your report if you have set this indicator.

You must use the characteristic “Controlling area” for reports assigned to table CCSS. The controlling area characteristic can only be used as an individual value, and then only in the general data selection criteria.

Before saving the report and assigning it to a report group, check your report definition for syntax errors. Choose Report ➔ Check The SAP R/3 System generates an error log listing any errors found.
Defining Reports For Overhead Cost Controlling

Use

In Overhead Cost Controlling, you use the Report Painter [Ext.] or Report Writer [Page 1100] for report definition. You use the CCSS and RWCOOM reporting tables for this. These tables provide the characteristics and key figures that you require for report definition in Cost Center Accounting, on internal orders, projects, and so on.

In report definition, you need to differentiate between totals record reports and line item reports. You can create only totals records reports with the RWCOOM reporting table. The CCSS reporting table enables you to define totals records reports as well as line item reports.

Do not use the Report Painter to define line item reports. Instead, use the line item display, and use display variants that meet your requirements. This has the following advantages compared with definition using the Report Painter:

- Improved performance
- Text columns are available
- All fields of the line item are available

Integration

Special Features of The RWCOOM Reporting Table:

You can use the RWCOOM reporting table to create user-defined reports in Overhead Cost Controlling.

In the standard system, these reporting tables are assigned to the following libraries:

- 1CT: Cost centers: Special reports
- 6O2: Internal orders: Special reports
- 9A2: Business processes: Special reports

The RWCOOM reporting table contains key figures, for example, for budgets and activity prices, which are not contained in the CCSS reporting table.

You can find examples of report definition that refer to the RWCOOM report table in the following standard reports:

- List: Budget/Actual/Commitment (6OBU-001)
- List: Budget/Actual/Commitment (6OPL-001)
- Area: Actual/Budget/Commitment (1SET-001)
- Cost Centers: Cost component split (1SKS-001)

When To Use CCSS And When To Use RWCOOM

You must use the RWCOOM reporting table for the following reports:

<table>
<thead>
<tr>
<th>Report</th>
<th>Sample Report</th>
</tr>
</thead>
</table>

April 2001 1115
### Defining Reports For Overhead Cost Controlling

<table>
<thead>
<tr>
<th>Report Type</th>
<th>Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Budget reports for internal orders</td>
<td>6OBU</td>
</tr>
<tr>
<td>Overall plan reports for internal orders</td>
<td>6OPL</td>
</tr>
<tr>
<td>Cost component split reports</td>
<td>1SKS</td>
</tr>
<tr>
<td>Budget reports</td>
<td>1SET</td>
</tr>
<tr>
<td>Reports with any rolling reporting timeframes</td>
<td>1SRJ</td>
</tr>
<tr>
<td>Settlement reports for internal orders that display the assets (assets under construction) settled to</td>
<td>6AO1</td>
</tr>
<tr>
<td>Price reports</td>
<td>KSBT (transaction)</td>
</tr>
</tbody>
</table>

In the CCSS reporting table, there are more characteristics available than in the RWCOOM reporting table. Therefore, you should use the CCSS reporting table to define your reports if they are not listed in the table above.

Instead of the following characteristics: Costs in controlling area currency (SCKG), costs in object currency (SWOG), costs in the transaction currency (SWTG), and costs in the reporting currency [Page 554], the RWCOOM reporting table provides the Currency type (CURTYPE) characteristic. You use this when defining the report, to specify if it is to be displayed in the controlling area, object, transaction, or reporting currencies.

For **performance reasons** you should use a characteristic for an account assignment object (such as a cost center, or internal order) in the general selections, or in all rows or columns.

For more information on report definition, see [Creating Report Painter Reports][1056].
Report Painter Or Report Writer?

Use


Report Painter fulfills a function similar to Report Writer, but is simpler to use. Report Painter contains a large amount of the functions from the Report Writer. However, you do not need to know all of the Report Writer concepts (such as, sets [Ext.]).

When executing a Report Painter report, it is displayed by the R/3 System in Report Writer format. You thus have access to the same functions as for Report Writer reports defined in the same way, and can combine Report Painter and Report Writer reports together in a report group.

Report Painter uses a graphical report structure, which forms the basis for your report definition and displays the rows and columns as they appear in the final report output.

To facilitate report definition, you can use many of the standard reporting objects provided by SAP (such as libraries, row/column models, and standard layouts) in your own specific reports. When you define a Report Painter report you can use groups (sets). You can also enter characteristic values directly.

Advantages of Report Painter include:

- Flexible and simple report definition
- Report definition without using sets
- Direct layout control: The rows and columns are displayed in the report definition as they appear in the final report output, making test runs unnecessary.

The Report Writer has a very comprehensive range of functions, and thus requires longer to learn.

Since Report Painter has most of the features offered by Report Writer, but is easier to use, it is generally recommended that you use Report Painter where possible.

For comprehensive information on the Report Writer, see the SAP Library, under Financial Accounting → Special Purpose Ledger → Report Writer [Ext.]

For comprehensive information on the Report Painter, see the SAP Library, under Financial Accounting → Special Purpose Ledger → Report Painter [Page 1052]
**Important Basic Key Figures In Overhead Cost Controlling**

**Use**

Basic key figures are value fields. They represent criteria with which you can select data records. The following key figures are important for defining reports in Overhead Cost Controlling:

<table>
<thead>
<tr>
<th>key Figure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Costs in report currency (SWKG)</td>
<td>Total costs in report currency. You can specify the report currency in the user settings [Page 954]. The controlling area currency is set as a default.</td>
</tr>
<tr>
<td>Costs in controlling area currency (SCKG)</td>
<td>All costs in controlling area currency. The controlling area currency is the currency used for cost accounting in CO.</td>
</tr>
<tr>
<td>Costs in object currency (SWOG)</td>
<td>All costs in object currency. The object currency is the currency defined in the master record of a Controlling object (cost center, internal order, etc.).</td>
</tr>
<tr>
<td>Costs in Transaction Currency (SWTG):</td>
<td>All costs in transaction currency. The transaction currency is the currency in which the given documents are posted. The transaction currency can differ from the controlling area currency and the object currency. The SAP R/3 System can make automatic currency conversions based on predefined average exchange rates.</td>
</tr>
<tr>
<td>Costs in target currency (SWZG)</td>
<td>All costs in target currency. When you use this key figure, the system prompts you in the report selection screen for additional entries regarding target currency, exchange rate date, and exchange rate type.</td>
</tr>
<tr>
<td>Quantity (SMEG):</td>
<td>All posted quantities</td>
</tr>
<tr>
<td>Activity quantity (SLST)</td>
<td>Posted quantities for activity types [Ext.].</td>
</tr>
<tr>
<td>Statistical quantity (SSME)</td>
<td>Posted quantities for statistical key figures [Ext.].</td>
</tr>
<tr>
<td>Scheduled activity quantity (SDIS)</td>
<td>The planned input quantity on receivers of a particular activity.</td>
</tr>
<tr>
<td>Capacity (SKAP)</td>
<td>Output of a cost center and activity type for a certain period that is technically possible</td>
</tr>
</tbody>
</table>

For the complete list of basic key figures in the CCSS and RWCOOM reporting tables, see library 1VK for example.
Characteristics In Overhead Cost Controlling

Use

For report definition [Page 1115] there are two reporting tables (CCSS, RWCOOM) in Overhead Cost Controlling that you can use, and that have many of the same characteristics. Some are true and some are virtual characteristics:

True characteristics are usually stored in the database tables for the totals records, and you cannot select these.

Virtual characteristics are not stored in the database tables for the totals records. Instead, the system determines them during the program runtime for the selected totals records using the selected characteristics.

Characteristics in the CCSS reporting table

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>True/Virtual</th>
<th>Description/Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>KOKRS</td>
<td>True</td>
<td>Key that uniquely identifies a controlling area. The controlling area represents the highest organizational unit in Controlling. Mandatory field that you only use in general selections. Only single values are possible, and no evaluations across controlling areas possible.</td>
</tr>
<tr>
<td>KOSTL</td>
<td>True</td>
<td>Key that uniquely identifies a cost center [Page 127].</td>
</tr>
<tr>
<td>PSPID</td>
<td>Virtual</td>
<td>Project definition</td>
</tr>
<tr>
<td>POSID</td>
<td>True</td>
<td>Work breakdown structure element (WBS element)</td>
</tr>
<tr>
<td>AUFNR</td>
<td>True</td>
<td>Order number [Ext.].</td>
</tr>
<tr>
<td>LSTAR</td>
<td>True</td>
<td>Key that uniquely identifies an activity type [Page 147].</td>
</tr>
<tr>
<td>STAGR</td>
<td>True</td>
<td>Key that uniquely identifies a statistical key figure [Page 163].</td>
</tr>
<tr>
<td>OBJNR</td>
<td>True</td>
<td>Object, technical characteristic, use only for project and order summarization reports [Page 1134].</td>
</tr>
</tbody>
</table>

Account Assignment Objects

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>True/Virtual</th>
<th>Description/Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRTPS</td>
<td>Virtual</td>
<td>Partner project</td>
</tr>
<tr>
<td>PRTPRO</td>
<td>Virtual</td>
<td>Partner WBS element</td>
</tr>
<tr>
<td>PRTPZ</td>
<td>Virtual</td>
<td>Partner business process</td>
</tr>
<tr>
<td>PRTKT</td>
<td>Virtual</td>
<td>Partner cost object</td>
</tr>
</tbody>
</table>
### Characteristics In Overhead Cost Controlling

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Virtual/True</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PKSTL</td>
<td>Virtual</td>
<td>Partner cost center</td>
</tr>
<tr>
<td>PAFNR</td>
<td>Virtual</td>
<td>Partner order number</td>
</tr>
<tr>
<td>PLSTR</td>
<td>Virtual</td>
<td>Partner activity type</td>
</tr>
<tr>
<td>PKSTL_BUE</td>
<td>Virtual</td>
<td>Partner cost center; technical characteristic for elimination of internal business volume, should not be used in the report definition</td>
</tr>
<tr>
<td>PAROB</td>
<td>True</td>
<td>Partner object (cost center KS, internal order OR and so on), suitable for report with drilldown with allocation partner, outputs all allocation partner categories, better performance than with PKSR, PAFNR</td>
</tr>
<tr>
<td>POBART</td>
<td>Virtual</td>
<td>Partner object type</td>
</tr>
<tr>
<td>PARGB</td>
<td>True</td>
<td>Partner object type</td>
</tr>
</tbody>
</table>

### Currency Characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Virtual/True</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TWAER</td>
<td>True</td>
<td>Transaction currency (see also: Reports With Currency Translation [Page 1135])</td>
</tr>
<tr>
<td>OWAER</td>
<td>Virtual</td>
<td>Object currency (see also: Reports With Currency Translation [Page 1135])</td>
</tr>
<tr>
<td>KWAER</td>
<td>True</td>
<td>Controlling area currency (see also: Reports With Currency Translation [Page 1135])</td>
</tr>
<tr>
<td>ZWAER</td>
<td>Virtual</td>
<td>Target currency (for currency translation in CO reports, not suitable as a characteristic for the selection screen) (see also: Reports With Currency Translation [Page 1135])</td>
</tr>
<tr>
<td>RWAER</td>
<td>Virtual</td>
<td>Report translation, not suitable as a characteristic for the selection screen (see also: Reports With Currency Translation [Page 1135])</td>
</tr>
</tbody>
</table>

### More Characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Virtual/True</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VALUTYP</td>
<td>True</td>
<td>Valuation [Ext.], the characteristic is only relevant if multiple valuation approaches are active in the client</td>
</tr>
<tr>
<td>KSTAR</td>
<td>True</td>
<td>Key that uniquely identifies a cost element [Page 110]</td>
</tr>
<tr>
<td>PERBL</td>
<td>True</td>
<td>Period [Page 1130], mandatory field for totals record reports and plan line item reports, you usually use the PERBL characteristic in Report Writer reports</td>
</tr>
<tr>
<td>GJAHR</td>
<td>True</td>
<td>Fiscal year</td>
</tr>
<tr>
<td>WRTTP</td>
<td>True</td>
<td>Value type [Page 1131], indicator for distinguishing different value categories (such as actual costs [Ext.], plan costs [Ext.], target costs [Ext.] and so on) in database tables.</td>
</tr>
</tbody>
</table>
### Characteristics In Overhead Cost Controlling

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VERSN</td>
<td>True</td>
<td>Version, mandatory field, controlling-area based collection of year-dependent indicators for plan data, such as for the delta version, version lock, integrated planning, copying allowed, iterative activity price, average prices, exchange rate type, and value date</td>
</tr>
<tr>
<td>BELKZ</td>
<td>Virtual</td>
<td>CO debit/credit indicator [Page 1125]</td>
</tr>
<tr>
<td>VRGNG</td>
<td>True</td>
<td>Business transaction</td>
</tr>
<tr>
<td>BUEKZ</td>
<td>True</td>
<td>Internal business volume indicator [Page 1132] (cost centers), can be defined in the report with this indicator, or be activated in the variation settings</td>
</tr>
<tr>
<td>RESCR</td>
<td>Virtual</td>
<td>Resources [Page 174]</td>
</tr>
<tr>
<td>RESP_FLAG</td>
<td>True</td>
<td>Importing data for the responsible cost center [Page 1128]</td>
</tr>
<tr>
<td>OBART</td>
<td>Virtual</td>
<td>Object type</td>
</tr>
<tr>
<td>BELNR</td>
<td>True</td>
<td>Document number for an accounting document, only for line item reports</td>
</tr>
<tr>
<td>BEKTNZ</td>
<td>True</td>
<td>Debit/credit indicator [Page 1125]</td>
</tr>
<tr>
<td>PERIO</td>
<td>True</td>
<td>Period [Page 1130] (line items), for line items in actual data only</td>
</tr>
<tr>
<td>BUZEI</td>
<td>True</td>
<td>Posting row, for line item reports only</td>
</tr>
<tr>
<td>USPOB</td>
<td>True</td>
<td>Source object</td>
</tr>
<tr>
<td>ABKAT</td>
<td>True</td>
<td>Category variance/accrual calculation</td>
</tr>
<tr>
<td>AWKUS</td>
<td>True</td>
<td>Variances, costs exceeded/underused</td>
</tr>
<tr>
<td>ZLNID</td>
<td>True</td>
<td>Row identification</td>
</tr>
<tr>
<td>MEINH</td>
<td>True</td>
<td>Unit of measure</td>
</tr>
<tr>
<td>MEINB</td>
<td>True</td>
<td>Posted unit of measure</td>
</tr>
<tr>
<td>MSEHI</td>
<td>True</td>
<td>Unit of measure, statistical key figure</td>
</tr>
<tr>
<td>AUSEH</td>
<td>True</td>
<td>Output unit</td>
</tr>
<tr>
<td>LEINH</td>
<td>True</td>
<td>Activity unit</td>
</tr>
<tr>
<td>KATYP</td>
<td>Virtual</td>
<td>Cost element category</td>
</tr>
<tr>
<td>EIGEN</td>
<td>Virtual</td>
<td>Cost element characteristic</td>
</tr>
<tr>
<td>GBRKE</td>
<td>Virtual</td>
<td>Ranking order, external value added (CO-ABC)</td>
</tr>
<tr>
<td>GBRKI</td>
<td>Virtual</td>
<td>Ranking order, internal value added (CO-ABC)</td>
</tr>
<tr>
<td>GBART</td>
<td>Virtual</td>
<td>Process characteristic: Category</td>
</tr>
<tr>
<td>DRVTP</td>
<td>Virtual</td>
<td>Process characteristic: Cost behavior (CO-ABC)</td>
</tr>
</tbody>
</table>
### Characteristics In Overhead Cost Controlling

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GBAT</td>
<td>Virtual</td>
<td>Process characteristic: Additional characteristic (CO-ABC)</td>
</tr>
<tr>
<td>PRZNR</td>
<td>True</td>
<td>Business processes</td>
</tr>
<tr>
<td>KSTRG</td>
<td>True</td>
<td>Cost object</td>
</tr>
<tr>
<td>ATTRI</td>
<td>Virtual</td>
<td>Characteristics, processes/activities in CO</td>
</tr>
<tr>
<td>ROLLUP</td>
<td>True</td>
<td>Summarization</td>
</tr>
<tr>
<td>VKOSTL</td>
<td>True</td>
<td>Summarization area</td>
</tr>
<tr>
<td>VRGKZ</td>
<td>True</td>
<td>Business transaction indicator: Business transaction for this version</td>
</tr>
<tr>
<td>BUKRS</td>
<td>Virtual</td>
<td>Company Code</td>
</tr>
<tr>
<td>GSBER</td>
<td>True</td>
<td>Business area</td>
</tr>
<tr>
<td>SCOPE</td>
<td>Virtual</td>
<td>Object class [Ext.]</td>
</tr>
<tr>
<td>TRGKZ</td>
<td>Virtual</td>
<td>Main program indicator</td>
</tr>
<tr>
<td>VORNR</td>
<td>True</td>
<td>Network activity number</td>
</tr>
<tr>
<td>VERKZ</td>
<td>Virtual</td>
<td>Indicator for input side/allocation side</td>
</tr>
<tr>
<td>HRKFT</td>
<td>Virtual</td>
<td>Origin group as part of the cost element</td>
</tr>
</tbody>
</table>

### Characteristics in the RWCOOM reporting table

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>True/Virtual</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KOKRS</td>
<td>True</td>
<td>Key that uniquely identifies a controlling area. The controlling area represents the highest organizational unit in Controlling. Mandatory field that you can use only in general selections, single value possible only</td>
</tr>
</tbody>
</table>

#### Account Assignment Objects

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KOSTL</td>
<td>True</td>
<td>Key that uniquely identifies a cost center [Page 127]</td>
</tr>
<tr>
<td>STAGR</td>
<td>True</td>
<td>Key that uniquely identifies a statistical key figure [Page 163]</td>
</tr>
<tr>
<td>ELEMT</td>
<td>Virtual</td>
<td>Element number in the cost component split</td>
</tr>
<tr>
<td>AUFNR</td>
<td>True</td>
<td>Order number [Ext.]</td>
</tr>
<tr>
<td>PRZNR</td>
<td>True</td>
<td>Business processes</td>
</tr>
<tr>
<td>KSTRG</td>
<td>True</td>
<td>Cost object</td>
</tr>
<tr>
<td>POSID</td>
<td>True</td>
<td>Work breakdown structure element (WBS element)</td>
</tr>
<tr>
<td>LSTAR</td>
<td>True</td>
<td>Key that uniquely identifies an activity type [Page 147]</td>
</tr>
</tbody>
</table>
### Partner Objects

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>POBART</td>
<td>Virtual</td>
<td>Partner object type</td>
</tr>
</tbody>
</table>

### Currency Characteristics

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WAERS</td>
<td>Virtual</td>
<td>Currency keys</td>
</tr>
<tr>
<td>CURTYPE</td>
<td>True</td>
<td>Currency type (controlling area, transaction, object, or report currency)</td>
</tr>
</tbody>
</table>

### More Characteristics

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GJAHR</td>
<td>True</td>
<td>Fiscal year</td>
</tr>
<tr>
<td>PERIO</td>
<td>True</td>
<td>Period [Page 1130] (for totals records)</td>
</tr>
<tr>
<td>FISCPER</td>
<td>Virtual</td>
<td>Fiscal year/period [Page 1130]</td>
</tr>
<tr>
<td>KSTAR</td>
<td>True</td>
<td>Key that uniquely identifies a cost element [Page 110].</td>
</tr>
<tr>
<td>WRTTP</td>
<td>True</td>
<td>Value type [Page 1131], indicator for distinguishing different value types (such as actual costs [Ext.], plan costs [Ext.], target costs [Ext.] and so on) in database tables.</td>
</tr>
<tr>
<td>VERSN</td>
<td>True</td>
<td>Version, mandatory field, controlling-area based collection of year-dependent indicators for plan data, such as for the delta version, version lock, integrated planning, copying allowed, iterative activity price, average prices, exchange rate type, and value date</td>
</tr>
<tr>
<td>VALUTYP</td>
<td>True</td>
<td>Valuation [Ext.], the characteristic can only be used on the selection screen if multiple valuation approaches are active in the client</td>
</tr>
<tr>
<td>BELKZ</td>
<td>Virtual</td>
<td>Debit/credit indicator [Page 1125]</td>
</tr>
<tr>
<td>TARKZ</td>
<td>True</td>
<td>Price indicator</td>
</tr>
<tr>
<td>AKBAT</td>
<td>True</td>
<td>Category variance/accrual calculation</td>
</tr>
<tr>
<td>GBRKE</td>
<td>Virtual</td>
<td>Ranking order, external value added (CO-ABC)</td>
</tr>
<tr>
<td>GBRKI</td>
<td>Virtual</td>
<td>Ranking order, internal value added (CO-ABC)</td>
</tr>
<tr>
<td>GBART</td>
<td>Virtual</td>
<td>Process characteristic: Category</td>
</tr>
<tr>
<td>DRVTP</td>
<td>Virtual</td>
<td>Process characteristic: Cost behavior (CO-ABC)</td>
</tr>
<tr>
<td>AUSEH</td>
<td>True</td>
<td>Output unit</td>
</tr>
<tr>
<td>LEINH</td>
<td>True</td>
<td>Activity unit</td>
</tr>
<tr>
<td>PANLKL</td>
<td>Virtual</td>
<td>Settlement receiver: Asset class/asset under construction</td>
</tr>
<tr>
<td>PANLNR</td>
<td>Virtual</td>
<td>Settlement receiver: Asset class/asset under construction</td>
</tr>
</tbody>
</table>
### Characteristics In Overhead Cost Controlling

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAIBKZ</td>
<td>Virtual</td>
<td>Settlement receiver: AuC indicator for investment measure</td>
</tr>
<tr>
<td>MEINH</td>
<td>True</td>
<td>Unit of measure</td>
</tr>
</tbody>
</table>
Debit/Credit Indicator (BELKZ <-> BEKNZ)

Definition
Indicator that shows the view of the sender/receiver relationships between CO objects.

Use

BELKZ
This characteristic is used to distinguish debit and credit postings in Controlling. The SAP R/3 System always interprets primary postings, reversals in FI, and activity-related and periodic postings in CO as debit postings (debits or adjustment postings of debits). In the case of secondary postings, the sender keeps a credit posting for the sender and a debit posting for the receiver.

The characteristic BELKZ is a virtual characteristic that is not entered in the database tables but is determined by the system at runtime. The following results are possible:

- S - Cost allocation debit of receiver
- H - Cost allocation credit of sender
- A - Credit via settlement
- L - Credit from delivery to warehouse

"A" and "L" are only used with internal orders.

BEKNZ
This characteristic represents the debit/credit indicator that is entered by the posting transactions of the posting records. It has a related meaning in Financial Accounting: in the case of reversals in FI and repostings in CO, the use of this characteristic causes the postings and the related primary postings to be displayed in special lines in reporting rather than being added together in one line. The following characteristics are possible:

- S - Debit
- H - Credit
- A - Credit via settlement
- L - Credit from delivery to warehouse

To obtain a correct view of the sender/receiver relationships in self-defined reports that arrange the line items per credit/debit indicator, you should use BELKZ as you would in standard reports. If you want a debit/credit view as in FI, you can use BEKNZ.

See also:
Examples of BELKZ and BEKNZ [Page 1126]
Examples of BELKZ and BEKNZ

1. External Posting

For an expense that was posted in FI and that has an account assignment for cost center EXAMPLE 1, the system sets the debit/credit indicator BEKNZ to S. This value is used for virtual characteristic BLEKZ.

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>EXAMPLE1</td>
<td>COIN</td>
<td>A</td>
<td>A</td>
<td>100 USD</td>
</tr>
</tbody>
</table>

2. Reversal in FI

If you reverse the posting in example 1, the system creates an additional CO posting record with debit/credit indicator BEKNZ = H.

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record from Ex. 1</td>
<td>EXAMPLE1</td>
<td>COIN</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Reversal</td>
<td>EXAMPLE2</td>
<td>COIN</td>
<td>Cr</td>
<td>A</td>
</tr>
</tbody>
</table>

In this example, no costs were incurred by the cost center. The SAP R/3 system does not show a credit or a debit for the cost center is the reports when using BELKZ. The postings balance to zero. If, however, you use BEKNZ, the system displays a debit of 100 USD and a credit of 100 USD in the report.

3. Reposting

If the posting in example 1 was assigned to the wrong cost center and repost this amount with an adjustment posting to debit cost center EXAMPLE2, you get the following result:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record from Ex. 1</td>
<td>EXAMPLE1</td>
<td>COIN</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Reposting</td>
<td>EXAMPLE1</td>
<td>RKU1</td>
<td>Cr</td>
<td>A</td>
</tr>
<tr>
<td>Reposting</td>
<td>EXAMPLE2</td>
<td>RKU1</td>
<td>A</td>
<td>A</td>
</tr>
</tbody>
</table>

Here as well, no debit is shown if you use BELKZ, since the system treats a reposting in a manner similar to a reversal used to make an adjustment to an incorrect primary posting.

4. Activity allocation

If you allocate the amount in example 1 using an activity allocation with order 12345678, you obtain the following values:
## Examples of BELKZ and BEKNZ

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record from Ex. 1</td>
<td>EXAMPLE1</td>
<td>COIN</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Activity allocation</td>
<td>EXAMPLE1</td>
<td>RKL</td>
<td>Cr</td>
<td>Cr</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Order</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity allocation</td>
<td>12345678</td>
<td>RKL</td>
<td>A</td>
<td>A</td>
</tr>
</tbody>
</table>

In this example (secondary posting), there is no difference between using BELKZ and BEKNZ. Cost center EXAMPLE1 is marked by BELKZ = H as the sender, the order by BEKNZ as the receiver. In either case, the system displays the primary posting to cost center EXAMPLE1 and the posting record the debits this cost center separately in the report.

### 5. Order settlement

If you settle the order from example 4 with cost center EXAMPLE2, the system updates the following data:

<table>
<thead>
<tr>
<th>Order</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record from Ex. 4</td>
<td>12345678</td>
<td>RKL</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Order settlement</td>
<td>12345678</td>
<td>KOAO</td>
<td>S</td>
<td>S</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Business transaction</th>
<th>BEKNZ</th>
<th>BELKZ</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order settlement</td>
<td>EXAMPLE2</td>
<td>KOAO</td>
<td>A</td>
<td>A</td>
</tr>
</tbody>
</table>

To obtain a correct view of the sender/receiver relationships in self-defined reports that arrange the line items per credit/debit indicator, you should use BELKZ as you would in standard reports. If you want a debit/credit view as in FI, you can use BEKNZ.
Responsible Cost Center (RESP-FLAG)

Definition
Indicator that enables you to define reports for responsibility areas.

Use
If you use this characteristic in the general selection criteria of a cost center report, then the system also selects certain transaction data for the orders and WBS elements. This is the transaction data in whose master data the cost centers used in the report are entered as the responsible cost center.

By simultaneously using the OBART characteristic (object type), you can control which object types in the report are to provide data.

You use the following characteristics combinations for a report:

<table>
<thead>
<tr>
<th>Cost center (KOSTL)</th>
<th>4711</th>
</tr>
</thead>
<tbody>
<tr>
<td>Responsible cost center (RESP_FLAG)</td>
<td>Active</td>
</tr>
<tr>
<td>Object type (OBART)</td>
<td>KS, KL, OR</td>
</tr>
</tbody>
</table>

The report displays the data that was posted to cost center 4711 as well as on the orders, in whose master data this cost center is entered as the responsible cost center.

You use the following characteristics combinations for a report:

<table>
<thead>
<tr>
<th>Cost center (KOSTL)</th>
<th>4711</th>
</tr>
</thead>
<tbody>
<tr>
<td>Responsible cost center (RESP_FLAG)</td>
<td>Active</td>
</tr>
<tr>
<td>Object type (OBART)</td>
<td>PR</td>
</tr>
</tbody>
</table>

The report displays the data that was posted on WBS elements, in whose master data this cost center is entered as the responsible cost center.

Report group 1SOP contains reports with the RESP_FLAG characteristic.
Period (PERIO/PERBL/FISCPER)

Definition
Characteristics for specifying the reporting period.

Use the PERIO and PERBL characteristics in the report definition as follows:

In actual line item reports: PERIO
In plan line items and totals record reports: PERBL

The characteristics are distributed to the reporting tables as follows:

<table>
<thead>
<tr>
<th>Reporting Table</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCSS</td>
<td>PERIO, PERBL</td>
</tr>
<tr>
<td>RWCOOM</td>
<td>PERIO, FISCPER</td>
</tr>
</tbody>
</table>

The PERIO characteristic in the RWCOOM reporting table corresponds to PERBL in CCSS.
The FISCPER characteristic is a summary of the PERIO and GJAHR characteristics.

FISCPER enables you to define reports that are cross-fiscal year.

If you use the PERIO characteristic to specify periods four to six, and the GJAHR characteristic to specify the fiscal years 1999 to 2000, then the system selects values for your report in the following periods of time:

Four to six, 1999 and
Four to six, 2000

If you use the FISCPER to specify 004.1999 to 006.2000, then the system selects the values for your report in the following period of time:

004.1999 to 006.2000

The selection also contains all periods between 007.1999 and 003.2000.
The report group 1SRJ contains reports that have the FISCPER characteristic.
Value Type (WRTTP)

Definition

Characteristic for specifying the value categories displayed in the report. The most important value types for the Overhead Cost Controlling reports are:

- Plan (true postings)
- Statistical plan (such as statistical additional account assignment, or statistical orders)
- Actual (true postings)
- Statistical actual
- Down payments as expenses
- Debit
- Budget
- Commitment from purchase requisition
- Commitment from purchase order
- Commitment from reservation
Elimination Of Internal Business Volume (BUEKZ)

Definition
This characteristic controls whether the costs from sender / receiver relationships between cost centers within a cost center group are displayed in the report. These costs are the internal business volume.

If you use internal orders to make indirect allocations between two cost centers, then internal business volume is also created.

Use
You can use this characteristic to eliminate costs that flow between the cost centers in a group in the report.

You can use the characteristic in the general selections as well as the rows and columns of a report.

If you use the characteristic in the general selections then this affects the entire report.

If you use the characteristic in the rows or columns, then elimination of internal business volume is only active in the rows or columns.

The SAP R/3 System provides you with a field that you can either activate or deactivate.

If the indicator is active then the corresponding report displays only the debits and credits, so the internal business volume that is/was created as a result of the allocations.

If the indicator is inactive (default value), the report does not display the debits and credits, the internal business volume is eliminated.

See also: Activate Elimination Of Internal Business Volume [Page 1084]

You can define a report with the following columns:

<table>
<thead>
<tr>
<th>Total costs</th>
<th>Net costs (without internal business volume)</th>
<th>Internal business volume</th>
</tr>
</thead>
</table>

Total costs = Net costs + Internal business volume
Net costs = Total costs - Internal business volume
BUEKZ = 'X'
Internal Business Volume = Total costs - Net costs
BUEKZ = ' '
Possible Combinations Of Characteristics/Key Figures

Use

When defining your own reports, note that you cannot use all combinations of characteristics and key figures.

The following table contains the key figure/characteristic combinations that are used most:

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Key Figure</th>
<th>Costs</th>
<th>Quantities</th>
<th>Activity quantities</th>
<th>Statistical quantities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account assignment objects (KOSTL, AUFNR, OBJNR, PSPID, POSID, ELEM, PRZNR, KSTRG)</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Cost element (KSTAR)</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Statistical key figure (STAGR)</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Activity type (LSTAR)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Partner objects (PAROB, USPOB, and so on)</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>Debit/credit indicator (BELKZ, BEKNZ)</td>
<td>X</td>
<td>X</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>
Special Features In The Definition Of Cost Element Reports For Projects

**Use**
Defining project reports requires several special settings.

Define project reports using the OBJNR characteristic, not PSPID or POSID.

When you define a project report, use the group variable for the OBJNR characteristic (such as, 6-OBJNR) in the general selections or in the report rows. Project reports defined in this way automatically receive a selection screen. This screen is extended with the logical database functions for projects (such as, dynamic selections, database profiles, and so on).

When you run a project report, the system selects the project hierarchy via the logical database for the project system. It then transfers this to the group variable for the OBJNR characteristic used in the report. Therefore, the system does not create an entry field in the selection screen for this variable.

To be able to go from a project report to the corresponding line items, you need to include the RKPEP000 report in the report-report interface for the corresponding project report.

You can also display actual line items for WBS elements. Choose the CJ62 transaction for this. The system provides you with all the functions of the line item report.

**Prerequisites**
You need to enter "PS" in the library used, under **Header -> Component ID**. You can use this library (for example, GP3) for project reports.

You can also activate the OBJNR characteristic in the library used.

**Result**
When you run a project report, the system selects the project hierarchy via the logical database for the project system. It then transfers this to the group variable for the OBJNR characteristic used in the report. Therefore, the system does not create an entry field in the selection screen for this variable.
Reports With Currency Translation

Use

In reporting for Overhead Cost Controlling (Cost Center Accounting, internal orders, business processes) you can display values in any currency as well as values in controlling area currency, transaction currency, or object currency. This particularly applies in the double currency phase for the European currency union. In this phase, you need to be able to display values in the Euro currency (as a freely selected currency) as well as the controlling area or object currencies in reports.

You can use the following options for defining or displaying reports in Overhead Cost Controlling, in a freely selected currency:

Set up currency translation interactively in the selection screen, and in the output list for the Report Writer or Report Painter reports.

You can define a currency translation in the selection screen for reports. If other translations were defined using the options below, the system executes this translation as well. This means that the system may execute two currency translations. Once the report has run, you can change or deactivate the settings for the currency translation interactively.

Reports with target currency entry on the selection screen

For customer-defined reports, the key figure Costs in target currency is provided in the Report Painter for column definitions. If you use this key figure during report definition in a column, then the following additional parameters appear in the selection screen for the report: Target currency, exchange rate date, and exchange rate type, for example, in the report for Cost Centers: Currency Translation (1S3W).

To do so, go to the SAP Easy Access menu, and choose Accounting -> Controlling -> Cost Center Accounting -> Information system -> Report selection -> More reports -> Cost Centers: Currency Translation.

To insert the target currency, the exchange rate date, or the exchange rate in the report texts, use a text variable from the selection criteria category.

SAP provides the following Report Painter standard reports. You can load this from the SAPServ as an alternative to the most important standard reports for cost centers and internal orders (available in the languages of the European currency union) in a variant that enables you to translate into any currency required.

Cost center reports (Library 1EU)

1EAI  Area: Cost Elements
1EGJ  Cost Centers: Fiscal Year Comparison
1EHK  Cost Centers: Drilldown by Partner
1EIP  Cost Centers: Actual/Plan/Variance
1EKL  Area: Cost Centers
1ELK  Cost Centers: Curr. Per. / Cumulated
1EOB  Cost Centers: Actual/Plan/Commitments
1EOL  Area: Actual/Plan/Commitments
Global settings for report currency

From Release 4.0, you can enter user-dependent settings for the report currency. This is for all reports that use the basic key figure (costs in report currency) SWKG. To do so, choose Cost Center Accounting -> Information system -> User settings -> Report currency.

You can specify any target currency, source currency (= reference currency, such as controlling area currency), and an exchange rate date and exchange rate type.

You can also make these settings for reports in the following applications:

- Internal Orders
- Business processes
- Overhead cost projects
- Reconciliation Ledger

Most of the standard reports provided by SAP use the SWKG key figure (costs in report currency).
Cost Center Summarizations

Use

Cost center summarization [Ext.] enables you to condense transaction data [Ext.] on the cost center group level in the Cost Center Accounting component (CO-OM-CCA). The system updates the summarized data of a cost center group in its own data record in the summarization table.

You can access this data in the information system. This improves performance in the Information system.

When you execute summarization, the SAP System progresses from the lowest hierarchy area in a cost center group to the highest. For technical reasons, you must assign a representative cost center to every group node during master data maintenance (see: Representative Cost Centers [Page 128]).

Summarization provides the Report-Painter [Ext.] reports with totals records. This has the advantage of making the report runtime significantly shorter, depending on the degree of summarization, than with use of the totals records from the subordinate cost centers.

To evaluate the summarization data, you must create custom reports. The system includes sample reports in the 1RU library [Ext.]

Implementation Considerations

You should consider carefully whether to generate an extract [Ext.] of the report data or execute a summarization. Summarizations generate a far greater amount of data than extract generation does (see Executing Report Painter Reports [Page 301]).

If you need few reports, we recommend you periodically save the reports in background for the entire cost center hierarchy and access the extracts afterwards online (see Variation [Page 1082]). This spares you the repeated definition of new summarization reports.

You use summarization if you wish to access a large number of reports (including those defined spontaneously) within the entire the cost center hierarchy.

Features

You create summarizations during Customizing in the Implementation Guide (IMG) for the highest group node of a cost center group. This can be the highest group node of:

- The standard hierarchy
- An alternative hierarchy

Summarization carried out within the application framework can also be used:

- For as many subareas of the hierarchy as desired
- For individual periods

In both cases, note during the evaluations afterward that data with differing degrees of relevance is included within a summarization.

Several forms of summarization are possible:

- Normal summarization applies to the object information, meaning the system replaces the cost center in the totals records with the representative cost center given for the cost center
Cost Center Summarizations

The degree of summarization depends on the data constellation, in particular that of the secondary allocations.

You can achieve a much higher degree of summarization by ignoring selected data. If, for example, you wish to generate the cost structure for the entire corporation in strategic reporting, you can leave out information on partner updating. This results in far faster runtimes for the evaluations.
Executing Cost Center Summarization

1. Create a representative cost center [Ext.] for every node of the cost center group you wish to summarize [Ext.], if these do not yet exist (see: Representative Cost Centers [Page 128]).

2. In cost center group maintenance or in the standard hierarchy, enter the representative cost center in the reporting information. To do so, choose Master data → Cost center group → Create or Change in the cost center group menu. Choose Extras → Report Information in the structure screen then enter the summarization cost center in the Report information dialog box under Repres. cost center.

   Report information maintenance does not verify whether the cost center exists in the controlling area [Ext.] or not.

3. For each hierarchy you define a summarization. When doing so, you must determine the highest group node and the criteria according to which the cost center transaction data is summarized:
   a) Cost center group
      You always create the summarization for the highest node of a cost center group.
   b) Further settings
      You determine whether to:
      i) Summarize costs, activity types [Ext.], and/or statistical key figures [Ext.]
      ii) Process quantities and/or whether sender cost centers are summarized in stages
      iii) Delete the data from the summarization cost center completely, or whether to reset it by period.

   You maintain summarization in the Implementation Guide (IMG). For more information, see the IMG for the Cost Center Accounting component (CO-OM-CCA) under Information System → Maintaining Summarization [Ext.]

   You can also choose Extras → Summarization in the initial Execute Summarization screen to go to the Summarization initial screen.

   Choose Check to determine whether the R/3 System created and saved the summarization correctly for the period in question.

4. You carry out summarization in the Cost Center Accounting component. Choose Information system → Tools → Summarization and enter the summarization.

   Summarization applies to a cost center group for given periods within a fiscal year.

   You can start summarization online or in a background job.
Executing Cost Center Summarization
Cross-Application Topics (CO-OM)

Use

There follows a collection of topics that apply to Cost Center Accounting, but which are described in the SAP Library as cross-application topics or in other components.
Validation and Substitution

Use

You can validate or substitute data directly at the input stage. You make the settings for validation [Ext.] and substitution [Ext.] in the Implementation Guide (IMG) for Controlling, under Controlling General → Account Assignment Logic → Define Validation [Ext.] or Define Substitution [Ext.].

Substitution and validation are only intended for actual postings. The SAP System cannot convert substitutions or validation rules completely for the following CO-internal business transactions:

- order settlement
- Assessment, distribution, periodic reposting, indirect activity allocation
- Target=Actual Activity Allocation
- Variance Calculation
- Overheads and accrual calculation
- Confirmation

The system can only substitute the fields from the CI_COBL include structure (customer enhancement: account assignment block) and COBK-BLTXT (document text). All remaining fields that are available for substitution maintenance can only be substituted for the following manual CO-internal postings:

- Repost Costs
- Repost Revenues
- Reposting line items
- Activity allocation
- Indirect activity
- Non-allocable activities
- Statistical key figures:

  Substitution of fields from cycle rules or settlement rules causes data inconsistencies.

For a complete description of validation and substitution, see the SAP Library under Accounting - FI Financial Accounting → Special ledger → Tools → Validation and Substitution Rules [Ext.].
Archiving

Use

In Cost Center Accounting you can archive transaction data with the relevant cost center accounting master data.

You carry out the archiving [Ext.] in the Cost Center Accounting menu, under Environment → Archiving.

For a detailed description of archiving, see the SAP Library, under CA - Cross-Application Components → General Application Functions → CA - Archiving and Deletion of Application Data in the section CO - Controlling (Cost Center Accounting (CO-OM-CCA) [Ext.]).

You can use Report Painter reports and line item reports from Cost Center Accounting (CO-OM-CCA) to evaluate archives. For more information, see Reading Standard Reports From the Archive [Page 911].
Application Link Enabling (ALE)

Use

If you want to work in Cost Center Accounting with distributed systems (ALE [Ext.]), there are two distribution methods available:

- Distribution method 1 (centralized Cost Center Accounting)
- Distribution method 2 (decentralized Cost Center Accounting)

For a more detailed description, see the SAP Library, under CA - Cross-Application Components → Business Framework Architecture → Application Link Enabling (CFA-BFA-ALE) → Library of ALE Business Processes → Accounting → Accounting <-> Accounting → ALE in Overhead cost Controlling (CO-OM) → Cost Center Accounting [Ext.].
Changeover to the Euro

Use

For information on how to carry out the changeover to the euro, see: European Monetary Union: Euro (CA-EUR) [Ext.] and the Implementation Guide (IMG) under European Monetary Union: Euro [Ext.]

For information on the changeover to the euro in cost center accounting, see

- Preparation in Overhead Cost Controlling (CO-OM)
  - Archive [Ext.]
  - Set Cutoff Period [Ext.]
  - Reconcile Settlement (RKAABR01) [Ext.]
  - Generate Reconciliation Ledger Report [Ext.]
- Changeover in Overhead Cost Controlling (CO-OM) [Ext.]
- Carry Out Cleanup in Overhead Cost Controlling (CO-OM) [Ext.]