Profitability Analysis (COPA)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
## Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔄</td>
<td>Caution</td>
</tr>
<tr>
<td>📜</td>
<td>Example</td>
</tr>
<tr>
<td>🔴</td>
<td>Note</td>
</tr>
<tr>
<td>🚨</td>
<td>Recommendation</td>
</tr>
<tr>
<td>💾</td>
<td>Syntax</td>
</tr>
</tbody>
</table>
### Inhalt

**Profitability Analysis (COPA)**................................................................. 9  
**Profitability Accounting Applications**.................................................. 12  
**Accounting Methods**........................................................................... 13  
**Features of the Applications COPA and ECPCA**................................... 15  
**Structures**............................................................................................. 16  
**Operating Concern**................................................................................ 18  
  - Characteristics ......................................................................................... 20  
  - Value Fields ............................................................................................ 25  
  - Setting the Operating Concern ................................................................. 27  
  - Assigning the Operating Concern ............................................................ 28  
**Operating Concern Templates**............................................................... 29  
**Database Tables for CO-PA Transaction Data**........................................ 31  
**Storing Multiple Currencies in CO-PA**................................................... 37  
**Master Data** ......................................................................................... 39  
**Characteristic Derivation**..................................................................... 41  
  - Derivation Types .................................................................................... 44  
  - Examples: Derivation Types ................................................................. 48  
  - Special Case: Table Lookup in Table VBDK ....................................... 50  
  - Source and Target Fields ................................................................. 51  
  - Influencing the Standard Derivation Procedure ................................ 54  
  - Changing the Standard Derivation Steps ............................................ 56  
  - Activities Following Upgrades ......................................................... 59  
**Characteristics Hierarchy**..................................................................... 61  
**Realignment** ....................................................................................... 62  
  - Maintaining Realignments ................................................................. 65  
  - Status of Realignment Runs ................................................................. 70  
  - Sequence of Requests Within a Realignment Run ............................ 71  
  - Restoring Previous States Following Realignments ....................... 72  
  - Effects on Summarization Levels and Data ....................................... 73  
  - Performance, Parallel Processing, and Partitioning ....................... 74  
**Valuation** ............................................................................................. 76  
  - Valuation Using Material Cost Estimates ........................................... 79  
  - Example: Valuation Using Material Cost Estimates ......................... 83  
  - Representing Different Requirements ............................................... 86  
  - Setting Up Valuation Using Actual Cost Estimates from Material Ledger ... 88  
  - Valuation Using Conditions ............................................................... 90  
  - Example: Valuation Using Conditions ............................................. 94  
  - Condition Types .................................................................................... 96  
  - Examples: Condition Types .............................................................. 99  
  - Meeting Managerial Requirements ................................................... 104  
  - Customer Exits: Valuation ............................................................... 123  
  - Analysis Options Using Valuation .................................................... 124  
  - Activate Valuation in Planning .......................................................... 126  
  - Periodic Valuation of Actual Data ..................................................... 129
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Performing Periodic Valuation</td>
<td>130</td>
</tr>
<tr>
<td>Results of Periodic Valuation</td>
<td>131</td>
</tr>
<tr>
<td><strong>Planning</strong></td>
<td>132</td>
</tr>
<tr>
<td>Planning Framework</td>
<td>134</td>
</tr>
<tr>
<td>Example: Planning Framework</td>
<td>137</td>
</tr>
<tr>
<td>Adjustments Following Upgrades</td>
<td>138</td>
</tr>
<tr>
<td><strong>Setting Up Planning Content</strong></td>
<td>140</td>
</tr>
<tr>
<td>Multiple Currencies in Planning</td>
<td>143</td>
</tr>
<tr>
<td>Multiple Valuation Views in Planning</td>
<td>145</td>
</tr>
<tr>
<td>Working with Prices in Planning</td>
<td>146</td>
</tr>
<tr>
<td><strong>Planning Methods</strong></td>
<td>147</td>
</tr>
<tr>
<td>Entering/Displaying Planning Data</td>
<td>149</td>
</tr>
<tr>
<td>Setting Up Manual Entry of Planning Data</td>
<td>150</td>
</tr>
<tr>
<td>Planning Layout</td>
<td>152</td>
</tr>
<tr>
<td>Transaction-Based Top-Down Distribution</td>
<td>155</td>
</tr>
<tr>
<td>Example: Transaction-Based Top-Down Distribution</td>
<td>157</td>
</tr>
<tr>
<td>Price Planning Using Ratios</td>
<td>159</td>
</tr>
<tr>
<td>Executing Manual Entry of Planning Data</td>
<td>160</td>
</tr>
<tr>
<td>Planning Methods</td>
<td>164</td>
</tr>
<tr>
<td>Valuation</td>
<td>165</td>
</tr>
<tr>
<td>Forecast</td>
<td>166</td>
</tr>
<tr>
<td>Revaluate</td>
<td>167</td>
</tr>
<tr>
<td>Events</td>
<td>168</td>
</tr>
<tr>
<td>Period Distribution</td>
<td>169</td>
</tr>
<tr>
<td>Ratios</td>
<td>170</td>
</tr>
<tr>
<td>Example: Valuating a Quantity Plan Using Ratios</td>
<td>172</td>
</tr>
<tr>
<td>Exits</td>
<td>174</td>
</tr>
<tr>
<td>Change Values</td>
<td>175</td>
</tr>
<tr>
<td>Goal Seek Function</td>
<td>176</td>
</tr>
<tr>
<td><strong>General Functions</strong></td>
<td>178</td>
</tr>
<tr>
<td>Format to Print</td>
<td>179</td>
</tr>
<tr>
<td>Cut</td>
<td>180</td>
</tr>
<tr>
<td>Copy</td>
<td>182</td>
</tr>
<tr>
<td>Paste</td>
<td>184</td>
</tr>
<tr>
<td>Insert</td>
<td>186</td>
</tr>
<tr>
<td>Long Text</td>
<td>187</td>
</tr>
<tr>
<td>Row Proposal</td>
<td>188</td>
</tr>
<tr>
<td>Clear Row, Undo, Redo</td>
<td>189</td>
</tr>
<tr>
<td>Overview Screen</td>
<td>190</td>
</tr>
<tr>
<td>Period Screen</td>
<td>191</td>
</tr>
<tr>
<td>Next Combination, Previous Combination, Other Combination</td>
<td>192</td>
</tr>
<tr>
<td>Line Item Display</td>
<td>193</td>
</tr>
<tr>
<td>Number Format</td>
<td>194</td>
</tr>
<tr>
<td>Lead Columns</td>
<td>195</td>
</tr>
<tr>
<td>All Key Values On/Off</td>
<td>197</td>
</tr>
<tr>
<td>Header Display On/Off</td>
<td>198</td>
</tr>
<tr>
<td>Function in the Information System</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Top-Down Distribution of Actual Data</td>
<td>308</td>
</tr>
<tr>
<td>Storing Actual Data in Multiple Currencies</td>
<td>318</td>
</tr>
<tr>
<td>Multiple Valuation Approaches/Transfer Prices in CO-PA</td>
<td>319</td>
</tr>
<tr>
<td>Manual Line Item Entry</td>
<td>305</td>
</tr>
<tr>
<td>Transferring Production Variances</td>
<td>301</td>
</tr>
<tr>
<td>Functions in the Information System</td>
<td>330</td>
</tr>
<tr>
<td>Information System</td>
<td>331</td>
</tr>
<tr>
<td>Analysis Types</td>
<td>332</td>
</tr>
<tr>
<td>Defining Profitability Reports</td>
<td>333</td>
</tr>
<tr>
<td>Line Item Lists</td>
<td>336</td>
</tr>
<tr>
<td>Data Selection for Line Item Lists</td>
<td>338</td>
</tr>
<tr>
<td>Performing Period-Based Allocation</td>
<td>296</td>
</tr>
<tr>
<td>Allocating Activities Directly</td>
<td>299</td>
</tr>
<tr>
<td>Multiple Currencies in the Information System</td>
<td>361</td>
</tr>
<tr>
<td>Authorization</td>
<td>368</td>
</tr>
<tr>
<td>Authorization Objects for the Information System</td>
<td>366</td>
</tr>
<tr>
<td>Characteristic Groups</td>
<td>347</td>
</tr>
<tr>
<td>Characteristics Hierarchy</td>
<td>348</td>
</tr>
<tr>
<td>SAP Example Profitability Reports</td>
<td>349</td>
</tr>
<tr>
<td>Executing Reports</td>
<td>351</td>
</tr>
<tr>
<td>Connection to inSight for SAP R/3</td>
<td>353</td>
</tr>
<tr>
<td>inSight for SAP R/3: Installation and Logging on</td>
<td>355</td>
</tr>
<tr>
<td>Drilldown Report in inSight</td>
<td>356</td>
</tr>
<tr>
<td>Data Update with Multiple Valuations</td>
<td>323</td>
</tr>
<tr>
<td>Example: Parallel Valuation of Stock Transfers and Billing</td>
<td>325</td>
</tr>
<tr>
<td>Defining Summarization Levels</td>
<td>373</td>
</tr>
<tr>
<td>Building Summarization Levels</td>
<td>375</td>
</tr>
<tr>
<td>Uses for Summarization Levels</td>
<td>377</td>
</tr>
</tbody>
</table>
Schedule Manager ..................................................................................................................... 380
Data Archiving .......................................................................................................................... 382
Distributed Profitability Analysis (CO-PA).............................................................................. 384
  Transaction-Based Distribution ......................................................................................... 387
  Periodic Rollup .................................................................................................................... 389
Transferring External Data ....................................................................................................... 390
  External Data Transfer ...................................................................................................... 391
  Performing an External Data Transfer ............................................................................. 392
  Evaluating Logs .................................................................................................................. 397
  Post Processing Incorrect Data Records ........................................................................ 401
  Using the Test Data Editor ............................................................................................... 402
IDoc Interface Between External Billing and Accounting with Update in CO-PA .............. 404
Checking the Flow of Billing Documents ............................................................................ 406
Checking Value Flows from Order/Project Settlement ....................................................... 409
Technical Aspects of Profitability Analysis .......................................................................... 412
  Index Support for Determination of Segment Numbers .................................................. 413
  How to Check Whether an Index Is Being Used ............................................................. 419
  Index Support for Drilldown Reports .............................................................................. 420
Physical Structure of the Data in COPA ............................................................................. 421
Physical Distribution of Data in CO-PA ............................................................................... 423
Profitability Analysis (CO-PA)

Purpose

Profitability Analysis (CO-PA) enables you to evaluate market segments, which can be classified according to products, customers, orders or any combination of these, or strategic business units, such as sales organizations or business areas, with respect to your company's profit or contribution margin.

The aim of the system is to provide your sales, marketing, product management and corporate planning departments with information to support internal accounting and decision-making.

Two forms of Profitability Analysis are supported: costing-based and account-based.

- Costing-based Profitability Analysis is the form of profitability analysis that groups costs and revenues according to value fields and costing-based valuation approaches, both of which you can define yourself. It guarantees you access at all times to a complete, short-term profitability report.

- Account-based Profitability Analysis is a form of profitability analysis organized in accounts and using an account-based valuation approach. The distinguishing characteristic of this form is its use of cost and revenue elements. It provides you with a profitability report that is permanently reconciled with financial accounting.

You can also use both of these types of CO-PA simultaneously.

Integration

Profitability Analysis, alongside Profit Center Accounting (EC-PCA), is one of the application components for profitability accounting.
Features

In the application component CO-PA, you can define your master data, the basic structures of this form of profitability analysis. This includes both units you want to evaluate (characteristics) and the categories in which you analyze values. In costing-based CO-PA, you define “value fields” in which to store your data for analysis. In account-based CO-PA, the values are structured by account.

Using the SAP master data (customer, product, customer hierarchy) or CO-PA derivation rules, the system can derive additional characteristics based on the ones entered manually or transferred from primary transactions. The combination of characteristic values forms a multidimensional profitability segment, for which you can analyze profitability by comparing its costs and revenues.

If you reorganize parts of your company, such as your sales districts or customer hierarchies, you can change the assignments between characteristics for data that has already been posted.

The actual postings represent the most important source of information in CO-PA. You can transfer both sales orders and billing documents from the Sales and Distribution (SD) application component to CO-PA in realtime. In addition, an interface program is available to let you transfer external data to the R/3 System. You can also transfer costs from cost centers, orders and projects, as well as costs and revenues from direct postings (G/L account postings in FI, orders received in MM, and so on) or settle costs from CO to profitability segments.

In costing-based CO-PA, you can valuate incoming sales orders or billing documents to automatically determine anticipated sales deductions or costs. You can also revaluate your data periodically to adjust the initial, realtime valuation or add the actual costs of goods manufactured.

In CO-PA Planning, you can create a sales and profit plan. Whereas both types of Profitability Analysis can receive actual data in parallel, there is no common source of planning data. Consequently, you always plan either in accounts (account-based CO-PA) or in value fields (costing-based CO-PA). In costing-based CO-PA you can use automatic valuation to calculate planned revenues, sales deductions and costs of goods manufactured based on the planned sales quantity.

The manual planning function lets you define planning screens for your organization. With this you can display reference data in planning, calculate formulas, create forecasts, and more. Planning can be performed at any degree of detail. For example, you can plan at a higher level, and have this data distributed top-down automatically.

In automatic planning, you can copy and revaluate actual or planning data for a large number of profitability segments at once. You can also transfer planned sales quantities from (costing-based) CO-PA to Sales and Operations Planning (SOP) for the purpose of creating a production plan there.

The Information System lets you interactively analyze existing data from a profitability standpoint using the functions of the drilldown reporting tool. There you can navigate through a multidimensional “data cube” using a number of different functions (such as drilldown or switching hierarchies). The system displays data in either value fields or accounts, depending on the currently active type of Profitability Analysis and the type to which the report structure is assigned. (Each report structure is assigned to either costing-based or account-based CO-PA.)

You can change the display parameters online directly from the displayed report. You can store report structures with predefined sort orders, number formats and so on, and execute these online or in the background at any time.
Profitability Accounting Applications

The applications Profitability Analysis (CO-PA) and Profit Center Accounting (EC-PCA) provide effective tools for analyzing profitability in your organization. This section compares the different purposes of these two applications in the SAP System and describes the different methods of profitability control.

Profitability Analysis (CO-PA)

The application CO-PA lets you analyze the profitability of segments of your market - structured according to products, customers, orders, and summarizations of these and other characteristics - and organizational units such as company codes or business areas. The aim is to provide your sales, marketing, planning, and management organizations with decision-support from a market-oriented viewpoint.

CO-PA can be used by companies in any branch of industry (mechanical engineering, wholesale and retail, chemical, service industries and so on) and with any form of production (repetitive manufacturing, make-to-order manufacturing, process manufacturing). The data can be analyzed by period, or by order or project.

Profit Center Accounting (EC-PCA)

The application EC-PCA lets you analyze internal profit and loss for profit centers. This makes it possible for you to evaluate different areas or units within your company. You can structure profit centers according to region (branch offices, plants), function (production, sales), or product (product ranges, divisions). Profit Center Accounting is a component of the module Enterprise Controlling.

EC-PCA can be used by companies in any branch of industry (mechanical engineering, chemical, service industries and so on) and with any form of production (repetitive manufacturing, make-to-order manufacturing, process manufacturing). The profit-relevant data is displayed by period.

For more information, see Profit Center Accounting [Extern].
Accounting Methods

Profitability Analysis (CO-PA) calculates profits according to the cost-of-sales method of accounting. Profit Center Accounting (EC-PCA), on the other hand, supports both period accounting as well as the cost-of-sales approach.

You can use both of these applications—and consequently both methods—at the same time in your organization.

The CO-PA application itself offers two forms of Profitability Analysis: costing-based and account-based. You can also use both of these types of CO-PA simultaneously.

Profitability Analysis Using the Cost-of-Sales Method

In cost-of-sales accounting, the cost of sales is set off against revenue using either direct costing or full absorption methods (contribution margin accounting). Fixed costs can be allocated on a proportional basis or en bloc to any level(s) of a hierarchy. You can use standard costs to valuate the cost of sales for the purpose of obtaining a preliminary profit analysis. Or you can also transfer the variances of production orders and cost centers to Profitability Analysis in order to reconcile CO-PA with Financial Accounting (FI) on the basis of actual costs.

Costing-Based Profitability Analysis

This type of Profitability Analysis is primarily designed to let you analyze profit quickly for the purpose of sales management. Its main features are, firstly, the use of value fields to group cost and revenue elements, and, secondly, automatic calculation of anticipated or accrual data (valuation). The advantage of this method is that data is always up-to-date and therefore provides an effective instrument for controlling sales.
Accounting Methods

Account-Based Profitability Analysis

This type of Profitability Analysis enables you to reconcile cost and financial accounting at any time using accounts. In contrast to costing-based Profitability Analysis, this type uses cost and revenue elements, which gives you a unified structure for all of accounting.

The system posts all revenues and costs to both Financial Accounting and Profitability Analysis at the same time and using the same valuation method. This means that the cost of sales is posted to Profitability Analysis at the point of goods issue.

Account-Based Profit Center Accounting Using the Period Accounting Method

In period accounting, the performance of a particular business unit (profit center) - that is, its revenues, changes in inventory and capitalized services - is set off against the total costs of the period. This occurs at the G/L account level and adheres to the formal structure of Financial Accounting. This gives you a uniform structure of report data and lets you reconcile the data of cost and financial accounting on the basis of cost elements.
Features of the Applications CO-PA and EC-PCA

Profitability Analysis (CO-PA)

For detailed information about the scope of functions in Profitability Analysis, see the chapter on Profitability Analysis (CO-PA) [Extern].

Profit Center Accounting (EC-PCA)

EC-PCA lets you calculate internal operating results for profit centers. A profit center represents an organizational subunit that operates independently on the market and bears responsibility for its own costs and revenues. You organize your organization into profit centers by assigning the master data of each profit-relevant objects (materials, cost centers, orders, projects, sales orders, assets, cost objects, and profitability segments) to a profit center.

All the business transactions in the R/3 System which are relevant for costs and profits are updated in the profit centers at the same time they are processed in the original module, and organized according to cost and revenue elements. This transforms all the flows of goods and services within the company into exchanges of goods and services between profit centers. This profit center structure applies for both actual postings and profit center plan data.

It is also possible to treat a profit center as an investment center. In addition to the flows of goods and services, you can transfer selected balance sheet line items (fixed assets, payables and receivables, material stocks and work in process) to profit centers on a periodic basis. This makes it possible to calculate such key figures as profit on sales, return on investments and cash flow.

The information system provides you with functions for analyzing the posted plan and actual data. You can use the complete standard hierarchy or sub-hierarchies, end nodes or individual profit centers as your selection criteria. It is also possible to expand nodes within a report to display more detailed information. Because profits are displayed by G/L account, you can reconcile your data directly with Financial Accounting by cost element. You can work with the standard reports that are delivered with the R/3 System or write your own reports.
Structures

Purpose
To use Profitability Analysis (CO-PA), you have to create structures first. The possible valuation levels are determined in the creation of structures.

Features
To create the structures, you need to define the operating concern as well as the characteristics and value fields belonging to the operating concern.

From a technical point of view, you are actually creating different tables. To find out how these tables are related to each other, you can consult the section Database Tables for CO-PA Transaction Data.

Integration
The master data is closely linked to the structures in Profitability Analysis. Master data consists of the individual values that the characteristics and value fields can take. The combination of the latter specifies the valuation level. In other words, the combination of particular characteristic values forms the actual analysis object, called the profitability segment.

The following graphic illustrates how the different concepts relate to one another:
Characteristics | Values
---|---
Sales region | North
Product | Prod1
Product group | Electronics
Customer | Cust1
Cust. group | Wholesale
State | Illinois
Sales rep. | Miller

Value fields
- Revenues: 800
- Discounts: 100
- Cost of sales: 650
Operating Concern

Definition

An operating concern [Extern] represents an organizational unit in your company for which the sales market has a uniform structure. It is the valuation level for Profitability Analysis (CO-PA).

Structure

You structure an operating concern by selecting

- **Characteristics [Seite 20]**
  
  You should ask yourself at what level your analyses should be performed, such as the sales organization, region, product, or customer level.

- and **value fields [Seite 25]** (only in costing-based Profitability Analysis)
  
  You should ask yourself which values and key figures should be analyzed, such as revenues, sales deductions, costs, or quantities.

- as well as **G/L accounts** (only in account-based Profitability Analysis)

This structure may vary greatly from one company to the next. For example, the structure of total production costs in a manufacturing company differs from that in a wholesale or retail company. Consequently, you need to "model" CO-PA in Customizing by defining the characteristics and value fields that you want to analyze.

The system then generates the necessary database tables for CO-PA transaction data [Seite 31] and access programs based on how you defined your operating concern.
See also:

For information on the procedure for defining an operating concern, choose Structures → Define Operating Concern [Extern] in Customizing.

Characteristics for Profitability Segments

All the characteristics in the operating concern are used in the line item. However, you can restrict the characteristics for a profitability segment [Extern] that forms the basis for valuation. This is because it is unnecessary and impractical for a profitability segment to use characteristics that are almost always populated and each has a different value. You should deactivate such characteristics when creating a profitability segment. Otherwise the data volume of the profitability segments is too large and hampers system performance.

One characteristic that should not be used in profitability segments is the sales order in repetitive manufacturing.

You specify in Customizing which characteristics are to belong in which profitability segments. For more information about this function, see Define Profitability Segments Characteristics (Segment-Level Characteristics) [Extern].
Characteristics

Definition

Characteristics [Extern] are the criteria in Profitability Analysis (CO-PA) according to which you can analyze your operating results and perform differentiated sales and profit planning. The combination of the values for the characteristics in an operating concern is called a Profitability Segment [Extern].

Use

The characteristics you define are stored in a field catalog. Using the function Maintain operating concern, you can select characteristics from this field catalog to define your operating concerns.

Structure

The semantic meaning of a characteristic is determined by the data element to which it is assigned. The data element contains the texts that appear on the screen and in lists for the characteristic.

The technical attributes (data type, length of the values, and value set) of a characteristic are determined by the domain. The valid characteristic values determined in the value set by the data type and value length can also be specified explicitly in a check table. If a characteristic is assigned to a check table, it can only take on those values that are contained in the check table. You can assign texts to the values contained in the check table. These texts are displayed on the screen whenever you work with those values.

You can arrange the values for a characteristic hierarchically in a characteristics hierarchy [Seite 348].

Characteristics can be categorized according to how and when they are defined:
Standard Characteristics in the SAP System

- **Fixed characteristics**
  
  A number of fundamental characteristics are automatically predefined in every operating concern. These include the product number, company code, billing type, business area, sales order, customer, and the controlling area, to name but a few.

  In addition, each type of Profitability Analysis has its own fixed characteristics:
  
  - *Record type* (costing-based CO-PA)
  - *Cost element* (account-based CO-PA)

  You can display the fixed characteristics in Customizing. Choose *Data Structures* → *Operating Concern* → *Maintain Characteristics*. Then select the option *All characteristics* → *Display*, and then *Extras* → *Fixed fields*.

- **Predefined characteristics**
  
  In addition to the fixed characteristics, a number of other predefined characteristics are available in the field catalog. Such characteristics include *customer group*, *customer district*, and *country*, and they can be added to your operating concern if desired.

**Customer-Defined Characteristics**

In addition to these predefined characteristics, you can also define your own additional ones. You define these in the field catalog— independent of any client or operating concern —and can later add them to your operating concerns.
Characteristics

You create characteristics in Customizing under Structures → Operating Concern → Maintain Characteristics [Extern]. There are a number of ways to define characteristics. Moreover, the way you define a characteristic influences its attributes.

- **Adopting characteristics from SAP tables**

  You can define your operating concerns by using characteristics that already exist in other applications. For example, you can select fields from the tables for customer master records, material master records, and sales documents. You can also select the partner roles defined in the structure PAPARTNER in the Sales and Distribution (SD) application and use them as characteristics in Profitability Analysis.

  The table that you take a characteristic from is referred to as that characteristic’s origin table. Characteristics that you take from the SAP table are then derived automatically from the key fields in the SAP table. The system creates the necessary derivation steps automatically.

  > Your operating concern contains the characteristic **Customer district**, which comes from the sales data in customer master table KNVV. The key fields of this table are the customer number, sales organization, distribution channel, and division. When you make a posting that contains these four characteristics, the system automatically derives the correct customer district.

  For more detailed information about derivation of characteristics, see Characteristic Derivation [Seite 41].

  The characteristic inherits all the technical attributes of the field in the origin table, including all the valid values that exist for that characteristic. These values are stored in a “check table” or in the corresponding domain. In Profitability Analysis, the characteristic can only take on values from this value set. In most cases, texts also already exist for a characteristic with a defined value set.

  You can use the function “Transfer Fields from SAP Table” to transfer special characteristics such as **customer hierarchy** and **product hierarchy** into CO-PA. You can find specific fields in the appropriate SAP tables. (For more information, choose Structures → Operating Concern → Maintain Characteristics [Extern] in Customizing)

- **Custom Characteristics**

  If the characteristic categories are insufficient for your needs, you can define completely new characteristics from scratch for exclusive use in Profitability Analysis. To derive values for these newly defined characteristics, you need to create your own derivation rules.

  To define such a characteristic, you need to specify the technical name, a description, a short text, a title, and the data type and length of its values. The texts you enter for this characteristic are used to identify the characteristic on transaction screens and in lists.

  If you only want a characteristic to have a fixed number of values (which should generally be the case), you need to create this characteristic by maintaining corresponding values. When you do, the system automatically creates a check table and a text table for this characteristic. You maintain the permitted values and their texts in Customizing under Master Data → Characteristic Values → Maintain Characteristic Values.

  If you do not want to limit the values permitted, you can create the characteristic without maintaining any corresponding values. Values entered later for these characteristics will
only be checked by the system to see that they use the correct data type. No texts exist for these values.

Another way of defining characteristics is to use the option that references existing values. This lets you create a characteristic by referencing a data element that already exists in the system. The characteristic inherits all the attributes of the data element.

Note that it is not possible to use two characteristics with the same data element in the same operating concern.

**Dependency of User-Defined Characteristics (Compounding Characteristics)**

You can make a user-defined characteristic dependent on another characteristic in your operating concern by compounding them. You do this in *Characteristics maintenance* with the function *Display compound*, where you specify one or more higher-level characteristics for a user-defined characteristic. The subordinate characteristic can only be defined in connection with the higher-level characteristic. This means that you can only determine a characteristic value for the subordinate characteristic when a dependency exists linking it to the characteristic value of the higher-level characteristic. A subordinate characteristic can thus never be used on its own.

A region defined as "North-East" can only make sense when dependent on a country. For this reason, the region is placed in a dependency-relationship with the country. In this example, you would assign the higher-level characteristic *Country* to the characteristic *Region* in characteristics maintenance. The characteristic *Region* could not, for example, be copied to a report on its own; you would have to transfer the characteristic *Land* as well. Were you not to do so, you would be unable to use the region as a basis for data analysis.

**Overview: Characteristic Categories**

An overview of the characteristic categories is shown below:
## Characteristics

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
<th>Value definition</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copied from SAP table</td>
<td>Reference to table field (such as to material grouping from mat.mstr)</td>
<td>(A) In external applications (such as MM)</td>
<td>Material group (MATKL)</td>
</tr>
<tr>
<td>Custom chars created from scratch</td>
<td>Fields specific to CO-PA without origin</td>
<td>(B) In CO-PA</td>
<td>Strategic Bus. unit (WWxxx)</td>
</tr>
<tr>
<td>Predefined</td>
<td>Sample characteristics delivered by SAP</td>
<td>(A) or (B)</td>
<td>Customer group</td>
</tr>
<tr>
<td>Fixed</td>
<td>Mandatory characteristics required by the system</td>
<td>In external applications (such as organizational structures)</td>
<td>Company code</td>
</tr>
</tbody>
</table>

---

**Strategic Bus. unit (WWxxx)**

**Material group (MATKL)**

**Company code**
Value Fields

Definition

Value fields [Extern] are only required in costing-based Profitability Analysis. These are the fields that contain the currency amounts and quantities that you want to analyze in CO-PA. They represent the structure of your costs and revenues.

Use

All the value fields that exist are stored in a field catalog. You can add these fields to your operating concerns by choosing Structures → Operating Concern → Maintain Operating Concern in Customizing.

Structure

The semantic meaning of a value field is determined by the data element to which it is assigned. The data element contains the texts that appear on the screen and in reports for the value field.

There are two types of value fields:

- Value fields that contain amounts in currencies are also referred to as "amount fields". All amount fields in a single line item use the same currency.

- Value fields that contain quantities are referred to as "quantity fields".
  Each quantity field is assigned a field containing a unit of measure. Consequently, each quantity field in a line item can use a different unit.

Value fields can be categorized according to how and when they are defined:

- **Predefined value fields**
  Value fields that are used frequently are predefined in the standard R/3 System. These include fields such as revenue, sales quantity, incoming freight, outgoing freight, and others. You can select those predefined value fields that you wish to transfer into your own operating concern.

- **User-defined value fields**
  In addition to the predefined value fields, you can also define your own value fields. You define these in the field catalog— independent of any client or operating concern — and can later add them to your operating concerns. You create value fields in Customizing under Structures → Operating Concern → Maintain value fields.

The definition of a value field consists of its name, texts, a rule defining how it is aggregated over characteristics of time, and whether it is an amount field or a quantity field. There are two texts for each value field — a "description" and a "short text". These texts are displayed on the screen to label the value field.

The aggregation rule determines how the values in a value field are to be handled when data is aggregated over multiple periods in planning and in reports. This does not affect the posting logic. You can choose from three aggregation rules: Addition, Average, and Last value. In most cases, you will want to add the values. Only noncumulative values, such as the number of employees, require the other options.
Value Fields
Setting the Operating Concern

Use
Before you can execute some of the functions for Profitability Analysis (CO-PA), you first need to specify the operating concern for which the function is to be performed and the type of Profitability Analysis (costing-based or account-based) you wish to use.

Features
You set the operating concern by defining its settings and specifying the desired type of Profitability Analysis in a dialog box. The settings in this dialog box are then valid until you log out of the system or reset the operating concern.

There are two ways of accessing the dialog box:

- By choosing Environment → Set Operating Concern in the CO-PA menu
- By choosing Structures → Set Operating Concern in CO-PA Customizing

When you first call up a function that requires an operating concern, the dialog box appears automatically if the operating concern has not yet been set.

If you only have one operating concern or generally only work with one operating concern, it makes sense to enter this operating concern and the required type of Profitability Analysis in your user master data. By doing so, the dialog box will no longer appear, even when you logon again to the system. The system then uses the operating concern and the type of Profitability Analysis stored in the user master record. Moreover, you can call up the dialog box at any time to switch to a different operating concern or to the other type of Profitability Analysis. The entries stored in the user master record then apply all the while you are still logged on to the system.

Activities
You store an operating concern and the type of Profitability Analysis from the dialog box for setting the operating concern. Enter the desired data and choose ✡.
Assigning the Operating Concern

Use

When you transfer data to Profitability Analysis, the system derives the appropriate operating concern from the controlling area, and derives the controlling area, in turn, from the company code. In Customizing, therefore, you have to assign each operating concern at least one controlling area. Generally, you assign several controlling areas.

Since the operating concern should reflect the structure of your sales market, one operating concern should normally be sufficient for your entire organization.

Prerequisites

You have to specify the data structures for the operating concern (that is, which characteristics and value fields are used) in Customizing for Profitability Analysis. You do this by choosing Structures → Define Operating Concern.

Activities

You assign controlling areas to an operating concern in Customizing for the company structure, under Assignment → Controlling.
Operating Concern Templates

Use

Operating concern templates are industry-specific example operating concerns delivered by SAP in a specific environment. This environment enables you, for example, to call up Customizing and to run demos (such as executing a profitability report), and it thereby quickly provides you with an insight into the possible uses of Profitability Analysis (CO-PA). You are not required to have any specialist knowledge about the application to use this quickstart function.

You can also use the operating concern template as a sample CO-PA operating concern in your productive system.

Integration

Operating concern templates are not integrated in existing applications. You can only activate integrated flows of values from the other applications you use into CO-PA when you copy an operating concern template.

Features

The following operating concern templates are delivered:

- An industry-independent operating concern template (Quickstart)
- A template for the consumer goods industry
- A template for airline companies for route profitability
Operating Concern Templates

In the environment for the operating concern templates, the individual templates are available on the left-hand side of the screen. You use \(\text{F1}\) to call up information that appears on the right-hand side of the screen. By double-clicking a template, you jump to the details view where the possible functions are presented in a tree structure. You can choose \(\text{F2}\) to call up documentation on each function. By double-clicking a function, you either perform the function or access the corresponding IMG activity.

**Activities**

You call up the environment for operating concern templates in Customizing by choosing *Structures → Define Operating Concern → Operating Concern Templates → Use SAP Operating Concern Templates*.

**See also:**

For more detailed information on the features of the operating concern templates and on how to use them, use the documentation described above. For technical information, see the IMG section *Using SAP Operating Concern Templates [Extern]*.
The concepts **line item** and **profitability segment** are essential for understanding how data is stored in CO-PA. A line item can be compared, for example, to an item in a billing document from the SD component. The combination of characteristic values stored in a line item is what defines the particular profitability segment to which the line item must be posted.

To improve system performance, you can also restrict the characteristics that make up the profitability segment. For more information, see the Customizing section [Define Profitability Segment Characteristics (Segment-Lvl Characteristics)](EXTERN).

Furthermore, a time-based dimension (the posting period) has to be represented.

The CO-PA data basis, which the system creates when an operating concern is generated, reflects how the information is organized logically.

There is the **table CE1xxxx for actual line items** (where xxxx = operating concern), which contains all the data at the most detailed level. Planned line items are stored in the table CE2xxxx.

There is also the **segment table CE4xxxx**, which is located at a higher level. It is used to assign segment numbers to each combination of characteristic values. For the first summarization to be performed, at least the document number and the billing item are hidden.

The characteristics that were deactivated from use in the profitability segment in Customizing are also hidden. Segment table CE4xxxx should therefore be optimized for processing data within
Profitability Analysis (COPA)

Database Tables for CO-PA Transaction Data

Profitability Analysis, such as for the information system. Table CE4xxxx_ACCT contains external account assignment information as well as the characteristics for CE4xxxx and serves as the "interface" to other applications.

The segment level CE3xxxx is set up between the segment table and the line items, thereby making a time-based classification possible. Alongside value fields, the segment level also contains the characteristics record type, planned/actual indicator, version, and period, as well as some additional technical details. Several lines from the segment level are attached to a particular profitability segment (that is, to a line in the segment table). These lines all have the same segment number but relate to different posting periods.

Each line at the segment level adds together the value fields for a row of line items bearing the same segment number and assigned to the appropriate posting period.

The following graphic provides an overview of the tables:

![Database Tables for CO-PA Transaction Data](image)

**Example**

You have invoiced three documents for customer 0815. The first posting occurs in March (posting period 003), and revenues of 100 DEM and 200 DEM are posted respectively for the products ART1 and ART2. The second posting occurs in April. Revenues of 400 DEM and 800 DEM are posted respectively for the products ART1 and ART3. The third posting also occurs in April. Revenues of 1600 DEM and 3200 DEM are posted respectively for the products ART1 and ART3. When the line items are posted, the segment table and segment level are updated, producing the following table contents:
### Segment Table (CE 4 XXX)

<table>
<thead>
<tr>
<th>Segment number</th>
<th>Customer</th>
<th>Product</th>
<th>Additional chars</th>
</tr>
</thead>
<tbody>
<tr>
<td>0815 0047</td>
<td></td>
<td>ART1</td>
<td></td>
</tr>
<tr>
<td>0815 0048</td>
<td></td>
<td>ART2</td>
<td></td>
</tr>
<tr>
<td>0815 0049</td>
<td></td>
<td>ART3</td>
<td></td>
</tr>
</tbody>
</table>
### Database Tables for CO-PA Transaction Data

<table>
<thead>
<tr>
<th>Segment Level (C3x3xxx)</th>
<th>Segment number</th>
<th>Period</th>
<th>Revenue</th>
<th>Additional value fields</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>000.47</td>
<td>003.2000</td>
<td>100.00</td>
<td>...</td>
</tr>
<tr>
<td></td>
<td>000.47</td>
<td>004.2000</td>
<td>2000.00</td>
<td>...</td>
</tr>
<tr>
<td></td>
<td>000.48</td>
<td>003.2000</td>
<td>200.00</td>
<td>...</td>
</tr>
<tr>
<td></td>
<td>000.49</td>
<td>004.2000</td>
<td>4000.00</td>
<td>...</td>
</tr>
</tbody>
</table>
### Database Tables for CO-PA Transaction Data

<table>
<thead>
<tr>
<th>Segment number</th>
<th>Period</th>
<th>Document</th>
<th>Item</th>
<th>Customer</th>
<th>Product</th>
<th>Additional chars</th>
<th>Revenue</th>
<th>Additional value fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>00047</td>
<td>003.2000</td>
<td>000007</td>
<td>0001</td>
<td>0815</td>
<td>ART1</td>
<td>...</td>
<td>100.00</td>
<td>...</td>
</tr>
</tbody>
</table>
### Database Tables for CO-PA Transaction Data

<table>
<thead>
<tr>
<th>Date</th>
<th>Material Code</th>
<th>Material No.</th>
<th>Date</th>
<th>Plant</th>
<th>Document Type</th>
<th>...</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>0003.2000</td>
<td>000007</td>
<td>0002</td>
<td>0815</td>
<td>ART2</td>
<td>...</td>
<td>200.00</td>
</tr>
<tr>
<td>7</td>
<td>0004.2000</td>
<td>000008</td>
<td>0001</td>
<td>0815</td>
<td>ART1</td>
<td>...</td>
<td>400.00</td>
</tr>
<tr>
<td>9</td>
<td>0004.2000</td>
<td>000008</td>
<td>0002</td>
<td>0815</td>
<td>ART3</td>
<td>...</td>
<td>800.00</td>
</tr>
<tr>
<td>7</td>
<td>0004.2000</td>
<td>000009</td>
<td>0001</td>
<td>0815</td>
<td>ART1</td>
<td>...</td>
<td>1600.00</td>
</tr>
<tr>
<td>9</td>
<td>0004.2000</td>
<td>000009</td>
<td>0002</td>
<td>0815</td>
<td>ART3</td>
<td>...</td>
<td>3200.00</td>
</tr>
</tbody>
</table>

**See also:**

For more detailed information on the more technical aspects, see [Physical Structure of the Data in CO-PA][1].
Storing Multiple Currencies in CO-PA

Use

Profitability Analysis lets you store your data in two currencies - a global (group) currency and a local (company) currency - to help meet the requirements of corporations operating on an international level.

You have the option of storing all data only in the operating concern currency or in both the operating concern currency and the currency of the relevant company code. You specify this when you define the attributes of your operating concern.

The data in the different currencies is distinguished by the currency type. The currency type determines which currencies are relevant from the viewpoint of which organizational units throughout the SAP System. For example, the company code currency is the currency defined for a specific company code. Likewise, the operating concern currency is that used for a specific operating concern.

CO-PA supports the following currency types:

- B0 (operating concern currency)
- 10 (company code currency)

When To Use Multiple Currencies

The answer to this question is demonstrated in the following example.

An international corporation has its headquarters in the United States and has a subsidiary in the UK. The operating concern currency is the U.S. dollar, while the company code currency of the subsidiary is the British pound.

If this organization uses parallel currencies in CO-PA, all transactions carried out by the British subsidiary are posted in British pounds in Financial Accounting (FI), but stored in two currencies in CO-PA - pounds and dollars. Both of these currencies are updated simultaneously in CO-PA when each transaction is posted.

It makes sense to use both currencies when the organization carries out transactions in currencies whose exchange rates change daily (such as US dollars and British pounds). This helps you avoid exchange rate differences and makes it possible to reconcile the CO-PA data with that in FI.

You can plan in CO-PA in either the company code currency or the operating concern currency in each version. You can convert your planning data to the other currency by copying the data to a plan version that uses the other currency and translating it using a planned exchange rate.

In the Information system, you can display reports in the operating concern currency as well as in the company code currency.

When Not To Use Multiple Currencies

If your organization works with average exchange rates by period instead of exchange rates that fluctuate daily, it is advisable not to update both currencies. If you did, you would be doubling your data volume without gaining any additional information. Alternative currency translation functions are available in planning and in the information system to let you translate all values using average exchange rates by period.
Storing Multiple Currencies in CO-PA

See also:
Storing Actual Data in Multiple Currencies [Seite 318]
Multiple Currencies in Planning [Seite 143]
Multiple Currencies in the Information System [Seite 361]
Master Data

Purpose

In Profitability Analysis, master data provides the fundamental data and content within the structures [Seite 16] you have already determined by characteristics and value fields.

Features

The system uses the combination of characteristic values to automatically create during a posting the affected market segment, that is the profitability segment [Extern] that is being posted to. The specifications you make for the characteristic values form the basis for the automatic determination of the profitability segment.

- You can specify the valid characteristic values for the new characteristics you have defined. See also the section Maintain Characteristic Values [Extern] in Customizing.
- You can place the characteristic values for a single characteristic into a hierarchical relationship. For more information, see the section Characteristics Hierarchy [Seite 348].
- You can specify which principles are to be applied for automatically determining further characteristic values when posting data to Profitability Analysis. For more information, see the sections dealing with Characteristic Derivation [Seite 41].
- You can perform a realignment [Seite 62] so that changes made to master data in the SAP System and copied to characteristic derivation are also applied to past data in the CO-PA dataset.

You can also specify for value fields which principles are to be applied for automatically determining further characteristic values and setting these values in the value fields when additional data is posted. For more information, see the sections dealing with Valuation [Seite 76].
Master Data

Billing document
Customer C1
Product P1
Revenue 100,000

INPUT

Derivation
Customer C1 → District D1 → Region CA

Valuation
Product P1 → Product group P2

Revenue
Internal commission (5% of revenue)

OUTPUT
Characteristic Derivation

Use

Characteristic derivation is the attempt to determine the characteristic values for all CO-PA characteristics in a given profitability-relevant business transaction. The characteristic values that are transferred automatically are used to determine other logically dependent characteristics. For this, the system can access information contained in the source document as well as that existing outside it.

The profitability segment to which the account assignments are to be made is determined using the quantity of characteristic values drawn from characteristic derivation.

You use the “Customer group” field from the material master (KNA1) as a characteristic in your operating concern. The system recognizes that the customer group depends on the customer number and it is therefore able, for example, to automatically determine the customer group "KG1" for customer "K1" by reading from the customer master.

Features

Characteristic derivation is performed with the following:

- Manual account assignments, including:
  - Settling Orders and Projects
  - Direct postings from FI
  - Manually created CO-PA line items
  - Manual Entry of Planning Data
Characteristic Derivation

Only a few characteristic values have to be entered manually. The remaining characteristic values can be entered via characteristic derivation.

- Automatic transfer of data from other applications, including:
  - Billing documents
  - Transferring Overhead
  - External data transfer

  External applications often supply values for only a few of the characteristics used in an operating concern. This is because some of these applications are not familiar with all profit-related information. Characteristic derivation fills in the remaining characteristic values, provided that they can be derived from the ones supplied by the source application.

Characteristic derivation consists of a series of derivation steps (the derivation strategy), each of which can be used in turn to derive characteristic values from other characteristics.

For each operating concern you define, the system generates standard derivation steps that automatically contain all the known dependencies between characteristics. The standard derivation strategy contains:

- Steps for deriving fixed characteristics
- Steps for deriving the characteristics you selected from SAP tables
- Steps for determining units of measure for the quantity fields assigned in the Sales and Distribution (SD) application or in planning.

In general, you can copy the standard derivation strategy as it is. If you have created user-defined characteristics, you should nevertheless enhance the standard derivation strategy with several additional derivation steps, provided that logical dependencies exist. For information of additional options for changing the standard derivation strategy, see the section Changing the Standard Derivation Steps [Seite 56].

Each derivation step describes how a group of target fields can be populated with values derived from a group of source fields. One or more values are derived from the combination of values in the source fields and then entered into the target fields. To find out which fields are valid as source fields and target fields, refer to the section Source and Target Fields [Seite 51].

There are different derivation types to represent the different logical dependencies between source and target fields (see Derivation Types [Seite 44]).

You can modify the order for processing the individual derivation steps by entering conditions governing how the step is carried out and by specifying step and field attributes (see Influencing the Standard Derivation Procedure [Seite 54]).

**Activities**

To access characteristic derivation, choose Master Data → Define Characteristic Derivation in CO-PA Customizing.

Then, by choosing View → Display All Steps, you can display all derivation steps in the derivation strategy for your operating concern.
Derivation Types

Use

CO-PA provides a number of different types of derivation step, called "derivation types".

Structure

These include:

- **Derivation rule**

  A derivation rule is an "if → then" rule that determines which actual characteristic values or combinations of source characteristic values result in which target characteristic values.

  To create a derivation rule, first enter the source and target fields in Customizing for characteristic derivation, as well as the conditions and step attributes. You can enter the actual characteristic values either by choosing Maintain Rule Entries in Customizing or by choosing Master data → Maintain derivation rules in the application. In either case, you can also enter the validity period.

- **Table lookups**

  Table lookups let you read individual records of any table to determine characteristic values. Here the source fields must make up the key of a specific table, from which the system can copy certain contents to the target fields.
When you generate the environment for your operating concern, the system automatically generates table lookups for all characteristics that you choose from predefined SAP tables.

One of the derivation steps defined automatically by the system determines the division based on the product number. This means that the system uses the value in the source field “Product number” to read a line of the material master, and then copies the content of the field “Division” in that line to the target field “Division”.

- **Moves**

  Moves let you copy a constant or the content of any source field to a target field. For example, you can copy the value of a characteristic to another field if certain conditions are fulfilled.

- **Clear**

  Clears let you delete the value of a characteristic, setting that field back to its initial value (blank for CHAR fields, “0” for NUMC fields).
• **Customer hierarchy**

You can only use this type of derivation step if you have maintained the assignment of the customer hierarchy in SD to the CO-PA auxiliary structure PAPARTNER (see the procedure below).

In the Sales and Distribution application SD, you can subdivide your customers into hierarchical structures. You can use characteristic derivation to transfer these structures (up to ten levels) to Profitability Analysis. This involves deriving the customer hierarchy from the customer hierarchy type, the sales organization, the distribution channel and the division.

In order for the characteristics of the customer hierarchy to be derived in Profitability Analysis, you need to define the derivation step “Customer hierarchy”.

In order that you can use this type of derivation step in characteristic derivation, you first need to maintain the assignment of the customer hierarchy in SD to the CO-PA auxiliary structure.
structure PAPARTNER. The fields HIEZU01 to HIEZU10 are available as valuation levels in this auxiliary structure and can be transferred to CO-PA as characteristics. SD customer hierarchy nodes are assigned to the evaluation levels in CO-PA when the customer master records for the hierarchy nodes in the customer hierarchy are maintained. For this, you need to maintain the field "Hierarchy assignment", found on the Marketing screens of the master record. If the field is locked against manual entry, you need to unlock it by maintaining the field status for customer master records.

The characteristics that are used to derive the customer hierarchy are automatically entered in this step as the **source fields**. These are *Sales Organization*, *Distribution Channel*, *Division*, and *Customer*. It is also possible to derive the customer hierarchy in Planning if planning is performed at the hierarchy level instead of the customer level. In that case, the relevant hierarchy characteristic, such as HIE03, is the source field, not the *Customer* characteristic.

The characteristics you defined for the customer hierarchy in your operating concern are automatically defined as the **target fields**.

All you need to maintain for the derivation step "Customer hierarchy" is the customer hierarchy type that you want to use for Profitability Analysis.

- **Customer Enhancement: Characteristic Derivation**

  For instances where the derivation types provided by the system do not fulfill your requirements, you can use a customer enhancement (COPA0001, component 003). This enhancement can be called up at any point in your derivation strategy (even more than once).

  Before using this enhancement, be sure that you can achieve the desired effect by doing the following: firstly, by defining steps with other derivation types that use conditions, step and field attributes (see *Influencing the Standard Derivation Procedure [Seite 54]*) as well as temporary intermediate fields (see *Source and Target Fields [Seite 51]*) and, secondly, by sorting them properly in your strategy. This will help you avoid any unnecessary reprogramming if you upgrade your system to a new release (see *Activities Following Upgrades [Seite 59]*).

  To define customer enhancements, choose **Tools → SAP Enhancements** in CO-PA Customizing. There you will find the technical information needed to set up a customer enhancement.
Examples: Derivation Types

Derivation rule

You can define derivation rules to populate your user-defined characteristics in Profitability Analysis. In the following example, the characteristic "Strategic business unit" is a user-defined characteristic in your operating concern. The strategic business unit (target field) is determined on the basis of the product group (source field). The step attribute Define values with period of validity is activated.

You enter the following values:

<table>
<thead>
<tr>
<th>Product group</th>
<th>To</th>
<th>Valid from</th>
<th>Strategic business unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>01.01.1998</td>
<td>Electronics</td>
<td></td>
</tr>
<tr>
<td>200</td>
<td>299</td>
<td>01.01.1998</td>
<td>Multimedia</td>
</tr>
<tr>
<td>200</td>
<td>399</td>
<td>01.06.1998</td>
<td>Multimedia</td>
</tr>
</tbody>
</table>

Table lookups

Normally, the characteristic "Country" is derived using an automatically created derivation step (table lookup in the customer master table KNA1) that takes the characteristic "Customer" (KNDNR) as the source field. In the following example, the country (WWCST) is derived using a table lookup (in customer master table KNA1) with the ship-to party (KUNWE) as the source field. The characteristic "Ship-to party" has been copied to Profitability Analysis from the SD structure PAPARTNER.

Table lookups using source fields

<table>
<thead>
<tr>
<th>Origin</th>
<th>Field name</th>
<th>=</th>
<th>Origin</th>
<th>Field name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KNA1</td>
<td>KUNNR</td>
<td></td>
<td>CO-PA</td>
<td>KUNWE</td>
<td>Ship-to party</td>
</tr>
</tbody>
</table>

Moving table fields to target fields

<table>
<thead>
<tr>
<th>Origin</th>
<th>Field name</th>
<th>=</th>
<th>Origin</th>
<th>Field name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>KNA1</td>
<td>LAND1</td>
<td></td>
<td>CO-PA</td>
<td>WWCST</td>
<td>Ship-to country</td>
</tr>
</tbody>
</table>

Moves

The following move copies the customer (KNDNR) to the ship-to party (KUNWE) if no ship-to party is contained in the ship-to field.

<table>
<thead>
<tr>
<th>Source field:</th>
<th>KNDNR</th>
<th>Customer</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Target field:</td>
<td>KUNWE</td>
<td>Ship-to party</td>
<td></td>
</tr>
</tbody>
</table>

Under Condition, enter the following for this step:

<table>
<thead>
<tr>
<th>Origin</th>
<th>Name</th>
<th>Description</th>
<th>Operator</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO-PA</td>
<td>KUNWE</td>
<td>Ship-to party</td>
<td>=</td>
<td></td>
</tr>
</tbody>
</table>
Clear

Since the characteristic Representative (VRTNR) is not relevant for analysis in certain divisions, you use the following clear so that this characteristic is not populated for the condition specified below.

You therefore want to clear the following field:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Operator</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO-PA</td>
<td>VRTNR</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Under Condition, enter the following:

Name Description Operator Value
SPART Division = (05) Machine sales
Special Case: Table Lookup in Table **VBKD**

When you define a table lookup for the table **VBKD** (Sales document: Business data), data does not have to be present for every item in the sales document. If the item data is no different than the header data, the system does not store it in the item as well. In this case, you can find the valid values in the header data, which is stored in table **VBKD** under the item number "000000".

Thus, if you want to read characteristic values from **VBKD**, you always need to define two table lookups.

You want the system to read the field **KDGRP** (customer group) from table **VBKD** and enter the value contained there in the temporary field **GLOBAL USERTEMP1**, so that you can use the customer group to derive other characteristics.

To achieve this, you need to create the following two steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Derivation type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Table lookup in table <strong>VBKD</strong> using the key <strong>KAUFN</strong> and <strong>KDPOS</strong>; Copy content of field <strong>KDGRP</strong> to characteristic <strong>GLOBAL USERTEMP1</strong></td>
</tr>
<tr>
<td>2</td>
<td>Table lookup in table <strong>VBKD</strong> using the key <strong>KAUFN</strong> and <strong>KDPOS</strong>. For <strong>KDPOS</strong>, you define field attributes stating that the constant &quot;000000&quot; should be used here. Then copy <strong>KDGRP</strong> to <strong>GLOBAL USERTEMP1</strong>.</td>
</tr>
</tbody>
</table>

This rule causes the system to first try to read the item data. But since this information is not stored explicitly, the field **GLOBAL USERTEMP1** remains blank. Then the system carries out step 2, which reads the header data.

If you have used the field **GLOBAL USERTEMP1** for other purposes earlier in the strategy, be sure to clear its content first.
Source and Target Fields

Use
You enter the source and target fields for derivation in a derivation step.

Structure

Source fields
You can use the following operating concern fields as source fields:

- All fixed characteristics
- All user-defined characteristics
- All characteristics copied from SAP tables or from the field catalog
- All characteristics copied from customer hierarchies (CO-PA HIE01 to HIE10)
- All quantity unit fields (CO-PA *_ME)

Generally, you cannot use technical fields from the costing-based line item for derivation. This is because these fields are not usually available when characteristic derivation is performed. No technical fields are located at the segment level (table CE4xxxx, where xxxx is the operating concern). Those fields that are at the segment level serve as the basis for characteristic derivation. (For background information on tables in Profitability Analysis, see the section Database Tables for CO-PA Transaction Data [Seite 31].)

Only the following technical fields are made available for use in characteristic derivation:

- The sender cost center (CO-PA SKOST) in cost center assessment and cost center activity allocation.
- The sender process (CO-PA PRZNR) in process assessment and process activity allocation
- Cost element (CO-PA KSTAR) for direct postings from financial accounting, for settlement and in assessment and activity allocation

In addition, you can use as source fields those indicators that lend themselves particularly well in step conditions. This applies to the following:

- The plan/actual indicator (GLOBAL PLIKZ) with actual value "0" and plan value "1"
  
  If you use this indicator, you can, for example, define derivation steps that only occur in planning.

- An indicator to show whether Profit Center Accounting is active (GLOBAL PCAACTIVE), using the value " " for inactive and the value "X" for active
  
  If you create your own derivation steps for populating your profit centers, you can set this indicator as a condition.

- An indicator using the values " " and "X" to show whether characteristic derivation is being called up from Realignments [Seite 62] (GLOBAL REALIGNMENT.MODE)
  
  If certain derivation steps are not to be performed in the case of realignments or if they are only to be performed in the case of realignments, then you can set this indicator to be called up by the system in the condition.
Source and Target Fields

It can sometimes be useful to be able to draw up and keep intercompany profits/losses for the derivation of characteristics. The following temporary fields enable you to do this:

- Temporary field 1 (GLOBAL USERTEMP1)
- Temporary field 2 (GLOBAL USERTEMP2)
- ...
- Temporary field 8 (GLOBAL USERTEMP8)

Finally, you can also choose from the characteristics in the variant configuration (configurable materials):

- Characteristics in the variant configuration (VCONF NAME)

If sales order items are entered with configurable materials, then you may often wish to determine characteristic values for CO-PA characteristics independently of the values in the variant configuration. You can also create derivation steps that have characteristics from the variant configuration as source fields.

When defining the source fields, you can enter as a source field name all the characteristics from the variant configuration system that have character-based or numeric names.

The possible entries function for the source fields does not list all the characteristics in the variant configuration. Instead, only the substitute field VCONF ? is offered. The values entered for the variant configuration are not checked for compatibility with the derivation logic. This means that the system does not reject any potentially invalid characteristic values in the variant configuration!

The system only executes a derivation step containing characteristics from the variant configuration if a sales order item contains a configurable material with which these characteristics were originally entered into the configuration.

Within the variant configuration itself, you define the characteristics COLOR and SIZE with which material 1000 is valuated.

For the profitability report, it is of interest to you whether a standard color or a special color is involved and which size category the material has. You therefore define in CO-PA the characteristic WWCOL (color type) with the characteristic values "standard" and "special" and the characteristic WWSIZ (size category) with the characteristic values "small", "medium" and "large".

You can then create, for example, the following derivation rules:

Derivation rule: Specify color type
Source field: VCONF COLOR
Target field: CO-PA WWCOL
Rule values:
RED = standard
BLACK = standard
WHITE = standard
APRICOT = special
MAGENTA = special

Derivation rule: *Specify size category*

Source field: VCONF SIZE
Target field: CO-PA WWSIZ

Rule values:
0 – 9,9 = small
10 – 19,9 = medium
20 – 100 = large

**Target fields:**

You can use the following fields as target fields for derivation:

- All user-defined characteristics
- All characteristics copied from SAP tables or from the field catalog
- All characteristics copied from customer hierarchies (CO-PA HIE01 to HIE10)
- **Only** the following fixed characteristics:
  - Customer number (CO-PA KNDNR)
  - Product number (CO-PA ARTNR)
  - Business area (CO-PA GSBER)
  - Profit center (CO-PA PRCTR)
  - Sales organization (CO-PA VKORG)
  - Distribution channel (CO-PA VTWEG)
  - Division (CO-PA SPART)
  - Plant (CO-PA WERKS)
- All quantity unit fields (CO-PA * _ME)
- Temporary fields (GLOBAL USERTEMP1 to GLOBAL USERTEMP8)
Influencing the Standard Derivation Procedure

**Use**

The standard derivation procedure runs by default as follows:

1. If you have specified any conditions for running a derivation step (see below), the system starts by checking these conditions. If those conditions are not fulfilled, the system ignores the step.

2. The system checks to make sure that the source fields contain values. If one of the source fields is initial (blank for CHAR fields or "0" for NUMC fields), the system does not perform derivation.

3. Provided that some of the target fields for the derivation step are not yet populated with values, the step is carried out. If values are found, they are entered in the corresponding target fields, provided that those fields do not already contain a value. Fields that already contain values are not changed.

4. If no target values can be found in the derivation step to match the specified source field values, all the target fields remain unchanged. No error message is displayed for most derivation types. If the step is a derivation rule, however, the system issues an error message by default if no suitable target values are found.

This means that the default settings no longer allow fields that already contain values to be overwritten in characteristic derivation. You should note that the account assignment screen in CO-PA (dialog box *Assignment to a Profitability Segment*) in particular operates according to its own logic to determine which target fields are to be derived again and which ones do not need to be changed. You can use the derivation analysis function in the account assignment screen to perceive how this screen interacts with characteristic derivation.

**Features**

By using conditions such as step and field attributes, you can modify the standard derivation procedure.

**Requirement**

For each derivation step, you can specify the condition under which the step should be executed. You do this by choosing *Condition*. A condition consists of a series of partial criteria that compare characteristics with the values they must have.

You can specify that a step should only be executed if the sales organization is "0010" and the product number is greater than or equal to "P-100" and less than or equal to "P-199". Enter the following under *Conditions*:

<table>
<thead>
<tr>
<th>Origin</th>
<th>Name</th>
<th>Description</th>
<th>Operand</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CO-PA</td>
<td>ARTNR</td>
<td>Product number</td>
<td>&gt;=</td>
<td>P-100</td>
<td>Pump 100</td>
</tr>
<tr>
<td>CO-PA</td>
<td>ARTNR</td>
<td>Product number</td>
<td>&lt;=</td>
<td>P-199</td>
<td>Pump 199</td>
</tr>
</tbody>
</table>

You should note that the product number is a character field and is not numeric in the system. For this reason, the "greater/less than" criterion operates alphabetically.
Influencing the Standard Derivation Procedure

according to the computer character set. This means that product number "100" is considered smaller than product number "20" because 100 (beginning with "1") comes before 20 (beginning with "2").

**Step attributes**

In the step attributes, you can choose Attributes to specify for each derivation step whether an error message should appear if no target values are found. For derivation rules, this option is automatically set as the default setting. If you do not want to maintain derivation rule values for every possible combination of source values, you should deactivate this error message display.

You can include the following additional step attributes in the derivation rules:

- **It should be possible to maintain rule values using the validity date**
  
  If you activate this attribute, you can then make derivation rule entries for rules that have a "valid from" date.

- **Optimize callup: no maintenance of "from-to" values.**
  
  If you can do without "from-to" values for rule entry maintenance, then it is advisable that you activate this attribute. Characteristic derivation is accelerated as a result.

- **Step ID for Direct Call**
  
  This attribute is not required in general. It is only useful if you program, for example, a batch input for the data input transaction KEDE and want to directly access maintenance for a specific rule. To activate this attribute, choose *Jump -> Direct call using step ID*. You can then enter one of the available step IDs.

**Field attributes**

By using the icon, you can specify field attributes for source and target fields.

- **For each source field, you can make a setting allowing it to contain initial values. This allows the system to perform derivation even if the source field does not contain a characteristic value.**

- **For each target field, you can specify whether the step should overwrite the existing characteristic value. This guarantees that the value determined in this step will always be copied to the target field, even if that field already contains another value.**

In the case of table callups, you can choose further options for selecting field attributes for source and target fields. For example, you can choose to consider just one part of each field.
Changing the Standard Derivation Steps

Use

For each operating concern defined, the system generates standard derivation steps to define all the automatically known dependencies between characteristics. You can display these standard derivation steps by choosing View → Display All Steps.

You can also change the derivation steps that have been generated automatically and add new steps to them. In this way, you can, for example, define logically dependent chains of derivation steps or make it possible to perform multiple derivation attempts for the same target field.

Example of a Logical Chain

You have defined the characteristics “Market region” and “Responsibility area”. The market region is derived from the country, and the responsibility area is derived from a combination of division and market region.

<table>
<thead>
<tr>
<th>Source field:</th>
<th>Target field:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Country</td>
<td>Market region</td>
</tr>
<tr>
<td>Division, Market region</td>
<td>Responsibility area</td>
</tr>
</tbody>
</table>

In this case, the order of the derivation steps is essential. First, the country and, if possible, the division are determined. Then the market region is derived from the country, and after this the responsibility area can be found. Including the default steps defined by the system for deriving the division and the country, the order of derivation steps thus is as follows:

<table>
<thead>
<tr>
<th>Step</th>
<th>Derivation</th>
<th>Derivation Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Customer → Country</td>
<td>Created automatically by the system; Table lookup in customer master</td>
</tr>
<tr>
<td>2</td>
<td>Product → Division</td>
<td>Created automatically by the system; Table lookup in material master</td>
</tr>
<tr>
<td>3</td>
<td>Country → Market region</td>
<td>User-defined derivation rule</td>
</tr>
<tr>
<td>4</td>
<td>Division/Market region → Responsibility area</td>
<td>User-defined derivation rule</td>
</tr>
</tbody>
</table>

Example for Multiple Derivation Attempts

You have defined a user-defined characteristic “Customer group”. You normally want this customer group to be derived from the customer class, which is stored in the customer master table. For some customers, though, you also want the customer group to depend on the division.

To achieve this, you need to create two derivation steps:

<table>
<thead>
<tr>
<th>Step</th>
<th>Derivation</th>
<th>Derivation Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Customer, Division → Customer group</td>
<td>Derivation rule</td>
</tr>
</tbody>
</table>
Changing the Standard Derivation Steps

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer → Customer group;</strong> Read customer master and copy the customer class</td>
<td>Table lookups</td>
</tr>
</tbody>
</table>

For the first step, you need to make the corresponding derivation rule entries to define all the instances where a differentiated customer group should depend on the customer and the division. If no customer group is stored for a given combination of customer and division, the system carries out the second step, which then supplies it from the customer master. If the first step is successful, the second step is not carried out, since for each step the system first checks with each step whether the target field has already been filled.

When you create a new derivation rule, the system always defines *Display error message* as the default reaction for instances where no target value is found. To achieve the effect described above, you need to deactivate the error message in step 1. You do this by choosing *Attributes* (see *Influencing the Standard Derivation Procedure* [Seite 54]).

The following graphic provides an example of a useful derivation strategy:

**Features**

To change the standard derivation steps, you can choose from the following options:

- **Adding to the Standard Derivation Steps**
  
  If you have defined your own characteristics and want have their values derived automatically from other characteristics, you need to add your own steps to the standard
Changing the Standard Derivation Steps

derivation steps. Moreover, it may also be necessary to create additional steps in order to represent logical chains or multiple derivation attempts.

- **Changing a Standard Derivation Step**

  For the standard derivation steps, the system defaults the dependency that usually yields the desired result. In rare instances, however, it may make sense to change a default derivation step since characteristics can be determined using different alternative dependencies.

  On the other hand, you cannot change all of the standard derivation steps. Only the standard steps for characteristics taken from SAP tables can be changed. The steps for fixed characteristics and unit fields cannot be changed. You can display all modifiable derivation steps by choosing View → Modifiable Steps.

You select the characteristics “Country” and “Customer group” from the customer master table KNA1. By default, the system derives values for these characteristics based on the sold-to party. If you want to derive values for country and customer group from the ship-to party instead, you need to change the source field for the standard derivation step accordingly.

- **Deleting a Standard Derivation Step**

  You can delete all the user-defined derivation steps. In addition, you can delete the standard steps generated by the system provided that they are modifiable (see above). Doing this makes sense if, instead of using a dependency suggested by the system, you want to define your own step to derive the values for a characteristic taken from an SAP table. If you delete a standard step, you should always make sure that you have defined your own step to derive values for that characteristic. If no other step exists for that characteristic, the system will create the deleted step again the next time you generate the environment of your operating concern.

- **Sorting Derivation Steps**

  It may be necessary to change the order of the predefined derivation steps in order to achieve a logical sequence of interdependent steps or to define multiple derivation attempts to populate a field.
Activities Following Upgrades

Use
When you upgrade your system to a new release, all the Customizing settings made in the previous release are automatically converted to the new functional environment and can be used as before. However, this cannot always be ensured in the case of customer enhancements for characteristic derivation. It is therefore recommended that you test these enhancements to make sure that they still work properly.

Original Release 3.x

Customer Enhancement COPA0001, Components 001 and 002
The customer enhancement COPA0001, components 001 and 002 (exit in characteristic derivation) are no longer supported from Release 4.x. However, they are still accessed in the new release and are therefore still functional in principle.

Following an upgrade, the system automatically checks whether this customer enhancement was active. If so, derivation steps are automatically created at the beginning and the end of the derivation strategy, so that the enhancement is still accessed.

However, you should observe the following recommendations to check whether the logic programmed in the enhancement is still necessary in the new release.

1. First check whether you can replace the enhancements using the new standard derivation types.
   
   You should avoid using customer enhancements wherever you do not absolutely require them. Since normal Customizing settings are automatically compatible without the need for manual changes, you will no longer need to check the compatibility in future releases.

2. If you cannot replace the enhancements, specify the source and target fields more precisely and, if desired, limit them further.
   
   When you upgrade to a new release, all possible fields are listed by default as source and target fields. You may be able to achieve significantly better performance by limiting the fields. Fewer fields need to be transferred to the customer enhancement, and the system does not have to recognize as many relationships between source and target fields (which, for example, can be used to optimize performance in summarization levels).

   At the same time, you should consider whether you can switch over to the new component 003 of customer enhancement COPA0001 and divide it into individual steps. For more information on this, see the documentation for enhancement COPA0001.

Original Release 2.x and 3.x

Compatibility of Customer Programs With Characteristic Derivation
Technically, derivation of characteristic values was completely reprogrammed in Release 4.0A. Both the data model - together with its tables - and the maintenance transactions are entirely new and have no connection with the technique used through Release 3.1.

If you have created user-defined programs or batch-inputs for derivation, you may need to redesign these.
Activities Following Upgrades

Check whether you have any

- Your own programs that read control tables TKEAS, TKEA1, TKEA2, TKEAT or TKEAN
- Your own programs that read the old tables for derivation rules (tables K9*)
- Batch-input programs that use the old transaction “Change Derivation Rules”

These programs or batch-inputs no longer work in Release 4.0A and higher and therefore need to be modified.

If you have programs that write derivation rule entries directly into tables K9*, you should check whether you cannot replace this using the batch-input technique. This will ensure that the highly complex consistency checks are carried out in the new release.
Characteristics Hierarchy

Definition

In a characteristics hierarchy, you place the characteristic values for a **single** characteristic into a hierarchical relationship.

Use

In the information system, you can run analyses on a characteristics hierarchy.

Structure

A characteristics hierarchy is made up of nodes that can be posted to. These nodes are the characteristic values. Furthermore, you can add to the hierarchical structure by creating nodes that cannot be posted to.

You define characteristics hierarchies in Customizing under Master Data → Characteristic Values → Define Characteristics Hierarchy [Extern].

See also:

The section Characteristics Hierarchies [Extern] in the documentation for Drilldown Reporting
Realignment

Use

A realignment makes organizational changes in your product, customer, or sales structure - such as a reassignment of sales districts to regions or products to product groups - effective for all past data. You can perform realignments periodically.

This makes it possible for you to apply changes in customer or material master records, in the SD customer hierarchy, or in CO-PA derivation rules to the data that has already been posted to Profitability Analysis.

Following a realignment, only the new assignment is known in the information system and in planning. The characteristic values valid at the time the original posting was made can only be analyzed in line item reports. Because the existing profitability segments are changed to adhere to the new assignment, all objects assigned to those profitability segments - such as sales orders or projects - and all existing SAP documents - such as billing documents or FI documents - reflect the new assignment as well.

Concepts

Realignment

A realignment changes the characteristic values of profitability segments and thereby activate master data changes for all existing data in CO-PA.

Selection Criteria

The selection criteria are a set of characteristics for which characteristic values are specified.

Conversion Rule

A conversion rule is a rule telling the system to do one of the following for each characteristic that can be changed by the realignment program:

- Derive characteristic again (default)
Realignment Request

A realignment request consists of a set of selection criteria, a conversion rule, and a description. Realignment requests are based on the concept of change documents. That is, you should have one realignment request per change document for smaller master data changes. Realignment requests cannot be carried out directly.

Realignment Run

A realignment run consists of one or more realignment requests. The realignment run is the executable unit for realignments. Once you have executed a realignment run successfully, you cannot change or repeat it. It is possible to restore the data to the state it had prior to a specific realignment run. The system stores status information (who executed the run when, final status) as well as a log.

Uses

In practice it is often difficult to limit changes to derivation-relevant master data to specific dates. These changes have an immediate effect on postings to CO-PA and constantly create new profitability segments, while the corresponding “old” profitability segments become obsolete and can no longer receive postings.

Customer “Sample” (customer number 1) is assigned to sales representative “Smith” (representative number 1234) up to 2/7/97. For sales of the product “1234.56.78.90” to Mr. Sample, a number of actual postings have been made to profitability segment “0000000001”, which is defined by the characteristic values “Customer number 1”, “Sales representative 1234”, and “Product 1234.56.78.90”. Due to a restructuring of the sales department, customer “Sample” is assigned to sales representative “Taylor” (representative number 1235) beginning on 2/8/97. The next time Mr. Sample buys product “1234.56.78.90”, the system posts the revenues to a new profitability segment “0000000002”, which is defined by the characteristic values “Customer number 1”, “Sales representative 1235”, and “Product 1234.56.78.90”. Profitability segment “0000000001” will no longer receive any new postings. Using realignments, you can change this profitability segment later so that profitability segments “0000000001” and “0000000002” have the same combination of characteristic values.

This type of situation should be avoided where possible, because the redundant profitability segments slow down the system when it reads from the segment level and may even make up the bulk of the data volume after a while.

This makes it necessary to make changes as quickly as possible using realignment runs. Such reassignment runs do in fact invalidate the summarization levels and data already set up. Both have to be recreated afterwards (see Effects on Summarization Levels and Data [Seite 73]).
Maintaining Realignments

Use
You can maintain realignment runs and realignment requests in an easy-to-use hierarchical display. First the system displays the existing realignment runs. You can then open any of these realignment runs to display the realignment requests that belong to them.

You also see the status of each realignment run.

Features
The following functions are available from this hierarchical display:

- Save Settings
- Create Realignment Run
- Create Realignment Request
- Display Detail
- Copy realignment run/request
- Move realignment request (within a realignment run or between realignment runs)
- Test Monitor
- Schedule a realignment run for background processing
- Refresh Status Information

Activities

Save Settings
New or changed realignment runs or realignment requests first appear in the hierarchy graphic only. To change these in the database, you need to save the settings. A number of functions (scheduling, test, and so on) require you to save the settings before you can execute the function.

Create Realignment Run
When you create a realignment run, you must enter a description. This description is displayed in the hierarchy graphic. Try to enter a text that clearly describes the content of the realignment run (for example, "Change to cust. hier. 7/1/98"). Since the realignment run is merely the executable unit and stores only the text and the status information, you do not need to make any other entries. When you press Confirm, the realignment run is inserted in the hierarchy.

Create Realignment Request
Position the cursor on a realignment run or an existing realignment request. The function Create request creates a new realignment request, which is then inserted below the cursor position (see the section Order of Realignment Requests in a Realignment Run [Seite 71] regarding the order of the requests).

First, you must enter a description. This description is displayed in the hierarchy graphic. Try to enter a text that clearly describes the content of the realignment request (for example, "New cust.
Maintaining Realignments

hierarchy”). Using the Selection condition and Conversion rule tab pages, you can maintain the corresponding components of the realignment request.

### Selection Criterion

A realignment is only carried out on those profitability segments which meet the selection criteria for that request. You can specify a characteristic value for each characteristic in the selection criteria. All the selection criteria must be true for a profitability segment before it is changed by the realignment.

You can use the arrow buttons to move the selected characteristics back and forth between the two tables. For each characteristics in the lower table, you can enter a fixed value in the Characteristic value column. If you do not make any entries there or in the More column (arrow), the system selects profitability segments that do not contain a value for that characteristic.

You can enter a complex selection criterion by choosing (in the Selection column). When a multiple selection has been entered for a characteristic, the arrow in that row becomes green.

The characteristic values you enter here are not checked for validity in the check table. That means that you can use the realignment function to remove characteristic values that no longer exist. In this case, the text “invalid characteristic value” appears.

If you enter multiple values, you should only enter positive values or intervals. All other selection criteria (such as “not”, “greater or equal to”, “less than”, and so on) are not written to the database and therefore hurt performance.

### Conversion Rule

For each characteristic, you need to specify how the realignment should change the characteristic value. You can specify the following:
Maintaining Realignments

- **Derive characteristic value again** This is the default setting for all characteristics that can be changed in realignments.

- **Do not change** This is the default setting for all quantity units and all characteristics that represent organizational units. In order to ensure that the CO-PA data basis remains consistent with other applications (FI, CO-OM, and so on), the system does not allow you to change these characteristics. These unchangeable characteristics are highlighted for your information.

- **Replace with fixed value** For these profitability segments, the existing characteristic value is replaced with the specified value. If you do not enter a fixed value, the existing characteristic value is simply removed. Use this option with extreme caution.

You can use the arrow buttons to move the selected characteristics back and forth between the two tables.

⚠️

When you carry out a realignment, the first successful derivation step also overwrites any existing values for that characteristic. This is different from how derivation works when you assign FI postings to CO-PA or when you otherwise post actual or planning data.

💡

A profitability segment consisting of the characteristic values “Product 1” and “Division 01” was created on the basis of a sales order item. The division was transferred from the order header. The material master for product “1” contains division “02”. If you run a realignment for this profitability segment and derive the division again, the information from the order header is lost and replaced by the division in the material master.

It is also possible to change characteristics that are not among the segment-level characteristics. This can be necessary, for example, if you want to remove the characteristic subsequently. In this case, it is recommended that you clear that characteristic in all existing profitability segments, so that new profitability segments do not always need to be created for all later postings.

**Display Detail**

To access the selection criteria and the conversion rule from the hierarchy screen, double-click the desired realignment request.

If you double-click a realignment run, the system displays a dialog box containing the short text of the run and other details. This information includes details about scheduled jobs and each status change. By clicking the *Detail* button for a status change, you can display further information about that step, such as the number of profitability segments changed.

**Copy**

You can copy an existing realignment run or request by positioning the cursor on that line and choosing *Edit → Copy*. You must enter a new text in the copy in order to distinguish it from the original.
Maintaining Realignments

When you copy if a realignment run, the system also copies all the requests (with unchanged texts) it contains. The copy takes on the status "New", because the status information and the change history are not copied.

When you copy a realignment request, the system also copies its selection criteria and conversion rule.

The copy function is particularly useful for repeated broad changes with realignment requests like "Derive customer hierarchy again for large customer".

Move Realignment Request

If you have not yet scheduled or executed a realignment run, you can sort the realignment requests contained there. To do so, select the request you would like to move and then position the cursor on the request below which you want to insert the request. Then choose the Move function. Note that this technique does not let you move a request to the first position within that run. If you want to do this, move the request to the second position and then drop the first request down one.

It is also possible to move a request to another run, provided that that run has not been scheduled or executed.

Test Monitor

A test monitor is available so that you can test complex realignments on individual profitability segments. To do this, position the cursor on a realignment run and choose the Test monitor function. There are two ways to specify which profitability segments you want to test:

- Profitability segments belonging to a reference document (sales document or accounting document) If you choose this option, you should always enter the record type for performance reasons. You are not required to enter an item number. If you do not enter one, the run is executed for all the profitability segments in all items of the reference document.

- Entering the profitability segment number directly

The changes that the realignment would make on the selected profitability segments is displayed as an interactive list. By clicking on the Detail button, you can navigate from the profitability segment to the realignment request and then down to the individual step. By clicking on the Expand button, you can display a "before and after" view of all the characteristic values in one profitability segment. At the first level, only the changed characteristic values are displayed. The second level contains all the characteristic values, with the changed ones highlighted.

Tests using the test monitor do not change the segment table in the database. This function is merely intended to allow you to simulate how the realignment would affect the profitability segments.

Schedule Realignment Run

You can schedule a realignment directly from the maintenance screen. All the functions in Job Administration in the SAP System (immediate or delayed execution, specification of an application server, and so on) are available. To check the job status, use the function Goto → Job overview.

For performance reasons, it is not possible to execute a realignment run online.
Note that it does not make sense to use the periodic scheduling function available in Job Administration, because realignment runs can only be executed or restored successfully once.

**Refresh Status Information**

The current status of a realignment run may differ from the status displayed in the hierarchy if a scheduled job has started in the meantime. To see the current status, choose *Refresh*.

See [Status of Realignment Runs][1].

---

[1]: #/Page/1
Status of Realignment Runs

A realignment run is supposed to make master data changes for a certain number of profitability segments in the CO-PA data basis. These changes can only be made once, so the realignment run can only be executed once (successfully). This is why each run contains status information ("New", "Scheduled", "Running", "Successful", "Terminated", "Restored"). The status of a run can only change as follows:

- **New**
  A new realignment run can change to the status “Scheduled” if you schedule it using `Execute → With/Without starting time` or `Restore → With/Without starting time`.

- **Scheduled**
  When a scheduled run is started, its status changes to “Running”.

- **Running**
  A running job can be completed “successfully” or terminated abnormally. If it is terminated abnormally, its status changes to “Terminated”.

- **Successful or Terminated**
  A run that has been executed successfully or terminated abnormally can then be restored, in which case its status changes to “Restored”. Again, if the restore terminates abnormally, the status becomes “Terminated”.

- **Restored**
  A restored realignment run always keeps this status. If you want to execute the realignment again, you first need to copy the realignment run.

You can test a realignment run at all times. This does not change its status.
Sequence of Requests Within a Realignment Run

The requests in a realignment run are applied to each profitability segment in the order in which they appear in the hierarchy. The changes made to a profitability segment during a run can be largely dependent on the order in which the requests are carried out, as you can see in the following example.

A realignment run “New form of manufacture 10/1/97” contains the following realignment requests.

1. Realignment request “Product 1”: selection criterion: product = 1; conversion rule: set form of manufacture to fixed value “PURCH” and leave all other characteristic values unchanged.
2. Realignment request “Form of manufacture “PURCH” to “EXTERN””: selection criterion: form of manufacture = “PURCH”; conversion rule: set form of manufacture to fixed value “EXTERN” and leave all other characteristic values unchanged.

After this realignment run is executed, the profitability segment with the characteristic values “Product 1”, “Form of manufacture INTERN” will have the values “Product 1”, “Form of manufacture EXTERN”. (The first request changes the form of manufacture to “PURCH”, the second from “PURCH” to “EXTERN”.)

If the order of these requests were reversed, the form of manufacture would have been set to “PURCH”.

However, such effects can only occur when characteristic values are overwritten by fixed values. If you only want to repeat derivation or not change all characteristics, the order of the requests is irrelevant (provided that characteristic derivation has been customized in a way that successive derivations do not repeatedly change the profitability segment).
Restoring Previous States Following Realignments

Use

When you “restore” a realignment run, you return all the profitability segments that were changed by that run to the state they had prior to that realignment.

⚠️

The system does not check whether the profitability segments affected have been changed again in the meantime by other realignments. Consequently, you should always be careful only to carry out restores for the last realignment run executed.

Multiple restores cannot be carried out in parallel or at the same time as a realignment run.

If a restore terminates abnormally, you can repeat it later by scheduling it again.

The information for restoring (the characteristic values of the changed profitability segments) is stored in table CE4xxxx_KENC (where xxxx = operating concern). If you frequently carry out large-scale realignments, this table may become quite large. It therefore might be useful to delete its contents from time to time. The most efficient way to do this is to use the Delete and create again function in the Database Utilities for table CE4xxxx_KENC. If necessary, contact your database administrator regarding this.
Effects on Summarization Levels and Data

It must be possible to ensure that, when you jump between reports using the report/report interface, or when you switch planning screens, the system always displays consistent values regardless of whether the data is selected from the segment table or from a presummarized form.

Consequently, when you perform realignments, this entails the invalidation of all summarization levels and summarization data. This means that you must recreate the summarization levels and data. Only then will access be available again.
Performance, Parallel Processing, and Partitioning

Realignments should not be executed in parallel with processes that post data to Profitability Analysis (more accurately: processes that determine a profitability segment). Especially with large data volumes, the conflicts that arise between read and write actions usually cannot be reconciled by the database system. In most such instances, the reading processes is forced to terminate - in this case, the realignments. Larger realignments can therefore only be processed at a time when the system workload is low and - most importantly - when no postings are made to Profitability Analysis.

Realignment runs in which the conversion rule merely carries out derivation again for some characteristics and does not change the others may be executed at the same time. To avoid unpredictable results, you should always use partitioned datasets when executing realignment runs in parallel. To do this, select one characteristic that divides the dataset into separate parts that are of the desired size. Then you need to define a realignment run for each characteristic values specified, and change each realignment request in the run to include that value as a selection parameter. (Note that the characteristic value used to partition the datasets is not changed during the realignment run.)

Situation: The sales view of a customer master record has changed. You create a realignment run called “Adapt sales hierarchy”, which contains only one realignment request - to derive characteristics WWS01, WWS02, ..., WWS05 of the sales hierarchy. However, your experience tells you that the realignment run cannot be completed during the available time window. The existing profitability segments are equally distributed between the five company codes in your organization (0001 through 0005). Your database hardware, the physical distribution of the data on the hard drives (see also the section Physical Distribution of the Data in CO-PA [Seite 423]), and the available application servers suggest to you that it would be possible to execute multiple runs simultaneously.

Procedure: Create four copies of the realignment run “Adapt sales hierarchy” and change the names to “Adapt sales hierarchy, CoCd 0001”, and so on. In the realignment request of “Adapt sales hierarchy, CoCd 0001”, specify company code 0001 as a selection criterion. Do the same with the other four realignment requests, each time specifying the corresponding company code. Then schedule the realignment runs for execution at the same time.

If the realignment request already contains selection criteria, you need to add this characteristic value to the existing ones.

If the realignment run you are partitioning contains more than one realignment request, you need to add the partitioning characteristic value to each of the requests.

The following realignment run is to be partitioned into two parts depending on the company code (“1000” and “2000”).

Realign.Run0
  Realign.Request1
    Selection criterion
Material hierarchy 1 between 1010 and 1019
Conversion rule
Derive material hierarchy 1 again
Derive material hierarchy 2 again
Derive material hierarchy 3 again

**Realign.Request2**
Selection criterion
Material hierarchy 1 = 1010
Conversion rule
Derive material group again

This yields the following realignment runs:

**Realign.Run1 (CCode 1000)**
**Realign.Request1**
Selection criterion
Material hierarchy 1 between 1010 and 1019
Company code = 1000
Conversion rule
Derive material hierarchy 1 again
Derive material hierarchy 2 again
Derive material hierarchy 3 again

**Realign.Request1**
Selection criterion
Material hierarchy 1 between 1010 and 1019
Company code = 2000
Conversion rule
Derive material hierarchy 1 again
Derive material hierarchy 2 again
Derive material hierarchy 3 again

**Realign.Request2**
Selection criterion
Material hierarchy 1 = 1010
Company code = 2000
Conversion rule
Derive material group again
Valuation

Purpose

In profitability and sales accounting, it is particularly important to have quick access to recent profitability information for sales-related business transactions, and this information should be as complete as possible. To this end, you use valuation for cost-of-sales accounting purposes, completing the information on units sold as well as the price and discount information for your marketing system.

Valuation can be used, for example, to calculate:

- Sales deductions that do not appear in the invoice (such as cash deductions, rebates, and commission)
- Costs of sales (sold products * standard costs of goods manufactured)
- Calculated direct costs, referred to as the special direct costs for sales (such as transportation costs, packaging or insurance)

In what follows, the various valuation options are described, along with the different cases for which you can calculate anticipated values in costing-based Profitability Analysis (CO-PA). Unlike costing-based CO-PA, account-based CO-PA only posts values that are reconcilable with Financial Accounting (FI). This means that the valuation functions described here can only be implemented for costing-based CO-PA.

You can use the valuation options described in this section for actual data as well as for planning data. While you usually valuate your business transactions just after they have occurred (that is, when they are posted), you can also perform a revaluation of your profitability information, to take into account, for example changed costs of goods manufactured.

Features

Valuation Methods

Profitability Analysis offers you the following methods of valuation:
• **Valuation Using Material Cost Estimates [Seite 79]**
  Valuation using material cost estimates lets you determine the cost of sales when you post a sales transaction to Profitability Analysis. For this, the quantities of products sold are multiplied by the standard costs of goods manufactured, thereby including in the contribution margin analysis detailed fixed and variable cost components for the cost of goods manufactured in the individual contribution margins.
  Moreover, you can use the actual cost estimate from Material Ledger to valuate your sales quantities during periodic revaluation.

• **Valuation Using Conditions [Seite 90] and Costing Sheets**
  You can use the condition technique to calculate values in CO-PA that, although relevant for analysis purposes, such as calculating a contribution margin at each level, are not yet established when the document posting occurs. This means in particular that you can determine anticipated sales commissions, discounts, or shipping costs that are not yet known at the time of billing, and use this information to analyze your sales transactions.
  Conditions are typically used in the case of percentage or absolute additions/deductions, for example, that are stored in CO-PA according to criteria that you can select (as in the case of price determination in SD).

• Valuation using customer-defined valuation routines ([Customer Exits: Valuation [Seite 123]])
  Customer-defined valuation routines are available for cases where anticipated valuation approaches cannot be determined using either of the two preceding methods. This means that you can implement your own valuation logic.

**Example**
The value fields in the following contribution margin scheme are filled with data partly from the relevant sales system, and partly from valuation using conditions and valuation using material cost estimates:

<table>
<thead>
<tr>
<th>Gross sales</th>
<th>From the sales system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer discount</td>
<td>From the sales system</td>
</tr>
<tr>
<td>Material discount</td>
<td>From the sales system</td>
</tr>
<tr>
<td>Special offer discount</td>
<td>From the sales system</td>
</tr>
<tr>
<td>Quantity discount</td>
<td>From the sales system</td>
</tr>
<tr>
<td>Cash discounts</td>
<td>Valuation using conditions and costing sheets</td>
</tr>
<tr>
<td>Rebates</td>
<td>Valuation using conditions and costing sheets</td>
</tr>
</tbody>
</table>

**Total sales deductions**

<table>
<thead>
<tr>
<th>Net sales</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales commission</td>
<td>Valuation using conditions and costing sheets</td>
</tr>
<tr>
<td>Accrued freight costs</td>
<td>Valuation using conditions and costing sheets</td>
</tr>
<tr>
<td>Special direct costs for sales</td>
<td>Valuation using conditions and costing sheets</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Net revenue</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Material direct costs</td>
<td>Valuation using material cost estimates</td>
</tr>
</tbody>
</table>
Valuation

Variable production costs ➦ Valuation using material cost estimates

Contribution margin I
Material overhead costs ➦ Valuation using material cost estimates
Fixed production costs ➦ Valuation using material cost estimates

Contribution margin II

Valuation Strategy

You can define a valuation strategy in relation to the point of valuation, the record type, and the plan version (if applicable). You specify in the valuation strategy which of the methods mentioned above (valuation using material cost estimates, valuation using conditions and costing sheets, as well as user exit valuation) are to be used to fill the value fields and in which order these methods are to be implemented.

You define your valuation strategies in Customizing.
Valuation Using Material Cost Estimates

Use

To calculate the cost of sales in Profitability Analysis (CO-PA), there are basically two ways to choose from.

While a retail company only needs to display the total value of goods as cost of sales, a much more detailed breakdown of the costs of goods manufactured is required in a manufacturing company. The costs are represented in the Cost Component Split for Cost of Goods Manufactured [Extern]. The cost component split for costs of goods manufactured subdivides your company's material value into fixed and variable cost components for the cost of goods manufactured (such as material costs, internal services, external services), which can then be entered into different rows during multi-leveled contribution margin accounting.

Valuation with cost estimates therefore valuates in CO-PA the quantities of products sold together with the costing results (such as the standard cost estimate) that were calculated in Product Cost Planning (CO-PC). See also the section Costing Sequence [Extern].

For valuation using cost estimates, you can also define an access key to the Material Ledger [Extern] in order to use the actual cost estimate to valuate your sales quantities during periodic revaluation (see Setting Up Valuation Using Actual Cost Estimates from Material Ledger [Seite 88]).

As an alternative to valuating using material cost estimates, it is possible in retail companies to calculate the value of goods using a condition from the material master or the goods issue document. For more detailed information, see the section...
Valuation Using Material Cost Estimates

Features

To calculate the cost of sales, you define rules in CO-PA Customizing and then use these rules to call up one or more specific material cost estimates in Product Cost Planning. To tailor contribution margin accounting to your needs, you can trace and display different requirements, such as the following examples:

- You wish to call up the standard cost estimate that has been released for material valuation and to calculate the costs of sales that have been reconciled with Financial Accounting (FI) for the goods issue key date.
- In additional rows of your contribution margin report, you wish to calculate the contribution margins for group production costs and then valuate sold products accordingly using group costing.
- As a make-to-order manufacturer, you wish to draw on the sales order costing results stored in the sales order to calculate the cost of sales.
- To display the most reliable early-warning information about the expected result, you wish to valuate your incoming sales orders using future or current costing.
- For planning purposes, you should use a search strategy to check several cost estimates individually and then incorporate them into valuation.

Procedure for Valuation using Material Cost Estimates

The valuation rules described above are stored in Customizing for CO-PA and are defined by the combination of the costing key and the assignment of the costing key to characteristics. How all this is related is depicted in the following graphic:
When a sales order or a billing document is posted, the system first checks whether valuation using material cost estimates is active.

The type of costing that is to be used to calculate the cost of sales is specified in a costing key. Costing keys can be assigned to different characteristic values. The cost components for cost of goods manufactured from Product Cost Planning are assigned to value fields in CO-PA.

**The Costing Key**

You use the costing key to define the rules specifying which cost estimates from Product Cost Planning should be used to valuate the cost of sales in CO-PA. Flexible assignment means that you can assign the desired cost estimates based on the product or material type, or based on any other characteristic in your operating concern. In the costing key, you define the callup parameters required for cost determination. The following includes an example demonstrating the valuation logic:

- You use the costing variant and the costing version to tell the system to access for valuation the standard cost estimate in a particular version.
- As the validity date for the cost estimate, choose the planning period indicator *Released standard cost estimate matching goods issue date* to reconcile the cost of goods manufactured in CO-PA with those in FI.
- Since the delivering plant comes under the organization of a marketing company, you do not wish to read from this plant's cost estimate in order to calculate the costs of goods manufactured. Instead, you wish to read from the production plant. You specify the desired plant in the costing key.
- Alongside the main cost component split, you also copy the auxiliary cost component split. In this way, both the primary cost component split and the cost component split for cost of goods manufactured can be used for analyses in CO-PA.
Activities

To set up valuation using material cost estimates, carry out the steps described in Customizing under *Master Data → Valuation → Set Up Valuation Using Material Cost Estimates [Extern].*
Example: Valuation Using Material Cost Estimates

The following example provides an overview of how valuation using cost estimates from Product Cost Planning works. The valuation strategy has been activated for the point of valuation 01 (valuation of actual data) as well as for the record type F (billing document) uses valuation with costing estimates on the basis of the quantity field "Billed quantity". In the Sales system, a line item is posted with product 4711 and 2 units of quantity (point of valuation 01 and record type F), and valuation using material cost estimates is run.

Assigning costing keys to products

The assignment of cost estimates to products is linked to a point of valuation and a record type. In this example, product 4711, when contained in a document with record type F, is to be valuated at the point of valuation 01 using costing key I01.

Defining how cost estimates are read

Costing key I01 specifies that valuation is to occur using costing variant PPC1 and costing version 1.

Costing Variant PPC1: Value Field Assignment (Field Name 1)

Value Field Assignment: Material

In CO-PC, costing variant PPC1 clearly designates cost component structure 01. According to the value field assignment for cost component structure 01, cost component 10 is assigned to the value field Material costs. The cost estimate found for costing key I01 shows US$ 100 for cost component 10, which contains the material costs. The amount USD 100 is the sum of the fixed and variable portions of the costs. The fixed/variable indicator 3 tells us that the total of the fixed and variable portions are to be transferred to Profitability Analysis. Thus, if the sales quantity is “2”, then the value field Material costs is valuated with USD 200. "Material costs" = 100 * 2 = 200.

Value Field Assignment: Fixed and Variable Production Costs

The fixed and variable shares of cost component 20 are transferred according to value field assignment to the value fields Fixed production costs (F/V indicator 1) and Variable production costs (F/V indicator 2) respectively. If the fixed production costs are USD 200 and the variable costs are USD 50, the sales quantity - 2 units - gives us values of USD 400 and USD 100, respectively. The value fields "Fixed production costs" (200 * 2 = 400) and "Variable production costs" (50 * 2 = 100) are then valuated with these values.

The above scenario is summarized in the graphic below:
Example: Valuation Using Material Cost Estimates

Line item before valuation

<table>
<thead>
<tr>
<th>Record type</th>
<th>Material</th>
<th>Plant</th>
<th>Billed quantity</th>
<th>Material costs</th>
<th>Fixed production costs</th>
<th>Variable production costs</th>
</tr>
</thead>
<tbody>
<tr>
<td>F</td>
<td>4711</td>
<td>0001</td>
<td>2</td>
<td>100</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>200</td>
<td>0</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>100</td>
<td>0</td>
<td>100</td>
</tr>
</tbody>
</table>

CUSTOMIZING

Assign costing key to product

<table>
<thead>
<tr>
<th>Pt</th>
<th>Record type</th>
<th>Material</th>
<th>Costing key</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>F</td>
<td>4711</td>
<td>I01</td>
</tr>
</tbody>
</table>

Define how material cost estimate is to be read

<table>
<thead>
<tr>
<th>Costing key</th>
<th>Costing variant</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>I01</td>
<td>PPC1</td>
<td>1</td>
</tr>
</tbody>
</table>

Assign value fields for cost component structure 01

<table>
<thead>
<tr>
<th>Pt</th>
<th>Component</th>
<th>Description</th>
<th>F/V indicator</th>
<th>Field number</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>10</td>
<td>Material costs</td>
<td>3</td>
<td>Material</td>
</tr>
<tr>
<td>01</td>
<td>20</td>
<td>Production costs</td>
<td>1</td>
<td>Fixed p</td>
</tr>
<tr>
<td>01</td>
<td>20</td>
<td>Production costs</td>
<td>2</td>
<td>Variable</td>
</tr>
</tbody>
</table>

Abbreviations

- “Pt” stands for point of valuation
- “F/V indicator” stands for the fixed/variable indicator.
Example: Valuation Using Material Cost Estimates
Representing Different Requirements

This section will take a potential problem and some typical specifications or inquiries to demonstrate how different requirements for valuation using material cost estimates are displayed.

Customizing

**Problem:** Valuation using material cost estimates either does not function at all or does not function as requested.

**Solution:** You can use the function *Valuation analysis* in manual planning and for actual line item entry. This function allows you to analyze the specific valuation you have performed. The system then informs you of any inconsistencies in your Customizing settings for valuation.

**Valuation Using Different Cost Estimates / Reconciliation with Financial Accounting**

**Specification:** You wish to ensure that the calculated costs of sales are always reconciled with Financial Accounting.

**Implementation:** Create a costing key with the appropriate definition and ensure that it is applied in the valuation of your billing document data. When defining your costing key, activate the planning period indicator so that valuation always occurs using the standard cost estimate that is valid on the goods issue key date.

**Specification:** You wish to valuate your sold products using group costs of goods manufactured.

**Implementation:** For the costing key, choose a costing variant that calculates using the valuation view *Group Valuation*.

**Specification:** You wish to valuate using sales order costing.

**Implementation:** When defining your costing key, make the appropriate setting so that valuation occurs using sales order costing.

**Specification:** You wish to display your cost component split for cost of goods manufactured according to the primary cost breakdown.

**Implementation:** Depending on the Customizing settings, the primary cost component split in product cost accounting is stored either in the main cost component split of a cost component structure or in that structure's auxiliary cost component split. When defining your costing key, make the appropriate setting so that the desired cost component split is used in valuation.

**Parallel / Exclusive Valuation Using Different Material Cost Estimates**

**Specification:** You wish to perform parallel valuation using several cost estimates.

**Implementation:** Assign several costing keys when you perform costing key assignment. You can valuate up to six different material cost estimates in parallel. In Customizing for value field assignment, ensure that the costing data found using the individual costing keys are then posted to different value fields. As an optional setting, you can have the system issue an error message.
if no cost estimate is found for one of the costing keys you have assigned.

**Specification:** During valuation, you wish to use a search strategy to look for several cost estimates individually and to execute valuation using just the first material cost estimate found.

**Implementation:** Assign several costing keys and make the setting in the costing key so that the system runs valuation exclusively with a single cost estimate.
Setting Up Valuation Using Actual Cost Estimates from Material Ledger

Use

In Profitability Analysis, not only can you valuate your sales quantities using a standard price determined with a standard cost estimate, but you can also valuate them using actual cost estimates from Material Ledger. You can copy the actual cost estimate either as a single total as the average transfer price or in detail as the actual cost component split. Valuation using actual cost estimates occurs periodically after period-end closing has been performed in Material Ledger, thereby determining the actual cost estimate.

In the information system in Profitability Analysis, you can compare the COGM cost components for the standard cost estimate with those for the actual cost estimate. This allows you to analyze where any variances have occurred.

The following section describes the procedure that you follow if you set up valuation using actual cost estimates retrospectively. This is the case, for example, if the application component Actual Costing/Material Ledger is installed after Profitability Analysis.

Prerequisites

- Valuation using material cost estimates (for a standard cost estimate) should be set up in Customizing for Profitability Analysis (under Master Data → Valuation → Set Up Valuation Using Material Cost Estimates [Extern]).

- The application component Actual Costing/Material Ledger is activated for the relevant Valuation Areas [Extern] (in Customizing under Controlling → Product Cost Controlling → Actual Costing/Material Ledger → Activate Valuation Areas for Material Ledger [Extern]).

- Actual costing is activated for the relevant valuation areas (in Customizing for Actual Costing/Material Ledger under Actual Costing → Activate Actual Costing [Extern]).

- If you want to copy the actual cost estimate in detail to be used as the actual cost component split, the actual cost component split must be activated for the relevant valuation areas (in Customizing for Actual Costing/Material Ledger under Actual Costing → Activate Actual Costing [Extern]).

Procedure

1. Decide how you would like the actual costing values to be copied and displayed. You have the following options:
   - You can copy the actual cost estimate as a total (just periodic transfer price) or in detail (periodic transfer price and actual cost component split).
   - You can overwrite the standard cost estimate with the actual cost estimate or you can create your own value fields for the actual cost estimate (in Customizing for Profitability Analysis under Structures → Maintain Value Fields [Extern]).
Setting Up Valuation Using Actual Cost Estimates from Material Ledger

These two options can also be applied together. If you copy the actual cost estimate in detail, you can place the periodic transfer price, for example, in a value field of its own, while overwriting the standard cost estimate values with the actual cost component split.

If you copy the actual costs in detail and want to place all values into new value fields, you need to create the following value fields:

- A value field for the periodic transfer price
- An extra value field for each of the individual cost components (as with the value fields for the standard cost estimates)

2. If you have created new value fields, include them in the operating concern and then activate the operating concern (in Customizing for Profitability Analysis under Structures → Maintain Operating Concern [Extern]).

3. Create a valuation strategy for valuation using actual cost estimates and activate the Material Cost Estimate indicator. Assign this valuation strategy to point of valuation 02 (Periodic Revaluation).

4. Define a costing key for the actual cost estimate (in Customizing for Profitability Analysis under Master Data → Valuation → Set Up Valuation Using Material Cost Estimate → Define Access to Actual Costing/Material Ledger [Extern]). In the costing key, assign the periodic transfer price to the corresponding value field.

5. Assign the costing key for point of valuation 02 to a product, a material type or - using flexible access - to any combination of CO-PA characteristics (using the corresponding activities in Customizing for Profitability Analysis under Master Data → Valuation → Set Up Valuation Using Material Cost Estimate).

6. If you want to copy the actual cost component split in detail, assign the individual cost components to the corresponding value fields (in Customizing for Profitability Analysis under Master Data → Valuation → Set Up Valuation Using Material Cost Estimate → Assign Value Fields [Extern])

7. If required, define a profitability report with which to compare the value fields from the standard cost estimate with those from the actual cost estimate.

Result

Once the costing run for periodic actual costing has been run in Material Ledger (see Process Flow: Periodic Actual Costing [Extern]), you can copy the actual cost estimate using periodic valuation for Profitability Analysis (see Periodic Valuation of Actual Data [Seite 129]).
Valuation Using Conditions

Use

The condition technique allows you to calculate anticipated values using percentage additions/deductions, prices, or absolute amounts. As with price determination in SD, you can use the condition technique to define a set of rules for calculating anticipated freight costs, for example. In the following section, you can find a description of how you can define the set of rules to suit your own valuation needs.

For more information, see Pricing and Conditions [Extern] in the online documentation for Sales and Distribution (SD).

Features

To supplement data that is being processed from the Sales and Distribution (SD) component or from Planning in CO-PA, define a set of rules in Customizing which you can then use to calculate the appropriate values and to post them to CO-PA. For example, you could include the following requirements for calculating values:

- You wish to assign additions/deductions (percentage or quantity-dependent) or fixed values to the corresponding value fields.
- The additions and deductions should be calculated in relation to certain combinations of characteristics that you are free to choose (such as customer and product).
- They should also be calculated using a multi-leveled callup logic. A price, for example, should first be found for special combinations of customers and products. If this price cannot be found, the system looks through the product groups for a valid price or searches at the division level.
- Instead of taking just those individual value fields that already have been filled with data in the line item as the basis for calculating additions and deductions, subtotals or value fields filled with data during valuation should also be used where applicable.
- You wish to calculate the value of goods using a condition from the material master or the goods issue document.

All these above requirements can be met using the condition technique. Before going into detail about the procedure for displaying the possible strategies, it is necessary to discuss various concepts. The possible valuation strategies are then outlined in an example, followed by a description of how to represent business requirements.

Costing Sheets

In a costing sheet, you specify which conditions should be used to calculate anticipated values. This is also where you determine the sequence in which the conditions are to be considered and the dependencies between them. For example, you can define the condition that sales commission be calculated on the basis of the sales revenue.

In Planning, you can use costing sheets from SD alongside those that you created in CO-PA.

In the costing sheet, you specify the following:

- The basis on which the additions or deductions are to be calculated
- The subtotals to be calculated
The dependencies between conditions
The sequence in which calculation is to occur

**Condition Types, Condition Tables, and Condition Records**

A **condition type** represents one step in a costing sheet. Condition types can

- Determine fixed amounts and calculate additions and deductions (percentage or quantity-dependent)
- Read prices (such as the standard price) from master records
- Serve as the basis for calculating additions and deductions (base conditions), or
- Find characteristic-dependent values through accessing series of **condition tables** (The values that are to be determined on the basis of characteristic values are stored in this case as **condition records** in the condition tables).

Each condition record stores the condition data maintained manually for certain combinations of characteristic values. For example, a condition record could be a price ("USD 3") for a certain product or a percentage charge or reduction ("3 %") for a certain customer.

**Access Sequences and Condition Tables**

During valuation, the system follows an access sequence to find valid condition records for a condition type. From a technical point of view, these condition records are stored in condition tables. The condition table determines the key combination (such as customer and product group) for which the condition record is to be stored and to be used in valuation.

A condition table can be used in more than one access sequence. Thus, the access sequence determines:

- The condition tables that are used to access condition records, and
- The order in which these condition tables are read
**Profitability Analysis (COPA)**

**Valuation Using Conditions**

### How the Elements of the Condition Tool Fit Together

The costing sheet forms the calculation logic for valuation using conditions. Here you determine the order in which the condition types are processed. Each condition type can be assigned one access sequence (or none, depending on the condition category). This access sequence in turn can access one or more condition tables. A condition table can be used in more than one access sequence. Moreover, it can store more than one condition record.

#### Multiple Costing Sheets

You can use more than one costing sheet with the same valuation strategy. This makes sense if you want to calculate prices with different quantity fields.

Note that if multiple condition types are assigned to the same value field, the values are added together. This is also the case when the condition types belong to different costing sheets.
Multiple Valuation Methods

In valuation, the system never overwrites an existing value (other than “0”) in any value field. This means that values transferred directly from billing documents in Sales and Distribution (SD) are not changed during valuation. Likewise, values already taken from material cost estimates cannot be overwritten with the values calculated in a costing sheet.

Values transferred from the sender document and manually entered values (other than zero) are consequently never changed during valuation. The only exception to this is in CO-PA planning, where valuation always overwrites the manually entered values.

Different valuation techniques - for example, material cost estimate or conditions - do not overwrite any value fields that are filled (value <> zero) or add values to the existing values. You can only add values within one valuation technique.

Activities

To set up valuation using conditions, choose Master Data → Valuation → Define Conditions and Costing Sheets [Extern] in Customizing.
Example: Valuation Using Conditions

Here is an example of valuation using conditions. The valuation strategy has been activated for the point of valuation 01 (valuation of actual data) as well as for the record type F (billing document) uses valuation with the costing sheet ACT001 on the basis of the quantity field "Billed quantity". In the sales system SD, the characteristic values "Product" 4711, "Customer group" 3 and "Sales organization" 001 are posted to a line item. The billed quantity is 2 and the revenue is 2000. Since billing occurs at the point of valuation 01 (actual data) and comes under record type F (billing document), valuation occurs using conditions.

- **Costing sheet and condition types**

  The condition types for the values to be calculated are summarized in costing sheet ACT001 (condition types REVN and PROV in the example). You also specify in the costing sheet what will be the calculation basis for a condition (condition PROV is calculated on the basis of REVN, and this is defined by the level specification).

  For each condition type, you maintain the parameters that are to be employed to calculate the anticipated values. The example uses a base condition (REV) and an addition/reduction condition with a percentage charge or reduction (PROV). Moreover, the access sequence Z200 has been assigned to the addition condition PROV.

- **Access Sequences, Condition Tables, Condition Records**

  An access sequence defines the order in which the system accesses different condition tables.

  A condition table contains condition records for each combination of valid characteristic values (in the case of the condition type PROV in condition table 506, for example, the valid characteristic values are those for the characteristics "Sales organization" and "Customer group").

  In the example, access sequence Z200 accesses condition table 506. This condition table contains a condition record for sales organization 0001 and customer group 03 that specifies a value of 5%. If you select the field *Exclusive*, the system will not search for any more condition records in the tables that follow in that access sequence (in this case table 507).

- **Value Field Assignment**

  The value field assignment determines the value field in CO-PA to which the value for a condition type is to be transferred. (For example, the condition type "PROV" is assigned to the value field "Commission".)

  From the definition of the condition types, we can see that the condition record (5%) found for the sales commission (condition type PROV) uses the value for condition type REVN as a basis. In the value field assignment we see that the condition type "REVN" is assigned to the value field "Revenue". Thus the line item in CO-PA shows a revenue of USD 2000. This yields CMSN\(= 5\% \times 2000 = 100\).

  This value is then transferred to the value field "Commission" as defined in the value field assignment (condition type "PROV" to value field "Commission"). The line item is thus valuated according to the specified strategy.
Example: Valuation Using Conditions

### Line item before valuation

<table>
<thead>
<tr>
<th>Record type</th>
<th>Material</th>
<th>Customer grp</th>
<th>Sales organization</th>
<th>Billed quantity</th>
<th>Rev.</th>
<th>Commission</th>
</tr>
</thead>
<tbody>
<tr>
<td>F</td>
<td>4711</td>
<td>3</td>
<td>0001</td>
<td>2</td>
<td>2000</td>
<td>100</td>
</tr>
</tbody>
</table>

### Customizing

#### Maintain costing sheet ACT00
- **Level**: 
  - **Condition type**: 10 REVN
  - **From level**: 10
  - **To level**: PROV

#### Create condition types

<table>
<thead>
<tr>
<th>Cond. type</th>
<th>Cond. category</th>
<th>Cond. class</th>
<th>Calc. type</th>
<th>A</th>
<th>REVN</th>
<th>Base amount</th>
<th>Prices</th>
<th>Fixed amount</th>
<th>PROV</th>
<th>Surch./dedctn</th>
<th>Percentage</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Specify access sequences: Access for Z200

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>506</td>
<td>Access sales organization and material</td>
</tr>
<tr>
<td>507</td>
<td>Access to sales organization</td>
</tr>
</tbody>
</table>

#### Assign value fields

<table>
<thead>
<tr>
<th>Condition type</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROV</td>
<td>Commission</td>
</tr>
<tr>
<td>REVN</td>
<td>Revenue</td>
</tr>
</tbody>
</table>

### Line item after valuation

<table>
<thead>
<tr>
<th>Record type</th>
<th>Material</th>
<th>Customer grp</th>
<th>Sales organization</th>
<th>Billed quantity</th>
<th>Revenue</th>
<th>Commission</th>
</tr>
</thead>
<tbody>
<tr>
<td>F</td>
<td>4711</td>
<td>3</td>
<td>0001</td>
<td>2</td>
<td>2000</td>
<td>100</td>
</tr>
</tbody>
</table>
Condition Types

Definition
A condition type [Extern] represents one step in a costing sheet.

Structure
What calculation the system carries out in that step depends on the following control indicators:

- Condition category
- Calculation type
- Condition class
- Scale basis

Condition Category
The condition category classifies condition types according to predefined categories.

The following condition categories are used in Profitability Analysis:

<table>
<thead>
<tr>
<th>Code</th>
<th>Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>Cash discount</td>
</tr>
<tr>
<td>G</td>
<td>Transfer cost according to price control indicator in the material master</td>
</tr>
<tr>
<td>K</td>
<td>Base value</td>
</tr>
<tr>
<td>S</td>
<td>Standard price</td>
</tr>
<tr>
<td>T</td>
<td>Moving average price</td>
</tr>
<tr>
<td></td>
<td>Blank — used for condition types that represent sales deductions or additions that do not fit into any of the above categories</td>
</tr>
</tbody>
</table>

Calculation Type
The calculation type determines how the system calculates prices, deductions, or additions for a condition type. For example, it can specify that a sales deduction should be dependent on the quantity sold or on a value scale.

The following calculation types are used in Profitability Analysis:

<table>
<thead>
<tr>
<th>Code</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Percentage</td>
</tr>
<tr>
<td>B</td>
<td>Fixed amount</td>
</tr>
<tr>
<td>C</td>
<td>Quantity-based</td>
</tr>
</tbody>
</table>
Condition Class
The condition class divides condition types into two different classes:

<table>
<thead>
<tr>
<th></th>
<th>Deductions/additions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>Prices</td>
<td></td>
</tr>
</tbody>
</table>

Scale Basis
The scale basis determines how the system interprets the value or quantity scale for a condition. Scales can be dependent on a quantity or on a currency amount.

The following scale bases are used in Profitability Analysis:

<table>
<thead>
<tr>
<th></th>
<th>Value scale</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>Quantity scale</td>
<td></td>
</tr>
</tbody>
</table>

Examples of Condition Types
How a condition type behaves depends on the values specified for the aforementioned attributes. The following is a list of all the combinations possible in Profitability Analysis, followed by some examples showing the effect of these combinations.

<table>
<thead>
<tr>
<th>Condition type</th>
<th>Cond. cat.</th>
<th>Calc. type</th>
<th>Cond. class</th>
<th>Scale basis</th>
<th>Acc. seq.</th>
</tr>
</thead>
<tbody>
<tr>
<td>a) Base amount</td>
<td>K</td>
<td>B</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>b) Prices from the material master</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ba) Standard price or moving average price, depending on price control indicator</td>
<td>G</td>
<td>C</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>bb) Standard price</td>
<td>S</td>
<td>C</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>bc) Moving average price</td>
<td>T</td>
<td>C</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>c) Cash discounts from customer master</td>
<td>E</td>
<td>A</td>
<td>A</td>
<td></td>
<td></td>
</tr>
<tr>
<td>d) Percentage addition/deduction</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Condition Types</td>
<td>A</td>
<td>A</td>
<td>B</td>
<td>C</td>
<td>Yes</td>
</tr>
<tr>
<td>---------------------------------------</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td>-----</td>
</tr>
<tr>
<td>da) Not scaled</td>
<td>-</td>
<td>A</td>
<td>A</td>
<td>-</td>
<td>Yes</td>
</tr>
<tr>
<td>db) Scaled by value</td>
<td>-</td>
<td>A</td>
<td>A</td>
<td>B</td>
<td>Yes</td>
</tr>
<tr>
<td>dc) Scaled by quantity</td>
<td>-</td>
<td>A</td>
<td>A</td>
<td>C</td>
<td>Yes</td>
</tr>
<tr>
<td>ea) Additions/reductions scaled by quantity</td>
<td>-</td>
<td>C</td>
<td>A</td>
<td>-</td>
<td>Yes</td>
</tr>
<tr>
<td>eb) Scaled by value</td>
<td>-</td>
<td>C</td>
<td>A</td>
<td>B</td>
<td>Yes</td>
</tr>
<tr>
<td>ec) Scaled by quantity</td>
<td>-</td>
<td>C</td>
<td>A</td>
<td>C</td>
<td>Yes</td>
</tr>
<tr>
<td>f) Fixed amount</td>
<td>-</td>
<td>B</td>
<td>B</td>
<td>-</td>
<td>Yes</td>
</tr>
<tr>
<td>fa) Not scaled</td>
<td>-</td>
<td>B</td>
<td>B</td>
<td>-</td>
<td>Yes</td>
</tr>
<tr>
<td>fb) Scaled by value</td>
<td>-</td>
<td>B</td>
<td>B</td>
<td>B</td>
<td>Yes</td>
</tr>
<tr>
<td>fc) Scaled by quantity</td>
<td>-</td>
<td>B</td>
<td>B</td>
<td>C</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Examples: Condition Types

Whenever an access sequence is used in the following example, this access sequence is understood to access a condition table whose key is defined by the characteristic Material group.

(a) Reference base

Condition category  K (Base amount)
Calculation type     B (Fixed amount)
Condition class     B (Prices)
Scale basis         -
Access sequence     None

This type of condition is a base condition for revenues from SD. Distribution (SD). This condition type can be used in a costing sheet to calculate additions or deductions depending on the revenue.

(b) Prices from the material master

Condition category  S (Standard price)
Calculation type     C (Quantity-based)
Condition class     B (Prices)
Scale basis         -
Access sequence     None

The standard price is read from the material master. For example, suppose that the standard price for material "M099312" is USD 100.00 a piece. If you have sold 5 units of this material, the condition takes on the value USD 500.00.

(c) Cash discounts from customer master

Condition category  E (Cash discount)
Calculation type     A (Percentage)
Condition class     A (Deductions/additions)
Scale basis         -
Access sequence     None

The percentage for the cash discount is read from the terms of payment in the customer master. If the payment terms provide for a cash discount of 3% for a payment within 14 days, the percentage is determined as 3%.

(da) Percentage addition/deduction (not scaled)
Condition Types

Condition category -
Calculation type A (Percentage)
Condition class A (Deductions/additions)
Scale basis -
Access sequence Yes

For material groups “312”, “313” and “314”, you can maintain the following condition records:

<table>
<thead>
<tr>
<th>Material group</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>312</td>
<td>1</td>
<td>% (set by the system)</td>
</tr>
<tr>
<td>313</td>
<td>2</td>
<td>%</td>
</tr>
<tr>
<td>314</td>
<td>1.5</td>
<td>%</td>
</tr>
</tbody>
</table>

These condition records can be used, for example, to calculate the expected outgoing freight.

(db) Percentage addition/deduction (scaled)

Condition category -
Calculation type A (Percentage)
Condition class A (Deductions/additions)
Scale basis B (Scaled by value)
Access sequence Yes

For material group “312”, you can define the following value scale:

<table>
<thead>
<tr>
<th>From value</th>
<th>Scale currency</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>10,000</td>
<td>USD</td>
<td>3</td>
<td>%</td>
</tr>
<tr>
<td>50,000</td>
<td>USD</td>
<td>3.5</td>
<td>%</td>
</tr>
</tbody>
</table>

This lets you define the expected sales commission depending on the revenue generated.

(dc) Percentage addition/deduction (scaled by quantity)

For material group “312”, you can define the following quantity scale:

Condition category -
Calculation type A (Percentage)
Condition class A (Deductions/additions)
Scale basis C (Quantity-based)
Access sequence Yes

<table>
<thead>
<tr>
<th>From quantity</th>
<th>Unit</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>Boxes</td>
<td>1</td>
<td>%</td>
</tr>
<tr>
<td>5000</td>
<td>Boxes</td>
<td>2</td>
<td>%</td>
</tr>
</tbody>
</table>

This lets you define expected discounts depending on the quantity sold.

**(ea) Quantity-based addition/deduction (not scaled)**

Condition category -
Calculation type C (Quantity-based)
Condition class A (Deductions/additions)
Scale basis -
Access sequence Yes

For material group “312”, you can define the following condition record:

<table>
<thead>
<tr>
<th>Material group</th>
<th>Amount</th>
<th>Unit per</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>312</td>
<td>1</td>
<td>USD 1</td>
<td>Boxes</td>
</tr>
</tbody>
</table>

This lets you assess, for example, USD 1 per box for packaging material.

**(eb) Quantity-based addition/deduction (scaled)**

Condition category -
Calculation type C (Quantity-based)
Condition class A (Deductions/additions)
Scale basis B (Scaled by value)
Access sequence Yes

For material group “312”, you can define the following value scale:

<table>
<thead>
<tr>
<th>From value</th>
<th>Scale currency</th>
<th>Amount</th>
<th>Unit per</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>USD</td>
<td>0.10</td>
<td>USD 1</td>
<td>Boxes</td>
</tr>
</tbody>
</table>
Condition Types

<table>
<thead>
<tr>
<th>Condition Types</th>
<th>From quantity</th>
<th>Amount</th>
<th>Unit per</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>500 USD 0.20 USD 1 Boxes</td>
<td>1000 Boxes</td>
<td>0.01 USD</td>
<td>1 Boxes</td>
<td></td>
</tr>
<tr>
<td>500 USD 0.20 USD 1 Boxes</td>
<td>10000 Boxes</td>
<td>0.03 USD</td>
<td>1 Boxes</td>
<td></td>
</tr>
</tbody>
</table>

(ec) Quantity-based addition/deduction (scaled by quantity)

Condition category -
Calculation type C (Quantity-based)
Condition class A (Deductions/additions)
Scale basis C (Quantity-based)
Access sequence Yes

For material group “312”, you can define the following quantity scale:

<table>
<thead>
<tr>
<th>From quantity</th>
<th>Amount</th>
<th>Unit per</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000 Boxes</td>
<td>0.01 USD</td>
<td>1 Boxes</td>
<td></td>
</tr>
<tr>
<td>10000 Boxes</td>
<td>0.03 USD</td>
<td>1 Boxes</td>
<td></td>
</tr>
</tbody>
</table>

(fa) Fixed amount (not scaled)

Condition category -
Calculation type B (Fixed amount)
Condition class B (Prices)
Scale basis -
Access sequence Yes

For material group “312”, you can define the following condition record:

<table>
<thead>
<tr>
<th>Material group</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>312</td>
<td>100</td>
<td>USD</td>
</tr>
</tbody>
</table>

(fb) Fixed amount (scaled)

Condition category -
Calculation type B (Fixed amount)
Condition class B (Prices)
Scale basis B (Scaled by value)
Access sequence Yes

For material group “312”, you can define the following value scale:
Condition Types

<table>
<thead>
<tr>
<th>From value</th>
<th>Scale currency</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>USD</td>
<td>20</td>
<td>USD</td>
</tr>
<tr>
<td>5000</td>
<td>USD</td>
<td>30</td>
<td>USD</td>
</tr>
</tbody>
</table>

(fc) Fixed amount (scaled)

Condition category -
Calculation type B (Fixed amount)
Condition class B (Prices)
Scale basis C (Quantity-based)
Access sequence Yes

For material group “312”, you can define the following quantity scale:

<table>
<thead>
<tr>
<th>From quantity</th>
<th>Unit</th>
<th>Amount</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>Boxes</td>
<td>50</td>
<td>USD</td>
</tr>
<tr>
<td>10000</td>
<td>Boxes</td>
<td>70</td>
<td>USD</td>
</tr>
</tbody>
</table>
Meeting Managerial Requirements

This section contains a detailed example that illustrates how you can use conditions to valuate actual data in Profitability Analysis to help meet your management requirements.

Procedure

The first part of this example explains the requirements. Then a suitable concept is laid out for using conditions to meet these requirements.

The section “Operating Concern” gives you more detailed information about the settings that are presumed to have been made in CO-PA and in Sales and Distribution (SD).

That is followed by a step-by-step explanation of how you work with conditions.

Objective

We want to calculate net revenue as the sales revenue minus customer discounts and price reductions, and then calculate the cost of sales based on the net revenue. This amount will then be used to calculate sales commission,

which can differ in rate in different sales organizations. In some cases, we also want to define a special commission rate for certain materials within each sales organization.

We also want to calculate our anticipated costs for outgoing freight as a percentage of the cost of sales. This percentage should differ from plant to plant.

And finally, we want to calculate anticipated costs for outgoing packaging as a percentage of the sales quantity. These costs will differ depending on the plant and, in some cases, the product being sold.

Concept

These requirements immediately tell us the three conditions that we need to calculate:

- Sales commission
- Outgoing freight
- Outgoing packaging

The sales commission is to be calculated based on the difference between the net revenue and the cost of sales. This net revenue is the gross revenue minus customer discount and price reduction. The outgoing freight and outgoing packaging are calculated on the basis of the cost of sales and the sales quantity, respectively.

Thus we can represent all of these conditions in the following form:

<table>
<thead>
<tr>
<th>Line</th>
<th>Component</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Revenue</td>
</tr>
<tr>
<td>20</td>
<td>% customer discount</td>
</tr>
<tr>
<td>30</td>
<td>% price reduction</td>
</tr>
<tr>
<td>40</td>
<td>Net revenue</td>
</tr>
</tbody>
</table>
The revenue, customer discount, price reduction and cost of sales are all transferred from SD to CO-PA in the original billing document. In Profitability Analysis, lines 40, 60, 100, 300, and 310 need to be calculated, with the results in lines 100, 300, and 310 being passed on to the appropriate value fields.

To carry out this calculation using conditions, we first need to define a condition type for each line in the formula, with the exception of lines 40 and 60, which simply represent subtotals.

The costing sheet forms the framework within which you can use conditions for valuation. A costing sheet determines the order in which the conditions are processed and the way in which they are interrelated.

We therefore need to create a costing sheet that contains all the condition types we require.

A costing sheet — **ACT001** — that meets our requirements would look like this:

<table>
<thead>
<tr>
<th>Line</th>
<th>Counter</th>
<th>Cond.type</th>
<th>Description</th>
<th>From step</th>
<th>To step</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>0</td>
<td>REVN</td>
<td>Revenue</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>20</td>
<td>0</td>
<td>DISC</td>
<td>Customer discount</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>30</td>
<td>0</td>
<td>DISP</td>
<td>Price reduction</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>40</td>
<td>0</td>
<td></td>
<td>Net revenue</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>50</td>
<td>0</td>
<td>COGS</td>
<td>Cost of sales</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>60</td>
<td>0</td>
<td></td>
<td>Base for calculating commission</td>
<td>40</td>
<td>50</td>
</tr>
<tr>
<td>100</td>
<td>0</td>
<td>PROV</td>
<td>Commission</td>
<td>60</td>
<td>0</td>
</tr>
<tr>
<td>300</td>
<td>0</td>
<td>OUPA</td>
<td>Outgoing packaging</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>310</td>
<td>0</td>
<td>OUTF</td>
<td>Outgoing freight</td>
<td>50</td>
<td>0</td>
</tr>
</tbody>
</table>

Remember that the sales commission is supposed to be calculated based on the sales organization and the product. Thus in order to be able to maintain condition records for the condition type **PROV**, we first need to define an access sequence, which we will call **Z100**. And since the condition records are to be maintain for two different combinations of characteristics — the sales organization alone, and the sales organization together with the product — we need to define two condition tables: **A502**, which contains the fields “Sales organization” and “Product”, and **A503**, which contains the field “Sales organization”.

---

**Table 1:**

<table>
<thead>
<tr>
<th>Line</th>
<th>Counter</th>
<th>Cond.type</th>
<th>Description</th>
<th>From step</th>
<th>To step</th>
</tr>
</thead>
<tbody>
<tr>
<td>50</td>
<td></td>
<td>% cost of sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>60</td>
<td></td>
<td>Base for calculating commission</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>100</td>
<td></td>
<td>Commission = percentage/100 * line</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>300</td>
<td></td>
<td>Outgoing packaging = amount * sales quantity</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>310</td>
<td></td>
<td>Outgoing freight = percentage/100 * value</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The outgoing packaging costs should be calculated depending on either the shipping plant or the combination of plant and product. We therefore need to define two condition tables: A505, which uses the characteristics “Plant” and “Product”, and A506, which only uses “Plant”. The system should access these tables as defined in access sequence Z200.

The outgoing freight is supposed to depend on what plant is delivering the goods. We therefore need another access sequence — Z300 — which reads a condition table that contains the characteristic “Plant”. Since one condition table can be used for different access sequences, we can use table A506 again here.

Condition types REVN, DISC, DISP, and COGS are “base condition types”, which are used to calculate other conditions. Base condition types do not need an access sequence. These conditions are transferred directly from the source document (billing document in SD).

<table>
<thead>
<tr>
<th>CO-PA conditions</th>
<th>→</th>
<th>CO-PA value fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>COGS</td>
<td>VV140</td>
<td>Cost of sales</td>
</tr>
<tr>
<td>DISC</td>
<td>VV030</td>
<td>Customer discount</td>
</tr>
<tr>
<td>DISP</td>
<td>VV050</td>
<td>Price reduction</td>
</tr>
<tr>
<td>OUPA</td>
<td>VV140</td>
<td>Dispatch packaging</td>
</tr>
<tr>
<td>OUTF</td>
<td>VV110</td>
<td>Anticipated outgoing freight</td>
</tr>
<tr>
<td>PROV</td>
<td>VV130</td>
<td>Sales commission</td>
</tr>
</tbody>
</table>
Condition types **COGS**, **DISC**, **DISP**, and **REVN** are assigned to the same value fields as the corresponding SD condition types for revenues, customer discounts, and price reductions. Thus the values for these conditions are first transferred from SD to the corresponding CO-PA value fields, from where they can be used for the conditions in the CO-PA costing sheet. This ensures that there is a direct link between the original SD condition type and that defined in CO-PA.

| Data flow: SD cond. type → CO-PA value field → CO-PA cond. type |
|------------------------|------------------------|------------------------|
| Example: PR00           | VV010                  | REVN                   |

Condition type **OUPA** (outgoing packaging) should be calculated based on the quantity billed in terms of the sales quantity unit. In this example, that is the quantity field **VVIQT**.

The functions for maintaining these components of the conditions tool are found in Customizing for Profitability Analysis. To access them, choose

*Master data → Valuation → Conditions and Costing Sheets*

When you maintain conditions, it is recommended that you proceed in the order shown there. First, define the condition tables, since these are the prerequisite for creating access sequences. Then you can define the access sequences, followed by the condition types and finally the costing sheet.

**The Operating Concern**

**1. The Fields of the Operating Concern**

In this example, we are going to assume that we are working in an operating concern that contains at least the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VVIQT</td>
<td>Invoiced quantity in the sales quantity unit</td>
</tr>
<tr>
<td>VVSQT</td>
<td>Invoiced quantity in the storage quantity unit</td>
</tr>
<tr>
<td>VV010</td>
<td>Revenue</td>
</tr>
<tr>
<td>VV020</td>
<td>Quantity discount</td>
</tr>
<tr>
<td>VV030</td>
<td>Customer discount</td>
</tr>
<tr>
<td>VV040</td>
<td>Material discount</td>
</tr>
<tr>
<td>VV050</td>
<td>Price reduction</td>
</tr>
<tr>
<td>VV060</td>
<td>Miscellaneous discounts</td>
</tr>
</tbody>
</table>
Condition Types

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VV070</td>
<td>Cash discount</td>
</tr>
<tr>
<td>VV110</td>
<td>Anticipated outgoing freight</td>
</tr>
<tr>
<td>VV120</td>
<td>Dispatch packaging</td>
</tr>
<tr>
<td>VV130</td>
<td>Sales commission</td>
</tr>
<tr>
<td>VV140</td>
<td>Cost of sales</td>
</tr>
</tbody>
</table>

Characteristics

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VKORG</td>
<td>Sales organization</td>
</tr>
<tr>
<td>ARTNR</td>
<td>Product number</td>
</tr>
<tr>
<td>WERKS</td>
<td>Plant</td>
</tr>
</tbody>
</table>

2. The SD Interface

The following fields are transferred from SD billing documents:

<table>
<thead>
<tr>
<th>SD quantity fields</th>
<th>CO-PA quantity fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>FKIMG</td>
<td>VVIQT</td>
</tr>
<tr>
<td></td>
<td>Invoiced quantity in</td>
</tr>
<tr>
<td></td>
<td>sales quantity unit</td>
</tr>
<tr>
<td>FKLMG</td>
<td>VVSQT</td>
</tr>
<tr>
<td></td>
<td>Invoiced quantity in</td>
</tr>
<tr>
<td></td>
<td>storage quantity unit</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SD condition types</th>
<th>CO-PA quantity fields</th>
</tr>
</thead>
<tbody>
<tr>
<td>PR00</td>
<td>VV010</td>
</tr>
<tr>
<td></td>
<td>Revenue</td>
</tr>
<tr>
<td>PI00</td>
<td>VV010</td>
</tr>
<tr>
<td></td>
<td>Revenue</td>
</tr>
<tr>
<td>KP00</td>
<td>VV020</td>
</tr>
<tr>
<td></td>
<td>Quantity discount</td>
</tr>
<tr>
<td>BO03</td>
<td>VV030</td>
</tr>
<tr>
<td></td>
<td>Customer discount</td>
</tr>
<tr>
<td>K029</td>
<td>VV040</td>
</tr>
<tr>
<td></td>
<td>Material discount</td>
</tr>
<tr>
<td>K004</td>
<td>VV040</td>
</tr>
<tr>
<td></td>
<td>Material discount</td>
</tr>
<tr>
<td>K030</td>
<td>VV050</td>
</tr>
<tr>
<td></td>
<td>Price reduction</td>
</tr>
<tr>
<td>K020</td>
<td>VV060</td>
</tr>
<tr>
<td></td>
<td>Miscellaneous discounts</td>
</tr>
<tr>
<td>SKTO</td>
<td>VV070</td>
</tr>
<tr>
<td></td>
<td>Cash discount</td>
</tr>
</tbody>
</table>
Using Conditions to Meet Your Requirements

When you make your Customizing settings for implementing valuation with conditions, it is recommended that you proceed in the following order:

1. Define condition tables
2. Define access sequences
3. Define condition types
4. Maintain condition records
5. Define costing sheet
6. Assign conditions to value fields
7. Define valuation strategy
8. Data Flow and Calculation of Condition Values

This order is not obligatory and is intended merely as orientation for less experienced users. Since not all the activities in Customizing are given in hierarchical fashion, every user can develop his or her own technique for working with the conditions tool.

Defining Condition Tables

In the example being discussed here, we need to create three condition tables. We can do this using the Customizing function *Maintain condition tables*:

<table>
<thead>
<tr>
<th>Table</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table 502</td>
<td>Table using the fields “Sales organization” and “Product”</td>
</tr>
<tr>
<td>Table 503</td>
<td>Table using the field “Sales organization”</td>
</tr>
<tr>
<td>Table 505</td>
<td>Table using the fields “Plant” and “Product”</td>
</tr>
<tr>
<td>Table 506</td>
<td>Table using the field “Plant”</td>
</tr>
</tbody>
</table>

Defining Access Sequences

Now we can define the required access sequences using the Customizing function *Define access sequences*:

Access sequence Z100 (Internal sales commission)
Condition Types

<table>
<thead>
<tr>
<th>No.</th>
<th>Table</th>
<th>Description</th>
<th>Requirement</th>
<th>Exclusive</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>502</td>
<td>Sales organization/Product</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>2</td>
<td>503</td>
<td>Sales organization</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

As a general rule, the access conditions should become more general as you go down: A table with more detailed selection criteria (2 characteristics) should thus come before a table with less detailed criteria (1 characteristic).

You should set the *Exclusive* indicator when you want the system to stop looking for condition records as soon as the first valid one is found for the given condition type.

This means that if the system finds a condition record for a combination of sales organization and product, it uses this record and does not search the second table for valid records for the sales organization. If we were to leave the *Exclusive* indicator blank here, the system would search through both tables and add together the individual condition records if more than one were found. However, this does not make sense here.

The other access sequences — **Z200** and **Z300** — look like this:

<table>
<thead>
<tr>
<th>No.</th>
<th>Table</th>
<th>Description</th>
<th>Requirement</th>
<th>Exclusive</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>505</td>
<td>Plant/Product</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>2</td>
<td>506</td>
<td>Plant</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>No.</th>
<th>Table</th>
<th>Description</th>
<th>Requirement</th>
<th>Exclusive</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>506</td>
<td>Plant</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

Defining Condition Types

The condition types **REVN**, **DISC**, and **DISP** form the basis for calculating the net revenue. The values for these condition types are transferred directly from the billing document in SD. Consequently, these condition types are defined as base condition types. It is not necessary to maintain condition records. The attributes need to be defined as follows:

1. **Condition Type REVN (Revenue)**

   Access sequence None

   **Control data:**
   - Condition category **K** Base value
   - Calculation type **B** Fixed amount
Condition Types

2. Condition Type DISC (Customer Discount)

<table>
<thead>
<tr>
<th>Access sequence</th>
<th>None</th>
</tr>
</thead>
</table>

Control data:

<table>
<thead>
<tr>
<th>Condition category</th>
<th>K Base value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation type</td>
<td>B Fixed amount</td>
</tr>
<tr>
<td>Condition class</td>
<td>B Prices</td>
</tr>
<tr>
<td>Scale basis</td>
<td></td>
</tr>
</tbody>
</table>

Condition master maintenance:

<table>
<thead>
<tr>
<th>Plus/minus</th>
<th>X Minus sign only</th>
</tr>
</thead>
</table>

We need to make this condition type negative because we want to subtract the customer discount from the revenue.

3. Condition Type DISP (Price Reduction)

<table>
<thead>
<tr>
<th>Access sequence</th>
<th>None</th>
</tr>
</thead>
</table>

Control data:

<table>
<thead>
<tr>
<th>Condition category</th>
<th>K Base value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation type</td>
<td>B Fixed amount</td>
</tr>
<tr>
<td>Condition class</td>
<td>B Prices</td>
</tr>
<tr>
<td>Scale basis</td>
<td></td>
</tr>
</tbody>
</table>

Condition master maintenance:

<table>
<thead>
<tr>
<th>Plus/minus</th>
<th>X Minus sign only</th>
</tr>
</thead>
</table>

We need to make this condition type negative because we want to subtract the price reduction from the revenue.

4. Condition type COGS (Cost of sales)
Condition Types

Condition type **COGS** (cost of sales) forms the basis for calculating the sales commission. We want to transfer the cost of sales directly from the billing document. Consequently, we do not need to maintain condition records. We also define this condition type as a base condition type.

<table>
<thead>
<tr>
<th>Access sequence</th>
<th>None</th>
</tr>
</thead>
</table>

**Control data:**
- **Condition category:** K Base value
- **Calculation type:** B Fixed amount
- **Condition class:** B Prices
- **Scale basis**

**Condition master maintenance:**
- **Plus/minus:** X Minus sign only

We need to make this condition type negative because we want to subtract the cost of sales from the net revenue.

**Condition Types PROV, OUPA, and OUTF**

We want to use condition types **PROV**, **OUPA**, and **OUTF** to calculate additions or reductions based on the above conditions or on subtotals calculated from these. We therefore need to define them as addition or reduction conditions that use an access sequence to find valid condition records.

**Condition Type PROV (Commission)**

<table>
<thead>
<tr>
<th>Access sequence</th>
<th>Z100</th>
<th>Internal sales commission</th>
</tr>
</thead>
</table>

**Control data:**
- **Condition category**
- **Calculation type:** A Percentage
- **Condition class:** A Deductions/additions
- **Scale basis**

**Condition Type OUPA (Outgoing Packaging)**

<table>
<thead>
<tr>
<th>Access sequence</th>
<th>Z200</th>
<th>Outgoing packaging</th>
</tr>
</thead>
</table>
Condition Types

<table>
<thead>
<tr>
<th>Control data:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition category</td>
<td></td>
</tr>
<tr>
<td>Calculation type</td>
<td>C Quantity-based</td>
</tr>
<tr>
<td>Condition class</td>
<td>A Deductions/additions</td>
</tr>
<tr>
<td>Scale basis</td>
<td></td>
</tr>
</tbody>
</table>

Condition Type OUTF (Outgoing Freight)

<table>
<thead>
<tr>
<th>Control data:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition category</td>
<td></td>
</tr>
<tr>
<td>Calculation type</td>
<td>A Percentage</td>
</tr>
<tr>
<td>Condition class</td>
<td>A Deductions/additions</td>
</tr>
<tr>
<td>Scale basis</td>
<td></td>
</tr>
</tbody>
</table>

4. Maintaining Condition Records

You can maintain condition records directly when you maintain the condition types. These condition records are maintained for the condition tables defined in the access sequence:

1. **Condition Type PROV**

Condition records for the characteristic combination “Sales organization/Product” (table A502)

| Validity period 12/09/1998 | | |
|-----------------------------|------------------|
| Sales org.                  | Product          | Amount       |
| 0001                        | CK-700 Chocolate | 10.000 %     |
| 0001                        | CK-710 Vanilla waffles | 12.000 % |

Condition records for the characteristic “Sales organization” (table A503)

| Validity period 12/09/1998 | | |
|-----------------------------|------------------|
| Sales org.                  | Amount           |
| 0001                        | Germany          | 2.000 %       |
| 0002                        | USA              | 4.000 %       |

2. **Condition Type OUPA**
Condition Types

Condition records for the characteristic combination "Plant/Product" (table A505)

<table>
<thead>
<tr>
<th>Plant</th>
<th>Product</th>
<th>Amount</th>
<th>Unit per Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>CK-700 Chocolate</td>
<td>4.0</td>
<td>US$ 1 BOX</td>
</tr>
<tr>
<td>1000</td>
<td>CK-701 Chocolate candies</td>
<td>3.9</td>
<td>US$ 1 BOX</td>
</tr>
</tbody>
</table>

Condition records for the characteristic “Plant” (table A506)

<table>
<thead>
<tr>
<th>Plant</th>
<th>Amount</th>
<th>Unit per Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>Hamburg</td>
<td>1.50 US$ 1 BOX</td>
</tr>
</tbody>
</table>

3. Condition Type OUTF

Condition records for the characteristic “Plant” (table A506)

<table>
<thead>
<tr>
<th>Plant</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>Hamburg 2.000 %</td>
</tr>
<tr>
<td>1100</td>
<td>Berlin 4.000 %</td>
</tr>
<tr>
<td>1200</td>
<td>Dresden 8.000 %</td>
</tr>
<tr>
<td>1300</td>
<td>Karlsruhe 5.000 %</td>
</tr>
</tbody>
</table>

5. Defining a Costing Sheet

Once we have maintain the condition types and their condition records, we can create costing sheet ACT001 in Customizing using the Maintain costing sheet function.

Costing sheet ACT001

<table>
<thead>
<tr>
<th>Step</th>
<th>Counter</th>
<th>Cond.type</th>
<th>Description</th>
<th>From step</th>
<th>To step</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>0</td>
<td>REVN</td>
<td>Revenue</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>20</td>
<td>0</td>
<td>DISC</td>
<td>Customer discount</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>30</td>
<td>0</td>
<td>DISP</td>
<td>Price reduction</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>40</td>
<td>0</td>
<td></td>
<td>Net revenue</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>50</td>
<td>0</td>
<td>COGS</td>
<td>Cost of sales</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>60</td>
<td>0</td>
<td></td>
<td>Base for calculating commission</td>
<td>40</td>
<td>50</td>
</tr>
<tr>
<td>110</td>
<td>0</td>
<td>PROV</td>
<td>Commission</td>
<td>60</td>
<td>0</td>
</tr>
<tr>
<td>300</td>
<td>0</td>
<td>OUPA</td>
<td>Outgoing packaging</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>310</td>
<td>0</td>
<td>OUTF</td>
<td>Outgoing freight</td>
<td>50</td>
<td>0</td>
</tr>
</tbody>
</table>
The number in the *Step* column determines the order in which the conditions are processed. The *Counter* column is only of interest if you want to work with more than one condition type in the same step. The fields *From step* and *To step* determine the steps to be used as the basis for calculating a given line. If you make entries in both of these fields, the system adds together the values in both of these steps and any steps that lie between them. The sum is then used as the basis for calculating the current line.

Condition types *REVN*, *DISC*, and *DISP* are “base condition types”, whose values are transferred directly from the billing documents. We therefore do not need to enter any reference steps. The same applies to condition type *COGS*.

In step 40, the net revenue is calculated as the subtotal of steps 10 through 30. Since condition types *DISC* and *DISP* are negative, the system calculates the net revenue as follows:

\[
\text{REVN} - \text{DISC} - \text{DISP} = \text{Net revenue}
\]

Step 50 contains the cost of sales *COGS*, as a negative value. The sum of steps 40 and 50 form the basis for determining the sales commission:

\[
\text{Net revenue} - \text{COGS} = \text{Basis for sales commission}
\]

Commission (*PROV*) is then calculated on the basis of step 60 (From step = 60). For example, if a value of 10% is found for sales organization 1000 and product CK-700, step 110 calculates the following:

\[
\text{PROV} = \frac{\text{Basis for sales commission}}{100} \times 10
\]

The outgoing packaging (*OUPA*) is calculated based on the quantity sold. Thus the basis used for determining the value of this condition is a quantity field and not another condition. This means that no reference step is necessary. We will define which quantity field should be the basis for calculating quantity-dependent condition values when we assign the costing sheet to a valuation strategy.

Let us assume that 2 BOX (boxes) of product CK-700 are sold from plant 1000, the system finds a condition record “4 US$/BOX”. This yields the following value:

\[
\text{OUPA} = 2 \text{ KAR} \times 4 \text{ US$/KAR} = 8 \text{ US$}
\]

The outgoing freight (*OUTF*) is calculated on the basis of the cost of sales (from step 50), which is a negative value. In plant 1000, for example, the value would be:

\[
\text{OUTF} = (- \text{cost of sales}) \times 2/100
\]

### 6. Assigning Conditions to Value Fields

Now that the values for the base condition types have been transferred from the billing document and the calculated conditions have been calculated, we need to assign these condition types to the value fields in Profitability Analysis so that the values can be transferred to the CO-PA line.
Condition Types

This assignment must always be in line with the assignments made between SD condition types and value fields when you set up the SD/CO-PA interface.

With the Assign value fields function in Customizing, you tell the system which value fields should be used as source fields for base condition types and which as target fields for the addition or reductions calculated in the costing sheet.

These assignments were already determined upon the conception of this valuation scenario and can be copied exactly here.

<table>
<thead>
<tr>
<th>CO-PA cond. type</th>
<th>&lt;---&gt;</th>
<th>CO-PA value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>COGS</td>
<td>VV140</td>
<td>Cost of sales</td>
</tr>
<tr>
<td>DISC</td>
<td>VV030</td>
<td>Customer discount</td>
</tr>
<tr>
<td>DISP</td>
<td>VV050</td>
<td>Price reduction</td>
</tr>
<tr>
<td>OUPA</td>
<td>VV120</td>
<td>Dispatch packaging</td>
</tr>
<tr>
<td>OUTF</td>
<td>VV110</td>
<td>Anticipated outgoing freight</td>
</tr>
<tr>
<td>PROV</td>
<td>VV130</td>
<td>Sales commission</td>
</tr>
<tr>
<td>REVN</td>
<td>VV010</td>
<td>Revenue</td>
</tr>
</tbody>
</table>

7. Defining A Valuation Strategy

A valuation strategy controls the overall valuation process. You need to enter your costing sheets in a valuation strategy in order for them to take effect.

In this example, we therefore want to enter costing sheet ACT001 in valuation strategy 001. The quantity field we want to use is VVIQT (the invoiced quantity in the sales quantity unit). This quantity thus becomes the basis for calculating condition type OUPA (outgoing packaging).

<table>
<thead>
<tr>
<th>Sequence</th>
<th>Appl.</th>
<th>Costing sheet</th>
<th>Description</th>
<th>Mat. CE</th>
<th>Quantity field</th>
<th>Exit no.</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td></td>
<td>ACT001</td>
<td>X</td>
<td>VVIQT</td>
<td>VVIQT</td>
<td></td>
</tr>
</tbody>
</table>

This entry causes costing sheet ACT001 to be processed immediately after the system reads a material cost estimate.

You must assign a quantity field to the costing sheet here whenever the costing sheet contains a quantity-dependent condition type.
8. Data Flow and Calculation of Condition Values

To show how the condition values are calculated, here is the entire data flow that take place when a billing document is transferred from SD to Profitability Analysis.

The Billing Document:

Sales organization 0001
Distribution channel 01
Division 05

Item 10 contains 1 BOX (= 10 PC) of product CK-701 with the following condition values:

<table>
<thead>
<tr>
<th>Cond. type</th>
<th>Description</th>
<th>Amount</th>
<th>Currency per</th>
<th>Unit</th>
<th>Condition value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PR00</td>
<td>Price</td>
<td>10.00</td>
<td>US$</td>
<td>1</td>
<td>100.00 US$</td>
</tr>
<tr>
<td></td>
<td>Gross</td>
<td>10.00</td>
<td>US$</td>
<td>1</td>
<td>100.00 US$</td>
</tr>
<tr>
<td>K030</td>
<td>Customer/material group discount</td>
<td>5.00-</td>
<td>%</td>
<td></td>
<td>5.00- US$</td>
</tr>
<tr>
<td>BO03</td>
<td>Customer rebate</td>
<td>6.00-</td>
<td>%</td>
<td></td>
<td>6.00- US$</td>
</tr>
<tr>
<td>VPRS</td>
<td>Cost</td>
<td>4.00</td>
<td>US$</td>
<td>1</td>
<td>40.00 US$</td>
</tr>
</tbody>
</table>

The following values are transferred to the CO-PA line item according to the definition of the interface with SD:

The CO-PA Line Item Before Valuation:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRGAR</td>
<td>Record type</td>
<td>F</td>
</tr>
<tr>
<td>VKORG</td>
<td>Sales organization</td>
<td>0001</td>
</tr>
<tr>
<td>VTWEG</td>
<td>Distribution channel</td>
<td>01</td>
</tr>
<tr>
<td>SPART</td>
<td>Division</td>
<td>05</td>
</tr>
<tr>
<td>ARTNR</td>
<td>Product</td>
<td>CK-701</td>
</tr>
<tr>
<td>KNDNR</td>
<td>Customer</td>
<td>900687</td>
</tr>
<tr>
<td>WERKS</td>
<td>Plant</td>
<td>1000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>VVIQT</td>
<td>Invoiced quantity in sales quantity unit</td>
<td>1</td>
<td>US$</td>
</tr>
<tr>
<td>VVSQQT</td>
<td>Invoiced quantity in sales quantity unit</td>
<td></td>
<td>US$</td>
</tr>
</tbody>
</table>
Condition Types

<table>
<thead>
<tr>
<th>Cond.type</th>
<th>Description</th>
<th>Value field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>VV010</td>
<td>Revenue</td>
<td>VV010</td>
<td>10.00</td>
</tr>
<tr>
<td>VV030</td>
<td>Customer discount</td>
<td>VV030</td>
<td>100.00</td>
</tr>
<tr>
<td>VV050</td>
<td>Price reduction</td>
<td>VV050</td>
<td>6.00</td>
</tr>
<tr>
<td>VV110</td>
<td>Anticipated outgoing freight</td>
<td>VV110</td>
<td>5.00</td>
</tr>
<tr>
<td>VV120</td>
<td>Dispatch packaging</td>
<td>VV120</td>
<td>0.00</td>
</tr>
<tr>
<td>VV130</td>
<td>Sales commission</td>
<td>VV130</td>
<td>0.00</td>
</tr>
<tr>
<td>VV140</td>
<td>Cost of sales</td>
<td>VV140</td>
<td>40.00</td>
</tr>
</tbody>
</table>

The following values are then transferred from the CO-PA value fields to the individual CO-PA condition types according to the assignments we made earlier:

<table>
<thead>
<tr>
<th>Cond.type</th>
<th>Description</th>
<th>Value field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>REVN</td>
<td>Revenue</td>
<td>VV010</td>
<td>100.00</td>
</tr>
<tr>
<td>DISC</td>
<td>Customer discount</td>
<td>VV030</td>
<td>6.00</td>
</tr>
<tr>
<td>DISP</td>
<td>Price reduction</td>
<td>VV050</td>
<td>5.00</td>
</tr>
<tr>
<td>COGS</td>
<td>Cost of sales</td>
<td>VV140</td>
<td>40.00</td>
</tr>
<tr>
<td>PROV</td>
<td>Commission</td>
<td>VV130</td>
<td>0.00</td>
</tr>
<tr>
<td>OUPA</td>
<td>Outgoing packaging</td>
<td>VV120</td>
<td>0.00</td>
</tr>
<tr>
<td>OUTF</td>
<td>Outgoing freight</td>
<td>VV110</td>
<td>0.00</td>
</tr>
</tbody>
</table>

The costing sheet "ACT001" is assigned the quantity field "VVIQT", which contains the value "1 BOX".

As defined in our valuation strategy "001", the system now processes the individual steps in this costing sheet:

<table>
<thead>
<tr>
<th>Step</th>
<th>Counter</th>
<th>Condition type</th>
<th>Description</th>
<th>From step</th>
<th>To step</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>0</td>
<td>REVN</td>
<td>Revenue</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Condition type "REVN" is a base condition, so no condition records are read and no calculations performed. "REVN" contains the value "100.00 US$", which was copied from field "VV010".
Condition type “DISC” is a base condition, so no condition records are read and no calculations performed. “DISC” contains the value “-6.00 US$”, which was copied from field “VV030”. This value is negative, because the condition type was defined as negative.

30 0 DISP Price reduction 0 0

Condition type “DISP” is a base condition, so no condition records are read and no calculations performed. “DISP” contains the value “-5.00 US$”, which was copied from field “VV050”. This value is negative, because the condition type was defined as negative.

40 0 Net revenue 10 30

The net revenue is a totals row that contains the sum of the value in steps 10 through 30:

<table>
<thead>
<tr>
<th>Step</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>100.00 US$</td>
</tr>
<tr>
<td>20</td>
<td>6.00- US$</td>
</tr>
<tr>
<td>30</td>
<td>5.00- US$</td>
</tr>
<tr>
<td>Total</td>
<td>Net revenue 89.00 US$</td>
</tr>
</tbody>
</table>

50 0 COGS Cost of sales 0 0

Condition type “COGS” is a base condition, so no condition records are read and no calculations performed. “COGS” contains the value “-40.00 US$”, which was copied from field “VV140”. This value is negative, because the condition type was defined as negative.

60 0 Base for calculating commission 40 50

The basis for calculating commission is a totals row that contains the sum of the values in steps 40 through 50:

<table>
<thead>
<tr>
<th>Step</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>40</td>
<td>89.00 US$</td>
</tr>
<tr>
<td>50</td>
<td>40.00- US$</td>
</tr>
<tr>
<td>Total</td>
<td>Basis for calculating commission 49.00 US$</td>
</tr>
</tbody>
</table>

110 0 PROV Commission 60 0

Condition type “PROV” is an addition for which condition records are to be found using access sequence “Z100”. The line item contains the sales organization “0001” and the product “CK-701”.

April 2001
Condition Types

According to access sequence “Z100”, the system should first look for a condition record in condition table “A502”. However, this table does not contain an entry for sales organization “0001” and product “CK-701”. Consequently, the system also searches condition table “A503” for a valid condition record. Here it finds a percentage of 2% for sales organization “0001”, and thus copies this value.

Condition type “PROV” references step 60, the totals for “Basis for calculating commission”. This means that the percentage found should be applied to the value in this step. This yields:

\[
\text{Base for calculating commission} \times \text{Percentage} = \text{PROV}
\]

\[
49.00 \text{ US$} \times \frac{2}{100} = 0.98 \text{ US$}
\]

Condition type “OUPA” is a quantity-based addition for which condition records are to be found using access sequence “Z200”. The line item contains the plant “1000” and the product “CK-701”.

According to access sequence “Z200”, the system should first look for condition records in condition table “A505”. There it finds an entry of $3.90/BOX for the plant “1000” and the product “CK-701”. Condition table “A506”, which is also contained in the access sequence, also has a condition record for plant “1000”. However, the system does not read this table because the Exclusive indicator is selected.

Condition type “OUPA” does not reference another step. However, this condition type is quantity-dependent, so the quantity field “VVIQT” is used as the basis:

\[
\text{Invoiced quantity in sales quantity unit} \times \text{Amount} = \text{OUPA}
\]

\[
1 \text{ BOX} \times 3.90 \text{ US$/BOX} = 3.90 \text{ US$}
\]

Condition type “OUTF” is a reduction for which condition records are to be found using access sequence “Z300”. The line item contains plant “1000”.

According to access sequence “Z300”, the system should first look for condition records in condition table “A506”. Here it finds a percentage of 2% for plant “1000”, and thus copies this value.

Condition type “OUTF” references step 50, the cost of sales “COGS”. This means that the percentage found should be applied to the value for this condition type. This yields:

\[
\text{Cost of sales} \times \text{Percentage} = \text{OUTF}
\]

\[
40.00\text{- US$} \times \frac{2}{100} = 0.80 \text{ US$}
\]

If the system is unable to find any valid condition record using the specified access sequence, it automatically enters “0” for the relevant condition type. No error message is displayed. Thus in our example the cost of sales would have been multiplied by 0%, which gives us outgoing packaging costs of 0.00 US$. 


After all the steps have been calculated, the costing sheet gives us the following values:

<table>
<thead>
<tr>
<th>Step</th>
<th>Counter</th>
<th>Condition type</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>0</td>
<td>REVN</td>
<td>Revenue</td>
<td>100.00 US$</td>
</tr>
<tr>
<td>20</td>
<td>0</td>
<td>DISC</td>
<td>Customer discount</td>
<td>6.00- US$</td>
</tr>
<tr>
<td>30</td>
<td>0</td>
<td>DISP</td>
<td>Price reduction</td>
<td>5.00- US$</td>
</tr>
<tr>
<td>40</td>
<td>0</td>
<td></td>
<td>Net revenue</td>
<td>89.00 US$</td>
</tr>
<tr>
<td>50</td>
<td>0</td>
<td>COGS</td>
<td>Cost of sales</td>
<td>40.00- US$</td>
</tr>
<tr>
<td>60</td>
<td>0</td>
<td></td>
<td>Base for calculating commission</td>
<td>49.00 US$</td>
</tr>
<tr>
<td>110</td>
<td>0</td>
<td>PROV</td>
<td>Commission</td>
<td>0.98 US$</td>
</tr>
<tr>
<td>300</td>
<td>0</td>
<td>OUPA</td>
<td>Outgoing packaging</td>
<td>3.90 US$</td>
</tr>
<tr>
<td>310</td>
<td>0</td>
<td>OUTF</td>
<td>Outgoing freight</td>
<td>0.80- US$</td>
</tr>
</tbody>
</table>

The condition values are then transferred to the CO-PA line item according to the value field assignment made earlier. Note that this only applies to the conditions calculated in the costing sheet — the base conditions (here, condition types "REVN", "DISC", "DISP", and "COGS") are not written back to the value fields. Their value field assignment merely shows the value fields from which their values were taken.

**The CO-PA Line Item After Valuation:**

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>VRGAR</td>
<td>Record type</td>
<td>F</td>
</tr>
<tr>
<td>VKORG</td>
<td>Sales organization</td>
<td>0001</td>
</tr>
<tr>
<td>VTWEG</td>
<td>Distribution channel</td>
<td>01</td>
</tr>
<tr>
<td>SPART</td>
<td>Division</td>
<td>05</td>
</tr>
<tr>
<td>ARTNR</td>
<td>Product</td>
<td>CK-701</td>
</tr>
<tr>
<td>KNdNR</td>
<td>Customer</td>
<td>900687</td>
</tr>
<tr>
<td>WERKS</td>
<td>Plant</td>
<td>1000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>VVIQT</td>
<td>Invoiced quantity in sales quantity unit</td>
<td>1</td>
<td>BOX</td>
</tr>
<tr>
<td>VVSQT</td>
<td>Invoiced quantity in storage quantity unit</td>
<td>10</td>
<td>BOX</td>
</tr>
<tr>
<td>VV010</td>
<td>Revenue</td>
<td>100.00</td>
<td>US$</td>
</tr>
<tr>
<td>VV030</td>
<td>Customer discount</td>
<td>6.00</td>
<td>US$</td>
</tr>
</tbody>
</table>
### Condition Types

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
<th>Value</th>
<th>Currency</th>
</tr>
</thead>
<tbody>
<tr>
<td>VV050</td>
<td>Price reduction</td>
<td>5.00</td>
<td>US$</td>
</tr>
<tr>
<td>VV110</td>
<td>Anticipated outgoing freight</td>
<td>0.80</td>
<td>US$</td>
</tr>
<tr>
<td>VV120</td>
<td>Dispatch packaging</td>
<td>3.90</td>
<td>US$</td>
</tr>
<tr>
<td>VV130</td>
<td>Sales commission</td>
<td>0.98</td>
<td>US$</td>
</tr>
<tr>
<td>VV140</td>
<td>Cost of sales</td>
<td>40.00</td>
<td>US$</td>
</tr>
</tbody>
</table>

This line item is then posted.
Customer Exits: Valuation

Purpose

To make it possible to valuate data in ways not supported by the system, SAP allows you to program your valuation routines using a Customer-Exit [Extern].

You can maintain the customer exit using SAP standard enhancement COPA0002 in SAP Project Management. Call up Project Management from CO-PA Customizing using the function Tools → SAP Enhancements. There you will find the technical information needed to set up a user exit as well as an example.

For more information about valuation using customer-specific valuation routines, see the sections on valuation in CO-PA Customizing.
Analysis Options Using Valuation

Use

There are various functions with which you can analyze your Customizing settings for valuating actual and planning data.

Features

- With the Customizing Monitor, you can gain an overview of all the Customizing settings relevant to CO-PA valuation.
- The Valuation Analysis option is attached to different functions (such as manual line item entry [Seite 305] or manual planning) and enables you to analyze in detail at the value field level all the individual valuation steps executed by the system during a given CO-PA valuation strategy.
- With the Valuation Simulation function, you can analyze the effect Customizing settings have at different points of valuation, without having to use a posting transaction.

Customizing Monitor

You access the CO-PA Customizing Monitor by choosing Tools → Analysis → Check Customizing Settings. Then you can select the Overview of valuation node to display - in conjunction with the operating concern, point of valuation, and record type - the valuation strategies that have been defined.

Valuation Analysis

You can perform detailed valuation analysis using a range of functions with which valuation is possible. Examples of such functions are:

- Manual Line Item Entry [Seite 305]
- Simulating Billing Document Transfer [Extern] (you access the analysis tool by choosing Tools → Analysis in CO-PA Customizing)
- Simulation of Document Transfer from Incoming Sales Orders [Extern]
- Subsequent Posting of Billing Documents [Seite 272]
- Periodic Valuation of Actual Data [Seite 129]
- Manual Planning Data Entry [Seite 160]

When you have carried out valuation, start the analysis by choosing Extras → Valuation analysis. The system then presents you with information about the business transactions in the valuation strategy that you executed. Such information includes the values that were entered and those that were issued. Moreover, you can display detailed information about the individual valuation methods and then jump to the Customizing settings.

Among the options open to you, you can execute a condition analysis for valuation with conditions and run an access analysis to see how a material cost estimate is read with flexible access. You call up these two functions separately:

- For the access analysis, choose Extras → Analyze Product Cost Planning
For the condition analysis, choose Edit → Condition analysis

**Valuation Simulation**

To test valuation in detail or to run a detailed analysis of errors, you can simulate valuation in Customizing by choosing Tools → Analysis → Valuation Simulation [Extern] for the different points of valuation. The screen that appears matches that for manual line item entry, but no values are posted. From this screen, you can use the valuation analysis described above, as well as the separate condition and access analyses.

Changes that you make at the same time in Customizing for valuation take immediate effect in this function, without your first having to quit the transaction.
Activate Valuation in Planning

Use

For valuation in planning, you can use the same valuation techniques as those that you use for actual flows of values. To valuate your planning data, you can, on the one hand, use costing sheets from Sales and Distribution (SD) as well as CO-PA-specific costing sheets, and, on the other hand, call up material cost estimates from Product Cost Planning (CO-PC). Furthermore, you can also use the valuation customer exit in planning. One function that is only available in planning is that for valuation using transfer prices.

Prerequisites

Firstly, you need to specify with which values you would like to valuate your planned quantities. Accordingly, you need to ensure that the values relevant to planning are filled with data in one of the following ways: via an SD costing sheet, via a costing sheet created in CO-PA, via a costing sheet from Product Cost Planning, or via a user-defined valuation routine.

This section explains the necessary steps for activating valuation in planning.

Procedure

Valuation Using SD Price Determination (SD Costing Sheet)

Price determination in SD is generally too detailed to be used directly for valuation in CO-PA planning. This is coupled with the technical requirement that characteristics accessed in valuation must be known to CO-PA planning. This means, firstly, that such characteristics must be present in CO-PA and included in the operating concern, and, secondly, that they should either appear in the planning level or be supplied with data via derivation. However, this is not always the case.

1. It is recommended that you identify which conditions in the relevant SD costing sheet are required for valuation in planning and that you then create a new costing sheet in SD for those conditions.
2. Create a valuation strategy for planning in CO-PA Customizing by choosing Master Data → Valuation → Valuation Strategies → Define and Assign Valuation Strategy.
3. Under Detail → New Entries, include the SD costing sheet into the valuation strategy. In the Application field, enter V (for sales). Then select the quantity field to be valuated.
4. Under Assignment of valuation strategy, assign the valuation strategy to a point of valuation for planning, a record type, and a plan version.

Valuation Using Anticipated Values (CO-PA Costing Sheet)

To valuate your planning data using anticipated values as well, you can use costing sheets defined in CO-PA. Then establish which costing sheet is relevant for your planning.

1. In your planning-based valuation strategy, create a new entry and enter the CO-PA costing sheet into it.
2. In the Application field, enter KE (for Profitability Analysis).
3. Then select the quantity field to be valuated.

Valuation Using Material Cost Estimate from Product Cost Planning
(Costing Key from CO-PC)
To valuate your planned quantities using cost of goods manufactured, you can call up in CO-PA planning costing keys from Product Cost Planning. First establish which costing key is relevant.

1. Dependent on whether the material cost estimate is read for products, for material types, or for a particular combination of characteristics, make the required settings in one of the following Customizing activities under Master Data → Valuation → Set Up Valuation Using Material Cost Estimates:

   - Assigning costing keys to products
   - Assign Costing Keys to Material Types
   - Assign Costing Keys to Any Characteristics

2. Here you assign the valuation strategy for each product, material type or characteristic combination to a point of valuation in planning, a record type, and a plan version.

3. Under Master Data → Valuation → Set Up Valuation Using Material Cost Estimates → Assign Value Fields, you assign the components of the component structure to the value fields in CO-PA and to a point of valuation.

4. In your planning-based valuation strategy, create a new entry and set the Material Cost Estimate indicator. Then select the quantity field to be valuated.

Valuation Using Transfer Prices
To valuate your planned quantities using transfer prices, you can call up in CO-PA planning transfer price variants that you created in Profit Center Accounting.

1. First define a transfer price variant in Customizing for Profit Center Accounting under Transfer Prices → Basic Settings for Pricing.

2. Create a new entry in the valuation strategy you use for planning and enter this transfer price variant in the Variant for TP field.

   🔴

   You can only use a valuation strategy with a transfer price variant in planning because valuation using transfer prices is only possible in planning.

3. Specify the value field into which the transfer price is to be set, such as the Revenue value field. Then select the quantity field to be valuated.

4. To take into account the costs of goods manufactured from the profit center view as well, create another entry in the valuation strategy for an appropriately defined valuation using material cost estimates (see also Content of Profit Center Valuation [Seite 321]).

Result
When you have made your Customizing settings, you can execute the Enter planning data planning method and analyze valuation by choosing Extras → Valuation Analysis.

If you would like to test the settings you have made before execution, perform Valuation Simulation [Extern] for the appropriate point of valuation. You reach simulation in Customizing under Tools → Analysis → Valuation Simulation.
Periodic Valuation of Actual Data

Purpose

Periodic valuation makes it possible for you to select and valuate actual data which has already been posted to Profitability Analysis (CO-PA). It uses a valuation strategy defined especially for the point of valuation 02 (Periodic actual valuation). This function is available for the record types A (incoming sales orders) and F (billing data) as well as user-defined record types.

Periodic valuation is useful, for example, if you posted line items to CO-PA at the beginning of the period using the standard cost of goods manufactured, and want to valuate them again later using the most up-to-date costs or using the actual costs of goods manufactured determined in Material Ledger [Extern] (see also Setting Up Valuation Using Actual Cost Estimates from Material Ledger [Seite 88]).

The system posts the difference between the original values of the line item and the new values in a new, separate line item. If you perform periodic valuation more than once for a single line item, the system posts a new “difference” line item each time the values change.

Once you have performed periodic valuation, you can display the new values in the information system.

For valuation using material cost estimates, you can choose the alternative option of displaying the periodically calculated values separately from the original values. To do this, you need to define special value fields into which to store the values from periodic valuation.

💡

Only values that are calculated in CO-PA during valuation can be recalculated in periodic valuation. However, those quantities and values that are stored according to the same value field assignment found in SD pricing when transferred from sales orders and billing documents remain unchanged.
Performing Periodic Valuation

Purpose

To be able to perform periodic valuation, you need to assign a valuation strategy to the point of valuation 02 (Actual periodic valuation). You do this in Customizing under Master Data → Valuation → Valuation Strategy → Define and Assign Valuation Strategy [Extern].

You must define valuation using the material cost estimate for the stated point of valuation. For this, you can use either an access key to the standard cost estimate for Product Cost Planning or the actual cost estimate from the Material Ledger [Extern]. If you want to see exactly which values were found using periodic valuation, you need to assign the components of the cost component split used to separate value fields for periodic valuation in Profitability Analysis.

You can find the function for performing periodic valuation in the CO-PA application by choosing Actual postings → Period end closing → Periodic adjustments. The system takes you through the following screens:

- On the initial screen, you can enter the record type and the time range of the line items you want to valuate.
- On the Periodic Valuation: Characteristics screen, you can specify characteristic values to limit the selection further. An asterisk (*) for a characteristic means that the system selects all the values of that characteristic.
- On the Periodic Valuation: Value Fields screen, you can explicitly select the value fields you want to valuate.

💡 If you need to process a large amount of data, execute periodic valuation in a series of successive partial runs (by valuating each period separately, for example).

To keep the system workload down, you should execute periodic valuation in the background.

When you perform periodic valuation, make sure that the valuation strategy that is assigned to the point of valuation 01 (Realtime valuation of actual data) remains available. This is the only way to ensure that the correct differences to the original values are found.
Results of Periodic Valuation

The system reads the posted line items from the line item table (CE1xxxx, where xxxx = operating concern) according to the selection criteria you specified. In the following, these line items will be referred to as “original line items”.

The system determines the new values on the basis of the valuation strategy that was defined for periodic actual valuation. The system creates a delta line item as follows for each original line item found:

- The system uses the same characteristic values as in the original line item (no derivation of characteristic values).
- Values and quantities that were transferred from the sales order or billing document in Sales and Distribution (SD) remain unchanged.

⚠️

If you are using Profitability Analysis without the SD module, you need to make sure that any value fields you do not want to change are not selected on the Periodic Valuation: Value Fields screen.

- Other value fields -- those which are filled using conditions from CO-PA or a material cost estimate -- are reset.
- This line item is then valuated using the current date.
- For each value field, the system calculates the difference between the new line item and the original line item, taking any other delta line items into account as well.
- If a difference exists for any value field, the delta line item is posted.
- The delta line item contains the document number of the original line item in the field Reference document number.

It is also possible to perform periodic valuation in a test run. This makes sense to do before you actually execute the valuation, since the log contains information about any errors which occurred plus the number of line items which were read and posted.

If the number of posted and incorrect records is less than the number of selected records, this is because the system only writes a new line item if at least one value changed.
Planning

Purpose
Planning in Profitability Analysis allows you to plan sales, revenue and profitability data for any selected profitability segments. You can display the entire planning process of your company in different ways, depending on your business demands.

Features
Sales and profit planning is generally perceived as an integrated process involving different roles within profitability and sales accounting (such as sales manager, regional manager, and sales employee). Distinctions are often made between the different approaches used, such as central top-down planning and local bottom-up planning.

The planning tool in Profitability Analysis offers all those involved in the planning process a uniform, graphical planning interface that is straightforward and modern. This interface ensures that the "poweruser", such as the central planning coordinator who models and monitors the planning process, and occasional users (such as sales employees), who only occasionally confirm planning values, can work in unison.

Since the contents and the level of detail of the individual plans vary depending on role and area of responsibility, the planning framework allows you to structure planning selectively according to specific planning levels and planning contents and to assign that planning structure to individual users. Your planning structure is represented in a tree hierarchy. From the planning framework, it is possible to execute almost all the planning functions, right from modeling the planning process and monitoring the planning tasks through to manual entry of planning data.

For sales and profit planning, many enterprises have implemented an iterative process consisting of a number of individual planning steps, in which existing planning data is copied, projected into the future, revaluated, adjusted manually, and distributed top-down until they obtain a sales and profit plan that fulfills the enterprise's requirements. To support the individual steps of a planning process, the planning tool for Profitability Analysis offers a wide range of planning methods and planning aids that you can use to create your planning data and to modify it to suit your needs. These include automatic methods that allow you to produce data automatically for an entire plan or to carry out changes on that data, and functions that allow you to enter planning data manually. As alternatives to using the standard SAP interface, you can enter planning data locally using Microsoft Excel before loading it centrally into the R/3 System, or you can enter planning data into the system directly from a corresponding Web page. For a detailed example of how the individual functions can be used in a typical planning process, see the section Planning Process: Creating a Valuated Sales Plan.

Another special feature with sales and profit planning is that it is not a "stand-alone component"; it can not only send planning data to other applications but it can receive planning data from those applications as well. Accordingly, you have the option, on the one hand, of transferring to CO-PA data from Sales and Operations Planning (SOP), from the logistical information system, from internal order planning, and from project planning, and, on the other hand, to transfer planning data to Profit Center Accounting or Financial Accounting (see Planning Integration).

Planning is not limited to any specific time frame. This means that you can plan more than one fiscal year at once, or on a rolling basis. In addition, you can plan your data by posting periods or calendar weeks (see "Planning Period Types" in the section Planning Layouts).
It is possible to create and store planning data in different plan versions. This allows you to run planning data versions in parallel (such as an optimistic one and a pessimistic one) for the same object.

You can use the cross-application Schedule Manager [Seite 380] to control and monitor recurring tasks in planning.
Planning Framework

Definition
The planning framework is the main working environment for sales and profit planning. Firstly, this framework contains all the possible settings for building your planning architecture. Secondly, you can carry out planning from this framework screen.

Structure
The elements that you can use to build your architecture for planning and to edit your planning data are essentially as follows:

- **Planning level**
  You use the planning level to determine the level at which planning is to occur. You do this by specifying the characteristics for planning.

- **Planning package**
  You specify characteristic values in a planning package. In this way, you determine the market segment for which planning is to take place for a particular period. A planning package can thereby be seen as a work package that determines which planning objects are relevant to a specific planner.

- **Planning method**
  Planning methods are functions with which planning data can be entered and changed.

- **Parameter set**
  A parameter set contains all the settings necessary for executing a *planning method*.

You can use personalization profiles to produce a user-specific view of the planning framework elements. Using these profiles means that, for each user, only those planning elements relevant to his or her task will appear in the planning framework.

The layout for the planning framework looks like this:
The planning levels and planning packages, as well as the planning methods and parameter sets, are all displayed in a tree hierarchy. With the right mouse button, you access the context menu for each element. You can use this menu (or the relevant menu entry under Edit) to display or maintain detailed information.

You can use a traffic light icon in the hierarchy to set the status for a planning package. This allows you to tell at a glance whether planning for a given planning package is complete or still in processing.

This status is not assigned automatically. Instead, you can specify the status according to your own criteria by double-clicking the icon.

The screen layout represents how the individual elements are related. The dependencies existing between them will now be discussed.

**Dependencies**

Through determining the characteristics, a planning level forms the highest structural level in planning. Planning packages (in which you specify the values for the planning level characteristics) are directly dependent on the planning level. Since a planning package is assigned directly to a planning level, these elements are displayed in a tree structure.

The available planning methods are also dependent on the planning level. The system automatically displays which planning methods are available when you select a planning level. You can use the same planning method with all planning packages belonging to the corresponding planning level. It is necessary, however, to have a parameter set containing the settings for the particular planning method that you wish to execute. Parameter sets are thus
Planning Framework

directly dependent on planning methods, and these elements are therefore represented in a tree structure.

Alternatively to using the permanently defined planning packages and parameter sets that are displayed in the hierarchy tree, you can also define ad hoc planning packages and ad hoc planning sets during the planning session. To define these ad hoc elements, you use the context menu for the corresponding higher-level element (planning level or planning method). They are only valid for the planning session in which they are defined.

Integration

You can call up the planning framework in Customizing as well as from the CO-PA application menu.
Example: Planning Framework

A company would like to plan sales for the following year. Three employees are responsible for sales, and each should plan for one of three sales organizations (North, SouthEast, and SouthWest).

1. The planning level Sales has been created with the following characteristics:
   - Sales organization
   - Distribution channel
   - Period/year
   - Plan version
   - Record type

   Since all three employees are to plan for the same period, using the same record type and plan version, the relevant characteristic values should be specified at the planning level under Selection.

2. In the second step, the market segments to be planned are determined. For the planning level defined previously, three planning packages (OrgNO, OrgSE and OrgSW) are also created. A sales organization is specified in each planning package under Selection (OrgNO -> North, OrgSE -> SouthEast and OrgSW -> SouthWest). Since the distribution channels should not be limited, no other selection is made for this characteristic.

3. The planning method Enter Planning Data is relevant to the three sales employees. Only the parameter set Enter Sales Plan is created for this method since the same parameters apply to all three employees. For example, they should all use the same planning layout.

4. To provide each sales employee with just the elements that are relevant to that sales organization, the following three personalization profiles are created:

   - The profile SalesNO contains the planning package OrgNO as well as the parameter set Enter Sales Plan, and it is assigned to the employee responsible for the sales organization North.

   - The profile SalesSE contains the planning package OrgSE as well as the parameter set Enter Sales Plan, and it is assigned to the employee responsible for the sales organization SouthEast.

   - The profile SalesSW contains the planning package OrgSW as well as the parameter set Enter Sales Plan, and it is assigned to the employee responsible for the sales organization SouthWest.

5. The personalization profiles are then entered into the user parameters for the individual sales employees. In this way, when the employee for the sales organization SouthWest, for example, calls up planning, the system only displays the planning package OrgSW and the parameter set Enter Sales Plan.
Adjustments Following Upgrades

If you have already used sales and profit planning in previous releases (up to and including Release 4.5B) and would like to integrate the same settings again in the new Planning Framework [Seite 134], you need to note the following:

- Convert your planning as soon as possible over to the new planning framework. The old transactions can still be accessed using transaction codes, but you should be aware of the fact that SAP may decide to discontinue their use in future releases.

- For the changeover to the new screen, all elements in the planning screen need to be redefined (see Setting Up Planning Content [Seite 140]).

- The planning framework makes the plan structure check redundant. Since the planning methods can only be executed for a specific planning package, this means that only valid profitability segments can be planned for. For this reason, maintenance of the plan structure is no longer available in Customizing.

Changes to Manual Planning

- The planner profile is no longer used. With the new planning framework, you enter most of the settings that you previously made in the planner profile into the parameter set for the planning method (Enter planning data or Display planning data). See the section Setting Up Manual Entry of Planning Data [Seite 150] However, the user-specific view of planning - previously provided by the planner profile - is not defined in the parameter set. Instead, you define it using the personalization profile.

  To facilitate the changeover from the planner profile to the parameter set and personalization profile, you can display the settings for the old planner profile by choosing Planning → Planning Framework → Aids for Changeover to the Planning Framework → Display Planner Profiles in Customizing.

- You can basically re-use old planning layouts by copying them to the parameter set. The layouts must nevertheless correspond to the planning level and planning package concerned. In other words, the characteristics in the general data selection, those in the lead columns, and those in the value columns need to match the characteristics in the planning level. Moreover, the characteristic values specified in the planning layout should match the values in the planning level and in the planning package. If this is not the case, the characteristic values in the planning level and in the planning package will hold.

  To facilitate the definition of a matching planning level, you can choose Planning → Planning Framework → Aids for Changeover to the Planning Framework in Customizing and then perform the function Create Planning Level from Planning Layout [Extern] . For detailed information, refer to the appropriate sections in the documentation.

- The default parameters for the variables in a planning layout are no longer applicable in the new planning framework. In place of these parameters, you can enter characteristic values when you define the planning package.

  To set the default parameters for a planning layout that uses Integrated Excel (that is, the settings for an Excel sheet template and a file description), select the function Settings → Formatting in the SAP menu when you are using a planning layout for planning data entry or display.
Before executing planning, the system no longer calls up the variables integrated in the planning layout. Instead, the system uses the selections made in the planning level and the planning package to fill the variables with data. If you want planning to be defined with flexibility, you should define an ad hoc planning package instead of using variables.

**Changes to Automatic Planning**

- The automatic planning functions are integrated in the planning framework as planning methods. Since they can now be used for specific planning packages, the parameterization has been changed. In the new release, you make the settings of the earlier variants by defining a corresponding planning level, a planning package, and a parameter set.

- Some functions that used to be executed as part of an automatic planning function have now been made into planning methods that have their respective parameter sets, such as revaluation, valuation, or period distribution.
Setting Up Planning Content

Purpose
To be able to perform sales and profit planning, you first need to set up the planning content in the Planning Framework. In the planning framework, you define planning levels and planning packages and thereby determine what is to be planned. In addition, you specify how planning is to occur by defining parameter sets for the planning methods.

Prerequisites
You need to have executed the IMG activities under Planning → Initial Steps in Customizing.

When setting up the initial planning screen, you should note the following navigation principles:

- You use a context menu to create or change elements. You call up this menu with the right mouse button. To create an element, you use the context menu for the higher-level node. To change an element, you use the context menu for that element. Alternatively, you can use these functions in the Edit menu.
- You can change the order of the elements by Drag & Drop.
- To activate the planning level or the planning package, double-click the one concerned in the tree. This displays all the relevant information; the detailed information is displayed in the right-hand side of the screen and the planning methods are displayed in the bottom left-hand corner of the screen. You can only carry out planning methods on planning packages that have been activated.
- When you maintain the individual elements in the detailed information section on the right-hand side of the screen, you can use to show the technical keys.
- An element that you have created appears in the tree once the system has checked that the element has been fully defined. Once the element has been incorporated into the tree, it remains available for that planning session. You can use to run the check manually, but the element will not be saved as permanent. This is only the case once you have carried out the inclusive check via .
- To cancel processing of a particular element, choose .

Process Flow
1. Creating a planning level
   First specify in one or more planning levels which characteristics are to serve as the basis for planning.

   A planning level determines the overall planning structure. This means that, to work with both strategic planning and operational planning, for example, you should create planning levels for each type of planning, and these planning levels should not contain the same characteristics. To specify the planning level contents to greater detail, such as to set up planning for different sales employees, you need to create different planning packages.
The characteristics *Period/year* (or *Week/year*), *Version*, and *Record type* automatically belong to each *planning level* in costing-based profitability analysis. The *currency type* is determined automatically from the version (see also [Multiple Currencies in Planning](https://support.sap.com/copaplan.html)). The characteristics *Period/year*, *Version*, *Controlling area* and *Cost element* automatically belong to the level in account-based profitability analysis. Any characteristic from the characteristics list (which contains all the characteristics in the operating concern) can be transferred to your *planning level*.

If individual characteristic values are valid for all *planning packages* in the same level, specify these characteristic values in the *Selection* tab page.

For the above-mentioned characteristics that exist in every planning level, it makes sense to make this selection there directly.

In the case of the characteristic *Controlling area* in account-based Profitability Analysis, you must select a characteristic value in the planning level (this is a required entry).

### 2. Creating planning packages

You define one or more *planning packages* for a *planning level* by selecting characteristic values on the basis of the characteristics in that *planning level*. A *planning package* corresponds to a market segment (such as all the combinations of customers and products dealt with by a sales employee) that is to be used in planning for a specified period.

When you perform planning, you can also create a planning package ad hoc for each planning level. However, an *ad hoc planning package* is only available for the planning session in which it has been created.

### 3. Creating parameter sets

If you have created a *planning level*, the system automatically makes the two possible *planning methods* available in this level.

On the one hand, you can use the *Enter planning data* planning method to plan individual profitability segments directly in an entry screen (in the same way as the display function using the *Display planning data* planning method). On the other hand, you can choose from a variety of planning methods that let you plan automatically all profitability segments that are specified by the planning package.

These planning methods can be applied via a *parameter set* that you create for one of them. You specify in a *parameter set* the parameters that are necessary for executing the method, such as which planning layout is to be used for manual data entry or for displaying planning data.

For more information on the individual planning methods and the respective parameter sets, see the section [Planning Methods](https://support.sap.com/copaplan.html).

When you perform planning, you can also create a parameter set ad hoc for each planning method. However, an *ad hoc parameter set* is only available for the planning session in which it has been created.

### 4. Create personalization profiles
Setting Up Planning Content

By means of personalization profiles, you can determine a user-specific view for the planning levels, packages, methods and parameter sets that have been defined previously. If you choose Edit → PersProfil → Create Personalization Profile, checkboxes appear alongside the individual elements, and you can use them to select the elements that are relevant to individual users.

If you only select one planning level or one planning method, the planning packages or the parameter sets for that level/method are not available. In such cases, the user can only use one ad hoc planning package or one ad hoc parameter set respectively. To include the availability of lower-level planning packages and parameter sets, you have to select them explicitly.

Users are assigned to personalization profiles in the User list tab page in the detailed information area. In the Authorizations tab page, you specify which context menu functions the users should be allowed to perform with that specific personalization. You also specify whether they are allowed to switch to the general overview.

5. Entering personalization profiles in user master data

If a standard personalization profile is to be valid for a user, you can enter that profile in that user's master data using the parameter RKE_PROF.

Result

When a planner accesses sales and profit planning via the initial planning screen set up for him/her, the data is displayed in the following ways depending on how the personalization profile was defined:

- If no personalization profile has been assigned to the planner, then the general overview is displayed.
- If a specific personalization profile has been assigned to the planner, then the elements specified in that profile are displayed.
- If several personalization profiles have been assigned to the planner, then the elements displayed are those specified in the profile entered in the user master. If no profile has been entered in the user master, then the system uses the profile that comes first alphabetically. By choosing Set Personalization Profile, the planner can switch to one of the other personalization profiles assigned to him/her.
Multiple Currencies in Planning

Use

If you use parallel currencies in Profitability Analysis (in other words, you have set the indicator for the company code currency as well as the operating concern currency under Structures → Define Operating Concern → Maintain Operating Concern → Attributes), then you can also plan in both currencies.

It is possible to activate the company code currency subsequently.

Features

In planning, you are always working with estimated future exchange rates. Consequently, it is not necessary (and likewise not possible) to update two currencies simultaneously for each transaction in planning (see also Updating Two Currencies in CO-PA [Seite 37]). Prior to planning, you instead need to specify for each plan version whether you want to plan in the global currency for your organization (operating concern currency) or in the local currency of whatever company code you are planning. You can convert your planning data to the other currency by copying the data to a plan version that uses the other currency and translating it using a planned exchange rate.

The following currency types can be included in a plan version:

- Operating concern currency (B0)
- Company code currency (10)

If you want to update the currency with profit center valuation, make the appropriate entry in the currency type field (PALEDGER). For more information, see the section Multiple Valuation Views in Planning [Seite 145].

The plan version is a mandatory characteristic in each planning level. If you want to plan using the company code currency, you need to include the company code as a characteristic in the planning level.

Currency in the planning layout

SAP recommends that you generate the planning layout from the parameter set (see Set Up Manual Entry of Planning Data [Seite 150]). If, however, you define it manually in Customizing under Planning → Manual Entry of Planning Data → Define Planning Layout, you need to make some settings for the currency as well in the definition. It is essential that you read the documentation on Defining a Planning Layout [Extern] in Customizing.

Currency Translation When Both Currencies Are Active

You can convert your planning data to the other currency by copying the data to a plan version that uses the other currency and translating it using a planned exchange rate. The system translates the values automatically when you use automatic planning method Copy.
Multiple Currencies in Planning

A typical scenario for profit planning for a corporate group with multiple currencies might look like this:

The various subsidiaries create their own plan at the company code level using a plan version that stores the data in the company code currency. These plans are then rolled up (copied) to another version that stores the data in the operating concern currency. The system translates the data using planned exchange rates that are stored separately for each period.

This makes it possible to unify corporate planning in the operating concern currency without the risk of incurring differences due to the translation.

Currency Translation When Only One Currency Is Active

If your system only stores values in one currency, you can use the Entry currency function to enter data in a foreign currency during the manual entry of planning data. The system automatically converts the values into either the operating concern currency or the company code currency before saving them to the database. This function is designed as an entry aid for users who need to enter values in a foreign currency. You specify the entry currency in the parameter set for the Enter planning data planning method.

See also:

For more information about multiple currencies, see Updating Two Currencies in CO-PA [Seite 37].
Multiple Valuation Views in Planning

Use

You can store data in Profitability Analysis in two separate valuation views in addition to two separate currencies. This feature is designed for organizations that

- Treat profit centers like independent companies acting on the market, and therefore want to analyze both external sales and internal sales, such as goods transfers between profit centers, in their profit analyses
- Update both internal and external sales using costs of goods manufactured calculated on the basis of transfer prices

For more information on profit center valuation in Profitability Analysis, see Multiple Valuation Approaches/Transfer Prices in CO-PA [Seite 319].

Features

In planning, you need to decide for each plan version what combination of valuation approach and currency type you want to plan. You can choose between the following combinations:

<table>
<thead>
<tr>
<th>Valuation approach</th>
<th>Valuation</th>
<th>Currency type</th>
</tr>
</thead>
<tbody>
<tr>
<td>B0</td>
<td>Legal</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>10</td>
<td>Legal</td>
<td>Company code currency</td>
</tr>
<tr>
<td>B2</td>
<td>Profit center</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>12</td>
<td>Profit center</td>
<td>Company code currency</td>
</tr>
</tbody>
</table>

If you have activated profit center valuation for your operating concern, you need to specify the valuation approach for the characteristic Currency type (field PALEDGER).

Valuation Approach in the Planning Layout

Although SAP recommends that you generate the planning layout from the parameter set (see Set Up Manual Entry of Planning Data [Seite 150]), you can also create the layout manually in Customizing under Planning → Manual Entry of Planning Data → Define Planning Layout. If you choose to do so, you have to make some settings for the valuation approach during layout definition. You should refer to the Customizing section Define Planning Layout [Extern].
Working with Prices in Planning

Profitability Analysis provides you with different functions to meet different requirements for using prices to help you plan.

- **Price planning using ratios/simulating price and quantity changes**
  
  By entering ratios directly in your planning layout, you can easily calculate prices and simulate price, value, and quantity changes without using pricing from the Sales and Distribution (SD) application component.

  You can do this directly during manual entry of planning data.

  See also Price Planning Using Ratios [Seite 159].

- **Valuation of quantity plans using reference prices from existing actual data or other plan versions**

  Using ratios and ratio schemes, you can valuate a plan version with average prices from actual data or a reference plan version. This makes it possible to plan your prices and quantities separately and still use these prices to valuate your quantities.

  This function is available for the manual entry of planning data (see the section Ratios [Seite 170]) and with the automatic planning method Ratios [Seite 236].

- **Price planning using conditions**

  To valuate revenues and sales deductions in planning, you can use conditions defined in CO-PA as well as conditions used in price determination in SD (see the paragraph on Valuation Using SD Price Determination (SD Costing Sheet) in the section Activate Valuation in Planning [Seite 126]).
Planning Methods

Definition

The planning methods available in the planning framework [Seite 134] allow you to plan the profitability segments specified in the planning packages.

Use

In order to be able to run the planning methods, you need to specify in a parameter set (be it permanently saved or defined as an expedient) the settings for each specific planning method. Execute the planning method via the parameter set.

To be in a position to create a parameter set, you need to have defined a planning level. For the parameter set to be executed, at least one planning package should exist at that level (an ad hoc or permanently defined package). (See also Setting Up Planning Content [Seite 140]).

Execute planning method

To edit your planning data using the planning methods for sales and profit planning, start the planning framework by choosing Planning → Edit planning data in the application menu.

Depending on whether a personalization profile has been entered into your user master data, either the complete view of the planning framework or the user-specific view of the personalization profile is displayed. With Set personalization profile, you can select one of the personalization profiles that your user ID has been assigned to.

From those offered, double-click the planning package containing the profitability segments you wish to plan. If no planning packages are offered or none of those offered include the profitability segments that you wish to use in planning, you can define an ad hoc planning package that is valid just for that planning session. You can do this in the context menu of the planning level you are working with (using the right mouse button). You do not need to name the ad hoc planning package, and it is not included in the tree. Instead, you know that you have defined an ad hoc planning package for a particular planning level during the planning session if that planning level is highlighted in green. By double-clicking the relevant planning level, you can select such an ad hoc planning package in order to enter or display planning data.

After you have activated an (ad hoc) planning package, you then choose a planning method from those available. By expanding the node for the relevant planning method, you display the parameter sets defined for that method. If no planning set is offered or none of those offered include the settings with which you wish to execute the planning method, you can define an ad hoc parameter set that is valid just for that planning session. You define it in the same way as you define ad hoc planning packages.

To execute a planning method, you can double-click either the parameter set or the method, whereby the settings for the ad hoc parameter set are used for the execution.

Structure

You can choose from two different types of planning methods. They differ in the way they allow you to enter and edit planning data for the profitability segments.

- The first type of planning method is the manual type. With the manual planning methods Enter planning data and Display planning data, the profitability segments specified in the planning package are listed individually for editing or display.
Planning Methods

In the parameter set, you chiefly specify how the profitability segments are to be listed. Processing then occurs interactively when the planning method is executed.

You can see directly the results of your processing.

- The second type of planning method is the automatic type. With automatic planning methods such as Copy, Top-down distribution, and Delete, all profitability segments that are specified in the planning package are processed.

You specify in the parameter set how these segments are to be processed. When you execute the method, the system automatically processes the segments without your being able to intervene interactively.

You can see the results of the processing in a report in the information system or by using the manual planning method Display planning data.

When using the manual planning method Enter planning data, you can choose from more planning methods. These additional planning methods apply the same logic to the data selected in the entry screen as the above mentioned automatic planning methods apply to the relevant planning package.
Entering/Displaying Planning Data

Use

The *Enter planning data* planning method allows you to enter and interactively edit planning data for individual profitability segments manually in an entry screen. The *Display planning data* planning method allows you to display planning data in the same degree of detail, that is, for individual profitability segments.

Prerequisites

In order to be able to execute the planning methods, you have to create a parameter set for each method. For detailed information, see the section Setting Up Manual Entry of Planning Data [Seite 150].

Features

To find out about the functions that you can use when executing planning methods, see the section Executing Manual Entry of Planning Data [Seite 160].

For the manual entry of planning data, there are alternative interfaces that can be used instead of the standard SAP interface:

- You can use Microsoft Excel as your interface (see Integrated Excel in Planning [Seite 200]).
- You can use an ordinary Web browser to enter planning data into the SAP System via the Internet (see Entering Planning Data via the World Wide Web [Seite 215]).

To simplify cooperation between different planners, the planning methods are connected to the SAP Business Workflow [Extern] (see Planning Data Entry in the Workflow [Seite 218]).
Setting Up Manual Entry of Planning Data

Use

You set up the manual entry of planning data by creating a parameter set for the Enter planning data or Display planning data planning method. This parameter set contains the settings for executing the respective planning method.

Features

For the planning method Enter planning data, you can make all of the following settings in the parameter set. Only some of these settings are relevant for the planning method Display planning data. Only relevant settings are offered in the parameter set.

- Planning Layout

The Planning Layout is used for entering and for displaying planning data. You define the layout that is to be used for entering or displaying data. You can select a planning layout that has been defined manually in Customizing (provided that the characteristics in the layout match those in the planning level). Alternatively, you can choose for a planning layout to be generated automatically.

As a rule, you should generate a planning layout from parameter set maintenance or use a planning layout that has already been generated for the planning level you are working with. This ensures that the planning level and the planning layout are compatible. You should only define planning layouts with complicated structures manually in Customizing. This applies, for example, to planning layouts where different characteristics are to appear in the rows of its lead column (which must therefore be a complex lead column). For more information about Customizing for planning layouts, see Defining a Planning Layout.

Planning layouts are generated as follows:

a. You can choose from the characteristics listed in the tab page Characteristics. These characteristics are the ones contained in the planning level. For each characteristic, decide whether it should be placed at the head of the layout or whether it should instead be unlocked for entries and serve as a lead column. You must use the following specifications:
   - The characteristics Period (or Week) and Version must appear in the planning layout header.
   - For account-based Profitability Analysis, the characteristic Controlling area must be in the header.
   - You can define up to a maximum of nine lead columns.

b. You choose from the list of value fields for the operating concern in the tab page Value fields. Select from this list the value fields to be used in planning.

c. If you want to include other functions in the planning layout, such as ratios or an additional column displaying actual values from the previous year, choose to change to planning layout maintenance in Customizing. In the maintenance screen, you can make the corresponding settings in the planning layout that has been generated.
• **Control Data for Manual Planning**

  This is where you can specify for manual planning an *entry currency* that differs from that used in Profitability Analysis. The entry currency simply serves as an entry aid and is translated into the database currency (which is either the operating concern currency or the company code currency) before being transferred to the database.

  As before, this is where you can enter a distribution profile for top-down planning. For detailed information on top-down planning, see the section *Transaction-Based Top-Down Distribution* [Seite 155].

  You can also choose to activate automatic valuation or *zero suppression* (not having objects displayed if all their value fields contain a zero).

  ![](image)

  Only the settings for the entry currency and for zero suppression are relevant for the planning method *Display planning data* (the entry currency serving as the display currency in this case).

• **Distribution Key for Period Distribution**

  This is where you can store standard distribution keys for currencies and quantities to be applied when new objects are entered. In each case, the system proposes the distribution key "2" (distribution as before).

  If you use object-related distribution keys, you can enter an access key as an alternative to the standard distribution keys.

  In Customizing for Profitability Analysis, you can define a standard distribution key as well as a segment-specific distribution key. You do this under *Planning → Planning Aids → Distribution Key for Periodic Distribution* [Extern].

• **Integrated Excel**

  Here you can activate Microsoft Excel as the interface for entering or displaying planning data. For more detailed information, see the section *Integrated Excel in Planning* [Seite 200].

  By choosing 📘, you can access the maintenance transaction for the selected parameters and display detailed information about the corresponding object. From there, you can switch to the change mode to change the object or to create a new one.
Planning Layout

Use

A Planning Layout [Extern] determines how the screens where you enter your planning data look, including which fields appear where on the screen. Each field is allocated to a row and a column, depending on its position on the screen. The content of each field, in turn, is determined by the definition of the column and row.

By default, you generate a planning layout during parameter set maintenance. In some cases, however, it is necessary to complete the planning layout or even define it completely using the Customizing activity Define Planning Layout [Extern]. For more detailed information, see the section Set Up Manual Entry of Planning Data [Seite 150].

Structure

Structure of Planning Layout

All planning layouts are based on the following structure:

- **Lead columns**
- **Value columns**
- **Attributes**

The header of the planning layout consists of several lines of text that describe the segments that you are going to use in planning. These entries result from the characteristic values that were selected in the planning level and in the planning package. You can display and change the selected characteristic values by choosing Edit → General data selection. When changing the selection, you should nevertheless keep in mind that the settings in the planning level and in the planning package will always apply. If, for instance, the characteristic Period/year has been
selected with the values 01.2000 through 12.2000, this setting will hold even if you enter different values in the layout.

**Defining a Lead Column**

There are two ways to define a lead column in a planning layout:

- You can choose a single characteristic to define the entire lead column at once. This option lets you define more than one lead column. It also makes it possible for you to add new profitability segments in planning.
  
  This option becomes available the planning layout is generated from the parameter set.

- In a type of planning similar to form planning, you can define each row individually using characteristics, a value field or a formula in each row (in the case of complex lead columns).
  
  If you want to use a planning layout involving complex lead columns, you can define it in the Customizing activity Define Planning Layout [Extern].

**Defining a Value Column**

Value columns are defined using value fields, characteristics, attributes, and formulas.

💡

The decision whether you want the value fields to appear in the rows or in the columns is made as soon as you define the first element of the layout. This decision cannot be reversed. When you define a value field in a row or column, you can also specify characteristics to limit the value field.

You can choose from the following attributes:

- Distribution key for distributing aggregated values to periods
- Unit for the value field (either a currency or a quantity unit)
- The "Action" field
- The long text indicator
- Any characteristic

The attributes "Distribution key", "Unit", and "Action" are always assigned to a data cell. For example, a distribution key distributes the aggregated values in one cell to individual periods in order to reflect seasonal fluctuations.

The attributes Long text indicator and Characteristic, on the other hand, always apply for a specific profitability segment. The long text indicator lets you display whether a long text exists for a certain profitability segment.

Characteristics are useful as attributes if you want to display a characteristic that is not contained in the planning layout but is to be derived automatically. For example, you could plan individual products and display the derived division for each product in a separate column.

**Version, Record Type, Plan/Actual Indicator**

The fields Version, Record type (only in costing-based Profitability Analysis) and Plan/actual indicator are treated as normal characteristics. This makes it possible for you to display a second plan version for comparison or to plan several versions at once, as well as to display actual data for information.
Planning Layout

In costing-based Profitability Analysis, you can plan all record types manually.
In account-based Profitability Analysis, each planning layout is assigned to a specific controlling area. The characteristic Account is a mandatory characteristic.

Calculation Columns and Calculation Rows

In addition to the normal value field columns, you can also define calculation columns or rows. When you do this, the system calculates values for those rows or columns based on the manually entered values. Or you can enter the “calculated” values manually and have the system calculate the values in the value field columns (inverse formula). This makes it possible for you to plan such complex values as contribution margins directly.

The system calculates the formula for the calculation immediately before displaying the data on the screen. Inverse formulas are calculated immediately after you enter your planning data. This may lead to differences due to rounding off.

Ratios represent an additional function with which to calculate corresponding values automatically (see Price Planning Using Ratios [Seite 159]). In contrast to calculation columns, ratios apply to more than one layout.

A complex example of how to use formulas is the standard planning layout 0-SAP05 of operating concern S001 in the R/3 System. This layout lets you plan a contribution margin directly and calculate the sales quantity on that basis. This is shown in the following graphic:

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales quantity</td>
<td>2000</td>
<td>PCS</td>
<td>1500</td>
<td>1800</td>
</tr>
<tr>
<td>Revenue</td>
<td>100,000</td>
<td>USD</td>
<td>75,000</td>
<td>90,000</td>
</tr>
<tr>
<td>Net revenue</td>
<td>80,000</td>
<td>USD</td>
<td>55,000</td>
<td>65,000</td>
</tr>
<tr>
<td>Cost of gds manuf.</td>
<td>40,000</td>
<td>USD</td>
<td>35,000</td>
<td>40,000</td>
</tr>
<tr>
<td>Contrib. margin 1</td>
<td>30,000</td>
<td>USD</td>
<td>10,000</td>
<td>15,000</td>
</tr>
</tbody>
</table>
Transaction-Based Top-Down Distribution

Use
When you enter planning data manually, you always enter your data at a specified planning level (at the product group or customer group level, for example). Using transaction-based top-down distribution, you can have the system automatically distribute your manually planned data to a more detailed planning level as soon as you save it. This achieves consistent planning at this detailed level. Distribution occurs on the basis of reference data that has already been posted at a level of greater detail, such as in a different plan version or record type.

Transaction-based top-down distribution can lead to long runtimes. If your planning process only calls for more detailed data in the individual planning levels in later phases, you should use the automatic planning method Top-Down Distribution [Seite 230].

You plan your data for the characteristics Product, Product group and Customer group. You define three planning levels for which planning data is to be entered: Customer group/product group (independent of the product), product/product group (independent of the customer group), and product/product group/customer group (the lowest, most detailed level). By using transaction-based top-down distribution, you can ensure that all planning data is saved at the lowest level.

For a more detailed example using figures, see the section Example: Transaction-Based Top-Down Distribution [Seite 157].

Prerequisites
In Customizing, you need to choose Planning → Manual Entry of Planning Data → Set Up Transaction-Based Top-Down Distribution add perform the following steps:

- Assign the value fields you want to distribute to reference fields
  If at this point you want to use a value field formula instead of individual value fields, you must define these formulas under Calculated Values as Reference for Top-Down Distribution [Extern].

- Define a distribution profile in which the reference data (among other things) are specified
  You enter the distribution profile in the parameter set for the higher planning level from which the data is to be distributed.

Distribution can only take place if corresponding reference data exists.

To check whether distribution has occurred as it should, it makes sense to physically define a planning level for the detailed level to which the distributed values are sent (see Setting Up Planning Content [Seite 140]) and to execute the Enter planning data planning method at that level.
Transaction-Based Top-Down Distribution

Features

Once you have set up top-down distribution, the system always automatically distributes planning data to the more detailed level when the data is saved. In all other respects, the functions in transaction-based top-down distribution generally correspond to those in the automatic planning method Top-Down Distribution [Seite 230].

![Diagram showing the process of top-down distribution]

- **Plan values**
- **Reference data**
- **Distributed values**

Methods:
- Only "nonassigned"
- Total value
Example: Transaction-Based Top-Down Distribution

Customizing Settings

Value Field Assignment

In the value field assignment, you specify which field you want to use as the reference for distributing the values in each value field.

<table>
<thead>
<tr>
<th>Value field:</th>
<th>Reference:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales quantity</td>
<td>Sales quantity</td>
</tr>
</tbody>
</table>

Distribution Profile

In the distribution profile, you specify the following:

<table>
<thead>
<tr>
<th>Reference record type</th>
<th>&quot;*&quot; - same record type as the data to be distributed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference version</td>
<td>&quot;*&quot; - same version as the data to be distributed</td>
</tr>
<tr>
<td>Method</td>
<td>2 - Distribute &quot;nonassigned&quot; only</td>
</tr>
</tbody>
</table>

*Distribution level:* Here we specify the **product** as the characteristic that should receive the data.

As a result of this distribution profile, any changes you make to the sales quantity at a higher level are automatically distributed top-down to the individual products using the previously existing planning data in the same version as the reference data.

Planning levels

The planning level from which the values are distributed contains the characteristics **Customer group** and **Product group**. At this level, a parameter set is created for the *Enter planning data* planning method. The distribution profile described above is entered into this parameter set. The planning layout for the parameter set has the lead columns **customer group** and **product group**.

The detailed planning level for monitoring distribution contains the characteristics **Customer group**, **Product group**, and **Product**. In this example, this is also the level for the reference data because the record type and the version are identical in each case.

Data Update

The following data already exists in the database (for one period):

<table>
<thead>
<tr>
<th>Customer group</th>
<th>Product group</th>
<th>Product</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P1</td>
<td>100</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P2</td>
<td>200</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P3</td>
<td>200</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B1</td>
<td>300</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B2</td>
<td>400</td>
</tr>
</tbody>
</table>

When executing the *Enter planning data* (or *Change planning data*) planning method at the planning level that is to be distributed, you now see the following values (data for products is summarized):
Example: Transaction-Based Top-Down Distribution

<table>
<thead>
<tr>
<th>Customer group</th>
<th>Product group</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>500</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>700</td>
</tr>
</tbody>
</table>

The values are changed as follows:

<table>
<thead>
<tr>
<th>Customer group</th>
<th>Product group</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>550</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>770</td>
</tr>
</tbody>
</table>

When we save these changes, the system creates the following line items:

<table>
<thead>
<tr>
<th>Customer group</th>
<th>Product group</th>
<th>Product</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P1</td>
<td>10</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P2</td>
<td>20</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P3</td>
<td>20</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B1</td>
<td>30</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B2</td>
<td>40</td>
</tr>
</tbody>
</table>

At the detailed planning level, the following values are now displayed:

<table>
<thead>
<tr>
<th>Customer group</th>
<th>Product group</th>
<th>Product</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P1</td>
<td>110</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P2</td>
<td>220</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRA</td>
<td>P3</td>
<td>220</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B1</td>
<td>330</td>
</tr>
<tr>
<td>K1</td>
<td>PRGRB</td>
<td>B2</td>
<td>440</td>
</tr>
</tbody>
</table>
Price Planning Using Ratios

Use

Using ratios, you can calculate the quotient of two value fields directly on the planning layout. You define ratios in CO-PA Customizing under Planning → Planning Aids.

When you define a planning layout, you can choose ratios to define columns just as you would choose value fields. By default, the ratio can also be entered manually by the user.

If you enter the quantity and the revenue, the system automatically calculates the price. If, however, you enter the quantity and the price, the system calculates the revenue.

If you change one of the three values, special rules determine which of the other two values should be recalculated. You can define these rules when you define the ratios.

The values you enter or have calculated for ratios are not stored in the database. Instead, the system calculates them based on the relevant value fields each time you display them.

Features

Ratios let you:

- calculate prices and other values directly in the planning layout
- simulate price, value, and quantity changes in the planning layout

See also:

In addition, you can use ratios together with ratio schemes to valuate your current plan version using average prices from actual data or from a reference plan version. For the manual entry of planning data, use the function Edit → Planning methods → Ratios [Seite 170].
Executing Manual Entry of Planning Data

Use

For sales and profit planning, you use the Planning Framework [Seite 134] to enter and display planning data manually. You use the respective planning methods Enter planning data and Display planning data. You can enter and modify plan values directly for individual profitability segments.

Prerequisites

You need to have defined a planning level and a planning package (see Setting Up Planning Content [Seite 140]) and a parameter set for the Enter planning data planning method (see Setting Up Manual Entry of Planning Data [Seite 150]).

Features

You can enter or display planning data in an R/3 screen, or you can activate Microsoft Excel as your interface for entry and display. You specify your choice in the parameter set. For more information on planning with Integrated Excel, see the section Integrated Excel in Planning [Seite 200].

To enter data, you can use a wide range of Planning Methods [Seite 164], such as valuating, forecasting, or revaluating planning data, as well as General Functions [Seite 178], such as copying, cutting and pasting values. You can exclude usage of the planning methods in the parameter set in the Methods tab page. By doing so, they are not made available during the manual entry of planning data.

Activities

After executing the parameter set for the planning method, the system displays the overview screen, which contains the relevant planning layout. If Microsoft Excel has been set up as the interface in the parameter set you have executed, then Excel is integrated into the overview screen.

Use 🖤 to switch to the period screen. The period screen is generated automatically from the overview screen. It moves the information from the rows of the overview screen to the header and places the periods in the rows. If you are using integrated Excel, you cannot display the period screen.

If a characteristic of time (such as Period/Year or Week/Year) was defined in the value columns of the overview screen, you can only enter values in those rows that correspond to the intervals in the columns.

Next Combination/Previous Combination

If the header of the planning layout contains several values for one characteristic, you can scroll back and forth on the overview screen using the Next combination and Previous combination functions.

On the period screen, these functions let you navigate through the rows of the overview screen (which moved to the header of the period screen).
Settings for Decimal Places and Display Factors

The number of decimal places and a display factor (10s, 100s, and so on) may be defined for individual rows and/or columns in the planning layout. You can change these settings during planning if you wish.

Selection of Existing Planning Data

Before displaying the planning screens, the system reads the existing planning data for the selected profitability segments from the database. If you are planning on a higher level (such as at the Product group level), the system reads the planning data for all the segments which lie below that level (individual products) and adds these together bottom-up. The changed plan values (the changes to the figures already stored in the database) are then written to the database at the higher level, such as at the product group level. The lower level (product) remains blank in this database record, ("not assigned", shown by ")

It has already been specified in the planning level whether you want to plan on the basis of the posting periods in the operating concern or on the basis of weeks (only possible in costing-based Profitability Analysis). If you plan in weeks, the data is automatically distributed to the correct posting periods based on the calendar. Consequently, when you display the data by period, you also receive the data that was planned in weeks. In contrast, values that you plan in periods are not distributed to weeks. This is similar to summarizing at the product group level the planning data that was entered at the product level. The data you plan for individual products is summarized in the corresponding product groups, but the data planned for product groups directly is not displayed for the individual products.

Technical Note

The data is generally selected from the segment level. This may lead to long runtimes, depending on the configuration of your system and the data volume. If this happens, you should define a summarization level to store the summarized planning data at the desired planning level.

If the system reads the data from a summarization level, it displays a message telling you this during the selection.

See also Defining Summarization Levels [Seite 373].

Characteristic Derivation

After it reads the data, the system automatically derives characteristic values according to the rules that were defined in Customizing. For more information, see Characteristic Derivation [Seite 41]. These derived characteristics can later be used to analyze the planning data. If an error occurs in derivation, the system locks the affected profitability segments so that you cannot plan them, but it still displays them for information purposes. You can see the derivation log to find out why derivation could not be performed. To display the complete profitability segment, including the derived characteristics, choose Other characteristics.

Note that the system cannot derive values for a characteristic if

- It is defined in the lead column or
- You are explicitly planning the nonassigned (##) level of that characteristic
Lock Logic

In order to prevent more than one user from planning the same profitability segments at the same time, the system locks the segments that are currently being planned. It is still possible for more than one person to plan at the same time, even in the same version, provided that none of the segments being planned overlap. It is also possible to perform manual planning and automatic planning in the same version, as long as different segments are planned.

You can plan product group PG1 and all the products contained in it, while at the same time a co-worker plans product group PG2 and all the products contained in that group.

Entry Currency

In Profitability Analysis, planning data is generally stored in the database in the currency of the operating concern.

However, as an entry aid, you can enter or display your planning data in another entry currency. When you save, the system automatically translates the data into the currency for the operating concern. When you display data in another currency, the system first selects the data, then translates it into the entry currency before displaying.

Currency translation is always performed using the exchange rate from the first day of the current period. The exchange rate type (such as the buying rate or a user-defined rate) is stored in the definition of the plan version. Only value fields are translated, not quantity fields.

There are three ways you can specify the entry currency:

- By entering the currency that is in the parameter set
- By entering a currency next to the plan value you want to have translated. This is only possible if you selected the unit field when defining the planning layout as an attribute unlocked for entry.
- Using the function Settings → Change entry currency. If you apply this function to existing planning data (by selecting that data beforehand), the system translates the data into the currency you specify. Otherwise the new currency applies for all new profitability segments you plan after choosing this function.

If you want to enter your planning data in a currency other than the operating concern or company code currency, it is recommended that you choose the attribute Unit when you define the planning layout.

Do not confuse this function with the use of a second database currency in profit planning. For each plan version, you can decide whether to store the planning data in the operating concern currency or the company code currency. See also Multiple Currencies in Planning [Seite 143].

Quantity Fields and Units

Quantity fields are displayed with the number of decimal places defined for the corresponding unit of measure in Customizing. In CO-PA, the unit of measure of each value field represents an individual characteristic. If the characteristic Unit of measure was not specified in the selection criteria for the planning session you are in, the system tries to find the correct unit based on the
transaction data or using characteristic derivation. If the units found are incompatible, you cannot plan the corresponding quantity.

This is the case when

- Data already exists with different units or
- The unit of the existing data differs from the unit found via characteristic derivation (the sales quantity unit or the storage unit from the material master, if you are planning a material).

You can also display these fields in the log.
Planning Methods

Use
For the manual entry of planning data, you can use various planning methods to change the plan values for individual profitability segments.

Features
With some of these planning methods, you use planning aids (defined in Customizing) on the individual profitability segments. Examples of such planning methods are the distribution key for period distribution method or the revaluation key method. With other planning methods, the system calculates new values on the basis of your direct entries. This is the case, for example, with the goal seek function.

You can exclude any planning methods from those to be made available. You do this in the parameter set for the Enter planning data planning method in the Methods tab page.

Activities
You access the planning methods from the Enter planning data planning method by choosing Edit → Planning methods.

If you want to edit a fairly large amount of profitability segments, you should use the corresponding automatic planning methods that you can execute for a planning package directly from the planning framework (see the section Automatic Planning Method [Seite 224] and the subordinate sections).
Valuation

Use

If you select the Valuate method for the manual entry of planning data, the system automatically valuates the value fields using conditions, material cost estimates or user-defined exit programs. In this way, you can use your CO-PA Customizing settings for valuation [Extern] to calculate, for example, your planned revenues, planned sales deductions, and planned costs.

For general information on valuation in CO-PA, see the appropriate sections dealing with Valuation [Seite 76]. In particular, see the section Activate Valuation in Planning [Seite 126].

Activities

Select the profitability segments you wish to valuate and then choose Edit → Planning methods → Valuate.

You can analyze valuation with the function Extras → Analyze valuation. For valuation using conditions, you can also choose the function Extras → Analyze conditions (see also Analysis Options Using Valuation [Seite 124]).

You can also specify that the planning data should be automatically valuated in the background when you save. For this, set the Automatic valuation indicator in the parameter set for the Enter planning data planning method. The system then valuates all the profitability segments that you changed during the current planning session.
Forecast

Use
For the manual entry of planning data, you can use the *Forecast* function to determine anticipated values for individual profitability segments on the basis of a time series.

Features
The forecast function for sales and profit planning is essentially the same as that for sales and operations planning (SOP). The system supports a number of forecast models, including constant, trend and seasonal models. The models and forecast parameters are specified in forecast profiles that you define in Customizing for Profitability Analysis under *Planning → Planning Aids → Forecast Profile*. Predictions can be made for any time periods and on the basis of both planning and actual data.

For more information on this topic, see the following sections in the SOP documentation:

- [Selection of Models](#)
- [Forecast Formulas](#)

Activities
1. Select the profitability segments for which you wish to forecast values and then choose *Edit → Planning methods → Forecast*.
2. Enter the forecast data as well as the past data that is to serve as the basis for calculating the forecast.
3. Enter a forecast profile OR select the *Interactive* indicator. By entering the forecast profile AND selecting the *Interactive* indicator, the data for the forecast profile is shown as the default values.
Revaluate

Use
For the manual entry of planning data, you use the Revaluate method to apply percentage additions or deductions to the value fields of the profitability segments you selected.

Prerequisites
You need to have created a revaluation key or an access key to a segment-specific revaluation key in Customizing for Profitability Analysis under Planning → Planning Aids → Revaluation Key [Extern].

Activities
Select the relevant lines and then choose Edit → Planning methods → Revaluate to execute revaluation. Enter either the revaluation key defined in Customizing or the access key that is to be applied in the revaluation.

If you select the Inverse computation option, the system reverses the sign of the revaluation key.

Revaluation of 20% with an initial value of 120
Result without inverse computation: 144
Result with inverse computation: 100

In this way, you can reverse any previous computations.

The initial value is 144, which was calculated without inverse computation above. When you repeat the revaluation with inverse computation, this yields 120.
Events

Use

During the manual entry of planning data, you use the method Events to take into account the short-term effects that events, such as sales campaigns, have on your planning data.

Prerequisites

You need to have created an event or an access key to a segment-specific event in Customizing for Profitability Analysis under Planning → Planning Aids → Event [Extern].

Activities

Select the relevant rows and then choose Edit → Planning Methods → Events. Enter the event or the access key that was defined in Customizing.

If you select the Inverse computation indicator, the system reverses the sign of the event. In this way, you can reverse any previous computations, for example.
Period Distribution

Use

The *Period distribution* planning method for the manual entry of planning data allows you to distribute - on the basis of a *distribution key* - the values of the planning objects you selected to the periods you specified in the fiscal year variant. If there are already values at those periods, they are distributed again.

Prerequisites

You need to have created a distribution key or an access key to a segment-specific distribution key in Customizing for Profitability Analysis under *Planning → Planning Aids → Distribution Key for Period Distribution [Extern]*.

Activities

Select the relevant lines and then choose *Edit → Planning methods → Period distribution* to execute period distribution. Enter the distribution key or the access key that was defined in Customizing.

⚠️

If a distribution key or an access key has already been assigned (for example, via the *Enter planning data* parameter set or due to a distribution key field having been added in the planning layout), then it is overwritten.
Ratios

Use

When entering planning data manually, you use the Ratios method to valuate your quantity plan using reference prices (ratios).

A typical scenario could resemble the following:

1. First you copy actual data or a plan version from the previous year to a reference version that you want to use as the basis for valuating your plan quantities.

2. Then you modify this reference version using the manual and automatic planning methods until you get the desired plan prices for the coming year.

   These prices are now available as an alternative to the pricing conditions from Sales and Distribution (SD) for changing and simulating planning data.

   Technically, this plan version contains quantities and values from which the system dynamically calculates ratios (prices) at a given planning level. You determine which planning level the prices should be calculated on by specifying access characteristics for the individual ratios. That way you can calculate average prices at a summarized level, such as product groups. See also Example: Valuation of Quantity Plans Using Ratios [Seite 172]. You enter access-level characteristics when you define ratios in Customizing.

3. Now you can use these prices to valuate the quantities in your sales plan.

4. Finally, you can use these separate plan versions to simulate price and quantity changes independently of one another.

   If your reference version contains different prices in the different periods, the system always calculates a weighted average and uses this to valuate your plan quantities.

Prerequisites

To valuate your plan quantities using ratios, you first need to define the required ratios and a ratio scheme in Customizing for Profitability Analysis. You do this under Planning → Planning Aids → Define Ratios and Ratio Schemes [Extern]. Assign these ratios to the ratio scheme in the desired order, and define access characteristics.
Activities

Plan your quantities for a product or group of products. To valuate these quantities using the prices in the reference version, select the rows you want to valuate and choose Edit → Planning methods → Ratio. Enter the desired ratio scheme and specify whether you want to valuate on the basis of plan or actual data.

See also:

Price Planning Using Ratios [Seite 159]
Example: Valuating a Quantity Plan Using Ratios

Before valuating planning data using ratios, you need to define access characteristics. The access characteristics define the planning level on which the system should calculate the ratio. This makes it possible for you to find average prices at a summarized level, such as for product groups.

You enter access-level characteristics when you define ratios in Customizing.

The following is an example of valuation of quantities at different planning levels.

Reference version

<table>
<thead>
<tr>
<th>Product</th>
<th>Product group</th>
<th>Quantity</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>10</td>
<td>200</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>20</td>
<td>700</td>
</tr>
</tbody>
</table>

Quantity plan

<table>
<thead>
<tr>
<th>Product</th>
<th>Product group</th>
<th>Quantity</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>11</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>22</td>
<td></td>
</tr>
</tbody>
</table>

If you valuate this quantity plan using the ratio of sales revenue to sales quantity at the product level, the system determines a separate price for each product:

Product 1 is valuated with the price \( \frac{200}{10} = 20 \)

Product 2 is valuated with the price \( \frac{700}{20} = 35 \)

Quantity plan valuated at product level

<table>
<thead>
<tr>
<th>Product</th>
<th>Product group</th>
<th>Quantity</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>11</td>
<td>220</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>22</td>
<td>770</td>
</tr>
</tbody>
</table>

If you valuate this quantity plan using the ratio of sales revenue to sales quantity at the product group level, the system determines a single average price for all the products in each individual product group:

\( \frac{(200 + 700)}{(10+20)} = 30 \)

Quantity plan valuated at product group level
<table>
<thead>
<tr>
<th>Product</th>
<th>Product group</th>
<th>Quantity</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>11</td>
<td>330</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>22</td>
<td>660</td>
</tr>
</tbody>
</table>
Exits

Use
By selecting the *Exits* method for the manual entry of planning data, you can use on your planning data planning functions that you programmed yourself. You can use planning functions with and without reference data.

Prerequisites
1. For every individual function that you carry out, you need to create an exit number for the customer enhancement [Extern] in Customizing by choosing *Planning → Planning Aids*. This exit number is then used to control the different functions separately within the function modules for the customer enhancement COPA0006 (see point 2).
2. All functions that you want to use must first be carried out in the enhancement COPA0006 in Customizing for Profitability Analysis under *Tools → SAP Enhancements*. By using two different function modules, you can choose between executing the enhancement with or without reference data. Both function modules contain an exit number field in the interface. This allows you to distinguish between the different functions within the same function module (such as "If exit no. = 1, execute function 1. If exit no. = 2, execute function 2.").

Activities
1. Select the profitability segments for which you want to use the function programmed by you. Then choose *Edit → Planning methods → Exits*.
2. Enter the exit number.
3. If the exit number calls up a function with a reference, the system will always call up the information from the reference data.
Change Values

Use

To use the function Change values, you first need to select a range of data cells that does not contain any attributes (such as distribution keys). You can then change the values in the selected range using the functions Revaluate and Add.

Features

- Revaluate
  
  This function increases the values in the selected cells by a percentage that you enter. You can also enter a negative sign, in which case the values in the selected cells are decreased by that percentage.

- Add

  The Add button lets you add the value you specify in the Value field to the values in the selected cells. Again, you can enter a negative sign, in which case the value you entered is subtracted from the previous values.

If you want to reverse the Change values function, choose Undo entries or the pushbutton (see Clear Row, Undo, Redo [Seite 189]).
Goal Seek Function

Use

The goal seek function is used in manual planning to find the content of a cell automatically by referencing another cell that shares the first cell's function. The cell whose content is to be sought is referred to as the source cell. The target cell must be linked to the source cell by a formula and must represent the result of this formula.

You can enter a value - the target value - for the target cell in the goal seek function. After the function has been carried out, the value necessary for reaching the target value is written to the source cell. In this way, the system simulates manual entry.

Your planning layout contains, among others, the following columns: planned revenue, planned quantity and planned price. The planned revenue is the product of planned quantity and planned price.

When entering planning figures, you can use the goal seek function to produce in the planned price cell the value required in order to attain a certain target revenue, such as 120,000 USD. Select the planned price as the source cell and the revenue as the target cell. Ensure that there is a value in the planned quantity cell.

Prerequisites

- Your current planning layout should always contain formulas or ratios.
Goal Seek Function

- You need to select two cells and ensure that at least one of those selected - the source cell - is unlocked for manual entry.
- All cells used to calculate between the source and target cells must have entries.
- Neither of the selected cells should be the totals row.

Activities

1. Select just two cells.
2. Choose Edit \(\rightarrow\) Goal seek.
3. If necessary, change around the source and target cells.
4. Enter a target value.
5. If you want to cancel the result produced by the goal seek function, choose Edit \(\rightarrow\) Undo \(\rightarrow\) Undo entry.
General Functions

The following sections contain descriptions of some general functions that are available for the manual entry of planning data (such as *cut*, *copy*, and *insert*).
Format to Print

This function lets you display the data your are currently displaying in list form, so that you can then do the following:

- print it
- send it as an attachment in SAPmail
- save it in a report tree
- download it to a file on your PC

It is technically not possible to print directly from the data entry screen. Consequently, the system formats all the data that meets the current selection criteria as a report list. This list looks exactly like the data entry screen. This means, for example, that if you change the width of a column on the entry screen, that will affect the width in the report list. It is not possible to change the report list directly.
Cut

Use

This function lets you move all the data in the selected range to the clipboard. When you do that, the system clears the selected cells.

You can select any of the following:

- An entire value column
- A block within a value column
- A block of value cells within a row

You can select an entire column by clicking on the column header. To select a block, use the `Select block` function. You can also select areas by positioning the cursor. The system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

If you have explicitly selected a block or entire column, the system ignores the cursor position.

Prerequisites

The selected area may not contain any attribute cells (such as distribution keys), since these cannot be cleared.

Features

When you choose Cut, all the selected cells are cleared (set to “0”) and the values contained there are moved to the clipboard. The contents are the clipboard are

- **Overwritten**, the next time you use the Cut or Copy function or
- **Deleted** as soon as you switch from the overview screen to the period screen or back.

The function Paste [Seite 184] lets you insert the values from the clipboard to another position on the entry screen.

If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Copy

Use
This function lets you copy all the data in the selected range to the clipboard.
You can select any of the following:
- An entire value column
- A block within a value column
- A block of value cells within a row
- An entire row

You can only paste a row into another row if the target row is ready for input.
Consequently, the screen must contain rows that are ready for input before you can copy
entire rows to the clipboard.

You can select an entire row or column by clicking on the row or column header. To select a
block, use the Select block function. You can also select areas by positioning the cursor. The
system interprets the cursor position as follows:

<table>
<thead>
<tr>
<th>Where is the cursor?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>in a lead column (not a blank row)</td>
<td>the row where the cursor is positioned</td>
</tr>
<tr>
<td>on a data cell (not a blank row)</td>
<td>the cell where the cursor is positioned</td>
</tr>
<tr>
<td>any other position</td>
<td>nothing</td>
</tr>
</tbody>
</table>

💡
If you have explicitly selected a block or entire column, the system ignores the cursor
position.

Features
When you choose Copy, the values contained in the selected cells are copied to the clipboard.
The contents are the clipboard are
- Overwritten, the next time you use the Cut or Copy function or
- Deleted as soon as you switch from the overview screen to the period screen or back.
The function Paste [Seite 184] lets you insert the values from the clipboard to another position on
the entry screen.
**Paste**

**Prerequisites**
You can only use this function if you have already cut or copied data to the clipboard. For details, see Cut [Seite 180] and Copy [Seite 182].

**Use**
The function *Paste* lets you insert the values from the clipboard to the selected area on the entry screen.

Where the data is inserted depends on what is in the clipboard and what you have selected (either explicitly or by positioning the cursor) on the entry screen.

<table>
<thead>
<tr>
<th>What is in the clipboard?</th>
<th>What is selected?</th>
</tr>
</thead>
<tbody>
<tr>
<td>an entire column</td>
<td>You can select either the entire target column or the first cell in that column.</td>
</tr>
<tr>
<td>an entire row</td>
<td>You can either select the entire target row (blank row) or position the cursor on the target row in the lead column.</td>
</tr>
<tr>
<td>a block within a column</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
<tr>
<td>a block within a row</td>
<td>Select the first cell (on the left) of the area where you want to insert the data from the clipboard. The data is inserted there and in the cells to the right.</td>
</tr>
</tbody>
</table>

💡 If you have explicitly selected a block or entire column, the system ignores the cursor position.

**Tips**
When using the *Paste* function, note the following:

- You can copy entire rows to the clipboard. If you do, you can only insert the row in a blank row that allows data entry.
  The system inserts the characteristic values in the lead columns along with the values in the value columns. However, if you only copied the row, note that the combination of characteristics already exists. You therefore need to change the new row.

- If some cells in the target range are in display mode, the values in those cells are not overwritten. However, if you change values that are used to calculate other values, this could also change those calculated values, even if they are in cells that are not ready for input.

- The *Paste* function does not change or delete the content of the clipboard.
If you want to reverse the Cut function, choose Undo entries or the corresponding icon.
Insert

This function lets you insert new lines between existing ones.
Long Text

Use
This function allows you to write an explanatory long text for a profitability segment, or to display or change an existing one.

Features
The long text indicator allows you to identify at a glance which segments have already been documented. If you want to see the long text indicator in planning, you need to specify it when you define your planning layouts.

Note that the long text is linked to the entire profitability segment, including all derived characteristics, and therefore can no longer be found if you change the derivation rules.
Row Proposal

Use

You use the *Propose rows* function to fill the lead columns in the planning layout with characteristic values from the master data.

Features

The system checks whether the combination of characteristic values is valid for the organizational units. If the *Check derivation* indicator is active in the plan version, the system also runs a check as to the compatibility with characteristic derivation when the valid characteristic values are determined. For example, only those products belonging the product group in the general data selection appear in this case.

💡

If you execute this function for characteristics with a large amount of values (such as the characteristics *customer* or *product*), the selection may take a very long time. In some cases, a timeout might even occur.
Clear Row, Undo, Redo

Clear Row
This function is only active when you make an entry that is not allowed.
It allows you to reverse the entries made in the row where the error occurred, thus returning the row to its last valid state in the planning session. The system then continues checking the entries with the next row.

Undo
This function (pushbutton 🔄) reverses all the entries in the last dialog step. The system always stores the five last states so that you can restore these. However, these states are lost each time you switch from the overview screen to the period screen or back. After that you can no longer undo the previous step.

💡
If you choose this function by mistake, you can “undo” the “undo” using the Redo function.

Redo
The Redo function (pushbutton 🔄) is only active after you have used the Undo function.
Overview Screen

This function takes you to the overview planning screen. What is displayed depends on where you are when you choose this function:

- **Initial screen**
  The system displays the rows and columns of the overview screen for the first valid combination of header characteristic values.

- **Period screen**
  The system displays the overview screen for the current combination of characteristic values.
**Period Screen**

This function takes you to the period planning screen. What is displayed depends on where you are when you choose this function:

- **Initial screen**
  
  The system internally determines the structure of the overview screen and then displays the period screen that corresponds to the first row of the overview screen.

- **Overview screen**

  The system displays the period screen for the selected row or the row where the cursor is positioned. The characteristic values in that row appear in the header of the period screen.

  The rows of the period screen contain the individual periods for the current combination of characteristic values.
Next Combination, Previous Combination, Other Combination

Use
If you enter an interval of characteristic values on the variables screen, you can plan multiple combinations of characteristic values. These functions let you navigate between these combinations.

Next Combination
- Overview screen
  This function takes you to the next valid combination of characteristic values from the general data selection.
- Period screen
  This function takes you to the combination of characteristic values that represents the next row of the overview screen.

Previous Combination
- Overview screen
  This function takes you to the previous valid combination of characteristic values from the general data selection.
- Period screen
  This function takes you to the combination of characteristic values that corresponds to the previous row of the overview screen.

Other Combination
This function lets you navigate to any valid combination of characteristic values in the general data selection. This function is only available on the overview screen.
Line Item Display

Use
This function (which you access by choosing Extras → Line items) allows you to list the logical plan line items for the records selected at the segment level and to display the specific line item.

Features
From the line item display, you can call up the master data for products, customers and profit centers directly using the Integration function key. You can find other display options in the information system or by choosing Extras → Report simulation.

See also:
Line Item List [Seite 336]
**Number Format**

This function lets you change the way the values in a specific column are displayed. For example, you can display the values in millions with one decimal place. This does not affect the way the data is stored.

💡

The number formats used when you first call up the planning screen are taken from the definition of the planning layout.
Lead Columns

Use

When planning data is entered, the total for all entries in the planning layout is always displayed in several lead columns. Furthermore, you can choose to have a subtotal displayed for each characteristic in the lead column. To make this setting, select/deselect the option Total in the relevant dialog box. If you are working with two lead columns and you select the option Total for just one of them, all the value fields for the characteristics in the other lead column are then summarized.

Planning layouts with only one lead column are the exception. The default setting is for no total to be displayed, but you can have it displayed by selecting the option Total.

With the default settings, an overview screen could appear as in the following example:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>90</td>
</tr>
</tbody>
</table>

If you select the option Total in the dialog box for the cost center, the following representation appears:

<table>
<thead>
<tr>
<th>Cost center</th>
<th>Cost element</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>4711</td>
<td>400000</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>60</td>
</tr>
<tr>
<td>4712</td>
<td>400000</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>50</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>150</td>
</tr>
<tr>
<td>4713</td>
<td>400000</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>410000</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>420000</td>
<td>90</td>
</tr>
<tr>
<td></td>
<td>*Cost element</td>
<td>240</td>
</tr>
</tbody>
</table>

*Cost center *Cost element 450
Lead Columns

In Customizing, you can make the subtotals be displayed using default parameters: when you are in CO-PA, you do this in the parameter set, when you are in other applications, you do this during planner profile definition. When entering planning data in the application, you can alter this setting for the duration of that planning session.

Activities

By choosing Settings → Lead Columns... in Customizing as well as in the application, you can access the dialog box to set the subtotals display.
All Key Values On/Off

Use

In planning layouts containing with several lead columns, it can occur that several characteristic values relate to the same value in another column. In such cases, the system default is to display the repeated characteristic only once in the overview screen.

By choosing Settings → All key values on/off, you can set the repeated characteristic values to be displayed or hidden. The selected setting, however, is only valid for the planning session you are working in.

Standard Setting All Key Values Off.

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

All Key Values On

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brown plc</td>
<td>Pump P-100</td>
<td>100 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-110</td>
<td>50 000.00</td>
</tr>
<tr>
<td>Brown plc</td>
<td>Pump P-200</td>
<td>120 000.00</td>
</tr>
<tr>
<td>Smith Ltd</td>
<td>Pump P-200</td>
<td>200 000.00</td>
</tr>
</tbody>
</table>

In order that you can distinguish the initial value of a characteristic from a hidden value, the initial value is displayed with the special character "#".
Header Display On/Off

Use
The function Header display on/off allows you to display or hide information at the top of the overview screen and of the period screen. The setting is only valid during that particular planning session.

Activities
Choose Settings → Header display on/off.
Posting

Use
When you post via 📊, the system saves the planning data you created.

Features
The system writes a plan line item for the planning session. This line item contains the changes you made to any existing planning data.
Integrated Excel in Planning

Use

For planning with integrated Excel, Microsoft Excel is used as a planning screen for your planning data in the SAP System. This allows you to combine the comfort of Excel's formatting and data processing functions with the powerful planning functions of your SAP application. You are therefore able to use the Office input interface with online planning in the SAP System.

There are two ways of using Excel to plan your data:

- Planning with Excel integrated into the user interface of the SAP System
  Excel replaces the standard SAP planning screen. This enables you to plan using the functions of both the SAP System and Excel.

- Offline planning in Excel and uploading data into the SAP System
  From one or more PCs that are not connected to the SAP System, you can enter your planning data into several Excel spreadsheets. This data can then be uploaded into the SAP System, where you can process it further using the SAP planning functions.

Prerequisites

Software

To be able to plan using integrated Excel, the following should be installed on your PC:

- The Windows NT 4.0 or Windows 95 operating system
- Microsoft Excel 97
- A current SAP GUI (32 Bit) matching your System Release

Hardware

To ensure good response times, your PC should have a Pentium II processor and 64 MB RAM.

Features

In Customizing, you can define Excel spreadsheets for use as templates in planning. In those templates, you can move data around, insert graphics, define macros, and format text and cells. You can use this template to plan with integrated Excel or to plan with the upload function.

Link between Excel and the SAP System

From the technical point of view, Excel is called up by the SAP System using OLE (Object Linking and Embedding), an interface in the Office programs. Integrated Excel into the SAP System allows you to use the same Excel functions that are available with the integration of Excel in Word, for example.

On a more detailed level, the link between the Excel spreadsheet and the SAP planning layout is created above the position of the data in the Excel spreadsheet:

The SAP System uses Customizing to determine which SAP data is in Excel and where it can be found. The position of the data cannot be changed in the planning screen to ensure that the data is imported correctly. The fields of the planning layout are mapped to the Excel spreadsheet using File Description [Extern].
Constraint
You cannot use integrated Excel to enter any planning data in the period screen.

Activities

Initial Steps
To be able to use Microsoft Excel as your planning screen, you need to activate the indicator integrated Excel in Customizing for your application when Setting Up The Planning Framework (only CO-PA), or when you assign your planning layouts to a planner profile.

In Customizing, you can also design an Excel spreadsheet to be used as a template for planning in Excel.

For more information about setting up integrated Excel, see Setting Up Integrated Excel.

Planning in Excel

- Excel integrated in the SAP interface
  To plan directly in the SAP System using integrated Excel, you can choose between executing a corresponding parameter set (only CO-PA) or using a planner profile in which Excel was activated as the planning screen for one or more layouts. You enter your planning data in Excel and can use Excel functions such as macros or diagrams as well as all the usual SAP planning functions. For more information on planning with integrated Excel, see How To Plan Using Integrated Excel.

- Planning in Excel and uploading data into the SAP System
  The Excel template created in Customizing can be copied as often as required and used to create planning data in Excel. By using the uploading function for Excel, you can transfer the individual files into the SAP system. This means that planning data can be entered into different PCs, local planning thereby being possible. For more information on the required procedure, see Planning Offline and Uploading into the SAP System.
Setting Up Integrated Excel

Prerequisites
Your Planning Layouts [Extern] must be defined.

If you want to change a planning layout for which you have already created an Excel template, you must create a new Excel template.

For technical reasons, it is necessary that the system already contain planning data that corresponds to the planning layout (at least one row) before an Excel spreadsheet can be formatted as a template. If no such data is present in the system, you need to create some. One way of doing this is by entering data into the appropriate layout without integrated Excel.

Procedure

Activating Excel
Depending on the application you are working in, you should proceed as follows:

- **In Profitability Analysis (CO-PA)**, you set the integrated Excel indicator to "active" when you define a parameter set for the planning method Enter planning data or Display planning data (for more information, see the section Set Up Manual Entry of Planning Data [Seite 150]). When you first select this parameter set in the planning framework, the structure that you specified in the planning layout is represented in the upper left-hand corner of an Excel sheet.

- **In the other applications**, select Integrated Excel in Customizing on the Define Planner Profiles screen when you assign planning layouts to the planner profile. This activates Excel as the planning tool for that layout in that planner profile. When you enter planning, the system displays the planning layout you defined in the upper left-hand corner of an Excel spreadsheet.

  When moving the planning layout, you can enter a specific name for the file description. This makes sense, for example, in cases where you intend to use the file description several times. If you do not enter anything here, the system automatically creates a file description when you save your planner profiles. This file description will reflect the position in the profile.

  If you want to customize a particular spreadsheet to be used uniquely with that layout in planning, you need to define an appropriate template (see “Defining an Excel Template”).

  If you want to upload an Excel spreadsheet, you need to edit an Excel sheet template in order that the system can generate a file description. This file description is required for the upload. Furthermore, you need to make several additional settings (see Planning Offline and Uploading into the SAP System [Seite 207]).
Defining an Excel Template

1. **CO-PA:** Execute the planning method *Enter planning data*, using the related parameter set. Doing so takes you to an unformatted Excel sheet. There you choose *Settings → Formatting*.

   **Other applications:** In the IMG for defining the planner profile, choose *Default Parameters* and enter values for the variables defined in the planning layout. You must do this so that you can open the spreadsheet in the next step. If desired, you can delete these entries again after you have customized your Excel template.

   To open Excel in the SAP window, choose 📈.

2. In the *Maintain File Description* screen, you can now customize an Excel spreadsheet as a template for your planning screen.

   Note the following:
   - To move planning data within the spreadsheet, **only use the appropriate SAP function**. To do this, select the data you want to move using 📦, and then position the cursor on the target location and choose 📦. You save the link between the old position and the new position of the data by choosing 📦 Save file description [Extern].
   - The first Excel spreadsheet is protected. Cells that were not locked against entries in the SAP entry screen, such as those that can be defined in the planning layout, are excluded from this protection in Excel. If you want to use functions in Excel that extend beyond editing those cells where entries can be made, you first need to remove the general spreadsheet protection in Excel.

     After editing, you should then reactivate the spreadsheet protection in Excel to ensure that, for subsequent planning, the only data that can be entered corresponds to that specified in the SAP System.

   - You can use the Excel formatting functions (such as different fonts or colors) to format the Excel template.
   - You can use Excel to create diagrams, macros and formulas and then use these for additional calculations, for example. It is recommended that you insert these into a second spreadsheet to avoid the data conflicting with the actual R/3 planning data later. The SAP planning data is imported from the first spreadsheet only.
   - When you enter formulas in the SAP data area in Excel, they are overwritten by the formula result during posting, and the formulas themselves are then discarded.

     You can save the Excel formatting in the SAP System by choosing 📦 Save Excel layout.

3. If you later want to upload files from your PC to the SAP System, you must enter a *generic file name* [Extern] (see the section Planning Offline and Uploading into the SAP System [Seite 207]).

4. Choose 📦 in the toolbar. This function will also save the file description and the Excel template.

Data saved with this function is permanent from then on.
5. Choose 

**CO-PA:** You then return to the planning framework.

**Other applications:** You return to the Default Parameters screen. Delete any values you entered for the variables if you do not want to have them displayed as the template in planning. Choose 

The default parameters are only saved temporarily at this point.

For this reason, you should then finish by saving the planner profile. Only then does the system assign a definitive file description to the planning layout and save the values for the variables are saved permanently.
How To Plan Using Integrated Excel

Prerequisites

To be able to use Microsoft Excel as your planning screen in the SAP System, you need to make the appropriate settings either in Customizing under Define Planner Profile or when defining the parameter set for the Enter planning data planning method (CO-PA only). For more information, see Setting Up Integrated Excel [Seite 202].

Procedure

1. CO-PA: Execute the planning method Enter planning data using a parameter set for which Excel has been activated as the planning tool. This automatically calls up Excel within the SAP window.
   
   Other applications: Enter planning using a planner profile and choose a planning layout for which integrated Excel has been activated. To open Microsoft Excel in the SAP System window, choose . (It is not possible to use Excel to create planning data in the period screen.)
   
   - If you have used Customizing just to set the indicator for integrated Excel and no special formatting has been made in the Excel template for this planning layout, the system displays the planning data unformatted in the upper left-hand corner of the spreadsheet.
   
   - If you have formatted an Excel template in Customizing, the system opens this template in Excel.

2. Enter your planning data.

   Note the following:
   
   - You must avoid any use of the following Excel functions:
     - Delete
     - Paste
     - Sort
   
   Use of the above functions prevents data from being imported correctly into the SAP System.
   
   - If you want to delete data, choose in the SAP System.
   
   - Enter new objects for planning directly beneath the existing SAP data (where appropriate, beneath the totals row). To paste, use the SAP possible entries function (available via ). Note that the system does not recognize data that is separated from the existing SAP planning data by an empty row.
   
   - You can sort additional data into existing data by choosing Edit → Sort in the SAP menu.
   
   - If the Excel spreadsheet is protected, then the entries that can be made in the individual cells correspond to those specified in the SAP System.
   
   - You can access SAP possible entries by choosing .
   
   - The SAP System only imports data from the first spreadsheet in an Excel folder. You can perform additional calculations or add diagrams on a second spreadsheet. These
How To Plan Using Integrated Excel

- Calculations and diagrams are only kept during your planning session if they have not already been created in Customizing.

- When you enter formulas in the SAP data area in Excel, they are overwritten by the formula result during posting, and the formulas themselves are then discarded.

- If you want to save, use an SAP planning function or run a validity check, you need to make sure that no cell is currently being edited in Excel. You can control this by displaying the "Formula Bar" in Excel (choose View → Formula bar).

- To run a validity check for the data you have entered, choose ✔ in the SAP System.

3. Post the data by choosing ✔.

   You then return to the initial screen.
Planning Offline and Uploading into the SAP System

Use

You can create your planning data in multiple files on your PC and upload those files later into the SAP System.

Prerequisites

To be able to upload the files, you must specify the **characteristic values** in the lead column of the corresponding planning layout. It is not enough to simply specify the characteristic text.

Procedure

Setup

The data you enter in Excel is uploaded into the SAP System using a suitable file description. You are therefore required to use an Excel template defined in Customizing for your offline planning. You need to proceed as follows:

1. Follow the procedure outlined in the section Setting Up Integrated Excel [Seite 202] and structure your Excel sheet template according to your needs.
2. Enter a **generic file name [Extern]** under Generic file. This name must consist of a string of characters (upper case), an asterisk (*), and the file suffix ".TXT" (example: PLANNING*.TXT).

When you later upload Excel files into the SAP System, this generic file name links the file on your local PC to the file description.

💡

The name ranges of the various generic file names cannot overlap, because this would mean that the assignment of file name to file description would not be unique. For example, if you assigned the generic file name PLAN*.TXT to one file description and PLANS*.TXT to another, file PLANS03.TXT would not be uniquely assigned.

For an overview of all file descriptions together with the generic file names, you can call up the program RKCDPREO with the **ABAP Editor** for the **ABAP Workbench**. From the list drawn up by the program, you can delete any file descriptions and generic file names that are no longer used.

3. In **Excel**, save a copy of the file on your PC and assign it a name that matches the **generic file name [Extern]**. For example, if the generic file name is SALES*.TXT, you can name the downloaded file SALES1, SALES2, or SALES_NW.

⚠️

You have to save your copy of the Excel template as an Excel file (suffix ".XLS") for the template to be opened correctly. The text format (suffix ".TXT") becomes necessary when the file is uploaded back into the SAP System. For this reason, you must save the file with file type "TXT" before uploading it into the SAP System.
Planning Offline and Uploading into the SAP System

Once you have downloaded the Excel template, you can make copies of it or give it to other users for the purpose of offline planning. The name of each new file you create must still adhere to the generic file name so that they can be uploaded later.

Local Planning

1. Enter your planning data offline using the downloaded Excel file (or copies of this file). Whenever you want to save your planning data but are not yet ready to upload it, save in .XLS-format.

   Note the following for local planning:
   - You must **avoid** any use of the following **Excel functions**:
     - Delete
     - Paste
     - Sort
     Use of the above functions prevents data from being imported correctly into the SAP System.
   - You can perform additional calculations or add diagrams on a second spreadsheet since only the first spreadsheet is saved when the Excel folder is saved as a TXT file before uploading. The additional spreadsheets are therefore not relevant for uploading.
   - During the upload, the SAP System interprets each row as an object. This means that, before you upload the file, you must delete any totals or subtotals rows. Otherwise the system will try to interpret these as separate planning objects and import them into the database as well.
   - If you want to delete a characteristic value (such as a product or cost element) in the SAP System, enter a zero in that row. This is necessary because the system uploads exactly those objects that are contained in the Excel file. If you remove the individual object completely, its values will not be reset to zero in the SAP System.

2. When you are ready to upload your data, save the file in text format (suffix ".TXT").
3. Make sure that the file name adheres to the generic file name, so that it can be assigned to the file description correctly.

Uploading Files

1. To import planning data into the SAP System, call up the uploading function:
   - By choosing **Extras → Excel Planning → Upload** in the planning menu for Cost Center Accounting
   - By choosing **Planning → Integrated Planning → Upload from Excel → Execute** in the Profitability Analysis menu.
   - By choosing **Planning → Plan values → Upload from Excel** in the Special Ledger menu.
2. Specify the file or directory that you want to import.
3. In the **file description** field, you can specify the file description with which the file(s) are to be imported. If you leave this field blank, the system will automatically create a file description using the generic file name.
4. Upload your files.
Example: Planning with Integrated Excel

This section describes how you can best use integrated Excel for your sales and profit planning.

The following scenario, for example, is supported very effectively by integrated Excel:

A planning coordinator is responsible for sales planning in a corporate group. He or she creates templates for the individual sales organizations, which then plan the sales figures before sending them back to the central planning for the group. The planning coordinator then consolidates all the planning data for the group and processes it.

Use of integrated Excel means that only the planning coordinator in this scenario is working in the SAP System. He or she sets up Customizing by formatting an Excel template, saving copies of it locally and sending those copies as simple Excel files to the sales organizations. In the sales organizations, planning occurs in Excel without any connection to the SAP System and the files are then returned to the head office, where the planning coordinator imports the planning data into the SAP System using the Excel uploading function.

For this scenario, it makes sense to have as small an amount of technical responsibility as possible placed with the local sales organizations. You should ensure in Customizing that the local planners are only allowed to plan the data that is relevant to them. Moreover, the local planners should be affected as little as possible by the technical restrictions brought about by using integrated Excel (see the sections Setting up Integrated Excel and How To Plan Using Integrated Excel).

These aims can be attained by observing the following:

Since the data is uploaded from the first spreadsheet, this is the one that should be set aside as the “SAP sheet”. It should not be possible to process data in this sheet. In a second spreadsheet, data can be copied to any desired item and processed. Macros should be used to ensure that the data is consistent in both spreadsheets.

Practical Conversion

First Spreadsheet

The first spreadsheet is used to provide an overview. The data is organized in the same way as when it was downloaded from SAP System. The individual profitability segments are listed in rows. To separate the planning data from the header data, the planning data area is placed just two lines lower (using the function in SAP System). For purposes of illustration, the cells have been stored in colors.

The first spreadsheet is protected as a whole.
This procedure has the advantage that the data can be imported safely from the first spreadsheet. Spreadsheet protection eliminates the danger of data being moved with the Excel function and the danger of losing the assignment to the SAP System using file description [Extern]. Furthermore, there is no way of adding data that could be misinterpreted as a profitability segment during the upload. The formatting - which could theoretically pose problems during upload - are simply discarded when the file is converted into the "TXT" format. The central planner only needs to delete the totals row before uploading to ensure the import is carried out correctly. See also Planning Offline and Uploading into the SAP System [Seite 207].

Second Spreadsheet

The second spreadsheet is structured so that the profitability segments can be imported and processed individually. To switch between profitability segments, you can use pushbuttons set with macros.

Spreadsheet protection can be set to be more flexible in the second spreadsheet than for the first one. It is possible to remove the protection from just the cells into which the planning data is to be entered. You can also remove protection from the entire spreadsheet to make additional calculations and so forth possible.

In the present example, entries can only be made in the value field for volume, whereby the other value fields for the profitability segment (cells B13 to B17) remain protected. Under additional calculations, it is possible to include information about the negotiated price, the average portion of sales discount and the average portion of product costs.

All other values for the profitability segments are calculated using the following formulas, stored in the respective cells:

Revenue = quantity * price (cell content: =B13*F27)
Sales deductions = revenue * average portion of sales discount / 100 (cell content: =B14*F28/100)
Cost of goods sold = revenue * average portion of product costs / 100 (cell content: =B14*F29/100)
Contribution margin I = revenue - sales deductions - cost of goods sold (cell content: =B14-B15-B16)

Macros

Work with visual basics macros is restricted when working with Excel in the SAP interface due to the connection to OLE (Object Linking and Embedding). For example, macros cannot be recorded. Moreover, no control elements (that usually start the macros) are available. Instead, you have to draw graphic objects in Excel and use them to store the macros (the gray rectangles in the above diagram).

The above example contains the following macros:

Definition of global variables:
Public firstline As Integer
Public lastline As Integer
Public actline As Integer

The macro initialize is performed as soon as the second spreadsheet customer is activated. First, variable assignments are used as the initial line to determine the number 14 (the first line of data in the first spreadsheet). Then, the macro get_item is called up and used to read and copy the data in this line. The total number of lines of data is also calculated. The system assumes that the final line is the totals line and that it therefore does not contain any data records to be processed. Hence the final line is not included in the calculation.

Sub initialize()
    Dim counter As Integer
    firstline = 14
    actline = firstline
    Call get_item
    counter = 14
    While Sheets(1).Cells(counter + 2, 1).Value <> initial
        counter = counter + 1
    Wend
    lastline = counter
End Sub

The macro get_item reads the data from a line in the first spreadsheet and copies it first of all to the auxiliary cells in the second spreadsheet. These are cells which, in coding, have 100 as a second value (in the above spreadsheet, cells CV13 to CV17). They can be placed anywhere on the spreadsheet or made invisible. Only the quantity value is placed into that cell for the profitability segment that can accept entries. If the other data were also to be transferred directly into the value fields of the profitability segment, the formulas stored in the cells (mentioned above) would be overwritten. In order that these cells also contain data, the three cells necessary for the formulas (those cells used for additional calculations) must have those values entered into them that are used in the formula to arrive at the corresponding values from the first spreadsheet. For this, the result from each inverted formula is written to the cells for additional calculations (see the last lines of the macro).

Sub get_item()
    Sheets(2).Cells(9, 2).Value = Sheets(1).Cells(actline, 1).Value
    Sheets(2).Cells(9, 4).Value = Sheets(1).Cells(actline, 2).Value
Example: Planning with Integrated Excel

The macro update_item copies any data, changed or otherwise, for the profitability object in the second spreadsheet and transfers it back to the first spreadsheet.

```vba
Sub update_item()
    Sheets(1).Cells(actline, 1).Value = Sheets(2).Cells(9, 2).Value
    Sheets(1).Cells(actline, 2).Value = Sheets(2).Cells(9, 4).Value
    Sheets(1).Cells(actline, 3).Value = Sheets(2).Cells(10, 2).Value
    Sheets(1).Cells(actline, 4).Value = Sheets(2).Cells(10, 4).Value
    Sheets(1).Cells(actline, 5).Value = Sheets(2).Cells(13, 2).Value
    Sheets(1).Cells(actline, 6).Value = Sheets(2).Cells(13, 3).Value
    Sheets(1).Cells(actline, 7).Value = Sheets(2).Cells(14, 2).Value
    Sheets(1).Cells(actline, 8).Value = Sheets(2).Cells(15, 2).Value
    Sheets(1).Cells(actline, 9).Value = Sheets(2).Cells(16, 2).Value
    Sheets(1).Cells(actline, 10).Value = Sheets(2).Cells(17, 2).Value
End Sub
```

The macro first_item is called up by selecting First.

```vba
Sub first_item()
    Call update_item
    Call initialize
End Sub
```

The macro next_item is called up by selecting Next.

```vba
Sub next_item()
    Call update_item
    actline = actline + 1
    If actline > lastline Then
        MsgBox ("Last item!")
        actline = actline - 1
    Else
        Call get_item
    End If
End Sub
```

The macro previous_item is called up by selecting Previous.

```vba
Sub previous_item()
    Call update_item
    actline = actline - 1
    If actline < firstline Then
```
Example: Planning with Integrated Excel

```vba
MsgBox("First item!")
actline = actline + 1
Else
    Call get_item
End If
End Sub
```

The macro `last_item` is called up by selecting `Last`.

```vba
Sub last_item()
    Call update_item
    actline = lastline
    Call get_item
End Sub
```

It is recommended to create macros first in Excel on its own and then to use Customizing to copy them into the spreadsheet template. In this way, you can always go back to a version of your macros. Otherwise, if a macro contains an error or if an instruction cannot be performed with OLE, it could happen that the spreadsheet template can no longer be opened after being saved in integrated Excel.
Entering Planning Data via the World Wide Web

Use
Part of the data relating to a company's sales and profit planning is often entered locally by individual sales employees, for example. The possibility of entering planning data via the World Wide Web (WWW) means that occasional users of the SAP System who only have limited experience with it are able to enter their planning data using a simple interface and without the need for a SAPGUI to have been installed locally.

Integration
Entering planning data via the WWW involves the same planning levels and planning packages as those in the planning framework.

Prerequisites
An Internet Transaction Server (ITS) needs to be set up in your system.

Features
The entry of planning data via the WWW is intentionally less complicated than entering planning data in the planning framework. Compared to the planning method Enter planning data, the WWW option offers less functions: it is only possible to enter data, to edit it using planning methods [Seite 164], before posting it. The user interface is kept simple and SAP terminology (such as the concepts planning level and parameter set) is avoided.

The employee entering the planning data uses a Uniform Resource Locator (URL) in his Web browser to call up the function for entering planning data. This function can be executed both with and without the mySAP.com Workplace [Extern].

Activities
Planning data entry via the WWW is set up from the planning framework, using the same principle described in the section Setting Up Planning Content [Seite 140]. The relevant planning method is Enter planning data. You should therefore consult the section Manual Planning Data Entry [Seite 150] as well.

The set up of planning data entry via the WWW differs, however, from the "normal" set up of planning data entry in the following ways:

- You need to include in a personalization profile the planning levels, planning packages and parameter sets that are relevant to a planner's tasks and then to assign the planner's user ID to this profile. When the planner calls up the URL, the only elements of planning that are available for editing are those that have been assigned to the planner's user id in one or more personalization profiles.

- To make planning data entry as straightforward as possible, you should give all the elements self-explanatory descriptions. These descriptions appear in the planner's user interface and structure his/her tasks.

  The following graphic shows how your specifications for the planning levels, planning packages, and parameter sets appear in the planner's user interface. The selected elements and their respective dependent objects appear in black.
You can (and should) use the element *description* to provide the planner with necessary information.

In the parameter set, you should use the *Methods* tab page to make only the essential planning methods available. In the *description*, you should explain how the methods should be applied. If the method to be applied involves using a planning aid (such as the *Revaluate* method, which contains the planning aid *Revaluation key*), you should also mention the name of the relevant planning aid (such as revaluation key) in the description.

The possible entries function is not available via the WWW. To ensure that the planner knows for which profitability segments he/she is supposed to plan, there should already be data in the system. The data could be a suggested plan, achieved by copying the actual data from the previous year.

If you do not want to enter prior values in this way, you can proceed as follows:

a. Deactivate the *Zero suppression* indicator in the parameter set.

b. Execute the parameter set from the planning framework.

c. Enter the value 0 for the relevant segments. To determine the relevant segments, you can use the *Propose rows* function.

This has the result that the profitability segments are displayed without values for the planner.

In the upper-right area of the screen, you can display a GIF or JPG graphic (such as a logo). This graphic needs to be named logo.gif or logo.jpg and its width should not exceed 170 pixels. In each ITS for the R/3 System, this graphic must be set in the following folder: mimes\kepm\99.
When planning data entry is called up via the WWW, a check is made to see whether a graphic with the name logo.gif exists in the above folder. If this is the case, the graphic is displayed. If no such graphic is found, a search is made for a graphic with the name logo.jpg. If there is no graphic with this name either, then no graphic is displayed.

When you have maintained all the settings in the planning framework (planning level, planning package, parameter set for the planning method Enter planning data, and the personalization profile), use role maintenance (transaction PFCG) to assign the relevant role Entering Sales and Profit Planning Data via the World Wide Web [Extern] to the planners. In this way, the planners have the authorization for entering planning data via the WWW; the function is accessible via the launch pad in their mySAP.com Workplace.

If the function, instead of being executed from the Workplace, is to be made accessible from a URL that is to be sent as a link in an e-mail, contact the ITS administrator for your R/3 System who can give you the correct URL. As a rule, the URL is made up as follows: http://<ITS-Name>/scripts/wgate/kepm/!. In each case, the name of the WebRFC service is contained in the URL beside the ITS name. Thus, in the above example, it is KEPM.
Entering Planning Data in the Workflow (CO-PA)

Purpose

The delivered workflow Execute CO-PA Planning (COPA_PLAN_M1) enables you to produce during sales and profit planning a planning set into which several planners can enter their planning data. You can assign planners to the planning packages centrally by starting the workflow and you can use the SAP Business Workflow [Extern] to monitor the process flow and execute a work item analysis [Extern], for example.

Process Flow

1. First set up the Planning Framework and thereby the architecture for planning (see Setting Up Planning Content [Seite 140]). At the same time, define a parameter set for the planning method Enter planning data.

2. Assign planners to the planning packages defined in the planning framework. For more detailed information, see the section Set Up and Customizing [Seite 222].

3. Start the Perform CO-PA Planning workflow manually by choosing Office → Start workflow. Enter the number of planning packages and the parameter set to be used in planning.

4. For each planning package, the system generates a work item and sends it automatically to the inbox belonging to the assigned planner.

5. The planners enter their planning data - possibly in separate phases - and then end the workflow manually.

See also:

BC - Workflow Scenarios in the Applications [Extern]
Technical Implementation

Object types

For sales and profit planning with workflow support, only the following object type [Extern] is relevant:

Object type BUS1166 (COPAPlanningPackage)

You can use the object type BUS1166 to process planning packages in CO-PA Planning. The key fields for the object type are:

- Operating Concern
- Type of Profitability Analysis
- Planning level
- Planning package

You define a planning level and the associated planning packages when setting up planning content [Seite 140].

The object type BUS1166 contains the following methods:

- ChangePlanData to change planning data
- DisplayPlanData to display planning data

Tasks

The following tasks delivered by SAP are available as modules and can be used in a workflow scenario without having to be changed beforehand (for more information, see Tasks and Task Groups [Extern]).

One task is used to enter planning data whereas the other task is used to display it.

Task COPA_PLAN_01

Definition

Task: 20000612
Short name: COPA_PLAN_01
Description: Entering CO-PA planning data

Structure

Object type: BUS1166 (COPAPlanningPackage)
Referenced object method: ChangePlanData
Attributes: Object method with dialog, confirm end of processing
Agent assignment: no restriction on possible agents

This is where you specify which agents can be selected as the responsible agent. The responsible agent for this task is determined by the role. Any agent can be the responsible agent.
Technical Implementation

For this reason, it is necessary to classify the task in Customizing as a general task. For more information, see: Set Up and Customizing [Seite 222].

**Task COPA_PLAN_02**

**Definition**
Task: 20000664
Short name: COPA_PLAN_02
Description: Displaying CO-PA planning data

**Structure**
Object type: BUS1166 (COPAPlanningPackage)
Referenced object method: DisplayPlanData
Attributes: Object method with dialog, confirm end of processing
Agent assignment: no restriction on possible agents

This is where you specify which agents can be selected as the responsible agent. The responsible agent for this task is determined by the role. Any agent can be the responsible agent. For this reason, it is necessary to classify the task in Customizing as a general task. For more information, see: Set Up and Customizing [Seite 222].

**Workflow**

Each workflow can contain one or more tasks. The business flow for this task is implemented as the workflow definition within a workflow.

**Workflow COPA_PLAN_M1**

You can use this workflow to influence sales and profit planning when several planning packages are to be processed.

**Definition**
Workflow: 20000377
Short name: COPA_PLAN_M1
Description: Performing CO-PA Planning

**Workflow Container**
The import parameters of a workflow are placed in the workflow container.
The following two sources of information are essential for the workflow COPA_PLAN_M1 to be processed and therefore must be available:

- A table containing object references to the planning packages to be processed. These planning packages are placed into the multiple-lined container element COPAPlanningPackage.
- A parameter set for executing the method ChangePlanData. This parameter set is placed into the container element ParameterSet. The parameter set contains the parameters for manual planning, such as the planning layout and the entry currency. You create them in the same way as planning packages when setting up the planning framework.
You must enter both sets of information when starting the workflow.

**Workflow Steps**

The workflow COPA_PLAN_M1 consists of a single step, the task *Enter CO-PA Planning Data*. However, the distinguishing feature of this step is that its dynamic processing occurs in parallel (tab page *Miscellaneous* in the step definition): the system creates a work item with a planning package for every entry in the multiple-lined container element *COPAPlanningPackage*.

**Agent for the Workflow Step *Enter CO-PA Planning Data***

You can enter in a workflow step the planning data for a planning package. There are many different ways of determining the responsible agent for this workflow step. Role COPA_PLAN_R1 is used to find the agent in the delivered workflow COPA_PLAN_M1 (see below).

**Starting the Workflow**

You do not use an event to start the workflow COPA_PLAN_M1. Instead, you start it directly by choosing *Office → Start Workflow* in the menu.

When starting the workflow, you need to enter one or several planning packages and a parameter set.

**Role COPA_PLAN_R1**

**Definition**

This is a role used to determine the agent for a planning package. It is used in the delivered workflow template COPA_PLAN_M1.

Role: 20000069
Short name: COPA_PLAN_01
Description: Person responsible for the CO-PA planning package

**Role Parameters**

You can copy all key fields for the object type BUS1166 as role parameters: *operating concern*, *type of profitability analysis*, *planning level* and *planning package*. Your assignment of an agent is then dependent on these fields. For more information, see: [Set Up and Customizing](SEITE_222).
Set Up and Customizing

Use

Prior to being able to execute the Perform CO-PA Planning workflow, you need to carry out the initial steps described below.

Prerequisites

You need to have set up the SAP Business Workflow.

Activities

1. Enter a planning level, planning packages and a parameter set for the planning method Enter planning data (see Setting Up Planning Content [Seite 140]).

2. Classify the task Enter Planning Data as a general task. You do this in Customizing for Basis Components by choosing Business Management → SAP Business Workflow → Perform task-specific Customizing → Controlling → Profitability Analysis → Assign Tasks to Agent.

3. Specify which planning package is to be assigned to which agent's inbox for entering planning data. For this, you need to maintain agent assignment in the role COPA_PLAN_R1. You do this in the workflow development menu. In the SAP menu, choose Tools → Business Workflow → Development → Definition tools → Standard roles → Display → Responsibilities.

   You enter the following in a responsibility: the planning package and the corresponding operating concern, the form of the operating concern and the planning level. You then assign one or several agents to this responsibility.
Example: Planning Approval

You have the choice between using the delivered workflow *Execute CO-PA Planning* (COPA_PLAN_M1) or defining your own workflows. In this way, you can produce a process for approving planning, similar to the following one:

To implement the process depicted in the diagram, you can use the delivered tasks *Enter CO-PA Planning Data* (COPA_PLAN_01) and *Display CO-PA Planning Data* (COPA_PLAN_02). For detailed information on these tasks, see the section *Technical Implementation* [Seite 219].

See also:

*Defining Workflows* [Extern]
Automatic Planning Methods

Use

The automatic planning methods can be used to edit automatically a large amount of planned profitability segments that you first specify in a planning package.

Features

The following automatic planning methods are available:

- Copy - for copying data from another year or another plan version, for example
- Forecast - for forecasting data using specific rules and on the basis of data from a previous year, for example
- Delete - for deleting a large amount of data
- Top-down distribution - for distributing data from a higher planning level (such as the customer group level) to a more detailed level (such as the customer level)
- Ratios - to valuate a quantity plan using reference prices from another plan version
- Valuation - to valuate data using the logic stored in CO-PA Customizing for valuation
- Revaluation - to calculate additions or deductions for data
- Event - to take into account a short-term event (such as a sales campaign) during planning
- Period distribution - to distribute data planned for the year to the individual periods
- Customer enhancement - to apply the user-programmed logic from a customer enhancement on data

⚠️

Note that all automatic planning methods have to be executed for the planning package for which the data is to be changed.

When you execute the automatic planning methods, the system automatically derives from the existing characteristics those characteristics that are not contained in the planning level.

Processing

For each automatic planning method, you can make processing settings in the parameter set. By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution.

- In the test run, no data is posted. A log is generated and displayed. If you execute the test run online, a dialog box appears offering you the option of displaying a report that simulates the data that would have been posted if the update run had been executed. However, this requires you to have created a corresponding report in the information system (see the section Defining Profitability Reports [Seite 333]).
- In the update run, the values are written to the database and a log is created and displayed. You can display the posted data in the information system by using a corresponding report or the Display planning data planning method.
Furthermore, for parameter sets that are saved as permanent, you can choose background processing to jump to a screen providing you with all the background processing options that are offered in the standard SAP System.

In such cases, you need to choose the processing options Test run or Update run. The option Decision at point of execution causes the background job to terminate.

You can run in parallel several background jobs that execute automatic planning functions. However, this is only possible when each job deals with an independent set of data. This means that you cannot run planning methods in parallel for the same planning package.

**Log**

For each automatic planning method executed, a log is generated, providing you with information about which data has been changed, when, how and by whom, and whether any messages occurred. You find all the functions for a log provided by the SAP log tool, the Application Log (see the section Display Logs [Extern]). Alongside these standard functions, you can choose to call up a detailed log that provides information specific to the method used.

You can use the function Jump → Administration to display all generated logs. You can set a filter for the log elements in this list so that you can display, for example, all runs for a given planning package or a specific user.

To delete logs, you can use the transaction SLG2. For more information, see the section Delete Logs [Extern].
Copy

Use

The automatic planning method [Seite 224] Copy allows you to copy existing reference data to data area specified by the selected planning package. Reference data can be, for example, the actual data from the previous year or planning data from a different plan version. You can use the copied data as the basis for planning, for example, and then change it by applying other planning methods.

Note that you have to call up the planning method for the target planning package in which the copied data is to be set.

Features

In the parameter set, you can specify the following:

- You specify how the system should proceed if values already exist in the target data area. It is possible to copy values and thereby overwrite the existing values. Alternatively, you can add the copied values to the existing values or subtract them from them.

- You specify the time frame for the reference data that is to be copied. There are two ways of doing this:
  - On the one hand, you can have the system automatically determine periods that fall before (or after) the periods at the planning level or those in the planning package. Under Period closing, you enter the number of periods that the system should count back. (If the reference data falls in the future, enter a figure with the negative sign.) You can display the current fiscal year variant in order to enter an appropriate value.
  - On the other hand, you can enter the periods for the reference data directly under Period from/to. Note, however, that the interval has to be identical in length to the interval that you entered in the planning level or in the planning package.

- You specify whether the data to be copied is actual data or data from the plan version for the planning package or from a different plan version that is yet to be specified.

- When copying data, you can change individual characteristics. In this way, you can copy the planning data for a customer, for example, as a basis for another customer. For this, use the Transform characteristic values function.

- You determine whether the value fields are to be revaluated when data is copied.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.

- You can jump to a background processing screen.

- In the Value fields tab page, you specify which specific value fields are to be copied.
Forecast

Use

With the automatic planning method [Seite 224] Forecast, you can forecast plan values on the basis of existing reference data.

Note that you have to call up the planning method for the target planning package in which the forecast data is to be set.

Features

The forecast function for sales and profit planning is essentially the same as that for sales and operations planning (SOP). The system supports a number of forecast models [Extern], including constant, trend and seasonal models. The models and forecast parameters [Extern] are specified in forecast profiles that you define in Customizing for Profitability Analysis under Planning → Planning Aids → Forecast Profile [Extern]. Predictions can be made for any time periods and on the basis of both planning and actual data.

For more information on this topic, see the following sections in the SOP documentation:

- Selection of Models [Extern] (and the subordinate chapters)
- Forecast Formulas [Extern]

Selection options

In the parameter set, you can specify the following:

- You specify whether the forecast is to occur on the basis of a universally valid forecast profile or on the basis of a segment-specific forecast profile via an access key. By choosing 🥇, you can jump to the appropriate Customizing transaction and display the settings for the forecast profile or access key at hand. From there, you can switch to the change mode and create a new forecast profile or access key if required.

- You specify the time frame for the reference data that is to be used as the basis for executing the planning method. There are two ways of doing this:
  - On the one hand, you can have the system automatically determine periods that fall before (or after) the periods at the planning level or those in the planning package. Under Period closing, you enter the number of periods that the system should count back. (If the reference data is to fall in the future, enter a figure with the negative sign.) You can display the current fiscal year variant in order to enter an appropriate value.
  - On the other hand, you can enter the periods for the reference data directly under Period from/to. The interval that you enter is not dependent on the period interval for the currently selected planning package.

- You specify whether the data to be used as reference data is actual data or data from the plan version for the planning package or from a different plan version that is yet to be specified.
Forecast

- You can use the values for a different characteristic value as reference data for the forecast. For example, you can use the values for a given customer to forecast the values for a different customer. For this, use the *Transform characteristic values* function.

- By making the appropriate setting, you specify, on the one hand, whether the forecast is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.

- You can jump to a background processing screen.

- In the *Value fields* tab page, you specify which specific value fields are to be changed.
Delete

Use

With this automatic planning method [Seite 224], you can set planning data to zero. No records are deleted in the database.

Among other things, you can also use this method to restore a plan at a later time. This might be necessary if, while entering planning data manually, you inadvertently posted incorrect data, or if automatic planning methods were interrupted unexpectedly (for example, due to a power failure), resulting in a plan with inconsistent data.

Features

In the parameter set, you can specify the following:

- If you do not want to delete all the data in the selected planning package, you can restrict the selection further by entering a date and a time from which the data should be deleted.
- By making the appropriate setting, you specify, on the one hand, whether the deletion is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.
- You can jump to a background processing screen.
- In the Value fields tab page, you specify which specific value fields are to be deleted.
Top-Down Distribution

Use

With the automatic planning method Top-down distribution, you distribute data from a higher planning level to a more detailed level, using reference data, such as data from the previous year, as the basis. For example, you can plan at the product group level and then distribute the planning data to the individual products on the basis of the distribution of the sales figures for the previous year.

Note that the planning level for which the planning package top-down distribution is to be executed must contain all characteristics relevant for the distribution: both the sender and the receiver characteristics.

Features

In the parameter set, you can specify the following:

- You can choose between two top-down methods that determine precisely which values are to be distributed:
  - On the one hand, you can only distribute values that are posted directly at the higher level, such as the product group level, and that cannot be assigned to the detailed level. This is possible with the method: Only distribute "nonassigned".
  - On the other hand, you can distribute all values located at the higher level, regardless of whether they were posted there directly or copied to the higher level. This is possible with the method Distribute total value. When you use this method, the values taken from the detailed level are overwritten by the new, distributed value.

For a direct comparison of the results of both methods, see the section Example of Distribution Methods.

- You specify the receiver characteristic for the distribution under Receiver characteristic. By choosing , you can select several characteristics. You can choose any of the characteristics in the planning level. The remaining characteristics in the planning level are the sender characteristics. The combinations of characteristic values are determined by the sender profitability segment.

- Under Reference value field, you can enter as the basis for distribution a specific value field for reference data or a key figure calculated from value fields. Alternatively, you can specify that the distribution occurs by value fields. In this way, each value field is taken as the basis for its distribution.

- To smooth out incidental differences that occurred from period to period in the reference data, you can select the Aggregate periods indicator (see also Example: Period Aggregation).

- You specify the time frame for the reference data that is to be used as the basis for executing the planning method. There are two ways of doing this:
  - On the one hand, you can have the system automatically determine periods that fall before (or after) the periods at the planning level or those in the planning package. Under Period closing, you enter the number of periods that the system should count back. (If
the reference data is to fall in the future, enter a figure with the negative sign.) You can display the current fiscal year variant in order to enter an appropriate value.

- On the other hand, you can enter the periods for the reference data directly under Period from/to. The interval that you enter must correspond to the period interval of the currently selected planning package, except in cases where you select the Aggregate periods indicator.

- You specify whether the data to be used as reference data is actual data or data from the plan version for the planning package or from a different plan version that is yet to be specified.

- You can specify for a sender characteristic that a different characteristic value in the reference data forms the basis for distribution. This means that you can specify that the distribution of product groups to the products in country 1 occurs on the basis of the product data in country 2. For this, use the Transform characteristic values function.

- You determine whether the value fields are to be revaluated during top-down distribution.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.

- You can jump to a background processing screen.

- In the Value fields tab page, you specify which specific value fields are to be distributed.
Example of Distribution Methods

The following planning data was planned at the product group level:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>--</td>
<td>90</td>
</tr>
</tbody>
</table>

The following planning data was planned at the product level:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>P1</td>
<td>100</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P2</td>
<td>80</td>
</tr>
</tbody>
</table>

You want to redistribute the revenue planned for product group PRGRA on the basis of the reference value field Quantity sold.

Selection in the planning package for which distribution is executed:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product group</td>
<td>PRGRA</td>
</tr>
<tr>
<td>Product</td>
<td></td>
</tr>
</tbody>
</table>

Distribution characteristic:

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product group</td>
<td>Sender</td>
</tr>
<tr>
<td>Product</td>
<td>Receiver</td>
</tr>
</tbody>
</table>

Reference data:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Sales quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>P1</td>
<td>50</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P2</td>
<td>100</td>
</tr>
</tbody>
</table>

Result 1: The Distribute total value procedure

The planned values are aggregated to a total value of 270 USD, and then distributed to the products again on the basis of the value field specified as the distribution basis.

The following line items are created:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>--</td>
<td>90-</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P1</td>
<td>10-</td>
</tr>
</tbody>
</table>
Result:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>P2</td>
<td>100</td>
</tr>
</tbody>
</table>

Result 2: The *Distribute "nonassigned" only procedure*

Only the value planned directly at the product group level - 90 USD - is distributed according to the sales quantity.

The following line items are created:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>--</td>
<td>90-</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P1</td>
<td>30</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P2</td>
<td>60</td>
</tr>
</tbody>
</table>

Result:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRGRA</td>
<td>P1</td>
<td>130</td>
</tr>
<tr>
<td>PRGRA</td>
<td>P2</td>
<td>140</td>
</tr>
</tbody>
</table>
**Example: Period Aggregation**

For setting up top-down distribution for planning and actual data, you have the option of specifying a period aggregation for the reference data (using the *Aggregate periods* indicator).

The following example will seek to demonstrate the difference between distribution with and distribution without period aggregation. It refers to the distribution of actual data but can also be applied to planning data.

The actual data for the periods 01.1999 through 03.1999 that is not posted to specific divisions is distributed to divisions corresponding to the actual data for the periods 01.1998 through 03.1998.

**Actual data to be distributed:**

<table>
<thead>
<tr>
<th>Division</th>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>01.99</td>
<td>24</td>
</tr>
<tr>
<td>#</td>
<td>02.99</td>
<td>30</td>
</tr>
<tr>
<td>#</td>
<td>03.99</td>
<td>40</td>
</tr>
</tbody>
</table>

**Reference data:**

<table>
<thead>
<tr>
<th>Division</th>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>1.98</td>
<td>9</td>
</tr>
<tr>
<td>01</td>
<td>2.98</td>
<td>10</td>
</tr>
<tr>
<td>01</td>
<td>3.98</td>
<td>5</td>
</tr>
<tr>
<td>02</td>
<td>1.98</td>
<td>3</td>
</tr>
<tr>
<td>02</td>
<td>2.98</td>
<td>5</td>
</tr>
<tr>
<td>02</td>
<td>3.98</td>
<td>5</td>
</tr>
</tbody>
</table>

**Distribution without period aggregation:**

<table>
<thead>
<tr>
<th>Period</th>
<th>Distribution relationship between division 01 and division 02</th>
<th>New data records</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>01.98</td>
<td>9:3 → 3:1</td>
<td></td>
</tr>
<tr>
<td>02.98</td>
<td>10:5 → { } – 2:1</td>
<td></td>
</tr>
<tr>
<td>03.98</td>
<td>5:5 → { } – 1:1</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Period</th>
<th>Division</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>01.99</td>
<td>01</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>02</td>
<td>6</td>
</tr>
<tr>
<td>02.99</td>
<td>01</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>02</td>
<td>10</td>
</tr>
<tr>
<td>03.99</td>
<td>01</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>02</td>
<td>20</td>
</tr>
</tbody>
</table>
### Distribution with period aggregation:

<table>
<thead>
<tr>
<th>Period</th>
<th>Distribution relationship between division 01 and division 02</th>
<th>New data records</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td><strong>Period</strong></td>
</tr>
<tr>
<td>01-03.98</td>
<td>24:13</td>
<td>01.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>02.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Ratios

Use

The automatic planning method [Seite 224] Ratios lets you valuate a quantity plan automatically using reference prices.

Note that you have to call up the planning method for the target planning package in which the valuated data is to be set.

A typical scenario could resemble the following:

1. First you copy actual data or a plan version from the previous year to a reference version that you want to use as the basis for valuating your plan quantities.

2. Then you modify this reference version using the manual and automatic planning functions until you get the desired plan prices for the coming year.

   These prices are now available as an alternative to the pricing conditions from Sales and Distribution (SD) for changing and simulating planning data.

   Technically, this plan version contains quantities and values from which the system dynamically calculates ratios (prices) at a given planning level. You determine which planning level the prices should be calculated on by specifying access characteristics for the individual ratios. That way you can calculate average prices at a summarized level, such as product groups. See also Example: Valuation of Quantity Plans Using Ratios [Seite 172]. You enter access-level characteristics when you define ratios in Customizing.

3. Now you can use these prices to valuate the quantities in your sales plan.

4. Finally, you can use these separate plan versions to simulate price and quantity changes independently of one another.

   If your reference version contains different prices in the different periods, the system always calculates a weighted average and uses this to valuate your plan quantities.

Prerequisites

To valuate your plan quantities using ratios, you first need to define the required ratios and a ratio scheme in Customizing for Profitability Analysis. You do this under Planning → Planning Aids → Define Ratios and Ratio Schemes. Assign these ratios to the ratio scheme in the desired order, and define access characteristics.

Activities

Plan your quantities for a product or group of products.

You valuate this quantity plan with the ratios for the reference version using the Ratios planning method.
Selection options

In the parameter set, you can specify the following:

- Specify which *ratio scheme* is to be used to valuate the quantity plan.

- You specify the time frame for the reference data that is to be used as the basis for executing the planning method. There are two ways of doing this:
  - On the one hand, you can have the system automatically determine periods that fall before (or after) the periods at the planning level or those in the planning package. Under *Period closing*, you enter the number of periods that the system should count back. (If the reference data is to fall in the future, enter a figure with the negative sign.) You can display the current fiscal year variant in order to enter an appropriate value.
  - On the other hand, you can enter the periods for the reference data directly under *Period from/to*. The interval that you enter is not dependent on the period interval for the currently selected planning package.

- You specify whether the data to be used as reference data is actual data or data from the plan version for the planning package or from a different plan version that is yet to be specified.

- As the basis for valuation using ratios, you can enter characteristic values that differ from the characteristic values for the data to be valuated. For this, use the *Transform characteristic values* function.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.

- You can jump to a background processing screen.

- In the *Value fields* tab page, you specify which specific value fields are to be changed.

See also:

For an overview of the functions available for planning prices and quantities in Profitability Analysis, see [Working With Prices in Planning](#).
Valuation

Use

The automatic planning method [Seite 224] *Valuation* lets you valuate value fields automatically using conditions, material cost estimates, or customer enhancements. In this way, you can use your CO-PA Customizing settings for valuation to calculate, for example, your planned revenues, planned sales deductions, and planned costs.

Activities

In the parameter set, you specify the value fields to be valuated and you make the settings for processing the planning method (test run, update run, or background processing).

You specify in Customizing for CO-PA valuation what is to form the basis for the valuation. You do this under *Master Data* → *Valuation [Extern]*.

See also:

For general information on valuation in CO-PA, see the appropriate sections dealing with *Valuation [Seite 76]*. In particular, see the section *Activate Valuation in Planning [Seite 126]*.
Revaluation

Use

You use the automatic planning method [Seite 224] Revaluation to apply percentage additions/deductions to value fields.

Prerequisites

You need to have created a revaluation key or an access key to a segment-specific revaluation key in Customizing for Profitability Analysis under Planning → Planning Aids → Revaluation Key [Extern].

Features

In the parameter set, you can specify the following:

- Enter either the revaluation key or the access key that is to be applied in the revaluation.
- If you select the **Inverse computation** option, the system reverses the sign of the revaluation key.

  ![Revaluation of 20% with an initial value of 120](image)

  Revaluation of 20% with an initial value of 120

  Result without inverse computation: 144
  Result with inverse computation: 100

  In this way, you can reverse any previous computations.

  ![The initial value is 144, which was calculated without inverse computation above. When you repeat the revaluation with inverse computation, this yields 120.](image)

  The initial value is 144, which was calculated without inverse computation above. When you repeat the revaluation with inverse computation, this yields 120.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.
- You can jump to a background processing screen.
- In the **Value fields** tab page, you specify which specific value fields are to be changed.
Event

Use
You use the automatic planning method [Seite 224] Event to take into account the short-term effects that events, such as sales campaigns, have on your planning data.

Prerequisites
You need to have created an event or an access key to a segment-specific event in Customizing for Profitability Analysis under Planning → Planning Aids → Event [Extern].

Features
In the parameter set, you can specify the following:

- You specify the event or the access key that is to be applied to the planning data.
- If you select the option Inverse computation, the system reverses the sign of the event. In this way, you can reverse any previous computations, for example.
- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.
- You can jump to a background processing screen.
- In the Value fields tab page, you specify which specific value fields are to be changed.
Period Distribution

Use
You use the automatic planning method [Seite 224] Period distribution to distribute values - on the basis of a distribution key - to the periods you specified in the fiscal year variant. If there are already values at those periods, they are distributed again.

Prerequisites
You need to have created a distribution key or an access key to a segment-specific distribution key in Customizing for Profitability Analysis under Planning → Planning Aids → Distribution Key for Period Distribution [Extern].

Features
In the parameter set, you can specify the following:

- You specify the distribution key or the access key that is to be used as the basis for period distribution.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.

- You can jump to a background processing screen.

- In the Value fields tab page, you specify which specific value fields are to be distributed.
Customer Enhancement

Use

By selecting the automatic planning method [Seite 224] Customer enhancement, you can use on your planning data planning functions that you programmed yourself. You can use planning functions with and without reference data.

⚠️ Note that you have to call up the planning method for the target planning package in which the changed data is to be set.

Prerequisites

3. For every individual function that you carry out, you need to create an exit number for the customer enhancement [Extern] in Customizing by choosing Planning → Planning Aids. This exit number is then used to control the different functions separately within the function modules for the customer enhancement COPA0006 (see point 2).

4. All functions that you want to use must first be carried out in the enhancement COPA0006 in Customizing for Profitability Analysis under Tools → SAP Enhancements. By using two different function modules, you can choose between executing the enhancement with or without reference data. Both function modules contain an Exit number field in the interface. This allows you to distinguish between the different functions within the same function module (such as "If exit no. = 1, execute function 1. If exit no. = 2, execute function 2.").

Features

In the parameter set, you can specify the following for the Customer enhancement planning method:

- By entering an exit number, you specify which function of enhancement COPA0006 is to be executed. You then specify whether the system should execute this function using reference data. The option that you choose here dictates whether the fields for specifying reference data are unlocked for entry.

- For functions using reference data, you specify the time period for the reference data. There are two ways of doing this:
  - On the one hand, you can have the system automatically determine periods that fall before (or after) the periods at the planning level or those in the planning package. Under Period closing, you enter the number of periods that the system should count back. (If the reference data falls in the future, enter a figure with the negative sign.) You can display the current fiscal year variant in order to enter an appropriate value.
  - On the other hand, you can enter the periods for the reference data directly under Period from/to.

- For functions using reference data, specify whether the actual/planning data to be used as reference should originate from the plan version of the planning package or from a different plan version that is yet to be specified.

- For functions using reference data, you can specify for a given characteristic that a different characteristic value to that changed in the target data is to be used in the reference data.
This allows you, for example, to change in the reference data the planning data for a customer on account of the values for a different customer. For this, use the *Transform characteristic values* function.

- By making the appropriate setting, you specify, on the one hand, whether the planning method is to be executed in a test run or in an update run, or, on the other hand, whether this decision is to be postponed until the point of execution of the parameter set.
- You can jump to a background processing screen.
- In the *Value fields* tab page, you specify which specific value fields are to be changed.
Integrated Planning

Purpose

The SAP System supports fully integrated planning in Controlling (CO) so that you can plan your different business activities separately but with the activities remaining integrated at the same time. In this way, consistency is achieved and group planning remains realistic.

In CO-PA, you can use different functions for copying and transferring planning data within Controlling. Furthermore, you can transfer planning data to different components or read data from Microsoft Excel for offline planning.

Features

The following graphic shows how sales and profit planning is integrated with other components in the SAP System. For more information about the individual functions, see the corresponding sections in this documentation.

Alongside achieving the above integration, CO-PA also enables you to work with integrated Excel in sales and profit planning. On the one hand, you can call up Excel directly from within the SAP interface and use the Excel screen, and, on the other hand, you have the option of planning in Excel on its own and then importing the data in the SAP System subsequently. For more information, see Integrated Excel in Planning [Seite 200].
Allocation of Planned Overhead

Use

Just as you can allocate overhead (cost center costs and process costs) for actual data, you can also transfer overhead for planning data to CO-PA by using assessment, indirect activity allocation, or template allocation.

Features

The functions for allocating overhead for planning data are generally the same as those for allocating overhead for actual data. For detailed information, see the sections for actual data dealing with Periodic Overhead Allocation [Seite 282].

Assessment and indirect activity allocation for planning data differs from that for actual data in that a cycle cannot be defined by the name and initial date alone. Instead, the sender version is also an essential part of the key for the cycle to run. This allows you to reuse the same cycle for different planned versions. All you need to do is simply change the sender version, without having to define a completely new cycle for each version.
Settling Planning Data for Orders and Projects

**Use**

You can settle planning data from internal orders and projects just like you settle actual data (see Settling Orders/Projects [Seite 273]).

**Prerequisites**

- You must define a settlement rule for the order or project. You can use the same settlement rule for settling both plan and actual data. For a detailed description of how to define a settlement rule, see CO Settlement [Extern]. See also Project Settlement [Extern].
- You must define a PA transfer structure and assign it to a settlement profile. You do this in CO-PA Customizing under Planning → Integrated Planning → Transfer of Order/Project Planning Data.
- The version in which the data was planned (plan version or results analysis version, for projects for which results analysis has been performed) must be assigned to a receiver version in CO-PA in the relevant fiscal year (in Customizing for General Controlling under Organization → Maintain Versions → Settings by Fiscal Year → Detail Screen).

**Features**

Two different functions are available for settling planning data from internal orders and projects - one for settling plan-integrated objects and one for transferring projects which are not plan-integrated. If results analysis has been carried out for the object you are settling, the system settles the results, otherwise all the plan costs and revenues are settled. The following table gives you an overview of which function to use when:

<table>
<thead>
<tr>
<th>Object</th>
<th>Integrated planning</th>
<th>Function</th>
<th>Results analysis</th>
<th>Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internal order</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>X</td>
<td>Settle</td>
<td></td>
<td>Cost plan</td>
</tr>
<tr>
<td>Project</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>X</td>
<td>Settle</td>
<td></td>
<td>Cost plan</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Transfer</td>
<td>X</td>
<td>Planned results</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Settle</td>
<td>X</td>
<td>Planned results</td>
</tr>
</tbody>
</table>

Integrated planning makes it possible for all plan allocations (cost element and activity input plan, assessment, and so on) to be updated automatically on the sender or receiver cost center or process. For more information on this, see Integrated Planning of Internal Orders [Extern].

Of the alternatives for projects listed above, settlement of plan-integrated projects without a results analysis key and transfer of projects that are not plan-integrated with a results analysis key are the standard uses. An example of a situation where you might use the former is a marketing event, where no revenues are generated and where the integration with Cost Center Accounting is required for calculating activity prices in the participating cost centers. The latter, on the other hand, could be used for construction of a power plant, where the costs were planned...
at the network level. Since networks are not plan-integrated, the entire project is not plan-integrated.

**Activities**

**Setup**

Before you can settle or transfer plan costs, you need to carry out the following steps:

- The costs and revenues of the internal order or project must have been planned.
- For projects that require results analysis, the plan results analysis must already have been carried out.

**Plan Settlement**

The functions for settling order and project planning data are found in the CO-PA application menu under **Planning → Integrated planning → Transfer order/project plan**. These functions can only be used with plan-integrated internal orders and projects. In CO version maintenance for the settings by fiscal year, the "Integrated planning" flag must be selected for both the sender object and the CO version in which the settlement is carried out. For projects, the individual WBS element also must be plan-integrated.

When you settle planning data, the sender objects are credited.

**Planning Data Transfer**

The functions for transferring project planning data are found in the CO-PA application menu under **Planning → Integrated planning → Transfer order/project plan**. These functions are only supported for projects with a results analysis key that are not plan-integrated.

This function makes it possible to take your planned projects into account in your profit plan. When you transfer planned project data, the sender project is not credited.
Transfer to Sales and Operations Planning (SOP)

Use

You can transfer a sales plan created in CO-PA to Sales and Operations Planning (SOP).

You can transfer the sales quantities either by individual products or by product groups. You can use any profitability segments (for example, all products in a division) and time frames (posting periods and weeks) as selection criteria.

Note that in CO-PA you always need to plan using a unit of measure. That means that the corresponding unit field is always filled. This is especially important when you plan at the product group level, where the system cannot derive the unit automatically as it does for single products.

You can transfer the data to SOP for one plant or for all plants (plant = *). If you do not plan at the plant level in CO-PA, the system distributes the planned quantities to plants according to table T445V. If that table does not have any entries, the system distributes evenly to all the plants in which the product or product group occurs. Any necessary conversions (for different units or period types) take place when you run the transfer.

You can transfer planning data to SOP at the product level or the product group level. If you want to plan and transfer data at the product group level, you need to create a characteristic (or characteristics) to represent the product group levels in SOP when you maintain your operating concern. Since in SOP product groups are stored as products in the database, make sure the characteristic you create for the product group has the same type and length as the characteristic "Product" (CHAR 18).

If you choose Product group, the system transfers the data at the product group level. On the characteristics screen, you can then specify whether all the product groups or only a specific one should be transferred.

You can transfer a sales plan more than once, since the sales volumes are overwritten in SOP with each transfer. If you select the Transfer changes only field, you can ensure that only the changes are transferred when you have made changes to a CO-PA sales plan.

You can carry out the function in a test run without updating the database. It is also possible to schedule a job in the background from the online transaction.

The parameters of the transfers carried out are stored and can be displayed later.

For detailed documentation about SOP in general, see Sales and Operations Planning (SOP) [Extern].
Interface Between CO-PA and LIS

Use

The interface between Profitability Analysis (CO-PA) and the Logistics Information System (LIS) provides a number of ways to transfer data between your operating concerns and the info structures in LIS.

⚠️

The interface is only available in costing-based Profitability Analysis.

This section describes the various uses as seen from the viewpoint of each application.

Interface from the CO-PA Viewpoint

- **Transfer of planning data**
  You can transfer your sales plan from CO-PA to LIS for further processing.

- **Transfer of planning data from SOP**
  You can transfer a sales plan created in CO-PA to Sales and Operations Planning (SOP), an information structure used for the quantity plan.

  See also [Transfer to Sales and Operations Planning (SOP)](Seite 248).

The basic difference between these two transfer functions is that the SOP info structure is used to store quantities only. Consequently, it does not contain any values in currencies.

Interface from the LIS Viewpoint

- **Transfer of planning data**
  You can transfer a sales quantity plan from SOP back to CO-PA.

- **Transfer of planning data from SOP**
  Once you have checked capacities based on the sales quantity plan from CO-PA, you can transfer the corrected quantities back to CO-PA, where you can valuate them again.

- **Transfer of actual data**

  Activity-Based Costing (CO-OM-ABC) requires statistical key figures - such as "Purchase order items per period" - in order to assess process costs to CO-PA. Since these key figures normally are not updated in CO-PA but do exist in LIS, they can be transferred to CO-PA periodically.

  This data is stored in the CO-PA line item table CE1xxxx (xxxx = operating concern) using record type **H**.

The interface between CO-PA and LIS covers all the instances where data that exists in one application should be available in the other application. This allows you to use the functions of both to achieve the maximum practical use.
Interface Between CO-PA and LIS

This interface is typically used to define a production plan iteratively. First, a sales quantity plan is created in CO-PA from a revenue-oriented viewpoint. Then these quantities are transferred to LIS where they are adjusted to fit capacities. After this, the sales quantities are sent back to CO-PA, where they used as a basis for a revenue plan.

This cycle can be repeated as often as necessary.

Activities

You set up the interface between CO-PA and LIS (that is, the assignment of the CO-PA operating concern to the LIS info structure) in CO-PA Customizing by choosing Planning ➔ Integrated planning ➔ Define LIS interface. You can find in this section more information on how to proceed.

Data transfer [Seite 251] from CO-PA to LIS can be executed in the CO-PA application menu under Planning ➔ Integrated planning ➔ Planned values ➔ Transfer to LIS.
Data Transfers

Use
For purposes of data reconciliation, you can transfer planning data between Profitability Analysis (CO-PA) and the Logistics Information System (LIS).

Prerequisites
To transfer data between CO-PA and LIS, you first need to assign the relevant LIS info structure to an operating concern in CO-PA. You do this in Customizing under Planning → Integrated Planning → Define LIS Interface.

This assignment contains the necessary attributes for the transfer. These attributes vary depending on the type of data transferred (plan or actual data).

If you transfer planning data from CO-PA to LIS, you need to specify the following:

- Characteristic assignment
  - CO-PA operating concern
  - CO-PA characteristic
  - LIS info structure
  - LIS characteristic

- Key figure assignment
  - CO-PA operating concern
  - CO-PA key figure
  - LIS info structure
  - LIS key figure

- Assignment group
  - CO-PA operating concern
  - CO-PA plan version
  - CO-PA record type
  - LIS info structure
  - LIS plan version
  - Characteristic assignment
  - Key figure assignment

Activities

Data Transfer from CO-PA to LIS
You execute the transfer from the application menu by choosing Planning → Integrated planning → Transfer to LIS.
Data Transfers

To transfer plan quantities from CO-PA to an info structure in SOP, choose Planning → Integrated planning → Transfer quantities to SOP.

If you have activated the alternative period type in your operating concern, you can choose whether you want to transfer the data in posting periods or in weeks.

- If you choose Posting periods, you can transfer the data that was posted in weeks and directly in posting periods.
- If you choose Weeks, you can only the data that was planned explicitly by week.

On the selection screen, you can specify characteristic values to limit the selection of data to transfer. You can enter one or more single values or an interval for each characteristic. The default value for each characteristic is an asterisk (*), which means that all the values of that characteristic will be transferred.

To save your selection criteria as a variant, choose Goto → Variants.

Data Transfer from LIS to CO-PA

Data transferred from LIS to CO-PA is always transferred in the smallest period type (posting periods or weeks). If the data in LIS is stored in a different period type than in CO-PA, the data is converted during the transfer.

If you are transferring planning data, the system uses either the factory calendar or calendar days for this conversion, depending on which was specified in the target plan version in CO-PA. If you are transferring actual data, the system always converts the data using calendar days.

For actual data, the transferred values are posted in CO-PA with record type H.
Transferring Planning Data to EC-PCA / FI-GL / FI-SL

Use
You can transfer planning data periodically from CO-PA by assigning the value or quantity fields in CO-PA to the accounts in G/L accounting (FI-GL), to the Special Ledgers (FI-SL) and to account-based Profit Center Accounting (EC-PCA). You can define rules in Customizing to derive the correct account for the transfer.

Prerequisites
The characteristics Controlling area and Company code need to have been planned explicitly or derived from other characteristics. If these characteristics are not filled with data in certain planning records, then those specific planning records cannot be included in the transfer of planning data.

Features
Initial Steps
You can determine accounts using one or more derivation steps, depending on your requirements. You can use up to six source fields to define in Customizing which value or quantity field should be transferred to which account. The characteristic Controlling area and the value or quantity field to be converted are set by the system. You can select the remaining four source fields from the characteristics in CO-PA.

First derivation rule:

<table>
<thead>
<tr>
<th>Source fields</th>
<th>Target field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Controlling area</td>
<td>Value or quantity field</td>
</tr>
<tr>
<td>Company code</td>
<td>REVEN</td>
</tr>
<tr>
<td>Partner profit center</td>
<td>SAQTY</td>
</tr>
<tr>
<td>0001</td>
<td>REVEN</td>
</tr>
<tr>
<td>0001</td>
<td>SAQTY</td>
</tr>
<tr>
<td>0001</td>
<td>REVEN</td>
</tr>
<tr>
<td>0001</td>
<td>SAQTY</td>
</tr>
</tbody>
</table>

In this example, the system assigns in the first derivation step the revenue and sales quantity fields to different accounts depending on which company code and which partner profit center the values are assigned to. If external revenues are planned (which means the partner profit center is empty), then the scenario can still be represented.

Second derivation rule:

<table>
<thead>
<tr>
<th>Source fields</th>
<th>Target field</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

April 2001
Transferring Planning Data to EC-PCA / FI-GL / FI-SL

<table>
<thead>
<tr>
<th>Controlling area</th>
<th>Company code</th>
<th>Value or quantity field</th>
<th>Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>0001</td>
<td>0001</td>
<td>FRACHT</td>
<td>471000</td>
</tr>
<tr>
<td>0001</td>
<td>0002</td>
<td>FRACHT</td>
<td>472000</td>
</tr>
</tbody>
</table>

In the second step, however, the freight costs are assigned to an account depending only on the company code.

You can assign more than one value field to the same account. If you do, the system adds their values together. You can also summarize quantity fields - provided they share the same unit of measure - by assigning them to the same account in one data record. It is also possible to assign both a value field and a quantity field to the same account so that values and quantities that belong together (such as sales revenues and the corresponding quantity) are transferred in the same data record in FI or EC-PCA. For more detailed information about derivation of characteristics, see Derivation of Characteristics [Seite 41].

You need to specify in Customizing all values and quantities in CO-PA that are posted with a different +/- sign to the other application. This is particularly important for value fields that you transfer to credit accounts (such as sales revenue accounts) that have a negative sign in FI or EC-PCA.

**Transfer of Planning Data**

You execute the transfer of planning data from the CO-PA application menu by choosing *Planning → Integrated Planning → Transfer Planned Values to EC-PCA* or *Transfer Planned Values to FI-GL* or *Transfer Planned Values to FI-SL*.

When you execute the transfer, you can specify selection criteria to limit the characteristics so that, for example, just the data for a specific controlling area is transferred. Note that you need to specify a single value, an interval, or an asterisk (*) for each characteristic.

In the processing rules, you can specify characteristics whose values you want to summarize, that is, the data for the characteristic values is aggregated. This is not allowed for the characteristics *Controlling area, Company code* and *Profit center*, since these characteristic values are required information in the receiver application.

On the *Value Fields* selection screen, you can select the value and quantity fields that you want to transfer. If you select fields for which no derivation rules are defined in Customizing, the data from those fields cannot be transferred. When maintaining derivation rules in Customizing, you can have the system display an error message in such instances. For more information, see Influencing the Standard Derivation Procedure [Seite 54].

Different principles are applied to post data in the different applications:

- The system only transfers to EC-PCA any changes made since the last transfer. This means that you can repeat the transfer as often as you like.

- For transfers to FI-GL and FI-SL, all data is always transferred. Prior to a new transfer, you therefore have to delete the data transferred previously to prevent it from being duplicated.
  - To delete this data, choose *Business Transactions → Planning → Integrated Planning → Delete Planning Data* in the IMG structure for General Ledger Accounting.
  - Choose *Tools → Delete Transaction Data* in the IMG structure for the Special Purpose Ledger.
The log tells you what selection criteria, processing rules, and value and quantity fields you defined along with the number of objects that were selected and transferred without errors. If errors occur for an object, that object is not transferred. The detail log lists which objects were not transferred and what errors occurred in each case. Once you have removed the errors, you can transfer these objects again.
Planning Process: Creating a Valuated Sales Plan

Purpose
Sales and profit planning varies greatly from company to company, and companies generally use a very individual process that depends to a large extent on the company's organizational structure and the industry the company is involved in. In this way, each planning process differs greatly with regards the contents that are planned or the scope the plan has. The following types of decisions have to be made for each individual case: which characteristics and value fields are to be planned, whether planning should occur centrally or locally, or whether the different business areas should be integrated for planning.

In spite of the individual nature of planning processes, it is nevertheless possible to identify specific subprocesses in sales and profit planning that occur in very similar ways in many companies. The following describes a typical planning subprocess as it might be performed in a real situation. The aim of this process is to generate for the coming year a valuated sales plan in which the targets set by management and planned at an aggregated level are reconciled with the sales forecasts entered by sales employees at a detailed level.

Scenario
It is October of the current year and the planning coordinator needs to prepare planning for the coming year. Drawing up a valuated sales plan is a subprocess of the company-wide, integrated planning process and is performed in Profitability Analysis.

The planned targets set by management and communicated to Product Management are used as the starting point. These targets enter planning at the division level, for example. They are then broken down to the product/customer level and then forwarded to the individual sales employees as default plan values. The plan is finally agreed upon when the targets at both levels have been reconciled.

Prerequisites
First of all, the planning coordinator must create appropriate planning elements. This includes a plan version that is created in Customizing for Profitability Analysis (see also the documentation on the activity Maintain Versions [Extern]). This plan version makes it possible for different planning data to be stored in parallel for the same market segment. In this way, optimistic and pessimistic plans, for example, can be generated.

For each of the planning methods to be executed (such as Copying actual data or Displaying planning data), the planning coordinator has to decide for which planning objects the planning method is to be performed. The planning coordinator does this by creating appropriate planning levels and planning packages in the planning framework in Profitability Analysis. To execute a planning method, there has to be a parameter set specifying what the method is to perform and which value fields are to be affected. For more information on this subject, see the sections Planning Framework [Seite 134] and Setting Up Planning Content [Seite 140].

Process Flow
1. Copy actual sales quantities to planning

The planning coordinator copies the actual sales quantities into planning to be used as the basis for valuated sales planning. It is October of the current year. Thus current actual data is available for the months January to September. For the outstanding actual
data for the months October to December, we take the actual sales for the same respective months of the previous year.

The sales quantities are planned at a higher level, that is, each quantity is planned per combination of division, material group, and sales organization.

To copy the actual sales quantities for the current year into the plan version, the parameters for the planning method Copy [Seite 226] need to be specified. In an initial run, the actual data is copied for months 01 to 09 of the current year. The planning coordinator then copies the actual quantities for the previous months 10 to 12.

For monitoring purposes, the planning coordinator then uses the method Display planning data to display the copied quantities in a planning layout (see the section Set Up Manual Entry of Planning Data [Seite 150]).

2. Increase actual sales quantities by 10%

Since management has set a general target of a 10% increase in sales, the planning coordinator increases sales for all divisions by 10%.

To do this, he creates a revaluation key and runs the planning method Revaluation [Seite 239].

3. Integrate new material group into planning

The planning coordinator is informed that a new material group is to be marketed in the coming year and that this new material group should be included in planning. To generate a default plan value automatically for this new material group, the planning coordinator uses the planning method Copy [Seite 226]. In the Transform characteristic values function, the necessary entries are then made so that the sales quantities for an existing, comparable material group are copied to the new material group.

4. Valuate plan sales quantities using average prices and costs

Alongside sales quantities, average actual values are then added to planning in a further step. Such values can be prices, average sales deductions, sales direct costs, and variable costs of goods manufactured. In this way, it is possible to perform contribution margin planning.

To valuate the planned sales quantities, the average actual values are first determined using the planning method Ratios [Seite 236] and then multiplied by the planned quantities. For this, the planning coordinator creates ratios and a ratio scheme. A ratio can allow you to calculate average values. For example, you could set up a ratio so that average price = revenue/sales quantity, or average rebates granted = rebates/sales quantities. Ratios can be summarized in a ratio scheme so that the values can then be calculated in a single run.

The planning coordinator uses the actual data for periods 01 to 09 of the current year and the actual data for the months 10 to 12 of the previous year to determine the average prices, average sales deductions, and so on. Using the Ratios method with the Transform characteristic values function, the planning coordinator transfers the values of the existing, comparable material group to the new material group.

5. Price increase of 3%

As in the case of the sales quantities above, the targets set by management mean that certain amounts are to be increased by an equal percentage. Prices, for example, are to be increased by 3%.
Planning Process: Creating a Valuated Sales Plan

For this increase, the planning coordinator first uses the Enter planning data method to look at the planning data in the planning layout. In the data entry screen, he/she then selects the Price division and executes the Change Values function (see also the section Execute Manual Entry of Planning Data).

6. Top-down distribution of planning data to products

The existing planning data were generated at the division/material group/sales organization level and were adjusted to meet the targets set by management. The planning coordinator breaks these targets down to the planning level at which the sales employees enter their planning data (in other words, down to the product/customer group level).

The planning data is saved in a separate version so that the targets from management (in one version) and the planning data entered by the sales employees (in a different version) can be changed independently of each other and yet still be compared against each other (in a shared report).

The planning method Top-down distribution is then used to distribute the values and sales quantities from the aggregated level (division/material group/sales organization) to the detailed level (product/customer group). The relationship for the distribution is dependent on the reference data (in this instance, the actual data from the current/previous year). To obtain values for the products in the new material group, the Transform characteristic values function in the Top-down distribution method was used.

7. Local manual planning by sales employees

The planning coordinator uses the Integrated Excel function to prepare planning in an Excel worksheet for the sales employees (see the section Setting Up Integrated Excel). This worksheet contains the management targets and - for comparison purposes - the past actual sales, actual prices, and actual sales deductions for products by customer group.

In the planning framework, the planning coordinator creates personalization profiles with which he assigns planning contents to the sales employees. In this way, when a sales employee calls up planning afterwards, only those planning tasks relevant to him/her appear.

Affected sales employees are then told by e-mail that planning tasks are to be completed in the SAP System by a certain deadline. During planning, they can then use the functions in CO-PA planning as well as the Excel working environment.

8. Plan reconciliation and agreeing upon the final plan

As the final step, the planning coordinator creates a report in the information system. He/she can then use this report to compare the planning data of the two versions for reconciliation purposes.

Once the planning data has been reconciled and adjusted in an iterative process, planning is then finalized as binding and continually compared during the coming year against the current actual values.
Planning Process: Planning Sales and Promotion Budgets

Purpose

Profitability Analysis allows you to create budgets for promotional measures such as advertising campaigns and the related campaign rebates. You then allot the funds for these budgets in the Sales and Distribution (SD) component by maintaining the relevant condition (sales rebates) for customer agreements. You can observe the progress of these budgets throughout the whole process, from when you initially create the budget on to the allotment in SD and to the final billing document, which is transferred to CO-PA. This is possible because the system now transfers allotted funds to CO-PA simultaneously when you maintain the corresponding conditions in SD.

By analyzing the variance between the planned and allotted budget, you can check the availability of the budget on an ongoing basis. This makes it possible to monitor your sales and promotion budgets at all times in CO-PA.

Process Flow

The following is a typical example of how you might use sales and promotion budgets in CO-PA planning:

1. You create budgets for individual promotional measures in sales and profit planning.
2. You transfer your sales agreements from SD to CO-PA. These agreements are conditions that are stored in SD and granted to customers as sales deductions at the time of billing or subsequently as bonuses.
3. In the information system, you can monitor the availability of funds for the promotion, broken down according to profitability segment.
4. Data is transferred from SD to CO-PA when you maintain the conditions, when you create the sales order, and when you create the final billing document. This lets you analyze the process chain in detail at any moment.
Maintaining Sales and Promotion Budgets

Prerequisites
You need to activate the transfer of allotments to Profitability Analysis separately for each condition type. You can do this in Customizing for CO-PA under Actual Value Flows → Transfer Customer Rebate Agreements.

Procedure
There are three stages to working with sales and promotion budgets:

1. **Budget planning in CO-PA**
   
   You create a budget in manual planning. To do so, you can use all the available manual planning functions and all the planning aids. It is recommended that you create a separate plan version for your budgets.

2. **Budget allotment in Sales and Distribution (maintenance of condition records)**
   
   You can assign budget funds when maintaining condition records for sales campaigns and promotions as well as in rebate agreements.

   To maintain a budget allotment, choose Logistics → Sales and distribution → Master data. In the Agreements menu, choose either Rebate agreement, Promotion, or Sales deal. Go to the conditions screen for the desired condition and display the detail screen for the desired characteristic.

   Here you enter the amount of the condition (which depends directly on the calculation type) and the planned basis. The result of this calculation is the value that the system transfers to CO-PA.

<table>
<thead>
<tr>
<th>Calculation type</th>
<th>Condition type</th>
<th>Planned basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Percentage</td>
<td>Planned sales</td>
</tr>
<tr>
<td>B</td>
<td>Fixed amount</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>Quantity-based</td>
<td>Planned quantity</td>
</tr>
<tr>
<td>etc.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

   You want to allot a budget by granting a 20% price reduction on planned sales of 100,000 USD for product P1.

   When you maintain the promotion in SD, you choose the condition screen for the condition type “Price reduction”. Then you display the detail screen for product P1. The calculation type is A (Percentage). You enter “20” in the field “Condition amount” and “100,000” in the field “Planned basis”. Save your entries.

   The system calculates the planned value 20,000 USD. This value is then transferred via value field assignment to the corresponding value field “sales deductions” in CO-PA.
3. Passive availability check in Profitability Analysis

Finally, you can perform an availability check in CO-PA using the information system. Here you can compare the plan version in which you planned the budget with the allotted funds transferred from SD (as record type G).
Flows of Actual Values

Purpose

The system uses the *flows of actual values* to transfer data from neighboring components to value fields in Profitability Analysis (CO-PA). The data is grouped together into operating results.

Features

CO-PA lets you assign all primary, profit-related postings and activities from the FI (G/L account postings), MM (invoice receipts, purchase orders) and SD (sales orders) application components to profitability segments.

For period-end closing, you can assign internal activities to profitability segments, assess cost center costs and business process costs to profitability segments, as well as settle orders, projects and cost objects to profitability segments. You can use the Schedule Manager [Seite 380] to monitor transfers of data during period-end closing.

The following graphic depicts the way the components are integrated:

The following values flow into Profitability Analysis:
If your system is set up to allow double postings, see the corresponding section below to read about how these are handled.
Sign Handling in CO-PA

For actual data as well as for planning data, Profitability Analysis (CO-PA) generally stores all values as positive in the individual fields. If you use a Key Figure Scheme [Seite 343] to define your contribution margin scheme appropriately, sales deductions can be subtracted from revenues in the net revenue in the information system, just as costs can be subtracted from it, and this involves multi-leveled contribution margin accounting. Revenues, sales deductions, and costs should therefore be entered into separate value fields.

Negative values generally only occur for business transactions (such as reversals, credit memos or returns) that revise the business transaction results when claims are processed or errors are corrected.

This applies to all revenues, sales deductions, and cost of goods manufactured, as well as to the different period costs, that flow into CO-PA during Order Settlement [Seite 273] or Periodic Overhead Allocation [Seite 282].

This is an important principle, particularly for the purposes of comparing actual values and planning values, because the logic in the information system for calculating the contribution margin lines for planning and actual values must be consistent.

How all this is related is depicted in the following graphic:

The cost element categories should correspond to those recommended by SAP. This is the prerequisite for producing a true representation of the +/- signs in the transfer of actual data to CO-PA (Flows of Actual Values [Seite 262]). SAP recommends the following cost element categories:

- Revenues: Cost element category 11
- Sales deductions: Cost element category 12
• Costs: Cost element category 01

In rare instances, you might not be able to keep to the rule of having all values updated as positive in CO-PA. This can be the case with special settings in Sales and Distribution (SD). For this reason, you have the option of setting the indicator *Transfer values with +/- signs* when assigning value fields for the transfer of billing documents and Incoming sales orders.

However, you should only use this indicator in the following exceptional circumstances:

- If several condition types in a value field need to "balance out" with different signs.
- If a condition with different signs flows into a value field.
- If anticipated and actual rebates need to balance in rebate processing.

By setting this indicator, you can transfer values with their +/- signs from condition types and thereby always be in a position to display a correct total value, even in the case of positive and negative condition values.

For planning (which you may intend to implement at a later date), you should nevertheless ensure that at least the balance of these condition types can be planned positively.
Transferring Incoming Sales Orders Online

Use

You can valuate incoming sales orders (as expected revenues) and transfer them from SD to CO-PA in order to obtain an early estimate of anticipated profits. By analyzing this data characteristic values, you can obtain early profitability results for individual segments of your business. Consequently, you can create reports that not only reflect the course of actual profits and contribution margins on the basis of billing documents, but also allow you to analyze these developments on the basis of incoming orders. (To analyze incoming orders, specify record type A in the report. To analyze billing data, specify record type F.)

This function is especially useful when there is a long span of time between when you open the sales order and when you actually bill the customer. It allows you to react early and appropriately if you notice any unexpected developments.

This function only allows you to analyze incoming orders as a cumulative value. It does not let you update balances of valuated orders or analyze non-cumulative “order commitments”.

Features

When you create or change a sales order, the system automatically transfers line items to Profitability Analysis in realtime. You can determine in which period the sales order should appear in CO-PA.

- Period of the date of entry
  This option means that the orders are updated under the same period in which they were created in the system.

- Period of the planned delivery or the scheduled billing dates
  This option means that the order appears in Profitability Analysis in the period of the planned delivery or the scheduled billing date. It thus comes closer to reflecting the expected billing information.

You make this setting in Customizing under Actual flows of values → Transfer incoming sales orders → Activate incoming sales orders. You need to set the corresponding indicator for each controlling area in the operating concern.

If the sales order is pre-costed using a CO unit cost estimate, you can transfer the calculated value to the sales order using a condition type. By assigning the SD fields to value fields in CO-PA, you can ensure that this preliminary costing value is updated in CO-PA. (This can be especially useful for make-to-order manufacturers.) You can also transfer the unit cost estimate by maintaining a costing key accordingly. It is also possible to transfer different quantity fields from the sales order, provided that you have assigned them to quantity fields in CO-PA.

Incoming orders are valuated in the same manner as billing data. See also Valuation [Seite 76].
Orders are updated according as follows, depending on how they were activated.

Sales order: Customer 4711 Date entered 1.9.97

<table>
<thead>
<tr>
<th>Item 10</th>
<th>Material 99</th>
<th>Quantity 40</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Delivery date 10/1/97</td>
<td>Quantity 15</td>
</tr>
<tr>
<td></td>
<td>Delivery date 11/8/97</td>
<td>Quantity 25</td>
</tr>
</tbody>
</table>

- Activate for date of entry
  
  This creates one line item with the quantity "40 PCS" in Profitability Analysis in September.

- Transfer with date of delivery/scheduled billing date
  
  This causes two line items to be posted in Profitability Analysis. One contains the quantity "15 PCS" in period 010, while the other contains "25 PCS" in period 011.

If the sales order is changed (either its values or characteristics), the line items already posted to CO-PA are completely canceled, and new line items containing the new characteristics and values are transferred from the order.

**Subsequent Posting of Records Containing Errors**

Errors may occur when the order is posted to CO-PA. This may occur, for example, if you defined valuation using the current standard cost estimate but the system could not find one, or if a derivation rule was not defined completely. In this case, no line items are posted to Profitability Analysis. The system saves the "original" records that contain errors in a separate table. You can display any records containing errors by choosing in the application menu Actual Postings → Periodic adjustments → Post incoming orders subsequently → Display.

Once you have corrected the errors, you can repost to CO-PA the records that contained them by choosing Actual Postings → Incoming order with errors → Subsequent posting. You can perform this function in the test run as well as in the update run.

The error table then indicates which line items have been reposted. You can delete them from the table by choosing Actual Postings → Incoming order with errors → Delete.

**Subsequent Posting of Existing Sales Orders**

It is possible to subsequently post existing sales orders to Profitability Analysis. This is particularly useful if you implement CO-PA after SD and you wish to transfer sales orders, for example, for the current or previous periods to CO-PA.

You execute the function for posting sales orders subsequently in Customizing under Tools → Production Startup → Subsequent Posting of SD Documents.

Subsequent posting is divided into two steps that you should execute in the following order:

1. Prepare Subsequent Posting of Sales Orders - A profitability segment is determined in the sales order if one does not already exist.
Transferring Incoming Sales Orders Online

2. Post Sales Orders Subsequently - Sales orders with a profitability segment are selected and copied to Profitability Analysis.
Transferring Billing Documents Online

Use

When billing document data is posted, the online transfer function transfers the values directly into Profitability Analysis. In the process, it uses the record type F to generate a line item automatically in Profitability Analysis for each item on the billing document.

Prerequisites

Before you can transfer billing data to Profitability Analysis in realtime, the controlling area you are working in must be activated. You do this in Customizing.

Features

The Sales and Distribution Module (SD) calculates revenues during billing with the help of a pricing mechanism, and then enters it in the billing document. If sales deductions are known (granted discounts, planned cash discount), these are also recorded in the billing document. In addition, the stock value of the product (delivered price for wholesale or retail goods, or cost of goods manufactured for in-house products) can also be determined.

The system transfers all the characteristics defined in Profitability Analysis and contained in the billing document, along with the customer and product numbers, from the document to the CO-PA line item. It also performs characteristic derivation [Seite 41] for those fields for which derivation logic has been defined.

If you have defined valuation [Seite 76] in your system, you can also use a material cost estimate (= cost of sales) to valuate the revenue, sales deductions, and cost of goods sold which were calculated in SD and transferred to Profitability Analysis.
Every billing document generated in SD (including credit memos, cancellations and so on) immediately results in a corresponding line item in Profitability Analysis. This means that the update in Profitability Analysis is linked with that in Financial Accounting (FI). That ensures that the same revenues and sales deductions are transferred to both modules at the same time. For more information about how data is passed on to CO-PA, see Customizing.

If the system recognizes an error (such as in characteristic derivation) while posting billing data to Financial Accounting or Profitability Analysis, it posts the billing document in SD anyway, but updates neither Financial Accounting nor Profitability Analysis.

When this happens, you need to correct the error and post the billing document again using ReleaseToAccounting. This function creates the Financial Accounting document as well as the line item in Profitability Analysis.
Transferring Billing Documents Online

See also:
Checking Value Flows from Billing Document Transfer [Seite 406]
Posting Billing Documents Subsequently

Use

The function *Posting Billing Documents Subsequently* allows you to post in Profitability Analysis (CO-PA) billing documents that have already been posted in Financial Accounting (FI). This is particularly useful if you implement CO-PA *after* SD and you wish to import the data for the current or previous periods to CO-PA.

You can run this program in the test mode to check your data for errors before actually transferring it to CO-PA.

Prerequisites

Before you can transfer billing data subsequently to Profitability Analysis, the controlling area you are working in must be activated. You do this in Customizing.

Activities

You can find this function in Customizing under the option *Tools → Production Startup → Subsequent Posting of Billing Documents*.

On the selection screen, you can specify which billing documents you want to transfer. The flag *Check for existing billing documents* is set by default. This means that the program checks that the billing documents have not already been posted to CO-PA.

If you deactivate this flag, the system will not check for existing data. In this case, you need to make sure that no billing documents are transferred to Profitability Analysis more than once.
Settling Orders/Projects

Use
In the SAP System, you can settle internal orders (component CO), sales orders (component SD), projects (component PS) as well as production orders and run schedules with production cost collectors (component PP) to profitability segments. These objects are used for various purposes relevant to Profitability Analysis.

- Internal orders and projects can be used to control the costs of an internal activity, such as the costs of an advertising campaign. The costs of the activity are posted to the order and collected there. At the end of the activity, they are settled to the appropriate profitability segments, such as the product range and sales area. For more information, see the online documentation Internal Orders [Extern].

- You can also use CO orders to calculate anticipated values in order to be able to evaluate the accuracy of your accrual method. First, you credit the accrual costs calculated in CO-PA to a special cost order for accruals (currently by manual posting only). When the costs are actually incurred, they are posted to that order as well so that the difference between the anticipated costs and the actual costs can be displayed at the order level.

- A third possible use of internal orders or projects is in make-to-order manufacturing. If you are dealing with a sales orders from SD, a customer project or a CO order to which revenue postings are allowed, you can post costs (such as production costs and S&A costs) as well as revenue and sales deductions to the order or project. Then, when the product is complete, the costs and revenues can be settled to Profitability Analysis. It is also possible to transfer accrued values, which are particularly important for progress billing (such as cost of sales and reserves for imminent losses). For more information, see the online documentation Cost Object Controlling [Extern].

- In repetitive manufacturing, it may also be useful to transfer the production variances calculated in CO-PC for both final production orders as well as run schedule headers (settled periodically) to CO-PA. The individual variance categories can be transferred separately. For more detailed information, see the section Transferring Production Variances [Seite 301] and the Cost Object Controlling [Extern] documentation.

If your system allows dual postings to a profitability segment and a statistical object (such as a statistical order), the statistical object is not settled to CO-PA. Dual postings such as this can be useful if, for example, you want to post the expenditures for a marketing campaign to a profitability segment comprising a specific product group and sales region, and at the same time post the costs to the relevant sales cost center for analysis purposes.

Prerequisites
Before you can settle orders or projects to Profitability Analysis in realtime, the controlling area you are working in must be activated. You do this in Customizing.

Before you can settle an order or project to a profitability segment, you must create a settlement rule for the settlement object with a profitability segment as a receiver. You do this when you maintain the master data for the order or project.
Settling Orders/Projects

If the **settlement profile** of the order allows settling to profitability segments, you can enter an assignment to a profitability segment when you create the **settlement rule**.

**Features**

To enter an assignment to a profitability segment for a settlement, choose to call up the dialog box *Assignment to a Profitability Segment* (the assignment screen). The assignment screen contains the CO-PA characteristics that you can choose from to specify the profitability segment. During Customizing, you can create a characteristics group to appear in this dialog box and assign the group to the business transaction KABK (settlement account assignment). The characteristic group defines which characteristics are displayed for selection.

To simplify the selection of similar, frequently entered combinations of characteristics, you can create entry aids. For more information, see the section *Entry Aids for Assignments to Profitability Segments* [Seite 280].

Other characteristics are **derived** automatically from the characteristics you enter (see also *Characteristic Derivation* [Seite 41]). A profitability segment number is assigned to the combination of assigned and derived characteristics.

You can assign 100% of the values to one profitability segment (as shown in the graphic below). Alternatively, you can distribute the values to several profitability segments on a percentage basis.

You can settle orders and projects online or in the background. You can run a simulation settlement or perform an update. The result of the settlement is stored in a log. For further information on settlement rules and performing settlement, see the documentation on settlement in *Internal Orders* [Extern].

The system creates a line item and updates the segment level for each item of the settlement rule that is posted to a profitability segment. In costing-based CO-PA, each value settled is assigned to the value field specified in the **PA transfer structure**. Each value can be assigned separately to two value fields for the fixed or variable components.

In account-based CO-PA, the costs are settled to the settlement cost elements specified in the **allocation structure** of the order or project. For more information, see the description of settlement rules in the online documentation for *Internal Orders* [Extern] or *PS Projects System* [Extern].

The **line item** created in CO-PA can be displayed in the application menu under *Information system* → *Display line item list* → *Actual* or under *Actual postings* → *Display line items*. You can select the line items you want to see by certain criteria, such as the author or the date created.

The following graphic uses an example to illustrate how an order is settled:
Settling Orders/Projects

Order 4913 - Marketing display

<table>
<thead>
<tr>
<th>G/L account</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>403000</td>
<td>1000.00</td>
</tr>
<tr>
<td>404000</td>
<td>500.00</td>
</tr>
</tbody>
</table>

Settlement rule

Prof. segment: Division A
Region North

Parameters

Settlement structure A1
PA settlement structure E1

CO-PA line item

<table>
<thead>
<tr>
<th>Document no.</th>
<th>Division</th>
<th>Region</th>
<th>VTRGK</th>
</tr>
</thead>
<tbody>
<tr>
<td>38000012</td>
<td>A</td>
<td>North</td>
<td>1500.00</td>
</tr>
</tbody>
</table>

See also:

Checking Value Flows from Order/Project Settlement [Seite 409]
Settling Incoming Orders and Open Orders for Projects

Use

Project-related incoming orders and project-related open orders are two important profitability indicators that you can settle to Profitability Analysis.

Prerequisites

For you to be able to use this function, sales order data must exist for the project, having been transferred either from the Sales and Distribution (SD) application or from an external system.

For these values to be updated in CO-PA, you must have the characteristic Sales order history (SORHIST) in your operating concern, and you must define a number range for the record type I.

Features

Incoming sales orders for projects are found for each billing element on the basis of the project plan and updated for the project. A history is created for the incoming sales orders. There, the origins of the orders are divided according to the following categories:

- New order
- Changed order
- Rejection
- Changed plan

The open orders are determined from the incoming orders and the costs of sales and revenue that have already been billed.

You can analyze the costs and revenues of the incoming orders and the open orders in the CO-PA information system and update them in CO-PA. The values are updated by means of settlement according to the Processing type indicator.
Direct Postings from FI

Use

You can use this function to directly post primary postings to market segments (profitability segments).

Prerequisites

Before you can transfer direct postings from FI to Profitability Analysis in realtime, the controlling area you are working in must be activated. You do this in Customizing.

Features

The individual steps shown in the graphic above are described below:

- **Post document**
  You can assign revenue, sales deductions and costs directly from Financial Accounting (FI) to **profitability segments** (such as **customers** and **products**) in CO-PA when you use the **Post document** function.

This lets you post sales deductions or actual costs that are first accrued at the end of the period for the purposes of estimating profits - such as annual rebates or freight costs - to the appropriate profitability segments at a later point in time. This makes it possible to compare your anticipated costs with the final actual costs. Both of these can be displayed in profitability reports.
Direct Postings from FI

You can post the actual costs to the original profitability segment (sales order or combination of product and customer), or - if a detailed assignment is not necessary or no longer possible - to any higher level in Profitability Analysis (actual freight posted to the division).

If your system allows dual postings to both a profitability segment and a cost center or statistical order, the real posting always goes to the profitability segment. The other object is posted only for statistical purposes.

Double postings can make sense if, for example, you want to post expenses for a marketing campaign to a profitability segment that represents a certain product group and sales region, and at the same time need to see the data in the relevant sales cost center for statistical purposes.

Direct posting also lets you post direct costs or revenue to profitability segments. These might include such things as license fees for retail goods or costs and revenue for services.

You assign the values to a profitability segment directly with the posting transaction in Financial Accounting. For each posting line to be posted to a profitability segment, you can use \textit{Assignment to a Profitability Segment} (the assignment screen). The assignment screen contains the CO-PA characteristics from which you can choose to specify the profitability segment. During Customizing, you can create a characteristics group to appear in this dialog box and assign the group to the business transaction RFBU (G/L account postings). The characteristic group defines which characteristics are displayed for selection.

To simplify the selection of similar, frequently entered combinations of characteristics, you can create entry aids. For more information, see the section \textit{Entry Aids for Assignments to Profitability Segments} [Seite 280].

- **Derivation**

  The system automatically derives additional characteristic values (see also \textit{Characteristic Derivation} [Seite 41]) based on those you specified.

  You can only assign a posting to a profitability segment if the relevant G/L account is assigned to a field status group that allows postings to profitability segments (see \textit{Financial Accounting} in Customizing).

  When the FI document is posted, the system creates a line item in CO-PA and updates the segment level for each posting line assigned to a profitability segment. The values and quantities posted are transferred to the corresponding value and quantity fields in Profitability Analysis.

- **PA transfer structure "FI"**

  For direct postings in FI, all assignments of values and quantities to the value fields in costing-based CO-PA are defined using the \textit{PA transfer structure "FI"}, which you maintain in Customizing. In account-based CO-PA, the data is posted in the same G/L account as in FI.

  For example, when you post an amount to an account in the cost element group BAB-ERLO (such as account 810000) in FI, this amount appears as revenue in the value field ERLOS in costing-based CO-PA.

- **Line Items and Segment Level Update**
The line item created in CO-PA can be displayed in the application menu under Information system → Display line item list → Actual or under Actual postings → Display line item. There you can select line items using the FI document number as the "reference document number".
Entry Aids for Assignments to Profitability Segments

Use

For manual assignments to CO-PA in the dialog box Assignment to a Profitability Segment (the assignment screen), it may be necessary to enter several times very similar or even the very same combinations of characteristic values. Instead of having to re-enter them each time, you can save such combinations of characteristic values as an Entry Aid [Extern].

Entry aids you have created can then be selected from a tree in the assignment screen. By double-clicking an entry aid, the characteristic values you have saved are entered into the corresponding fields in the dialog box.

💡

Batch-input transactions, however, use an assignment screen that does not have any entry aids.

Features

Creating entry aids

You can create entry aids for business transactions in Customizing for CO-PA by choosing Actual Flows of Values → Initial Steps → Characteristic Groups → Assign Characteristic Groups for Assignment Screen. The entry aid for a particular business transaction can then be used by every user performing assignments for that transaction. Users can access such entry aids by choosing Central entry aids.

Furthermore, users can create their own entry aids when in account assignments. Such entry aids can then only be used in subsequent account assignments by the user who created the entry aid and for the business transaction it was created for. Users can access the entry aids they have created by choosing My entry aids.

The following applies to both central and user-specific entry aids:

- Derived characteristic values are not saved in an entry aid because the system continually determines new values in account assignment.
- You cannot retrospectively change characteristic values in an entry aid. You can only change the entry aid description.
- You should first enter the characteristic values to be saved and then select 📐.

Displaying entry aids

Depending on the position of the cursor in the tree, you can choose 📐 to display an overview of the characteristic values in one or more entry aids.

- If you position the cursor directly on an entry aid, only the characteristic values for that entry aid are shown in the overview.
- If you position the cursor on a node, the characteristic values for all lower-level entry aids are shown in the overview.
Alternatively to using the pushbuttons, you can use the right mouse button to call up a context menu offering you the same functions as for a node.

**Selection of entry aids**

When you double-click an entry aid to select it, the system treats the characteristic values as if they had been entered manually. The following applies:

- Fields that are locked against entry, such as those transferred from the sender document, are not populated with data.

- Any fields that have already been populated but which still remain unlocked for entry are then overwritten if characteristic values for those fields are stored in the entry aid or if derived values are determined for those fields. Empty characteristic values in the entry aid will clear any data from fields unlocked for entry in the assignment screen.

- If there is no field in the assignment screen for some characteristic values stored in the entry aid, then those characteristic values are not transferred. This could occur if, after the entry aid was created, for example, a characteristic line has been deleted from the characteristic group assigned to the business transaction.

- Characteristics that are not visible in the current page of the assignment screen but that can be shown by scrolling are also supplied with the characteristic values stored in the entry aid.

- You can still write over and add to characteristic values that have been entered using an entry aid.

**Transporting entry aids**

You can transport central entry aids when you transport an operating concern.
Periodic Overhead Allocation

To reflect all the actual costs from Overhead Cost Controlling in Profitability Analysis, you need to transfer the cost center costs and business processes which are not directly attributable to the production process. You can transfer these costs to any profitability segments you wish and thus assign them to any level of your contribution margin hierarchies.

That way you can assign them to the level that best reflects the cause of the overhead.

For example, you can assign the costs that arose in the marketing for a certain customer group to that particular customer group in CO-PA.

The fixed costs and the excess costs in production should be assigned to the products or product groups that caused these costs. Since you want to be able to analyze these costs easily in reports by drilling down, it would not make sense to assign them to combinations of customer and product.
Transferring Cost Center Costs

Use

This function makes it possible for you to transfer to Profitability Analysis overhead costs, such as the variances for production cost centers (as a single whole, not according to variance categories) and the costs for sales and administrative cost centers.

Cost center costs are always transferred to one profitability segment:

- Production cost centers
  
  These cost centers are first credited during production as the activities they perform (such as machine hours and assembly hours) are required. The amount of the credit is based on the quantities confirmed by production and on the activity prices (such as machine hour rates) usually calculated in cost center planning. The balances that are thus achieved - or the overabsorption/underabsorption remaining for the production cost centers due to the difference between credits and actual costs - are transferred en bloc in periodic profit analysis to those profitability segments in CO-PA that caused those costs.

- Sales and administration cost centers
  
  Many companies transfer the costs from administrative cost centers to CO-PA en bloc instead of allocating them to cost objects. This reduces the period results of the individual divisions, product groups, or business areas.

It is also possible to transfer postings that are made in Financial Accounting to cost centers and profitability segments at the same time. In this case, the postings are statistical in Cost Center Accounting, while the true costs are stored in Profitability Analysis. The system ignores these statistical costs in Cost Center Accounting when assessing costs to Profitability Analysis.

Features

For information on the procedure for allocating cost center costs to Profitability Analysis, see the section Methods of Allocating Overhead [Seite 285].
Transferring Process Costs

Use

The Activity-Based Costing (CO-OM-ABC) application component provides an alternative form of overhead control that is particularly useful when indirect activities account for a large share of the value added to products.

Whereas traditional approaches allocate machine-hour rates or similar overhead to cost objects, CO-OM-ABC lets you allocate overhead activities in a way that better reflects the origin of those costs. It uses "cost drivers" to allocate indirect activities to "business processes", which can then be transferred periodically to Profitability Analysis.

For example, you could transfer the costs of processing orders to CO-PA based on the cost driver "Number of sales orders processed" in order to identify those customers and business divisions that generate the highest sales costs.

These costs can be transferred periodically to CO-PA using the process assessment function, for example. In this way, the overhead allocated to the processes is transferred to CO-PA. Reference values for the transfer can be quantities and values posted in CO-PA or additional cost driver information, such as the number of sales orders processed.

This method charges the process costs to the profitability segments, which you can then analyze in detail in terms of their contribution margins. You can transfer both actual and planned process costs to Profitability Analysis.

Before you can transfer process costs to Profitability Analysis, Activity-Based Costing must be active as an operational Controlling component in your system.

Features

For information on the procedure for allocating process costs to Profitability Analysis, see the section Methods of Allocating Overhead [Seite 285].
Procedure for Overhead Allocation

Use

You can choose between several different methods for the periodic transfer of process costs and cost center costs to CO-PA:

Features

Assessment

From an accounting viewpoint, assessment cycles allocate your planned or actual costs for cost centers or business processes to profitability segments in CO-PA on the basis of reference values, percentages, or fixed amounts.

For detailed information about assessment, see the section Assessment [Extern] in the online documentation for Cost Center Accounting (CO-OM-CCA).

Indirect activity allocation

Whereas assessment lets you split cost elements or cost element groups on the basis of reference values, activity allocation lets you allocate on the basis of the activities performed.

This function is especially useful for cost centers whose activities cannot be measured directly, because you can create a quantity structure based on certain assumptions and then valuate and allocate this just as you would allocate activities directly. An example of such a cost center whose activity cannot easily be measured would be an "Order Processing" cost center. To allocate the costs for this cost center according to their cause, you can create a quantity structure based on the quantity "Number of orders processed" and then valuate this with an activity price.

Processes can also be allocated using indirect activity allocation. This function is especially useful for instances where the process quantities cannot easily be measured directly, because
Procedure for Overhead Allocation

you can create a quantity structure based on certain assumptions and then valuate and allocate this just as you would allocate activities directly. An example of such a process for which the activity cannot easily be measured would be the process “Creating Quotations”. To allocate the costs for this process according to their cause, you can create a quantity structure based on the quantity "Number of quotations" and then valuate this with an activity price.

For detailed information about the indirect allocation of activities, see the section Allocating Activities Indirectly [Extern] in the online documentation for Cost Center Accounting (CO-OM-CCA).

Template allocation

In Template Allocation [Extern], you can determine in detail which profitability segments used the processes (as well as cost centers/services) and then use this information for allocating the costs. Here you can use a template [Extern] to define formulas and functions that select cost drivers from Profitability Analysis or other sources in order to assign the costs most accurately to their cause.

In Customizing, you assign this template to "characteristics", which are used to select the cost drivers. Then you need to assign "update characteristics", which ultimately determine the profitability segments to which the overhead costs are allocated.

Your company uses a process "Customer Service" to differing degrees for different customer groups. You therefore define a template for the customer group "Wholesale" that is used to determine cost drivers. When you allocate these process costs to CO-PA, you can add further characteristics, such as "Key customer". These characteristics are ultimately the ones to receive the process costs that you allocate.

You can use template allocation for both actual and planned data.

For detailed information about template allocation, see the section Template Allocation for Actual Data [Extern] in the online documentation for Activity-Based Costing.

Activities

To assess overhead to CO-PA or to allocate activities indirectly, you need to define cycles, which let you allocate overhead to profitability segments in connection with your period-end closing activities. For more information, see the section Use of Cycles in Profitability Analysis [Seite 287].

When using template allocation for overhead, you need to define a Template for Profitability Segments [Extern]. For more information, see the section Template Allocation to Profitability Segments [Extern] in Activity-Based Costing (CO-OM-ABC).
Use of Cycles in Profitability Analysis

For the periodic transfer of overhead to Profitability Analysis (CO-PA), start an assessment or an indirect activity allocation at the end of the month. This performs a cycle or several cycles at once. These cycles contain the control information and can be maintained in Customizing in CO-PA.

Cycles for period-based allocation are mainly used in overhead allocation (CO-OM) to allocate cost center costs to other cost centers or to other receiver objects in CO-OM. In the documentation for Cost Center Accounting (CO-OM-CCA), you can find detailed information about the scope of functions for using cycles. This section will concentrate on the special features for using cycles in CO-PA and includes references to the appropriate and more detailed sections in the CO-OM-CCA documentation.
Cycles

Definition
A cycle controls how assessment or indirect activity allocation are processed. All the relevant information about the senders, receivers, sender rules, receiver rules and tracing factors is contained in Segments [Seite 290].

The individual key for a cycle is made up its name and the initial date.

Use
In Profitability Analysis (CO-PA), you use a cycle to allocate cost center costs or process costs using assessment or indirect activity allocation to CO-PA.

Structure
A cycle contains one or several segments describing combinations of senders and receivers that are to be processed together to CO-PA.

The amount of time required to execute a cycle and the amount of data created depend largely on the following:

- The number of segments
- The number of sender cost centers/sender processes
- The number of receivers
- The type of database selection
- The structure of the cycle

A cycle consists of 100 segments. In each segment, two cost centers are distributed to the independent characteristics Customer (10,000 characteristic values) and Product (1000 characteristic values) based on variable percentages. Each customer buys 5 products per period. This means that each sender distributes to 50,000 profitability segments.

Thus the system creates $100 \times 2 \times 50,000 = 10,000,000$ line items per period. If each record contains 1150 bytes (approximately 50 value fields), the resulting data volume is about 10 GB.

This cycle cannot be executed!

Note the following recommendations:

- You should optimize the structure of a cycle for both possible types of database selection, and then use this access strategy to execute the cycle.

  This means that the characteristics for the receiver objects should overlap as much as possible in the segments of a cycle that is to undergo selection by cycle. You must not, for example, define a cycle in which one segment distributes to Division and another segment distributes to Product. Moreover, such a cycle should not consist of more than 100 segments.
In the segments of a cycle that is to undergo **selection by segment**, the characteristics for the receiver objects should overlap as little as possible.

- Do not distribute to more than one independent characteristic at the lowest level (either "Customer" or "Product").

During allocation to Profitability Analysis, the order of the segments in a cycle does not affect the results of the cycle in any way.

**Example**

A cycle contains two segments, both of which credit the same cost center: segment 1 works with fixed amounts (sender rule “2”), while segment 2 works with the posted amounts (sender rule “1”).

This assessment has the following result: The cost center is credited the amount posted and the fixed amount. If you just want to credit the cost center with the remaining amount, you need to create two cycles and execute them one after the other.

In theory, you could create one cycle for transferring all cost centers or processes to Profitability Analysis. However, for performance reasons as well as from the point of view of allocation, it may make more sense to create several cycles, and process them sequentially in the order entered. The system ensures that one cycle has been completed before the next cycle starts.

You should divide your assessment into several cycles if you want to allocate different areas of your organization to CO-PA at different times. It also has the advantage that when errors or changes occur, you only need to repeat the affected cycles.

To define a cycle to **assess** actual overhead to Profitability Analysis, go to Customizing and choose Flows of Actual values → Transfer Overhead → Assess Cost Center Costs / Process Costs → Define Structure of Cost Center Assessment / Process Cost Assessment.

To define a cycle to **allocate** the actual overhead of **indirect activities** to Profitability Analysis, choose in Customizing Flows of Actual values → Transfer Overhead → Set Up Indirect Activity Allocation of Cost Centers/Processes.

To define a cycle in **Planning** for **assessment**, choose in Customizing for CO-PA Planning → Integrated Planning → Transfer Cost Center Planning/Process Planning → Assess Cost Center Costs / Process Costs → Define Structure of Cost Center Assessment/Process Cost Assessment.

To define a cycle in **Planning** for **indirect activity allocation**, choose in Customizing for CO-PA Planning → Integrated Planning → Transfer Cost Center Planning / Process Planning → Direct/Indirect Activity Allocation → Set Up Indirect Allocation of Activities from Cost Centers /Processes.

**See also:**

Functions for Maintaining Cycles [Extern]
Segments

Definition

A segment is part of a cycle. Senders using the same rules to determine the allocated values and the corresponding receivers using the same rules to determine the tracing factor are grouped into the same segment for period-based allocation.

Use

The sales cost center “Automotive” allocates all the incurred costs to the product groups in the divisions “Cars” and “Motorcycles” at the end of each period. Division “Cars” distributes the costs according to the revenues earned by each product group, whereas division “Motorcycles” distributes them according to production costs. Here we need to create two segments, because the tracing factors for the two receiver groups are different. In each segment, we specify which share of the costs should be allocated to the two divisions. The following table illustrates this example:

<table>
<thead>
<tr>
<th>Sender</th>
<th>Receiver</th>
</tr>
</thead>
<tbody>
<tr>
<td>SEGMENT 1</td>
<td></td>
</tr>
<tr>
<td>Cost center “Automotive”</td>
<td>Division “Cars”</td>
</tr>
<tr>
<td>Allocate 70% of actual costs</td>
<td>Tracing factor “Revenue”</td>
</tr>
<tr>
<td>SEGMENT 2</td>
<td></td>
</tr>
<tr>
<td>Cost center “Automotive”</td>
<td>Division “Motorcycles”</td>
</tr>
<tr>
<td>Allocate 30% of actual costs</td>
<td>Tracing factor “Production costs”</td>
</tr>
<tr>
<td>Senders in a segment using identical value determination</td>
<td>Receivers in a segment using identical trace factor determination</td>
</tr>
</tbody>
</table>

If the percentages of the sender values in the segments within a cycle amount to over 100%, the system determines an error during allocation. If the percentage of the segments falls below 100%, the remaining percentage is not allocated and stays in the sender cost center.

Structure

The senders of a segment and the rules for calculating the sender values differ according to the type of allocation.

The receivers are always profitability segments that are created by entering a combination of characteristic values. The rules (tracing factors) used for allocating to the receiver also differ according to the type of allocation.
You define a segment by entering in the segment header frame the sender rules (to be used to determine the sender values) and the receiver rules (to be used to determine the receiver tracing factors). The rules that you select will dictate what entries are possible for the allocation characteristics (senders and receivers) and what entries can be used to specify the tracing factors and sender values. If you select "variable portions" as a receiver rule, you can also carry out entries for the receiver weighting factors.

Since how these entries are related depends on the type of allocation, see the following sections for more detailed information:

- Assessment Segment [Seite 292]
- Segment for Indirect Activity Allocation [Seite 294]

**Logic for allocating to company codes, business areas and profit centers**

The characteristics Company code, Business area and Profit center are handled differently depending on whether they are specified explicitly in the segment.

If you do not specify them as receiver characteristics, they are copied automatically from the sender to the receiver profitability segments. If you use the receiver rule "Variable portions", the tracing factors are aggregated over all company codes, business areas and profit centers.

If you explicitly specify the characteristics as receivers, distribution occurs using the receiver rule. In particular, cross-company-code, cross-business-area or cross-profit-center postings can be created if the characteristics specified for the sender differ from those entered explicitly for the receiver. In this case, the tracing factors used for the receiver rule "Variable portions" are selected for that particular company code, business area or profit center.
Assessment Segment

Structure

Sender

In assessment, each sender is defined by:

- Either cost centers or business processes (where the data to be allocated originates)
- Either a cost element or a cost element group (what is being allocated)
- Sender value (the value is being allocated)

You enter the cost centers or business processes in the Allocation characteristics frame.

The sender cost elements are grouped into a single assessment cost element or alternatively into several assessment cost elements via an allocation structure before being allocated to CO-PA. You enter the assessment cost element or the allocation structure in the segment header. You enter the sender cost elements to be grouped under allocation characteristics.

The sender value can be calculated using various rules. You also enter the rule you want to use in the segment header. You must also enter a percentage for the sender value (with which the sender value is to be credited).

The following are possible sender rules:

- Posted amounts (rule 1)
- Fixed portions (rule 2)
- Fixed prices (rule 3)

If you use rule 2 or 3, you have to enter the fixed portions or prices for the individual senders in the sender values frame.

Receiver

The receiver is defined in assessment by:

- The profitability segment (which market segment is being allocated to / what generated the costs?)
- The value field (which is being allocated to)
- Tracing factor (according to which distribution to the receivers occurs)

The profitability segment for the receiver is defined by a combination of characteristic values. You enter the characteristic values in the Allocation characteristics frame.

You can use a characteristic group to restrict the amount of characteristics offered at this point. Furthermore, to assign the respective characteristic group to the business transaction for indirect activity allocation to CO-PA, choose Actual Flows of Values → Transfer Overhead → Initial Steps → Assign Characteristic Groups to Actual Cycles [Extern] in Customizing. For the allocation of planning data, choose Planning → Integrated Planning → Transfer Cost Center Planning/Process Planning → Initial Steps → Assign Characteristic Groups to Plan Cycles.

In the segment header, you specify the value field (or value fields for fixed and variable portions, depending on the sender selected in the cycle header) into which the sender cost elements are
to be entered. Alternatively, you can enter a PA transfer structure with which several value fields can be found for each sender cost element.

The **tracing factor** for allocating to the receivers can be selected using various rules:

- Variable portions (rule 1)
- Fixed amounts (rule 2)
- Fixed percentage rates (rule 3)
- Fixed portions (rule 4)

If you use rule 1, you need to enter an allocation base for calculating the variable portions. The allocation base can be either a value field or a key figure and it is obtained by adding and subtracting value fields in CO-PA Customizing (by choosing *Flows of Actual Values* → *Transfer of Overhead* → *Initial Steps* → *Define Calculated Values for Use as Reference Values*). Using rule 1 can sometimes result in a negative tracing factor. You therefore need to specify what scaling should be used in such instances. With receiver rule 1, you make the other entries for the tracing factor in the *segment header frame*. You can change and specify your entries in the *tracing factors frame*.

The variable portion that is produced by the tracing factor can be manipulated again manually by choosing *Receiver weighting*. You can enter receiver-specific weighting factors, which are multiplied by the portion the system has calculated. Hence the portion calculated automatically and the receiver weighting factor you enter are both involved in the allocation.

**See also:**
- [Combinations of Sender and Receiver Rules](#)
- [Functions for Maintaining Cycles](#)
Segment for Indirect Activity Allocation

Structure

Sender

In indirect activity allocation, a sender is defined according to the following:

- Cost centers/Activity types or business processes (where the data to be allocated originates)
- Sender value (the value is being allocated)

You enter the **cost centers/activity types** or the **business processes** in the *Allocation characteristics frame*. You can only allocate activity types belonging to the **activity type category [Extern] 2** (indirect entry, indirect allocation) or the activity type category 3 (manual entry, indirect allocation).

The **sender value** is an activity quantity. The costs to be allocated are derived from the plan activity price for the allocation type. The sender value can be calculated using various rules. You enter the rule you want to use in the *segment header*. You must also enter a percentage for the sender value (with which the sender value is to be credited).

The following are possible sender rules:

- Posted quantities (rule 1; **only** valid for activity type category 3)
- Fixed quantities (rule 2)
- Quantities determined retrograde (rule 3)

If you use rule 2, you have to enter the fixed quantities for the sender objects in the *sender values frame*.

If you use rule 3, the activity quantity for the receiver is determined. You then have to enter the sender-specific weighting factors in the *sender values frame*.

Receiver

In indirect activity allocation, the receiver is defined by the following:

- The profitability segment (which market segment is being allocated to / what generated the costs?)
- The value field (which is being allocated to)
- Tracing factor (according to which distribution to the receivers occurs)

The **profitability segment** for the receiver is defined by a combination of characteristic values. You enter the characteristic values in the *allocation characteristics frame*.

You can use a characteristic group to restrict the amount of characteristics offered at this point. Furthermore, to assign the respective characteristic group to the business transaction for indirect activity allocation to CO-PA, choose *Actual Flows of Values → Transfer Overhead → Initial Steps → Assign Characteristic Groups to Actual Cycles [Extern]* in Customizing. For the allocation of planning data, choose *Planning → Integrated Planning → Transfer Cost Center Planning/Process Planning → Initial Steps → Assign Characteristic Groups to Plan Cycles*. 
The value field into which the costs are placed is determined automatically using the PA transfer structure in CO that is valid for direct and indirect activity allocation. The value field used is the one that is assigned to the allocation cost element stored in the attributes for that activity type or in the attributes for that business process.

The tracing factor for allocating to the receivers can be selected using various rules:

- Variable portions (rule 1)
- Fixed quantities (rule 2; not valid for activity type category 3)
- Fixed percentage rates (rule 3)
- Fixed portions (rule 4)

**If you use rule 1, you need to enter an allocation base for calculating the variable portions.**

The allocation base can be either a value field or a key figure and it is obtained by adding and subtracting value fields in CO-PA Customizing (by choosing Flows of Actual Values → Transfer of Overhead → Initial Steps → Define Calculated Values for Use as Reference Values). Using rule 1 can sometimes result in a negative tracing factor. You therefore need to specify what scaling should be used in such instances. With receiver rule 1, you make the other entries for the tracing factor in the segment header frame. You can change and specify your entries in the tracing factors frame.

The variable portion that is produced by the tracing factor can be manipulated again manually by choosing Receiver weighting. You can enter receiver-specific weighting factors, which are multiplied by the portion the system has calculated. Hence the portion calculated automatically and the receiver weighting factor you enter are both involved in the allocation.

See also:

- Combinations of Sender and Receiver Rules [Extern]
- Functions for Maintaining Cycles [Extern]
Performing Period-Based Allocation

Use
To transfer cost center costs or process costs at the end of the period to Profitability Analysis, execute assessment, indirect activity allocation or template allocation.

Prerequisites
Before you can allocate plan or actual costs from cost centers or processes to Profitability Analysis, the controlling area you are working in must be activated. If you want to allocate process costs, you must have Activity-Based Costing implemented as an operational component in your system.

You need to have completed Customizing for each procedure you wish to use for the allocation. For information about the procedures, see the section Methods of Allocating Overhead [Seite 285].

Features

Performing Assessment and Indirect Activity Allocation

Given that Cycles [Seite 288] are allocated in assessment and in indirect activity allocation, the same procedure is executed for both.

You can allocate cycles online or in the background.

Assessment cycles that process large amounts of data should always be executed in the background in order to avoid bottlenecks. It is recommended that you do not execute more than one large cycle in the same job step.

You can perform cycles sequentially or in parallel. If you want to prevent specific cycles from being performed in parallel (such as ones that are dependent on other ones), you must assign these particular cycles to the same cycle run group (see also Processing the Cycle Run Group [Extern]).

If your controlling area and your operating concern use different currencies, the system translates the values during the transfer.

- For actual costs, the system uses the mean exchange rate (exchange rate type M). The default setting translates the values using the rate valid on the last day of the period. By choosing Extras → Value date in assessment, you can also enter a date on which the currency translation should take place.

- In planning, the exchange rate type is taken from the definition of the plan version. The system always uses the rate valid for the first day of the period.

Line items are written, being credited to the cost centers/processes and debited from the profitability segments. To display these line items, use the information system or choose Assessment → Overview or Indirect Activity Allocation → Overview.

In costing-based CO-PA, the receiver data is transferred to value fields in CO-PA. Records are also created in CO-PA with record type D.
The receiver data in account-based CO-PA is stored using the allocation cost element for the sender (or the assessment cost element).

For the allocation of actual data, the posting date is the last day of the period. For the allocation of planning data, the posting date is the first day of the period.

If you repeat a cycle during a period, data already posted is canceled automatically before the cycle is run a second time.

Along with the cycle name and the initial data, the sender version is also part of the unique key of a plan cycle. This means that you can carry out the same cycle repeatedly with different sender versions. Hence nothing is canceled if you change the sender version in the cycle definition.

If you want to manually cancel a cycle, choose Indirect Activity Allocation → Cancel or Assessment → Cancel.

Cancellation is always carried out at the line item level. Once you have archived your data or have deleted the line items in either Profitability Analysis or Cost Center Accounting, you can no longer reverse the cycles.

You can check the allocation results (such as the sender and receiver information) by creating detailed lists (sender and receiver lists as well as journal lists) in which to record the results.

To specify which detail lists should be created, select the detail lists indicator and choose List selection. If you perform allocation in the background, the system generates the following spool files:

- A spool file is generated for the basic list, the segment list, and for the receiver and sender lists if appropriate.
- If applicable, a separate spool file is generated for the journal list.
- If applicable, a separate spool file is generated for the expert trace.

Moreover, you can display a runtime analysis (expert trace) or any messages while allocation is being executed. See also Results of Periodic Allocations or of Periodic Repostings [Extern]. The message section of the lists also contains information about which summarization levels were read (see also Defining Summarization Levels [Seite 373]). You can improve performance significantly by defining suitable summarization levels. You can find more detailed explanations by double-clicking the individual messages.

You can make the following settings by choosing Edit → Settings:

- Enter the display variant for detail lists
- Specify the strategy for database selection
- Enter the name under which the detail lists are to be stored with the allocation results
- Record the run log and the runtime analysis
- Determine system behavior when an error has occurred during the collective execution of cycles.
Performing Period-Based Allocation

One main difference with allocating planned overhead is that a cycle cannot be defined by the name and initial date alone. Instead, the sender version is also an essential part of the key for the cycle to run. This allows you to reuse the same cycle for different planned versions. All you need to do is simply change the sender version, without having to define a completely new cycle for each version.

Performing Template Allocation

For information on performing template allocation, see the section on Activating Template Allocation [Extern] in the online documentation for Activity-Based Costing (CO-OM-ABC).

Activities

You carry out periodic allocation in the CO-PA menu.

- You perform allocations of actual data by choosing Actual postings → Period-end closing / process costs.
- You perform allocations of planning data by choosing Planning → Integrated planning → Transfer cost center planning / process planning.
Allocating Activities Directly

Use
It is possible to allocate the costs for internal activities directly to profitability segments. To do so, you need to specify the sender and receiver along with the quantity of the activity provided. This quantity is automatically valuated with the planned price for that activity type, and the resulting amount is credited to the cost center providing the activity and debited to the receiver profitability segment.

In this way, the man hours of a sales employee, for example, can be posted directly to the specific customer groups or divisions for which the service was provided. This does not necessitate the use of cost centers or orders.

You can allocate activities to profitability segments directly on the detail screen for activity allocation or on a list screen. The allocation updates both costing-based and account-based CO-PA, provided that both are active.

Prerequisites
You should have maintained the PA transfer structure CO in CO-PA Customizing by choosing Flows of actual values → Transfer overhead → Direct/indirect allocation of activities → Maintain PA Transfer Structure for Template and Activity Allocation [Extern].

Activities
To allocate internal activities, choose Actual postings → Activity allocation from the application menu for Cost Center Accounting.

On the initial screen, you need to enter a screen variant, which defines the structure of the list screen. By entering a suitable screen variant, you can specify a sender cost center, the activity quantity, and a receiver profitability segment for each line.

From the initial screen, you can choose to call up a list screen or a detail screen.

- On the detail screen, you can specify a profitability segment as the receiver by selecting the Profit. segment field. Then when you press ENTER, the system displays a dialog box in which you can specify the characteristic values to which you want to allocate the activity. You can influence the structure of this dialog box by assigning a characteristic group to the business transaction RKL. You do this in Customizing.

  Once you have made your assignment and confirmed your entries, the Ass’d to prof.seg. check box is selected to indicate that the assignment has been made.

- If you want to allocate a number of activities to profitability segments, you can do this more quickly by calling up the list screen.

  As on the detail screen, you need to call up the dialog box for assigning a profitability segment. Again, a special check box indicates that a profitability segment has already been assigned.

For further information on internal activity allocation such as how the activity prices for valuating activities are determined or how to define screen variants see the section Allocating Activities Directly [Extern].
Allocating Activities Directly

**Postings Across Company Codes and Business Areas**

The characteristics “Company code” and -- where required by the system -- “Business area” must be specified for allocation to profitability segments, unless they are set automatically by means of a user parameter. The company code and the business area of the profitability segment may differ from those of the sender cost center. The cross-company or cross-business-area activities which result from this are stored in the "reconciliation ledger". If necessary, you can create corresponding reconciliation postings in Financial Accounting at the end of the period. (For more information on cross-company and cross-business-area postings, see the documentation [Cost and Revenue Element Accounting [Extern]]).

To assign the costs to value fields, you first need to maintain the PA transfer structure CO in Customizing for costing-based Profitability Analysis. PA transfer structure CO contains the assignment of costs and quantities to the value fields in Profitability Analysis.

If account-based Profitability Analysis is active, costs are updated there under the settlement cost element specified for the relevant activity type.

Before you can allocate activities directly to Profitability Analysis, the controlling area you are working in must be activated. You do this in Customizing.
Transferring Production Variances

Use

To run closed profitability analysis for periods, you need to transfer to CO-PA at the end of the period all the variances that have occurred in that period. Variances typically occur if you valuate your materials with standard prices. At the end of the period, these standard costs are then compared with the actual costs incurred, and this comparison forms the basis for a detailed variance analysis. The variances are finally transferred to CO-PA at the end of the period to produce a factually correct representation of the results.

While the variances for production cost centers flow into CO-PA during cost center assessment, the variances for cost objects are transferred to CO-PA when production orders, for example, are settled. For a description of how variances arise and what causes them, see the documentation on Cost Object Controlling.

The functions described below are relevant mainly for manufacturing enterprises.

Features

Three ways for transferring production variances are set out below. How you use them depends on your information requirements in CO-PA.

- You might wish, for example, to display the individual variance categories for Cost Object Controlling (CO-PC-OBJ) in CO-PA. In that case, you would **settle the variance categories to CO-PA**.

- You only need to display the production variances as a total in CO-PA, which is how they are posted to FI. You might not need to calculate cost object variances and only wish to assign the relevant FI posting to CO-PA. In that case, you would **post the production variances in FI to CO-PA**.

- You implement the Material Ledger (CO-PC-ACT). For the closing operations in Material Ledger, you might not wish to replace just the posted standard prices with the actual costs incurred. At the same time, you might want to subsequently allocate (across multiple levels) production variances to finished products at the end of the period and then display the revised variances in CO-PA. In that case, you would **allocate the production variances subsequently using the Material Ledger**.

Settling Variance Categories to Profitability Analysis

For the settlement of production orders, you can transfer to CO-PA the variance categories calculated in Cost Object Controlling. The requirements for this are as follows:

- You are working with standard prices for processed materials.

- You have already performed variance calculation in Cost Object Controlling.

- You have entered in the settlement profile for your production order that you wish to settle variances.

- You have set up and assigned a PA transfer structure in Customizing for CO-PA to be used to direct the calculated variance categories into the desired value fields.
Transferring Production Variances

The variance categories are settled in a much the same way as that for Settling Orders and Projects [Seite 273]. For more information on these requirements, choose Flows of Actual Values → Settling Production Variances [Extern] in CO-PA Customizing.

When your cost object is settled, the information will be transferred to costing-based CO-PA if these requirements have been fulfilled. In this way, the production variances are shown at the level of the particular product currently being produced. It is only possible to allocate production variances subsequently as a total when the Material Ledger is involved (see below).

### Production Order
- Actual debit: 56,000
- Credit to standard costs: 50,000
- Variances:
  - Price variance: 3000
  - Quantity var.: 2000
  - Lot size var.: 1000

### Result
- Revenue
- Cost of sales
- Price var.: 3000
- Quantity var.: 2000
- Lot size variance: 1000

### Financial Accounting
- Production variances: 6000
- to inventory changes: 6000

The variance categories can only be displayed in value fields. This function is therefore not available in account-based Profitability Analysis.

**Assigning Production Variances from FI to CO-PA**

If you only need to display production variances as a total as described above, you can alternatively assign the production variances from FI to CO-PA using account assignment.

Since the production variances are posted as a total in FI during settlement of the production order, you can also choose to assign this posting to CO-PA. The requirements for this are as follows:

- You are working with standard prices for processed materials.
- You have specified in CO-PA Customizing for the relevant production variance account (PRD account) that that account is automatically assigned to CO-PA. For more information, see the section Flows of Actual Values → Direct Posting from FI/MM → Automatic Account Assignment [Extern] in Customizing.
- You have specified in the appropriate PA transfer structure in FI which value field is the one to which the information is to be transferred.
Production variances are transferred in this case in much the same way as Direct Postings from FI [Seite 277] to CO-PA.

When your production order is settled, the variance posting created in FI will be posted to CO-PA if these requirements have been fulfilled. In this way, the production variances are shown at the level of the particular product currently being produced.

This function is available in both costing-based and account-based Profitability Analysis.

**Subsequent Allocation of Production Variances Using the Material Ledger**

When you use the Material Ledger, you can allocate production variances subsequently across several levels. This means that you can use the quantity flows recorded in the Material Ledger to charge the production variances arising for semi-finished products proportionally to the finished products. During period-end closing in the Material Ledger, the production variances posted temporarily are corrected accordingly in FI and then reposted to the next manufacturing level upwards. Subsequent allocation can only occur for summaries. For more information, see Material Ledger [Extern].

To transfer this information to CO-PA, you need to assign the relevant FI postings as described above. It is also possible to transfer the variance categories in parallel. However, the transfer would not be affected by the subsequent allocation due to the summary correction postings.

The requirements for this parallel transfer are the same as those described in the above section entitled "Assigning Production Variances from FI to CO-PA".

This function can be used in both costing-based and account-based Profitability Analysis.
Manual Line Item Entry

Use

Data is usually transferred to Profitability Analysis automatically. However, in some cases it may be necessary to enter line items manually (for example, in order to correct postings).

Prerequisites

By creating characteristics groups and value field groups and assigning them to record types, you can reduce the number of the characteristics or value fields you need to enter and achieve the desired amount. In this way, entering characteristics and value fields is quicker and more individualized.

To define and assign characteristics groups and value field groups, choose Actual Flows of Values → Initial Steps → Characteristic Groups or Value Field Groups in Customizing.

Features

You access manual line item entry in the application menu under Actual postings → Create line items.

You first enter the header data for each line item, specifying (among other things) which record type is to be used to post the line item. Enter in the tab page Characteristics those characteristic values that are to make up the profitability segment to which the line item is to be posted. Enter in the tab page Value fields those values that are to be posted to the profitability segment. You can choose from the technical fields and characteristics from SD and Controlling that are available in the tap page Source data. The fields that are offered are always the same ones; they cannot be limited to those forming a characteristic group. In some cases, some of the characteristics in these fields are also those offered in the tap page Characteristics. If this is the case, the characteristics offered in the tap page Source data are locked against manual entry. Only one value (possibly the one entered under Characteristics) is displayed.

If you have assigned characteristic groups and value field groups to the record type specified in the header data, then only those characteristics and value fields contained in these groups are offered in the corresponding tab pages. If you would then like to enter additional characteristics, you can replace the characteristics that were selected using the characteristic group by all the characteristics found in the operating concern. You do this by choosing Extras → All characteristics <-> Characteristic group. Similarly, by choosing Extras → All value fields <-> Value field group, you can switch between those value fields that were selected in the value field group and all those found in the operating concern.

Entry Aids

In the Characteristics tab page, you have the option of saving as user-specific entry aids particular combinations of characteristic values that you need to enter repeatedly. Enter the corresponding characteristic values and choose . All entry aids that you save are then listed under My entry aids. It is not possible to change the characteristic values belonging to an entry aid that has been saved. You can only change the description using .

When you double-click an entry aid, the system enters the corresponding characteristic values into the respective entry fields, including those that are not on view. With the exception of the controlling area, only fields that are unlocked for entry are filled. Fields that already contain data
Manual Line Item Entry

are overwritten or initialized by the entry aid. You are then able to overwrite or add to the characteristic values that were entered via the entry aid.

Use of entry aids for line item entry works according to the same principle as Entry Aids for Assignments to Profitability Segments [Seite 280]. The only difference is that, for assignments to profitability segments, you also have the option of creating - alongside the user-specific entry aids - central entry aids that can be used by all users.

**Derivation**

You can use the *Derivation* pushbutton to execute Characteristic Derivation [Seite 41] for the characteristics you have entered. When you do this, the system locks all the source fields for derivation so that no further entries can be made. If you have not executed derivation manually by the time posting is to take place, the system will automatically perform derivation.

Once characteristic derivation has been executed, you can run an analysis of the derivation by choosing Extras → Analyze derivation. This function displays a log containing a list of the steps carried out during derivation. This log tells you which characteristic values were found and how they were found.

- **Characteristic**
  - This column contains the description and the field name of the characteristic that was derived.

- **Value**
  - This is the characteristic value that was found.

- **Derivation type**
  - This column tells you which type of derivation step was performed. It also gives you certain technical information (table name, function name, and so on).

You can display detailed information about the derivation by double-clicking the desired line. You can use the function Cancel derivation to reset the fields to the state they had before you carried out derivation.

**Valuation**

If you activate the *Valuation* pushbutton, the system valuates the quantity and value fields (for more detailed information, see the section Valuation [Seite 76]). You can perform the valuation interactively by choosing Edit → Analyze conditions.

The system valuates the data based on the operating concern currency. If the currency you have entered (field Foreign currency key) differs from the operating concern currency, the currency is translated using the current average rate. If you have not executed valuation manually by the time posting is to take place, the system will automatically perform derivation.

Once valuation has been executed, you can run an analysis of the valuation by choosing Extras → Analyze valuation.

You use the function Cancel valuation to reset the quantity/value fields to the state they had before valuation.

**Posting**

Once all the fields relevant to the line item are filled, use to post the data.
If you want to post the line item even though it was not valuated or characteristic values were not derived completely, you need to execute the function Post again after receiving the error message.

**Line Item Display**

You can call up posted line items manually and automatically by doing one of the following:

- By choosing *Actual postings* → *Display line items* in the CO-PA menu
- By choosing *Line items* → *Display* from within the line item entry screen.

If you do not know the document number for a line item, you can choose \[\text{FS}\] in the initial screen to call up a line item list based on your entries and then select a line item from that list.

For more information about displaying line items and line item reports, see Line Item List [Seite 336].
Top-Down Distribution of Actual Data

Use

In Profitability Analysis, sales revenues, sales deductions, and costs of goods manufactured are generally stored at the customer/product level. However, many business transactions - such as freight invoices, insurance expenses, or advertising - cannot easily be assigned to such a detailed level in CO-PA. Consequently, these need to be posted at a summarized level, such as the division, sales organization, or company code level.

Top-down distribution of actual data is a periodic function that lets you distribute this aggregated data to more detailed levels in CO-PA on the basis of reference information (such as the data from the previous year).

Freight invoices that for organizational reasons can only be posted by division can be distributed to sales organizations based on the anticipated freight costs. This function is only available with costing-based Profitability Analysis.

Features

The data is distributed according to existing "reference data". You can use either planning or actual data as a reference. You can also distribute period by period, or aggregate the period values to smooth out variances.

The system distributes the data by value field or according to how the values in the selected value field are distributed.

When top-down distribution is executed, values that are not assigned at the higher level (§) are distributed. Characteristic derivation occurs but only for those characteristics that were used in
summarization (in other words, those values for which the *summarized* field in the processing instructions screen was selected).

You can perform distribution in any of the following ways:

- You can select values posted to any profitability segments and in any value fields, and then distribute this data to a specified distribution level.
- You can use existing actual or planning data as the basis for this distribution. The basis can be the values in a single value field (such as revenue) or a calculated value (such as contribution margin) or occur by value fields.
- You can also distribute period by period, or aggregate the period values to smooth out variances.

Using top-down distribution of actual data can lead to quite large data volumes, since the data is distributed to a large number of profitability segments.

Assessment can be used to obtain a complete view while eliminating data volume at the same time:
For example, if you assess from \( n \) cost centers to \( m \) profitability segments in each case, you create \( n \times m \) data records. As an alternative, you can first assess from \( n \) cost centers to one (or only a few) profitability segment(s), and then distribute this data to \( m \) segments. If the distribution factors for each cost center are the same, this technique only leads to \( 2 + m \) records.

**Activities**

You execute the top-down distribution of actual data by choosing *Actual postings → Period-end closing → Periodic adjustments → Top-down distribution* from the application menu.

**Entries for the actual data**

1. The posting periods or -- if you are using the alternative period type -- the weeks that you want to distribute
2. The record type of the data you want to distribute

**Entries for the reference data**

1. Enter the periods from which the reference data should be selected.
2. Specify whether you want to reference actual data or planning data. If you reference planning data, enter the plan version from which the data should be selected.
3. Enter the record type of the data you want to reference.
4. Select the *Aggregate periods* field if you want to add together the period values of the reference data rather than distributing them directly. This gives you the same value in each period for each segment, to smooth out incidental differences which occurred from period to period (see also *Example: Period Aggregation* [Seite 315]).

If you select this indicator, your reference period can be as large as you want. Only if you distribute by period do the planning period and reference period have to be the same length.
Top-Down Distribution of Actual Data

Entries for the reference base

1. Select the *Single value field* if you want to distribute all the value fields in proportion to the values contain in one value field. You can use any value field or key figure (formula defined using value fields). The key figures you can use here need to be defined in Customizing.

2. If you have selected the *Single value field*, enter the value field that you want to use as the distribution factor.

3. Select the *By value fields* field if you want to use each single value field as the basis for how that value field is distributed. This means that the value field *Revenue* would serve as the basis for how the revenues are distributed. Quantity discount would form the basis for how quantity discounts are distributed, and so on.

Entries under Extras

1. Select the *Test run* field if you want to distribute your planning data without making any changes to the database.

2. Select the *Background processing* field if you are distributing for a large number of segments. The system will execute the function in the background so that your system is not loaded down unnecessarily.

Selection Criteria pushbutton

Here you can restrict the amount of profitability segments that you want to delete. You can enter one or more single values or an interval for each characteristic. All the values of that characteristic are distributed if you enter an asterisk (*).

Processing Instructions pushbutton

Here you can specify how each characteristic should be processed in top-down distribution:

- **Distribution level**: this is the level to which the data is distributed.
- **Retain**: the characteristic values remain the same.
- **Summarize**: the data for all values of the characteristic is summarized.

For those characteristics that are neither distributed nor distributed to, you should leave the default values for the following:

- The selection criteria *
- The processing instructions (generally the option Summarize, for some characteristics such as controlling area the option Copy/Transfer).

See also Example: Selection Criteria and Processing Instructions [Seite 312].

Value fields pushbutton

Here you specify the value fields of the operating concern that you want to distribute.
**Example: Selection Criteria and Processing Instructions**

The characteristics *product* and *product group* are taken into account (where the *product group* is derived from the *product*). The value field to be distributed is the *sales quantity*.

Products P1 and P2 belong to product group PG1, while products P3 and P4 belong to product group PG2.

During top-down distribution, all product groups are to be distributed across the individual products. Reference data should be the actual data from the previous year and it should be distributed by value fields.

The following reference data from the previous year exists in the database:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PG1</td>
<td>P1</td>
<td>10</td>
</tr>
<tr>
<td>PG1</td>
<td>P2</td>
<td>30</td>
</tr>
<tr>
<td>PG2</td>
<td>P3</td>
<td>40</td>
</tr>
<tr>
<td>PG2</td>
<td>P4</td>
<td>40</td>
</tr>
</tbody>
</table>

The following current data at the *product group level* should be distributed:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PG1</td>
<td>600</td>
</tr>
<tr>
<td>PG2</td>
<td>600</td>
</tr>
</tbody>
</table>

In a report with the characteristic *product* in the lead column, these values would appear as follows:

<table>
<thead>
<tr>
<th>Product</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td># (not assigned)</td>
<td>1200</td>
</tr>
</tbody>
</table>

To distribute the values at both product groups to their products, enter the following parameters:

**Processing Instructions**

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product group</td>
<td>Retain</td>
</tr>
<tr>
<td>Product</td>
<td>Distribution level</td>
</tr>
<tr>
<td>Other characteristics</td>
<td>Default value (summarize or retain)</td>
</tr>
</tbody>
</table>

**Selection Criteria**

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Characteristic value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product group</td>
<td>PG1, PG2</td>
</tr>
</tbody>
</table>
Each product group is now distributed separately according to the reference data for the individual products in each product group.

A report with the lead column *Product* contains the following values after distribution:

<table>
<thead>
<tr>
<th>Product</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>0</td>
</tr>
<tr>
<td>P1</td>
<td>150</td>
</tr>
<tr>
<td>P2</td>
<td>450</td>
</tr>
<tr>
<td>P3</td>
<td>300</td>
</tr>
<tr>
<td>P4</td>
<td>300</td>
</tr>
</tbody>
</table>

The data at the product group level remains unchanged since the value aggregated at the product level is retained during distribution:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PG1</td>
<td>600</td>
</tr>
<tr>
<td>PG2</td>
<td>600</td>
</tr>
</tbody>
</table>

The following line items were created:

<table>
<thead>
<tr>
<th>Product group</th>
<th>Product</th>
<th>Sales Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>PG1</td>
<td>#</td>
<td>-600</td>
</tr>
<tr>
<td>PG1</td>
<td>P1</td>
<td>150</td>
</tr>
<tr>
<td>PG1</td>
<td>P2</td>
<td>450</td>
</tr>
<tr>
<td>PG2</td>
<td>#</td>
<td>-600</td>
</tr>
<tr>
<td>PG2</td>
<td>P3</td>
<td>300</td>
</tr>
<tr>
<td>PG2</td>
<td>P4</td>
<td>300</td>
</tr>
</tbody>
</table>

Looking at product group PG1, which contains products P1 and P2, we can see how the line items came to be:

Of the value 600, product P1 receives $150 = 600 \times \frac{10}{10+30}$, while P2 receives $450 = 600 \times \frac{30}{10+30}$. 600 was the total value for product group PG1, while 10 is the reference value for P1 and 30 the reference value for P2. The credit posting for - 600 was made to the product group level, where Product = # (not assigned).
Example: Period Aggregation

For setting up top-down distribution for planning and actual data, you have the option of specifying a period aggregation for the reference data (using the Aggregate periods indicator).

The following example will seek to demonstrate the difference between distribution with and distribution without period aggregation. It refers to the distribution of actual data but can also be applied to planning data.

The actual data for the periods 01.1999 through 03.1999 that is not posted to specific divisions is distributed to divisions corresponding to the actual data for the periods 01.1998 through 03.1998.

### Actual data to be distributed:

<table>
<thead>
<tr>
<th>Division</th>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>01.99</td>
<td>24</td>
</tr>
<tr>
<td>#</td>
<td>02.99</td>
<td>30</td>
</tr>
<tr>
<td>#</td>
<td>03.99</td>
<td>40</td>
</tr>
</tbody>
</table>

### Reference data:

<table>
<thead>
<tr>
<th>Division</th>
<th>Period</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>1.98</td>
<td>9</td>
</tr>
<tr>
<td>01</td>
<td>2.98</td>
<td>10</td>
</tr>
<tr>
<td>01</td>
<td>3.98</td>
<td>5</td>
</tr>
<tr>
<td>02</td>
<td>1.98</td>
<td>3</td>
</tr>
<tr>
<td>02</td>
<td>2.98</td>
<td>5</td>
</tr>
<tr>
<td>02</td>
<td>3.98</td>
<td>5</td>
</tr>
</tbody>
</table>

### Distribution without period aggregation:

<table>
<thead>
<tr>
<th>Period</th>
<th>Distribution relationship between division 01 and division 02</th>
<th>New data records</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>01.98</td>
<td>9:3 → 3:1</td>
<td>01.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td>01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>02</td>
</tr>
<tr>
<td>02.98</td>
<td>10:5 → 2:1</td>
<td>02.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td>01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>02</td>
</tr>
<tr>
<td>03.98</td>
<td>5:5 → 1:1</td>
<td>03.99</td>
</tr>
<tr>
<td></td>
<td></td>
<td>01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>02</td>
</tr>
</tbody>
</table>
Example: Period Aggregation

Distribution with period aggregation:

<table>
<thead>
<tr>
<th>Period</th>
<th>Distribution relationship between division 01 and division 02</th>
<th>New data records</th>
</tr>
</thead>
<tbody>
<tr>
<td>01-03.98</td>
<td>24:13</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Period</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Division</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Value</strong></td>
</tr>
<tr>
<td>01.99</td>
<td></td>
<td>01</td>
</tr>
<tr>
<td>02.99</td>
<td></td>
<td>01</td>
</tr>
<tr>
<td>03.99</td>
<td></td>
<td>01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>02</td>
</tr>
<tr>
<td></td>
<td></td>
<td>02</td>
</tr>
</tbody>
</table>
Checking/Canceling Top-Down Distribution of Actual Data

Use

After you have executed top-down distribution in an update run, you can check the result by displaying the line items that were written during the run. Alternatively, you can cancel the distribution run.

Procedure

Checking Top-Down Distribution

There are various options with which you can display the line items that resulted from the top-down distribution:

- As soon as the update run has finished, you can call up the function Goto → Line items.
- From the menu, you can call up the function Accounting → Controlling → Profitability Analysis → Actual Postings → Period End Closing → Periodic Adjustments → History of Periodic Adjustments. You can call up the log for the top-down distribution run you want to check and then choose Goto → Line items.

⚠️ In some cases, using one of the above methods to call up the line items can take a long time.

- From the menu, you can call up the function Accounting → Controlling → Profitability Analysis → Actual Postings → Display Line Items. To enhance system performance when calling up line items, you should restrict your selection as far as possible. Be sure to always enter a value for the Record type and for the Period/year.

Alternatively, you can display the result in a suitable report in the information system. This requires you, however, to update the corresponding summarization levels beforehand (see Building Summarization Levels [Seite 375]).

Canceling Top-Down Distribution

From the menu, you can cancel a distribution run by calling up the function Accounting → Controlling → Profitability Analysis → Actual Postings → Period End Closing → Periodic Adjustments → History of Periodic Adjustments. You can then call up the log for the top-down distribution run you want to cancel and then choose Goto → Cancel.
Storing Actual Data in Multiple Currencies

Prerequisites

Before you can update data in CO-PA in two currencies, you need to activate the company code currency on the Attributes screen for your operating concern. You do this in Customizing under Structures → Operating Concern → Maintain Operating Concern.

You can activate the company code currency when you first activate your operating concern, or you can activate it later for all subsequent postings.

Use

When actual data is posted in CO-PA, the system technically creates two line items: one in the operating concern currency and one in the company code currency.

Where possible, the values in each currency are taken directly from the original documents (invoices, G/L accounts, and so on). If the amounts do not exist there in the desired currency, the system translates them from the transaction currency using the exchange rate valid on the posting date. By default, CO-PA uses exchange rate type “M” (mean rate) for translating actual data. You can use other exchange rate types, though, by defining customer exits. (For more information, see the documentation on customer enhancement “COPA0004” (foreign currency translation).)

See also:

Storing Multiple Currencies in CO-PA [Seite 37].
Multiple Valuation Approaches/Transfer Prices in CO-PA

Use

The Profitability Analysis (CO-PA) application component normally represents external sales with customers outside the group and other companies within the group. This allows you to analyze the external sales and valuate these using the cost of goods manufactured from a legal or group standpoint.

Organizations that want to handle profit centers as independently operating companies, however, need to be able to see internal sales between profit centers (exchanges of goods, goods issues, stock transfers, and so on) as well as external sales in order to analyze their profit centers correctly in this environment. Moreover, it may be necessary to valuate both internal and external sales from the viewpoint of the individual profit centers (costs of goods manufactured on the basis of transfer prices) in addition to the legal viewpoint.

If your organization valuates exchanges of goods between profit centers with transfer prices, you can update this information in costing-based CO-PA and thus evaluate your sales from both the legal viewpoint and the profit center viewpoint. The following valuations are possible:

For detailed information on transfer pricing and multiple valuations, see Transfer Prices [Extern] in the online documentation for Profit Center Accounting.

Prerequisites

To be able to update values with profit center valuation in CO-PA, your system must meet the following criteria:

1. Your system must valuate exchanges of goods between profit centers using transfer prices.
Multiple Valuation Approaches/Transfer Prices in CO-PA

2. A currency and valuation profile (in which at least one valuation approach uses profit center valuation) must be defined and assigned to the desired controlling area in Customizing under General Controlling → Multiple Valuation Approaches/Transfer Prices, and multiple valuations must be activated.

In addition, certain settings must also be made for CO-PA Customizing.

1. You must activate profit center valuation for at least one currency under Structures → Operating Concern → Define Operating Concern → Attributes.

2. You must define accounts for internal goods movements between profit centers to value and quantity fields in CO-PA and activate profit center valuation (Flows of Actual Values → Multiple Valuation Approaches/Transfer Prices).

3. You must activate the characteristic Partner profit center (field PPRCTR) under Structures → Define Profitability Segment Characteristics (Segment-Lvl Characteristics).

To be able to analyze the results generated between profit centers, you need to know which profit centers sold to which other profit centers. Consequently, each internal transaction has to have two profit centers, which are stored in the characteristics Profit center (PRCTR) and Partner profit center (PPRCTR). This gives you both profit centers as characteristics for analysis in CO-PA.

The characteristic Partner profit center is a fixed characteristic in the operating concern data structures, and must be active as a segment level characteristic.
Content of Profit Center Valuation

Features
The profit center valuation view shows you the cost of goods manufactured from the profit center viewpoint and valuation according to transfer price conditions.

Use
Cost of Goods Manufactured in Profit Center Valuation
To show the cost of goods manufactured according to profit center valuation in CO-PA, the system needs to be able to access material cost estimates according to the valuation view required (legal or profit center valuation).

You need to set this up in CO-PA Customizing using the function Assign Costing Key to Any Characteristics. There, you need to define an assignment rule with the global field ITEM_TYPE ("Valuation view CO-PA") as a source field.

The costing variant determines which cost estimate in CO-PC is read for the specified valuation view. Consequently, you need to define costing keys that read cost estimates for legal valuation (as in earlier releases) as well as costing keys that read cost estimates for profit center valuation.

The following costing variants were defined in Product Cost Controlling:

- LEG1: Cost estimates for legal valuation
- TPR1: Cost estimates for profit center valuation
  
  In Profitability Analysis, you want the system read separate cost estimates for each material type and using costing variants LEG1 and TPR1.

  You therefore define the following costing keys in Profitability Analysis:

  - LEG1: Uses costing variant LEG1
  - TPR1: Uses costing variant TPR1

  Then you assign these costing keys to the following field combinations:

  **Source:**
  - GLOBAL-BWFKT (Point of valuation)
  - GLOBAL-VRGAR (Record type)
  - GLOBAL-VERSI (Plan version)
  - GLOBAL-ITEM_TYPE (Valuation view)
  - CO-PA-MTART (Material type)

  **Target:**
  - GLOBAL-KALAW1

  **Rule values:**
Content of Profit Center Valuation

<table>
<thead>
<tr>
<th>Record type</th>
<th>Vers.</th>
<th>Val. view</th>
<th>Material type</th>
<th>Costing key</th>
</tr>
</thead>
<tbody>
<tr>
<td>F</td>
<td>FERT</td>
<td>= LEG1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>P</td>
<td>= TPR1</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This assignment has the effect that the system uses costing type TPR1 to find the cost estimate for profit center valuation and costing type LEG1 for legal valuation (valuation view "blank").

Valuation Using Transfer Price Conditions

You can use transfer price conditions in SD pricing to valuate the revenue and the cost of goods sold in billing, and update these values in the value fields of your operating concern.

In CO-PA planning, you can use these conditions for valuation by including a pricing procedure from SD (application "V") in your valuation strategy.

It is also possible to valuate using transfer prices by accessing pricing procedures in Profit Center Accounting. Note that Profit Center Accounting uses "transfer price variants". These variants mean that the system reads a series of pricing procedures until one condition value - the transfer price - is found. To transfer this value to a value field in CO-PA, you need to define a separate step in your valuation strategy that uses a transfer price variant and transfers the values found to a CO-PA value field.

<table>
<thead>
<tr>
<th>Seq.</th>
<th>Appl.</th>
<th>Costing sheet</th>
<th>Material cost est.</th>
<th>Quantity</th>
<th>Variant</th>
<th>Value field</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>X</td>
<td></td>
<td></td>
<td>VVQTY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>V</td>
<td>COPA</td>
<td></td>
<td>VVQTY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>03</td>
<td>TP</td>
<td></td>
<td></td>
<td>VVTRP</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In step 03, the system accesses transfer price variant TP. The value found for this step is entered in value field VVTRP.
Data Update with Multiple Valuations

Features

Actual Data Update

Actual data created using profit center valuation (transfer prices) is updated in the same tables in CO-PA as data created using legal valuation. These are tables CE1xxxx and CE3xxxx, where "xxxx" is the name of the operating concern.

The two valuations are separated from one another technically by different values in the field PALEDGER (currency type). Including the two database currencies (operating concern currency and company code currency), which are likewise separated using the field PALEDGER (see Updating Two Currencies in CO-PA [Seite 37]), the following valuation approaches, or combinations of valuation and currency type, are available in CO-PA:

<table>
<thead>
<tr>
<th>Valuation approach</th>
<th>Valuation</th>
<th>Currency type</th>
</tr>
</thead>
<tbody>
<tr>
<td>B0</td>
<td>Legal</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>10</td>
<td>Legal</td>
<td>Company code currency</td>
</tr>
<tr>
<td>B2</td>
<td>Profit center</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>12</td>
<td>Profit center</td>
<td>Company code currency</td>
</tr>
</tbody>
</table>

During data update, the system creates, valuates, and posts the line items for legal and profit center valuation separately.

External billing documents are updated in both legal and profit center valuation.

Since the profitability segment is the same for all valuation approaches, derivation only needs to be carried out once for all the line items. Valuation, on the other hand, is carried out separately for the line items for legal and profit center valuation. If necessary, the values in each valuated line item are translated to the operating concern currency (currency types B0 and B2) and the company code currency (currency types 10 and 12).

Finally, the system issues document numbers and posts the line items. Note that the line items belonging to a billing item are all posted with the same document number. The different valuation approaches are indicated by the different currency types.

This update process is the same for settlement of internal orders, sales orders, and projects, as well as for direct postings from Materials Management (MM) and Financial Accounting (FI).

Internal transfers are only relevant for profit center valuation and are therefore only updated with currency types B2 and 12 in CO-PA.

Incoming sales orders, customer rebate agreements, manually created CO-PA line items, and external data are only updated with legal valuation.

Production variances can only be updated in detail according to variance categories for legal valuation in the operative version 000. However, production variances as a total can also be updated in profit center valuation. This is possible by extending the FI posting (production variances to factory service accounts) to Profitability Analysis. This is made technically possible by assigning the production variance account to Profitability Analysis during automatic account assignment. In this way, the production variances are also placed as a total in an extra value field that can be used in all active valuations. The value fields are assigned via the PA transfer structure FI, as in other FI direct assignments.
Data Update with Multiple Valuations

The following table summarizes how the individual actual value flows are updated in CO-PA:

<table>
<thead>
<tr>
<th>Value flow is updated in...</th>
<th>Legal valuation</th>
<th>Profit center valuation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Billing documents</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Internal order settlement</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Sales order settlement</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Project settlement</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Direct postings from FI</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Direct postings from MM</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Internal goods transfers</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Overhead</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Incoming sales orders</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer rebate agreements</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Manually created CO-PA line items</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>External data transfer</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Production variance categories</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Production variances as a total</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

**Planning**

You can plan in either the profit center valuation view or the legal valuation view. You need to specify the desired valuation approach (currency type) when you define the plan version. As a result, line items are only updated with one currency type in each plan version.

For more information on planning in multiple valuation views, see *Multiple Valuation Views in Planning [Seite 145]*.

**Information system**

You can define reports for analyzing data according to the legal or the profit center valuation view or both.

For more information on reporting on multiple valuation views, see *Multiple Valuation Views in the Information System [Seite 363]*.
Example: Parallel Valuation of Stock Transfers and Billing

This example shows you how actual data is updated when you are using both legal valuation and profit center valuation.

In this business process, the company transfers a material from plant 1 - which is assigned to profit center 1 - to plant 2, which is assigned to profit center 2. Plant 2 then sells the product to a customer outside the group.

In Profitability Analysis, currency types B0 (operating concern currency, legal valuation) and B2 (operating concern currency, profit center valuation) are active.

Both legal valuation (L) and profit center valuation (P) are used in both plants and profit centers. These valuations yield the following data:

<table>
<thead>
<tr>
<th>Plant/PrCtr</th>
<th>Profit center valuation</th>
<th>Legal valuation</th>
<th>Transfer price (TP)</th>
<th>Sale price</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>110</td>
<td>100</td>
<td>170</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>160</td>
<td>120</td>
<td></td>
<td>200</td>
</tr>
</tbody>
</table>
Example: Parallel Valuation of Stock Transfers and Billing

Business Process: Stock Transfer → Billing

PrCtr1

Material P 110,-
L 100,-
TP=170

PrCtr2

Material P 160,-
L 120

Sale to customer
200

CO-PA Information System

Profit Center 1

Report
Internal revenue 170
Internal costs 110
Profit 60

Profit Center 2

Report
Internal revenue 200
COS 160
Pr.diff.(expense) 10
Profit 30

Company Code

Report
Internal revenue 200
COS 120
Pr.diff.(revenue) 20
Profit 100

Relevant Line Items in CO-PA

<table>
<thead>
<tr>
<th>Curr.</th>
<th>Trans.</th>
<th>PrCtr</th>
<th>PPrCtr</th>
<th>Revenue</th>
<th>Int.Revenue</th>
<th>Costs</th>
<th>Internal Costs</th>
<th>Price difference</th>
</tr>
</thead>
<tbody>
<tr>
<td>B2</td>
<td>B</td>
<td>P1</td>
<td>P2</td>
<td>170</td>
<td>110</td>
<td></td>
<td></td>
<td>Stock transfer</td>
</tr>
<tr>
<td>B2</td>
<td>B</td>
<td>P2</td>
<td>P1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Price difference</td>
</tr>
<tr>
<td>B0</td>
<td>B</td>
<td>P2</td>
<td>P1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Price difference</td>
</tr>
<tr>
<td>B0</td>
<td>F</td>
<td>P2</td>
<td></td>
<td>200</td>
<td>120</td>
<td></td>
<td></td>
<td>Externl bill.docs</td>
</tr>
<tr>
<td>B2</td>
<td>F</td>
<td>P2</td>
<td></td>
<td>200</td>
<td>160</td>
<td></td>
<td></td>
<td>Externl bill.docs</td>
</tr>
</tbody>
</table>

Financial Accounting

<table>
<thead>
<tr>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legal</td>
<td></td>
</tr>
<tr>
<td>Inventory</td>
<td>120</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Profit Center</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory</td>
<td>160</td>
<td>Inventory</td>
</tr>
<tr>
<td>Goods from PrCtr</td>
<td>170</td>
<td>Internal revenue</td>
</tr>
<tr>
<td>Price difference</td>
<td>10</td>
<td>Internal balance</td>
</tr>
<tr>
<td>Internal balance</td>
<td>110</td>
<td></td>
</tr>
</tbody>
</table>

Result

1. The internal transfer from plant 1 to plant 2 yields a line item with currency type B2. This goods movement is only relevant for profits from the profit center viewpoint. Consequently, no posting is created from the legal viewpoint (currency type B0).
To update this document in CO-PA, you must assign your accounts "Internal revenues" and "Internal costs" (stock changes) to value fields in Customizing. The profitability segment is determined based on the information contained in the document.

2. The system creates line items for the price differences that arise due to the different stock valuations in the two plants. These line items are not updated automatically in CO-PA. However, you can update them if you assign the price difference accounts to a profitability segment by means of a CO automatic account assignment.

3. The system creates line items with currency types B0 and B2 for the external billing document. Here you can also use CO-PA valuation to copy the manufacturing cost component split from a material cost estimate in CO-PC and add this to the information transferred from the billing document.
Summarization During Transfer to CO-PA

Use

You can summarize multiple items of a sender document into one line item during the transfer to Profitability Analysis (CO-PA).

This summarization reduces the volume in the line item table (CE1xxxx). This is especially useful when you want to transfer large amounts of data from an external system. Moreover, summarizing line items can reduce runtimes during data transfers to CO-PA.

The summarization takes place on a sender document basis (billing document or financial accounting document). It is not possible to summarize the data across multiple documents. The system retains only the document number of the sender document as the proof of origin. Consequently, it is no longer possible to attribute the data in the CO-PA document to the corresponding item of the sender document.

Activities

You can maintain summarization in Customizing under Actual postings → Initial Steps → Summarize data during update. There you will also find examples for summarization.

You can maintain the summarization for billing documents, financial accounting documents and logistic documents such as incoming invoices, goods movement documents and goods receipts for purchase orders. This applies to both external and internal documents. In this case, an external sender document can be either an IDoc (an intermediate document that is imported from an external system via the central interface to accounting) or a BAPI (Business Application Programming Interface).

The indicator “External” can only be selected for the transfer of billing documents. Use the IDoc ACLREC01 (Load Receivable) or the BAPI BILLING for the external data transfer.

See also IDoc Interface Between an External Billing System and Accounting With Update in Profitability Analysis [Seite 404].

Summarization can take place at one of two different points of time:

- **1**: After derivation and valuation
- **2**: Before derivation and valuation

If you choose to summarize before derivation and valuation ("2"), the system can transfer the data to CO-PA more quickly than for "1", since the derivation and valuation functions do not need to be applied to as many line items.
If you summarize before derivation and valuation ("2"), the system runs valuation on the basis of the summarized data. If you have defined scales in valuation, this could lead to incorrect results.
Information System

Purpose

The information system lets you use the drilldown reporting tool for analyzing your profitability data. The data available in Profitability Analysis (CO-PA) can be processed individually and analyzed according to any desired view. The reports are defined in modular fashion, that is to say, the individual elements of each report are defined independently of one another in CO-PA and can be linked in any combination in different reports.

The following reports are examples of traditional reports:

- Object list, displaying the key figures of all values for a characteristic, such as the numbers of all sales areas in one country.
- Contribution margin report for a market segment
- Comparison of contribution margin accounting for several market segments
- Ranking list report

For general information on drilldown reporting and how to work with it, see the cross-application documentation Drilldown Reporting [Extern].

This documentation provides information specifically about working with drilldown reporting in Profitability Analysis.
Functions in the Information System

The CO-PA information system uses an online reporting tool - called "drilldown reporting" - which lets you evaluate the data collected in Profitability Analysis. With this tool you can select the desired dataset according to any of the characteristics in your CO-PA system.

You can carry out standard profitability reports as well as reports that analyze line items (see Analysis Types [Seite 332]).

When you use the interactive drilldown reporting tool, you can draw on any important business indicators (key figures) you wish. You can also perform variance analyses (plan/actual comparisons, fiscal year comparisons, comparisons of profitability segments, and so on). You can display several profitability segments for any key figure, or several key figures for any profitability segment.

You can choose between different output types for displaying a drilldown report. For example, with graphic report output, you can split the report into different information areas. With classic drilldown, you can use a range of drilldown functions to navigate in the dataset (for example, you can move from one segment to the next level or the next segment within a level, deactivate a level, switch between detail and overview lists, and display the origins of the data).

Drilldown reporting offers you a number of other functions for editing online reports (conditions, sort orders, top n lists and so on). The information system also has interfaces to SAP graphics, SAPmail and the ABAP List Viewer. Other than the dialog functions, the information system also provides functions for printing reports or calling up inSight (see Connection to inSight [Seite 353]).

When you execute a report, you can "freeze", or save the selected report data so that it can be called up again later. This leads to improved response times when you display report data.

The drilldown functions are divided into three levels that differ in the number of functions available. Each user can choose or be assigned the function level that suits his or her requirements.

See also:

To obtain CO-PA-specific information about drilldown reporting, choose the respective Information System section in this documentation. For general information about drilldown reporting, see the cross-application online documentation Drilldown Reporting [Extern].
Analysis Types

The CO-PA information system provides you with a number of different ways to analyze your profitability data.

- You can define and display **profitability reports** to analyze the characteristics that are contained in the segment level for your operating concern. You define and display profitability reports using the functions of drilldown reporting. For more information, see Reports [Extern] in the cross-application documentation Drilldown Reporting.

- You can define and display **line item analyses** to analyze additional characteristics that are not contained in the segment level. There are two different types of line item analyses:
  - **Line item list**
    You can define the columns for your line items lists by modifying the standard layout and defining variants, or by defining your own line item layouts in Customizing. For more information, see Line Item Lists [Seite 336].
  - **Report based on line items**
    For reports based on line items, you can define the **rows and columns** yourself just like for profitability reports, and you can analyze these reports using the drilldown reporting functions. For more information, see Reports Based on Line Items [Seite 341].
Defining Profitability Reports

Use

When defining your profitability report, you specify the different analysis criteria mainly by selecting characteristics and value fields.

Procedure

You can access the functions for defining reports from Customizing or from the CO-PA application menu. From the initial screen for defining a report, you can use tab pages to access - in any order you wish - any of the components of the report to be selected or processed.

Selecting Characteristics

You find all the characteristics of the operating concern in the Characteristics tab page. In this tab page, you can select the ones that you want to analyze. The characteristics that you select then form the different dimensions of the "data cube" that you wish to analyze. If characteristic groups have been defined for the operating concern, you can select one of those available in the Characteristic group field. If you enter a characteristic group, the system only displays the characteristics in that group, instead of all the characteristics of the operating concern.

Note that the amount of data that is called up for processing by the report is determined by the number of characteristics selected and by which characteristics you select.
Defining Profitability Reports

Selecting Key Figures

You find all the value fields of the operating concern in the Key figures tab page. In this tab page, you can select the ones that you want to analyze. If key figure schemes have been defined for the operating concern, you can select one of those available in the Key figure scheme field. In this way, the calculated key figures for the selected key figure scheme are added to the list of value fields.

Note that it is not always necessary to choose key figures for your report. If you are defining a form report that uses a form for which key figures have already been specified, the Key figures tab page is not displayed and you cannot select any key figures here.

Reserving Variables

In the Variables tab page, you can select fields for entry from those that were stored as variables during report definition or in the form you selected. If you want to specify default values for report execution, fill in the fields using the possible entries function. In the case of variables that have been specified in the form, you can enter fixed values for these by deactivating the Entry at execution indicator.

If no variables were used in the report or the form or the only variables used are filled automatically, then this tab page is not displayed.

Specifying Output Type

In the Output type tab page, you specify how the report should be displayed when executed.

- **Graphical report output**
  The report can be compiled using several information areas. For example, the report data in graphic form or an HTML-designed report header can be displayed. You can navigate using Drag & Drop.

- **Classic drilldown**
  The report is displayed as a drilldown list. For information on the functions that are available in this type of report output, see the section Functions in the Report List in the documentation for Drilldown Reporting.

- **Object list (SAP List Viewer)**
  The object list in the SAP List Viewer is a convenient report output type if several characteristics are to be displayed in the lead column.

- **XXL (Spreadsheet)**
  With the list export tool XXL, the report can be sent directly to a spreadsheet program without being started in the SAP System.

  The performance option Read upon each navigation step (see below) is not suitable for this output type because Excel no longer accesses the system after the export.
Specifying Other Options

- Specifying the print layout [Extern]
- Creating comments on the report
- Report assignment [Extern] for the report/report interface
- Enabling access from inSight (see Connection to inSight [Seite 353])

Reports can only be called up from inSight if the inSight indicator has been activated for them.

Making Performance Settings

For each separate report, you specify from where the report should read its data. This setting has a strong bearing on performance during report execution. You can make settings specifying, on the one hand, what type of presummarization is to be applied to the data to be called up (summarization data or summarization level) and, on the other hand, whether the presummarized data is to be supplemented by current line items. For more detailed information about the types of presummarization, see the section Performance in the Information System [Seite 357].

When using summarization data, you can enter whether additional archived data should be read (see also the section Archiving CO-PA Transaction Data [Extern]). If so, data appropriate to the report is read from the archive files for CE3xxxx (in addition to segment level CE3xxxx) when the summarization data is created for the first time and then it is included in the summarization data. It makes sense to do this with reports so that you can compare current data with existing archived legacy data. Archived data is displayed in the report without any particular flag. This means that the report looks as if no data has yet been archived.

If you are using archiving as a means of deleting erroneous data or test data, these two types of data are also displayed in the report and included in the summarization data.

Beside the setting determining which presummarization is to be applied when data is read, you specify how the report is to behave if, at the point of execution, no presummarization exists. For highly summarized reports that would terminate during execution in the absence of presummarization, select the Error message option to prevent such reports from being executed.

Deleting Profitability Reports

If you wish to delete a report, you can do this from the change transaction. However, if you want to delete an entire group of reports, it is easier to do this in Customizing using the Reorganize Reports function.
Line Item Lists

Definition

The line item list is a tool for displaying in the SAP List Viewer (ALV) Grid Control the line items posted to Profitability Analysis.

Use

By restricting your selection criteria (see Data Selection for Line Item Lists), you can display a specific amount of line items in the line item list. The line item list is especially useful for displaying characteristics that you do not use for creating profitability segments and that you have deactivated accordingly in Customizing (by choosing Structures → Define Profitability Segments Characteristics (Segment-Level Characteristics)). In costing-based Profitability Analysis, these characteristics are still filled in the line item and hence listed in the line item list.

You can display either planning data or actual data in a line item list.

If you wish to analyze your line items using the drilldown reporting functions instead of the SAP List Viewer functions, use the line-item based reports.

Structure

Each line item list consists of a header and a list section. The header contains the selection criteria, the number of line items read, the layout or variant used, and the access method.

The way the list area is structured depends on the Layout used in each case. You can define different layouts by tailoring the list area to your requirements (for example, by showing/hiding and moving the characteristics and values in the columns, by sorting rows, and setting filters for specific values) and then saving this view as a layout. You can set one of the layouts as the standard layout. This layout will then be used the next time you call up the line item list. If you do not specify a standard layout, then one of the standard layouts delivered by SAP is used.

Functions in Line Item Lists

A number of SAP List Viewer functions are available with which you can display additional information, such as

- Sort the list according to the values in one column
- Switch the layout
- Return to the standard layout
- Create totals and subtotals for quantity fields
- Hide/Display fields
- ABC analysis

For additional functions, see the documentation on the SAP List Viewers.

Furthermore, you can choose several functions specific to CO-PA, such as

- By choosing Profitability segment, you can display the profitability segment to which the line item is posted.
• Using the function Master data, you can display the billing document, sales order, FI document, or (for periodic valuation) CO-PA original line item that created that line item. In line items from periodic valuation, the reference document number is the document number of the original line item (not in account-based Profitability Analysis).

• By double-clicking the appropriate line, you can display detailed information about the individual line items. The detail display is different depending on the plan/actual indicator and the type of Profitability Analysis.

Integration
You can call up the line item list from a number of different transactions:

• By choosing Actual postings → Display line item, you can then choose to display a specific line item from the line item list, even if you do not know the document number.

• By choosing Information system → Display line item list → Actual

• By choosing Information system → Display line item list → Plan

• From the drilldown report by choosing Goto → Line items (this displays the line items for the data shown in the report)

• From the Change planning data screen by choosing Extras → Display line item
Data Selection for Line Item Lists

Use

To display plan or actual line items in a Line Item List (Information system → Display line item list → Actual/Plan), you need to enter some information for the data selection.

Procedure

Entries Made on the Initial Screen

What you can enter as selection conditions depends on the plan/actual indicator and the type of Profitability Analysis. If you choose Additional selections, you can enter values for the segment level characteristics. The system ignores these in background processing.

The access method determines how the system reads the data - "as posted" or "according to the current structure", and whether it is executed in the background.

- As posted

  Here the system reads the line item tables CE1xxxx and CE2xxxx (where xxxx = operating concern) directly. This option is not available in account-based Profitability Analysis.

- According to current structure

  First the system finds the relevant segment numbers in the segment table. Then it uses these numbers to access tables CE1xxxx and CE2xxxx (costing-based Profitability Analysis) or tables COEP and COEJ (account-based Profitability Analysis).

  If realignments have been made in your system, these two methods will yield different results. In this case the characteristic values stored in the line items do not correspond to the characteristic values stored for the segment number.

  The segment number contains the characteristic values which resulted from the realignments, whereas the line item contains the values to which the data was originally posted.

- Execute in background

  You can execute the line item report in the background to generate a list for printing. To do so, choose Execute in background. The report will start immediately.

  If you wish, you can also define a variant for program RKEB0601. You need to enter the operating concern, the type of Profitability Analysis and the plan/actual indicator. In account-based Profitability Analysis, you also need to specify the controlling area. Once you have created the variant, you can schedule it for processing. For more information, see Background Processing [Extern] in the online documentation Computing Center Management System.
Technical Note

To start the program, choose *Execute*. Before selecting the line items, the system checks whether the selection criteria allow it to use database indexes. If not, a warning appears, telling you to restrict the selection criteria further. The warning also contains a suggestion as to how you could do this.

If you are calling up the line items from within a drilldown report and receive a warning, you should first drill down to a deeper level and then call up line items from there.
Converting Layouts Following Upgrades

Use

As of Release 4.6C, it is no longer possible to create your line item list using line item layouts that were defined in the Report Painter. Instead, you need to use the SAP List Viewer (ALV) Layouts [Extern] (referred to as "display variants" prior to Release 4.6C) and to save your existing line item layouts as ALV layouts.

Procedure

To save your existing line item layouts as ALV layouts, proceed as follows:

1. On the selection screen, enter the line item layout that you wish to convert and call up the list.
2. Choose (Save layout...). If the layout is to be used as your standard layout (initial layout), select the Default values indicator.
3. If you want to convert more line item layouts, choose Extras → Change line item layout and proceed as described above.

Result

The ALV layouts that you saved can now be called up from the selection screen or the line item list.

If you call up the layouts from the selection screen via the Layout field, you can call up the old line item layouts as well as the ALV layouts. The old line item layouts are listed at the end of the possible functions. If an ALV layout and a line item layout have the same name and you select it via the possible entries function, then only the line item layout is used. If, on the other hand, you enter the name manually, then the ALV layout is used as the list structure.
Reports Based on Line Items

Use

A report based on line items [Extern] allows you to display the line items you have in Profitability Analysis. This type of report always reads the line items directly. Unlike the profitability report, it never accesses data from the segment level. In this way, you can analyze characteristics that are contained in line items but were locked out of the segment level in Customizing under segment-level characteristics.

For more information on the terms segment table, segment level, and line item, see Database Tables for CO-PA Transaction Data [Seite 31].

It makes most sense to use reports based on line items when you analyze a relatively small amount of line items, such as when analyzing sales for a given day. More extensive analyses cause very long runtimes.

In contrast to line item lists, which offer you only a limited number of functions, reports based on line items allow you to use all of the navigation and display functions available in drilldown reporting.

The system reads the data according to the current structure. This means that the system selects and displays the characteristic values on the basis of the information in the profitability segment. If a realignment [Seite 62] was performed after the data for a characteristic value was posted, the new assignment is displayed in the line-item-based report.

This type of report is only available in costing-based Profitability Analysis.

Structure

You need to define special forms in Customizing for use with reports based on line items. All other report components, such as key figure schemes, variables, and authorization objects, are common to both types of report.

Reports based on line items let you use the following characteristics:

- Characteristics in the segment level
- Characteristics that were excluded from the segment level
- Date the line item was created
- Person who created the line item

Note that the system requires a large amount of resources for these reports, since it has to read the line items directly. You cannot define them to use summarization levels or summarization data.

If you use this function frequently, you can improve system performance by having your system administration create an appropriate index to the table CE1xxxx or CE2xxxx.
See also:

Since the procedure for creating a line-item-based report is the same as that for creating a profitability report, it is recommended that you also refer to the section Defining Profitability Reports [Seite 333].
Key Figure Schemes

Use

You can analyze a large number of key figures in your reports in Profitability Analysis. These key figures can be either value fields stored in the database or key figures calculated in a Key Figure Scheme [Extern]. A key figure scheme is a group of formulas that define a number of key figures. For example, you can display a contribution margin scheme in the key figure scheme by taking the corresponding values and calculating the extra key figures required.

Two functions are available for defining individual key figures:

- In the Basic formula editor, you can define simple formulas that only use addition and subtraction.
- In the Formula Editor [Seite 345], you can also define more complex formulas.

Structure

The elements can be defined using value fields as well as any other already defined elements of the same key figure scheme. Each element is assigned a unique number, and can also be given a text and special display parameters.

- The value fields defined in your operating concern can be used in all your key figure schemes and have element numbers between 9001 and 9999.
- The user-defined, calculated key figures in a key figure scheme are given the element numbers 1 through 8999.
Key Figure Schemes

On the *Elements in the key figure scheme* screen, you can choose to display an overview list containing all the elements of a key figure scheme and the formulas stored.

As with value fields, you can use the elements of the key figure scheme both in forms and in report definitions.

Since key figures are generally defined in several steps, it makes sense to define several related key figures in the same key figure scheme.

It is possible to represent all the key figures you require in the same key figure scheme. However, it makes more sense to create different key figure schemes for different business purposes, as explained in the following example:

- The first key figure scheme is used for sales management. Consequently, it contains sales data, contribution margins, and key figures based on these (contribution margin/sales, and so on).
- The second key figure scheme is designed according to the needs of the production manager and contains a more detailed breakdown of production costs (variable costs of goods manufactured, setup costs, and so on) along with production-oriented key figures such as setup costs/total costs.

You define key figure schemes in CO-PA Customizing under *Information System → Report Components → Define Key Figure Scheme [Extern]*. When you define a profitability report, you can change an existing key figure scheme or define a new one by choosing *Extras → Key figure scheme*. 
**Formula Editor**

**Use**

The formula editor is used to define key figures in a Key Figure Scheme [Seite 343]. A key figure can be defined as a formula using standard mathematical operations and consisting of key figures or other calculated key figures. You can also program your own ABAP functions.

**Prerequisites**

The operating concern must be defined.

**Features**

- You can call up the formula editor by choosing Change view. The key figures used in the formula can be displayed using their element numbers or texts.
- In addition, you can run a syntax check to check for the following:
  - Undefined formulas
  - Recursive formulas
  - Correct use of operators and parentheses

💡 You should only use the Without check if you need to leave the dialog box before you finish defining the formula. Always choose Check when you finish the formula.

- **User-defined functions**

  The functions for key figure schemes are defined as form routines in include SAPMKEBF. There you can also define your own functions to supplement the existing ones.

  The interface of your forms must adhere to the conventions shown in include SAPMKEBF. This means that the return parameter if declared first and then the input parameters after "USING". Do not define any types.

```abap
FORM notzero USING pe p1.
IF p1 = 0.
  pe = 0.
ELSE.
  pe = 1.
ENDIF.
```

The function "notzero" expects a parameter "p1". If this parameter is not "0", the function returns ("pe") a "1", otherwise it returns a "0".

⚠️ When you call up a key figure scheme, the system reads include SAPMKEBF and analyzes the existing form routines so that they can be displayed using the Possible
Formula Editor

entries function in the formula editor. If the interface does not adhere to the conventions shown above, you cannot use the function in key figure schemes.

When you add further form routines to include SAPMKEBF, you must check the ABAP code and activate include SAPMKEBF.
Characteristic Groups

Use

You can define special characteristic groups for the information system. These groups determine what combination of characteristics is available when you define a report (see Creating Profitability Reports [Seite 333]).

When you define a report, the system offers all the characteristics of the operating concern for selection. However, if you enter a characteristic group, you only receive the characteristics in that group to choose from.

A typical way to use this function might be to group together all the customer-related characteristics which members of your sales department might use when they call up a report. For regional directors, you might define a second characteristic group that contains characteristics relevant to the region, perhaps including some customer-related characteristics.

You can define a specific characteristic group in the user master record using parameter ID MKG. This lets you limit the choice of characteristics for individual users.

You define the characteristic groups in Customizing.
Characteristics Hierarchy

**Definition**

In a characteristics hierarchy, you place the characteristic values for a single characteristic into a hierarchical relationship.

**Use**

In the information system, you can run analyses on a characteristics hierarchy.

**Structure**

A characteristics hierarchy is made up of nodes that can be posted to. These nodes are the characteristic values. Furthermore, you can add to the hierarchical structure by creating nodes that cannot be posted to.

You define characteristics hierarchies in Customizing under Master Data → Characteristic Values → Define Characteristics Hierarchy [Extern].

**See also:**

The section Characteristics Hierarchies [Extern] in the documentation for Drilldown Reporting
SAP Example Profitability Reports

Use

The structures and tables in Profitability Analysis are not delivered by SAP. Instead, the customer creates them in Customizing. For this reason, it is not possible to deliver reports that are ready for productive use. However, to enable you to gain an insight into how profitability reports can be structured, SAP delivers example reports for both costing-based and account-based Profitability Analysis. You can use these as templates for purposeful profitability reports.

Features

The example reports are delivered in operating concern S001 and have the technical names 0-SAPnn. The name of the corresponding key figure scheme is -0. These names were chosen to avoid any conflict with user-defined objects.

You use the technical name to execute, display, or change a report, via the corresponding menu options. These reports are available in all clients of the customer system. However, you can change reports in any client of your system except client 000.

If, after making changes, you want to reset the example report to its original state and call up the delivered SAP example report, you can do this using the function Tools → Production Startup → Import Objects in Customizing. This function imports the reports and related objects from client 0 to your client as these objects were delivered with the standard system.

The following profitability reports are delivered:

Costing-Based Profitability Analysis

<table>
<thead>
<tr>
<th>Report</th>
<th>Technical Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plan/actual comparison</td>
<td>0-SAP01</td>
</tr>
<tr>
<td>Division comparison</td>
<td>0-SAP02</td>
</tr>
<tr>
<td>Ranking list by customer group</td>
<td>0-SAP03</td>
</tr>
<tr>
<td>CM I: Districts/Plants/Material Groups</td>
<td>0-SAP04</td>
</tr>
<tr>
<td>Percentages</td>
<td>0-SAP05</td>
</tr>
<tr>
<td>Comparison: Current Year/Previous Year</td>
<td>0-SAP06</td>
</tr>
<tr>
<td>Quarterly comparison: customer group/material group</td>
<td>0-SAP07</td>
</tr>
<tr>
<td>Quarterly comparison: customer list</td>
<td>0-SAP08</td>
</tr>
<tr>
<td>Quarterly comparison: product list</td>
<td>0-SAP09</td>
</tr>
</tbody>
</table>

Account-Based Profitability Analysis

<table>
<thead>
<tr>
<th>Report</th>
<th>Technical Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost element report</td>
<td>0-SAP01</td>
</tr>
<tr>
<td>Plan/actual comparison in COArea currency</td>
<td>0-SAP02</td>
</tr>
<tr>
<td>Plan/actual comparison in CoCde currency</td>
<td>0-SAP03</td>
</tr>
<tr>
<td>Profit center report</td>
<td>0-SAP04</td>
</tr>
<tr>
<td>Automatic currency translation</td>
<td>0-SAP05</td>
</tr>
</tbody>
</table>
SAP Example Profitability Reports

When you execute a report, you can use pushbuttons to display more detailed information about the individual reports (such as report parameters, layout structure, and comments).
Executing Reports

Use
To analyze your profitability data in drilldown reporting, you execute a report that has been defined in accordance with your requirements.

Features
There are several ways of executing a report:

- You can execute both profitability reports and reports based on line items by choosing Information system → Execute report from the CO-PA application menu.
- From report definition, you can choose to start the respective report.
- You can include your reports in the role menus so that they can be executed directly via a menu option. In this way, you can allow users to access those reports that are relevant to them. For more information on this procedure, see the section Assign Reports/Report Selection to Role [Extern] in Customizing.

Independently of how you execute the report, a selection screen appears. Since it should be as easy as possible for the user to execute a report, most of the settings are made during report definition (see Defining Profitability Reports [Seite 333]) and only a few settings need to be made here:

You specify which data should be read. Moreover, you can change the output type setting made in report definition. To save the effort of having to enter the same values often, you can define selection variants by choosing Goto → Variant → Save as variant and use it to execute the report in the background.
Executing Reports

A drilldown report can select new data when you call it up or you can have it work with a dataset that was saved on a previous occasion (frozen report data). If several options are available, the system displays a dialog box containing all the available options when you run the report. The possible options are as follows:

- **Current data...**, if you selected the option *Display current data* when you defined the report.
- **Data from ...**, if you did not select *Display current data* when you defined the report.
- **Frozen data from ...**, if frozen report data exists for the report.

Then the report is displayed using the output type you set. You can store as frozen report data the displayed status of the report. However, you can only execute this function (menu option *Report → Freeze data*) if given the authorization to store frozen report data.

💡

If all selection characteristics are predefined as standard in the report definition or in the form, the report is executed directly without calling up the selection screen.

**See also:**

For more detailed information, see the section [Executing Reports](#) in the documentation for Drilldown Reporting.
Connection to inSight for SAP R/3

inSight for SAP R/3 is a special version of the PC application inSight, which is suitable for the presentation of data from various R/3 components. It offers an alternative to the SAP-GUI user interface for displaying drilldown reports.

inSight accesses an R/3 System online via an interface. The elements of the individual drilldown reports are then available in inSight. In inSight, you can drag-and-drop the elements of the drilldown report to design a new report. The inSight interface is then actively connected to R/3 using RFC (Remote Function Call). This ensures that both the users who access R/3 via inSight and those who work directly in drilldown reporting have access to the same figures.

Functions in inSight

In an inSight document you can display several drilldown lists and graphics at once, insert bitmaps and configure and position control elements such as radio buttons and push buttons as you like.

You can also use the inSight interface to present reports that use variables or master data hierarchies. You specify the variable or hierarchy when setting up the document in inSight. You can set conditions and change sort orders just as in drilldown reporting. If exceptions were defined in the drilldown report, the corresponding colors are displayed in inSight.

inSight is an ideal tool for the controller or management assistant because of the diversity of its functions. You can, for example, create quite a complex presentation or choose a specific selection of reports relevant to a manager’s area of responsibility. Managers can use inSight as a user interface. Using push buttons and radio buttons, they can call up further data, reports, lists, graphics and pictures. A document can also be created so that navigation through various levels is possible.

inSight for SAP is attractive to managers because it combines the business functionality of SAP R/3 with a convenient, user-friendly interface. There are various display options and you can configure the documents as you wish (see graphic: Drilldown Report in inSight [Seite 356]).

Interface between R/3 and inSight

To display report data from R/3 in inSight, you must first log on to an R/3 system from inSight (see inSight for SAP R/3: Installation and Logging on [Seite 355]). An index of the R/3 reports is then automatically created in the inSight developer mode and is displayed in the inSight database window. When you select a report with the mouse, the report definition is read from R/3 and the drilldown report is opened with RFC. All the necessary data for the report is read from the R/3 database when the report is opened. The data remains in R/3 however, and is transferred individually for each view in inSight. If you wish to display the data according to another characteristic value in inSight, the data is prepared in R/3 for this new selection and then sent to inSight.

Only a selection of drilldown reports are available in inSight. You can determine whether a report can be called up from inSight or not when you are creating or changing a report in R/3 (see Creating a Report [Extern]).

If you want to display data from several SAP R/3 reports in inSight, then inSight logs on to R/3 several times. For each log on, the system uses the same details that you entered when you
Connection to inSight for SAP R/3

logged on first. You can also display report data from other systems in an inSight file. In this case, the logon box appears for each system that data is taken from.

The facility to simultaneously display data from more than one report in an inSight file is available only indirectly (by opening several parallel sessions in the same system). However, overuse of this facility can lead to an excessive load on the system and poorer response times. As a reference, the critical limit lies between 20 and 30 reports per inSight file.
inSight for SAP R/3: Installation and Logging on

Installation

To install inSight for SAP R/3 under the Windows NT operating system you will need Windows NT 3.51 or higher. For installation under the Windows 3.11 and Windows for Workgroups operating systems you need the Win32S Version 1.30 system enhancement.

To enable inSight to communicate with the R/3 system you must install the SAP Automation Server. The Automation Server is delivered with the R/3 system. For more information on the installation of the SAP Automation Server see the BC - SAP Assistant documentation.

Logging on

After you have fulfilled the prerequisites above and installed inSight, you can set up the connection to the R/3 system. Proceed as follows:

1. Call up inSight and open the database window.
2. Click on the Create new connection file button in the database window.
3. In the Create new connection dialog box select the option External database and interface SAP R/3.
4. In the following dialog box, Create new connection, enter a name for the connection file.
5. A dialog box for logging on to the R/3 system is displayed.
   Enter the name of the R/3 system and the client. In addition, enter your R/3 user name, password and the desired language (English or German). You must also fill out the fields with the necessary server and gateway information. The Host Name is the name or IP address of the application server. Enter the R/3 instance number in the field System. The Gateway Host is the name or IP address of the gateway server. The normal entry in the field Gateway Service is sapgw plus the system number, for example sapgw00. If you require more detailed information about these entries you should contact your system administrator or use the menu path Tools → Administration → Monitoring → System monitoring → Gateway monitor.

For general information on inSight see Connection to inSight for SAP-EIS [Seite 353].
Drilldown Report in *inSight*

This is an example of the display options in a drilldown report in *inSight*. You can include graphics, bitmaps, push buttons and radio buttons with the report lists.
Performance in the Information System

The task of the information system in Profitability Analysis is to display data in aggregated form. This involves reading a large amount of data from the database. In the R/3 System, however, the callup of data is optimized in such a way that a large number of transactions process a small amount of data each.

The callup of a large amount of data by one transaction therefore represents an exception. To meet the requirements of this exception, the information system offers two different approaches for calling up data.

- When a report is executed with the first approach, all the data to be analyzed in the report can be loaded into the main memory. All types of navigation are then executed in the main memory. Good performance is only possible, however, if the space used up in the main memory is kept to a minimum.

  Some reports only display a few rows when you call them up (such as the company result) but allow you to drilldown to the characteristics \textit{Customer} and \textit{Product}. When you call up such a report, all data is loaded into the main memory, that is, all possible combinations of customer and product for your enterprise. This means having to load a large part of the segment level into the main memory. However, the capacity of the main memory is usually not sufficient for this.

- With the second approach, only the data that needs to be displayed for the current list is loaded into the main memory when the report is executed. With each navigation step, the system reads data from the database, selecting each time just the data that is required.

  When you execute the report discussed in the above example, only the company data is shown at first. The data at the more detailed levels is then read during drilldown.

The following sections contain a description of how these two approaches are implemented in the system and the considerations that you need to keep in mind.

Reading All Data When Calling Up The Report

When you execute the report using this option, the selected data is loaded into the main memory with the level of detail specified in the report. In the case of very detailed reports, such as those using the characteristics \textit{Customer} and \textit{Product}, it takes a long time to read the data if you have not restricted the scope of the report by making a selection. This method for reading data prevents the report from being called up quickly.

For this reason, any reports for which all data is to be read when you call them up should have a minimal level of detail. Performance can now be enhanced by applying suitable presummarization.

There are three types of presummarization:

- Report-specific \textit{frozen report data}
- Report-specific \textit{summarization data}
- \textit{Summarization data} that is valid across CO-PA
You create report-specific **frozen report data** by executing the report in the background and by choosing the **Rebuild frozen report data** option in the selection. You can also create frozen report data online. You do this in the report display by choosing **Report → Save data**. When you call up the report again using the same selection, you have the option of displaying this frozen report data. If you would like more up-to-date frozen report data, you need to create this data again.

The following types of presupmarization (summarization data and summarization levels) are used during report execution if you specified the appropriate options in the **Options** tab page when you defined the report (see also **Defining Profitability Reports [Seite 333]**).

Report-specific **summarization data** is created automatically the first time you call up a report using the **Use summarization data** option. The initial execution of the report should be performed in the background. The next time you execute the report, the summarization data is read and, if necessary, supplemented by current data, that is, current line items (if the appropriate option has been selected for the report). This current status is displayed in the report. In addition, the summarization data is updated accordingly.

Unlike report-specific summarization data, **summarization levels** are valid throughout Profitability Analysis. As with summarization data, current line items can be read automatically. Summarization levels aggregate the entire database, not just the data that is relevant for a report. You have to build them manually.

For more detailed information, see **Summarization Levels [Seite 369]**.

**Reading Data Upon Each Navigation Step**

With the second approach, only the data that needs to be displayed for the current list is loaded into the main memory when the report is executed. With each navigation step, the system reads data from the database, selecting each time just the data that is required. The prerequisite for being able to navigate in the report with quick response times is having appropriate summarization levels for different navigation levels. Moreover, when defining a report, you should apply the rules concerning form and selection (see the section **Recommendations for Defining a Report below**). If these prerequisites have been met, performance is optimized for drilling down from company results all the way to the line item level of the report, that is, to the lowest level of detail (customer/product).

You activate this function in the **Options** tab page during report definition (using the indicator **Read upon each navigation step**).

Summarization levels are always taken as presupmarization for reports using the option **Read upon each navigation step**. When using this option, you cannot create summarization data or frozen report data because that would require all report data.

External hierarchies are not analyzed until the data has been read upon each navigation step. For this reason, do not use any external hierarchies (or at least as few as possible) to restrict the selected data.

The following example describes how you can call up - for a large number of users - a detailed report with the characteristics *Customer* and *Product*, without slowing down performance.
a. Define a basic report with the user-defined characteristics Sales organization, Customer, and Product (in this order).

b. In the Options tab page, select the Read upon each navigation step option for the report.

c. The system then proposes a summarization level for the report. For this, choose Tools → Summarization Levels → Define Summarization Levels in Customizing and then choose Extras → Proposal for → Reports in the menu.

d. Make two copies of the proposed summarization level and add an asterisk (*) to the levels for the following characteristics:
   - Level 1: Sales organization
   - Level 2: Sales organization and Customer
   - Level 3: Sales organization, Customer, and Product

e. Build the summarization levels (see Building Summarization Levels [Seite 375]).

f. Execute the report.

If you reproduce the above example in your system, you can gradually increase its complexity. This will allow you to gauge at what point and to what extent performance is hampered.

**Recommendations for Defining a Report**

An important way of reducing the amount of data records to be read and thereby enhance performance is by defining your reports appropriately. The following factors are critical for performance:

- **Complexity of the form**
  - The complexity of the form depends on the quantity and type of the characteristics used. Characteristics with few characteristic values are uncritical. Those with many characteristic values, on the other hand, are critical.

- **Depth of the drilldown**
  - In the case of reports that read all data when executed, the level of detail of the drilldown in the report directly influences the amount of data read. The greater the level of detail involved in the drilldown, the greater the amount of data that has to be read.
  - This restriction does not apply in the case of reports for which the data is read upon each navigation step.

- **Size of the selection**
  - The more you restrict the selection in the initial screen for the report, the smaller the amount of data that has to be read.

Consequently, there are several rules that can be applied when defining a report in order to reduce the storage requirements in the main memory:

- Include as few characteristics as possible in the form for a report. In particular, be sure not to include too many characteristics that have many characteristic values.

- Ensure that the drilldown in the report does not go beyond the required level of detail.
Performance in the Information System

- If you need to drilldown to a level of considerable detail, you should restrict the selection made upon report execution as much as possible.

- In any case, avoid the following combination: many detailed characteristics in the report, drilldown to particularly detailed levels, and no selection of characteristic values. A report reflecting the above combination cannot realistically be executed without serious performance problems.

- If possible, use the *Read upon each navigation step* function.
Multiple Currencies in the Information System

Use
You can update all actual data transferred to CO-PA simultaneously in both the company code currency and the operating concern currency. In reports, you can then display both the operating concern currency and the company code currency. This is true of both basic reports and form reports.

Prerequisites
Before you can update data in CO-PA in two currencies, you need to activate the company code currency on the Attributes screen for your operating concern. You do this in Customizing under Structures → Operating Concern → Maintain Operating Concern.

You can activate the company code currency when you first activate your operating concern, or you can activate it later for all subsequent postings.

Activities
When you create a form or a basic report, the system displays a dialog box asking you whether you want to see the values

- In the operating concern currency only or
- In both the operating concern currency and the company code currency

You cannot change this setting once you have saved it.

Based on this setting, the system decides whether or not you can choose the characteristics Company code and Currency type you define the report.

- If you only choose the operating concern currency, the characteristic Currency type is not available. You can choose the company code as a normal characteristic.
- If you choose to report in both currencies, the system requires you to select both of these characteristics in the form or report.

Entries in the Form
In a form, you can place the characteristics "Company code" and "Currency type" in the rows, the columns, or the general data selection, just like any other characteristic. You can display the values in both currencies at the same time, allowing you to analyze currency variances.

If you want to place the characteristics "Company code" and "Currency type" in the rows, you need to define your rows before you define any columns.

See also:
Multiple Currencies in the Information System

Storing Data in CO-PA in Multiple Currencies [Seite 37].

Currency Translation When Only One Currency Is Active

If you are not storing actual data in both currencies, you can still use the function Settings → Currency to translate your report data from the operating concern currency to the currency of the relevant company code using daily or period exchange rates.

For more information, see Currencies [Extern] in the online documentation for drilldown reporting.
Multiple Valuations in the Information System

Use
You can store data in Profitability Analysis in two separate valuation views as well as in two separate currencies (see Updating Two Currencies in CO-PA [Seite 37]). This feature is designed for organizations that

- Treat profit centers like independent companies acting on the market, and therefore want to analyze both external sales and internal sales, such as goods transfers between profit centers, in their profit analyses
- Update both internal and external sales using costs of goods manufactured calculated on the basis of transfer prices

For more information on profit center valuation in Profitability Analysis, see Multiple Valuation Approaches/Transfer Prices [Seite 319].

Features
In the information system, you need to decide what combination of valuation view and currency type you want to analyze with each report. You can choose between the following combinations:

<table>
<thead>
<tr>
<th>Valuation approach</th>
<th>Valuation view</th>
<th>Currency type</th>
</tr>
</thead>
<tbody>
<tr>
<td>B0</td>
<td>Legal</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>10</td>
<td>Legal</td>
<td>Company code currency</td>
</tr>
<tr>
<td>B2</td>
<td>Profit center</td>
<td>Operating concern currency</td>
</tr>
<tr>
<td>12</td>
<td>Profit center</td>
<td>Company code currency</td>
</tr>
</tbody>
</table>

Settings in Report Definition
When you create a basic report or form, the system displays a dialog box asking you which valuation approaches you want to analyze.

- Legal valuation in operating concern currency or
- Either valuation approach in either or both currencies

Here you need to choose the characteristics company code and currency type in the form or report.

⚠️
You can specify different company codes for different cells of the form. If these company codes use different currencies, you will have multiple currencies displayed in your report.

- Legal valuation in operating concern currency

Here you need to choose the characteristic currency type in the form or report.
Currency types B0 (legal valuation in operating concern currency) and B2 (profit center
Multiple Valuations in the Information System

valuation in operating concern currency) allow you to analyze both valuation views in the same report.

Authorizations

If profit center valuation is active in Profit Center Accounting, the system checks authorization object K_TP_VALU when you execute a report in Profitability Analysis. This object contains the fields Controlling area, Valuation view, and Activity.
Account-Based CO-PA in the Information System

The information system has some special features for account-based Profitability Analysis:

- This type of Profitability Analysis uses separate forms, reports, line item layouts, and authorization objects for combinations of characteristics. Apart from the authorization objects for characteristics, account-based CO-PA uses the same ones as costing-based Profitability Analysis.

- You can represent a hierarchy based on the characteristic *Cost element* by specifying a set in Customizing. The following display forms are available:
  - Compact display
  - Line display
  - Asterisk display

- You can display different currencies in the same report:
  - Controlling area currency
  - Company code currency
  - Transaction currency
    For each currency you must enter a currency reference characteristic: controlling area, company code, or foreign currency.

- If you have activated multiple valuations for at least one controlling area belonging to the operating concern, you can use the characteristic *Valuation* to analyze the respective actual data in the different valuation views [Extern]. It is not possible to perform such an analysis on planning data.

  For the case described above, the characteristic *Valuation* is mandatory and must therefore be entered in the respective report. If you wish to analyze actual data, you need to select a value for the characteristic in the Variables tab page during report definition or when you execute the report. However, you may not select a value when analyzing planning data. The following characteristic values are allowed:
  - 0 - Legal valuation
  - 1 - Group valuation
  - Profit center valuation
    The system automatically includes the characteristic *Valuation* in a basic report. In the case of form reports, you have to include the characteristic in the form in order to analyze actual data. For the analysis of planning data, you are not permitted to include this characteristic.

- To analyze line items, you can only use line item lists [Seite 336], and not line-item based reports [Seite 341].
Authorization Objects for the Information System

Definition

SAP provides standard Authorization Objects [Extern] for certain functions in the information system, such as for creating forms and reports. In addition, it is possible to define your own CO-PA authorization objects in Customizing.

Use

The system checks different authorizations depending on what type of analysis [Seite 332] you are executing. You can define authorization objects for the information system and authorization objects specifically for line item analyses.

The following table shows what authorization checks are carried out in the information system:

<table>
<thead>
<tr>
<th>Authorization objects for the information system</th>
<th>Authorization objects for reports based on line items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profitability report</td>
<td>X</td>
</tr>
<tr>
<td>Report based on line items</td>
<td>X</td>
</tr>
<tr>
<td>Line item list</td>
<td>X</td>
</tr>
</tbody>
</table>

💡
For general information about authorization protection, especially on how to protect individual functions, see Tools → Authorization Management in Customizing.
Tools

Purpose
The tools in CO-PA are functions that can be applied to all areas of Profitability Analysis. These include the functions for defining authorizations, defining summarization levels, or importing external data.

The features of each of these functions are described in detail in the separate sections.
Authorizations

The general concept for Users and Authorizations [Extern] applies in Profitability Analysis. You can also use the Profile Generator [Extern] to create a role in which you combine transactions, reports, and web addresses in a menu. The Profile Generator automatically makes authorization objects [Extern] available with which you specify the specific authorizations. From the Profile Generator, you can then generate an authorization profile [Extern] and assign users. When the users you assign logon, the menu for their role appears. They are authorized to perform all the functions contained in that menu.

You can access the Profile Generator in CO-PA Customizing by choosing Tools → Authorization Management → Create Role/Profile and Assign Users [Extern].

Alongside having the system generate authorization profiles automatically, you can also create authorization profiles manually when you are in general administration for the SAP System. However, since this procedure requires you to be familiar with all the SAP authorization components, it is recommended that you use the profile generator.

The individual authorization profiles delivered by SAP are already complete upon delivery. The authorization profile K_RKE_ALL in the delivery system contains all the authorization objects for Profitability Analysis.

The authorization profiles delivered by SAP or those you have created manually can be used in roles. To do this, you first access Authorization Maintenance of the Profile Generator (by choosing Maintain authorization data and generate profiles) and then you need to transfer the data (by choosing Edit → Insert → Authorization → From profile).

The authorization objects in all the cases described above are delivered by SAP. In addition, you can create authorization objects specific to Profitability Analysis for combinations of characteristics and key figures. These protect specific key figures, profitability segments (groups of characteristics) and combinations of these from unauthorized access in planning and the information system. You can create these authorization objects in CO-PA Customizing by choosing Tools → Authorization Management → CO-PA-Specific Authorization Objects.
Summarization Levels

Use

The data in Profitability Analysis is stored at the individual document level. This means, for example, that every item of a sales order is sent to the CO-PA database as a line item. This can lead to a huge amount of data being created. If a report has to read the entire dataset to display data summarized to a high degree, you may experience runtimes of several hours. To improve runtimes, you can reduce the volume of data that has to be read online. You can achieve this via Summarization Levels [Extern], which allow you to create summarized versions of the dataset.

The following graphic shows how the data volume gradually reduces over different levels of summarization. The system can then read the data efficiently at the higher levels online.

Structure

The structure of the summarization types "segment table and segment level" and "summarization levels" are briefly described below: For more information on the terms "segment table" and "segment level", see also the section Database Tables for CO-PA Transaction Data [Seite 31].

Segment Table and Segment Level

The lowest level from which the application can read data is the combined level for the segment table and the segment level. The data from the line items are stored at this level in a primary summarized form (for example, using the sales order number).

- The segment table contains the profitability segments and their characteristic values.
The segment level contains the value fields for the profitability segments and the characteristics of time.

The segment level always contains the most up-to-date data since it is updated simultaneously with each transaction instead of periodically.

The division of this information into two tables according to characteristics (segment table) and value fields (segment level) reduces data volume by eliminating redundancy. This method has two other important advantages:

- **Storing historic data**
  
  If you no longer need the origin information for data from previous periods, you can archive the line items and retain only the segment level.

- **Realigning posted data**
  
  For example, you can retroactively assign a customer to a different sales representative. This only changes the segment table, while the line items retain the assignment they had when you originally posted the documents. No change is necessary in the segment level since the change in the segment table implicitly affects the data for the periods in the segment level.

**Summarization Levels**

A summarization level stores an original dataset in a reduced form. This original dataset describes the individual profitability segments in terms of the amount of characteristics each has. Summarization means that selected characteristics are left out. Any segments in the original dataset that are now identical through having had characteristics removed are combined into a single pseudo-segment in the summarization level.

From the technical point of view, a summarization consists of two tables that have just been generated, the *key table* and the *totals table*. Key table corresponds to the segment table and contains the pseudo-segments produced from the reduced characteristics. The totals table corresponds to the segment level and contains the associated value fields.
The summarization levels can be used in a number of different areas in Profitability Analysis:

- The information system Drilldown Reporting
- To find the tracing factor for cost center assessment
- Manual planning
- Automatic planning
- Transfer to Sales and Operations Planning (SOP)

The following transactions are available for maintaining summarization levels:

- Defining Summarization Levels
- Filling the summarization levels with new data from the segment level
- Updating the summarization levels with the new line items

**See also:**

- [Defining Summarization Levels](#) and [Building Summarization Levels](#) in the SAP Library
- [Defining Summarization Levels](#) in the Implementation Guide (IMG)

In practice, however, companies primarily use just a few of the possible analysis paths. Consequently, it is only necessary to summarize data for a few of the possible combinations.

Each time the system has to select data, it automatically determines which summarization level to collect the data from based on the combination of characteristics specified. If no ideal summarization level exists for the combination of characteristics specified, the system reads from the level that will give you the best response time. In some cases, this may be the segment level.

The following two business transactions are transferred to Profitability Analysis:

Customer 1 buys 10 units of product 1 at 1.00 USD.
Customer 1 buys 40 units of product 2 at 3.00 USD.

This gives you the following profitability segments, segment level entries and line items in Profitability Analysis:

### Segment table

<table>
<thead>
<tr>
<th>Profitability segment</th>
<th>Characteristic &quot;Customer&quot;</th>
<th>Characteristic &quot;Product&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>2</td>
</tr>
</tbody>
</table>

### Segment level
Summarization Levels

<table>
<thead>
<tr>
<th>Profitability segment</th>
<th>Value field &quot;Quantity&quot;</th>
<th>Value field &quot;Revenue&quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>10</td>
<td>10.00</td>
</tr>
<tr>
<td>2</td>
<td>40</td>
<td>120.00</td>
</tr>
</tbody>
</table>

Line items

<table>
<thead>
<tr>
<th>Customer</th>
<th>Product</th>
<th>Profitability segment</th>
<th>Quantity</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>10</td>
<td>10.00</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>2</td>
<td>40</td>
<td>120.00</td>
</tr>
</tbody>
</table>

If this data is to be summarized at the customer level, the characteristic "Product" has to be hidden (that is, the data for this characteristic is summarized). When we do this, operating concerns 1 and 2 are collapsed into one, and we get the following summarization structure:

Key table (corresponds to the segment table):

<table>
<thead>
<tr>
<th>Pseudo object</th>
<th>Customer</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>1</td>
</tr>
</tbody>
</table>

Summarization table (corresponds to segment level):

<table>
<thead>
<tr>
<th>Pseudo object</th>
<th>Quantity</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>50</td>
<td>130.00</td>
</tr>
</tbody>
</table>
Defining Summarization Levels

Use

By defining Summarization Levels [Seite 369], you can store the data in CO-PA in presummarized form. This makes it possible for the system to access the data more quickly.

Activities

You define a summarization level by specifying which characteristics you want to summarize. When you save the summarization level, the system generates two tables in the ABAP Dictionary: the "key table" and the "totals table". These tables only contain the fields required for that particular summarization.

Each summarization level can be created for fixed characteristic values. For example, if you only want to analyze the data for one plant, you only have to store data for that plant in the summarization level. That way you save the memory space which would otherwise be taken up for the other plants in the tables of that summarization level.

Theoretically, you can create up to 5000 summarization levels. However, the more you define, the more memory you will require and the longer it will take to update the summarization levels.

Try to get by with as few summarization levels as possible. For example, you might check once a month whether you need additional summarization levels, or whether you have any which are no longer used and can thus be deleted. This lets you save memory and optimizes the updating process for your purposes.

For more information about how to define summarization levels, see Define Summarization Levels [Extern] in the Implementation Guide (IMG).

Status of Summarization Levels

Each summarization level has a status which tells you whether it can be used. You can use any summarization levels which have the status “active”.

The following statuses are allowed:

- **To be created**: This status is only temporary and appears while you are defining the summarization level. No tables have been generated yet for the level, and you cannot use yet to select data. When you save, the system generates the tables and sets the status to

- **Active, without data**: The summarization level has been defined, and the tables have been generated. However, the level does not yet contain any data, and consequently cannot be used in the information system, planning, and so on. When you first build data in the summarization level (see Supplying Summarization Levels with Data [Seite 375]), the status changes to

- **Active**: The summarization level contains data and can be used in the information system and other functions.
Building Summarization Levels

Use

Before the system can use a summarization level to read data, it needs to be supplied with data. You do this in the application menu by choosing Tools → Summarization levels → Update...

The summarization levels are updated at fixed intervals and not by transaction. You can update them at night, when the system workload is otherwise low. The periodic method also makes it possible to make changes to the summarization levels en masse.

Features

Building Summarization Level Data

Once you have finished defining a summarization level, it retains the status "Active, without data" until you create data for the level. This is referred to as "building" the summarization level. Once you have done this, the status changes to "Active", and you can use the summarization level in the information system, planning and cost center assessment. When you build a summarization level, the system reads the data from the segment level.

Updating Summarization Level Data

In order to keep your summarization levels up to date, you need to update the data on a regular basis. When you do this, the system reads the changes that have been made since you last updated or created the data (so-called "delta method"). The system reads the new line items here. If a large amount of new data exists, it may make more sense to delete the data completely from the summarization level and then create it again.

Schedule a background job to be run periodically (daily) to update the summarization levels. This update is not automatic.

Safety Delta

The delta method relies on a time stamp which is contained in each line item, record in the segment level and summarization level. This time stamp makes it possible for the system to decide which line items are already contained in the summarization level. However, if you are using more than one computer (database/application servers), these could show a slight difference in their system times. The system can correct inaccuracies of up to half an hour by ignoring any postings made in the last half hour.

Do not update summarization levels until at least half an hour after making mass postings, since those records will otherwise not be included in the update.
Uses for Summarization Levels

Once you have created summarization levels and “built” them (supplied them with data), you can use them in the following areas:

- Drilldown reporting
- For finding the tracing factor for cost center assessment
- Manual planning
- Automatic planning
- Transferring planning data to Sales and Operations Planning (SOP)

Each summarization level can be used for any of these areas. For example, if you created a level in order to use it in the information system, you can still use it in manual planning.

The idea behind the summarization levels is that

- the end user no longer has to be concerned with system performance and
- each of the above areas can be used efficiently in the online mode

As a result, you never need to specify which summarization level(s) you want to use when you call up a function. The system automatically finds one that fits your needs and contains the adequate level of detail.

Drilldown Reporting

In reports, you can display

- only the data from the summarization level, i.e. only the data up to the last time you updated the level, or
- the current data, in which case the system reads the summarization level and then adds the line items which have been posted since the last update.
- If no suitable summarization level exists, the system displays a warning.

You determine which the system will display when you define the report (menu Extras → Summarization levels).

You should you use the current data when you want to display data from the current period. Use the most recent summarized data when you want to display data only after the end of the period, i.e. when the data is not going to change anymore.

If you choose to store summarization data for a report, the system creates this data by reading a summarization level. That means that the fewer characteristics you use in the report, the less data the system has to read from the level, and consequently the less time it takes to display the report.

Generating a Default Summarization Level

In the Customizing function for defining summarization levels, you can have the system propose a suitable summarization level. To use this function, choose Extras → Proposal for → Reports...
Uses for Summarization Levels

Drilling Down from Company Results to Line Items

You can use summarization levels and the report/report interface to drill down from the results for your entire company all the way down to the original line items. You do this by creating a number of smaller reports which read summarization levels and can select the data online. You can then call up lower reports from the higher ones using the report/report interface.

For more information about the report/report interface, see
Overview: Report/Report Interface [Extern] and
Working with the Report/Report Interface [Extern].

Another way to drill down to the line item level in a report is to activate the Read upon each navigation step function in the Performance dialog box. To do this, choose Extras → Performance... when you are defining the report. This allows the system to always read the required summarization level (or the segment level) needed for that particular navigation step. This function means that it is no longer necessary for the system to select all the data required for the entire report. Instead, it only reads the data needed for one particular list. However, this also means that you can no longer use some functions that require all the report data at once (such as the function for updating summarization data).

Two-Dimensional Reports

For two-dimensional reports, the system always reads the data from one summarization level.

You defined a form where the first column contains the revenue for Product group A and the second column contains the revenue for Product group B. After your company introduced a new product onto the market, you added a third column to contain the revenue for this product. This column requires the system to read all the data from the detail level Product, even the data for product groups A and B.

Reports such as these read a large number of data records. If this leads to runtime errors when you run the reports online, you need to run them in the background and save the data. You can then call up this data online. For more information, see the section Save [Extern] in the documentation for Drilldown Reporting.

Cost Center Cost Assessment

In cost center cost assessment, the summarization levels are used to determine the tracing factor. Each cycle uses one summarization level. You therefore should not group together segments that require different levels of detail into one cycle.

Segment 1 uses customer groups as the tracing factor, while segment 2 uses product groups. You therefore need a summarization level with the detail level of customer group and product group. If, however, you use two cycles, you can use two different summarization levels -- one with the customer group and one with the product group.
Manual Planning

Due to the design of the system, the more actual data is contained in the segment level, the longer it takes for the system to select planning data from the segment level. Summarization levels make it quicker to select planning data as well. Response times are also quicker when you call up planning data at a higher level after planning bottom-up.

In planning, the system always displays the current figures. Since the summarization levels only contain the data up to the last time the levels were updated, the system also needs to select the line items which have been posted since that time. Every time you change planning data you increase the number of additional line items the system needs to read. When you notice that the time needed to read the line items increases considerably, you should update the summarization levels used. This will reduce the time needed to select the line items. One possible approach would be to update the summarization levels in short intervals (once per hour, for example) in the background.

Transferring Planning Data to Sales and Operations Planning (SOP)

The system can only read from the summarization levels if you have deactivated the flag Only transfer changes. If this flag is active, the system has to read the data from the segment level. For this reason, it may sometimes be more efficient to transfer the entire plan again than to transfer only the changes.

The following characteristics need to be included in the summarization level:

- the characteristic WERKS (Plant) and the characteristic of the level at which you want to transfer the data (product or product group)
- all other characteristics you want to use to further restrict the data selection -- that is, all the characteristics for which you specify a fixed value on the characteristics screen
- the characteristic ALTPERIO (Week/year), if you are using the alternative period type
- the characteristics GJAHR (Fiscal year), PERDE (Period), VERSI (Version) and VRGAR (Record type), which are included in the level by default

Using Summarization Levels Following Realignments

If you carry out realignments, see Effects on Summarization Levels and Summarization Data [Seite 73].
Schedule Manager

Use
In Profitability Analysis, you perform tasks that recur periodically. The order in which these tasks are performed depends either on how they fit into the business context or on technical considerations. These activities typically involve programs that are executed in background processing. The Schedule Manager allows you to group together, schedule, and execute these regularly recurring tasks and to monitor the results of the activities. At period-end closing in particular, you can use the Schedule Manager to control the necessary activities efficiently from a central location.

Integration
The Schedule Manager is a cross-application tool that is mainly used in Accounting. The applications provide programs and transactions that can be added in the Schedule Manager to a task list (across different applications if desired).

Features
The Schedule Manager also lets you define complex sequences of activities and to execute them automatically. You can monitor and analyze the way these sequences are performed. The main components and the main functions of the Schedule Manager are shown in the following graphic. For more information on the Schedule Manager, see the cross-application documentation about the Schedule Manager [Extern].

In Profitability Analysis, you can find a broad variety of functions (both programs and transactions) that can be included in a task list:

- **Period-end closing** functions, such as transferring overhead, periodic valuation, and top-down distribution
- **Data analysis** functions, such as executing reports in the background and value flow analyses
- **System administration** functions, such as building summarization levels, external data transfer, and executing a realignment

- **Planning** functions, such as transferring planning data and executing automatic planning methods

The individual programs and transactions that are available are offered when you create a task. Call up the possible entries function for the *program or transaction* and enter **CO-PA** under *Application*.

The following task lists are delivered by SAP as examples:

- Task list 0-SAP-PAAC contains the recurring activities for actual data in CO-PA
- Task list 0-SAP-ROLE contains activities for cross-application period-end closing
- Task list 0-SAP-PRPL contains activities for cross-application planning
Data Archiving

Use
You can use *data archiving* to reorganize transaction data that has been posted to costing-based and to account-based Profitability Analysis. You can use it to store legacy data that is no longer required in the system and to delete erroneous data or test data.

Features
Archiving includes the following functions:

- Archiving transaction data
- Deletion of transaction data
- Reload of transaction data from the archive
- Archive Management

In the information system within Profitability Analysis, you can define reports that access the archived data.

Archiving can be performed for the following types of data:

- Actual and plan line items
- Segment level data (summarization records for the line items)
- Transaction-based distribution for [Distributed Profitability Analysis](#)

For more information, see the section [Archiving CO-PA Transaction Data](#).

Activities
Call up archiving in the CO-PA application menu by choosing Tools → Archiving. Here you can execute the different functions described above.

The procedures for executing the functions can be found in the following sections of the [Archiving in Controlling](#) documentation:

- [Creating Archive Files (CO-PA)](#)
- [Starting the Deletion Program (CO-PA)](#)
- [Reloading the Archive (CO-PA)](#)

If you wish to display archived data in a report to compare, for example, current data against legacy data, you have to select the "Read archived data also" option in the Options tab page when you create the report. For more information, see the section [Defining Profitability Reports](#).

⚠️ Archive data is displayed in the report without any particular flag. This means that the reports looks as if no data has yet been archived. If you are using archiving as a means of deleting erroneous data or test data, these two types of data are also displayed in the report along with the "genuine" data.
See also:
The section [Introduction](#) for general information on archiving.
Distributed Profitability Analysis (CO-PA)

Use

It is possible to distribute Profitability Analysis (CO-PA) to different SAP Systems which are connected with one another by means of ALE (Application Link Enabling). Thus the systems are still integrated despite the distribution.

Profitability Analysis then runs concurrently on each system. In distributed Profitability Analysis, (new) line items posted in a sender system are also sent to a receiver system which centrally collates the data from the sender systems. Functions such as derivation and valuation occur exclusively in the sender systems.

For information on the general functions for ALE distribution, see the documentation ALE Integration Technology [Extern].

Integration

Distributed Profitability Analysis is supported in both costing-based and account-based CO-PA.

Prerequisites

All profitability analyses that are connected by means of ALE must belong to the same operating concern. All operating concerns should therefore have the same name and the same characteristics in all of the systems. You can achieve this consistency most efficiently by maintaining operating concerns in a central system. Customizing can then be transported into the other systems from this central system.

Features

Costing-Based Profitability Analysis

Distributed profitability analysis supports the distinct handling of logistics and accounting. Sales functions occur in several local logistic systems. Line items and summarizations are posted when data is transferred from sales (SD) to CO-PA. Other applications that run locally and that are connected to CO-PA can post to the local system in CO-PA. This applies, for example, to the settlement of internal orders and to cost center cost assessment. Reports can be drawn up to enable local profitability analysis to occur in the local system. Costing can be distributed to local systems so that valuation can be performed with the material cost estimate in the local systems. Data is sent from the local SD systems that perform CO-PA locally to a central receiver system where the individual CO-PA data is collated centrally. Data transfers for applications running centrally, such as Cost Center Accounting or direct postings from Financial Accounting, occur in the central system Planning from the local systems can be combined in central planning.
Costing-based CO-PA can be implemented by using the message CPxxxx (xxxx = operating concern). You have to generate this message type in Customizing for CO-PA.

There are two methods that can be used for distributed Profitability Analysis in costing-based CO-PA:

- **Transaction-based distribution**
  
  For every CO-PA posting, an IDoc [Extern] in the sender system is sent to the receiver system together with the line item. 
  For more information, see Transaction-Based Distribution [Seite 387].

- **Periodic rollup**
  
  The data is only copied to the receiver system when the rollup function is initiated in the application. 
  For more information, see Periodic Rollup [Seite 389].

Only one of the methods can be activated in a system infrastructure. You should not change method during productive operations since this could create inconsistencies in the data.

**Account-Based Profitability Analysis**

Transaction data in account-based Profitability Analysis is stored as individual CO documents. As in other CO applications, these documents are distributed via message type CODCMT (CO document). The receiver system is always the controlling area system. The
Distributed Profitability Analysis (CO-PA)

functions of the local sender systems are limited to those required for creating the CO documents. This means that total figures are not updated in the local sender systems and it is not possible to create reports.

Activities

You can set up distributed Profitability Analysis in CO-PA Customizing by choosing Tools → Data Transfers Between CO-PA and Other Systems → Distributed Profitability Analysis (ALE) [Extern].
Transaction-Based Distribution

Use

In transaction-based distribution, an IDoc in the sender system is sent for every CO-PA posting to the receiver system together with the line item. New line items from the sender system are posted in the receiver system as copies.

In costing-based Profitability Analysis, the sender and receiver roles of the systems involved are very flexible. Not only can a sender system send data to several receivers, but senders and receivers can also swap roles. Hence system A can send data to system B and B can also send data to A simultaneously.

The basic scenario has thus been enhanced in the following ways (see the section Distributed Profitability Analysis [Seite 384]):

- Actual data posted for the first time in the central system can be sent to one or more local systems. This means that cost center assessments, for example, can be sent to local profitability reports.
- Profit planning can occur in the form of competitive planning between the central and local organizations within the company. In particular, a centrally-planned plan version can also be sent to the local systems. Competitive planning between the central system and the local systems can then take place as a result of using different plan versions.

<table>
<thead>
<tr>
<th>Advantages</th>
<th>Disadvantages</th>
</tr>
</thead>
<tbody>
<tr>
<td>In the receiver system, information remains current and is available at the greatest level of detail.</td>
<td>System workload is made greater since each line item is sent.</td>
</tr>
<tr>
<td>In cases where discrepancies occur between the sender and receiver systems, you can use the synchronization function (see below) to determine exactly which line items in the sender system were sent to the receiver system.</td>
<td></td>
</tr>
</tbody>
</table>

Integration

Integration

In account-based Profitability Analysis, distribution is always transaction-based. In costing-based Profitability Analysis, you have the alternative of performing a Periodic Rollup [Seite 389].

Activities

You can activate transaction-based distribution in CO-PA Customizing by choosing Tools → Data Transfers Between CO-PA and Other Systems → Distributed Profitability Analysis (ALE) → Activate Distributed Profitability Analysis [Extern].

Data Synchronization

To ensure that all the data actually arrived in the central system, you can synchronize the data in your local and central systems. This function is for control purposes only and should not be used to synchronize all your CO-PA data. You perform this function in the CO-PA application menu by choosing Tools → Distribution → Synchronization.
Transaction-Based Distribution

If you suspect that data has not been transferred correctly to the central system, you should first try to locate any differences by calling up the same report in both the local and central systems. Then carry out the same steps in both systems. First, drill down in the report to zoom in on the time period and characteristics for which differences occurred. This may require going all the way down to the line item level.

Once you have done this, you can use the synchronization function to determine the cause of the discrepancy. Examine the cause closely.

Always check the ALE buffer before performing the synchronization function. Buffered data that has not yet been distributed can lead to differences between the systems.
Periodic Rollup

Use

With the periodic rollup, data is only copied to the receiver system when the rollup function is initiated in the application. This can take place on a daily, weekly or monthly basis. The sender system selects the line items, summarizes them if desired, and sends them to the receiver system. The different ways in which senders and receivers can be related are more restricted than in transaction-based distribution [Seite 387] because a sender can only send to one specific receiver. Moreover, data transfer can only take place in one direction. Hence, if a rollup occurs from system A to system B, then system B cannot send any data to system A.

<table>
<thead>
<tr>
<th>Advantage</th>
<th>Disadvantage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Improved performance with the summarization</td>
<td>Loss of information: It is no longer possible to</td>
</tr>
<tr>
<td>option in the sender system</td>
<td>find out which line items were sent to the receiver</td>
</tr>
<tr>
<td></td>
<td>system.</td>
</tr>
</tbody>
</table>

Integration

This function is only relevant for costing-based Profitability Analysis. Account-based Profitability Analysis always uses transaction-based distribution.

Activities

You can activate the rollup function in CO-PA Customizing by choosing Tools → Data Transfers Between CO-PA and Other Systems → Distributed Profitability Analysis (ALE) → Activate Distributed Profitability Analysis [Extern].

You can determine the type of summarization in CO-PA Customizing by choosing Tools → Data Transfers Between CO-PA and Other Systems → Distributed Profitability Analysis (ALE) → Define Segment-Level Characteristics for Distributed CO-PA [Extern].

To perform the rollup in the CO-PA application menu, choose Tools → Distribution → Rollup.
Transferring External Data

Use

If the Sales and Distribution (SD) module is not operational in your company, you can transfer billing data to Profitability Analysis using an external interface. You can also use this interface to transfer other data, such as legacy data.

Features

The interface for external data transfer involves a cross-application component with which the data can be written directly to the corresponding tables in CO-PA.

A log for the transfer is generated so that you can easily identify and rectify any errors that occur (see Evaluation of the Logs).

You can set up the transfer of actual data to CO-PA in such a way so that the system also generates a batch input session, along with the output file, for importing corrected data. For this, use the Batch Input option under Expert Mode. After rectifying any errors, you then have to decide which of the two functions you wish to use for transferring the corrected data records. You are not permitted to use both functions because doing so would cause the data to be posted twice!

The Test Data Editor enables you to test the transfer of external data. You use it to create sequential files and then to fill these files with test data.

Activities

You set up external data transfers to CO-PA in Customizing under Tools → Data Transfer Between CO-PA and Other Systems → CO-PA External Data Transfer [Extern].

To start the transfer, choose Tools → External Data Transfer → Execute in the CO-PA application menu. For more detailed information about the options available in the selection screen, choose.
External Data Transfer

Purpose
You use this component when you want to transfer data from an old/legacy system into the R/3 system using a direct input procedure.

This function is used in the following components:
- Treasury Loan Management (TR-LO)
- SAP Business Partner
- Executive Information System (EIS)
- Profitability Analysis and Market Segment Analysis (CO-PA)
- Bank Customer Accounts (BCA), Profitability Analysis and Risk Analysis for SAP Banking.
- Industry solution Insurance
- Contract Current Accounts (FI-CA)

Features
The data is read and converted from a sequential input file, which you have created using data from your old/legacy system. Before being saved in the R/3 datapool, the data is put through several checks. In the case of an error(s), you can rectify the situation using the error log and additional functions.

To assist you with large masses of data, there is a function with which you can split the input file into several smaller files which can then be transferred at the same time.

In several components there are example programs which you can use as templates for your own program. You can then use an RFC to transfer data from a legacy system in "near time".

For testing purposes, you can create an input file using the test data editor.

Constraints
Selecting data in the source system and creating a sequential input file is not done in the R/3 system.

You can only transfer data which have SAP interfaces in R/3. You can find further information under Transfer Categories in the IMG of the relevant component. Note that there are no transfer categories for some components (CO-PA, for example).
Performing an External Data Transfer

Purpose
This component enables you to transfer data from a legacy or previous/feeder system to the R/3 system and process it in the R/3 system.

Prerequisites
Before starting external data transfer you must have selected the required data from your source system. Additionally, you must have specified the relevant system settings in Customizing of the respective component.

Process flow
Data is transferred from the source systems to the R/3 data pool in the following steps:

1. Acquisition of the source data:
   
   With the help of data selection programs you create a sequential input file (for example, as Excel file that you have to save in CSV format or as (UNIX) text file) to make the required data available for transfer. The data record structure in this file corresponds to the sender structure you define in Customizing. You have the following options for this:

   - You define the **sender structure on the basis of the data pool in your source system**. In this case, the conversion of the sender structure data to receiver structure data takes place by means of transfer rules defined by you.

   - You define the **sender structure identically to the receiver structure of the R/3 system**. In this case, the conversion of the sender structure data to receiver structure data takes place by means of transfer rules defined by SAP. Then the data selection program must supply the data in accordance with the sender structure.

   The file has to be available on the presentation or application server. Within Customizing, you need to have entered logical file names for the physical file paths in which the files are stored. (Refer to the Implementation Guide (IMG) of the respective component under Platform-independent file name assignment). This helps avoid any later adjustments in connection with the respective operating system.

   The data requirements of the R/3 system depend on the transfer categories and other Customizing settings. (Refer to the IMG of the respective component under Transfer categories, and in Treasury and in the industry solution for banks SAP Banking also under Display required/optional fields). Ensure that you do not supply two data records (or logical units in the case of header/item structure) on the same subject (for example, transaction) in one input file. For example, if you enter a new loan and change data of this loan soon afterwards, you may not deliver the resultant data records for transfer in the same sequential file. If the same data records are processed in the same block, (see below), runtime errors occur or there is an error entry in the log.

2. External data transfer
   
   First of all the system checks the parameters assigned at the start of external data transfer. This involves checking the name of the transfer program (corresponds to the sender structure) and the date details. Then the input file is divided into blocks that are processed one after the other. All blocks first pass through conversion. Once this is
completed without termination or conversion errors, the blocks pass through the function part.

a. Conversion part

Every program run starts with the import of the acquired data to an internal table. Then you can trigger a user exit for sender records (see the IMG of the respective component under Enhancements for external data transfer). Then conversion of the sender records to receiver records takes place in accordance with the transfer rules and, depending on Customizing, other conversions such as currency conversion. At this point, in some components there can then be a user exit for receiver records.

If an error occurs during conversion, the transfer is terminated. In this case, no data records are written to the database. The error is noted in the conversion log.

An error-free conversion process results in an internal table containing all the receiver records. The table is made available to external data transfer so that the function part can be carried out.

b. Function part

In the function part, the system also reads the receiver records in blocks and processes these one after the other.
Performing an External Data Transfer

First the system checks whether the delivered and converted data records are complete, logical and filled with permissible values. Incorrect data records are extracted and later forwarded to post processing. The system totally rejects a data record for a transfer category consisting of a header/item structure, even if only part of it is incorrect.

Correct data records are completed in an additional step. In this step, for some transfer categories the system enters certain empty fields (such as the transfer date and the time). Then the records are written in the data pool and the error handling routine is triggered.

The incorrect data records are written in an output file. You name this file when you start external data transfer. The program uses this name and adds other data to it. This helps to identify the output files at a later stage. The system also creates a detailed log for incorrect records.

With this, the program run is completed. If there is a program termination during the function part, you can perform a restart. For more information, see Evaluation of Logs [Seite 397]: Restart.

You always have the option of repeating the entire external data transfer run. Records which have already been imported are recognized by the system and disregarded.

3. Logs and error processing

The system creates a log for every transfer - even an error-free one. This serves as basis for the correction of errors. Several functions are available for this. For more information, see Evaluation of Logs [Seite 397].

The following graphic explains the entire process flow of external data transfer from a technical perspective:
Result
The data from your legacy / previous systems is now in the R/3 data pool and can be processed in the R/3 system.

Special features of a release upgrade in some components
It is possible that a changed receiver structure is delivered with a new release. If a field is added, the system would not enter this field unless it is appropriately adjusted. It could be necessary for you to adjust the sender structure and the sequential input files or the transfer rules to incorporate the additional fields (see the IMG of the respective components under Transfer categories, in Treasury and in the industry solution for banks also in the Required/optional field display in Customizing.

If a field is removed, it is possible that an existing rule no longer refers to a target field. In this case, a transfer can terminate with an error message. For this reason, before other transfers, we recommend you first perform a test run and check the transfer rules. If you have entered complex rules for a transfer program, it is advisable to print these before a release upgrade.
Performing an External Data Transfer
Evaluating Logs

Use

After a data transfer has taken place or been terminated, you can use this function to find and rectify errors.

Features

The system creates a list of all transfer runs in which you can see the statuses of the transfers. The status indicates whether a transfer was completed, or if there were errors. The following statuses are possible:

<table>
<thead>
<tr>
<th>Status</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>❗ Conversion error</td>
<td>The transfer was terminated in the conversion stage. No records were written to the database.</td>
</tr>
<tr>
<td>⚠ Canceled</td>
<td>The conversion was successfully completed, but errors occurred in the subsequent processing. The transfer was therefore not completed. It is possible that no records were written to the database. You can find further information concerning confirmed data records in the detail log.</td>
</tr>
<tr>
<td>🔴🔴 Error</td>
<td>The transfer was completed, but there were business content errors. All of the data records except the ones containing errors were written to the database.</td>
</tr>
<tr>
<td>🔴 Warning</td>
<td>The transfer was completed, but warnings were output to the log. All of the records were written to the database.</td>
</tr>
<tr>
<td>🔴🔴 OK</td>
<td>The transfer was completed without errors or warnings. All of the records were written to the database.</td>
</tr>
</tbody>
</table>

Two logs are written for each transfer which represent the two logical parts of the transfer:

1. Conversion Stage:

   The conversion log is created for every data transfer. The technical aspects of the transfer run are described step-by-step. Errors which prevented the program from running to completion are logged. In the conversion log, you can display all of the sender and receiver records, or just the ones containing errors.

2. Function Stage:

   The detail log is only created if the conversion is completed successfully. It contains information about the checks and the saving of the data for each record which contains errors. If, during a transfer involving header and item structures, only one item from many is incorrect, the whole block will be listed. This includes the header and all items.

   You must always use this log in evaluating whether the transfer occurred successfully, as the messages on the screen and those in the spool directly after the transfer run do not always match those in the log.

When evaluating log entries, note that the messages in an EDT log can change over the course of several releases. Both the content and the name of a message can change. If messages are used in programs you developed, you should check them after changing releases.
**Error Correction**

Sometimes the scope of the imported data does not match the system’s requirements. In this case, you may have to make certain “conceptual adjustments” before you actually correct any errors. You may have to either:

- modify the system’s data requirements in Customizing (that is, modify the data requirements to more closely match the data in the operative system).
- modify the imported data by changing or enhancing your data selection programs (that is, modify the data to be imported to more closely match target system’s requirements).

**Postprocessing**

For transfers which end with status errors, it is possible for you to directly correct the data in each record with contains errors. Afterwards, you can transfer the corrected data records to the R/3 datapool.

**Output File**
You can use the file to make corrections en masse using a small self-authored program. This would be the best option, for example, if a particular field contains an incorrect value in all of the data records. After running such a program, you can restart the data transfer using the output file with the corrected records as the new input file. The name extensions added by R/3 are listed in the detail log. The extensions are such things as the external number, the client, the date, and an indicator whether the data records were saved in sender or receiver format.

**Restart**

Under certain circumstances, the transfer can terminate in the conversion or function stage. This could occur, for example, if there were an overflow of table spaces in the database, a runtime error, or a power outage.

- If this happens, and no data records actually reached the database (which means that there would be nothing listed in the detail log about confirmed data records), then you can simply repeat the transfer after correcting the error(s).
- If all of the data records have already been transferred, then the database condition is "consistent".
- What can cause problems, however, is when the transfer terminates during the function stage. If this happens, there is no way of immediately knowing how many records actually made it to the database. The program will thus note how many data records are confirmed (successfully committed to the database).

A restart makes it possible to repeat the transfer in such a way that the function stage will only be carried out for those data records which were not confirmed the first (previous) time(s). Subsequently, the database will contain consistent records. Afterwards, if necessary, you can edit the data records which contain errors again, just as with every other data transfer.
Evaluating Logs

Use
With this function you can display conversion and detail logs, display sender and receiver records, post process and transfer incorrect sender records and perform a restart.

Procedure
1. Choose the respective Menu Path [Extern].
   This brings you to the screen External data transfer: Evaluate logs.
2. Under Function, choose whether you wish to have a list of the transfer runs (choose Evaluate) or whether you wish to delete logs.
3. In the field Created by, enter the user and in the field Created on the creation period. Choose whether you wish to have the test and update runs displayed, all runs or only transfer runs that were completed with a certain status. If you do not specify a user, the system displays or deletes all selected transfer runs during the specified period in the current client.
4. Choose Execute.
   If you chose Evaluate, a list of all selected transfer runs appears.
   The following functions are available:

<table>
<thead>
<tr>
<th>Menu description</th>
<th>Other information</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Conversion log" /></td>
<td>The system displays all messages on the transfer run in a list. You can select the messages according to problem classes by double clicking on the corresponding node on the left of the screen.</td>
</tr>
<tr>
<td><img src="image" alt="Job log" /></td>
<td>The system displays the job logs of background transfers.</td>
</tr>
<tr>
<td><img src="image" alt="Detail log" /></td>
<td>This brings you to the detail log display. For transfers performed in an update run you can have an error message displayed for every incorrect data record by choosing Expand all.</td>
</tr>
<tr>
<td><img src="image" alt="Restart" /></td>
<td>This brings you to the screen External data transfer: Post processing logs. Choose Execute.</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>The system deletes the conversion and detail logs belonging to the selected transfer run.</td>
</tr>
<tr>
<td><img src="image" alt="Post processing" /></td>
<td>Post Processing Incorrect Data Records [Seite 401]</td>
</tr>
</tbody>
</table>
Post Processing Incorrect Data Records

Procedure

1. In the list of transfer runs, select the transfer you wish to edit and choose Post processing. This brings you to a different screen. The displayed list shows the incorrect data records. You can navigate within a data record in this sequential display by means of the arrow buttons in the application toolbar. The data displayed is then Offset [Extern] differently.

2. Select a data record and choose . This brings you to the screen Sender records.

3. Make the necessary corrections.

   If you are correcting several records, you can use the arrow buttons in the application toolbar to navigate between the records.

   Use the three left-hand columns F (front), M (middle) and B (back) in the table to reassign the lines. This makes correcting the data easier if the sender structure has a lot of fields and you do not need to correct the data in all of them. It is not possible to save these settings, meaning that the next time you call up this screen, the fields will again be displayed in the standard fashion. Navigating among the records has no effect on the settings.

4. You can write single or all data records in your own file by choosing File → Physical, entering a name for the file, selecting the data records you wish to write in the file and choosing Write selected.

5. To transfer the corrected data records, select them and choose .

6. If no errors have occurred during the test run, you can transfer the corrected data records by choosing . It is not possible to only transfer part of the incorrect data records after they have been corrected. It is however possible to delete data records from the list before an update run.

Result

The corrected data records are now in the R/3 data pool and can be processed in the R/3 system.
Using the Test Data Editor

Use

With this function you can create sequential files and fill them with test data that you can use for the purpose of testing external data transfer.

Prerequisites

You create the test data each for a certain transfer program or in a certain sender structure. You must already have defined these in Customizing.

Procedure

1. Choose the respective Menu Path [Extern]. A dialog box appears.
2. Enter the name of an existing Transfer program and choose Continue.

   This brings you to the screen Editing sender records. Initially, the displayed list contains only an empty data record.

3. Editing data records:

   • If you wish to create a new file with test data, choose File → File name → Physical. Enter a name - you can choose this at random. If you choose Edit, you then have the option of inserting other records, both new ones or copies. To create the test data, select one or more data records and then choose .

   • If you wish to change an existing file, choose File → File name → Physical or Logical and enter the name of the file with the test data you wish to change. Choose Read file. All data records are then displayed in the list. You can navigate within a data record in this sequential display by means of the arrow buttons in the application toolbar. The data displayed is then offset differently. For a more detailed display and to make changes, choose .

4. On the next screen, enter the test data in the Contents column.

   If you are creating or changing several records, you can use the arrow buttons in the application toolbar to navigate among the records.

   Use the three left-hand columns F (front), M (middle) and B (back) in the table to reassign the lines. This makes entering the data easier if the sender structure has a lot of fields and you do not wish or need to enter data in all of them. It is not possible to save these settings, meaning that the next time you call up this screen, the fields will again be displayed in the standard fashion. Navigating among the records has no effect on the settings.

5. To save your created or changed data, on the previous screen choose Write selected. All selected records are saved.

Result

The files are then stored on your application server.
IDoc Interface Between External Billing and Accounting with Update in CO-PA

Use

The IDoc ACLREC01 makes it possible to transfer data from an external billing system to the accounting applications in the SAP System via the "FI/CO interface". This IDoc corresponds to the communication structure defined by OAG (the Open Application Group) for BODs (business object documents) for importing a billing document from an external system (Load Receivable). If desired, you can update the data in Profitability Analysis (CO-PA) at the same time.

Prerequisites

External billing data is transferred to Profitability Analysis with the record type "F". You do not need to maintain the SD interface in this case, since the data is sent via the segments of the IDoc.

The system valuates the data during the transfer, provided that you have maintained a valuation strategy for the record type "F" in Customizing.

💡 You can choose to summarize the data for each document upon transfer. This makes it possible to reduce the volume of data in the CO-PA line item table and may improve runtimes during the update.

To do this, enter the following in Customizing under Actual postings → Summarize upon data update:

- **Transaction**: SD00 (Billing document)
- **Select the field**: External document

See also Summarization During Data Transfer to CO-PA [Seite 328]

Features

Filling the IDoc Fields

When it generates an operating concern, the system automatically assigns the fields of the IDoc segments to the characteristics and value fields in the operating concern. You can see these assignments under Tools → Data Transfers Between CO-PA and Other Systems → Data Transfer via FI/CO Document → Field Assignment in Customizing.

Because these assignments are only valid in one operating concern, the segment fields of the IDoc can have different semantic meanings in different operating concerns. For example, a segment field might contain the characteristic "Form of manufacture" in operating concern S001 and the characteristic "Strategic business unit" in operating concern ZK23.

Validity Check for Characteristics

Characteristics are transferred using six CO-PA-specific segments (E1KEVA1 through E1KEVA6). These contain all the characteristics and unit of measure fields defined in the operating concern.
When determining the profitability segment from the characteristics, the system checks the validity of the characteristic values. If a value does not exist in the corresponding check table, the system displays an error message.

**Validity Check for Value Fields**

All the value fields are transferred via six segments especially for CO-PA (E1KEVA1 through E1KEVA6). This means that different segment fields in the IDoc need to be supplied with identical values (for example, for FI and CO-PA).

The system does not check whether the values transferred to CO-PA are identical to those transferred to Financial Accounting (FI) in other segments of the IDoc. This is due primarily to the fact that it has to be possible in CO-PA to update Product Cost Planning (CO-PC) with imputed values and the costs of goods manufactured even though they do not result in an FI posting at the time of billing.

⚠️

For this reason, the external system must ensure that the values are correctly sent to the IDoc.

The segments for value fields cannot contain a different currency from that of the other segments of the IDoc.

Note that CO-PA has a special way of handling +/- signs during the update. Revenues, sales deductions and costs are all transferred with a “+” sign. Returns and credit memos are transferred with a “-“. The system calculates net revenues and contribution margins in the information system using the calculation rules stored in a report line structure. Due to this handling, you need to supply identical values with different signs in the different segment fields of the IDoc.

⚠️

The external system needs to ensure that the +/- signs are correct.

**See also:**

For technical information, see Interfaces to Accounting [Extern].
Checking the Flow of Billing Documents

Use

You can use this function to compare the actual data in CO-PA to the corresponding postings made in Financial Accounting (FI). This makes it possible to analyze the flow of values from billing documents in Sales and Distribution (SD) to CO-PA and understand how any differences arose between the different applications.

You can find this function in Customizing in the Tools → Analysis section and in the application menu under Tools → Analyze Value Flows.

Functions

Values in billing documents are assigned to condition types in SD, accounts in FI and value fields in CO-PA. This function shows you a list of the values posted in CO-PA value fields, along with those posted in FI (profit and loss accounts) and SD (condition types). It also shows any differences between the values in CO-PA and SD (Delta CO-PA/SD) and between SD and FI (Delta SD/FI). If there is a difference, you can drill down to the respective billing documents.

Statistical condition types (that do not lead to accrual postings) are marked as such and are included in the SD value. This makes it possible to compare the SD value with the CO-PA value. Since these condition types do not lead to FI postings, their values are not taken into account in the comparison between SD and FI. The delta between SD and FI therefore may not be the same as the actual difference between the SD and FI values.

List Structure

The list is arranged in blocks, each of which contains logically related, hierarchically structured information. Each block typically contains a value field, the condition types assigned to it, and the profit and loss accounts linked to these condition types.

If two condition types post to the same account, they appear together with the corresponding value fields and accounts in one block. At the top of this block, you see a separate total for all the values in that block. Accounts that receive postings from more than one condition type are listed separately again at the end of the block. Wherever possible, the system lists a CO-PA value, an SD value and an FI value for each value field, condition type, or account.

The goods issue posting for a billing document is assigned to the condition type of the category G (such as condition type VPRS). Condition types of this category are specially marked as such. At the account level below condition types of the category G, you can see the accounts of the goods issue postings, and any categories of billing documents that do not require a goods issue are shown without an FI value.

Under Additional condition types you can find the following values:

- Condition types that are not assigned to a value field (the corresponding accounts appear under Additional accounts)
- Non-statistical conditions that are not posted to an account with cost element type 11 or 12 are not transferred to CO-PA.
Under Goods issue, you can see goods issue postings for which the billing document does not contain a condition type of the category G.

For the purposes of reconciliation, two values are shown. These principally cause discrepancies between CO-PA and FI. If you restrict the billing date in the selection screen (for example, to a period), then the following values are displayed:

- **Goods issue in earlier periods**: These are the goods issue values for billing documents that have a billing date falling within the selection interval but for which goods issue precedes the selection interval. These values were therefore posted in CO-PA in the current period but were posted in FI in an earlier period.

- **Nonbilled goods issue**: This applies to goods issue values that, firstly, have a goods issue date falling within the selection interval, but, secondly, that were not billing at the end of the interval (or were not billed at all). These values were therefore posted in FI but not until later in CO-PA, if at all.

### Table: Values and Comparison

<table>
<thead>
<tr>
<th>Value field/Cond. type/Account</th>
<th>Currency</th>
<th>CO-PA value</th>
<th>SD value</th>
<th>FI value</th>
<th>Delta COPA/SD</th>
<th>Delta SD/FI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue, discounts, . . .</td>
<td>DEM</td>
<td>30,000.00</td>
<td>40,000.00</td>
<td>40,000.00</td>
<td>10,000.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Revenue</td>
<td></td>
<td>50,000.00</td>
<td>60,000.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PR00</td>
<td></td>
<td>60,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Misc. discounts</td>
<td></td>
<td>20,000.00</td>
<td></td>
<td></td>
<td></td>
<td>0.00</td>
</tr>
<tr>
<td>PREX</td>
<td></td>
<td>5,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RB00</td>
<td></td>
<td>15,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>DEM</td>
<td>20,000.00</td>
<td>20,000.00</td>
<td>25,000.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>VPRS (G)</td>
<td></td>
<td>20,000.00</td>
<td></td>
<td>25,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Returns</td>
<td></td>
<td>5,000.00</td>
<td></td>
<td>15,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>00004000020</td>
<td></td>
<td>10,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revenue (st)</td>
<td>EUR</td>
<td>35,000.00</td>
<td>35,000.00</td>
<td>25,000.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>PR00</td>
<td></td>
<td>25,000.00</td>
<td></td>
<td>25,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0000800000</td>
<td></td>
<td>25,000.00</td>
<td></td>
<td>25,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PR01 (st)</td>
<td></td>
<td>10,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### +/- Signs

The signs of the SD values are changed to match those of the CO-PA values so that you can easily compare the values directly with one another.

The values for these SD condition types consequently need to have their signs reversed again before they can be compared with the FI values. Any change in sign is shown at each level of the hierarchy with a “+” or “-”.

In some Customizing constellations it may not be possible to compare two hierarchical levels that lie below the same level.
### Checking the Flow of Billing Documents

<table>
<thead>
<tr>
<th>Value field</th>
<th>Cond. type</th>
<th>Account</th>
<th>SD value</th>
<th>FI value</th>
<th>Comparable?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revenue</td>
<td></td>
<td></td>
<td>110.00</td>
<td>90.00</td>
<td>No</td>
</tr>
<tr>
<td>PR00</td>
<td></td>
<td>800000</td>
<td>100.00</td>
<td>100.00</td>
<td>+</td>
</tr>
<tr>
<td>ZU01</td>
<td></td>
<td>801000</td>
<td>10.00</td>
<td>-10.00</td>
<td>-</td>
</tr>
</tbody>
</table>

The aggregated values at the higher level (revenue) cannot be compared. Such unusual cases are marked as exceptions (with a lightning icon).

**See also:**

*Transferring Billing Documents Online [Seite 269]*
Checking Value Flows from Order/Project Settlement

Use
You use this function to trace the flow of values during the settlement sales document items and WBS elements to Profitability Analysis (CO-PA) and to Financial Accounting (FI). In this way, you can determine, for example, whether all sender CO objects (sales order items and WBS elements) were settled completely, or whether a posting was made subsequently to a settled period.

The function for verifying the flows of values from settlements can be found in Customizing by choosing Tools → Analysis and in the application menu by choosing Tools → Analyze Value Flows.

Features
The flow of values usually operates as follows during settlement:

1. First, primary and secondary costs are charged to the sales order item or the WBS element, which contain revenues if applicable.

2. If the object has a Results Analysis Key [Extern], Results Analysis [Extern] is performed at the end of the period. This analysis determines the cost of sales, profitability-related revenues as well as work in process and reserves for imminent loss.

3. These accrued values (or, in the case of objects without a results analysis key, these actual values) are then settled to CO-PA and FI. During the settlement process, the costs of sales and the profitability-related revenues are transferred to CO-PA and the work in process and reserves for unrealized costs are transferred to FI.

The flow of values occurs when the values of all the selected order items and WBS elements are read and balanced.

At the same time, the actual costs and revenues are determined, and a comparison is made. Moreover, all these values that are "to be settled" (although they should have been settled according to the Customizing settings) are also compared to those values that have actually been settled. These comparisons show the sender page of settlement.

The values that are to be settled are also compared to the values posted to CO-PA and FI. In this way, the sender page is compared to the receiver page.

These comparisons are displayed in the system as follows:

The sender page is displayed in the View screen: Two reconciliation formulas - one for costs, one for revenues - are used in order to compare the actual values with the accrued values.

- Actual costs = costs of sales (COS) + work in progress (WIP) - reserves for unrealized costs (RUC)
- Actual revenue = revenues affecting income (AffectInc.) + revenue in excess of billings (Rev.Exc.Bill.) - revenue surplus (RevSurplus)

Furthermore, the credits from settlement are compared to the costs, revenues, and reserves for imminent loss (RIL). In this way, the values that were actually settled (which can be identified in the credits) are compared to the values that should have been settled according to the Customizing settings.
Checking Value Flows from Order/Project Settlement

By opening out the tree, you can differentiate the formulas according to these values with and without results analysis. Displaying the values without results analysis restricts the display of the actual costs, the actual revenues, and the credits from settlement.

By expanding the tree further, you can differentiate the actual values (with and without results analysis) according to cost element.

If a comparison detects differences, the delta is displayed in red. By double-clicking the delta value, you can call up the objects where the difference occurred.

You can use these differences in the credits to identify objects that have not been settled completely.

You can identify objects for which results analysis has not yet been executed by the differences within the two comparative formulas.

The direct comparison between the sender and receiver settlement pages is displayed in the screens View: CO-PA and View: FI. In these views, the values in the CO objects that should have been settled according to the Customizing settings (CO values; these are the accrued values in the case of objects with an results analysis key, otherwise the actual values) are compared to the values that have actually been posted in the receiver application (CO-PA value or FI value). For CO-PA, the display occurs at value field level (VALFLD/FIXVAR). For FI, it occurs at the G/L account level (account).

You can expand the tree to view the values at the higher level in more detail according to cost elements with results analysis categories (CElem/RA cat.) as well as according to the line IDs for results analysis (LineID).

With Swap levels 1 & 2 and Swap levels 1 & 3, you can swap these different examination levels at any time to gain a multi-dimensional view of the data.

Within the value field level (View: CO-PA), you can examine the data in even greater detail in terms of fixed, variable and total costs. To do this, select the value field line and choose Summarize<->Details. This function allows you to change the level of detail of cost elements that have results analysis categories. This means that you can summarize all the results analysis categories for a cost element instead of viewing them individually. The *** icon indicates that the value fields displaying the fixed/variable indicator or coming under the results analysis category are combined.

In the screens View: CO-PA and View: FI, it is not possible to identify which objects have been settled or which have been completely settled.

Current Customizing settings are used to assign sender CO object values to the value fields and G/L accounts in CO-PA or FI. Consequently, the cause of the differences displayed here could be a change in the Customizing settings after the settlement has occurred.

See also:
Settling Orders and Projects [Seite 273]
Technical Aspects of Profitability Analysis

The information contained in these sections is not necessary information for end users of Profitability Analysis.

These sections describe what you can do at the technical level to improve your system’s performance when you create an operating concern.
Index Support for Determination of Segment Numbers

When a document is posted to Profitability Analysis, the system has to find a profitability segment number for the combination of characteristic values supplied by that document. It is extremely important that the system be able to do this as quickly as possible; otherwise, the overall throughput can slow down considerably when you transfer external data or post collective invoices (cases in which you post to a large number of profitability segments at the same time).

This section describes from a technical point of view how the system finds the segment number and addresses potential problems. This information is valid for all releases beginning with 2.1A.

Data Structure of the Segment Table

The most important elements of the segment table CE4xxxx are the segment number, which is found in the key of the table, and the characteristics of your operating concern, which form the data part. Table CE4xxxx is structured as follows:

<table>
<thead>
<tr>
<th>Field name</th>
<th>Key</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>MANDT</td>
<td>X</td>
<td>Client</td>
</tr>
<tr>
<td>AKTBO</td>
<td>X</td>
<td>currently always “X”</td>
</tr>
<tr>
<td>PAOBJNR</td>
<td>X</td>
<td>Profitability segment number</td>
</tr>
<tr>
<td>PASUBNR</td>
<td>X</td>
<td>currently always “0001”</td>
</tr>
<tr>
<td>KNDNR</td>
<td></td>
<td>Customer number</td>
</tr>
<tr>
<td>ARTNR</td>
<td></td>
<td>Material number</td>
</tr>
<tr>
<td>FKART</td>
<td></td>
<td>Record type</td>
</tr>
<tr>
<td>other fixed characteristics</td>
<td></td>
<td></td>
</tr>
<tr>
<td>characteristics defined in the operating concern in Customizing</td>
<td></td>
<td></td>
</tr>
<tr>
<td>additional technical fields</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Each segment number represents a specific combination of characteristic values.

Selection from the Segment Table to Find the Segment Number

When a document (such as a billing document or document from order settlement or external data) is posted to Profitability Analysis, the system needs to determine the appropriate segment number based on the combination of characteristic values supplied by the document. To do this, the system selects from the segment table using all the values specified in the data part. The selection looks like this:

SELECT * FROM CE4xxxx
WHERE AKTBO = “X”
Index Support for Determination of Segment Numbers

AND KNDNR = ...
AND ARTNR = ...
AND FKART = ...
AND (all other characteristics specified)

A client condition is also implicitly specified by the ABAP/4 runtime system!

The Standard Secondary Index

The speed with which the system finds segment numbers in the segment table is extremely important for overall system performance in transferring collective invoices, external data or postings (such as order settlement, direct postings from FI) to profitability segments.

The primary index (index ID 0) to the key of the segment table is not well-suited for the above selection. Consequently, SAP tries to support this special access by means of a suitable secondary index (index ID 1). In the standard system, this index contains some of fixed characteristics which are found in every operating concern:

- MANDT
- AKTBO
- KNDNR
- ARTNR
- BUKRS
- WERKS
- VTWEG

💡 Use of indexes for search queries

An index contains a copy of just a few fields of a database table. In the index these fields are sorted -- in contrast to the data in the table itself. This makes it possible for the system to access the data in the index more quickly. Furthermore, each index entry "points" to the corresponding data record in the table.

When conditions are specified for fields contained in an index during a search request, the system can process part of the search request simply using the data contained in the index. As a result, certain index entries -- and their corresponding data records -- can be ruled out without the system having to read the table directly.

The system then needs to read the data records in the table which correspond to the remaining index entries. Only then can it be determined whether a data record also fulfills the rest of the search request, that is, whether it makes the hit list. The time needed to read complete data records is long, compared with that needed to read the index.

Consequently, one should try to define the index so that the number of data records that need to be read from the table is not much larger than the number of records
that fulfill the search condition. This kind of index is referred to as a selective index, since it performs most of the selection for the search request.

1: Profitability Analysis at the customer/product level

If you are using the characteristics “Customer” and “Product” in the segment level, the system automatically transfers billing documents from SD to CO-PA with that level of detail. Thus when the system searches for the profitability segment number for a billing document item, values for both characteristics “Customer” (KNDNR) and “Product” (ARTNR) are found in the SELECT command. Both of these characteristics have a very large number of values in the segment table (they are selective fields in the segment table). As a result, the secondary index MANDT, AKTBO, KNDNR, ARTNR, BUKRS, WERKS, VTWEG is also selective, and it is possible to determine the profitability segment number quickly.

2: Profitability Analysis at a higher level

Now let us look at a system in which the characteristics “Customer” and “Product” are not segment level characteristics. (See also the chapter Master Data \rightarrow Structures \rightarrow Define Profitability Segment Characteristics (Segment-Lvl Characteristics) in Customizing).

In this case the fields KNDNR and ARTNR are empty in all the records in the segment level CE4xxxx. As a result, the aforementioned index is not selective. In this case the selection for finding the profitability segment number reads:

```
SELECT * FROM CE4xxxx
WHERE AKTBO = "X"
AND KNDNR = "          
AND ARTNR = "                           
AND FKART = fixed value
AND (all other characteristics specified)
```

The problem here is that the selective independent fields (in this case maybe the customer group and division) are specified in the selection but do not occur in the secondary index used. On the other hand, the comparatively less selective fields -- MANDT (usually one value), AKTBO (always "X"), KNDNR and ARTNR (always blank), BUKRS, WERKS and VTWEG (usually only a few different values) -- are contained in the secondary index. When the system reads this index (index range scan), it also has to read all the records of the segment table which contain the specified values for MANDT, AKTBO, KNDNR, ARTNR, BUKRS, WERKS, and VTWEG. In a worst case scenario, this could even be the entire segment table. As a result, the system may read far too much, making the request extremely slow. This in turn affects the runtimes for billing documents considerably.

These examples yield the following rule:
Index Support for Determination of Segment Numbers

**Rule:**
A secondary index is useful for supporting segment number determination if it contains the **logically unrelated, restrictive characteristics** from the segment table. The fields MANDT and AKTBO must be the first fields in the secondary index, otherwise the database system reads the primary index instead.

### 3: A well-suited secondary index

If your system uses the characteristics “Customer” and “Product” in the segment level, you should use an index which contains the fields MANDT, AKTBO, KNDNR and ARTNR. On the other hand, if you are not using “Customer” and “Product”, and if the customer group (KDGRP) and division (SPART) are the independent characteristics, it would make much more sense to use an index with the fields MANDT, AKTBO, KDGRP and SPART. Thus in order to create a suitable secondary index, you need to know the logical hierarchy of characteristics in your operating concern.

**Postings to Several Hierarchical Levels**

The secondary index proposed in the above rule would make it possible for the system to determine the segment number for billing documents quickly. However, another problem arises when you post data from other transactions to another hierarchical level.

### 3.1: External transfer of planning data at a higher level

We will now look at an operating concern which has the customer and product in the segment level, but where planning is done at the customer group (KDGRP) and division (SPART) level. Here too, the secondary index indicated above (MANDT, AKTBO, KNDNR, ARTNR) is adequate for transferring billing documents.

However, when you create plan documents at a higher level, you might have performance problems when the system tries to find the segment numbers. To do that, the system needs to read all the segment table records in which the fields KNDNR and ARTNR are blank. If a large number of these records exists, performance worsens considerably.

### 3.2: Account-based Profitability Analysis

A similar problem arises if you work at the customer/product level in costing-based CO-PA and these characteristics are not used in account-based CO-PA.

As a result, we need to amend the rule stated above. You should not only include the logically unrelated characteristics in the secondary index. Therefore:

**Rule:**
An "optimal" index for supporting segment number determination must contain -- after MANDT and AKTBO -- all the logically unrelated, restrictive characteristics for all the segment number selections (including those on higher levels).
Notes

- The fields MANDT and AKTBO must be the first fields in the secondary index, otherwise the database system reads the primary index instead.

- When you decide which characteristics to use, be sure to consider billing documents, external transfers of plan and actual data, cost center assessment and direct postings to profitability segments.

- Use as few fields as possible in the index. Each additional field takes up disk space and worsens performance.

- The sequence of fields in the index is not relevant for finding segment numbers. However, by choosing the sequence carefully, you may be able to support some other read access.

- Note that an index in the ABAP/4 Dictionary may not contain more than 16 fields.

4: Optimal secondary index

In the above example (actual data at the customer/product level and planning at the customer group/division level), a secondary index consisting of MANDT, AKTBO, KNDNR, ARTNR, KDGRP, SPART would be sufficient. If you also need profitability segments at higher levels (for example, due to cost center assessment), you need to extend this index again.

It does not make sense to create additional indexes (e.g. an index 1 with MANDT, AKTBO, KNDNR, ARTNR and index 2 with MANDT, AKTBO, KDGRP, SPART) instead of extending the first index. Since the selection condition for finding the profitability segment number is always completely specified, the system always uses the same index.

SAP strongly recommends that you replace the SAP example secondary index (index code 001) with a secondary index which is optimized for your particular circumstances.

You can check whether the secondary index you created is actually being used to find segment numbers in transaction ST05 (SQL trace) and with the pushbutton Explain SQL. See also How to Check Whether an Index Is Being Used [Seite 419].

The function Explain SQL shows the database’s access strategy when it processes a SELECT statement. Search for an OPEN or a REOPEN statement for table CE4xxxx in the list view of the SQL trace. Based on the time indicated there (which should lie well below 100 milliseconds), you can obtain an idea of the absolute efficiency of the selected access path.
Index Support for Determination of Segment Numbers
How to Check Whether an Index Is Being Used

Use

Sometimes a suitable index is not used for a selection, even if one exists. Which index is used depends on which optimizer the database system uses. The following tells you how to find out which index the database system uses for a selection.

Procedure

To check whether an index is being used, proceed as follows:

1. Open a second session and choose System → Utilities → Performance Trace there.
2. Select SQL Trace and choose Trace on.
3. In the first window, carry out the action for which you want the system to use the desired index.
4. Choose Trace off and then Trace list.
5. The display generated depends on the database system used. You can find the index used with the function EXPLAIN on the critical statements (PREPARE, OPEN, REOPEN).

If your database system uses a cost-based optimizer, you should carry out step 3 with as representative a data volume as possible, since a cost-based optimizer finds the best index on the basis of statistics.
Index Support for Drilldown Reports

In the section Index Support for Determination of Segment Numbers [Seite 413], we only looked at a single secondary index for the segment table intended to help the system find the profitability segment number for a given combination of characteristic values. In drilldown reporting and in other areas, however, the system queries the segment table in other ways. It therefore makes sense to support these queries with an appropriate secondary index as well.

Following the introduction of multipurpose summarization levels in Release 3.0C, the system should only need to access the segment table directly in rare instances. Still, it does need to read the segment table under the following circumstances:

- When no "adequate" summarization level exists for a query
- When you operate drilldown reporting using report-specific summarization data
- When you want to supply data to a summarization level with a low degree of summarization
- When you want to create a report at the greatest level of detail

⚠️ If more than one index exists for the segment table, the optimizer of the database system may decide to use the "wrong" index. As a result, performance in finding segment numbers may worsen after you create a second secondary index. If this happens, check whether the right index (index ID 1) is being used. See also How to Check Whether an Index Is Being Used [Seite 419].

How to construct an efficient structure of secondary indexes for the segment table depends greatly on which database and which optimizer you use (rule-based or cost-based). For detailed information about how to use summarization levels, see note 83204 in SAPNet.

If you are using report-specific summarization data in drilldown reporting, be sure to read note 21773 in SAPNet as well.
Physical Structure of the Data in CO-PA

The following sections describe the detailed physical structure of the data (physical insertion sequence) and the typical accesses of the dataset.

In the section Physical Distribution of the Data in CO-PA [Seite 423], we will propose a way to distribute the data effectively over larger areas (table spaces, hard drives, striping, and so on).

Documents

Actual line items are stored in table CE1xxxx (where xxxx = operating concern). The system inserts into this table on an ongoing basis (sorted according to time stamp of the insertion point).

In drilldown reporting, cost center assessment, etc., the system accesses the data by this time stamp. Thus the physical insertion sequence corresponds to the typical read access method.

Plan line items are stored similarly in table CE2xxxx and are accessed in the same way. Consequently, this table will not be referred to separately in the following.

Segment Level

The segment level -- CE3xxxx -- contains the data in its first summarized form. The profitability segment number and the period are key fields (along with additional technical fields: plan version, record type, plan/actual indicator, etc.). The data part consists of the value fields.

The data in the segment level is typically sorted by period when it is created (INSERT) and updated during the period. That is, the insertion sequence depends on the random order in which the business transactions occurred and is only sorted roughly according to period (or period block PERBL).

The typical queries search in the segment level with a few (approximately 100) fixed segment numbers (WHERE PAOBJNR IN <List> ...) and a condition of time (... AND PERBL IN ...). Thus the physical insertion sequence does not correspond to the typical read access sequence! The segment level is always accessed via the primary index CE3xxxx__0.

Segment Table

The segment table CE4xxxx contains a unique profitability segment number (the primary key) for each combination of characteristic values (data part) to which data has been posted.

The records are inserted in the order of the profitability segment numbers (albeit only approximately, due to buffering of the segment number assignment on the application servers) and are practically never changed.

Selections from the segment table can generally be divided into two groups:

1. Selections of large data volumes for drilldown reporting, planning or cost center assessment

   Here the system finds all the profitability segment numbers whose combination of characteristic values meets a specified condition (e.g. in a drilldown report). If a suitable index exists, the system uses it to access table CE4xxxx. In that case the access does not correspond to the physical insertion sequence. If no suitable index exists, the system selects using the primary index. To read about how you can improve performance for this type of access, see Physical Distribution of the Data in CO-PA [Seite 423].
Physical Structure of the Data in CO-PA

2. Determination of a profitability segment number based on the known combination of characteristics

   In this case the system finds the profitability segment number when the values of all characteristics are known. To read about how you can improve performance for this type of access, see Index Support for Determination of Segment Numbers [Seite 413].
Physical Distribution of Data in CO-PA

If you have large data volumes, the system may need a lot of time to access the segment level (for example, in order to fill summarization levels with data). Since the standard installation of the SAP System is not optimized for handling large amounts of data in CO-PA, there is a lot of potential for fine-tuning if you distribute data physically among the available hard drives.

The following information is always applicable to Releases 2.1 through 3.0B. Beginning with Release 3.0C, you can use summarization levels so that it is not always necessary to access the segment table and the segment level in the online functions.

However, it is still necessary to access the segment table and segment level when you fill the summarization levels with data, or if you are working with report-specific summarization data as in Release 2.2.

Systems in an I/O-Bound State

In order to avoid increasing the complexity of a standard installation, the tables CE3xxxx and CE4xxxx (where operating concern = xxxx) are always created in the table space PSAPBTABD. The corresponding indexes are found in table space PSAPBTABI.

When reading large data volumes from the segment level, the system accesses the same hard drives a number of times. As a result, these hard drives regularly operate at the limits of their workload capacity and thus represent the limiting factor for the overall performance of the reading procedure. The processors involved are usually have the status "idle" or "wait" during this time.

If this situation occurs, the system is said to be in an “I/O-bound” state. By distributing the data among several hard drives, you can increase the overall performance of the system considerably.

A Simple Way to Improve I/O

In standard installations, the system can typically read about 200,000 records per hour from the segment level. This performance is largely independent of the hardware used.

However, if you have four table spaces available (for example, PSAPCE4D, PSAPCE4I, PSAPCE3D and PSAPCE3I) which are stored on four different hard drives, you can distribute the data in CO-PA as follows:

- Table CE4xxxx in table space PSAPCE4D
- Indexes CE4xxxxx for table CE4xxxx in table space PSAPCE4I
- Table CE3xxxx in table space PSAPCE3D
- Primary index CE3xxxx0 for table CE34xxxx in table space PSAPCE3I

If no data has been posted to Profitability Analysis in your system yet, it makes sense to redefine the parameters for those database objects using the database utility (transaction SE14). Otherwise you will have to back up the existing data before the conversion and then restore it later, a time-consuming process.

This “mini-solution”, which can be achieved with relatively little effort, can usually increase the typical speed at which the system reads the segment level to about 500,000 records per hour.
More I/O Distribution

Despite the increase in performance achieved using the simple data distribution described above, systems with powerful processors will usually still be in an I/O-bound state. In that case, it makes sense to take additional measures to distribute the I/O workload.

Here we will only look at *striping at the hardware level*, which is in most cases supported in a transparent fashion by the database system.

Striping Data Files

In striping, files are created at the operating system level and stored (in small pieces) on as many drives as possible. The idea is that the system reads randomly in this type of file more quickly because the time needed to position the header can be eliminated or performed several times in parallel. Since the file is stored in stripes on the different drives, this is referred to as “striping”.

The drives involved are called “stripe sets”.

The files which are distributed to several drives are subsequently used to create a table space. The database system sees the table space as a consecutive sequence of blocks, which are used for the EXTENTS of a table. The operating concern makes sure that the random read accesses will most likely be performed on different drives. The “width” of a stripe should correspond to the size of the database blocks (generally 8 KB).

Striping for Tables in Profitability Analysis

Because of the way the system accesses data in Profitability Analysis, it makes sense to store the tables CE3xxxx and CE4xxxx (as well as their indexes) in a number of different table spaces in order to steer consecutive read accesses in drilldown reporting to as many physical drives as possible (and thus make it possible to run them in parallel).

See also Physical Structure of the Data in CO-PA [Seite 421].

To achieve as broad an I/O distribution as possible, you should stripe the four table spaces PSAPCE4D, PSAPCE4I, PCAPCE3D and PSAPDE3I as evenly as possible across all the available drives.

Supporting Measures

In addition to the striping, you should also make sure that the physical blocks within the table spaces are being used optimally (e.g. for ORACLE PCTFREE=1 and PCTUSED=99). In addition, the tables should contain as few EXTENTS as possible. That requires a careful volume analysis of the expected data volume.

Security Aspects

When you use stripe sets, you need to be especially careful about backing up your data. Remember that if even one hard drive containing part of a stripe set falls out of service, the entire stripe set usually can no longer be used and needs to be restored from a data backup and the corresponding archive log.

This can be quite time-consuming, especially if you use the “ad-hoc” solution described above (all table spaces striped to all hard drives).

The technical realization of the recommendations given here varies depending on the database and operating systems you are using.