Production Orders (PP-SFC)

Release 4.6C
Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of SAP AG. The information contained herein may be changed without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®, AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide Web Consortium, Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow, SAP EarlyWatch, BAPI, SAPPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com are trademarks or registered trademarks of SAP AG in Germany and in several other countries all over the world. All other products mentioned are trademarks or registered trademarks of their respective companies.
### Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>🚨</td>
<td>Caution</td>
</tr>
<tr>
<td>🎵</td>
<td>Example</td>
</tr>
<tr>
<td>📣</td>
<td>Note</td>
</tr>
<tr>
<td>🧨</td>
<td>Recommendation</td>
</tr>
<tr>
<td>🔧</td>
<td>Syntax</td>
</tr>
<tr>
<td>🤔</td>
<td>Tip</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Creating Components</td>
<td>143</td>
</tr>
<tr>
<td>Reassigning Components</td>
<td>144</td>
</tr>
<tr>
<td>Sorting in the Component Overview</td>
<td>145</td>
</tr>
<tr>
<td>Filtering in the Component Overview</td>
<td>146</td>
</tr>
<tr>
<td>Deleting Components</td>
<td>147</td>
</tr>
<tr>
<td>Backflushing with Stock Shortage</td>
<td>148</td>
</tr>
<tr>
<td>Alternative Items</td>
<td>149</td>
</tr>
<tr>
<td>Discontinuation Data</td>
<td>151</td>
</tr>
<tr>
<td>Batch Determination</td>
<td>154</td>
</tr>
<tr>
<td>Executing Batch Determination</td>
<td>155</td>
</tr>
<tr>
<td>Batch Splits</td>
<td>156</td>
</tr>
<tr>
<td>Splitting Batches</td>
<td>157</td>
</tr>
<tr>
<td>Batch Splits: Requirement Quantities</td>
<td>158</td>
</tr>
<tr>
<td>Batch Key</td>
<td>159</td>
</tr>
<tr>
<td>Production Resources and Tools (PRTs)</td>
<td>160</td>
</tr>
<tr>
<td>Creating Production Resources/Tools as Material</td>
<td>161</td>
</tr>
<tr>
<td>Creating Production Resources/Tools as Equipment</td>
<td>162</td>
</tr>
<tr>
<td>Creating Production Resources/Tools as a Document</td>
<td>163</td>
</tr>
<tr>
<td>Creating Prod. Resources/Tools with a PRT Master Record (Misc.)</td>
<td>164</td>
</tr>
<tr>
<td>Classifying Production Resources/Tools</td>
<td>165</td>
</tr>
<tr>
<td>Linking a Document to a Production Resource/Tool</td>
<td>166</td>
</tr>
<tr>
<td>Releasing/Locking Production Resources/Tools</td>
<td>167</td>
</tr>
<tr>
<td>Maintenance Planning for Production Resources/Tools</td>
<td>168</td>
</tr>
<tr>
<td>Creating PRT Usage Counters</td>
<td>170</td>
</tr>
<tr>
<td>Creating Measurement Documents for PRT Usage Counters</td>
<td>171</td>
</tr>
<tr>
<td>Assigning PRT Usage Counters to Prod. Resources/Tools</td>
<td>172</td>
</tr>
<tr>
<td>Assigning Preventive Maintenance Plans to Prod. Resources/Tools</td>
<td>173</td>
</tr>
<tr>
<td>Deletion of Production Resources/Tools</td>
<td>174</td>
</tr>
<tr>
<td>Deleting Production Resources/Tools with a PRT Master Record</td>
<td>175</td>
</tr>
<tr>
<td>Production Resources/Tools: Setting/Canceling a Deletion Flag</td>
<td>176</td>
</tr>
<tr>
<td>Assignment of Production Resources/Tools to Operations</td>
<td>177</td>
</tr>
<tr>
<td>Assigning Production Resources/Tools to Operations</td>
<td>178</td>
</tr>
<tr>
<td>Production Resources/Tools: Deleting Assignments to Operations</td>
<td>179</td>
</tr>
<tr>
<td>Assignment of Test Equipment to Inspection Characteristics</td>
<td>180</td>
</tr>
<tr>
<td>Assigning Test Equipment to Inspection Characteristics</td>
<td>181</td>
</tr>
<tr>
<td>Trigger points</td>
<td>182</td>
</tr>
<tr>
<td>Standard Trigger Points</td>
<td>183</td>
</tr>
<tr>
<td>Trigger Point Groups</td>
<td>184</td>
</tr>
<tr>
<td>Example: Triggering a Function when Status Changes</td>
<td>185</td>
</tr>
<tr>
<td>Example: Manually Triggering Functions During Confirmation</td>
<td>186</td>
</tr>
<tr>
<td>Example: Linking a User Status to a Reason for Variance</td>
<td>187</td>
</tr>
<tr>
<td>Creating Trigger Points</td>
<td>188</td>
</tr>
<tr>
<td>Trigger Points: Usage</td>
<td>190</td>
</tr>
<tr>
<td>Example: Using the Release Stop Indicator</td>
<td>191</td>
</tr>
<tr>
<td>Availability Check</td>
<td>192</td>
</tr>
<tr>
<td>Checking the Availability of Material</td>
<td>193</td>
</tr>
<tr>
<td>Checking Group</td>
<td>195</td>
</tr>
<tr>
<td>Checking Rule</td>
<td>196</td>
</tr>
</tbody>
</table>

6 April 2001
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Checking Scope</td>
<td>197</td>
</tr>
<tr>
<td>Checking Control</td>
<td>198</td>
</tr>
<tr>
<td>How is the Availability Determined?</td>
<td>199</td>
</tr>
<tr>
<td>At What Level is the Availability Checked?</td>
<td>200</td>
</tr>
<tr>
<td>When is the Availability Checked?</td>
<td>201</td>
</tr>
<tr>
<td>Carrying out an Availability Check</td>
<td>203</td>
</tr>
<tr>
<td>Resetting Checking Result</td>
<td>204</td>
</tr>
<tr>
<td>Collective Availability Check</td>
<td>205</td>
</tr>
<tr>
<td>Collective Availability Check: Criteria</td>
<td>206</td>
</tr>
<tr>
<td>Collective Availability Check: Results</td>
<td>208</td>
</tr>
<tr>
<td>Executing a Collective Availability Check</td>
<td>209</td>
</tr>
<tr>
<td>Checking Availability of PRTs</td>
<td>211</td>
</tr>
<tr>
<td>Execute Availability Check for PRTs</td>
<td>212</td>
</tr>
<tr>
<td>Checking the Availability of Capacities</td>
<td>213</td>
</tr>
<tr>
<td>Preliminary Costing</td>
<td>214</td>
</tr>
<tr>
<td>Cost Elements</td>
<td>215</td>
</tr>
<tr>
<td>Material Costs</td>
<td>216</td>
</tr>
<tr>
<td>Planned Costs for Components</td>
<td>217</td>
</tr>
<tr>
<td>Planned Costs for Material Manufactured In-house</td>
<td>218</td>
</tr>
<tr>
<td>Planned Costs for Material Procured Externally</td>
<td>219</td>
</tr>
<tr>
<td>Production Costs</td>
<td>220</td>
</tr>
<tr>
<td>Planned Costs for Production</td>
<td>221</td>
</tr>
<tr>
<td>Planned Costs for Internal Activity</td>
<td>222</td>
</tr>
<tr>
<td>Setting up a Quantity Structure</td>
<td>223</td>
</tr>
<tr>
<td>Planned Costs for External Processing</td>
<td>224</td>
</tr>
<tr>
<td>Overhead Costs</td>
<td>225</td>
</tr>
<tr>
<td>Overhead Groups</td>
<td>226</td>
</tr>
<tr>
<td>Displaying Costs</td>
<td>227</td>
</tr>
<tr>
<td>Order Release</td>
<td>229</td>
</tr>
<tr>
<td>Release at Order Header Level</td>
<td>230</td>
</tr>
<tr>
<td>Manual Release of Orders</td>
<td>231</td>
</tr>
<tr>
<td>Automatic Release</td>
<td>232</td>
</tr>
<tr>
<td>Collective Release</td>
<td>233</td>
</tr>
<tr>
<td>Executing Collective Release</td>
<td>234</td>
</tr>
<tr>
<td>Release of Operations</td>
<td>236</td>
</tr>
<tr>
<td>Releasing an operation</td>
<td>237</td>
</tr>
<tr>
<td>Material Serial Numbers in Production Orders</td>
<td>238</td>
</tr>
<tr>
<td>As-Built Configuration</td>
<td>240</td>
</tr>
<tr>
<td>Creation of As-Built Configurations</td>
<td>241</td>
</tr>
<tr>
<td>Creating/Changing As-Built Configurations Using the List Input</td>
<td>244</td>
</tr>
<tr>
<td>Creating/Changing As-Built Configurations Using Node Assignment</td>
<td>245</td>
</tr>
<tr>
<td>Inspection Lots</td>
<td>247</td>
</tr>
<tr>
<td>Creating Inspection Lots</td>
<td>248</td>
</tr>
<tr>
<td>Deleting Inspection Lots</td>
<td>249</td>
</tr>
<tr>
<td>Creating Inspection Characteristics</td>
<td>250</td>
</tr>
<tr>
<td>Deleting Operations with Inspection Characteristics</td>
<td>251</td>
</tr>
<tr>
<td>Inspection Lots: Restrictions</td>
<td>252</td>
</tr>
</tbody>
</table>

April 2001
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Missing Parts</td>
<td>253</td>
</tr>
<tr>
<td>Calling Up a Missing Parts List</td>
<td>255</td>
</tr>
<tr>
<td>Backorder Processing</td>
<td>256</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Mail Link</td>
<td>257</td>
</tr>
<tr>
<td>Checking Rule</td>
<td>258</td>
</tr>
<tr>
<td>Calling Up Backorder Processing</td>
<td>259</td>
</tr>
<tr>
<td>Processing Dependent Reservations</td>
<td>260</td>
</tr>
<tr>
<td>Processing Sales Orders</td>
<td>261</td>
</tr>
<tr>
<td>Printing</td>
<td>262</td>
</tr>
<tr>
<td>List Types</td>
<td>263</td>
</tr>
<tr>
<td>Printing: Parameters in Customizing</td>
<td>264</td>
</tr>
<tr>
<td>Printing: Prerequisites</td>
<td>265</td>
</tr>
<tr>
<td>Lists of Operations</td>
<td>266</td>
</tr>
<tr>
<td>Lists for Components</td>
<td>267</td>
</tr>
<tr>
<td>Lists for Production Resources and Tools</td>
<td>268</td>
</tr>
<tr>
<td>Printing Types</td>
<td>269</td>
</tr>
<tr>
<td>Printing from a Production Order</td>
<td>270</td>
</tr>
<tr>
<td>Printing Production Orders</td>
<td>271</td>
</tr>
<tr>
<td>Automatic Printing on Order Release</td>
<td>273</td>
</tr>
<tr>
<td>Printing a Component/Operation List</td>
<td>274</td>
</tr>
<tr>
<td>External Procurement/Processing</td>
<td>275</td>
</tr>
<tr>
<td>External Processing of Operations</td>
<td>276</td>
</tr>
<tr>
<td>External Procurement of Components</td>
<td>278</td>
</tr>
<tr>
<td>Goods Receipt</td>
<td>279</td>
</tr>
<tr>
<td>Changes in the Order</td>
<td>280</td>
</tr>
<tr>
<td>Provision of Components</td>
<td>281</td>
</tr>
<tr>
<td>Scheduling an External Operation</td>
<td>282</td>
</tr>
<tr>
<td>Costs of External Processing/Procurement</td>
<td>283</td>
</tr>
<tr>
<td>Goods Movements</td>
<td>284</td>
</tr>
<tr>
<td>Withdrawing Material Components</td>
<td>285</td>
</tr>
<tr>
<td>Goods Movement Overview</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Splitting Goods Movements</td>
<td>288</td>
</tr>
<tr>
<td>Executing Batch Determination</td>
<td>289</td>
</tr>
<tr>
<td>Executing Stock Determination</td>
<td>290</td>
</tr>
<tr>
<td>Picking</td>
<td>291</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Picking - Execution</td>
<td>293</td>
</tr>
<tr>
<td>Stock Determination</td>
<td>294</td>
</tr>
<tr>
<td>Material Staging</td>
<td>295</td>
</tr>
<tr>
<td>Executing Unplanned Withdrawal of Components for an Order</td>
<td>297</td>
</tr>
<tr>
<td>Automatic Creation of Batches</td>
<td>298</td>
</tr>
<tr>
<td>Delivering to the Warehouse</td>
<td>299</td>
</tr>
<tr>
<td>Automatic Goods Receipt</td>
<td>300</td>
</tr>
<tr>
<td>What Checks are Carried out During a Goods Receipt?</td>
<td>301</td>
</tr>
<tr>
<td>Effects of a Delivery to Stock</td>
<td>302</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Delivery to Stock: Costs</td>
<td>303</td>
</tr>
<tr>
<td>Delivery to Stock: Updates in the Material Master</td>
<td>304</td>
</tr>
<tr>
<td>Delivery to Stock: Updates in the Order</td>
<td>305</td>
</tr>
</tbody>
</table>
Performing a Goods Receipt.................................................................................................................. 306
Confirmations ........................................................................................................................................ 307
Confirmation: Fixed Parameters ............................................................................................................. 310
Confirmation: Variable Parameters ....................................................................................................... 312
Entering Confirmations ........................................................................................................................... 313
  Entering Time Ticket Confirmations ................................................................................................ 316
  Executing Single Screen Entry of Time Ticket Confirmations............................................................ 318
    Settings for Single Screen Entry ...................................................................................................... 320
  Entering Collective Confirmations ....................................................................................................... 321
  Executing Fast entry for Time Tickets .................................................................................................. 323
  Entering a Confirmation for a Time Event ............................................................................................ 324
    Time Event Confirmations ................................................................................................................ 325
  Entering Confirmations at Order Level ................................................................................................. 326
  Confirming Individual Capacities ......................................................................................................... 327
  Determining a Default for Yield .......................................................................................................... 329
Milestone Confirmation............................................................................................................................. 332
  Milestone Confirmation ....................................................................................................................... 333
  Progress confirmation .......................................................................................................................... 335
    Entering Progress Confirmations ..................................................................................................... 338
    Progress Confirmations and Operations with Final Confirmations .................................................. 339
  Summary Confirmations ...................................................................................................................... 340
    Creating Summary Confirmations .................................................................................................... 341
  Standard confirmation .......................................................................................................................... 342
    Entering Standard Confirmations ..................................................................................................... 343
Goods Movements for Confirmation ...................................................................................................... 344
  Determining Quantities for Batch Splits/Parts to be Discontinued...................................................... 346
  Displaying Requested Confirmations .................................................................................................. 347
Displaying Confirmations ....................................................................................................................... 348
Canceling Confirmations ........................................................................................................................ 349
  Canceling Confirmations ...................................................................................................................... 350
  Example: Canceling confirmations ....................................................................................................... 351
Reprocessing .......................................................................................................................................... 352
  Reprocessing Confirmations ............................................................................................................... 353
    Reprocessing Confirmations ............................................................................................................ 355
  Cost Determination Error Processing ................................................................................................ 356
    Starting a New Costing Run .............................................................................................................. 357
  Failed Goods Movements Processing ................................................................................................. 358
    Reprocessing Goods Movements ..................................................................................................... 359
Decoupling Processes Carried out During Confirmation ......................................................................... 360
  Settings for Decoupling Confirmation Processes .............................................................................. 362
    Example: Background Processing .................................................................................................. 363
  Processing Predefined Confirmation Processes .................................................................................. 364
PDC Data Transfer via Communication Channel 2 (CC2) .................................................................... 366
  Download .......................................................................................................................................... 367
  Upload ............................................................................................................................................... 369
  Application Logic of the PDC Data Transfer in CC2 ......................................................................... 370
PP-PDC Interface .................................................................................................................................. 371
Rework .................................................................................................................................................. 374
Rework Operations and Rework Quantities ................................................................. 375
Rework and Confirmation.......................................................................................... 376
Order Settlement..................................................................................................... 377
Requirements for Settlement.................................................................................... 378
  Settlement Profile ............................................................................................... 379
  Settlement Structure............................................................................................ 380
  Settlement Rule.................................................................................................... 381
  Settlement: Standard Settings............................................................................. 382
Calling Up a Settlement Rule................................................................................... 383
Changing a Settlement Rule..................................................................................... 384
Deleting a Distribution Rule..................................................................................... 385
Creating Distribution Rules.................................................................................... 386
Percent Validation................................................................................................... 387
Delivery to Stock.................................................................................................... 388
Settling an Order.................................................................................................... 389
Result of Settlement............................................................................................... 390
Connections Between Delivery and Settlement..................................................... 391
Settlement in the Case of Stock Shortage................................................................. 392
  Example: Settlement in the Case of Stock Shortage.......................................... 393
Settling Scrap.......................................................................................................... 394
  Example: Settling Scrap...................................................................................... 395
Technical Completion of a Production Order......................................................... 396
Closing a Production Order...................................................................................... 397
Archiving Production Orders................................................................................... 398
Order Change Management (OCM)........................................................................ 399
Change Process....................................................................................................... 401
Creation of Initiating Object Records..................................................................... 402
  Change Profile...................................................................................................... 403
Processing Initiating Object Records...................................................................... 404
  Searching for Procurement Elements............................................................... 406
Changing Production Orders.................................................................................. 410
  Executing Process Steps.................................................................................... 412
  Creation of a Simulation Order.......................................................................... 413
  Determination of the Changes.......................................................................... 414
  Executing a Comparison.................................................................................... 415
  Checking Changes............................................................................................. 417
  Processing Change Steps.................................................................................. 419
  Execution of the Changes................................................................................ 420
  Execution with Marked Objects........................................................................ 421
  Confirming or Rejecting Change Actions......................................................... 423
  Overview of the Change Steps......................................................................... 424
  Change Management in the Production Order................................................. 425
Assembly Orders in Order Change Management.................................................. 426
  Completing a Change Comparison................................................................. 428
Mass Processing of Production Orders.................................................................... 429
Mass Processing Functions...................................................................................... 432
Displaying the Application Toolbar with Mass Proc. Functions.............................. 444
Logs ........................................................................................................................................... 445
Executing Mass Processing Online............................................................................................ 446
Scheduling Mass Processing in the Background ...................................................................... 448
Definition of Variants .................................................................................................................. 449
Processing Requests .................................................................................................................. 453
Example: Using Mass Processing ............................................................................................. 454
Setting Up Parallel Processing .................................................................................................... 456
Status .......................................................................................................................................... 457
System/User Status ....................................................................................................................... 458
Displaying a Status ...................................................................................................................... 459
What is a Business Transaction? ............................................................................................... 460
What is a Status Profile? ............................................................................................................. 461
What is a Selection Profile? ......................................................................................................... 463
Creating User Statuses ............................................................................................................... 464
Activating User Statuses ............................................................................................................ 465
Status Change Documents ......................................................................................................... 466
Maintaining Default Settings ...................................................................................................... 467
Displaying Status Change Documents ...................................................................................... 468
Co-Products .................................................................................................................................. 470
Co-Products: Prerequisites .......................................................................................................... 471
Co-Products: Costs ....................................................................................................................... 472
Co-Products: Source Structures ................................................................................................. 473
Collective orders .......................................................................................................................... 474
Creation of Collective Orders ..................................................................................................... 476
Maintaining Collective Orders .................................................................................................... 477
Costs in Collective Orders .......................................................................................................... 478
Release of Collective Orders ....................................................................................................... 479
Example: Releasing Orders and Operations in Collective Orders .............................................. 480
Confirmations in Collective Orders ............................................................................................. 481
Example: Confirming Collective Orders .................................................................................... 482
Posting Sub-Assemblies to Stock in a Collective Order ............................................................... 483
Order Information System .......................................................................................................... 484
Individual Object Lists ................................................................................................................ 485
Calling Individual Object Lists ................................................................................................. 488
Profiles ....................................................................................................................................... 489
Layouts ....................................................................................................................................... 490
Object Overview ......................................................................................................................... 491
Calling Up the Object Overview ............................................................................................... 492
Overall profiles .......................................................................................................................... 493
Selecting and Deselecting Database Objects .............................................................................. 494
Order Progress Report ............................................................................................................... 496
Settings for Order Progress Reports .......................................................................................... 498
Progress Value Determination and Display of Exception Messages .......................................... 500
Functions in the Order Progress Report ..................................................................................... 504
Calling the Order Progress Report ............................................................................................. 507
Assembly Orders ....................................................................................................................... 509
Order Split .................................................................................................................................... 511
Prerequisites ........................................................................................................................................... 515
Examples for Order Split .......................................................................................................................... 516
Executing Order Split ............................................................................................................................... 518
Serial Number Assignment During Order Split ....................................................................................... 520
Operations/Components Not Relevant to MRP ...................................................................................... 521
Activate Purchase Requisition/Reservation ............................................................................................ 523
Product Cost Collector ............................................................................................................................. 524
Production Orders (PP-SFC)

Purpose
This section gives you an overview of the integration of the application component Production Orders (PP-SFC) in the R/3 System and its integration in the component Production Planning and Control.

Production Orders in the R/3 System
Production orders are a fundamental part of Production Planning and Control (PP). PP is fully integrated in the Logistics (LO) component and has, among others, interfaces to

- Sales and Distribution (SD)
- Materials Management (MM)
- Controlling (CO)

Integration of Production Orders in Production Planning
The work processes within a company are executed using orders.

A production order defines which material is to be processed, at which location, at what time and how much work is required. It also defines which resources are to be used and how the order costs are to be settled.

As soon as a planned order or a company-internal requirement is generated from previous planning levels (material requirements planning) shop floor control takes over the information available and adds the order-relevant data to it to guarantee complete order processing.

Production orders are used to control production within a company and also to control cost accounting.

Features
You can use the production order to specify:

- What is to be produced
- When production is to take place
- Which capacity is to process the order
- How much production costs
Production orders can be generated in the following ways:

- From a requirement generated in requirements planning, that is, by converting a planned order to a production order
- Using an assembly order
- Without any previous requirement, that is, by creating it manually

When a production order is created the following actions are carried out:

- A routing is selected, its operations and sequences are transferred to the order
- The bill of materials is exploded and the items in the bill of material are transferred to the order
- Reservations are generated for bill of material items held in stock
- The planned costs for the order are generated
- The capacity requirements are generated for the work centers
- Purchase requisitions are generated for non-stock items and externally-processed operations

**Working with Production Orders**

Separate menus were developed for all the areas in the R/3 System. You can select all the data and evaluations that are needed from the menu. You also have the option of selecting specific processes or overviews using function keys.
Production Order Maintenance

Use

In production order maintenance you can create, change and display production orders. The authorizations that you have determine which of these processing types you can use.

Production order processing is explaining in more detail using creation as an example.

Features

Along with maintenance of order header data and operation data you can also maintain the following data:

- Components

  In the production order, components must always be assigned to an operation. All components that were not already assigned to a specific operation in the routing are assigned by the system to the first operation when the order is created. However, you have the option of adding components from one operation to another.

  You can find more information on maintaining components in the order in Changing Component Data [Page 141].

- Production resources and tools

  Production resources/tools (PRTs) are, in contrast to machines and fixed assets, moveable resources that are not tied to a particular location and can be used several times. In the production order production resources/tools must always be assigned to a specific operation. However, assignment can already take place in the routing.

  You can find more information on production resources / tools in Assignment of Production Resources/Tools to Operations [Page 177].

- Trigger points

  In the production order trigger points must always be assigned to an operation. They are used to execute a specific function if:

  - a confirmation is created for an operation
  - the status of an operation changes

  You can find more information on trigger points in Trigger Points [Page 182].

Other Functions

- Order Comparison

  With order comparison [Page 49] you can represent the effects of changes. In this process, two production orders are compared, or a production order is compared with a temporary production order. A temporary production order is created during order comparison, based on initial data that has changed (for example, a changed purchase order).

- Simulation Order

  You can create Simulation Order [Page 50] to check the effect of changes. They have the same structure as production orders, but have no operational effect.
Creating a Production Order

Use
A production order specifies which material is to be produced, where it is to be produced, which operations are required to do this and on which date production is to take place. It also defines how the order costs are to be settled.

As described in this procedure, production orders can be created manually without being previously requested. Alternatively, they can be automatically created by converting a planned order. During requirements planning (MRP run), planned orders are created at every BOM level to cover requirements. For materials produced in-house, a secondary requirement is also generated when the BOM is exploded, which is necessary for producing the end product or assembly. For externally produced materials, an ordering transaction is initiated when a purchase requisition is generated.

Planned orders generated in the MRP run can be converted individually into production orders from the current stock/requirements list. They can also be grouped together by the MRP run and converted into production orders together. These production orders can be released together.

Procedure
1. Call up the transaction as follows:

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Material</td>
<td>Number of the material to be produced</td>
<td>R</td>
<td>Enter or select via matchcode</td>
<td>Required field</td>
</tr>
<tr>
<td>Production plant</td>
<td>Number of the plant</td>
<td>R</td>
<td>Enter or select via matchcode</td>
<td>Required field</td>
</tr>
<tr>
<td>Planning plant</td>
<td>Number of the plant</td>
<td></td>
<td>Enter or select via matchcode</td>
<td></td>
</tr>
<tr>
<td>Order type</td>
<td>Order type according to usage</td>
<td>R</td>
<td>Enter or select via matchcode</td>
<td>Required field</td>
</tr>
<tr>
<td>Order</td>
<td>Order number</td>
<td></td>
<td>Leave blank or enter (in the case of external assignment)</td>
<td></td>
</tr>
<tr>
<td>Reference order</td>
<td>Number of the reference order</td>
<td></td>
<td>Leave blank or enter if a reference order is to be copied</td>
<td></td>
</tr>
</tbody>
</table>

2. Enter the required data on the initial screen Create Production Order.

<<< Screen print goes here>>>
Creating a Production Order

3. Enter the required data on the General tab page.

<<< Screen print goes here>>>

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total quantity</td>
<td>Total quantity of the material to be produced</td>
<td>R</td>
<td>Change, if necessary</td>
<td></td>
</tr>
<tr>
<td>Scrap portion</td>
<td>Scrap quantity that occurs during production</td>
<td>O</td>
<td>Enter, if required, in the</td>
<td>The system increases the order by this proportion</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>base unit of measure</td>
<td></td>
</tr>
<tr>
<td>Order finish date</td>
<td>Date on which the required quantity of the material is available (requirements date)</td>
<td>D</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Order start date</td>
<td>Earliest date on which order execution can start</td>
<td>D</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Scheduling type</td>
<td>Key which specifies the scheduling type for detailed scheduling (backward, forward and so on)</td>
<td>R</td>
<td>Retain, if necessary</td>
<td>Defines which date is entered by the user and which date is calculated by the system</td>
</tr>
<tr>
<td>Priority</td>
<td>Priority of an order, for information purposes</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Scheduling margin key</td>
<td>Key with which the system determines the required floats (opening period, float after production, float before production, release period)</td>
<td>R</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>

4. To save the order, choose  

To reduce the number of steps you have to work through, you can already release an order when you create it. To release a production order, choose  . In Customizing for Shop Floor Control (Master Data → Define Production Scheduling Profile) you can set up automatic release to take place when an order is created.

Result

The order has the status CRTD (created) and cannot be executed (goods issue, receipt, completion) until it has been released.
Creating a Production Order
Changing a Production Order

Use
Maintenance of the status is the most common reason for changing an order. Unless defined otherwise in a profile, the order receives the status CRTD (created) after it has been created. The order cannot be executed until it has been released (status REL).

Other reasons for changing an order are changes to the order header, components or operations. This mostly occurs when an order is to be created for rework, with the current material as the component.

Change documents can be created when an existing production order is changed, provided corresponding settings have been made in Customizing (Customizing for Shop Floor Control, by choosing Master data → Order → Define Order Type-Dependent Parameters). Change documents for a particular status can be displayed in the status display.

Procedure
1. Call up the transaction as follows:
   
   | Menu path | Logistics → Production → Shop floor control → Order → Change |
   | Transaction code | CO02 |

2. You can change the following order header data:
   - General tab page on the order header

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total quantity</td>
<td>Total quantity of the material to be produced</td>
<td>R</td>
<td>Change, if necessary</td>
<td></td>
</tr>
<tr>
<td>Scrap portion</td>
<td>Scrap quantity that occurs during production</td>
<td>O</td>
<td>Enter, if required, in the base unit of measure</td>
<td>The system increases the order by this proportion</td>
</tr>
<tr>
<td>Order finish date</td>
<td>Date on which the required quantity of the material is available</td>
<td>D</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(requirements date)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order start date</td>
<td>Earliest date on which order execution can start</td>
<td>D</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>
### Scheduling type
- Key which specifies the scheduling type for detailed scheduling (backward, forward and so on)
- **R** Retain, if necessary
- Defines which date is entered by the user and which date is calculated by the system

### Priority
- Priority of an order, for information purposes
- **O** Retain, if necessary

### Scheduling margin key
- Key with which the system determines the required floats (opening period, float after production, float before production, release period)
- **R** Retain, if necessary

---

### Assignment tab page on the order header

### Field name | Description | R/O/D | User action and values | Comments
--- | --- | --- | --- | ---
MRP controller | MRP controller for the order | **O** | **Retain, if necessary** |  
Production scheduler | Production scheduler | **O** | **Retain, if necessary** |  
WBS element | Work breakdown structure element | **O** | **Retain, if necessary** |  
Profit center | Profit center | **O** | **Retain, if necessary** |  
Sequence number | Sequence number | **O** | **Retain, if necessary** | **Used to sort the orders**

---

### Goods receipt tab page on the order header

### Field name | Description | R/O/D | User action and values | Comments
--- | --- | --- | --- | ---
Stock type | Stock type | **O** | **Retain, if necessary** |  

---

April 2001
### Changing a Production Order

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>GR process time</td>
<td>Processing time for goods receipt in days</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Delivery complete</td>
<td>Delivery complete indicator</td>
<td>O</td>
<td>Retain, if necessary</td>
<td>Indicates that the item is to be regarded as closed</td>
</tr>
<tr>
<td>Underdelivery</td>
<td>Tolerance limit for underdelivery</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Overdelivery</td>
<td>Tolerance limit for overdelivery</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Unlimited overdelivery</td>
<td>Unlimited overdelivery allowed</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Storage location</td>
<td></td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Distribution</td>
<td>MRP distribution key</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Batch</td>
<td>Batch number</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Goods recipient</td>
<td>Goods recipient</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Unloading point</td>
<td>Unloading point</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>

*Control tab page on the order header*

<< Screen print goes here>>
### Changing a Production Order

<table>
<thead>
<tr>
<th>Plan cost calc.</th>
<th>Determines planned costs</th>
<th>O</th>
<th>Retain, if necessary</th>
<th>Controls whether planned costs are automatically calculated when you save a network or a production order</th>
</tr>
</thead>
<tbody>
<tr>
<td>CstgVariantAct</td>
<td>Costing variant for actual costs</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Overhead key</td>
<td>Overhead key</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Variance key</td>
<td>Variance key</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Calculates capacity requirements</td>
<td>Calculates capacity requirements</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Exact breaks</td>
<td>Scheduling allowing for breaks</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Automat.</td>
<td>Schedule automatically</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td>Production scheduling profile</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>

- Long text tab page on the order header

Choose **Functions** to access various functions that you can execute for the order.

Choose **Header** to access various functions that you can execute for the order header.

3. To reach the **Operation overview**, choose 🎉. You can change the following operation data:

<< Screen print goes here >>

<table>
<thead>
<tr>
<th>Field name</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work ctr</td>
<td>Work center</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Plant</td>
<td>Plant</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>
Changing a Production Order

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>R/O/D</th>
<th>User action and values</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>Material number</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Reqmts qty</td>
<td>Requirements quantity of the component</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>UoM</td>
<td>Base unit of measure</td>
<td>O</td>
<td>Retain, if necessary</td>
<td>Unit of measure in which the material's stock is managed</td>
</tr>
<tr>
<td>Plant</td>
<td>Plant</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>SLoc</td>
<td>Storage location</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>Blf</td>
<td>Backflush</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
<tr>
<td>SP</td>
<td>Special stock indicator</td>
<td>O</td>
<td>Retain, if necessary</td>
<td></td>
</tr>
</tbody>
</table>

You can find more fields that can be changed on the operation tab pages: General, Standard values, External processing, Interoperation times, Standard value calculation, Splitting, Overlap, Qualification, Long text. To go there, select the operation and choose 🗒️.

Choose Operation to access various functions that you can execute for the operation.

4. To reach the Component overview, choose 📚. You can change the following component data:

<<< Screen print goes here>>>
You can find more fields that can be changed on the component tab pages: General data, Purchasing data, Variable-size item data, Co-product, Text item, Long text. To go there, select the component and choose .

Choose Component to access various functions that you can execute for the component.

5. To save the order, choose .
Production Order Creation

Use

To create a production order you have the following options:

- With reference to a material:
  - you create an order manually (see Creating a Production Order with a Material [Page 27])
  - you copy another order. Here you have the option of making an object selection using Further (settlement rule, operations with production resources/tools and trigger points, components).

- Without reference to a material [Page 29]

- With reference to planned orders [Page 40] (one or more)
  - With reference to a sales order [Page 31]
  - With reference to a project
Creating a Production Order with a Material

1. Choose Logistics → Production → Shop Floor Control → Order → Create → With material.
   You reach the initial screen Create production order.

2. Enter the following data:
   - the material that you want to produce
   - the production plant where the material is to be produced
   - the planning plant where the goods receipt should occur for the material produced

   You can use the planning plant for example when you have organized sales as an independent plant. However, in most cases the production plant and the planning plant are not identical. If both plants are identical you only have to specify a plant number. The other number is then filled automatically.
   - the order type (it controls whether an internal or external number range is used.)
   - if you have selected an order type for which an external number assignment is required then you must also specify an order number in the field Order.

3. Choose 🌐.
   You reach the tab page General.

4. Enter the following data:
   - **Total quantity**: Specify the quantity that you want to produce. (The unit of measure is copied from the material master).
     
     If a fixed lot size is specified in the material master for the material to be produced (MRP) then the lot size is proposed as the order quantity in this field.
   - **Order start date or order finish date**: Depending on the scheduling type [Page 93] you must specify the order start and/or the order finish date.
     
     Production orders are generally scheduled backwards.
   - **Scheduling type**: Use a key to specify how the order is to be scheduled.
     - **Scheduling margin key or float before production, float after production and release period**: The release period, the float before production and the float after production of the order are defined using the scheduling margin key.
       
       If you specify a scheduling margin key the system fills these fields automatically.
       
       If no scheduling margin key has been specified you can specify the float before production, the float after production and the release horizon by specifying the corresponding number of days.
Creating a Production Order with a Material

5. You must also specify the following data:

- **Scrap portion:** You can specify the scrap quantity that you expect for this order. If assembly scrap is maintained in the material master, this is proposed.
- **Priority:** You can assign the order a priority. (This field does not affect order processing.)
- **Long text:** To create a long text for the production order choose the *Long text* tab page.

6. Choose ✧.

The system searches for a valid routing (see **Routing Selection** [Page 52]) and a valid bill of material (see **Selecting Bills of Material** [Page 63]).

If alternative sequences exist in the selected routing, they can only be copied to the production order if alternative sequences are permitted for the order type in **Customizing for Shop Floor Control**: Choose *Master data → Order → Define Order Type-Dependent Parameters*.

If you do not want to change data copied from the routing or bill of materials then you can save the production order now. Otherwise, change the data and then save the production order.
Creating Production Orders Without a Material

1. Choose Logistics → Production → Shop Floor Control → Order → Create → Without material.
   You reach the initial screen Create production order.

2. Enter the following data:
   - the plant
   - the sales order (you can specify a sales order as a reference.)
   - the order type (it controls whether an internal or external number range is used.)
   - if you have selected an order type for which an external number assignment is required then you must also specify an order number in the field Order.

3. You must also specify the following data:
   - the responsible MRP controller
   - the responsible production scheduler

   If you want to create the order with reference to an existing order then the order referenced must also be one without a material.

4. Choose .
   The General tab page appears.

5. Enter the following data:
   - a Short text for the order
   - Total quantity: Specify the quantity and the unit of measure.
   - Order start date or order finish date: Depending on the scheduling type [Page 93] you must specify the order start and/or the order finish date.

   Production orders are generally scheduled backwards.
   - Scheduling type: Use a key to specify how the order is to be scheduled.
   - Scheduling margin key or float before production, float after production and release period:
     The release period, the float before production and the float after production of the order are defined using the scheduling margin key.

     If you specify a scheduling margin key the system fills these fields automatically.

     If no scheduling margin key has been specified you can specify the float before production, the float after production and the release horizon by specifying the corresponding number of days.

6. You must also specify the following data:
Creating Production Orders Without a Material

- **Scrap portion**: You can specify the scrap quantity that you expect for this order.
- **Priority**: You can assign the order a priority. This field does not affect order processing.
- **Long text**: To create a long text for the production order choose the Long text tab page.

7. Choose 📡.

You reach a dialog box where you can specify whether you want to use a reference operation set. If you do not want to use a reference operation set then a standard sequence is automatically generated with an operation.

The system searches for a valid routing (see [Routing Selection](Page 52)) and a valid bill of material (see [Selecting Bills of Material](Page 63)).

If alternative sequences exist in the selected routing, they can only be copied to the production order if alternative sequences are permitted for the order type in Customizing for Shop Floor Control: Choose Master data → Order → Define Order Type-Dependent Parameters.

If you do not want to change the operations or add any components, you can now save the production order. Otherwise, change the data and then save the production order.
Creating a Production Order with a Sales Order

1. Choose Logistics → Production → Shop Floor Control → Order → Change → With sales order.
   
   You reach the initial screen Create production order.

2. Enter the following data:
   - the sales order number
   - the order number
   - the order type (it controls whether an internal or external number range is used.)
   - if you have selected an order type for which an external number assignment is required then you must also specify an order number in the field Order.

   ! The item in the sales order must allow the requirements type sales order stock. For more information on this topic refer to the documentation SD Sales.

   ⇒ Material number, quantities and dates are copied from the sales order. You can change the plant, configuration, quantities and dates in the production order. In contrast to assembly processing [Page 509], changes in the sales order or the production order are not automatically copied to the other object.

   If a sales order bill of materials and a sales order routing exist then they are copied to the production order.

3. Otherwise you proceed as with Creating a Production Order with a Material [Page 27].
Maintenance of Header Data in the Production Order

Use
With this function you maintain the data that is assigned to the production order at header level.

Integration
The order header data is only a part of the data that you can maintain in the production order. You can also maintain data for the following objects in the production order:

- Operations
- Components
- Production resources and tools
- Trigger points

Features
The production order data that you can maintain with this function is saved in a tab with the following tab pages:

- General: Quantities, dates and scheduling data
- Assignment: Responsibility, plants, other assignments
- Goods receipt: Tolerances, receipt and delivery
- Control: Reference order, costing data, production scheduling profile
- Dates/quantities: Quantities and dates in detail
- Master data: Routing, bill of material
- Long text: Text field for entering a long text
- Administration: Created/changed by

You maintain production order data in all of the tab pages in the same way.

Activities
Change the order data according to your requirements. Many of the fields are filled automatically when you create the order. The settings that determine this are made in Customizing for the order type and the plant.
Changing Header Data

Prerequisites
You can make changes to the order data both in create and in change mode.

Procedure
1. Choose Logistics → Production → Shop Floor Control → Order → Change.
2. Specify the number of the order that you want to change.
3. Choose 📊.
   You branch to the initial screen for the production order. You can see the tab for production order data.
4. Choose the tab page on which you would like to change data.
5. Make the desired changes.
6. Save the order data.
Maintenance of Operation Data

Use
With this function you maintain the data that is assigned to operations.

Features
You can maintain operation data in the operation overview, as well as in the tab pages or the operation detail screens.

Operation Overview
The fields for operations are found in the operation overview. In this overview you can process operation data in a table (table control). Each operation is on a separate line. You can control the appearance of the table yourself. For more information refer to Table Controls [Ext.].

Tab Pages and Operation Detail Screens
If you want to maintain the tab pages or the operation detail screens, you have to go to the operation overview first. From there you switch to the tab pages or the operation detail screens.
The operation control key controls which data is relevant. The fields are organized thematically:

- **Tab pages**
  - General
  - Standard values [Page 114]
  - External processing (only for operations that can be processed externally)
  - Interoperation times (only for operations that can be scheduled)
  - Standard Value Calculation
  - Splitting (only for operations that can be scheduled)
  - Overlapping (only for operations that can be scheduled)
  - Dates [Page 112] (only for operations that can be scheduled)
  - User Fields
    You can create user-defined fields in Customizing for Shop Floor Control by choosing Master Data → Routing Data → Create User-Defined Fields (for example, general fields, quantity fields/unit, value fields/unit, date fields, indicator). The key that you enter on this tab page activates the user-defined fields.
    The user fields are not checked by the system. You are responsible for the content of the fields yourself.
    - Suboperation Dates [Page 116] (only for operations that can be scheduled)
    - Quantities/activities (only for operations that can be confirmed)
    - Confirmed dates (only for operations that can be confirmed)
    - Assignment of capacity requirements [Page 133]
    - Qualificats
For each plant and order type, you can define your own layout of the tab pages for the operations (Customizing for Shop Floor Control by choosing Screen Control \rightarrow Define User-Specific Tab Pages \rightarrow Define Operation Detail Screens).

- **Operation detail screens**
  - **Purchase requisition [Page 280]** (only for operations that can be processed externally)
  - Object dependencies
  - Long text:

**Activities**

Change the operation data according to your requirements. Many of the fields are filled automatically when you create the order. The settings that determine this are made in Customizing for the order type and the plant.
Maintenance of the Operation Overview

Use
The operations taken from the routing and scheduled for the order are listed on the operation overview. You can maintain this data here.

Features
The following information is listed for every operation on this screen:

- The **operation number** (this number specifies the sequence in which operations are processed).
- The **suboperation number** of existing suboperations
- The **work center** where the operation is to be executed
- The **control key** that determines how the operation is to be used (for example, whether it must be confirmed, whether it can be scheduled, whether it can be printed, and so on)
- The current **status** of the operation (for example, whether it has already been created or released)
- The **start** and **finish date** of the operation
- A **short description** of the operation

There are also the **COMP**, **PRT** and **TPT** columns:

- If the indicator is set in the **COMP** column, it means that components are assigned to the operation.
- If the indicator is set in the **PRT** column, it means that production resources/tools are assigned to the operation.
- If the indicator is set in the **TPT** column, it means that trigger points are assigned to the operation.
Maintaining an Individual Operation

Prerequisites
You can make changes to the order data both in create and in change mode.

Procedure
1. Choose Logistics → Production → Shop Floor Control → Order → Change.
2. Specify the number of the order that you want to change.
3. Choose .
   The initial screen for production orders appears.
4. Choose .
5. Select one or more operations.
6. The operation data is divided into two sections that you can access in different ways.

To go to the tab pages, first choose and then one of the following tab pages:
   - General
   - StandardVals
   - Ext. processing
   - Interop. times
   - Std value determin.
   - Splitting
   - Overlapping
   - Dates
   - User Fields
   - SO delta
   - Qty/activities (display-only fields)
   - Confirmed dates (display-only fields)
   - Assignment of reqmts
   - Qualificats
   - Long text:

For each plant and order type, you can define your own layout of the tab pages for the operations (Customizing for Shop Floor Control by choosing Screen Control → Define User-Specific Tab Pages → Define Operation Detail Screens).

To go to the operation detail screens, choose
Maintaining an Individual Operation

- Operation → Purchase requisition
- Operation → Object dependency
- Operation → Long text

7. Make the necessary changes and save the order.
Cumulating Standard Values

Prerequisites
If the standard values of the suboperations are to be automatically cumulated to the main operation when you create the production order, you must set the Cumulation type key accordingly in the routing.

Alternatively, you can trigger the cumulation of standard values in the production order. A condition for cumulation is that you have maintained standard values at suboperation level.

Procedure
1. Choose Logistics → Production → Shop Floor Control → Order → Change.
2. Specify the number of the order that you want to change.
3. Choose .
   The initial screen for production orders appears. You can see the tab for production order data.
4. Choose .
   You reach the operation overview.
5. Select the operation for which you want to cumulate the standard values.
6. Choose Operation → Cumulate standard values

Result
The standard values of the suboperations are added together and written to the standard values of the operation.
Planned Order Conversion

Use

Planned orders are created in material requirements planning to cover the requirements. Planned orders represent a demand to procure or produce a material. Planned orders for materials that are to be produced in-house are converted to production orders. The material components required for production are contained as items in the planned order and are copied directly when the planned order is converted to a production order.

You have the following options for converting planned orders to production orders:

- Individual Conversion [Page 42]
- Collective Conversion [Page 43]
- Partial Conversion [Page 46] (see also Partial Conversion of a Planned Order [Page 47])

In a partial conversion, a planned order is reduced in partial quantities into several production orders. Partial conversion is described separately.

Prerequisites

If the material requirements planning, routings, and bills of material components have been implemented, you can create planned orders that contain almost all the data that is required to create a production order.

Features

A planned order contains the following data:

- Reqmts qty
- Start date and delivery date
- Material number
- Material components

The material components required for production are contained as items in the planned order and are copied directly when the planned order is converted to a production order. The BOM is not exploded again.

On conversion, the secondary requirements for the components are converted to reservations. The operation data and production resource/tool data is copied as usual from the routing for the material to be produced. Routing selection is described in the section Routing Selection [Page 52].

If, when converting the planned order, you make changes to the required quantity that is copied or if the basic finish date is changed, then a planning file entry is generated. When material requirements planning is executed again, the material and its components are planned again.
Executing Individual Conversion of Planned Orders

Prerequisites
The planned order that is to be converted to a production order must be marked as convertible. The material must permit in-house processing.

Procedure
1. Choose Logistics → Production → Shop floor control → Order → Create → From planned order.
   You branch to the initial screen for converting a planned order.
2. Specify the planned order number as well as the order type of the production order that you want to create.
3. If the order type specified uses external number assignment, specify in the field order the number of the production order to be generated. Choose ✚.
   The system copies all the data in the planned order such as the order quantity, order dates and components. The system also selects a valid routing.
4. Check the data copied from the planned order and change it if necessary.
5. Choose ✬.
Executing Collective Conversion of Planned Orders

Use
You have the option of converting several planned orders into production orders in a collective conversion. You can select the planned order that you want to convert together according to the date of their creation.

Procedure
1. Choose Logistics → Production → Shop floor control → Order → Create → Collective conversion of planned orders.

   You branch to the initial screen for collectively converting planned orders.

2. Enter the planning plant.

   Other selection criteria that you can use for planned orders are: MRP area, MRP controller. Opening date from - to, Material, Sales order, WBS element, BOM explosion number.

   You can search for a material in the Material field using any character string (for example, A* for all materials beginning with A).

   If you want to restrict the selection of the planned orders to be converted according to their opening date, you can also specify an interval from opening date and to opening date.

   If an opening period has been defined in your user master (parameter IDs AEV and AEB) then the values are automatically proposed by the system.

   Only planned orders that allow in-house processing can be selected. To convert planned orders to purchase requisitions, choose Logistics → Production → MRP → Planned order → Convert to pur.req.

3. Enter the order type with which the production order is to be created.

   If you want to create production orders with different order types (for example, some with internal and some with external number assignment) then on the next screen you have the options of specifying the order number separately for every order.

   An order type can be proposed via the production scheduling profile. The assignment of the production scheduling profile to the order is made via the material master record of the material to be produced (tab page Work scheduling). There, you can either directly enter the profile or carry out indirect assignment via the production scheduler (you define the production scheduler in Customizing for Shop Floor Control by choosing Master Data → Define Production Scheduler). If both are entered, priority is given to assignment via the profile.
Executing Collective Conversion of Planned Orders

4. Choose \( \text{Choose} \).

The system lists all planned orders that fit the given selection criteria. Double-click a planned order to display it (number of the planned order in the \textit{Planned order} column).

With \( \text{Planned orders} \), you can branch to a printable list of the selected planned orders. In addition, other functions you can use are: Filter, sort, ABC analysis.

5. Now select the planned order that you want to convert.

Planned orders that you do not want to convert can be deleted from the list by choosing \( \text{Choose} \).

You can branch to various objects from the list of selected planned orders using a double-click (for example, material, planned order number, production order number after the conversion).

You can sort the list of selected planned orders any way that you like. To create a temporary or permanent search profile, choose \( \text{Fields} \). A permanent sort profile can be preset in the user parameter SPO.

The orders in a collective order are displayed together and must be converted together, that is, subtrees cannot be converted. In addition, you can expand and compress orders in a collective order.

6. If necessary change the order type of the selected planned orders. If you specify an order type for a planned order that uses external number assignment then you should specify an order number for this order.

7. Choose \( \text{Convert} \).

The system converts all the selected planned orders.

A log is created for every planned order for which conversion has been called up. You call this up by choosing \( \text{Convert} \) for converted planned orders or \( \text{Not converted} \) for those not converted, in the \textit{Result} column. This log contains all logs that are also in the production order, by choosing \textit{Goto \rightarrow Logs}.

You can carry out a new selection of planned orders at any time. You do not need to exit the application to do this. Expand the selection area by choosing \( \text{Choose} \). Then enter the selection criteria and choose \( \text{Choose} \).
Executing Collective Conversion of Planned Orders
Partial Conversion of Planned Orders

Use
In certain cases if can be useful to convert partial quantities of a planned order to a production order rather than the whole quantity. This is the purpose of the partial conversion function.

With a partial conversion the planned order quantity can be split into as many partial quantities as you like. A separate production order is generated for every partial quantity. Thus partial lots of a planned order can, as required, flow into production on different dates.

Integration
You can call up the function for partial conversion in the following places:

- In the production control menu
- From the current stock-/requirements list of the material to be produced
- From the MRP list of the material to be produced
- From material requirements planning

Features
A planned order that is partly converted is fixed. A fixed planned order can no longer be changed by a planning run. Its secondary requirements are reduced according to the partial quantity entered.

The planned order remains until the indicator Delete planned order is set.

The Delete planned order indicator can be set in two ways:

- The system sets the indicator automatically as soon as the planned order quantity is completely covered by production orders.
- You can set the indicator once no further conversion of the planned order is required (that is, independently of any remaining planned order quantity).

If a partial conversion is carried out and the routing selection or bill of material selection for the production order is controlled by a production version, then the production version is always used that is valid for the original planned order quantity.

Partial conversion can only occur simultaneously for all partial quantities. If errors occur for one or more partial quantities, then those partial quantities without errors are also not converted. For example, a manual termination when a routing is being selected is also regarded as an error.
Executing Partial Conversion of Planned Orders

Prerequisites
To execute a partial conversion for a planned order you must first branch to the screen for query subset/order correction. Here you have the following options:

Shop Floor Control
1. Choose Logistics → Production → Shop Floor Control → Order → Create → From planned order.
   The initial screen Create production order appears.
2. Enter the required data.
3. Set the partial conversion indicator and choose 🎉.
   You reach the screen Query subset/order correction.

Current Stock/Requirements List
1. Choose Logistics → Production → MRP → Evaluations → Stock/requirements list.
   You reach the screen Current stock/requirements list.
2. Enter the material to be manufactured and the plant. Choose 🎉.
3. Double-click the required planned order to call it up and choose -->PartConvProdOrder.
   You reach the screen Query subset/order correction.

MRP List
1. Choose Logistics → Production → MRP → Evaluations → MRP list - material.
   The initial screen MRP list appears.
2. Enter the material to be manufactured and the plant. Choose 🎉.
3. Double-click the required planned order to call it up and choose -->PartConvProdOrder.
   You reach the screen Query subset/order correction.

Material Requirements Planning
   The initial screen Create production order appears.
2. Enter the required data.
3. Set the partial conversion indicator and choose 🎉.

Procedure
The rest of the procedure is the same in all cases above:
1. If you want to execute several partial conversions choose 🎉.
Executing Partial Conversion of Planned Orders

2. Specify the desired dates and quantities.

During conversion, the system uses the scheduling type that is specified for the order type and plant entered in Customizing for Shop Floor Control, by choosing Operations → Scheduling → Specify Scheduling Parameters. However, this can be changed once the conversion to the individual orders has taken place.

3. Choose Generate.

The system generates a production order for each line. Since the orders created have not yet been saved you at first receive temporary order numbers (for example, %0000000001).

As soon as a partial quantity has been converted to a production order the corresponding line in the screen can no longer be deleted. If you want to delete this, you must leave the transaction and execute a new partial conversion.

4. If you want to make more changes to a created order, select the line and choose .

The screen Create production order: Header appears.

Once you have made the changes, choose to branch back to the Query subset / order correction screen.

5. Choose .

Result

The system saves the production orders created.

If the total quantities of the created production orders is less than the remaining planned order quantity and the indicator Delete planned order has not been set, the planned order quantity is reduced accordingly.

If the total quantity of the created production orders is greater than or equal to the remaining planned order quantity, the planned order is deleted.
Order Comparison

Use
Order comparison enables you to make detailed statements about the effects of changes, without having to execute a change process in OCM.

The result of the comparison is represented in the form of a Change Step Overview [Page 424] and in the form of comparison statistics.

Features
Comparison objects that you can use are:

- Existing production orders
  You can use any operational production orders for comparison

- Temporarily created production orders
  When you enter a (changed) sales order or a material as a comparison object, a production order is temporarily created. Master data (BOMs, routings) are exploded for this process. You can enter parameters for creating the production order, by specifying the explosion date for the master data, plant, order type and base quantity.

  When you use the sales order as a comparison object, the material and all the relevant data for the explosion (for example, characteristic value assignment, serial number) are used from the sales order item that you have specified.

Order comparison determines the change steps that would change the first object into the second object.

The material in the comparison objects must match. The quantities, however, can differ.

Activities
To execute order comparison, choose Logistics → Production → Shop floor control → Control → Order change management → Order comparison.
Simulation Order

Use
A simulation order enables you to see how changes to initial data (sales order, master data) affect a production order. You can use the simulation order, for example, to find errors in the material configuration. It is structured like a production order but has no effect on operations.

A simulation order is created automatically when sales orders are changed. When changes are made to master data, you can use this function to create, change and display a simulation order as required.

The simulation orders created using this function do not participate in the OCM change process.

Activities
If you want

• To create, choose Logistics → Production → Shop floor control → Order → Simulation order → Create.

• To change Logistics → Production → Shop floor control → Order → Simulation order → Change.
  You cannot change simulation orders that have been created automatically during the change process.

• To display, choose Logistics → Production → Shop floor control → Order → Simulation order → Display.

• To delete, choose Logistics → Production → Shop floor control → Order → Simulation order → Delete.
  You cannot delete simulation orders that have been created automatically during the change process.
Copying Master Data

Use
When you create the production order various master data can be copied to the production order. Copying makes maintaining production orders simpler because the system uses predefined data.

Features
Selection of master data comprises the following functions:

- Routing selection [Page 52]
- Bill of material selection [Page 63]
- Read master data [Page 70]
Routing Selection

Use

The steps necessary to produce a material are generally saved as operations and suboperations in a routing. The routing is selected on order creation. The individual operations and suboperations as well as other routing data is copied to the production order.

In exceptional cases, you may want to create a production order without using a routing. This situation can arise, for example, when you create an order for unplanned rework.

When an order is created, the system looks for a routing that is valid for the specified explosion date [Page 69] and that fits the specified lot size.

In Customizing and in the material master for the material to be produced you can specify whether a routing must be selected for a production order and according to what criteria.

Features

The options that you have for routing selection are described in the section Settings for Routing Selection [Page 54].

Validity of the Routing

The system takes into account during routing selection only those routings that are valid at the time of the conversion. The transfer date of the routing is calculated as follows:

- If you have specified the order start date, the system takes this date as the transfer date of the routing.
- If you have specified the order finish date the system calculates the transfer date from the order finish date minus the in-house production time defined in the material master.

If you have specified in Customizing for material requirements planning (plant parameters) that the explosion date is to be at the end of the order (bill of material explosion) then the system uses the same procedure: If the order finish date is specified, then this is copied. If no order finish date is specified then the transfer date is determined using the in-house production time.

If scheduled dates are specified instead of basic dates then the system calculates temporary basic dates while taking the relevant order floats (floats before and after production) into account.

- If a routing must be selected but no routing can be selected then the system reacts with a termination message and you must carry out order creation again.

Reading Master Data

You can copy the routing data again to the order. For more information, refer to Reading Master Data [Page 70].
Data from the Routing

Depending on the setting in Customizing, the data in all of the detail screens is tested (*field operation dtl check* in order type dependent parameters). If data relevant to orders is missing then the system displays the corresponding detail screens. You then have the option of maintaining this data again.

As soon as a routing is selected the data contained in the routing is copied to the production order. The production order copies the following data from the routing:

- Operations
- Data on external processing
- Parallel Sequences
- Work centers
- StandardVals
- Activity types
- Bill of material assignments
- Assignments of production resources/tools
- Trigger points
Settings for Routing Selection

You can make the following settings for routing selection:

- **Routing Selection**
  
  You can use the *Routing selection* key to specify:
  
  - whether a routing must be selected
  
  - which routing categories are permitted (for example, only routings, reference operation sets, or both)
  
  - whether routing selection is to be automatic or manual

  You assign the *routing selection* key to an order type in Customizing for Shop Floor Control, by choosing Master data → Order → Define Order-Type Dependent Parameters.

- **Selection priorities**
  
  The selection priorities specify the priorities according to which the automatic routing selection should take place (task list type, usage, status).

  You maintain the possible selection priorities in Customizing for Shop Floor Control, by choosing Operations → Routing selection → Select automatically. You assign the selection priorities to the order type-dependent parameters (field selection ID) for an order type.

- **Selection of alternatives/production version**

  With automatic routing selection you can specify in the material master that the automatic selection is to take place using the production version maintained in the material master instead of with the selection priorities. To achieve this, specify a value in the Alternative selection field in the MRP section that defines the bill of material selection using the production version.

  To maintain the material master choose Logistics → Production → Master data → Material master.

- **Default values**

  If you work without a routing default values are used for operation data. The system creates an operation with these default values.

  To maintain the possible default values in Customizing for Shop Floor Control, choose Operations → Routing selection → Define default values.
Automatically Selecting a Routing

Criteria for the Selection

When carrying out automatic selection using the selection ID the system tries to select a routing according to predefined criteria.

On order creation you specify a material, the quantity of the material to be manufactured and a basic date. When automatically selecting a routing the system uses the following criteria:

1. **Material**: First of all the system looks for all the routings that exist for the material.
2. **Quantity**: The system then looks for all the routings whose lot sizes fit the order quantity specified. If there are no routings whose lot sizes fit the order quantity then the system looks without taking the lot size into account.
3. **Basic date**: The system then determines the date when the routing must be exploded for the order. It proceeds as follows:
   - If you have specified the basic start date of the order the system takes this date as the explosion date for the routing.
   - If you have specified the basic finish date of the order the system calculates the explosion date from the basic finish date minus the in-house production time defined in the material master. If the in-house production time is not defined in the material master record then the system carries out the same calculation with the lot-size dependent in-house production time.

The system restricts the routing selection to routings that exist at the explosion date.

If the production order was converted from a planned order in which a production version was specified then the system tries to select a routing using this production version.

Automatic Selection

If an automatic selection is not possible the system functions as follows:

- If no routing matches the selection criteria then no routings are displayed (you must make another selection).
- If several routings match the selection criteria equally well then all of them are displayed.

Two priorities are maintained for one selection ID. Routing selection takes place automatically. Two routings match the first priority equally well. One routing matches the second priority exactly:

In this case, no automatic selection is possible. Thus the system lists the two routings with priority 1 AND the routing with priority 2. You must select one of the three routings manually.
Automatically Selecting a Routing

**Selection Priority**

It can happen that several routings fulfill all the selection criteria. In this case you can also define additional selection criteria in Customizing according to which the system can automatically select exactly one routing. Selection priorities can be assigned for the following criteria:

- Task list type ([routing [Ext.]], [reference operation set [Ext.]])
- Use
- Status

If a reference operation set is included, then the components that belong to it are also transferred to the production order.

**Production Version**

If it is specified in the material master of the material to be produced that the bill of material is to be selected using a *production version* and if a routing is also assigned in the production version then this task list is copied to the order.

If there are several production versions, either the system decides automatically which production version is used, or you choose the production version manually.

You make the settings for this in the order type-dependent parameters (*Production version* indicator in Customizing for Shop Floor Control by choosing Master Data → Order → Define Order-Type Dependent Parameters).
Priorities for Automatic Routing Selection: Example

In Customizing, the following priorities are assigned for plant 0001 and order type PP01:

Priorities for Routing Selection

<table>
<thead>
<tr>
<th>Task list type</th>
<th>Use</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. N</td>
<td>Electronics</td>
<td>Released</td>
</tr>
<tr>
<td>2. N</td>
<td>Electronics</td>
<td>Created</td>
</tr>
<tr>
<td>3. N</td>
<td>Production</td>
<td>Created</td>
</tr>
</tbody>
</table>

In this case the system first looks for a routing with the usage electronics and the status released. If it does not find a routing that fulfills these criteria it looks for a routing with the usage electronics and the status created. If it does not find a routing that fulfills these criteria it looks for a routing with the usage production and the status created.

If, in spite of these priorities, it is not possible to select a routing, the system reads all the routings that exist for the material at the explosion date that should be selected according to the selection ID. You must then choose a routing manually from this list.
Selecting a Routing Manually/Working without a Routing

Manual Selection
With manual selection the system lists all the valid task lists that exist for the material at the time of copying and that should be selected according to the selection ID. You can select the required routing from this list.

Working Without a Routing
When you work without a routing the system automatically generates an operation. It proceeds as follows:

- If default values have been maintained for the automatic generation of an operation the system uses these values to generate an operation automatically in the order.
- If no default values are specified in Customizing the system generates an operation with the control key 0001 and the operation number 0010.

If a routing must be selected but no routing can be selected then the system reacts with a termination message and you must carry out order creation again.
Sequences

Use
Sequences group together operations in the order. Operations in a sequence are processed according to their place in the sequence. Sequences are linked in network-like structures.

Features
The following types of sequence exist in the SAP System:

- **Standard sequence**
  A standard sequence is the first sequence of operations that is created in the routing or production order. If all of the operations are to be processed sequentially in an order then only a standard sequence is required for this order. If certain operations are to be executed as alternatives to or parallel to part of the standard sequence then they must be grouped together as alternative or parallel sequences.
  
The operation in the standard sequence at which a parallel sequence is to start or from which the standard sequence is to be replaced by an alternative sequence is known as the branch operation.

  The operation in the standard sequence after which a parallel sequence is to branch back to the standard sequence or up to which an alternative sequence is to replace the standard sequence is known as the return operation.

- **Alternative sequence**
  Alternative sequences contain operations that replace the operations in the standard sequence. They are used for example if
  - the production process in the order is changed for certain lot sizes or
  - alternative capacities are available that can be used as alternatives in the case of capacity bottlenecks

  Alternative sequences cannot be changed or added to the production order.

- **Parallel sequence**
  A parallel sequence runs parallel to the operations of the standard sequence. The start of the parallel sequence corresponds to the start of the branch operation in the standard sequence. The end of the parallel sequence corresponds to the end of the return operation.

  If parallel sequences exist in the routing selected then they are automatically copied to the order when the routing is exploded.
Exchanging Alternative Sequences

Use
When you create or change a production order you can exchange the standard sequence with an alternative sequence.

Prerequisites
The following conditions must be fulfilled:

- For alternative sequences to be copied to the production order this must be explicitly authorized (fields Sequence exchange and Altern.sequences in Customizing for Shop Floor Control, choose Master data → Order → Define Order Type-Dependent Parameters).
- The branch and return operation specified in the standard sequence must exist for the alternative sequence.
- The operation numbers specified in the alternative sequence must fit in the number interval specified in the standard sequence.
- The alternative sequence must not overlap with alternative or parallel sequences.

A standard sequence can be exchanged with alternative sequences as often as you wish so long as the standard sequence
- Does not contain any operations that are already released
- Does not contain any operations with planned inspection characteristics
- Does not contain operations for which QM actual data has been created
- Does not contain any externally-processed operations for which orders already exist

If these conditions are fulfilled then the system ask you when copying the routing whether you want to exchange an alternative sequence with a segment of the standard sequence.

Activities
If you decide to exchange sequences the system lists all existing alternative sequences in a dialog box. If you want to compare the operations to be exchanged in the standard sequence with the operations of one of the alternative sequences you should double-click on the desired alternative sequence.
Adding Parallel Sequences

If you want to add parallel sequences proceed as follows:

1. Choose Goto → Overviews → Sequences.
   The system lists all the alternative and parallel sequences that already exist in the production order. Blank lines are also displayed.

2. In one of the blank lines, enter a branch operation (BOp) and a return operation (ROp) as well as a descriptive text for the sequence, if necessary.

3. Save your entries.
Changing Parallel Sequences

If you want to change the **text for the sequence**, **the branch operation or the return operation**, proceed as follows:

1. Choose *Goto → Overviews → Sequences*.  
   The system lists all the alternative and parallel sequences that already exist in the production order.

2. Select the parallel sequence that you want to change and choose 📝.  
   The system branches to a screen where you can make the changes.

If you want to change the **operations in a sequence** proceed as follows:

1. Choose *Goto → Overviews → Sequences*.  
   The system lists all the alternative and parallel sequences that already exist in the production order.

2. Select the parallel sequence that you want to change and choose 📝.  
   The system lists all the operations contained in the sequence.

For more information about maintaining operations refer to *Changing Operation Data [Page 37]*.
Selecting Bills of Material

Use
To specify the material components that are needed to execute a production order a bill of material is generally used. This is selected when the order is created. The individual bill of material items, as well as other data from the bill of material, are copied to the production order.

Features
A bill of material can be selected by lot size, date, or production version.

Reading Master Data
You can copy the bill of material data into the order again. For more information, refer to Reading Master Data [Page 70].
Settings for Bill of Material Selection

You can make the following settings for bill of material selection:

- **Selection of alternatives/production version**
  
  You specify how the bill of material selection is to take place in the material master in the field *Alternative selection*. The bill of material can be selected by:
  
  - lot size
  - date
  - Production Version

  If the selection is to take place using the production version then you must maintain the *production versions* and assign a bill of material alternative to each of these.

  To maintain the material master choose *Logistics → Production → Master data → Material master*.

- **Bill of material usage**

  The bill of material usage is assigned to an order type. It groups together various parameters. The bill of material usage controls whether, for example, the bill of material is selected by date or by production version. You can also control for each application which bill of material status is checked during bill of material selection. For production orders you would get the system to check, for example, the status *Released for order*.

  You maintain bill of material usage in Customizing for Shop Floor Control by choosing *Operations → Bill of Material Selection → Define Usages*.

  You assign *bill of material usage* to an order type in Customizing for Shop Floor Control by choosing *Master data → Order → Define Order Type-Dependent Parameters*.

- **Selection priorities**

  You can specify a selection priority according to which bills of material are selected with different usages. This priority is used if several bills of material with different usages exist for one material (for example, production BOM and engineering/design BOM).

  The selection priorities are assigned to the individual bill of material application and define the priorities used to determine the bill of material usages during bill of material selection.

  To maintain the data for the selection priority, choose *Operations → Bill of Material Selection → Define Priorities for BOM Usages* in Customizing for Shop Floor Control.

- **Selecting bill of material alternatives**

  If bill of material selection takes place according to the material master by date then you must maintain the validity periods for the bill of material alternatives.

  You maintain the data for alternative selection in Customizing for Shop Floor Control, by choosing *Operations → Bill of Material Selection → Define Alternative Determination for Multiple BOMs*. 
Selecting a Bill of Material Alternative

In the material master record of the material to be produced you use the key AlternSelection (MRP) to define how a bill of material alternative is selected.

You can choose between the following three selection strategies. For all strategies, a bill of material alternative can only be selected if it is valid at the specified explosion date [Page 69] and matches the specified lot size.

- **Selecting by order quantity**
  
  The system selects here the bill of material alternative that has the relevant lot size range for the order quantity. Further selection takes place according to the Priorities for BOM Usage [Page 67].

- **Selecting by explosion date**
  
  Here the system selects the bill of material alternative that is valid according to the setting Bill of material by date for the explosion date (see Define alternative determination for multiple BOMs in Customizing for production orders).

- **Selecting by production version**
  
  Here the system selects the bill of material alternative that is stored in the valid production version. If a routing is defined in the production version then it is also copied into the order.

  If there are several production versions, either the system decides automatically which production version is used, or you choose the production version manually. You make the settings for this in the order type-dependent parameters (Production version indicator in Customizing for Shop Floor Control by choosing Master Data → Order → Define Order-Type Dependent Parameters).

  If the bill of material alternative in the collective order is selected both in the leading order and in subordinate orders using a production version then the system functions as follows:
  
  First the system determines the production version of the leading order.
  
  For subordinate orders it searches for a production version with the same key (for example, 0001). If a valid production version exists with the same key then this production version has the highest priority in the selection.

  If several valid alternatives exist after the selection then the system copies the first of the alternatives to the order.

  If no valid bill of material can be selected for the material then you have two options:

  - you can enter another material. The system then tries to select a BOM for the material according to the same criteria.
Selecting a Bill of Material Alternative

- you can work without a BOM. In this case you must add the required components manually. How to add components manually is described in Manually Adding or Changing Components [Page 140].

You can find out more about BOM explosion and the automatic selection of alternatives in the document PP - Production Planning/Material Requirements Planning.
Priorities for BOM Usage (Selection Priorities)

If the selection priorities for bill of material usage are used the system checks which bills of materials for the material with different usages exist and chooses the bill of materials whose usage has the highest priority. If a multiple BOM was found using the selection priority the order quantity decides which alternative is selected.

The usage of selection priorities generally takes place if the bill of material selection is defined in the material master according to order quantity. If the BOM selection is entered in the material master according to explosion date/production version even though the BOM usage prohibits this then the BOM selection is also executed using selection priorities.

The selection priorities are assigned to the bill of material usage. The BOM usage is a parameter in the order type (see Settings for BOM Selection [Page 64]).
**BOM Explosion**

The selected BOM is exploded one level. The BOM items are then copied to the order as components. If there are phantom assemblies in the BOM then they are exploded until a buildable level is reached.

A BOM item is **not** copied to the production order if:

- Its item status marks it as not relevant for production
- Its item category marks it as a document or PM structure element

BOM sub-items are generally **not** copied to the order.

**Explosion Over Multiple BOM Structures**

With multi-level BOM structures there can be large time intervals between the explosion dates of the individual assemblies. If BOM (alternatives) have changed through time because of various demands (for example, because individual components are exchanged or because of changed production techniques) it can happen that a commonly-used assembly is manufactured according to different BOMs.

To make sure that for a particular unit of production the whole BOM structure is always exploded with the same explosion date you have the option in the planned order of specifying a serial number.

You can use the **serial number** to specify a common explosion date for all BOM levels. This so-called **fixed-key date** is stored in the serial number. The BOM explosion takes place for all levels with this fixed-key date.

A serial number can only be assigned in the planned order and cannot be added or changed in the production order.
Determination of the Explosion Date

If the production order is generated by converting a planned order then the explosion date is copied from the planned order.

If the production order is added **manually** the system determines the explosion date as follows:

- If you have specified the order start date on order creation the system takes this date as the explosion date for the bill of material.

- If you have specified the order finish date on order creation the system calculates the explosion date from the order finish date minus the in-house production time defined in the material master.

  ![Diagram]

  If you have specified in Customizing for material requirements planning (**plant parameters**) that the explosion date is to be at the end of the order (**bill of material explosion**) then the system uses the same procedure: If the order finish date is specified, then this is copied. If no order finish date is specified then the explosion date is determined using the in-house production time.

  ![Diagram]

  If scheduled dates are specified instead of basic dates then the system calculates temporary basic dates by taking the relevant order floats (floats before and after production) into account.
Reading Master Data

Use
If data is changed in the routing, in the work centers affected or in the BOM after order creation then these changes are not automatically taken into account in the production order.

Thus you can read in the master data (BOMs and routing) again into a created or released production order.

Features
If you decide to read in the master data again then it has the following consequences:

- Before it is read in again certain criteria are checked that must be fulfilled (see Criteria for a Single Order [Page 73], Criteria in a Collective Order [Page 74]).
- When reading the BOM:
  - all existing material components are deleted
  - all purchase requisition items for non-stock components are deleted
- When reading the routing:
  - all existing sequences, operations, PRTs and trigger points are deleted
  - all assignments of material components to operations are deleted
  - all purchase requisition items for non-stock components are deleted

The status of a released order is set to created again.

The deleted data is then replaced by new data from the selection BOM/routing. The selection procedure is identical to the procedure for creating a production order (see Selecting Bills of Material [Page 63] or Routing Selection [Page 52]).

Which Data is Read?

Only the master data that you select in the dialog box for reading master data is read in again.

You have specified that master data is to be selected using a new production version. The production version contains a valid routing and a valid BOM alternative. In the Read PP master data dialog box, however, you have only selected the field New routing. In this case the system does not select a new BOM.

The explosion date for the master data to be read in can be changed.

Read with Production Version

You can read in master data for a specific production version. In this case the system selects the routing or BOM alternative that is determined by the production version.

The following conditions must be fulfilled:
• A production version must be maintained for the material to be produced.
• The production version is valid for the specified explosion date and for the given lot size.

Read with Revision Status

You can read in master data for a specific revision status. In this case the system selects the routing or BOM alternative with the date from the revision status.

The following conditions must be fulfilled:

• A revision status must be maintained for the material to be produced.
Reading Master Data

To display master data, proceed as follows:

1. Branch to the header screen of the production order.
2. Choose Functions → Read PP master data.
   A dialog box appears where you can specify which master data can be read or for which explosion date it is to be selected.
3. Specify which master data must be read:
   - routing
   - BOM or
   - routing and BOM
4. If necessary change the explosion date for the BOM or the routing.
   ![Change date]
   If you want to read the master data with a particular revision status then you can leave out this step: The system copies the date from the revision status in this case.
5. You can also specify the following data:
   - a production version to select the relevant BOM or routing alternatives
   - a revision status
   ![Revision status]
   If no production version or revision status is maintained for the material to be produced then the corresponding field is not displayed in the dialog box.
6. Choose .
   The system chooses the selected master data again according to the specified criteria [Page 70].
Criteria for a Single Order

Various checks are carried out when reading a new routing or BOM in a single order.

Reading a New Routing

If one of the following questions is answered with yes then a new routing cannot be read in:

- Is the order partially or finally confirmed?
- Is the order partially or completely delivered?
- Do purchase orders for externally processed operations already exist?
- Are there inspection lots for the order?
- Are there future change records from the confirmation (parallelization)?

Reading a New BOM

If one of the following questions is answered with yes then a new BOM cannot be read in:

- Do purchase orders already exist for non-stock components or components with direct procurement?
- Have components already been taken from stock?
- Are there transport requirements?
- Are there future change records from the confirmation (parallelization)?
- Are there goods movements containing errors that have not been processed?
Criteria in the Collective Order

Additional checks are carried out when reading a new routing or BOM in a collective order.

Reading a New Routing

All the checks are carried out that are valid for reading in a single order.

If the routing can be read in again then the system only reads the routing for the individual production order that is currently being processed.

Reading a New BOM

- All the checks are carried out that are valid for reading in a single order.
- The checks are carried out for all the subordinate orders that are valid when reading a single order.

If the BOM can be read again the system sets a deletion indicator for all the subordinate orders and creates new orders.
**Document Integration in the Production Order**

**Use**

Document integration allows you to create fixed links between orders and documents in the Document Management System (DMS). This ensures that the correct document versions are supplied during the production process. In addition, this also allows you to keep track of which documents were used to produce a certain order.

The document links can be generated **automatically** when an order is created or released (see Settings for Document Integration [Page 77]). You can also generate document links **manually**.

**Automatic Generation from Material Master/BOM**

The material master or BOM is checked during automatic generation:

- All existing document links for the material are copied to the production order. These document links are assigned to the document header. You make assignments to an operation **manually** [Page 79].

- All production-relevant document items are copied from the BOM to the production order as document links. When a document item in a routing is assigned to an operation, then this assignment is also copied to the production order.

The material master or BOM is used to determine which documents are valid. In the process, the explosion date of the production order is the decisive factor, along with the configuration or parameter validity of the produced material, where applicable. Only released documents are taken into account. If several released versions exist, the version that is valid on the explosion date is used.

**Manual Generation**

The following options are available for manual generation:

- You can create document links manually from the document links/documents saved in the material master and in the BOM (see Generating a Document Link from Master Data [Page 80]). In this process, the same rules apply as for automatic generation (see above).

- You can create any document links when the document type is allowed for production orders (see Settings for Document Integration [Page 77]).

**Integration**

The document integration in the production order is based on the functions of the Document Management System (DMS). The documents and the original files are managed in the DMS. The document links can be managed both in the DMS and in the production order.

**Restrictions**

Document links are not generated automatically when changes are made within Order Change Management (OCM) [Page 399].

**Features**

Document integration has the following characteristics:
Document Integration in the Production Order

- Assignment to document header or to operations
  Documents can be linked with the order header or with operations in the production order.

- Print
  The LV03 list is available for printing the document links.

- Where-used list
  The Document Management System (DMS) provides a where-used list with object links (for example, with material masters or production orders). It allows you to determine which production orders use a specific document.

- Archiving
  The document links are archived together with the corresponding production order (archiving class CV_OBJC). Since the display of document links is not integrated in the order information system, document links from archived orders can only be displayed using the technical view of the SAP archiving system.

- Logical database
  Document links to the document header and to operations are integrated in the IOC logical database with structures IODOCL and IOOPDOCL, and can be evaluated using these structures.

- Customer enhancements
  The following customer enhancements are available:
  - PPCO0015: Additional attributes for document links
  - PPCO0016: Generating document links from master data
  - PPCO0017: Additional checks during dialog processing of document links

- Displaying the links for a finished material
  The function Header → Documents displays the current links to the produced material, but does not establish a fixed link to the order.

See also:

Document Management [Ext.]
Settings for Document Integration

You make the following settings for document integration in the production order:

- **Customizing for Document Management**
  
  In Customizing for Document Management (Cross-Application Components → Document Management → Control Data → Define Document Types), you must configure which document types are allowed for a link to an order. The corresponding document types must be linked with object PORDER. To do this, select the document type and choose Define object link. Enter PORDER and Screen number 251.

  If you do not make this setting, the documents in question are ignored during the automatic generation of the document link [Page 78]. When you attempt to manually create the link, the system issues an error message and refuses to create it.

- **Production scheduling profile**
  
  In the production scheduling profile, (Customizing for Shop Floor Control by choosing Master Data → Define Production Scheduling Profile) you can define that when an order is created or released, document links from the material master of the produced material or document items from the BOM are copied as document links into the production order.
Automatic Generation of Document Links

Use

Document links can be generated automatically from master data when an order is created or released (see Settings for Document Integration [Page 77]). In the process, the following existing document links are taken into account:

• Document links to the material master of the produced material
• Document items from the BOM of the produced material that are marked as relevant for production

The document links are also generated automatically in the following cases:

• Convert planned order (link from material master/BOM)
• Create order with reference (links in the reference order are copied)
• Read master data (document items from a new explosion of the BOM)

See also:

Document Integration in the Production Order [Page 75]
Generating a Document Link from Master Data [Page 80]
Manual Generation of Document Links

Use
You generate document links manually in the document overview during order maintenance. The following functions are available:

- Generating Document Links from Master Data [Page 80]
- Creating Document Links [Page 81]
Generating a Document Link from Master Data

Use

You use this procedure when you want to copy document links from the material master or BOM of the produced material to the production order. The same rules apply as for automatic generation.

If you use this procedure, any existing links that were automatically generated from master data are deleted.

Procedure

1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number for the order.
3. Choose 📄.
   The document overview appears.
4. Choose 📄 Material or 📄 Bill of material.
   The documents for the material or BOM are displayed in the document overview and assigned to the document header.
   To assign the document to an operation, make the appropriate entries in the Sequence and Operation fields or choose 📄 (see Reassigning a Document Link [Page 84]).
5. Choose 📄.

See also:

Document Integration in the Production Order [Page 75]
Creating a Document Link

1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number.
3. Choose .
   The document overview appears.
4. Enter the data for the new document link (sequence, operation, document type, document, document version, subdocument).
   You can assign the document to the order header (no entries in the Sequence and Operation fields) or to an operation.
5. Choose .
Document Link Maintenance

Use
You maintain document links in the document overview during order maintenance. The following functions are available:

• Changing Document Links [Page 83]
• Reassigning Document Links [Page 84]
• Deleting Document Links [Page 85]
• Displaying Document Info Records [Page 86]
• Displaying Original Files [Page 87]

Calling master data using a double-click:

− double-click the material number to call the material master
− double-click the BOM number to call the BOM
Changing Document Links

1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number.
3. Choose .
   The document overview appears.
4. Make the changes.
5. Choose .

   If the changed link was generated from master data, the change must be confirmed (confirmation prompt).

   Changes of operation numbers are copied into the document links.

   When sequences are changed, the links assigned to an operation that is to be changed are reassigned to the order header.
Reassigning Document Links

Use
A document link can be assigned to an order header (no entries in the Sequence or Operation fields) or to an operation. You change this assignment using this procedure.

Procedure
1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number.
3. Choose .
   The document overview appears.
4. Select the document links that are to be reassigned.
5. Choose .
6. You have the following options:
   – Select Header to assign the documents to the header.
   – Select Operation to assign the documents to an operation, and enter the operation and sequence numbers.
7. Choose .
8. Choose .
Deleting Document Links

1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number.
3. Choose .
   The document overview appears.
4. Select the document links that you want to delete.
5. Choose .
6. Choose .
   Document links are also deleted when the operation to which they are assigned is deleted.
Displaying Document Info Records

1. Choose Logistics → Production → Shop floor control → Order → Display.
2. Enter the order number.
3. Choose ✓.
   The document overview appears.
4. Double-click the required document to display the corresponding document info record [Ext].
5. Choose ✖ to return to the production order in the document overview.
Displaying Original Files

1. Choose Logistics → Production → Shop floor control → Order → Display.
2. Enter the order number.
3. Choose .
   
   The document overview appears.
4. Select the required document link.
5. Choose .
   
   You branch to the display of the original file [Ext.].

If several original files exist, the system asks you which of these files you want to display.
Integrated Viewer for Displaying Original Application Files

Use
You use this function in order maintenance to display and print out digital original application files of any kind in the production order. The documents of these original application files can be

• Linked with the material components in the production order
• Linked with the production order via document integration

Integration
This function is based on the functions of the Document Management System (DMS). The documents and the original files are managed in the DMS.

Prerequisites
The viewer and the display of original application files must be set up in the Document Management System (DMS) (see Viewer for Displaying Original Application Files [Ext.]).

Activities
1. Choose Logistics → Production → Shop Floor Control → Order → Change.
2. Enter the order number.
3. Choose 📄.  
   You branch to the initial screen for the production order. You can see the tab for production order data.
4. Choose 🔍.
   The product structure of the production order appears on the left side (Material, Documents, Components).
5. Select the required item and press the right mouse button.
6. Select the original application file that you want to display.
   The original application file is displayed in the same processing window.
   📄

   If you have read master data or made changes to components, you can update the display by choosing 🔍.
Scheduling

Use
In order processing and control, the scheduling function calculates the production dates and capacity requirements for all operations within an order or a collective order.
Settings for Scheduling

Settings in Customizing

You find the following Customizing activities in Customizing for Shop Floor Control in the
Operations → Scheduling section, unless otherwise stated.

• Scheduling parameters for production orders
  The scheduling parameters are defined per order type, plant and production scheduler
  (from the material master). They cover many control parameters that are described in the
  corresponding places in the documentation (see Scheduling Parameters [Page 94]).

• Scheduling type
  The scheduling type determines which dates must be entered during scheduling and
  which dates are determined by the system (see Scheduling Type [Page 93]).

• Formula definition/formula parameter
  To calculate the duration of individual operation segments (setup, process, teardown),
  the formula parameters and formulas are used (see Calculation of the Operation
  Segments [Page 108]). They are assigned to the work center.

• Standard value key
  The standard value key determines the meaning of the individual standard values (see
  Calculation of the Operation Segments [Page 108]). It is assigned to the work center.

• Performance efficiency rate key
  Performance efficiency rates are assigned to the individual standard values in the work
  center. They specify the relationship between the specified target and actual time.

• Scheduling margin key
  You define the order float in the scheduling margin key, (see Scheduling at Order Level
  [Page 97]). The scheduling margin key is copied from the material master.

• Move time matrix (location groups)
  If the move time defined in the routing is insufficient then the move time can be defined in
  a move time matrix (see Date Determination at Operation Level [Page 102]).

• Reduction strategy
  The reduction strategy is assigned to the individual operations in the routing. If an order
  cannot be executed within the specified order dates, the system tries to shorten the lead
  time of an order using the entries from the reduction strategy (see Reduction Measures
  [Page 119] and Reduction via the Critical Path [Page 130]).

• Shift sequence
  You can carry out a very detailed definition of the operating time of a work center using a
  shift sequence. You define the shift sequence in Customizing for Shop Floor Control by
  choosing Operations → Capacity Planning → Define Shift Sequence.

• Calendar
The calendar defines the workdays and non-working days. It is assigned to the capacities in the work center. You maintain the calendar in Customizing by choosing General Settings → Maintain Calendar.

- **Order type-dependent parameters**
  
  You can enter a reduction strategy here. When an order is created, this reduction strategy is assigned to all operations that are not assigned a reduction strategy in the routing.
  
  You maintain the order type-dependent parameters in Customizing for Shop Floor Control by choosing Master Data → Order → Order-Type Dependent Parameters.

- **Control key for operations**
  
  In the control key you can define whether and how each operation is scheduled and whether capacity requirements are to be generated (see Control Key for Operations [Page 95]). The control key is assigned to the individual operations in the routing.
  
  You maintain the control key for operations in Customizing for Shop Floor Control, by choosing Master Data → Routing Data → Define Control Key.

**Settings in Master Data**

The settings described here are transferred to the production order and, as a rule, can still be changed there.

- **Work center**
  
  - Standard and minimum queue time [Page 102]
  
  - Formulas [Page 108] for calculating individual time segments for the execution time (setup, processing, teardown).
  
  - Capacity definition (see Determination of the Operating Time [Page 106])
  
  - Capacity that is relevant to scheduling
  
  - Number of individual capacities

- **Routing**
  
  - Standard and minimum queue time [Page 102]
  
  - Minimum wait time [Page 102]
  
  - Standard and minimum move time [Page 102]
  
  - Number of splits [Page 113]
  
  - Standard values [Page 108]
  
  - Overlap indicator
  
  - Parallel teardown and wait time
    
    If wait times are defined in the routing and in the work center, then the definition in the routing takes precedence.

- **Material master**
  
  - Scheduling margin key (order float, see Date Determination at Order Level [Page 97])
Settings for Scheduling

- Bill of material
  The determination of the requirements dates for directly produced components in collective orders can be influenced in the bill of material:
  - Lead-time offset
  - Operation-related lead-time offset
Scheduling Types

Scheduling types are defined in Customizing (Customizing for Shop Floor Control by choosing Operations → Scheduling → Define Scheduling Type). The following scheduling types are predefined for production orders:

- **Forward scheduling**
  With this scheduling type the system schedules forwards starting from the basic start date or the scheduled start date of the order.

- **Backward scheduling**
  With this scheduling type the system schedules backwards starting from the basic finish date or scheduled finish of the order.

- **Today scheduling**
  With this scheduling type the system uses today’s date as the basic start date and schedules forwards.

- **Only capacity requirements**
  Only the capacity requirements are calculated with this scheduling type. The individual operations are not scheduled. The system copies the basic dates to the scheduled dates. These dates are copied as the operation dates.

- **Forward scheduling (using exact times)**

- **Backward scheduling (using exact times)**
Scheduling Parameters

The scheduling parameters are defined in Customizing per order type, plant and production scheduler (from the material master) (Customizing for Shop Floor Control, by choosing Operations → Scheduling → Define Scheduling Parameters). In what follows the parameters are described that affect the scheduling of a production order. Further control parameters are described in the course of this section.

Scheduling Type

The scheduling type [Page 93] determines how scheduling is to take place (for example, backwards). When you create a production order it is proposed on the order header screen. However, you can overwrite the default in the individual production orders.

Today Scheduling

In Customizing you can specify that an order is rescheduled as soon as it is a certain number of days late (Start in the past indicator). The system then automatically carries out today scheduling when the basic start date of the order is more than the given number of days in the past. Today scheduling is a type of forward scheduling starting from today’s date and where the necessary reduction measures are applied (see Reduction Measures [Page 119]).

Rescheduling

You can specify that a production order is to be rescheduled automatically whenever it is saved (indicator Automatic scheduling). If changes relevant to scheduling are made in the order and this indicator is not set then the order is given the status NTER (dates not current).

Scheduling Allowing for Breaks

With the Scheduling with breaks indicator, you can define that the exact timing of a break is taken into account. It is then impossible for a calculated date to fall at the time of a break. For scheduling with breaks to occur, an active version of the available capacity must have been entered in the work center.

Scheduling Based on Production Dates

With the From production dates indicator, you can define that the production dates (scheduled dates) must be defined for scheduling.
Control Key for Operations

Use
You maintain the control key for operations in Customizing for Shop Floor Control, by choosing
Master Data ➔ Routing Data ➔ Define Control Key.

Schedule
Using the Schedule indicator you can define that an operation is scheduled. If an operation is
• Scheduled, the system calculates the duration of the operation segments and the dates
• Not scheduled, the system assumes that all the operation segments have a duration of 0

External Processing
If an operation is externally processed (relevant setting in the External processing key), you can
define how it is scheduled. If the Sched. external op. indicator is
• Not set, the system schedules the operation using the number of delivery days maintained on
  the external processing screen of the operation
• Set, the system calculates the duration of the operation segments from the standard values

Capacity Requirements
You use the Det. Cap. Reqmnts indicator to determine whether capacity requirements are
determined for an operation.
Scheduling Individual Orders

Use

The scheduling of individual orders takes place on two levels:

- Date Determination at Order Level [Page 97]
- Date Determination at Operation Level [Page 102]
Date Determination at Order Level

Use

The specified order dates or production dates (scheduled dates) form the starting point for scheduling an order and the scheduling type determines whether the start or finish date is required to do this (see Date Determination on Order Creation [Page 99]). Since disturbances and delays in the production process can never be completely avoided, you can plan in additional time floats at the beginning and end of an order (float before production, float after production). You define the duration of these floats in the master record of the material to be produced. Scheduling determines the required dates using these floats.

Features

The order start date and the order finish date form the framework within which a production order is to be executed. Since malfunctions and disturbances in the production process can never be fully prevented, the system uses particular floats in a production order. The system takes into account so-called "before and after production floats" when scheduling an order.

The float before production is a start float. It has two functions:

- It can compensate for delays in the staging of the material components.
- If there is a capacity bottleneck at the work centers involved, the production dates can be moved forward in the future. In this way it serves as a float for capacity leveling.

The float after production is a finish float. It is used to compensate for unexpected disturbances in the production process, so that they do not delay the scheduled finish date.

The floats before and after production are defined for each material using a scheduling margin key. This scheduling margin key is automatically transferred from the material master when an order is created. However, you can change the times in the order.

The system calculates the scheduled start of the order by adding the float before production to the order start date. It calculates the scheduled finish of the order by subtracting the float after production from the order finish date.

The system deducts the number of days defined in the release period from the scheduled start of the order and thus determines the scheduled release date of the order. This date can be used for collective release.
Date Determination at Order Level

**Scheduling margin key**

The float before production, float after production and the release period are defined in the scheduling margin key (Customizing for Shop Floor Control, by choosing *Operations → Scheduling → Define Scheduling Margin Key*). The scheduling margin key is assigned to the material (*MRP* area in the material master) and is transferred when the production order is created. These values can be changed in the production order.

**When is an order scheduled?**

When you create a production order it is always automatically scheduled. In the scheduling parameters (Customizing for Shop Floor Control by choosing *Operations → Scheduling → Define Scheduling Parameters*) you can define that, after every change relevant to scheduling, the production order is also automatically rescheduled before saving (*Automatic scheduling indicator*).
Date Determination when an Order is Created

Use
The determination of dates depends on the order creation type. A production order is created by

- Converting a planned order into a production order
- Creating a production order manually

Features

Converting a Planned Order into a Production Order
If material requirements planning has already created a planned order for producing the material, the basic dates are copied from the planned order and the order start and finish dates are determined in a new scheduling run. If necessary, reduction measures [Page 119] are carried out.

Creating a Production Order Manually
If no planned order exists and you create the production order manually, the scheduling type [Page 93] determines which basic dates you have to enter.

If you enter both basic dates, the system tries to adhere to these dates when carrying out forwards or backwards scheduling. If necessary, the system also carries out reduction measures.

The following tables show which dates you have to enter and which dates are calculated via scheduling.

Date Determination Based on the Basic Dates

<table>
<thead>
<tr>
<th>If the scheduling type specifies</th>
<th>you enter</th>
<th>scheduling calculates</th>
</tr>
</thead>
<tbody>
<tr>
<td>forward scheduling</td>
<td>order start date</td>
<td>scheduled start finish date</td>
</tr>
<tr>
<td>forward scheduling</td>
<td>order start date order finish date</td>
<td>scheduled start finish</td>
</tr>
<tr>
<td>backward scheduling</td>
<td>order finish date</td>
<td>order start date scheduled start finish</td>
</tr>
<tr>
<td>backward scheduling</td>
<td>order finish date order start date</td>
<td>scheduled start finish</td>
</tr>
<tr>
<td>only capacity requirements are determined</td>
<td>order start date order finish date</td>
<td>scheduled start finish</td>
</tr>
<tr>
<td>today scheduling</td>
<td>no entry</td>
<td>order finish date scheduled start finish</td>
</tr>
</tbody>
</table>
### Date Determination when an Order is Created

<table>
<thead>
<tr>
<th>today scheduling</th>
<th>order finish date</th>
<th>scheduled start</th>
<th>scheduled finish</th>
</tr>
</thead>
</table>

### Date Determination Based on the Scheduled Dates (Production Dates)

<table>
<thead>
<tr>
<th>If the scheduling type specifies</th>
<th>you enter</th>
<th>scheduling calculates</th>
</tr>
</thead>
<tbody>
<tr>
<td>forward scheduling</td>
<td>scheduled start</td>
<td>order start date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>scheduled finish</td>
</tr>
<tr>
<td>forward scheduling</td>
<td>scheduled start</td>
<td>order start date</td>
</tr>
<tr>
<td></td>
<td>scheduled finish</td>
<td>order finish date</td>
</tr>
<tr>
<td>backward scheduling</td>
<td>scheduled finish</td>
<td>order start date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>scheduled start</td>
</tr>
<tr>
<td>backward scheduling</td>
<td>scheduled start</td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td>scheduled finish</td>
<td>order start date</td>
</tr>
<tr>
<td>only capacity requirements are determined</td>
<td>scheduled start</td>
<td>order start date</td>
</tr>
<tr>
<td></td>
<td>scheduled finish</td>
<td>order finish date</td>
</tr>
<tr>
<td>today scheduling</td>
<td>No entry</td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>scheduled start</td>
</tr>
<tr>
<td>today scheduling</td>
<td>scheduled finish</td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td></td>
<td>scheduled start</td>
</tr>
<tr>
<td>today scheduling</td>
<td>scheduled start</td>
<td>order finish date</td>
</tr>
<tr>
<td></td>
<td>scheduled finish</td>
<td>order finish date</td>
</tr>
</tbody>
</table>
Example: Calculation of Order Dates

A production order is created using forward scheduling and a start date of 12.08.1999. The scheduling floats entered are:

<table>
<thead>
<tr>
<th>Float after production</th>
<th>2 workdays</th>
</tr>
</thead>
<tbody>
<tr>
<td>Float before production</td>
<td>5 workdays</td>
</tr>
<tr>
<td>Release period</td>
<td>5 workdays</td>
</tr>
</tbody>
</table>

Under the condition that no work is carried out on Saturdays or Sundays, scheduling determines the following dates:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>scheduled release</td>
<td>12.03.1999</td>
<td>5 workdays before the scheduled start</td>
</tr>
<tr>
<td>order start date</td>
<td>12.08.1999</td>
<td>entered</td>
</tr>
<tr>
<td>scheduled start</td>
<td>12.10.1999</td>
<td>2 workdays after the order start date</td>
</tr>
<tr>
<td>scheduled finish</td>
<td>12.13.1999</td>
<td>Example: Determined by the total duration of all operations</td>
</tr>
<tr>
<td>order finish date</td>
<td>12.20.1999</td>
<td>5 workdays after the scheduled start</td>
</tr>
</tbody>
</table>
Date Determination at Operation Level

Use
With this function, the system determines the start and finish dates of operations while scheduling orders.

The lead time of an operation can be divided into the following time segments:

- Queue time (operation float)
- Setup time
- Processing time
- Teardown time
- Wait time

The setup time, processing time and teardown time together make up the execution time of an operation.

The execution time, queue time and wait time together make up the lead time of an operation.

You can also define a move time. Move time is the time required to move a material from one work center to another. The move time always lies between two operations and is assigned to the preceding operation.

The queue time, wait time and move time together make up the interoperation time of an operation.

Features
How an operation is scheduled depends on whether it is marked for in-house processing or external processing in the Control Key [Page 95].
Scheduling In-House Operations

Duration of Queue Time
You can define a **queue time** (normal, minimum) in both the work center and the operation. The system carries out scheduling using the queue time from the work center only if you have not maintained a queue time in the operation. The queue time is an additional means of neutralizing disturbances and delays for each operation (see *queue time (earliest and latest dates in the operation)* [Page 112].

The queue time is defined in the routing operation and transferred to the production order. The queue time can be changed in the production order.

Duration of Execution
In the work center (*Scheduling* tab page), you can specify different formulas for calculating the duration of the operation segments: Setup, processing and teardown. The system uses these *Formulas* [Page 108] to determine the **execution time** of an operation in the production order. You can insert the following parameters into the formulas:

- Operation standard values
- Performance efficiency rate, that is the percentual relationship between the defined target time and the actual time (defined per standard value).
- Operation lot size
- Base quantity to which the standard values refer
- Total number of splits
- Formula constants
- User fields (tab page of the operation)

If you have not maintained standard values or a formula for one of these three operation segments, the system assumes that the duration of the corresponding segment is 0.

In the work center, you can maintain separate formulas for calculating durations and capacity requirements. The system can only determine the duration of individual operation segments if you have maintained the formulas on the *Scheduling* tab page of the work center.

Capacity Utilization Rate
The system takes breaks and organizational and/or technical disturbances into account by lengthening the duration of the operation segments accordingly *Queue, Setup, Process and Teardown* (see diagram).
The minimum wait time is defined in the routing.

Duration of Move Time
You can maintain a move time in the following places:

- In the operation
- With location groups in the move time matrix

On the Interoperation times screen in the operation, you can maintain a minimum and a standard move time. If reduction measures are carried out, the system schedules the operation using the minimum move time (see Reduction Measures [Page 119]).

If you do not maintain any move times on the Interoperation times tab page, the system determines the move times using the location groups maintained in the move time matrix.

In the move time matrix, you can specify planned values for the move time within a location group or from one location group to another. For each entry, you can specify a minimum and a standard move time. If reduction measures are carried out, the system schedules the operation using the minimum move time (see Reduction Measures [Page 119]).
Work centers that are close in proximity to each other can be grouped together in **location groups**. Location groups and move time matrices are maintained in Customizing (Customizing for Shop Floor Control by choosing **Operations** → **Scheduling** → **Define Move Time Matrix**). You assign a work center to a location group on the scheduling screen of the work center.

The move time matrix is maintained in customizing.

**Dates**

The dates of the operation segments are determined by distributing the duration of the operation segments, corresponding to the work time of the work centers, along the time axis (see diagram). In this process, the system also takes into account the time relationships between operations, that is, **overlaps** [Page 114] of operations and the position of float times that occur when you work with **parallel sequences** [Page 115].

The work time of the work centers is either calculated from the standard available capacity (breaks are evenly distributed) or from the active version of the available capacity (scheduling allowing for breaks [Page 94]).

If times are at the start of a shift/end of shift or at midnight, the following rules apply:

- Starting times are aligned with the start of the shift or 0:00.
- Finish times are aligned to the end of the shift or 24:00.
- If an operation with a duration of 0 is scheduled for one of these dates, the following special rules apply:
  - in forward scheduling, start and finish times are aligned with work finish or 24:00
  - in backward scheduling, start and finish times are aligned with work start or 0:00

This is necessary in order to avoid finish times preceding start times.

**Scheduling Externally Processed Operations**

In the **Control Key** [Page 95] you decide the data upon which scheduling is to be based for externally processed operations. You have the following options to choose from:

- **Scheduling using standard values**
  - In this case, the operation dates are determined in exactly the same way as for in-house operations (see above).

- **Scheduling using the planned delivery time**
  - In this case, operation dates are determined taking the following factors into account:
    - Planned delivery time and the Gregorian calendar
      - The system uses the planned delivery time of the operation as the basis for the duration (see **General data screen**, **External processing** section). This is distributed along the time axis using the Gregorian calendar.
    - **Overlapping** [Page 114]
      - The same rules apply here as for in-house operations (see above).
Determination of the Operating Time

Use
To be able to calculate operation dates, the system needs to be able to calculate a duration and an operating time per operation segment. For each scheduling run, the system places each operation segment on the time axis, taking into account the operating time defined for the operation segment in question. The result of this procedure is the individual operation dates.

The operating time specifies when work is to be carried out. The calendar used for scheduling distinguishes between workdays and non-working days. You can define an operating time in the system by specifying the start and end of shifts as well as the breaks for each workday.

Features

Operating Time Unit
The following rules apply:

- If the unit of the operation segment is smaller than the unit day, the operating time per workday applies
- If the unit of the individual operation segments is greater than or equal to the unit day, the operation segments are scheduled to the day on the basis of the calendar used for scheduling

Operation Times of the Operation Segments
The following operating times apply to the individual operation segments:

- For the operation segments wait, setup, processing and teardown, the operating times defined in the work center per day and the calendar specified in the work center or operation apply

The operating time of the work center is maintained on the Capacities tab page of the work center for the capacity category that is the basis for scheduling. The capacity category that is to be used for scheduling is specified as the basis for scheduling in the work center on the tab page Scheduling.

Operation Time per Workday
The following applies for calculating the operating time per workday:

- In addition to the start and end of shift and the break times, the rate of capacity utilization for the work center is taken into account when calculating the operating time.
- The capacity utilization rate represents the ratio between the actual capacity of a machine and the theoretically available capacity. This value shows you if there are any technical and organizational malfunctions. The relevant capacity utilization rate for scheduling is defined when maintaining the capacity category, which is the basis for scheduling.
- The operating time of the work center is defined for the capacity category that is specified on the scheduling screen.
Selection of a Valid Calendar

The following applies for selecting the valid calendar:

- The work center calendar has highest priority. If no calendar is maintained there, then the Gregorian calendar applies.
- The wait time is scheduled independently of the factory calendar, that is the wait time can be scheduled daily from 0.00 to 24.00.
- The operating time of the move time is determined via parameters specified in the move time matrix. In the move time matrix, you can enter in the Calendar field which of the following calendars determines the operating time:
  - Calendar of the initial work center
  - Calendar of the target work center
  - Calendar of the move time matrix
  The operating time per workday is specified via the start and end of shift in the move time matrix.
- The delivery time is specified in days for operations processed externally. These operations are scheduled on the basis of the Gregorian calendar.

Scheduling Allowing for Breaks

You can set the indicator Exact breaks (Customizing for Shop Floor Control by choosing Operations → Scheduling → Define Scheduling Parameters):

- If the indicator is set, the exact times of the breaks are taken into account For scheduling with breaks to occur, an active version of the available capacity must have been entered in the work center.
- If the indicator is not set, the system distributes the break time evenly over the day In this case, you may find that an operation date is scheduled within a break time

Date Determination Without the Operating Time

If no operating time is maintained for a time segment, the system calculates using an operating time from 0:00 to 24:00.
Duration of the Operation Segments

Use

Calculating the Duration of Operation Segments

Standard Value Key

The standard value key defines the meaning of the six standard values (for example, setup time, machine time, personnel time). It is assigned to the individual work center. You define the standard values (for example, setup time 12 minutes, machine time 30 minutes).

Formulas and Formula Parameters

The formulas are entered in the work center and are used to calculate the duration of the operation segments setup, process and teardown. These formulas refer back to the formula parameters (for example, standard values 1-6, base quantity, operation quantity).

Calculating the Duration (Example)

The formula for calculating the duration of processing is, for example:

\[
\text{Duration} = \frac{(\text{operation quantity} \times \text{machine time})/\text{base quantity}/\text{operation splits}}{
\text{base quantity}}
\]

Entering example data, the result is:

\[
\text{Duration} = \frac{(10 \text{ pieces} \times 30 \text{ minutes})/2 \text{ pieces}/3 = 50 \text{ minutes}}
\]

Performance Efficiency Rate Key

The performance efficiency rate key defines the relationship between the entered target time to the actual time that you aim for. If a performance efficiency rate key is defined for a standard value, this standard value is entered in the formula with the performance efficiency rate key.

Standard Value Calculation

In addition to defining standard values manually, you can also get the system to calculate them for you.

On the Std. val. calculation tab page in the operation of a production order/routing, you can maintain data that specifies

- The type of standard value calculation (for example, using CAPP or estimation)
- The year in which the standard values were calculated
- The basis used for calculating the standard values
- The standard value code used for calculating the standard values (for example, tables containing planned times)

For more information about calculating standard values using CAPP, refer to the document PP-CAP - Standard Value Calculation [Ext].
Example: Determining the Operation Dates

An order contains two operations (operation 10 and operation 20). The order quantity is 100 pieces and the order start date has been set to Tuesday, May 2nd. The scheduling type is forward scheduling.

Duration of the individual Operation Segments for Operation 10

First, the system calculates the duration of the time segments for the operations (see Duration of the Operation Segments [Page 108]). To calculate the execution time, the system uses the formulas stored in the work center for setup, process or teardown and takes into account the performance efficiency rate specified for the individual standard values:

1 hour setup + 4 hours processing + 1 hour teardown = 6 hours execution time

The operation lead time is calculated by adding queue time and wait time to the execution time:

4 hours queue + 6 hours execution + 15 hours wait = 25 hours lead time

A move time of 0.5 hours is maintained between operation 10 and operation 20. This is assigned to the preceding operation (operation 10).

Calculating the Operating Time for Operation 10

The operating time of the work centers is calculated as follows:

The system calculates the working hours (standard available capacity) of the work center:

16:00 work finish - 7:00 work start = 9 working hours

The break times are subtracted from the working hours:

9 working hours - 1 hour breaks = 8 hours

The operating time of the move time is specified in the move time matrix: The shift starts at 7:00 and finishes at 17:00 and is a total of 10 hours.

Selecting a Calendar

The system now selects the valid factory calendars. The same factory calendar is maintained in both work centers. According to the factory calendar, work is carried out from Monday to Friday.

Calculating the Dates for Operation 10

The system has now collected all information relevant to scheduling and has calculated the duration of the individual operation segments. The next step is to calculate the operation dates. The system lines up the order floats and the individual operation segments along the time axis, taking into account the operating times.

The production order is scheduled using forwards scheduling so the system starts with the order start date (Tuesday, May 2nd).

Starting at the order start date, the float before production of one day is first added to the time axis. The scheduled start of the order is, therefore, Wednesday, May 3rd.

Starting from the scheduled start, the operation segments are now lined up on the time axis and the breaks are distributed proportionally among the individual operation segments.
Example: Determining the Operation Dates

Calculating the Operation Dates for Operation 10 Without Queue Time (Earliest Date)

<table>
<thead>
<tr>
<th>Segment</th>
<th>Duration</th>
<th>Operating time/day</th>
<th>Start</th>
<th>Finish</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup</td>
<td>1 hr</td>
<td>8 hr</td>
<td>3rd May 07:00:00</td>
<td>3rd May 08:07:30 1)</td>
</tr>
<tr>
<td>Process</td>
<td>4 hr</td>
<td>8 hr</td>
<td>3rd May 08:07:30</td>
<td>3rd May 12:37:30 2)</td>
</tr>
<tr>
<td>Teardown</td>
<td>1 hr</td>
<td>8 hr</td>
<td>3rd May 12:37:30</td>
<td>3rd May 13:45:00</td>
</tr>
<tr>
<td>Wait</td>
<td>15 hr</td>
<td>24 hr</td>
<td>3rd May 13:45:00</td>
<td>4th May 04:45:00</td>
</tr>
<tr>
<td>Move</td>
<td>0.5 hr</td>
<td>10 hr</td>
<td>4th May 07:00:00</td>
<td>4th May 07:30:00</td>
</tr>
</tbody>
</table>

1) The wait time is scheduled independently of the factory calendar.

2) The duration of the setup results from: Setup = 1 hour * (1 + 1/8) = 1 hour 7.5 minutes

3) The duration of processing results from: Processing = 4 hour * (1 + 4/8) = 4.5 hours

Calculating the Operation Dates for Operation 10 with Queue Time (Earliest Date)

<table>
<thead>
<tr>
<th>Segment</th>
<th>Duration</th>
<th>Operating time/day</th>
<th>Start</th>
<th>Finish</th>
</tr>
</thead>
<tbody>
<tr>
<td>Queue</td>
<td>1 hr</td>
<td>8 hr</td>
<td>3rd May 07:00:00</td>
<td>3rd May 11:30:00 AM</td>
</tr>
<tr>
<td>Setup</td>
<td>1 hr</td>
<td>8 hr</td>
<td>3rd May 11:30:00</td>
<td>3rd May 12:37:30</td>
</tr>
<tr>
<td>Process</td>
<td>4 hr</td>
<td>8 hr</td>
<td>3rd May 12:37:30</td>
<td>4th May 08:07:30</td>
</tr>
<tr>
<td>Teardown</td>
<td>1 hr</td>
<td>8 hr</td>
<td>4th May 08:07:30</td>
<td>4th May 09:15:00</td>
</tr>
<tr>
<td>Wait</td>
<td>15 hr</td>
<td>24 hr</td>
<td>4th May 09:15:00</td>
<td>5th May 00:15:00</td>
</tr>
<tr>
<td>Move</td>
<td>0.5 hr</td>
<td>10 hr</td>
<td>5th May 07:00:00</td>
<td>6th May 07:30:00</td>
</tr>
</tbody>
</table>

Calculations for Operation 20

The sum of wait, setup, processing and teardown time totals 14 hours. The operating time per day is 8 hours, as for operation 10. Teardown finish (latest date) is, as a result, scheduled for 8th May at 9:45:00 starting from 6th May at 7:30, because the factory calendar is not used on May 6th and 7th. The wait time of operation 20 is 15 hours. Since the wait time is scheduled independently from the factory calendar, it can be scheduled outside the working/operating time valid for this day. The scheduled finish falls on May 9th. Since operation 20 is the last operation in the order, there is no subsequent move time

Finally, the float after production is added to the time axis. The float after production for this order is 1 day. The order finish date is therefore 10th May.
Simultaneous Teardown and Wait

Use

Using the Parallel teardown/wait indicator on the Interoperation times tab page of the operation you can control whether the wait time and teardown time are to be scheduled as simultaneous or consecutive operation segments. The parallel positioning of teardown time and wait time reduces the lead time of the operation.
Queue Time (Earliest and Latest Dates)

The queue time is the interval between the **earliest** and **latest dates** of the operation.

During each scheduling run, the system calculates the earliest and the latest dates for the individual operation segments.

- When calculating the **earliest** dates and times the **queue time** is not used.
- When the system calculates the **latest** dates and times the system assumes that the **normal queue time** is valid.
Splitting

If an operation is usually carried out on several machines or by several employees at the same time, the operation can be split. Splitting is defined in the operation.

Splitting an operation has the following effects:

- The processing time/execution time is reduced compared with an operation that is not split
- Multiple setup and teardown is required for the operation

The system selects the minimum from one of the following as the actual number of splits:

- Number of splits in the operation
- Number of individual capacities of the work center capacity that is relevant to scheduling
Overlapping and Process Flow Production

Overlapping

If an operation is usually started before the preceding operation is finished, this is an overlap. The overlap is defined in the operation (Overlapping tab page).

In this case, the system calculates the start dates and finish dates in such a way that the overlapped operations can be carried out continuously, taking into account the minimum send-ahead quantity and the minimum overlap time. The waiting time of the overlapped operations is determined from the waiting time of the first operation (the overlapping sequence).

If you want to overlap two operations, you have to maintain the overlapping data on the operation detail screen in the first of the two operations (in the above figure, operation 10 and operation 40).

Process Flow Production

If operations are completely overlapped, regardless of their duration, this is called process flow production. Process flow production is defined in the operation (Overlapping tab page).

All operations for which process flow production is set up are lengthened, so that their execution time is equal to the execution time of the longest operation using process flow production.

When overlapping takes place or in the case of process flow production, all overlapped operations are scheduled with the queue time of the first operation that is overlapped.
Parallel Sequences

Use

A sequence groups together operations in the order. Operations in a sequence are processed according to their place in the sequence. Sequences are linked in network-like structures. Sequences are defined in the routing and transferred to the production order when it is created.

A parallel sequence is a sequence that runs parallel to operations in the standard sequence. The start of the parallel sequence corresponds to the start of the branch operation in the standard sequence. The end of the parallel sequence corresponds to the end of the return operation.

If several sequences run parallel in an order, the execution times are usually of varying lengths. As a result of this, time floats develop in the sequences. These floats may exist both at the start and at the end of the sequence. The alignment key of the sequence controls where a possible time float is situated in a sequence: If the sequence is aligned

- with the earliest date, the float is placed at the end of the sequence
- with the latest date, the float is placed at the beginning of the sequence

The alignment key is assigned to the standard sequence and to each of the parallel sequences in the routing.

The following diagram shows the connection between the alignment key and the chronological alignment of the sequences. While the three parallel sequences are aligned to the earliest possible date, the standard sequence has an alignment key that plans according to the latest allowed alignment.

Alternative sequences [Page 60] are only taken into account during scheduling when they have been exchanged with the standard sequence during the creation or change of a production order.
Suboperation Dates

Suboperations are not divided into individual operation segments. Instead, they are assigned a start and a finish date calculated with reference to a specific reference date in the corresponding operation.

To define the start and finish of a suboperation, you must go to the operation tab page "Suboperation dates."

The following data is required to calculate dates for a suboperation:

- A reference date (for example, the start date for setup or the finish date for the execution of the respective operation)

- A time interval:
  - If the time interval is positive, the system schedules forwards starting from the reference date.
  - If the time interval is negative, the system schedules backwards starting from the reference date.

If you have not maintained any scheduling data for a suboperation, the setup start date and the execution finish date of the respective operation are taken over into the suboperation.
Scheduling Partially Confirmed Operations

Use
There are two ways to schedule partially confirmed operations:

- **Partially confirmed operations**
  
  A partially confirmed operation is scheduled forwards starting from the actual finish date. Only the remaining duration is scheduled.

  The remaining duration of an operation is calculated according to the following formula:

  \[ \text{Remaining qty} = \text{original qty} - \text{actual qty} \]

  To calculate the duration of the operation segments, the remaining quantity and the forecast values are entered into the formula. If no forecast values were entered in the confirmation, the remaining quantity and the standard values are entered.

- **Shift order**

  You can set the Shift order indicator for scheduling partially confirmed orders (Customizing for Shop Floor Control by choosing Operations → Scheduling → Define Scheduling Parameters). This indicator causes the order to be shifted to a new date. The system carries out scheduling using the remaining duration of the operations, which means that the actual dates of the operations are no longer taken into account. The system schedules starting from the basic dates of the order using the remaining duration of the operations. The original setup duration is used for scheduling.
Lead Time Scheduling with Takts

Use

Production orders can be scheduled using the line hierarchy [Ext.] in the routing. The operation dates are calculated using the takts [Ext.] and takt times from the line hierarchy. To do this, it is necessary that a line hierarchy has been entered in the routing and the individual operations have been assigned to a takt. Lead time scheduling will be executed for operations that have not been assigned to a takt.

Scheduling occurs analogous to the scheduling [Ext.] in the sequencing (see Example 1 [Ext.], Example 2 [Ext.], Example 3 [Ext.]).

In addition, the duration of the operation steps is calculated using the default values in the routing. The information obtained from the durations can be compared to the results of the lead time scheduling with takts (for example, the check whether an operation can be processed in takt).
Reduction Measures

Use

If it turns out during scheduling that the lead time of an order is longer than the time available between the basic dates then the system tries to shorten the lead time by applying reduction measures.

The system reduces the lead time of the order step by step and checks after every reduction whether the dates calculated lie within the basic dates. If this is the case the reduction is terminated.

You can define a maximum reduction time for each order type, plant and production scheduler in the scheduling parameters (Customizing for Shop Floor Control, by choosing Operations → Scheduling → Define Production Order Scheduling Parameters).

With every reduction step the system has to reschedule the whole order. We recommend that you keep the number of reduction steps as low as possible on performance grounds.

Reduction Strategy

You can assign a reduction strategy to each operation in the routing. You can use this strategy to specify which reduction measures are carried out in every step. You define the reduction strategies in Customizing for Shop Floor Control by choosing Operations → Scheduling → Define Reduction Strategies.

Reduction in an Operation

The following operation-specific reduction measures are possible:
Reduction Measures

- Reduction of **queue time**
  
  You can specify for each reduction step by what percentage the queue time is to be reduced. However, the queue time may not be less than the minimum queue time.

- Reduction of the lead time by **splitting**
  
  Splitting up the operation between several employees or machines shortens the lead time.

- Reduction of the lead time by **overlapping**
  
  By overlapping operations the overall lead time of the order is reduced.

- Reduction of the **move time**
  
  The move time can be reduced to the minimum transport time.

  The process-related wait time cannot be reduced.

**Reduction in the Order**

You can also authorize a reduction of the [Order Float][Page 101] (float before and after production). You can specify for each reduction step by what percentage the float is to be reduced for each reduction step. You make this setting in the scheduling parameters for each order type, plant and production scheduler (Customizing for Shop Floor Control, by choosing Operations → Scheduling → Define Production Order Scheduling Parameters).
Starting Scheduling

Use
You can start scheduling manually at any time.

If changes relevant to scheduling are made in the order it is given the status NTUP (dates are not updated). In this case, the order is automatically rescheduled when it is saved, if at least one of the following conditions are fulfilled:

- The Automatic scheduling indicator is set automatically (Customizing for Shop Floor Control by choosing Operations → Scheduling → Define Production Order Scheduling Parameters).
- The order is released (REL status)

Procedure
1. Call up a production order (only in create or change mode).
2. Choose .
   The system schedules the production order and creates a scheduling log.
Displaying Scheduling Settings and Scheduling Results

Use
This section describes how to display the scheduling settings and the scheduling results.

Procedure

Call Settings
1. Call up a production order.
2. Choose Order \rightarrow Settings \rightarrow Scheduling.

Scheduling Results
You have different ways of displaying the scheduling results on the screen.

Scheduling Log
For every scheduling run, the system creates a scheduling log in the production order. The log records all information that is important for scheduling. If, for example, data relevant to scheduling is not maintained in a work center or an operation, the scheduling run is not interrupted. Instead, the information is gathered in the form of messages in the scheduling log.

The scheduling log is used to:
- Collect messages issued by the system during the scheduling run
- Sort and group together the system messages according to certain criteria.

In Customizing, you can define control parameters that specify whether the scheduling log is automatically displayed after each scheduling run, or whether it has to be called up via the menu.

1. Choose Goto \rightarrow Logs \rightarrow Scheduling
   An overview of the messages collected is displayed.
2. Choose \textbf{[].}
   A message list is displayed for all errors that occurred during scheduling.

Date Overview for the Order
Via the header screen Date/quantity overview, you can display the release, start and finish dates of the production orders as well as of the planned order, if a conversion has taken place.

1. Call up a production order.
2. Choose the tab page Dates/quantities.

Operation Dates
On the operation overview screen, select the operation for which you want to see the dates.

1. Choose \textbf{[].}
2. Choose the tab page *Dates.*
Scheduling Collective Orders

Use

If a production order contains a component that is manufactured using a second production order (direct production), the requirements date for this component serves as the order finish date for the second order. If the second production order again contains a component that is manufactured using a third production order, the requirements date for this component serves once again as the order finish date for the third order, and so on.

When you are scheduling a subtree or a complete collective order, you enter framework dates in the order that is on the top level. These framework dates serve as a guideline. They mark out the period within which the system tries to schedule the current order and all the subordinate orders.

Collective orders are normally scheduled backwards. Therefore, if you have entered a framework finish date in the top order of a collective order, the system goes backwards from this date and schedules each order backwards, starting with the requirements date for the component, that is produced in the order. The order start date for the earliest production order is identical to the framework start date for the collective order.

The following graphic contains an example of backwards scheduling in the collective order (without Taking Into Account Move Time [Page 127]):

[Diagram of collective order scheduling]
Features

Dates Proposed Manually in a Collective Order

Framework dates serve as guidelines for scheduling the collective order: When scheduling a subtree or a complete collective order, you must propose at least one framework date according to the scheduling type:

- Framework finish date
  The system tries to complete the current order and all dependent orders before this date.

- Framework finish date
  The system schedules the current order and all dependent orders after this date.

- Framework start and finish date
  The system tries to schedule the current order and all dependent orders within the specified time period. On scheduling, if it is established that the framework dates cannot be kept to, then the system uses reduction measures to try to shorten the lead time of the scheduled orders.

If an order’s start date is in the past, the system switches to Today Scheduling [Page 94]. In this case, you receive an appropriate warning message in the scheduling log.

You can propose framework dates on various levels in a collective order. Note, however, that every proposal of a framework date represents a fixed schedule for the corresponding sub-tree. This may lead to the situation in which the dates of individual orders in the collective order are no longer coordinated.

Calculated Dates in a Collective Order

Collective order scheduling calculates the dates for the individual orders (basic dates and scheduled dates) and the scheduled dates for the collective order.

The result of lead time scheduling has the following effect on the collective order dates:

- The earliest order start date of all orders represents the scheduled start of the collective order
- The latest order finish date of all orders represents the scheduled finish date of the collective order
- If the framework dates could not be kept to, then the scheduled dates and the framework dates in the collective order are different. In this case, you receive an appropriate warning message in the scheduling log.

Scheduling Individual Orders in a Collective Order

When you schedule an individual order, proceed as for scheduling a normal production order.

Scheduling Subtrees or Whole Collective Orders

When you schedule more than one order at the same time

- Scheduling can only be executed if you access the sub-tree or the entire collective order
Scheduling Collective Orders

- Framework dates that were entered at a lower level are taken into account during the scheduling run.

- The user has to enter at least one framework date:
  - The system tries to keep to all existing framework dates that were entered on a lower level.

    Framework dates are only then written to an order, if they are entered manually.

  - The basic dates for all orders in the subtree / collective order to be scheduled are brought into line with the scheduled dates.
  - Forward scheduling allows both basic dates to differ from the framework dates.
  - With backward scheduling, the order finish date should be the same as the framework date.

    If an order deadline that is determined in a scheduling run comes after the requirements date for the components to be produced, the scheduling log informs the user about it. If the user saves the orders despite this warning, then a system status is set in the corresponding order.
Linking Dates in Collective Orders

Use

Orders within a collective order are linked via the requirements date of the corresponding component in the superior order. The scheduling of the subordinate order is based on this requirements date.

You can choose whether the **move time** should be taken into account when scheduling. Move time is the time required to move a material from one work center to another. Move time is defined in the operation or in the move time matrix (see [Operation Segments](#)). If you want this to be taken into account when scheduling a collective order, you have to maintain the move time in the corresponding operation of the subordinate order.

In the component (General data tab page), you can define which option is used for linking the dates of the orders. In Relationships, if you

- Enter a time unit, the system schedules without move time
  
  If you specify a duration as well as a time unit, the subordinate order is changed accordingly. The requirements date of the component is transferred to the order finish date of the subordinate order.

- Do not enter a time unit, then the system schedules with move time
  
  The finish date of the last operation of the subordinate order is set to the requirements date and the move time of this operation is taken into account. In this case, the order finish date of the subordinate order and the requirements date of the component can be different, as long as a float after production has been maintained in the subordinate order.

Features

Scheduling Without Taking Move Time Into Account

The starting point for scheduling is the requirements date of the component in the superior order. All time elements in the subordinate order come before this point of time, starting with the float after production.

Scheduling Taking Move Time Into Account
Linking Dates in Collective Orders

In this example, a move time is maintained in operation 30 in the subordinate order. The starting point for scheduling is the requirements date of the component in the superior order. The move time is deducted from these dates in order to calculate the scheduled finish for the subordinate order.

The float after production is added to the scheduled finish, to define the basic finish date for the subordinate order.

Note that in this scheduling option, the superior order is linked to the subordinate order via the **scheduled finish date** (and not the basic finish date).

**Determination of the Order Dates**

If you have proposed an in-house production time \( > 0 \) days in the material master record, the order finish date that is calculated is always moved to 0:00 on the following workday.

You want to directly produce a pressure regulating valve. In collective order scheduling, the system determines that the order finish date is 14:00, on August 5th. An in-house production time of one day is specified in the material master record, therefore the order finish date is set to 0:00 on August 6th.
Overlapping in Collective Orders

Use
You can maintain overlaps between orders in a collective order. During scheduling, the system creates overlaps between the last operation in the subordinate order and the operation in the superior order in which the components are required, according to the settings you have made. Only the minimum move time of the last operation in the subordinate operation is used in scheduling.

Prerequisites
For an order in a collective to overlap with a superior order, the following requirements must be fulfilled:

- You must have set up the overlap parameters in the last operation of the subordinate order (Overlap operation tab page)
- You cannot enter an offset in the superior order for a component that is directly produced in the subordinate order.

An offset (Offset field) is the time between the requirements date of the component and the basic finish date of the subordinate order. You maintain this in Component detail data on the General data tab page in the Relationship menu.
Reduction via the Critical Path

Use

In order to reduce the lead time of a collective order or an order with parallel sequences, you specify that reduction is only carried out on operations, if a reduction in their execution time leads to a reduction in the overall lead time of the order or collective order. The sequence of such operations in the order or collective order forms the “critical path”. If applying reduction measures to an operation, would not lead to an overall lead time reduction, this operation is not reduced.

In this reduction type reduction measures are carried out until the overall lead time has been reduced sufficiently. You can consequently retain floats for uncritical operations and prevent unnecessary splits or overlaps.

Prerequisites

You set up reduction via the critical path in Scheduling parameters for production orders by selecting the reduction type (in Customizing for Shop Floor Control by choosing Operations → Scheduling → Specify Scheduling Parameters).

You can also choose another reduction type in order maintenance for a single order or a collective order, by choosing Order → Settings → Scheduling. This overwrites the settings you made in Customizing (as do the other settings for reduction).

If a routing or a production order does not contain parallel sequences or does not belong to a collective order, there is no critical path. All operations are then reduced, irrespective of whether you have selected reduction via the critical path or not.

Features

You can choose reduction via the critical path for

- Production orders with parallel sequences
- Collective orders with production orders

Activities

Process Flow for Reduction

In reduction via the critical path the system first determines which operations lie on the critical path. These operations are then lead time scheduled using the selected reduction strategy and reduction level 1. The floats in your order are also reduced according to the settings. If the overall lead time has been sufficiently reduced after this first reduction run, no further reduction is carried out.

If it is not sufficient, the system determines the critical operations (operations on the critical path) again. This could include different operations to those in the first critical path. The reduction level of the operations on the new critical path is increased by one, the uncritical operations are left as they are. Lead time scheduling is carried for the order or collective order again. If the collective order or the order can be carried out within the framework dates or the basic dates respectively, the reduction is sufficient.

If the reduction is not sufficient, the system repeats this process until it is sufficient or in all operations on the critical path the maximum reduction level has been reached:
1. Determine critical path
2. Increase the reduction level of critical operations by 1
3. After lead time scheduling, check whether the overall lead time has been reduced sufficiently.

In this process only the critical operations are reduced in each reduction step. Consequently each operation is reduced by the smallest reduction level necessary.

**Recommendations for Working with Reduction via the Critical Path**

Reduction via the critical path places greater demands on the system as reducing all operations step-by-step. The following procedure is a good compromise between performance and effective scheduling.

1. Carry out a reduction run for all operations.
   - All the operations are reduced to the same reduction level. You carry out this reduction, to determine the maximum reduction level, at which the critical operations have to be reduced, so that the overall lead time is sufficiently reduced.

2. Execute the reduction again, but this time via the critical path.
   - Enter as the maximum reduction level the level you determined above.

Through this procedure, only the critical operations are reduced with the maximum level that is necessary to reduce the overall lead time. Other critical operations are reduced with a smaller reduction level. The operations whose reduction does not contribute to a reduction of the overall lead time are not reduced.
Scheduling of Requirements Dates

Use

During scheduling, the requirements dates of components are also determined. The requirements date of a component is set to the order start date of the order to which the component is assigned. You find the requirements date in the component tab on the General data tab page in the Dates section.

If a component is required at a later or earlier stage, you can shift the requirements date. To do this, you use the Lead-time offset and Op.LdTimeOffset fields on the component tab on the General data tab page, in the Dates section.

Lead-Time Offset

If you make an entry in the Lead-time offset field, the requirements date, which is initially set to the order start date, is moved. During order scheduling, only negative values are allowed. That is, the component must be available before the scheduled start (lead time).

The order start date of an order is 04.20.2000 7:00am You enter a safety time of 2 days for component ABC (2- entered in the field). The requirement date of the component is set to 04.18.2000 7:00am

Lead-Time Offset for an Operation

If you make an entry in the Lead-time offset field, the requirements date, which starts as the start date of the operation to which the component is assigned, is moved. Depending on the symbol that you enter: Lead-time offset (positive value): Component can be available after the start date of the operation

Lead time (negative value): Component must be available before the start date of the operation

Component ABC is required for operation 10. The start date of operation 10 is 5.4.2000 at 9.15am. You enter a lead-time offset of 3 days. The requirements date of component ABC is set to 5.10.2000 at 09:15am, taking into account the weekend.

The entries in the Lead-time offset and Op.LdTimeOffset fields are transferred from the bill of material and can be changed in the order, except in the case of directly produced components. If both values are maintained, the entry in the Op.LdTimeOffset field takes precedence. The field with the time unit is valid for both fields.
Capacity Requirements

Use

The capacity requirements are calculated for an operation using the formulas that are maintained per capacity category on the Capacities tab page of the work center. However, the capacity requirements of an operation can only be calculated if the Control Key [Page 95] of the operation allows this. The dates of calculated capacity requirements correspond to the dates of the operation.

Features

Assigning Individual Capacities

In the production order you can specify which individual capacities are used to cover which capacity requirements.

Operation 30 is a milling operation. In the production order you specify that this operation is to be carried out on machines 001 and 002 by employees A and C.

You can distribute this operation quantity to as many individual capacities as you wish.

The operation quantity for operation 30 is 100 pieces. In the production order you specify that 40 pieces are to be processed by machine 001 and 60 pieces from machine 002, or 40 pieces by employee A and 60 pieces by employee C.

Capacity Requirements Assignment with Standard Value Splits

In the case of an assignment of capacity requirements the operation quantity is distributed between several machines or people. Depending on how you split up the operation requirements, it may be necessary to change the standard values.

You have an operation quantity of 100 pieces. Employee A and employee B process the same 100 pieces on a machine one after the other. In this case the split quantity for employee A and employee B is 100 pieces each. However, since every employee only needs half of the time to process each piece the standard values of the individual capacities for people must be reduced accordingly.

You can change the standard values of an individual capacity in the production order on the operation tab page Assignment of capacity requirements by choosing standard values (beneath the level of the section with individual capacities).
Assigning Capacity Requirements

Prerequisites
You can only assign capacity requirements in the production order, if you have already defined individual capacities in the corresponding work center.

Procedure
1. Call up the operation overview in the production order.
2. Select the relevant operation and choose .
3. Choose the tab page Assignment of reqmts.
4. Choose the capacity category for which you want to assign the requirements:
   - with the machine assignment you specify the description of the relevant machine.
   - when assigning personnel you specify the name of the relevant employee.
5. Enter the split quantity for each individual capacity.
6. If necessary adjust the standard values.
7. Save your entries.
Dispatching and Deallocating Without the Planning Board

Use
You can use this function to:
- Dispatch or deallocate operations
- Deallocate all operations of a production order

Dispatching
Proceed as follows when dispatching:
1. Dispatch an operation. The operation receives the status DSPT (dispatched). The capacity requirements are planned without capacity leveling.

   The system issues a warning if a capacity is overloaded.

2. If necessary, change the operation dates of the dispatched operation (operation tab, Dates tab page).

3. Midpoint scheduling is used when the order is rescheduled. The dates of the dispatched operation are not adjusted.

Activities
- To dispatch an operation, select Operation → Dispatch on the operation overview (select operation) or on the tab page.
- To deallocate an operation, select Operation → Deallocate on the operation overview (select operation) or on the tab page.
- To deallocate all operations of a production order, select Functions → Deallocate.

See also:
Executing Capacity Leveling (SFC) [Ext.]
Capacity Leveling in Shop Floor Control [Ext.]
Components

Use
When you create a production order, you need to specify the components required for production in the order. If the relevant data is already contained in the master data, it is automatically transferred into the production order.
Data from Bills of Material

If a bill of material exists for the material to be produced, the BOM items contained in the bill of material are automatically copied to the production order as components. The following information is also copied for each BOM item:

- **ItemCat**: The item category determines, amongst other things, how the component is dealt with in the order:
  - **Category “L”: Stock item**
    When you open an order, the system creates a reservation.
  - **Category “R”: Variable-size item**
    This item category is a stock item, for which variable-size data is also maintained.
  - **Category “N”: Non-stock item**
    When you open an order, the system creates a purchase requisition.
  - **Category “T”: Text item**
    This item category has no reference to a material. The item only contains text.
  - **Category “D”: Document item**
    You use this item category to account for different types of documents (for instance technical drawings, graphics, photos).
  - **Category “I”: PM structure element**
    This item category designates an item that is used to describe the structural design of a piece of equipment (PM assembly). It is only relevant for maintenance BOMs.

  BOM items with categories “D” or “I” are not copied to production orders.

- **CostingRelevncy**: This indicator determines whether the component is costed.

- **Bulk material**: If a material is a bulk material, it is not withdrawn specially for the order, rather it is staged to the work center. A bulk material item is only for information. It is not relevant for MRP or costing.

- **Op.LdTimeOffset**: With the follow-up time you specify whether a component has to be available before (negative value) or after (positive value) the start date of an operation.
Data from the Routing

If a routing exists for the material to be produced, components can be assigned to specific operations in the routing.

If necessary, the following indicator is copied from the operations in a routing:

- **Backflushing**: If the Backflushing indicator is set for a component, the withdrawal posting for the component is carried out automatically with the completion confirmation of the operation to which the component is assigned. You can set this indicator on the General data screen of the component (see Changing Component Data [Page 141].)

The Backflushing indicator can also be set in the work center and in the material master (see Goods Movements During Confirmation [Page 344]).
Data from the Material Master Record

The following key is copied, if necessary, from the material master record of the component:

- **Phantom assembly**: If a component is marked in its material master record as a phantom assembly (special procurement key in planning), this indicator is copied into the order with the component.
Manually Creating or Changing Components

Use
Components can be added to, changed or deleted from a production order that has been created or released at any time. Note, however, the following:

- You cannot change the item category of a component once it has been created in the order.
- If you delete a component that is assigned to a released operation, the system continues to display the component in the order. However, you can no longer enter data for the component. The status *Deletion indicator set* is activated in the component.
Changing Component Data

Use
You can make changes to the component data both in create and in change mode.

Procedure
1. In the order header, choose 📰.
   The component overview appears.
2. Select a component and choose 📰.
   The tab of the component appears. The following tabstrips exist:
   − General data
   − Purchasing data
   − Variable size item data
   − Co-product
   − Text item
   − Long text:
3. Make the necessary changes and save the order.
Assignment of Components

Use

Components can be assigned to different operations in the production order. Assignment can be carried out either

- Using the routing
- In the production order

All components that are not already assigned to a specific operation in the routing are assigned automatically to the first operation when the order is created. You can, however, change the assignment of components by reassigning them to different operations.
Creating Components

1. Choose 📊.

2. Select the operation to which you want to add the component. Select 📊 Components and then 📊. The system displays a list screen in which you can enter new components.

3. Enter the following data for every component:
   – requirements quantity of the component
   – unit of measure of the component
   – item category
   – if necessary, the material description

4. Choose 📊.

   If the system needs further information for entering the component, it branches automatically to the corresponding detail screen where the data needs to be entered. When entering a non-stock component, for example, you automatically branch to the purchasing data screen.
Reassigning Components

1. Choose 📁. You receive a list of the components contained in the production order.

2. Select the component that you want to reassign to another operation. Choose 📁. A dialog popup appears.

3. You have two options:
   – If you know to which operation you want to reassign the component, enter the operation number in the popup.
   – If you do not know to which operation you want to reassign the component, choose 🐸. You can then select an operation from the list displayed.

4. Choose 📁.
Sorting in the Component Overview

Use
You can sort the components in the component overview in the production order any way you like.

Features
You can choose from the following sort types when maintaining an order:

- Standard sorting (according to item number and component description)
- BOM sorting (corresponds to the structure list)
- Multi-level dummy structures are not be separated
- Manual sorting (according to a temporarily created sort profile)
- Column sorting upwards (sorting according to selected column)
- Column sorting downwards (sorting according to selected column)
- Profile from Customizing (Customizing for Shop Floor Control by choosing Screen Control→Define Sort Criteria for Components)
- Profile defined in the production order

Profile Definition in the Production Order
You can define your own sort profiles during order maintenance. The system does not propose those profiles already defined by other users in the dialog box. You can use the following columns as sort criteria (for example): Operation number, BOM item number, component description, requirements date.

User Parameters
You can predefine the sorting of components in the user parameters. These parameters are evaluated when you call up the component overview:

- Set the user parameter S5F to “X” if you want to sort the same way as in the bill of material.
- In the user parameter S3F, you can specify which profile is to be used. The entry in user parameter S5F overrides that in S3F

Activities
- Select the corresponding entry in order to sort the components (the field to the right next to 📅).
- In order to create or change a profile, choose Components → Profile → Create/change sort profile in the component hierarchy
Filtering in the Component Overview

Use
You can filter the components in the component overview in the production order any way you like. The system then displays only those components that meet the specified criteria.

Features
You can select the following types of filtering when maintaining an order:

- No filter
- Manual filter (according to a temporarily created filter profile)
- Profile from Customizing (Customizing for Shop Floor Control by choosing Screen Control → Define Filter Criteria for Components)
- Profile defined in the production order

Profile Definition in the Production Order
You can define your own filter profiles during order maintenance. The system does not propose those profiles already defined by other users in the dialog box. You can save field values (for example, for the selection of dummy components) in the profiles that you define in the order. If you have not defined values in the profile, the system will display a dialog box asking you to enter field values. You can use the following fields as filter criteria, for example: missing part, item category, dummy assembly.

User Parameters
You can define the filter profile that will be evaluated when the component overview is called up in the user parameter F1F.

Activities

- To filter the components, select the corresponding entry (the field to the right next to ).
- To create or change a profile, choose Components → Profile → Create/Change Filter Profile in the component hierarchy
Deleting Components

As long as the production order is not released, you can delete material components. Proceed as follows:

1. Choose ✖.

2. Select the components that you want to delete. Choose ✖. The system deletes the material components.
Backflushing with Stock Shortage

Use

If a component could not be backflushed due to missing stock, the system sets a corresponding status in the component. You then have the possibility of posting the withdrawal of this component manually at a later date (see Reprocessing Goods Movements [Page 359]).
**Alternative Items**

**Use**

In the bill of material, alternative items are assigned to an alternative item group. On the *General item data* detail screen, you enter the same freely-definable character string (for example, *A1*) for all related alternative items in the *AltItemGroup* field.

In the production order you can see this assignment on the *General data* tab page of the corresponding components (*Alternative data* pushbutton).

The system carries out additional checks for an alternative item:

- An alternative item cannot also be a co-product
- Discontinuation data (*Discontinuation data* function key) is not supported for alternative items
- If an alternative item is defined as a material to be discontinued in its material master, you see a warning when you enter the alternative item group in the BOM: When the BOM is processed in related application areas (for example, MRP), the alternative item overrides the discontinuation data.
- An item in an alternative item group cannot be a phantom assembly

You can enter the following additional data both in the BOM and in the production order: *Priority, Strategy, and Usage probability*.

- **Priority**
  
  In this field, you define the priority of the item within an alternative item group. This determines the priority for planned withdrawal of items.

    - Two items are assigned to an alternative item group (*A1*) with the following values for priority:
      - Item 0060 Value for priority: 02
      - Item 0065 Value for priority: 01

    The system reads item 0065 first.

- **Strategy**
  
  You use the strategy to determine how selection of the item for planned withdrawal is controlled within the alternative item group.

  The strategy should be the same for all alternative items in an alternative item group.

    - If the value 2 (100% check) is defined for the strategy, the first material in the defined priority sequence for which sufficient quantities are available is reserved.

- **Usage probability**
  
  MRP plans these alternative material components according to probability of use.
Alternative Items

In this field you enter a percentage to show the probability of using an object in production. Material requirements for the BOM components are planned according to the usage probability. Variant parts of a standard product are also planned according to the usage probability.

If you do not enter a usage probability for the alternative item, a warning message appears. In this case, MRP does not receive any quantities for planning the material.

The planned withdrawal for the production order is based on reservation lists. These lists are based on the priority and strategy for the alternative item.
Discontinuation Data

Use
In MRP, the discontinuation functionality is used to transfer dependent requirements of a component to one or several follow-up materials, if the requirements are no longer covered by stock. You can also define a follow-up material in the bill of material.

The follow-up item defined in the bill of material overrides any follow-up material maintained in the material master record.

You cannot maintain discontinuation data for text items or class items.

Features
A distinction is made between the following:

• Simple discontinuation
  You assign a follow-up material to the material that you wish to discontinue. The missing requirement quantity is then automatically assigned to the follow-up material.
  You can assign a follow-up material to a material in the material master and in the bill of material.

• Parallel discontinuation
  A main material (main item in a group of parts to be discontinued) controls the discontinuation of further materials using a group key. The missing quantity of the discontinued material is assigned proportionally to the planned quantity of the follow-up materials.
  You can only maintain items of parallel discontinuation in the bill of material.

Requirements for Discontinuation
The following requirements must be met for follow-up materials and parts to be discontinued:

• Both materials must be planned using MRP
• The base unit of measure of the follow-up material must be the same as the base unit of measure of the discontinued material
• In the bill of material, you enter discontinuation data for the discontinued item and follow-up data for the follow-up item
• The system checks the following item data:
  − You can only define a stock item or variable-size item as a discontinued or follow-up item
  − If a stock item or variable-size item is assigned to an alternative item group, you cannot maintain discontinuation data for it
  − If you have already maintained discontinuation data for an item, you can no longer assign the item to an alternative items group
Discontinuation Data

- Discontinuation functionality is not supported for co-products

The discontinuation functionality does not work over multiple BOM levels. This means that if the discontinuation indicator 1 (single/parallel discontinued part) is set in the material master of a material, this material can no longer be entered as a follow-up material in the bill of material.

Discontinuation Data

You enter the data for discontinuation on the General data tabstrip. You maintain discontinuation data via the function key Discontinuation data.

In a dialog box, you can display or maintain the following data for the item:

- **Discontinuation group**
  
  This freely-definable character string groups together related discontinued items of a bill of material.

  - You can only enter a discontinuation group for an item if the discontinuation indicator is selected in the material master (MRP view). The discontinued item is replaced by a follow-up item.
    
    A follow-up group is maintained for the follow-up item. The follow-up group should have the same value as the discontinuation group of the discontinued item (see Examples for discontinuation data).

  - You can implement parallel discontinuation using the discontinuation group. When one item is discontinued (the main item to be discontinued), another item is discontinued with it (subordinate item to be discontinued).
    
    For example, if a nut is discontinued, the bolt that goes with it is also discontinued.

    To carry out a parallel discontinuation, you need to identify the main item to be discontinued in the bill of material and the subordinate item to be discontinued using the same discontinuation group (see example below).

- **Follow-up group**
  
  This freely-definable character string groups together related follow-up items in a bill of material. The follow-up group also determines which discontinued items this follow-up item replaces.

  - you can only enter a follow-up group if the item is kept in stock (for example, a stock item)

  - You can only maintain an item as a follow-up item when you first enter the item. Once you have saved the item, you can no longer change the value in this field.

  - the follow-up item replaces the discontinued item that has this value in the Discontinuation group field (see example for the Discontinuation group field).

- **Discontinuation type**
  
  If this indicator is set, the material is defined as ‘to be discontinued’. The material is then discontinued in MRP. MRP transfers dependent requirements that are no longer covered by stock of this material to the follow-up material. The system determines this value from the material master record.
Examples for Discontinuation

The following examples illustrate how discontinued and follow-up items are used:

**Simple discontinuation**

In this case, Item 0010 (material M-2) replaces Item 0010 (Material M-1). There is no need to define a discontinuation group or a follow-up group.

<table>
<thead>
<tr>
<th>Item</th>
<th>Material</th>
<th>Discontinuation type</th>
<th>Discontinuation group</th>
<th>Follow-up group</th>
</tr>
</thead>
<tbody>
<tr>
<td>0010</td>
<td>M-1</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0010</td>
<td>M-2</td>
<td>1</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Parallel discontinuation**

In this case, the discontinued items 0010 (material M-1) and 0020 (material M-2) are replaced by the follow-up item (material M-3). Material M-1 is the main material to be discontinued (discont. type 2), material M-2 is the subordinate material to be discontinued (discont. type 3), and material M-3 is the follow-up item (discontinuation indicator 5).

<table>
<thead>
<tr>
<th>Item</th>
<th>Material</th>
<th>Discontinuation type</th>
<th>Discontinuation group</th>
<th>Follow-up group</th>
</tr>
</thead>
<tbody>
<tr>
<td>0010</td>
<td>M-1</td>
<td>2</td>
<td>A1</td>
<td></td>
</tr>
<tr>
<td>0020</td>
<td>M-2</td>
<td>3</td>
<td>A1</td>
<td></td>
</tr>
<tr>
<td>0030</td>
<td>M-3</td>
<td>5</td>
<td></td>
<td>A1</td>
</tr>
</tbody>
</table>

**Parallel follow-up**

In this case, the discontinued item 0010 (material M-1) is replaced by the follow-up items 020 (Material M-2) and 0030 (Material M-3). Material M1 is to be discontinued (discont. type 2), materials M-2 and M-3 are the follow-up items (discont. type 5).

<table>
<thead>
<tr>
<th>Item</th>
<th>Material</th>
<th>Discontinuation type</th>
<th>Discontinuation group</th>
<th>Follow-up group</th>
</tr>
</thead>
<tbody>
<tr>
<td>0010</td>
<td>M-1</td>
<td>2</td>
<td>A1</td>
<td></td>
</tr>
<tr>
<td>0020</td>
<td>M-2</td>
<td>5</td>
<td></td>
<td>A1</td>
</tr>
<tr>
<td>0030</td>
<td>M-3</td>
<td>5</td>
<td></td>
<td>A1</td>
</tr>
</tbody>
</table>

For information on how to maintain discontinuation data, see the document *PP Bills of Material*. 
Batch Determination

Use
If a production order contains components that are managed in batches, you can manually trigger the batch determination process for these components.

Batch determination selects all batches, that comply with selection criteria specified in Customizing and which have stock available on the requirements date of the component.

Prerequisites
To be able to use the batch determination function, the following requirements must be met:

• The component must be kept in stock
• The component must be marked as being managed in batches in the material master
• A search strategy (search procedure) for batch management must be maintained in Customizing as an order type-dependent parameter

You can find more information on the selection criteria in the Implementation Guide (IMG).
Executing Batch Determination

1. Branch to the component overview screen.

2. Select the material component for which you want to execute batch determination and choose Component → Batch management → Trigger batch determination.

   The system lists all batches that meet the selection criteria and that have available stock on the requirements date.

   You can change the proposed assignment of the requirement quantity any way you want.

   

   If the system cannot select any batches using the selection criteria entered, you can switch off the selection criteria off by choosing Batch determination → W/o class selection.

3. Choose .
Batch Splits

Use
If a material is managed in batches, you can carry out a batch split for every component. This means that if you split a batch, you assign more than one batch to one component. In this case, each batch is displayed as a separate component in the component overview.

Batch splits can only be triggered manually in the production order.

Prerequisites
The following requirements must be met for batch splitting:

- The material master record of the material must specify that the material is managed in batches
- Batches must exist for the material
Splitting Batches

1. Branch to the component overview screen.

2. To carry out **automatic batch splitting** via batch determination, proceed as follows:
   a. Select the component that you wish to split and choose **Component → Batch management → Trigger batch det.**
      The system lists all batches that meet the selection criteria and that have available stock on the requirements date.
   b. Distribute the required quantity as required over the existing batches.
   c. Choose .
      The system copies each batch as a separate component into the component overview screen.
      For more information refer to Batch Determination [Page 154].

   To carry out **manual batch splitting** with manual batch assignment, proceed as follows:
   a. Select the component for which you want to carry out batch splitting. Choose **Edit → Insert → Batch split.**
   b. Enter the batch number and the required quantity manually in the component.
   c. Save your entry.
Batch Splits: Requirement Quantities

Use

If a component is split into separate batches, you can distribute the required quantity over the individual splits.

To find out information about the requirements situation of a component with batch splits, you first need to branch to the component overview.

- If you want to see the total required quantity of a component, or the portion that has not yet been assigned to a batch, choose for the item in question (batch key):
  - The field `Reqmts qty` contains the requirements quantity that has not yet been assigned to a particular batch.
  - The field `Original qty` contains the total requirements quantity of the component.

You can manually change the original quantity of a component. If you should do so (for example, because you need less of the component than usual), we recommend that you delete any previously assigned requirements quantities and carry out another batch determination.

- If you want to see which portion of the requirements quantity has been assigned to a particular batch, choose for the item in question (batch key).
  - The field `Reqmts qty` contains the portion of the requirements quantity, that has already been assigned to this batch.
Batch Key

If a component in a production order is managed in batches, it is assigned a batch key. The batch key is displayed on the component overview screen and on the detail screen ‘General View’. The following keys exist:

- **‘X’ Batch allowed**
  This key specifies that the component is managed in batches, but that no batch splits have been carried out.

- **‘1’ Batch totals record**
  This key specifies that a batch split has been carried out for the component. An entry with this key displays the total requirements quantity of the component and the quantity that has not yet been assigned.

- **‘2’ Batch single record**
  This key specifies that a batch split has been carried out for the component. An entry with this key shows the portion of the requirements quantity that has been assigned to a particular batch.
Production Resources and Tools (PRTs)

Definition
The business object *Production Resource/Tool* (PRT) is a moveable operating resource used in production or plant maintenance.

Use
The R/3 System differentiates between the following types of production resources/tools, according to their properties and business function:

- Materials that are accounted for in materials management, for instance in inventory management, requirements planning and procurement.
- Equipment that is serviced, for example measuring instruments or valuable tools
- Documents that use the document management system, for example drawings or programs
- Miscellaneous production resources/tools (with a PRT master record) that require less maintenance in the system

You can assign production resources and tools to the task lists and production orders for which they are required.

Production resources/tools that are used for testing during production can be assigned to the corresponding inspection characteristic in the inspection plan.

At the moment you cannot use PRTs in process orders.

Integration
You can use user-defined criteria to classify PRTs in order to help you find them in the system.

PRTs can be linked with a document info record so that you can refer to additional information, for example a design drawing.

See also:

- CA - Classification System [Ext.]
- CA - Characteristics [Ext.]
- CA - Document Management [Ext.]
Creating Production Resources/Tools as Material

1. On the R/3 main menu, choose Logistics → Production → Master data → Production resources/tools, and then Prod.resources/tools → Material → Create general.

   If you want to create the production resource/tool (PRT) for a certain date in the future, rather than immediately, choose Material → Create → Schedule.

2. Enter the data on the initial screen.
   
   Use a material type that allows you to maintain the Production Resources/Tools view. In the standard system, the material type Prod.resources/tools has been defined for this purpose.

3. Choose .

   The Select View(s) dialog box appears.

4. Select the Production Resources/Tools view and, if required, views of other user departments in which PRTs are to be taken into account. Choose Continue.

   The Organizational Levels dialog box appears.

5. Enter the plant to which you want to assign the PRT, as well as organizational levels and profiles if you have selected further views.

   If you have specified on the initial screen that you want to copy from a reference, also enter the organizational levels from which the reference data is to be copied.

6. Choose .

   The first view appears.

7. Enter data as required and choose the next tab page.

8. Repeat step 6 until you have maintained all views.

   By specifying the MM/PP status, you release the material for use as a production resource/tool.

   After you have assigned the material as a production resource/tool to operations, you can no longer change the base unit of measure or the unit of issue.

9. Save the material.

See also:

Creating Production Resources/Tools as Equipment

1. On the R/3 main menu, choose Logistics → Production → Master data → Production resources/tools, and then Prod.resources/tools → Equipment → Create.

2. Enter the data on the initial screen.
   Use an equipment category that allows you to maintain production resources/tools data.
   In the standard system, equipment category $P$ has been defined for this.

3. Choose $\ldots$.

4. If you have specified a reference to be copied from on the initial screen, select the data to be copied and choose $\ldots$.

5. Enter the data.

   The PRT automatically has the status Released. If you want to lock the PRT, for example, because it is defective, choose Equipment → Functions → Active <-> Inactive → Deactivate.

6. Save the equipment.

**See also:**

*PM - Structuring Technical Systems*, section Working with Equipment
Creating Production Resources/Tools as a Document

1. On the R/3 main menu, choose Logistics → Production → Master data → Production resources/tools, and then Prod.resources/tools → Document → Create.

2. Enter the data on the initial screen.
   Use a document type that has been defined for use as a production resource/tool.

3. Choose 📝.

4. Enter the document data.
   For more information, see CA - Document Management Guide.

      By specifying the document status, you release the document for use as a production resource/tool.

5. Save the document.

See also:

CA - Document Management Guide
Creating Prod. Resources/Tools with a PRT Master Record (Misc.)

1. On the R/3 main menu, choose Logistics → Production → Master data → Production resources/tools, and then Prod.resources/tools → PRT master (misc.) → Create.

2. Enter the data on the initial screen and choose ➢.

3. If you have specified a reference to be copied from on the initial screen, select the data to be copied and choose ➢.

4. Enter the data.

5. Choose Goto → Defaults and enter the default values for assigning the PRT to operations.

   If you want to take specific properties of the PRT into account in the formulas for the quantity and usage value, define these properties as formula constants for the PRT. To do so, choose Extras → Formula constants.

6. Enter additional texts for the production resource/tool if required.

   – To enter language-dependent short texts, choose Extras → Short text.

   – To enter a long text, choose Extras → Long text.

7. Save the PRT.
Classifying Production Resources/Tools

This procedure describes how to classify a production resource/tool (PRT) with a PRT master record (miscellaneous).

For information on how to classify the other PRT categories, see:
- for materials choose LO - Managing Material Master Data
- for equipment - PM - Structuring Technical Systems
- for documents - CA - Document Management

Prerequisites

The class to which you want to assign the production resource/tool (PRT) has been created with class type 009 Production resources/tools in the classification system; see CA - Classification Guide.

Procedure

1. Choose Logistics → Production → Master data → Production resources/tools and then Prod. resources/tools PRT master (misc.) → Change.
2. Enter the PRT key and choose .
3. Choose Class overview and if necessary choose a class type.
4. Enter the class to which you want to assign the production resource/tool. This class must belong to class type 009 Production resources/tools.
5. Choose Edit → Values.
   A list with the class characteristics that are assigned to the PRT class is displayed.
6. Assign values that are valid for the selected production resource/tool to the characteristics.
7. Save the PRT.

Result

The production resource/tool is assigned to the class. You can now search for the production resource/tool using the class or its characteristics.
Linking a Document to a Production Resource/Tool

This procedure describes how you can link a document to a production resource/tool (PRT) with a PRT master record (miscellaneous).

For information about how to assign documents to the other PRT categories, see:

- for materials choose LO - Managing Material Master Data
- for equipment choose PM - Structuring Technical Systems
- for documents choose CA - Document Management

Prerequisites

The document with which you want to link the PRT has been created in document management. Its document type allows it to be assigned to PRTs (set up in Customizing), see CA - Document Management Guide.

Procedure

1. Choose Logistics → Production → Master data → Production resources/tools and then Prod. resources/tools PRT master (misc.) → Change.
2. Enter the PRT key and choose 📜.
3. Choose Documents.
4. Enter the data of the documents, which you want to link with the PRT. Choose 📜.
5. Save the PRT.

Result

The documents are now linked with the production resource/tool. You can display and print the documents in the PRT master record.
Releasing/Locking Production Resources/Tools

Use

When you create or change a production resource/tool (PRT), you can specify the availability of the PRT by entering its status. In this way, you can, for example, temporarily lock defective PRTs, in order to prevent them from being used. The status is taken into account when you:

- Assign production resources/tools to operations in routings, production orders, or maintenance orders
- Check the PRT availability in the production order.

Features

How you can release a PRT and for which areas you can do this depends on the category to which it belongs.

- For materials, equipment, and documents you specify in the status whether they can be used as production resources/tools.

  When you check the PRT availability in production orders:
  - The system also carries out a static stock determination, that is, it checks whether there is sufficient stock at the time of the check
  - For equipment, the system also checks the reading on the PRT-usage counter

- For production resources/tools with a PRT master record (miscellaneous), you specify in the status:
  - Whether the production resource/tool may be assigned in resource planning, that is, in routings and orders
  - Whether the production resource/tool is available for production and is therefore valid for the availability check in the order

See also:

LO - Managing Material Master Data
PM - Structuring Technical Systems
CA - Document Management Guide
Maintenance Planning for Production Resources/Tools

Use
For production resources/tools (PRT) with an equipment master record, you can:

- Plan and monitor the wear and tear of production resources/tools
- Create a preventive maintenance plan that relates to the degree of wear and tear

In this way, you can plan preventive maintenance measures to suit your requirements. The current degree of wear and tear is taken into account during the PRT availability check in production orders.

Features
During maintenance planning, you enter the following information for a production resource/tool:

- A PRT counter that contains information on the degree of wear and tear of the production resource/tool
- The expected wear and tear for each operation
- An activity-related preventive maintenance plan

PRT Usage Counter
In plant maintenance, you create a counter for the production resource/tool. You assign a characteristic to the counter, which has a unit suitable for displaying the wear and tear of the PRT. You enter the counter in the equipment master record of the production resource/tool.

You specify the initial counter reading by entering the number of available units in a measurement document. When you confirm a production order, the system creates a corresponding measurement document for the affected production resource/tool; that is, it automatically updates the counter reading.

See also:
PM - Measurement and Counter Readings.

Expected Wear and Tear
When you assign PRTs in routings, you specify the expected wear and tear by entering the following data:

- A usage value that specifies the expected wear and tear with reference to the base quantity of the material to be produced
  The unit of measure of the usage value and the PRT counter must be identical.
- A formula that the system can use to calculate the total usage value in the order, that is, the wear and tear to be expected for the order quantity
  The system also uses this formula when deducing the actual wear and tear from the confirmed yield during confirmation. The PRT counter is updated with the value calculated in this way (see above PRT Counter).
Preventive Maintenance Plan

To ensure that the production resource/tool is maintained on a regular basis, you define a preventive maintenance plan in which you plan the maintenance measures required depending on the counter reading. You enter the preventive maintenance plan in the equipment master record of the production resource/tool.

See also:

PM - Maintenance Planning
Creating PRT Usage Counters

Prerequisites

The production resource/tool (PRT) has been created as a piece of equipment.

A characteristic describing the type of wear and tear has been created in the classification system; see CA - Characteristics Guide. A unit of measure for the degree of wear and tear has been assigned to the characteristic.

Procedure

1. Choose Logistics → Plant maintenance → Technical objects, and then Environment → Measuring points → Create.
2. Enter the following data on the initial screen:
   - The measuring point object Equipment
   - The key of the PRT equipment for which you want to create the PRT counter
3. Select MeasPoint is counter and choose Enter.
4. Enter the data as required on the General Data screen.
   - Assign a characteristic to the counter whose unit of measurement describes the type of wear and tear.
5. Save the data for the counter.
Creating Measurement Documents for PRT Usage Counters

Prerequisites
The PRT counter has been created in the system.

Procedure
1. Choose Logistics → Plant maintenance → Technical object, and then Equipment → Measurement documents → Create.
2. Enter the data on the initial screen and choose 📊.
3. Enter the counter reading on the General Data screen.
4. Save the measurement document.
Assigning PRT Usage Counters to Prod. Resources/Tools

Prerequisites
An equipment master record has been created for the production resource/tool.
The PRT counter has been created in the system.

Procedure
1. Choose Logistics → Production → Master data → Production resources/tools and then Prod.resources/tools → Equipment → Change.
2. Enter the data of the PRT equipment on the initial screen and choose ✅.
3. Choose PRT data.
4. In the MeasPoint field, enter the key of the PRT counter.
5. Save the data.
Assigning Preventive Maintenance Plans to Prod. Resources/Tools

Prerequisites
An equipment master record has been created for the production resource/tool.
The preventive maintenance plan has been created in the system; see PM - Maintenance Planning.

Procedure
1. Choose Logistics → Production → Master data → Production resources/tools and then Prod.resources/tools → Equipment → Change.
2. Enter the data of the PRT equipment on the initial screen and choose 🌐.
3. Choose PRT data.
4. Enter the maintenance plan you want to use for the production resource/tool.
5. Save the data.
Deletion of Production Resources/Tools

Use
You can use this function to delete production resources/tools (PRTs) that are no longer available in the system. You then prevent them from being used in routings and orders.

Features
There are two main functions for deleting master records:

• Immediate deletion
  You can only use this function for production resources/tools with a \textit{PRT master record (miscellaneous)}.

  Immediate deletion can only be carried out if the production resource/tool:
  
  – Is no longer assigned to an operation
  – Is no longer linked to a document

  The production resources/tools are deleted logically, that is, you can no longer access their master records. However, the master records are still physically present in the database.

• Deletion flag
  You can set a deletion flag for \textit{all PRT categories}. For production resources/tools with a PRT master record (miscellaneous) however, this is only possible if the PRTs are no longer assigned to operations.

  You can still display production resources/tools for which the deletion flag has been set. However, you can no longer change or reassign them. During archiving or in the next deletion program run these production resources/tools are deleted from the database, provided that they are no longer used.

  At present, there is no archiving or deletion program for production resources/tools with a PRT master record.

  You can remove a deletion flag at any time, as long as the production resource/tool has not been deleted from the database.

See also:
\begin{itemize}
\item \textit{LO - Managing Material Master Data}
\item \textit{PM - Structuring Technical Systems}
\item \textit{CA - Document Management Guide}
\end{itemize}
Deleting Production Resources/Tools with a PRT Master Record

Prerequisites
You can only delete a production resource/tool (PRT):

- If it is no longer assigned to an operation
- If it is no longer linked to a document

Procedure
1. Choose Logistics → Production → Master data → Production resources/tools and then Prod. resources/tools PRT master (misc.) → Change.
2. Enter the PRT key and choose 📋.
3. Choose Prod.resource/tool → Delete and confirm the command.
Production Resources/Tools: Setting/Canceling a Deletion Flag

This procedure describes how you set or cancel a deletion flag for a production resource/tool with a PRT master record (misc.).

For information about how to set deletion flags for the other PRT categories, see -

- for materials choose LO - Managing Material Master Data
- for equipment - PM - Structuring Technical Systems
- for documents - CA - Document Management

Prerequisites

You can only set a deletion flag for a production resource/tool with a PRT master record (misc.) if it is no longer assigned to any operations.

Procedure

1. Choose Logistics → Production → Master data → Production resources/tools and then Prod. resources/tools PRT master (misc.) → Change.
2. Enter the PRT key and choose 📋.
3. On the Basic Data screen choose Edit → Deletion flag on/off.

Result

The deletion flag is changed, that is, it is either set or canceled depending on its initial state. You cannot assign PRTs for which a deletion flag is set.
Assignment of Production Resources/Tools to Operations

Use
You can use this function to specify in the routing which production resources/tools (PRT) are required when an operation is carried out.

After you have assigned production resources/tools to operations you can also assign them as test equipment to the inspection characteristics of the operation.

Prerequisites
A master record must have been created for production resources/tools in the system. Depending on the PRT category, the following additional requirements must be met:

- Materials, equipment, and documents must have been released for use as production resources/tools via their status
- Production resources/tools with a PRT-specific master record (miscellaneous) must have been released for resource planning via their status
- Production resources/tools with a material master record, a PRT-specific master record, or an equipment master record must have been defined for routings via their task list usage.

Features
You can assign several production resources/tools to one operation. You can assign one production resource/tool to several operations.

When assigning PRTs to operations, you can enter certain data that determine how production resources/tools are treated during order processing.
Assigning Production Resources/Tools to Operations

Prerequisites
A master record must have been created in the system for a production resources/tool (PRT). Depending on the PRT category, the following additional requirements must be met:

- Materials, equipment, and documents must have been released for use as production resources/tools via their status
- Production resources/tools with a PRT-specific master record (miscellaneous) must have been released for resource planning via their status
- Production resources/tools with a material master record, a PRT-specific master record, or an equipment master record must have been defined for routings via their task list usage.

Procedure
1. On the operation overview of the routing, select the operation to which you want to assign production resources/tools.
2. Choose Goto → Production resources/tools.
   - If PRTs have already been assigned to the operation, the PRT overview of this operation appears.
     Choose Edit → New entries and the category of the PRT you want to assign.
   - If no PRTs have been assigned to the operation, the dialog box for production resources/tools of the category Material appears.
     If you want to assign a different PRT category, choose the corresponding function key.
3. Enter the PRT key as well as the item number and the basic data for PRT assignment and choose Continue.
4. If you want to assign more production resources/tools, choose Edit → New entries and the PRT category you want to assign. Then repeat step 3.
5. If you have finished assigning production resources/tools, choose Back.
6. Select the assigned PRTs on the PRT overview and enter additional data for the assignment as required:
   - To enter standard values, choose Details → Prod.resource/tool → General view.
   - To enter usage dates, choose Details → Prod.resource/tool → Dates.
   - To enter a long text, choose Goto → Long text.
Production Resources/Tools: Deleting Assignments to Operations

1. On the operation overview of the routing, select the operation whose production resources/tools (PRT) you want to edit.
2. Choose Goto → Production resources/tools.
3. Select the PRT assignment that you want to delete.
4. Choose Edit → Delete and confirm the command.
   The system deletes the PRT assignment.
Assignment of Test Equipment to Inspection Characteristics

Use
You can use this function for inspection planning in the routing to specify which production resource/tool (PRT), for example, which measuring device, is required as test equipment when a quality inspection during production is carried out.

When you release the order, the system transfers the test equipment assignment to the inspection lot. When recording the inspection results for an inspection characteristic, you can display the production resources/tools for the corresponding operation. Test equipment is highlighted in the display.

Prerequisites
Production resources/tools that you want to use as test equipment must be assigned to the same operation as the relevant inspection characteristic in the routing.

The assignment of test equipment must be allowed in the control indicator for the inspection characteristic.

Features
When assigning test equipment, you have the following options:

• You can assign test equipment directly to the inspection characteristic.
• If you have maintained several materials to be produced, you can also assign individual pieces of test equipment to every material/inspection characteristic combination.

When an inspection lot is created, the system transfers the test equipment assignment for the material/inspection characteristic combination. If no such assignment exists, the system uses the test equipment directly assigned to the inspection characteristic.
Assigning Test Equipment to Inspection Characteristics

Prerequisites
Production resources/tools (PRT) that you want to use as test equipment must be assigned to the same operation as the corresponding inspection characteristic. The assignment of test equipment must be allowed in the control indicator for the inspection characteristic.

Procedure
In the operation overview of the routing select the operation whose inspection characteristics you want to edit.
1. Choose Goto → Insp. char. overview.
2. Select the inspection characteristic to which you want to assign test equipment.
3. If you want to assign test equipment directly to the inspection characteristic:
   a) Choose Details → Insp. characteristic → General data.
   b) In the References section enter the item number of the PRT that you want to use as a piece of test equipment
   If you want to assign each material/inspection characteristic combination different test equipment:
   c) Choose Goto → Insp. char. overview.
   An overview of assignment values to inspection characteristics appears.
   d) If the required material is still displayed in the overview, choose Edit → New Entries, place the cursor on the material and choose Select.
   e) Select the material in the value overview and choose Sel. Value → Insp. Equip. Assignmt.
   f) Enter the item number of the PRT that you want to use as an item of inspection equipment and choose Continue.
**Trigger points**

**Use**
A trigger point is an object that can be assigned to an operation in order to trigger a function. Trigger points can trigger functions,

- If the status of an operation changes ([example [Page 185]])
- When an operation is confirmed. In this case the user decides whether the function is triggered ([example [Page 186]])

You can also trigger a function by linking a user status to a ‘reason for variance’ ([example [Page 187]]).

**Features**
At present, the following functions can be triggered:

- **Releasing directly succeeding operations**
  You can release all operations which come directly after the operation

- **Releasing operations up to stop indicator**
  You can release all operations up to and including the next operation with a release stop indicator.

- **Releasing preceding operations**
  You can release all operations which come before the operation in the order

- **Creating a new order by copying**
  You can create a new order. The order is created without reference to material using a reference operation set.

- **Including a reference operation set**
  You can include a reference operation set in the existing order. In this case you need to specify the operation after which the operation set is to be inserted. A production order is always rescheduled after a reference operation set has been included via a trigger point.

- **Triggering a workflow task**
  You can trigger a task defined as a workflow ([Trigger Points [Ext.]]).

To minimize the effort involved in creating trigger points, you can create standard trigger points and trigger point groups.
Standard Trigger Points

You can create standard trigger points in the routing or in the production order. A standard trigger point is used as a reference for creating trigger points. If you refer to a standard trigger point when creating a trigger point, the system transfers all necessary data from the standard trigger point into the new trigger point. As a result, the effort required for entering data is reduced.

To create standard trigger points, choose Logistics → Production → Master data → Std. trigger point → Create
Trigger Point Groups

You can group several standard trigger points together in a trigger point group. With reference to the trigger point group, you can copy all standard trigger points contained in the group into an operation. The effort required for entering data is reduced even more, if you use trigger point groups.

You can create trigger point groups in Customizing (Customizing for Shop Floor Control, choose Master data → Trigger Point → Defining Trigger Point Groups for Standard Trigger Points).
Example: Triggering a Function when Status Changes

You assign a trigger point to operation 30. In the trigger point you specify that when operation 30 is released, the operation(s) that come directly after it are also to be released. As soon as the system status ‘REL’ is activated in operation 30, the system automatically releases the directly succeeding operation(s).
Example: Manually Triggering Functions During Confirmation

You assign a trigger point to operation 40.

In the trigger point you specify that the following functions can be triggered manually during confirmation:

- Include a reference operation set
- Create a new order

When you confirm operation 40, a list of all the functions that can be triggered manually for this operation is displayed. (In this example this is include reference operation set and Create order.) You decide whether you want to trigger one of these functions.

If you include a reference operation set, the production order is scheduled again.
Example: Linking a User Status to a Reason for Variance

In Customizing, you have specified that the user status ‘MLF’ (malfunction) is to be activated automatically in an operation, every time ‘00011’ (tool breakage) is entered as a reason for variance during a confirmation.

Now you assign a trigger point to operation 50. In the trigger point you specify via a workflow task that a mail is to be sent to a particular MRP controller, as soon as the user status ‘MLF’ is activated in the operation. If ‘00011’ is entered as a reason for variance when operation 40 is confirmed, the trigger point causes a mail to be sent to the MRP controller.
Creating Trigger Points

Use
Trigger points are assigned to operations just like components or production resources/tools (PRTs). You can create and assign them in the routing or in the order.

Procedure
1. Call up the operation overview in the order.
2. Select the operation to which you want to assign a trigger point and choose Trigger points.
   The system branches to a screen that lists all existing trigger points.
3. Enter a Usage [Page 190] and/or a description.
   Specify whether the trigger point is to be used
   – to trigger a function (for example, to release operations, insert a reference operation set and so on) by setting the Functions indicator
     None of the functions maintained on the detail screen can be triggered if the Functions indicator is not set.
   – or as a release stop by setting the RelStop indicator
     If an operation has a trigger point in which the release stop indicator is activated, the operation will be the last operation to be released by any previous trigger point in which the indicator “Release stop” is active. (Example [Page 191])
     You can use the same trigger point both as a release stop and to trigger a function.
4. If you want to...
   – create a trigger point by copying a standard trigger point, press function key Std.trg.pt to select and copy a standard trigger point
   – create several trigger points by copying a group of standard trigger points, press function key Trig. pt. grp to select and copy a trigger point group
   – create a trigger point manually, you have to enter a usage and a description for the trigger point
5. Using a double-click, call up the detail data for the trigger point.
   A screen appears with the title Trigger point - Workflow.
6. In the screen section Trigger point - functions, select the function that you want the trigger point to carry out. In addition, enter
   – the status that is supposed to trigger the function
   – whether the function should be triggered when the status is Reset, Set, or Set and reset.
– whether the function is only to be triggered once

If you have copied a standard trigger point, the system will already have this information.

7. Choose Parameters.

A dialog box appears in which you may need to enter further information.

The fields that appear in the dialog box depend on the function you selected. If, for example, you have chosen "Include reference operation set", you must enter the task list group, the group counter for the reference operation set and also the operation number in the dialog box. The operation number specifies the operation after which the reference operation set is to be included.

You can also enter a selection profile in the dialog box. The function can then only be triggered if the status of the operation matches the selection criteria specified in the selection profile.

8. Choose 📋 and save the production order.
Trigger Points: Usage

The *Usage* key is used to group (standard) trigger points.

Grouping (standard) trigger points by their usage can have the following advantages:

- It makes it easier to locate similar standard trigger points.
  
  When you enter a usage, the system lists all standard trigger points that have the same usage.

- You can see which function is triggered by a trigger point.
  
  If you group together trigger points that trigger similar functions, you can see which type of functions they trigger without having to branch to the detail screen.

You create usages for (standard) trigger points groups in Customizing (Customizing for *Shop Floor Control*, by choosing *Master data* → *Trigger points* → *Defining Usages for (Standard) Trigger Points*).
Example: Using the Release Stop Indicator

You assign a trigger point to operation 10 and set the indicator *Release up to stop indicator*. You assign a trigger point to operation 50 and set the indicator *RelStop*.

When the trigger point in operation 10 is triggered, the system automatically releases operations 10, 20, 30, 40, and 50.
Availability Check

Use

The availability check in Shop Floor Control checks whether the components, production resources/tool or capacities required for a production order are available.
Checking the Availability of Material

Use
Before you start production, you have the option of checking whether all the material components production resources and tools (PRTs) assigned to a production order are available on the calculated requirements dates.

Features
In a production order, the system can only check a material component, if it is

- Kept in stock
- Not a phantom item
- Not a bulk material

Availability checks can be triggered either automatically or manually:

- The availability of components in an order can be checked automatically during order creation and/or order release. You specify in Customizing per order type and plant whether the availability should be checked automatically (see Checking Control [Page 198]). In addition, an automatic availability check can be carried out when the order is saved.
- You can always trigger a manual availability check

The checking scope is defined via the Checking Group [Page 195] (in the material master) and the valid Checking Rule [Page 196] (in Customizing).

They define:

- Which MRP elements are taken into account in the check
- Which inventory categories are taken into account
- Whether the replenishment lead time is taken into account
- Whether the check is also to be carried out at storage location level
Checking the Availability of Material

In Customizing (checking control) you specify which quantity is used to check the availability of a material. You can choose between the following:

- **Availability Check Against Planned Independent Requirements**

  In the check against planned independent requirements, the system only checks the open planned independent requirement quantities created for the components. This means that the ATP quantity is not included in this availability check nor are receipts or stocks.

  This type of availability check is most useful:
  - if assembly planning or phantom assembly planning is used to plan the components
  - if quick statements about the availability situation are required and the results from this check are precise enough

  The system uses the open planned independent requirements quantity at component level to determine a committed quantity and this quantity is copied to the planned order header in the Committed quantity field. As opposed to the availability check according to ATP logic, however, the committed quantity is not recorded in the dependent requirements. The planned independent requirements of the components are not consumed by the committed quantity but by the complete dependent requirements quantity. In availability checks that follow, the system can only commit quantities for the amount of planned independent requirements that have not yet been consumed.

  In the availability check against planned independent requirements, the following dates/quantities are **not** calculated:
  - overall commitment date
  - partial commitment date/quantity

- **ATP quantity**

  In the check according to ATP logic, the system checks whether the dependent requirements of each component are covered by specific receipt and issue elements or by stock. This check is carried out dynamically, that is, each time you carry out the check, the system recalculates the current situation. If a quantity can be committed for the requirement date, the system enters precisely this quantity as the committed quantity in the dependent requirements and the ATP quantity for the components is reduced by the committed quantity. Therefore, in the next availability check, dependent requirements can only be committed for the amount of the remaining ATP quantity.
Checking Group

Every material that is to take part in the availability check must be assigned to a checking group. Assignment is carried out in the material master record.

Using the checking group you can define

- Whether the materials to be checked are locked during the availability check
  
  If the “Block with TrOfQties” indicator is set, the committed quantities are stored in a table of locks. This leads to more exact results because the check results of an order are already taken into account before saving when other orders are checked.

- Whether the normal ATP quantity or the cumulated ATP quantity is used
  
  The check with cumulated ATP quantity is recommended because in this check, inconsistencies in commitments, which can be caused by postponed receipts, are avoided.

The checking group is used to group materials that are to be checked according to the same criteria (see scope of check).

You can also switch the availability check off for a particular checking group. Materials with this checking group do not then take part in the check. This is useful, for example, if the materials are to be planned using KANBAN.

A checking group must also be entered in the material master record (MRP data screens/SD data screens) for assemblies or components that are to be checked against planning. The checking group is used to control whether the check against planning is permitted. You have the following options for setting up the checking group:

- No check against planning
  
  If the checking group is set up in this way, no check against planning can be carried out for this component in the production order. The material, however, can take part in the check according to ATP logic.

- Always check the material against planning
  
  If the checking group is set up in this way, a check against planning can be always be carried out for this component in the production order. At the same time, you can also execute a check according to ATP logic for this material.

- Only check the material against planning if it is a phantom assembly
  
  If the checking group is set up in this way, the check against planning can only be carried out for this component in the production order if it is a phantom assembly (special procurement key: phantom assembly). At the same time, you can also execute a check according to ATP logic for this material.

The settings for the checking groups are made in Customizing for Shop Floor Control (Operations → Availability Check → Define Checking Group) in the RelChkPlan field.
Checking Rule

You can maintain the following checking rules in Customizing:

- Checking rule for **created orders** (availability transaction ‘1’):
  - This checking rule applies to
    - manual checks in a created order
    - automatic checks during order creation
    - automatic checks when a created order is saved

- Checking rule for **released orders** (availability transaction ‘2’):
  - This checking rule applies to
    - manual checks in released or partially released orders
    - automatic checks during the release of an order
    - automatic checks when a released or partially released order is saved

  The checking rule for **backorder processing** is defined per plant. It applies exclusively to availability checks carried out in backorder processing.

You define checking rules in Customizing for Shop Floor Control (Operations → Availability Check → Define Checking Rule). You maintain checking rules per order type in Checking Control [Page 198] (Customizing for Shop Floor Control, choose Operations → Availability Check → Define Checking Control).
Checking Scope

The checking scope specifies

- Which types of stock/goods receipts/goods issues are to be taken into account in the check
- Whether the check is to take into account the replenishment lead time
- Whether the check is only to be carried out at plant level, regardless of whether a storage location is specified in the reservation

You assign **checking group IN** to materials produced in-house.

In the checking scope you specify that the system need not check purchase orders or purchase requisitions for materials with the checking group IN, since they are irrelevant to materials produced in-house.

You assign **checking group EX** to materials produced externally.

In the checking scope, you specify that the system need not check sales or production orders for materials with the checking group EX, since they are irrelevant to materials produced externally.

The settings for the checking scope, however, not only influence the results of the material availability check, they also affect the speed with which the result can be determined.

You define the checking scope in Customizing for Shop Floor Control by choosing Operations → Availability Check → Define Scope of Check.
Checking Control

In checking control, you can define for each order type and checking rule which type of check is to be used for the material availability check:

- No automatic check when an order is created, released or partially released (see Checking Rule [Page 196])
- ATP check
- Check against planning
- Check when an order is saved

You can also assign checking rules for production resources and tools, and for capacities or define that no check is to take place.

You define checking control in Customizing for Shop Floor Control by choosing Operations → Availability Check → Define Checking Control.
How is the Availability Determined?

The availability is determined according to the ATP method (available to promise). Using this method, the system checks:

- Whether the material requirements can be covered on the requirements date
- At what point in time the requirements can be covered if full coverage of the requirements is not possible on the requirements date

Committing Partial Quantities in Availability Checks

As a rule, the system tries to commit the entire requirements quantity of a component, providing the ATP quantity is sufficient.

Committing the entire quantity

Order quantity: 100 pieces

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements qty</th>
<th>ATP qty</th>
<th>Committed qty</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>200 pcs</td>
<td>300 pcs</td>
<td>200 pcs</td>
</tr>
<tr>
<td>B</td>
<td>100 pcs</td>
<td>40 pcs</td>
<td>40 pcs</td>
</tr>
<tr>
<td>C</td>
<td>50 pcs</td>
<td>200 pcs</td>
<td>50 pcs</td>
</tr>
</tbody>
</table>

If you want to ensure that the system only commits quantities that are needed in production, you can set up the commitment of partial quantities in Customizing (production scheduling profile).

In a partial commitment, only a percentage of the requirements quantity is committed. The committed quantity received by all components that are checked is determined by the component with the lowest relative committed quantity (commitment factor).

Confirming partial quantities

Order quantity: 100 pieces

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirements qty</th>
<th>ATP qty</th>
<th>Committed qty</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>200 pcs</td>
<td>300 pcs</td>
<td>80 pcs (40% of 200)</td>
</tr>
<tr>
<td>B</td>
<td>100 pcs</td>
<td>40 pcs</td>
<td>40 pcs (40% of 100)</td>
</tr>
<tr>
<td>C</td>
<td>50 pcs</td>
<td>200 pcs</td>
<td>20 pcs (40% of 50)</td>
</tr>
</tbody>
</table>
At What Level is the Availability Checked?

The availability check can be carried out at plant, or at storage location level. At which level the check is actually carried out depends on the data maintained in the material component and the checking scope: If a storage location is specified in the reservation, the check is carried out at storage location level, unless the checking scope specifies that the check should always be carried out at plant level.

If a check is carried out at storage location level and the components are available, the system automatically carries out an additional check at plant level. For performance reasons we recommend that you only carry out this type of check where required.

If, during an availability check, a material requirement exists with reference to a sales order / project, the check is carried out in the individual planning section of the sales order / project.
When is the Availability Checked?

To check the availability of components, you can either use an overall check or individual checks:

- **An overall check** determines the availability of all components within an order/collective order [Page 474]. It can be carried out automatically, or you can trigger it manually.

- **An individual check** determines the availability of a single component. It can only be triggered manually.

By branching into the production order information system, you can carry out an overall check for several orders at the same time (see Collective Availability Check [Page 205]).

You can specify in Customizing whether an availability check is to be carried out automatically. You can also specify when the checks are to be carried out. You can specify, for example, that the check is to be carried out automatically during order creation or order release. In addition, you can specify that the availability check is to take place when a created or released order is saved. You make these setting in Customizing for Shop Floor Control by choosing Operations → Availability Check → Define Checking Control.

If the check determines in an overall check that a material component is not available on the required date, the system activates the status “missing part” in the order header. An overall check or an individual check can also deactivate the status “Missing part”, if the check determines that the required quantity of all component has since become available (according to ATP logic).

You can access details on the results of an availability check in the following places:

- **The availability log** offers you
  - the result of the check (i.e. whether all components are available)
  - a list of the missing parts
  - a list of the reservations that could not be checked (for example due to incomplete data in the material master)

  The log is not stored when you exit the order.

- **The missing parts overview** offers you
  - a list of the missing parts
  - the ability to process the missing parts (for example by changing the requirements quantity or the issuing storage location)
  - the date on which all components are available

  The missing parts overview always displays the results of the last availability check carried out in the order, regardless of whether you have since exited the order.

- **The missing parts list** offers you
  - a list of the missing parts
  - a list of the reservations that could not be checked (for example due to incomplete data in the material master)
When is the Availability Checked?

- a list of all components checked, if you select the menu options View → Check result → All components
- the date on which the other components are available

The missing parts list is not stored when you exit the order.

If an availability check is carried out when the order is released, the system writes the results of the availability check in the release log.

If you make changes in an order, which could affect the availability of its components (for example date or quantity changes), this does not automatically trigger a new availability check. For up-to-date information on any missing parts in an order, you should restart the availability check manually after you have made the changes.

You must activate an automatic check when the order is saved in Checking Control [Page 198].
Carrying out an Availability Check

You can carry out an availability check either for the entire order, or for an individual material component in the order.

Checking all Material Components

To check the availability of material components for the entire order, choose Functions → Availability check → Material - ATP, or Material - planning.

The system carries out an availability check. If material components are not available on their requirements date, the system activates the status "material shortage" in the production order.

Checking Individual Components

You can carry out an individual check from the component overview, from the missing parts overview and from the missing parts list.

To check the availability of an individual material from the component overview, proceed as follows:

1. Choose

   The system branches to the overview screen of all the material components contained in the order.

2. Select the material component, whose availability you want to check. Choose Component → Availability → Check availability.

   The system carries out an availability check. The system issues a message informing you whether or not the component is available on its requirement date.

3. For more information on how material availability is checked, see PP Production Planning / Material Requirements Planning.
Resetting Checking Result

To reset the check result, that is, to reset the commitment at dependent requirement level, proceed as follows:

In the order header, choose Functions → Availability check → Reset material.

The committed quantity and the committed date of the production order, as well as the committed dates and quantities of the dependent requirements are reset.
Collective Availability Check

Use

In the mass processing function for production orders, you can check the material availability of several orders at the same time. These collective availability checks always carry out an overall availability check for each of the orders.

You can check production orders or planned orders in this way. As with individual checks, the checking rule is determined via the order type (production orders) or the MRP group / plant parameters (planned order).
Collective Availability Check: Criteria

Before a collective availability check is carried out, the following criteria need to be decided on:

- **Sequence of the checks**
  The orders are checked in the sequence in which they are displayed in the object detail list (i.e., the top order is checked first). You can change the sequence using the grouping and sort functions of the production order information system.

- **Number of orders to be checked**
  All orders in the list that are marked are checked.
  When you carry out a collective availability check online, you specify the following:

- **Reset of availability data from the last check**
  If you decide to reset the availability data from the last check, the following data is deleted for all orders, before the checks are carried out.
  - the committed quantity in the material components
  - the missing parts indicator in the material components (only in production order)
  - the total committed date in the order header
  - the committed quantity in the order header
  The system statuses Material shortage (MSPT) and Material committed (MACM) in the production order are deactivated.

  The system always resets all orders in one step. The orders are not unlocked until the last order has been reset.

- **Execute availability check**
  Use this indicator to switch on the collective availability check. You can choose between the following options:
  - **Individual**
    If you select this indicator, the availability check is carried out for each material depending on the settings in the checking group. If the checking group specifies, for example, that the material is always checked against planning then a check is always carried out against planning.
  - **ATP check**
    If you select this indicator, the availability check is carried out for all materials using the ATP logic. In this case, the settings in the checking group are ignored.
  - **Planning check**
    If you select this indicator, the availability of all materials is checked against planning, providing the checking does not specify No checking against planning.

- **Firm planned orders**
You can specify, that planned orders for which components are available are firm after the availability check has been carried out. This means that the planned orders are firm for the planning run and will not be changed automatically.

- **Availability logs**

  You can specify which level of message is to be recorded in a log (for example information message or error message). If no messages of the specified types occur, or only messages of a lower level, then the system does not write a log.

  ![Log Icon]

  If you work without using the check mode, you can maintain the following parameters:

  - **Reset of the availability data**
  - **Execute availability check**

  The check type is set up individually for each material previously. This means that the availability of each material is checked according to its check group.

  The default setting is that planned orders are firm and that a log is produced from message level "W" (warning).
Collective Availability Check: Results

The following data is generated as a result of a collective availability check with the standard profile.

- **Results key**
  This key informs you of the result of the overall availability check for the order (fully committed, not fully committed etc.).

- **Messages issued during the check**
  This key specifies the highest level of message issued during the availability check (information being the lowest, abend the highest message level).

- **Commitment ratio**
  Ratio between the committed order quantity and the order quantity.

- **Commitment difference**
  Difference (in workdays) between the planned basic finish date and the committed basic finish date (=overall commitment date) of the order.

- **Total committed date** of the order (date on which the entire quantity can be delivered)

- **Committed quantity** of the order

- **Missing parts status** (for production orders with missing parts)
Executing a Collective Availability Check

Use
This transaction for the collective availability check (COMAC) has been defined as a variant transaction in mass processing (see Definition of Variants [Page 449]). For more information about executing mass processing and about the parameter settings, see Executing Mass Processing Online [Page 446], Scheduling Mass Processing in the Background [Page 448], and Mass Processing Functions [Page 432].

Procedure
1. Choose Logistics → Production → Shop Floor Control → Control → Collective availability check.
   In the List field, Order Headers is a fixed setting.
2. Choose a Profile [Page 493] or a Layout [Page 490]
3. Enter your selection criteria.
   To make execution easier, you can define variants (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria and preset the parameters for the mass processing functions.
4. Choose the tab page Mass processing - Material availability check and make the settings for the material availability check (see Mass Processing Functions [Page 432]).
   You can simplify execution of the function by using the application toolbar [Page 444].
5. Choose .
   The list appears with the selected objects (this is the Individual Object List [Page 485] of the order information system).
6. Select the items for which the function is to be executed.
7. Choose .
   After mass processing has been executed, the display in the list is not automatically refreshed. To refresh the list, choose .
   The production orders in a collective order are processed together in a LUW (Logical Unit of Work). This means that if processing is stopped for whatever reason, none of the functions is carried out for the collective order.
Checking Availability of PRTs

Use
Before you start production, you have the option of checking whether all the production resources and tools (PRTs) required to carry out the order are available.

Features

Where is the check carried out?
Each PRT category (material, PRT master, document or equipment) has a status in its master record which specifies whether the PRT is available.
For PRT category 'material', you can also check the plant stock of the PRT. The system checks the following inventory categories:

- Unrestricted-use stock
- Stock in quality inspection
- Unrestricted-use consignment stock
- Consignment stock in quality inspection
You specify in Customizing whether the system should check only the status, or the status and the plant stock, when it carries out an availability check.

When is the check carried out?
You can specify in Customizing whether an availability check is to be carried out automatically. You can also specify when the checks are to be carried out.
You can specify, for example, that the check is to be carried out during order creation or order release.
If the check determines in an check that a PRT is not available, the system activates the status "PRT Shortage" in the order header.
During the check, the system creates an error log that lists the PRTs which are not available.

If you make changes in an order, which could affect the availability of its PRTs, this does not automatically trigger a new availability check. For up-to-date information, you should restart the PRT availability check manually after you have made the changes.
Execute Availability Check for PRTs

It is possible to execute a PRT availability check either for the whole order, or for individual PRTs.

Check for all PRTs

To execute a PRT availability check for the whole order, choose Availability check → PRTs. The system executes an availability check. If PRTs are not available, the status “PRT shortage” is posted to the production order.

Check for Individual PRTs

To check the availability of an individual PRT, proceed as follows:

1. Choose PRT.
   
   The system branches to the overview screen for all operations contained in the production order.

2. Select the PRT, whose availability you want to check. Choose Prod.resource/tools → PRT availability.
   
   The system executes an availability check.

   The system only activates the status “PRT Shortage” if an availability check of all the PRTs was carried out and one or more PRTs are not available.

You can find more information on production resources / tools in production resources / tools (PRTs) [Page 160].
Checking the Availability of Capacities

Use
When creating or changing a production order you can check capacity availability. The system checks for every operation in the production order whether there is sufficient capacity on the relevant date at the corresponding work center. The capacity requirements of other orders or operations at this work center are also taken into account.

When creating or changing a production order you can call up the capacity availability check by choosing Capacity. You can also call it up at operation level and at sequence level.

If you have called up the capacity availability check and there is insufficient remaining available capacity, a dialog box is displayed.

- Choose Detail info to display detailed information on the capacity situation.
- Choose Finite scheduling to carry out finite scheduling.

For more information, read Document PP Capacity Planning, Section View of Shop Floor Control (SFC)

Determining the Capacity Load
When determining the capacity load of a work center (basic load) in the context of the capacity availability check, the requirements of the operations with a particular status are taken into account. You specify which status is to be taken into account in Customizing for Capacity leveling in the selection profile via the requirements grouping. If you have not made any setting of your own, only released operations are taken into account.
Preliminary Costing

When you create a production order and after each subsequent change to the order, the system calculates the planned order costs that are expected to be incurred during production. The planned costs are assigned to cost elements.
Cost Elements
A distinction is made between primary and secondary cost elements:

Primary Cost Elements
Costs that are considered as primary cost elements include:
- Material costs
- Costs for external procurement/external processing

These costs are assigned to the order, for example, via primary costs, such as material withdrawals or the purchasing of externally processed parts.

Secondary Cost Elements
Costs that are considered to be secondary cost elements include:
- Production costs
- Material overhead costs
- Production overhead costs

These costs are allocated to the order via internal cost allocation.

Cost Segments
Cost elements are recorded in so-called cost segments that are managed per fiscal year. The system uses the latest start date of the operation or the requirement date of the material to calculate in which period of which fiscal year the planned costs of an order are incurred.

Planned/Actual Cost Comparison
Both planned costs and actual costs are recorded in cost segments. Actual costs are updated when material withdrawals or confirmations are carried out for the order, or when a goods receipt is posted for an externally procured material component, for example. This enables you to compare planned with actual costs at any stage of order processing.
Material Costs

The materials used in an order can be divided into stock components and non-stock components. You can calculate planned costs for both component categories.

Planned Costs for Components [Page 217]
Planned Costs for Material Manufactured In-House [Page 218]
Planned Costs for Material Procured Externally [Page 219]
Planned Costs for Components

Whether planned costs are calculated for a material component depends on the costing relevancy indicator of the component. This indicator specifies which factor is used to calculate the component costs. If the indicator is not set, the material component is not taken into account in costing. This indicator is on the General data tab page of the component detail data.

The system automatically assigns the material component to the relevant cost element via the MM Consumption Account Assignment. Examples of consumption accounts in the standard chart of accounts are:

- 400000 Consumption raw materials
- 410000 Consumption trading goods
- 890000 Change in stock of unfinished products
Planned Costs for Material Manufactured In-house

If a material is manufactured in-house, the system calculates the planned costs of the material using the valuation variant and a price stored in the material master record.

In customizing, a costing variant is defined per order type and plant. The costing variant refers to a valuation variant, which determines which price from the material master record is used to calculate the planned costs of a material (for example, the moving average price or the standard price).
Planned Costs for Material Procured Externally

For materials procured externally the system distinguishes between stock components and non-stock components:

- Planned costs for a component **kept in stock** are calculated in exactly the same way as for a material manufactured in-house.
- Planned costs for a component **not kept in stock** equal the value of the purchase requisition created for the component. The value of the purchase requisition is calculated using the price specified in the material component.
Production Costs

The activity used in an order can be divided into internal activity and external activity. Planned costs are calculated for both.

The system calculates the planned costs for the activities contained in an operation or suboperation via the valuation variant specified for the order type (defined via the costing variant). The values of the individual activities are specified via the activities defined in cost center accounting.

For more information on the valuation of activities, refer to CO-CCA Cost Center Planning.

In costing, suboperations are treated in the same way as operations. For this reason the following only describes the costing of operations.
Planned Costs for Production

Whether an operation is relevant to costing depends on its control key and its costing relevancy indicator:

• You can specify via the control key of the operation whether the operation is relevant to costing.
• If, according to its control key, the operation is relevant to costing, you must ensure that the costing relevancy indicator is set (general data screen) for the activity produced in the operation to be costed.
Planned Costs for Internal Activity

To calculate the planned costs for carrying out an operation, the system first sets up a quantity structure for the produced activities. In a second step, the quantity structure is valued with a price.
Setting up a Quantity Structure

The most important data for setting up a quantity structure for an activity is defined in the work center:

- Activity types
- Formulas

Every activity which is calculated is allocated to an activity type. A formula is allocated to each activity type in the work center. Using the formula and the standard times in the operation, the system calculates how much activity is expected for a particular activity type in a particular operation.

As soon as the system has calculated how much activity is expected for a particular activity type, it can evaluate the activity per activity type.
Planned Costs for External Processing

If you want to calculate planned costs for an externally processed operation, you must maintain a cost element for the operation:

- If you have entered a purchasing information record number for an externally processed operation, the system determines the cost element of the operation via the info record.
- If you have not entered a purchasing info record number for an externally processed operation, you must add the cost element manually.

The costing variant defined in Customizing refers to a valuation variant which in turn specifies the price with which the external activity is to be valued (for example with the price from the purchasing info record, or the price from the operation).
Overhead Costs

Overhead costs are costs which can be assigned only indirectly to the production order, such as electricity costs or general storage costs.

Overhead costs are assigned to the production order via overhead surcharges. They are updated in the order under the cost elements defined in the costing sheet.

A costing variant is defined in customizing per order type and plant. The costing variant refers to a costing sheet. The costing sheet determines what overhead surcharges are assigned to the order.

The costing sheet specifies:

- Which direct costs to apply surcharges to
- Under which conditions an overhead is calculated
- How high, depending on these conditions, the surcharge percentage is
- Which object (for example, a cost center) is credited under which cost element during actual postings
Overhead Groups

You can make the calculation of overheads dependent on the material to be produced by specifying an overhead group. The system determines via the overhead group and the costing sheet the percentage used to calculate the overhead costs of the order.

If you want the calculation of overheads to depend on which material is being produced, you should note the following:

- In the material master record of the material to be produced, you must have maintained an overhead group which refers to an overhead key.
- The costing sheet valid for the order must refer to the above-mentioned overhead key.

You can find more information on overhead surcharges online in the guide to *Organizational Elements Internal Orders*, as well as under the menu option "Overhead surcharges" in the Customizing menu of product cost accounting.
Displaying Costs

Use
In a production order, you can display costs according to the following criteria:

• Costs per cost element
• Itemization according to cost element and origin
• Cost stratification

Procedure

Costs Per Cost Element
In this display format the system totals the order costs per cost element.
To display this form of cost breakdown, proceed as follows:
1. Call up the production order.
2. Choose Go to Costs → Analysis.
   The system displays the total order costs broken down into cost elements.

Cost Itemization
In this display format the system totals the order costs per cost element and, provided origins were maintained for the material components in the order, according to origin.
The system lists all components that are assigned to the individual cost elements and origins.
To display the cost itemization, proceed as follows:
1. Call up the production order.
2. Choose Go to Costs → Itemization.
   The system displays the costs broken down into cost elements and origins.

Cost Stratification
It is possible to group together similar cost elements to so-called cost components. In this way you can group together all cost elements which, for example, refer to machine time activity into one cost component.
In Customizing, you can define a maximum of forty cost components per order type. Each cost component can be divided into either fixed or fixed and variable costs.
To display costs in the production order per cost element, proceed as follows:
1. Call up the production order.
2. Choose Go to Costs → Cost comp. structure. The system displays the costs according to cost elements.
   You can only display a cost stratification of planned costs.
Displaying Costs

**Balance Display**

In the balance display, the difference between the costs resulting from confirmations and goods movements and the income from goods receipts is displayed. The balance is displayed as long as the production order has not been settled. To reach the display, proceed as follows:

1. Call up the production order.
2. Choose *Goto* → * Costs* → *Balance*. The system displays the balance.
Order Release

Use
A production order must be released, before it can be processed. You can use the time period between creating and releasing a production order, for example, to carry out company checks and preparations. If you do not require this time period, you can automatically release the production order when it is created (see Automatic Release [Page 232]).

A newly created production order initially receives the status CRTD (created). The following restrictions apply to a production order that has been created:

- Confirmations for the order cannot yet be executed.
- Shop floor papers cannot be printed.
- Goods movements for the order cannot yet be executed.

Releasing the order lifts these restrictions.

Features
Order release can be executed at the following levels:

- With Release at Order Header Level [Page 230] all operations are released. The order and the operations receive the status REL (released).
- With Release of an Operation [Page 236] the operation receives the status REL and the order receives the status PREL (partially released). If all operations in an order have been released, the order has the status REL.
Release at Order Header Level

Use
Release at order header level, results in the order and all its operations being released. The order and the operations receive the status REL (released). You can release a production order in creation and change mode.

Features
Release at order header level can be carried out as follows:

- Automatic Release [Page 232]

Automatic Actions when Releasing a Production Order
When you release a production order, the following actions can be executed automatically:

- In the production scheduling profile, you can set the system to print shop floor papers or to schedule the order. You maintain the production scheduling profile in Customizing for Shop Floor Control, by choosing Master Data → Define Production Scheduling Profile.

- In the checking control for the availability check, you can specify that a check is made for availability of material, capacity and production resources/tools. You maintain the checking control in Customizing for Shop Floor Control, by choosing Operations → Availability Check → Define Checking Control.
Manual Release of Orders

Prerequisites
To release an order manually, you have to be in Production Order Maintenance [Page 15].

Procedure
Choose 📊. The production order is released when you save it.

Result
When it is released, the production order and all operations receive the status REL (released).
Automatic Release

Use
Automatic release of an order takes place when the order is created. You can use this function if you do not need time for preparatory activities between creating and releasing an order.

Prerequisites
You can use the production scheduling profile to define that an order is automatically released when it is created. You maintain the production scheduling profile in Customizing for Shop Floor Control, by choosing Master Data → Define Production Scheduling Profile.

The assignment of the production scheduling profile to the order is made via the material master record of the material to be produced (tab page Work scheduling). There, you can either directly enter the profile or carry out indirect assignment via the production scheduler (you define the production scheduler in Customizing for Shop Floor Control by choosing Master Data → Define Production Scheduler). If both are entered, priority is given to assignment via the profile.

Features
With automatic release, the order and all its operations are released.

Automatic Batch Creation [Page 298] is possible for the material to be produced.
Collective Release

Use

You can select production orders with the same order type, plant and MRP controller and release them simultaneously. You can select production orders according to the following criteria:

- Material number
- Order number (interval)
- Sales order number and item
- WBS element
- Release date (interval)
- Status selection profile

See also:

Mass Processing Production Orders [Page 429]
Executing Collective Release

Use
This transaction for collective release (CO05N) has been defined as a variant transaction in mass processing (see Definition of Variants [Page 449]). For more information about executing mass processing and about the parameter settings, see Executing Mass Processing Online [Page 446], Scheduling Mass Processing in the Background [Page 448], and Mass Processing Functions [Page 432].

Procedure
9. In the List field, select the object for which you want to execute collective release: Order headers, Operations.
11. Enter your selection criteria.

To make execution easier, you can define variants (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria and preset the parameters for the mass processing functions.

12. Choose the tab page Mass processing - Release and make the settings for collective release (see Mass Processing Functions [Page 432]).

You can simplify execution of the function by using the application toolbar [Page 444].

13. Choose .

The list appears with the selected objects (this is the Individual Object List [Page 485] of the order information system).

14. Select the items for which the function is to be executed.
15. Choose .

After mass processing has been executed, the display in the list is not automatically refreshed. To refresh the list, choose .

The production orders in a collective order are processed together in a LUW (Logical Unit of Work). This means that if processing is stopped for whatever reason, none of the functions is carried out for the collective order.
Release of Operations

Use
You can release individual operations within a production order. Use this function if you want to process a production order without releasing the whole order.

Features
The following applies when releasing operations:

- If you release one or more operations within a production order, the operations receive the status REL (released) and the production order receives the status PREL (partially confirmed).
- As soon as you have released all operations in an order, the order automatically receives the status REL.

An operation can only be released if the preceding operation has been released.

Using Trigger Points to Release Operations
You can assign a trigger point to an operation in the routing or in the production order. You can release one, or several successive operations, using trigger points (see Trigger Points [Page 182]).

How to Create a Trigger Point [Page 188] explains how to assign a trigger point.

Actions for Partially Confirmed Orders
The following actions can be executed for partially confirmed orders:

- Shop floor papers can be printed for a partially confirmed order.
- A released operation can be confirmed.
- Material movements can be executed for material components that are assigned to a released operation.
Releasing an operation

Prerequisites
You have to go to Production Order Maintenance [Page 15].

Procedure
1. Choose .
2. Select the operations that you want to release.
3. Choose Operation → Release. The system releases the selected operations.
Material Serial Numbers in Production Orders

Use
The assignment of serial numbers when creating a production order, enables you to choose between single items of a material. Each produced part can then be uniquely identified using the combination of the material number and the serial number.

Integration
If you want to use the serial number assignment function, you must work with the PM module.

Prerequisites
The following requirements must be fulfilled if you want to assign single items of a material with a serial number when you create a production order:

- In the material master record (Storage area) of the material to be produced, a serial number profile must be assigned
- The serial number profile must permit the creation of serial numbers for the serialization activity Create production order (PPAU)

Features
For each material, you can specify

- When the serial number is assigned (for example, when the production order is created, during goods receipt)
- Whether serial numbers must be assigned then or whether the user can decide whether the serial numbers are to be assigned, or whether the serial numbers are assigned automatically by the system

If serial numbers are assigned automatically, then you must manually trigger assignment by selecting Header → Select serial numbers in the order header and then determine the number yourself or let the system do this (Create serial number automatically).

If you change the order quantity after assigning serial numbers in the production order, then the system informs you that the number of assigned serial numbers must be checked and adjusted.

During goods receipt of the manufactured product, the serial numbers are transferred from the production order to inventory management.

Activities
Create a serial number profile with the relevant settings in Customizing for Plant maintenance. Assign the profile to the affected material master records.

For more information about serial number profiles, refer to the Management of Serial Numbers document.
As-Built Configuration

Definition
A special form of installed base. An as-built configuration (ASBC) describes the structure of a serialized assembly that has been produced and the condition or history of its individual components.

Use
You can use an as-built configuration to look at the condition and history of a produced assembly at any time. You can record changes to an as-built configuration in the form of an as-maintained configuration.

You can use an as-built configuration for complex products for which you need to be able to tell at all times which assemblies and components have been used in production (for example, an airplane).

Integration
An as-built configuration is an Installed Base [Ext.] that you can create using existing production data (process and production orders).
Creation of As-Built Configurations

Use
You use this function if you want to create As-Built Configurations [Page 240] with close reference to the production process. It enables you to include the creation of an as-built configuration in the production process and use the production data (order structure, serial number hierarchy).

You can either create an as-built configuration after each individual order (you can integrate creation into single screen entry of confirmations) or you can create an as-built configuration after completing production of a finished product.

As-built configurations are created in two stages. First, you assign one or more material and serial numbers to an existing as-built configuration or identify finished products (material and serial numbers) for which new as-built configurations are to be created. When you save, new as-built configurations are created or existing as-built configurations are changed. In this way, you keep on gradually building up as-built configurations.

Integration
This function is based on the data of Installed Based Management (CS-IB) [Ext.]. Therefore, you can also use the installed base management transactions to create, change and display.

You can use this function for process and production orders.

Prerequisites
A prerequisite for the creation of as-built configurations from production data is that goods issues and receipts have been carried out for the orders. If the system is to propose serial numbers, these must be entered when you enter the goods movements.

Features
Processing Types
The following processing types are available:

- **List Input [Page 244]**
  With the list input, you use the keyboard to assign material and serial numbers.

- **Node Assignment [Page 245]**
  Here, you can use a graphical user interface to carry out assignments using Drag & Drop.

- Creation using a barcode reader
  To create assignments, you can read in material and serial numbers that have been encoded in barcodes.

Creation of As-Built Configurations
The creation of as-built configurations on the basis of assignments can be carried out either in the dialog, for an individual as-built configuration, or in the background with collective processing
Creation of As-Built Configurations

for all processed as-built configurations. If an as-built configuration is created in the dialog, the user can change it manually before saving.

Integration in the Production Process

- Including the function as a detail area in order confirmation
  As-built configurations can be created during [Single Screen Entry of Confirmations](Page 318). For this process, the corresponding detail area must be inserted into the screen for single screen entry of confirmations (see [Settings for Single Screen Entry](Page 320)). A record is then kept of which serialized components have been incorporated in the individual assemblies. During confirmation, assignment is carried out using the list input. However, you can switch to the graphical user interface (select Assignment tool).

- Automatically linking as-built configurations of subordinate production levels
  When a confirmation is saved, the assignments of serialized components to serialized assemblies are automatically converted to as-built configurations and saved as an installed base. When as-built configurations are created for the superior production level, subordinate as-built configurations are automatically linked to the newly created as-built configurations. Single-level as-built configurations of serialized assemblies are thereby progressively built up into multi-level as-built configurations for finished products.

Evaluation of Production Data

When production orders and process orders are used, the evaluation of production data is supported in the following way:

- Entry help for the list input
  When using the list input to create an assignment, you can set up the system so that it automatically enters the material numbers of components, which have been incorporated in a serialized assembly according to the manufacturing order, into the component list (choose Explode). To complete the assignments for the serialized assemblies, you then only have to add the related serial numbers.

- Assignment proposals for node assignment
  If serialized components have already been withdrawn for an order, the serial number hierarchy for this order can be exploded (choose Explode). All possible assignments are represented in a tree structure (single-level or multi-level).

- Checking assignments
  If you create an assignment, the system carries out a consistency check using the production data (order structure, serial number hierarchy). In the case of an error, you can decide whether or not you want to execute assignment. You can also reverse an assignment (choose). 

- Transferring production data
  When you create an as-built configuration based on assignments, production data is automatically transferred to the items of the as-built configuration (plant, batch, revision level, quantity, unit of measure).

- Order quantity 1
  For a serialized assembly that is produced from an order with a quantity of 1, the subordinate assignments are clearly defined if their serialized components have already
been withdrawn. In this case, all subordinate assignments are generated automatically by the system when this serialized assembly is assigned as a component.

- Automatic assignment of components that are not serialized

  When an as-built configuration is created on the basis of the defined assignments, the system creates automatic assignments of components that are not serialized. In this process, the system determines the component quantities automatically.
Creating/Changing As-Built Configurations Using the List Input

Use
You use this procedure within the production process, if the production data is available on shop floor papers.

Procedure

   In the standard system, the list input screen appears. To change the type of processing, choose List<>Tree.

2. Enter the material number and serial number of the assembly to which you want to assign components.

3. Enter the components that you want to assign, with the corresponding serial numbers. To do this, you have the following options:
   - Choose Explode. The serialized components assigned to the material are listed. Enter the serial numbers. You can delete the components from the list that you now do not want to copy to the as-built configuration.
   - Enter the components and serial numbers manually.

4. Choose Transfer.

   The assigned components are transferred to the as-built configuration, but are not yet saved (item marked with ). Components that are already stored in an as-built configuration are marked with . To reverse an assignment, select the assignment and choose .

5. Select the top-level material in the as-built configuration. You have the following options when you save:

<table>
<thead>
<tr>
<th>You choose</th>
<th>You create assignment(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Create/change as-built in foreground]</td>
<td>as an as-built configuration by switching to the transaction for installed base management. Then, the installed base is only saved when you select the symbol for saving in installed base management. Before saving, you can still make manual changes or additions.</td>
</tr>
<tr>
<td>![Create/change as-built in background]</td>
<td>as an as-built configuration without switching to installed base management.</td>
</tr>
</tbody>
</table>
Creating/Changing As-Built Configurations Using Node Assignment

Use
You use this procedure if withdrawals of serialized components already exist.

Procedure

   In the standard system, the list input screen appears. To change the type of processing, choose List<->Tree.

2. Enter an order number or a material with serial number.

3. You define whether explosion of the order structure is to be single-level or multi-level.
   - If you choose single-level, then you create the as-built configuration for the order entered. This scenario can be used for creation during the production process.
   - If you choose multi-level, then you also create as-built configurations for the subordinate orders. This scenario can be used for creation after production. In this case, you enter the order for the finished product.

4. Choose 🗒 Explode.

   The order structure is displayed in the left half of the screen. Under the order structure you see the available serial numbers for the material that is selected in the order structure. Serial numbers that are already used in an as-built configuration are marked with 🗼. Serial numbers that are not yet used in an as-built configuration are marked with 📑.

5. You can now create new as-built configurations or change existing as-built configurations.

   To create a new as-built configuration, proceed as follows:
   a. Select the material for which you want to create a new as-built configuration.
      The serial numbers that are available for this material appear.
   b. Select the serial number (item is marked with 📑).
   c. Assign the serial number to the item 🗼 As-built configuration.
   d. You can extend an as-built configuration by carrying out more assignments (see change).

   To change (extend) an existing as-built configuration, proceed as follows:
   a. Select the material for which you want to change the as-built configuration.
      The serial numbers that are available for this material appear.
   b. Select the serial number (item is marked with 📑).
Creating/Changing As-Built Configurations Using Node Assignment

c. Assign the serial number to the item *As-built configuration*. An existing as-built configuration appears on the right of the screen.
d. Select the material that you want to assign to an item of the existing as-built configuration.
e. Select the serial number (item is marked with ).
f. Assign the serial number to an item of the existing as-built configuration using Drag&Drop. The assigned materials are transferred to the structure, but are not yet saved in the as-built configuration (symbol for a component, for the top-level material in an as-built configuration). Materials that are already part of an as-built configuration are marked with the symbol. To reverse an assignment, select the assignment and choose .

You can also carry out assignment by selecting the serial number and the item in the as-built configuration to which you want to assign the serial number and then choose .

6. Select the top-level material in the as-built configuration. You have the following options when you save:

<table>
<thead>
<tr>
<th>You choose</th>
<th>You create assignment(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image-url" alt="Create/change as-built in foreground" /></td>
<td>as an as-built configuration by switching to the transaction for installed base management. Then, the installed base is only saved when you select the symbol for saving in installed base management. Before saving, you can still make manual changes or additions.</td>
</tr>
<tr>
<td><img src="image-url" alt="Create/change as-built in background" /></td>
<td>as an as-built configuration without switching to installed base management.</td>
</tr>
</tbody>
</table>
**Inspection Lots**

**Use**

In a production process, it is sometimes necessary to carry out inspections to ensure the quality of a product. An inspection lot documents a request for an inspection. Inspection characteristics are assigned to the inspection lot. An inspection characteristic defines what needs to be inspected. A distinction is made between qualitative characteristics and quantitative characteristics.

With in-process inspections, an inspection lot is created for a production order. Characteristics are assigned to individual operations in the order. The characteristics define the inspection requirements.

The results of the inspection are then recorded for each inspection characteristic and stored in the inspection lot.

For more information about inspection lots, see *Inspection Processing*.

For more information about inspection characteristics, see *Inspection Planning*.

**Features**

The system distinguishes between planned and unplanned inspection characteristics:

- Planned inspection characteristics are maintained in the routing
- Unplanned inspection characteristics are maintained in the production order

If inspection data has been maintained in the quality management view of the material master of the material being produced, then the system automatically creates the inspection lot, as soon as the first operation in the production order is released.

You also have the option of creating an inspection lot manually in the production order.
Creating Inspection Lots

Use
You can only create an inspection lot in a production order, if
- Inspection data has been maintained and activated in the quality management view of the material master of the material being produced
- The order is not technically complete
- The order has no deletion flag or deletion indicator in the header
You can check the production order status in the status line of all header screens. You can also do this via the menu. To do so, choose  

Procedure
Create Manually
To create an inspection lot manually, proceed as follows:
1. Call up the production order.
2. Choose Functions → Inspection lot → Create.

Create Automatically
The system automatically generates an inspection lot for a production order, when the first operation in the order is released:
- If the system manages to create an inspection lot, the system status ILCR (Inspection lot created) is set in the header of the production order
- If the inspection lot could not be created, the system status ILNC (Inspection lot not created) is set

You can select and process all orders in which the generating of an inspection lot failed by using a selection profile and searching for all orders with the status ILNC
Deleting Inspection Lots

Use
You can only delete an inspection lot, if
- The operations in the production order do not contain any unplanned characteristics
- No inspection results have been recorded in the inspection lot

Procedure
1. Call up the production order.
2. Choose Functions → Inspection lot → Delete.
   The system automatically deletes the inspection lot for the production order.
Creating Inspection Characteristics

Use

Inspection characteristics are normally copied over from the routing. However, you can also create inspection characteristics in the production order. These are known as ‘unplanned’ inspection characteristics.

Procedure

Call up the production order.

1. Go to the operation overview and select the operation to which you want to assign an inspection characteristic.

2. Choose Operation → Unplanned inspection characteristics.

You can only create an inspection characteristic when an inspection lot has been created and saved for the relevant production order.
Deleting Operations with Inspection Characteristics

Use
If an inspection characteristic has been assigned to an operation (system status ICHA), you can delete the operation if the following requirements have been met:

- The inspection characteristic is a “planned” inspection characteristic
- QM data (status QMDA) has not yet been recorded for the operation

Procedure
1. Delete the inspection lot assigned to the production order.
2. Delete the operation in question.
3. Regenerate the inspection lot

   This will ensure that the inspection characteristics of the remaining operations remain in the production order.

   If you delete an operation that has already been released, the system activates the system status DLFL for the operation, but leaves the operation in the operation overview.
Inspection Lots: Restrictions

In the following cases, the use of inspection lots or inspection characteristics is restricted:

- **Reference operation sets**
  
  If a reference operation that contains inspection characteristics is inserted into a production order *after an inspection lot has been created*, the inspection characteristics are ignored.

- **Alternative sequences**
  
  If the standard sequence contains an operation with inspection characteristics, it cannot be replaced by an alternative sequence.

- **Routings with operations containing inspection characteristics**
  
  - if the routing is copied when the production order is created, all assigned inspection characteristics are copied into the production order.

  - if the standard and alternative sequence are exchanged in the production order without subsequently reading the routing, you may find that any inspection characteristics specified in the alternative sequence are not transferred to the standard sequence.
Missing Parts

Use

If, during an availability check ([Overall Check](Page 201)), the system determines that a component is not available on a date on which it is required, the production order is automatically given the status "PRT shortage" (MSPR). This status remains active in the order header until a subsequent availability check (overall check) determines that all components have become available (for example, due to a goods receipt).

An individual check has no effect on the status of components.

It is possible to display missing parts in the SAP System

- for a specific order/collective order [Page 474]
- for several orders using the missing parts information system

Features

Missing Parts in an Order/Collective Order

You obtain information on missing parts in the following places in the order/collective order:

- In the **missing parts overview** you can
  - edit missing parts data (for example, by changing the requirements quantity or issue storage location)
  - check the availability of individual components
  - filter / sort components

  The missing parts overview always displays the results of the last availability check carried out in the order, regardless of whether you have since exited the order.

- In the **missing parts list** you can
  - display the missing parts of all orders which have been checked (for collective orders)
  - check the availability of individual components
  - filter / sort components
  - print the missing parts
  - vary the field selection

  The missing parts list is not saved if you exit order processing.

Missing Parts Information System

You can use the missing parts information system to display the missing parts list for a selection of materials, or for all materials. You can also restrict your selection of missing parts according to a specific plant, MRP controller or requirements date.
Missing Parts

A profile determines what data is displayed on the missing parts list and how it is displayed. The SAP System contains two standard profiles. They sort the missing parts list according to order number or material number. You can, however, define your own profiles in Customizing for Shop Floor Control.

If you often enter the same selection criteria when you create missing parts list, you can save the criteria in the form of a variant. You can then call up the variant any time you want via the menu.

You can branch directly from the missing parts list into backorder processing for the material. When you call up backorder processing, the system recalculates the ATP quantity (Available To Promise) of the material. It then displays the stock/requirements situation of the material(s), the quantities that have been committed to orders, reservations, and so on, as well as the cumulative ATP quantity. If individual requirements exist for sales orders, the system displays these separately.

If you change the committed quantity in backorder processing, the change will not automatically register in the missing parts list. To update the missing parts list, choose List → Refresh when you return to the missing parts list.

In backorder processing, you can change the quantities committed to the orders/reservations.
Calling Up a Missing Parts List

1. Choose Logistics → Production → Shop floor control → Information system → Missing parts info system

   The system branches to the initial screen for generating a missing parts list.

2. Select a Profile.

   In Customizing for Shop Floor Control, you can create your own profiles (Information system → Define Profile for Missing Parts Information System). Please refer to Customizing for information on how to define such profiles.

3. If required, maintain additional criteria for creating the missing parts list. You can enter the following criteria: Material, plant, MRP controller, requirements date (or interval), WBS element, sales order.

   You include or exclude data that meets these criteria in the list. You can also specify that a particular field is to be taken as the upper or lower (alphabetic/numeric) limit for the selection process.

   To do this, position the cursor on the relevant field and choose Edit → Selection options. Enter the required restrictions and choose ✔.

   If you want to save your entries as a variant, select Goto → Save as variant.

4. Choose 🔄.

   The system lists all reservations with missing parts that meet the specified selection criteria.

   By choosing Environment, you can branch to the following objects: Current stock/requirements list, stock overview, material master, backorder processing, production order (display and maintenance).
Backorder Processing

Use
When you call up backorder processing for a material, the system lists all goods receipts and issues relevant to the availability check. You can process missing parts from this list. If an availability check (ATP logic) determines that a requirement (sales order, reservation and so on) cannot be totally covered, that is, if the committed quantity is smaller than the required quantity, the material in question is considered to be a missing part.

Any of the following reasons may cause a material to become a "missing part":

- A sales order cannot be delivered either partially or in its entire quantity on the date requested. It has, however, been confirmed.
- A sales order is confirmed because its requested delivery date is not within the replenishment period. However, the quantities have not yet been procured.
- A dependent reservation is not yet confirmed.

Backorder processing offers you the following processing options:

- You can commit open requirements, for example, if the stock has increased since the last availability check, a new goods receipt has occurred and so on.
- Quantities that have already been committed can be redistributed by subtracting an amount already committed to one requirement and assigning it to another, more urgent requirement.
**Mail Link**

In Customizing for MRP, you can maintain a mail link to inform an MRP controller of the fact that a goods receipt has been posted for a missing part.
Checking Rule

In order to process backorders, you need to define a missing parts checking rule (Customizing for Shop Floor Control, by choosing Operations → Availability check → Define Checking Rule for Backorder Processing).

If you use different checking rules in backorder processing and in a production order, the result of the check may be different. This can lead to components in the order being represented as missing parts, but they do not appear in backorder processing. As a result, they cannot be processed in backorder processing.
Calling Up Backorder Processing

Use

You can either call up backorder processing directly from the initial menu for Shop Floor Control or from the missing parts information system.

Procedure

- If you are on the initial menu:
  a. Choose Logistics → Production → Shop Floor Control → Control → Backorder processing → Material.
  b. Enter the material number of the material to be processed and also the plant and choose .

- If you are in the missing parts info system:
  a. Position the cursor on the corresponding line.
  b. Select Environment → Backorder processing.

When you call up backorder processing, the system calculates the ATP quantities. The system displays the plant stock, any existing storage location stock and also any open sales orders.

The texts for the receipt and issue elements are analogous to the stock/requirements list. The different stocks (individual customer stock and so on) and storage locations are listed in separate sections.
Processing Dependent Reservations

Prerequisites
You can set up backorder processing in such a way that only the requirements relevant to Shop Floor Control are displayed as missing parts. To do this, choose Settings → Reserv. for prod.ords

Dependent reservations that have not yet been committed, or for which a goods receipt has not yet been planned are displayed as missing parts. The missing quantity is displayed in the column Rec./reqd qty.

Procedure
You can assign ATP quantities to the open reservations. To do this, proceed as follows:

1. Position the cursor on the line with the reservation to which you want to assign an ATP quantity. Choose Change commitment.
   
   The system displays the details of the reservation on the date selected in the lower half of the screen.
   
   The following data is displayed in detail:
   
   **Origin**: The number of the product or assembly that requires material.
   
   **Order**: Number of the source production order of the reservation.
   
   **Reqmts qty**: Total quantity required for the reservation
   
   **Committed quantity**: Quantity that has been committed in backorder processing.
   
   **ATP quantity**: Available quantity that can be used to commit to requirements

2. On the basis of the ATP quantity, enter the quantity that you can commit to the requirement in the field Commited qty.

3. Commit the quantity by choosing Transfer. In this way, you can use the ATP quantity as the basis for committing missing quantities.

4. Save your entries.
Processing Sales Orders

Use
You can also set up backorder processing from a sales point of view. Then only the requirements relevant to sales are displayed as missing parts. To do this, choose Settings → Only SD requirements

If the requested delivery date of a sales order is outside the replenishment lead time and if the replenishment lead time is taken into account in the availability check, the sales order is automatically considered to be available.

Sales orders that can only be partially delivered on the date requested or for which the full quantity has been committed despite a lack of availability are displayed in two lines:

- The first line shows the quantity missing on the requested delivery date in column Req/recpt.
- The second line shows the committed quantity on the committed date. This enables you to commit the full quantity on the requested delivery date, providing the quantity is available.

Procedure
1. Position the cursor on the sales order or customer requirement to which you wish to commit an ATP quantity. Choose Change commitment.

   The system displays the details of the sales order on the date selected in the lower half of the screen.

   The following data is displayed in detail:

   - **Open quantity**: Total requirement quantity of the sales order or customer requirement.
   - **Material availability date**: The material staging date is the date on which the quantity must be available for the sales order item.
   - **Total committed quantity**: Quantity that has been previously committed (in sales order administration when creating a sales order or customer requirement).
   - **Committed quantity**: Quantity that has been committed, in backorder processing.
   - **ATP quantity**: Available quantity that can be used for open requirements.

2. On the basis of the ATP quantity, enter the quantity that you can commit to the requirement in the field Committed qty.

3. Commit the quantity by choosing Transfer.

   In this way, you can use the ATP quantity as the basis for committing missing quantities.

4. Save your entries.
Printing

In the SAP System, the printing of shop floor papers is carried out in the form of lists. A list can be a complete printout of a material provision list, for example, or a printout of time tickets.
List Types

The standard SAP System distinguishes between the following four list types:

- Operation-related lists: for example, time tickets, completion confirmation slips
- Component-related lists: for example, material provision lists, withdrawal slips
- PRT-related lists: for example a PRT overview
- General lists: for example an object overview, or an operation control ticket
  
  (This list type can contain information on operations or production resources/tools, for example).

As a rule, lists that are created and printed by the system refer to all the operations, suboperations, components and production resources/tools contained in an order.

You can change the name of the individual lists at any time. Since both list names and SAPSCRIPT forms are stored in the system per language, it is possible to print lists in different languages.

In the following, the term "operation" comprises both operations and suboperations.
Printing: Parameters in Customizing

In Customizing, you can define for an order type, plant and MRP controller.

- **What lists a user may print**
  
  For example, you can define that user "A" may only print out pull lists and material withdrawal certificates, while user "B" may only print out time tickets and confirmation slips.

- **What lists may be printed from a transaction**
  
  For example, you can define that shop papers should be created in full during order processing but that the printing of lists should only be possible using Functions → Print.

  These two settings clearly define which lists may be printed by which user in which transaction.

- **The data that a list should have**
  
  You can define with this report the relevant list should be created. This report processes the data provided and issues it using a SAPSCRIPT form.

- **The layout of the list**
  
  For example, you can define a SAPSCRIPT form for a certain order type that prints a barcode on the confirmation slip.

- **Spool parameters for printing**
  
  You can use the spool parameters to define on which printer the list should be printed, whether it should be printed immediately and the number of days it should be retained in the spool file before it is deleted.

  ![Warning]

  For collective lists, the immediate printing of shop floor papers is subject to certain restrictions. Please refer to note 199151.
Printing: Prerequisites

If you want to print lists for a production order in the standard setting for the SAP system, you should check the following:

Lists for Operations [Page 266]
Lists for Components [Page 267]
Lists for Production Resources and Tools [Page 268]
Lists of Operations

Note the following when you print lists of operations:

- Is Customizing set up in such a way that the control key for the operations is checked when printing lists?
  
  If this is the case, you must check whether the control key:
  
  - permits the printing of operations
  - permits the printing of time tickets
  - permits the printing of confirmation slips

  If the control key check is not activated in Customizing, the system does not check the control key or the status. In this case, the system also does not set a print status.

- Does the status of the order and the status of the operation permit the list to be printed?
  
  - If the order status does not permit printing, the system does not print a list.
  - If the order status permits printing, the system prints a list. Operations whose status does not permit printing are not included in this list.

  The printing of lists is permitted if
  
  - the order is either released or partially released
  - the order is neither technically complete nor deleted

  The printing of individual operations in an order is permitted if
  
  - the order is partially released or released
  - the operation is released and not deleted

- Do you want to print time tickets or confirmation slips?

  In this case, you should ensure that the specified number of time tickets or confirmation slips for the operation is greater than zero.

  The number of time tickets or confirmation slips is proposed from the work center. However, you can change this on the General operation detail screen. To reach this screen choose " in the production order. Select the relevant operation and choose
Lists for Components

Whether or not you can print a list of components depends on the status of the operation to which they are assigned. If you can print the operation, you can also print the relevant components.

Dummy components cannot be printed.
Lists for Production Resources and Tools

Whether or not you can print a list of production resources and tools depends on the status of the operation to which they are assigned. If you can print the operation, you can also print the relevant production resources and tools.
Printing Types

The SAP System distinguishes between the following printing types:

- **Original printout**, that is the first printout of orders.
- **Reprint**, that is the reprint orders that have already been completely printed.

To trigger a partial print of shop floor papers, use the option ‘original printout’ in combination with a selection profile that includes the selection of partially released orders.

The reprint of lists is only possible in display mode.

You can initiate the printing of shop floor papers in the following two ways:

- Printing within production order processing
- Printing from the initial menu of the production order
Printing from a Production Order

All list types that are defined in customizing for the corresponding order type, plant and MRP controller can be printed within production order processing. The above-mentioned requirements must however be met for printing to be carried out (See Requirements for Printing [Page 265]).

If you do not want to print all the list types allowed, you can limit the number of lists to be printed for a production order.

To print from a production order, choose Functions → Print.

- In creation mode and change mode printing is carried out after saving the order.
- In display mode printing is carried out immediately.
Printing Production Orders

Use

This transaction for printing (CO04N) has been defined as a variant transaction in mass processing (see Definition of Variants [Page 449]). For more information about executing mass processing and about the parameter settings, see Executing Mass Processing Online [Page 446], Scheduling Mass Processing in the Background [Page 448], and Mass Processing Functions [Page 432].

Procedure

16. Choose Logistics \rightarrow Production \rightarrow Shop floor control \rightarrow Control \rightarrow Print.

17. In the List field, select the object for which you want to execute collective release: Order headers, operations, production resources/tools, components.

18. Choose a Profile [Page 493] or a Layout [Page 490]

19. Enter your selection criteria.

\[→\]

To make execution easier, you can define variants (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria and preset the parameters for the mass processing functions.

20. Choose the tab page Mass processing - Print and make the print settings (see Mass Processing Functions [Page 432]).

\[→\]

You can simplify execution of the function by using the application toolbar [Page 444].

21. Choose \[→\].

The list appears with the selected objects (this is the Individual Object List [Page 485] of the order information system).

22. Select the items for which the function is to be executed.

23. Choose \[→\].

After mass processing has been executed, the display in the list is not automatically refreshed. To refresh the list, choose \[→\].

\[→\]

The production orders in a collective order are processed together in a LUW (Logical Unit of Work). This means that if processing is stopped for whatever reason, none of the functions is carried out for the collective order.
Automatic Printing on Order Release

You can use a production scheduling profile (Customizing for Shop Floor Control by choosing Master Data → Define Production Scheduling Profile) to define that the system automatically prints shop floor papers when you release an order.

You can assign the profile to an order either by using the material master record (work preparation) of the material to be produced or the production scheduler (Customizing for Shop Floor Control by choosing Master Data → Define Production Scheduler).
Printing a Component/Operation List

Use
With this function, you can generate a component list or an operation list (ALV technology). You can also print these lists. In addition, other functions you can use are: Filter, sort, ABC analysis.

Activities
- In the component overview, choose Components and 
- In the operation overview, choose Operations and 

See also:
SAP List Viewer (ALV) Grid Control [Ext.]
ALV Grid Control (BC-SRV-ALV) [Ext.]
External Procurement/Processing

Use
If individual operations in a production order need to be carried out by a separate company, you need to make use of the functions for external processing.

If certain parts that are needed to make a product have to be bought in from a different company, you need to make use of the functions for external procurement. This type of procurement is also referred to as direct procurement.

Integration
In the case of external processing or procurement, you need access to information from the purchasing department.

For example, you need to know about the vendor and the conditions that apply for external processing/procurement. This information is maintained in purchasing and can be entered in the external operation or non-stock component, for example, via a purchasing info record.

Prerequisites
If you want to use external processing/procurement functions, you first need to make the corresponding settings in the Purchasing module.

Features
If a production order contains
- External processing operations, or
- Non-stock components
the system creates a purchase requisition for external processing or external procurement.

A purchase requisition is an internal document that defines the requirement for a material or a service. It authorizes Purchasing to procure a certain quantity of a material or service so that it is available on the date required.

You can see the number of the purchase requisition on the external processing screen of an operation or on the purchasing data screen of a non-stock component. If a purchase requisition changes, you can start a workflow to inform Purchasing (see Changes in Purchasing (PP-SFC) [Ext.]).

Purchasing generates a purchase order from the purchase requisition, which informs the vendor which service is required, or which material is to be delivered.

For more information on purchase requisitions and purchase orders, see the SAP Library MM Purchasing Guide.
External Processing of Operations

Purpose
An externally processed operation is not carried out within your own organization, but is assigned to a vendor, who then does the work.

This type of processing is particularly important for subcontracting. It can also provide a company with a feasible alternative to in-house processing, if capacity bottlenecks occur.

If certain components are required to carry out an external operation, you can also provide these components for the vendor (see Provision of Components [Page 281]).

Prerequisites
An operation can only be processed externally if its control key allows or prescribes external processing.

Since an external operation has to be sent to a different company, additional data needs to be maintained on the External processing tab page. You can maintain the data in the routing or in the production order.

Process Flow
When you create an order, the system creates a purchase requisition for an externally processed operation.

When a purchase order with reference to a purchase requisition is created, all data necessary to process the material externally is transferred to the purchase order. After the material has been processed, the vendor delivers the material back to stock.
Result

The goods receipt of an externally processed material causes the status of the operation to be updated:

- For partial delivery, the status is: EOPD (External operation - partial delivery)
- For final delivery: EOFD (External operation - final delivery)

After the goods receipt, the material can be processed further in-house, if required.
External Procurement of Components

Purpose
If a material component, for example, is only rarely used, is very valuable or its fixed properties are not known until the production process has started, it is sometimes worth delaying procurement until it is needed by a production order. This has the advantage of reducing stock costs as well as capital tie-up.

Prerequisites
A component can be only be procured externally, if

- It is a non-stock item
- It has a material type that is not subject to inventory management

Pipeline materials cannot be procured externally.

Process Flow
During order creation, the system creates a purchase requisition for externally procured components.

The remaining procedure for external procurement is identical to that for an external operation.
Goods Receipt

If a goods receipt has already taken place for an externally processed operation or a non-stock component, the system displays the received quantity on the external processing screen of the operation or the purchasing screen of the component.
Changes in the Order

If any changes are made to the dates or quantities in the operation or in the component, the system automatically adjusts the data in the purchase requisition.

An indicator on the external processing screen of the operation and the Purchasing screen of the component informs you of whether a purchase order has already been created via the purchase requisition.

If a purchase requisition has already been converted to a purchase order, the indicator Purchase order exists is set on the tab page External processing in the order. Changes to the order are not copied to the purchase order.
Provision of Components

Use
When an operation is processed externally, you may want provide the vendor with parts required for carrying out the operation.

Integration
When a purchase order is created with reference to a purchase requisition, the system copies the components assigned to the external operation into the purchase order as parts to be provided to the vendor.

Prerequisites
The following prerequisites must be met if you want a component to be copied into a purchase order as a part to be provided:

- The component must be assigned to an operation with a control key that specifies external processing.
- The indicator Subcontracting must be set on the external processing detail screen of the operation.

If you want to assign a component to an external operation, but wish to exclude it from being sent to the vendor, you can overrule the Subcontracting indicator in the operation by setting the indicator Mat. provision ind. in the BOM item.

Features
The staging of parts to be provided takes place via functions in MM Inventory Management (see MM Inventory Management, Special Stocks and Inventory Sampling). As soon as the goods receipt has been posted for the purchase order, a consumption posting is carried out of the parts provided. This causes the production order to be debited with the costs of the parts provided.
Scheduling an External Operation

Use
When an order is scheduled, both internal and external operations need to be taken into account. You can choose how the duration of external operations is calculated:

- Using the planned delivery time
  If a planned delivery time is maintained in the purchasing info record, it is copied into the order. The planned delivery time can also be maintained in the operation itself.

- Using the standard values
  The standard values defined in the external operation are entered into the scheduling formula to calculate the duration of the operation (that is, the same procedure as for in-house operations).

Integration
The control key of the external operation specifies whether the system uses the planned delivery time or the standard values to schedule the external operation.

Features
External operations are scheduled as part of Order Scheduling [Page 89].
Costs of External Processing/Procurement

Provided a non-stock component is defined as being relevant to costing, it is possible to determine costs for the component. The value of the component corresponds to the value of the purchase requisition and is determined via the price defined in the component.

Provided the control key of an operation specifies that it can be costed and that the operation is marked as being relevant to costing, it is possible to cost the operation.

The costing variant specifies how the externally processed operation is to be valued. The costing variant refers to a valuation variant. The valuation variant specifies the price used to valuate the external activity.

The goods receipt of the material causes the production order to be debited with the actual costs of external processing or procurement, and the consumption accounts to be posted in financial accounting. However, it does not cause an increase in the quantity and value of the warehouse stock.

For more information on how costs are determined, see CO Cost Object Controlling.
Goods Movements

Use

Before you can start producing a material, all the necessary material components have to be issued from stock via goods issues. The delivery to stock of the manufactured material is documented in the system via a goods receipt. Both types of goods movement trigger the following transactions in the system:

- A material document is created to record the goods movement.
- The stock quantities of the material are updated.
- The stock values are updated in the material master record and the stock/consumption accounts are updated.
Withdrawning Material Components

Use

When you create a production order, the system automatically generates a reservation for the required material components. Each material component of the order receives a separate item number within the reservation. You can only withdraw the reserved materials from the warehouse if the operation to which the materials are assigned in the order has already been released.

If you withdraw material components, the values of the material components you have withdrawn are updated as actual costs in the order according to cost type and origin.

You can refer to either the order or reservation number when you withdraw material components from the warehouse. The reservation number is displayed on the general component data screen.

Procedure


2. Choose To order… A dialog box is displayed in which you can directly enter either the reservation or order number. You can also perform a search using search criteria.

3. Enter the reservation or order number directly or choose a number using the specified search criteria. Choose 

   The system automatically proposes the movement type 261 (goods issue for order) as well as all the material components in the order, which are not marked as bulk material or as material to be backflushed [Page 344].

4. Check the list of the material components that are proposed as defaults for goods withdrawal and save the goods issue.

   If you do not refer to the reservation or the production order when you withdraw material components, these will still be outstanding when generated reservations are released and the required quantities reserved, although the requirement physically no longer exists.

Backflushing of Components

For information on backflushing components, see Goods Movements in Confirmations [Page 344]
Goods Movement Overview

Use

In the goods movement overview (previously material overview) you can process goods movements for production orders.

You can call up the goods overview from the following functions:

- **Confirmation** [Page 313] (order confirmation, operation confirmation, collective entry, fast entry)
- **Picking** [Page 291]
- **Reprocessing Goods Movements** [Page 358]

Features

In the goods movement overview the material components that are assigned to an order/operation are listed, for which goods movements are possible.

The goods movement overview comprises of the following functions:

- Change goods movements
  
  You can change goods movements (for instance requirement quantities, plant, storage location, special stock)

- **Split Goods Movement** [Page 288]
  
  You can use this function to enter several goods movements for one reservation. You use this function, if for instance you want to withdraw a material component from several different storage locations. If you do not use this function and create a new goods movement, the system will consider this to be an unplanned movement, it has no reference to a reservation.

- **Batch Determination** [Page 289]
  
  You can use this function to conduct batch determination for the components. The system uses the search strategy for batch determination. You can also enter the batch manually. Another possible entry is the batches that can be entered. In this case the freely accessible stock per batch is displayed.

- Create batches
  
  You can create a batch for the goods receipt of a finished product and, if applicable, assign values to characteristics. Choose **Component → Batch management → Create batch.**

- **Stock Determination** [Page 290]
  
  You can also determine stocks for individual goods movements.

- Display options
  
  In **Environment** there are the following display options:
  
  - Display stock/requirements list
- Display stock
- Display material
- Display order
- Display errors (for goods movements that contain errors)

You can also display batch master records by choosing Component → Batch management → Master record.

- Sort, filter, search

  In the edit menu there are various options for influencing the display of goods movements. You can, for example
  - Set a filter, so that only certain movements are displayed.
  - Sort the goods movements
  - Delete those goods movements from the list that you do not want to process at the moment.

- Dependent goods movements

  If the material to be produced in a subordinate order of a collective order is transferred to the superior order, this can occur with a goods receipt (to stock for finished material of the subordinate order) and a goods issue (from stock of the directly produced components by the superior order). The goods issue and goods receipt are mutually dependent goods movements and can only be posted and processed together.

  Initially only the goods receipt appears in the goods movement overview. This entry cannot be changed. To process the goods movements, select the entry and choose Goto → Dependent items

- Table settings

  You can process goods movements in a table (table-control). Each goods movement is on an individual line. You can control the appearance of the list yourself. For more information refer to Table Settings [Ext].
Splitting Goods Movements

Prerequisites
You must be in the Goods Movement Overview.

Procedure
1. Select the goods movement that you want to split.
3. Enter the quantity for which the second goods movement should be executed.
4. Choose Copy. The goods movement overview reappears. There is now a further goods movement.
5. Edit the goods movement as required.

In confirmation transactions the posting of goods movements is triggered when you save the confirmation(s).

In the picking list and in re-working goods movements the posting of goods movements is triggered when you choose Save.
Executing Batch Determination

Prerequisites
You must be in the Goods Movement Overview.

Procedure
1. Select the goods movement, for which you want to determine the batch.
2. Choose Component → Batch management → Batch determination. The system assigns batches to inventory management according to the batch search profile.

In confirmation transactions the posting of goods movements is triggered when you save the confirmation(s).

In the picking list and in re-working goods movements the posting of goods movements is triggered when you choose Save.
Executing Stock Determination

Prerequisites

You must be in the Goods Movement Overview.

Procedure

1. Select the goods movement, for which you want to determine the stock.
2. Choose Components → Stock determination. The system uses the Customizing settings for the material and the order type and completes the goods movement.

For more information refer to Stock Determination [Page 294].

In confirmation transactions the posting of goods movements is triggered when you save the confirmation(s).

In the picking list and in re-working goods movements the posting of goods movements is triggered when you choose Save.
Picking

Use

You can use this function to determine which components have not yet been issued from stock for a production order and then carry out the goods issue.

Picking is also one of the functions that can be used in mass processing (see Mass Processing of Production Orders [Page 429] and Functions of Mass Processing [Page 432]).

Features

When you select orders for picking, you should note the following:

- Orders with the following statuses are not selected:
  - Created
  - Locked
  - Technically complete

- The following components are not listed:
  - Backflushed components
  - Phantom items
  - Components with direct production
  - Components with ‘final issue’ indicator
  - Batch totals records
  - Co-Products
  - Bulk material items
  - Components with a deletion flag
  - Text items

The initial screen for selecting production orders is the same as the object detail list for components in the production order information system.

The result of the selection is a component overview for the orders selected and a pick list containing the components still to be issued.

You select orders using selection criteria. All the components are displayed for each order selected. For example, if you enter a component as a selection criterion, all the components are displayed, of those orders that contain this component.

The goods issues can be carried out in online or background mode.

- In online mode, the system calls up Stock Determination [Page 294]. Successful goods movements are posted immediately. Any goods issues with errors can be immediately corrected online.
Picking

- In **background mode**, the components are marked for goods issue and then processed in background jobs (see Executing Picking [Page 293]).
Picking - Execution


2. Enter a profile for displaying the component overview. Enter order selection criteria for the orders and choose \( \text{Pick} \). The component overview is displayed.

3. Select the components, for which you wish to execute goods movements. Choose \( \text{Pick} \). The pick list appears.

   The input dialog is identical for the pick list and the goods movement overview. You can change individual goods movements, if for instance, a goods movement had errors. For more information refer to Goods Movement Overview [Page 286].

4. To post the goods issues, choose \( \text{Post} \).

   On the component overview screen you can choose to post the goods issues in the background (Environment → Pick/Batch). In this case, you need to schedule the background jobs CORUAFW0 and CORUAFWP to post the goods movements.

   - You use program CORUPROC, if you also want to execute goods movements that originate from confirmations.
   - You use program CORUAFWP, if you only want to execute goods movements from the pick list.
Stock Determination

Use
Stock determination is used to determine the special stock type (for example, consignment stock), the movement type and the production storage location of requirements. It is carried out during the backflushing of components or Picking [Page 291].

Prerequisites
You need to make the following settings in Customizing:

- You assign the stock determination rule to a plant, an order type and a business transaction (backflushing, picking).
- In order to carry out stock determination, you need a strategy that specifies how stock is to be reduced. The withdrawal strategy is deduced from the combination of the checking rule (plant/order type/transaction) and checking group (material master).
Material Staging

Use
If you are using Warehouse Management, you can use this function to transport materials to production bin locations, that are grouped into supply areas.

One of the main advantages of this functionality, is that employees on the shop floor can request the material required in the production process. The system generates a transfer requirement in the Warehouse Management System. Warehouse management is then responsible for staging the required materials by creating a transfer order from the transfer requirement. This occurs in the normal WM processing.

Prerequisites
In order to use this functionality, you have to set up a WM / Production Planning interface.


Features
Material staging offers you the following features:

- You can simulate material staging.
- You can execute material staging.
- You can display the material staging results.

To use the staging function, an order has to at least be partially released, at least one operation has to have been released.

You can start material staging with WM integration in the following ways:

- In the production order, choose Goto → WM pick list. The system prompts you through the dialog steps.
- In the production order, choose Order → Functions → Material staging → Simulate or Proceed. The remaining processing steps are carried out in the background.
- Material staging is automatically triggered during order release. You specify in Customizing, whether the function is carried out automatically, or whether it is triggered manually.

In Customizing (production scheduling profile), you can choose the following options for creating transfer requirements:

- You can activate automatic staging. The interface must be set up.
- You can specify that only complete transfer requirements are to be created per operation. This means that for a released operation there must be a transport requirement for every component.
Material Staging

- You can specify that the **committed quantity** is taken into account for staging.
Executing Unplanned Withdrawal of Components for an Order

Use
You can withdraw materials for an order that are not listed as components in the order. These "unplanned withdrawals" cause the actual costs of the production order to be updated.

Procedure
2. Choose Movement type → Consumption → To order → From warehouse. The system automatically proposes movement type 261 (goods issue for order).
3. Enter the storage location from which the goods withdrawal should take place. Choose 📦.
   The system automatically branches to the screen Enter Goods Issue: New Items.
4. Enter the number of the production order, as well as the material number, quantity, unit of measure and, if necessary, the batch number for each material that should be withdrawn. Save the goods issue.
Automatic Creation of Batches

Use
You can use this function to automatically create a batch for the material to be produced.

Features
You can make the following settings in Customizing (production scheduling profile):

- No automatic creation of batches in production orders
- Automatic creation of batches during order creation
- Automatic creation of batches during order release

In Customizing for Inventory Management you can specify that the system should automatically assign batch numbers. If this has not been specified, the system will prompt you to assign the numbers manually during order creation / order release.
Delivering to the Warehouse

The data required to deliver the manufactured material to the warehouse is contained on the Goods receipt tab page in the order.

It contains the following information:

- **tol.**: Here you can enter a percentage for the tolerance of underdelivery. If a goods receipt quantity is within the underdelivery tolerance, the receipt is regarded as a partial delivery and accepted without a corresponding warning message. If the underdelivery falls short of the tolerance, the system issues a corresponding message.

- **tol.**: Here you can enter a percentage for the tolerance of overdelivery. The system does not accept a goods receipt that is greater than the order quantity plus the overdelivery tolerance. If this case arises, the system issues an error message during the posting of the goods receipt.

- **Unlimited overdelivery**: If this indicator is set, unlimited overdeliveries are permitted. The system does not issue any warnings.

- **Stock type**: Here you can set whether upon goods receipt, the material
  - is posted to unrestricted-use stock
  - is posted to stock in quality inspection (setting is transferred from the material master)
  - is locked

- **Goods receipt**: If this indicator is set, a goods receipt is expected for the production order. This means that the production order is relevant to inventory management.

- **Delivery completed**: This indicator is set automatically by the system, as soon as a delivery is posted within the delivery tolerances. You can, however, set this indicator manually during a goods receipt posting.

- **GR non-val.**: This indicator is set automatically by the system, if the order is assigned to an account other than that of the material to be produced (for example to a sales order).

- **Storage location**: If a storage location is maintained in the material master of the material being produced, the system proposes it in this field.
  
  If desired you can also maintain **Batch, Goods recipient and Unloading point** as additional information for the goods receipt.
Automatic Goods Receipt

Use

You can specify in the control key of an operation, that the system should automatically post the finished material to stock when the operation is confirmed. A posting is also carried out for a partial confirmation.

An automatic goods receipt can only be posted for one operation per order. You should therefore make sure that only one operation in the order (normally the last operation) has a control key that specifies automatic goods receipt.

Automatic goods receipt can be activated by the production scheduling profile. It is always carried out during the confirmation of the last operation that requires confirmation. However, the indicator in the production scheduling profile is ignored as soon as one of the operations in the order has a control key that specifies automatic goods receipt.

The following applies to production scheduling profiles:

- The Production Scheduling Profile is defined in Customizing
- You can assign the profile to an order either by using the material master record (work preparation screen) of the material to be produced or the production scheduler (Customizing).

If several operations in an order have a control key that specifies automatic goods receipt, the system issues a warning message when you confirm one of them. No automatic goods receipt posting is carried out to prevent the goods receipt from being posted more than once. In this case, you have to post the goods receipt manually.

In collective orders, an automatic goods receipt is only possible for the leading order. The “Automatic goods receipt” indicator has no effect in operations of dependent orders.
What Checks are Carried out During a Goods Receipt?

Use

The system performs the following checks when the produced materials are delivered to the warehouse:

- **Goods receipt indicator**
  
  The system checks
  
  - whether a goods receipt is allowed for a production order (indicator *Goods receipt*)
  
  and
  
  - whether the goods receipt should be valued or not (indicator *GR-unvaluated*).

- **Underdelivery/overdelivery tolerances**
  
  If the quantity delivered does not lie within the underdelivery or overdelivery tolerances specified in the order header (*tabstrip Goods receipt* of the order header), the system will issue a warning or an error message.
Effects of a Delivery to Stock

Delivering a material to stock after production has the following effects:

- Effects on costs [Page 303]
- Updates in the material master [Page 304]
- Updates in the order [Page 305]
Delivery to Stock: Costs

When you deliver the material to stock, the system determines the costs of the material produced in the following way:

- If the price control indicator in the material master record is set to $, the delivered quantity is multiplied by the standard price in the material master record of the material produced.
- If the price control indicator in the material master record is set to $, the delivered quantity is multiplied by the price defined by the valuation variant.
- For more information on how goods movements affect the order costs, refer to Relationships Between Delivery and Settlement [Page 391].
Delivery to Stock: Updates in the Material Master

The following fields of the material master record (accounting view) are updated when you post a goods receipt for the material:

- **Total stock quantity**
  The total valued stock for the material

- **Total value**
  The value of all the valued stock of the material.

- **Moving average price**
  Price that is calculated according to the corresponding goods movements and invoices created for the material.
  The system automatically determines the moving average price by dividing the material value in the stock account by the total warehouse stock of a plant.
Delivery to Stock: Updates in the Order

The following fields are updated on the tabstrips *General data* and *Date / Quantity overview* of the order header when you post a goods receipt for the material produced.

- **Delivered**
- The total quantity of the material that has been delivered to stock.
- **Confirmed finish date**
  - The date of the last goods receipt for the material.
- **Order status**
  - The status "partially delivered" is activated in the order until
    - the total quantity delivered to stock reaches the order quantity (minus underdelivery tolerance), or
    - the "Del.compl." indicator is set manually during a good receipt.
- **The status final delivery** is activated in the order as soon as
  - the total quantity delivered to stock for the order is within the tolerance limits of the order, or
  - the "Del.compl" indicator is set manually during a goods receipt.

The status final delivery specifies that no further goods receipt is expected for the order. However, it is still possible to post goods receipts for remaining quantities.
Performing a Goods Receipt

1. Choose Logistics → Materials management → Inventory management → Goods movement → Goods receipt → To order.
   You branch to: Goods Receipt for Order: Initial Screen.

2. Choose Movement type → Order to warehouse.
   The system writes the movement type in the corresponding field. Check this entry and add the order number, plant and storage location and confirm the entries you have made by choosing .

   Do not use movement type 101 for unplanned goods receipt.

   You reach the screen Goods receipt for Order: Selection Screen 0001. The planned quantity of the production order is proposed.

3. Enter the quantity that you want to deliver.
   − If the production order is ready, set the indicator "delivery completed".
   − Do not set an indicator if only part of the order lot has been delivered.

4. Save the goods issue.

For more information on goods movement, see MM - Inventory Management.
Confirmations

Purpose
A confirmation documents the processing status of orders, operations, sub-operations and individual capacities. It is an instrument for controlling orders.

With a confirmation you specify

- The quantity in an operation that was produced as yield, scrap and the quantity to be reworked
- How much work was actually done
- Which work center was used for the operation
- Who carried out the operation

Exact confirmation shortly after completion of an operation is essential for realistic production planning and control.

Features
The following business transactions can be executed via confirmations:

- Updating order data (for example, quantities, activities, dates, status)
- Backflushing of components
- Automatic goods receipt (for one operation per order max.)
- Capacity reduction in the work center
- Updating costs based on confirmed data
- Updating MRP-relevant excess or missing quantities in the order

  In Customizing for Shop Floor Control, by choosing Master Data → Production Scheduling Profile, you can set up the following:
  - update of the yield variance
  - Adjustment of the operation and component quantity for a yield variance

- Trigger reprocessing function (see Trigger Points [Page 182])
- Update usage counter for equipment PRTs

You can enter confirmations for

- An order
- An operation
- A sub-operation
- An individual capacity in an operation
- An individual capacity in a sub-operation
Confirmsations

Operations, sub-operations and individual capacities are generally dealt with the same way in the confirmation. Therefore, only confirmation of operations is described. However, any differences are pointed out.

You can confirm the following data:

- **Quantities**
  You can confirm the quantity produced, the quantity of scrap that has occurred and a rework quantity. (This function does not apply to sub-operations).

- **Activity data**
  You can confirm the activities performed, for example setup time or machine time. You can also enter forecast values for individual standard values. These are used for determining the remaining activities and capacity requirements.

  The actual or planned evaluation of work can take place using a cost center (activity types assignment) or using a Business Process [Ext.]. For more information about the business process refer to Quantity Determination [Ext.].

- **Dates**
  You can confirm when setup, processing or teardown were started or finished.

- **Personnel data**
  You can confirm the following data:
  - The personnel number of the employee who carried out the operation
  - The number of employees who carried out the operation

- **Work center**
  You can confirm at which work center the operation was carried out.

- **Posting date**
  A posting date is entered for every confirmation. The default value is today's date. You can however enter another date. On the basis of the posting period in which the posting date falls, the system determines the rate for settling activities.

- **Goods movements**
  You can enter planned and unplanned goods movements for every confirmation. For more information, refer to Goods Movements in Confirmations [Page 344].

- **Reason for Variance**
  If the actual values differ from the planned values due to unpredictable events (for example, machine breakdown), you can enter a key in the Reason field, which documents the reason for the variance.

  If you combine the reason for variance key with a user status, you can trigger a follow-on function automatically via the reason for variance (for example, sending a mail to the responsible MRP controller). You can combine reasons for variance with
user statuses in Customizing. For more information, see Example: Linking a User Status with a Reason for Variance [Page 187].

- Update usage counter for equipment PRTs
  
The usage counter is updated in relation to the confirmed quantity for equipment PRTs that are assigned to the operation and for which a measuring point has been defined.

- Long text:
  
  You can enter a long text to describe a confirmation.
**Confirmation: Fixed Parameters**

**Use**

The fixed parameters influence the behavior of the confirmation function. They are defined in Customizing for an order type and plant. You can display the fixed parameters in the confirmation function.

Fixed parameters are not available for Single Screen Entry of Time Tickets [Page 318].

**Features**

In Customizing, you can specify for confirmations,

- Whether a partial or a final confirmation should always be proposed by the system, or whether it should be determined automatically depending on the quantity to be confirmed [Page 329].
  - If the confirmed quantity (yield + rework + scrap quantity) is less than the quantity to be confirmed, then the indicator is set to **Partial confirmation**.
  - If the confirmed quantity is the same as, or more than, the quantity to be confirmed, the indicator is set to **Final confirmation**.

- Whether, in the case of final confirmations, all open reservations should have the **final issue** indicator set.

- Whether a log should be displayed when an error occurs in actual cost determination.

- Which time units should be proposed for the activities to be confirmed.

- Which confirmation detail screen the system should branch to automatically after the initial screen.

- How the system should react, if the operation sequence is not adhered to during confirmation entry or if you want to confirm a quantity larger than that confirmed for the previous operation.
  
  In these situations, you can define if a message should be displayed, as well as the message category: information message, warning message and so on.

- Whether the order’s underdelivery or overdelivery tolerances should be checked during confirmation.

- Whether data that has already been confirmed or that has been confirmed according to planning should also be displayed when confirming.

- Whether an error log should be displayed for incorrect goods movements (backflushing or automatic goods receipt). Afterwards, you can correct goods movements in the material overview.

**Activities**

You maintain fixed parameters in Customizing. To have the fixed parameters displayed in the confirmation function, choose **Parameters → Fixed parameters**.
Confirmation: Variable Parameters

Use
Using variable parameters, you can override some of the fixed parameter settings when entering confirmations.
Variable parameters are not available for Single Screen Entry of Time Tickets [Page 318].

Features
You can define:

• Whether a partial or final confirmation is entered
• Whether the quantity to be confirmed [Page 329] defines whether a partial or final confirmation is entered.
  – If the confirmed quantity (yield + rework + scrap quantity) is less than the quantity to be confirmed, then the indicator is set to Partial confirmation.
  – If the confirmed quantity is the same as, or more than, the quantity to be confirmed, the indicator is set to Final confirmation.
• Whether all open reservations should be posted when a final confirmation occurs
• Which confirmation detail screen the system should branch to automatically after the initial screen
• Whether only operations that are still open, or also those that have already been confirmed, are displayed in the list of operations to be confirmed
• Whether an error log should be displayed for incorrect goods movements (backflushing or automatic goods receipt). Afterwards, you can correct goods movements in the material overview
• Whether a log should be displayed when an error occurs in actual cost determination.
• Whether only operations that require confirmation should be displayed, as defined in the control key.

These settings are variable parameters that you can display as well as maintain in the confirmation function. With each confirmation, the system copies the parameters again that are maintained in Customizing (Fixed Parameters [Page 310]).

Activities
To have the variable parameters displayed in the confirmation function, or to change them, choose Parameters -> Var. Parameters.
Entering Confirmations

Use
A confirmation documents the processing status of orders, operations, suboperations and individual capacities.

Features
You can enter a confirmation

- For an operation
  You have the following options:
  - To confirm quantities, durations, activities or personnel data, enter a time ticket confirmation or a progress confirmation.
  - To make a confirmation at a particular point in time (for example, at the start of setup or the finish of processing) enter a confirmation for a time event.
  - When you confirm time events, the system calculates the required duration. For example, the setup duration is the time between setup start and setup finish.

- For an order
  If you enter a confirmation at order header level, the system confirms all the operations that have a control key in which confirmation is optional or necessary. The quantities confirmed in the operations are proportional to the quantities confirmed in the order header.

- By using another confirmation as a reference
  You can copy the data from a confirmation that has already been made to the current confirmation. Enter the number of the reference confirmation to identify it.

Control keys are assigned to the individual operations in the routing. They control

- Whether a confirmation for an operation is necessary, possible or not possible. An operation is confirmable, if a confirmation is possible. An operation requires confirmation, if it has to be confirmed.
- Whether the operation should have milestone confirmation.

Confirmation changes the status at operation or order header level (PCNF = partially confirmed, CNF = finally confirmed). An order is partially confirmed, if at least one but not all of the operations that require confirmation have been confirmed (operation status PCNF or CNF). An order is also partially confirmed, if all the operations requiring confirmation have been finally confirmed, but there are confirmable operations that have been partially confirmed. An order is finally confirmed, when all operations for which confirmation is required have been finally confirmed (status CNF) and when there are no confirmable operations that have been partially confirmed (status PCNF).
Entering Confirmations

If you are confirming an operation, you can decide if it is a partial or final confirmation. This decision can be taken automatically; the system examines the confirmed quantity and then decides (Partial/Final Confirmation indicator in the confirmation parameters, see Confirmations: Fixed Parameters [Page 310]). An operation that was confirmed manually also receives the status MCNF (manually confirmed).

Once you have entered a confirmation for an operation, you cannot confirm at order level. If you want to confirm the whole order, you must cancel the confirmation at operation level.

The same is true at operation level for a time ticket and time event confirmation for the same operation.

Collective Entry

You can use collective entry to enter several confirmations on an operation basis, on one screen. Collective entry has the following advantages:

- You can adapt the table in which the confirmations are entered individually (table control).
  For more information refer to Table Controls [Ext].
- You can define various settings in Customizing (identification with order number or confirmation number, default settings for actual data).
- Various input help is available (enter default values, suggest actual data)

For more information refer to Entering Collective Confirmations [Page 321]

Fast Entry

Fast Entry [Page 323] is a type of time ticket confirmation that has the following advantages:

- You can enter several confirmations on one screen.
- The system does not set any locks.
- The system only executes limited checks.

One of the main features of fast entry is the decoupling of the processing functions from online data entry. The process, up to the complete update of the confirmations, is as follows:

1. You enter the confirmations [Page 323].
2. The confirmations are marked. If you want to, you can display these confirmations (Displaying Marked Confirmations [Page 347]).
3. To update the marked confirmation, schedule program CORUPROC1 as a background job. To do this on a regular basis, you can schedule program CORUPROC1 to run periodically.
   Depending on the settings in Customizing, Decoupling Processes during Confirmation [Page 360] can be triggered during the confirmation update.
4. If errors occur during the update, you can reprocess the error records (Reprocessing Confirmations [Page 353]). In this case, you use the same function as for processing error records from PDC data transfer.
**Comparison of Collective Entry and Fast Entry**

The screen and the entry flow are identical for both functions. There are the following differences in processing:

- In comparison to collective entry, fast entry only conducts limited checks.
- In fast entry the confirmations are marked first. In collective entry the confirmations are processed according to the confirmation parameters (possibly decoupled processes).

**Single Screen Entry**

Single screen entry provides you with a simple option for entering time tickets confirmations. You can design your own screen layout for single screen entry. This enables you to adapt it to the processes in your company.

The differences between this and Time Ticket Confirmation Without Single Screen Entry [Page 316] are:

- All entries are carried out on an entry screen, that is, there is no initial screen
- The layout of the entry screen can be individually defined
- The detail areas can be opened and closed, that is, the data to be entered is not organized on a tab
- If the predefined screens are not sufficient, you can define your own screens in the customer enhancement CONFPP07
Entering Time Ticket Confirmations

1. Call up time ticket confirmation entry using the transaction code 1011 (see Entering a Transaction Code [Ext.]).

   To create a Progress confirmation [Page 335] choose Logistics → Production → Shop floor control → Confirmation → Enter → For operation → Progress confirmation.

2. Enter the operation you want to confirm:
   - Enter the confirmation number or the order, sequence and operation number and choose 📚.
   - If you only enter the order number and choose 📚, the operation overview appears.
     Select the operation you want to confirm and choose 📚.

3. Depending on the data you want to confirm, you can branch from the initial screen to various tab pages.

   → Quantity/activity
   → Dates
   → Personnel/additional data
   → Quantity/forecast

4. Choose partial confirmation, final confirmation or automatic confirmation.
   - If the operation has only been partly processed you can still create confirmation data so as to document the current progress of the operation. In this case set the indicator Partial confirmation.

   ![A partial confirmation can be especially useful if the operations in your orders have long lead times.](image)

   - When the operation has been completely processed set the indicator Final confirmation.
   - If you want the decision between a partial and final confirmation to be dependent on the quantity to be confirmed [Page 329] (see Variable Parameters [Page 312]), choose ‘Automatic confirmation’.
   - If you want to confirm data for an operation that is finished, and you wish to simultaneously clear any open reservations for the operation, mark the indicator Clear open reservs. This sets the final issue indicator. The operation receives the system status final issue as well as the system status finally confirmed.

5. Enter the data you want to confirm.

   ![In time ticket confirmations, you enter the quantity that you have processed since the last confirmation for the operation. You can let the system suggest a yield to be confirmed (see Determining a Default for Yield [Page 329]).](image)
If not all fields that you need for confirmation are available on the screen, you can reach the required fields or the required screens via the function keys or via the menu.

6. Save your confirmation.

When you are entering a confirmation, you can go to the goods movements overview (choose Goods movements) to check or change goods movements that are to be posted with the confirmation, if required. As soon as you save a confirmation, the goods movements are also posted. For more information, refer to Goods Movement Overview [Page 286].
Executing Single Screen Entry of Time Ticket Confirmations

Prerequisites
You have defined the layout and default values for single screen entry in Customizing (see Settings for Single Screen Entry [Page 320]).

Procedure
1. Choose Logistics → Production → Shop floor control → Confirmation → Enter → For operation → Time ticket.
2. Enter the confirmation data in the header area. In the header data, you identify the operation that you want to confirm.
3. Set the key Confirmation type.
   - Partial confirmation
     If the operation has only been partly processed you can still create confirmation data so as to document the current progress of the operation. A partial confirmation can be especially useful if the operations in your orders have long lead times.
   - Final confirmation
     If the operation has already been completely processed, choose this setting.
   - Automatic final confirmation
     If you want the decision between a partial and final confirmation to be dependent on the quantity to be confirmed [Page 329], choose this setting
     - If the confirmed quantity (yield + rework + scrap quantity) is less than the quantity to be confirmed, then a partial confirmation is executed
     - If the confirmed quantity is the same as or more than the quantity to be confirmed, a final confirmation is executed
     With the indicator Clear open reservations, you define that with a final confirmation, the Final issue indicator is set for all open reservations that are assigned to the confirmed operation. The operation receives the system status final issue as well as the system status finally confirmed.
4. Enter the confirmation data in the detail areas.
   ![Actual data]
   If you want the system to propose the data to be confirmed, choose Actual data.
   ![Name of the area]
   You can open the detail areas (choose Name of the area) or close them (choose Name of the area).
5. To post the confirmation, choose.
Executing Single Screen Entry of Time Ticket Confirmations

You remain on this screen. The data fields are deleted and are available again for entering the next confirmation.

To enter a new confirmation, choose 🔄. If you make a mistake when entering data, you can use this function to start afresh. You can also use this function if, as you enter data, you discover that you have entered the wrong confirmation.

When you are entering a confirmation, you can go to the goods movements overview (choose 📊 Goods movements) to check or change goods movements that are to be posted with the confirmation, if required. As soon as you save a confirmation, the goods movements are also posted. For more information, refer to Goods Movement Overview [Page 286].
Settings for Single Screen Entry

In Customizing for Shop Floor Control, you can define confirmation profiles for single screen entry of time ticket confirmations by choosing Operations → Confirmation → Single Screen Entry → Define Single Screen Entry.

In a confirmation profile, you can define which input and output fields are available to a user or a user group and the order that they come in. You can also define which settings are made regarding default values.

You assign individual user profiles via the user parameter CORUPROF. If no value is assigned to this parameter, the standard profile is used. If there is no standard profile, a predefined user interface is used.

For more information, refer to the Implementation Guide (IMG) under Define Single Screen Entry [Ext].
Entering Collective Confirmations

Prerequisites
You can predefine values to identify confirmations and to determine default values in Conf. parameters for collective confirmation/fast entry (Customizing for Shop Floor Control by choosing Operations → Confirmation → Confirmation Parameters Collective Entry/Fast Entry):

- **Identifying the confirmation**
  You can identify an individual confirmation either by the confirmation number or the order number/operation number.

- **Suggest actual data**
  You can define whether and when (after entry, during saving) quantities (see Determining a Default for Yield [Page 329]) or activities are suggested. The default setting is that no quantities are suggested and activities are determined during saving. Personnel data and dates are always suggested.

Procedure
1. Choose Logistics → Production → Shop floor control → Confirmation → Enter → For operation → Collective entry.
   The screen for collective entry of confirmations appears.

2. In this screen you can enter confirmations in a table (table control). You enter a new confirmation in each line. You can control the appearance of the table yourself. For more information refer to Table Controls [Ext.].
   You can change the type of confirmation identification during input. To do so choose Other view.
   Enter all the data needed for the confirmations. Each line corresponds to a new confirmation. In this line you have all the fields that are available in single entry of a time ticket confirmation.

   ![Diagram showing data entry process]

   On the top line of the screen you can enter default values (for example unit of measure, personnel number) that are copied to all confirmations. Enter the values and choose . You can save these default values for a specific user, so that they are preset the next time the user logs on. You can also delete these defaults.

   ![Diagram showing default value deletion]

   With this function, you can let the system suggest actual data (quantities, activities, dates, personnel data). To do so, select the confirmations, choose Propose actual data, set the indicator for the relevant actual data and choose . This data overwrites data that you may have already entered.

3. Save your confirmations.
Entering Collective Confirmations

To reach the **Actual data screen** for the selected confirmations choose 📊. Here you have the complete functionality of time ticket confirmation. From this screen you can go to the detail screens and to the goods movement overview. If several confirmation have been selected, you can switch between the individual confirmations.

You can switch to the goods movement overview from the collective entry screen (choose 🏷 Goods movements). In this screen the goods movements for the selected confirmations are displayed.

You can check and, if necessary, change the goods movements. When you go back to the collective entry screen, the GM indicator is set for the selected confirmations (goods movements for confirmations already determined). As soon as you save a confirmation, the goods movements are also posted.

For more information, refer to Goods Movement Overview [Page 286].
Executing Fast entry for Time Tickets

1. Choose Logistics → Production → Shop floor control → Confirmation → Fast entry → For operation → Time ticket.

   The screen for fast entry of confirmations appears.

2. From this step the input dialog for fast entry and collective entry of confirmations [Page 321] is identical.

For more information about fast entry, refer to Entering Confirmations [Page 313].
Entering a Confirmation for a Time Event

1. Choose Logistics → Production → Shop floor control → Confirmation → Enter → For operation → Time event.

2. Select the time event you want to confirm.

3. Enter the operation you want to confirm:
   - Enter the number of either a confirmation, or the order, sequence and operation number. The operation is then clearly identified.
   - If you enter an order number, the system displays a list with the corresponding operations. Select an operation.

4. Choose ✅.

5. Enter the actual data for the time event.
   You can let the system suggest a yield to be confirmed (see Determining a Default for Yield [Page 329]).

6. Save your confirmation.

When you are entering a confirmation, you can go to the goods movements overview (choose 🛒 Goods movements) to check or change goods movements that are to be posted with the confirmation, if required. As soon as you save a confirmation, the goods movements are also posted. For more information, refer to Goods Movement Overview [Page 286].
Time Event Confirmations

Every confirmed time event is assigned internally to a record type group:

- Setup times are assigned to record type group 1.
- Processing times are assigned to record type group 2.
- Teardown times are assigned to record type group 3.

Each record type group can be assigned to one or more parameters in the standard value key for the work center (for example machine time). (See Customizing in Production $ Basic data $ Work center $ General data $ Standard value $ Define standard value key). The link between time event and parameter ensures that the calculated duration counts as an activity (for example, when calculating the actual costs of the operation).

The processing of an operation requires both machine time and labor time. The time event confirmation for the processing section of the operation can take effect on activity ‘machine time’ and on ‘processing time’, if you enter record type group ‘2’ for the parameters ‘machine’ and ‘labor’ in the standard value key.

You can only confirm quantities when you confirm processing time events.

You can only confirm activities that cannot be assigned to a particular record type group (Set-up, processing, teardown) by using the time event ‘Variable activity’. The confirmed value is assigned to corresponding value in the standard value key parameters.
Entering Confirmations at Order Level

1. Choose Logistics → Production → Shop floor control → Confirmation → Enter → For order.

2. Enter the order number. Choose 📏.

3. Enter the data you want to confirm.

You can confirm activities and quantities with different proportions of the total value (for instance 70% of the activity, 50% of the quantity). If you only enter one of the two values, the other is entered with the same percentage. The planned values are posted for the operation activities.

You can enter a degree of processing. Only the activities, not the quantities, will be determined from the degree of processing.

4. Save your confirmation.

When you are entering a confirmation, you can go to the goods movements overview (choose 🏦 Goods movements) to check or change goods movements that are to be posted with the confirmation, if required. As soon as you save a confirmation, the goods movements are also posted. For more information, refer to Goods Movement Overview [Page 286].
Confirming Individual Capacities

Use
You can also enter confirmations for individual capacities. An individual capacity is a subdivision of an operation's capacity requirements (for example, between various machines or employees). Each individual capacity that you create for an operation receives a split number.

Features
You have two ways of confirming individual capacities:

- **Manual Confirmation of an Individual Capacity**
  With relation to capacity category and split number, you can confirm quantities as well as activities for an individual capacity.

- **Summary Confirmation of all Individual Capacities**
  Using a Summary Confirmation [Page 340], you can confirm a degree of processing for all individual capacities. All the quantities and activities are confirmed proportionally by entering a degree of processing.

Updating actual values
You use the NoActValue indicator (Customizing for Shop Floor Control, by choosing Operations → Capacity Planning → Define Capacity Category) to control whether the capacity requirement of an operation is also reduced when you confirm splits, dependent on the capacity category. If the indicator is set, the system only reduces the capacity requirements of the splits. If it is not set, the system reduces both the capacity requirements of the splits and of the operation.

If the NoActValue indicator is not set, the actual values of the splits as well as those of the operation are updated when the splits are confirmed. If you are working with **standard value splits**, make sure

- You confirm for only one split or
- None of the splits is confirmed, but you enter an extra confirmation for the quantities in the operation.

When the quantities are confirmed both in the individual splits and the operation, the confirmed quantities are added together. This has the following effects:

- Due to the increased quantity confirmation, the system reduces too much capacity requirement
- In the case of backflushing, too many components are issued
- In the case of automatic goods receipt, the system posts too much material to stock

Actual costs are only calculated, if the indicator No actual values is not set. In this case only, the actual values of the split are passed on to the operation. When you confirm splits for a capacity category, and the confirmed values of the individual capacity are passed on to the operation, you make sure that you also confirm any activities performed by a capacity category that does not pass its actual values on to the operation.
You have an operation that is processed using two capacities: One capacity with the capacity category *Machine*, with two splits, and one with the category *Person*, also with two splits. You have set the *NoActValue* indicator for the capacity category *Machine*, so that the actual values are not confirmed twice. Only when the splits for the capacity category *Person* are confirmed, are actual values confirmed and as a result the actual costs are calculated. Activities that only arise for the capacity category *Machine* (for example, machine time) should then also be entered when the capacity category *Person* is confirmed.
Determining a Default for Yield

In Customizing, you can specify that the system suggests a yield to be confirmed for each confirmation. Either the order quantity or the quantity of previously confirmed operations is taken into account. The following settings are relevant:

- **In the confirmation parameters** (Customizing for Shop Floor Control, choose Operations → Confirmation → Define Confirmation Parameters) you set the Propose indicator in the quantities area, to stipulate that quantities should be proposed when confirmations are entered. The same key is found in Customizing for Single Screen Entry (Customizing for Shop Floor Control, by choosing Operations → Confirmation → Single Screen Entry → Define Single Screen Entry).

- **In the confirmation parameters**, you also specify what should happen if you do not adhere to the sequence of operations when entering confirmations (Operation sequence key). Possible message types are: No message, information, warning, error.

- **When you define a Control key for operations** (in Customizing for Shop Floor Control by choosing Master Data → Routing Data → Define Control Key), you stipulate whether an operation can or must be confirmed (Confirmations key).

  For confirmations of individual capacities (capacity splits) the planned quantity of the relevant split is used instead of the underdelivery tolerance.

How the default quantity is determined, is described below. It makes no difference if the sequence of operations is to be kept to or not.

**Operation Sequence is not Relevant**

The system suggests the yield from the last finally confirmed predecessors (except rework operations). If there are no finally confirmed operations, the system uses the order quantity.

**Operation Sequence Should be Adhered To**

The following graphic illustrates which factors have an effect on the default quantity if the operation sequence is to be adhered to.
Determining a Default for Yield

Parallel Sequences
If an operation has several predecessors (parallel sequences), then the default quantity is the smallest quantity from the various operations.

Rework
If rework operations follow the operation in question, the confirmed quantity of the rework operation is added to the quantity to be confirmed.

Checking the Quantity to be Confirmed
If the operation sequence is checked for confirmations, then the following quantity check takes place: If you want to enter a confirmation in which the sum of the yield, rework quantity and scrap is larger than the yield of the predecessor, then the system issues an appropriate message (for example, an error message). The predecessor is determined exactly as described in the graphic.

Irrespective of whether the operation sequence is adhered to, the quantity is checked against the quantity of the predecessor operation (= expected quantity) and a message is issued (the category is set in Customizing). The following cases can occur:

- The confirmed quantity is larger than the expected quantity.
- You are entering a final confirmation and the confirmed quantity is smaller than the expected quantity.

The message category determines your next entry option:

- After acknowledging a warning, you can continue entering.
- In the case of an error message, the system terminates the input dialog.
Special Types of Confirmation

Use
In the special types of confirmation, various processes are automated.

Features
The following special types of confirmation are available in the R/3 system:

- Milestone Confirmation [Page 333]
- Progress Confirmation [Page 335]
- Summary Confirmation [Page 340]
- Standard Confirmation [Page 342]
Milestone Confirmation

Use

The milestone confirmation is a special form of confirmation, in which the confirmation of one operation causes other operations or suboperations to be automatically confirmed at the same time.

Milestones are operations that have the corresponding indicator in the control key.

You use milestones, for example, if you have included inspection operations that require confirmation.

Features

Operations can be defined as milestone operations in their control keys. If a milestone operation is confirmed, then previous operations are automatically confirmed.

Operation 30 is marked in its control key as a milestone operation. You partially confirm operation 30 with a quantity of 100 pieces. Operations 20 and 30 are then also partially confirmed with the same quantity.

Observe the following special features:

- If several operations in an order are marked as milestones, the processing sequence of these operations must be adhered to when carrying out confirmations. In this case, automatic confirmation is effective up to the preceding milestone within the operation sequence.

  Operation 30 and operation 50 are marked in their control keys as milestone operations. First, you must confirm operation 30. By confirming operation 50, you only automatically confirm the preceding operation 40.

- You can define whether the planned scrap percentage rate is incorporated in the quantity calculation for automatically generated confirmations. You make this setting in Customizing for Shop Floor Control by choosing Operations → Confirmation → Define Confirmation Parameters (Generated confirmations without quantity adjustments, Generally Valid Settings tab page):

  - If the indicator is not set, the planned scrap percentage rate is used for the quantity calculation. The yield as well as the scrap are displayed.

  - If the indicator is set, then the scrap is posted as yield in the automatically confirmed operations. The confirmed total quantity is identical in the milestone confirmation and in the automatically generated confirmations.

- If a milestone operation is confirmed, all preceding suboperations up to the next milestone operation are also automatically confirmed. Suboperations of milestone operations must always be confirmed manually.
Milestone Confirmation

Operations 10, 20, 30 and 40 each have a suboperation. Operation 20 and operation 40 are marked in their control keys as milestone operations. You confirm operation 20 with a quantity of 50 pieces. The system automatically confirms operation 10 with the same quantity and its suboperation with its corresponding activities. You then confirm operation 40 with a quantity of 100 pieces. The system automatically confirms operation 30 (+ suboperation) with the same quantity (+ activity). You must confirm the suboperations for operation 20 and 40 manually.

• Operations that have already been manually confirmed are not affected by milestone confirmations.

Operation 30 is marked in its control key as a milestone operation. You partially confirm operation 10 manually with a quantity of 50 pieces. You then finally confirm operation 30 manually with a quantity of 100 pieces. Operation 10 is still partially confirmed with a quantity of 50 pieces; operations 20 and 30 however are finally confirmed with quantities of 100 pieces.

• If you enter a milestone confirmation for an operation, it receives the status MILE (milestone confirmation) and the status MCNF (manually confirmed). The automatically confirmed operations also receive the status MILE. If you use the transaction for entering progress confirmations, the operation also receives the status MILE.

You enter a confirmation for milestone operation 30. It does not matter which transaction you use. Operation 30 receives the statuses MCNF and MILE. Operations 10 and 29 receive the status MILE.

In collective orders, you can use milestone confirmations to confirm operations of more than one order simultaneously (see Example: Confirming Collective Orders [Page 482]).

• In milestone confirmations, planned activities are always posted on the basis of the confirmed quantity. If you have entered activities manually during a milestone operation, planned activities are also confirmed when the preceding operations are automatically confirmed. The exception to this is the setup times, which are always confirmed fully, independently of the entered quantity.

You enter a confirmation of 7 pieces for milestone operation 30, which has a planned yield of 10 pieces. Operation 20 is confirmed automatically. The planned machine time for operation 20 is 40 minutes, therefore a machine time of 28 minutes is confirmed.
Progress confirmation

Use

The milestone confirmation is a form of confirmation, in which the confirmation of one operation causes preceding operations or sub-operations to be automatically confirmed at the same time. When you carry out a progress confirmation, you report the progress of the order by confirming the operation that you have reached (for example at the end of the day).

As opposed to milestone operations, you do not have to make any settings in the control key for operations that are to be confirmed with progress confirmation. You can select each confirmable operation.

If the operation has the relevant indicator in the control key, one speaks of Milestones [Page 333] rather than progress confirmation.

⚠️

As opposed to other types of confirmation, progress confirmation requires you to enter the total quantity that has been produced, rather than the quantity that has been produced since the last confirmation. This means that the quantity that you enter in a progress confirmation is different from that of other types of confirmation, if you carry out confirmations for partial quantities.

You produce 10 pieces of a material in total. You want to enter the confirmations in two steps, each time after 5 pieces have been produced.

- If you use a time ticket confirmation, you enter 5 pieces per confirmation.
- If you use progress confirmation, you enter 5 pieces for the first confirmation and 10 pieces for the second confirmation (= the total quantity).

Integration

You can combine progress confirmation with the other forms of confirmation. You should note the following:

- Operations which have been confirmed directly or automatically with a milestone confirmation, are not affected by a progress confirmation.

Operation 30 is marked in its control key as a milestone operation. You partially confirm operation 30 with a quantity of 50 pieces. Operations 10 and 20 are likewise partially confirmed with a quantity of 50 pieces. Then you enter a progress confirmation for operation 50 with a quantity of 100 pieces, which means that operation 50 is finally confirmed. Operation 40 is also finally confirmed with 100 pieces, whereas the confirmation data for operations 10 to 30 is not changed. To finally confirm these operations, you must make a confirmation for operation 30 with a total quantity of 100 pieces.
Progress confirmation

- If no confirmations are yet available for a milestone, the system does not allow you to enter a progress confirmation for an operation following on from the milestone. The milestone has to be at least partially confirmed.

  Operation 30 is marked in its control key as a milestone operation. You want to enter a progress confirmation for operation 40 for a quantity of 50 pieces. The system does not allow you to create a progress confirmation for operation 40 until you confirm operation 30.

- Operations that have been confirmed manually are not affected by a progress confirmation.

  You partially confirm operation 10 manually with a quantity of 50 pieces. You then confirm operation 30 with a progress confirmation with a quantity of 100 pieces. (This is a final confirmation). Operation 10 is still partially confirmed with a quantity of 50 pieces; operations 20 and 30 however are finally confirmed with quantities of 100 pieces.

- Operations that have been confirmed via a summary confirmation or a standard confirmation, are not affected by a progress confirmation, that is, they are treated like manually confirmed operations.

Features

A progress confirmation is entered at operation level. When you enter a progress confirmation, all preceding operations are confirmed. The quantities for the automatically confirmed operations are determined automatically.

  You enter a progress confirmation for operation 30 for a quantity of 100 pieces. The preceding operations 10 and 20 are are automatically confirmed also with quantities of 100 pieces.

If progress confirmations already exist for a preceding operation, the quantity to confirm is determined by expanding to the total confirmed quantity of the operation.

  You have confirmed operation 30 with 40 pieces using a progress confirmation. You enter a progress confirmation of 90 pieces for operation 40. The system automatically produces a confirmation for operation 30 for the additional quantity of 50 pieces (=90 pieces - 40 pieces).

Note the following points regarding progress confirmation:

- You do not need to keep to the processing sequence when using progress confirmations.

  You want to enter a progress confirmation for operations 30 and 50. You first enter a partial confirmation of 50 pieces for operation 50. All operations preceding operation 50 are automatically partially confirmed. You then enter a partial confirmation of 50
pieces for operation 30. Operation 30 remains confirmed with a quantity of 50, since the same progress level had already been recorded through in the first confirmation.

- You can define whether the planned scrap percentage rate is incorporated in the quantity calculation for automatically generated confirmations. You make this setting in Customizing for Shop Floor Control by choosing Operations → Confirmation → Define Confirmation Parameters (Generated confirmations without quantity adjustments, Generally Valid Settings tab page):
  - If the indicator is not set, the planned scrap percentage rate is used for the quantity calculation. The yield and the scrap are both displayed.
  - If the indicator is set, then the scrap is posted as yield in the automatically confirmed operations. The confirmed total quantity is identical in the milestone confirmation and in the automatically generated confirmations.

- If a progress confirmation is entered, all preceding sub-operations are also automatically confirmed. Sub-operations of the operation for which the progress confirmation is entered, always have to be confirmed manually.

  Operations 10 and 20 each have a sub-operation. You confirm operation 20 with 50 pieces using a progress confirmation. The system automatically confirms operation 10 with the same quantity and its sub-operation with its corresponding activities. You must confirm the sub-operations for operation 20 manually.

- If you enter a progress confirmation for an operation, it receives the status MILE (Milestone confirmation) and the status MCNF (Manually confirmed) Preceding operations whose confirmations were made automatically receive the status MILE only.

  You enter a progress confirmation for operation 20. Operation 20 receives the statuses MCNF and MILE. Operation 10 receives the status MILE.

  In collective orders, you can use progress confirmations to simultaneously confirm operations of more than one order (see Collective Orders: Example of Confirmations [Page 482]).
Entering Progress Confirmations

You enter progress confirmations similarly to Entering Time Ticket Confirmations [Page 316] The only difference is in the quantities entered:

In progress confirmations you enter all quantities (yield, scrap, rework) as the total quantity.
Progress Confirmations and Operations with Final Confirmations

Under certain circumstances, the system does not allow you to enter a confirmation for an operation with final confirmations. This is the case in the following situations:

- An operation was finally confirmed using a progress confirmation. You now want to make a progress confirmation for a subsequent operation with a larger quantity as in the previous confirmation. The system would then have to increase the quantity of the finally confirmed operation. This is not supported.

- You want to enter a confirmation that has been confirmed automatically using a progress confirmation.

  First, correct the operations that you confirmed manually using a progress confirmation.

You have entered a progress confirmation for operation 30 for a quantity of 8 pieces (final confirmation). Further confirmations are dealt with as follows:

- You enter a progress confirmation for operation 30 for 9 pieces (that is, one piece more than before). The system displays a warning, but allows the confirmation to take place.

- You enter a progress confirmation for operation 20 for 9 pieces (that is, one piece more than before). The system does not allow confirmation because operation 20 has already been finally confirmed via operation 30. To enter this confirmation, the confirmation of operation 30 must first be corrected (that is, canceled and reentered).

- You enter a progress confirmation for operation 40 for 9 pieces (that is, one piece more than before). Again, the system does not allow confirmation. Operations 10 to 30 have already been finally confirmed via the progress confirmation of operation 30. To enter this confirmation, the confirmation of operation 30 must first be corrected.
Summary Confirmations

Use
Summary confirmations are a special form of confirmation, in which all the suboperations that belong to an operation are confirmed at the same time. All the planned activities are confirmed proportionally by entering a degree of processing.

Quantities are not confirm for suboperations.
Creating Summary Confirmations

1. Call up time ticket confirmation entry using the transaction code CO11 (see Entering a Transaction Code [Ext.]).

2. Enter the operation you want to confirm:
   - Enter the number of either a confirmation, or the order-, sequence- and operation number. The operation is then clearly identified.
   - If you only enter the order number and choose , the operation overview appears. Select the operation you want to confirm. Choose Quantity/Activity, Dates, Personnel, Actual Dates or Forecast.

3. You can now enter a confirmation for the operation, which is also saved when you save the summary confirmation. In the next step you must make a decision about this.

4. Choose Goto → Summary confirmation. The system asks you whether the confirmation for the operation should also be saved. After you have answered this, the summary confirmation screen is displayed.

5. There are two options:
   - Enter a degree of processing. This degree of processing will then be confirmed for all suboperations when saved (summary confirmation of all suboperations).
   - Select one of the suboperations and go to the corresponding confirmation screen (for example, personnel data). There you can confirm the individual suboperations manually.

   If no operation is selected, you branch to the detail screen for the confirmation of the operation.

6. Save the summary confirmation.

Suboperations that have already been manually confirmed are only affected by a summary confirmation, if the Final confirmation indicator is set when executing a summary confirmation.

You have already confirmed suboperations. These suboperations are not updated by a summary confirmation. In the case of a final confirmation, these suboperations are set to finally confirmed.
Standard confirmation

Use
The standard confirmation is a special form of confirmation, in which the planned values of an operation are confirmed as the actual values.

Features
Note the following points:

• You can only enter one standard confirmation at a time for an operation. An operation that was confirmed using a standard confirmation receives the corresponding status.

• You can only use standard confirmations for operations that have not been finally confirmed.

• You can combine a standard confirmation with a milestone confirmation. If you confirm a milestone operation using a standard confirmation, the system also executes the milestone confirmation.

• You cannot use a standard confirmation for the last expected confirmation in an order. You can, however, get the system to propose the planned values automatically (setting in Customizing) or manually (by choosing in the confirmation detail screen).

An operation that has been confirmed using a standard confirmation, receives the status STND (standard confirmation).
Entering Standard Confirmations

1. Choose Logistics → Production → Shop floor control → Confirmation → Enter → For operation → Time ticket or Time event.

2. Enter the number of the order for which you want to enter confirmations.
   The system automatically branches to the corresponding operation overview screen.

3. Select the operation you want to confirm.

4. Save your confirmation. The system confirms the values (that is, the planned values) that are to be confirmed for the operation.
Goods Movements for Confirmation

Goods movements can be created with a confirmation:

- **Backflush**
  
  If you confirm an order / operation with components that have the Backflushing indicator set, the system automatically posts a goods issue for these components. For more information about the Backflushing indicator, refer to the end of this section.

- **Automatic Goods Receipt**
  
  If the control key of the operation being confirmed specifies automatic goods receipt, the system automatically posts the produced material to stock. Automatic goods receipt can also be activated by the production scheduling profile. For more information refer to Automatic Goods Receipt [Page 300].

  You cannot post an automatic goods receipt for co-products.

  Automatic goods movements are not permitted for materials that require serial numbers. However, if an automatic goods movement is specified for a material that requires a serial number then an error record is written. This error record can be displayed using the reprocessing function but it cannot be posted. Error records for materials that require serial numbers must be deleted manually. The goods movement must then be executed manually in inventory management.

Goods Movement Overview

You can branch from the confirmation to the Goods Movement Overview [Page 286] of the planned goods movements. In Customizing for Confirmations (All components indicator) you determine whether all material components are listed or just those for which automatic goods movements should occur. You can change the goods movements on the material overview.

Incorrect Goods Movement

If errors arose for whatever reason during a goods movement (for example, during backflushing insufficient stock is available in the warehouse) then you can either process the incorrect goods movements directly in the confirmation transaction or separately using a reprocessing function.

- **Correction in the confirmation**
  
  In Customizing for Confirmations (Goods movements indicator in the Error handling/logs area) you can define that, for individual entry of confirmations, the system displays an error log before it saves a confirmation with incorrect goods movements. Before you save the confirmation you have the option of correcting the incorrect goods movements.

- **Correction when reprocessing**
  
  If you want to process incorrect goods movements at a later stage, you can use the reprocessing function. For more information, see Reprocessing Goods Movements [Page 358].
Goods Movements in the Background

Using Decoupling Confirmation Processes [Page 360] in Customizing for Confirmation Processes, you can define that goods movements are to be stored temporarily, rather than being carried out immediately during confirmation. You can post the goods movements being temporarily stored, by scheduling program CORUPROC in a background job. To schedule the background job in Customizing for Shop Floor Control choose Operations → Schedule background job.

Backflushing Indicator

You can control backflushing in the following objects:

- Material master
  
  With the Backflushing key (MRP) you can specify that
  
  - The material is not generally backflushed
  
  - The material is always backflushed
  
  - The work center determines whether the material is backflushed

- Work center
  
  You can set the Backflushing indicator on the Basic data screen. This is only taken into account, if the material master stipulates that the work center should determine whether the material is backflushed. Work centers are assigned to a production order via the operations. The operations are copied from the routing used.

- Routing
  
  You can stipulate that the material is to be backflushed, on the component overview in the routing. This indicator is always taken into account, irrespective of the indicators in the material master or work center.

If the Backflushing indicator has been maintained in the master data, it is copied from there when you create a production order. You can change the indicator in the production order, as you like.

In Customizing for Shop Floor Control, you define that Stock Determination [Page 294] for backflushing is to take place by choosing Operations → Stock and Batch Determination for Goods Movement.
Determining Quantities for Batch Splits/Parts to be Discontinued

Requirements or stocks are reduced sequentially in the quantity determination for batch splits or discontinued materials during backflushing [Page 344].

In detail:

- **Batch splits [Page 156]**

  The batch stocks for a material are reduced according to the sequence in the component overview for the order. This means the consumed quantity of a component is withdrawn from the first batch, till the planned requirements quantity is achieved. Afterwards, withdrawals are made from the next batch.

  The sequence of the batches in the component overview is determined by the sort in the batch search strategy.

  You have carried out a batch split for material MAT-1. The requirements quantity for batch BT-1 is 30 pieces and for batch BT-2 is 10 pieces (total requirements 40 pieces). You make a partial confirmation and a final confirmation for half the order quantity in each case. In the partial confirmation 20 pieces are withdrawn from batch BT-1. During the final confirmation 10 pieces are withdrawn from batch BT-1 and 10 pieces from BT-2.

- **Discontinued materials [Page 151]**

  In the case of simple discontinuation, the stock of the material to be discontinued is used first, then the new material.

  MAT-3 is the follow-up material for MAT-2. There are 30 pieces of MAT-2 still in stock. 40 pieces of MAT-2 are required by a production order. After the availability check, 30 pieces MAT-2 are reserved for the order. The remainder of 10 pieces changed to MAT-3. You make a partial confirmation and a final confirmation for half the order quantity in each case. In the partial confirmation 20 pieces of MAT-2 are withdrawn. In the final confirmation 10 pieces of MAT-2 and 10 pieces of MAT-3 are withdrawn.

  In the case of parallel discontinuation, the stock of the main discontinued part is used first, then the stock of the new material(s).

  The discontinued/new materials should be treated in the same manner in backflushing; that is, either all material or no material is backflushed.
Displaying Requested Confirmations

Use
Requests are transmitted via fast entry of confirmations to the system.
The posting of requested confirmations is carried out in general by scheduling the program CORUPROC1 as a background job. You can create variants for this program to account for different applications.

Procedure
1. Choose Logistics → Production → Shop floor control → Confirmation → Requested confirmations.
   A dialog box for selecting requests appears.
2. Enter the application and the interface for the requests that you want to display.
3. Choose 📜.
   A list of requested confirmations appears.
Displaying Confirmations

1. Choose Logistics → Production → Shop floor control → Confirmation → Display.

2. Enter the data for the confirmation that you want to display (confirmation number/counter or order, sequence and operation number).

3. Choose .
   - If several confirmations exist, the system branches to an operation overview containing the confirmations. Select one or more confirmations and choose . If you select more than one confirmation then you can switch between confirmations in the detail display.
     You double-click an individual confirmation to branch to it.

     You can print the operation overview and define a user-specific layout for it (column selection and sorting).

   - If only one confirmation exists, the system branches directly to the detail screen for the confirmation.
Canceling Confirmations

Use
It is possible to cancel data previously confirmed.

Features
Every confirmation entered in the system can be canceled. If you entered three confirmations for an operation, you can also cancel three confirmations and all confirmations automatically created by them (Example: Canceling Confirmations [Page 351]).

- You can change confirmations or partially cancel them.
- If you also activate user statuses when confirming an operation, these statuses are not automatically canceled when you cancel the confirmation.
- If you cancel a confirmation, the functions that were triggered by a trigger point are not revoked (for example, creating a rework operation).
Canceling Confirmations

Prerequisites
If you want to cancel a confirmation, you must decide which confirmation is to be canceled.

- If only one confirmation has been entered for an operation or order, you only have to identify the operation/order.
- If several confirmations have been entered for an operation or order, you must also specify which confirmation you want to cancel.

Procedure
1. Choose Logistics → Production → Shop floor control → Confirmation → Cancel.
2. Enter the data for the confirmation that you want to cancel (confirmation number/counter or order, sequence and operation number).
3. Choose .
   - If several confirmations exist, the system branches to a screen which lists the confirmations. You can directly cancel the required confirmations here by selecting them and choosing .
     To branch to the detail screen of the confirmation, select the confirmation and select . To cancel the confirmation, choose .
     You can print the operation overview and define a user-specific layout for it (column selection and sorting).
   - If only one confirmation exists, the system branches directly to the detail screen for the confirmation. To cancel the confirmation, choose .
4. When you save, you can enter a long text describing the reasons for the cancellation.
   To reverse the cancellation of a confirmation, you must manually reenter a confirmation.
Example: Canceling confirmations

For an operation you have entered

- A partial confirmation of 50 pieces
- A partial confirmation of 30 pieces
- A final confirmation of 20 pieces

In total, therefore, you have already confirmed 100 pieces for the operation.

You notice that you have forgotten to confirm 2 pieces of scrap and cancel the final confirmation of 20 pieces.

The system sets the confirmed operation quantity back to 80 pieces and the confirmation status in the operation back to **partially confirmed**.

Now you can enter a final confirmation with a yield of 18 pieces and a scrap quantity of 2 pieces.
Reprocessing

Use
In the area of confirmation, you can separate confirmation entry from processing. As a result, errors may occur when confirmations, or the processes that follow them, are posted. You can eliminate these errors by reprocessing them. The following reprocessing functions are available:

- Confirmations [Page 353]
- Actual costs [Page 356]
- Goods movements [Page 358]
Reprocessing Confirmations

Use
You use this function to process confirmations for which errors occurred as they were being automatically processed. With this function, you can either delete or, if possible, eliminate the errors and post the confirmations again.

Confirmations with errors can arise if they were entered in one of the following ways:

• Upload from a PDC system (see Upload [Page 369])
• Online entry (Fast Entry [Page 323] or Mass Processing [Page 429])
• Entry via BAPI interface

Possible errors include:

• Order does not exist (for entry via PDC system, BAPI interface)
• Order was locked
• Sequence of time events incorrect
• Individual capacity does not exist
• Work center or personnel number does not exist

Features
Reprocessing has the following advantages:

• Selection
  On the initial screen, you can enter your selection criteria for selecting the confirmations that you want to reprocess. Possible selection criteria are: Production order, plant, confirmation, WBS element, sales order, MRP controller, work center, created by, created on.

• Navigation
  The screen for reprocessing confirmations is split into two areas:
  – Overview list of the confirmations
  – Detail screen for the selected confirmation
  In the standard setting, the overview list is on the left and the detail display of the confirmation is on the right. To change the position of the overview list, choose (move the list in an anti-clockwise direction, select the position of the overview list). This last setting is saved for the particular user who created it and is used again the next time the function is called up.

• Reprocessing
  The confirmation that you have chosen from the overview (cursor position) is displayed in the detail screen. In the detail screen, you can remove the error in the confirmation.
  The following confirmations can be reprocessed:
  – Order confirmation
Reprocessing Confirmations

- Operation confirmation
- Time event confirmation
- Activity confirmation

The layout of the detail screen is determined by the confirmation that you are currently processing. The layout can be set up flexibly for an operation confirmation (see Single Screen Entry [Page 318]).

• Display error

To display a long text about the error for each confirmation, position the cursor on the confirmation and choose .

• Check confirmation

You can check one or more confirmations. To check confirmations, select them and choose . In the Status field on the overview list, the result of the check is displayed with a symbol.

• Delete confirmation

If a confirmation is not to be posted because, for example, it has entered the SAP System by mistake, you can delete it. To do this, select the confirmation and choose . The confirmation is flagged for deletion and is deleted when you save.

• Delete a line

To delete confirmations from the overview that you do not want to process at the moment, choose . The confirmation is, however, retained for reprocessing at a later stage.
Reprocessing Confirmations

Use
Prior to release 4.6A, this procedure was used exclusively for reprocessing PDC error records.

Procedure
1. Choose Logistics → Production → Shop floor control → Confirmation → Reprocessing → Confirmations.
2. Enter the selection criteria for the confirmations that you want to process.
3. Choose .
4. To remove the errors, if possible, correct the confirmations accordingly.
5. To post the processed confirmation, choose .

All selected confirmations are processed when you save. If you want to process a confirmation at a later stage, choose to delete it from the list .
Cost Determination Error Processing

Use
You use this function to gather information about errors in cost determination and if necessary to repeat it.

If errors occurred when determining actual costs online, you can decide whether or not the confirmation and the error records are saved. If you are using Decoupling Confirmation Processes [Page 360], the errors are recorded during the execution of the background job or during updating.

Features
This function includes:

- An error log which displays the cost determination errors in detail

  Errors are, for example: missing activity prices, invalid cost centers or incorrect assignment of an activity type to a cost center.

- Rerunning cost determination
Starting a New Costing Run

1. Choose Logistics → Production → Shop floor control → Confirmation → Reprocessing → Actual costs.

2. Enter your selection criteria.

3. Choose 📈.

4. Select the confirmation in question and choose 📈.
   - Analyse the error.

5. If necessary remove the errors.
   - To remove the errors, you have to exit the reprocessing function.

6. As before, choose Logistics → Production → Shop floor control → Confirmation → Reprocessing → Actual costs.

7. Enter selection criteria for the confirmations for which you want to restart the actual cost calculation.

8. Choose 📈.

9. Select the confirmation and choose 📈.
Failed Goods Movements Processing

Use
This function allows you to process goods movements that failed when posting confirmations. After correcting any errors that occurred, you can then post the goods movements a second time.

Features
This function includes:

• Detailed display of errors
  
  Errors can be caused by insufficient information such as missing storage locations or missing batch numbers. Errors can also include locked material data, insufficient stock, or attempts to post goods movements in the wrong accounting period.

• Opportunity to correct failed goods movements

• Option of posting goods movements a second time
Reprocessing Goods Movements

1. Choose Logistics → Production → Shop floor control → Confirmation → Reprocessing → Goods movements.
2. Enter your selection criteria.
3. Choose .
4. Select the goods movement that you want to reprocess.
5. Choose to display the errors that have arisen in detail. To leave the message choose .
6. Select the required goods movements and make the necessary changes (for example, Edit → Replace → Storage location).
7. Choose to restart the execution of goods movements.

As you reprocess goods movements for the confirmation, you can branch to the goods movements overview (choose ) to change the goods movements. For more information, refer to Goods Movement Overview [Page 286].
Decoupling Processes Carried out During Confirmation

Use
When you carry out a confirmation, processes are triggered that could negatively affect the response time of the confirmation process. For example, goods movements and actual costs determination.

You alleviate this situation by decoupling these processes from the actual confirmation. Decoupling is set up in Customizing  (Settings for Decoupling Confirmation Processes [Page 362]).

Features
You can decouple the following confirmation processes:

- Automatic Goods Receipt
- Backflush
- Actual cost determination

You can define for each process when it should run:

- **Online** the processes are triggered immediately. The next dialog step can only occur when all processes have finished.
  
  If errors occur during actual costs determination or goods movement, you can remove the cause of the error or cancel the processing of the confirmation.

- If you are working in **update task** the next dialog step is possible immediately. The data for the processes is passed to the update task without delay and is processed immediately.

- If the processes are **background jobs**, they are not executed immediately. The next dialog step can take place straight away.

If you do not make any special setting, processing takes place as usual online.

Background Processing
Pay attention to the following points for background processing:

- **Future change records** are saved for the individual processes. These future change records contain all the necessary information for being processed in a background job at a later stage (see Processing Predefined Confirmation Processes [Page 364]). You cannot set deletion flags (status DFVL) for orders which still have future change records.

- In a background job you schedule the program CORUPROC with a variant. You use the variant to define which processes are to be executed in the job. You schedule the job in Customizing for Shop Floor Control (Operations → Schedule background jobs). You can see how to schedule processes in Example: Background Processing [Page 363]

- You can process future change records in parallel (see Settings for Decoupling Confirmation Processes [Page 362]). This is useful if a large number of future change records have to be processed in a limited time.
Decoupling Processes Carried out During Confirmation

- Due time differences from decoupling, data inconsistencies can arise, which disappear when processing of all future change is finished. This is the case for instance, if the confirmed quantity of a material has not yet been posted to stock by the automatic goods movement.
Settings for Decoupling Confirmation Processes

You can make the following settings for decoupling:

- **Execution Time**
  
  You summarize the following settings in a key term for process control:
  
  - Which processes should be decoupled (automatic goods receipt, backflushing, actual costs determination)?
  
  - When should the processes run (online, update task, background task)?

  To define the control key for process control choose **Operations → Confirmation → Define Time for Confirmation Processing** in Customizing for **Shop Floor Control**.

- **Confirmation Parameters**

  You assign an order type and plant to a key term for process control. This activates decoupling for the order type.

  To maintain the confirmation parameters in Customizing for **Shop Floor Control**, choose **Operations → Confirmation → Define Confirmation Parameters**.

- **Parallel Processing**

  If you are working with background jobs, you enter the confirmation processes that should be processed in parallel here.

  The confirmation processes for goods movement and actual cost determination differ. For each of these groups you can determine the following parameters:

  - number of parallel tasks
  
  - which server
  
  - maximum number of items per material document (for goods movements)

  To define the settings for parallel processing, choose **Operations → Confirmation → Define Paralleling Type for Confirmation Processes** in Customizing for **Shop Floor Control**.
Example: Background Processing

If confirmation processes are to be processed in the background, you have to decide when the individual processes are to take place. As a general guide:

- **Automatic goods receipts** should be processed soon after the actual confirmation. This applies to materials that are processed further or that are needed in Sales, for which it is particularly important that stock levels are kept up-to-date. Processing should be **online** or executed as an **update** task.

- **Backflushing withdrawals** can be processed in **longer periods** (for example twice a day). Since the material has already been withdrawn physically from the storage location, stock levels are not as important. However, other consumers of the material and material requirements planning should be notified.

- Actual costs determination can take place less frequently (for example once a day). Actual costs determination is not important for smooth production processing. It is needed for controlling and should be adapted to the demands of this department.
Processing Predefined Confirmation Processes

Use
You use this function to process future change records for confirmation processes (see Decoupling Processes Carried out During Confirmation [Page 360]). You only need to process future change records in exceptional cases (for example, bringing processing forward, if the background job is scheduled for a later point in time). Future change records are normally processed as background jobs (see Goods Movements in Confirmations [Page 344]). There are separate functions for processing goods movements with errors [Page 358] and errors in cost determination [Page 358].

Features
You decide which future change records should be read on the selection screen. By doing this, you can limit the selection of orders or processes.

You can use this function to process future change records from confirmations for the following processes:
- Backflush
- Automatic Goods Receipt
- Actual cost determination
- Data transfer to HR

You can execute the following actions:
- Displaying an order for a future change record
  (Select the required record and choose Order).
- Displaying a confirmation for a future change record
  (Select the required record and choose Confirmation).
- Executing backflushing/automatic goods receipt/actual costs determination
  (Select the required record and choose .)
- Executing data transfer to HR
  (Select Data transfer to HR You can only execute this action simultaneously for all records.)

You cannot cancel confirmations that still have future change records.

Activities
Choose Logistics → Production → Shop floor control → Confirmation → Predefined processes.
Processing Predefined Confirmation Processes
PDC Data Transfer via Communication Channel 2 (CC2)

Use
It is possible to enter completion confirmations for a production order in a subsystem and to import them into R/3 via a PDC data transfer. This means that you can enter a confirmation close to production in a non-SAP system and process it in R/3.

Prerequisites
To execute the PDC data transfer, the following requirements must be met:

- Communication channel 2 (CC2) must have been set up technically (Setting up the PDC Interface [Ext.]).
- You specify the communication parameters for CC2 in Customizing.
  - Which data should be downloaded (work centers, variations, units of measure, material dependent units of measure).
  - Whether the update of confirmations that are received is to be triggered immediately.
  - Which user is informed by the system with an express mail, if an error occurs.

The communication parameters are maintained in Customizing by choosing Cross Application Components → Plant Data Collection → Production Orders (PP, Communication Channel 2) → Define communication parameters.

- In order to download operations, these operations must be suitable for PDC [Page 367].

Features
With the download function you can send data to a subsystem, so that input checks can be made in this subsystem. This function is not absolutely necessary for using PDC data transfer.

With the upload function you transfer the confirmations from the subsystem to the R/3 system. You can set up the system so that either the confirmations are updated automatically after they have been transferred (communication parameters) or a program is scheduled to do the update as a background job.

In general, the communication parameters are set up so that the update of the confirmations is triggered automatically.

In error processing, you can reprocess [Page 353] confirmations for which errors occurred during updating.

You will generally schedule the relevant programs as background jobs. However, you can call up the PDC data transfer functions manually.

See also:
PP - PDC Interface [Ext.]
Download

Use
You need to download data to the subsystem to carry out checks in the subsystem. Downloading is not necessary for PDC data transfer. The following checks can be carried out at the subsystem level:

- Existence checks for operations
- Quantity checks

Prerequisites
Operations that are to be transferred to the subsystem must be suitable for PDC. This means that,

- The PDC active indicator has to be set in the order-dependent parameters (for each order type, plant).
- The work center of the operation has to be assigned to a subsystem via Subsystem grouping (tab page Basic data, pushbutton: Subsystem). You carry out this assignment in work center maintenance.

Features
In the initial download, the operations from the production orders that meet the corresponding conditions, are downloaded from R/3 to the subsystem.

In the master data download the master data is downloaded to the subsystem, so that extensive checks can be carried out there. You can download the following data:

- Work centers
- Variations
- Units of measure
- Material-dependent units of measure

In the delta download all the operations that have been created since the last initial download are transferred to the subsystem.

Scheduling Background Jobs
You have to schedule the following programs for a download:

<table>
<thead>
<tr>
<th>Task</th>
<th>Program</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial download</td>
<td>SAPPCC21</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Download → Initial download.</td>
</tr>
<tr>
<td>Master data download</td>
<td>SAPPCC22</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Download → Master data download.</td>
</tr>
</tbody>
</table>
You schedule the jobs in Customizing by choosing Cross-Application Components -> Plant Data Collection -> Production orders (PP, communication channel 2) -> Schedule background jobs for PDC.

<table>
<thead>
<tr>
<th>Delta download</th>
<th>SAPPPC23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Download → Delta download.</td>
<td></td>
</tr>
</tbody>
</table>
Upload

Use
You use an upload to transfer confirmation data from the subsystem to R/3. The upload is triggered by the R/3 system.

Features
R/3 sends an upload request to the subsystem, asking it to transfer confirmation records to R/3.
You can set up the system so that either the confirmations are updated automatically after they have been transferred (communication parameters) or the program SAPVBKK2 is scheduled to do the update as a background job.

Scheduling Background Jobs
You have to schedule the following programs for an upload:

<table>
<thead>
<tr>
<th>Task</th>
<th>Program</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload request</td>
<td>SAPPCC4</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Upload → Request PDC upload.</td>
</tr>
<tr>
<td>CC2 update</td>
<td>SAPVBKK2</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Upload → Update PDC records.</td>
</tr>
</tbody>
</table>

You schedule the jobs in Customizing by choosing Cross-Application Components → Plant Data Collection → Production orders (PP, communication channel 2) → Schedule background jobs for PDC.
Application Logic of the PDC Data Transfer in CC2

The confirmation data that is transferred to the R/3 system from the subsystem has to fulfill certain conditions from the application point of view. The confirmation must

• Take into account the current status of the operation (for example, you cannot confirm an operation that has not been released).
• Pay attention to the conversion of order unit of measure to operation unit of measure.
• Take into account how to react to overdelivery and underdelivery.
• Handle operation splits correctly.
• Take into account the sequence of time events in an operation.
• Take into account the sequence of confirmations referring to time tickets.

For a more detailed description of the application logic, refer to the PDC Interface component in Confirmations to PP (CC2) [Ext.].
PP-PDC Interface

Use
The PP-PDC interface is available as of release 4.6A. PP-PDC is an interface for R/3 Shop Floor Control. It is standardized for connecting subsystems used for entering time tickets and time events.

The interface used previously (as of release 3.0A) was called Communication Channel 2 (CC2). In comparison to the previous interface, the new interface includes an enhanced range of business functions. In addition, it has been implemented as an asynchronous SAP R/3 BAPI interface that functions without the transceiver.

Subsystems can take part in the SAP Complementary Software Program (CSP) for this interface. For detailed information about this interface, refer to the certification documentation: R/3 Shop Floor Control: Plant Data Collection (PDC) PP-PDC.

Prerequisites
To execute the PDC data transfer, the following requirements must be met:

- In Customizing, you define in the communication parameters
  - Which data should be downloaded (work centers PP-PDC, variances, units of measure, material dependent units of measure). This setting is valid for scheduling in a background job. When transferring in the dialog, you can select the data in the selection screen.
  - Whether the update of confirmations that are received is to be triggered immediately.
  - Which user is informed by the system with an express mail, if an error occurs.
    You maintain the communication parameters in Customizing for Shop Floor Control by choosing Operations → Confirmation → PDC Data Transfer → Define Communication Parameters.

- Operations that are to be transferred to the subsystem must be suitable for PDC. This means that,
  - The PDC active indicator has to be set in the order-dependent parameters (for each order type, plant).
  - The work center of the operation has to be assigned to a subsystem via Subsystem grouping (tab page Basic data, pushbutton: Subsystem). You carry out this assignment in work center maintenance.

Features
Download
With the download function you can send data to a subsystem, so that input checks can be made in this subsystem. You need to download data to the subsystem to carry out checks in the subsystem. The following checks can be carried out at the subsystem level:

- Existence checks for operations
PP-PDC Interface

- Quantity checks

When the operations are downloaded, the operation data is transmitted to the subsystem. A distinction is made between the following types of transmission:

- In the initial download, the operations from the production orders that meet the above-mentioned requirements are downloaded from R/3 to the subsystem.

- In the delta download all the operations that have been created since the last initial download are transferred to the subsystem.

In the master data download the master data is downloaded to the subsystem, so that extensive checks can be carried out there. You can transmit the following data:

- Work centers
- Variations
- Units of measure
- Material-dependent units of measure

<table>
<thead>
<tr>
<th>Task</th>
<th>Program</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Download operations</td>
<td>CIBDOP_DOWN_PP</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Download → Download operations PP-PDC-4.6.</td>
</tr>
<tr>
<td>Master data download</td>
<td>SAPPPC22</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Download → Master data download.</td>
</tr>
</tbody>
</table>

Upload

R/3 sends an upload request to the subsystem, asking it to transfer confirmation records to R/3.

With the upload function you transfer the confirmations from the subsystem to the R/3 system. You can set up the system so that either the confirmations are updated automatically after they have been transferred (see prerequisites) or the program CORUPROC1 is scheduled to do the update as a background job.

<table>
<thead>
<tr>
<th>Task</th>
<th>Program</th>
<th>Menu path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Upload request</td>
<td>CIBDCONF_REQUEST</td>
<td>Logistics → Production → Shop floor control → Confirmation → Subsystem → Upload → Request PP PDC 4.6 upload.</td>
</tr>
<tr>
<td>Update</td>
<td>CORUPROC1</td>
<td></td>
</tr>
</tbody>
</table>

Scheduling in the Background

The scheduling of the above-mentioned programs is prepared in Customizing for Shop Floor Control: Operations → Confirmation → PDC Data Transfer → Schedule Background Jobs for PP-PDC.
Error Processing

In error processing, you can reprocess [Page 353] confirmations for which errors occurred during updating.
Rework

Use

It is sometimes necessary during or at the end of a production process to execute additional operations in order to improve components or products with insufficient quality. These additional processing steps are referred to as rework.

You have a production order for 20 shafts. After a turning operation you carry out an inspection operation to check the tolerances. % shafts are found to be outside the tolerances. By reworking you can enter these 5 pieces as yield. You therefore insert a rework operation where the 5 pieces are turned a second time.

Features

You can incorporate rework into the production process in the following ways:

- You can insert additional operations into the production order where rework is required
- You can insert a reference operation set
- You can create a separate production order without a material and assign it to the original production order

Planned Rework

If rework frequently occurs at particular points in the production process, you can assign trigger points to operations, which then automatically trigger the following functions when a status changes (for example, when a confirmation is entered):

- Insertion of reference operation set via trigger point
- Creation of rework order via trigger point

For more information about handling and maintaining trigger points, refer to the SAP Library Trigger Points [Page 182].
Rework Operations and Rework Quantities

Use

Rework Operations

An operation is marked as a rework operation by its control key.

It is not possible to carry out an automatic goods receipt for operations that are marked as rework operations.

If an operation is marked as a rework operation, this has an effect on the operation quantity.

Rework Quantity

The following applies to the rework quantity:

• If, when carrying out a confirmation, a rework order is created (see Trigger Points [Page 182]), the confirmed rework quantity is taken over as the rework-order quantity.

• If, when carrying out a confirmation, a reference operation set is inserted (via Trigger Points [Page 182]), the confirmed rework quantity is taken over as the operation quantity of the inserted operations.

• In the case of rework operations, you can maintain the operation quantity in the production order.

• The operation quantity of a rework operation is not taken into account when scheduling calculates scrap-adjusted quantities for the operations in an order.

• Any change in the order quantity has no effect on the quantity of the rework operation.
Rework and Confirmation

Use
The following applies to the confirmation of rework quantities or rework operations:

- You can confirm rework at operation or at order header level. If you confirm at order header level, it is assumed that the rework was incurred in the last operation.

- During confirmation, you can enter a rework quantity directly. The rework quantity is the amount that, after the original operation, requires additional processing before it can be counted as yield. In the case of the rework quantity, it is assumed that this can be counted as yield again by being reworked.

  When the system determines the Expected yield variance, it counts the confirmed rework quantity as yield.

- When you confirm a rework operation (that is, an operation in which rework was carried out), the operation quantity is proposed as the quantity to be confirmed. This means that the confirmed yield of the last operation with final confirmation has no influence on rework operations.

Rework and Backflushing
When components that are assigned to an operation are backflushed, the system takes into account the yield, the scrap quantity and the rework quantity.

Rework and Automatic Goods Receipt
You can only carry out an automatic goods receipt for the original operation (that is, the operation in which rework was reported) and not for the actual rework operation. If you post an automatic goods receipt for the original operation, the system only posts the confirmed yield to stock. Any reworked goods must be posted to stock manually using Inventory Management functions.
Order Settlement

Use

When a production order is settled, the actual costs incurred for the order are settled to one or more receiver cost-objects (for example, to the account for the material produced or to a sales order). Offsetting entries are generated automatically to credit the production order:

- If the costs for the production order are settled to a material account, the order is credited each time material is delivered to stock. The material stock account is debited accordingly.
- If the costs for the production order are settled to another receiver (for example to a sales order), the order is credited automatically at the time of settlement. The cost-objects are debited accordingly.

The debit posting remains in the order and can be displayed even after the costs have been settled. The settled costs are updated in the corresponding receiver cost-object and can be displayed in reporting.
Requirements for Settlement

Before you can settle a production order, you must maintain valid settlement parameters for the order. The settlement parameters include a settlement profile and a settlement structure:

Settlement Profile [Page 379]
Settlement Structure [Page 380]
Settlement Rule [Page 381]
Settlement Profile

A settlement profile is specified in Customizing for each order type. The settlement profile specifies:

- To which settlement receivers the order can be settled,
- The maximum number of distribution rules
- Whether the settlement share is to be calculated as a percentage rate or as equivalence numbers (see Settlement Rule [Page 381])
- A default for the settlement structure
Settlement Structure

The settlement structure determines how the debit cost elements are assigned to settlement cost elements. Each debit cost element may only be assigned to one settlement cost element.
Settlement Rule

The system automatically assigns a settlement rule to the production order when the order is created. The assignment is carried out via the default rule defined in Customizing.

The settlement rule includes one or more distribution rules for the production order. The distribution rule consists of a cost receiver, a settlement share and a settlement type:

- The settlement receiver determines to which object the actual costs of the production order are to be settled. Possible receivers include:
  - a material
  - a cost center
  - an internal order
  - a sales order
  - a project
  - a network
  - a fixed asset

- The settlement share determines the percentage rate or the equivalence number to distribute the costs to the individual cost receivers.

- The settlement type determines whether all the costs are settled which were incurred for the order (full settlement) or whether the costs collected on the order are to be settled periodically (periodic settlement).

The settlement receiver Material allows periodic settlement only for orders.
Settlement: Standard Settings

In the standard system, the system requires that the production order is assigned to the material to be produced. The settlement receiver in this case is the material's stock account. The settlement share is 100%. The settlement type is "full settlement".

You can change a distribution rule that was automatically generated when the order was created, but you cannot delete it. To invalidate an automatically generated distribution rule, set the percentage rate of the settlement share to 0. All manually created distribution rules can, however, be changed or deleted at any time before settlement.
Calling Up a Settlement Rule

1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Specify the number of the order that you want to change.
3. Choose 📖.
   You branch to the initial screen for the production order.
4. Select the menu options Header → Settlement rule.
   The system displays the settlement rule and its distribution rules.
Changing a Settlement Rule

Call up the settlement rule of the order (see Calling Up a Settlement Rule [Page 383]).

1. Call up the distribution rule using a double click.
   
   The system branches to the detail screen of the distribution rule. You can make the changes required here.
Deleting a Distribution Rule

Use
This function is only possible for manually created distribution rules.

Procedure
Call up the settlement rule of the order (see Calling Up a Settlement Rule [Page 383]).
1. Position the cursor on the required line and choose Edit → Delete rule.
Creating Distribution Rules

Use
The settlement profile specifies the maximum number of distribution rules per order.

Procedure
Call up the settlement rule of the order (see Calling Up a Settlement Rule [Page 383]).
1. Select the required cost receiver via the menu option Receivers. The system branches to the corresponding detail screen.
2. Maintain the new distribution rule.
Percent Validation

If you wish to check the total percentage rate of all the distribution rules contained in the settlement rule, choose *Settlement rule → Check*. The system issues a warning if the total percentage rate of the settlement rule is more than 100%.
Delivery to Stock

Use
If a production order is settled to a material account, the system expects one or more deliveries to stock.

Each delivery to stock credits the order and debits the stock account of the material.

Crediting the Order
In Customizing for Shop Floor Control you define how the production order is to be credited when a goods receipt is posted. A valuation variant is defined for each valuation area. This specifies which price is to be transferred from the material master record when the order is credited.

Debiting the Stock Account
The price control indicator in the material master specifies how stocks of a material are to be valued:

- If the Price control indicator in the material master of the material produced is S, the quantity delivered is multiplied by the standard price. Any difference between this debit posting and the credit posting to the order is posted to a price difference account.
- If the Price control indicator in the material master of the material produced is V, the quantity delivered is valued with the price according to the valuation variant. The stock account for the material produced is debited with these costs and the moving average price changes accordingly.  

If the production order is settled to a material account, you can only settle the order after the final delivery has taken place for the order.
Settling an Order

1. Choose Logistics → Production → Shop floor control → Period-end closing → Settlement → Individual processing.

2. Enter the number of the production order that you wish to settle.

3. Enter at least the following data:
   - settlement period
   - fiscal year

   You can also enter the following data:
   - processing type
   - posting period
   - asset value date

4. At this point, you can decide whether to carry out the settlement as a simulation or as an update:
   - If you do not set the indicator Test run, the results of settlement are updated.
   - If you do set the indicator, settlement is simulated. By simulating settlement, you can check, for example, the completeness and correctness of the objects to be settled.

5. Choose .

   You can settle a production order any number of times.
Result of Settlement

Where a production order is settled to a material account, the amount settled is the difference between the actual costs incurred for the order and the costs credited to the order when the goods produced were delivered to stock (see section Delivery to Stock).

The order is credited with the settled costs. Following the credit posting, the order has a balance of zero. The offsetting entry for this credit is made as follows:

- If the Price control indicator in the material master record is S, a price difference account is debited.
- If the Price control indicator in the material master record is V, the total stock value and the moving average price change accordingly.
Connections Between Delivery and Settlement

The following tables show the effects that the delivery of the production order to the warehouse and the settlement of the actual costs for the production order to stock have on the material master record of the material produced.

The production orders are identical in both tables, apart from the price control indicator.

The actual costs of the production order amount to US$ 105.00:

- The order was credited with US$ 100.00 when the material produced was delivered to stock.
- The order was credited with the remaining US$ 5.00 of the order costs when the order was settled.

Material Master Record with Price Control Indicator “S”

<table>
<thead>
<tr>
<th>Fields in material master record</th>
<th>Before production</th>
<th>After delivery</th>
<th>After settlement</th>
</tr>
</thead>
<tbody>
<tr>
<td>GLD price</td>
<td>10.00 US$</td>
<td>10.00 US$</td>
<td>10.25 US$</td>
</tr>
<tr>
<td>Standard price</td>
<td>10.00 US$</td>
<td>10.00 US$</td>
<td>10.00 US$</td>
</tr>
<tr>
<td>Total stock</td>
<td>10</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>Total value</td>
<td>100.00</td>
<td>200.00</td>
<td>200.00</td>
</tr>
</tbody>
</table>

Material Master Record with Price Control Indicator “V”

<table>
<thead>
<tr>
<th>Fields in material master record</th>
<th>Before production</th>
<th>After delivery</th>
<th>After settlement</th>
</tr>
</thead>
<tbody>
<tr>
<td>GLD price</td>
<td>10.00 US$</td>
<td>10.00 US$</td>
<td>10.25 US$</td>
</tr>
<tr>
<td>Standard price</td>
<td>0.00 US$</td>
<td>0.00 US$</td>
<td>0.00 US$</td>
</tr>
<tr>
<td>Total stock</td>
<td>10</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>Total value</td>
<td>100.00</td>
<td>200.00</td>
<td>205.00</td>
</tr>
</tbody>
</table>
Settlement in the Case of Stock Shortage

Use

If at the time of settlement the warehouse stock of the material is less than the order quantity, because goods have since been issued from stock, this has the following effect on settlement:

- The costs referring to the order quantity still in stock are settled as usual to the stock account for the material in question
- The remaining costs are automatically posted to a price difference account

Example: Settlement in the Case of Stock Shortage [Page 393]
Example: Settlement in the Case of Stock Shortage

The costs to be settled are based on an order quantity of 40 pieces. The price control indicator in the material master record of the material produced is "V" (moving average price).

Between the time when the order was delivered to stock and the time of settlement, 20 pieces were issued from stock. If the costs for the total order quantity were posted to the stock account of the material produced, this would lead to an unrealistic increase in the moving average price of the material. To avoid this, the system makes the following postings: For the 20 pieces in stock, 50% of the costs to be settled are posted to the stock account for the material and for the 20 pieces that were issued from stock, 50% are posted to a price difference account.
Settling Scrap

Use

In the standard system, all actual costs incurred in an order are settled 100% to the material produced. Any scrap produced in the production process causes the average price to increase in the standard system, due to the difference between the order quantity and the actual yield. To avoid the price of the material increasing when scrap occurs, you must manually adjust the percentage of the existing distribution rule to the actual yield produced and then create a new distribution rule for the actual scrap percentage. You could then, for example, enter a cost center as the settlement receiver for the new distribution rule.

Example: Settling Scrap [Page 395]
Example: Settling Scrap

The order quantity to be manufactured is 10 pieces. The actual yield is 8 pieces, the scrap quantity is 2 pieces.

You change the distribution rule in the settlement rule so that only 80% of the costs are settled to the stock account of the material. Then you create a second distribution rule that specifies that the remaining 20% of the costs are to be settled to a cost center.

The actual costs for the order are US$ 2,800. Due to the delivery of 8 pieces to stock, the order was credited with US$ 2,000.

80% of the total costs are US$ 2,240.

20% of the total costs are US$ 560.

The order has already been credited with US$ 2,000 due to the delivery to stock.

As a result, US$ 240 is settled to the stock account for the material and US$ 560 to the cost center.
Technical Completion of a Production Order

Use

Technical completion means ending a production order from a logistical viewpoint. This function is usually used, if the execution of an order has to be stopped prematurely or if the order could not be executed in the required manner and open requirements for the order (reservations, capacities) should be deleted.

Prerequisites

The Technically complete function must be allowed for the operation, that is, it cannot be disallowed due to a system or user status. To this end, the system checks the business transaction BTAB (technically complete; see business transaction [Page 460]).

Features

The following actions are executed if an order is set to Technically complete.

- The order is not relevant for MRP planning
- Reservations are deleted
- Capacity requirements are deleted
- Purchase requisitions for external operations or non-stock materials are deleted
- The order and its operations receive the system status Technically Completed (TECO)

If an order is technically complete, you cannot change it. The fields in the order are displayed but cannot be changed. You can however cancel technical completion, for instance if order data has to be changed.

After technical completion you can still make postings for the order. For instance, material withdrawal or a confirmation can be posted if they were previously forgotten.

Activities

You can execute this function in two ways:

- When you are changing an order, choose Functions → Restrict processing → Technically complete.
- Technically complete is a function that you can use in mass processing [Page 429].

You can reverse technical completion as follows:

- When you are changing an order, choose Functions → Restrict processing → Revoke technical completion.
Closing a Production Order

Use
The Closed (CLSD) status has been introduced in the production order. It has the following characteristics:

• No more costs can be posted to the order, that is, confirmations and goods movements are no longer permitted for the order.

• The order can no longer be changed. Exceptions to this are revoking the CLSD status and setting the deletion flag.

• All actions relating to the status technically completed [Page 396] (TECO) are executed.

• In a collective order, the CLSD status is also set for subordinate orders.

• If the system comes across an order in the collective order that cannot be closed, the orders that come between this order and the leading order are also not closed. Other subtrees are closed if they only contain orders that can be closed.

Prerequisites
Prerequisites for setting the CLSD status are:

• The order must have the status Released (REL) or Technically completed (TECO)

• The order balance must be 0

• There can be no open purchase requisitions, purchase orders or commitments

• There can be no future change records from confirmation processes

Activities
The Closed (CLSD) status is only set automatically for subordinate orders in a collective order. To set the status, you have the following options:

• In the production order, choose Functions → Restrict processing → Close

• Function in mass processing [Page 432]
Archiving Production Orders

**Purpose**
Archiving production orders is part of the general reorganization procedure for production orders.

**Prerequisites**
To archive production orders only one **archiving object** is required. The archiving object is called **PP_ORDER**.

**Process Flow**
The reorganization of orders is divided into three steps in the R/3 System:
1. Activation of a deletion flag in the order
2. Activation of a deletion indicator in the order
3. Execute an archiving session

Orders that have already been archived can be displayed again in the R/3 System using a fourth step, called the **retrieval function**.

An order can only be archived after a deletion flag has been activated for it, either manually, or automatically (in other words, via a background report). After an initial residence time has passed, the orders that have been flagged for deletion are assigned with deletion indicators in a background run. After a second residence time has passed the orders are archived and **simultaneously** deleted from the database.

**See also:**
Archiving Production Orders (PP-SFC) [Ext.]
Order Change Management (OCM)

Purpose
Engineering change management (ECH) allows you to change various master data in a coordinated manner when they have to be changed together within a change process. Future procurement elements can thus be created directly with a changed product structure. Order change management (change management for production orders), in short OCM, expands this function. It is possible to include existing procurement elements (production orders, planned orders, purchase orders) that are also affected by a change, in the change process. The change process begins when a sales order or master data is changed. You can also adapt production orders on which work has already been done to the changed product structure.

Implementation Considerations
OCM does not need to be used in all cases. You should therefore check whether the following options are sufficient for changing production orders in your particular case:

- Manual changes [Page 15] to the production order
- Read master data [Page 70]
- Use of assembly orders [Page 509]

Features
The change process in OCM is based on Initiating Objects [Page 404]. These initiating object records refer to changes in purchase orders or in master data, which, in turn, necessitate changes to production orders.

The initiating object determines which procurement elements are affected by a change and a Procurement Element Change Record [Page 410] is created for each one.

On the basis of the procurement element change records, a controlled change of production orders takes place. In detail, changes are determined [Page 414], checked [Page 417] and executed [Page 420]. The change process is completed when the production order has been changed.

Restrictions
You can carry out the full change process only for production orders. Fixed planned orders and purchase orders cannot be changed in the change process, but they can be identified as affected procurement elements when changes to sales orders occur.

The order change process does not support changes in
- Components for which a batch split has been executed
- Co-products
- Sequences

With master data changes, the order change process does not support changes in
- Materials for which discontinued parts have been defined
- Alternative Items
Order Change Management (OCM)

- Trigger points
- Headers of phantom assemblies
- Production resources/tools
- The network structure in collective orders
- The usage of alternative dates in change numbers

Multi-level make-to-order production without direct production is not supported for sales order changes. In this process, only the top order can be adjusted.
Change Process

Purpose
The change process cannot begin without an initiating object [Page 404] and this is created as follows:

- Master data change
  - release of a change number or a leading change master record
  - additions to a leading change master record
  - shift of the change number’s validity date
- Sales order change
  - changes to the configuration on using the variant configuration
  - changes to the assigned serial number
  - changes to the direct assignment of change numbers by using direct assignment, it is possible to assign change numbers specifically to a sales order item
  - changes to the parameter validity

⚠️ The change of the quantity or of the date in the sales order item is not taken into consideration.

- Creating initiating object records manually
  You can add or delete initiating object records manually (Creating Initiating Object Records [Page 407]).

Prerequisites
In order to use order change management for production orders, initiating object records have to be created. To do this, various settings are necessary (see Creating Initiating Objects [Page 404]).
1. **Searching for Procurement Elements [Page 409]**

   The initiating object record determines which procurement elements are affected by a change and a procurement element change record [Page 410] is created.

   This process step is possible for the procurement elements: Production order, planned order and purchase order. All other steps are only available for the production order.

2. **Creating a Simulation Order [Page 413]** (only for sales order changes)

   A complete simulation order (if necessary, in a collective order) is created based on the changed sales order data. This provides the basis for a comparison.

   The production order is locked to changes from other change processes as soon as process steps 2-5 have been executed.

3. **Determining Changes [Page 414]**

   This process step determines which changes are necessary to adapt the production order according to the changes in initial data. For sales order changes, the comparison is based on the simulation order and for master data changes, it is based on object information, which is entered with the change number.

   The changes that are determined are saved and can be displayed and analyzed in the Change Step Overview [Page 424]. The change steps that are to be executed have an indicator for the type of change (for example, for added components and for components that are removed).

   As soon as the process for determining changes begins, changes cannot be made to the production order because it is locked (status NOCH Changes forbidden). However, actual data can be entered, that is, confirmations or goods movements.

4. **Checking Changes [Page 417]**
The changes to be made in the production order are checked using rules that you define in a Change Profile [Page 405] in Customizing. For example, you can define that the deletion of a component

- Leads to a warning message being issued in an operation that is released
- Leads to a warning message being issued in an operation that is confirmed

As soon as the check begins, actual data also cannot be entered because the production order is locked (status CGFB Confirmation / goods movement forbidden).

5. Executing Changes [Page 420]

Changes are made to the production order in this step. The locks created in steps 2 - 4 are lifted by the system.

Collective orders can also participate in the change process. The change steps for all orders in the collective order are determined. However, changes to the structure of the collective order are not allowed in the case of master data changes.

Several procurement element change records can exist for a production order. The current process must be completed before changes can be executed in a new change process (steps 2 - 5). (Completing Processing [Page 410]).
Creation of Initiating Object Records

Use
Initiating object records are created automatically by the system when a sales order is changed or when a change number or a leading change master record is released. These initiating object records determine which production orders (procurement elements) have to be changed.

Prerequisites
Initiating object records can be written if the following prerequisites are met:

- Overall change profile in the material master
  The overall profile for order change management must be entered in the material master under Work scheduling in the field Overall profile. In the overall change profile, you assign Change Profiles [Page 405] to the possible changes (sales order change, master data change). A change profile controls the change process. You maintain the profile for order change management in Customizing for Shop Floor Control by choosing Operations → Order Change Management (OCM).

- Change of master data
  The leading change master record/change number, with which you executed the changes to the master data (for example, bill of material, order BOM, routing), has to be released with a release key that is intended for order change management (Release: Rel. OCM, Shift the date: Date OCM). You maintain the release key in Customizing by choosing General Logistics → Order Change Management → Release Key → Define Release Key. The object category to be changed (routing or BOM) must be active in the change number or change package (default from ECH change profile).

- Change in sales order data
  Change management must be activated in the requirements class in the sales order item’s requirements type (Field EC Management). You can maintain the requirements class in Customizing under Sales and Distribution → Basic Functions → Availability Check and Transfer of Requirements → Transfer of Requirements → Define Requirements Classes.

Features
Initiating object records are written automatically when you:

- Change the sales order
- Release the change number or the leading change master record with a corresponding release key

The initiating object record contains the sales order number or the change number (see Processing Initiating Object Records [Page 407]).
Change Profile

In change profiles, you make settings for controlling the change process. In an overall profile, you assign change profiles to changes that trigger the creation of an initiating object record (change in a sales order, change in master data). Then, overall change profiles are assigned to a material.

You define the change profiles and overall profiles in Customizing for Shop Floor Control by choosing Operations → Order Change Management (OCM).

The parameters of the change profile are subdivided as follows:

- **General**
  
  You can specify that:
  
  - changes are also transferred to the order automatically, if a warning has occurred during the check. In this case, the changed objects are marked in the order (see Execution with Marked Objects [Page 421]).
  
  - individual change steps are also executed if there are change steps that cannot be automatically executed because of a conflict. This setting is only effective for networks and assembly orders.
  
  - objects that are added manually are not deleted by automatic change steps.

- **Handling of conflict situations**
  
  You can specify whether certain actions in change management represent a conflict, depending on the processing state of the order or the objects involved, and if so, how serious a conflict. The objects, actions and conflicts concerned are:
  
  - **Objects**
    
    operations, suboperations, components, directly produced components, production resources/tools
  
  - **Actions**
    
    changing, deleting, creating, reassigning (only for components)
  
  - **Seriousness of conflict**
    
    no conflict, information, warning, error

  For each object and action there are various situations for which you can specify the seriousness of the conflict. The following are examples of possible settings:

  - changing a released operation: **Information**
  
  - deleting a released operation: **Warning**
  
  - deleting a partially-released operation: **Error**

  If you specify that a situation is **No conflict**, then the corresponding check is not carried out. Therefore, these settings are important from the point of view of performance.
Processing Initiating Object Records

Use

You use this function to process initiating object records. Initiating object records indicate that procurement elements have to be changed because changes have been made to a sales order or to master data. The main task of this function is to determine which procurement elements are affected by changes.

Features

The initiating object records are displayed in a tree structure along with the procurement elements affected by the changes.

This function offers you the following features:

- **Search for Procurement Elements Relating to Initiating Object Record** [Page 409]
  
  You use this function to search for procurement elements (production orders, planned orders, purchase orders) relating to initiating object records. If a procurement element is found to be affected by a change, a procurement element change record is created.

- **Procurement element change records** ([Changing Production Orders [Page 410]])
  
  To switch to the overview of the procurement element change records for an initiating object record, select the initiating object record and choose Procurement element.

- **Deleting initiating object records**
  
  You can delete initiating object records only if the corresponding procurement element change records are completed [Page 410] or if no procurement element change records have been assigned. All assigned procurement element records are also deleted.

  To carry out deletion, select the initiating object record and choose.

- **Delete procurement element record**
  
  You can only delete a procurement element record if this is complete [Page 410].

  To carry out deletion, select the procurement element record and choose.

- **Creating Initiating Object Records**
  
  You can create initiating object records for sales order changes or master data changes that are not involved in the change process because of settings (see [Creating Initiating Object Records [Page 404]]). To find procurement elements for an initiating object record that has been created manually, an Overall Profile [Page 405] must be assigned to the material produced in the material master.

  To create an initiating object record, choose.

- **Logs**
  
  The system provides you with logs that contain information about the processing steps carried out for the initiating object records. Choose Goto → Process log to look at a temporary log in which the processing steps for the current session are recorded.

  Choose Log to call up a log in which all processing steps that have been carried out for an initiating object record up to now are stored.
Delete all affected objects (reorganization)

When a change process has been completed (that is, all procurement element change records involved are complete [Page 410]) you can delete the initiating object record and the related procurement element change records. In this process, all objects created during the change process (determined change steps, simulation orders and so on) are deleted:

– you can manually delete initiating object records and the procurement element change records (see above). When you delete an initiating object record, all related procurement element change records are also deleted.

– you can schedule the CO_OCM_OBJECT_LISTH program to delete the initiating object records. The related procurement element change records are also deleted in this process.

Background Processing

You can use program CO_OCM_OBJECT_LISTH to execute all functions for processing the initiating object records. For example, you can search for the procurement elements relating to an initiating object record or delete initiating object records (see above).

Symbols

The symbols at the beginning of each initiating object record show their processing status.

- : No search for procurement elements has been carried out for the initiating object record

- : A search for procurement elements has already been carried out for the initiating object record

Activities

To process initiating objects, choose Logistics → Production → Shop floor control → Control → Order change management → Change process → Initiating objects.

See also:

SAP List Viewer (ALV) Grid Control [Ext.]

ALV Grid Control (BC-SRV-ALV) [Ext.]
Searching for Procurement Elements

1. Choose Logistics → Production → Shop floor control → Control → Order change management → Change process → Initiating object records.

2. Enter the selection criteria for the required initiating object records.

3. Choose 🔍.


4. Select the initiating object records whose procurement elements you want to find.

5. Choose 🔍.

6. Save the list of initiating object records.

   You can repeat the search as often as you like. It makes no difference whether
   - the search was already executed
   - procurement elements were already found

   Purchase orders and planned orders are selected as procurement elements only for sales order changes, and not for master data changes.

   In the case of date validity, production orders are found whose explosion date lies within the validity period (date field Valid from).
Changing Production Orders

Use
You execute changes to production orders using this function. Each production order to be changed has a procurement element change record. The procurement element change record shows which process steps have been executed up to now and how advanced the change process is for the production order.

Features
The following functions are available:

- Overview of the procurement element change records
  This overview displays all change records for procurement elements that are to be changed in the change process. To reach the overview, choose Logistics → Production → Shop floor control → Control → Order change management → Change process → Procurement elements. The selection parameter Processing not possible for enables you to select procurement element change records for which processing has not been possible for a certain time period.
  You can also reach the procurement element overview from the initiating object record overview.

- Creation of a Simulation Order [Page 413] (only for sales order changes)
- Determining Changes [Page 414]
- Checking Changes [Page 417]
- Executing Changes [Page 420]
- Completing Processing
  You can complete the processing at any point in time. At the latest, the change process will be automatically completed when the production order is changed. Completing the processing is the prerequisite for deleting the procurement element change records. To complete processing, choose Complete change process.
Undoing Processing

Only successive processing steps can be undone. After the changes have been made to the production order, you cannot undo any more processing steps. To undo processing, choose ❯.

Logs

The system provides you with logs that contain information about the processing steps that have been carried out for the procurement element change records. Choose Goto \( \rightarrow \) Process log to look at a temporary log in which the processing steps for the current session are recorded (for example, process step Check changes was executed). Choose \( \square \) Display to call up a log in which all processing steps that have been carried out for a procurement element change record up to now are stored.

Delete procurement element record

You can only delete a procurement element record if this is complete [Page 410].

To carry out deletion, select the procurement element record and choose ❯.

Deletion of the objects involved (see Processing Initiating Object Records [Page 407])

Background Processing

You can use program CO_OCM_ORDER_LIST to execute all the functions for the procurement element change records. This covers the functions in the process (Creating a Simulation Order [Page 413], Determining Changes [Page 414], Checking Changes [Page 417], Executing Changes [Page 420]).

While production orders are being processed, orders that are currently being processed by other users may have to be accessed. In this case, you are informed which orders are affected and who is processing them. To start processing again at a later stage, remain in the dialog box and choose ❯ Collect locks.

See also:

SAP List Viewer (ALV) Grid Control [Ext.]

ALV Grid Control (BC-SRV-ALV) [Ext.]
Executing Process Steps

Use
You use this procedure to execute individual process steps.

Procedure
1. Choose Logistics → Production → Shop floor control → Control → Order change management → Change process → Procurement elements
2. Enter the selection criteria for the required procurement element change records.
3. Choose の．
   The screen Overview of the Procurement Element Change Records [Page 410] appears.
4. Select the procurement element change records for which you want to execute the processing steps.
5. Choose の．
6. Select one or more of the following process steps:
   - create a simulation order
   - determine changes
   - check changes
   - change original order

   Only successive processing steps can be executed together. When the process step Change original order has been carried out, the change process is complete (see Completing Processing [Page 410]).
7. Choose の．
Creation of a Simulation Order

Use
During the change process, a simulation order that takes into account the changed sales order is created. To determine the change, the simulation order is compared with the operational production order.

The simulation order is created and saved automatically. The creation dialog for the simulation order appears only if manual entries have to be made (for example, manual routing selection).

The creation of a simulation order is only relevant for sales order changes. For master data changes, no simulation order is created during the change process.

Simulation orders that are created during the change process cannot be scheduled.

Activities
The execution of these process steps is described in Executing Process Steps [Page 412].

To display a simulation order, choose Simulation order in the Overview of the Procurement Element Change Records [Page 410].
Determination of the Changes

Use

This function defines which changes are to be made to a production order in order to take into account the change to a sales order or master data.

- Sales order changes
  
  To determine the changes, the system compares the Simulation Order [Page 413] with the production order that is to be changed.

- Master data changes
  
  The order objects that are to be changed are determined directly from the master data.

To display the changes for a production order, choose Changes in the Overview of the Procurement Element Change Records [Page 410]. The screen Change Step Overview [Page 424] appears. There you can see which changes are allowed.

For technical information about the determination of the changes refer to Executing a Comparison [Page 415].

Examples of changes that must be made to a production order:

- Deleting an operation
- Inserting a component
- Reassigning a component

Activities

The execution of these process steps is described in Executing Process Steps [Page 412].

See also:

Execution of the Comparison [Page 415] in customer enhancement COOCM002
Executing a Comparison

To determine changes in production orders when sales orders have been changed, primary and secondary fields are compared. No comparison is executed when master data is changed. In this case, the objects affected are found directly using the change number.

**Primary fields** are used to identify the object. This means that two objects of the same object category, from the orders that were compared to one another, are recognized as matching objects and assigned to one another, if the values of their primary fields match (for example, MATNR for the material number of an order component).

**Secondary fields** are used in the second comparison step to check the equality of objects that were assigned using the primary fields. If the values of all secondary fields match, the objects assigned to one another are assessed as being identical in the comparison result.

If the values of all secondary fields do not match, the objects assigned to one another are assessed as being non-identical in the comparison result.

The possible comparison fields per object category are fields designed specially for the comparison of created structures in the Data Dictionary. These structures are called:

- **COMPHEAD** for the order header
- **COMPSEQ** for the order sequence
- **COMPOPER** for the order operation and the sub-operation
- **COMPCOMP** for the order component
- **COMPTOOL** for the production resources/tools

These structures can be extended by using additional fields. To do this, the following append structures were created in the Data Dictionary, which you can activate using the enhancement COOCM002:

- **CI_COMPHEAD** for the order header
- **CI_COMPSEQ** for the order sequence
- **CI_COMPOPER** for the order operation and the suboperation
- **CI_COMPCOMP** for the order component
- **CI_COMPTOOL** for the production resources/tools

The possible enhancement fields are fields from the following structures:

- **CAUFVDB** for the order header
- **AFFLB** for the order sequence
- **AFVGB** for the order operation and the suboperation
- **RESBB** for the order component
- **AFFHB** for the production resources/tools

When including a comparison field you have to ensure that the first field contains the name of the field without the structure name. One of the OBJ constants has to be assigned to the second field.
Executing a Comparison

In the include COMPFIELDDEF you can see the standard default for the primary and secondary fields.

**Customer Enhancement COOCM001**

For the process of checking change steps, you can use this customer enhancement to define situations not covered by the standard as conflicts. To do this, use the function module EXIT_SAPLCOOCMB_001.

**Customer Enhancement COOCM002**

You can use this customer enhancement to define a customer-specific execution of the comparison. You can use the function module EXIT_SAPLCOOCM_001 to define comparison fields for the production order comparison per object category.

You can use the include COMPFIELDDEF as an example when you create your own entries for the primary and secondary fields.

⚠️

To use this customer enhancement, you need very detailed knowledge of the data structure of the production order.
Checking Changes

Use
To control the execution of the change steps, you can enter a customer-specific checking control in the Change Profile [Page 405]. By doing so, you define how conflicts are to be handled in order change management. Conflicts arise because changes are to be made to a production order for which production has already commenced (for example, deletion of a partially confirmed operation).

Features
The checking control entered in the change profile ensures that you are informed via messages of conflict situations. The message type determines the options for continuing processing. In the case of warning messages and error messages, however, you must make a decision in the Change Step Overview [Page 424] (see Processing Change Steps [Page 419]):

- Handling an information message or no conflict
  If, according to the settings in the change profile, no conflict is present or an information message is issued, then the change steps are executed automatically. You do not need to process these change steps.

- Handling a warning
  In the case of a warning, you must decide whether or not the relevant change step is to be executed. Until you have done this, the change in the production order is not carried out.

  If the indicator When warning appears, execute and mark changes is set in the change profile, change steps to which a warning has been assigned are executed automatically (see Execution with Marked Objects [Page 421]). However, you can set these change steps manually to Do not execute. The objects are marked accordingly in the production order (inserted, changed, to be deleted). The markers are removed only when the change actions have been confirmed or rejected [Page 423].

- Handling an error message
  In the case of an error, you must set the corresponding change step to Do not execute. Until you have done this, the change in the production order is not carried out.

  For change steps that have lead to an error and are marked as a change (Change object), you can define in the Change Profile [Page 405] that the change step is automatically set to Do not execute.

Handling Conflict Types

<table>
<thead>
<tr>
<th>Conflict type</th>
<th>Change of production order</th>
<th>Manual intervention</th>
</tr>
</thead>
<tbody>
<tr>
<td>No conflict</td>
<td>Yes</td>
<td>No action necessary</td>
</tr>
<tr>
<td>Information</td>
<td>Yes</td>
<td>No action necessary</td>
</tr>
<tr>
<td>Warning</td>
<td>Yes/no</td>
<td>Manual decision in the Change Step Overview [Page 424]</td>
</tr>
</tbody>
</table>
Checking Changes

| Error | No                                           | Manual confirmation in the Change Step Overview [Page 424] |

Examples
This is demonstrated in the following examples. You can decide that the deletion of a component

- In an operation that is not released leads to an information message being issued. The change is executed without any further processing.
- In an operation that is released leads to a warning being issued. You decide manually whether the change is to be executed (see Executing Change Steps [Page 419]).
- For which goods issue has already been carried out leads to an error message. The changes are not executed. You must process this error message manually (see Processing Change Steps [Page 419]). Afterwards, the other change steps can be executed.

Activities
The execution of these process steps is described in Executing Process Steps [Page 412].

See also:
Executing a Comparison [Page 415] in customer enhancement COOCM001
Processing Change Steps

1. Choose Logistics → Production → Shop floor control → Control → Order change management → Change process → Procurement elements

2. Enter the selection criteria for the required procurement element change records.

3. Choose.

   The screen Overview of the Procurement Element Change Records [Page 410] appears.

4. Select the procurement element change records for which you want to process the change steps.

5. Choose Changes.


6. To select the change step that you want to process, position the cursor on the change step and choose.

   You can also select several change steps.

7. Choose one of the following functions:
   - Set "Do not execute"
   - Reset "Do not execute"
   - Set "execute"

   If you process the change steps for a collective order, the overview of the collective order appears first. Select the order there that you want to process. The processing then continues with step 6.

For more information, refer to Change Step Overview [Page 424].
Execution of the Changes

Use

Using this function, the determined changes are made to the production order. After executing the changes, the change process is complete and the changes cannot be undone (exception Execution with Marked Objects [Page 421]).

The changes are installed after a decision is made when Checking the Changes [Page 417].

- Changes that have not lead to a warning or error message are executed without any further decision having to be made.

- If a warning occurred, you must decide whether the change is to be executed (see Processing Change Steps [Page 419]). In the case of Execution with Marked Objects [Page 421], the system carries out changes that have lead to warnings without any more checks.

- Changes that lead to an error are definitely not executed. You must, however, set errors manually to "Do not execute" (see Processing Change Steps [Page 419]).

If discontinued materials, follow-up materials, alternative components or batch material exist in an order, you should start a new availability check after transferring the changes to the production order.

Automatic change of a production order triggers the business transaction RMCL Delete Automatically or RMCV Change Automatically.

These transactions (RMCL Delete Automatically or RMCV Change Automatically) are checked for each change step during the Check of Changes [Page 417] for the order header or the operation in addition to the conflicts from Customizing (with the issue of messages), but are not executed.

Activities

The execution of these process steps is described in Executing Process Steps [Page 412].
Execution with Marked Objects

Use

Execution with marked objects is a special procedure in Execution of the Changes [Page 420]:

- When execution with marked objects is used, change steps that have been assigned a warning are automatically executed. However, you can set these change steps manually to Do not execute.
- The objects are marked in the production order (Inserted, Changed, To be deleted).
- The changes are executed and the markers are removed, only when the change actions have been confirmed or rejected [Page 423].

You use execution with marked objects if the number of changes is so great that you cannot manually process the change steps with the “warning” conflict type.

In Customizing (Change Profile [Page 405]) you define that an object that is to be added to an order is marked with ☐, if it is expected to enter an order too late. That is, the relevant part of the production order is already processed and the processor has no knowledge of this object (for example, the subsequent operation is already partially confirmed, components have already been picked). Accordingly, an object that is to be deleted is marked with ☐ if it is expected that it has already been processed (operation) or withdrawn/incorporated (component).

Handling Conflict Types

<table>
<thead>
<tr>
<th>Conflict type</th>
<th>Change of production order</th>
<th>Manual intervention</th>
</tr>
</thead>
<tbody>
<tr>
<td>No conflict</td>
<td>Yes</td>
<td>No action necessary</td>
</tr>
<tr>
<td>Information</td>
<td>Yes</td>
<td>No action necessary</td>
</tr>
<tr>
<td>Warning</td>
<td>Yes</td>
<td>Acceptance or rejection of change step by manual decision in the production order [Page 423]</td>
</tr>
<tr>
<td></td>
<td>Execution of changes marked in the production order with appropriate symbols</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Set change step manually to Do not execute in the Change Step Overview [Page 424]</td>
<td></td>
</tr>
<tr>
<td>Error</td>
<td>No</td>
<td>Manual confirmation in the Change Step Overview [Page 424]</td>
</tr>
</tbody>
</table>

Prerequisites

Execution with marked objects is used when the indicator When warning appears, execute and mark changes is set in the Change Profile [Page 405] (Customizing for Shop Floor Control by choosing Operations → Order Change Management (OCM) → Define Change Profile).
Execution with Marked Objects

Activities

The procedure is the same as for execution without marked objects (see Executing Process Steps [Page 412]).
Confirming or Rejecting Change Actions

Use

If the indicator *When warning appears, mark and execute changes* is set in the **Change Profile** [Page 405], you can confirm or reject changes in the order that lead to a warning. Object markers are removed and objects that require deletion are deleted. Confirmation can be executed for the order header, operations and components.

This procedure is only relevant for execution of the change process with marked objects (see **Execution with Marked Objects** [Page 421]).

Procedure

1. Choose **Logistics** → **Production** → **Shop floor control** → **Order** → **Change**.
2. Enter the order number.
3. Choose 📋.
4. You have the following options:
   - You confirm the change action. The changes are executed. Depending on whether the changes relate to the order header, operations or components, proceed as follows:
     - **Order header**: Choose **Header** → **Change action** → **Confirm**.
     - **Operation overview**: Choose 📊. Select the components in question. Choose **Operation** → **Change action** → **Confirm**.
     - **Component overview**: Choose 📊. Select the components in question. Choose **Components** → **Change action** → **Confirm**.
   - You reject the change action. As a result of the rejection, the object markers are removed. Added objects are deleted. Objects marked for deletion remain. Depending on whether the changes relate to the order header, operations or components, proceed as follows:
     - **Order header**: Choose **Header** → **Change action** → **Reject**.
     - **Operation overview**: Choose 📊. Select the components in question. Choose **Operation** → **Change action** → **Reject**.
     - **Component overview**: Choose 📊. Select the components in question. Choose **Components** → **Change action** → **Reject**.

5. Save the production order.
Overview of the Change Steps

Use

The overview of the change steps (for example, change step = deleting a component) displays the changes determined for a production order in a hierarchical structure.

This overview can be called up from the production order (see Change Management in the Production Order [Page 425]) and from the Overview of Procurement Element Change Records [Page 410].

Features

For every change step you see:

- Which type of change it is (for example, adding, deleting, reassigning a component):
  - Add object
  - Delete object
  - Reassign object
  - Change object

- Which is the highest level conflict that occurred
  - Information
  - Warning
  - Error

- Which messages have lead to the conflict (to display the messages relating to a change, choose )

- Whether a decision has already been made about executing the change step (see Processing Change Steps [Page 419])
  - Executed
  - do not execute after manual decision
  - execute after manual decision

In addition, you can use a filter function to restrict the objects displayed.

If you display the change steps for a collective order, the overview of the collective order appears first. Select the order that you want to look at.
Change Management in the Production Order

Use

Change management in the production order provides you with the following information:

- Overview of the change processes that were executed
- Overview of the Change Steps [Page 424]
- Old and new characteristic value assignment in the case of changed configuration

Features

The change management screen appears when you choose Goto → Change management in the order header. In change management, the following functions are available in display mode:

- Select a line with a change comparison and choose Change steps. The screen Change Step Overview [Page 424] appears.
- For changes in a configurable material in the sales order, you can look at the old and new characteristic value assignment in the change comparison’s entry. For this, choose old or new in the corresponding column Display configuration.
Assembly Orders in Order Change Management

**Use**

You can use this function to adapt an assembly order to configuration changes in the sales order when actual costs have already been debited for this order (for example, by confirmations or material withdrawals).

The process that starts with the determination of the necessary changes and ends with the adaption of the assembly order is called *Change comparison*.

If you use this function, it is always used for configuration changes, also when an automatic new explosion of the master data would suffice.

**Integration**

This function integrates *Order Change Management [Page 399]* and *Assembly Processing with Production Orders [Ext.]*. This provides functions from order change management that have been modified for assembly processing.

**Prerequisites**

To use this function, the following prerequisites must be met:

- Overall change profile in the material master
  
  The overall profile for order change management must be entered in the material master under *Work scheduling* in the *Overall profile* field (see *Creating Initiating Object Records [Page 404]*).

- Material with assembly processing
  
  Assembly processing must be defined for the material (see *Special Settings for Production Orders [Ext.]*). That is, the material has planning strategy 82 (material master area *MRP*).

**Features**

The changes are executed in the following ways:

- Execute change comparison automatically
  
  If changes up to the conflict level "information" have occurred in the production order, the system executes the change comparison automatically.

- Complete change comparison manually
  
  If at least one change step has the conflict level "warning" or "error", the change comparison must be completed manually (production order status MADJ = manual adjustment necessary). The production order changes are executed in the *Overview of the Change Steps [Page 424]*.

  You set the changes that have lead to an error to *Do not execute*. You can decide whether or not changes that have lead to a warning are to be executed.
When you have processed all change steps, complete the change comparison (see Completing a Change Comparison [Page 428]).
Completing a Change Comparison

1. Go to the production order.
   The change comparison has the open status. That is, the system has determined the changes but has not yet processed them completely.

   In the case of static assembly order processing, you make the changes to the production order directly from the sales order.
   In the case of dynamic assembly order processing, you must call the production orders separately (see Changing Header Data [Page 33]).

2. In the order header, choose Go to → Change management (see Change Management [Page 425]).

3. To process the change steps, choose Change steps (see Overview of the Change Steps [Page 424]).
   You set change steps that have lead to an error to Do not execute. You can decide whether or not changes that have lead to a warning are to be executed.
   The change comparison receives the complete status. That is, all changes that require a manual decision or processing (warning, error) have been processed.

4. To complete the change comparison, choose Process → Complete change comparison.
   The change comparison receives the status complete.
Mass Processing of Production Orders

Use
Mass processing enables you to carry out functions for multiple orders.

Features

Functions
The following lists contain the mass processing functions that are available:

- Order headers
  - Material availability check
  - Release
  - Printing of shop floor papers
  - Costing
  - Scheduling
  - Generate capacity requirements
  - WM material staging
  - Picking
  - Set/delete user status
  - Confirmation
  - Technically complete
  - Close
  - Log display

- Operations
  - Release
  - Print shop floor papers
  - Picking
  - Set/delete user status
  - Confirmation
  - Log display

- Components
  - Print shop floor papers
  - Picking
  - Log display
Mass Processing of Production Orders

- Production resources and tools
  - Printing of shop floor papers
  - Log display

Starting Mass Processing

Mass processing can be started in the following ways:

- Triggering the execution of a function
  The execution of a function can be triggered as follows:
  - Execute function immediately
    The functions are executed directly after mass processing has been triggered. This can take a long time for functions that require a lot of system resources. However, you can immediately check whether the function was successfully executed.
  - Execute function with dialog transaction
    Further processing is controlled by a dialog that is specific to the function. This option is available for the following functions: Confirmation, Picking, Log display.
  - Create a function request (refer to Processing Requests [Page 453])
    First, requests are created without any further checks. The requests are created very quickly. Mass processing is actually executed with the program COWORKDISPATCH. As a result, it is delayed until the next time the program starts. You can decouple the function in terms of time, so that the main work takes place at night, for example. The end users create requests and system administration takes care of their execution.
  - Execute function in the background
    First, requests are created without any further checks. Then a background process is started, which processes these requests immediately. Scheduling a background job does not create any administrative work and reduces the workload for the dialog.

- Parallel Processing [Page 456]
  For parallel processing, you define server groups for mass processing (COWORK-DIALOG, COWORK-BATCH). This enables you to speed up the execution of processing.

- Mass processing online [Page 446] in the background [Page 448].
  You can either execute mass processing online or you can schedule it in a background job (no online steps are possible).

Application Toolbar with Mass Processing Functions

You can define that an application toolbar, with selected mass processing functions, is displayed in the list of the selected objects. You can use this application toolbar to execute the functions in the dialog.

For more information refer to Display Application Toolbar with Mass Processing Functions [Page 444].
Test Run
You can decide whether changes caused by a mass processing function are executed in the form of a test run only. Error messages that may occur are collected. No changes are updated to the database.

You can use the test run for these functions:
- Close
- Set/delete user status
- Release
- Costing
- Generate capacity requirements
- Technically complete
- Scheduling
- WM material staging

To test a function, select the option Test function without changes to data on the Mass processing tab page.

Log
Log records are written and saved as a function is being executed. They provide information about the execution of a mass processing function. If no log record exists, the function was executed without any problems. The log records are assigned to the order or the collective order.

For more information, see Logs [Page 445].
Mass Processing Functions

The following options are available for the individual functions:

<table>
<thead>
<tr>
<th>Material availability check</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Reset availability data</td>
</tr>
<tr>
<td>- Scope of the check (no check, individual check per material according to checking group, ATP check for all materials, check for all materials against planning)</td>
</tr>
<tr>
<td>- Firm planned orders</td>
</tr>
<tr>
<td>- Check log (no log, start log at information message, start log at warning message, start log at error message, start log at termination message)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Test</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
</tr>
</tbody>
</table>
When you release an order, you can decide whether just the order or the collective order to which it belongs is released.

When you release an operation, you have the following options:

- Release the order to which the operation belongs
- Release the collective order to which the operation belongs
- Release an individual operation (all preceding operations or orders for directly produced assemblies must have been released)
- Release an individual operation and all the preceding operations (all preceding operations or orders for directly produced assemblies are released automatically)

Release control order (order release, collective order release, release of first operation, release of first operation and dependent orders)

<table>
<thead>
<tr>
<th>Release Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
</tr>
<tr>
<td>Test</td>
</tr>
</tbody>
</table>

Execute function immediately, execute function in the background, create function requests

Yes
Mass Processing Functions

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
</table>
| Print mode: | - Reprint for status PRT (printed) and PPRT (partially printed)  
- Original print for PPRT and not printed |
| Spool parameters (order type, plant, MRP controller); the selection of the lists for the parameters is made from print customizing. If you select after entering spool parameters, the lists to be printed according to print customizing are displayed. |

| Time | Execute function immediately, execute function in the background, create function requests |
| Test | No |

**Costing**
### Mass Processing Functions

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Scheduling

You can **completely reschedule** production orders. During forward or backward scheduling you can enter new basic dates or move the basic dates a fixed amount. You can also have the dates determined by scheduling, get them from the sales order, if applicable, or set them to the overall commitment date. You can also change the scheduling type of the order.

In **collective orders**, all the orders are scheduled. The data entered refers to the leading order.

Rescheduling is subject to the normal restrictions on scheduling. For instance an order that has the status DLV (delivered) cannot be rescheduled.

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
</tbody>
</table>
### Mass Processing Functions

<table>
<thead>
<tr>
<th>Generate Capacity Requirements</th>
<th>In Customizing for the Availability Check, the generation of requirements can be switched off.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters</td>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
<tr>
<td>WM material staging</td>
<td></td>
</tr>
<tr>
<td>---------------------</td>
<td>--</td>
</tr>
<tr>
<td>Parameters</td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
</tbody>
</table>
### Mass Processing Functions

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Execute goods movements online</td>
</tr>
<tr>
<td></td>
<td>Execute goods movements in a batch program</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time</th>
<th>Execute function with dialog transaction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test</td>
<td>No</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Set/Delete Status Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header or operation</td>
<td></td>
</tr>
<tr>
<td>Status profile</td>
<td>(must be identical in the order and in the mass processing function)</td>
</tr>
<tr>
<td>Status</td>
<td></td>
</tr>
<tr>
<td>Active/not active</td>
<td></td>
</tr>
</tbody>
</table>
Mass Processing Functions

<table>
<thead>
<tr>
<th>Time</th>
<th>Execute function immediately, execute function in the background, create function requests</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Confirmation
### Mass Processing Functions

<table>
<thead>
<tr>
<th>Parameters</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>• Enter confirmations</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Enter order confirmation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you work with the option <em>Execute function with dialog transaction</em>, you branch to the individual entry of <em>order confirmations</em> [Page 326]. You then enter confirmations for the selected objects in succession. If you have chosen the options <em>Execute function immediately</em> or <em>Execute function in the background</em>, the confirmations are carried out with the expected values, provided this is set up in Customizing <em>(Customizing for Shop Floor Control, by choosing Operations ➔ Confirmations ➔ Confirmation Parameters Collective Entry/Fast Entry)</em>.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Enter time ticket</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you work with the option <em>Execute function with dialog transaction</em>, you branch to the collective entry [Page 321] of time tickets. You then enter confirmations for the selected objects in succession. If you have chosen the options <em>Execute function immediately</em> or <em>Execute function in the background</em>, the confirmations are carried out with the expected values, provided this is set up in Customizing <em>(Customizing for Shop Floor Control, by choosing Operations ➔ Confirmations ➔ Confirmation Parameters Collective Entry/Fast Entry)</em>.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Enter time event</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Time events can only be executed with the option <em>Execute function with dialog transaction</em> (see <em>Entering a Confirmation for a Time Event</em> [Page 324]). You enter confirmations in succession for the selected objects.</td>
<td></td>
</tr>
<tr>
<td>• Entry in error table</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you have chosen the options <em>Execute function immediately</em> or <em>Execute function in the background</em>, you cannot check for errors online. In this case, you can decide whether confirmations that are not processed are available in <em>Reprocessing Confirmations</em> [Page 353]:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• No insert in error table</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• No insert in error table for lock situations</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Insert all unprocessed confirmations in error table</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time</th>
<th>Execute function immediately, execute function in the background, execute function with dialog transaction</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Test</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Parameters</td>
<td>Time</td>
<td>Test</td>
</tr>
<tr>
<td>------------</td>
<td>------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td>Execute function immediately, execute function in the background, create function requests</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Close
### Mass Processing Functions

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Execute function immediately, execute function in the background, create function requests</td>
</tr>
<tr>
<td>Test</td>
<td>Yes</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Execute function with dialog transaction</td>
</tr>
<tr>
<td>Test</td>
<td>No</td>
</tr>
</tbody>
</table>

You can select all other mass processing functions, except for *Log display*. If you do not choose any functions, all logs are selected.
Displaying the Application Toolbar with Mass Proc. Functions

Use
You use the application toolbar to execute mass processing functions. That is, you use the pushbuttons, rather than the menu, to access the functions. In this way, for example, you can release several production orders and then print them without having to use the menu.

You use this procedure when you execute mass processing in the dialog or when you want to define a selection screen variant.

Procedure
1. Go to the Mass processing tab page in the mass processing transaction (COHV, COMAC; CO04N or CO05N).
2. Set the Display applicat. toolbar indicator.
3. Select the pushbutton(s) that are to appear on the application tool bar.
4. Define the parameters for the mass processing functions of the selected pushbuttons.

The pushbutton for a mass processing function for which no parameter has been defined appears on the application toolbar but cannot be selected. You can also define parameters after the objects to be processed have been selected (choose Mass processing → Execute in the menu).
Logs

Use
Log records are written and saved as a function is being executed. They provide information about the execution of a mass processing function. If no log record exists, the function was executed without any problems. The log records are assigned to the order or the collective order.

Features
In detail:
- You can display the log for the last execution of mass processing. To do this, select an object and choose Mass processing → Log of last MP.
- The Log display function in mass processing provides you with the logs for all other mass processing functions. To use this function, you select the object in question and start the log display (see Executing Mass Processing Online [Page 446]). The log for this object appears. If no mass processing functions were selected, all logs for the selected object are displayed.
- When a mass processing function is executed immediately, the most serious error level that arises for the objects being processed is displayed in the form of a symbol in the Message type field. By double-clicking the Message type field, you can branch to the log display.

If a mass processing function is not immediately executed, the logs cannot be automatically provided. In this case, you must explicitly select the logs for the object using the mass processing function Log display.

Log display
The log display consists of
- An upper section
  It contains a structure that represents the selected objects with the executed functions.
- A lower section
  The individual messages are shown here. The messages are read in by double-clicking an object.

Using profile settings, you can adapt the display and sort function to meet your requirements and save this as a user-specific profile.
Executing Mass Processing Online

1. Choose Logistics → Production → Shop Floor Control → Control → Mass Processing.

2. In the List field, select the object for which you want to execute mass processing: Order headers, operations, production resources/tools, components.

3. Choose a Profile [Page 493] or a Layout [Page 490]

4. If necessary, define the parameters for the mass processing functions that you want to execute.

   You can also execute this step after selection by using the menu (see step 7).

5. Enter your selection criteria.

   To make execution easier, you can define variants (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria and preset mass processing functions.

6. Choose .

   The list appears with the selected objects (this is the Individual Object List [Page 485] of the order information system).

7. Select the objects for which the function is to be executed. You have the following options for executing the function:

   − Direct start

      If the function and the parameters for mass processing are already predefined (defined in step 4 or in a variant), you can start mass processing by choosing .

      The function that is set up by choosing Mass processing → Execute is started.

   − Start using the application toolbar

      If you have defined on the Mass processing tab page that the Application Toolbar [Page 444] is to be displayed with the mass processing functions, you can also execute the function by choosing the corresponding pushbutton.

   − Start via the menu

      a. Choose Mass processing → Execute.

      b. Select the function that you want to execute. If necessary, enter parameters for executing the function (see Mass Processing Functions [Page 432]).

      c. Choose how to start the function: Execute function immediately, Execute function in the background, Create function request, Execute function with dialog transaction.

      d. Decide whether a test run is to be carried out.

      e. Choose .

   After mass processing has been executed, the display in the list is not automatically refreshed. To refresh the list, choose .
The production orders in a collective order are processed together in a LUW (Logical Unit of Work). This means that if processing is stopped for whatever reason, none of the functions is carried out for the collective order.

See also:

SAP List Viewer (ALV) Grid Control [Ext.]
ALV Grid Control (BC-SRV-ALV) [Ext.]
Scheduling Mass Processing in the Background

1. Choose Logistics → Production → Shop Floor Control → Control → Mass Processing.

2. In the List field, select the object for which you want to execute mass processing: Order headers, operations, production resources/tools, components.

3. Choose a Profile [Page 489] or a Layout [Page 490].

4. Enter your selection criteria.

5. Choose the Mass processing tab page.

6. Select the function that you want to execute. If necessary, enter parameters for executing the function (see Mass Processing Functions [Page 432]).

7. Select how the function is to be started. The option Execute function immediately is recommended.

8. Decide whether a test run is to be carried out.

9. Choose Program → Execute in background.

The function is executed for all objects that meet the selection criteria. After execution, a list of the processed objects is printed. The data in this list corresponds to the status before executing mass processing.

You can also define a variant for scheduling in the background (see Definition of Variants [Page 449]).

You can also save your entries as a variant. To do so, in step 9 choose Goto → Variants → Save as variant... You define a variant for the program PPIO_ENTRY. You can schedule this sort of variant later in a background job.
Definition of Variants

You can adapt the mass processing function and the order information system in a very flexible way, to meet the requirements of your company and its individual users. You can put together user-dependent report variants, report transactions and variant transactions, to provide every user with the exact range of functions required.

Techniques Used

• Report variants

With a report variant, (see Variant Maintenance [Ext.]) you can specify default values for fields, hide fields or make them unavailable for input on the initial screen of a program. You can use report variants to schedule in the background or to define a report transaction. For technical reasons, only the display and input availability of the selection criteria can be influenced for the program. The display and input availability of other fields (for example, the parameters for mass processing or the list category) can only be controlled via a transaction variant. Conversely, the selection criteria cannot be influenced in the transaction variant.

• Report transactions

A report transaction is used to call up a report variant of a program (see Report Transaction [Ext.]). You can insert a transaction in the menu or add it to the favorites list.

• Transaction variants

With a transaction variant (see Transaction Maintenance [Ext.] and Variant Transaction [Ext.]) you can also hide fields or specify default values for them (for example, the parameters for mass processing, list category, production order selection, planned order selection).

• Variant transaction

A variant transaction is used to call up a transaction variant (see Transaction Maintenance [Ext.] and Variant Transaction [Ext.]). You can insert a transaction in the menu or add it to the favorites list. A variant transaction, for example, can be added to a user's favorites menu or role menu.

Example

The following example shows you how to create a customized transaction for reprinting time tickets.

1. Defining a report variant

Using transaction SE38, you define the report variant Z_LV01 for program PPIO_ENTRY. When you do this, you preset the following:

- The operation list is the only list that can be selected.
- Operations is predefined for the List field.
- The indicator Mass processing active is set.
- Selection fields that are not needed are hidden.
- Print and Print mode, as mass processing functions, are preset for immediate execution. You define that these fields are blocked for entry.
Definition of Variants

2. Defining a report transaction

   Using transaction SE93, you define the report transaction Z_LV01_T for report variant Z_LV01 of program PPIO_ENTRY.

3. Defining a transaction variant

   Using transaction SHD0, you define the transaction variant Z_LV01_01 for report transaction Z_LV01_T. You hide the Production orders and Planned orders fields.

4. Defining a variant transaction

   Using transaction SE93, you define the variant transaction ZLV01 for transaction variant Z_LV01_01 of report transaction Z_LV01_T. These variant transactions can, for example, be added to the end user’s favorites menu or role menu.

Execution in the Order Information System and Mass Processing

The central program for mass processing and the order information system is PPIO_ENTRY. Examples have been set up in the standard system to demonstrate the use of the options described above:

<table>
<thead>
<tr>
<th>Mass processing</th>
<th>Variant transaction</th>
<th>Transaction: COHV</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Logistics → Production → Shop Floor Control → Control → Mass Processing</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transaction variant</th>
<th>Transaction: COHVOMPP Transaction variant: HVOM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report transaction</td>
<td>COHVOMPP</td>
</tr>
<tr>
<td>Report variant</td>
<td>Report: PPIO_ENTRY Variant: SAP&amp;HVOM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Order Information System</th>
<th>Report transaction</th>
<th>Transaction: COOIS</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Logistics → Production → Shop Floor Control → Control → Information system → Order info system</td>
<td></td>
</tr>
</tbody>
</table>

| Report variant | Report: PPIO_ENTRY Variant: SAP&COOIS |
### Definition of Variants

#### Collective Release

<table>
<thead>
<tr>
<th>Variant transaction</th>
<th>Transaction: CO05N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logistics → Production → Shop Floor Control → Control → Mass Processing → Collective release</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transaction variant</th>
<th>Transaction: COHVOMRELEASE Transaction variant: CO05</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report transaction</td>
<td>COHVOMRELEASE</td>
</tr>
<tr>
<td>Report variant</td>
<td>Report: PPIO_ENTRY Variant: SAP&amp;RELEASE</td>
</tr>
</tbody>
</table>

#### Print

<table>
<thead>
<tr>
<th>Variant transaction</th>
<th>Transaction: CO04N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logistics → Production → Shop Floor Control → Control → Print</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transaction variant</th>
<th>Transaction: COHVOMPRINT Transaction variant: CO04</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report transaction</td>
<td>COHVOMPRINT</td>
</tr>
<tr>
<td>Report variant</td>
<td>Report: PPIO_ENTRY Variant: SAP&amp;PRINT</td>
</tr>
</tbody>
</table>

#### Collective availability check

<table>
<thead>
<tr>
<th>Variant transaction</th>
<th>Transaction: COMAC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logistics → Production → Shop Floor Control → Control → Collective availability check</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Transaction variant</th>
<th>Transaction: COHVOMAVAILCHECK Transaction variant: COMAC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report transaction</td>
<td>COHVOMAVAILCHECK</td>
</tr>
<tr>
<td>Report variant</td>
<td>Report: PPIO_ENTRY  Variant: SAP&amp;AVAILCHK</td>
</tr>
<tr>
<td>----------------</td>
<td>------------------------------------------</td>
</tr>
</tbody>
</table>

Definition of Variants
Processing Requests

Prerequisites
Function requests must have been created.

Procedure
1. Choose System → Services → Reporting.
2. Enter COWORKDISPATCH in the Program field.
3. Choose .
4. Enter OR (= order) in the Object type field.
5. Enter the following selection criteria (user name, plant, date of entry, time of entry).
6. Choose Mass processing → Settings...
7. Select the functions, whose requests are to be processed.
   If necessary, enter a sequence number. This determines the sequence of execution, if you want to execute more than one function.
   
   You can determine whether all functions for production orders in a collective order are processed together in a LUW (Logical Unit of Work). This means that if processing is stopped for whatever reason, none of the functions is carried out for the collective order.
8. Choose .

   The requests are processed.

   You can also save your entries as a variant. To do so, in step 7 choose Goto → Variants → Save as variant...

   The program COWORKDISPATCH executes the function requests that were created with mass processing.

   If you use mass processing online and work with requests, you can schedule the program COWORKDISPATCH periodically to ensure that the requests are processed regularly.
Example: Using Mass Processing

The following examples demonstrate possible uses for mass processing:

- Rescheduling a small number of orders with date specification
  If you want to reschedule a small number of orders for a particular date without waiting for this process to be carried out, you can execute mass processing online and execute the function in the background, that is, the orders will be rescheduled immediately.

- Rescheduling a large number of orders with date specification
  If you want to reschedule a large number of orders for a particular date and you want scheduling to be carried out at night, you can start mass processing online and create requests that will be processed in a background job scheduled to take place at night (planning program COWORKDISPATCH).

- Periodically releasing a large number of orders
  If you want to periodically release a large number of orders that have reached or exceeded their release date, you can schedule the processing to take place in the background. To do this, schedule the program PPIO_ENTRY with immediate execution of the function in a background job.

- Log display
  When you release several orders and you want to immediately check whether this process was successful, start mass processing with immediate execution. You can check what happened by displaying the log for the last execution of mass processing.

- Log display
  Schedule several background jobs if you want to schedule, cost, release and print several orders. You can then display the logs for these mass processing functions together using the Display log function in mass processing.

- Printing individual lists
  If you want to print shop floor papers for several orders, start the mass processing function print online with immediate execution of function. The scope of printing is defined in print customizing via the order type, plant and MRP controller.

- Set user status
  If you want to set a user status for several orders, start the mass processing function set user status online with immediate execution of function.

- Confirmation
  If you want to create several orders using collective entry of confirmations, start the mass processing function enter time ticket confirmation and execute the function online.

- Reprinting time tickets
  If you want to reprint a time ticket for an operation, select the operations of the corresponding order in the operation list and select the operation. Enter a key for the valuation of the spool parameters and deselect all lists apart from the time ticket.
Example: Using Mass Processing
Setting Up Parallel Processing

Prerequisites
By using parallel processing, you increase the speed of mass processing.
If you want to use parallel processing for mass processing online, you must set up the server group COWORK-DIALOG. If you want to work in the background, set up the server group COWORK-BATCH. These server groups will then be used automatically by the mass processing function.

Procedure
1. Choose Tools → Administration → Administration → Network → RFC Destinations.
2. Choose RFC → RFC groups.
3. Create the server groups COWORK-BATCH and COWORK-DIALOG and define the properties of these server groups.
4. Choose .

Lock problems can occur as a result of parallel processing (for example, in collective release with availability check).
Status

Definition
A status documents the current processing status of an object. When business transactions are carried out on an object (for example on a production order, an operation or a component) the status of the object changes accordingly. The statuses activated influence which business transactions can be carried out on an object.
System/User Status

In the SAP System, a distinction is made between system status and user status.

System Status

A system status is a status set by the system. It informs the user that a particular function was carried out on an object. You cannot influence a system status in any way, that is, it cannot be directly deleted or changed.

When you release a production order, the system automatically sets the system status "released". You cannot influence this status unless you carry out a business transaction that leads to a change of the system status.

User Status

A user status is activated by the user and can be created as an addition to the existing system status. You can define and activate any number of user statuses. To define a user status, you need to have created a status profile, which is created per order type in Customizing (see What is a Status Profile? [Page 461]).

You can activate any number of statuses in a production order.

It is possible for a production order to be simultaneously "released", "pre-costed", "printed" and "confirmed".
Displaying a Status

Use
A status can be displayed in two different ways in the system:

- As a 30-character text
- As a 4-character identification code

Both forms of display are language-dependent.

Procedure
To display the statuses activated in a production order, choose [ ].
What is a Business Transaction?

A business transaction is an action carried out by the user on the screen, for example, the execution of a transaction or a function.

For example, you carry out a business transaction when you:

- Release an order
- Release an operation
- Post a goods receipt
- Enter a confirmation
- Print an order

How Can a Status Influence a Business Transaction?

A status can

- Allow a business transaction
- Issue a warning before the business transaction is carried out, or
- Forbid the business transaction

In the second case, you receive a warning message before the system carries out the transaction desired. It is up to you to decide whether you want to proceed, despite the warning.

You want to mark a released production order for deletion. However, the order does not yet have the status "technically completed". The system issues a warning message informing you that the order is not yet technically complete.

When Can You Carry Out a Business Transaction?

To be able to carry out a business transaction, the following requirements must be met:

- At least one active status must allow the transaction
- No active status may forbid the transaction

When is a Status Active?

A status can be either active or inactive:

- A status is active if it is set in the object.
- A status is inactive if it either
  - has never been activated, or
  - it was active before but has since been deactivated.
What is a Status Profile?

A status profile is created in customizing per order type.

Within a status profile you can

• Define user statuses and document their function in long texts
• Specify the expected sequence of user statuses by assigning a "status number" to each user status
• Define an initial status, which is automatically set when the object is created
• Specify that a user status should automatically be activated, if a certain business transaction is carried out
• Allow or forbid certain transactions, if a status is active

Status Numbers

For every user status you can define a status number. With the help of the **status number** you determine the sequence in which the user statuses are activated.

If you do not assign a status number to a user status, the user status can always be activated. However, only one user status with a status number can be active at any given time.

If you assign a status number to a user status, you must also specify a **lowest** and a **highest status number** for the user status. These limit the status number interval from which the next user status can be selected.

You have defined the following user statuses with the following status numbers in a status profile:

<table>
<thead>
<tr>
<th>Status no.</th>
<th>Status</th>
<th>Lowest no.</th>
<th>Highest no.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Planning locked</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>Preparation</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>Execution</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>4</td>
<td>Completion</td>
<td>4</td>
<td>4</td>
</tr>
</tbody>
</table>

In this example, the status "planning locked" can always be activated since it has no status number.

Status "preparation" must be activated first. When status "preparation" is active, it is possible to activate status "execution".

If status "execution" is active, you can activate either status "preparation" or status "check".
What is a Status Profile?

The lowest and highest number of the **highest activated** status number is always valid. In the above example it would therefore not be possible to first activate status "execution" from status "check" and to then activate status "preparation" from status "execution".

If status "check" is activated, you can activate either status "execution" or status "completion". Once status "completion" is activated, a return to preceding statuses is no longer possible.
What is a Selection Profile?

In a selection profile you can use selection criteria that are combinations of user and system statuses.

Selection profiles are used for selecting in the order information system [Page 484] and to activate predefined trigger point functions [Page 188].

You can enter system statuses and user statuses in a selection profile. If you want to make a selection based on a user status, you need to enter the corresponding status profile when you create the selection profile. You cannot assign a status profile after you have created the selection profile.

You can find out how to create a selection profile in Customizing for Shop Floor Control, by choosing Master data → Order → Define Selection Profile.
Creating User Statuses

Use

User statuses are always defined in a status profile.

Procedure

1. First, you create a status profile.
2. Assign the corresponding object types to the status profile.
3. Define the required user statuses in the status profile.
4. Assign the user statuses to the corresponding business transactions.
5. If necessary, translate the status profile and the user statuses.

To be able to work with a status profile, you first need to assign it to the order type in Customizing (Customizing for Shop Floor Control by choosing Master Data → Order → Define Order Types).

For information on how to create a status profile, see Customizing for Shop Floor Control by choosing Master Data → Order → Define Status Profile.
Activating User Statuses

Use
You can activate a user status at order header and at operation level.

Procedure

Order Header Level
1. Go to the order header.
2. Choose \[\text{Function Key} 1\].
3. Choose Edit → Direct entry.
   The system displays a dialog box in which you can select the permitted user statuses.
4. Position the cursor on the required user status and choose Choose \(\checkmark\).

Operation Level
1. Go to the operation overview.
2. Select the operation in question.
3. Choose \[\text{Function Key} 1\].
4. Choose Edit → Direct entry.
   The system displays a dialog box in which you can select the permitted user statuses.
5. Position the cursor on the required user status and choose Choose \(\checkmark\).
Status Change Documents

Use

Any status changes that occur when an order is processed can be recorded in the form of status change documents.

A status change document records,

- **Which** status was changed
- **Who** changed the status
- **When** the status was changed
- Whether the status was **activated or deactivated**
- In which **transaction** the status change occurred

In the production order you can define statuses for the following objects:

- Order header
- Operation
- Material component
- Production Resources and Tools

You can specify that status change documents are to be created for any of these objects.

For performance reasons we recommend that you activate status change documents only at order header level.
Maintaining Default Settings

Use
In Customizing for Shop Floor Control, you can specify per order type and plant whether status change documents are to be written.

Procedure
1. In Customizing for Shop Floor Control choose Master Data → Order → Define Order Type-Dependent Parameters.
2. Select the line with the corresponding order type and plant.
3. Tick the required documents (tab page Implementation, field group Status change documents).
4. Save your entry.

From now on, the system writes a status change document for every status change at this order level, provided the order (or operation/component/PRT) was created after the status change documents were activated.
Displaying Status Change Documents

1. First, call up the corresponding status display:

   Displaying statuses at order header level:
   Choose 1.

   Displaying statuses at operation level:
   Branch to the operation overview screen. Select the operation in question and choose 2.

   Displaying statuses at component level:
   Branch to the component overview screen. Select the component in question and choose 3.

   Displaying statuses at PRT level:
   Branch to the operation overview screen. Select the operation that the PRT is assigned to and choose 4. The system branches to a list of all the PRTs assigned to the operation. Select the required PRT and choose 5.

   The system lists all the statuses that are currently active in the selected object (order header, operation and so on).

2. Now you must specify whether you want to display change documents for one or several statuses:

   Change documents for one status:
   If the status in question is already displayed in the list, select the status and choose Extras → Change documents → For status.

   The system lists all the change documents created for the status.

   Change documents for all statuses:
   Choose Extras → Change documents → All.

   The system lists all statuses that were ever active in the object.

3. You can display change documents for statuses in the following ways:

   Change documents for one status:
   If you want to display change documents for a particular status, select the status with a double-click.

   Change documents for all statuses listed by status:
   If you want to see all change documents listed by status, select the menu options Goto → All changes.

   Change documents for all statuses in chronological order:
   If you want to see all change documents in chronological order, select the menu options Goto → History.

   If you want to know which statuses changed at a specific point in time, position the cursor on the left half of the corresponding list entry (Date, Time, Last changed by) and
choose *Select*. The system displays all the statuses that were active and all the statuses that were deactivated at that particular time.

If you want to display **all statuses with their short texts that were active at a particular point in time**, position the cursor on the right half (System status/User status) of the corresponding entry in the list and choose *Select*. The system displays all the statuses that were active at that particular point in time.

- If you want to know **which business transactions were allowed or prohibited** at that point in time, choose the tab page *Business transactions. Operations*

  The system first lists all transactions that were allowed transactions, followed by all transactions that were prohibited.

- If you also want to know **why a particular transaction was prohibited/allowed** at that time, position the cursor on the transaction and choose *Transaction analysis*.

  The system lists all statuses that influenced the transaction.

  Please bear in mind that a business transaction is only allowed if at least one status allows the transaction and no status prohibits it.
Co-Products

Use

Products that are usually manufactured together can be produced using one production order. The main product is the primary reason for the production process. It is displayed in the production order header. The system also creates a separate order item for the main product.

A co-product is a product that is produced in conjunction with other products. The system creates a separate order item in the production order for each co-product. As a result, it is possible to display actual costs at co-product level.

A by-product is a product that is produced in conjunction with other products. The system does not create a separate order item for each by-product. The material valuation of a by-product is always based on the price specified by price control in the material master.

Creating a production order to manufacture co-products has the following advantages:

- Main product and co-product(s) are settled to different receivers
- Goods movements can be posted simultaneously for all products manufactured in the order
Co-Products: Prerequisites

The following prerequisites must be fulfilled if you want to create a production order with co-products or by-products.

**Prerequisite for the main product:**
- The indicator *Co-product* must be activated in the material master of the main product (MRP area)

**Prerequisites for a co-product:**
- The indicator *Co-product* must be activated in the material master of the co-product (MRP area)
- The co-product must be listed as an item in the bill of material of the main product
- On the *Basic data* tab page of the BOM item, the indicator *Co-product* must be activated in the field group *General data*.

**Prerequisites for a by-product:**
- The by-product must be listed as an item in the bill of material of the main product
- The bill of material item must have a **negative quantity** (for example ‘1 - ’).

Do **not** set the indicator *Co-product* for by-products.
Co-Products: Costs

The costs for the orders are assigned to the order header and then distributed to the individual co-products according to equivalence numbers. You define an apportionment structure in the material master of the main product. The apportionment structure specifies how the total costs should be distributed over the main product and the co-products.

Based on this data, the system automatically creates the following when a production order is created:

- One settlement rule that distributes the total order costs over the main product and the co-products (that is, over the individual order items)
- One settlement rule per item, that assigns the costs to stock

At present, it is only possible to distribute actual costs.
Co-Products: Source Structures

By using a source structure, you can enter different equivalence numbers for different cost element groups within the same apportionment structure.

Example of equivalence numbers with source structure

<table>
<thead>
<tr>
<th>Source assignment</th>
<th>Main product</th>
<th>Co-product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Production costs</td>
<td>1</td>
<td>4</td>
</tr>
<tr>
<td>Material costs</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>Overheads</td>
<td>5</td>
<td>3</td>
</tr>
</tbody>
</table>

With source structures, you can vary the distribution of costs according to the cost element group.

If you do not use a source structure, the cost distribution must be the same for all cost element groups in the apportionment structure:

Example of equivalence numbers without source structure

<table>
<thead>
<tr>
<th>Source assignment</th>
<th>Main product</th>
<th>Co-product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Production costs</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>Material costs</td>
<td>2</td>
<td>1</td>
</tr>
<tr>
<td>Overheads</td>
<td>2</td>
<td>1</td>
</tr>
</tbody>
</table>

If you want to work with a source structure, proceed as follows:

- Define a source structure in Customizing
- Define an apportionment structure in the material master of the main product (pushbutton Joint production in the MRP area).
Collective orders

Use
In a collective order, planned orders or production orders are linked to one another over several production levels. Each order in the collective order has its own order number. If subassemblies are produced directly for superior orders within a production process, without physically entering the warehouse, it is useful to have a representation via collective orders.

The components for which separate production orders are created in the collective order are called directly produced components (see Creating Collective Orders [Page 476]).

Prerequisites
A collective order cannot be created for components that have one of the following indicators set:

- Co-product
- By-product
- Alternative item with strategy 2
- Alternative item with usage probability 0
- Discontinued
- Follow-up material
- Intra material

Features
Collective orders offer the following advantages:

- Integrated view of a production process
  Collective orders make it possible to represent different levels of the production process together in the system. The production process can be viewed as an integrated whole.

- Separate order number for every order
  Every level in a collective order represents a separate production order/planned order. Every production order/planned order has its own order number. This enables you to process the entire collective order, a subtree in the collective order or an individual order.

- No placements in storage or removals from storage between production levels
  Within a collective order stock movements only take place for the leading order (that is, the order that is at the highest production level) and not for directly produced components. This makes it easier to maintain the collective order in comparison with several individual orders. A further advantage is a more realistic representation of the costs of the production process, since subordinate orders can be directly assigned and settled to superior orders.

- Business functions simultaneously for several orders
  Certain business transactions can be carried out simultaneously for several orders. Releasing an order that belongs to a collective order has the effect that all the hierarchically subordinate orders are released simultaneously.
• **Automatic change to dependent orders**
  Changes to an order automatically affect dependent orders / components affecting orders. For example, if you change the order quantity in an order then
  – the relevant quantity changes are automatically made to dependent orders
  – the requirements quantity of the directly produced component is automatically changed.
  
  In the collective order, you also have the option of manufacturing directly produced material in a different plant to the planning plant.

• **Set status in leading order**
  If you make changes in subordinate orders that have an affect on the status, then the system sets the corresponding status in the order header of the leading order in the collective order as follows:
  – CFCO Confirmation in collective order
  – GMCO Goods movements in collective order
  – RLNE Release taken place in network
  
  In this way you are informed about changes in the whole collective order.

• **Reading master data**
  You can copy the routing data and BOM data to the order again. You can find more information in [Read master data](Page 70).

**Example**

You want to produce a pump. The BOM for the pump contains a pressure regulating valve and a spiral casing. You want to enter these two components in separate production orders, but you do not want them to be posted to stock.

You set the special procurement type to direct production in the material master record for the pressure regulating valve and the spiral casing, so that production occurs using a collective order.

When you create a production order for the pump, a collective order is automatically created, which contains subordinate production orders for the pressure regulating valve and the spiral casing.
Creation of Collective Orders

Use

Collective orders are only created if the special procurement type is set to direct production in the components for which the separate production orders are to be created (materials planning area in the material master).

In the standard system, 52 is the special procurement type for direct production (that is, for components that are produced within a collective order).

Activities

To create a collective order, proceed as follows:

- To create a collective order manually, proceed as described in Creating a Production Order with a Material [Page 27].
- To convert a planned order, proceed as described in Individual Conversion of a Planned Order [Page 42].

To create a collective order, you must use an order type with internal number assignment.
Maintaining Collective Orders

Use

Collective orders are maintained the same way as production orders.

Procedure

1. Choose Logistics → Production → Shop Floor Control → Order → Display or Logistics → Production → Shop Floor Control → Order → Change

2. If you want to display or change a collective order, specify which level of the collective order you want to call up. To do this, set the relevant indicator, enter the order number and choose.

   If you access the collective order with
   
   - Specified order you branch to the individual order
   - Sub-tree of network then the network is displayed and the orders of the sub-tree are read in
   - Whole network then all of the orders in the network are read in, irrespective of which order you entered from the network
   - Display overview (default setting) an overview of the whole collective order is displayed (no order is read in)

   In collective order maintenance, a green tick indicates the orders for which order data has already been read in.

   From maintenance of an individual order you always branch to the collective order overview. You can read in other orders from there.

   If you access it with Sub-tree or Whole network, then the functions can be carried out directly for all the orders (for example, release). When you execute functions in the collective order, the system always reads those orders that are needed for these functions.

   You can switch between normal display and compressed display. Choose in collective order maintenance.
Costs in Collective Orders

Use
You can calculate planned costs and actual costs for any orders within a collective order.

Prerequisites
In the definition of the order type (Customizing for Shop Floor Control, by choosing Master data \( \rightarrow \) Order \( \rightarrow \) Define Order Types) you can use the indicator Coll.ord.process to determine how costs are to be settled in the collective order.

Features

Planned Costs
If the indicator Collective order with goods movements

- Is set, then the directly produced assemblies are evaluated using the price-determination strategy in product costing
- Is not set, the price of the directly produced assemblies is evaluated using the order costing for the relevant orders

Actual costs
If the indicator Collective order with goods movements

- Is set, then automatic goods movements take place between the production orders in a collective order. This means that a subordinate production order delivers the material it has produced to stock. At the same time as the goods receipt posting, a goods issue posting is made for the superior order. During the posting of the goods movement
  - costs are credited to the subordinate order
  - costs are debited from the superior order
- Is not set then no automatic goods movements take place between the production orders. In the closing period, the costs collected per order are then settled to the superior order.

For more information, refer to the component CO - Cost Object Controlling in the section Order-related product controlling under Collective order [Ext.].
Release of Collective Orders

Use

Production orders that belong to collective orders are generally released in the same way as normal production orders. When there is a release in the collective order, the system sets the status RLNE (release occurred in network) at header level in the collective order’s leading order. This status is not reversed.

An operation cannot be released if one of the following applies:

- The operations in dependent orders are not released
  
  An operation can only be released, if all preceding operations have been released. If components are assigned to an operation and if a separate order was created to manufacture these components, then the operation can only be released if all the operations in the dependent order have already been released.

- The operations in the dependent orders cannot be accessed
  
  The system cannot check whether all preceding operations are released if, when calling up the order, you have not specified that you want to display the whole order, or at least a subtree.

  If you have called up an individual order, the system does not let you release it (unless the order is at the end of a subtree).

Example: Releasing Orders and Operations in Collective Orders [Page 480]

For more information about releasing operations and orders, refer to Order Release [Page 229].
Example: Releasing Orders and Operations in Collective Orders

In the following example, you can

- Automatically release orders 4 and 5 by releasing order 2
- Only release operation 3, if operations 2 and 1, as well as order 5, are released
- Always release operation 1
Confirmations in Collective Orders

Use

Production orders that belong to collective orders are generally confirmed like normal production orders. However, you should note the following:

- When you carry out a confirmation at header or suboperation level, you can only confirm the order concerned.
- When you confirm at operation level, you can confirm operations for all orders as long as you work with milestone operations or progress confirmations.
- When there is a confirmation in the collective order, the system sets the status CFCO (release occurred in network) at the header level of the leading order in the collective order.

Example: Confirming Collective Orders [Page 482]

With cross-order confirmations you can use an indicator in Customizing to specify whether orders that have already been finally confirmed at header level (status CONF) should also be confirmed.

For more information about releasing operations and orders, see Confirmations [Page 307].
Example: Confirming Collective Orders

The following example shows how you can confirm the entire collective order by marking operation 3 as a milestone.
Posting Sub-Assemblies to Stock in a Collective Order

Use
In a collective order, goods movements are usually not required for assemblies that are directly produced. The material produced is passed directly to the work center where it is needed as a component in the superior order. To represent the costs correctly in a collective order, the confirmation of the sub-assembly simulates a goods receipt and also goods issue for the superior order. For the directly produced assembly, the result is that costs are credited to the subordinate order and costs are debited to the superior order.

In exceptional cases, however, you may want to place a particular part of the produced sub-assembly in stock.

In a directly produced order, the planned order quantity is 110 pieces. 10 pieces of this are planned as scrap. However, no scrap occurs during production. As a result, you confirm 110 pieces as yield. As only 100 pieces are needed in the superior order (requirements quantity of the components = 100 pieces), you have a surplus of 10 pieces that you want to post to the warehouse.

The confirmation of yield in the subordinate order has the result that costs are credited to the subordinate order and costs are debited from the superior order. Goods receipt with reference to the subordinate order would therefore lead to costs being debited twice from the superior order.

To avoid this error, we recommend that you enter an unplanned goods receipt for the surplus quantity with reference to the superior order.

Procedure
1. Confirm the actual yield as usual in the subordinate order
   Via the confirmation, the value of the superior order is automatically debited.
2. In the initial screen, choose Logistics → Materials management → Inventory management → Goods movement → Goods receipt → Other.
3. Enter the movement type 531 (goods receipt of by-product), plant and storage location. Choose 🛒.
4. Enter the number of the superior order in the Order field. For item 1, enter the assembly of the subordinate order and also the surplus quantity.
5. Save the goods movement.
Order Information System

Use
The order information system is a tool for shop floor control with a reporting function for production orders and planned orders:

Evaluations take place, with the aid of the IOC logical database, via the original production order tables.

Features
All the orders to be found in the system, including the orders with deletion flags or deletion indicators, can be taken into account. Archived orders are not taken into account.

The order information system has the following display options:

- In an individual object list [Page 485], a list is generated for the selected object (for instance, order header, operation, component). You can define the structure and appearance of the individual object list with a Profile [Page 489] or a Layout [Page 490].

- On the object overview [Page 491] the individual orders are displayed with their subordinate objects in a hierarchical structure. With an overall profile [Page 493], you can define which fields are displayed and which objects (order headers, items, sequences, and so on) are read or displayed. In addition, you can define which fields are displayed for the individual objects.

In Release 4.6C, the individual object list has been converted to the ABAP list viewer (ALV) interface. For technical reasons, the ALV interface is not available for the object overview.
Individual Object Lists

Use

Individual object lists contain detailed information about objects in an order (production order, planned order). For example, you want to display all PRTs used within a particular time period. The individual object list for PRTs is suitable for this, since you do not require detailed information about the superior objects, operation, sequence and order. However, you can group the information in the individual list according to order or operation.

You can either define the structure of an individual object list in a Profile [Page 489] or using a Layout [Page 490].

Features

Individual Object Lists

Individual object lists are available for the following objects:

- Order headers
- Items
- Documented goods movement
- Sequences
- Operations (inc. suboperations)
- Components
- Confirmations (order, operation, suboperation)
- Production resources and tools
- Trigger points
- Capacities (operation, suboperation)
- Automatic goods movements (backflushing, automatic GR)
- Goods movements with errors (backflushing, automatic GR)
- Purchase requisitions (externally processed operations)
- Purchase orders (externally processed operations)

If you want to include planned orders in the individual object list, then the objects are restricted to order headers and components.

Working with Individual Object Lists

You can use the following functions to adapt the structure, contents and presentation of the individual object list:

- Standard functions of the ALV interface
- Sort objects in any way and filter them according to particular field values
Individual Object Lists

- Hide or display columns
- Create totals and subtotals
- Print and export individual object lists
- Define generally-valid and user-specific layouts
- Use individual object lists in the SAP GUI for HTML

The option of comparing field values is not available.

Special Functions in the Individual Object List

- The following functions are available when you choose Settings:
  - Set filter → Set status filter/filter → User filter
  - Delete filter → Delete status filter/filter → User filter
  - Get profile

  A status filter cannot be assigned to a layout. However, you can use these functions directly call up a status filter or fetch a profile to which a status filter is assigned.

- You have the following navigation options:
  - By choosing Environment, you can branch to different order objects and other overviews.
  - Using a double-click or Display object, you can go to the display of the object assigned to the selected field (for example, material master). With Change object you go to the processing of the object.
  - With Order or Order, you switch to order display or processing.

- To display all logs for an order, choose Order.

Refreshing the List

When you branch to production orders/planned orders within the list to carry out business transactions (such as order/operation releases, availability checks and so on), you can update the list afterwards:

- A complete refresh will update all production orders in the list (choose ).
- If you have only changed a small number of orders in the list, you may only want to refresh the orders that have changed, as this would reduce the system load. Select the relevant objects and choose .

No new selection is executed when you refresh. Filters are reused.

See also:
SAP List Viewer (ALV) Grid Control [Ext.]
ALV Grid Control (BC-SRV-ALV) [Ext.]
Calling Individual Object Lists

1. Choose Logistics → Production → Shop floor control → Information system → Order information system.

2. If required, set the indicator for the selection of planned and/or production orders.

3. In the List field, choose which individual object lists you want the system to display.
   - If you also want to select planned orders, you only have the choice of Order headers or Components.


5. Enter your selection criteria.

   To make execution easier, you can define variants for the selection program PPIO_ENTRY (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria. If you do not need mass processing, you can deactivate it when you define a variant.

6. Choose .
Profiles

Use
In profiles, you define the structure and appearance of the individual object lists.

Features
You can make the following settings in a profile:

- **Displayed fields**
  In a subprofile, you can define which fields are displayed when you call up the list.

- **Formatting settings**
  You can specify which fields are displayed, define column width, influence field grouping and define whether values should be shown as percentages.

- **Sort criteria**
  In a subprofile you can define how the fields should be sorted, when you call up the list.

- **Grouping criteria**
  In a subprofile you can define how the fields should be grouped, when you call up the list.

- **User filters**
  With a report variant you can save filter criteria for the objects. The respective individual object list is then automatically filtered according to these specific criteria when you call it up.

- **Status filters**
  You can filter objects that have a status (order header, operation, component) via a selection profile [Page 461].

Activities
Maintain the profiles in Customizing for Shop Floor Control by choosing Information System → Profiles for Order Information System.
Layouts

Use
In layouts you can enter default values for the structure and appearance of the individual object lists. You define layouts in the order information system. You can define layouts that are generally valid and layouts that are user-specific.

Features
You can make the following settings in a layout:

- Column selection
- Sorting criteria and grouping options
- Filter
- Global settings (general appearance)
- Web options

A status filter can be assigned to the layout (possible for a profile).

Activities
You maintain layouts in the individual object list in the order information system.
Object Overview

Use

The object overview displays the objects selected from the production orders/planned orders in hierarchical form (see Selecting and Deselecting Database Objects [Page 494]). This makes it easy to see the relationship between the individual objects (for example component assigned to an operation or confirmation assigned to an order header).

You define the structure of the object overview in an Overall Profile [Page 493].

Features

The following functions allow you to structure the information in a way which best suits your requirements:

- Hide irrelevant objects
  
  You have, for example, chosen all production orders to which a certain component is assigned. In this case, you may want to hide the objects sequence and operation, as they are of no interest to you. This can be specified in the transaction, or in the overall profile.

- Display certain fields or change the field sequence
  
  You have, for example, selected operations. You either want to display the field confirmed time, or you want to put it at the beginning of the line rather than at the end. You change the displayed fields or the sequence of the field display via the field selection for object operations. This can be specified in the transaction, or in the overall profile.

Refreshing the List

When you branch to production orders/planned orders within the list to carry out business transactions (such as order/operation releases, availability checks and so on), you can update the list afterwards:

- A complete refresh will update all production orders in the list (choose ).

- If you have only changed a small number of orders in the list, you may only want to refresh the orders that have changed, as this would reduce the system load. Select the relevant objects and choose .

No new selection is executed when you refresh. Filters are used again.
Calling Up the Object Overview

1. Choose Logistics → Production → Shop floor control → Information system → Order information system.

2. Choose the entry Object overview in the List field.

3. Select a Profile [Page 493].
   The setting for the selection of planned orders or production orders is copied from the profile and can be changed as required.
   The settings for object selection are copied from the profile. You can change the settings on the Object selection tab page. If you also want to select planned orders, Order headers and Components are the only objects that can be selected.

   !
   Only select those objects that you want to display. The less data requested from the system, the quicker it can be provided. If, for example, you select components and operations in addition to order headers, as a rule, the volume of data multiplies.

4. Enter your selection criteria.
   To make execution easier, you can define variants for the selection program PPIO_ENTRY (see Definition of Variants [Page 449]). This enables you to hide unnecessary selection criteria.

5. Choose .
Overall profiles

Use
Overall profiles control what information is displayed in the object overview and which layout is used to display this information.
Overall profiles use the Profile [Page 489] that is also used for the individual object list.

Features
In an overall profile, you can
• Define whether production orders and/or planned orders are to be read
• Specify a variant that can be used to hide and predefined selection criteria
• Determine an object that is to be read from the database
• Determine which of these objects are to be displayed in the list
• Define the object up to which the objects in the object overview are to be expanded
• Enter profiles that define the field selection for the displayed objects

Activities
You can maintain the profiles in Customizing for Shop Floor Control by choosing Information System → Profiles for Order Information System.
Selecting and Deselecting Database Objects

To improve system performance, you can specify which objects are to be read for the object overview from the database.

You want to have an overview of the status of all orders with a particular order type. In this case you should select the order header object type.

You want additional information on partially released or partially confirmed operations (for example, on the operation status). In this case you also have to select the Operations object type. The system then automatically selects the Sequence object type, because operations come below sequences in the hierarchy.

You can (de-)select the following objects from the database:

- Order items
- Documented goods movement
- Sequences
- Operations/suboperations
- Components
- Production resources and tools
- Trigger points
- Capacity Requirements
- Confirmation (order header, operation and suboperation level)
- Automatic goods movements (order header and operation level)
- Incorrect automatic goods movements (order header and operation level)
- Purchase requisitions
- Purchase orders

In an overall profile [Page 493] you define which objects are read from the database. You can also change these setting manually on the initial screen. To do this, choose Object selection.

Object Hierarchies in the Database

The objects are stored in the database in a hierarchical structure. The order header is at the top of the hierarchy, followed by the order items and so on.

With regard to the selection of objects that are to be read from the database: To display an object, the object itself and all objects situated above it in the hierarchy are read.

You want to generate a list of all components that are required for a particular group of orders. To be able to display components, the system has to read the relevant order headers, operation sequences, operations and components. When you select
the *components* object, the system automatically selects all other objects that are required for the selection.
Order Progress Report

Use
The order progress report shows you which documents, MRP elements, stocks and deliveries exist for products and their components that have been ordered by a customer. The order progress report gives you:

- A quick overview of the status of production and procurement
- Statements about the adherence to delivery dates or delays

An order progress report can be displayed for more than one sales orders or a WBS element.

Features

Presentation and Structure of the Report

The data is presented in a hierarchical structure that can be expanded or compressed. All the procurement elements, stocks and deliveries for a product are presented according to the selection criteria. You can expand the corresponding component structure for each internal procurement element. The existing elements are determined and displayed for each component.

The selected elements are displayed in the left-hand area of the report, the information about the elements is in the right-hand area. The form of the right-hand area can change, depending on whether material fields or element fields are being displayed. You can influence the form and contents of the report in Customizing.

For more information refer to Settings for Order Progress Reports [Page 498].

Displayed Elements

Elements that are account assigned to a sales order or a WBS element are displayed. Elements that were manually created and are account assigned to a sales order or a WBS element are also displayed. Elements that do not have a header material (for example, a purchase requisition for an external service) are presented using a placeholder material, which means that the material field remains empty.

Only those elements and requirements are displayed that are explicitly assigned to the sales order or WBS element from the selection criteria. In other words, elements that have access to sales order stock or project stock. Elements that access plant stock are not expanded further.

The following elements can be displayed:

- Planned orders
- Production orders
- Process orders
- Networks
- Purchase requisitions
- Purchase orders
- Contract release orders
- Delivery schedules
- Reservations, dependent requirements
- Deliveries, goods issue from an SD view
- Sales order stocks, project stocks
- Plant stocks, goods receipts from an MM view
- Purchase requisitions and orders from external processing
- Rework orders

Colors are used to differentiate between the element types. To display the key, choose 📆 in the report.

The elements are sorted in the following order:
1. Requirements/finish date of the elements
2. Receipts before issues
3. Element type
4. Number of the element

**Progress**

The progress or delay of each procurement element is determined and displayed individually. As well as variances in dates, variances in quantities are also examined. For more information refer to [Progress Determination (Page 500)](Page 500).

**Navigation Options**

The order progress report offers you various methods of navigation. From the report you can display or change each procurement element. You can also, for example, go directly to the stock/requirement list, the MRP list, stock overview and so on. For more information refer to [Functions in the Order Progress Report (Page 504)](Page 504).
Settings for Order Progress Reports

You can enter settings for the structure and layout of the order progress report in two profiles. You define these profiles in Customizing for Shop Floor Control by choosing Information System → Profiles for Order Progress Report:

- When you enter the order progress report, you must enter an overall profile
- Profiles for displayed fields are assigned to an overall profile

Overall Profile

In the overall profile you make the following settings:

- Assignment of the profiles for displayed fields
- Standard values for certain selection criteria:
  - Elements that are account assigned to the production order
    You can use this indicator to determine whether purchase requisitions and purchase orders for external operations and also rework orders are displayed. These elements are directly assigned to the production order. They are shown by a placeholder material (empty material field) and a corresponding icon.
  - Elements outside the product structure
    This indicator determines whether other elements that are account assigned to the order or WBS element are displayed in addition to the elements that are in the product structure of the selected product (or assembly).
    For instance, you have selected a sales order for a pump. The order progress display then displays the product structure (shaft, rotor, casing etc.). A production order that is account assigned to the sales order with material Motor is only displayed, if the indicator is set.
    For all materials outside the product structure, only the first hierarchy level is displayed. This is because the hierarchy cannot be determined here and relationships that possibly exist cannot be taken into account. All the materials outside the product structure are displayed below the product structure.
  - Number of hierarchy levels
    This number determines how many hierarchy levels are initially read into the order progress report. When you are working in the report you can read in further hierarchy levels.
- Display options:
  - Normal or compressed layout
  - Display and length of material short texts
- Specify the conditions for exception messages (see order progress determination [Page 500]).
**Profile for Displayed Fields**

In a profile for displayed fields, you specify which fields are to be displayed in the report and how long these fields are. For each profile, you can create one subprofile for material fields and one for element fields (production orders, purchase requisitions, planned orders). You assign this profile to the overall profile.
Progress Value Determination and Display of Exception Messages

Use
The difference between the desired and actual progress of an order is shown in the order progress report. The following functions are used for this:

- The ability to recognize deviations is based on progress value determination. You must activate progress value determination for production orders in Customizing (see Prerequisites - Progress Value Determination). The progress values for all elements, except production orders, are determined dynamically by the System while the report is being structured.
- In the order progress report, a number of deviations (for example, schedule deviations) are regarded as exceptions (see Features - Exceptions).
- It is possible that not every exception is to be displayed as an exception message in the order progress report. Therefore, you can define in Customizing from when (size of deviation) an exception leads to the display of exception messages (for example, length of the schedule delay).
- The progress or delay of each procurement element is displayed individually. As well as date deviations, quantity deviations are also examined. If, for instance, a production order can be finished on or before the planned date, but the confirmed yield is smaller than the planned yield, this constitutes an exception.

Prerequisites

Progress Value Determination
The following prerequisites must be met if progress values are to be determined for production orders:

- Creation of requests
  The Progress values indicator must be set in the order-type–dependent parameters (Customizing for Shop Floor Control by choosing Master data → Order → Define order-type dependent parameters). A request is then created for every change in an order that affects progress. Such changes are:
  - Changing the quantity in the order header
  - Final confirmations of operations
  - Canceling confirmations

- Processing the requests
  The progress values are determined by processing the requests. In this case only the last operations that were finally confirmed are taken into account. You can process requests in the following ways:
  - Program PPORPCRE determines the progress values based on the requests. You can schedule this program to run as a background job.
Progress Value Determination and Display of Exception Messages

– You can also manually trigger progress value determination based on requests, by choosing List→Functions → Update progress values in the order progress report.

Displaying Exception Messages

Exceptions do not necessarily lead to exception messages being displayed. For this to happen, the following prerequisites have to be met:

• The variations, which have been determined, have to be larger than the value entered in the overall profile [Page 498]:
  – Difference in operation quantity (percentage, positive/negative variation)
  – Actual delay (time)
  – Expected delay (time)

• The fields that represent the exceptions must be selected in the profile for displayed fields:
  – Target quantity, Receipt/requirement, Quantity variation (displayed by symbol)
  – Expected delay + unit, actual delay + unit (displayed by and symbols)

Features

Displaying Exception Messages

Exception messages warn you that the procurement situation for certain elements can lead to problems (either due to dates or quantities). The variations between planned and actual values that cause exceptions for elements are represented in the report by the following icons:

实际延迟太长
期望延迟太长
资金不足的量太大
异常存在于元素
丢失零件
元素被分配到一个订单

Exceptions

The following exceptions are examined in the order progress report:

• Production order dates

  If the planned finish date of an operation cannot be kept, a yellow traffic light appears.

  If the basic finish date of an order cannot be kept, a red traffic light appears. If there are floats in an order, a delay in an operation does not necessarily lead to a delay in the basic finish date of the order.

  This is illustrated in the graphic below.
The second graphic is an example of an actual delay leading to an expected delay in the order.

- Production order quantity
Progress Value Determination and Display of Exception Messages

To keep track of the order quantity, the difference between the planned yield and the yield of the last operation that has been confirmed is calculated. If this difference, expressed as a percentage of the overall quantity, is larger than the value entered in the overall profile, a bell appears.

- **Planned order**
  - If the basic start date of a planned order is in the past, a yellow traffic light appears.
  - If the basic finish date of a planned order is in the past, a red traffic light appears.

- **Purchase requisition**
  - If the release date of a purchase requisition is in the past, a yellow traffic light appears.
  - If the desired delivery date of a purchase requisition is in the past, a red traffic light appears.

- **Purchase order**
  - If the latest confirmed date of a delivery schedule is after the desired delivery date, a yellow traffic light appears.
  - If the desired delivery date is in the past, a red traffic light appears.
Functions in the Order Progress Report

Use
When you work with the order progress report, you can

- Select the individual objects in the report in a flexible manner
- Adapt the contents and the presentation of the report (for example, include hierarchy levels later)
- Execute functions (for example convert planned orders)
- Go to object maintenance (for instance Change production order)

Features

Selection Criteria and Overall Profile
A progress report can be displayed for more than one sales order or a WBS element. The requirement elements and procurement elements are displayed.

The following selection criteria are available:

- Plant
- Sales order from-to
- Sales order item from-to
- Project
- WBS element
- Material
- Production/process order, network
- Planned order

If you want to display all objects for a sales order, enter the sales order with item number. By entering a material or production order, you can further limit the number of objects displayed.

If you want to display objects from the Project System, you have to choose a network or a material. The selected object (network or material) must be assigned to a WBS element. Depending on what you have entered, a structure is displayed, from which you can select a network or material.

You can enter the overall profile on the selection screen (see Settings for the Order Progress Report [Page 498]).

Report Structure, Contents and Presentation
You can use the following functions to adapt the structure, contents and presentation of the report:
# Functions in the Order Progress Report

<table>
<thead>
<tr>
<th>Function</th>
<th>If you want</th>
</tr>
</thead>
</table>
| Switch between normal and compressed layout                             | ![Switch](image)
| Change overall profile                                                  | ![Profile](image)                                                          |
| Change selected fields for elements and materials                       | ![Fields](image)                                                            |
| Expand hierarchy tree for a subtree (depending on cursor position), read further hierarchy levels (if there are more objects below the cursor position) | ![Hierarchy](image)                                                         |
| Read more hierarchy levels                                              | ![Read](image)                                                             |
| Display a subtree of the report up to the element on which the cursor is positioned. Use this function to switch back to complete presentation | ![Display](image)                                                           |
| Display a subtree of the report from the cursor position down. Switch back to the complete presentation by selecting the top element (shown on a separate line) | ![Display](image)               |
| Step-by-step expansion up to next exception                              | ![Expansion](image)                                                        |

## Navigation Options

<table>
<thead>
<tr>
<th>Function</th>
<th>If you want</th>
</tr>
</thead>
<tbody>
<tr>
<td>Branch to other screens</td>
<td><strong>Goto →</strong>&lt;br&gt;Stock overview&lt;br&gt;Purchase order history&lt;br&gt;Material document</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Stock/requirements" /> (stock/requirements list)</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="MRP" /> (MRP list)</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Sales" /> (sales document flow)</td>
</tr>
<tr>
<td>Process a selected element</td>
<td><strong>Goto → Element →</strong>&lt;br&gt;Planned order&lt;br&gt;Production order&lt;br&gt;Sales order&lt;br&gt;Material master&lt;br&gt;Purchase order&lt;br&gt;Purchase requisition&lt;br&gt;Network</td>
</tr>
</tbody>
</table>

## Other Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Choose</th>
</tr>
</thead>
</table>

---

April 2001
## Functions in the Order Progress Report

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
</table>
| Convert planned order to production order                                | List → Functions → Convert planned order to production order  
You select the planned order to convert and choose the function above. The system converts the planned orders online. |
| Convert planned orders to production orders                              | List → Functions → Convert planned orders to production orders  
You select the planned orders that you want to convert and choose the above function. The system executes the function in the background. You can continue working in the background. The system responds by displaying a dialog box when it has finished the conversion. |
| Conversion of planned order to purchase requisition                      | List → Functions → Convert planned order to purchase requisition                                                                                                                                         |
| Manually trigger update of progress values                               | List → Functions → Update progress values                                                                                                                                                                |
| Determines the pegged requirement for a MRP element                      |                                                                                                                                                                                                          |
Calling the Order Progress Report

Use

You can call up the order progress report from various places in the SAP menu and using various functions. The overall profile is a required entry.

From the Shop Floor Control Menu

2. Enter the selection criteria (see Functions in the Order Progress Report [Page 504] under Element selection and Overall profile).
3. Choose .
4. Process the report (see Functions in the Order Progress Report [Page 504]).
5. Exit the report.

From the Material Requirements Planning Menu

1. Choose Logistics → Production → MRP → Evaluations → Order Progress.
2. Enter the selection criteria (see Functions in the Order Progress Report [Page 504] under Element selection and Overall profile).
3. Choose .
4. Use the report (see Functions in the Order Progress Report [Page 504]).
5. Exit the report.

From the Order Information System

Choose Logistics → Production → Shop Floor Control → Information Systems → Order Information System.
1. Choose the entry Object overview in the List field.
2. Enter the profile and the selection criteria.
3. Choose .
4. Place the cursor on the production order for which you want to see the report.

The selected production order must have a reference to a sales order or a WBS element.
5. Choose . Now you can use the report (see Functions in the Order Progress Report [Page 504]).
6. Exit the report.

From the Sales Order

1. Choose Logistics → Sales and Distribution → Sales → Order → Display.
2. Enter the sales order number.
Calling the Order Progress Report

3. Choose 📋.

4. Select the item, for which you want to see the order progress report.

5. Choose Environment → Order report. Now you can use the report (see Functions in the Order Progress Report [Page 504]).

6. Exit the report.

From the Order Browser

Choose Logistics → Production → Master data → BOMs → BOM → Order BOM → Order browser

1. Enter the sales order number, the order item and the application.

2. Choose Goto → Order progress.

3. Use the report (see Functions in the Order Progress Report [Page 504]).

4. Exit the report.
Assembly Orders

Use
When creating a sales order the system can automatically:

- Generate a network or
- Generate an assembly order. Here it concerns the automatic generation of a planned order or production order to cover the planned independent requirements.

The strategy group in the material master defines whether an order/network is to be created in the background.

Prerequisites
The following conditions must be fulfilled for an assembly order to be created:

- The Strategy group field in the material master (MRP) for the finished product must contain a strategy group that allows assembly orders.
- The finished product must have a BOM.
- The field Individual/collective in the material master (MRP) for the component should have the indicator Only collective requirements.

Features

Exchanging Data Between Sales Order and Assembly Order
The following data is copied between the sales order and the production order:

- The material staging date and the order quantity are copied from the sales order to the assembly order.
- The costs for the goods to be produced, the available quantity (in case an availability check has taken place) and the confirmed delivery date are copied from the assembly order to the sales order.

Scheduling
The sales order contains a desired delivery date. Scheduling is carried out automatically and a material staging date is calculated. The goods receipt processing time is subtracted from the material staging date. This generates the basic finish date of the production order.

Then the production order is scheduled backwards to determine the basic start date of the production order.

- If the basic start date of the production order is not in the past then the desired delivery date of the sales order is confirmed.
- If the basic start date of the production order is in the past then the order is rescheduled using today scheduling (see Parameters in Customizing [Page 94]). A new basic finish date is calculated in the scheduling run. The goods receipt processing time is added to the basic finish date; then a further scheduling run is carried out to determine a delivery date that can be confirmed.

For more information on assembly orders, see the SAP Library LO - Assembly Processing [Ext].

April 2001

SAP AG Production Orders (PP-SFC) Assembly Orders
Assembly Orders
Order Split

Use
Order split enables you to split an existing production order, for which processing may have already begun, into two separate production orders. These production orders are then executed separately from a logistics perspective. You might want to perform an order split for the following reasons:

- When a partial lot of a production order has to be handled differently than the rest due to quality reasons, you can create a separate order to do this.
- If capacity bottlenecks occur, the portion of the order quantity that is required immediately can be processed separately.
- The material availability can only be confirmed for part of the order quantity. You split the order to create an order with full material availability.
- If the required date for a partial quantity of the finished material has changed, this portion can be split off in a different order.
- If a production order cannot be completed on time, you can split the order to reduce the order quantity. The reduced order quantity then requires less time to produce.

Features
When you split an order, you split off part of the order quantity (split quantity) of a production order (parent order) from a certain operation of the standard sequence (split operation). The quantity that is split off is produced in a separate production order (child order). In the process, the operations from the split operation onwards are copied from the parent order to the child order, along with the assigned material components. The system automatically recalculates all the quantities affected by the order split, as well as dates at header, operation, and component level.

The following functions are provided:

- Structure
  The structure of the parent order does not change. The structure of the child order is a copy of the partial quantity of the objects from the parent order. All assigned components, production resources and tools, and trigger points are copied for the operations included in the child order. In addition, the sequences that contain the selected operations are also copied.

- Parallel Sequences
  If the parent order has parallel sequences and they are parallel in the split operation, you can decide which operations from these parallel sequences are copied to the child order.

- Quantities
  The quantities (header, operation, component) are determined automatically, based on the selected split quantity. The order quantity of the parent order is modified by the expected yield variance. In this process, the yield variance is reduced by the split quantity.
Order Split

The split quantity must be less than the split operation quantity, to ensure that the split operation retains a remaining quantity. Quantities confirmed in the parent order cannot be split. If the sum of split quantity and confirmed quantity in the split operation (or maximum confirmed quantity in a successor) exceeds the split operation quantity, a warning message informs you of this fact. If you ignore the warning message, the order quantity is increased accordingly.

- Dates
  The parent order is rescheduled after the order split. The child order is scheduled in accordance with the specified scheduling data.

- Order type
  The order type from the parent order is proposed for the child order. You can give the child order a different order type if necessary.

- Costs
  - Actual costs
    The costs of the parent and child orders are collected in a common Product Cost Collector [Page 524]. This is because the parent order, as a rule, has already caused actual costs before the split took place. If the actual costs were collected in the parent order before the split, and separately in the parent/child orders after the split, then the materials of the parent order would have excessively high costs per piece, and the child order correspondingly lower costs. As a result, settlement for each order would result in unwanted variances in controlling.
  - Planned Costs
    Temporary planned costs can be determined and analyzed within split orders (applies only to orders with product cost collectors).
    A general cost analysis, with target costs and variances, can be performed for product cost collectors in reporting for periodic product controlling.

- System Status
  There are various system status values that indicate that an order has been split:
  - SPLT (split) for the parent order
  - SPLE (generated through a split) for the child order
  - SPLT (split) for a split operation

- Multi-level order split
  Orders (including child orders) can be split several times. The dependencies can be seen in the split hierarchy.

- Split hierarchy
  The split hierarchy displays the dependencies between the parent and child orders in an overview tree. During order maintenance, the split hierarchy and the selected order from the split hierarchy are displayed. You can navigate to any order in the split hierarchy (tree structure).
  In the default setting, the split hierarchy appears to the left, and the order to the right. To change their position, choose (move counter-clockwise) or select the position directly.
The split hierarchy provides other standard functions: Managing display variants, expanding and collapsing subhierarchies, and printing.

- Inspection Lots
  Order processing with QM integration is supported together with the order split. After order release, a separate inspection lot is created for the child order, just like for the parent order, and planned inspection characteristics are copied to the order.

- Serial number assignment
  Serial number assignment in the production order and the order split are integrated.
  If serial numbers have already been assigned before the split, you must select the serial numbers that are to be reassigned from the parent order to the child order. This is important, for example, when certain pieces are to be processed separately, depending on the inspection results.
  On the other hand, if you assign the serial numbers after an order split, the required number of serial numbers to assign is adjusted to fit the order quantity minus the split quantity. Inspection results that were entered for individual pieces before the split are retained after the split, even if the serial numbers of these individual pieces are assigned to a child order after the split. Inspection results for the split-off individual pieces can subsequently be recorded in the inspection lot for the child order.
  For more information, refer to Serial Number Assignment During Order Split [Page 520].

- Alternative sequences
  Alternative sequences that are parallel to the split operation or come before the split operation are not copied to the child order. Alternative sequences that come after the split operation are copied to the child order.

Confirmation
Orders that are part of a split hierarchy can only be confirmed through operation confirmations – that is, confirmations for the document header are not supported. Operations in a parent order that lie before the split operation cannot automatically be confirmed through Milestone Confirmation [Page 333] or Progress Confirmation [Page 335]. Manual confirmations must be entered for these operations.

An order has operations 10 to 40. Operation 40 is a milestone. You split an order from operation 10. When you confirm operation 40, operations 10 through 30 are confirmed automatically in the parent and child orders.

An order has operations 10 to 40. Operation 40 is a milestone. You split an order from operation 20. When you confirm operation 40, operations 20 through 30 are confirmed automatically in the parent order. Operation 10 in the parent order must be manually confirmed. When you confirm operation 40, operations 20 through 30 are confirmed automatically in the child order. The child order does not have an operation 10 because the order was split from operation 20.

Restrictions
The following restrictions apply to the order split:
Order Split

- The parent order and child order must both be settled to the same product cost collector
- You cannot read master data for the orders in a split hierarchy
- Orders in a collective order cannot be split
- Orders of a split hierarchy cannot be supplemented with a subtree
- The parent and child order must both have the same header material
- You cannot perform confirmations at order header level
- The batch where-used list is not updated during order split
**Prerequisites**

Certain prerequisites must be met before you can perform an order split.

**System Status**

An order split is allowed with the following system status:

- *Header status*: Partially released, released, partially confirmed
- *Operation status* of the split operation and all successors: Created, released, partially confirmed

The order split is not allowed with the following status:

- *Header status*: Created, delivered, finally confirmed, locked, technically complete, closed, deletion indicator set
- *Operation status* of the split operation and all successors: Finally confirmed, dispatched, partially dispatched, capacity split, capacity requirement assigned, capacity requirement partially allocated
- *Operation status of the split operation*: Deleted

**Open Confirmations**

Before an order split can be performed, you must first post all requested confirmations for the parent order (see Displaying Requested Confirmations [Page 347]). The posting of requested confirmations is carried out in general by scheduling the program CORUPROC1 as a background job.

**Order Settlement**

To ensure that settlement is performed without any additional variances, the parent and child orders must be assigned to the same *Product Cost Collector* [Page 524].

After an order split, the costs per piece can no longer be calculated for each order, since operations and goods movements are usually not distributed equally between parent and child. As a result, settlement by order is not supported. Settlement is performed through a product cost collector.

Make the following settings in the order type-dependent parameters (Customizing for Shop Floor Control by choosing Master data → Orders → Define Order Type-Dependent Parameters):

- With the *Cost collector* indicator, you decide whether you want to collect the costs in a product cost collector.
- The *Distribution rule* must support periodic settlement.

**See also:**

*PP – Production orders: Product Cost Collector [Page 524]*

*CO – Cost Object Controlling – Periodic Product Controlling: Product Cost Collector [Ext.]*
Examples for Order Split

Example 1: Order Split from an Operation with Predecessors and Successors

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Header quantity 10 pcs</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>10 pcs</td>
</tr>
<tr>
<td>20</td>
<td>10 pcs</td>
</tr>
<tr>
<td>30</td>
<td>10 pcs</td>
</tr>
<tr>
<td>40</td>
<td>10 pcs</td>
</tr>
</tbody>
</table>

4 pcs are split off during operation 30.

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Header quantity 10 pcs</th>
<th>Child order</th>
<th>Yield variance -4 pcs</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>10 pcs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>10 pcs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>6 pcs</td>
<td>30</td>
<td>4 pcs</td>
</tr>
<tr>
<td>40</td>
<td>6 pcs</td>
<td>40</td>
<td>4 pcs</td>
</tr>
</tbody>
</table>

Example 2: Order Split with Parallel Sequences

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Header quantity 10 pcs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard sequence</td>
<td>Parallel sequence</td>
</tr>
<tr>
<td>0/10</td>
<td>10 pcs</td>
</tr>
<tr>
<td>0/20</td>
<td>10 pcs</td>
</tr>
<tr>
<td>0/30</td>
<td>10 pcs</td>
</tr>
<tr>
<td>0/40</td>
<td>10 pcs</td>
</tr>
</tbody>
</table>

An order split of 4 pcs is defined from operation 20. Operation 27 is also split off from the parallel sequence (sequence 1).
Examples for Order Split

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Child order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header</td>
<td>Header</td>
</tr>
<tr>
<td>quantity 10</td>
<td>quantity 4</td>
</tr>
<tr>
<td>pcs</td>
<td>pcs</td>
</tr>
<tr>
<td>Yield variance</td>
<td>4 pcs</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Standard sequence</th>
<th>Parallel sequence</th>
<th>Standard sequence</th>
<th>Parallel sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>0/10</td>
<td>10 pcs</td>
<td></td>
<td></td>
</tr>
<tr>
<td>0/20</td>
<td>6 pcs 1/23</td>
<td>10 pcs</td>
<td>0/20</td>
</tr>
<tr>
<td>0/30</td>
<td>6 pcs 1/27</td>
<td>6 pcs</td>
<td>0/30</td>
</tr>
<tr>
<td>0/40</td>
<td>6 pcs</td>
<td></td>
<td>0/40</td>
</tr>
</tbody>
</table>

**Example 3: Order Split with Operation Scrap**

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Child order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header</td>
<td>Header</td>
</tr>
<tr>
<td>quantity 100</td>
<td>quantity 50</td>
</tr>
<tr>
<td>pcs</td>
<td>pcs</td>
</tr>
<tr>
<td>Yield variance</td>
<td>50 pcs</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>100 pcs</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>100 pcs</td>
<td>20%</td>
</tr>
<tr>
<td>30</td>
<td>80 pcs</td>
<td>10%</td>
</tr>
<tr>
<td>40</td>
<td>72 pcs</td>
<td></td>
</tr>
</tbody>
</table>

50 pcs are split off from operation 20. The scrap is calculated for the parent order and the child order.

<table>
<thead>
<tr>
<th>Parent order</th>
<th>Child order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header</td>
<td>Header</td>
</tr>
<tr>
<td>quantity 100</td>
<td>quantity 50</td>
</tr>
<tr>
<td>pcs</td>
<td>pcs</td>
</tr>
<tr>
<td>Yield variance</td>
<td>50 pcs</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>100 pcs</td>
<td></td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>50 pcs</td>
<td>20%</td>
<td>20</td>
<td>50 pcs</td>
<td>20%</td>
</tr>
<tr>
<td>30</td>
<td>40 pcs</td>
<td>10%</td>
<td>30</td>
<td>40 pcs</td>
<td>10%</td>
</tr>
<tr>
<td>40</td>
<td>36 pcs</td>
<td></td>
<td>40</td>
<td>36 pcs</td>
<td></td>
</tr>
</tbody>
</table>
Executing Order Split

Prerequisites
An order that you want to split must meet certain prerequisites (see Prerequisites [Page 515]).

Procedure
1. Choose Logistics → Production → Shop floor control → Order → Change.
2. Enter the order number.
3. Choose .
   The operation overview of the standard sequence appears.
4. Select the operation from which you want to split the order.
   The operation from which you want to split the order (the split operation) must be an operation of the standard sequence.
5. Choose Functions → Split order.
   If serial numbers already exist for the order, the system asks you to select the serial numbers that you want to use in the child order.
   If the order has parallel sequences, and at least one sequence is parallel to the split operation, the system asks you to select the operations of the parallel sequences that are to participate in the order split. The system displays the affected parallel sequences for selection one after the other. You have the following selection options:
   - Select the operation of the parallel sequence from which you want to copy the operations and choose Transfer operations
   - If you do not want to select operations from any parallel sequence, choose Skip parallel sequences
   - If you do not want to transfer any operations from the parallel sequence currently displayed, choose No transfer of operations
6. Enter the Split quantity.
   The entire operation quantity is not available as the split quantity (see Order Split [Page 511]).
   If necessary, you can also enter the Order type and Order number (in the case of external number assignment), as well as the scheduling data.
7. Choose .
8. Choose .
Result
A new child order has been created. In the split hierarchy, this child order is subordinate to the parent order from which it was split.
Serial Number Assignment During Order Split

Use
This function ensures that the correct number of serial numbers (order quantity) is assigned to every order in the split hierarchy.

Features
The procedure differs depending on whether the serial numbers were assigned before or after the order split:

- Serial number assignment before the order split
  If the serial numbers already exist when you split the order, the system prompts you to select the serial numbers that you want to transfer to the child order (see Splitting an Order [Page 518]).

- Serial number assignment after the order split
  If the serial numbers do not exist yet when you split the order, you can assign the serial numbers for each order in the split hierarchy. To do this, select the following in the document header: Header → Serial numbers.

See also:
Material Serial Numbers in the Production Order [Page 238]
Management of Serial Numbers [Ext.]
Operations/Components Not Relevant to MRP

Use

You can create production orders:

- For which no purchase requisitions for externally processed operations and externally procured components are currently created
- For which the reservations for components are currently not taken into account in MRP

These order objects (operations, components) are not relevant to MRP, that is, they do not result in the creation of corresponding procurement elements (purchase requisitions planned orders).

You can specify that:

- Purchase requisitions and reservations for the order objects are activated at the point of release (order, operation), that is, purchase requisitions for externally processed operations and externally procured components are created and the reservations for components in MRP are taken into account. Before release, you can activate these purchase requisitions and reservations using a corresponding function.
- Purchase requisitions and reservations are not relevant to MRP and can only be activated using the appropriate function.
- Order objects are immediately relevant to MRP.

Prerequisites

This function is set up using the key Reservation/Purc.req in the order type-dependent parameters.

Features

When the order is created, the setting in the Res./Purc.req, key from the order type-dependent parameters is entered in the order header (key Res./Purc. req, tab page: Control). The order objects will then be processed according to these settings. The key also exists at component and operation level, and it describes the state of the object.

The key at order header level can be changed at a later stage. A change does not, however, have an effect on already existing order objects. In the case of newly added operations and components, the key in the order header is used.

When or how the activation of the order objects occurs depends on the characteristics of the Res./Purc.req, key. The key can have the following values:

- Not relevant to MRP
  - The order objects can be activated via a function in production order maintenance. To do this, functions are available at order, operation and component level. You can see how to execute these functions by referring to Activate Purchase Requisition/Reservation [Page 523].

- Not relevant to MRP until release
  - The purchase requisitions and reservations are automatically activated when releasing (order, operation). Released objects (operations, components) are always relevant to MRP.
Operations/Components Not Relevant to MRP

The order objects can also be activated prior to release via a function in production order maintenance. To do this, functions are available at order, operation and component level. You can see how to execute these functions by referring to Activate Purchase Requisition/Reservation [Page 523].

Immediately relevant to MRP

This is a standard setting.

You have to consider the following dependencies when using this function:

- All dependent objects (suboperations, components) will be activated when an operation is activated.
- When you have activated the purchase requisition or reservation, you cannot cancel this activation.
- When components are added or reassigned to a released operation, the components will also be activated.
- When planned orders are converted, the reservations for components that come from the bills of materials for MRP are always active. Routing data are dealt with during the conversion according to the setting in the order header key Reservation/Purc.req.
- At the point of release, the key in the order header is given the characteristic immediately.

Application

A possible application of this function could be as follows:

1. You create a production order with an order type whereby the order objects are not activated (Not relevant to MRP until release).

2. You can now change the order without this affecting the MRP results.

3. You release the order. By doing so, all objects are automatically activated. From now on the objects are relevant to MRP.

Activities

To maintain the Res./Purc.req. key in the order type-dependent parameters, choose Master data → Order → Define order type-dependent parameters in Customizing for Shop Floor Control.
Activate Purchase Requisition/Reservation

You can activate purchase requisitions and reservations at various levels. To do this, you must be in the creation or change mode for order maintenance (Creating Production Orders [Page 26], Maintaining Header Data in the Production Order [Page 32]):

Order header

To switch to the order header, choose .

1. Choose Functions → Activate purch. requisition/reservation.

When you execute this function, all objects in the production order are activated (purchase requisitions and reservations for all operations, suboperations and components).

If you execute this function at order header level, the subordinate orders that have been read in the collective order [Page 474] are also affected. The subordinate orders are not affected when executing at operation or component level.

Operation Overview

To switch to the operation overview, choose .

1. Select those operations for which you want to activate the purchase requisition.

2. Choose Functions → Activate purch. requisition/reservation.

By activating an operation, all dependent objects (purchase requisitions for suboperations, reservations for assigned components) are also activated.

Component Overview

To switch to the component overview, choose .

1. Select those components for which you want to activate the reservations.

2. Choose Components → Activate purch. requisition/reservation.
Product Cost Collector

Use

You can decide whether the costs related to a production order are collected in the production order or in a product cost collector.

Features

You decide where the costs are to be collected by using the Cost Collector indicator in the order type-dependent parameters in Customizing for Shop Floor Control, by choosing Master Data -> Order -> Define Order Type-Dependent Parameters.

- If the indicator is set, the costs are collected in a product cost collector. In this case, you execute a periodic product costing. The preliminary, simultaneous and final costing occurs at product cost collector level. In this case, you determine periodically the work in process and variances.

- If the indicator is not set, the costs are collected directly in the production order. In this case, you execute an order-related product costing. The preliminary, simultaneous and final costing occurs at production order level. In this case, you usually determine work in process and variances with reference to the lot.

For more information, see the SAP Library Product Cost Collector [Ext.].